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IGEL OS Creator Manual
With the IGEL OS Creator (OSC), you can install IGEL OS 11 on any device that supports it. Moreover, you can use 
the IGEL OS Creator for recovering a broken installation of IGEL OS which is not able to boot anymore. 

General Information (see page 4)
Devices Supported by IGEL OS 11 (see page 5)
Licensing (see page 7)
Installation (see page 8)

IGEL Tech Video
How to reflash a device using IGEL OS Creator:

You can roll out IGEL OS also via the IGEL OS Deployment Appliance. For this purpose, you will need to 
install IGEL OS Deployment Appliance 11.0 or higher. See IGEL OS Deployment Appliance Manual.



Sorry, the widget is not supported in this export.
But you can reach it using the following URL:

https://www.youtube.com/watch?v=z1Wp51KQ8tI

https://www.youtube.com/watch?v=z1Wp51KQ8tI
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General Information
The IGEL OS Creator (OSC) software allows the migration of existing hardware to create a functionally standardized 
IGEL Workspace infrastructure. In the process, the existing operating system is replaced by IGEL OS. The devices can 
then be administered via the IGEL Universal Management Suite (UMS).

This manual describes the installation of IGEL OS 11 using OSC.

Installing the IGEL OS operating system via OSC destroys all data on the target device’s mass storage 
device (hard disk, flash memory, SSD).
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Devices Supported by IGEL OS 11

IGEL Devices

Core Requirements for IGEL OS 11
CPU with 64-bit support 
CPU speed: ≥ 1 GHz
Memory (RAM): ≥ 2 GB

Storage: 2 GB minimum; ≥ 4 GB recommended

IGEL Devices Supported by IGEL OS 11

IGEL UD (Universal Desktop)

Product Line Device Type Hardware ID 64 Bit Memory
(RAM)

Storage HW Video 
Acceleration

UD2 D220 40 Yes 2 GB 4 GB Yes

UD2 M250C 50 Yes 2 GB 4 GB Yes

UD2 M250C 51 / 52*** (see 
page 6)

Yes 2 or 4 GB 8 GB Yes

UD3* (see page 
6)

M340C 50 Yes 2 GB 4 GB Yes

UD3 M340C 51 Yes 2 GB 4 GB Yes

•
•

•

RAM size higher than 2 GB is recommended if you use any of the following:
Unified Communications optimizations (uses a client-side media engine)
High-resolution graphics output
For details on the supported graphics-related characteristics of IGEL devices, 
see Graphics on IGEL Devices or, for older devices, Graphics on Legacy IGEL 
Devices. 
More than two monitors



Storage Requirements for IGEL OS 11.04 or Higher

IGEL OS 11.04.100 or higher requires at least 2.4 GB storage if the full feature set is applied. Thus, 
the feature set must be modified accordingly; for more information, see Error: "Not enough space 
on local drive" when Updating to IGEL OS 11.04 or Higher.





IGEL OS Creator Manual

IGEL OS Creator   6 / 37

Product Line Device Type Hardware ID 64 Bit Memory
(RAM)

Storage HW Video 
Acceleration

UD3 M350C 60 Yes 4 GB 8 GB Yes

UD5* (see page 
6)

H830C 50 Yes 2 GB 4 GB Yes

UD6 H830C 51 Yes 2 GB 4 GB Yes

UD7 H850C 10 Yes 4 GB 4 GB Yes

UD7** (see page 
6)

H850C 11 Yes 4 GB 4 GB Yes

UD7 H860C 20 Yes 8 GB 8 GB Yes

UD9* (see page 
6)

TC215B 40 / 41 (Touch) Yes 2 GB 4 GB Yes

* IGEL UD3-LX 50 and UD5-LX 50 are officially supported up to IGEL OS 11.05, incl. private builds. IGEL UD9-LX 40 / 41 
(Touch) devices are officially supported up to IGEL OS 11.07.910.

** As of December 2019, IGEL UD7 model H850C is equipped with the AMD Secure Processor; for further information, 
see UD7 Model H850C.

*** IGEL UD2-LX 52 is supported with IGEL OS 11.06.140 and later.

IGEL Zero

Product 
Line

Device 
Type

Hardware 
ID

64 Bit Memory
(RAM)

Storage UEFI Secure 
Boot Support

HW Video 
Acceleration

IZ2 D220 40 Yes 2 GB 4 GB Yes Yes

IZ3 M340C 50 Yes 2 GB 4 GB Yes Yes

IZ3 M340C 51 Yes 2 GB 4 GB Yes Yes

Third-Party Devices
For an up-to-date list, see https://kb.igel.com/os11-supported-hardware.

Note on IZ Devices

The IZ devices listed below can be upgraded to IGEL OS 11. To upgrade your IZ devices to IGEL OS 11, 
please contact your IGEL sales representative. See also https://www.igel.com/os11migration/.



https://www.igel.com/os11migration/
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Licensing
For information on licensing, see IGEL Software License Overview and Deploying Licenses.
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Installation
Installation Requirements (see page 9)
Create USB installation medium (Windows) (see page 10)
Create USB installation medium (Linux) (see page 13)
Create DVD installation medium (see page 15)
Boot settings (see page 16)
Installation procedure (see page 19)
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Installation Requirements
In order to install IGEL OS via OSC, the target device must meet the following requirements:

64-bit-capable CPU
CPU speed ≥ 1 GHz

At least 2 GB RAM
At least 2 GB mass storage space (≥ 4 GB recommended): hard disk, flash memory, SSD, eMMC or 
NVME.
Intel, ATI/AMD or Nvidia graphics chip

USB 3.0 or 2.0 port from which the device can boot (alternatively a DVD drive)
Ethernet or wireless adapter

When using multimedia content (e.g. Unified Communications), a Dual Core CPU with at least 1.5 
GHz is recommended.



For information about supported graphics chip sets, see the IGEL Linux 3rd Party Hardware 
Database1.



If these requirements are not fulfilled, the full functionality of the device with IGEL OS can not be 
guaranteed, and technical support will not be provided by IGEL.



Installing IGEL OS via OSC destroys all data on the target device’s mass storage device (hard disk, flash 
memory, SSD).



https://www.igel.com/linux-3rd-party-hardware-database/
https://www.igel.com/linux-3rd-party-hardware-database/
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1.

2.
3.

4.

Create USB installation medium (Windows)
Download the ZIP archive for OS Creator from our download server2:
- For new devices, use the standard installer (e. g. OSC_11.01.100.zip).
- For older devices or if you haven't been able to boot the installer at all, use the legacy installer (e. 
g. OSC_11.01.100_legacy.zip).
Unzip the contents into a local directory.
Connect a USB memory stick with at least 4 GB capacity to the computer.

Double-click the  preparestick.exe  file from the unzipped directory.

The dropdown menu Isofile shows the ISO files contained in the unzipped directory.

All existing data on the USB memory stick will be destroyed.

If you are in the "administrators" group, the program will start after you have confirmed a 
dialog. If you are not in the "administrators" group, you must enter the administrator 
password to start the program.



https://www.igel.com/software-downloads/workspace-edition/
https://www.igel.com/software-downloads/workspace-edition/
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5.
6.

7.

Under Isofile, select the appropriate ISO file, e. g.  osc11.01.100.iso
Under Destination USB stick, select the USB storage medium on which you would like to save the 
installation data.

Click on Start writing process.
In the program window, the progress of the process is shown.

When the process is finished, a message window is displayed.

It is recommended that you only have one USB storage medium connected during this 
procedure. If you accidentally select the wrong medium, all data on it will be lost.



Generally speaking, the list of available USB storage media is refreshed automatically. If, 
however, you would like to refresh it manually, click on View > Refresh USB Device List.
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8.
9.

Close the message window and the program.
After about 3 seconds, remove the USB memory stick.

If you remove the USB memory stick immediately, there is a possibility that the writing 
process has not been completed. In this case, the data on the memory stick gets 
corrupted.
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1.

2.
3.

4.

5.

6.

Create USB installation medium (Linux)
Download the ZIP archive for OS Creator from our download server3:
- For new devices, use the standard installer (e. g. OSC_11.01.100.zip).
- For older devices or if you haven't been able to boot the installer at all, use the legacy installer (e. 
g. OSC_11.01.100_legacy.zip).
Unzip the contents into a local directory.
From this directory, you will need the ISO file (e. g.  osc11.01.100.iso  or 

osc11.01.100_legacy.iso ) to create a bootable medium.
Connect a USB memory stick with at least 4 GB capacity to the computer.

Open a terminal emulator and enter the command  dmesg  to determine the device name of the 
USB memory stick.
Example output: 
[...]

[19514.742229] scsi 3:0:0:0: Direct-Access JetFlash Transcend 8GB 

1100 PQ: 0 ANSI: 6

[19514.742805] sd 3:0:0:0: Attached scsi generic sg1 type 0

[19514.744688] sd 3:0:0:0: [sdb] 15425536 512-byte logical blocks: 

(7.89 GB/7.35 GiB)

[19514.745370] sd 3:0:0:0: [sdb] Write Protect is off

[19514.745376] sd 3:0:0:0: [sdb] Mode Sense: 43 (0) 00 00 00

[19514.746040] sd 3:0:0:0: [sdb] Write cache: enabled, read cache: 

enabled, doesn't support DPO or FUA

[19514.752438] sdb: sdb1

In this example, the device name searched for is  /dev/sdb .

The following command writes the installation data to the USB memory stick:
dd if=osc11.01.100.iso of=/dev/sdX bs=1M oflag=direct

Replace  sdX  with the device name of the USB memory stick that you have determined. 

When the dd  command has terminated, you can see the terminal emulator input prompt again.

All existing data on the USB memory stick will be destroyed.

Ensure that you have determined the correct device name. Use of the dd  command in 
the next step can destroy your operating system if you use the wrong device name.



https://www.igel.com/software-downloads/workspace-edition/
https://www.igel.com/software-downloads/workspace-edition/
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7. Wait for about 3 seconds after the  dd  command has terminated, and remove the USB memory 
stick.

The USB memory stick for OSC installation is ready for use.

If you remove the USB memory stick immediately, there is a possibility that the writing 
process has not been completed. In this case, the data on the memory stick gets 
corrupted.
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1.
2.
3.

Create DVD installation medium
The ISO file in the installation directory for OSC is a so-called hybrid image. It can not only be copied onto USB 
storage devices but can also be used to create a bootable DVD.

Burn ISO Image (Windows)

In Explorer, open the directory that contains the ISO file.
Right-click on the ISO file.
Select Burn disc image.

Burn ISO Image (Linux)
Under Linux, various burning programs with a graphical user interface or for the command line are available.

The Ubuntu Wiki4 explains how to burn an ISO image onto a DVD using a number of programs.

https://help.ubuntu.com/community/BurningIsoHowto#Burning_from_Ubuntu
https://help.ubuntu.com/community/BurningIsoHowto#Burning_from_Ubuntu
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Boot settings
OSC works on systems with BIOS and UEFI.

It is essential that your system supports booting from USB storage media or from DVD. This may already be 
enabled, or you may have to enable it yourself.

Third-Party Devices
The required key presses for this may vary from vendor to vendor. However, here are some hints:

 While the device is booting, try pressing [F12] (in general), [F10] (Intel devices), or [F9] (Hewlett-Packard 
devices) in order to access a list of boot devices and select your USB installation medium.

 If the above does not work, access the BIOS settings via pressing [Del], [F1], or [F2] during boot and activate 
booting from USB storage media and/or change the boot order.

 See the BIOS/UEFI documentation for your system for details of how to boot from USB storage media.

IGEL OS 11 supports UEFI Secure Boot. Refer to the manual of your device's manufacturer to learn whether 
your device supports Secure Boot and how to enable it. Enabling Secure Boot often consists of two steps. 
First, the boot mode has to be changed to UEFI Boot in the BIOS; after that, Secure Boot can be activated, 
also in the BIOS.



If IGEL OS fails to boot in UEFI mode, try it in legacy/BIOS mode. IGEL OS will then be installed in legacy/
BIOS mode.



For older devices or if you haven't been able to boot the installer at all, use the legacy installer 
under https://www.igel.com/software-downloads/workspace-edition/ > OS 11 > OS CREATOR > LEGACY.



On modern computers such as secured-core PCs (see e.g. https://www.microsoft.com/en-us/windows/
business/devices?col=secured-core-pcs), there may be a BIOS setting related to Secure Boot that allows 
the use of Microsoft’s 3rd party UEFI Secure Boot Certificate. The usual description of such a BIOS setting is 
"Allow Microsoft 3rd Party UEFI CA". This setting must be set to enabled, as IGEL uses the 3rd party 
certificate to support UEFI Secure Boot. If UEFI Secure Boot is enabled, but "Allow Microsoft 3rd Party UEFI 
CA" is not enabled, you may be unable to boot IGEL OS Creator or UD Pocket. Similarly, if the setting 
"Allow Microsoft 3rd Party UEFI CA" is disabled after a previous installation of IGEL OS, IGEL OS will fail to 
boot. For how to enable the setting, see Secured-Core PCs: Microsoft 3rd-Party UEFI Certificate for Secure 
Boot.



https://www.igel.com/software-downloads/workspace-edition/
https://www.microsoft.com/en-us/windows/business/devices?col=secured-core-pcs
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7.

1.
2.
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6.
7.
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9.

10.
11.

IGEL Devices

UD6 (H830)

Power up the device while pressing the [Del] button repeatedly in rapid succession.
Select SCU.
If a password prompt is shown, enter the BIOS password.
Select the Boot tab.
Set USB Boot to <ENABLED>.
Save the settings and exit.
Connect the USB stick to the device.
Reboot the device while pressing the [Del] button repeatedly in rapid succession.
Select Boot Manager.
Select the USB stick as the boot medium and press Enter.
You can continue with the installation procedure (see page 19).

UD5 (H830)

Power up the device while pressing the [Del] button repeatedly in rapid succession.
If a password prompt is shown, enter the BIOS password.
Select the Boot tab.
Select Boot Options Priorities.
Select the entry for the USB stick and move it to the first position using the [+] key.
Save the settings and exit.
You can continue with the installation procedure (see page 19).

UD3 (M340)

Power up the device while pressing [Del] button repeatedly in rapid succession.
Select SCU.
If a password prompt is shown, enter the BIOS password.
Select the Boot tab.
Set USB Boot to <ENABLED>.
Save the settings and exit.
Connect the USB stick to the device.
Reboot the device while pressing the [Del] button repeatedly in rapid succession.
Select Boot Manager.
Select the USB stick as the boot medium and press Enter.
You can continue with the installation procedure (see page 19).

•
•

If the USB installation medium is not found, though the USB boot is enabled, try the following:
Reconnect the USB  installation medium and reboot the endpoint device.
Use another USB port.
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1.

2.
3.
4.
5.
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8.

9.
10.
11.

1.
2.
3.
4.
5.
6.
7.

UD2 (M250C)

Power up the device while pressing [Del] button repeatedly in rapid succession.
Select SCU.
If a password prompt is shown, enter the BIOS password.
Select the Boot tab.
Set USB Boot to <ENABLED>.
Save the settings and exit.
Connect the USB stick to the device.
Reboot the device while pressing the [Del] button repeatedly in rapid succession.
Select Boot Manager.
Select the USB stick as the boot medium and press Enter.
You can continue with the installation procedure (see page 19).

UD2 (D220)

Power up the device while pressing the [F2] (older devices) or [Del] (newer devices) button 
repeatedly in rapid succession.
Select SCU.
If a password prompt is shown, enter the BIOS password.
Select the Boot tab.
Set USB Boot to <ENABLED>.
Save the settings and exit.
Connect the USB stick to the device.
Reboot the device while pressing the [F2] or [Del] (newer devices) button repeatedly in rapid 
succession.
Select Boot Manager.
Select the USB stick as the boot medium and press Enter.
You can continue with the installation procedure (see page 19).

UD9 (TC215B)

Power up the device while pressing the [F2] button repeatedly in rapid succession.
If a password prompt is shown, enter the BIOS password.
Select the Boot tab.
Select Boot Option Priorities.
Select the entry for the USB stick and move it to the first position using the [+] key.
Save the settings and exit.
You can continue with the installation procedure (see page 19).
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2.
•

•
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•

3.
4.
5.

•

•

•

•
•
•
•

Installation procedure
Connect the prepared USB memory stick to the target device or insert the DVD and switch the 
target device on.
Select one of the following options from the boot menu:

Standard Installation + Recovery: Boots the system with just a few messages from the USB 
memory stick and launches the installation program. (Default)
Verbose Installation + Recovery: Boots the system from the USB memory stick and shows 
the Linux boot messages in the process.
Failsafe Installation + Recovery: Fallback mode to be used if the graphical boot screen 
cannot be displayed.
Memory Test: Memory test, only available in legacy/BIOS mode. This option does not carry 
out an installation.
EFI Debug Shell: Available only in UEFI boot mode. If the hardware in use is EFI capable, 
boot problems can be analyzed with that.

Please choose your language: Select the language for the installation process.
Accept the EULA by clicking I agree.
Installation program IGEL OS Creator: Here, you can configure settings for the installation process 
and start it. Check the target drive to ensure that the system is installed on the desired drive.

The following options are available:
Force Legacy Installation (only available after UEFI boot)
☑ The legacy/BIOS version of IGEL OS 11 will be installed, even if the system was booted in 
UEFI mode.

☐ UEFI booting results in a UEFI installation, and legacy/BIOS booting in a legacy/BIOS 
installation. (Default)
Force MS-DOS Partitioning
☑ Use a MS-DOS partition table instead of a GPT partition table.
☐ Use a GPT partition table. (Default)
Migrate Old Settings
☑ Carries over the settings from a previously installed IGEL OS system. (Default)
Edit: Open the IGEL setup where you can configure settings for the system to be installed.
Reset: Resets all changes to the setup made with Edit.
Install firmware: Starts the installation process.
Cancel: Cancels configuration for the installation and shuts down the device.

The installation will destroy all existing data on the target drive.

Remember to set the system to legacy/BIOS mode after installation.
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6.

7.

8.
9.

10.

Click on Install firmware.
The installation program will set up IGEL OS 11 on the target drive. If you see the IGEL OS Creator 
build finished successfully message, the installation is complete. 
Detach any external network adapters from the device.
In this way, you ensure that the unit ID for the device is derived from the built-in network adapter. 
The unit ID will be saved on the device persistently, regardless of any external network adapter 
that may be used in the future. This is important for licensing.
Click on Reboot at the bottom of the installation window.
Remove the USB memory stick or the DVD.
Close the message window.
The system will shut down and then boot IGEL OS 11.
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IGEL OS Creator Articles
Café Wireless (Wi-Fi) (see page 22)
Reduce CPU Power Consumption (see page 26)
Installing UDC3 on Secunet SINA Workstation (see page 27)
Setting up UDC3 on Mobile Devices (see page 29)
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1.
2.
3.

4.

Café Wireless (Wi-Fi)
When you use your mobile device frequently at different Wi-Fi hotspots, automatic Wi-Fi roaming may be useful. 
This is what IGEL Café Wireless does. The IGEL Café Wireless feature can be used, for instance, with IGEL UDC3. After 
you have configured your wireless networks, your mobile device is ready to roam.

For optimizing the network switchover, please see Configuring Wi-Fi Network Roaming.

If the network's SSID is hidden, see Connecting to a Wi-Fi Network with Hidden SSID.

See also the manual chapter "Wireless".

To configure a wireless network with the Wireless Manager:

Open Network > LAN interfaces > Wireless in the Setup.
 Enable Activate wireless interface.
Activate Enable Wireless Manager.

Click the tray icon   and select Manage wireless networks.

The Wireless networks dialog opens. After a few seconds, all wireless networks within reach are 
shown, sorted by signal strength. Previously configured connections are flagged with a tick in the 
Configured column. The connection currently active is flagged with a symbol under Connected.
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5. Double-click the network to be configured.
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6.

7.
8.
9.

A dialog named with the name (SSID) of the desired network opens.

Activate Permanently store network key so that your mobile device remembers the network key.

Enter the Network key. To have the network key displayed while typing, click .
Click OK.
Repeat the steps described above for the remaining networks.
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To connect to a configured network manually:

 Highlight the network and click on  in the Wireless networks dialog.

Your mobile device is connected to the wireless network. The icon    shows the network's current signal 
strength.



IGEL OS Creator Articles

IGEL OS Creator   26 / 37

1.
2.

Reduce CPU Power Consumption
Reduce CPU Power Consumption

When you are using the IGEL Universal Desktop Converter (UDC2) on a mobile device in battery mode, you might 
want to reduce power consumption. One major power consumer is your CPU.

You can easily gain some control over the power consumption of your CPU using the tray icon  (CPU Power 
Plan) on your taskbar.

 If the tray icon is not displayed, open the IGEL Setup, go to System > Power Options > System and activate 
Tray Icon.

To change the CPU power settings:

Click on .
Select the appropriate option. High Performance gives you the highest performance, but also the 
highest CPU power consumption, Power Saver results in lowest performance and lowest CPU 
power consumption. The other options are in between.
For further information about the power plan settings, see the system (see page 26) chapter in the 
manual.
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Installing UDC3 on Secunet SINA Workstation
To install IGEL Universal Desktop Converter 3 on a SINA workstation, proceed as follows:

Download the UDC3 zip file under IGEL Software Download5 and unzip the file.
Copy the ISO image to an USB stick.
Start the SINA workstation
Click Administration > Volumes in the navigation bar.
Click + Add item at the bottom of the screen to add a new item.
Enter a distinct name for the volume in the Name field top right.
The target drive is already specified.
Click New CFS under Select volume type.
The form expands.
Choose the preconfigured Security domain, Cipher algorithm and Hash algorithm.
Click Define Guest system under CFS content.
The form expands.
Enter a distinct name for the system under Guest system name. 
Choose 2 GiB as minimum for the Guest system size. 
Select Disabled under Quarantine. 
Click Create.

The system will now create the volume. This may take a while - depending on the size of the guest system. 

Go to Administration > Volumes and click the new volume. 
Next to it a little form opens. 
Open Guest systems. 
You will see the volume you've created.
Click Local under Add guest system from... to add the ISO image to this volume.
The form expands.
Plug the USB Stick with the ISO image into the workstation. 
Choose the stick as Device and the ISO image as Guest system image. 
Click Add at the bottom of the form.

The system now adds the ISO image to your new volume. This will take a while.

Switch to the Workplaces menu. 
Click + Add item at the bottom of the screen. 
Enter a distinct name for the workplace in the Name field top right.
Choose the Guest system you've created. It has a small hard disk icon.
Choose the ISO image under Secondary guest system. It should have a small CD icon.
Select Secured networking under Network mode.
Choose your prefered settings under Display layout, Workplace hotkey and Audio mode.
Select CD/DVD under Boot order.
Select Automatic reservation under IP to claim and MAC to claim.
Select Ubuntu as OS type.
It is not necessary to activate the Detailed settings.

https://www.igel.com/software-downloads/
https://www.igel.com/software-downloads/
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12.

1.

2.

3.

4.

5.
6.
7.

Click Create.

The system now creates the workplace.

Klick on the new workplace. 
Next to it a little form opens. 
Click Launch to start the workplace. 
The IGEL Universal Desktop Converter starts.
After a few second you will see this screen:

 
Keep the first selected item Boot IGEL UD Converter. 
The conversion process starts. 
Next you will see the blue IGEL Linux background. 
A little popup appears. 
Choose your desired language.
Agree the license agreement.
Install the IGEL Linux OS to the workspace.

Be aware, that all data of the volume will be deleted. That’s why you should always create a new 
volume for the IGEL Linux OS.
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Setting up UDC3 on Mobile Devices
Multi Monitor Environment (see page 30)
Presentation Mode (see page 31)
Display Brightness (see page 32)
Power Management (see page 33)
Wireless Manager (Café Wireless) (see page 34)
Shortening Network Timeouts in Mobile Scenarios (see page 35)
Battery Level Control (see page 37)
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1.
2.

3.
4.

Multi Monitor Environment
If you use your notebook in an office workstation, you can use a multi monitor environment.

To configure the display for multiple screens, use the Display Switch.

Respective Tray Icon:

Tray Icon Name Icon Where to configure

Display Switch Menu path: Setup > Accessories > Display 
Switch

Activating the Display Switch:

Enable the Display Switch in the IGEL Setup under Accessories > Display Switch.
Select Quick Start Panel as a starting method.
The Display Switch icon is shown in the quick start panel.
Click the icon to open the display configuration dialogue.
Switch between simple and advanced settings.

•
•

For a detailed description, see the manual, chapter Display Switch.
Here you can find additional instructions concerning monitor settings:

How-To Dual Screen
Manual topic RDP Global > Window
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2.

Presentation Mode
You are using your mobile device for a presentation. You neither want the monitor to enter power saving mode nor 
to start the screensaver during the presentation.

For this situation, use the Presentation Mode which disables the DPMS and the screen saver.

Respective Tray Icon:

Tray Icon Name Icon Where to configure

Notebook BAT Menu path: Setup > System > Power 
Options > Battery

Activating the Presentation Mode:

Right-click the battery symbol in the system tray.
The context menu opens:

Click Presentation Mode to enable/disable it.
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1.

2.

Display Brightness
In order to preserve the battery you want to reduce the display brightness.

Respective Tray Icon:

Tray Icon Name Icon Where to configure

Notebook BAT Menu path: Setup > System > Power 
Options > Battery

Right-click the battery symbol in the system tray.
The context menu opens.
Click the slider of the brightness display to reduce the Display Brightness.
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1.

2.

Power Management
You are using your mobile device in battery mode and need to reduce power consumption to preserve the battery.

To save power, set CPU power options to scale the CPU frequency down.

Respective Tray Icon:

Tray Icon Name Icon Where to configure

CPU Power Plan Menu path: Setup > System > Power 
Options > System

Setting CPU power options:

Click the CPU Power Plan icon in the system tray.
The context menu opens.

Select the appropriate mode.

•
Here you can find additional instructions concerning the power management:

Define the CPU Power Plan, Critical Battery Level, Standby Time or Suspend 
Time, Brightness reduction, and Shut-down Options. See the manual, chapter System > 
Power Option > System.
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Wireless Manager (Café Wireless)
If you are traveling with your notebook, you need to handle different WiFi connections.

You can use Café wireless to configure different wireless network connections.

Respective Tray Icon:

Tray Icon Name Icon Where to configure

Wireless Network Connection Menu path: Setup > Network > LAN 
Interfaces > Wireless

Defining Café wireless:

Enable the Wireless Manager under Network > LAN Interface > Wireless.
Set all options:

Click the WiFi tray icon in the right corner of the panel.
Open the Wireless Manager dialog.

You can find the complete instruction in the manual, chapter Wireless Manager.
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•
•
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1.
2.
3.

1.

Shortening Network Timeouts in Mobile Scenarios
When on the road with their UDC2 mobile device, users often experience slow system startup. This is due to the 
system waiting for network connections or the UMS which are not available in the mobile scenario. This document 
describes how to minimize waiting by shortening various timeouts.

Don't Wait for Wired Network

When an Ethernet interface is configured but not physically connected, startup is delayed by default. The goal is to 
give the user an opportunity to plug in the network cable. If this is not desired, as of IGEL Linux version 
5.10.100waiting can be turned off.

In Setup, go to System > Registry.
Go to the  network.interfaces.ethernet.device[number].nolink_nowait  regist
ry key. Replace [number] with:

0 for eth0, the first Ethernet interface
1 for eth1, the second Ethernet interface

Enable No waiting without physical link. By default, this option is disabled.

Don't Contact UMS Unless Specific Network Devices Are Up

Startup is also delayed because the system tries to contact UMS by default, which may not be available in a mobile 
scenario. You can configure IGEL Linux version 5.10.100 to contact UMS only if one of the network devices in a 
whitelist is up.

In Setup, go to System > Registry.
Go to the  system.remotemanager.device_whitelist  registry key.
Put a space-separated device list into the Network device whitelist field. Only if at least one of 
these devices is up, the system will try to contact UMS. Device names:

First Ethernet adapter:  eth0
Second Ethernet adapter: eth1
Wireless: wlan0
Mobile broadband: ppp10

OpenVPN: tun0

Don't Contact UMS Unless Specific Networks Are Available

You can configure IGEL Linux version 5.10.100 to contact UMS only if one of the networks in a whitelist is reachable.

In Setup, go to System > Registry.
Go to the  system.remotemanager.network_whitelist  registry key.
Enter a space-separated list of networks in CIDR notation into the Network whitelist input field, 
e.g. 172.30.0.0/16 192.168.100.0/24. If there are entries in this field, the system will only try to 
contact UMS if one of the device's current IP addresses happens to be in one of these ranges.

Shorten the UMS Timeout

When different environments cannot be distinguished by the previous two mechanisms, as of IGEL Linux version 
5.10.100 the startup delay can be reduced by setting a shorter timeout for connections to the UMS.

In Setup, go to System > Registry.
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3.
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3.

Go to the  system.remotemanager.rmagent_timeout  registry key.
Enter an integer number of seconds into IGEL Remote Management Timeout. The default is 90.

Don't Wait for All Network Interfaces

You can configure IGEL Linux to wait only for one of the network interfaces to be up instead of all. This also means 
that error messages concerning Ethernet devices will only be displayed shortly.

In Setup, go to System > Registry.
Go to the  network.global.waitfor_interfaces  registry key.
Disable Wait for interfaces to come up. By default, this option is enabled.
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4.

Battery Level Control
Since Linux version 10.03.100 it is possible to display the battery level of a mobile device via UMS. The frequency of 
the battery level reports sent by the device to the UMS can be adjusted: A report is triggered when the battery status 
has changed at a specified percentage compared to the previously reported status. The percentage is specified by 
the Battery status update frequency parameter.

Example use case: The IT administrator in a hospital has to take care of battery-powered medical devices. Using the 
new feature, he can easily keep track of all these devices via the UMS, without any need of physical access or 
mirroring VNC.

To adjust the report frequency:
In Setup, go to System > Registry.
Go to the system.remotemanager.battery_report_frequency registry key.
Select the Battery status update frequency:

Often
Normal
Rarely
Very Rarely
Never

Click Apply or Ok.
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