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Overview: First Steps with IGEL OS 11

e

IGE

Overview: First Steps with IGEL OS 11

The following article provides a short overview of how to get started with an IGEL device or a third-party device that
you want to convert to IGEL OS. The steps are generally the same, but in the case of a third-party device you will
need to use the IGEL OS Creator.
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Overview: First Steps with IGEL OS 11

IGEL Device
Step 1: Download and install the UMS

IGEL Download Server?

Instruction: Installing an IGEL UMS Server
Video: UMS installation on a Windows Server?
Video: UMS installation on a Linux operating
system?®

Step 2: Activate your IGEL 0S 11

with the Setup Assistant (free
evaluation license):

« Instruction: Setup Assistant for IGEL OS,
section "Register for Demo License". See also
Getting a Demo License.

« Video: Acquire a Demo License Including
Workspace Edition and Enterprise
Management Pack*

via UMS (purchased license):

+ Deploy licenses using automatic or manual
license deployment method.

+ Video: Register an endpoint in the UMS and
assign a license to it

Step 3: Configure your device
with the UMS:

+ Create a profile with the required settings
and assign it to the device. See also Profiles.

+ Video: Configure an endpoint in the UMS
using profiles®

without the UMS:

+ Use the IGEL Setup on the device, e.g. to
configure User Interface and Sessions.
+ Video: Configuring an Endpoint with IGEL OS
117
<z IILLIJD.// VVVVVV.yUuLuIJC.\.UIII/ WalLtciiiv=orJdi et yJVV
3 https://www.youtube.com/watch?v=p52CxtB_0ok
4 https://www.youtube.com/watch?v=j31c8dzBMAg
5 https://www.youtube.com/watch?v=01N-9b3P4wo
6 https://www.youtube.com/watch?v=Sc38mRv5Z1s
7 https://www.youtube.com/watch?v=6WfLVgYBTHg
8 https://www.igel.com/software-downloads/workspace-edition/
9 https://www.youtube.com/watch?v=3YJnFiE7y5w
10 https://www.youtube.com/watch?v=p52CxtB_0ok
11 https://www.igel.com/software-downloads/workspace-edition/
12 https://www.youtube.com/watch?v=xVqcX6QTZ5g
13 https://www.youtube.com/watch?v=j31c8dzBMAg

IGEL OS Articles

3d-Party Device

Step 1: Download and install the UMS

IGEL Download Server®

Instruction: Installing an IGEL UMS Server
Video: UMS installation on a Windows Server®
Video: UMS installation on a Linux operating
system??

Step 2: Download IGEL OS 11

IGEL Download Server', section 0S 11> 0S
Creator

Step 3: Convert your device to IGEL OS 11

« IGEL OS Creator Manual

Video: Converting an x86-Endpoint Using the
IGEL OS Creator*

Step 4: Activate your IGEL OS 11

with the Setup Assistant (free
evaluation license):

Instruction: Setup Assistant for IGEL OS,
section "Register for Demo License". See also
Getting a Demo License.

Video: Acquire a Demo License Including
Workspace Edition and Enterprise
Management Pack®

via UMS (purchased license):

Deploy licenses using automatic or manual
license deployment method.
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Overview: First Steps with IGEL OS 11

e

IGE

IGEL Device 3d-Party Device

+ Video: Register an endpointin the UMS and
assign a license to it

Step 5: Configure your device
with the UMS:

+ Create a profile with the required settings
and assign it to the device. See also Profiles.

+ Video: Configure an endpointin the UMS
using profiles®

without the UMS:

+ Use the IGEL Setup on the device, e.g. to
configure User Interface and Sessions

+ Video: Configuring an Endpoint with IGEL OS
1116

14 https://www.youtube.com/watch?v=01N-9b3P4wo
15 https://www.youtube.com/watch?v=Sc38mRv5Z1s
16 https://www.youtube.com/watch?v=6WfLVgYBTHg
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Update and Upgrade

e

IGE

Update and Upgrade

+ Upgrading UDC3 or UD Pocket from IGEL OS 10.06 to IGEL OS 11 via Universal Firmware Update (see
page7)

+ Upgrading from IGEL OS 10 to IGEL OS 11 (see page 61)

+ Buddy Update (see page 221)

+ Firmware Update (see page 227)

+ Updating IGEL OS Using a USB Storage Device (see page 230)

+ Updating the Firmware using the Linux Console (see page 232)
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Update and Upgrade

e

IGE

Upgrading UDC3 or UD Pocket from IGEL OS 10.06 to IGEL OS 11 via
Universal Firmware Update

This document describes how to upgrade UDC3 or UD Pocket devices from IGEL OS 10.06 to IGEL OS 11 via the
Universal Firmware Update feature of the UMS (Universal Management Suite).

Since a new licensing model has been introduced with IGEL OS 11, a license from an IGEL Workspace Edition
Product Pack must be available for each device. If you have valid maintenance for your devices, you can convert
your existing UDC3 or UD Pocket Product Packs to Workspace Edition (WE) Product Packs; see Converting UDC3 or
UD Pocket Licenses for Upgrading to IGEL OS 11.

Read all the following chapters in the order given and follow the instructions.

Devices That Can Be Upgraded to IGEL OS 11 (see page 8)

Important! Consider This Before Upgrading (see page 21)

Getting the UMS Ready (see page 23)

Deploying the Licenses (see page 24)

Creating the Universal Firmware Update (see page 25)

Creating an Upgrade Profile (see page 36)

Assigning the Upgrade Profile and the Universal Firmware Update to the Test Devices (see page 45)
Testing the Upgrade (see page 49)

Unassigning the Upgrade Profile and the Universal Firmware Update (see page 51)
If Applicable: Restoring Custom Partition and Custom Applications (see page 52)

. Upgrading All Devices (see page 53)
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Update and Upgrade

Devices That Can Be Upgraded to IGEL OS 11

In this section, you find the general hardware requirements for IGEL OS 11 and a list of third-party devices officially
supported by IGEL OS 11.

Core Requirements

« CPU with 64-bit support
+ CPUspeed:>1GHz
« Memory (RAM): =2 GB

() RAMsize higher than 2 GB is recommended if you use any of the following:
+ Unified Communications optimizations (uses a client-side media engine)
+ High-resolution graphics output
« More than two monitors

() With devices that have 2 GB RAM and shared video memory, a maximum of 512 MB may be
used as video memory.

+ Storage: Depends on the release version of IGEL OS 11. The details are listed below: 2 GB
minimum; =4 GB recommended

« UptoIGEL 0S 11.03: 2 GB minimum; =4 GB recommended

« From IGEL OS 11.04 to IGEL OS 11.07: If the full feature set is applied, at least 2.4 GB of
storage is required. For instructions on how to reduce the feature set, see Error: "Not
enough space on local drive" when Updating to IGEL OS 11.08 or Higher.

+ From IGEL OS 11.08 onwards: If the full feature set is applied, at least 2.4 GB of storage is
required. For instructions on how to reduce the feature set, see Error: "Not enough space on
local drive" when Updating to IGEL OS 11.08 or Higher. TODO Add URL when published

+ NoVIA graphic adapter; VIA graphics support is discontinued in IGEL OS.
+ Legacy Bios and EFI/UEFI are supported.

Devices Supported by OSC and UD Pocket with IGEL OS 11

& Thefollowing list only includes those devices that are tested by IGEL (with each major release of IGEL OS).
By no means it implies that the devices which are not included in this list but meet the minimum
requirements will not function with IGEL OS: Any x86-64 hardware endpoint device that meets the IGEL-
stated minimum hardware requirements for IGEL OS (for example, the processor speed and RAM) can be
expected to work adequately with IGEL OS and should be considered a candidate for repurposing from
another OS. With an IGEL OS subscription or active maintenance, customers can expect IGEL to make any
necessary “best effort” to support, regardless of whether the endpoints in question are specifically listed
within the IGEL Knowledge Base or elsewhere (e.g. on the IGEL Ready Showcase at https://www.igel.com/
ready/showcase-categories/endpoints/).

For any devices not listed here or on the IGEL Ready showcase, you can contact your hardware vendor and
request those devices to be added to the IGEL Ready program.
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Update and Upgrade

IGEL

Integrated drivers and supported peripherals are listed in the Third-Party Hardware Database!’. For more
solutions compatible with IGEL OS, see Partner Solutions.

(@ HP,Lenovo, and LG device models are available from the factory with pre-installed IGEL OS 11. Please
contact IGEL Ready™® to get information on which device models are available with pre-installed IGEL OS.

() Forsome of the devices listed here, Flash memory must be extended to = 2 GB. For these devices, an
appropriate note is added.

() Onmodern computers such as secured-core PCs (see e.g. https://www.microsoft.com/en-us/windows/
business/devices?col=secured-core-pcs), there may be a BIOS setting related to Secure Boot that allows
the use of Microsoft’s 3rd party UEFI Secure Boot Certificate. The usual description of such a BIOS setting is
"Allow Microsoft 3rd Party UEFI CA". This setting must be set to enabled, as IGEL uses the 3rd party
certificate to support UEFI Secure Boot. If UEFI Secure Boot is enabled, but "Allow Microsoft 3rd Party UEFI
CA" is not enabled, you may be unable to boot IGEL OS Creator or UD Pocket. Similarly, if the setting
"Allow Microsoft 3rd Party UEFI CA" is disabled after a previous installation of IGEL OS, IGEL OS will fail to
boot. For how to enable the setting, see Secured-Core PCs: Microsoft 3rd-Party UEFI Certificate for Secure
Boot.

(@ [Fn] keys may not work on some supported and listed laptop/notebook models.

ADS-Tec

Name Endpoint Type Minimum Storage Size Processor Supported from
Memory IGEL OS Version
(RAM) Size

DVG- Industrial PC/ 4GB 64 GB eMMC Intel Atom®x7- 11.02.100

VMT9010 Terminal 3GB E3950

DVG- Industrial PC/ 4GB 64 GB eMMC Intel Atom® x7- 11.02.100

VMT9012 Terminal 3GB E3950

DVG- Industrial PC/ 4GB 64 GB eMMC Intel Atom®x7- 11.02.100

VMT9015 Terminal 8GB E3950

DVG- Industrial PC/ 4GB 64 GB eMMC Intel Atom®x7- 11.02.100

VMT9112 Terminal 8GB E3950

17 https://www.igel.com/linux-3rd-party-hardware-database/
18 https://www.igel.com/technology-partners/
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Update and Upgrade

Advantech
Name Endpoint Type Minimum

Memory

(RAM) Size
POC-W213L Medical Allin 4GB 128 GB

One

POC- Medical Allin 4GB 32GB
W243L* (see One
page 19)
POC- Medical Allin 4GB 128 GB
W243L* (see One
page 19)

Advantech-DLoG

Name Endpoint Type Minimum
Memory
(RAM) Size
DLT-V6210 Industrial PC/ 4GB
Terminal
DLT-V7210 K Industrial PC/ 4GB
Terminal
Dell / Wyse
Name Endpoint Minimum Storage
Type Memory  Size
(RAM) Size
5040 /5212 AllinOne 2GB 2GB
3040 Thin Client 2 GB 8 GB
5020 Thin Client 2 GB 8 GB
5060 Thin Client 4GB 8 GB
5070 Thin Client 8 GB 32GB

IGEL OS Articles

Storage Size Processor

Intel Core
i7-7300U

Intel Kaby Lake
Corei5-7300U

Intel Core
i7-7300U

Storage Size Processor

32GB Intel Atom
4GB Intel Atom
E3845
Processor Supported

from IGEL OS
Version

AMD G-T48E 11.01.100

Intel Atom 11.01.100

x5-78350

AMD G-Series 11.02.140
SoC

AMD 11.01.100
GX-424CC

Intel Celeron 11.01.100

J4105

Supported from
IGEL OS Version

11.01.100

11.01.110

11.01.100

Supported from
IGEL OS Version

11.01.100

11.01.100

Note
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Update and Upgrade

Name Endpoint Minimum Storage
Type Memory Size
(RAM) Size
Latitude Laptop/ 8 GB 256 GB
5510 Notebook
Optiplex  ThinClient 4 GB 32GB
3000
Dynabook
Name Endpoint Minimum
Type Memory
(RAM) Size
Portegé X20W- Laptop/ 8 GB
D Notebook
Portegé X30-D Laptop/ 8 GB
Notebook
Tecra C50 Laptop/ 4GB
Notebook
TecraZ50-D  Laptop/ 8 GB
Notebook
SATELLITE R50 Laptop/ 4 GB
Notebook
Elo
Name Endpoint Minimum
Type Memory
(RAM) Size
i2 Touch Allin One 8 GB
(15and 22
inches)

IGEL OS Articles

Processor

Intel Core
i5-10210U

Intel Celeron 11.08.200

N5105

Storage Size Processor

256 GB

256 GB

500 GB

256 GB

500 GB

Storage Size Processor

128 GB

Supported Note
from IGEL OS
Version
11.05.100 Wake-on-LAN
functionality is
not supported.
Supported from

IGEL OS Version

Intel Core 11.01.100
i5-7200U
Intel Core 11.01.100
i5-7300U
Inteli5-4210U 11.01.100
Intel Core 11.01.100
i5-7200U
Inteli3-6006U 11.01.100
Supported from

IGEL OS Version

Intel Core 11.05.100

i3-8100T
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Update and Upgrade

Fujitsu

Name

Q957

FUTRO S740 Thin Client

HP

Name

HP t420

HP t430

HP t530

HP t630
HP t730

HP t820

HP t640

HP t540

IGEL OS Articles

Endpoint
Type

Desktop PC

Endpoint
Type

Thin Client

Thin Client

Thin Client

Thin Client
Thin Client

Thin Client

Thin Client

Thin Client

Minimum

Memory

(RAM) Size

8 GB

4GB

Minimum Storage

Memory
(RAM) Size

2GB

2GB

4GB

4GB
16 GB

16 GB

4GB

16 GB

Size

8 GB

16 GB

8 GB

8 GB
8 GB

16 GB

16 GB

16 GB

500 GB

8 GB

Storage Size Processor

Supported from
IGEL OS Version

Intel Core 11.02.100
i3-6100
Intel Celeron 11.04.100
J4105
Processor Supported Note
from IGEL OS
Version
AMD 11.02.100
Embedded G-
Series
GX-209JA

Intel®Celeron®11.01.110

N4020

AMD GX-215JJ 11.01.100

Dual-Core

AMD GX-420GI 11.01.100

AMD

RX-427BB APU

Intel Core
i5-4570S

AMD Ryzen
R1505G

AMD Ryzen
Embedded
R1305G

11.01.100

11.01.100

11.04.100

11.06.100
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Update and Upgrade

Name Endpoint Minimum Storage

Type Memory Size
(RAM) Size

HP mt46 Mobile Thin 8 GB 32GB
Client

HP Elite Thin Client 4GB /8GB 32 GB

t655

HP Elite Mobile Thin 8 GB 256 GB

mt645 G7  Client

HP t740 Thin Client 8 GB 16 GB

HP Pro t550 Thin Client 4 GB 32GB

HP Pro Mobile Thin 8 GB 128 GB

mt440 G3  Client

IGEL OS Articles

Processor Supported
from IGEL OS
Version

AMD Ryzen3 11.07.100

PRO 4450U

AMD Ryzen  11.07.160

Embedded

R2314

AMD Ryzen 3 11.08.230

5425U

AMD Ryzen5 11.08.330

5625U

AMD Ryzen 11.08.290
Embedded
V1756B

Intel Celeron 11.08.330
J6412

Intel Celeron 11.08.440
7305

Note

Excluding
support for
WWAN

and Wake-on-
LAN (both
features are
planned)

Support for
WWAN Intel XMM
7560 R+ (as of
11.08.330)

Excluding
support for
Wake-on-LAN
(featureis
planned)

Excluding
support for built-
in fingerprint
sensor

Excluding
support for
WWAN Intel XMM
7560 R+ (feature
is planned)
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Update and Upgrade

HP Docking Stations

Name Supported from IGEL OS Version
HP USB-C Docking Station G5 11.08.230
HP USB-C G5 Essential Dock 11.08.290
Intel
Name Endpoint Minimum Storage Size Processor Supported from
Type Memory IGEL OS Version
(RAM) Size
NUC 5i5MYHE Desktop PC 2 GB 32GB Intel i5-5300U 11.01.100
NUC 5i3RYH DesktopPC 2GB 2GB Intel i3-5010U 11.01.100
NUC7CJYH DesktopPC 2GB 4GB Intel Celeron 11.01.100
J4005
Lenovo
Name Endpoint Minimum Storage Processor Wi-Fi Chip Supported Note
Type Memory Size from IGEL

(RAM) OS Version

Size
ThinkCentreDesktop 4 GB 32GB  AMD Intel AC9260 11.04.100
M625q PC E2-9000e

8 GB 128GB  AMD QCA6174 11.04.100

A4-9120e 802.11ac
ThinkCentreDesktop 8 GB 256 GB  AMD Ryzen Intel AC9260 11.05.100

M75n PC 3

Pro 3300U
ThinkCentreDesktop 16 GB 256 GB  Intel Comet Lake 11.05.100
M70q Genl PC i5-10500t PCH CNVi

WiFi, Intel

ThinkCentreDesktop 16 GB 256 GB Intel Core Intel AX201 11.08.240
M70q Gen 3 PC i5-12500T
ThinkCentreDesktop 4 GB 128 GB  AMD Ryzen Intel AX200 11.08.240
M75q Gen 2 PC 3 Pro

5350GE
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Update and Upgrade

Endpoint Minimum Storage
Memory Size

Name

Type

(RAM)
Size

K14 AMD  Laptop/ 8GB
Genl Notebook
ThinkPad Laptop/ 64GB
L14 AMD Notebook
Gen1l
14w Laptop/ 4GB

Notebook
ThinkPad Laptop/ 16GB
L14 AMD Notebook
Gen3
ThinkCentreThin 8 GB
Neo50q Client
Gen 4 4GB
K14 Intel Laptop/ 16GB
Genl Notebook
ThinkPad Laptop/ 16GB
L14 Intel Notebook
Gen3
ThinkEdge Thin 8GB
SE10 Client
ThinkPad Thin 8 GB
L14 AMD Client
Gen4
ThinkPad Thin 8 GB
L15 AMD Client
Gen4

IGEL OS Articles

256 GB

1TB

64 GB

256 GB

256 GB

256 GB

256 GB

512 GB

1TB

256 GB

256 GB

256 GB

Processor

AMD Ryzen
5PRO
5650U

AMD Ryzen
7 Pro
4750U

AMD
A6-9220C

AMD Ryzen
55625U

Intel Core
i3-1215U

Intel
Celeron
7305

Intel Core
i5-1135G7

Intel Core
i5-1235U

Intel Atom
X6425RE

Intel Atom
X6214RE

AMD Ryzen
3 Pro
7330U

AMD Ryzen
3 Pro
7330U

Wi-Fi Chip

Mediatek
MT7921

11.08.240

Wi-Fi 6
AX200, Intel

11.05.100

QCA6174
802.11ac

AMD RZ616
2X2AX (WiFi
6E)

Wi-Fi 6
RTL8852BE
Wi-Fi 6 AX201

11.05.100

11.08.230

11.08.240

Intel AX210
WiFi /BT
combo

Intel Wi-Fi6 11.08.330
AX201 2x2 AX
vPro

MediaTek
MT7921LEN

Intel AX210

11.08.290

11.08.360

11.08.360

AMD RZ616 11.08.440

Realtek

RTL8852CE
AMD RZ616 11.08.440

Realtek
RTL8852CE

IGE

|

A

|

Supported Note
from IGEL
OS Version

Excluding
support for
WWAN

LTE support
as of
11.08.360

Quectel
EMO05-G 4G
CAT4

Quectel
EMO05-G 4G
CAT4
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Update and Upgrade

Name Endpoint Minimum Storage
Type Memory Size
(RAM)
Size
ThinkPad Laptop/ 8GB 256 GB
L14 Intel Notebook
Gen4
ThinkPad Laptop/ 8GB 256 GB
L15 Intel Notebook
Gen4
Lenovo Docking Stations
Name
ThinkPad USB-C Hybrid Dock
IOBOX
Lenovo Universal USB-C Dock
LG
Name Endpoint Minimum
Type Memory
(RAM) Size
24CK550N* Allin One 4GB
* (see page
19)
24CK550W* All in One 4GB
* (see page
19)
24CK560N* Allin One 4GB
* (see page
19)
CK500W  ThinClient 4GB
38CK950N Allin One 8 GB
38CK900N Allin One 8 GB

IGEL OS Articles

Processor Wi-Fi Chip

|

IGE

A

r

Supported Note

from IGEL
OS Version
Intel Core Intel AX211 11.09.100 Quectel
i3-1315U EMO05-G 4G
CAT4
Intel Core Intel AX211 11.09.100  Quectel
i3-1315U EMO05-G 4G
CAT4
Supported from IGEL OS Version
11.07.100
11.07.100
11.08.440
Storage Size Processor Supported from

32GB

32GB

32GB

32GB

128 GB
128 GB

AMD G-Series
GX-212JJ

AMD G-Series
GX-212JJ

AMD G-Series
GX-212JJ

AMD G-Series
GX-212JJ

AMD Ryzen 3
AMD Ryzen 3

IGEL OS Version

11.01.100

11.01.100

11.01.100

11.01.100

11.02.100
11.02.100
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Update and Upgrade

Name Endpoint
Type
CL600ON Thin Client
CL600W  Thin Client
34CN650N Allin One
24CN650N Allin One
27CN650N Allin One
CQ600l Thin Client
24CQ6501 Allin One
CQ601I Thin Client
24CR6701  Allin One

LG Docking Stations
Name

LG USB Multi Port Hub

Minimum
Memory
(RAM) Size
4GB

8 GB

4GB

8 GB

8 GB

4GB

4GB

4GB

4GB

OnlLogic
Name Endpoint Type Minimum
Memory
(RAM) Size
CL210G-10 IndustrialPC/ 4GB
Terminal
KARBON 300 Desktop PC 4GB

IGEL OS Articles

Storage Size Processor

16 GB

128 GB

16 GB

16 GB

16 GB

16 GB

16 GB

16 GB

16 GB

Intel® Celeron
J4105

Intel® Celeron
J4105

Intel® Celeron
J4105

Intel® Celeron
J4105

Intel® Celeron
J4105

Intel Celeron
N5105

Intel Celeron
N5105

Intel Pentium
Silver N6005

Intel Celeron
N5105

IGEL

Supported from
IGEL OS Version

11.03.100
11.03.100
11.05.100
11.05.100
11.05.100
11.08.330
11.08.330
11.08.360

11.09.110

Supported from IGEL OS Version

11.09.100

Storage Size Processor

32GB

32GB

Intel Celeron

N3350

Intel Atom x5-

E3930

Supported from
IGEL OS Version

11.04.100

11.04.100
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Update and Upgrade

Onyx Healthcare

Name Endpoint Type Minimum
Memory
(RAM) Size

Venus 223 Medical Allin 4GB

One

Pepperl+Fuchs

Name EndpointType Minimum
Memory
(RAM) Size

BTC12N Industrial Box 4GB

Thin Client
BTC14N Industrial Box 4GB
Thin Client
Rein Medical
Name Endpoint Type Minimum
Memory
(RAM) Size

Silenio C122 Allin One 8 GB

Silenio C124 Allin One 8 GB

Clinio S Medical Allin 8 GB

522TCT One

Clinio S Medical Allin 8 GB

524TCT One

IGEL OS Articles

128 GB

32GB

32GB

128 GB

128 GB

16 GB

16 GB

Storage Size Processor

Intel Quad-Core

J1900

Storage Size Processor

Intel Apollo Lake
N4200

AMD Ryzen
Embedded
V1202B

Storage Size Processor

Intel® Core™i5 -
6th Generation

Intel® Core™ i5 -
6th Generation

Intel® Pentium®
Silver J5005

Intel® Pentium®
Silver J5005

Supported from
IGEL OS Version

11.01.100

Supported from
IGEL OS Version

11.09.100

11.09.100

Supported from
IGEL OS Version

11.01.110

11.01.110

11.04.100

11.04.100
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Secunet
Name Endpoint Minimum Storage Size Processor Supported from
Type Memory IGEL OS Version
(RAM) Size
SINA Workstation Workstation 16 GB 256 GB Intel Core 11.01.100
S EliteDesk 800 G2 i7-6700

USB Memory Sticks That Can Be Used as Alternative UD Pocket Hardware

DIGITTRADE
Name Storage Supported from IGEL OS Version
Kobra Stick > 4GB 11.05.133

Officially Supported Virtual Environments
+ Tested with Ubuntu (64-bit) and default settings

A Notethat the use of a UD Pocket within a virtual machine is not supported by IGEL.

() Forsome features, more than 2 GB RAM is required. Example: if you use dual monitor environments, a
virtual machine must have at least 8 GB RAM.

Name Memory Storage Type Supported from IGEL OS
(RAM) Version

Oracle VM VirtualBox  =2GB >4 GB Linux 11.04.100

VMware Workstation >2GB >4GB Linux 11.04.100

* Delock Adapter DP 1.2 to DVI does not work.
**When using an additional 4k screen with this device, please edit the BIOS settings as follows:

1. Goto the Chipset screen.
2. SetIntegrated Graphics to “Force”.
3. Set UMA Frame Buffer Size to “256M” or higher
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Check List

0 The devices you want to upgrade meet the hardware requirements for IGEL OS 11.

Next Step

>> |mportant! Consider This Before Upgrading (see page 21)
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Important! Consider This Before Upgrading

To make sure that your upgrade can be successful, check the following warnings and notes; a warning symbol
indicates that irreversible damage can be done to your devices.

@ Existing partitions: Any existing partition on the target drive of your device will be deleted. The installer
will repartition the target device. The overall size of the newly created partitions will be calculated based
on the available disk space. The minimum disk usage is 2 GB, the maximum is 16 GB.

© NoDowngrade

You cannot restore your IGEL OS 10 system once you have migrated to IGEL OS 11. The device storage is
overwritten completely with a new partitioning scheme.

© Features (e.g. Clients)

IGEL OS 11 does not have the complete feature set of IGEL OS 10. Make sure that the current version of
IGEL OS 11 meets your requirements. For details, refer to the appropriate release notes.

© Custom Partitions

The contents of Custom Partitions will be deleted by the upgrade. Make sure that the Custom Partition is
restored after the upgrade has finished. Besides becoming dysfunctional after the upgrade, applications
and kernel drivers in a Custom Partition might corrupt the upgrade. For this reason, make sure to first test
the upgrade on a characteristic device.

© Custom Commands

The persistence of custom commands cannot be guaranteed. Besides becoming dysfunctional after the
upgrade, custom commands might corrupt the upgrade. For this reason, make sure to first test the
upgrade on a characteristic device. In general, custom commands must be adapted for IGEL OS 11. We
recommend that you disable custom commands when upgrading; you can enable them once the upgrade
has been successfully completed.

© Power Supply

Ensure that the device is not running on battery power, i.e. it must be connected to a power supply during
the complete upgrade process.

() Network

All devices must be connected to a LAN or WLAN. LAN is the recommended option. The device will not be
upgraded if OpenVPN, OpenConnect, mobile broadband, or genucard is configured. To be sure, check if
the following parameters are deactivated resp. no session is configured:

+ Network > VPN Open VPN (registry: sessions.openvpn% )
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+ Network > VPN > OpenConnect VPN (registry: sessions.openconnect%)

+ Network > Mobile Broadband, checkbox Enable Mobile Broadband (registry:
network.interfaces.mobile_broadband.enabled)

+ Network > VPN > genucard (registry:
network.interfaces.genucard_vpn_connector.autostart_enabled)

When you have changed the settings, restart the device to enable the upgrade.

Check List

@ The limitations and conditions are understood and do not constitute a problem.

Next Step
>> Getting the UMS Ready (see page 23)
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Getting the UMS Ready

To upgrade your devices to IGEL OS 11, you need the appropriate version of the UMS. Also, the devices must be
registered with the UMS to receive their licenses.

1. Ifyou have not already done so, update your UMS to version 6.01.130 or higher. For instructions,
see Updating a UMS Installation.

2. Make sure that your devices are registered with the UMS. For more information, see the
chapter Registering Devices on the UMS Server in the UMS Manual.

Check List
0 Your Universal Management Suite (UMS) version is 6.01.130 or higher.
OAII devices that will be upgraded are registered in the UMS.

Next Step

>> Deploying the Licenses (see page 24)
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Deploying the Licenses

Checking If the Required Licenses Are Available

» Ensure that you have the following licenses:

+ Avalid license from an IGEL Workspace Edition (WE) Product Pack for each device.
+ Depending on the features you want to use, you might need IGEL Enterprise Management (EMP)
licenses in addition. For further information, see IGEL Software License Overview.

Deploying the Licenses

» Choose one of the following methods:

+ If you want to deploy a license quickly on a single device: See Manual License Deployment for IGEL
0S without UMS; start from step 5.

+ If you have a smaller or medium number of devices and want to control exactly which device
should get a license: See Manual License Deployment for IGEL OS.

+ If you have a medium or greater number of devices, and you are planning to add new devices/
licenses regularly: See Set up Automatic License Deployment (ALD) with ALD Token.

+ If you have a medium or greater number of devices, and you are planning to add new devices/
licenses frequently (licensing can be managed completely in the IGEL License Portal): See Setting
up Automatic License Deployment (ALD).

Check List
@ The licenses have been purchased.

0 License deployment is set up.

Next Step

>> Creating the Universal Firmware Update (see page 25)
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Creating the Universal Firmware Update

In this step, we will create a Universal Firmware Update that will be used for testing the upgrade and for rolling out
the upgrade on all relevant machines.

() Ifyou use the High Availability Extension, note that Universal Firmware Updates are NOT synchronized,
that is why you have to either download them to all HA nodes or configure an external (FTP) server.

Choose the procedure that suits your needs:

« Configuring the Universal Firmware Update with Files Hosted by the UMS (see page 25)
+ Configuring the Universal Firmware Update with Files Hosted by FTP Server (Required for ICG) (see
page 30)

Configuring the Universal Firmware Update with Files Hosted by the UMS

1. Goto Server - [UMS address] > Universal Firmware Update and in the context menu, select
Check f w firmware updates.

mware Update
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IGEL

2. Select the entry for the IGEL OS 11 firmware and then select Download. (In the example, IGEL OS
11.03.110is used.)

Universal Firmware Updates

Ln

Include  Model
HTRL

HThL
HThiL

HimiL
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3. Read and confirm the disclaimer. (IGEL OS 11.03.100 or higher only)
Disclaimer of IGEL OS 11 11.03.110
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4. Confirm the status message.

Universal Update Download results

Mame Status Errar
IGEL 0S5 11-11.03.110

In the main window, you can monitor the download process.

IGEL OS Articles 28/823



Update and Upgrade

Firmware Update Settings

IGEL_INTER

HTHL

Firmware Update Settings
IGEL_INTER

Download Status

Error
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Configuring the Universal Firmware Update with Files Hosted by FTP Server (Required for ICG)

You can use an FTP server instead of the UMS to host the firmware files. If you are using IGEL Cloud Gateway (ICG),
an FTP server is required.

To configure an FTP server as update source:

1. Inthe UMS, go to UMS Administration > Universal Firmware Update and click Edit.
2. Enter the data required for accessing the FTP server and click Save.

Edit FTP Server Configuration

Universal update settings
The IGEL Un al Firr re downloaded fram: ‘fin

The FTP server settings where the files are downloaded to (optionalhy).

Host fips name

Directory

3. Click Test server connection to test your settings.
If everything went well, a success message is shown both for the IGEL download server and for the
FTP server:

The FTP server settings where the files are downloaded fo (optional).
Protocol

Host

Fort

Directory

Connection test  [Connection :
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4. Go to Server - [UMS address] > Universal Firmware Update and in the context menu, select
Check for new firmware updates.

red Workplace Users

5. Select the entry for the IGEL OS 11 firmware, click to select the FTP server selected in step 2
and then select Download.

Universal Firmware Updates

Include  Model
HTRL

HThiL
HThL
HThL
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6. Read and confirm the disclaimer. (IGEL OS 11.03.100 or higher only)
Disclaimer of IGEL OS 11 11.03.110
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7. Confirm the status message.

Universal Update Download results

Errar
25 11-11.03.110

The firmware is transferred to the FTP server. In the main window, you can monitor the download
process.
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sal Firmwa

Froduct  1GE
11.03.110
HTML T

Firmware Update Settings

ufu

Host  localhost
Part
Protocol

Target URL 11-11.03.110

Download Status
]
[ ]

:- Stared Diovenload the firmware update...

- .
Status =

Errar

When the status is Finished, your Universal Firmware Update is ready for use.
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al Firrr

Product

Haost

Fort
Protocol
Target LURL

shotfile

Download Status

Status

Error

Check List

0 The Universal Firmware Update has been created successfully.

Next Step

1-11.03.110

11.03.110

HThL

Settings
ufu
localhost
21
FTP

IGEL_O5_11-11.03.110

>> Creating an Upgrade Profile (see page 36)
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Creating an Upgrade Profile

The upgrade profile varies, depending on whether the devices are in the same network as the UMS or connected via
ICG. Choose the appropriate procedure:

« For Devices that Are in the UMS Network (see page 36)
« For Devices that Are Connected via ICG (see page 40)

For Devices That Are in the UMS Network

1. Inthe UMS structure tree, go to Profiles, open the context menu and select New Profile.
¥ £ |GEL Universal Management Suite &
¥ Profil
il

8 Impaort (03

2. Enter the following data:
+ Profile Name: Name for the profile, e. g. "Upgrade to IGEL OS 11".
« Description: Optional description for the profile.
« Based on: Firmware version for the profile; select the current firmware of your devices, that
is, "IGEL UD Pocket 10.06.100".
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3. Click Ok.

MNew Profile

Profile Marme | Upgrade to IGEL OF

Cescription

Based on [GEL LD Pocket 10.06.100.01

* Expert mode

4. Go to System > Update > Firmware Update and change the settings as follows:
« Select "HTTPS" as the Protocol.
« Activate Automatic update check on boot.
« Ensure that Automatic update check on shutdown is deactivated. Otherwise, the device
will shut down when the update is finished.
Upgrade to IGEL 0OS 11
< > A ur

. . d 5 Related Configurations
Configuration : —~ ]

Search

5. Go to System > Update > Firmware Update > OS 11 Upgrade.
6. Activate Upgrade to OS 11.
7. Make the following settings according to your needs:
« If you want the device to retry the upgrade immediately after a failed attempt,
activate Upgrade to OS 11 even if a previous upgrade attempt failed. With this setting,
the device will retry the upgrade 5 times. When the 5th attempt has failed, a message will be
shown in the upgrade tool window.
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« If your device has a PowerTerm license, and you want to upgrade to IGEL OS 11 even
though IGEL OS 11 does not support PowerTerm, you must activate Upgrade to OS 11 even
if PowerTerm is enabled.

+ Under Require an Enterprise Management Pack license to upgrade to OS 11, select the
appropriate option:

« If you are using IGEL Cloud Gateway (ICG) or Shared Workplace (SWP) or a Custom
Partition and want to make sure that the upgrade is performed only if these features
can be used furthermore, select Smart. When Smart is selected, and one of these
features is activated, the upgrade is performed only if the device succeeded in
fetching a license from an Enterprise Management Pack.

+ If you want to force the device to fetch a license from an Enterprise Management
Pack and make sure that the upgrade is performed only if this license has been
fetched, select Always.

+ If you want the device to upgrade to IGEL OS 11 without fetching a license from
an Enterprise Management Pack, disregarding the features, select Never.

8. Under Timeout waiting for OS 11 license to start automatic upgrade, set the time period the
device will wait for a license in a mass deployment scenario. This setting prevents the device from
starting the upgrade at an inappropriate time as a result of the license just being deployed. This
way, the setting prevents unwanted interruptions at work. For a mass deployment scenario, the
default value 10 Minutes is recommended.

Upgrade to IGEL OS 11

< > ~ ! ¥ Systen » Update » O35 11 Upgrade

Configuration

wen if 3 previous upgrade attempt failed

d send to device
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9. If you have a Custom Partition, go to Firmware Customization > Custom Partition > Partition
and deactivate Enable Partition.

Upgrade to IGEL OS 11

zation ® Custom Partition ™ Partition

5

v Enahle Partition

10. If you have custom applications, go to Firmware Customization > Custom Application and, for
each custom application, deactivate Autostart. This is to prevent the custom application from
interfering with the device's system before it can be tested properly.
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ITC14DDA94FE94E
> ~

Configuration

Panel

Mone

11. Click Save.

For Devices That Are Connected via ICG

1. Inthe UMS structure tree, go to Profiles, open the context menu and select New Profile.
IGEL Univer

contral

Migration UDC? Update Firrr

Scheduled firm Logging: b
ter Profil
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2. Enterthe following data:
+ Profile Name: Name for the profile, e. g. "Upgrade to IGEL OS 11".
+ Description: Optional description for the profile.
+ Based on: Firmware version for the profile; select the current firmware of your devices, that
is, "IGEL UD Pocket 10.06.100".
3. Click Ok.

MNew Profile

Profile Mame | Lip e to IGEL

Cescription

Based on [GEL LD Pocket 10.06.100.01

* Expert mode

4. Go to System > Update > Firmware Update and change the settings as follows:
+ Select "FTP" as Protocol.
« Activate Automatic update check on boot.
« Ensure that Automatic update check on shutdown is deactivated. Otherwise, the device
will shut down when the update is finished.
Upgrade to IGEL 0OS 11
< > A

. roto 4 igurations
Configuration i

[Z Features

Search

5. Go to System > Update > Firmware Update > 0S 11 Upgrade.
6. Activate Upgrade to OS 11.
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7. Make the following settings according to your needs:

+ If you want the device to retry the upgrade immediately after a failed attempt,
activate Upgrade to OS 11 even if a previous upgrade attempt failed. With this setting,
the device will retry the upgrade 5 times. When the 5th attempt has failed, a message will be
shown in the upgrade tool window.

+ If your device has a PowerTerm license, and you want to upgrade to IGEL OS 11 even
though IGEL OS 11 does not support PowerTerm, you must activate Upgrade to OS 11 even
if PowerTerm is enabled.

+ Under Require an Enterprise Management Pack license to upgrade to OS 11, select the
appropriate option:

+ Ifyou are using IGEL Cloud Gateway (ICG) or Shared Workplace (SWP) or a Custom
Partition and want to make sure that the upgrade is performed only if these features
can be used furthermore, select Smart. When Smart is selected, and one of these
features is activated, the upgrade is performed only if the device succeeded in
fetching a license from an Enterprise Management Pack.

+ If you want to force the device to fetch a license from an Enterprise Management
Pack and make sure that the upgrade is performed only if this license has been
fetched, select Always.

+ If you want the device to upgrade to IGEL OS 11 without fetching a license from an
Enterprise Management Pack, disregarding the features, select Never.

8. Under Timeout waiting for OS 11 license to start automatic upgrade, set the time period the
device will wait for a license in a mass deployment scenario. This setting prevents the device from
starting the upgrade at an inappropriate time as a result of the license just being deployed. This
way, the setting prevents unwanted interruptions at work. For a mass deployment scenario, the
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default value 10 Minutes is recommended.
Upgrade to IGEL OS 11

> ~ [ W Systermn * Update * 0511 Upgrade

Configuration € S ¥ Upgradeto 0511
Sessions a . .
€ /¥ Upgradeto 0S 11 even if a previous upgrade attempt failed
Accessories

User Interface A

Netwark Require an Enterprise Management Pack license to upgrade ta 05 11

Devices

Security Timeout waiting for 05 11 license to start automatic upgrade

System

B Time and Date
v O3 Update
B Firmware Update
B Buddy Update
[ o511 Upgrade
» Il Remote management
» I Remote Access
B Remote Sysing
» Il Power Options
» I Firmware Customization
B Registry

Search

Apply and send o device Save Cancel

9. If you have a Custom Partition, go to Firmware Customization > Custom Partition > Partition
and deactivate Enable Partition.
ITC14DDA94FES4E

> ~ [ W Systern ® Firmware Customization ® Custom Partition  ®* Parition

. . This feature requires an active Enterprise Management Pack subscription.
conflguratlon
Enable Partition
Sessions
Accessories
User Interface

Metwork
Paritions Parameters
Devices
Marme
Security

P4 4 4 4 4 4

Systerm

B Time and Date
+ I Update
» Il Remote management
» I Remote Access
B Logging
» Il Power Options
¥ [ Firmware Customization
¥ [ Custam Partition
B Fariition

» Il Custom Application

» I Custom Commands

» B Corporate Design

» Il Ervironment Variables
B Features

B Registry

Search

Apply and send to device Save Cancel
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10. If you have custom applications, go to Firmware Customization > Custom Application and, for
each custom application, deactivate Autostart. This is to prevent the custom application from
interfering with the device's system before it can be tested properly.

ITC14DDA94FES4E

> ~ I » M i zation ® Custorm Ap|

me
Configuration
Starting Methods for Session
it enu
n Launcher
1t Fanel
Menu folder
pplication Launcher folder
dop folder

wrotection Mone

Huotkey

Appliance

Search

11. Click Save.

Check List
0 The upgrade profile is configured properly for your needs.

Next Step

>> Assigning the Upgrade Profile and the Universal Firmware Update to the Test Devices (see page 45)

IGEL OS Articles 44 /823



Update and Upgrade

IGEL

Assigning the Upgrade Profile and the Universal Firmware Update to the Test
Devices

1. Ifyou have not already created a directory as a distribution condition while setting up Automatic
License Deployment (ALD): In the Devices node of the UMS structure tree, create a directory and
name it "Upgrade to IGEL OS 11", for instance. For more information about distribution conditions,
see Configuring the Distribution Conditions, section "Distributing Licenses to Devicesin a
Specified Directory".
Bl Devy
8 Impo
b Er" r"llE!'III'III'
e 1 Clear 'Configuration Change Status'flag
» [ Remote C AL

; control

‘% ITC14DDAI4FESAE
Clitc 7 A
Mobile C

. chromium-k i -

an for devices
I client-cert.pem

New Directory

Directory Mame Upgrade to I(GEL 05 11
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2. Putthe devices that are to be updated into the new directory. You can use drag & drop.

[ I|_-' [mpaort (0%

[ Mew

e ] =
I DAY4FERSE
IDAS4FES4E

3. Inthe Update time dialog, select Now and click Ok.
The directory change is communicated immediately to the device.

Update time

YWhen should these changes take effect?
4 Rebiont

settings on next reboot (and dan't show this dialog again)

Server - 172.30.92.9
1
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5. Assign the upgrade profile and the Universal Firmware Update for IGEL OS 11.03 to the directory
and click Ok.

Select assignable objects

6. Inthe Update time dialog, select Now and click Ok.
The changes are sent to the devices immediately.

Update time

uld th
Rehoot

w this dialog
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In the Assigned objects area, the profile and the Universal Firmware Update are shown:

() Ifyou are using Automatic License Deployment (ALD), it might be feasible to confine the distribution of
licenses to the current directory. For more information, see Configuring the Distribution Conditions,
section "Distributing Licenses to Devices in a Specified Directory".

Check List

O The test devices are in a directory to which the upgrade profile and the Universal Firmware Update are assigned.

Next Step

>> Testing the Upgrade (see page 49)
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Testing the Upgrade

1. Inthe UMS, select the directory containing the test devices and select Reboot.

0511 (1)
AFEB4E

UMS Administrati

Fonnected to 1
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2. Inthe Reboot devices dialog, click Reboot.

Reboot devices

o) |TCH \O4FEQ4E

Reboot Cancel

If no IGEL OS 11 licenses have been deployed on the devices yet, the licenses are deployed within a
few minutes. The upgrade will be started when the licenses are deployed. The maximum time
period the device will wait for a license is configured by the parameter Timeout waiting for 0S 11
license to start automatic upgrade; for details, see Creating an Upgrade Profile (see page 36), step
8.
The parameter Automatic update check on boot makes the devices look for new firmware
again. Although two Universal Firmware Updates are assigned to the devices, the UMS offers the
IGEL OS 11 firmware, because the ID of the IGEL OS 11 firmware is higher than the ID of the IGEL OS
10 firmware.
The upgrade is completed.

3. Check whether all features and functions of your test devices are working as expected.

Check List

0 All features and functions of your test devices are working as expected.

Next Step

>> Unassigning the Upgrade Profile and the Universal Firmware Update (see page 51)
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Unassigning the Upgrade Profile and the Universal Firmware Update

The upgrade profile and the Universal Firmware Update should be unassigned from the devices after they have
been upgraded to IGEL OS 11 successfully.

To unassign upgrade profile and the Universal Firmware Update:

1. Move the devices to a different folder.

2. Inthe Update time dialog, select Now and click Ok.
The directory change is communicated immediately to the devices.

Update time

should these changes take effect?

If a device had a Custom Partition before, it will be downloaded by the device and activated again.

Check List
If a device had a Custom Partition before:

@ The Custom Partition has been downloaded by the device and activated.

Next Step

If some devices have a Custom Partition:

>> |f Applicable: Restoring Custom Partition and Custom Application (see page 52)
If no device has a Custom Partition:

>> Upgrading All Devices (see page 53)
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If Applicable: Restoring Custom Partition and Custom Applications

If a device had a custom partition before the upgrade, it has been downloaded and activated again after the
upgrade profile has been unassigned; see Unassigning the Upgrade Profile and the Universal Firmware Update (see
page 51). It cannot be ruled out that custom commands and the applications and drivers of a Custom Partition
disturb your device's system. Therefore, it is very important to check the Custom Partition, the custom applications,
and the device's basic functionality.

1. Testthe Custom Partition and the custom applications. If errors should occur, modify the Custom
Partition and the custom applications accordingly.
2. Checkif all other functions are still working properly.

Check List
0 The Custom Partition and the custom applications are enabled and can be used.

0 All other functions are working properly.

Next Step

>> Upgrading All Devices (see page 53)
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Upgrading All Devices

Assigning the Upgrade Profile and the Universal Firmware Update to the Devices

1. Putthe devices that are to be upgraded into the directory you have created for the test devices. It
is recommended to use cut and paste.
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L ITCO0EDC
L1 TcooEnCs:
B ITC1 40D DAL
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contral
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Take over settings from ...
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Connected to 172,
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3.

L ITCooE

Ll mcoooecanssnl A

control

Ll
Mabile D

Specific Device Command

License manually...

Export Device Settings
Save device files for support

Logoing

In the Update time dialog, select Now and click Ok.
The directory change, the upgrade profile and the Universal Firmware Update are communicated
immediately to the devices.

Update time

changes take effect?

settings on next reboot (and don't show this dialog again

In the UMS, select the directory with the devices and select Reboot.
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UMS Administrati

apshot commands

Command
License manually...
Export De ettings
evice files for support

Logaing

[ 3 Mew Directory
! 'E' .:

for devii

sonnected o 172.30.92.9 as admin
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4. Inthe Reboot devices dialog, click Reboot.

Rehboot devices

W TC14DDAS4FES4E

Rehboot Cancel

If no IGEL OS 11 licenses have been deployed on the devices yet, the licenses are deployed within a
few minutes. The upgrade will be started when the licenses are deployed. The maximum time
period a device will wait for a license is configured by the parameter Timeout waiting for 0S 11
license to start automatic upgrade; for details, see Creating an Upgrade Profile (see page 36), step
8.

The parameter Automatic update check on boot makes the devices look for new firmware

again. Although two Universal Firmware Updates are assigned to the devices, the UMS offers the
IGEL OS 11 firmware, because the ID of the IGEL OS 11 firmware is higher than the ID of the IGEL OS
10 firmware.

Unassigning the Upgrade Profile and the Universal Firmware Update

1. Tounassign the upgrade profile and the Universal Firmware Update, move the devices to a
different folder.
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¥ Fm Upgrade to IGEL OS5 11 {13
8 WOl (o Edit Configuration
L1 Teooo

B [TC14D . (1) Clear 'Configuration Change Status' flac

% ITC14D

cure Terminal
Tyl )
Shutdown
£ IGEL 0% 11.03

u
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lear 'Canfiguration Change Status'flag

contral

& uDc
Em Upor
BT

Llmco

& ITC
B ITCH
LT3
Mobile C

shot commands

Command

License manually...

LA A A,

2. Inthe Update time dialog, select Now and click Ok.
The directory change is communicated immediately to the device.

Update time

YWhen should the
t Rehoot

L ] r"u_l Oy

If a device had a Custom Partition before the upgrade, it has been downloaded and activated
again after the upgrade profile has been unassigned.

3. If applicable, restore the required custom applications; see |f Applicable: Restoring Custom
Partition and Custom Applications (see page 52).
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Check List
@ All devices have been upgraded to IGEL 0S 11.

0 All required functionality is available, including custom applications.
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Upgrading from IGEL OS 10 to IGEL OS 11

+ Upgrading UDC3 Devices from IGEL OS 10 to IGEL OS 11 (see page 62)
+ Upgrading IGEL Devices from IGEL OS 10 to IGEL OS 11 (see page 151)
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Upgrading UDC3 Devices from IGEL OS 10 to IGEL OS 11

This document describes how to upgrade any number of devices (UDC3) from IGEL OS 10 to IGEL OS 11.

IGEL OS 10.05.800 or higher is required for upgrading to IGEL OS 11. If you have an older version of IGEL OS 10, you
need to update to version 10.05.800 or a higher version first.

Since a new licensing model has been introduced with IGEL OS 11, a license from an IGEL Workspace Edition
Product Pack must be available for each device. If you have a valid maintenance for your devices, you can convert
your existing UDC3 or UD Pocket Product Packs to Workspace Edition (WE) Product Packs; see Converting UDC3 or
UD Pocket Licenses for Upgrading to IGEL OS 11.

The following methods of mass deployment are described here:

« Zero-Touch Deployment Using Universal Firmware Update (see page 63): Mass upgrade from any
version of IGEL OS 10 to IGEL OS 11 in one step using Universal Firmware Update. This method can
be started immediately or as a scheduled job (wake up or reboot).

+ Zero-Touch Deployment Using Buddy Update (see page 101): Mass upgrade from any version of IGEL
0S 10 to IGEL OS 11 in one step using two devices as update buddies. This method can be started
immediately or as a scheduled job (wake up or reboot).

+ Zero-Touch Deployment Using a Scheduled Job (see page 131): Upgrade devices that are already
running IGEL OS 10.05.800 (or higher) using a specific scheduled job.
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Zero-Touch Deployment Using Universal Firmware Update

This method is the most convenient way to upgrade from IGEL OS 10 to IGEL OS 11. The method uses the Universal
Firmware Update feature of the UMS (Universal Management Suite) and a profile.

Read all the following chapters carefully and follow the instructions.

Devices That Can Be Upgraded to Igel OS 11 (see page 64)
Important! Consider This Before Upgrading (see page 76)
Preparing the Upgrade (see page 77)

Testing the Upgrade (see page 82)

Checking the Requirements (see page 86)

Creating the Universal Firmware Updates (see page 87)
Creating a Profile (see page 91)

Deploying the Licenses (see page 96)

Putting It All Together (see page 97)

Executing the Upgrade (see page 99)

WoeNoOkwWwNE
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Devices That Can Be Upgraded to Igel 0S 11

Core Requirements

« CPU with 64-bit support
« CPUspeed:=1GHz
+ Memory (RAM): =2 GB

() RAMsize higher than 2 GB is recommended if you use any of the following:
+ Unified Communications optimizations (uses a client-side media engine)
+ High-resolution graphics output
+ More than two monitors

@ With devices that have 2 GB RAM and shared video memory, a maximum of 512 MB may be
used as video memory.

+ Storage: Depends on the release version of IGEL OS 11. The details are listed below: 2 GB
minimum; =4 GB recommended

« UptoIGEL 0S 11.03:2 GB minimum; =4 GB recommended

« From IGEL OS 11.04 to IGEL OS 11.07: If the full feature set is applied, at least 2.4 GB of
storage is required. For instructions on how to reduce the feature set, see Error: "Not
enough space on local drive" when Updating to IGEL OS 11.08 or Higher.

« From IGEL OS 11.08 onwards: If the full feature set is applied, at least 2.4 GB of storage is
required. For instructions on how to reduce the feature set, see Error: "Not enough space on
local drive" when Updating to IGEL OS 11.08 or Higher. TODO Add URL when published

+ NoVIA graphic adapter; VIA graphics support is discontinued in IGEL OS.
+ Legacy Bios and EFI/UEFI are supported.

Devices Supported by OSC and UD Pocket with IGEL OS 11

& Thefollowing list only includes those devices that are tested by IGEL (with each major release of IGEL OS).
By no means it implies that the devices which are not included in this list but meet the minimum
requirements will not function with IGEL OS: Any x86-64 hardware endpoint device that meets the IGEL-
stated minimum hardware requirements for IGEL OS (for example, the processor speed and RAM) can be
expected to work adequately with IGEL OS and should be considered a candidate for repurposing from
another OS. With an IGEL OS subscription or active maintenance, customers can expect IGEL to make any
necessary “best effort” to support, regardless of whether the endpoints in question are specifically listed
within the IGEL Knowledge Base or elsewhere (e.g. on the IGEL Ready Showcase at https://www.igel.com/
ready/showcase-categories/endpoints/).

For any devices not listed here or on the IGEL Ready showcase, you can contact your hardware vendor and
request those devices to be added to the IGEL Ready program.

Integrated drivers and supported peripherals are listed in the Third-Party Hardware Database!®. For more
solutions compatible with IGEL OS, see Partner Solutions.

19 https://www.igel.com/linux-3rd-party-hardware-database/
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(@ HP,Lenovo, and LG device models are available from the factory with pre-installed IGEL OS 11. Please
contact IGEL Ready? to get information on which device models are available with pre-installed IGEL OS.

() Forsome of the devices listed here, Flash memory must be extended to = 2 GB. For these devices, an
appropriate note is added.

() Onmodern computers such as secured-core PCs (see e.g. https://www.microsoft.com/en-us/windows/
business/devices?col=secured-core-pcs), there may be a BIOS setting related to Secure Boot that allows
the use of Microsoft’s 3rd party UEFI Secure Boot Certificate. The usual description of such a BIOS setting is
"Allow Microsoft 3rd Party UEFI CA". This setting must be set to enabled, as IGEL uses the 3rd party
certificate to support UEFI Secure Boot. If UEFI Secure Boot is enabled, but "Allow Microsoft 3rd Party UEFI
CA" is not enabled, you may be unable to boot IGEL OS Creator or UD Pocket. Similarly, if the setting
"Allow Microsoft 3rd Party UEFI CA" is disabled after a previous installation of IGEL OS, IGEL OS will fail to
boot. For how to enable the setting, see Secured-Core PCs: Microsoft 3rd-Party UEFI Certificate for Secure
Boot.

(@ [Fn] keys may not work on some supported and listed laptop/notebook models.

ADS-Tec

Name Endpoint Type Minimum Storage Size Processor Supported from
Memory IGEL OS Version
(RAM) Size

DVG- Industrial PC/ 4GB 64 GB eMMC Intel Atom®x7- 11.02.100

VMT9010 Terminal 8GB E3950

DVG- Industrial PC/ 4GB 64 GB eMMC Intel Atom®x7- 11.02.100

VMT9012 Terminal 8GB E3950

DVG- Industrial PC/ 4GB 64 GB eMMC Intel Atom®x7- 11.02.100

VMT9015 Terminal 8GB E3950

DVG- Industrial PC/ 4GB 64 GB eMMC Intel Atom®x7- 11.02.100

VMT9112 Terminal 3GB E3950

Advantech

20 https://www.igel.com/technology-partners/
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Name Endpoint Type Minimum Storage Size Processor
Memory
(RAM) Size
POC-W213L Medical Allin 4GB 128 GB Intel Core
One i7-7300U
POC- Medical Allin 4GB 32GB Intel Kaby Lake
W243L" (see One Core i5-7300U
page 75)
POC- Medical Allin 4GB 128 GB Intel Core
W243L* (see One i7-7300U
page 75)
Advantech-DLoG
Name Endpoint Type Minimum Storage Size Processor
Memory
(RAM) Size
DLT-V6210 Industrial PC/ 4GB 32GB Intel Atom
Terminal
DLT-V7210 K Industrial PC/ 4GB 4GB Intel Atom
Terminal E3845
Dell / Wyse
Name Endpoint Minimum Storage Processor Supported
Type Memory  Size from IGEL OS
(RAM) Size Version
5040 /5212 AllinOne 2GB 2GB AMD G-T48E 11.01.100
3040 Thin Client 2 GB 8 GB Intel Atom  11.01.100
x5-728350
5020 Thin Client 2 GB 8 GB AMD G-Series 11.02.140
SoC
5060 Thin Client 4GB 8 GB AMD 11.01.100
GX-424CC
5070 Thin Client 8 GB 32GB Intel Celeron 11.01.100

IGEL OS Articles

J4105

IGEL

Supported from
IGEL OS Version

11.01.100

11.01.110

11.01.100

Supported from
IGEL OS Version

11.01.100

11.01.100

Note
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Name Endpoint Minimum Storage
Type Memory  Size
(RAM) Size
Latitude Laptop/ 256 GB
5510 Notebook
Optiplex  ThinClient 4 GB 32GB
3000
Dynabook
Name Endpoint Minimum
Type Memory
(RAM) Size
Portegé X20W- Laptop/ 8 GB
D Notebook
Portegé X30-D Laptop/ 8 GB
Notebook
Tecra C50 Laptop/ 4GB
Notebook
Tecra Z50-D  Laptop/ 8 GB
Notebook
SATELLITE R50 Laptop/ 4GB
Notebook
Elo
Name Endpoint Minimum
Type Memory
(RAM) Size
i2 Touch Allin One 8 GB
(15and 22
inches)

Fujitsu

IGEL OS Articles

Processor

Intel Core
i5-10210U

Supported
from IGEL OS

Version

11.05.100

Intel Celeron 11.08.200

N5105

Storage Size Processor

256 GB

256 GB

500 GB

256 GB

500 GB

Intel Core
i5-7200U

Intel Core
i5-7300U

Intel i5-4210U

Intel Core
i5-7200U

Intel i3-6006U

Storage Size Processor

128 GB

Intel Core
i3-8100T

Note

Wake-on-LAN
functionality is
not supported.

Supported from
IGEL OS Version

11.01.100

11.01.100

11.01.100

11.01.100

11.01.100

Supported from
IGEL OS Version

11.05.100
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Name

Q957

FUTRO S740 Thin Client

HP

Name

HP t420

HP t430

HP t530

HP t630
HP t730

HP t820

HP t640

HP t540

IGEL OS Articles

Endpoint
Type

Desktop PC

Endpoint
Type

Thin Client

Thin Client

Thin Client

Thin Client
Thin Client

Thin Client

Thin Client

Thin Client

Minimum

Memory

(RAM) Size

8 GB

4GB

Minimum Storage

Memory
(RAM) Size

2GB

2GB

4GB

4GB
16 GB

16 GB

4GB

16 GB

Size

8 GB

16 GB

8 GB

8 GB
8 GB

16 GB

16 GB

16 GB

Storage Size Processor

500 GB

8 GB

IGEL

Supported from
IGEL OS Version

Intel Core 11.02.100

i3-6100

Intel Celeron 11.04.100

J4105

Processor Supported Note
from IGEL OS

Version

AMD 11.02.100
Embedded G-
Series

GX-209JA

Intel®Celeron®11.01.110
N4020

AMD GX-215JJ 11.01.100
Dual-Core

AMD GX-420GI! 11.01.100

AMD 11.01.100
RX-427BB APU

Intel Core 11.01.100

i5-4570S

AMD Ryzen
R1505G

AMD Ryzen
Embedded
R1305G

11.04.100

11.06.100
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Name

HP mt46

HP Elite
t655

HP Elite
mt645 G7

HP t740

HP Pro t550 Thin Client 4 GB

HP Pro
mt440 G3

Endpoint Minimum Storage

Type Memory Size
(RAM) Size

Mobile Thin 8 GB 32GB

Client

Thin Client 4GB/8GB 32GB

Mobile Thin 8 GB 256 GB

Client

Thin Client 8 GB 16 GB
32GB

Mobile Thin 8 GB 128 GB

Client

HP Docking Stations

IGEL OS Articles

Processor Supported
from IGEL OS
Version

AMD Ryzen3 11.07.100

PRO 4450U

AMD Ryzen  11.07.160

Embedded

R2314

AMD Ryzen 3 11.08.230

5425U

AMD Ryzen5 11.08.330

5625U

AMD Ryzen 11.08.290

Embedded

V1756B

Intel Celeron 11.08.330
J6412

Intel Celeron 11.08.440
7305

Note

Excluding
support for
WWAN

and Wake-on-
LAN (both
features are
planned)

Support for
WWAN Intel XMM
7560 R+ (as of
11.08.330)

Excluding
support for
Wake-on-LAN
(featureis
planned)

Excluding
support for built-
in fingerprint
sensor

Excluding
support for
WWAN Intel XMM
7560 R+ (feature
is planned)
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Name Supported from IGEL OS Version
HP USB-C Docking Station G5 11.08.230
HP USB-C G5 Essential Dock 11.08.290
Intel
Name Endpoint Minimum Storage Size Processor Supported from
Type Memory IGEL OS Version
(RAM) Size
NUC 5i5MYHE Desktop PC 2 GB 32GB Intel i5-5300U 11.01.100
NUC5i3RYH DesktopPC 2GB 2 GB Intel i3-5010U 11.01.100
NUC7CJYH DesktopPC 2GB 4GB Intel Celeron 11.01.100
J4005
Lenovo
Name Endpoint Minimum Storage Processor Wi-Fi Chip Supported Note
Type Memory Size from IGEL

(RAM) OS Version

Size
ThinkCentreDesktop 4 GB 32GB  AMD Intel AC9260 11.04.100
M625q PC E2-9000e

8 GB 128GB  AMD QCA6174 11.04.100

A4-9120e 802.11ac
ThinkCentreDesktop 8 GB 256 GB  AMD Ryzen Intel AC9260 11.05.100

M75n PC 3

Pro 3300U
ThinkCentreDesktop 16 GB 256 GB  Intel Comet Lake 11.05.100
M70q Genl PC i5-10500t PCH CNVi

WiFi, Intel

ThinkCentreDesktop 16 GB 256 GB IntelCore Intel AX201 11.08.240
M70q Gen 3 PC i5-12500T
ThinkCentreDesktop 4 GB 128 GB  AMD Ryzen Intel AX200 11.08.240
M75q Gen 2 PC 3 Pro

5350GE
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Endpoint Minimum Storage
Memory Size

Name

Type

(RAM)
Size

K14 AMD  Laptop/ 8GB
Genl Notebook
ThinkPad Laptop/ 64GB
L14 AMD Notebook
Gen1l
14w Laptop/ 4GB

Notebook
ThinkPad Laptop/ 16GB
L14 AMD Notebook
Gen3
ThinkCentreThin 8 GB
Neo50q Client
Gen 4 4GB
K14 Intel Laptop/ 16GB
Genl Notebook
ThinkPad Laptop/ 16GB
L14 Intel Notebook
Gen3
ThinkEdge Thin 8GB
SE10 Client
ThinkPad Thin 8 GB
L14 AMD Client
Gen4
ThinkPad Thin 8 GB
L15 AMD Client
Gen4

IGEL OS Articles

256 GB

1TB

64 GB

256 GB

256 GB

256 GB

256 GB

512 GB

1TB

256 GB

256 GB

256 GB

Processor

AMD Ryzen
5PRO
5650U

AMD Ryzen
7 Pro
4750U

AMD
A6-9220C

AMD Ryzen
55625U

Intel Core
i3-1215U

Intel
Celeron
7305

Intel Core
i5-1135G7

Intel Core
i5-1235U

Intel Atom
X6425RE

Intel Atom
X6214RE

AMD Ryzen
3 Pro
7330U

AMD Ryzen
3 Pro
7330U

Wi-Fi Chip

Mediatek
MT7921

11.08.240

Wi-Fi 6
AX200, Intel

11.05.100

QCA6174
802.11ac

AMD RZ616
2X2AX (WiFi
6E)

Wi-Fi 6
RTL8852BE
Wi-Fi 6 AX201

11.05.100

11.08.230

11.08.240

Intel AX210
WiFi /BT
combo

Intel Wi-Fi6 11.08.330
AX201 2x2 AX
vPro

MediaTek
MT7921LEN

Intel AX210

11.08.290

11.08.360

11.08.360

AMD RZ616 11.08.440

Realtek

RTL8852CE
AMD RZ616 11.08.440

Realtek
RTL8852CE

IGE

|

A

|

Supported Note
from IGEL
OS Version

Excluding
support for
WWAN

LTE support
as of
11.08.360

Quectel
EMO05-G 4G
CAT4

Quectel
EMO05-G 4G
CAT4
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Name Endpoint Minimum Storage
Type Memory Size
(RAM)
Size

ThinkPad Laptop/ 8GB 256 GB

L14 Intel Notebook
Gen4

ThinkPad Laptop/ 8GB 256 GB

L15 Intel Notebook
Gen4

Lenovo Docking Stations

Name

ThinkPad USB-C Hybrid Dock

IOBOX

Lenovo Universal USB-C Dock

LG

Name Endpoint
Type

24CK550N* Allin One
* (see page
75)

24CK550W* Allin One
* (see page
75)

24CK560N™* Allin One
* (see page
75)

CK500W  Thin Client

38CK950N Allin One
38CK900N Allin One

IGEL OS Articles

Minimum
Memory
(RAM) Size

4GB

4GB

4GB

4GB

8GB
8GB

Processor Wi-Fi Chip

Intel Core
i3-1315U

Intel Core
i3-1315U

|

IGE

A

r

Supported Note

from IGEL
0OS Version

Intel AX211  11.09.100  Quectel

EMO05-G 4G
CAT4

Intel AX211 11.09.100  Quectel

EMO05-G 4G
CAT4

Supported from IGEL OS Version
11.07.100
11.07.100
11.08.440

Storage Size Processor

32GB

32GB

32GB

32GB

128 GB
128 GB

AMD G-Series
GX-212JJ

AMD G-Series
GX-212JJ

AMD G-Series
GX-212JJ

AMD G-Series
GX-212JJ

AMD Ryzen 3
AMD Ryzen 3

Supported from

IGEL OS Version

11.01.100

11.01.100

11.01.100

11.01.100

11.02.100
11.02.100
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Name

CL600ON

CL600W

34CN650N

24CN650N

27CN650N

CQeo00l

24CQ650I

CQ6011

24CR670I

Endpoint
Type

Thin Client

Thin Client

Allin One

Allin One

Allin One

Thin Client

Allin One

Thin Client

Allin One

LG Docking Stations

Name

LG USB Multi Port Hub

OnLogic

Name

CL210G-10

KARBON 300 Desktop PC

IGEL OS Articles

Minimum
Memory
(RAM) Size
4GB

8 GB

4GB

8 GB

8 GB

4GB

4GB

4GB

4GB

Endpoint Type Minimum

Industrial PC/

Terminal

Memory
(RAM) Size

4GB

4GB

Storage Size Processor

16 GB

128 GB

16 GB

16 GB

16 GB

16 GB

16 GB

16 GB

16 GB

Intel® Celeron
J4105

Intel® Celeron
J4105

Intel® Celeron
J4105

Intel® Celeron
J4105

Intel® Celeron
J4105

Intel Celeron
N5105

Intel Celeron
N5105

Intel Pentium
Silver N6005

Intel Celeron
N5105

IGEL

Supported from
IGEL OS Version

11.03.100
11.03.100
11.05.100
11.05.100
11.05.100
11.08.330
11.08.330
11.08.360

11.09.110

Supported from IGEL OS Version

11.09.100

Storage Size Processor

32GB

32GB

Intel Celeron

N3350

Intel Atom x5-

E3930

Supported from
IGEL OS Version

11.04.100

11.04.100
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Onyx Healthcare

Name Endpoint Type Minimum
Memory
(RAM) Size

Venus 223 MedicalAllin 4GB

One

Pepperl+Fuchs

Name EndpointType Minimum
Memory
(RAM) Size

BTC12N Industrial Box 4GB

Thin Client
BTC14N Industrial Box 4GB
Thin Client
Rein Medical
Name Endpoint Type Minimum
Memory
(RAM) Size

Silenio C122 Allin One 8 GB

Silenio C124 Allin One 8 GB

Clinio S Medical Allin 8GB

522TCT One

Clinio S Medical Allin 8GB

524TCT One

Secunet

IGEL OS Articles

128 GB

32GB

32GB

128 GB

128 GB

16 GB

16 GB

Storage Size Processor

Intel Quad-Core

J1900

Storage Size Processor

Intel Apollo Lake
N4200

AMD Ryzen
Embedded
V1202B

Storage Size Processor

Intel® Core™i5 -
6th Generation

Intel® Core™i5 -
6th Generation

Intel® Pentium®
Silver J5005

Intel® Pentium®
Silver J5005

Supported from
IGEL OS Version

11.01.100

Supported from
IGEL OS Version

11.09.100

11.09.100

Supported from
IGEL OS Version

11.01.110

11.01.110

11.04.100

11.04.100
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IGEL

Name Endpoint Minimum Storage Size Processor Supported from
Type Memory IGEL OS Version
(RAM) Size
SINA Workstation Workstation 16 GB 256 GB Intel Core 11.01.100
S EliteDesk 800 G2 i7-6700

USB Memory Sticks That Can Be Used as Alternative UD Pocket Hardware

DIGITTRADE
Name Storage Supported from IGEL OS Version
Kobra Stick > 4GB 11.05.133

Officially Supported Virtual Environments
+ Tested with Ubuntu (64-bit) and default settings

& Notethat the use of a UD Pocket within a virtual machine is not supported by IGEL.

() Forsome features, more than 2 GB RAM is required. Example: if you use dual monitor environments, a
virtual machine must have at least 8 GB RAM.

Name Memory Storage Type Supported from IGEL OS
(RAM) Version

Oracle VM VirtualBox >2GB >4 GB Linux 11.04.100

VMware Workstation >2GB >4 GB Linux 11.04.100

* Delock Adapter DP 1.2 to DVI does not work.
** When using an additional 4k screen with this device, please edit the BIOS settings as follows:

1. Goto the Chipset screen.
2. SetIntegrated Graphics to “Force”.
3. Set UMA Frame Buffer Size to “256M” or higher

When you have confirmed that your devices can be upgraded to IGEL OS 11, make sure to consider Important!
Consider This Before Upgrading (see page 76).
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Important! Consider This Before Upgrading

To make sure that your upgrade can be successful, check the following warnings and notes; a warning symbol
indicates that irreversible damage can be done to your devices.

© Existing partitions: Any existing partition on the target drive of your device will be deleted. The installer
will repartition the target device. The overall size of the newly created partitions will be calculated based
on the available disk space. The minimum disk usage is 2 GB, the maximum is 16 GB.

© NoDowngrade

You cannot restore your IGEL OS 10 system once you have migrated to IGEL OS 11. The device storage is
overwritten completely with a new partitioning scheme.

© Features (e.g. Clients)

IGEL OS 11 does not have the complete feature set of IGEL OS 10. Make sure that the current version of
IGEL OS 11 meets your requirements. For details, refer to the appropriate release notes.

© Custom Partitions

The contents of custom partitions will be deleted by the upgrade. Make sure to back up the contents and
restore them after the upgrade has finished. Besides becoming dysfunctional after the upgrade,
applications and kernel drivers in a custom partition might corrupt the upgrade. For this reason, make
sure to first test the upgrade on a characteristic device. We recommend that you disable custom partitions
when upgrading; you can enable them once the upgrade has been successfully completed.

© Custom Commands

The persistence of custom commands cannot be guaranteed. Besides becoming dysfunctional after the
upgrade, custom commands might corrupt the upgrade. For this reason, make sure to first test the
upgrade on a characteristic device. In general, custom commands must be adapted for IGEL OS 11. We
recommend that you disable custom commands when upgrading; you can enable them once the upgrade
has been successfully completed.

© Power Supply

Ensure that the device is not running on battery power, i.e. it must be connected to a power supply during
the complete upgrade process.

() Network

All devices must be connected to a WLAN or LAN. LAN is the recommended option. The device will not be
upgraded if connected to OpenVPN, OpenConnect, genucard or mobile broadband.

When you have considered everything that is relevant, continue with Preparing the Upgrade (see page 77).

IGEL OS Articles 76 /823




Update and Upgrade

Preparing the Upgrade

This section describes the required preparations and tests before any productive devices can be updated. The
testing should be done with at least one device that is characteristic of your environment. This device should have
every custom partition and every custom command that may possibly exist in any of your devices.

To prepare the upgrade, perform the following steps:

1. Preparing the UMS (see page 78)

2. Adjusting the Setup (see page 79)

3. Deploying a License (see page 80)

4. Configuring the Update Source (see page 81)
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Preparing the UMS

To upgrade your devices to IGEL OS 11, you need the appropriate version of the UMS. Also, the devices must be
registered with the UMS to receive their licenses.

1. If you have not already done so, update your UMS to version 6.01.130 or higher. For instructions,
see Updating UMS.

2. Make sure that your devices are registered with the UMS. For more information, see the
chapter Registering IGEL OS Devices on the UMS Server in the UMS Manual.

When the UMS is ready, continue with Adjusting the Setup (see page 79).
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Adjusting the Setup

Depending on the features that are in use now or will be used in the future, a specific set of parameters must be set
in the device's Setup.

1. Inthe Setup, go to System > Firmware Update > OS 11 Upgrade.
2. Make your settings as appropriate:
+ Activate Upgrade to OS 11.

(0 When Upgrade to OS 11 is activated, the device checks for a Workspace Edition license and
stops checking for a legacy UDC3 or UD Pocket license. Therefore, in the UMS, it is displayed
as an unlicensed device until a Workspace Edition license has been deployed.

+ If you want the device to retry the upgrade immediately after a failed attempt,
activate Upgrade to OS 11 even if a previous upgrade attempt failed. The device will retry
the upgrade 5 times. When the 5th attempt has failed, a message will be shown in the
upgrade tool window.

+ If your device has a PowerTerm license, and you want to upgrade to IGEL OS 11 even though
it does not support PowerTerm, you must activate Upgrade to OS 11 even if PowerTerm is
enabled.

+ Under Require an Enterprise Management Pack license to upgrade to OS 11, select the
appropriate option:

+ Ifyou are using IGEL Cloud Gateway (ICG) or Shared Workplace (SWP) or a Custom
Partition and want to make sure that the upgrade is performed only if these features
can be used furthermore, select Smart. When this option is selected, and any of these
features is activated, the upgrade is performed only if the device could fetch a license
from an Enterprise Management Pack.

+ If you want to force the device to fetch a license from an Enterprise Management
Pack and make sure that the upgrade is performed only if the license could be
fetched, select Always.

+ If you want the device to upgrade to IGEL OS 11 without fetching an Enterprise
Management Pack, disregarding the features that might be activated, select Never.

+ Under Timeout waiting for OS 11 license to start automatic upgrade, set the time period
the device will wait for a license in a mass deployment scenario (see Zero-Touch
Deployment Using Universal Firmware Update (see page 63), Zero-Touch Deployment Using
Buddy Update (see page 101) and Mass Deployment Using a Scheduled Job (see page 204)). This
setting prevents the device from starting the upgrade at an inappropriate time as a result of
the license just being deployed. This way, the setting prevents unwanted interruptions at
work. For a mass deployment scenario, the default value 10 Minutes is recommended.

3. Click Apply.

When the Setup is adjusted, continue with Deploying a License (see page 80).
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Deploying a License

To upgrade from IGEL OS 10 to IGEL OS 11, you need an appropriate license. Depending on your requirements, one
or more of these licenses will be needed for each device:

+ One Workspace Edition license for basic functionality. For further information, see Workspace
Edition

+ IfIGEL Cloud Gateway (ICG), or Shared Workplace (SWP) will be used: One Enterprise Management
Pack license. For further information, see Enterprise Management Pack.

+ Custom Partition - if IGEL OS 11.03.100 or lower is the target version; in IGEL OS 11.03.500 or
higher, the Custom Partition feature is included in the Workspace Edition.

> Deploy the licenses for IGEL OS 11 using the method that suits your needs:

+ Manual License Deployment: Licenses are created and deployed manually. For instructions,
see Manual License Deployment for IGEL OS.
« Automatic License Deployment (ALD): Licenses are created and deployed automatically to each
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).
+ Download three demo licenses from https://www.igel.com/download/.

When the device has a license, continue with Configuring the Update Source (see page 81).
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Configuring the Update Source

1. Inthe Setup, go to System > Update > Firmware Update and configure the update source for
IGEL OS 11. For more information, see the Firmware Update chapter in the IGEL OS Manual.
2. Click Ok.

When the correct update source is configured, continue with Testing the Upgrade (see page 82).
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Testing the Upgrade

1. Click E] System and then Upgrade to OS 11. The OS 11 Upgrade Tool starts and indicates
whether all requirements are met.

() You can change the starting the starting methods for the OS 11 Upgrade Tool in the Setup under
Accessories > 0S11 Upgrade.

0S 11 Upgrade x

Q Hardware
0 License
Q Setup

Q Update Source

o Network

IGELOST10->11

Close 05 Upgrade

2. Check the output of the OS 11 Upgrade Tool and continue appropriately:
« If each requirement has an o icon, click OS Upgrade to start the upgrade process.

+ If one or more requirements have an ® icon, check the messages and resolve the
issues. Afterwards, click Check again. If all requirements are met, the button changes to 0S
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Upgrade, and you can start the upgrade.
0S 11 Upgrade x

Q Hardware
o License
® Setup
® Powerterm

® Update Source

IGELOS10->11 |

Setup: PowerTerm will not be available in 05 11. To proceed, activate 'Upgrade to 05 11 even if PowerTerm is
enabled' at IGEL Setup = System > Update > 05 11 Upgrade.

Update Source: Please configure a valid OS 11 update source at 'System > Update = Firmware Update’ and
check your network connection.

Network: Please disable all VPN/Mobile Broadband network connectivity on the device. Otherwise it cannot be
guaranteed that your update source will be reachable after the upgrade.

Close Check again

When you start the upgrade, a warning dialog is shown.
3. Click OK to continue.

Confirm Upgrade to 0S 11

With this upgrade, IGEL 0S 11 will be installed on the device.
It is not possible to downgrade to IGEL OS 10 afterwards.

| ¥ Cancel

A warning dialog with a timeout is shown. If you click Cancel before the timeout expires, the
upgrade is canceled. If you click OK or just wait for the timeout to expire, the upgrade is started
Upgrade - A

Please note: With this upgrade, IGEL 0S 11 will be installed on
the device. It is not possible to downgrade to IGEL OS 10
afterwards.

This upgrade involves a critical phase in which the device
must not be powered off. The critical phase will be indicated
by a flashing warning. You will be notified after the upgrade
has finished successfully.

54 seconds remain

¥ Cancel

After the warning dialog has been confirmed or the timeout has expired, the device reboots into a
special IGEL OS 10 environment, in which the system upgrade is executed. The Upgrade window
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show the progress.
Upgrade

IGELOS

During the critical phase, the device must not be powered off. At this stage in the progress, an
additional warning is shown.

Upgrading base system.
DO NOT POWER OFF YOUR DEVICE!

When the base system is upgraded successfully, a message is shown.

0 Upgraded base system successfully.

The remaining components of the firmware are installed, which is indicated by update messages.

Firmware update

System

34%

When the installation is completed, the Upgrade window looks like this:
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Upgrade

IGELOS10->11

After a few seconds the device reboots into IGEL OS 11.

]

Local Terminal

\\m///ﬁ;
Z-1GEL

Congratulations
l The upgrade to IGEL OS 11 is now
complete

P X W |t 1020

When the upgrade test has been successful, you are ready to set up the mass upgrade. Continue with Checking the
Requirements (see page 86).

IGEL OS Articles 85/823



Update and Upgrade

Checking the Requirements
The following requirements must be met:

+ The upgrade has been tested with characteristic devices.

+ UMS6.01.130 or higher is available.

+ The firmware IGEL OS 10.05.800 (or higher) is known to the UMS. For this purpose, a device
with this firmware version must be registered in the UMS. This is already the case if you tested the
upgrade with the same UMS with which you are about to do the mass upgrade. If not, you must
register a device with the appropriate firmware version now.

+ All devices are connected to a regular LAN (not OpenVPN, OpenConnect, genucard, NCP VPN or
mobile broadband).

+ All devices are in a safe environment where the upgrade process cannot be disrupted, e.g. by
powering off the devices.

When all requirements are met, continue with Creating the Universal Firmware Updates (see page 87).
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Creating the Universal Firmware Updates

For detailed information, see the chapter Universal Firmware Update in the UMS Manual.

() Ifyou use the High Availability Extension, note that Universal Firmware Updates are NOT synchronized,
that is why you have to either download them to all HA nodes or configure an external (FTP) server.

1. Create a Universal Firmware Update for IGEL OS 10.05.800 (or higher).

2. After you have created the Universal Firmware Update for IGEL OS 10.05.800 (or higher), create a
Universal Firmware Update for IGEL OS 11.

© Theorder of creation is crucial because the IGEL OS 11 firmware must have a higher ID in order to
be chosen by the device. For details, see Executing the Upgrade (see page 99).

Configuring the Universal Firmware Update for ICG

If you are using IGEL Cloud Gateway (ICG), an FTP server that is accessible to all devices must be configured as an
update source.

To configure an FTP server as update source:

1. Inthe UMS, go to UMS Administration > Universal Firmware Update and click .
2. Enter the data required for accessing the FTP server and click Save.

Edit FTP Server Configuration

Universal update settings
The IGEL U zal Firr are downloaded from; ‘fia

Pram

The FTP server settings where the files are downloaded to {optionally).

Host fipSerername

Port

Directory

Cancel
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3. Goto Server - [UMS address] > Universal Firmware Update and in the context menu, select
Check for new firmware updates.

Shared Workplace Users

4. Select the entry for the IGEL OS 10.05.800 (or higher) firmware, click to select the FTP server
selected in step 2 and then select Download.

Universal Firmware Updates

Firmware Updates

IGELUD LX
IGELOS 11

Show only latest firmwe des already downlo
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5. The firmware is transferred to the FTP server.

IUniversal Firmware Update/IGEL Universal Desktop LX-1

Product  IGEL Uniy 1D op LX
Version 100 0
Release Notes  HTML Text
Firmware Update Settings
User fiplser
s
Host /ername
Part
Protocol
Target URL  ftpServerpath/IGEL_Unive
Snapshot file
Download Status
~

(]
Status -: .'

Error

Started Download the firmware update...

6. Under Server - [UMS address] > Universal Firmware Update, in the context menu, select Check

for new firmware updates again.

IGEL OS Articles
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7. Select the entry for the IGEL OS 11 firmware, click to select the FTP server selected in step 2

and select Download.

Universal Firmware Updates

Universal Firmware Updates
Include Model
IGEL UD LX
IGELOS 11

Show only latest firmware versions (hides already downloaded versions)

8. The firmware is transferred to the FTP server.

Product IGEL

Version  11.01.100

Firmware Update Settings

User fipUser
jord

Host
Port

Protocol

Target URL  MpServerpath/IGE 1-11.01.100

Download Status
]
=< Started L Download the firmware update...

%

Error

The devices can download the firmware from the FTP server,

When the Universal Firmware Update is ready, continue with Creating a Profile (see page 91).
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Creating a Profile

1. Create a profile that is based on the IGEL OS 10 firmware (10.08.800 or higher). Find a suitable
name for the profile, e.g. "Firmware upgrade to IGEL 0S 11",

MNew Profile

Profile Mame
Diescriptian

Inhetits Settings fram

¥ @ Upgrade to 13
[ I |
L mcooEncst

Ga
Ll oo

Based on IGEL Universal Deskiop X 10.05.800

no Settings

Cancel

2. Inthe profile's configuration dialog, go to System > Update > Firmware Update and change the
settings according to your environment:
+ Ifthe UMS and the devices are in one and the same network and no IGEL Cloud Gateway
(ICG) is used:

+ Select "HTTPS" as Protocol.

« Activate Automatic Update Check on Boot.

« Ensure that Automatic Update Check on Shutdown is deactivated. Otherwise, the

device will shut down when the update is finished.
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Allow firmware upgrade te IGEL 0S5 11

» Update » Fi

Related Configurations

Search

« IfIGEL Cloud Gateway (ICG) is used:
+ Select "FTP" as Protocol.
+ Activate Automatic Update Check on Boot.
» Ensure that Automatic Update Check on Shutdown is deactivated. Otherwise, the
device will shut down when the update is finished.
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Allow firmware upgrade te IGEL 0S5 11
< > A

? al Related Configurations
uration

Search

3. Go to System > Update > 0OS 11 Upgrade and change the following settings according to your
successful upgrade test (for details of the settings, see Adjusting the Setup (see page 79)):
« Activate Upgrade to OS 11.
Set Upgrade to OS 11 even if PowerTerm is enabled according to your needs.
Set Upgrade to OS 11 even if a previous upgrade attempt failed according to your needs.
+ Set Require an Enterprise Management Pack license to upgrade to OS 11 according to
your needs.

Ensure that the Timeout waiting for OS 11 license to start automatic upgrade is set to 10
Minutes.
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Allow firmware upgrade te IGEL 0S5 11

> Upda

Require an Ente

Time

Search

4. Go to System > Remote Management and change the settings as follows:
« Deactivate Display 'Apply changes' dialog on boot.
+ Set Default action on boot to Apply changed configuration immediately.
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Allow firmware upgrade te IGEL 0S5 11
14 > A ! * Rel

Configuration

a0
Timeout

Defal

A

Timeout

Search

5. Click Save.

When the profile is created, continue with Deploying the Licenses (see page 96).
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Deploying the Licenses
Deploy the licenses for IGEL OS 11 using the method that suits your needs:

+ Automatic License Deployment (ALD): Licenses are created and deployed automatically to each
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).

+ Manual License Deployment: Licenses are created and deployed manually. For instructions,
see Manual License Deployment for IGEL OS.

When the license deployment is set up, continue with Putting It All Together (see page 97).
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Putting It All Together

1. Putall devices that are to be updated into a directory.

¥ |L—| Devices (4)
¥ B Remote Devices (1)
L ITCO0EDCST1 4345

g D3
¥ i Upgrade to IGEL OS5 11 (1)

1 ITCoonBCANSS01 8

WL (00

- ,' ITCOOEQCSTCA087
2. Select the directory and in the Assigned objects area, click @

Server-172.30.92.9

e 6

£l iTcoo.
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3. Assign the profile (see Creating a Profile (see page 91)) and the two Universal Firmware Updates
(see Creating the Universal Firmware Updates (see page 87)) to the directory and click Ok.

Select assignable obhjects

Cancel

Mame

L1 meoon.

5. If you are using Automatic License Deployment (ALD), it might be feasible to confine the
distribution of licenses to the current directory. For more information, see Configuring the
Distribution Conditions, section "Distributing Licenses to Devices in a Specified Directory".

When everything is in place, continue with Executing the Upgrade (see page 99).
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Executing the Upgrade

1. Inthe UMS,; select the directory containing all devices that are to be upgraded and reboot them.

@ Alternatively, you can create a scheduled job for reboot or wake up and assign it to the
devices or the directory containing these devices. For more information, see Jobs

On reboot or wake up, the devices update to the appropriate IGEL OS 10 firmware (10.05.800 or
higher). With this version, the Upgrade to OS 11 parameter is recognized by the devices; also, the
devices request IGEL OS 11 licenses from the UMS (Workspace Edition and, if required, Enterprise
Management Pack).
If no IGEL OS 11 licenses have been deployed on the devices yet, the licenses are deployed within a
few minutes. The upgrade will be started when the licenses are deployed. The maximum time
period the device will wait for a license is configured by the parameter Timeout waiting for 0S 11
license to start automatic upgrade; for details, see Adjusting the setup (see page 79).
The parameter Automatic update check on boot causes the devices look for new firmware
again. Although two Universal Firmware Updates are assigned to the devices, the UMS offers the
IGEL OS 11 firmware, because the ID of the IGEL OS 11 firmware is higher than the ID of the IGEL OS
10 firmware.

2. When all devices have been upgraded successfully, remove the "Firmware upgrade to IGEL OS 11"
profile and the two Universal Firmware Updates from the directory.
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igned objects

Mame

The upgrade is completed.
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Zero-Touch Deployment Using Buddy Update

This method uses the buddy update feature of IGEL OS. One or more devices that are configured as an update
buddy access the main server and download the firmware. The other devices are configured to download their
firmware from an update buddy.

Read all the following chapters carefully and follow the instructions.

=

Devices That Can Be Upgraded to IGEL OS 11 (see page 102)
Important! Consider This Before Upgrading (see page 114)
Preparing the Upgrade (see page 115)

Testing the Upgrade (see page 120)

Checking the Requirements (see page 124)

Configuring Two Update Buddies (see page 125)

Creating a Profile (see page 126)

Deploying the Licenses (see page 128)

Putting It All Together (see page 129)

Executing the Upgrade (see page 130)

RNk WN

=
e

IGEL OS Articles 101/823



Update and Upgrade

Devices That Can Be Upgraded to IGEL OS 11

Core Requirements

« CPU with 64-bit support
« CPUspeed:=1GHz
+ Memory (RAM): =2 GB

() RAMsize higher than 2 GB is recommended if you use any of the following:
+ Unified Communications optimizations (uses a client-side media engine)
+ High-resolution graphics output
+ More than two monitors

@ With devices that have 2 GB RAM and shared video memory, a maximum of 512 MB may be
used as video memory.

+ Storage: Depends on the release version of IGEL OS 11. The details are listed below: 2 GB
minimum; =4 GB recommended

« UptoIGEL 0S 11.03:2 GB minimum; =4 GB recommended

« From IGEL OS 11.04 to IGEL OS 11.07: If the full feature set is applied, at least 2.4 GB of
storage is required. For instructions on how to reduce the feature set, see Error: "Not
enough space on local drive" when Updating to IGEL OS 11.08 or Higher.

« From IGEL OS 11.08 onwards: If the full feature set is applied, at least 2.4 GB of storage is
required. For instructions on how to reduce the feature set, see Error: "Not enough space on
local drive" when Updating to IGEL OS 11.08 or Higher. TODO Add URL when published

+ NoVIA graphic adapter; VIA graphics support is discontinued in IGEL OS.
+ Legacy Bios and EFI/UEFI are supported.

Devices Supported by OSC and UD Pocket with IGEL OS 11

& Thefollowing list only includes those devices that are tested by IGEL (with each major release of IGEL OS).
By no means it implies that the devices which are not included in this list but meet the minimum
requirements will not function with IGEL OS: Any x86-64 hardware endpoint device that meets the IGEL-
stated minimum hardware requirements for IGEL OS (for example, the processor speed and RAM) can be
expected to work adequately with IGEL OS and should be considered a candidate for repurposing from
another OS. With an IGEL OS subscription or active maintenance, customers can expect IGEL to make any
necessary “best effort” to support, regardless of whether the endpoints in question are specifically listed
within the IGEL Knowledge Base or elsewhere (e.g. on the IGEL Ready Showcase at https://www.igel.com/
ready/showcase-categories/endpoints/).

For any devices not listed here or on the IGEL Ready showcase, you can contact your hardware vendor and
request those devices to be added to the IGEL Ready program.

Integrated drivers and supported peripherals are listed in the Third-Party Hardware Database?!. For more
solutions compatible with IGEL OS, see Partner Solutions.

21 https://www.igel.com/linux-3rd-party-hardware-database/
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(@ HP,Lenovo, and LG device models are available from the factory with pre-installed IGEL OS 11. Please
contact IGEL Ready? to get information on which device models are available with pre-installed IGEL OS.

() Forsome of the devices listed here, Flash memory must be extended to = 2 GB. For these devices, an
appropriate note is added.

() Onmodern computers such as secured-core PCs (see e.g. https://www.microsoft.com/en-us/windows/
business/devices?col=secured-core-pcs), there may be a BIOS setting related to Secure Boot that allows
the use of Microsoft’s 3rd party UEFI Secure Boot Certificate. The usual description of such a BIOS setting is
"Allow Microsoft 3rd Party UEFI CA". This setting must be set to enabled, as IGEL uses the 3rd party
certificate to support UEFI Secure Boot. If UEFI Secure Boot is enabled, but "Allow Microsoft 3rd Party UEFI
CA" is not enabled, you may be unable to boot IGEL OS Creator or UD Pocket. Similarly, if the setting
"Allow Microsoft 3rd Party UEFI CA" is disabled after a previous installation of IGEL OS, IGEL OS will fail to
boot. For how to enable the setting, see Secured-Core PCs: Microsoft 3rd-Party UEFI Certificate for Secure
Boot.

(@ [Fn] keys may not work on some supported and listed laptop/notebook models.

ADS-Tec

Name Endpoint Type Minimum Storage Size Processor Supported from
Memory IGEL OS Version
(RAM) Size

DVG- Industrial PC/ 4GB 64 GB eMMC Intel Atom®x7- 11.02.100

VMT9010 Terminal 8GB E3950

DVG- Industrial PC/ 4GB 64 GB eMMC Intel Atom®x7- 11.02.100

VMT9012 Terminal 8GB E3950

DVG- Industrial PC/ 4GB 64 GB eMMC Intel Atom®x7- 11.02.100

VMT9015 Terminal 8GB E3950

DVG- Industrial PC/ 4GB 64 GB eMMC Intel Atom®x7- 11.02.100

VMT9112 Terminal 3GB E3950

Advantech

22 https://www.igel.com/technology-partners/
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Name Endpoint Type Minimum Storage Size Processor
Memory
(RAM) Size
POC-W213L Medical Allin 4GB 128 GB Intel Core
One i7T-7300U
POC- Medical Allin 4GB 32GB Intel Kaby Lake
W243L" (see One Core i5-7300U
page 113)
POC- Medical Allin 4GB 128 GB Intel Core
W243L" (see One i7-7300U
page 113)
Advantech-DLoG
Name Endpoint Type Minimum Storage Size Processor
Memory
(RAM) Size
DLT-V6210 IndustrialPC/ 4GB 32GB Intel Atom
Terminal
DLT-V7210 K Industrial PC/ 4GB 4GB Intel Atom
Terminal E3845
Dell / Wyse
Name Endpoint Minimum Storage Processor Supported
Type Memory Size from IGEL OS
(RAM) Size Version
5040 /5212 AllinOne 2GB 2 GB AMD G-T48E 11.01.100
3040 Thin Client 2 GB 8 GB Intel Atom  11.01.100
x5-78350
5020 Thin Client 2 GB 8 GB AMD G-Series 11.02.140
SoC
5060 Thin Client 4 GB 8 GB AMD 11.01.100
GX-424CC
5070 Thin Client 8 GB 32GB Intel Celeron 11.01.100

IGEL OS Articles

J4105

IGEL

Supported from
IGEL OS Version

11.01.100

11.01.110

11.01.100

Supported from
IGEL OS Version

11.01.100

11.01.100

Note
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Name Endpoint Minimum Storage
Type Memory  Size
(RAM) Size
Latitude Laptop/ 256 GB
5510 Notebook
Optiplex  ThinClient 4 GB 32GB
3000
Dynabook
Name Endpoint Minimum
Type Memory
(RAM) Size
Portegé X20W- Laptop/ 8 GB
D Notebook
Portegé X30-D Laptop/ 8 GB
Notebook
Tecra C50 Laptop/ 4GB
Notebook
Tecra Z50-D  Laptop/ 8 GB
Notebook
SATELLITE R50 Laptop/ 4GB
Notebook
Elo
Name Endpoint Minimum
Type Memory
(RAM) Size
i2 Touch Allin One 8 GB
(15and 22
inches)

Fujitsu

IGEL OS Articles

Processor

Intel Core
i5-10210U

Supported
from IGEL OS

Version

11.05.100

Intel Celeron 11.08.200

N5105

Storage Size Processor

256 GB

256 GB

500 GB

256 GB

500 GB

Intel Core
i5-7200U

Intel Core
i5-7300U

Intel i5-4210U

Intel Core
i5-7200U

Intel i3-6006U

Storage Size Processor

128 GB

Intel Core
i3-8100T

Note

Wake-on-LAN
functionality is
not supported.

Supported from
IGEL OS Version

11.01.100

11.01.100

11.01.100

11.01.100

11.01.100

Supported from
IGEL OS Version

11.05.100
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Name

Q957

FUTRO S740 Thin Client

HP

Name

HP t420

HP t430

HP t530

HP t630
HP t730

HP t820

HP t640

HP t540

IGEL OS Articles

Endpoint
Type

Desktop PC

Endpoint
Type

Thin Client

Thin Client

Thin Client

Thin Client
Thin Client

Thin Client

Thin Client

Thin Client

Minimum

Memory

(RAM) Size

8 GB

4GB

Minimum Storage

Memory
(RAM) Size

2GB

2GB

4GB

4GB
16 GB

16 GB

4GB

16 GB

Size

8 GB

16 GB

8 GB

8 GB
8 GB

16 GB

16 GB

16 GB

Storage Size Processor

500 GB

8 GB

IGEL

Supported from
IGEL OS Version

Intel Core 11.02.100

i3-6100

Intel Celeron 11.04.100

J4105

Processor Supported Note
from IGEL OS

Version

AMD 11.02.100
Embedded G-
Series

GX-209JA

Intel®Celeron®11.01.110
N4020

AMD GX-215JJ 11.01.100
Dual-Core

AMD GX-420GI! 11.01.100

AMD 11.01.100
RX-427BB APU

Intel Core 11.01.100

i5-4570S

AMD Ryzen
R1505G

AMD Ryzen
Embedded
R1305G

11.04.100

11.06.100
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Name

HP mt46

HP Elite
t655

HP Elite
mt645 G7

HP t740

HP Pro t550 Thin Client 4 GB

HP Pro
mt440 G3

Endpoint Minimum Storage

Type Memory Size
(RAM) Size

Mobile Thin 8 GB 32GB

Client

Thin Client 4GB/8GB 32GB

Mobile Thin 8 GB 256 GB

Client

Thin Client 8 GB 16 GB
32GB

Mobile Thin 8 GB 128 GB

Client

HP Docking Stations

IGEL OS Articles

Processor Supported
from IGEL OS
Version

AMD Ryzen3 11.07.100

PRO 4450U

AMD Ryzen  11.07.160

Embedded

R2314

AMD Ryzen 3 11.08.230

5425U

AMD Ryzen5 11.08.330

5625U

AMD Ryzen 11.08.290

Embedded

V1756B

Intel Celeron 11.08.330
J6412

Intel Celeron 11.08.440
7305

Note

Excluding
support for
WWAN

and Wake-on-
LAN (both
features are
planned)

Support for
WWAN Intel XMM
7560 R+ (as of
11.08.330)

Excluding
support for
Wake-on-LAN
(featureis
planned)

Excluding
support for built-
in fingerprint
sensor

Excluding
support for
WWAN Intel XMM
7560 R+ (feature
is planned)
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Name Supported from IGEL OS Version
HP USB-C Docking Station G5 11.08.230
HP USB-C G5 Essential Dock 11.08.290
Intel
Name Endpoint Minimum Storage Size Processor Supported from
Type Memory IGEL OS Version
(RAM) Size
NUC 5i5MYHE Desktop PC 2 GB 32GB Intel i5-5300U 11.01.100
NUC5i3RYH DesktopPC 2GB 2 GB Intel i3-5010U 11.01.100
NUC7CJYH DesktopPC 2GB 4GB Intel Celeron 11.01.100
J4005
Lenovo
Name Endpoint Minimum Storage Processor Wi-Fi Chip Supported Note
Type Memory Size from IGEL

(RAM) OS Version

Size
ThinkCentreDesktop 4 GB 32GB  AMD Intel AC9260 11.04.100
M625q PC E2-9000e

8 GB 128GB  AMD QCA6174 11.04.100

A4-9120e 802.11ac
ThinkCentreDesktop 8 GB 256 GB  AMD Ryzen Intel AC9260 11.05.100

M75n PC 3

Pro 3300U
ThinkCentreDesktop 16 GB 256 GB  Intel Comet Lake 11.05.100
M70q Genl PC i5-10500t PCH CNVi

WiFi, Intel

ThinkCentreDesktop 16 GB 256 GB IntelCore Intel AX201 11.08.240
M70q Gen 3 PC i5-12500T
ThinkCentreDesktop 4 GB 128 GB  AMD Ryzen Intel AX200 11.08.240
M75q Gen 2 PC 3 Pro

5350GE
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Endpoint Minimum Storage
Memory Size

Name

Type

(RAM)
Size

K14 AMD  Laptop/ 8GB
Genl Notebook
ThinkPad Laptop/ 64GB
L14 AMD Notebook
Gen1l
14w Laptop/ 4GB

Notebook
ThinkPad Laptop/ 16GB
L14 AMD Notebook
Gen3
ThinkCentreThin 8 GB
Neo50q Client
Gen 4 4GB
K14 Intel Laptop/ 16GB
Genl Notebook
ThinkPad Laptop/ 16GB
L14 Intel Notebook
Gen3
ThinkEdge Thin 8GB
SE10 Client
ThinkPad Thin 8 GB
L14 AMD Client
Gen4
ThinkPad Thin 8 GB
L15 AMD Client
Gen4

IGEL OS Articles

256 GB

1TB

64 GB

256 GB

256 GB

256 GB

256 GB

512 GB

1TB

256 GB

256 GB

256 GB

Processor

AMD Ryzen
5PRO
5650U

AMD Ryzen
7 Pro
4750U

AMD
A6-9220C

AMD Ryzen
55625U

Intel Core
i3-1215U

Intel
Celeron
7305

Intel Core
i5-1135G7

Intel Core
i5-1235U

Intel Atom
X6425RE

Intel Atom
X6214RE

AMD Ryzen
3 Pro
7330U

AMD Ryzen
3 Pro
7330U

Wi-Fi Chip

Mediatek
MT7921

11.08.240

Wi-Fi 6
AX200, Intel

11.05.100

QCA6174
802.11ac

AMD RZ616
2X2AX (WiFi
6E)

Wi-Fi 6
RTL8852BE
Wi-Fi 6 AX201

11.05.100

11.08.230

11.08.240

Intel AX210
WiFi /BT
combo

Intel Wi-Fi6 11.08.330
AX201 2x2 AX
vPro

MediaTek
MT7921LEN

Intel AX210

11.08.290

11.08.360

11.08.360

AMD RZ616 11.08.440

Realtek

RTL8852CE
AMD RZ616 11.08.440

Realtek
RTL8852CE

IGE

|

A

|

Supported Note
from IGEL
OS Version

Excluding
support for
WWAN

LTE support
as of
11.08.360

Quectel
EMO05-G 4G
CAT4

Quectel
EMO05-G 4G
CAT4
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Name Endpoint Minimum Storage
Type Memory Size
(RAM)
Size

ThinkPad Laptop/ 8GB 256 GB

L14 Intel Notebook
Gen4

ThinkPad Laptop/ 8GB 256 GB

L15 Intel Notebook
Gen4

Lenovo Docking Stations

Name

ThinkPad USB-C Hybrid Dock

IOBOX

Lenovo Universal USB-C Dock

LG

Name Endpoint
Type

24CK550N* Allin One
* (see page
113)

24CK550W* Allin One
* (see page
113)

24CK560N™* Allin One
* (see page
113)

CK500W  Thin Client

38CK950N Allin One
38CK900N Allin One

IGEL OS Articles

Minimum
Memory
(RAM) Size

4GB

4GB

4GB

4GB

8GB
8GB

Processor Wi-Fi Chip

Intel Core
i3-1315U

Intel Core
i3-1315U

|

IGE

A

r

Supported Note

from IGEL
0OS Version

Intel AX211  11.09.100  Quectel

EMO05-G 4G
CAT4

Intel AX211 11.09.100  Quectel

EMO05-G 4G
CAT4

Supported from IGEL OS Version
11.07.100
11.07.100
11.08.440

Storage Size Processor

32GB

32GB

32GB

32GB

128 GB
128 GB

AMD G-Series
GX-212JJ

AMD G-Series
GX-212JJ

AMD G-Series
GX-212JJ

AMD G-Series
GX-212JJ

AMD Ryzen 3
AMD Ryzen 3

Supported from

IGEL OS Version

11.01.100

11.01.100

11.01.100

11.01.100

11.02.100
11.02.100
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Name

CL600ON

CL600W

34CN650N

24CN650N

27CN650N

CQeo00l

24CQ650I

CQ6011

24CR670I

Endpoint
Type

Thin Client

Thin Client

Allin One

Allin One

Allin One

Thin Client

Allin One

Thin Client

Allin One

LG Docking Stations

Name

LG USB Multi Port Hub

OnLogic

Name

CL210G-10

KARBON 300 Desktop PC

IGEL OS Articles

Minimum
Memory
(RAM) Size
4GB

8 GB

4GB

8 GB

8 GB

4GB

4GB

4GB

4GB

Endpoint Type Minimum

Industrial PC/

Terminal

Memory
(RAM) Size

4GB

4GB

Storage Size Processor

16 GB

128 GB

16 GB

16 GB

16 GB

16 GB

16 GB

16 GB

16 GB

Intel® Celeron
J4105

Intel® Celeron
J4105

Intel® Celeron
J4105

Intel® Celeron
J4105

Intel® Celeron
J4105

Intel Celeron
N5105

Intel Celeron
N5105

Intel Pentium
Silver N6005

Intel Celeron
N5105

IGEL

Supported from
IGEL OS Version

11.03.100
11.03.100
11.05.100
11.05.100
11.05.100
11.08.330
11.08.330
11.08.360

11.09.110

Supported from IGEL OS Version

11.09.100

Storage Size Processor

32GB

32GB

Intel Celeron

N3350

Intel Atom x5-

E3930

Supported from
IGEL OS Version

11.04.100

11.04.100
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Onyx Healthcare

Name Endpoint Type Minimum
Memory
(RAM) Size

Venus 223 MedicalAllin 4GB

One

Pepperl+Fuchs

Name EndpointType Minimum
Memory
(RAM) Size

BTC12N Industrial Box 4GB

Thin Client
BTC14N Industrial Box 4GB
Thin Client
Rein Medical
Name Endpoint Type Minimum
Memory
(RAM) Size

Silenio C122 Allin One 8 GB

Silenio C124 Allin One 8 GB

Clinio S Medical Allin 8GB

522TCT One

Clinio S Medical Allin 8GB

524TCT One

Secunet

IGEL OS Articles

128 GB

32GB

32GB

128 GB

128 GB

16 GB

16 GB

Storage Size Processor

Intel Quad-Core

J1900

Storage Size Processor

Intel Apollo Lake
N4200

AMD Ryzen
Embedded
V1202B

Storage Size Processor

Intel® Core™i5 -
6th Generation

Intel® Core™i5 -
6th Generation

Intel® Pentium®
Silver J5005

Intel® Pentium®
Silver J5005

Supported from
IGEL OS Version

11.01.100

Supported from
IGEL OS Version

11.09.100

11.09.100

Supported from
IGEL OS Version

11.01.110

11.01.110

11.04.100

11.04.100
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IGEL

Name Endpoint Minimum Storage Size Processor Supported from
Type Memory IGEL OS Version
(RAM) Size
SINA Workstation Workstation 16 GB 256 GB Intel Core 11.01.100
S EliteDesk 800 G2 i7-6700

USB Memory Sticks That Can Be Used as Alternative UD Pocket Hardware

DIGITTRADE
Name Storage Supported from IGEL OS Version
Kobra Stick > 4GB 11.05.133

Officially Supported Virtual Environments
+ Tested with Ubuntu (64-bit) and default settings

& Notethat the use of a UD Pocket within a virtual machine is not supported by IGEL.

() Forsome features, more than 2 GB RAM is required. Example: if you use dual monitor environments, a
virtual machine must have at least 8 GB RAM.

Name Memory Storage Type Supported from IGEL OS
(RAM) Version

Oracle VM VirtualBox >2GB >4 GB Linux 11.04.100

VMware Workstation >2GB >4 GB Linux 11.04.100

* Delock Adapter DP 1.2 to DVI does not work.
** When using an additional 4k screen with this device, please edit the BIOS settings as follows:

1. Goto the Chipset screen.
2. SetIntegrated Graphics to “Force”.
3. Set UMA Frame Buffer Size to “256M” or higher

When you have confirmed that your devices can be upgraded to IGEL OS 11, make sure to consider Important!
Consider This Before Upgrading (see page 114).
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Important! Consider This Before Upgrading

To make sure that your upgrade can be successful, check the following warnings and notes; a warning symbol
indicates that irreversible damage can be done to your devices.

© Existing partitions: Any existing partition on the target drive of your device will be deleted. The installer
will repartition the target device. The overall size of the newly created partitions will be calculated based
on the available disk space. The minimum disk usage is 2 GB, the maximum is 16 GB.

© NoDowngrade

You cannot restore your IGEL OS 10 system once you have migrated to IGEL OS 11. The device storage is
overwritten completely with a new partitioning scheme.

© Features (e.g. Clients)

IGEL OS 11 does not have the complete feature set of IGEL OS 10. Make sure that the current version of
IGEL OS 11 meets your requirements. For details, refer to the appropriate release notes.

© Custom Partitions

The contents of custom partitions will be deleted by the upgrade. Make sure to back up the contents and
restore them after the upgrade has finished. Besides becoming dysfunctional after the upgrade,
applications and kernel drivers in a custom partition might corrupt the upgrade. For this reason, make
sure to first test the upgrade on a characteristic device. We recommend that you disable custom partitions
when upgrading; you can enable them once the upgrade has been successfully completed.

© Custom Commands

The persistence of custom commands cannot be guaranteed. Besides becoming dysfunctional after the
upgrade, custom commands might corrupt the upgrade. For this reason, make sure to first test the
upgrade on a characteristic device. In general, custom commands must be adapted for IGEL OS 11. We
recommend that you disable custom commands when upgrading; you can enable them once the upgrade
has been successfully completed.

© Power Supply

Ensure that the device is not running on battery power, i.e. it must be connected to a power supply during
the complete upgrade process.

() Network

All devices must be connected to a WLAN or LAN. LAN is the recommended option. The device will not be
upgraded if connected to OpenVPN, OpenConnect, genucard or mobile broadband.

When you have considered everything that is relevant, continue with Preparing the Upgrade (see page 115).
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Preparing the Upgrade

This section describes the required preparations and tests before any productive devices can be updated. The
testing should be done with at least one device that is characteristic of your environment. This device should have
every custom partition and every custom command that may possibly exist in any of your devices.

To prepare the upgrade, perform the following steps:

1. Preparing the UMS (see page 116)

2. Adjusting the Setup (see page 117)

3. Deploying a License (see page 118)

4. Configuring the Update Source (see page 119)
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Preparing the UMS

To upgrade your devices to IGEL OS 11, you need the appropriate version of the UMS. Also, the devices must be
registered with the UMS to receive their licenses.

1. If you have not already done so, update your UMS to version 6.01.130 or higher. For instructions,
see Updating UMS.

2. Make sure that your devices are registered with the UMS. For more information, see the
chapter Registering IGEL OS Devices on the UMS Server in the UMS Manual.

When the UMS is ready, continue with Adjusting the Setup (see page 117).
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Adjusting the Setup

Depending on the features that are in use now or will be used in the future, a specific set of parameters must be set
in the device's Setup.

1. Inthe Setup, go to System > Firmware Update > OS 11 Upgrade.
2. Make your settings as appropriate:
+ Activate Upgrade to OS 11.

(0 When Upgrade to OS 11 is activated, the device checks for a Workspace Edition license and
stops checking for a legacy UDC3 or UD Pocket license. Therefore, in the UMS, it is displayed
as an unlicensed device until a Workspace Edition license has been deployed.

+ If you want the device to retry the upgrade immediately after a failed attempt,
activate Upgrade to OS 11 even if a previous upgrade attempt failed. The device will retry
the upgrade 5 times. When the 5th attempt has failed, a message will be shown in the
upgrade tool window.

+ If your device has a PowerTerm license, and you want to upgrade to IGEL OS 11 even though
it does not support PowerTerm, you must activate Upgrade to OS 11 even if PowerTerm is
enabled.

+ Under Require an Enterprise Management Pack license to upgrade to OS 11, select the
appropriate option:

+ Ifyou are using IGEL Cloud Gateway (ICG) or Shared Workplace (SWP) or a Custom
Partition and want to make sure that the upgrade is performed only if these features
can be used furthermore, select Smart. When this option is selected, and any of these
features is activated, the upgrade is performed only if the device could fetch a license
from an Enterprise Management Pack.

+ If you want to force the device to fetch a license from an Enterprise Management
Pack and make sure that the upgrade is performed only if the license could be
fetched, select Always.

+ If you want the device to upgrade to IGEL OS 11 without fetching an Enterprise
Management Pack, disregarding the features that might be activated, select Never.

+ Under Timeout waiting for OS 11 license to start automatic upgrade, set the time period
the device will wait for a license in a mass deployment scenario (see Zero-Touch
Deployment Using Universal Firmware Update (see page 63), Zero-Touch Deployment Using
Buddy Update (see page 101) and Mass Deployment Using a Scheduled Job (see page 204)). This
setting prevents the device from starting the upgrade at an inappropriate time as a result of
the license just being deployed. This way, the setting prevents unwanted interruptions at
work. For a mass deployment scenario, the default value 10 Minutes is recommended.

3. Click Apply.

When the Setup is adjusted, continue with Deploying a License (see page 118).
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Deploying a License

To upgrade from IGEL OS 10 to IGEL OS 11, you need an appropriate license. Depending on your requirements, one
or more of these licenses will be needed for each device:

+ One Workspace Edition license for basic functionality. For further information, see Workspace
Edition

+ IfIGEL Cloud Gateway (ICG), or Shared Workplace (SWP) will be used: One Enterprise Management
Pack license. For further information, see Enterprise Management Pack.

+ Custom Partition - if IGEL OS 11.03.100 or lower is the target version; in IGEL OS 11.03.500 or
higher, the Custom Partition feature is included in the Workspace Edition.

> Deploy the licenses for IGEL OS 11 using the method that suits your needs:

+ Manual License Deployment: Licenses are created and deployed manually. For instructions,
see Manual License Deployment for IGEL OS.
« Automatic License Deployment (ALD): Licenses are created and deployed automatically to each
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).
+ Download three demo licenses from https://www.igel.com/download/.

When the device has a license, continue with Configuring the Update Source (see page 119).
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Configuring the Update Source

1. Inthe Setup, go to System > Update > Firmware Update and configure the update source for
IGEL OS 11. For more information, see the Firmware Update chapter in the IGEL OS Manual.
2. Click Ok.

When the correct update source is configured, continue with Testing the Upgrade (see page 120).
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e

IGE

Testing the Upgrade

1. Click E] System and then Upgrade to OS 11. The OS 11 Upgrade Tool starts and indicates
whether all requirements are met.

() You can change the starting the starting methods for the OS 11 Upgrade Tool in the Setup under
Accessories > 0S11 Upgrade.

0S 11 Upgrade x

Q Hardware
0 License
Q Setup

Q Update Source

o Network

IGELOST10->11

Close 05 Upgrade

2. Check the output of the OS 11 Upgrade Tool and continue appropriately:
« If each requirement has an o icon, click OS Upgrade to start the upgrade process.

+ If one or more requirements have an ® icon, check the messages and resolve the
issues. Afterwards, click Check again. If all requirements are met, the button changes to 0S
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Upgrade, and you can start the upgrade.
0S 11 Upgrade x

Q Hardware
o License
® Setup
® Powerterm

® Update Source

IGELOS10->11 |

Setup: PowerTerm will not be available in 05 11. To proceed, activate 'Upgrade to 05 11 even if PowerTerm is
enabled' at IGEL Setup = System > Update > 05 11 Upgrade.

Update Source: Please configure a valid OS 11 update source at 'System > Update = Firmware Update’ and
check your network connection.

Network: Please disable all VPN/Mobile Broadband network connectivity on the device. Otherwise it cannot be
guaranteed that your update source will be reachable after the upgrade.

Close Check again

When you start the upgrade, a warning dialog is shown.
3. Click OK to continue.

Confirm Upgrade to 0S 11

With this upgrade, IGEL 0S 11 will be installed on the device.
It is not possible to downgrade to IGEL OS 10 afterwards.

| ¥ Cancel

A warning dialog with a timeout is shown. If you click Cancel before the timeout expires, the
upgrade is canceled. If you click OK or just wait for the timeout to expire, the upgrade is started
Upgrade - A

Please note: With this upgrade, IGEL 0S 11 will be installed on
the device. It is not possible to downgrade to IGEL OS 10
afterwards.

This upgrade involves a critical phase in which the device
must not be powered off. The critical phase will be indicated
by a flashing warning. You will be notified after the upgrade
has finished successfully.

54 seconds remain

¥ Cancel

After the warning dialog has been confirmed or the timeout has expired, the device reboots into a
special IGEL OS 10 environment, in which the system upgrade is executed. The Upgrade window
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show the progress.
Upgrade

IGELOS

During the critical phase, the device must not be powered off. At this stage in the progress, an
additional warning is shown.

Upgrading base system.
DO NOT POWER OFF YOUR DEVICE!

When the base system is upgraded successfully, a message is shown.

0 Upgraded base system successfully.

The remaining components of the firmware are installed, which is indicated by update messages.

Firmware update

System

34%

When the installation is completed, the Upgrade window looks like this:
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Upgrade

IGELOS10->11

After a few seconds the device reboots into IGEL OS 11.

]

Local Terminal

\\m///ﬁ;
Z-1GEL

Congratulations
l The upgrade to IGEL OS 11 is now
complete

P X W |t 1020

When the upgrade test has been successful, you are ready to set up the mass upgrade. Continue with Checking the
Requirements (see page 124).
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Checking the Requirements
The following requirements must be met:

+ The upgrade has been tested with characteristic devices.

+ UMS6.01.130 or higher is available.

+ The firmware IGEL OS 10.05.800 (or higher) is known to the UMS. For this purpose, a device
with this firmware version must be registered in the UMS. This is already the case if you tested the
upgrade with the same UMS with which you are about to do the mass upgrade. If not, you must
register a device with the appropriate firmware version now.

+ All devices are connected to a regular LAN (not OpenVPN, OpenConnect, genucard, NCP VPN or
mobile broadband).

+ All devices are in a safe environment where the upgrade process cannot be disrupted, e.g. by
powering off the devices.

When all requirements are met, continue with Configuring Two Update Buddies (see page 125).
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Configuring Two Update Buddies
For setting up buddy updates, see the how-to Buddy Update (see page 221).

© Ensure that the network contains only the update buddies and the devices that are to be updated. This
prevents other devices from updating inadvertently.

1. Update one device to the appropriate IGEL OS 10 firmware (10.05.800 or higher) and configure it as
an update buddy.

2. Upgrade another device to IGEL OS 11 and configure it as an update buddy. Make sure that the
IGEL OS 11 update buddy has the same User Name and Password in System > Update > Buddy
Update as the IGEL OS 10 update buddy.

When the update buddies are configured, continue with Creating a Profile (see page 126).
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Creating a Profile

1.

Create a profile that is based on the appropriate IGEL OS 10 version (10.05.800 or higher). Find a
suitable name for the profile, e.g. "Firmware upgrade to IGEL OS 11".
In the profile's configuration dialog, go to System > Update > Firmware Update and change the
settings as follows:

+ Select "FTP" as Protocol.

+ Enter User Name and Password according to the update buddy server.

+ Activate Automatic Update Check on Boot.

« Ensure that Automatic Update Check on Shutdown is deactivated. Otherwise, the device

will shut down when the upgrade to 0S 10.05.800 is finished.
+ Activate Automatic Buddy Detection.

Allow firmware upgrade te IGEL 0S5 11

Related Configurations

A
A

A

€ » FIPUSER

Search

3. Go to System > Update > 0OS 11 Upgrade and change the following settings according to your

successful upgrade test (for details, see Adjusting the Setup (see page 117)):
« Activate Upgrade to OS 11.
+ Set Upgrade to OS 11 even if PowerTerm is enabled according to your needs.
+ Set Require an Enterprise Management Pack license to upgrade to OS 11 according to
your needs.
+ Set Timeout waiting for OS 11 license to start automatic upgrade to 10 Minutes.

4. Go to System > Remote Management and change the settings as follows:

« Deactivate Display 'Apply changes' dialog on boot.
+ Set Default action on boot to Apply changed configuration immediately.
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Allow firmware upgrade te IGEL 0S5 11
14 > A ! * Rel

Configuration

a0
Timeout

Defal

A

Timeout

Search

5. Click Save.

When the profile es created, continue with Deploying the Licenses (see page 128).
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Deploying the Licenses
Deploy the licenses for IGEL OS 11 using the method that suits your needs:

+ Automatic License Deployment (ALD): Licenses are created and deployed automatically to each
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).

+ Manual License Deployment: Licenses are created and deployed manually. For instructions,
see Manual License Deployment for IGEL OS.

When the license deployment is set up, continue with Putting It All Together (see page 129).
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Putting It All Together

1. Assign the profile to all devices that are to be upgraded. This can be done by assigning the profile
to the directory that contains these devices.

© Do notassign the profile to the update buddies.

2. Inthe context menu of the assignment, select Now.
3. For Automatic license deployment, a condition can be set to the directory. For more information,
see Configuring the Distribution Conditions, section "Distributing Licenses to Devices in a

Specified Directory".

When everything is in place, continue with Executing the Upgrade (see page 130).
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Executing the Upgrade

1. Inthe UMS,; select all devices that are to be upgraded and reboot them.

() Alternatively, you can create a scheduled job for reboot or wake up and assign it to the devices or
the directory containing these devices; for more information, see Jobs.

On reboot or wake up, the devices choose the IGEL OS 10 buddy. They ignore the IGEL OS 11 buddy
at this stage because this version is not known to them yet. The devices update to the appropriate
IGEL OS 10 version (10.05.800 or higher). With this version, the Upgrade to OS 11 parameter is
recognized by the devices; also, the devices request IGEL OS 11 licenses from the UMS (Workspace
Edition and, if required, Enterprise Management Pack).
If no IGEL OS 11 licenses have been deployed on the devices yet, the licenses are deployed within a
few minutes. The upgrade will be started when the licenses are deployed. The maximum time
period the device will wait for a license is configured by the parameter Timeout waiting for 0S 11
license to start automatic upgrade; for details, see Adjusting the Setup (see page 117).
The parameters Automatic update check on boot and Automatic buddy detection cause the
devices to look for a new firmware and wait for an IGEL OS 11 update buddy to reply. When an IGEL
0S 11 update buddy is found, the devices start the upgrade process.

2. When all devices have been upgraded successfully, remove the "Firmware upgrade to IGEL OS 11"
profile.

The upgrade is completed.
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Mass Deployment Using a Scheduled Job

This scenario is appropriate if you already have a working environment with IGEL OS 10.05.800 (or higher) and want
to update all devices to IGEL OS 11 at a defined time.

Read all the following chapters carefully and follow the instructions.

1. Checking the Requirements (see page 132)
Creating a Profile (see page 133)
Deploying the Licenses (see page 137)
Assigning the Profile (see page 138)
Creating the Scheduled Job (see page 140)

ok wnN
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Checking the Requirements
The following requirements must be met:

+ The upgrade has been tested with characteristic devices.

+ UMS6.01.130 or higher is available.

+ The firmware IGEL OS 10.05.800 (or higher) is known to the UMS. For this purpose, a device
with this firmware version must be registered in the UMS. This is already the case if you tested the
upgrade with the same UMS with which you are about to do the mass upgrade. If not, you must
register a device with the appropriate firmware version now.

+ All devices are connected to a regular LAN (not OpenVPN, OpenConnect, genucard, NCP VPN or
mobile broadband).

+ All devices are in a safe environment where the upgrade process cannot be disrupted, e.g. by
powering off the devices.

When all requirements are met, continue with Creating a Profile (see page 133).
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Creating a Profile

1. Create a profile that is based on the appropriate IGEL OS 10 firmware version (10.05.800 or higher).
Find a suitable name for the profile, e.g. "Scheduled firmware upgrade to IGEL OS 11".

MNew Profile
Profile Name Scheduled firrrware upgrade to IGEL 0F 11
Diescriptian

Inhetits Settings fram Profiles (11

Ipgrade to IGEL 05 11

Based on IGEL Universal Desktop

Cancel
2. Inthe profile's configuration dialog, go to System > Update > Firmware Update and change the

settings according to your environment:

() Ifyouuse Universal Firmware Update (see page 167) for OS 11, you do not need to configure the
settings described in this step.

+ Select an update source for IGEL OS 11. For further information, see Firmware Update.

() Ifyou use FILE as the protocol (local file or network drive), the device will show an error
message and go through an additional reboot. Apart from that, the upgrade will work
normally.

« Ensure that Automatic Update Check on Boot and Automatic Update Check on
Shutdown are deactivated.

(@ Inthefollowing screenshot, FTP is used as an example. The other protocols can be used as
well.
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Scheduled firmware upgrade to IGEL OS 11

14 > A ! Update  » Firmw

Related Configurations
iguration

Search

3. Go to System > Update > 0OS 11 Upgrade and change the following settings according to your
successful upgrade test:

« Activate Upgrade to OS 11.
+ Set Upgrade to OS 11 even if PowerTerm is enabled according to your needs.
+ Set Upgrade to OS 11 even if a previous upgrade attempt failed according to your needs.

+ Set Require an Enterprise Management Pack license to upgrade to OS 11 according to
your needs.

« Ensure that the Timeout waiting for OS 11 license to start automatic upgrade is set to 10
Minutes.
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Scheduled firmware upgrade to IGEL OS 11

> Upda

Search

4. Go to System > Remote Management and change the settings as follows:
« Deactivate Display 'Apply changes' dialog on boot.
+ Set Default action on boot to Apply changed configuration immediately.
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Allow firmware upgrade te IGEL 0S5 11
14 > A ! * Rel

Configuration

a0
Timeout

Defal

A

Timeout

Search

5. Click Save.

When the profile is created, continue with Deploying the Licenses (see page 96).
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Deploying the Licenses
Deploy the licenses for IGEL OS 11 using the method that suits your needs:

+ Automatic License Deployment (ALD): Licenses are created and deployed automatically to each
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).

+ Manual License Deployment: Licenses are created and deployed manually. For instructions,
see Manual License Deployment for IGEL OS.

When the license deployment is set up, continue with Assigning the Profile (see page 138).
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Assigning the Profile

1. Putall devices that are to be updated into a directory.

¥ |L—| Devices (4)
¥ B Remote Devices (1)
L ITCO0EDCST1 4345

g D3
¥ i Upgrade to IGEL OS5 11 (1)

1 ITCoonBCANSS01 8

WL (00

- ,' ITCOOEQCSTCA087
2. Select the directory and in the Assigned objects area, click @

Server-172.30.92.9

e 6

£l iTcoo.
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IGEL

3. Assign the profile (see Creating a Profile (see page 133)) to the directory and click Ok.
New Scheduled Job

Select assignable objects

4,

When the profile is assigned, continue with Creating the Scheduled Job (see page 140).
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Creating the Scheduled Job
1. Inthe UMS, select Jobs > New Scheduled Job.

Server -172.30.92.9

T
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New Scheduled Job

Details

Mame
Command
cution tire  11:53 Start date  2013- V' Enahled

Comment

Options
v Lo gre

Timeaut

Joh-Info

Joh 1D

Mext Execution  Apr10, 201911

Liser
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3. Under Command, select OS 11 Upgrade.
New Scheduled Job

Details
Marme
Cammand
cution firme  11°53 Start dlate 2018 v Enabled

Comment

Options
v Lo gre

Tirmeaut
Joh-Info

Joh 1D

Mext Execution  Apr10, 201911

Liser
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4. Under Execution time and Start date, set the time at which the upgrade should be executed, and
click Next.

New Scheduled Job

Details

Mame

Command | 1 Upgrade

Execution time  11:53 Start date  2013- V' Enahled

Comment

Options
v Log
Max. Thres
Timeaut
Joh-Info
Joh 1D

Apr1o, 201911
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5. Review the execution time and click Next.
New Scheduled Job
Schedule

tion tirme 11: Sit: 2019-04-10

wpiration date

hour

Comment

Cancel jobh execution
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6. Assign the directory containing the devices to the job and click Finish.
New Scheduled Job

Select assignable objects

8 Upgrade to IGEL ©S 11

Finish Cancel

The upgrade is completed.
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Troubleshooting

This section describes possible error cases and solutions.
+ Regaining a Usable System (see page 147)
+ Getting Error Messages (see page 148)

+ Starting an New Upgrade Attempt (see page 149)
+ Starting Another Upgrade Attempt after 5 Retries (see page 150)
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Regaining a Usable System

Here you can find typical upgrade failures and the appropriate methods to regain a usable system.

Device Has Upgraded to Igel OS 11, but Does Not Boot Any More
To get a working IGEL OS 11 system:

» Use the IGEL OS Creator to recover the IGEL OS 11 system. For more information, see the IGEL OS Creator
Manual.

IGEL OS 10 Rescue System Fails to Update Missing Partitions

If a severe error has occurred during the upgrade process, the device boots into a minimal IGEL OS 10 (10.05.800 or
higher) rescue system. If unattended, the device tries to download and update the missing partitions and reboots
on failure.

To regain a full IGEL OS 10 system, you have two possibilities:

» In the rescue system, start the Setup, go to System > Update > Firmware Update and set a valid update source
for the appropriate IGEL OS 10 firmware (10.05.800 or higher).

Or:

> Configure a UMS profile that contains a valid update source for the appropriate IGEL OS 10 firmware (10.05.800
or higher) under System > Update > Firmware Update and assign it to the device.
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Getting Error Messages

> Open the 0S 11 Upgrade Tool (default path: click E] System and then Upgrade to OS 11).

The OS 11 Upgrade Tool shows the error messages. The most important message is prefixed with Retries; see the
example below:

05 11 Upgrade

& Hardware
ﬁ License
I:E!::I SEtup

ﬁ Lipdate Saiante

IGELOS10-211

Stup: The upgrade Lo OS 11 has faled previously. To try sgain acthvate Upgrade to IGEL 05 11 even f a
mwmwm‘w?w} m.
Retries: Could not write the new System partition to permanent Storage.

Closa Chachk again

> Formore information, review the main migration log under /wfs/migration.log

() You can use the system log viewer to review the migration log (see the chapter System Log Viewer in the
IGEL OS Manual) or save the log files in order to send them to the IGEL Support Team (see the chapter Save
Device Files for Support support).
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Starting an New Upgrade Attempt
If you want the device to start multiple upgrade attempts (and the device is not already configured to do so):

1. Inthe UMS profile or in the Setup, go to System > Update > OS 11 Upgrade and activate Upgrade
to OS 11 even if a previous upgrade attempt failed.
2. Reboot the device.
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Starting Another Upgrade Attempt after 5 Retries

When the Upgrade to OS 11 even if a previous upgrade attempt failed option is set and the upgrade has failed
each time, the system will stop trying after 5 attempts.

To reset the retry counter:

1. Inthe Setup or the UMS profile, go to System > Update > OS 11 Upgrade and deactivate Upgrade
to OS 11 even if a previous upgrade attempt failed.

2. When the setting is effective on the devices, go to System > Update > OS 11 Upgrade again and
activate Upgrade to OS 11 even if a previous upgrade attempt failed..
The retry counter is reset, and the devices will try upgrading another 5 times, if necessary.
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Upgrading IGEL Devices from IGEL OS 10 to IGEL OS 11

This document describes how to upgrade any number of IGEL Universal Desktop devices (UD) from IGEL OS 10 to
IGEL OS 11.

IGEL OS 10.05.700 or higher is required for upgrading to IGEL OS 11. If you have an older version of IGEL OS 10, you
need to update to version 10.05.700 or a higher version first.

The following methods of mass deployment are described here:

« Zero-Touch Deployment Using Universal Firmware Update (see page 152): Mass upgrade from any
version of IGEL OS 10 to IGEL OS 11 in one step using Universal Firmware Update. This method can
be started immediately or as a scheduled job (wake up or reboot).

+ Zero-Touch Deployment Using Buddy Update (see page 183): Mass upgrade from any version of IGEL
0S 10 to IGEL OS 11 in one step using two devices as update buddies. This method can be started
immediately or as a scheduled job (wake up or reboot).

+ Mass Deployment Using a Scheduled Job (see page 204): Upgrade devices that are already running
IGEL OS 10.05.700 (or higher) using a specific scheduled job.
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Zero-Touch Deployment Using Universal Firmware Update

This method is the most convenient way to upgrade from IGEL OS 10 to IGEL OS 11. The method uses the Universal
Firmware Update feature of the UMS (Universal Management Suite) and a profile.

Read all the following chapters carefully and follow the instructions.

IGEL Devices That Can Be Upgraded to IGEL OS 11 (see page 153)
Important! Consider This Before Upgrading (see page 155)
Preparing the Upgrade (see page 157)

Testing the Upgrade (see page 162)

Checking the Requirements (see page 166)

Creating the Universal Firmware Updates (see page 167)
Creating a Profile (see page 172)

Deploying the Licenses (see page 177)

Putting It All Together (see page 178)

Executing the Upgrade (see page 181)

WoeNoOkwWwNE

=
e
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IGEL Devices That Can Be Upgraded to IGEL OS 11

Core Requirements for IGEL OS 11

« CPU with 64-bit support
« CPUspeed:=1GHz
+ Memory (RAM): =2 GB

() RAMsize higher than 2 GB is recommended if you use any of the following:

+ Storage: 2 GB minimum; =4 GB recommended

+ Unified Communications optimizations (uses a client-side media engine)

+ High-resolution graphics output
For details on the supported graphics-related characteristics of IGEL devices,
see Graphics on IGEL Devices or, for older devices, Graphics on Legacy IGEL

Devices.

« More than two monitors

() Storage Requirements for IGEL OS 11.04 or Higher

IGEL OS 11.04.100 or higher requires at least 2.4 GB storage if the full feature set is applied. Thus,
the feature set must be modified accordingly; for more information, see Error: "Not enough space
on local drive" when Updating to IGEL OS 11.04 or Higher.

IGEL Devices Supported by IGEL OS 11

IGEL UD (Universal Desktop)

Product Line Device Type HardwareID 64 Bit

ubD2
ubD2
ubD2

D220
M250C
M250C

UD3* (see page M340C

154)
ubD3
ubD3

M340C
M350C

UD5" (see page H830C

154)

IGEL OS Articles

40
50

51 /52" (see
page 154)

50

51
60
50

Yes
Yes

Yes

Yes

Yes
Yes

Yes

Memory
(RAM)

2GB
2GB
20r4GB

2GB

2GB
4GB
2GB

Storage

4GB
4GB
8 GB

4GB

4GB
8 GB
4GB

HW Video
Acceleration

Yes
Yes

Yes

Yes

Yes
Yes

Yes
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Product Line Device Type HardwareID 64 Bit

uD6 H830C
ub7 H850C

UD7** (see page H850C
154)

ub7 H860C

UD9* (see page TC215B
154)

51
10
11

20

Yes
Yes

Yes

Yes

40/ 41 (Touch) Yes

Memory
(RAM)

2GB
4GB
4GB

8 GB
2GB

Storage

4GB
4GB
4GB

8 GB
4GB

e

IGE

HW Video
Acceleration

Yes
Yes

Yes

Yes

Yes

* IGEL UD3-LX 50 and UD5-LX 50 are officially supported up to IGEL OS 11.05, incl. private builds. IGEL UD9-LX 40 / 41

(Touch) devices are officially supported up to IGEL OS 11.07.910.

** As of December 2019, IGEL UD7 model H850C is equipped with the AMD Secure Processor; for further information,

see UD7 Model H850C.

***|GEL UD2-LX 52 is supported with IGEL OS 11.06.140 and later.

IGEL Zero

() NoteonIZDevices

The 1Z devices listed below can be upgraded to IGEL OS 11. To upgrade your IZ devices to IGEL OS 11,
please contact your IGEL sales representative. See also https://www.igel.com/osllmigration/.

Product Device

Line Type
1722 D220
1Z3 M340C
1Z3 M340C

Hardware 64 Bit

ID
40
50
51

Yes
Yes

Yes

Memory Storage UEFI Secure

(RAM)
2GB
2GB
2GB

4GB
4GB
4GB

HW Video

Boot Support Acceleration

Yes
Yes

Yes

Yes
Yes

Yes

When you have confirmed that your devices can be upgraded to IGEL OS 11, make sure to consider Important!

Consider This Before Upgrading (see page 155).
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Important! Consider This Before Upgrading

To make sure that your upgrade can be successful, check the following warnings and notes; a warning symbol
indicates that irreversible damage can be done to your devices.

© NoDowngrade

You cannot restore your IGEL OS 10 system once you have migrated to IGEL OS 11. The device storage is
overwritten completely with a new partitioning scheme.

© Features (e.g. Clients)

IGEL OS 11 does not have the complete feature set of IGEL OS 10. Make sure that the current version of
IGEL OS 11 meets your requirements. For details, refer to the appropriate release notes.

© Custom Partitions

The contents of custom partitions will be deleted by the upgrade. Make sure to back up the contents and
restore them after the upgrade has finished. Besides becoming dysfunctional after the upgrade,
applications and kernel drivers in a custom partition might corrupt the upgrade. For this reason, make
sure to first test the upgrade on a characteristic device. We recommend that you disable custom partitions
when upgrading; you can enable them once the upgrade has been successfully completed.

© Custom Commands

The persistence of custom commands cannot be guaranteed. Besides becoming dysfunctional after the
upgrade, custom commands might corrupt the upgrade. For this reason, make sure to first test the
upgrade on a characteristic device. In general, custom commands must be adapted for IGEL OS 11. We
recommend that you disable custom commands when upgrading; you can enable them once the upgrade
has been successfully completed.

() Network

All devices must be connected to a WLAN or LAN. LAN is the recommended option. The device will not be
upgraded if connected to OpenVPN, OpenConnect, genucard, NCP VPN or mobile broadband.

() Hardware Support

Make sure that your devices support IGEL OS 11; please refer to IGEL Devices Supported by IGEL OS 11.
This document describes upgrading methods for IGEL UD and IGEL 1Z devices. Upgrading methods for IGEL
UDC3 and UD Pocket are described under Upgrading UDC3 Devices from IGEL OS 10 to IGEL OS 11 (see page
62).

() License
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« Avalid license from an IGEL Workspace Edition (WE) Product Pack must be available for
each device. For general information, see IGEL Software License Overview. For deploying

licenses, see Setting up Automatic License Deployment (ALD) or Manual License
Deployment for IGEL OS.

+ |1Z devices are not allowed to upgrade to IGEL OS 11. Please contact your IGEL sales
representative for a UD Upgrade License which allows you to upgrade your IZ devices.

(@) UMS Version

UMS version 6.01.130 or higher is required for upgrading from IGEL OS 10 to IGEL OS 11.

When you have considered everything that is relevant, continue with Preparing the Upgrade (see page 157).
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Preparing the Upgrade

This section describes the required preparations and tests before any productive devices can be updated. The
testing should be done with at least one device that is characteristic of your environment. This device should have
every custom partition and every custom command that may possibly exist in any of your devices.

First of all, you should check thoroughly if IGEL OS 11 has all features required for your purposes.

> Continue with Preparing the UMS (see page 158).
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Preparing the UMS

To upgrade your devices to IGEL OS 11, you need the appropriate version of the UMS. Also, the devices must be
registered with the UMS to receive their licenses.

1. If you have not already done so, update your UMS to version 6.01.130 or higher. For instructions,
see Updating a UMS Installation.

2. Make sure that your devices are registered with the UMS. For more information, see the
chapter Registering Devices on the UMS Server in the UMS Manual.

When the UMS is prepared, continue with Adjusting the Setup (see page 159).
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Adjusting the Setup

Depending on the features that are in use now or will be used in the future, a specific set of parameters must be set
in the device's Setup.

1. Inthe Setup, go to System > Update > OS 11 Upgrade.
2. Make your settings as appropriate:

+ Activate Upgrade to OS 11.

+ If you want the device to retry the upgrade immediately after a failed attempt,
activate Upgrade to OS 11 even if a previous upgrade attempt failed. The device will retry
the upgrade 5 times. When the 5th attempt has failed, a message will be shown in the
upgrade tool window.

+ If your device has a PowerTerm license, and you want to upgrade to IGEL OS 11 even though
it does not support PowerTerm, you must activate Upgrade to OS 11 even if PowerTerm is
enabled.

+ Under Require an Enterprise Management Pack license to upgrade to OS 11, select the
appropriate option:

+ Ifyou are using IGEL Cloud Gateway (ICG) or Shared Workplace (SWP) or a Custom
Partition and want to make sure that the upgrade is performed only if these features
can be used furthermore, select Smart. When this option is selected, and any of these
features is activated, the upgrade is performed only if the device could fetch a license
from an Enterprise Management Pack.

+ If you want to force the device to fetch a license from an Enterprise Management
Pack and make sure that the upgrade is performed only if the license could be
fetched, select Always.

+ If you want the device to upgrade to IGEL OS 11 without fetching an Enterprise
Management Pack, disregarding the features that might be activated, select Never.

+ Under Timeout waiting for OS 11 license to start automatic upgrade, set the time period
the device will wait for a license in a mass deployment scenario (see Zero-Touch
Deployment Using Universal Firmware Update (see page 152), Zero-Touch Deployment Using
Buddy Update (see page 183) and Mass Deployment Using a Scheduled Job (see page 204)). This
setting prevents the device from starting the upgrade at an inappropriate time as a result of
the license just being deployed. This way, the setting prevents unwanted interruptions at
work. For a mass deployment scenario, the default value 10 Minutes is recommended.

3. Click Apply.
4. Continue with Deploying a License (see page 160).
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Deploying a License

To upgrade from IGEL OS 10 to IGEL OS 11, you need an appropriate license. Depending on your requirements, one
or more of these licenses will be needed for each device:

+ One Workspace Edition license for basic functionality; see Workspace Edition
+ If one of the following features is used, one Enterprise Management Pack license is required
(see Enterprise Management Pack):
+ IGEL Cloud Gateway (ICG)
+ Shared Workplace (SWP)
+ Custom Partition - if IGEL OS 11.03.100 or lower is the target version; in IGEL OS 11.03.500 or
higher, the Custom Partition feature is included in the Workspace Edition.

Proceed as follows:

> Deploy the licenses for IGEL OS 11 using the method that suits your needs:

+ Manual License Deployment: Licenses are created and deployed manually. For instructions,
see Manual License Deployment for IGEL OS.
+ Automatic License Deployment (ALD): Licenses are created and deployed automatically to each
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).
+ Download three demo licenses from https://www.igel.com/download/.

When the device has a license, continue with Configuring the Update Source (see page 161).
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Configuring the Update Source

1. Inthe Setup, go to System > Update > Firmware Update and configure the update source for
IGEL OS 11. For more information, see the Firmware Update chapter in the IGEL OS Manual.
2. Click Ok.

When the correct update source is configured, continue with Testing the Upgrade (see page 162).
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IGE

Testing the Upgrade

1. Click E] System and then Upgrade to OS 11. The OS 11 Upgrade Tool starts and indicates
whether all requirements are met.

() You can change the starting the starting methods for the OS 11 Upgrade Tool in the Setup under
Accessories > 0S11 Upgrade.

0S 11 Upgrade x

Q Hardware
0 License
Q Setup

Q Update Source

o Network

IGELOST10->11

Close 05 Upgrade

2. Check the output of the OS 11 Upgrade Tool and continue appropriately:
« If each requirement has an o icon, click OS Upgrade to start the upgrade process.

+ If one or more requirements have an ® icon, check the messages and resolve the
issues. Afterwards, click Check again. If all requirements are met, the button changes to 0S
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Upgrade, and you can start the upgrade.
0S 11 Upgrade x

Q Hardware
o License
® Setup
® Powerterm

® Update Source

IGELOS10->11 |

Setup: PowerTerm will not be available in 05 11. To proceed, activate 'Upgrade to 05 11 even if PowerTerm is
enabled' at IGEL Setup = System > Update > 05 11 Upgrade.

Update Source: Please configure a valid OS 11 update source at 'System > Update = Firmware Update’ and
check your network connection.

Network: Please disable all VPN/Mobile Broadband network connectivity on the device. Otherwise it cannot be
guaranteed that your update source will be reachable after the upgrade.

Close Check again

When you start the upgrade, a warning dialog is shown.
3. Click OK to continue.

Confirm Upgrade to 0S 11

With this upgrade, IGEL 0S 11 will be installed on the device.
It is not possible to downgrade to IGEL OS 10 afterwards.

| ¥ Cancel

A warning dialog with a timeout is shown. If you click Cancel before the timeout expires, the
upgrade is canceled. If you click OK or just wait for the timeout to expire, the upgrade is started
Upgrade - A

Please note: With this upgrade, IGEL 0S 11 will be installed on
the device. It is not possible to downgrade to IGEL OS 10
afterwards.

This upgrade involves a critical phase in which the device
must not be powered off. The critical phase will be indicated
by a flashing warning. You will be notified after the upgrade
has finished successfully.

54 seconds remain

¥ Cancel

After the warning dialog has been confirmed or the timeout has expired, the device reboots into a
special IGEL OS 10 environment, in which the system upgrade is executed. The Upgrade window
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shows the progress.

Upgrade

n partition fo
m partition to

IGELOS

During the critical phase, the device must not be powered off. At this stage in the progress, an
additional warning is shown.

Upgrading base system.
DO NOT POWER OFF YOUR DEVICE!

When the installation is completed, the Upgrade window looks like this:

Upgrade

ng for upgrade tool to start
upgrade

IGELOS 10211
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After a few seconds the device reboots into IGEL OS 11.

]

Local Terminal

\\LH///
Z-1GEL

Congratulations
Z *  The upgrade to IGEL OS 11 is now
complete.

<) | 10:29

When the upgrade test has been successful, you are ready to set up the mass upgrade. Continue with Checking the
Requirements (see page 166).
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Checking the Requirements
The following requirements must be met:

+ The upgrade has been tested with characteristic devices.

+ UMS6.01.130 or higher is available.

+ The appropriate IGEL OS 10 firmware version (10.05.700 or higher) is known to the UMS. For this
purpose, a device with this firmware version must be registered in the UMS. This is already the
case if you tested the upgrade with the same UMS with which you are about to do the mass
upgrade. If not, you must register a device with the appropriate IGEL OS 10 firmware version now.

+ All devices are connected to a regular LAN (not OpenVPN, OpenConnect, genucard, or mobile
broadband).

+ All devices are in a safe environment where the upgrade process cannot be disrupted, e.g. by
powering off the devices.

When all the requirements are met, continue with Creating the Universal Firmware Updates (see page 167).
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Creating the Universal Firmware Updates

For detailed information, see the chapter Universal Firmware Update in the UMS Manual.

() Ifyou use the High Availability Extension, note that Universal Firmware Updates are NOT synchronized,
that is why you have to either download them to all HA nodes or configure an external (FTP) server.

1. Create a Universal Firmware Update for the appropriate IGEL OS 10 firmware (10.05.700 or higher).

2. After you have created the Universal Firmware Update for IGEL OS 10, create a Universal Firmware
Update for IGEL OS 11.

© Theorder of creation is crucial because the IGEL OS 11 firmware must have a higher ID in order to
be chosen by the device. For details, see Executing the Upgrade (see page 181).

Configuring the Universal Firmware Update for ICG

If you are using IGEL Cloud Gateway (ICG), an FTP server that is accessible to all devices must be configured as the
update source.

To configure an FTP server as update source:

1. Inthe UMS, go to UMS Administration > Universal Firmware Update and click .
2. Enter the data required for accessing the FTP server and click Save.

Edit FTP Server Configuration

Universal update settings
The IGEL U zal Firr are downloaded from; ‘fia

Pram

The FTP server settings where the files are downloaded to {optionally).

Host fipSerername

Port

Directory

Cancel
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IGEL

3. Goto Server - [UMS address] > Universal Firmware Update and in the context menu, select
Check for new firmware updates.

Shared Workplace Users

4. Select the entry for the appropriate IGEL OS firmware, click to select the FTP server selected
in step 2 and select Download.

Universal Firmware Updates

Universal Firmware Updates
Include Model Target directory
v IGEL UD LX
IGELOS 11

Show only latest firmware versions (hides already downloaded versi

Download Cancel
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5. The firmware is transferred to the FTP server.

IUniversal Firmware Update/IGEL Universal Desktop LX-10.05.700

Product  IGEL Uniy 1D op LX
Wersion  10.05700
Release Notes  HTML Text
Firmware Update Settings
User fiplser
s
Host /ername
Part
Protocol
Target URL  ftpServerpath/IGEL_Unive Desktop_LX-10.0
Snapshot file
Download Status
~

(]
Status -: .'

Error

Started Download the firmware update...

6. Under Server - [UMS address] > Universal Firmware Update, in the context menu, select Check

for new firmware updates again.
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7. Select the entry for the IGEL OS 11 firmware, click to select the FTP server selected in step 2
and select Download.

Universal Firmware Updates

Universal Firmware Updates
Include Model
IGEL UD LX 00 y me21MpSe

IGEL O3 11 11.01.100 fip:iftpServername 21fpServerpath

Show only latest firmware versions (hides already downloaded
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8. Thefirmware is transferred to the FTP server.
IUniversal Firmware Update/GEL 0S5 11-11.01.100
Product  IGEL OS 11

Version  11.01.100

ase Notes  HTML

Firmware Update Settings

User fipUser

Host
Port
Protocol

Target URL | rverpath/lGE 1-11.01.100

Download Status
]
-:‘:- Started L Download the firmware update. .

Error

The devices can download the firmware from the FTP server.

When the Universal Firmware Update is ready, continue with Creating a Profile (see page 172).

IGEL OS Articles 171/823



Update and Upgrade

Creating a Profile

1. Create a profile that is based on the appropriate IGEL OS 10 firmware version (10.05.700 or higher).
Find a suitable name for the profile, e.g. "Firmware upgrade to IGEL OS 11",

New Profile

Cancel

2. Inthe profile's configuration dialog, go to System > Update > Firmware Update and change the
settings according to your environment:
« If the UMS and the devices are in one and the same network, and no IGEL Cloud Gateway
(ICG) is used:

+ Select "HTTPS" as Protocol.

« Activate Automatic Update Check on Boot.

« Ensure that Automatic Update Check on Shutdown is deactivated. Otherwise, the

device will shut down when the update is finished.

IGEL OS Articles 172/823



Update and Upgrade

Allow firmware upgrade te IGEL 0S5 11

» Update » Fi

Related Configurations

Search

« IfIGEL Cloud Gateway (ICG) is used:
+ Select "FTP" as Protocol.
+ Activate Automatic Update Check on Boot.
» Ensure that Automatic Update Check on Shutdown is deactivated. Otherwise, the
device will shut down when the update is finished.
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Allow firmware upgrade te IGEL 0S5 11
< > A

? al Related Configurations
uration

Search

3. Go to System > Update > 0OS 11 Upgrade and change the following settings according to your
successful upgrade test:
« Activate Upgrade to OS 11.
Set Upgrade to OS 11 even if PowerTerm is enabled according to your needs.
Set Upgrade to OS 11 even if a previous upgrade attempt failed according to your needs.
+ Set Require an Enterprise Management Pack license to upgrade to OS 11 according to
your needs.

Ensure that the Timeout waiting for OS 11 license to start automatic upgrade is set to 10
Minutes.
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Allow firmware upgrade te IGEL 0S5 11

> Upda

Require an Ente

Time

Search

4. Go to System > Remote Management and change the settings as follows:
« Deactivate Display 'Apply changes' dialog on boot.
+ Set Default action on boot to Apply changed configuration immediately.
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Allow firmware upgrade te IGEL 0S5 11
14 > A ! * Rel

Configuration

a0
Timeout

Defal

A

Timeout

Search

5. Click Save.

When the profile es created, continue with Deploying the Licenses (see page 177).
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Deploying the Licenses
Deploy the licenses for IGEL OS 11 using the method that suits your needs:

+ Automatic License Deployment (ALD): Licenses are created and deployed automatically to each
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).

+ Manual License Deployment: Licenses are created and deployed manually. For instructions,
see Manual License Deployment for IGEL OS.

When the license deployment is setup up, continue with Putting It All Together (see page 178).
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Putting It All Together

1. Putall devices that are to be updated into a directory.

Server -172.30.92.9

nagement Suite & 3 ho.. M r'o i.. .. Mame
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3. Assign the profile (see Creating a Profile (see page 172)) and the two Universal Firmware Updates
(see Creating the Universal Firmware Updates (see page 167)) to the directory and click Ok.

Select assignhable objects

Selected objects

Cancel

4. In the context menu of the assignment, select Now.
Update time

When should these ¢
ket Rehoot

) Mow

In the Assigned objects area, the profile and the Universal Firmware Updates are shown:

IGEL OS Articles 179/823



Update and Upgrade 1

Server-172.30.92.9

5. If you are using Automatic License Deployment (ALD), it might be feasible to confine the
distribution of licenses to the current directory. For more information, see Configuring the
Distribution Conditions, section "Distributing Licenses to Devices in a Specified Directory".

When everything is in place, continue with Executing the Upgrade (see page 181).
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Executing the Upgrade

1. Inthe UMS,; select the directory containing all devices that are to be upgraded and reboot them.

@ Alternatively, you can create a scheduled job for reboot or wake up and assign it to the
devices or the directory containing these devices. For more information, see Jobs.

e Status'flag

ommands

END]

On reboot or wake up, the devices update to the appropriate IGEL OS firmware version (10.05.700
or higher). With this version, the Upgrade to OS 11 parameter is recognized by the devices; also,
the devices request IGEL OS 11 licenses from the UMS (Workspace Edition and, if required,
Enterprise Management Pack).

If no IGEL OS 11 licenses have been deployed on the devices yet, the licenses are deployed within a
few minutes. The upgrade will be started when the licenses are deployed. The maximum time
period the device will wait for a license is configured by the parameter Timeout waiting for 0S 11
license to start automatic upgrade; for details, see Adjusting the Setup (see page 159).

The parameter Automatic update check on boot causes the devices to look for new firmware
again. Although two Universal Firmware Updates are assigned to the devices, the UMS offers the
IGEL OS 11 firmware, because the ID of the IGEL OS 11 firmware is higher than the ID of the IGEL OS
10 firmware.
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2. When all devices have been upgraded successfully, remove the "Firmware upgrade to IGEL OS 11"
profile and the two Universal Firmware Updates from the directory.

- : o o
Assigned ohjects E

Mame

The upgrade is completed.
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Zero-Touch Deployment Using Buddy Update

This method uses the buddy update feature of IGEL OS. One or more devices that are configured as an update
buddy access the main server and download the firmware. The other devices are configured to download their
firmware from an update buddy.

Read all the following chapters carefully and follow the instructions.

IGEL Devices That Can Be Upgraded to IGEL OS 11 (see page 184)
Important! Consider This Before Upgrading (see page 155)
Preparing the Upgrade (see page 157)

Testing the Upgrade (see page 162)

Checking the Requirements (see page 166)

Configuring Two Update Buddies (see page 198)

Creating a Profile (see page 199)

Deploying the Licenses (see page 201)

Putting It All Together (see page 202)

Executing the Upgrade (see page 203)

WoeNoOkwWwNE

=
e
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IGEL Devices That Can Be Upgraded to IGEL OS 11

Core Requirements for IGEL OS 11

« CPU with 64-bit support
« CPUspeed:=1GHz
+ Memory (RAM): =2 GB

() RAMsize higher than 2 GB is recommended if you use any of the following:

+ Storage: 2 GB minimum; =4 GB recommended

+ Unified Communications optimizations (uses a client-side media engine)

+ High-resolution graphics output
For details on the supported graphics-related characteristics of IGEL devices,
see Graphics on IGEL Devices or, for older devices, Graphics on Legacy IGEL

Devices.

« More than two monitors

() Storage Requirements for IGEL OS 11.04 or Higher

IGEL OS 11.04.100 or higher requires at least 2.4 GB storage if the full feature set is applied. Thus,
the feature set must be modified accordingly; for more information, see Error: "Not enough space
on local drive" when Updating to IGEL OS 11.04 or Higher.

IGEL Devices Supported by IGEL OS 11

IGEL UD (Universal Desktop)

Product Line Device Type HardwareID 64 Bit

ubD2
ubD2
ubD2

D220
M250C
M250C

UD3* (see page M340C

185)
ubD3
ubD3

M340C
M350C

UD5" (see page H830C

185)

IGEL OS Articles

40
50

51 /52" (see
page 185)

50

51
60
50

Yes
Yes

Yes

Yes

Yes
Yes

Yes

Memory
(RAM)

2GB
2GB
20r4GB

2GB

2GB
4GB
2GB

Storage

4GB
4GB
8 GB

4GB

4GB
8 GB
4GB

HW Video
Acceleration

Yes
Yes

Yes

Yes

Yes
Yes

Yes

184/823



Update and Upgrade

Product Line Device Type HardwareID 64 Bit

uD6 H830C
ub7 H850C

UD7** (see page H850C
185)

ub7 H860C

UD9* (see page TC215B
185)

51
10
11

20

Yes
Yes

Yes

Yes

40/ 41 (Touch) Yes

Memory
(RAM)

2GB
4GB
4GB

8 GB
2GB

Storage

4GB
4GB
4GB

8 GB
4GB

e

IGE

HW Video
Acceleration

Yes
Yes

Yes

Yes

Yes

* IGEL UD3-LX 50 and UD5-LX 50 are officially supported up to IGEL OS 11.05, incl. private builds. IGEL UD9-LX 40 / 41

(Touch) devices are officially supported up to IGEL OS 11.07.910.

** As of December 2019, IGEL UD7 model H850C is equipped with the AMD Secure Processor; for further information,

see UD7 Model H850C.

***|GEL UD2-LX 52 is supported with IGEL OS 11.06.140 and later.

IGEL Zero

() NoteonIZDevices

The 1Z devices listed below can be upgraded to IGEL OS 11. To upgrade your IZ devices to IGEL OS 11,
please contact your IGEL sales representative. See also https://www.igel.com/osllmigration/.

Product Device

Line Type
1722 D220
1Z3 M340C
1Z3 M340C

Hardware 64 Bit

ID
40
50
51

Yes
Yes

Yes

Memory Storage UEFI Secure

(RAM)
2GB
2GB
2GB

4GB
4GB
4GB

HW Video

Boot Support Acceleration

Yes
Yes

Yes

Yes
Yes

Yes

When you have confirmed that your devices can be upgraded to IGEL OS 11, make sure to consider Important!

Consider This Before Upgrading (see page 186).

IGEL OS Articles
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Important! Consider This Before Upgrading

To make sure that your upgrade can be successful, check the following warnings and notes; a warning symbol
indicates that irreversible damage can be done to your devices.

© NoDowngrade

You cannot restore your IGEL OS 10 system once you have migrated to IGEL OS 11. The device storage is
overwritten completely with a new partitioning scheme.

© Features (e.g. Clients)

IGEL OS 11 does not have the complete feature set of IGEL OS 10. Make sure that the current version of
IGEL OS 11 meets your requirements. For details, refer to the appropriate release notes.

© Custom Partitions

The contents of custom partitions will be deleted by the upgrade. Make sure to back up the contents and
restore them after the upgrade has finished. Besides becoming dysfunctional after the upgrade,
applications and kernel drivers in a custom partition might corrupt the upgrade. For this reason, make
sure to first test the upgrade on a characteristic device. We recommend that you disable custom partitions
when upgrading; you can enable them once the upgrade has been successfully completed.

© Custom Commands

The persistence of custom commands cannot be guaranteed. Besides becoming dysfunctional after the
upgrade, custom commands might corrupt the upgrade. For this reason, make sure to first test the
upgrade on a characteristic device. In general, custom commands must be adapted for IGEL OS 11. We
recommend that you disable custom commands when upgrading; you can enable them once the upgrade
has been successfully completed.

() Network

All devices must be connected to a WLAN or LAN. LAN is the recommended option. The device will not be
upgraded if connected to OpenVPN, OpenConnect, genucard, NCP VPN or mobile broadband.

() Hardware Support

Make sure that your devices support IGEL OS 11; please refer to IGEL Devices Supported by IGEL OS 11.
This document describes upgrading methods for IGEL UD and IGEL 1Z devices. Upgrading methods for IGEL
UDC3 and UD Pocket are described under Upgrading UDC3 Devices from IGEL OS 10 to IGEL OS 11 (see page
62).

() License
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« Avalid license from an IGEL Workspace Edition (WE) Product Pack must be available for
each device. For general information, see IGEL Software License Overview. For deploying

licenses, see Setting up Automatic License Deployment (ALD) or Manual License
Deployment for IGEL OS.

+ |1Z devices are not allowed to upgrade to IGEL OS 11. Please contact your IGEL sales
representative for a UD Upgrade License which allows you to upgrade your IZ devices.

(@) UMS Version

UMS version 6.01.130 or higher is required for upgrading from IGEL OS 10 to IGEL OS 11.

When you have considered everything that is relevant, continue with Preparing the Upgrade (see page 188).
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Preparing the Upgrade

This section describes the required preparations and tests before any productive devices can be updated. The
testing should be done with at least one device that is characteristic of your environment. This device should have
every custom partition and every custom command that may possibly exist in any of your devices.

To prepare the upgrade, perform the following steps:

1. Preparing the UMS (see page 189)

2. Adjusting the Setup (see page 190)

3. Deploying a License (see page 191)

4. Configuring the Update Source (see page 192)
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Preparing the UMS

To upgrade your devices to IGEL OS 11, you need the appropriate version of the UMS. Also, the devices must be
registered with the UMS to receive their licenses.

1. If you have not already done so, update your UMS to version 6.01.130 or higher. For instructions,
see Updating a UMS Installation.

2. Make sure that your devices are registered with the UMS. For more information, see the
chapter Registering Devices on the UMS Server in the UMS Manual.

When the UMS is ready, continue with Adjusting the Setup (see page 190).
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Adjusting the Setup

Depending on the features that are in use now or will be used in the future, a specific set of parameters must be set
in the device's Setup.

1.

In the Setup, go to System > Update > 0OS 11 Upgrade.

2. Make your settings as appropriate:

+ Activate Upgrade to OS 11.
+ If you want the device to retry the upgrade immediately after a failed attempt,

activate Upgrade to OS 11 even if a previous upgrade attempt failed. The device will retry
the upgrade 5 times. When the 5th attempt has failed, a message will be shown in the
upgrade tool window.

If your device has a PowerTerm license, and you want to upgrade to IGEL OS 11 even though
it does not support PowerTerm, you must activate Upgrade to OS 11 even if PowerTerm is
enabled.

Under Require an Enterprise Management Pack license to upgrade to OS 11, select the
appropriate option:

+ Ifyou are using IGEL Cloud Gateway (ICG) or Shared Workplace (SWP) or a Custom
Partition and want to make sure that the upgrade is performed only if these features
can be used furthermore, select Smart. When this option is selected, and any of these
features is activated, the upgrade is performed only if the device could fetch a license
from an Enterprise Management Pack.

+ If you want to force the device to fetch a license from an Enterprise Management
Pack and make sure that the upgrade is performed only if the license could be
fetched, select Always.

+ If you want the device to upgrade to IGEL OS 11 without fetching an Enterprise
Management Pack, disregarding the features that might be activated, select Never.

Under Timeout waiting for OS 11 license to start automatic upgrade, set the time period
the device will wait for a license in a mass deployment scenario (see Zero-Touch
Deployment Using Universal Firmware Update (see page 152), Zero-Touch Deployment Using
Buddy Update (see page 183) and Mass Deployment Using a Scheduled Job (see page 204)). This
setting prevents the device from starting the upgrade at an inappropriate time as a result of
the license just being deployed. This way, the setting prevents unwanted interruptions at
work. For a mass deployment scenario, the default value 10 Minutes is recommended.

3. Click Apply.

When the Setup is adjusted, continue with Deploying a License (see page 191).
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Deploying a License

To upgrade from IGEL OS 10 to IGEL OS 11, you need an appropriate license. Depending on your requirements, one
or more of these licenses will be needed for each device:

+ One Workspace Edition license for basic functionality; see Workspace Edition
+ If one of the following features is used, one Enterprise Management Pack license is required
(see Enterprise Management Pack):
+ IGEL Cloud Gateway (ICG)
+ Shared Workplace (SWP)
+ Custom Partition - if IGEL OS 11.03.100 or lower is the target version; in IGEL OS 11.03.500 or
higher, the Custom Partition feature is included in the Workspace Edition.

Proceed as follows:

> Deploy the licenses for IGEL OS 11 using the method that suits your needs:

+ Manual License Deployment: Licenses are created and deployed manually. For instructions,
see Manual License Deployment for IGEL OS.
+ Automatic License Deployment (ALD): Licenses are created and deployed automatically to each
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).
+ Download three demo licenses from https://www.igel.com/download/.

When the device has a license, continue with Configuring the Update Source (see page 192).

IGEL OS Articles 191/823


https://www.igel.com/download/

Update and Upgrade

Configuring the Update Source

1. Inthe Setup, go to System > Update > Firmware Update and configure the update source for
IGEL OS 11. For more information, see the Firmware Update chapter in the IGEL OS Manual.
2. Click Ok.

When the correct update source is configured, continue with Testing the Upgrade (see page 193).
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IGE

Testing the Upgrade

1. Click E] System and then Upgrade to OS 11. The OS 11 Upgrade Tool starts and indicates
whether all requirements are met.

() You can change the starting the starting methods for the OS 11 Upgrade Tool in the Setup under
Accessories > 0S11 Upgrade.

0S 11 Upgrade x

Q Hardware
0 License
Q Setup

Q Update Source

o Network

IGELOST10->11

Close 05 Upgrade

2. Check the output of the OS 11 Upgrade Tool and continue appropriately:
« If each requirement has an o icon, click OS Upgrade to start the upgrade process.

+ If one or more requirements have an ® icon, check the messages and resolve the
issues. Afterwards, click Check again. If all requirements are met, the button changes to 0S
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Upgrade, and you can start the upgrade.
0S 11 Upgrade x

Q Hardware
o License
® Setup
® Powerterm

® Update Source

IGELOS10->11 |

Setup: PowerTerm will not be available in 05 11. To proceed, activate 'Upgrade to 05 11 even if PowerTerm is
enabled' at IGEL Setup = System > Update > 05 11 Upgrade.

Update Source: Please configure a valid OS 11 update source at 'System > Update = Firmware Update’ and
check your network connection.

Network: Please disable all VPN/Mobile Broadband network connectivity on the device. Otherwise it cannot be
guaranteed that your update source will be reachable after the upgrade.

Close Check again

When you start the upgrade, a warning dialog is shown.
3. Click OK to continue.

Confirm Upgrade to 0S 11

With this upgrade, IGEL 0S 11 will be installed on the device.
It is not possible to downgrade to IGEL OS 10 afterwards.

| ¥ Cancel

A warning dialog with a timeout is shown. If you click Cancel before the timeout expires, the
upgrade is canceled. If you click OK or just wait for the timeout to expire, the upgrade is started
Upgrade - A

Please note: With this upgrade, IGEL 0S 11 will be installed on
the device. It is not possible to downgrade to IGEL OS 10
afterwards.

This upgrade involves a critical phase in which the device
must not be powered off. The critical phase will be indicated
by a flashing warning. You will be notified after the upgrade
has finished successfully.

54 seconds remain

¥ Cancel

After the warning dialog has been confirmed or the timeout has expired, the device reboots into a
special IGEL OS 10 environment, in which the system upgrade is executed. The Upgrade window
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shows the progress.

Upgrade

n partition fo
m partition to

IGELOS

During the critical phase, the device must not be powered off. At this stage in the progress, an
additional warning is shown.

Upgrading base system.
DO NOT POWER OFF YOUR DEVICE!

When the installation is completed, the Upgrade window looks like this:

Upgrade

ng for upgrade tool to start
upgrade

IGELOS 10211
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After a few seconds the device reboots into IGEL OS 11.

]

Local Terminal

\\LH///
Z-1GEL

Congratulations
Z *  The upgrade to IGEL OS 11 is now
complete.

<) | 10:29

When the upgrade test has been successful, you are ready to set up the mass upgrade. Continue with Checking the
Requirements (see page 197).
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Checking the Requirements

The following requirements must be met:

The upgrade has been tested with characteristic devices; see Testing the Upgrade (see page 162).
UMS 6.01.130 or higher is available.

The firmware IGEL OS 10.05.700 or 10.05.800 is known to the UMS. For this purpose, a device

with OS 10.05.700 or 10.05.800 must be registered in the UMS. This is already the case if you tested
the upgrade (see Testing the Upgrade (see page 162)) with the same UMS with which you are about to
do the mass upgrade. If not, you must register a device with OS 10.05.700 or 10.05.800 now.

All devices are connected to a regular LAN (not OpenVPN, OpenConnect, genucard, NCP VPN or
mobile broadband).

All devices are in a safe environment where the upgrade process cannot be disrupted, e.g. by
powering off the devices.
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Configuring Two Update Buddies
For setting up buddy updates, see the How-To Buddy Update (see page 221).

© Ensure that the network contains only the update buddies and the devices that are to be updated. This
prevents other devices from updating inadvertently.

1. Update one device to the appropriate IGEL OS 10 firmware (10.05.700 or higher) and configure it as
an update buddy.

2. Upgrade another device to IGEL OS 11 and configure it as an update buddy. Make sure that the
IGEL OS 11 update buddy has the same User Name and Password in System > Update > Buddy
Update as the IGEL OS 10 update buddy.

When the update buddies are configured, continue with Creating a Profile (see page 199).
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Creating a Profile

1. Create a profile which is based on the appropriate IGEL OS 10 firmware version (10.05.700 or
higher). Find a suitable name for the profile, e.g. "Firmware upgrade to IGEL OS 11".
2. Inthe profile's configuration dialog, go to System > Update > Firmware Update and change the
settings as follows:
+ Select "FTP" as Protocol.
+ Enter User Name and Password according the update buddy server.
+ Activate Automatic Update Check on Boot.
« Ensure that Automatic Update Check on Shutdown is deactivated. Otherwise, the device
will shut down when the update is finished.
+ Activate Automatic Buddy Detection.

Allow firmware upgrade te IGEL 0S5 11

Related Configurations

A
A

A

€ » FIPUSER

Search

3. Go to System > Update > 0OS 11 Upgrade and change the following settings according to your
successful upgrade test:
« Activate Upgrade to OS 11.
+ Set Upgrade to OS 11 even if PowerTerm is enabled according to your needs.
+ Set Require an Enterprise Management Pack license to upgrade to OS 11 according to
your needs.
+ Set Timeout waiting for OS 11 license to start automatic upgrade to 10 Minutes.
4. Go to System > Remote Management and change the settings as follows:
« Deactivate Display 'Apply changes' dialog on boot.
+ Set Default action on boot to Apply changed configuration immediately.
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Allow firmware upgrade te IGEL 0S5 11
14 > A ! * Rel

Configuration

a0
Timeout

Defal

A

Timeout

Search

5. Click Save.

When the profile is created, continue with Deploying the Licenses (see page 201).
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Deploying the Licenses
Deploy the licenses for IGEL OS 11 using the method that suits your needs:

+ Automatic License Deployment (ALD): Licenses are created and deployed automatically to each
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).

+ Manual License Deployment: Licenses are created and deployed manually. For instructions,
see Manual License Deployment for IGEL OS.

When the license deployment is set up, continue with Putting It All Together (see page 202).
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Putting It All Together

1. Assign the profile to all devices that are to be upgraded. This can be done by assigning the profile
to the directory that contains these devices.

© Do notassign the profile to the update buddies.

2. Inthe context menu of the assignment, select Now.
3. For Automatic license deployment, a condition can be set to the directory. For more information,
see Configuring the Distribution Conditions, section "Distributing Licenses to Devices in a

Specified Directory".

When everything is in place, continue with Executing the Upgrade (see page 203).
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Executing the Upgrade

1. Inthe UMS,; select all devices that are to be upgraded and reboot them.

() Alternatively you can create a scheduled job for reboot or wake up and assign it to the devices or
the directory containing these devices; for more information, see Jobs.

On reboot or wake up, the devices choose the IGEL OS 10 buddy. They ignore the IGEL OS 11 buddy
at this stage because this version is not known to them yet. The devices update to the appropriate
version of IGEL OS 10 (10.05.700 or higher). With this version, the Upgrade to OS 11 parameter is
recognized by the devices; also, the devices request IGEL OS 11 licenses from the UMS (Workspace
Edition and, if required, Enterprise Management Pack).
If no IGEL OS 11 licenses have been deployed on the devices yet, the licenses are deployed within a
few minutes. The upgrade will be started when the licenses are deployed. The maximum time
period the device will wait for a license is configured by the parameter Timeout waiting for 0S 11
license to start automatic upgrade; for details, see Adjusting the Setup (see page 159).
The parameters Automatic update check on boot and Automatic buddy detection cause the
devices to look for a new firmware and wait for an IGEL OS 11 update buddy to reply. When an IGEL
0S 11 update buddy is found, the devices start the upgrade process.

2. When all devices have been upgraded successfully, remove the "Firmware upgrade to IGEL OS 11"
profile.

The upgrade is complete.
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Mass Deployment Using a Scheduled Job

This scenario is appropriate if you already have a working environment with IGEL OS 10.05.700 (or higher) and want
to update all devices to IGEL OS 11 at a defined time.

Read all the following chapters carefully and follow the instructions.

1. Checking the Requirements (see page 205)
Creating a Profile (see page 206)
Deploying the Licenses (see page 210)
Assigning the Profile (see page 211)
Executing the Upgrade (see page 181)

ok wnN
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Checking the Requirements
The following requirements must be met:

+ The upgrade has been tested with characteristic devices.

+ UMS6.01.130 or higher is available.

+ The appropriate IGEL OS 10 firmware version (10.05.700 or higher) is known to the UMS. For this
purpose, a device with this firmware version must be registered in the UMS. This is already the
case if you tested the upgrade with the same UMS with which you are about to do the mass
upgrade. If not, you must register a device with the appropriate IGEL OS 10 firmware version now.

+ All devices are connected to a regular LAN (not OpenVPN, OpenConnect, genucard, or mobile
broadband).

+ All devices are in a safe environment where the upgrade process cannot be disrupted, e.g. by
powering off the devices.

When all requirements are met, continue with Creating a Profile (see page 206).
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Creating a Profile

1. Create a profile that is based on the appropriate IGEL OS 10 firmware version (10.05.700 or higher).
Find a suitable name for the profile, e.g. "Scheduled firmware upgrade to IGEL OS 11".

New Profile

Prafile Marne Scheduled firrmware upgrade to IGEL 08 11

Cancel

2. Inthe profile's configuration dialog, go to System > Update > Firmware Update and change the
settings according to your environment:

@ Ifyou use Universal Firmware Update (see page 167) for OS 11, you do not need to configure the
settings described in this step.

+ Select an update source for IGEL OS 11. For further information, see Firmware Update.
() Ifyou use FILE as the protocol (local file or network drive), the device will show an error
message and go through an additional reboot. Apart from that, the upgrade will work

normally.

« Ensure that Automatic Update Check on Boot and Automatic Update Check on
Shutdown are deactivated.

(@ Inthefollowing screenshot, FTP is used as an example. The other protocols can be used as
well.
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Scheduled firmware upgrade to IGEL OS 11
< > A

) ol Related Configurations
uration
ne €) » itgafileigellocal
a.v £11.01.100
a .,
|y -

Search

3. Go to System > Update > 0OS 11 Upgrade and change the following settings according to your
successful upgrade test (for details of the settings, see Adjusting the Setup (see page 159)):
« Activate Upgrade to OS 11.
Set Upgrade to OS 11 even if PowerTerm is enabled according to your needs.
Set Upgrade to OS 11 even if a previous upgrade attempt failed according to your needs.
+ Set Require an Enterprise Management Pack license to upgrade to OS 11 according to
your needs.

Ensure that the Timeout waiting for OS 11 license to start automatic upgrade is set to 10
Minutes.
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Scheduled firmware upgrade to IGEL OS 11

> Upda

Search

4. Go to System > Remote Management and change the settings as follows:
« Deactivate Display 'Apply changes' dialog on boot.
+ Set Default action on boot to Apply changed configuration immediately.
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Allow firmware upgrade te IGEL 0S5 11
14 > A ! * Rel

Configuration

a0
Timeout

Defal

A

Timeout

Search

5. Click Save.

When the profile is created, continue with Deploying the Licenses (see page 210).
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Deploying the Licenses
Deploy the licenses for IGEL OS 11 using the method that suits your needs:

+ Automatic License Deployment (ALD): Licenses are created and deployed automatically to each
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).

+ Manual License Deployment: Licenses are created and deployed manually. For instructions,
see Manual License Deployment for IGEL OS.

When the license deployment is set up, continue with Assigning the Profile (see page 211).
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Assigning the Profile

1. Putall devices that are to be updated into a directory.

2. Select the directory and in the Assigned objects area, click @

Server -172.30.92.9
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3. Assign the profile (see Creating a Profile (see page 206)) to the directory and click Ok.
New Scheduled Job

Select assignable objects
Selected aohjects

¥ [ Deyi A4 8 Upgrade to IGEL 05 11

Finish

4. In the context menu of the assignment, select Now.

Update time

When the profile is assigned, continue with Creating the Scheduled Job (see page 213).
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Creating the Scheduled Job
1. Inthe UMS, select Jobs > New Scheduled Job.

Server -172.30.92.9

T

rade to IGELOS 11".
Mew Scheduled Job

Details

V' Enabled

Options
v Lc

I

Timeout

Job-Info

Joh D

Finish
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3. Under Command, select OS 11 Upgrade.
New Scheduled Job

Details

Mame Upgrade to IGEL

v Enabled

Options
VL
Th
Timeout
Job-Info

Joh D

Apri0,

Einish

4. Under Execution time and Start date, set the time at which the upgrade should be executed, and
click Next.
New Scheduled Job

Details

MName Upgrade to IGEL

Command 11 Upgrade

Execution time 11:02 Start date 201 12 v Enabled

Commaent

Options

v Log results Retry next boot

Max. Threads Delay 0 Seconds
Timeout

Job-Info

Job 1D

MNext Execution

User

Next Finish
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5. Review the execution time and click Next.
Mew Scheduled Job
Schedule
Execution time

ration date

Repeat Joh

1] day I hour

Man Tue

Comment

Cancel job execution

Einish

6. Assign the directory containing the devices to the job and click Finish.
New Scheduled Job

Select assignable objects

Finish
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Troubleshooting

This section describes possible error cases and solutions.
+ Regaining a Usable System (see page 217)
+ Getting Error Messages (see page 218)

+ Starting a New Upgrade Attempt (see page 219)
+ Starting Another Upgrade Attempt after 5 Retries (see page 220)
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Regaining a Usable System

Here you can find typical upgrade failures and the appropriate methods to regain a usable system.

Device Has Upgraded to Igel OS 11, but Does Not Boot Any More
To get a working IGEL OS 11 system:

» Use the IGEL OS Creator to recover the IGEL OS 11 system. For more information, see the IGEL OS Creator
Manual.

IGEL OS 10 Rescue System Fails to Update Missing Partitions

If a severe error has occurred during the upgrade process, the device boots into a minimal 10.05.700 (or higher)
rescue system. If unattended, the device tries to download and update the missing partitions and reboots on
failure.

To regain a full IGEL OS 10 system, you have two possibilities:

» In the rescue system, start the Setup, go to System > Update > Firmware Update and set a valid update source
for the appropriate IGEL OS 10 firmware version (10.05.700 or higher).

Or:

> Configure a UMS profile that contains a valid update source for the appropriate IGEL OS 10 firmware version
(10.05.700 or higher) under System > Update > Firmware Update and assign it to the device.
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Getting Error Messages

> Open the 0S 11 Upgrade Tool (default path: click E] System and then Upgrade to OS 11).

The OS 11 Upgrade Tool shows the error messages. The most important message is prefixed with Retries; see the
example below:

05 11 Upgrade

& Hardware
ﬁ License
I:E!::I SEtup

ﬁ Lipdate Saiante

IGELOS10-211

Stup: The upgrade Lo OS 11 has faled previously. To try sgain acthvate Upgrade to IGEL 05 11 even f a
mwmwm‘w?w} m.
Retries: Could not write the new System partition to permanent Storage.

Closa Chachk again

> Formore information, review the main migration log under /wfs/migration.log

() You can use the system log viewer to review the migration log (see the chapter System Log Viewer in the
IGEL OS Manual) or save the log files in order to send them to the IGEL Support Team (see the chapter Save
Device Files for Support support).
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Starting a New Upgrade Attempt
If you want the device to start multiple upgrade attempts (and the device is not already configured to do so):

1. Inthe UMS profile or in the Setup, go to System > Update > OS 11 Upgrade and activate Upgrade
to OS 11 even if a previous upgrade attempt failed.
2. Reboot the device.
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Starting Another Upgrade Attempt after 5 Retries

When the Upgrade to OS 11 even if a previous upgrade attempt failed option is set and the upgrade has failed
each time, the system will stop trying after 5 attempts.

To reset the retry counter:

1. Inthe Setup or the UMS profile, go to System > Update > OS 11 Upgrade and deactivate Upgrade
to OS 11 even if a previous upgrade attempt failed.

2. When the setting is effective on the devices, go to System > Update > OS 11 Upgrade again and
activate Upgrade to OS 11 even if a previous upgrade attempt failed..
The retry counter is reset, and the devices will try upgrading another 5 times, if necessary.
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Buddy Update

A certain number of devices that are running IGEL OS in your company regularly need to be updated. If every device
accesses the main update server individually, maybe even over a great geographical distance, the update could
take quite a long time and might overload the entire connection.

Update
Server

~ Internal network .

-
- -

Set up one of your devices as a so-called buddy update server. In the future, only this client will access the main
server to download the updates. All other clients access the local buddy update server from within the network and
will no longer offload the network outside.
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Update
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(@ Thebuddy update server is always an FTP server.

For the configuration details, see:

+ Configuring the Buddy Update Server (see page 224)
+ Configuring the Buddy Update Client (see page 225)

TechChannel
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Sorry, the widget is not supported in this export.
But you can reach it using the following URL:

https://www.youtube.com/watch?v=IVUIFtOT5uE
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Configuring the Buddy Update Server

Basic Configuration

1. Inthe Setup, go to System > Update > Buddy Update.
Activate Enable Update Server.

Enter the credentials User Name and Password.

Specify the maximum number of Concurrent Logins allowed.
Click Save to confirm the changes.

Perform a complete firmware update on the server.

Reboot the server.

NoohkwnN

@ Whenever a buddy update server has received a firmware update, it needs to be rebooted
before it can distribute the new firmware to other devices.

Configuration for Different Firmware Versions
This feature is available for the following versions of IGEL OS:

+ IGEL 0OS 10: 10.06.100 or higher
« IGEL0S 11:11.02.100 or higher

If you have an environment which requires two or more different firmware versions running simultaneously, you
can use the buddy update method to provide each buddy update client device with the appropriate firmware
version. A typical use case might be two groups of employees, of which one requires an older version of the
browser, or an older version of the Citrix receiver, whereas the other group should get the newest version of IGEL
0S. This is achieved by dividing both the clients and the servers into groups. To each group, a specific firmware
version is assigned by first installing that version on the group's update servers. As an example, you can assign
group 1 to IGEL 0S 10.07.100, and group 2 to IGEL OS 10.08.100.

In the following description, the local Setup is used for simplicity reasons; however, in a productive environment, it
is recommended to use profiles. For further information, see Profiles.

To assign a server to a group:

1. Configure the server as described above (Basic Configuration (see page 224)), using the firmware that
is to be assigned to this group.

In the Setup, go to Registry > update > ftp > buddy_group_id.

In the field Buddy Group ID, set the appropriate group id. Unsigned integers are allowed.

Click Ok.

Reboot the device.

The device will provide the firmware update for the group it is assigned to.

oW

For client configuration, see Configuring the Buddy Update Client (see page 225), "Configuration for Different Firmware
Versions".
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Configuring the Buddy Update Client

Basic Configuration

1. Inthe Setup, go to System > Update > Firmware Update.
2. Setthe following parameters:
Server Name: IP address of the buddy update server
Port: 21 (default with FTP protocol)
Server Path: -
User Name: User name of the buddy update server
Password: Password of the buddy update server

@ Ensure that all servers in the network use the same credentials. For security reasons, you
have to enter them in the upper mask, even if you did not specify a server.

3. Activate Automatic Update Check if you want the client to check automatically during the boot
process whether new updates are available on the server.

4. Activate Automatic Buddy Detection if you want the client to look for a buddy update server on
its own.
This is useful if you work with more than one buddy update server and do not wish to determine a
specific one.
In this case, you do not need to define the Server Name, Port and Server Path. If you enter a
server name anyway, the system treats this server as a fall-back. Thus, you can be sure that the
system accesses at least this one server if it cannot find any others.

5. Click Ok.

6. Continue with further configuration changes or reboot the device.

Configuration for Different Firmware Versions
The feature is available for the following versions of IGEL OS:

+ IGEL 0OS 10: 10.06.100 or higher
« IGEL0OS 11:11.02.100 or higher

This feature is described under Configuring the Buddy Update Server (see page 224), "Configuration for Different
Firmware Versions".

In the following description, the local Setup is used for simplicity reasons; however, in a productive environment, it
is recommended to use profiles. For further information, see Profiles.

To assign a client to a group:

1. Inthe Setup, go to Registry > update > ftp > buddy_group_id.
2. Inthe field Buddy Group ID, set the id of the group to which the desired firmware is assigned.
3. Click Ok.
4. Reboot the device.
The device will use the firmware update for the group it is assigned to.
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Balancing the Server Load
This feature is available for the following versions of IGEL OS:

+ IGEL OS 10:10.06.100 or higher
+ IGEL0OS 11:11.02.100 or higher

Itis possible to balance the load between several buddy update servers. If System > Update > Firmware Update

> Automatic Buddy Detection is activated, the clients send a broadcast in their network to determine which buddy
servers are available. Each server that responds within a fixed timeout is added to a list whose maximum length can
be defined. When the list is complete, either because its maximum length is reached or because the timeout has
expired, the client selects a random server from the list. This way, the load of the buddy servers is distributed
evenly.

To configure a client for balancing the server load:

1. Inthe Setup, go to Registry > update > ftp > buddy_server_candidates.

2. Inthe field Buddy Update Server Candidates, enter the maximum number of servers the client
should collect. If the number is 1, the server that responds first is selected.

Click Ok.

4. Reboot the device.

w
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Firmware Update

Here we show you the best practice of downloading a firmware update from our download server and distributing it
to various devices in your company:

1. Check our download server® to see whether there are new updates which are relevant for your
applications.

2. Download the relevant update files.
3. Install an update directory for them on the UMS server or on your FTP server.
4. Assign this update directory to your devices.
5. Start the update process manually or via a Scheduled Job (see page 229).
Download
server
A FTP
Server 3 Assign updates
o >
(2]
Q
g A
©
(o
=
> A
@©
o
E 2 Download updates
(O]
<
4 Execute updates

+ Downloading Updates and Storing them on an FTP Server (see page 228)
+ Executing an Update Process (see page 229)

23 https://www.igel.com/software-downloads/
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Downloading Updates and Storing them on an FTP Server

You can save the update files either directly on the UMS server or you can put them on your captive FTP server. If
you have many devices to be updated, you should work with the FTP server because it makes it easier to distribute
large amounts of data in the local network.

Preparation

1. Click Universal Firmware Update in the UMS Administration area of UMS console.
Click Edit... .

Enter your FTP server under Host, to save the update files in this location.

Add further details like storage path and access data for the server.

Save your settings and click Test Server Connection.

ok N

Downloading updates

1. Right-click Universal Firmware Update on the UMS console tree.

2. Choose Check for new firmware updates from the context menu.

A window opens with a list of all updates associated with the firmware versions registered in the
UMS database.

Choose a Version in the drop-down-list.

Click Information to see the release notes of each update.

Activate the check box Include for downloading a certain update.

Click Download to start the process.

The update will be added to the tree and the current processing status will be shown.

The unpacked firmware files are finally in the target directory on the FTP server.

oA W

Assigning updates to the thin clients

Assign the downloaded update by dragging and dropping to your device directory. Now, if you click this directory
you can see the firmware update in the right window under Assigned objects. The devices will now know where to
find the firmware update in the event of an update command.
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Executing an Update Process

1. Create one or more new Views to distinguish which thin clients will get the new update.
2. Create a new Job, called "firmware update" for example.
. Specify on the Schedule tab when you want the update to be performed.

w

(@ The Repeat job option should not be activated for Update, Update on boot or Update on
shutdown commands.

4. Add one or more Views on the Assignment tab.
5. Save thejob.

The update process will be performed according to the schedule specified in the job.
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Updating IGEL OS Using a USB Storage Device

You can use a USB storage device to update IGEL OS locally. This method is particularly suitable if only one device
oronly a few devices are to be updated and it would not be worth installing an FTP or HTTP server purely for the
update.

To update the device's firmware without having access to the local setup, follow Updating the Firmware using the
Linux Console (see page 232).

To update IGEL OS using a USB storage device, proceed as follows:

1.

10.

11.

Download the update file (.zip) for your device from the IGEL download server®,
Unpack the update files and save them to a USB storage device.
@ You can find the officially supported file systems under Storage Hotplug.
Open the IGEL Setup on the device and select Devices > Storage Devices > Storage Hotplug.
Set Client Drive Mapping to Static.
Enable Private drive letter for each storage drive.
Set Number of drives to at least 1.
Apply the changes so that they are effective for the device.
@ You can find more information under Storage Hotplug.
Connect the USB storage device to the device and wait until the device has been detected.
Go to System > Update > Firmware Update.

Set Protocol to FILE.

Start the file chooser (Server path) and navigateto /userhome/media/label of the

USB storage device/ lxos.inf andclick Open.

() Do NOT use spaces in the USB device name.

24 https://www.igel.com/software-downloads/workspace-edition/

IGEL OS Articles 230/823


https://www.igel.com/software-downloads/workspace-edition/
https://www.igel.com/software-downloads/workspace-edition/

Update and Upgrade

e

IGE

12. Click Update firmware and confirm the warning message.
The device will reboot while updating the firmware. Do not remove the USB device until the

update has finished.

& Make sure you do not boot from the USB storage device. You might need to change the boot order in the
BIOS/UEFI.
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Updating the Firmware using the Linux Console

Issue

You have to update the device's firmware without IGEL Universal Management Suite or local IGEL Setup application.

Solution
The device's firmware update can also be carried out directly on the Linux console itself without IGEL Setup:

1. Restartthe device.

Press [ESC ]key during booting to bring up the boot menu.

Select Verbose Boot from the boot menu.

When instructed, switch to the console by pressing [CTRL-ALT-F11] or [CTRL-ALT-F12].
Press [RETURN Jkey to login.

You may have to enter your password.

oW

Carry out the update. The exact procedure varies according to the protocol which is to be used, that is, FILE, HTTP,
or FTP; see the instructions below. You can check whether the correct parameter values have been passed using the

get command,e.g. get update.protocol

HTTP

1. If necessary, set up a static IP address (DHCP is active by default)
setparam network.interfaces.ethernet.device0.usedhcp false

setparam network.interfaces.ethernet.device®.manual true
setparam network.interfaces.ethernet.device0.ipaddr

setparam network.interfaces.ethernet.device®.netmask
2. Configure the update server
setparam update.protocol http

setparam update.http.server

setparam update.http.port

® The default UMS portis 9080

setparam update.http.path
setparam update.http.user

setcryptparam update.http.crypt_password
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3. Startthe update processinthe / directory usingthe command update

FTP

1. If necessary, set up a static IP address (DHCP is active by default)
setparam network.interfaces.ethernet.device0.usedhcp false

setparam network.interfaces.ethernet.device®.manual true
setparam network.interfaces.ethernet.device0.ipaddr

setparam network.interfaces.ethernet.device®.netmask
2. Configure the update server
setparam update.protocol ftp

setparam update.ftp.server

setparam update.ftp.port

® The default portis 21

setparam update.ftp.path
setparam update.ftp.user
setcryptparam update.ftp.crypt_password

3. Startthe update processinthe / directory usingthe command update

FILE

(@ Requirement: The unpacked update files are available in the root directory of a USB storage device.

1. Configure at least one hotplug USB device:

setparam devices.hotplug.usb-storage.numdevices 1
2. Apply your changes:

kill_postsetupd

Connect the USB storage device to the device.
Wait for the USB storage device to be mounted automatically.
5. Determine the mount point:

1ls /media/
6. Configure the update parameters:

> w

setparam update.protocol file

setparam update.file.path /media/<name of USB storage device>
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7. Startthe update processinthe / directory usingthe command update
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Citrix
« Performance (see page 236)
* Mouse (see page 243)
« How to Configure Citrix Native USB Redirection (see page 249)
+ Mapping USB Storage Media into Citrix Sessions (see page 251)
+ Auto-Hide Toolbar in Appliance Mode (see page 253)
+ Create a Seamless, Transparent User Experience with Appliance Mode (see page 254)
« Connecting to a Citrix Farm (see page 255)
+ Create a Self-Service Setup for the User with Quick Settings (see page 262)
+ Login Failed because of the Expired AD Password (see page 264)
« Configuring Auto Logon for Citrix Virtual Desktops (see page 266)
+ Force Citrix Logout Using Hotkey (see page 270)
« Citrix: Freeze at Logout (see page 271)
« Warning Message: [Citrix Store] Could Not Connect to the Citrix Server (see page 273)
« Setting up Citrix Sessions with Hardware-Accelerated H.264 Deep Compression Codec (see page 275)
+ Using Font Smoothing (ClearType) in Citrix Sessions (see page 276)
+ Highly Secured XenServer has Problems with LD_BIND_NOW Workaround (see page 278)
« Workaround for Citrix Receiver X Error (see page 279)
o Citrix HTML5 Receiver Issue (see page 280)
+ Macbook Keyboard Layout inside Citrix Session (see page 281)
+ Using Lync / Skype for Business with Citrix HDX RealTime Optimization Pack (see page 282)
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Performance

+ Poor Performance: Black Blocks and Stripes in Citrix Sessions (see page 237)

« Poor Performance with Citrix XenDesktop 7.6 Deep Compression (see page 238)
Citrix Receiver: Grey Blocks in Excel 2013 (see page 239)

« Bar Code Scanning is Slow via Citrix (see page 240)

Slow Performance of Citrix Session in a Cloud Environment (see page 241)
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Poor Performance: Black Blocks and Stripes in Citrix Sessions

Symptom

In the Citrix session, you sometimes experience a problem with black blocks, frames, or stripes.

Problem

Poor performance is often connected with the delayed or slow refreshing of the screen content.

Solution

» Inthe IGEL Setup or the configuration dialog in the UMS, activate one of the following parameters or all of them
under Sessions > Citrix > Citrix Global > Options:

+ Use server redraw
+ Backing store
« Deferred screen update mode

s P Citrix ™ Citrix Global ™ Options

ﬂ o Vv Use server redraw
ﬂ < V' Backing store
) ¥ Deferred screen update mode

ent Selection .
Cac zein kB

server Location Minimum bitmap size in bytes
Persistent cache path

Scrolling control

Audio bandwidth limit in StoreFront

A

Maximurm retries &

Apply and send to device Save Cancel

See also Options in the manual chapter for Citrix.
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Poor Performance with Citrix XenDesktop 7.6 Deep Compression

Symptom

When using XenDesktop 7.6 on Windows Server 2008R2 with Citrix Receiver 13.0.4, 13.1.4 or 13.2.1 with H.264 Deep
Compression Codec, dragged Windows lag and the performance is generally poor.

Problem

Server and/or client do not have enough computing power for the H.264 Deep Compression Codec.

Solution

Enable the legacy graphics mode on the XenDesktop 7.6 server via a policy.
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Citrix Receiver: Grey Blocks in Excel 2013

Symptom

When using Microsoft Excel 2013 on XenDesktop 7.6 with Citrix Receiver 13.1.3, 13.1.4 or 13.2, grey blocks appear
especially if you mark multiple cells.

Problem

Codec parameters may not be optimal for this use case.

Solution

1. InIGEL Setup, go to Sessions > Citrix > Citrix Global > Codec.
2. Disable Text Tracking.
3. Disable Small Frames Feature.

Additional parameters for H.264 Deep Compression Codec
[] Accelerated H.264 Deep Compression Codec

€) [ ] Text Tracking

€) [} small Frames Feature
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Bar Code Scanning is Slow via Citrix

& Solution Based on Experience from the Field

This article provides a solution that has not been approved by the IGEL Research and Development
department. Therefore, official support cannot be provided by IGEL. Where applicable, test the solution
before deploying it to a productive environment.

Issue

Bar code scanning is slow via Citrix.

Environment

+ Firmware version: any
+ UMS version: any

Description

USB attached bar code scanner is very slow via Citrix.

Solution

In order to pass the Bar Code scanner through correctly, you want it to be a HID so it passes through as a HID
instead of using Native USB Redirection. A quick way to determine that would be to open a terminal in IGEL OS and
simply scan something. If it populates data in the terminal, then it is configured as HID. Also, check the
configuration guide for the particular scanner that you are using. The config guide is simply a bunch of barcodes
that the device can scan. Once a code is scanned, the device beeps twice, and that changes the config on the
scanner. On some devices, there is a setting for Alternate OS Linux/MACOS. The default setting for the scanner
usually doesn't enable this. Once the setting was set, everything scanned very fast and that same speed was shown
in Citrix.
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Slow Performance of Citrix Session in a Cloud Environment

Symptom

Your cloud-based Citrix session is very slow.

Environment

+ IGEL OS 10.05 or higher, up to IGEL OS 11.05 (with IGEL OS 11.06 or higher, the default setting has
changed)

« Citrix client is connected to a cloud server. NOT affected: On-premises and Netscaler
environments

Problem

The HDX transport protocol is set to "UDP with fallback to TCP", which causes slow performance.

Solution

1. Open the UMS configuration dialog or the local Setup and go to Citrix > Citrix Global > Options.
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<
.

IGE

tive Transport over EFT to"TCP only UDP disabled" and click Apply or Ok.

Global » Options

r

2. Set HDX Adap

Ll « ® Citri

lert sounds

Deferred en update mode

Cache size in kB 1024
Minimum bitmap n bytes 1024
Pe nt cache path $ICAROOT/cache
Scrolling control 100
Audio bandwidth limit in StoreFront se high

v Auto reconn
Maximum retries
Delay in seconds before reconnecting

V' Allow Kerberos passthrough authentication in StoreFront
CGP address disabled

Mu am

HDX Adaptive Transport over EDT | TCP only - UDP disabled
lI.JI':IP without fallback ta TCP
TCP only - UDP disabled
(9] Tallback to 1er

Apply

When the Citrix client is started again, the performance should be better.

IGEL OS Articles 242 /823



Citrix

Mouse

« Changing Middle Mouse Button Function for Citrix Session and Local Firefox Browser (see page 244)
+ How to Connect a SpaceMouse with a Citrix Session (see page 246)
+ Solve SpaceMouse USB Reset Problem (see page 248)
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Changing Middle Mouse Button Function for Citrix Session and Local Firefox
Browser

Middle mouse button cannot be used for smooth scrolling within applications like Excel or Internet Explorer within a
Citrix session or with the local Firefox browser.

The default function of the middle mouse button is copy and paste.

> Open IGEL registry in local client setup or UMS.

< > ' [ » System M Registry

Configuration Search parameter ... ica.wfclient. mousesendscontroly

=essions B keyboardtype :
S e B keypassthroughescapechar
User Interface B keypassthroughescapeshift
Metwork B argecachesizeink
T B lcgoffdesktopthrotwi
i B mousedoubleclickheight
= B mousedoublaclicktimer
ylem B mousedoubleclickwidth
Il Time and Date B mousesendscontroly
> I Update . mousetimer
: : 2:?2: :Cacr;zgsement B palettechangetimeout
» [ Power Options i persistentcacheminbitmap Allow Middle Button Paste
» I Firmware Customization B persistentcachepath ] allow Middle Button Paste
‘ Registry i persistentcachepercent W
[ RN R

> For Citrix sessions change:

+ System > Registry > ica.wfclient.mousesendscontrolv
+ System > Registry > sessions.ica%.appsrv.mousesendscontrolv

» For local Firefox browser change:

+ System > Registry > browserglobal.app.middlemouse_contentloadurl
« System > Registry > browserglobal.app.middlemouse_paste

More information on the Firefox parameters can be found at

http://kb.mozillazine.org/Middlemouse.contentLoadURL
http://kb.mozillazine.org/Middlemouse.paste
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The changes will take effect after rebooting the thin client.
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How to Connect a SpaceMouse with a Citrix Session

This article describes how to use a 3Dconnexion SpaceMouse in a Citrix session.

© Always use a SpaceMouse only as an additional, i.e. second, mouse.

() From version 10.06.100 or 11.02.100 on, the SpaceMouse does not interfere anymore with the local
mouse pointer because of a registry key which is enabled by default.
This registry parameter ignores the SpaceMouse for the IGEL graphical user interface:

IGEL Setup System > Registry

Parameter Deactivates 3Dconnexion/Logitech SpaceMouse
products as a standard mouse

Registry Key userinterface.mouse.spacemouse.x11l_igno
re

Value enabled/disabled

"enabled" means that the SpaceMouse is passed
through to the session and ignored by the local GUI.
"disabled" means that the SpaceMouse is also used for
the local GUI.

To configure the SpaceMouse for Citrix sessions:

1. In Setup, go to Sessions > Citrix > Citrix Global > Native USB Redirection.

Activate the checkbox Native USB Redirection.

Set the Default rule to Deny.

Add a device exception rule as in the following screenshot with the Vendor ID and Product ID of
your specific SpaceMouse:

SpaceMouse products included (VID, PID, Vendor, Product)

Eall

+ 0x046D; 0xC603; Logitech, Inc.; 3Dconnexion Spacemouse Plus XT

+ 0x046D; 0xC605; Logitech, Inc.; 3Dconnexion CADman

+ 0x046D; 0xC606; Logitech, Inc.; 3Dconnexion Spacemouse Classic

+ 0x046D; 0xC621; Logitech, Inc.; 3Dconnexion Spaceball 5000

+ 0x046D; 0xC623; Logitech, Inc.; 3Dconnexion Space Traveller 3D Mouse
+ 0x046D; 0xC625; Logitech, Inc.; 3Dconnexion Space Pilot 3D Mouse

+ 0x046D; 0xC626; Logitech, Inc.; 3Dconnexion Space Navigator 3D Mouse
+ 0x046D; 0xC627; Logitech, Inc.; 3Dconnexion Space Explorer 3D Mouse

+ 0x046D; 0xC628; Logitech, Inc.; 3Dconnexion Space Navigator for Notebooks
+ 0x046D; 0xC629; Logitech, Inc.; 3Dconnexion SpacePilot Pro 3D Mouse

+ 0x046D; 0xC62B; Logitech, Inc.; 3Dconnexion Space Mouse Pro

+ 0x256F; *; 3Dconnexion; SpaceMouse
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Add

Rule v

VendoriD €} /

ProductiD €}

Name €) / SpaceMouse Pro

5. Save the settings.

Now, the SpaceMouse is ready for use.

() To achieve that the mouse behaves as usual in CAD programs, change the configuration as follows:
1. Go to IGEL Setup > System > Registry > ica.wfclient.mousesendscontrolv.
2. Setthe parameter to disable.

& fthe SpaceMouse does not function properly after the previous Citrix session, the USB reset of
the SpaceMouse must additionally be configured. Follow the instructions in Solve 3Dconnexion
SpaceMouse USB Reset Problem (see page 248).
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Solve SpaceMouse USB Reset Problem

Environment
Valid for IGEL hardware H850C, H830C, and M340C

Problem

After a previous Citrix session, the SpaceMouse does not function properly (e.g. after the end of the Citrix session,
the reset of the SpaceMouse does not take place; as a result, the display of the SpaceMouse always remains bright).

Solution
Use a power cycle command to automatically turn all USB devices off and on again:

1. InIGEL Setup, go to System > Firmware Customization > Custom Commands > Post Session.
2. Under Session type, select Citrix.

3. Under Post session command, enter the following command: /etc/igel/usb-power-

reset/igel-usb-power-ctl -p cycle

() Youdo not need root permissions for this action.
As a result of the configured USB power cycle, after the end of the Citrix session, the display of the SpaceMouse

should become dark for about 1 second and then bright again.

See also How to Connect a SpaceMouse with a Citrix Session (see page 246).
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How to Configure Citrix Native USB Redirection

Native USB Redirection redirects most popular USB devices to the Citrix session. To use this feature, you must
have at least XenDesktop 7.6 installed. In addition, the guidelines for USB redirection must be defined. More
information can be found on the following pages

« Citrix Generic USB Redirection Configuration Guide®
« Generic USB redirection and client drive considerations®®

The following types of USB device are not supported by default for use in a Citrix Virtual Apps and Desktops
session:

+ Bluetooth dongles
+ Integrated NICs
+ USB hubs

The following types of device are supported directly in a Citrix Virtual Apps and Desktops session, and so do not
use USB support:

+ Keyboards
+ Mice

« Smart cards
+ Headsets

+ Webcams

In addition to the server policies, the USB redirection must also be activated at the client:

1. In Setup, go to Sessions > Citrix > Citrix Global > Native USB Redirection.
2. Enable Native USB Redirection.
3. Set the Default rule to Deny or Allow:

+ Allow: All devices that are allowed by default are redirected.

« Deny: No device is redirected.

@ Tip
To secure your endpoint, it is generally recommended to set Default rule to Deny and to
configure Allow rules only for the required USB devices and USB device classes.

4. To customize the USB redirection, you can create classes or device rules to redirect e.g. Bloomberg
keyboards or 3D Spacemouse.

() Getting USB Device Information

To find out the Class ID, Subclass ID, Vendor ID and Product ID of the connected USB device, you can use
the System Information tool. For further information, see Using “System Information” Function.
System Information example:

25 https://support.citrix.com/article/CTX137939
26 https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/general-content-redirection/usb.html
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Devices - USB Devices - System Information

Information View Help

(:) Refresh Generate Report ||_:| Copy to Clipboard  |7¥| Synchronize

g_ Computer

Fil 001:001 | Linux | 2.0 root hub

@ summary 002:001 1.1 root hub
4% Operating System (&) 002:002 [WMware virtual Mouse
@ Security i ub

4§ Kemnel Modules ) 002:004 logitech 960 Headset

@ Boots |
m Languages
B Memory Usage

(== Filesystems

@ Display
[SJ Environment Variables
..... Devices Device Information
g_ System DMI Product [0x0002] 2.0 root hub
Vendor [0x1d6b] Linux Foundation

[ Linux.

@ Monitors Device EHCI Host Controller

Memory Devices Manufacturer Linux 5.12.19 ehci_hcd

o ' [ Linux |

Max Current 0 mA

) USB Version 2.00
S8 Interfaces Speed 480 Mbys
- d -

Done.

Alternatively, you can use the command lsusb (or lsusb | grep -i [search term] )inthe
terminal.
Example for lsusb :
Local Terminal
Fle Edit View Terminal Tabs Help
root@ITCOO5056930CAD :~# lsusb | grep -i logitech

Bus 002 Device 004: ID 046d:0a4d5 , Inc. 960 Headset
root@ITCOO5056930CAD: ~# [

() Foradevice exception rule, use the SpaceMouse Guide (see page 246).
For more information about USB redirection rules, see Native USB Redirection and the documentation of
the respective Citrix Workspace app.
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Mapping USB Storage Media into Citrix Sessions

How to configure USB storage mapping so that users can access USB storage media attached to the IGEL OS device
within Citrix sessions?

(@ The mapping of USB storage devices is possible for "USB mass storage class" devices. The storage of
smartphones and digital cameras is usually accessed via the MTP protocol. Mobile device access via MTP is
available with IGEL Linux 10.04.100 or higher; for more information see the how-to Using Mobile Device
Access (see page 745).

Basic Configuration of the Client

nfigurations
Read/Write i bal - Drive
pping

slobal - Drive

Client Drive Mapping €) Dynamic

Notification
¥ Hotplug b
v Hotplug m

Timeout
15 Seconds

Search

Apply Ok Cancel

Within the IGEL Setup or a UMS profile, you basically need to configure these parameters:

> Activate Devices > Storage Devices > Storage Hotplug > Client drive mapping > Dynamic. This option
activates dynamic client drive mapping. It automatically recognizes new storage media as they are connected to
the endpoint device. The endpoint device beeps and shows a notification while it mounts the new device. The
storage devices automatically become usable on the endpoint and in Citrix ICA Sessions.

© Mounted devices need to be unmounted before they are removed to ensure data integrity. This can be
done via the Disk Utility, the Disk Removal tool, or a tray icon.

Additional Parameters to Check

» The following parameters are set by default, thus storage mapping will work, but maybe for some reason you
have changed these and need to adjust them to allow the storage mapping:
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Sessions > Citrix > Citrix Global > Mapping > Drive Mapping > Drive mapping (set checkmark)
Sessions > Citrix > Citrix Global > Native USB Redirection > Native USB redirection (remove checkmark)

Sessions > Citrix > Citrix Global > Fabulatech USB Redirection > Fabulatech USB redirection (remove
checkmark)

Devices > USB access control > Enable (remove checkmark)

Sessions > RDP > RDP Sessions > [session name] > USB Redirection > Enable Native USB Redirection (set
to Global setting)

Sessions > RDP > RDP Sessions > [session name] > Mapping > Enable Drive Mapping (set to Global setting)

Assigning a Drive Letter within the Session (Optional)

» Incase you not only want to see the drive in the session as e.g. "A on IGEL-123456789", but want to address the
drive with a real drive letter within the session, you may run one of these commands:

subst T: \\tsclient\t

or

net use T: \\tsclient\t

In this example, "T on IGEL-123456789" is assigned to drive letter T: within the session. You may also assign the
mapped drive to another drive letter than is used in its name.

Configuration on the Server Side

On the server side, e.g. with Windows Server 2008R2, a user in the group "Users" with access to the terminal server
will have the mapping default. This is true for a newly installed server. But the mapping can be prevented by
changing the policies:

() Do not allow drive redirection specifies whether to prevent the mapping of client drives in a Remote
Desktop Services session (drive redirection). By default, an RD Session Host server maps client drives
automatically upon connection. Mapped drives appear in the session folder tree in Windows Explorer or
Computer in the format [driveletter] on [computername]. You can use this setting to override this
behavior." Source: https://technet.microsoft.com/de-de/library/ee791794%28v=ws.10%29.aspx
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Auto-Hide Toolbar in Appliance Mode

Environment

IGEL Linux v5.x or newer

Problem
In the appliance mode, the toolbar at the top of the screen is permanently displayed.

You want to configure the toolbar to hide automatically after it loses the focus of the mouse pointer.

Solution

1. InIGEL Setup, go to System > Registry >
userinterface.igel_toolbar.show_always_in_appliance_mode.

2. Disable Show toolbar always in appliance mode.

3. Click Ok to save the changes.

(@ Forthe changes to take effect, you need to restart active appliance mode sessions.
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Create a Seamless, Transparent User Experience with Appliance Mode

With appliance mode, you can confine a device to a specific session. In appliance mode, the device itself fades in the
background, and the session is presented to the user in the most straighforward way. The user will not have to deal
with a Linux desktop, multiple login procedures, switching between windows, or device configuration.

Use the appliance mode to allow access only to one specific session. On device startup, the user is directed
immediately to the login screen of the virtual desktop.

The appliance mode can be applied to the following session types:

« VMware Horizon

« Citrix Self-Service (for published desktops only, not for published applications)
« RHEV/Spice

+ Imprivata

+ RDP MultiPoint Server

« XDMCP for this display

To configure a session that runs in appliance mode:

1. Open the setup and go to Sessions > Appliance mode.
2. Choose the session type of the desired session using the drop-down menu Appliance mode.
3. Configure your appliance mode session as appropriate.

For further information, see the manual chapter Appliance Mode.
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Connecting to a Citrix Farm

By connecting a Citrix farm, your data and applications are kept centrally on a Citrix farm. Applications must now be
delivered instantly to users anywhere on any device.

There are several ways of connecting to a Citrix farm and starting sessions. We describe three best practice variants
below:

« Citrix StoreFront (see page 256): Integrates published applications into the IGEL GUI.
« Citrix Self-Service (see page 257): Users will be directed to a web interface where they will find pre-
defined published applications and they will be able to add more published applications the

server provides.
« Appliance Mode (see page 261): Shows only the web interface of the farm and hides the IGEL GUI

completely.
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Citrix StoreFront

Prerequisites:

484))

Connecting via StoreFront:

WeNO b

10.

11.

12,

Click Sessions in the configuration tree of the IGEL setup.
Click Citrix > Citrix StoreFront > Server.

Click the ADD icon in the Server location window.
The ADD mask opens.

Enter the names or IP addresses of the services sites.
Confirm with OK.

Click Citrix StoreFront > Desktop Integration.
Enter "Citrix Storefront" under Login Session Name.
Choose Desktop as the starting method.

Click OK to save the changes.

Setup closes.

Doubleclick the Citrix icon on the desktop.

The login window opens.

Enter the credentials of a user in the login window.

The published applications of the Citrix farm will appear on the desktop.

Doubleclick an application icon on the desktop to start the program.

IGEL OS Articles

« Trust root certificate in directory /wfs/ca-certs (see Deploying Trusted Root Certificates (see page

256 /823



Citrix

Citrix Self-Service

Prerequisites:

+ Trust root certificate in directory /wfs/ca-certs (see Deploying Trusted Root Certificates)
Connecting via StoreFront:

1. Click Sessions in the configuration tree of the IGEL setup.
Click Citrix > Citrix Self-Service > Server.
Enter the Server, the Path to Store and the Store name of the services sites.
Confirm with OK.
Click Citrix Self-Service > Desktop Integration.
Enter "Citrix Self-Service" under Login Session Name.
Choose Desktop as the starting method.
Click OK to save the changes.
Setup closes.
9. Doubleclick the Citrix icon on the desktop.
The login window opens.
10. Enter the credentials of a user in the login window.
The published application icons of the Citrix farm will appear in the Self-Service Ul.
11. Doubleclick an application icon to start the program.

NGO A WN
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Using Citrix Self-Service

1. Start Citrix Self-Service e.g. with desktop icon.

Log on to the server.

Add published applications to the list (+-button on the left).
Click a published application to start.

Use the search bar to find a published application.

Use the user's menu to change preferences, server etc.

)

Citrix Self Service

oA WD

Citrix Receiver

Citrix Receiver User

./ s

Paint Copy of Rechner
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Citrix Receiver - A X

Citrix Receiver User

=
L
-
#
e
N
]
2

« Configure Full-Screen Mode (see page 260)
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Configure Full-Screen Mode

Use following parameter in your Custom Command script to activate the full-screen mode for Citrix Self-Service:

> SICADIR/storebrowse —-c FullscreenMode=[0/1/2]

With following options:

+ 0 =Thewindow is not displayed full-screen
« 1 =Thewindow is displayed full-screen

+ 2 =Thewindow is displayed maximized and undecorated, which does not mask the desktop
environment's taskbar
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Appliance Mode

Connecting Citrix via Selfservice:

1. Click Sessions > Appliance Mode in the configuration tree of the IGEL setup.
Select Citrix Self-Service under Appliance mode.

Enter the URL of the delivery server.

Click OK to save the changes and close setup.

Follow the instructions on the screen.

ok N
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Create a Self-Service Setup for the User with Quick Settings

Usually, the user should not have full access to the thin client's setup. However, it may prove useful to enable users
to quickly change certain settings by themselves, without even needing a password. Typical examples are settings
for keyboard, mouse, or screen. This can be done using the Quick Settings.

Here is how to select setup pages for quick setup:

1. Open the setup and go to Accessories > Quick Settings > Setup User Permissions.
2. Select the setup pages to which the user should have access, e. g. User Interface > Input > Mouse,
or Screenlock / Screensaver.

L4 F_ﬁ Screenlock / Screensaver
v [l options
v ﬁ Taskbar
v m Screensaver
v v [l input
a

&
v m Mouse
a

-

3. Click Apply or Ok.
When the user starts Quick Settings, the previously selected options are presented.
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Configuration

User Interface

» I Display
+ Il Desktop
B Language
v £3 Screenlock / Screensaver
B options
B Taskbar
ﬁ Screensaver
¥ O Input
B xeyboard
B 2dditional keyboard layouts
‘ Mouse
» [ Touchpad

Quick settings set permissions for setup screens. If you want to set permissions for individual
parameters, you can use UMS profiles. For more information, see Profiles.
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Login Failed because of the Expired AD Password

Problem

When you try to log in to a native Citrix Storefront session, you get the error message "Login Failed!" because your
Active Directory password expired.
You are unable to change your password, because the local login does not provide an option for that.

() Beforeyou follow these instructions, check that the ports are open, maybe you can fix the problem by
that:
+ Login to Client -> Port: 88
+ Change password -> Port: 464

Here you find an overview of ports of the domain controller: Required Ports to Communicate with Domain
Controller?”

Solution

Enable Active Directory/Kerberos authentication for the Storefront session. The next time you try to login to IGEL
0S, you will be prompted to change your expired password.

Changing an Expired Active Directory Password

© When using sessions with passthrough authentication, it is essential that you lock your device's screen
when leaving it unattended.

Enabling Active Directory/Kerberos Authentication for Storefront Sessions

1. InIGEL setup, go to Security > Login > Active Directory/Kerberos.
Enable Login to Active Directory domain.

Go to Security > Active Directory/Kerberos.

Activate Enable.

Fill in the Default domain (fully qualified domain name).

Go to Sessions > Citrix > Citrix Storefront > Login.

Enable Use passthrough authentication.

Click Apply or Ok.

NGO A WN

() Please note that the client must now be locked locally and no longer in the session to prevent another
person from entering the session via the passthrough without specifying the password.

27 https://social.technet.microsoft.com/Forums/windows/en-US/1c6a59de-c1fe-4946-bb4e-1fe36fd40b08/required-ports-to-communicate-with-
domain-controller?forum=winserverDS
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Enabling Screenlock

ok W

6.

In the IGEL setup go to User Interface > Screenlock / Screensaver.
Enable Use hotkey.

Under Modifiers select Win .

Under Hotkey enter "L".

Got to User Interface > Screenlock / Screensaver > Options.
Enable User password.

So the "Win + L" hotkey locks the IGEL client instead of the session desktop.

The AD password must be entered to activate the IGEL clients.
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Configuring Auto Logon for Citrix Virtual Desktops

This how-to describes how to configure Auto Logon for Citrix Virtual Desktops.

Steps

1. InIGEL Setup, go to Sessions > Citrix > Citrix StoreFront > Server.

Configuration
Server location
Sessio

Protocol Store address
I sessions Summary

[ Global Session Options
vOc
nt Selection
bal
ix StoreFront
W server
B togin
B 2ppearance
B Reconnect
B Refresh
B Logoff
n Desktop Integration
» I Citrix Self-Service
> [l RDP

2. Add your Server Location.

Configuration
Server location

Protocol Store address

B Login
‘ Appearance
' Reconnect
B Refresh
B Logoft
B Desktop Integration
+ [N Citrix Self-Service
» Il RDP

Add

Citrix Store site address
|. http s:/f |

Store name
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Path to Store Store name

Path to Store Store name

Path to Store
Citrix/Store

Cancel
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IGEL

3. Add your Active Directory domain to Domains, making sure that you use its Fully Qualified Domain
Name (FQDN).

Configuration
Server location .
Sessions
Protocol Store address Path to Store Store name
[ Sessions Summary

B Global Session Options

ent Selection
obal
itrix StoreFront
B server
‘ Login
n Appearance
B Reconnect
B Refresh
B Logoff
B Desktop Integration W
itrix Self-Service

B Appliance Mode
» M Evidian Auth
I NoMachine N

Domains

I ThinLinc
I ssH Handling of domain in login window normal
» Il VNC Viewer

Domain

Configuration hentication type Password authentication

Sessions Only for Citrix StoreFront
' Sessions Summary

Use passtl authenticati
B Global Session Options Use passthrough authentication

Auto login
rix Client Selection User name
% Global
Password

Domain

¥ Remember user name and domain
B Refresh
B Logoff
ktop Integration
» M Ci If-Service Start a single published application automatically
I rOP
» I Horizon Client Start following applications automatically after server connection is established
‘ Appliance Mode
an AuthMgr
achine NX

Synchronize Citrix password with screenlock

Relaunch Citrix login after logoff

5. Set Authentication type to Password authentication.
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Authentication type Password authentication

Only for Citrix StoreFront

Use passthrough authenticati
Auto login

User name
Password

Domain

6. Activate Auto Login.

Authentication type Password authentication

Only for Citrix StoreFront

Use passthrough authentication
€ V) Auto login

User name
Password

Domain

V' Remember user name and domain
rix password with screenlock
Relaunch Citrix login after logoff
Start a single published application autematically

Start following applications automatically after server connection is established

7. Set User Name to the Active Directory user name.

ication type Password authentication

Only for Citrix StoreFront

Use passthrough authentication
€) (V) Auto login
User name
Password
Domain
V' Remember user name and domain

Synchroniz rix password with screenlock
Relaunch Citrix login after logoff

Start a single published application automatically

Start following applications automatically after server connection is established
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8. Setthe Password.

Authentication type Password authentication

Only for Citrix StoreFront

Use passthrough authentication
€) (V) Auto login
User name
Password
Domain
¥ Remember user name and domain
Synchroniz % password with screenlock

Relaunch Citrix login after logoff

Start a single published application automatically

Start following applications automatically after server connection is established

9. Set Domain to your Active Directory domain's FQDN, the same as in step 3.

Authentication type Password authentication

Only for Citrix StoreFront

Use passthrough authentication
€) (V) Auto login
User name
Password
Domain
v Remember user name and domain

Synchronize Citrix password with screenlock
Relaunch Citrix login after legoff

Start a single published application automatically

Start following applications automatically after server connection is established
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Force Citrix Logout Using Hotkey

You will find the instructions under Citrix: Freeze at Logout (see page 271).

& This page is due for deletion. Please check the above link and use it in the future.
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Citrix: Freeze at Logout

Symptom
A user tries to log out from a Citrix session but the session does not respond.

Example: Once you connect to a Citrix session, everything works. After having reconnected and disconnected
several times, you log out. The window freezes while the logout screen is shown.

Solution

» Select TCP only - UDP disabled under Sessions > Citrix > Citrix Global > Options > HDX Adaptive Transport
over EDT.

OR
> Try to use another Citrix Receiver version: Sessions > Citrix > Citrix Client Selection > Citrix client version.

OR

» Troubleshoot the issue with your Citrix infrastructure to discover why the session is not closing when
the wfica process makes the call for disconnection.

Workaround

As a less recommended alternative, you can configure a hotkey to force a logout in such situations. Note, however,
that this workaround can cause issues with hung sessions on the Citrix servers.

To configure a logout hotkey:

1. InIGEL Setup, go to System > Firmware Customization > Custom Application.
Click L*] to create a new Custom Application and name it e.g. "Kill Citrix Sessions".
Disable all Starting Methods for this session.

Enable Hotkey.

Choosee.g. Ctr1|Alt asModifiers and define C (for "Citrix) as Key.

Go to System > Firmware Customization > Custom Application > Kill Citrix Sessions > Settings.
Enter an Icon name.

Enter /tmp/kill_citrix as Command.

Go to System > Firmware Customization > Custom Commands > Desktop.
10. In the field Desktop initialization enter following command in one line:

echo -e "#! /bin/bash\n\nps -eo comm,pid | grep *wfica | while read
c p tail; do echo \$p; done | xargs -r kill -TERM" >/tmp/
kill_citrix; chmod 755 /tmp/kill_citrix

11. Click Apply and reboot the device.

L o N A WN
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To configure the hotkey for a group of devices, you can alternatively create a profile or use this
one: profile_KillCitrixSessionsViaHotkey.xml.

Here you can learn how to import a profile: Importing a Profile and Firmware.
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Warning Message: [Citrix Store] Could Not Connect to the Citrix Server

Environment

+ You are using Citrix Receiver 13.0.x or newer.
+ You have a session of the type Citrix StoreFront configured.

Symptom
« When establishing the connection, a warning message appears:
Warning: [Citrix Store] Could not connect to the Citrix server.

Warning: [Citrix Store] A

Warning: [Citrix Store] Could not connect to the Citrix server.

-iiclick for more details
url supplied is not a valid store
Have you installed your root certiﬁcate?)

or
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Warning: [Citrix Store]

Warning: [Citrix Store] Could not connect to the Citrix server,

-iiClick for more details:

Have you installed your root certificate?

Error adding store:AM_ERROR_HTTP_SERVER_CERTIFICATE_NOT_TRUSTED[65150]

W Ok

Problem

Citrix Receiver 13.0.x or newer on Linux only supports connections via HTTPS, and you have to make sure the device
has a valid root certificate of the Certificate Authority (CA) available. If the root certificate is missing, the connection

will fail.

Solution

Install an appropriate root certificate on the device to allow HTTPS connections to your Citrix Server.

For information on how to distribute the certificate, see Deploying Trusted Root Certificates (see page 484).
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Setting up Citrix Sessions with Hardware-Accelerated H.264 Deep
Compression Codec

This document describes how to activate a hardware-accelerated H.264 deep compression codec for Citrix sessions.

Prerequisites

+ Licensed IGEL Multimedia Codec Pack

+ IGEL UD device offering hardware video acceleration, see the FAQ Hardware Video Acceleration on
IGEL OS.

« Citrix XenApp / XenDesktop server with active H.264 display mode
See http://support.citrix.com/article/CTX200370 to learn how to determine the display mode.

Activating the Codec

1. In Setup, go to System > Firmware Customization > Features.
Enable Hardware Video Acceleration.

Go to Sessions > Citrix > Citrix Client Selection.

Select the Citrix Client Version.

Go to Sessions > Citrix > Citrix Global > Codec.

Set Graphical Codec to H.264 Deep Compression Codec.
Enable Accelerated H.264 Deep Compression Codec.

Noukwn

Known issues on VIA-based IGEL devices UD3-LX 40/41/42 and UD10-LX:
+ Hardware-accelerated HDX only works with 256 MB video memory or more. Video memory
must be adjusted in the system BIOS. The default is 128 MB.
+ Seamless window mode is not supported.
+ Desktop sessions spanning 2 monitors are not supported.
+ Desktop sessions on rotated screens may flicker (depending on the screen resolution).

©

() Ifyou use the Citrix Receiver 13.5 or older in combination with a Citrix Server 7.15, the Always Lossless
option for the Visual Quality policy will not work under Linux.
With IGEL Linux version 10.05.100 the Build to Lossless option for the Visual Quality policy will work on
the condition that you are using Citrix Receiver 13.6 or younger and the Use Video Codec policy is set to
For actively changing regions.
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Using Font Smoothing (ClearType) in Citrix Sessions

Symptom

+ You have set Font Smoothing to ClearType in
IGEL Setup > Sessions > Citrix > Citrix Global > Window > Font smoothing (Off / Standard /
ClearType)

+ ClearType does not work for Citrix PNAgent | Webinterface sessions.

Problem

ClearType is not supported in PNAgent / Webinterface sessions because Citrix Receiver uses Windows settings which
are not present on the Linux client.

Solution

All Citrix Receivers up to version 12.x do not use wfclient.ini to configure Font Smoothing. To force
Webinterface, PNAgent/XenApp to enable Font Smoothing proceed as follows:

PNAgent / XenApp:

1. Onthe Citrix server open C:

\inetpub\wwwroot\citrix\pnagent\config\default.ica .
2. Goto section Application.
3. Add new line FontSmoothingType=3 .
4. Save and close the file.

Webinterface:

1. Onthe Citrix server open C:

\inetpub\wwwroot\citrix\xenapp\config\default.1ica .
2. Go to section Application.
3. Add new line FontSmoothingType=3 .
4. Save and close thefile.

@ Ifyouinstalled the Webinterface site to a different location, please change the path
accordingly.

FontSmoothingType parameter options:

+ 0 =Nosmoothing

+ 1 =Nosmoothing
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+ 2 =Standard smoothing
+ 3 =ClearType (horizontal sub-pixel) smoothing (default)

A Legal Note
IGEL's Terms & Conditions®® apply.

28 https://www.igel.com/terms-conditions/
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Highly Secured XenServer has Problems with LD_BIND_NOW Workaround

Problem

You want to launch multiple desktop sessions with RTME and H.264 acceleration, but it doesn't work.

Solution

1. InIGEL Setup, go to System > Registry > ica > workaround-dual-rtme (Search
parameter: ica.workaround-dual-rtme)

2. Enable Activate workaround for dual RTME sessions and H264 acceleration.

3. Click Apply or Ok to save the changes.

() Thisregistry key should not be used if "Enable Secure ICA" is active for the specific delivery group. You
have to decide if you want to use the registry key or to reduce security.

IGEL OS Articles 278 /823



Citrix

Workaround for Citrix Receiver X Error

Problem
When starting Citrix XenApp you get the following Citrix Receiver errors on your IGEL OS devices:
The X Request 55.0 caused error: "9: BadDrawable (invalid Pixmap or Window

parameter)"

The X Request 60.0 caused error: "13: BadGC (invalid GC parameter)".

Environment

« Citrix XenApp 7.15
« Citrix Receivere.g. 13.2,13.3,13.7,13.8

Solution
Two parameters have to be activated in IGEL Setup:

1. Go to System > Registry > ica > forceignorexerrors.

2. Activate Suppress X error message boxes.

3. Go to System > Registry > ica > wfclient > ignorexerrors.
4,

Activate IgnoreXErrors and pass the parameters: 55.0/9, 60.0/13

See also the corresponding entry in the Citrix forum?®,

29 https://discussions.citrix.com/topic/393872-possible-workaround-citrix-receiver-x-error-on-linux-thin-clients/
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Citrix HTML5 Receiver Issue

Affected Versions

+ IGEL 0S 10.05.100 or higher
+ IGEL0S 11.01.100 or higher

Issue

Due to the abolition of plugin technology in Firefox 60+, the Workspace app installed under Linux is no longer
automatically recognized.

Solution

1. Ifyour device has IGEL OS 10.05, update to IGEL OS 10.06; if applicable, you can also upgrade to
IGEL OS 11.02. If your device has IGEL 0S 11.01, update to IGEL 0OS 11.02.
IGEL 0S 10.06 and IGEL OS 11.02 have been adapted for a workaround that requires server-side
modifications.

2. Change the server-side settings according to the instructions under https://support.citrix.com/
article/CTX237727.
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Macbook Keyboard Layout inside Citrix Session
To get the Macbook keyboard layout working correctly inside Citrix sessions, proceed as follows:

1. Under Sessions > Citrix > Citrix Global > Keyboard > Keyboard mapping file, select "Linux".
2. Under User Interface > Input > Keyboard > Keyboard type, select "Macbook".
All other keyboard layout settings can be left unchanged, i.e. as set by default.

() Inorderto type special characters like € and #, use the right-hand Alt/Option key, not the left-hand key.
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Using Lync / Skype for Business with Citrix HDX RealTime Optimization
Pack

Issue

You want to use Microsoft Lync or Skype for Business via a Citrix session with IGEL OS devices.

Solution

IGEL OS comes with Citrix HDX RealTime Media Engine (RTME) preinstalled: Setup > Sessions > Citrix > Citrix
Global > Unified Communications > Skype for Business. See also HDX Multimedia.

+ IGEL 0S 11.02.100 and higher contains RTME 2.8 (activated by default).
IGEL 0S 11.01.100 contains RTME 2.7 (disabled by default).

IGEL OS 10.06.100 contains RTME 2.8 (disabled by default).
IGEL OS 10.05.500 contains RTME 2.6 (disabled by default).
IGEL OS 10.05.100 contains RTME 2.6 (disabled by default).

For further information, see Citrix HDX RealTime Optimization Pack®,

30 https://docs.citrix.com/en-us/hdx-optimization/
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RDP

+ Mapping USB Storage Media into RDP Sessions (see page 284)

« What Is the String for Token-Based Load Balancing? (see page 287)

« RDP RemoteApp Parameter Settings (see page 288)

« RDP Performance Enhancements (see page 289)

+ RDP Session playing Sound: Error RDPSND_NEGOTIATE (see page 290)
+ Login Failed Because of Expired AD Password (see page 291)

+ User Has to Provide Credentials Twice for RDP Logon (see page 293)
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Mapping USB Storage Media into RDP Sessions

How to configure USB Storage mapping so that users can access USB storage media attached to the IGEL LX Client
within RDP sessions?

Solution:

(@ The mapping of USB storage devices is possible for "usb mass storage class" devices. The storage of
smartphones and digital cameras is usually accessed via the MTP protocol. Mobile device access via MTP is
available with IGEL Linux 10.04.100 or higher; for more information see the how-to Using Mobile Device
Access.

Basic Configuration of the Client

< p 2 N ! ™ Devices ™ Storage Devices ™ Storage Hotplug

Configuration (] storage Hotplug

= Default permission [Read;’Write v]

Acc ries Client Drive Mapping ) | Dynamic ,.J

User Interface
Static Client Drive Mapping

Network ) D e s R S
F e |etter for each storage
Devices N 1
B Hardware Info
» I Printer Start storage drives with this drive letter A
¥ [ storage Devices IER rmit ik p e e kv el s ol i
CA readaccess 1or storage nOtplug aevices B
. Storage Hotplug
‘ Options ICA write access for storage hotplug devices Yes
B Slustooth Notificati
B UsE access control otfication
Eacirity [¥f] Hotplug beep
Hotplug message
System o S ?
—_0

Timeout
15 Seconds

Within the IGEL Setup or an UMS profile you basically need to configure these parameters:

> Activate Devices > Storage Devices > Storage Hotplug > Client drive mapping > Dynamic. This option
activates dynamic client drive mapping. It automatically recognizes new storage media as they are connected to
the thin client. The thin client beeps and shows a notification while it mounts the new device. The storage devices
automatically become usable on the thin client and in Citrix ICA Sessions.

€© Mounted devices need to be unmounted before they are removed to ensure data integrity. This can be
done via the Disk Utility, the new Safely Remove Hardware Tool or a tray icon.
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Additional Parameters to Check

» The following parameters are set by default, thus storage mapping will work, but maybe for some reason you
have changed these and need to adjust them to allow the storage mapping:

Sessions > RDP > RDP Global > Mapping > Drive Mapping > Enable Drive mapping (set checkmark)
Sessions > RDP > RDP Global > Native USB Redirection > Enable Native USB redirection (remove checkmark)

Sessions > RDP > RDP Global > Fabulatech USB Redirection > Enable Fabulatech USB redirection (remove
checkmark)

Devices > USB access control > Enable (remove checkmark)

Sessions > RDP > RDP Sessions > [session name] > USB Redirection > Enable Native USB Redirection (global
setting)

Sessions > RDP > RDP Sessions > [session name] > Mapping > Enable Drive Mapping (global setting)

Assigning a Drive Letter within the Session (Optional)

> Incase you not only want to see the drive in the session as e.g. "A on IGEL-123456789", but want to address the
drive with a real drive letter within the session, you may run one of these commands:

subst T: \\tsclient\t
or
net use T: \\tsclient\t

In this example "T on IGEL-123456789" is assigned to drive letter T: within the session. You may also assign the
mapped drive to another drive letter than is used in its name.

Configuration on the Server Side

On the server side, e.g. with Windows Server 2008R2, a user in the group "Users" with access to the terminal server
will have the mapping default. This is true for a newly installed server. But the mapping can be prevented by
changing the policies:

() Do not allow drive redirection Specifies whether to prevent the mapping of client drives in a Remote
Desktop Services session (drive redirection). By default, an RD Session Host server maps client drives
automatically upon connection. Mapped drives appear in the session folder tree in Windows Explorer or
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Computer in the format [driveletter] on [computername]. You can use this setting to override this
behavior." Source: https://technet.microsoft.com/de-de/library/ee791794%28v=ws.10%29.aspx

A

r
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What Is the String for Token-Based Load Balancing?

Environment

A token-based mechanism is used as a load balancing method. This document does not apply to other load
balancing methods.

Question

What string should be entered in Sessions > RDP > RDP Sessions > [Session name] > Options to make token-
based load balancing work?

Answer

IGEL OS 10.05.700 or Higher, IGEL OS 11.01.110 or Higher

» Under Sessions > RDP > RDP Sessions > [Session name] > Options > Collection, simply enter the name of
your RDS collection. The collection name has been defined by the server administrator.

IGEL OS 10.01 to 10.05.500, 11.01.100

» Under Sessions > RDP > RDP Sessions > [Session name] > Options > Load balancing routing token,
enter tsv://MS Terminal Services Plugin.l.[collection name] ,where

+ tsv://MS Terminal Services Plugin.1l. istheroutingtoken
and
+ [collection name] isthe name of the RDS collection, defined by the server administrator.
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RDP RemoteApp Parameter Settings

Symptom

RemoteApp is not starting or closes immediately after login.

Problem

Missing or incomplete session settings on server or device

Solution

1. Set an ALIAS for the RemoteApp with the RemoteApp Management Console on the
Terminalserver.

E RemoteApp-Eigenschaften

Eigenschaften |Benutzerzuweisung |

.
A Remotedpp-Mame:

I Microsoft Excel 2010

Pfad:

I %3 STEMDRIVE s \Program Files (oBaMicrosoft OfficeOfficel 41Exc

2. Usethat ALIAS value in the device's setting in Setup > Sessions > RDP > RDP Sessions > (Session
Name) > Server > Application.

€ O server (®) Enable RemoteApps mode

Server

ROP Port 3388
Application a IIIE)(CEL |

Command Line Parameters for the Executed Program

[[] changeable Server-URL on Local Logon

@® Add two pipe-characters (|| ) at the beginning of the ALIAS value.
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RDP Performance Enhancements

Symptom
RDP users have performance issues (bad user experience).
For example:

+ Mouse is lagging

+ Screen is building up very slow

+ Session uses high bandwidth

+ Several other performance issues

Problem

There are many different causes that can result in bad performance.

Solution

The following settings can be used as a single option and also in combination.

Basics

+ The color depth should be the same on the server, the device, and in the session (best: 32 bit).
+ Inthe BIOS, set the VGA shared memory to 64 MB or more.

Optimizations for a LAN Environment

+ Under Sessions > RDP > RDP Global > Performance, edit the settings as follows:
+ Disable Compression. (Increases performance, generates about 30% more traffic)
« If RemoteFX 8 is available, activate Enable RemoteFX.
+ If RemoteFX 8 is available, set RemoteFX codec mode to "Optimized for LAN".
+ If Windows Server 2012 R2 or lower or Windows 8.1 or lower is used: Under Sessions > RDP > RDP
Global > Multimedia, activate Enable Video Redirection.

Optimization for a WAN Environment

+ Under Sessions > RDP > RDP Global > Performance, edit the settings as follows:
« Enable Compression. (Generates about 30% less traffic, consumes more local resources)
« If RemoteFX 8 is available, activate Enable RemoteFX.
+ If RemoteFX 8 is available, set RemoteFX codec mode to "Optimized for WAN".
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RDP Session playing Sound: Error RDPSND_NEGOTIATE

Symptom

If the user plays some sound within the RDP session the connection terminates on some devices with error
message:

ERROR: RDPSND: Extra RDPSND_NEGOTIATE in the middle of a session

ERROR: TCP Connection: Cannot receive data (Keep alive timeout)

ERROR: RDPSND: Extra(RDPSND NEGOTIATE)in the middle of

a 5ession
ERROR: TCP Connection; Cannot receive data (Keep alive
timeout)

Problem

This may happen if during data transmission the connection fails.

Solution
Try a different sound driver for RDP session:

1. Go to System > Registry > rdp.winconnect.sound-driver
2. Choose 0SS or ALSA
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Login Failed Because of Expired AD Password

Issue

When you try to log in to a RDP session, you get the error message "Login Failed!" because your Active Directory
password expired.
You are unable to change your password because the local logon does not provide an option for that.

() Beforefollowing these instructions, check the ports:
+ Login to Client -> Port 88
+ Change password -> Port 464

Here you find an overview of ports of the Domain Controller: Required Ports to Communicate with Domain
Controller

Solution

Enable Active Directory/Kerberos authentication for the RDP session. The next time you try to log in to IGEL OS,
you will be prompted to change your expired password.

Changing an Expired Active Directory Password

© When using sessions with passthrough authentication, it is essential that you lock your device's screen
when leaving it unattended.

Enabling Active Directory/Kerberos Authentication for RDP Sessions

1. InIGEL setup, go to Security > Logon > Active Directory/Kerberos.
Enable Login to Active Directory Domain.

Go to Security > Active Directory/Kerberos.

Activate enable.

Fill in the Default Domain (Fully Qualified Domain Name).

Go to Sessions > RDP > RDP sessions > [RDP session] > Logon.
Enable Use passthrough authentication for this session.

Click Appy or Ok.

NGO A WN

() Please note that the client must now be locked locally and no longer in the session to prevent another
person from entering the session via the passthrough without specifying the password.

31 https://social.technet.microsoft.com/Forums/windows/en-US/1c6a59de-c1fe-4946-bb4e-1fe36fd40b08/required-ports-to-communicate-with-
domain-controller?forum=winserverDS
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Enabling Screen Lock

ok W

6.

In the IGEL setup go to User Interface > Screenlock / Screensaver.
Enable Use Hotkey.

Under Modifiers select Win .

Under Hotkey enter "I".

Got to User Interface > Screenlock / Screensaver > Options.
Enable User Password.

So the "Win + L" hotkey locks the IGEL client instead of the session desktop.

The AD password must be entered to activate the IGEL clients.
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User Has to Provide Credentials Twice for RDP Logon

Issue

When you connect to a Windows terminal server, you are asked to provide your credentials twice.

Cause

This behavior is caused by the way RDS load balancing works. The crucial point to understand is that the terminal
server does not communicate with the session broker directly.

Instead, the scenario is the following:

1. The client connects to terminal server 1 and authenticates with terminal server 1. This is the first
time the user is asked for their credentials.

2. Since we have a load balancing setup, terminal server 1 will talk to the session broker and ask if
the client can use terminal server 1 or if it should be redirected to a different terminal server.

3. Ifredirection occurs, the client will also have to authenticate with the terminal server the client
was redirected to (terminal server 2 in the figure below). This is the second time the user is asked
for their credentials.
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Solution

The issue can be resolved by activating Kerberos/Active Directory authentication. For further information,
see Active Directory/Kerberos.
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VMware Horizon

+ Setting up VMware Blast Sessions (see page 296)

Use NLA (Network Layer Authentication) for Logon with Horizon Client Sessions (see page 297)
Workaround for Hotkeys in Horizon Sessions (see page 298)

Multimedia Acceleration with VMware Horizon View in VESA Mode (see page 299)
Troubleshooting the Horizon Client (see page 300)
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Setting up VMware Blast Sessions

Prerequisites

+ Device offering hardware video acceleration, see the FAQ Hardware Video Acceleration on IGEL OS.
« VMware Horizon 7 Server
For further information about the server configuration, refer to VMware's documents at http://
pubs.vmware.com/horizon-7-view/index.jsp

Activating VMware Blast

1. In Setup, go to System > Firmware Customization > Features.

Enable Hardware Video Acceleration.

Go to Sessions > Horizon Client > Horizon Client Global > Server Options.
Set Preferenced desktop protocol to VMware Blast.

Click Apply or Ok.

oW
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Use NLA (Network Layer Authentication) for Logon with Horizon Client
Sessions

Starting a session, even just presenting a logon screen, has quite an impact on resources. Each time a user tries to
logon, processes are started on the remote machine, no matter whether the user's credentials are valid or not. You
can save resources and prevent Denial of Service (DoS) attacks by using Network Layer Authentication (NLA). NLA
checks whether a user is the right person before any logon processes is started.

For more information about NLA, see https://technet.microsoft.com/en-us/magazine/hh750380.aspx.

NLA for Horizon Client Sessions is available from IGEL Linux version 5.08.100 upwards.

To use NLA for a Horizon Client session:

1. Open the setup and go to Sessions > Horizon Client > Horizon Client Sessions > [Session Name]
> Options.
2. Activate Network Level Authentication.
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Workaround for Hotkeys in Horizon Sessions

Issue

You want to switch from the VMware Horizon session to the IGEL desktop with the key combination [Ctrl]
+ [Windows] + [D]. While the key combination [Ctrl] + [Windows] + [D] can be realized with IGEL OS 11.01.100 or
lower (Horizon Client 4.x), this is not possible for IGEL OS 11.01.110 or higher (Horizon Client 5.x).

Solution

1. Press [Ctrl] + [Alt] and release the keys.
The focus is switched from the VMware Horizon session to the local system.

2. Use [Ctrl] + [Windows] + [D] to switch to the IGEL desktop.

3. To switch the focus back to the VMware Horizon session, click into the VMWare Horizon session
window.
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Multimedia Acceleration with VMware Horizon View in VESA Mode

Symptom

You did install IGEL Universal Desktop OS 2 on not fully supported hardware using IGEL Universal Desktop
Converter 2. Multimedia acceleration is not working within a VMware Horizon View session.

Problem

The graphics chip of your hardware is not supported and as a fallback the VESA mode is used.

Solution

There is no other solution to the problem than using fully supported hardware. Information on supported hardware
can be found in the UDC2 manual.®

You can also access IGEL's 3rd party hardware support database® to find fully supported graphic chips.

32 http://edocs.igel.com/index.htm#11873.htm
33 https://www.igel.com/linux-3rd-party-hardware-database/
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Troubleshooting the Horizon Client

& Solution Based on Experience from the Field

This article provides a solution that has not been approved by the IGEL Research and Development
department. Therefore, official support cannot be provided by IGEL. Where applicable, test the solution
before deploying it to a productive environment.

Symptom

There are some issues with the performance of the Horizon client.

Environment
+ IGEL OS 10 or higher

Problem

You don't know how to collect the log files and send them to the IGEL Support team.

Solution

1. Inthe Setup, go to System > Registry > sessions > vdmcient% > options > debug and activate
Save debug information (registry parameter: sessions.vdm_client%.options.debug).

2. Go to System > Registry > vmware > USB > log and set Set VMware Horizon USB debug level to
"debug" (registry parameter: vmware.view.usb.log).

3. Goto System > Registry > vmwarevdmapp > debug and activate Save debug
informations (registry parameter: vmwarevdmapp.debug ).

The log files are created in the /tmp directory and can be found using the following patterns:
/tmp/vvdm *
/tmp/vmware-*

4. Changeto /tmp and putthe logfilesinto a compressed tarfile: tar —-czf vmware-

logs.tar.gz [logfiles]

5. In the structure tree of the UMS Console, go to the device and select Device File->UMS the context
menu.

6. Under Devices file location, enter "/tmp/vmware-logs.tar.gz".

Under Target URL, select the location on the UMS Server where the file is to be stored.

8. Click Device->UMS.

~
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Authenticating with Evidian Authentication Manager

You can connect to Citrix, RDP and VMware Horizon roaming sessions using RFID badges with Evidian
Authentication Manager (AuthMgr). Custom commands are supported as well.

Prerequisites

+ IGEL Universal Desktop Linux 5.06.100 or newer on the device.

+ Aninstalled and running Evidian SSO Controller, version 10.0 or higher

+ When using HTTPS (IGEL Linux 5.07.100 or newer), the User Access Server's CA root certificate
saved locally on the device.

« The device and the server(s) have to be part of the same Active Directory domain.

+ Asupported RFID reader (e.g. OMNIKEY 5022 CL, OMNIKEY 5421), connected to the device.

+ RFID badges that are already enrolled.

Configuring an Evidian Authentication Manager Session

1. InIGEL Setup, go to Sessions > Evidian AuthMgr > Evidian AuthMgr Sessions.

Add a new session.

Go to Sessions > Evidian AuthMgr > Evidian AuthMgr Sessions > [Session Name] > Connection.
Choose the Protocol used for the user access service (e.g. HTTP).

Enter the IP address or DNS name used for the user access service under Server.

Choose the Port for the user access service (e.g. 9764).

Under Path to service, enter the path for the user access service (e.g. /soap ).
Under CA certificate, enter the path to the CA certificate, including its name, or path of the
certification authority (e.g. /wfs/ca-certs/ca.crt ). Thecertificate is required for HTTPS

© N oLk WwN

connections.
9. Enterthe secret for the Roaming session secret.

10. When using HTTPS, select CA certificate as the user access server's CA root certificate on the
device.

11. Under Evidian AuthMgr > Evidian AuthMgr Sessions > [Session Name] > Options, select the
desired Session type.
This will make Evidian Authentication Manager use the first configured session of its type, e.g. RDP.
Make sure that a session is configured.

() Ifyou choose the user-defined session type, you need to supply the custom commands; see
Custom Commands (see page 304). For further options, see Options in the IGEL OS Reference Manual.

12. Start the new session by clicking on its icon in the Start Menu. Alternatively, reboot the device. In
the default autostart setting the Evidian Authentication Manager for your session will start
automatically and wait for an RFID badge to be placed on the reader.

@ Youcan only start a single instance of an Evidian Authentication Manager session.
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Configuring Citrix/RDP/VMware Horizon Sessions

> Configure the session that you want to use with Evidian Authentication Manager as the first session of its kind.
The shortcuts to the session settings are provided in the Setup section Related Configurations:

SesnT e Select.. | Related Configurations

Configuration
» I Horizon Client
‘ Appliance Mode
O
» M Evidian AuthMgr Global
= Language selection Automatic
v

Custom catalog of messages

N Availability Message

Using a Custom Configuration File

Instead of using the settings provided by IGEL Setup, you can enable a custom configuration file under Sessions >
Evidian AuthMgr > Evidian AuthMgr Sessions > [Session Name] > Options > Use configuration file. Then all the
other session settings will be ignored. You find a commented template for the configuration fileat /etc/

rsUserAuth/rsUserAuth.ini.

Logging in with Evidian Authentication Manager

1. Place your RFID badge on the RFID reader (or tap the reader with it if you configured Tapping
Mode)

2. Your Citrix/RDP/VMware Horizon session will open if an active roaming session for your user
already exists. If it does not, you will be presented with a password prompt for the user's Active
Directory password.

3. Remove your RFID badge (or tap the reader again) to disconnect from the session.
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Custom Commands

The following simple shell scripts illustrate how to write custom commands that receive username and domain as
parameters from Evidian Authentication Manager.

In order to use them

1. Savethescriptsin /wfs/.
2. Make them executable with chmod a+x [filename].

3. Enter their full path (e.g. /wfs/start.sh)in Sessions > Evidian > [Session name] > Options.

Start Script
#!/bin/sh
# Sample start script
if [ $# -eq 3 ] ; then
# Start "session"
gtkmessage -t "Evidian Authentifcation Manager Login" -m "Login as user '$1'
with domain '$3'."
else
exit 1
fi

exit 0O

Stop Script

#!/bin/sh

# Sample stop script

# Close running "session"

pkill gtkmessage

gtkmessage -t "Evidian Authentication Manager Logout" -s 5 -S -m "Logout user
1§10,

exit 0
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Debugging and Troubleshooting

Debugging

1. Enable Debug mode in Sessions > Evidian > [Session Name] > Options in Setup and set the level
of detail.

2. Kill the Evidian Authentication Manager process (see Further Troubleshooting).

3. Start the desired Evidian session from the Start Menu.

4. Watch the outputwith tail -F /var/log/user/rsuserauth[Session

Number] .debug in Local Terminal. Alternatively, add the file to System Log Viewer.

() The session number starts with 0, not 1. To watch the output of the first configured session, use
thus tail -F /var/log/user/rsuserauth0.debug

Further Troubleshooting
1. Open Local Terminal
2. Enter ps fax | grep rsuserauth | grep -v grep tolook for Evidian Authentication

Manager processes.
3. Use the Evidian AuthMgr Restart session to restart all Evidian sessions if neccesary

OR kill unwanted processes by entering kill [process ID] intheterminal, start desired
processes via the Evidian entries in the Start Menu.
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IBM iAccess

+ Editing the List of Visible Menu Entries for IBM iAccess (see page 307)
+ Key Mapping for IBM iAccess Client (see page 309)
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Editing the List of Visible Menu Entries for IBM iAccess

You can simplify the menu of an IBM iAccess client session by removing items from the menu tree. You also can
restore the original menu.

Removing Menu Items

1. Inthe IGEL Setup, go to System > Registry > sessions > iaccessINUMBER] > options >
deletemenus (Registry key: sessions.iaccess[NUMBER].options.deletemenus).

[NUMBER] is the instance number of the session you want to configure; 0, for instance, stands for

the first session, 1 for the the second session, etc.
2. Inthe List of visible menu entries, using the mouse, mark the line with the entry you want to

delete:
List of visible menu entries

Y Edit|Preferences|TabSetup i
Edit|Preferences|Watermark

€) | Edit|Preferences|TranslationTable
Wiew

E1N

3. Pressthe backspace [ —] or delete [Del] key.
The menu item is deleted:

List of visible menu entries

Edit|Preferences|TabSetup &

#) | Edit|Preferences|TranslationTable
Wigw

E1S

( Ifyou delete a menu item that has subitems, the subitems will be invisible, too.

4. To remove further menu items, repeat steps 2 and 3.

5. Click Apply or Ok.
6. Start or restart the IBM iAccess client to check your changes.

Restoring the Original Menu
1. Inthe IGEL Setup, go to System > Registry > sessions > iaccessINUMBER] > options >
deletemenus (Registry key: sessions.iaccess[NUMBER].options.deletemenus).[N

UMBER] is the instance number of the session whose menu you want to restore; 0, for instance,
stands for the first session, 1 for the the second session, etc.
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2. Inthe List of visible menu entries, click the following symbol:

List of visible menu entries

@

[=A=10 La

T [T T s v T

Edit|Preferences|TabSetup

Edit|Preferences|TranslationTable

L.ljﬂ.

The original menu is restored.

3. Click Apply or Ok.
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Key Mapping for IBM iAccess Client

Problem

When you change the key mapping in the IBM iAccess client, the changes are not retained when the client is
restarted.

Applying the changes via IGEL Setup is not possible.

Environment/Prerequisites

+ IGEL 0S 10.05.100 or higher
+ UMS5.09.110 or higher
« IBMiAccess Client session is set up

Solution

Save the settings made in the IBM iAccess client in a file and distribute that file via the UMS.

Editing the Key Mappings

1. Open the IBM iAccess session and log on to your remote environment.
In the IBM iAccess client, go to Edit > Preferences > Keyboard.

On the Key Assignment tab, create the desired key bindings.

When you are finished creating key bindings, click Save as....

In the save dialog, choose File and edit the file path as follows: /userhome/IBM/

iAccessClient/Emulator/IBMi.kmp
6. Click OK.
The IBM iAccess client will recognize the file IBM1 . kmp as the default key.

o kN

Importing the Configuration File to the UMS
1. Openthe UMS.
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2. Inthe navigation tree, find the thin client with the IBMi.kmp file and select Other Thin Client
commands > File TC->UMS in the context menu.
¥ 5 My Linux Thin Clients (3)

[ TCO00BCADSS
[ TCOnENCS114
L
¥ ' My Windows Thin
H |GEL-PEQ4BDS
[ TCO0ENCS139
o Mew devices (0)
12} ITCONEOCS36256
B mobile Devices (0)
S0 Shared Workplace s
B views (10
O Jobs (4
E Files 1)
" Universal Firmware U
® Search History (1)

T Recycle Bin (106

IGEL OS Articles

Mermary Size (MB)
Metwork Speed
Duplex Mode

=Y Edit Configuration

& Rename

] Delete

@ Clear '"Configuration Change Status' flag
ES Access control

2% cut
[&) Copy
[ Paste

Shadow

Secure Terminal
Suspend
Shutdown

Wake up
Rehoot

Lpdate & snapshot commands [
Other Thin Client commands

Send Message
Resetta Factary Defaults

Settings UMS-=TC
Settings TC-=UIMS
Lipdate deskiop customization

File LInS-=T0

File TC-=LIMS

Delete file from TG

Diowenload Flashplaver
Remaove Flashplayer

Store UMS Cedificate
Eemowve UMS Cerificate

Refresh license infarmation
Refresh system infarmation
Refresh Aszet Inventary data

sults

Take over settings from ...
Export Thin Client Settings

= Windows Updates and Hotfixes
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3. Under Thin Client file location, enter /userhome/IBM/iAccessClient/Emulator/

IBMi . kmp
File TC->UMS x
File TC-=mMS

TCOOEQCS362YEE

File information
& .Y

Thin Client file location § | fuserhomelBmMfiAccessClientEmulatorBMIi kmp |

Target LIRL -

File TC-=LIMS

LI TR B B L e B e B AR
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4. Click - to open the Save dialog. o

File TC->UMS x

File TC-=UmMS

[TCOOEQCA362TEE

File information
r Y

Thin Clientfile location | fuserhomelBwMfiAccessClientEmulatorBMI kmp |

Target URL -

File TC-=LIMS

LIS B B L e e B T
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5. Choose afile location within the ums_filetransfer folder.

File TC-=UMS
File TC-=LIMS

1 ITCODEDCA3627EE

File infor
—

Thin G

Look [n: lﬁ‘ wehday

v

Save x

- ]- ] Jojrs

ﬁ‘ ums_filetransfer

File Marme: |

Files of Type: | Al Files

Target URL

File TC-=LIMS
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6. Under File Name, enter IBM1i.kmp and click Save.

File TC->UMS
File TC-=UMS
[TCOOEQCAS362ZTEE
|
Look [n: lﬁ‘ ums_filetransfer "] m i
ﬁ‘ supportinfo lgelstart.jpg
6346891785 _17d4b31a9d_o.jpg kKyocera_FS-600_de.ppd
eDocs-Logo.png Maisons_Basques.jpg
elch.jpg stopweatch jpo
hedgehag-child_1920.jpa te_files_for_support 00EOCS13924
- L -
File Mame: |IElru1i.kmp |
Files of Type: | All Files v
File infor
F— [r—
Thin
Target URL -
File TC-=LIWMS
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7. Click TC->UMS. e

File TC->UMS x

File TC-=LIMS

[TCOOEOCA362VEE

File information
i i |

Thin Clientfile location | fuserhomelBwMfiAccessClientEmulatorBMI kmp |

Target LURL hitpsi1 72 .30 92 9:844 3fums_filetransferBMi kmp -

File TC-=LIMS

The file is stored within the UMS. Next, we will make it available as an object.
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Creating the File Object in the UMS

1. Inthe navigation tree, go to Files, open the context menu and choose New file.
5 Jobs ()
E

" Universal Firmware

Eename
Delete
Aecess contral

. Bearch History (13
T Recycle Bin (1063

- ot

[ Paste

Logoing: Messages

Connected to 1723092
[ Mew Directory
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2. Inthe New file dialq_g_l_, _;__hqg_sg__Sl_gl_e_q_f_ilgf[gln_\_9M§_§g[¥gr and click - to open the file gi_iglog.

File source
() Upload local file to UMS server
Lacal file -
Upload location (URL) |https:ﬁ{senfer:pnrtriums_ﬂletransfer |-

[ (® Selectfile from UMS ser\rer]
File location (URL) - |

File target

Classification [Undeﬂned "’]

Thin Client il location | |

Access rights

Read ‘Write Execute
owner [ [ &Y
others [ [ O

Cwiner .User b
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3. Inthefile dialog, find the file IBMi.kmp you created previously, and click Open.

New file

File source
O Lipload local file to UMS server

® Selectfi
File o IEM krmip
d_ojpg lgelstarnt.jpg
File target Kyocera_FS-600_de.ppd

mMaisons_Basgues.jpy

Clagsificat stopwatch jpg

Thin Client -

te_files_for_support
tc_files_for_support

Accessrighi File Mame: B kmp

R Files of Type: [ Al Files

owner |

Others |

=
Lpl .
woa Look In: lﬁ ums_filetransfer '] m

Cwiner | Llser ¥
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4. Back in the New file dialog, enter the Thin Client file location as follows: /userhome/IBM/

iAccessClient/Emulator/

File source
O Lipload local file to UMS server

Lacal file -

Lipload location (URL) |https:Iksewer:pnrt:Iums_ﬂletransfer |-

(®) Selectfile from UMS server

File location (URL) ‘https:m 723092 8:8443ums_filetransferEmMi.kmp |-
File target
Classification [Undeﬂned ']

Thin Client file location |IuserhcumeJ‘IElMIiAccessCIienﬁEmulatnrﬂ |

Access rights

Read Wyrite Execute
owner ] [V &Y
others [ [ ]

Owner | User ¥

5. Ensure that the Access rights and Owner are set as follows:
« Owner rights: Read, Write, Execute
+ Owner: "User"
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File source
() Upload local file to UMS server

Lacal file -

Lipload location {(URL) |https:Iksewer:panIums_ﬂletransfer |-

® Selectfile from UMS server

File location (LURL) ‘https:m 723092 8:8443fums_filetransferBMi kmp |-
File target
Classification [Undeﬂned ']

Thin Client file location |IuserhcumeIIElMIiAccessClienﬁEmulatnrﬂ |

Access rights

(- Read “Wyrite E}:ecut;\
owner o ¥ &Y
others [ [ ]

Cwner .User v

J
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6. Click Ok.

File source
() Upload local file to UMS server

Lacal file -

Lipload location {(URL) |https:Iksewer:panIums_ﬂletransfer |-

® Selectfile from UMS server

File location (LURL) ‘https:m 723092 8:8443fums_filetransferBMi kmp |-
File target
Classification [Undeﬂned ']

Thin Client file location |IuserhcumeIIElMIiAccessClienﬁEmulatnrﬂ |

Access rights

Read Write Execute
owner o ¥ &Y
others [ [ ]

Owner | User ¥

The file object "IBMi.kmp" is created.
Assigning the File Object to Thin Clients

1. Inthe navigation tree, select the file object "IBMi.kmp" and click [ linthe Assigned objects area
(upper right).
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2. Inthe Select assignable objects dialog, select the thin clients to which you want to assign the new
key mapping and add them to the Selected objects area.

Select assignable objects x

Selected ahjects

= [ Master Profiles (2) [ ITCoOEDCET143A5
» [T Profiles (20) [ ITCONEDCA3R2TEE
¥ [ Thin Clients (&)
[ Import (o)
¥ E@ Wy Linux Thin Clients (3

L ITCO0EDCS] |

| N\
A E@ Wy Windowes Thin Clients (29 '

@ IGEL-PEQ4BDEYLY
@ ITCOOEQCS1 39243
[ New devices (0)
(‘.{z [TCOOEDCA362560
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3. Click Ok.
Select assignable objects x

+ [ Master Profiles (2
T Profiles (29)
¥ LI Thin Clients (5)
[ Import (o)
¥ F'E Wy Linux Thin Clients (3
[ TcoooeCADsant &
L ITCO0E 14345
L TCO0EDC
A F'E Wy Windowes Thin Clients (29
IGEL-PEQ4BDSYLY
[ 1TConEDCS1 39243
[ New devices (0)
‘ﬂ [TCODEDCS3E2460

Selected ahjects

[ ITCOOEDCET1 4348
[ ITCOOEDCA2GZ7EE

Cancel

4. Inthe Update time dialog, choose whether the file should be assigned to the thin clients at next

reboot orimmediately; then, click Ok.

When should these changes take effect?
() Mext Reboot

@ Mo

Update time bod

E] Alweays apply settings on next reboot (and don't show this dialog againg

Thefile is transferred to the thin clients.
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Imprivata

+ Imprivata: Clear the Imprivata Data Partition (see page 325)
« Imprivata: Session Customization (see page 326)
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Imprivata: Clear the Imprivata Data Partition

The function that explicitly clears the Imprivata data partition has been removed. However, you can simply emulate
this feature by disabling and re-enabling the Imprivata appliance mode.

If you already have a valid appliance running and want to delete the Imprivata data partition, take the following

steps:

1.
2.

o

In the IGEL Setup, go to Sessions > Appliance Mode.
Set Appliance mode to "Disabled".

Appliance mode || Disabled |-) l

Configuration

Sessions

n Sessions Summary

B Global Session Options
» Il Citrix
» I RDP
» [ Horizon Client

. Appliance Mode
» Il Caradigm

Click Ok to save the setting.
Click Yes to confirm the Apply Settings dialog.

Apply Settings b4
Do you want to let the settings take effect now?
This might terminate ongoing sessions.

Mo

Normal desktop mode is active. The Imprivata data partition is void now.
In the IGEL Setup, go to Sessions > Appliance Mode.

Set Appliance Mode to "Imprivata".

In the Set the URL to the Server field, enter the new server address.

Appliance mode ] [Impriuata ']

Set the URL to the Server |https:fr‘y0ur server |

Click Ok and confirm the Apply Settings dialog.
Now you have a fresh Imprivata appliance mode without any outdated data.
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Imprivata: Session Customization

You can make the same settings in the IMPRIVATA_RDP (IGEL Setup > RDP > RDP Sessions > Imprivata_RDP) and
IMPRIVATA_VMware (IGEL Setup > Horizon Client > Horizon Client Sessions > IMPRIVATA_VMware) sessions as
in the standard sessions (see the description for RDP Session and Horizon Client Session).

(» [IMPRIVATA_RDP and IMPRIVATA_VMware will be shown in the IGEL Setup when Imprivata is selected
under Setup > Sessions > Appliance Mode, see Imprivata.

However, the changes under the following subsections will be ignored:

Imprivata_VMware Session

+ Connection Settings

Imprivata_RDP Session

+ Server
« Logon
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« Enable Weaker Algorithms in the Built-in OpenSSH Server (see page 328)
« Enable Weaker Algorithms in the SSH Client (see page 329)
+ SSH: Deprecation of Weak Algorithms as of IGEL Linux 10.04.100 (see page 330)
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Enable Weaker Algorithms in the Built-in OpenSSH Server

Problem

You are trying to connect to the built-in OpenSSH server of IGEL OS with an SSH client which does not support the
strong algorithms of the server.

Solution
To enable weaker encryption algorithms, proceed as follows:

1. In Setup, go to System > Registry > network > ssh_server.
2. Change the settings according to your requirements:
+ disable_weak_encryption: Disable this option to enable weaker encryption.
+ disable_weak_hostkey_algos: Disable this option to enable weaker host key algorithms.
+ disable_weak_kexalgorithms: Disable this option to enable weaker key exchange
algorithms.
+ disable_weak_macs: Disable this option to enable weaker MACs.
« minimal_encryption_level: The minimal level of encryption
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Enable Weaker Algorithms in the SSH Client

Environment
IGEL Linux 10.04.100 or higher

Problem

You are trying to connect to an SSH server which does not support the strong algorithms enabled by default in the
SSH client.

Solution
To enable weaker encryption algorithms, proceed as follows:

1. In Setup, go to System > Registry > network > ssh_client.
2. Change the settings according to your requirements:
« disable_weak_encryption: Disable this option to enable weaker encryption.
+ disable_weak_hostkey_algos: Disable this option to enable weaker host key algorithms.
+ disable_weak_kexalgorithms: Disable this option to enable weaker key exchange
algorithms.
+ disable_weak_macs: Disable this option to enable weaker MACs.
« minimal_encryption_level: The minimal level of encryption
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SSH: Deprecation of Weak Algorithms as of IGEL Linux 10.04.100

As of IGEL Linux 10.04.100, certain older, less secure algorithms are deprecated in both the SSH client and server.

The following table shows the algorithms enabled by default as of IGEL Linux version 10.04.100.

Key exchange algorithms

Message authentication codes
(MACs)

Host keys

curve25519-sha256@libssh.org
ecdh-sha2-nistp521
ecdh-sha2-nistp384
ecdh-sha2-nistp256
diffie-hellman-group-exchange-sha256

hmac-sha2-512-etm@openssh.com
hmac-sha2-256-etm@openssh.com
umac-128-etm@openssh.com
hmac-sha2-512

hmac-sha2-256
umac-128@openssh.com

ssh-ed25519-cert-v01@openssh.com
ssh-rsa-cert-vOl@openssh.com

ssh-ed25519

ssh-rsa
ecdsa-sha2-nistp521-cert-v0l@openssh.com
ecdsa-sha2-nistp384-cert-vOl@openssh.com
ecdsa-sha2-nistp256-cert-v0l@openssh.com
ecdsa-sha2-nistp521

ecdsa-sha2-nistp384

ecdsa-sha2-nistp256

If you need to enable weaker algorithms, see Enable Weaker Algorithms in the SSH client (see page 329) and/or Enable

Weaker Algorithms in the Built-in OpenSSH Server (see page 328).
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+ Define Multiple Start Pages for Your Browser (see page 332)

« Touchscreen: Multitouch/Gesture Support for Firefox (see page 333)
« Set Advanced User Preferences for the Browser (see page 334)

« Use the Browser in Kiosk Mode (see page 336)

o SSL/TLS Error with Firefox in Appliance Mode (see page 339)

« Browser Cannot Download Files (see page 340)

+ Some PDFs are not opened by Firefox (see page 341)

« Can |l Install Firefox Extensions? (see page 343)
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Define Multiple Start Pages for Your Browser

In some cases, a fixed set of start pages displayed in separate tabs may prove useful. For instance, if the browser is
working in kiosk mode, reusing a set of tabs from an earlier session is not an option.

Here is how to define multiple start pages to be opened at browser startup:

Configuration When browser starts | show my homepage v Related Configurations
" " User Interface -
B BM iAccess Client 4 Homepage https:/fkb.igel.com|https:/iwww.igel.co E Displ
A - isplay

= I ThinLinc

i SsH
» B VNG Viewer Display resolution | System setting vJ
Ll Smnser Minimum font size [None v]

v [ Browser Global
B Tabs
n Content
B Frint
n Proxy
‘ Privacy
n Security
B Advanced
n Encryption
B certificates
n Smartcard Middley
B commands
I EBrowser Sessions
» Il Flugins
= M Media Player
| WS Sessions
» I olP Client

] show browser splash screen

User Interface
Network
Devices

Security

System

Search

Open the setup and go to Browser > Browser Global.

Set When Firefox starts to Show my home page.

Set Homepage to the URLs that the browser should open at startup. Use "|" as a separator.
Click Apply or Ok.

Rl e
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Touchscreen: Multitouch/Gesture Support for Firefox

You can use multitouch/gestures in the Firefox browser that is built into IGEL OS 10 and IGEL OS 11. This is done by
adding an environment variable.

To enable multitouch:

1. Open the local Setup or the UMS configuration dialog and go to System > Firmware
Customization > Environment Variables > Predefined.

2. Inthefirst free Variable name field, enter MOZ_USE_XINPUT2

3. Inthe corresponding Value field, enter 1
Click Ok.

IGEL Setup 11.03.258.01 (Build 6.3.11)

m ™ Firmware Cu: zation ™ Environmen es * Predefined

Variable name €) MOZ_USE XINPUTZ Value

Variable name Value
Variable name Value
Variable name Value
Variable name Value
Variable name Value
Variable name Value
Variable name Value
Variable name Value

Variable name Value

Search

5. Reboot the device.
6. To check if multitouch is working, open the Firefox browser and go to https://www.paulirish.com/
demo/multi.
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Set Advanced User Preferences for the Browser

The Mozilla Firefox browser included in IGEL OS offers a vast array of configuration options. They range from the
sorting order of bookmarks over encryption algorithms to fixing quirks in web applications that are important to
you. In total, they are too many to present them as individual items in IGEL Setup. However, as of IGEL Linux version
5.09.100, IGEL Setup lets you set any browser user preference in a generic way.

© Changes to the advanced Firefox browser settings can impair its stability, security, and speed. IGEL
Support is not responsible for problems caused by changing the browser configuration, even if the
browser configuration was changed in IGEL Setup.

You will find information regarding the configuration parameters for Firefox in the MozillaZine Knowledge Base
under Firefox About:config entries®4,

1. In Setup, go to Sessions > Browser > Browser Global > Advanced.
2. Inthe Custom preferences area, click on Add.

4 > A | » Sessions ™ Browser ™ Browser Global » Advanced

Configuration
. Global Session Options
» I Citrix
[
3
B ode
» [ Evidian AuthMgr
B NoMachine NX Client
B X Sessions
» I Parallels Client
» I IBMiAccess Client
» I ThinLinc
8 ssH
» [l VNC Viewer
v O Browser
v [ Browser Global
| "RELS A
B cContent
B Print A
B Proxy
B Privacy
B Ssecurity
B Advanced Active Mode Custom preference
B Encryption
B Certificates
B Smartcard Middieware
‘ Restart
- .

search )

Check my spelling as I type

Custom preferences

w

Using the Active option, specify whether the configuration parameter is to be active.
Specify the Mode of the configuration parameter - for many cases pref will do.
5. Under Custom preference, give the name of the configuration parameter. Example:

>

ui.textSelectBackground

6. Specify the Type of the configuration parameter.
Possible values:
+ String: The value is a string of characters.
«+ Integer: The value is a whole number.

« Boolean: Thevalueis a Boolean value,i.e. true or false.

34 http://kb.mozillazine.org/About:config_entries
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|

IGE

7. Specify the Value of the configuration parameter. The possible entries depend on the Type
selected.

8. Click Ok.
The configuration parameter will take effect the next time that the browser is launched.

For more details on browser configuration, refer to the section Browser Global in the IGEL OS
reference manual.

A

r
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Use the Browser in Kiosk Mode

Browser kiosk mode is an option when you are operating any kind of public terminal with anonymous access, e.g.:

+ Educational service in a museum
« Service terminals or ticket vending machines for public transport
« Entry portal for a corporate intranet

Albeit configuring an IGEL OS device for browser kiosk mode may seem quite extensive, you have the possibility to
define your own flavor of kiosk mode. Consider the following settings.

Settings under Sessions > Browser > Browser Sessions > [Session Name]

> Activate Autostart.

Settings under Sessions > Browser > Browser Sessions > [Session Name] > Settings
» Set When browser starts to Show my home page.
> Set Homepage to the desired home page.

> if necessary, select the correct Start Monitor.

Settings under Sessions > Browser > Browser Global > Tabs

> Set New pages should be opened in to the current window or to a new tab.

Settings under Sessions > Browser > Browser Global > Content
> i applicable, activate Block pop-up windows.
> Activate Load images automatically.

» Activate Enable JavaScript if desired, and adapt the actions permitted for JavaScript according to your needs.

Settings under Sessions > Browser > Browser Global > Privacy
» Set Save Browsing History (in days) to Do not save History.
> Deactivate Save information entered in forms and the Search bar.
» Deactivate Remember Passwords.
> Activate Clear private data when closing browser.

> Activate all items in the area Select the items to be cleared.
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> If you want to suppress any tracking of the user's activities, activate Allow private browsing feature and
Always start in private browsing mode.

i applicable, activate Enable "Do Not Track" feature.

» To make the browser block domains and websites which are known for tracking users, activate Enable built-in
tracking protection.

Settings under Sessions > Browser > Browser Global > Security
» Toenable phishing protection, activate Safe Browsing.

» Toenable protection against malicious downloads, activate Malware Protection.

Settings under Sessions > Browser > Browser Global > Restart
> Activate Restart. The browser will restart automatically if a user closes the browser window.

> If you want the browser to restart automatically after some idle time, activate Restart after idle time and set
Idle time after which a restart occurs in minutes or seconds.

Settings under Sessions > Browser > Browser Global > Window
» |fthe browser shall run in full-screen mode, activate Start in fullscreen mode.
> Activate Hide local filesystem.

> Activate Hide configuration page of the browser.

Settings under Sessions > Browser > Browser Global > Menus & Toolbars
» Activate Hide App Menu/Menu Bar.
> Select which menus and toolbars are to be hidden.

» Deactivate User Customization of toolbars.

Disabling Access to Developer Tools

To disable access to the developer tools, add the following custom preference.

For general instructions on adding custom preferences, see Set Advanced User Preferences for the Browser (see page
334).

Mode pref
Custom devtools.toolbox.host
preference
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Type

Value

String

(leave the value field empty)

Disabling Crash Reports

To disable crash reports, add the following three custom preferences.

For general instructions on adding custom preferences, see Set Advanced User Preferences for the Browser (see page

334).

Mode

Custom
preference

Type
Value

Mode

Custom
preference

Type
Value

Mode

Custom
preference

Type

Value

IGEL OS Articles

pref

datareporting.policy.dataSubmission

Boolean
false
pref

datareporting.healthreport.upload

Boolean
false
pref

toolkit.telemetry

Boolean

false
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SSL/TLS Error with Firefox in Appliance Mode

Symptom

Firefox on IGEL Linux 5.07.100 warns of an SSL/TLS error in appliance mode that does not occur in normal window
mode. The error code is ssl_error_unsupported_version. This does not happen on IGEL Linux 5.06.x.

Problem

You cannot connect to the affected HTTPS service.

Solution
As a workaround you can instruct Firefox to ignore issues with SSL/TLS versions:

1. InIGEL Setup, go to System > Firmware Customization > Custom Commands > Base
Commands
2. Enter the following command into the After Session Configuration input field:

echo "clearPref(\"security.tls.version.min\");" >> /services/fbrw/

firefox/firefox.cfg

There is also an IGEL Linux private build that addresses this issue.
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Browser Cannot Download Files

Symptom

You are trying to view or download a file with the browser, but you get error messages instead.

Problem

The browser has no permissions for the file path you have selected for download. This is because the Firefox
browser is being guarded by AppArmor for security reasons.

Solution

Check whether one of the following possibilities for downloading files is applicable/available:

+ Storage hotplug device (USB flash drive) which is mounted to /media/[device name] or /

userhome/media/[device name]
For hotplug storage configuration, see Storage Hotplug.
« Network drive which is mountedto /mnt/[folder name]

+ Folder /userhome in the local file system; not persistent
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Some PDFs are not opened by Firefox

Symptom

When opening some PDFs from the Internet, the Mozilla Firefox browser opens a new window or tab, but fails to
display the PDF contents.

Problem

This can be due to a malfunction of the mozplugger Firefox component.

Solution

Disable mozplugger. Firefox will download the PDF document and open it with a local application (/GEL Linux
5.07.100 or newer):

1. Go to System > Registry in /GEL Setup.
2. Use Search Parameter ... to find the parameter
browserglobal.app.dom_ipc_plugins_enabled_mozplugger_so.

Check Completely disable mozplugger.
Confirm the setting with Apply or OK.
5. Restart Firefox.

> w
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< >

Configuration
s ons
Acc
User Interface
Network
Devices
Security
System

B Time and Date
» [ Update
» I Remote managemeant
» Il Remote Access
B Remote Syslog
» [l Power Options
» M Firmware Customization
‘ Registry

1y

IGEL Setup 10.05.500.01 (Build 5.9.18)

* Regis

Search amete

B conv_proxy_autoconfig_url
B conv_proxy_autologin
B conv_proxy_ftp
B conv proxy ftp_port
B conv_proxy_http
B conv proxy http_port

» [ conv_proxy_preset_cred
B conv proxy socks
B conv_prowy_socks_port
B conv_proxy_socks_version
B conv_proxy_ss!
B conv_proxy_ssl_port
B conv_proxy_type
B conv_save_browsehistory
B conv save forms
B conv_save_passwords

> I custom_config
B deactivate_hotkeys

B disablegstreamer
B disableopengl
B dom_disable_open_during_load

B dom_disable window flip

B dom_disable_window_move_resize

B dom event_contextmenu_enabled

B dom_ipc_plugins_enabled libflashplayer_so
B dom_ipc_plugins_enabled libnpjp2_so

B dom_ipc_plugins_enabled_libnptest_so

browserglobal.app.dom_ipc_plugins_enabled_mozplugger_so

Isolate PDF Viewer plugin process from the browser process

] Isolate PDF Viewer plugin process ...

B dom_ipc_plugins_enabled_libtotem-cone-plugin_s
B dom_ipc_plugins_enabled_libtotem-gmp-plugin_s
B dom_ipc_plugins_enabled_libtotem-mully-plugin_s
B dom_ipc_plugins_enabled libtotem-narrowspace-
B dom_ipc_plugins_enabled_mozplugger_so

B dom_ipc_plugins_enabled npica_so

B dom_ipc_plugins_timeoutsecs

Search

Ok Cancel
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Can | Install Firefox Extensions?

Question

Can Firefox extensions be installed?

Answer

The installation of Firefox extensions is not possible. This applies to any version of both IGEL Linux v5.x and IGEL OS.
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+ Resetting a Device with Unknown Administrator Password (see page 345)

+ Custom Boot Commands Are Still Active after Factory Reset (see page 347)

« How to Show the Boot Mode of IGEL OS (see page 348)

+ Disabling Features to Reduce Firmware Size (see page 349)

« Fabulatech USB Redirection Server Component (see page 350)

« Which Features of IGEL OS Will Be Affected If the UMS Is Down? (see page 351)
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Resetting a Device with Unknown Administrator Password

Symptom

An administrator password has been set on IGEL OS (via Setup > Security > Password > Administrator) but it has
been lost.

Problem

The local setup is not accessible without the password. Also, resetting the device to factory defaults seems
impossible.

Solution

+ Change the administrator password using IGEL UMS via Setup > Security > Password >
Administrator
or

+ Reset the device using IGEL UMS via Devices > Other commands > Reset to Factory Defaults in
the UMS menu.
or

+ Reset the thin client locally using a reset to defaults key provided by IGEL (as described below):

1. Pressthe [ESC] key repeatedly in rapid succession while the device is booting.
This will bring up the boot menu.

Juiet boot
Uerboze boot
Emergencg huut (Setup unlg]

RESE'I'. to facturg defaults j_

2. Choose Reset to factory defaults and press [Enter].
The following will be displayed:

Loading "German" keyboard layout.
The Administrator Password is required to reset the terminal settings.
If your Administrator Password is not available anymore, enter 3 times return.

Fassword :
Authentication: Authentication failure

Fassword :
Authentication: Authentication failure
Fassword: _

3. Press [Enter] three times without supplying a password.
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nter <{c> if guu want to continue and reset the terminal settings

in case your Administrator Password i= mot available anymore.
<r> Oor <cr. _

4. Enter[c] and press [Enter].
The software will then display a terminal key. Make a note of it, as you need it for requesting the
reset to defaults key from IGEL.
5. Request a reset to defaults key from IGEL. Write an email to license@igel.com® containing
« your terminal key
+ your email address as registered with IGEL support
« your company address
« your phone number

IGEL will send you the reset to defaults key.

6. Inthe current session, enter [e] and press [Enter] to shut down the device.

7. Onreceiving the reset to defaults key, repeat steps 1 to 3 to boot the device with the same
terminal key.

Enter [c] and press [Enter]. You will be prompted to enter the reset to defaults key.
3) enter now the “"reset to defaults key"”, you got by the service team
for "terminal key" 39099-53083-29440-48934 and firmware version 5.03.100.01
(you have only three tries to enter the key correctlyt)

1. Try: _

9. Enterthe reset to defaults key. Enter yes and press [Enter] to confirm resetting the client. All
local thin client settings will be lost.

Should you enter the wrong key or mistype the key you will have to resume from step 1.

35 mailto:license@igel.com
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Custom Boot Commands Are Still Active after Factory Reset

Symptom

You have reset your device to factory defaults, but the custom boot commands are still active.

Problem
After a factory reset, the following settings will still be available:
+ boot_-id
« uptime_total
« product
+ force_Legacy

+ The bootregentry Splash willbesetto 1

Solution
You can delete these settings manually with the following command:

1. Open a local terminal and login as root.
2. Enter the following command to delete the settings:

bootreg delete /dev/igfdisk boot_cmd

For further information about custom boot commands, see Custom Boot Command.
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How to Show the Boot Mode of IGEL OS

To check the boot mode of IGEL OS, proceed as follows:

1. Open the IGEL start menu.

2. Click thei-icon.
The About dialog opens.

3. Find the parameter Boot Mode under the Hardware section.
Example: BIOS
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Disabling Features to Reduce Firmware Size

Symptom
You want to update your IGEL OS firmware to a higher release version, but the firmware update requires more disk
space. Updating devices with less disk space than required leads to an error: Not enough space on local

drive.

Problem
The size of the new firmware

+ with all enabled software features included

+ with the NVIDIA graphics driver

« with the Firefox profile partition

+ possibly with a custom partition

+ possibly with custom wallpaper and bootsplash

exceeds the device's disk space (e.g. 2 GB).

Solution
Disable firmware features not needed for productive operation to reduce the size of the firmware:

In IGEL Setup, go to System > Firmware Customization > Features.
Disable features not needed in your environment.

Activate your settings with Apply or OK.

Reboot the device.

Update the device.

ok wnNE

(@ Use profiles with UMS in order to deactivate features on a group of devices.
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Fabulatech USB Redirection Server Component

Issue

For Fabulatech USB Redirection, a special Fabulatech server component must be installed on the Citrix or RDP
server (USB for Remote Desktop IGEL Edition). More detailed information on the function can be found on the
Fabulatech partner site®, On this site the server component is available for download.

Current versions are (as of 2017-05-29):

+ USB for Remote Desktop IGEL Edition Ver.3.1.5
+ USB for Remote Desktop IGEL Edition V5 Ver. 5.0.2

Problem
Which version is suitable for which IGEL Linux device?

Release notes of IGEL Linux only name the version of the Fabulatech client included but miss out the necessary
server component version.

Solution
> All Fabulatech clients version 3.x require server component version 3.x

> All Fabulatech clients version 5.x require server component version 5.x
So for IGEL Linux thin clients following requirements apply:

« IGEL Linux v4 devices up to current version 4.13.270 require server component version 3.x
« IGEL Linux v5 devices up to version 5.02.100 require server component version 3.x

+ IGEL Linux v5 devices from version 5.03.100 and later require server component version 5.x
+ IGEL Linux 10.x requires server component version 5.x.

36 http://www.usb-over-network.com/partners/igel/

IGEL OS Articles 350/823


http://www.usb-over-network.com/partners/igel/
http://www.usb-over-network.com/partners/igel/

System

Which Features of IGEL OS Will Be Affected If the UMS Is Down?

Overview

In general, IGEL OS works independently of the Unified Management Suite (UMS). This includes, for instance, all
remote desktop clients like Citrix, RDP, or VMware Horizon, and browsers.

Any configuration changes that are made via the UMS are stored on the device and thus remain stable when the
UMS is down.

However, the Shared Workplace (SWP) feature and administration functions are affected by a UMS outage.

The following sections list the details.

Productivity Features That Are Affected If the UMS Is Down
+ Login via Shared Workplace (SWP); see Shared Workplace (SWP)

Administration Functions That Are Affected If the UMS Is Down

+ Configuration changes

+ License Management

+ Secure Shadowing

+ Secure Terminal

« Universal Firmware Update

+ Firmware Customizations

« Transfer of files to the device, including Custom Partitions
+ Remote commands, such as Wake-on-LAN or restart
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« Configuring Open VPN Sessions (see page 353)

+ Running the OpenVPN Client with a Preconfigured Configuration File (see page 365)
« Configuring Wi-Fi Network Roaming (see page 367)

« Connecting to a Wi-Fi Network with Hidden SSID (see page 369)

« Improving WiFi Connectivity (see page 370)

+ Preventing Permanent Storage of Wireless Network Keys (see page 374)

« Using WPA Enterprise / WPA2 Enterprise with TLS Client Certificates (see page 375)
« |IPv6 Settings (see page 379)

« Extended Logging With Syslog, Tcpdump and Netlog (see page 383)

+ Making a Telnet Connection from IGEL Linux (see page 397)

+ Configuring Dynamic DNS Updates via DDNS (see page 398)

« Changing the SMB protocol version (see page 400)

« How to Launch the Wireless Manager within IGEL OS when the Taskbar Is Hidden (see page 401)
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Configuring Open VPN Sessions

This document describes how to configure the OpenVPN Client on IGEL Linux.

Prerequisites

+ A configured and running OpenVPN 2.x server

+ Information about the OpenVPN server configuration (e.g. authentication method)

+ Athin client with IGEL Linux 10.01.100 or newer

+ The certificate and private key files for the client, along with the root certificate of the CA that
signed the client and server certificates.

« Optionally, a Smartcard or eToken supported by IGEL Linux.
To learn how to distribute keys and certificates to the thin clients, refer to the How-To document
"Securely Distributing Keys and Certificates (see page 364)".

« Authenticating with TLS Certificates (see page 354)

« Authenticating with Name/Password (see page 355)

+ Authenticating with Name/Password with TLS Certificates (see page 356)
+ Authenticating with Static Key (see page 357)

« Options and TLS Options (see page 358)

« DNS and Routing Options (see page 359)

» Proxy (see page 360)

« Checking the VPN Connection (see page 361)

« Automatically Starting the VPN During Boot (see page 362)

» Further Information (see page 363)

« Securely Distributing Keys and Certificates for OpenVPN (see page 364)
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Authenticating with TLS Certificates

1.

Go to Network > VPN > OpenVPN and create a new connection.

In the Session section for the new connection, enter the name or public IP address of the
OpenVPN Server.

Select TLS-Certificates as the Authentication Type.

Select the client certificate as the Client Certificate file.

Select the root certficate of the CA as the Certificate Authority (CA) file .

Select the client's private key as the Private Key file. Enter the passphrase in Private Key
password if the key is protected with one.

®* Opent'Ph Connection

OpenyPR Server(s) |1?2.3IZI.EI1 136 |

Configuration

B Mobie Broadband
» Il DHCP Client
¥ [ ven
O Open WPM
r[O Open'yPN Connection
. Session
‘ Options

Click anicon for the newly created session (e.g. in the Start Menu) to initiate the connection.

Sessions Authertication Type | TLE-Certificates v
-"—". SCESS "'.._:
AEEESSANES Clientt Centificate file |clier|t.u:rt |
User Interface
CA certificate file |ca.cr1 |
- . LAM Interfaces Private key file ||:Iier|t.ke3-' |

EEEEE

Private Key paz=ward

@ IfaPKCS12fileis available, which includes the client certificate, the certificate authority
and the private key, then you just need to enter the PKCS12 file name in the three
corresponding fields. The advantage is that you only have to roll out one single file instead
of three different files.

IGEL OS Articles 354 /823



Network

Authenticating with Name/Password

1. Goto Network >VPN > OpenVPN and create a new connection.

2. Inthe Session section for the new connection, enter the name or public IP address of the
OpenVPN Server.

3. Select Name/Password as the Authentication Type.

4. Enter the Username. If you leave this field blank the user will be prompted for the Username when
connecting.

5. Check Password required.

6. Enter the Password. If you leave this field blank the user will be prompted for the password when

connecting.

Select the root certficate file of the CAAs the Certificate Authority (CA) file.

} ot i " network ™ VPN ™ Open PR P OpenPR Connection

Configuration Open'PM Server(s) | 172.30.91 136

Authertication Type lNamEJPasswcurd T]

Uzer name | client1 |

User Interface
[;_f] Passward recuired

Pazsward ******|

» I L&N Interfaces
B obile Broadband
» Il DHCP Client
¥ 3 ven
O3 Open VPN
A | Open'PH Connection
. Session
n Cptions

8. Click anicon for the newly created session (e.g. in the Start Menu) to initiate the connection.

CA& cedificate file ||:a.|:rt |
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Authenticating with Name/Password with TLS Certificates

1. Goto Network >VPN > OpenVPN and create a new connection.

2. Inthe Session section for the new connection, enter the name or public IP address of the
OpenVPN Server.

3. Select Name/Password with TLS-Certificates as the Authentication Type.

4. Enter the Username. If you leave this field blank the user will be prompted for the username when
connecting.

5. Check Password required.

6. Enter the Password. If you leave this field blank the user will be prompted for the password when
connecting.

7. Select the client certificate as the Client Certificate file.

8. Select the root certficate of the CA as the Certificate Authority (CA) file.

9. Select the client's private key as the Private Keyfile. Enter the passphrase in Private Key

password if the key is protected with one.

k- ® WP ® Open PR ® OpentPR Connection ® Session

Open'yPR Server(s) 1723091 136

Configuration

e Authertication Type | MamePassword with TLS-Certificates v|

Accessories i
User name client]
User Interface .
[;_F] Pazzwoard required

Pazzwoard FAERER

» [ LAN Interfaces .
‘ Nohile Broadband Client Certificate file client.crt
» I DHCP Cliert .
* [ veN CA certificate file ca.crt
¥ 8] WPMN [
B3 Open Private key file client key
* O Open''PM Connection
. Session Private Mey password fia
. Options

10. Click anicon for the newly created session (e.g. in the Start Menu) to initiate the connection.

@ IfaPKCS12fileis available, which includes the client certificate, the certificate authority
and the private key, then you just need to enter the PKCS12 file name in the three
corresponding fields. The advantage is that you only have to roll out one single file instead
of three different files.
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Authenticating with Static Key

Go to Network > VPN > OpenVPN and create a new connection.

In the Session section for the new connection, enter the name or public IP address of the
OpenVPN Server.

Select Static Key as the Authentication Type.

Select the static key file as the Private Key.

Select None as the Key Direction.

Enter the server's VPN IP address as Remote IP Address.

Enter your client's VPN IP address as Local IP Address.

> i® petwork ™ WPN P Open VPN ™ OpenPM Connection ™ Session

Cunﬁguratiun Openy'PH Server(s) |1T2.3EI.EI1 136

Authertication Type | Static Key v|
Private key file ||:Iier|t.kev
User Interface

Remaote [P Address |192.1 51231

» Il LAN Interfaces
B 'obile Broadband
» [l DHCP Client
* 3 wen
*xO Open VPN
*[O Open''PH Connection

I Session

‘ Options

Key Direction lNu:une v]

Local IP &ddress |192.1 B5.123.2

8. Click anicon for the newly created session (e.g. in the Start Menu) to initiate the connection.
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Options and TLS Options

Options

Under Network > VPN > OpenVPN > [Session Name] > Options, you can set various options for the OpenVPN
client. Usually, you can leave the default settings as they are. If the server uses compression, enable Use LZO data
compression.

() When using a proxy, set Protocol used for communication to the host to tcp-client.

TLS Options

Under Network > VPN > OpenVPN > [Session Name] > TLS-Options, you can set various TLS-related options. In
particular, you can configure whether the remote peer certificate will be verified.
For details about these settings, refer to Configuring Open VPN Sessions (see page 353) or OpenVPN.
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DNS and Routing Options

By default, OpenVPN automatically uses the server's settings for DNS and routing.
If you want to change these settings, go to Network > VPN > Open VPN > [Session Name] > IPv4. Here you can:

+ Deactivate Automatic DNS

« Add Extra nameserver(s)

+ Add Extra search domains
Deactivate Automatic Routes
Deactivate VPN is the default route

Additionally, you can enable three custom routes in Network > VPN > Open VPN > [Session Name] > Route
[0,1,2]. For each enabled route you can configure:

+ whetheritis a Network Route or a Host Route

Network/Host IP

Network Mask (for Network Route only)

Optional: Gateway

Optional: Metric (a quality rating used for routing decisions, 0 being the best)
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Proxy

If you wish to configure a proxy for your VPN connection, go to Network > VPN > OpenVPN > [Session Name] >
Proxy. Here you can configure:

« Proxy Type: SOCKS or HTTP, by default this is set to None
+ Proxy Address and Proxy Port
+ Retry indefinitely when errors occur

If you select the HTTP proxy type you can configure:
+ Proxy Username
+ Proxy Password

@ When using a proxy, set Options > Protocol used for communication to the host to tcp-
client.

® When experiencing issues with OpenVPN, read the messagesin /var/log/messages,
e.g. using the System Log Viewer.
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Checking the VPN Connection

As soon as a VPN connection is established, a lock icon with connected plugs is shown in the panel:

DE ll))l__ﬂ_," 11:21 | 4
L

However, this only serves as an indicator. To be sure that the VPN connection really exists:

1. Open aLocal Terminal.
2. Runthe command 1ifconfig.

3. Check whether the output containsa tun device with an IP address from the private network.

Terminal =k e

user@IGEL -Q0ABCAGS50027 :~$¢ ifconfig

eth@ Link encap:Ethernet HwWaddr 00:0b:ca:05:00:27
inet addr:172.30.91.219 Bcast:172.30.255.255 Mask:255.255.0.0
inet6 addr: feBO::20b:caff:fe@5:27/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:150@ Metric:1
RX packets:1091674 errors:0 dropped:47 overruns:0 frame:@
TX packets:125138 errors:0 dropped:@ overruns:@ carrier:@
collisions:0 txgueuelen:1000
RX bytes:79070067 (79.0 MB) TX bytes:58744380 (58.7 MB)
Interrupt:105 Base address:0xal@@@

lo Link encap:lLocal Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:85536 Metric:1
RX packets:108954 errors:0 dropped:@ overruns:@ frame:0
TX packets:108954 errors:0 dropped:@ overruns:@ carrier:0@
collisions:0 txgueuelen:@
RX bytes:45078307 (45.0 MB) TX bytes:45078307 (45.0 MB)

itun® Link encap:UNSPEC Hwaddr|GG-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet addr:192.168.123.10 |P-t-P:192.168.123.9 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:150@ Metric:1
RX packets:23080 errors:0 dropped:0 overruns:@ frame:0
TX packets:48007 errors:0 dropped:74 overruns:@ carrier:0@
collisions:0 txgueuelen:100
RX bytes:1266538 (1.2 MB) TX bytes:63784736 (63.7 MB)

user@lGEL -GO0BCAGSE027 :~% |

4. Additionally, check whether you can ping the VPN server's private IP address.
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Automatically Starting the VPN During Boot

(@ Ifyou want to update the firmware via the VPN, you need to enable Autostart During Boot. Enabling
Autostart of the control application in Network > VPN > OpenVPN > [session name] is not adequate!

Go to Network > VPN > OpenVPN.

Check Enable Autostart During Boot.

Select one of the configured sessions.

Click Set Auto.

The session will be marked in the Auto column.

Click Set Auto again to dectivate autostarting the session.

Rl e

@ The system will prompt you for key pass phrases or the eToken/smartcard PIN if
necessary.
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Further Information
Further information about OpenVPN can be found in

« the OpenVPN how-to®* and
« the OpenVPN manual page®®

maintained by the OpenVPN project.

37 https://openvpn.net/index.php/open-source/documentation/howto.html
38 https://openvpn.net/community-resources/reference-manual-for-openvpn-2-0/
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Securely Distributing Keys and Certificates for OpenVPN

Use the file distribution mechanism in the Universal Management Suite (UMS) to securely distribute keys and
certificates to the thin clients:

1. Select Undefined as the Classification.
. Enter /wfs/OpenVPN/ as the thin client file location.

2
3. Enable the Read permission for the Owner exclusively, and uncheck all remaining permissions.
4. Select Root as the Owner.

Mew file x

File source
@ Upload local file to UMS server

Local file Clsersiddministratoniclient?.key Q
Upload location (URL) | hitps:#172.30.91.23:8443/ums_filetransfer/ -
() Selectfile from UMS server
File location (URL) | [
File target
Classification [Undeﬁned .*]

Thin Client file location | swfs/OpenyVPR/

Access rights

Read Write Execute
owner [ [ U]
others [ [ ]

Owner |Root ¥

IGEL OS Articles 364 /823



Network

e

IGE

Running the OpenVPN Client with a Preconfigured Configuration File

& Solution Based on Experience from the Field

This article provides a solution that has not been approved by the IGEL Research and Development
department. Therefore, official support cannot be provided by IGEL. Where applicable, test the solution
before deploying it to a productive environment.

This article describes a basic solution for getting the built-in OpenVPN client running with a preconfigured
configuration file. This is an alternative to using the Setup for configuration.

Environment
This article is valid for the following environment:

+ IGEL OS 10 or higher
¢ OpenVPN server

Setting up an OpenVPN Connection with a Preconfigured Configuration File

1. Inthe UMS Console, open the context menu on Files and select New File.
Selectyour .ovpn filein the file system.

In the File target section, under Devices file location, enter "/wfs/".

Click Ok.

The file is uploaded to the UMS.

5. Assign the file object to your device by clicking the "+" symbol in the Assigned objects area (upper
right).

6. Create a profile with a suitable name, e. g. "OpenVPN Connection".

7. Inthe profile, go to System > Firmware Customization > Custom Commands > Network.

8. Inthe Final network command field, enter the following code, replacing example.ovpn with

W

the correct filename:

while :; do if [ -z $(pgrep openvpn) ]; then echo "openvpn is not
running"; openvpn --config /wfs/example.ovpn --auth-user-pass
<(echo -e $(zenity --forms --text="Enter your VPN credentials" --
add-entry=Username --add-password=Password --title=0OpenVPN) | sed
's/|/\n/"); else echo "openvpn is running"; fi; sleep 1; done &

9. Click Save to save the profile.
10. Assign the profile to your device by clicking the "+" symbol in the Assigned objects area.
11. Reboot the device.
After reboot, you should see a login window for OpenVPN.
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12. Enter your OpenVPN credentials.
If the login was successful, a Network connecting popup appears briefly. No other indicator is
shown. You can disconnect only by rebooting the device.
If the login has failed, the login window reappears.

Removing the OpenVPN Connection

» To remove the OpenVPN connection from the settings, unassign the profile from the device and reboot it.
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Configuring Wi-Fi Network Roaming

Issue

Different wireless network instances have been configured for a mobile device. The device should switch over to the
strongest network automatically.

Solution

Parameters to configure Wi-Fi roaming options can be found in the IGEL registry (Setup > System > Registry).
These settings should be changed by experts only.

Parameters for better control of Wi-Fi roaming capabilities with access points that share the same
SSID:
network.interfaces.wirelesslan.device0.lock_initial

Default: false

If true ,the device will stick to the access pointitis connected to even if candidates with better
signal quality are present.

Setting this parameterto true isa last resort for problems that are caused by too much
roaming.

network.interfaces.wirelesslan.device0.bgscan.module
Default: default (Perservingthe unpachted NM's behaviour)
Possible values:

default :Nobackground scanningisdone.

simple :The Wi-Fi module tries to scan for a potentially better signal in the background.

bgscan.module simple provides following options:

network.interfaces.wirelesslan.device0.bgscan.simple.signal_strength (default: -45 dBm)
This defines a threshold that determines which of the following two parameters shall be effective:

network.interfaces.wirelesslan.device0.bgscan.simple.short_interval (default: 30 s)

Interval between background scans (in seconds) if the actual signal level of the currently
connected access point is worse than signal_strength.

network.interfaces.wirelesslan.device0.bgscan.simple.long_interval (default: 300 s)

Interval between background scans (in seconds) if the actual signal level of the currently
connected access point is better than signal_strength.
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® i parameter lock_initialis true ,itis recommended to set bgscan.module to none .

« Parameters to control Wi-Fi roaming between Wi-Fi networks with different SSIDs:
network.interfaces.wirelesslan.device0.mssid_check_interval (default: 10 s)

The interval in seconds between checking if automatic roaming might be neccessary. This includes
detecting that a connection has been lost and a new one should be established.

network.interfaces.wirelesslan.device0.mssid_quality_threshold (default: 20 )

If the current connection's quality percentage is below this value, scanning will be performed to
find a potentially better network.

network.interfaces.wirelesslan.device0.mssid_quality_difference_threshold (default: 40 )

A candidate for automatic roaming is only considered if its quality percentage is this much better
than the current connection's quality.

network.interfaces.wirelesslan.device0.mssid_previously_used_threshold (default: 55 )
During boot: If the previously used SSID's quality percentage is above this threshold, it is preferred.

network.interfaces.wirelesslan.device0.mssid_user_selection (default: false)

If true ,theusercan initiate roaming to a network via the Wi-Fi tray icon's context menu (must
be enabled).

If automatic roaming shall not interfere with the user's choice, the following values are
appropriate:

network.interfaces.wirelesslan.device0.mssid_quality_threshold= 0
network.interfaces.wirelesslan.device0.mssid_quality_difference_threshold= 101

network.interfaces.wirelesslan.device0.mssid_previously_used_threshold= 0
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Connecting to a Wi-Fi Network with Hidden SSID

Symptom

The device does not connect to a wireless network with hidden SSID.

Problem

An option in the device's network configuration is missing.

Solution

If you need to configure a hidden access point, proceed as follows:

1.
2.

Hw

Start IGEL Setup or open the device configuration dialog in the UMS.

Go to Network > LAN Interfaces > Wireless > Default Wi-Fi network (or Additional Wi-Fi
networks depending on your configuration).

Choose Enable WPA Encryption.

Set parameter AP Scan mode to "no broadcast".

Click Apply or Ok to save the settings.

4 > ~ / * Network » LAN Interfaces * Wireless » Default Wi-Fi network

Configuration ﬂ . =
(U Disable Encryption () Enable WEP Encryption (® Enable WPA Encryption

wireless Network Name (SSID)

User Interface

Network Network authentication | wPa Persanal v|  Network key

¥ O LAN Interfaces Data encryption | Defautt Y] I AP Scan mode 8} [no broadcast M| I
» Il interface 1
» Il Interface 2
¥ [ wireless
i Default Wi-Fi network
B 2dditional Wi-Fi networks
B Wireless regulatory domain
B Mobile Broadband

Search

Cancel
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Improving WiFi Connectivity

Problem

Your WiFi connection is unstable, or weak, or both.

Environment

« UDC with IGEL Linux v5??? or IGEL OS??? or higher???
+ UD Pocket IGEL Linux v5??? or IGEL OS??? or higher???

Possible Causes and Solutions

There are many circumstances and parameters which influence the quality of a device's WiFi connection. To find a
suitable solution to your problem, check out the following collection of possible causes and suggested solutions,
workarounds and hints for debugging.

Several Access Points (APs) Are Using the Same Channel

If more than one Access Points visible to the thin client are using the same WiFi channel, interference issues may
arise.

> Reconfigure the Access Point (AP) in question to use different channels.

Roaming within One Network (Same SSID)

When the device is configured to roam within its network, it tries to make sure that it is using the strongest/nearest
Access Point (AP) within its network. Dependent on the given situation, it might be feasible to disable or to optimize
roaming.

See also Configuring Wi-Fi Network Roaming (see page 367).

Avoid Roaming

» Inthe Setu p, go to System > Registry > network > interfaces > wirelesslan > device0 > lock_initial (Registry
key: network.interfaces.wirelesslan.device0.lock_initial)and activate Avoid roaming
within the same network.

() Ifroamingis deactivated, System > Registry > network > interfaces > wirelesslan > device0 > bgscan >
module should be set to none.
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Select the Access Point with the Best Signal

With the following setting, the thin client selects the Access Point that emits the best signal when the device starts

up.

> In the Setu p, go to System > Registry > network > interfaces > wirelesslan > device0 > bssid (Registry

key: network.interfaces.wirelesslan.device0.bssid )andenter bestsignal inthe BSSID field.

Automatic Roaming

Automatic roaming is feasible if the device is moved around frequently, and several Access Points are available.

In the following example, the device is configured to start scanning for another Access Point 10 seconds after the
signal of the current Access Point has dropped below -78 db, while a routine scan is executed every 60 seconds, :

1. Inthe Setup, go to System > Registry > network > interfaces > wirelesslan > device0 > bgscan >

module (Registry key: network.interfaces.wirelesslan.device0.bgscan.module)
and select simple.

. Set System > Registry > network > interfaces > wirelesslan > device0 > bgscan > module >

simple > long_interval (Registry
key: network.interfaces.wirelesslan.device@.bgscan.module.simple.long_

interval)to60.

. Set System > Registry > network > interfaces > wirelesslan > device0 > bgscan > module >

simple > short_interval (Registry
key: network.interfaces.wirelesslan.device0.bgscan.module.simple.shor

t_interval)to 10.

. Set System > Registry > network > interfaces > wirelesslan > device0 > bgscan > module >

simple > signal_strength (Registry
key: network.interfaces.wirelesslan.device0.bgscan.module.simple.sign
al_strength)to-78.

40 MHz Bandwidth in the 2.4 GHz Band
With some Access Points, it may be feasible to disable the 40 MHz bandwidth in the 2.4 GHz band.

> In the Setu p, go to System > Registry > network > interfaces > wirelesslan > device0 > driver > cfg80211
> cfg80211_disable_40mhz_24ghz (Registry
key: network.interfaces.wirelesslan.device@.driver.cfg80211.cfg80211_disable_40mh

z_24ghz ) and deactivate Disable 40 MHz channel bandwidth in 2.4 GHz band.

High Throughput Option

In some environments, the high throughput functionality built into the driver may not produce optimal results. You
can disable this functionality and check if the connection has improved.
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> Inthe Setu p, g0 to System > Registry > network > interfaces > wirelesslan > device0 > driver >
disable_ht (Registry key: network.interfaces.wirelesslan.device0.driver.disable_ht)and
deactivate Disable HT.

2.4 GHz Band Only
In some environments, it might be better to use only the 2.4 GHz band.

» In the Setu p, go to System > Registry > network > interfaces > wirelesslan > device0 > band (Registry key:
network.interfaces.wirelesslan.device0.band )and select 2.4 GHz.

If one or more alternative WiFi networks (SSIDs) are configured, do the following for each alternative SSID:

> Inthe Setu p, go to System > Registry > network > interfaces > wirelesslan > device0 > alt_ssid[number] >
band (Registry key: network.interfaces.wirelesslan.device@.alt_ssid[number].band)and
select 2.4 GHz.

Frame Aggregation

It might be helpful to disable the frame aggregation feature of IEEE 802.11n.

> Disable frame aggregation on your Access Point (AP).

() OnyourAccess Point, this feature may have a different name.
Also note that IGEL cannot give a guarantee that the Access Point will function properly after the
suggested configuration changes.

WiFi Driver Scans And Selects Access Point

By default, the WPA supplicant initiates scanning and the selection of an Access Point. You can change this behavior
and assign this task to the driver.

1. Inthe Setup, go to System > Registry > network > interfaces > wirelesslan > device0 > wpa >
ap_scan (Registry key: network.interfaces.wirelesslan.device®O.wpa.ap_scan)

and select WLAN driver initiates scanning and AP selection.
2. Restart the thin client.

Whitelist of BSSIDs

You can restrict the number of Access Points to be scanned by creating a whitelist. This whitelist contains only the
BSSIDs of those Access Points that the device should scan.

In the Setup, go to System > Registry > network > interfaces > wirelesslan > device0 > bssid_whitelist (Registry
key: network.interfaces.wirelesslan.device0.bssid_whitelist )and enterthe BSSIDs of those
Access Points that should be scanned, separated by whitespaces.
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Debugging
If none of the methods described above work, you can create a log file and send it to the IGEL Support Team.
1. Inthe Setup, go to System > Registry > network > interfaces > wirelesslan > device0 > wpa >
debug (Registry key: network.interfaces.wirelesslan.deviceo.wpa.debug)and

select very verbose.
2. Restart the thin client.

3. Sendthefile /tmp/wpa_debug.all totheIGEL Support Team.
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Preventing Permanent Storage of Wireless Network Keys

This document describes how to prevent users from storing wireless network keys/passwords for Wireless
Manager on the endpoint device.
1. In Setup, go to System > Registry.
. Gotothe network.applet.wireless.allow_storing_credentials parameter.

2
3. Uncheck Allow permanently storing credentials, which is checked by default.
4. Click Apply.

This will affect the Wireless Manager dialogs for wireless networks with the network authentication methods in
their variants requiring passwords:

+ WPA Personal

« WPA Enterprise
+ WPA2 Personal
+ WPA2 Enterprise

In particular, users will not have check boxes labeled Permanently store identity and password or Permanently
store network key available.
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Using WPA Enterprise / WPA2 Enterprise with TLS Client Certificates

This document describes how to use UMS to configure Wi-Fi connections on IGEL OS with WPA Enterprise / WPA2
Enterprise and TLS client certificates.

There are two options for supplying client certificates and keys to devices:

Via SCEP (NDES)

SCEP allows the automatic provisioning of client certificates via an SCEP server and a certification authority (CA).

Learn how to configure it, using How-To Certificate Enrollment and Renewal with SCEP (NDES) (see page 464).

Via Files Served from UMS

You need:

+ aclient certificate in PEM (base64) format
+ aclient private key (needs to be passphrase-protected) in PEM (base64) format

Alternatively,

+ a PKCS#12 file containing both client certificate and private key (needs to be passphrase-
protected).

() Inboth cases, SCEP and files from UMS, the device needs to have a working Ethernet or Wi-Fi connection
to the SCEP server or the UMS first, so that it can fetch the necessary certificates before it can connect to
the target Wi-Fi.

+ Deploying Client Certificates and Keys (see page 376)
+ Configuring the Network Interface (see page 377)
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Deploying Client Certificates and Keys

To deploy client certificates and keys via UMS, follow these steps for the client certificate and client private key files
(or the PKCS#12 files containing both):

1.

PN G A~ WN

In the UMS Console navigation tree, right-click Files and select New file from the context menu.
The New file dialog opens

Under File source, use the file chooser to choose the file as the Local file.

Under File target, leave the classification as Undefined.

Set the Thin Client file locationto /wfs/wpa-tls/

Under Access rights, set check Read and Write for the Owner and none for Others.
Set the Owner to Root.

Click OK to upload the file.

Drag the file icon onto a thin client or thin client directory in order to assign the file.
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Configuring the Network Interface

This describes how to configure the Wi-Fi interface.

() Inboth cases, SCEP and files from UMS, the device needs to have a working Ethernet or Wi-Fi connection

to the SCEP server or the UMS first, so that it can fetch the necessary certificates before it can connect to
the target Wi-Fi.

Using SCEP (NDES)

NoohkwnN

10.
11.

In Setup go to Network > LAN Interfaces > Wireless.

Check Activate Wireless Interface.

Go to Default WiFi-network.

Select Enable WPA Encryption.

Enter the Wireless Network Name (SSID).

Select WPA Enterprise or WPA2 Enterprise according to your preferences.
Set EAP Type to TLS

or set EAP Type to PEAP and Auth Method to TLS.

(@ IGEL OS supports both EAP-TLS and PEAP-EAP-TLS. Choose one that is supported by your
infrastructure.

Leave Validate Server Certificate enabled.

Enter the path to a CA Root Certificate if you use a CA other than those supported by IGEL OS (see
page 484).

Check Manage Certificates with SCEP (NDES).

Click Save.

Using Certificate and Key Files

Nk~ wN

In Setup go to Network > LAN Interfaces > Wireless.

Check Activate Wireless Interface.

Go to Default Wi-Fi network.

Select Enable WPA Encryption.

Enter the Wireless Network Name (SSID).

Select WPA Enterprise or WPA2 Enterprise according to your preferences.
Set EAP Type to TLS

or set EAP Type to PEAP and Auth Method to TLS

@ IGEL OS supports both EAP-TLS and PEAP-EAP-TLS. Choose one that is supported by your
infrastructure.

Leave Validate Server Certificate enabled. Enter the path to a CA Root Certificate if you use a CA
other than those supported by IGEL OS (see page 484).
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9. Enter the path to the Client Certificate file in PEM (base64) format, e.g. /wfs/wpa-tls/

client.crt.

Leave this field blank if you use a PKCS#12 file containing both certificate and private key.
10. Enter the path to the Private Key file in PEM (base64) format.

If you use a PKCS#12 file containing both certificate and private key, enter its path here.
11. Specify the Identity to be used if your key/certificate contains more than one entry.
12. Enter the Private Key Password.
13. Click Save.
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IPv6 Settings

IGEL Linux version 5.07.100 or newer and IGEL Linux version 10.01.100 or newer offer new options for configuring
network interfaces for IPv6.

Application Scenario

IGEL devices cannot so far communicate with the UMS via IPv6. Therefore, the major application scenario for IPv6 is
as follows:

+ Devices still receive their IPv4 configuration and potentially /GEL-specific DHCP options from a
DHCPv4 server.
Most of the settings are received from the UMS via IPv4.
Only the default options are requested from the DHCPv6 server. These are as follows:
+ IPv6 address
« nameservers
+ DNSsearch list.
Regarding DNS, only IPv6 nameserver addresses should be delivered (in router advertisements or
DHCPv6 options). The resolver should be able to use these for retrieving AAAA records and also A
records if necessary.
Clients and servers use IPv6 if they are prepared to do so.
Examples:
« An NTP server (System > Time and date > NTP time server) can be specified as an IPv6
address or as a name for which the DNS has only an AAAA record available.
+ Similarly, in a web browser session, IPv6 will be used when the DNS has AAAA records
available for servers.

« Available Configurations (see page 380)
« Timeouts in Automatic Configuration (see page 382)
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Available Configurations

IPv6 support is configured by network interface in Network > LAN Interfaces:

“ DIIT Setup 5.07.100.rc8,01 (Build 4.9.12)

P LAN Interfaces ™ Interface 1

L . =
L]
SEEELEEIES Athentication  Wake On Lan
User Interface
¥ W3

- Metwork .
¥ LAM Interfaces T

» o Interface 1 Metwark Mask 255,255,255.0

o Interface 2

B Wireless
" SF'HI‘(-iP Client IPvB-Configuration
[ =
b o SCEF Client (NDES) C?"“E?t;blllty mode
» o Routing Disable .

~ Hosts Metwark Linktype Automnatic

i DHCPwS

> & Network Drives Force guto-negotiation

-~ Prowy

[ Enable tray icon
Search [¥/] Enable context menu ’

The following configurations are available:

Value Effect

Compatibilty

Equivalent to former versions of IGEL Linux: NetworkManager ignores the

mode device, but the kernel performs some basic configuration. In particular, it
assigns an IPv6 link local address to the device.

Disabled

Automatic

IPv6 is disabled completely.

The device tries to perform an IPv6 stateless or stateful autoconfiguration

based on router advertisements. Depending on the router advertisements,

this involves DHCPvV6 (see RFC 4861).
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DHCPv6 This option is supported by NetworkManager. It can be used when a DHCPv6
server is available but no router advertisements. Routing has to be
configured by other means. In most cases Automatic will be preferable.

@ Inallcases IPv4 is configured in the usual way.
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Timeouts in Automatic Configuration

If Automatic is selected, there is a configurable timeout for the dual stack mode. This is the time that the system
waits after the first of the stacks IPv4 or IPv6 has completed its configuration for the other stack to complete its own
configuration. After this time has elapsed, it runs the scripts that depend on the network being up. The default
timeout value is 15 seconds.

The timeout can be configured with the following parameters in System > Registry:

Parameter Device

network.interfaces.ethernet.device0.dual stack_ Firstethernetdevice

timeout

network.interfaces.ethernet.devicel.dual_stack_ Second ethernetdevice

timeout

network.interfaces.wirelesslan.device®.dual_ Wireless LAN device

stack_timeout

® Use the Search parameter ... function with the string dual_stack to find these parameters quickly.
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Extended Logging With Syslog, Tcpdump and Netlog

The IGEL OS Registry offers a number of extended logging options that can help customers, Support and PreSales
debug system and network issues.

For instructions on how to send log files to the IGEL support team via the UMS, see Sending Thin Client Log Files to
IGEL Support (see page 383).

Debuglog Partition (see page 384)
Syslog (see page 386)

« Tcpdump (see page 387)

Netlog (see page 390)
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Debuglog Partition

Logfiles can get very large quite fast. This is why they are stored in a separate partition. It is mounted at /

debuglog .

Enabling and Configuring the Debuglog Partition

The partition is enabled and configured in the Registry:

IGEL Setup > System > Registry

> Enable debuglog debug.tools.log_partition.enabled enabled / disabled
partition

Enables the debuglog partition.

IGEL Setup > System > Registry

> Size of debuglog debug.tools.log_partition_size 50...500/ 100
partition in MiB

© Resizing the debuglog partition will delete its contents!

Debuglog Partition Contents

Depending on which logging options you enable (see the following topics), you may find the following files in the
debuglog partition:

+ Syslog

+ messages (the currentsyslog)

+ messages[1-9].gz (compressed and rotated syslog)
Ethtool

+ netlog-ethtool-[device].log
+ Ping

+ netlog-host-[0-9]-ping.log (pinglog)
+ netlog-host-[0-9]-ping[n].log.gz (compressed and rotated ping log)
Ifconfig

+ netlog-ifconfig-[device].log
Netstat
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+ netlog-netstat.log (netstatlog)

+ netlog-netstat[n].log.gz (compressed and rotated netstat log)
+ Socket Status
+ netlog-socket_status.log (socketstatus log)

+ netlog-socket_status[n].log.gz (compressed and rotated socket status log)
« Tcpdump

+ tcpdump[0-3]_capture_current[n] (tcpdump capture)

+ tcpdump[0-3]_capture-[n].pcap.{lzo,gz,bzip2,xz} (compressed and

rotated tcpdump captures)
+ Tcpdump triggered by an error

« ERROR_[timestamp]/tcpdump[0-3]_capture-[n].pcap.

{1zo,gz,bzip2,xz} (compressed and preserved tcpdump captures)
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Syslog

It is possible to send all syslog messages that are writtento /var/log/message (IGEL Linux version 5.10.250

and versions 5.11.x) or to the systemd journal (IGEL Linux version 10.01.100) to the debuglog partition as well. The
logfile will be rotated and compressed as needed. This preserves the log if the thin client crashes, and logs from
several previous boots.

Configure it in the Registry:

IGEL Setup > System > Registry

> Enable syslog logto  debug.tools.syslog0.enabled true/ false
debuglog partition

IGEL Setup > System > Registry

> Number of Rotate Files debug.tools.syslog0.num_rotate_files 2..9
Number of files to be kept while rotating.

IGEL Setup > System > Registry

> Logfile rotate sizein  debug.tools.syslog0.rotate_size 2,4,8,16
MiB

Rotate when the size of the compressed file reaches this size in MiB.
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Tcpdump

Tcpdump will help you debug network issues by capturing packets from up to 4 individual network interfaces.

(@ Using the Netlog (see page 390) facility, it is possible to copy capture files to a subdirectory, triggered by an
error in another log, so the captures before and after the error will be preserved for your analysis.

() Youcanuse Wireshark on an external system for analyzing capture files.

Find out more about Tcpdump from its homepage®.

IGEL Setup > Registry
> Resolve addresses/ports to debug.tools. tcpdump[0-3]. enabled/disabled

names .
address_resolution

IGEL Setup > Registry

> Compression Method debug.tools. tcpdump[0-3] . 1zop, gzip, bzip2, xz

compression

The compression method affects file size as well as system performance while compressing. The
default [zop methiod is relatively light on the CPU.

IGEL Setup > Registry
> Interface for tcpdump debug.tools. tcpdump [0- user editable string / ethQ
logging .
3] .interface
IGEL Setup > Registry

>Number of Rotate Files  gepug.tools.tcpdump[0-3].num_rota 310
te_files
Number of files to be kept while rotating.

IGEL Setup > Registry

39 http://www.tcpdump.org
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> Only Log Package Headers debug.tools.tcpdump[0-3] . enabled/disabled
only_headers

IGEL Setup > Registry
> Enable promisc tcpdump debug. tools. tcpdump [0-3] enabled/disabled
logging .

.promisc

Enable promiscuous mode on the network interface to also capture packets not intended for
this host.

IGEL Setup > Registry

].rotate_size

Rotate when the size of the uncompressed file reaches this size in MiB.
IGEL Setup > Registry
> Logfile rotate timeins debug. tools. tcpdump [0-3 O/ user editable integer

].rotate_time

Time in seconds after which the logfile is rotated and compressed. If set to 0 no time-based
rotation happens.

IGEL Setup > Registry
>Additional Parameters for  gepug.tools.tcpdump[0-3] usereditable string

tcpdum
P P .tcpdump_additional_param

eters
Use with care.
IGEL Setup > Registry
> Enable tcpdump debug.tools. tcpdump[0-3] . tc enabled/disabled
pdump_enabled
IGEL Setup > Registry

>tcpdump filter expression  depug. tools. tcpdump[0-3 User editable string

].tcpdump_filter
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Tcpdump filter expression. For the expression syntax, see the pcap-filter(7)* manpage.

40 http://www.tcpdump.org/manpages/pcap-filter.7.html
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Netlog

The netlog facility combines the following network diagnosis tools:

+ ethtool

- ifconfig

+ netstat

+ ping

+ ss (socket status)

It can also trigger tcpdump .

IGEL Setup > Registry
> Enable netlog logging debug.tools.netlog.enabled enabled / disabled
IGEL Setup > Registry

> period between netlog logs in debug.tools.netlog.period
3

1,5, 10, 20, 30, 60, 120

Ping logging is not affected by this and uses its own timing.

 Ethtool (see page 391)

+ Ifconfig (see page 392)

« Netstat (see page 393)

+ Ping (see page 394)

» Socket Status (ss) (see page 396)
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Ethtool

Ethtool is the standard Linux utility for getting diagnostic information about wired Ethernet devices and their
drivers.

IGEL Setup > Registry
> Disable ethtool logging debug.tools.netlog.ethtool.disabled true / false
By default Ethtool logging is included in Netlog logging. However, you can disable it here.

IGEL Setup > Registry
> Log only if ethtool debug.tools.netlog.ethtool.log_on_changes true /false
output changes _only

Log only if ethtool output changes (on bootup there will always be at least one log entry)
IGEL Setup > Registry
> Number of Rotate Files debug.tools.netlog.ethtool.num_rotate_files2... 4

Keep up to this number of rotated files (also compressed), the current log not included
(which is limited to 600 lines)

IGEL Setup > Registry

> Logfile rotate sizein  debug.tools.netlog.ethtool.rotate_size 2,4,6
MiB

Rotate when the size of the uncompressed file reaches this size in MiB.
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Ifconfig

Apart from configuring network devices, ifconfig also gives diagnostic information such as RX bytes, TX bytes and
dropped packets.

IGEL Setup >
> Disable ifconfig logging debug.tools.netlog.ifconfig.disabled true / false
By default Ifconfig logging is included in Netlog logging. However, you can disable it here.

IGEL Setup >
> Log only if ifconfig debug.tools.netlog.ifconfig.log_on_changes no,error_counter,al
output changes _only l

» no:logon every netlog run
+ error_counter: log only if an error counter or the address changes
« all: log on every change of ifconfig output

IGEL Setup >
> Number of Rotate files debug.tools.netlog.ifconfig.num_rotate_files 2...4

Keep up to this number of rotated files (also compressed), the current log not included
(which is limited to 600 lines).

IGEL Setup >

> Logfile rotate sizein  debug.tools.netlog.ifconfig.rotate_size 2,4,6
MiB

Rotate when the size of the uncompressed file reaches this size in MiB.

IGEL Setup >

> Trigger tcpdump log  debug.tools.netlog.ifconfig.trigger_tcpdump true/false
_save

Trigger the saving of tcpdump logs if an error counter increases or if the IP address changes.
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Netstat

Netstat displays a variety of network statistics for the local machine.

> Disable netstat logging debug.tools.netlog.netstat.disabled true / false

By default netstat -s loggingisincluded in Netlog logging. However, you can disable
it here.

> Number of Rotate files debug.tools.netlog.netstat.num_rotate_file 2... 4
s

Keep up to this number of rotated files (also compressed), the current log not included
(which is limited to 600 lines).

>Logfile rotate sizein  debug.tools.netlog.netstat.rotate_size 2,4,6
MiB

Rotate when the size of the uncompressed file reaches this size in MiB.

>Log only if triggered  debug.tools.netlog.netstat.trigger_log net_error_changes,
net_changes,
ifconfig_changes,
ethtool_changes,
no_trigger

+ net_error_changes: log if ethtool output changes or ifconfig error counter or address
changes

+ net_changes: log if ethtool or ifconfig output changes

« ifconfig_changes: log if ifconfig output changes

+ ethtool_changes: log if ethtool output changes

+ no_trigger: log on every netlog run
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IGEL Setup >
> Enable ping check debug.tools.netlog.ping_host[0-9].enabled true / false

IGEL Setup >

> Logonly if ping fails  debug.tools.netlog.ping_host[0-9].log_only_o true/false
n_error

Log only if any one of the configures pings [0-9 fails.]
IGEL Setup >

> Number of Rotate Files debug.tools.netlog.ping_host[0-9].num_rotate 2... 4
_files

Keep up to this number of rotated files (also compressed), the current log not included
(which is limited to 600 lines).

IGEL Setup >

> Logfile rotate sizein  debug.tools.netlog.ping_host0.rotate_size 2..4
MiB

Rotate when the size of the uncompressed file reaches this size in MiB.

IGEL Setup >

> Trigger tcpdump save debug.tools.netlog.ping_host0.trigger_tcpdum?2 ... 4
p_save

Trigger the saving of tcpdump logs if an error counter increases or if the IP address changes.
IGEL Setup >

> Ping target debug.tools.netlog.ping_host0.ping_target  user-editable
string

Target IP/hostname to ping (if none is given ping will be considered as disabled!)
IGEL Setup >

>Time between pings  debug.tools.netlog.ping_host0.ping_time 1,5, 10,30, 60,
120

Time between pings in seconds.
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IGEL Setup >

> Type of ping debug.tools.netlog.ping_host0.type icmp, http
request, https
request

+ icmp: use normal ping command
« http request: send an http request (failsifno  HTTP/*.* % OK answer is received)

+ https request: send an https request (failsif no CONNECTED is returned by openssl)
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Socket Status (ss)

Socket Status (ss)
IGEL Setup >

> Disable socket status debug.tools.netlog.socket_status.disabled  true/false
Logging

By default socket_status logging is included in Netlog logging. However, you can disable it
here.

IGEL Setup >

> Number of Rotate Files debug.tools.netlog.socket_status.num_rotate true / false
_files

Keep up to this number of rotated files (also compressed), the current log not included
(which is limited to 600 lines).

IGEL Setup >

> Logfile rotate sizein  debug.tools.netlog.socket_status.rotate_size true/false
MiB

Rotate when the size of the uncompressed file reaches this size in MiB.

IGEL Setup >

> Logonly if triggered  debug.tools.netlog.socket_status.trigger_log ping_errors,
no_trigger

+ ping_errors: log only if ping test fails
+ no_trigger: log on every netlog run
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Making a Telnet Connection from IGEL Linux

Issue

You want to connect to a Telnet service and can't find a Telnet command on the device.

Solution
Using Ericom Powerterm (Requires the Ericom Powerterm Firmware Feature):

1. In Setup, go to Sessions > PowerTerm Terminal Emulation > PowerTerm Sessions.
2. Create a new session.
3. Editthe session.
4. Under Connection, make the following settings:
a. Select TELNET as Session Type.
b. Enteran IP adress or a name in Host Name.
c. If youwant to use a graphical login dialog, activate Enable Login Dialog.

kaessicm Type | TELMET hd

Parameters

Host Mame 172.30.61.153 Port Number 23
Terminal Name Keep Alive Timeout |0
[/] Enable Login Dialog [] Save last user name

[¥] set window Size
(] Force Binary Mode

5. Under Desktop Integration enter a Session Name and enable the desired Starting Methods for
the Session.

6. Click Apply to save your settings or OK to save and exit.

7. Start the new session and enter your username and password.
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Configuring Dynamic DNS Updates via DDNS

Issue:
You want to register a device's IP address with your DNS server.

You are not using DHCP.

Solution:

Use the DDNS tools contained in IGEL Linux, which can be configured by Setup.

(® This only works for BIND9 or other nameservers supporting TSIG, not for Microsoft Active Directory servers.

Distribute your nameserver's shared TSIG key with the UMS:

Create a New File.
Set the Device Storage Pathto /wfs/ddns .

Enable Read permission for the Owner and disable all other permissions.
Set the Owner to Root.

AL d =

Set up Dynamic DNS Registration:

Go to Network > LAN Interfaces in Setup.

Enable Specify an IP Address.

Enter an IP Address and Network Mask.

Enter a Terminal Name.

Check Enable DNS.

Enter a Default Domain.

Enter at least one Nameserver P address.

Enable Dynamic DNS Registration.

Select DNS as Dynamic DNS Registration Method.
If the nameserver expects a TSIG key: Select the TSIG key file.
Otherwise, leave the input field blank.

. Click Apply or OK to confirm your settings.

W Nk WNE

=
e

—
[
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] Activate default interface (Ethernet)

a

() Get IP from DHCP Server
(®) Specify an IP Address

IP &ddress 192.0.0.1
MNetwork Mask 255.255.255.0
Default Gateway [] enable

Terminal Name

¥} /] Enable DNS

Default Domain €) | dynamic.igel.local
Nameserver €) |172.30.178.1
Nameserver

[[] Manually overwrite DHCP settings
€ [V] Dynamic DNS Registration

Dynamic DNS Registration Method £} [DNS VJ

TSIG key file for additional DNS authentication ) | mfs/ddns/ddns.private

ok Cancel
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Changing the SMB protocol version

Depending on which Windows (Samba) server you are using, you will need a specific SMB protocol version.

(@ Due to security reasons, Microsoft recommends to disable SMB version 1.0 support on Windows ,so you
need to switch to at least version 2.0 to be further able to access systems with disabled SMBV1.

IGEL Linux version 10.04.100 and higher offer several SMB protocol versions.
To change the version setting:

1. Inthe IGEL Setup go to System > Registry.
2. Goto parameter network.smbmount.smb_version.

3. Select the apropriate SMB protocol version.
Possible options:
« 1.0
+ 2.0
« 2.1
« 3.0
4. Click Save or Apply and send to thin client.
The windows shares are configurable at IGEL Setup > Network > Network Drives > Windows
Drive.
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How to Launch the Wireless Manager within IGEL OS when the Taskbar Is
Hidden

Problem

The taskbar or system tray has been disabled for some reason (User Interface > Desktop > Taskbar / Taskbar
Items; also User Interface > Screenlock /Screensaver > Taskbar). As a result, a systray icon for the Wireless
Manager can't be accessed anymore, and the user can't manage wireless networks.

Environment
+ IGEL 0S 10.06 or higher

Solution

You can configure the Wireless Manager as a custom application and define the way it can be launched.

1. Goto Network > LAN Interfaces > Wireless and check that the wireless interface and the Wireless
Manager are enabled.

2. Go to System > Firmware Customization > Custom Application and click [+].

Specify the Session name and configure the Starting methods according to your needs.

< > / » System ™ Firmware Customization ™ Custom Application ™ WLAN Manager

Configuration Session name WLAN Manager |

Sessions

Accessories Starting Methods for Session

= v Start Menu Start Menu's System tab

User Interface

7] Application Launcher Application Launcher's System tab
v Desktop €) V Desktop Context Menu

Quick Start Panel

Network

De

Menu folder
System
B Time and Date
» @ Update Desktop folder
» Il Remote management
» Il Remote Access Password protection
B Logging
» Il Power Options Hotkey
v [ Firmware Customization
» I Custom Partition
v [ Custom Application
[ WLAN Manager
B settings
B Desktop Integration Autostart
» Il Custom Commands
» Il Corporate Design
» [ Environment Variables
B Features
B Registry
Appliance Mode Access
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4. Under Settings, specify the Icon name and enter the following Command: /bin/start-

wireless-manager

< > | » System ™ Firmware Customization ® Custom Application » WLAN Manager » Settings

Configuration Icon name applications-other

Sessions Command Q /bin/start-wireless-manager

Accessories
User Interface
Network
Devices
Security
System

B Time and Date
» [ Update
» Il Remote management
» Il Remote Access
R Logging
» Il Power Options
v [ Firmware Customization
» [ Custom Partition
v [ Custom Application
v [J WLAN Manager
B settings
B Desktop Integration
» [ Custom Commands
» [ Corporate Desian
Search

5. Click Apply or OK.
The Wireless Manager can now be launched via the configured starting methods.
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Security

« Securing IGEL OS Endpoints (see page 404)

+ Secure Shell (SSH) Access to IGEL OS with Keys (see page 446)

« Secure Terminal (Telnet with TLS/SSL) (see page 452)

+ Secure Shadowing (VNC with TLS/SSL) (see page 453)

+ Cherry eGK Channel Substitution (see page 457)

+ Single Sign-on for the Browser Proxy (see page 459)

+ Limiting the Number of Permitted Login Attempts (see page 462)
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Securing IGEL OS Endpoints

This document describes settings for IGEL OS that will increase security.

It applies to the following types of devices:

IGEL UD devices
Devices which are temporarily converted by UD Pocket
Devices which are permanently converted by IGEL OS Creator (0SC)

Introduction (see page 405)

Setting Passwords (see page 406)

Keeping the System Up-To-Date (see page 413)

Disabling Access to Components (see page 418)

Minimizing the Attack Surface (see page 423)

Configuring Remote Access and Management (see page 434)
Wi-Fi and Bluetooth (see page 442)

Using UD Pocket for BYOD Devices (see page 445)
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Introduction

This document describes various settings to make IGEL OS more secure. In general, the more of these settings you
apply, the better device security will be. However, it is up to you to strike a balance between security and enabling
your users to do their work. Some settings may even be inappropriate for your use case, e.g. if you use Bluetooth
peripherals, it does not make sense to disable Bluetooth.

In order to configure multiple devices, put the relevant settings into a Universal Management Suite (UMS) master
profile, which you can assign to any number of devices. For more information, see Master Profiles.
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Setting Passwords

You can restrict access to various system components by setting passwords.

+ Setting Local Passwords (see page 407)

+ Password-Protecting Sessions and Accessories (see page 408)
+ Using Screenlock (see page 409)

» Do Not Save Session Passwords (see page 410)

+ Setting a UEFI Password (see page 411)

+ Using Two-Factor Authentication (2FA) (see page 412)
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Setting Local Passwords

Rationale

Passwords protect the system against local changes. They restrict access to the Local Terminal, Setup, and to the
rescue shells on the virtual consoles. The administrator password is also needed to reset the system to factory
defaults.

These passwords are saved in a way (salted and hashed) that prevents them from being recovered from the local
storage.

By default, no passwords are set on IGEL OS. Set at least an administrator password:

Instructions

1. InIGEL Setup go to Security > Password.

2. Inthe Administrator area, check Use Password.

3. Enter a password twice when prompted.

4. Optional: If you want to grant unprivileged user access to IGEL Setup check Use Password in the
Setup user area and enter a password twice when prompted.

5. Click Apply.

For configuration of the User Account for Remote Access, see Using Secure SSH Settings (see page 440).

Find further information in the IGEL OS manual under Password - Restrict Access to IGEL OS Components.
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Password-Protecting Sessions and Accessories

Rationale

Sessions can be used to access corporate resources, while the accessories in IGEL OS can be used to make changes
to the local system. If you do not want to disable certain sessions or accessories completely, you can set passwords
to restrict access to them.

Instructions

By default, sessions do not have passwords set. In IGEL Setup, you can set a password on the Desktop
Integration page of a session or accessory.

To enable password protection:

1. Inthe Setup, go to the relevant Desktop Integration page. The path has the following
pattern: Sessions > [session type] > [session name] > Desktop Integration.
For accessories, go to Accessories > [accessory name].
2. Set Password Protection to
« Administrator to require the Administrator password, or
+ User to require the User password, or
+ Setup User to require the Setup User password.
3. Click Apply.
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Using Screenlock

Rationale

Leaving a screen unlocked enables attackers to access the system with the logged-in user's privileges. Manual or
automatic locking the screen with a password prevents such access.

Instructions for Enabling Manual Locking

By default, there is no way for the user to manually lock the screen. To enable manual locking, follow these steps:

1.
2.

3.

In the Setup, go to User Interface > Screenlock [ Screensaver.
Do one or both of the following:
« Activate the Quick start panel starting method to give the user a button for locking the
screen manually.
« Activate Use hotkey and set a combination of keys that lets the user lock the screen
manually, e.g. [Ctrl+Shift+L].
Click Apply.

Instructions for Automatic Locking

By default, the screensaver is started automatically after 5 minutes, but the screen is not locked with a password.
To enable locking, follow these instructions:

1.
2.
3.

Go to User Interface > User Interface > Screenlock / Screensaver > Options.

Activate Start automatically.

Set the Timeout, i.e. the number of minutes of user inactivity before the screensaver starts
automatically.

As a password, select User password (see Setting Local Passwords (see page 406)) or a separate
Screenlock password (and set one).

If applicable, activate Allow administrator password to allow the administrator to unlock the
screen.

Click Apply.
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Do Not Save Session Passwords

Rationale

Passwords for sessions should not be stored on the endpoint device.

Instructions

» When configuring a session, on the login page, leave the Password field empty. The user will then be prompted
interactively for the password.

» Wherever possible use Two-Factor Authentication (2FA) (see page 412).
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Setting a UEFI Password

Rationale

In the UEFI settings you can modify very fundamental system properties, e.g. disable booting from USB. Access to
these settings should be protected by a password.

Instructions for IGEL Devices

» |f UEFIis not enabled, see the instructions under UEFI Secure Boot Enabling Guides.
By default no UEFI password is set on IGEL UD devices. To set a password, do the following:

1. Hold down the [Del] key ([F2] key for UD2) while booting.
The UEFI menu opens.

2. Usingthe arrow and return keys, go to SCU.

The Setup Utility opens.

Using the arrow and return keys, go to Security.

Use the arrow keys to select Set Supervisor Password.

Hit [Return].

Enter the desired UEFI password and hit [Return]

Enter the same UEFI password again and hit [Return] twice.

Hit [F10] in order to save and exit.

Confirm Exit Saving Changes? by hitting [Return].

The system boots, and the UEFI settings are now password-protected.

LN W

Instructions for 3rd-Party Devices Converted with OS Creator (OSC)

> Refer to the instructions of your BIOS/UEFI vendor.

() Alternatively, try pressing [F12] (in general), [F10] (Intel devices), or [F9] (Hewlett-Packard devices) to
access the BIOS/UEFI settings. If this does not work, try pressing [Del], [F1], or [F2] during booting.
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Using Two-Factor Authentication (2FA)

Rationale

Two-factor authentication (2FA) combines two different factors to prove the user's identity, often a hardware device
such as smartcard or smart token and a password or PIN. This improves protection against impostors, as they
would have to gain both possession of the hardware device and knowledge of the password or PIN.

Instructions

Use two-factor authentication with a smartcard or smart token where possible. IGEL OS supports this for the
following sessions:

« Smartcard authentication for sessions
« Citrix Storefront (see page 518)
» RDP Sessions (see page 520)
» Horizon Sessions (see page 521)
» Web browser (see page 522)
+ (Kerberos) Passthrough Authentication (see page 803)
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Keeping the System Up-To-Date

Rationale

Software updates fix newly discovered vulnerabilities in IGEL OS and applications. This means that keeping up with
updates is one of the most important measures in securing IGEL OS systems.

To start and configure updates, you can use IGEL Setup and/or the Universal Firmware Update feature of the
Universal Management Suite (UMS).

The instructions described on this page use the Universal Firmware Update feature of the UMS. For defining a
scheduled job, see the section "As a Job" in Assigning Updates; for configuring the update on a device, see
Firmware Update.

Instructions

> To be notified of secu rity-critical IGEL OS updates and to receive the IGEL Technical Newsletter, subscribe to
IGEL communications on www.igel.com™*.,

The upgrade procedure consists of the following steps:

+ Getting the update from the IGEL download server
+ Testing the update on one or a few devices
+ Rolling out the update on all devices

Getting the Update from the IGEL Download Server

1. Inthe UMS Console, go to Universal Firmware Update, open the context menu, and select Check
for new firmware updates.

e Lpdate {0}

41 http://www.igel.com/
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2. Activate the firmware you want to download and click Download.

Universal Firmware Updates

Ln

Include —
HTHL

HThL
HThL
HThL

The current status of the firmware download is shown.
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3. Click Ok.

Universal Update Download results

Errar
1-11.01.100

4. When the download has succeeded, the firmware is registered and stored in the UMS.

on  11.01.100

[t & Mo HThL Text

Firmware Update Settings

User  IGEL_INTEI

Host D
Port

Protocol  hitps

Errar
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Testing the Update on One or a Few Devices

1. Inthe UMS Console, go to Universal Firmware Update, select the desired firmware and drag and

drop it on the test device or on the folder containing the test devices.
¥ Bp WoOL (7

CADES018

IGEL OS5 11-11.01.100
rsal Desktop L-10.05

The firmware is updated on the devices; during the update process, the devices reboot.

Rolling out the Update on All Devices
You can either start the update immediately or use a scheduled job to start it at a defined time.

To start the update immediately:
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1. Inthe UMS Console, go to Universal Firmware Update, select the desired firmware and drag and
drop it on the folder containing the devices that are to be updated.

. EMP Expiry

required

IGEL LIni
GEL L

2. Inthe Update time dialog, select Now and click Ok.

Update time

1 should these chanoes take effect?
levt Reboot
f I

settings on next reboot (and don't showe this dialog again

The firmware is updated on the devices; during the update process, the devices reboot.
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Disabling Access to Components

You can hide IGEL OS components from the user that could be used to make changes to the system.

Disabling Local Terminal Access (see page 419)
Disabling Virtual Console Access (see page 420)
Using Appliance Mode (see page 421)

Hiding Unused Accessories (see page 422)
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Disabling Local Terminal Access

Rationale

The Local Terminal accessory allows the user to execute commands or make changes to the system. By default, the
local terminal is disabled, that is, no local terminal session is configured. To enhance security, you should do one of
the following:

+ Leave the local terminal disabled
+ If alocal terminal session is configured, but not needed, disable it.
« Ifalocal terminal session is needed, password-protect it.

Instructions
To remove an existing local terminal session:

1. InIGEL Setup, go to Accessories > Terminals.
2. Select a local terminal session you want to delete.

3. Click [ to remove the selected session.
4. When prompted, confirm that you want to delete the session.
5. Click Apply.

Alternatively, you can password-protect the terminals.
To password-protect the local terminal:

1. Find the local terminal session under Accessories > Terminals.
2. Follow the instructions under Password-Protecting Sessions and Accessories (see page 408).
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Disabling Virtual Console Access

Rationale

The virtual consoles ttyll and ttyl2 give the useraccessto ashell. Disabling these makes it more diffcult to
execute commands or make changes to the system.

Instructions

By default, the user can access the virtual consoles with the [Ctr{]+[Alt]+[F11] and [Ctrl]+[Alt]+[F12] keyboard
commands. To disable access, do the following:

1. InIGEL Setup go to User Interface > Display > Access Control
2. Activate Disable Console switching (Default: Console switching enabled)
3. Click Apply.
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Using Appliance Mode

Rationale

By default, IGEL OS users are not presented with a full-screen remote session, but have access to the desktop and to
the start menu. On the contrary, in the appliance mode, a single predefined session is presented full-screen to the
user. As access to other applications is prevented, this reduces the system's potential exposure to attack.

Instructions

The appliance mode is available for the following session types:

« VMware Horizon

« Citrix Self-Service

« RHEV/Spice

+ Imprivata

« RDP MultiPoint Server
« XDMCP for This Display

To enable the appliance mode for a session, proceed as follows:

1. InIGEL Setup, go to Sessions > Appliance Mode.
2. Pick the session and configure it according to the manual chapter Appliance Mode.

(@ Youcan combine most of the appliance mode sessions with Two-factor Authentication (see page 412) for
increased security.
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Hiding Unused Accessories

Rationale

Accessories can be used to make changes to the system. Restricting access to these accessories helps to keep the
system secure.

Instructions
To hide individual accessories (both in the start menu and the Application Launcher):

1. InIGEL Setup go to Accessories > [accessory name].
2. Disable all Starting Methods for Session.
3. Click Apply.

To password-protect an accessory:

» Follow the instructions under Password-Protecting Sessions and Accessories (see page 408).
To hide the complete System icon of the start menu:

1. InIGEL Setup go to User Interface > Desktop > Start Menu.
2. Deactivate System tab.
3. Click Apply.

To hide the complete Application Launcher's System icon:

1. InIGEL Setup go to Accessories > Application Launcher > Application Launcher Configuration.
2. Activate Hide system page.
3. Click Apply.
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Minimizing the Attack Surface

Removing unused features and disabling unneeded network services reduces the parts of the system that can be
attacked.

+ Removing the Local Web Browser (see page 424)

« Configuring the Browser (Kiosk Mode) (see page 425)
+ Disabling Java in the Browser (see page 426)

+ Disabling the PC/SC Daemon (see page 427)

+ Disabling X Server TCP Connections (see page 428)

+ Removing Unused Features (see page 429)

+ Disabling Storage Hotplug (see page 430)

+ Using USB Device Control (see page 431)

+ Disabling USB Boot (see page 432)

+ Leveraging AppArmor (see page 433)
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Removing the Local Web Browser

Rationale

The local web browser may expose vulnerabilities to the internet and can be an entry point for malware. If the
browser is not needed, it is safer to remove it.

© Do notremove the local web browser if you use Citrix StoreFront sessions.

Instructions

By default, IGEL OS has a local web browser (Firefox) installed, even if no web browser session is configured. To
remove the browser:

1. Inthe IGEL Setup go to System > Firmware Customization > Features.
2. Uncheck the Local Browser (Firefox) feature.

3. Click Apply.

4. Reboot the device.
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Configuring the Browser (Kiosk Mode)

Rationale

If you want to offer a local web browser, there are some settings that improve its security. Additionally, these
settings add up to a kiosk mode, hiding the rest of IGEL OS from the user.

Instructions

By default, the web browser makes all of its features and menus available. To achieve a restricted 'kiosk' mode,
follow these instructions:

1.

~

In the IGEL Setup, under Sessions > Browser > Browser Global > Security, activate the following
options:

+ Safe Browsing

« Malware Protection
Under Sessions > Browser > Browser Global > Restart, activate Restart.
Under Sessions > Browser > Browser Global > Window, activate the following options:

« Startin fullscreen mode

+ Hide local filesystem

+ Hide configuration page of the browser
Under Sessions > Browser > Browser Global > Menus & Toolbars, activate Hide App Menu/Menu
Bar.
Under Sessions > Browser > Browser Global > Context, activate Hide the browser's context
menu.
Under Sessions > Browser > Browser Sessions > [session name] > Settings, activate Autostart.
Click Apply.
Reboot the device.
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Disabling Java in the Browser

Java Applets and Java Web Start may constitute a potential security threat and are now regarded as deprecated. As
of IGEL OS version 10.06.100, they are no longer included in IGEL OS. The registry keys under System > Registry >
java > deployment are obsolete.
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Disabling the PC/SC Daemon

Rationale

Unless you are running smartcard readers that use it, you can disable the PC/SC daemon. Running fewer daemons
reduces the attack surface.

Instructions
To deactivate the PC/SC daemon:

1. Inthe IGEL Setup go to Security > Smartcard > Services.
2. Deactivate Activate PC/SC Daemon.
3. Click Apply.
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Disabling X Server TCP Connections

Rationale

The X graphics server in IGEL OS has network functionality that could allow others to see your screen and read
keyboard input. Leave it disabled to keep your data confidential.

Instructions
By default the network functionality of the X server is disabled. To disable it again at a later time, do the following:

1. InIGEL Setup go to User Interface > Display > Access Control
2. Make sure that Access Control is activated.

3. Make sure that Disable TCP connections is activated.

4. Click Apply.
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Removing Unused Features

Rationale

Reducing the amount of software running on a system reduces its attack surface. Therefore a basic security
measure for IGEL OS 10 is to remove all unused features.

Instructions
To disable a feature:

1. Inthe IGEL Setup go to System > Firmware Customization > Features.
2. Deactivate all the features that you do not intend to use.
3. If you do not use local printers on the endpoint device that you want to share with others,
deactivate:
+ Printing (Internet Printing Protocol CUPS)
+ Printing (Line Printer LPD)
+ Printing (TCP/IP)
+ Printing (ThinPrint)

© Do not remove the Custom Partition feature if you have a custom partition that contains
software or data for which you have no backup copy. After disabling the feature and a
reboot the contents of the custom partition will be lost.

© Do notremove Fluendo Gstreamer Codec Plugins or Hardware Video Acceleration if
you use sessions that make use of these features.

4. Click Apply.
5. Reboot the device.
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Disabling Storage Hotplug

Rationale

Removable USB media can be used to steal data or to execute unauthorized software or even malware on the
device.

Instructions

Storage hotplug is disabled by default. Should you want to disable it again at any later point, follow these
instructions:

1. InIGEL Setup go to Devices > Storage Devices > Storage Hotplug.
2. Deactivate Storage Hotplug.
3. Click Apply.
Storage devices are no longer automatically mounted when they are plugged in.
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Using USB Device Control

Rationale

USB devices such as pen drives, wireless controllers, or printers can be used to steal data or to execute
unauthorized software or even malware. Deactivating as many USB device classes as possible increases security.

Instructions
To enable and configure USB access control:

1. InIGEL Setup, go to Devices > USB Access Control.
2. Check Enable.

& The activation of USB Access Control and setting the Default rule to Deny will block the use of
USB devices locally and in the session and, thus, might disable devices needed for the users.
Therefore, activate the USB access control only if your security policy requires that. In this case, set
Default rule to Deny and configure Allow rules for the required USB devices and USB device
classes.

It is recommended to make settings for USB Access Control as the last step in the device
configuration. Before activating the USB access control, check that all your other settings for
printers, Unified Communication, USB redirections, mapping settings for USB devices are working
as expected.

Note that the USB access control is completely separate than USB redirection for remote sessions,
see When to Use USB Redirection (see page 761).

Take also notice that the feature does not disable a USB port physically, i.e. power delivery will still
work.

3. Set Default rule to Deny.
In combination with the preconfigured rule that allows Human Interface Devices (HID), no USB
devices apart from e.g. mouse and keyboard are allowed.

4. Configure further rules as needed. For instructions, see How to Configure USB Access Control (see
page 765).

5. Click Apply.

6. Reboot the device.
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Disabling USB Boot

Rationale

Disabling USB “boot prevents booting another operating system, which could be used to manipulate or (even
accidentally) overwrite IGEL OS on mass storage.

Instructions for IGEL Devices

USB boot is disabled in the factory settings on IGEL UD LX devices. If it has been enabled and you want to disable it
again, follow the instructions given here:

1.

w

No ok

Hold down the [Del] key ([F2] key for UD2) while the system is booting.
The UEFI menu opens.

Use the arrow and return keys to go to SCU.

Enter the UEFI password if one is set.

The Setup Utility opens.

Go to Boot.

Set USB Boot to Disabled.

Press [F10].

Confirm Exit Saving Changes?

The device boots.

© Additionally, set a UEFI Password (see page 411) so the boot settings cannot be changed
back.

Instructions for 3rd-Party Devices Converted with OSC

» Refer to the instructions of your BIOS/UEFI vendor.

(@ Alternatively, try pressing [F12] (in general), [F10] (Intel devices), or [F9] (Hewlett-Packard devices) to

access the BIOS/UEFI settings. If this does not work, try pressing [Del], [F1], or [F2] during booting.
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Leveraging AppArmor

AppArmor controls which privileges should be granted to an application that is running on the system. This way
even vulnerabilities that are yet unknown can be mitigated.

The following applications are guarded by AppArmor:

« Firefox browser
+ Cups print server
« Evince pdf viewer

The following system programs are guarded by AppArmor:

« tcpdump
+ haveged
+ dhclient

By default, AppArmor is enabled. They registry key is system.security.apparmor

IGEL OS Articles 433/823



Security

Configuring Remote Access and Management

Remote management via UMS and remote access are powerful features of IGEL OS. Select secure settings and
disable what you do not use.

+ Tying Endpoints to Your UMS instance (see page 435)
+ Disabling Shadowing (see page 436)

+ Using Secure VNC Settings (see page 437)

+ Disabling SSH Access (see page 438)

+ Disabling X11 Forwarding (see page 439)

+ Using Secure SSH Settings (see page 440)

+ Disabling Secure Terminal (see page 441)
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Tying Endpoints to Your UMS instance

Rationale

Devices that have remote management enabled but are not yet tied to a UMS instance can be taken over by an
attacker's UMS. Make sure to register all IGEL devices on your network.

Instructions

By default, remote management is enabled on IGEL OS devices. Use automatic registration to catch all devices in
your corporate network:

1. Assignthe DNSentry igelrmserver tothe UMS host. For further instructions, see Registering

Devices Automatically on the IGEL UMS.

2. Inthe UMS console go to UMS Administration > Global Configuration > Device Network
Settings.

3. Activate Enable automatic registration (without mac address import)
Now all new IGEL devices, UD Pockets and devices converted with OSC that are booting up in the
network will automatically register with your UMS instance.

4. Optionally, put newly registered devices into a quarantine directory automatically with UMS
Default Directory Rules.

5. Optionally, assign a Master Profile to this directory, thereby enforcing secure settings, e.g. a local
administrator password.

@ Alternatively you can disable remote management in the local IGEL Setup under System >

Remote management. Of course this means losing one of the most powerful features of
IGEL OS. However, this may be an option for particular devices.
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Disabling Shadowing

Rationale

Shadowing is made possible by a VNC server on IGEL OS, which is a network service. Reducing the number of
running network services reduces the system's attack surface.

Instructions
By default, Shadowing is not active on IGEL OS. However, if you want to disable it at any time, follow these steps:

1. Inthe IGEL Setup go to System > Remote Access > Shadow
2. Deactivate Allow Remote Shadowing.
3. Click Apply.
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Using Secure VNC Settings

Rationale

If you intend to use shadowing on IGEL OS, there are a number of options that can make it more secure.

Instructions

By default, Shadowing does not use encrypted network transport or a password. To activate these security features,
do the following:

1. InIGEL Setup go to System > Remote Access > Shadow.
2. Make as many of the following settings as possible for your use case. Each setting improves
security, and often also privacy:
+ Enable Secure Mode.
+ Enable Use Password and set a strong password (not needed in Secure Mode). The
maximum length for this password is 8 characters.
« Enable Prompt User to allow Remote Session.
« Enable Allow User to disconnect Remote Shadowing.
« Disable Allow Input from Remote.
3. Click Apply.

@ Secure mode for shadowing can be enabled globally in UMS under UMS Administration >

Global Configuration > Remote Access. There you can also enable the logging of users
who have used secure mode shadowing .
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Disabling SSH Access

Rationale

The SSH server on IGEL OS is a network service. Reducing the number of running network services reduces the
system's attack surface. Even more so in this case, as SSH by design enables a remote user to execute commands
on the system.

Instructions
By default, the SSH server is running on IGEL OS. To deactivate it, follow these steps:

1. InIGEL Setup go to System > Remote Access > SSH Access.
2. Deactivate Enable.
3. Click Apply.
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Disabling X11 Forwarding

When X11 forwarding is disabled, graphic applications cannot be run over SSH. By default, X11 forwarding is
disabled.

() IfX11forwardingisdisabled, itis not possible to launch the IGEL Setup from an SSH session.

To ensure that X11 forwarding is disabled:

1. Inthe Setup, go to System > Remote Access > SSH Access and make sure that Permit X11
forwarding is deactivated.
2. Click Apply or Ok.
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Using Secure SSH Settings

Rationale

If you intend to allow SSH connections to IGEL OS, there are a number of options that can make these more secure.

Instructions

To secure the SSH settings of your devices, make as many of the following settings as possible for your use case

1.
. Deactivate Permit empty passwords.
. Deactivate Permit administrator login.

2
3
4.
5

In IGEL Setup go to System > Remote Access > SSH.

Deny User access for user , who can execute any command with regular user privileges.

. Allow User access for ruser ,whose access is restricted by the list Applications access for

remote user 'ruser'.
Where needed, edit the list Applications access for remote user 'ruser’. It defines the commands

that ruser canrunfrom remote. By default, a local shell ( Localshell ) and IGEL Setup ( /

config/sessions/setup0d )are allowed.

Click Apply.

Go to Security > Password, under User Account for Remote Access activate Use Password and
set a password

Click Apply.
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Disabling Secure Terminal

Rationale

The secure terminal server on IGEL OS is a network service, providing a TLS/SSL-encrypted Telnet session. Reducing
the number of running network services reduces the system's attack surface. Even more so in this case, as the
secure terminal by design enables a remote user to execute commands on the system.

Instructions
By default, the secure terminal is not active. Should you want to deactivate it at any time, do the following:

1. InIGEL Setup go to System > Remote Access > Secure Terminal
2. Deactivate Secure Terminal.
3. Click Apply.

@ Secure Terminal can be enabled globally in the UMS under UMS Administration > Global

Configuration > Remote Access. There you can also enable the logging of users of the
secure terminal.
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Wi-Fi and Bluetooth

Rogue or unencrypted Wi-Fi access points can put your data at risk, as can Bluetooth devices. If your device has Wi-
Fi and Bluetooth, make sure to configure them securely or disable them.

+ Restricting Wi-Fi Access (see page 443)
+ Disabling Bluetooth (see page 444)
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Restricting Wi-Fi Access

Rationale

Using an unencrypted Wi-Fi network or falling for a rogue access point puts your users' data at risk. Enable strong
encryption and restrict Wi-Fi access to a default network and optionally employ a whitelist of additional networks in
order to prevent this.

Instructions

By default, Wi-Fi is not activated on IGEL OS. To activate it and preconfigure one or more allowed networks, follow
these instructions:

1. InIGEL Setup go to Network > LAN Interface > Wireless.

2. Activate Activate Wireless Interface.

3. Do not activate Enable wireless manager, as this would give the user free choice of Wi-Fi

networks.

Click Apply.

Go to Network > LAN Interface > Wireless > Default Wi-Fi network.

Check Enable WPA Encryption.

Enter the Wireless network name (SSID).

Make authentication and encryption settings, see Default Wi-Fi Network in the IGEL OS Manual.

Click Apply.

10. If needed, add further networks under Network > LAN Interface > Wireless > Additional Wi-Fi
networks.

LNk
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Disabling Bluetooth

Rationale

If your device has a Bluetooth interface it may be used to access data. Disabling the interface reduces the risk of
data theft.

Instructions
By default Bluetooth is deactivated on IGEL OS. Should you want to disable it at any time, do the following:

1. Inthe IGEL Setup go to Devices > Bluetooth.
2. Decativate Bluetooth.
3. Click Apply.

IGEL OS Articles 444 /823



Security

Using UD Pocket for BYOD Devices

Rationale

Letting users access company resources with their own devices (BYOD) and software poses a security risk: These
systems may have insecure configurations or even contain malware. In addition, company data should not be saved
on users' private devices.

Instructions

» Use the IGEL UD Pocket. This ensures the use of secure and trusted software. As the UD Pocket does not access
the device's mass storage, company data and private data will remain separated.

For details on the IGEL UD Pocket, see UD Pocket (UDP) Reference Manual.
For how to select the UD Pocket during the boot procedure, see Boot Settings and Starting Your UD Pocket.

IGEL OS Articles 445 /823



Security

Secure Shell (SSH) Access to IGEL OS with Keys

IGEL OS has a built-in OpenSSH server that can be activated and configured via the Setup application. It lets you
connect securely to the device over the network in order to issue commands or transfer files. While authentication
can be done with a username-password combination, using a private-public key pair can increase convenience
and/or security. This document describes how to generate and distribute the keys required.

+ Generating the SSH Key Pair (see page 447)

+ Distributing the Public Key with UMS (see page 449)
+ Configuring SSH Access on the Device (see page 451)
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Generating the SSH Key Pair

Prerequisites

+ Linux/Unix operating system, typically on the administrator's workstation
+ OpenSSH client software installed

Introduction
The following procedure will generate two keys:

+ Public key: This key is distributed to all machines the administrator wants to connect to. It can be
made public.
+ Private key: This key stays on the administrator's machine and has to be kept secret.

© Forthe confidentiality of the encrypted connection to devices, it is essential to keep the
private key secret.

An easily understandable explanation of private and public keys can be found in a blog post by the
programmer Blake Smith*,

Generating the Key Pair

1. Open aterminal session on your workstation as the user who is going to make the SSH
connections to the devices.
2. Issue the following command:

ssh-keygen
3. When prompted for the location to store the key pair in, you can:
+ Hit return, which will accept the default file name ~/.ssh/id_rsa

© Using the default name may overwrite existing SSH key pairs!

« Enter an absolute file path and key file name of your choice .

4. When prompted for a passphrase, you can
+ Enter a passphrase (twice)

@ Apassphrase protects the private key file in case it gets into the hands of an attacker. On
the other hand, it may be inconvenient to enter the passphrase for every connection.

« Hitreturnin order to use no passphrase.

42 http://blakesmith.me/2010/02/08/understanding-public-key-private-key-concepts.html
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© Thisincreases convenience because you will be able to log in without entering the
passphrase. However, it weakens security: The private key file will be unprotected if it gets
into the hands of an attacker.

Two files have been generated (default names):
« id_rsa -the private key file

+ id_rsa.pub -the publickey file
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Distributing the Public Key with UMS

o N oA

In UMS Console, right-click on Files in the navigation tree.
Select New File.

Upload the public key file ( *. pub ) as a Local File.

[ © Make sure that you do not upload the private key file by mistake. ]

Set the Classification to Undefined.
Specify the Thin Client file location as /wfs/user/.ssh/authorized_keys

Leave the Access rights as Read, Write, Execute.
Leave the Owner as User.
Assign the file to the desired thin clients, profiles or directories.

e ]

File source
(®) Upload local file to UMS server

Local file | C:Users\Administratorisample_rsa.pub | -

Upload location (LURL) | hitps IPM-MH-WINT-UMS.IGEL LOCAL 844 3iums_filetransfer/ | .

() Selectfile from UMS server

File location (URL) | -
File target
Classification | Undefined ‘l’]

Thin Client file location |M’stuseri.sshfauthnrized_keys |

Access rights

Read Write Execute
owner [ [V [+
Others [ [ U

Owner |User ¥

Ok Cancel
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@ If you wish to authorize more keys for SSH connections to thin clients, prepare an
authorized_keys file containing all the public keys. Simply append them using a text
editor.
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Configuring SSH Access on the Device

1. Go to System > Remote Access > SSH Access in the IGEL Setup or a profile.
Check Enable.
Optionally, if user hasanempty password, check Permit empty passwords.
Set Deny to No in the User access entry for user.

W

@ This configuration gives the remote user full shell access as if they were the local user on
the client.

Now you can connect to the device from the administrator's machine with the following
command:

ssh user@[client name or IP address]
Depending on whether you set a passphrase for the key, you may have to enter it or not.
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Secure Terminal (Telnet with TLS/SSL)

IGEL Linux version 5.11.100 or newer and IGEL Linux version 10.01.100 or newer allow terminal access via UMS with
transport encryption. In analogy to secure shadowing (see page 453), network traffic is encrypted with TLS/SSL. Secure
terminal connections can only be initiated from the UMS whose certficate is stored on the device.

For details about setting up a secure terminal connection, see UMS manual Secure Terminal (Secure Shell).

Secure Terminal is the best way to create a remote access from the UMS (on Linux or Windows installed) to Linux
devices, without installing an additional terminal software. Because the UMS includes the software.
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Secure Shadowing (VNC with TLS/SSL)

The Secure Shadowing function improves security when remotely maintaining a device via VNC at a number of
locations:

+ Encryption: The connection between the shadowing computer and the shadowed device is
encrypted.
This is independent of the VNC viewer used.

« Integrity: Only devices in the UMS database can be shadowed.

« Authorization: Only authorized persons (UMS administrators with adequate authorizations) can
shadow devices.
Direct shadowing without logging on to the UMS is not possible.

« Limiting: Only the VNC viewer program configured in the UMS (internal or external VNC viewer)
can be used for shadowing.
Direct shadowing of a device by another device is likewise not permitted.

@ Inaddition, IGEL Management Interface (IMl) in Version 2 or newer provides an API for
Secure Shadowing.

+ Logging: Connections established via secure shadowing are recorded in the UMS server log.
In addition to the connection data, the associated user data (shadowing UMS administrator,
optional) can be recorded in the log too.

(@ Of course, this is only relevant to devices that meet the requirements for secure
shadowing and have enabled the corresponding option. Other devices can be "freely"
shadowed in a familiar manner and, if necessary, secured by requesting a password. If you
would like to allow secure shadowing only, you can specify this in the UMS Console under
UMS Administration > Global Configuration > Remote Access.

« Basic Principles and Requirements (see page 454)
« Shadow Devices Securely (see page 455)
» VNC Logging (see page 456)
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Basic Principles and Requirements
The Secure Shadowing option can be enabled if the following requirements are met:

« IGEL Linux as of version 5.03.190 and 10.01.100 or IGEL Windows Embedded Standard 7 from
version 3.09.100

+ IGEL Universal Management Suite from version 4.07.100 onwards

+ The device is registered on the UMS Server

+ The device can communicate with the UMS Console and UMS Server (see below)

Basic Technical Principles

Unlike with "normal" shadowing, the connection between the VNC viewer and the VNC server (on the device) is not
established directly during secure shadowing. Instead, it runs via two proxies - one for the UMS Console and one for
the VNC server on the device. These proxies communicate via a TLS/SSL-encrypted channel, while the local
communication, e.g. between the VNC viewer application and the UMS proxy, takes place in the conventional
unencrypted manner. As a result, a secure connection can also be established with external VNC programs that do
not support TLS/SSL connections.

The two proxies (UMS Console and device) communicate with TLS/SSL encryption via the same port as the
"normal" VNC connection: 5900. As a result, no special rules for firewalls need to be configured in order to perform
secure shadowing.

If secure shadowing is active for a device under Setup > System > Remote Access > Shadow > Secure mode), the
device generates a certificate in accordance with the X.509 standard and transfers it to the UMS Server when the
system is next started. The UMS Server checks subsequent requests for a secure VNC connection using the

certificate. The certificate in PEM format can be found inthe /wfs/client-certs/tc_ca.crt directoryon
the device. The validity of the certificate can be checked on the (Linux) client using the command: x11lvnc

-sslCertInfo /wfs/client-certs/tc_ca.crt

If a UMS administrator calls up the Shadowing function in the UMS Console for the device, the console receives a
signed request from the UMS Server which is then passed on to the device to be shadowed. This in turn passes on
the request to the UMS Server which checks the validity of the request using the original certificate. If this check is
successful, the console reports that the channel for the connection between the proxies can be established. The
UMS proxy on the console connects to the server proxy on the device, and the server proxy, in turn, establishes on
the device the connection to its VNC server.

Only when these connections have been established, the console calls up the VNC viewer which then connects to
the console proxy. The VNC client and VNC server are now connected via the two proxies which transfer data with
TLS/SSL encryption.

Secure shadowing can be enforced independently of the device configuration for all devices that support this
function: UMS Administration > Global Configuration > Remote Access > Enable secure VNC globally.
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Shadow Devices Securely

In order to shadow a device securely (with encryption), the administrator must log on to the server via the UMS
console. When doing so, it is irrelevant whether a purely local UMS administrator account is used or the user was
adopted via an Active Directory for example. As always, however, the UMS administrator must have the permission
to shadow the object, see Object-Related Access Rights.

The device to be shadowed is called up in the structure tree and, as usual, can be executed via Shadow in the
context menu. The connection window, however, differs from the dialog for normal VNC shadowing. The IP and port
of the client to be shadowed cannot be changed, and a password for the connection is not requested - this is
superfluous after logging on to the console beforehand.

Connect with

Password

When a VNC connection has been established, the symbol in the connection tab indicates secure shadowing:

2= IGEL VNC Viewer

File Tab Help

j 10.201.1.123:
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VNC Logging

Connections via secure shadowing are always logged in the UMS. Via UMS Administration > Global Configuration
> Remote Access > Secure VNC, you can configure whether the user name of the person shadowing is to be
recorded in the log:

+ Log user for secure VNC
The user name is included in the log.
O The user name is not included in the log. (default)

The VNC log can be called up via the context menu of a device or folder (for several devices, Logging > Logging:
Secure Access Logs). The name, MAC address and IP address of the shadowed device, the time and duration of the
procedure and, if configured accordingly, the user name of the shadowing UMS administrator are logged.

Remote Access Logs x

Filter: [ I

Thin Clie... | MAC Address UnitID: | Thin ClientIP | User | Starttime | Durat .| Comment Protocal
ws-l-trunk  00:E0:C5:14:31:C0 00EOCS51431C0  172.30.91.129 Sep 30, 2016 11:54:29 AM 0 Unknown Error Secure VMC A
ws-lx-trunk  00:E0:C5:14:31:C0 00EOC51431C0 172.30.91.129 Sep 30, 2016 11:54:42 AM 58 Secure VMNC
ws-l-trunk  00:EQ0:CH:14:31:C0 00EOCH1431C0 172.30.91.129 Sep 30, 2016 11:56:31 AM 0 Shadowing triggered by IMI - Secure VMC
ws-lx-trunk 00:E0:C5:14:31:C0 O00EOCH1431C0 172.30.91.129 Sep 30, 2016 11:56:31 AM 0 Shadowing triggered by IMl - Secure VMC
ws-lx-trunk 00:E0:C5:14:31:C0 00EOCS51431C0 172.30.91.129 Sep 30, 2016 11:57:31 AM 0 Shadowing triggered by IMI - Secure VMC
ws-betrunk  00:E0:C5:14:31:C0 00EOC51431C0 172.30.91.129 Sep 30, 2016 12:03:34 PM 5 Secure VNC
ws-le-trunk  00:E0:C5:14:31:C0 00EOC51431C0 172.30.91.129 Sep 30, 2016 1:48:18 PM 219 Secure VNC
ws-letrunk  00:E0:C5:14:31:C0 00E0C51431C0 172.30.91.129 Sep 30, 2016 2:32:40 PM 1007 Secure VMNC
ws-lx-trunk 00:EQ0:C5:14:31:C0 00E0CS51431C0 172.30.91.129 Sep 30, 2016 3:25:24 PM 120 Secure VNG v

48 Logs found.

> Tosort the list (e.g. according to user names), click on the relevant column header or filter the content shown
by making entries in the Filter field.

IGEL OS Articles 456 /823



Security

Cherry eGK Channel Substitution

As of firmware version 10.05.100, the Cherry eGK Channel is no longer available. In the Igel Universal Desktop
Firmware, Linux V5, the VirtualChannel for Cherry eGK devices is still included parallel to the Cherry USB2LAN Proxy.
If you want to continue using the G87-1504/ST-1503 as before, with firmware version 10.05.100 and higher you have
to activate the proxy. All settings are automatically applied and run through the connector in the network.

Using the G87-1504/ST-1503 with firmware version 10.05.100 and higher:

« Activate the proxy - this can also be done from the backend.

® « Cherry USB2LAN Proxy (Under Smartcard) (see screenshot)
« IGEL device, valid for Cherry devices G87-1505, G87-1504/ST-1503 to USB

For IGEL Lx v5 and OS10:
+ Activate Cherry USB2LAN Proxy under IGEL Setup > Security > Smartcard > Services.

V' Activate Pt Daemon

Configuration
€) [V] Cherry USB2LAN Proxy
Metwark Interface auto
User Interface
Metwork

Devices

‘ Password
» Il Logon
» I Active Directory/Kerberos
O
[

B Middleware

System

For IGEL Lx v5:

+ Disable Cherry Channel 0 and Cherry Channel 1 under IGEL Setup > Sessions > RDP > RDP
Global > Mapping > Device Support.
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« Do not activate smartcard.

Configuration

op / XenApp

‘ Local Logon
‘ Window

B Drive Mapping

B cowmPorts

ﬁ Printer

[

ﬁ Audio
‘ Performance
‘ Options
B nat edirection
B Fabuia SB Redire
B vutimedia

2] |zl Enable plugin support

2]

CenterTools DriveLock cl
Cherry Channel 0 for reading German eGK-KVK with ST-1503/G
Cherry Channel 1 for reading German with 5T-15
Grundig MMC channel for dictation with Grundig de
Channel for Dictation with Olympus Devi
5 SpeechMike Control Channel for Dictation
¥ Phili peechMike Audio Channel for Dictation

Legacy Philips SpeechMike Mixer Channel for Dictation ((

Legacy Philips Digital Pocket Memo Channel for Dictation (C

Philips Speech Channel for Dictation

Enable smartcard

Install the Cherry eGK KVK software on the server. See https://www.cherry.de/files/software/Cherry-eGK-

KVK_Software_33.zip

Install the Cherry Linux software on the device.

+ In the CT-API configuration the G87-1504/ST-1503 can be configured as network device.

+ Link to Doku Client Server Integration: https://www.cherry.de/files/manual/
64410063-01_USBLANProxyClientServerUndCitrix.pdf

« Link to the software architecture documentation:: https://www.cherry.de/files/manual/Cherry-
eGK-KVK_Sofware-Architektur_Windows-20130927-v04.pdf

() TheVirtualChannel was replaced due to the following difficulties and the future application of the
telematics infrastructure (see also gematik anforderung lan)
+ Independent of Citrix version (no need to check compatibility anymore)
+ Independent of the server version (2008, 2012...), if the connection runs via RDP
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Single Sign-on for the Browser Proxy

Using a proxy to handle a browser's internet traffic provides additional security and control. However, if the proxy is
password-authenticated, the user has to enter their credentials, which adds some inconvenience.

With IGEL Linux version 5.08 or newer and IGEL Linux version 10.01.100 or newer, you can avoid this inconvenience
by using the passthrough feature. As a prerequisite, user logon must be carried out via Kerberos.
To enable single sign-on for the browser proxy:

1. Open the Setup and go to Security > Logon > Active Directory/Kerberos.
2. Activate Login to Active Directory/Kerberos.

IGEL Setup 10.01.120.01 (Build 5.3.27)

£ > ”~ / ™ Security * Logon ™ Active Directory/Kerberos

Configuration

B rirmware Update |

B smartcard Personalizat]
B dentify Monitors
B webcam Information
User Interface
Network
Devices
B Hardware Info
» Il Printer
¥ [J Storage Devices
B storage Hotplug
B Automount

4] Login to Active Directory Domain

B Elustooth
B USE access contral
Security
B Password
¥ [J Logen
B IGEL Smartcard
B Taskbar
|
B shared Workplace
¥ [ Active Directory/Kerbert

Login methods:

(] Explicit

] Remember last user name
[] smartcard

Logoff shortcut locations:
(/] start Menu
(] Application Launcher

[ start Menu's System tab
] Application Launcher's System tab

[ ] Desktop ] Desktop Context Menu
(] Quick Start Panel

Menu folder

Password Protection

[] Hotkey

Related Configurations

2] Active Directory /
Kerberos

Post Session
A
5] Command

Smartcard
& Middleware

Apply Ok Cancel

3. Go to Sessions > Browser > Browser Sessions > [name of the browser session] > Settings >

Proxy.
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4. In the Proxy Configuration choice, select Manual proxy configuration.
IGEL Setup 10.01.120,01 (Build 5.3.27)

s ™ Browser ™ Browser s » Browser ™ Settings ™ Proxy

Proxy Configuration | Manual proxy configuration Related Configurations

Proxy

Configuration

Im NoMachine NX Client FTP Proxy Port
» Il Parallels Client
» [ PowerTerm Terminal Ei
» I ThinLinc SSL Proxy
I ssH
» Bl VNC Viewer S0CKS Host

v 5 e SOCKS Protocal version [ SOCKS v5
¥ [ Browser Global

I Tabs No Proxy for localhost, 127.0.0.1
B content
B Frint Proxy Realm moz-proxy:{/172.30.178.10:8080
B Proxy [¥] Use Passthrough authentication
B Privacy o
B security
B Advanced Password
B Encryption
B commands [¥] Do not prompt for proxy authentication if credentials are saved
¥ [ Browser Sessions
¥ [ Browser
¥ [ settings
B Tabs
B content
| Frint
i Proxy
B Privacy
B Security
B Advanced
B Encryption
B Restart
B window
B Menus & Toolb -4
L

HTTP Proxy 172.30,178.10

Search v

Apply Ok Cancel

5. Foran HTTP proxy, define the following settings:
« HTTP proxy: IP address or hostname of the proxy to be used
+ Port: Port of the proxy for HTTP
+ No proxy for: IP addresses or hostnames of servers that can be accesses directly
+ Proxy realm: Area in which the browser authenticates itself for the proxy. Together with the
user name and password, this information is necessary for authentication.

® The Proxy realm field is internally pre-populated with the value moz-proxy://[HTTP

Proxy]: [Port] .Ifthefield is empty, this value will be used when authenticating the
browser. If the proxy expects another unknown value for the proxy realm, you can
determine this as follows: Leave the User name and Password fields empty and launch
the browser. The dialog window which appears will contain the correct value for the
Proxy realm field:

Authentication Required A X

The proxy moz-proxy:(/172.30.178.10:8080 is requesting a username and password. The
" site says:["'moz-proxy://172.30.178.10:8080"]

User Name: |

Password: | |

® cancel W 0K

In the
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example above, the value for the Proxy realm field is as follows: moz-proxy://

172.30.178.10:8080

+ Use passthrough authentication: Must be enabled to allow single sign-on for the browser

proxy.

+ Do not prompt for proxy authentication if credentials are saved: Must be enabled to
enable seamless single sign on for the browser proxy; suppresses the Authentication

Required dialog.

M NoMachine NX Client &
» [ Parallels Client
» Il PowerTerm Terminal E
» [l Thinlinc
B SSH
» [ VNC Viewer
v [ Browser
¥ [ Browser Global
B Tabs
B content
B rrint
B Proxy
B Privacy
B security
B Advanced
B Encryption
B commands
¥ [ Browser Sessions
v (3 Browser
¥ [ settings
B Tabs
B content
W Print
Prao:
B Frivacy
B security
B Advanced
B Encryption
B Restart
B window
B Menus & Toolb ‘;

Proxy Configuration

[Manua\ proxy configuration

M|

FTP Proxy Port

HTTP Proxy 172.30.178.10 Port 8080

SSL Proxy Port

S0CKS Host Port

SOCKS Protocol version |s0cKs vs M|

No Proxy for localhost, 127.0.0.1

Proxy Realm moz-proxy://172.30.178.10:8080

(] Use Passthrough authentication

(] Do not prompt for proxy authentication if credentials are saved ]

The next time the user logs in to the device, the browser proxy is ready to use.
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Limiting the Number of Permitted Login Attempts

Symptom

Users can attempt logging in as often and as fast as they want at the screen unlock prompt and local login prompts
(e.g. for Kerberos, Shared Workplace, IGEL Smartcard).

Problem

This leaves the system and remote sessions vulnerable to brute force login attacks.

Solution
In IGEL OS 10.03.100 and newer, the number of login attempts is limited to 5 within 30 seconds.
These values can be changed in the system registry:

1. In Setup, go to System > Registry

2. Gotothe auth.login.lockout_threshold parameter to set the maximum number of
login attempts within the specified interval.

3. Gotothe auth.login.lockout_duration parameterto settheintervalin seconds.

4. Click Apply or Ok.
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+ Certificate Enrollment and Renewal with SCEP (NDES) (see page 464)
+ Deploying Trusted Root Certificates (see page 484)
« Which CA Certificates Are Contained in IGEL OS? (see page 492)
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Certificate Enrollment and Renewal with SCEP (NDES)

SCEP is a protocol for certificate management which supports the secure issuance of certificates to network
devices.

Requirements

« SCEP server
The following SCEP server implementations can be used with IGEL Linux v5 or IGEL Linux 10:
« Windows 2008 Server with the Network Device Enrollment Service (NDES) role
« Windows 2012 Server
+ Windows 2016 Server
For information on how to deploy the NDES, see http://aka.ms/ndes.

« Connection between the SCEP server and the certification authority (CA).

This document explains the enrollment of certificates with SCEP.

Technical Background (see page 465)

Client Enrollment Details (see page 467)
Configuration of the SCEP Client (see page 469)
Files Involved (see page 478)

« Troubleshooting (see page 479)
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Technical Background

The Simple Certificate Enrollment Protocol (SCEP) defines a way of automatically enrolling certificates for the
authentication of network devices or VPNs. The client uses HTTP requests to fetch root certificates, to send

certificate requests, and to fetch client certificates from the server.

For an in-deep description, see the Microsoft technet article "Network Device Enrollment Service (NDES) in Active

Directory Certificate Services (AD CS)" under http://aka.ms/ndes.

Here is a typical certificate enrollment process:
e

~m

CA Certilicate
i [T
L 2

Certification
Authority

Check pefmissions

(

‘

AN

Domain
Controller

Confirm permissions

Device Administator SCEP Server
—— Create key j
N Request
password
Provide
password

Set password

Send enrolln

ent request

Send RArequest _

_ Issue certificate

Return certificate

1. The device creates an RSA public-private key pair.

2. The administrator requests a challenge password from the SCEP service (e. g. NDES).

@ Thechallenge password is only required for the first enrollment request. For certificate
renewal, the current certificate is used for authentication.

3. The SCEP server asks the domain controller if the administrator holds the required permissions for

the configured certificate templates.

4. The domain controller confirms that the administrator holds the required permissions.
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5. The SCEP server creates a challenge password and hands it over to the administrator.

@ Typically, the challenge password expires after a defined time. With the NDES that is
included in Windows 2008 Server, the default expiry time is 60 minutes.

6. The administrator provides the device with the challenge password, the CA identifier, and the
fingerprint of the CA certificate.

7. The device sends the enrollment request to the SCEP server, using the challenge password to
authenticate with the SCEP server. This action is triggered by the administrator.

8. The SCEP server signs the enrollment request with its enrollment agent certificate and sends it to
the CA.

9. The CAissues the desired certificate and returns it to the SCEP server.

10. The SCEP server returns the certificate to the device.
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Client Enrollment Details

This section describes the actual certificate enrollment in detail. The process described here corresponds to step 7
to 10 in the overall process (see page 465).

(® Theenrollment request and the response from the CA that contains the req

1. Theclient requests the CA's public certificate from the SCEP server.

The SCEP server sends the CA's public certificate to the client.

3. Theclient checks the CA's public certificate against the relevant fingerprint. The fingerprint has
been provided by the administrator via a UMS profile; see Defining the Certification Authority (see
page 474).

4. The client sends an enrollment request to the SCEP server. This enrollment request isan HTTP GET
request that contains the following:

Signed data PKCS7 Enveloped data PKCS7 Certificate Signing Request
(PKCS 10)

N

Version
Hashing algorithm
Signed (unencrypted) data: Version

Recipient and related
encrypted data encryption
key; the recipient is the CA.

Encrypted data: Version

(encrypted with a randomly
generated key that is
encrypted with the recipient's
public key)

Requested subject name
Public key of client
Challenge password
Requested extensions
Signature algorithm
Digital signature

Client certificate

Digital signature

5. Ifthe request was successful, the HTTP response from the SCEP server includes the following data:
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Signed data PKCS7 Enveloped data PKCS7 Degenerate Certificates (only
PKCS7)

Version

Hashing algorithm

Signed (unencrypted) data:  Version
List of recipients

Encrypted data: Version
Issued X.509 certificate

CA certificate

Digital signature
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Configuration of the SCEP Client

The configuration of the SCEP client on the IGEL OS device is carried out as follows:

+ Creating a Profile in the UMS (see page 470)

+ Activating the SCEP Client (see page 471)

« Entering the Data for the Certificate Signing Request (CSR) (see page 472)
« Defining the Certification Authority (CA) (see page 474)

+ Providing the SCEP Server Data (see page 475)

+ Applying the Profile to the Devices (see page 476)
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Creating a Profile in the UMS

1. Inthe UMS structure tree, go to Profiles, open the context menu and select New Profile.

Enter an appropriate Profile Name.

In the Based on menu, select the firmware version that is installed on the devices in question.
Click OK.

The configuration dialog opens. The configuration dialog corresponds to the IGEL Setup available
on the devices to which the profile is assigned.

Call S
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Activating the SCEP Client

1. Goto Network > SCEP Client (NDES).
2. Enable Manage Certificates with SCEP.

SCEP Certificate Enrollment

> ' I petwork * SCEP Client (NDES)

Configuration & (V] Manage Cerificates with SCEP

User Interface

» I LAN Interfaces
B Mobile Broadband
» Il DHCP Client
» Il VPN
v [ SCEF Client (MDES)
i Certificate
i Cerification Authority
B scer
» [ Routing
i Hosts
» Il Network Drives

n P rosxy

Security
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Entering the Data for the Certificate Signing Request (CSR)

» Go to Network > SCEP Client (NDES) > Certificate and enter the following data:

Type of CommonName/SubjectAltName: The characteristic for linking the certificate to the device.

IP address: The IP address of the device.

DNS name: The DNS name of the device.

IP address (auto): The IP address of the device (inserted automatically).
DNS name (auto): The DNS name of the device (inserted automatically).
Email address: An email address.

DNS name as UPN (auto)

If the client automatically obtains its network name, DNS Name (auto) is a good type for the client
certificate.

The following parameter is available if Type of CommonName/SubjectAltName is set to IP address, DNS name, or
Email address:

CommonName/SubjectAltName: Give a designation which matches the Type of CommonName/SubjectAltName.
For certain types, this occurs automatically. No entry is then required.

The following parameter is available if Type of CommonName/SubjectAltName is set to IP address (auto), DNS
name (auto), or DNS name as UPN (auto):

CommonName/SubjectAltName Suffix: Specifies a suffix that will be added to CommonName/SubjectAltName.
Possible values:

"none": No suffix will be added.
"dot + DNS domain (auto)": The system's current DNS domain name separated with a dot will be

added. Example: .1igel. local

Free text entry: The manually entered suffix will be added. Take notice that the percent symbol
"%" is used for introducing the escape sequence, and thus the following replacements take place
automatically:

+ % D isreplaced by the system's DNS domain name at the time the certificate signing
request (CSR) is created. Example: @% D will be changed into @ igel.de if the system's
current DNS domain nameis igel.de.

+ %% will be replaced by %. Example: A %% B will be changedinto A % B .

+ Other combinations with % are currently discarded. Example: A % BC will be changed
into A C.
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() Ifyou have to specify the suffix manually, make sure you enter the separator.

Organizational unit: Stipulated by the certification authority.

Organization: A freely definable designation for the organization to which the client belongs.
Locality: Details regarding the device’s locality. Example: "Augsburg".

State: Details regarding the device’s locality. Example: "Bayern".

Country: Two-digit ISO 3166-1 country code. Example: "DE".

RSA key length (bits): Select a key length (one suited to the certification authority) for the certificate that is to be
issued.
Possible values:

. "1024"
. "2048"
. "4096"

(@ TheRSAkey length specified here must not be lower than the minimum key length configured on the
server.

SCEP Certificate Enroliment

) ~ I ® Network ®™ SCEP Client (MDES) ™ Cerificate

Configuration Type of CommonMName/SubjectAliName DMNS name (auto)

CommonMame/SubjectAlthame Suffix

ries
Organizational Unit Technical Documentation
User Interface

Organization IGEL Technology

| Interfaces Locality Augsburg
bile Broadband

State Bayern
Country DE
RSA Key Length (bits)

n Authority

ts
» I Network Drives

‘ Proxy

Search

Apply and send to device Cancel
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Defining the Certification Authority (CA)

1. Goto Network > SCEP Client (NDES) > Certification Authority.
2. Enter the details for the certification authority (CA):
+ CAldentifier: FQDN (fully qualified domain name) of the CA
+ CA Certificate Fingerprint (MD5): Fingerprint of the CA certificate in the form

01:02:03:04:05:06:07:08:09:0A:0B:0C:0D:0E:0F:10

® Youcan get the fingerprint from your NDES server: https://<NDES Servername>/

certsrv/mscep_admin

ITCO00BCADS5018

) ~ I ® MNetwark ™ SCEP Client (MNDES) ™ Certification Authority

Configuration CA ldentifier |Ca-examp|8-com |

= ion CA Cerificate Fingerprint (MD5) |:lJ--i:DS:DE:D?:IJB:DEI:DA:DEI:DC:DD:DE:DF:1 D||

User Interface

» [l LAN Interfaces
B Mobile Broadband
» [ DHCP Client
» I VPN
¥ [ SCEP Client (NDES)
B Certificate
B certification Authority
B scer
» [ Routing
‘ Hosts
» [l Metwork Drives
‘ P roxy

Apply and send to thin client Save Cancel

If the CA certificate fingerprint is specified, the client will use it to check the integrity of the CA
certificate it receives from the SCEP server.
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Providing the SCEP Server Data

1. Goto Network > SCEP Client (NDES) > SCEP.
2. Enter the following data:
« SCEP server URL: URL by which the SCEP client communicates with the SCEP server.

@ HTTPS s not supported; however, all security critical data that are transferred between
the SCEP client and other components are encrypted.

+ Proxy server for SCEP requests (optional): IP address or host name of the proxy server that
is used for the communication between the device and the SCEP server. If a web application
firewall is used instead of a proxy, its IP address or host name of the proxy server must be
entered here.

« Challenge password: Password that the SCEP client must present to the SCEP server in its
request (CSR).

® 0n aMicrosoft NDES server, you can retrieve the password by default under https:///

certsrv/mscep_admin.

© By default, the password on a Microsoft NDES server is valid for 1 hour and can be used only once.
In order to use the password on numerous devices, additional settings must be made on the NDES
server. For information, see the section "Password and Password Cache" on https://
social.technet.microsoft.com*,

+ Certificate renewal period (days): Time interval before certificate expiry after which the
certificate renewal procedure is started. (Default: 30)

« Certificate expiry check interval (days): Specifies how often the certificate is checked
against its expiry date. (Default: 1)

3. Save the settings.

43 https://social.technet.microsoft.com/wiki/contents/articles/9063.active-directory-certificate-services-ad-cs-network-device-enrollment-service-
ndes.aspx
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Applying the Profile to the Devices

1. Inthe UMS structure tree under Devices, select the devices you want to assign the profile to.
2. Inthe Assigned objects area, click €.

Z- IGEL Universal Management Suite 6
Help

< - c}’t’) Q"_I H '% J 5 Regex [ Whole Text

Server - 172.30.91.216 D O0EDC \ ned objects

¥/t IGEL Uniy nagement Suite 6

@ ITCOOEOC520986A

System Information
Advanced System Information

License Information
Monitor Information Indire
I Directory Name
Windows Updates and Hotfixes
¥ [ Devic
= Partial updates
] ITCODEOCS20986A

P 5 File Transfer status
UMS Administration

N
3. Inthe Select assignable objects dialog, select the relevant profile and click -~ to assign it.
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Select assignable objects

Selected objects

SCEP Certificate Enrollment
¥ = Firmware History (5)
10.04.100
500
10.06.100
11.01.100
11.02.100
SCEP Cerificate Enrollment
B ruesu)
Universal Firmware Upda

Firmware Customizations

4. Click Ok.
5. Inthe Update time dialog, select Now and click Ok.
The device performs the actions as described in Client Enrollment Details (see page 467).
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Files Involved

Allfiles involved are stored in the directory /wfs/scep_certificates/cert0 . The following fixed file

names are used:

cacert.pem
racert_enc.pem
racert_sig.pem
client.csr
client.cert

client.key

IGEL OS Articles

CA certificate

RA certificate used for encryption (optional)
RA certificate used for signature (optional)
Certificate signing request

Client certificate

Private key of client certificate
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Troubleshooting

+ Diagnostics (see page 480)
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Diagnostics
Preliminary: Tools

System Log Viewer

» Inthe start menu, select the system icon and then System Log Viewer to open the system log viewer.

g Firmware Update
ICG Agent Setup

@ Identify Monitors

Metwork Tools

05 11 Upgrade Tool
Safely Rermove Hardware
Screenshot Tool

Setup

@ System Infarmation

IQ System Log Viewer ]

Task Manager
Touchscreen Calibration

E UMS Registration
m Webcam Information

For more information on starting, using, and configuring the system log viewer, see the System Log Viewer chapter

of the IGEL OS Manual.

Local Terminal
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» In the start menu, select the Local Terminal.

w EEElAppIication Launcher
. Local Terminal

If a local terminal session has not been set up on your device, proceed as follows:

1. Open the Setup and go to Accessories > Terminals.
2. Click Lt to create a local terminal session.
3. Click Ok to save the setting and exit the Setup.

For more information on starting and using the local terminal, see the Terminals chapter of the IGEL OS Manual.

Checking the Current Status of the Client Certificate Enrollment

> In the local terminal, enter the command cert_show_status
The status for each certificate relating to SCEP is shown:

+ CA certificate

+ RA encryption certificate
+ RAsignature certificate

+ Client certificate

Reviewing Log Messages

1. Open the system log viewer and select /tmp/journal.log

2. Press[Ctrl] + [F] and enter cert_agent to search for relevant messages.
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Alternatively, you can open a local terminal and enter journalctl | grep cert_agent

Reviewing the Certificates and Certificate Requests in the File System

1. Opena local terminal and login as user .

2. Enter 1s /wfs/scep-certificates/cert@/

Deleting a Certificate Request

1. Opena local terminal and login as root .

2. Enter rm -rf /wfs/scep-certificates/certo/

The directory that includes the certificate request, received certificates (if existing), and the
device's own private client key, is deleted. This can be useful for debugging purposes, and if SCEP
is no longer used.

Checking the CA

1. Openalocal terminal and login as root .

2. Enter scep_getca 0

Generating an SCEP Request Manually

1. Openalocal terminal and login as root .

2. Enter scep_mkrequest 0

Enrolling a Certificate Manually

1. Openalocal terminal and login as root .

2. Enter scep_enroll 0

Testing Certificate Renewal

1. Opena local terminal and login as root .
2. Generate an SCEP request and append "new" to the key file name: scep_mkrequest 0
“new”
An SCEP request is issued. In the directory /wfs/scep-certificates/cert0/ ,thekeyfile
clientnew. key iscreated.
3. Renew the certificate: scep_renew 0
4. Overwrite the old certificate with the new one: mv /wfs/scep-certificates/cert0/

clientnew.cert /wfs/scep-certificates/cert@/client.cert
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5. Overwrite the old key with the new one: mv /wfs/scep-certificates/cert0/

clientnew.key /wfs/scep-certificates/cert@/client.key
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Deploying Trusted Root Certificates

Purpose

IGEL OS comes with a number of trusted root certificates from certain Certificate Authorities (CA) pre-installed. For
a complete list of pre-installed root certificates, see CA Certificates Contained in IGEL OS 11.02.100.

Certificates signed with these root certificates can be used for server authentication and encryption in ICA, RDP,
Horizon and browser sessions. You can also verify the origin of Java applications.

Nevertheless, the root certificate you need might be missing. This document explains how to load and distribute it.

Requirements

The certificates must be available in the Base64 file format encoded with the file extension .pem, .crt

or .cer.

To check the file format, open the certificate with a text editor. It should look like this:

—————BEGIM CERTIFICATE-———-
MIIDWZCCakogawIBAGIGaGd BwW7UVOGEMS
MROWE QY KCZIMIZPyLGOBGRYEGYZADET

EiNszngJsngHMQmmyS'29285062u3
JUZN3SVTZT UZ 5w D HOMOC P2y D ey
————— EMD CERTIFICATE-----

Solution

We advise you to use the following file transfer types for distributing the certificates via the UMS; see also
Registering a File on the UMS Server:

Type To be used for

Undefined All-purpose class, you need to set the owner and
access permissions manually.

Web Browser Certificate Server authentication/encryption of HTTPS
websites in browsers

SSL Certificate Server authentication/encryption in ICA, RDP or
Horizon sessions

Authentication via Active Directory (AD)

Java Certificate Authentication/encryption for Java applications
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IBM iAccess Certificate Server authentication/encryption for IBM iAccess
sessions
Common Certificate (all-purpose) Multiple applications needing a certificate, e.g. if

you want to launch an ICA session in a browser, or
if you want to secure a Java session on a secure
website.

With these file transfer types, you will not need to reboot after installing.

+ Deploying Certificates via UMS (see page 486)
« Installing Certificates Manually (see page 489)
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Deploying Certificates via UMS

We advise you to use the Universal Management Suite for deploying certificates when you have a certain number of
clients to be addressed.

Certificates can be deployed via the UMS in two steps:

+ Loading Certificates in the UMS (see page 487)
+ Assigning Certificates to IGEL Thin Clients (see page 488)
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Loading Certificates in the UMS

Open the UMS console.

Right-click Files.

Choose New file to open the New file mask.

Activate Upload local file to UMS server.

Browse your new certificate file under Local file.

Select the suitable Classification of the certificate under File target.
Confirm with OK.

Your certificate is now listed in the Files window.

Nk whE
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Assigning Certificates to IGEL Thin Clients
After integrating the new certificates, you distribute them to the thin clients:

1. Choose one thin client or a group of thin clients in the UMS tree.
2. Click Add under Assigned objects.

The Select assignable object window opens.

Mame IF Address  MAC Address Product Firmuware
BIGEL—DDDCH N 167 1RA3  NAAC?909  IGFI Universal Desktop..  4.06.50...
@IGEL_DDDCE Select assignahble ohjects E TN
BIGEL—DDEDC p.. 4.06.50..
@IGEL—DDEDC ¥ |GEL Universal Management Suite p 40611
» Profiles
P Thin Clients
P Views
Shared Workplace Users
» Jobs
¥ Files
©  Fedifikattest.cer
Universal | FilesiZerlikatiest.cer |

r @

igned objects E ."_ (-EI‘ =

4
Mame

o Full config sample

Directary

ned objects 2 .':. [ ]

MName

w

Select the new certificate and confirm by clicking on OK.
4. Select the Update time and confirm by clicking on OK.

The new certificate is now assigned to every thin client of the group and is listed under Assigned
objects.

Mame

o Full config sample
= Zedifikattest.cer

IGEL OS Articles

488 /823



Certificates

Installing Certificates Manually

Use the Firefox Certificate Manager in order to install web browser certificates; see Installing Web Browser
Certificates (see page 491).

Also a USB flash drive can be used for the manual import.

+ Importing SSL Certificates (ICA, RDP, Horizon) (see page 490)
+ Installing Web Browser Certificates (see page 491)
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Importing SSL Certificates (ICA, RDP, Horizon)

If a CA certificate is missing for RDP, ICA or Horizon, you can copy it from a USB storage device to the thin client:

1.
2.

Connect your USB storage device to the thin client.

Launch a Terminal session or press [CTRL]+[ALT]+[F11] to log in as ROOT on the Linux console of
the thin client.

Create a directory for certificates:

mkdir /wfs/ca-certs

Change to the directory:

cd /wfs/ca-certs

Get the name of your USB storage device:

1ls /userhome/media

Copy the certificate to the client:

cp /userhome/media// /wfs/ca-certs

Check whether the certificate was transferred:

1ls -al /wfs/ca-certs

End the terminal session or press [CTRL]+[ALT]+[F1] to exit the console.

@ The certificates you have saved will be available when you boot up the thin client next
time.
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Installing Web Browser Certificates
Installing web browser certificates manually:

1. Open the IGEL Setup.
2. Click Sessions > Browser > Browser Global > Certificates > View Certificates to open the Firefox

Certificate Manager.

s ™ Browser ™ Browser Global ™ Certificates

‘When a website requires a certificate | Select one automatically -

View Certificates

Certificate Validation | validate a certificate if it specifies an OCSP server A

» [ PowerTerm Terminal Enf
B IEM iAccess Client
» Il ThinLinc
M ssH
» Il VNC Viewer
¥ [ Browser
¥ [ Browser Global
B Tabs
B content
B Print
B Proxy
B Privacy
B security
B 2dvanced
B Encryption
i Certificates |
B smartcard Middley

3. Click Import... in the Authorities tab to import a new certificate from a directory or a USB flash
drive.

] When an OCSP server connection fails, treat the certificate as invalid

Certificate Manager

Your Certificates People|ServersfAuthoritiesjothers

You have certificates on file that identify these certificate authorities:

Certificate Name Security Device B
+ AC Camerfirma S.A. £
Chambers of Commerce Root - 2008 Builtin Object Token
Global Chambersign Root - 2008 Builtin Object Token
+ AC Camerfirma SA CIF AB2743287
Chambers of Commerce Root Builtin Object Token
Global chambersign Root Builtin Object Token .

— T

View... Edit Trust...

Export... Delete or Distrust...

(» Manually installed certificates will be saved permanently without any further configuration.
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Which CA Certificates Are Contained in IGEL OS?

The following CA certificates are contained in IGEL OS 11.02.100:

Certificate name Expiry date File in /etc/ssl/certs
ACCVRAIZ1 Dec 3109:37:37 2030 GMT ACCVRAIZ1.crt
AC RAIZ FNMT-RCM Jan 100:00:00 2030 GMT AC_RAIZ FNMT-RCM.crt

Actalis Authentication Root CA  Sep 22 11:22:022030 GMT Actalis_Authentication_

Root_CA.crt

AddTrust External CA Root May 30 10:48:38 2020 GMT AddTrust_External_Root.
crt

AffirmTrust Commercial Dec 31 14:06:06 2030 GMT AffirmTrust_Commercial.
crt

AffirmTrust Networking Dec 31 14:08:24 2030 GMT Aff9rmTrust_Networking.
crt

AffirmTrust Premium Dec 31 14:10:36 2040 GMT AffirmTrust_Premium.crt

AffirmTrust Premium ECC Dec 3114:20:24 2040 GMT  AffirmTrust_Premium_ECC
.crt

Amazon Root CA 1 Jan 17 00:00:00 2038 GMT Amazon_Root CA_1.crt

Amazon Root CA 2 May 26 00:00:00 2040 GMT Amazon_Root_CA_2.crt

Amazon Root CA 3 May 26 00:00:00 2040 GMT Amazon_Root_CA_3.crt

Amazon Root CA 4 May 26 00:00:00 2040 GMT Amazon Root CA_4.crt

Atos TrustedRoot 2011 Dec 3123:59:59 2030 GMT Atos TrustedRoot 2011.c
rt
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Certificate name

Autoridad de Certificacion
Firmaprofesional CIF A62634068

Baltimore CyberTrust Root

Buypass Class 2 Root CA

Buypass Class 3 Root CA

CA Disig Root R2
CFCAEVROOT

COMODO Certification Authority

COMODO ECC Certification
Authority

COMODO RSA Certification
Authority

Certigna
Certigna Root CA

Certinomis - Root CA

Class 2 Primary CA

IGEL OS Articles

e

IGE

Expiry date File in /etc/ssl/certs

Dec 31 08:38:152030 GMT Aytoridad_de_Certificac

jon_Firmaprofesional_CIF

_A62634068.crt

May 12 23:59:00 2025 GMT Ba1timore_CyberTrust_Ro

ot.crt

.crt
.Ccrt

Jul 19 09:15:30 2042 GMT CA_Disig_Root_R2.crt

Dec 3103:07:012029 GMT CFCA_EV_ROOT.crt

Dec 3123:59:59 2029 GMT  cOMODO_Certification_Au
thority.crt

Jan 18 23:59:59 2038 GMT  coMODO_ECC_Certificatio
n_Authority.crt

Jan 18 23:59:59 2038 GMT  cOMODO_RSA_Certificatio
n_Authority.crt

Jun 29 15:13:05 2027 GMT Certigna.crt

Oct108:32:272033 GMT  certi gna_Root_CA.crt

_Root_CA.crt
Jul623:59:592019GMT  certplus_Class_2_Primar

y_CA.crt
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Certificates

Certificate name

Certum Trusted Network CA

Certum Trusted Network CA 2

Chambers of Commerce Root -

2008

AAA Certificate Services

Cybertrust Global Root

D-TRUST Root Class 3 CA 22009

D-TRUST Root Class3CA2 EV
2009

DST Root CA X3

Deutsche Telekom Root CA 2

DigiCert Global Root CA

DigiCert Assured ID Root CA

DigiCert Assured ID Root G2

IGEL OS Articles

Expiry date
Dec 31 12:07:37 2029 GMT

Oct 6 08:39:56 2046 GMT

Jul3112:29:50 2038 GMT

Dec 31 23:59:59 2028 GMT

Dec 15 08:00:00 2021 GMT

Nov 5 08:35:58 2029 GMT

Nov 5 08:50:46 2029 GMT

Sep 30 14:01:15 2021 GMT

Jul923:59:00 2019 GMT

e

IGE

File in /etc/ssl/certs

Certum_Trusted Network_
CA.crt

Certum_Trusted_Network_

CA_2.crt

Chambers_of_Commerce_Ro
ot_-_2008.crt

Comodo_AAA_Services_roo

t.crt

Cybertrust_Global_Root.

crt

D_
TRUST_Root_Class_3_CA_2_
2009.crt

D_
TRUST_Root_Class_3_CA_2_
EV_2009.crt

DST_Root_CA_X3.crt

Deutsche_Telekom_Root_C
A_2.crt

Nov 10 00:00:00 2031 GMT p4giCertGlobalRootCA.pe

m)

NOV lO 00:00'00 2031 GMT D-i g-i Ce rt_Assu red_ID_ROO

Jan 15 12:00:00 2038 GMT

t_CA.crt

DigiCert_Assured_ID_Roo
t_G2.crt
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Certificate name

DigiCert Assured ID Root G3

DigiCert Global Root CA

DigiCert Global Root G2

DigiCert Global Root G3

DigiCert High Assurance EV Root
CA

DigiCert Trusted Root G4

E-Tugra Certification Authority

EC-ACC

EE Certification Centre Root CA

Entrust.net* Certification

Authority (2048)

Entrust Root Certification
Authority

Entrust Root Certification
Authority - EC1

44 http://Entrust.net

IGEL OS Articles

e

IGE

Expiry date File in /etc/ssl/certs

t_G3.crt

.Ccrt

.crt

.Ccrt

Nov 10 00:00:00 2031 GMT DigiCert_High_Assurance
_EV_Root_CA.crt

Jan 15 12:00:00 2038 GMT p+ giCert_Trusted_Root_G
4.crt
Mar 3 12:09:48 2023 GMT g

Tugra_Certification_Auth

ority.crt

Jan 722:59:59 2031 GMT  Ec-ACC.crt

Dec 1723:59:592030 GMT EE_Certification_Centre
_Root_CA.crt

Jul2414:15:122029 GMT  Entrust.net_Premium_204

8 _Secure_Server_CA.crt

Nov 27 20:53:42 2026 GMT Entrust_Root_Certificat

jon_Authority.crt

Dec 18 15:55:36 2037 GMT Entrust_Root_Certificat
jon_Authority_-_ECl.crt
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Certificates

Certificate name

Entrust Root Certification
Authority - G2

GDCA TrustAUTH R5 ROOT

GTS Root R1
GTS Root R2
GTS Root R3
GTS Root R4
GeoTrust Global CA

GeoTrust Primary Certification
Authority

GeoTrust Primary Certification
Authority - G2

GeoTrust Primary Certification
Authority - G3

GeoTrust Universal CA

GeoTrust Universal CA 2

GlobalSign

IGEL OS Articles

e

IGE

Expiry date File in /etc/ssl/certs

Dec717:55:542030 GMT = Entrust_Root_Certificat

jon_Authority_-_G2.crt

Dec 3115:59:59 2040 GMT  GDCA_TrustAUTH_R5_ROOT.

crt
Jun 22.00:00:00 2036 GMT GTS Root _Rl.crt
Jun 22.00:00:00 2036 GMT GTS Root _R2.crt
Jun 22.00:00:00 2036 GMT GTS Root_R3.crt

Jun 22 00:00:00 2036 GMT GTS_Root_R4.crt

May 21 04:00:00 2022 GMT GeoTrust_Global _CA.crt

Jul16 23:59:59 2036 GMT  GeoTrust_Primary_Certif

jcation_Authority.crt

Jan 1823:59:59 2038 GMT  GeoTrust_Primary_Certif
ication_Authority_-

_G2.crt

Dec123:59:592037GMT  GeoTrust_Primary_Certif
ication_Authority_-

_G3.crt

Mar 4 05:00:00 2029 GMT  GeoTrust_Universal CA.c
rt

Mar 4 05:00:00 2029 GMT  GeoTrust_Universal CA_2

.crt

Jan 19 03:14:07 2038 GMT  G1obalsSi gn_ECC_Root_CA_
- _R4.crt
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Certificate name

GlobalSign

GlobalSign Root CA

GlobalSign

GlobalSign

GlobalSign

Global Chambersign Root - 2008

Go Daddy Class 2 Certification
Authority

Go Daddy Root Certificate
Authority - G2

Hellenic Academic and Research
Institutions ECC RootCA 2015

Hellenic Academic and Research
Institutions RootCA 2011

Hellenic Academic and Research
Institutions RootCA 2015

IGEL OS Articles

Expiry date
Jan 19 03:14:07 2038 GMT

Jan 28 12:00:00 2028 GMT

Dec 15 08:00:00 2021 GMT

Mar 18 10:00:00 2029 GMT

Dec 10 00:00:00 2034 GMT

Jul3112:31:40 2038 GMT

Jun 29 17:06:20 2034 GMT

Dec 31 23:59:59 2037 GMT

Jun 30 10:37:12 2040 GMT

Dec 113:49:52 2031 GMT

Jun 30 10:11:21 2040 GMT

e

IGE

File in /etc/ssl/certs
GlobalSign_ECC_Root_CA_
- _R5.crt

GlobalSign_Root_CA.crt

GlobalSign_Root_CA_-
_R2.crt

GlobalSign_Root_CA_-
_R3.crt

GlobalSign_Root_CA_-
_R6.crt

Global_Chambersign_Root
_—_2008.crt

Go_Daddy_Class_2_CA.crt

Go_Daddy_Root_Certifica
te_Authority_-_G2.crt

Hellenic_Academic_and_R
esearch_Institutions_ECC
_RootCA_2015.crt

Hellenic_Academic_and_R
esearch_Institutions_Roo
tCA_2011.crt

Hellenic_Academic_and_R
esearch_Institutions_Roo
tCA_2015.crt
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Certificate name

Hongkong Post Root CA 1

ISRG Root X1

IdenTrust Commercial Root CA 1

IdenTrust Public Sector Root CA 1

Imprivata Embedded Code
Signing CA

lzenpe.com®

LuxTrust Global Root 2

Microsec e-Szigno Root CA 2009

NetLock Arany (Class Gold)
F6tanusitvany

Network Solutions Certificate
Authority

e

IGE

Expiry date File in /etc/ssl/certs
.Crt

Jun411:04:382035GMT  TSRG_Root_X1.crt

Jan 16 18:12:23 2034 GMT  TdenTrust_Commercial_Ro
ot_CA_l.crt

Jan 16 17:53:322034 GMT  1denTrust_Public_Sector
_Root_CA_l.crt

Sep 7 16:20:00 2033 GMT Imprivata.crt

Dec 13 08:27:252037 GMT 1 cnpe. com®. crt

Mar513:21:572035GMT | uxTrust_Global_Root 2.

crt
Dec 30 11:30:18 2029 GMT M4 crosec_e-
Szigno_Root_CA_2009.crt
Dec 6 15:08:212028 GMT  Netlock_Arany_=Class_Go
ld=_F6tanusitvany.crt

Dec 3123:59:59 2029 GMT  Network_Solutions_Certi
ficate_Authority.crt

OISTE WiSeKey Global Root GA CA Dec 11 16:09:51 2037 GMT 0ISTE_WISeKey_Global_Ro

ot _GA_CA.crt

OISTE WiSeKey Global Root GB CA Dec115:10:31 2039 GMT  0ISTE_WISeKey_Global_Ro

45 http://Izenpe.com
46 http://Izenpe.com

IGEL OS Articles

ot_GB_CA.crt
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Certificates

Certificate name

e

IGE

Expiry date File in /etc/ssl/certs

OISTE WiSeKey Global Root GC CA May 9 09:58:33 2042 GMT  0ISTE_WISeKey_Global_Ro

QuoVadis Root Certification
Authority

QuoVadis Root CA1G3

QuoVadis Root CA 2

QuoVadis Root CA2 G3

QuoVadis Root CA3

QuoVadis Root CA3 G3

SSL.com*" EV Root Certification
Authority ECC

SSL.com® EV Root Certification
Authority RSA R2

SSL.com® Root Certification
Authority ECC

SSL.com® Root Certification
Authority RSA

SZAFIR ROOT CA2

SecureSign RootCAl1

47 http://SSL.com
48 http://SSL.com
49 http://SSL.com
50 http://SSL.com

IGEL OS Articles

ot_GC_CA.crt

rt

Nov 24 18:23:33 2031 GMT Qroad-i s_Root_CA_z .crt

rt

rt

Feb1218:15:23 2041 GMT S5 com_EV_Root_Certifi
cation_Authority_ECC.crt

May 30 18:14:37 2042 GMT 55| . com_EV_Root_Certifi
cation_Authority_RSA_R2.

crt

Feb 12 18:14:03 2041 GMT sS|.com_Root_Certificat
jon_Authority_ECC.crt

Feb 1217:39:39 2041 GMT sS| . com_Root_Certificat
jon_Authority_RSA.crt

Oct1907:43:30 2035 GMT szZAFIR ROOT_CA2.crt

Apr804:56:47 2029 GMT  secureSign_RootCAll.crt
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Certificates

e

IGE

Certificate name Expiry date File in /etc/ssl/certs

Security Communication RootCA2 May 29 05:00:39 2029 GMT Security_Communication_
RootCA2.crt

Security Communication RootCAl Sep 30 04:20:49 2023 GMT Security_Communication_
Root_CA.crt

Sonera Class2 CA Apr607:29:40 2021 GMT  sonera_Class_2_ Root_CA.
crt

Staat der Nederlanden EV Root CA Dec 8 11:10:28 2022 GMT  staat_der_Nederlanden_ E
V_Root_CA.crt

Staat der Nederlanden Root CA-  Mar2511:03:102020 GMT staat_der_ Nederlanden_ R

G2 oot_CA_-_G2.crt

Staat der Nederlanden Root CA-  Nov 13 23:00:00 2028 GMT staat_der_Nederlanden R

63 oot_CA_-_G3.crt

Starfield Class 2 Certification Jun2917:39:16 2034 GMT starfield Class_2 CA.cr

Authority .

Starfield Root Certificate AuthorityDec 31 23:59:59 2037 GMT starfield_Root_Certific

62 ate_Authority_-_G2.crt

Starfield Services Root Certificate Dec 3123:59:59 2037 GMT starfield _Services_Root

Authority - G2 o .
_Certificate_Authority_-

_G2.crt
SwissSign Gold CA - G2 Oct 25 08:30:35 2036 GMT  gissS gn_Gold_CA_-
_G2.crt
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Certificate name

SwissSign Silver CA - G2

T-TeleSec GlobalRoot Class 2

T-TeleSec GlobalRoot Class 3

TUBITAK Kamu SM SSL Kok

Sertifikasi - Surum 1

TWCA Global Root CA

e

IGE

Expiry date File in /etc/ssl/certs

Oct 25 08:32:46 2036 GMT SwissSign_Silver_CA_-
_G2.crt
Oct 123:59:59 2033 GMT  T-

TeleSec_GlobalRoot_Class
_2.crt

Oct123:59:59 2033 GMT  1-
TeleSec_GlobalRoot_Class
_3.crt

Oct 25 08:25:55 2043 GMT TUBITAK _Kamu_SM_SSL_Kok
_Sertifikasi_-

_Surum_1l.crt

Dec 31 15:59:59 2030 GMT TwCA _Global _Root CA.crt

TWCA Root Certification Authority Dec 31 15:59:59 2030 GMT TyCA Root_Certification

Government Root Certification
Authority

TeliaSonera Root CA vl

TrustCor ECA-1

TrustCor RootCert CA-1

TrustCor RootCert CA-2

Trustis FPS Root CA

IGEL OS Articles

_Authority.crt

Dec513:23:332032GMT  Taiwan_GRCA.crt

Oct 18 12:00:50 2032 GMT  TeliaSonera_Root_CA_v1.
crt
Dec 31 17:28:07 2029 GMT TrystCor ECA-1.crt

Dec3117:23:16 2029 GMT  TrystCor_RootCert_CA-1.

crt

Dec 3117:26:39 2034 GMT TrystCor_RootCert_CA-2.

crt

Jan 2111:36:54 2024 GMT  Trystis_FPS_Root_CA.crt
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Certificates

Certificate name

UCA Extended Validation Root

UCA Global G2 Root

USERTrust ECC Certification
Authority

USERTrust RSA Certification
Authority

VeriSign Class 3 Public Primary

Certification Authority - G4

VeriSign Class 3 Public Primary
Certification Authority - G5

VeriSign Universal Root
Certification Authority

VeriSign Class 3 Public Primary
Certification Authority - G3

XRamp Global Certification
Authority

certSIGN ROOT CA

ePKI Root Certification Authority

IGEL OS Articles

e

IGE

Expiry date File in /etc/ssl/certs

Dec 31 00:00:00 2038 GMT ycaA _Extended Validation

_Root.crt

Jan 18 23:59:59 2038 GMT ySERTrust_ECC_Certifica

tion_Authority.crt

Jan 1823:59:59 2038 GMT ySERTrust_RSA_Certifica

tion_Authority.crt

_Primary_Certification_A

uthority_-_G4.crt

Jul 16 23:59:59 2036 GMT VeriSign_Class_3_Public

_Primary_Certification_A

uthority_-_G5.crt

Dec 123:59:592037 GMT  veriSign_Universal_Root

_Certification_Authority

.crt
_Primary_Certification_A
uthority_-_G3.crt

Jan 1 05:37:19 2035 GMT XRamp_Global_CA_Root.Cr
t

Jul417:20:04 2031 GMT certSIGN_ROOT _CA.crt

Dec 20 02:31:27 2034 GMT opKI Root_Certification
_Authority.crt
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Certificate name

thawte Primary Root CA

thawte Primary Root CA - G2

thawte Primary Root CA - G3

IGEL OS Articles

e

IGE

Expiry date File in /etc/ssl/certs
Jul 16 235959 2036 GMT thawte_Pr-i ma ry_Root_CA .

crt

-_G2.crt

Dec 123:59:59 2037 GMT thawte_Pr-ima ry_Root_CA_
-_G3.crt
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» Authentication with IGEL Smartcard (see page 505)
» Smartcard Authentication (see page 514)
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Authentication with IGEL Smartcard

Smartcards make the user experience more convenient by providing a single device that supports multiple
authentication products across the enterprise. The user only has to remember a single PIN that unlocks the smart

card to access the network.

Prerequisites

Before using the IGEL smartcard, the relevant profiles and session information need to be written to the smartcard.

We describe a best practice way of how to proceed. The names of folders and profiles are only examples and can be

changed individually.

It is useful to use following folders and profiles on the Universal Management Suite (UMS):

Folder Profile

Smartcard Creation

Smartcard Key

Smartcard Operation

Smartcard Login

Purpose

Folder for devices which will be used for
smartcard creation.

This profile will apply the defined company key to
the devices. This key will be written while creating
the IGEL smartcard.

Folder for devices whose authentication process
will work only via IGEL smartcard.

This profile will apply the company key to the
devices and will activate the login with IGEL
smartcard.

» Create two folders under Profiles in the Universal Management Suite (UMS), e.g. "Smartcard Operation" and

"Smartcard Creation".

> Create the profile "Smartcard Login" for "Smartcard Operation".

» Create the profile "Smartcard Key" for "Smartcard Creation".

IGEL OS Articles

Creating IGEL Smartcard Folders (see page 506)

Folder "Smartcard Operation" (see page 507)

Folder "Smartcard Creation" (see page 508)

Writing the IGEL Smartcard (see page 509)

Smartcard Readers Supported by IGEL Smartcards (see page 513)
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Creating IGEL Smartcard Folders

First, add two new profile folders for creating profiles and assigning them to devices:

« "Smartcard Operation";
« "Smartcard Creation".

Server - 172.30.91.30

Fy

¥ /- IGEL Universal Management Suite 6

¥ Profiles (0)

[ Smartcard Operation (0)

[ Smartcard Creation (0)

IGEL OS Articles
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Folder "Smartcard Operation"
In this folder, you create a new profile "Smartcard Login":

1. Right-click the folder "Smartcard Operation".
Choose New Profile.

Enter a Profile Name, e.g. "Smartcard Login".
Click Security > Logon > IGEL Smartcard.
Enable Login with IGEL smartcard.

Enter your Company key.

oA WD

Configuration € [¥) Login with IGEL Smartcard

g
5
A .ories Company Key okkskokdok

REGE RS Start application to write IGEL Smartcards:
Network

Smartcard Personalization

Devices
Security

‘ Password
¥ [ Logon
B 1GEL smartcard
B Taskbar
B Active Directary/Kerber
I Active Directory/Kerberos
> I Smartcard

() Lateron, this profile will be applied to all devices where the authentication process shall work only
with a smartcard.
This way, the device will receive:

« the company key and
« theinformation that the authentication is only possible with the smartcard.

@ The company key is a private key shared between devices and smartcards. It should be
chosen similarly to a good password. If the smartcard does not hold the same company
key as the device, authentication will not be possible. Remember this company key
because you will need later to write exactly the same key to the smartcard.
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Folder "Smartcard Creation"
In this folder, you create a new profile "Smartcard Key":

1. Right-click the folder "Smartcard Creation".

2. Choose New Profile.

3. Enter a profile name, e.g. "Smartcard Key".

4. Click Security > Logon > IGEL Smartcard.

5. Enter the same Company key as in the profile "Smartcard Login".

Another additional folder is useful:

> Create the subfolder "Get settings from" under "Smartcard Creation".
In this folder, you create the profile with the session information you want to write to the smartcard.

Server - 172.30.91.30

¥ /- IGEL Universal Management Suite 6
Profiles (2]
¥ = Smartcard Operation (1)

Smartcard Login
¥ = Smartcard Creation (1)
¥ = Get settings from (1)
Smartcard Key

(D You need this additional folder because the assignment of active profiles from the UMS to the IGEL
smartcard can cause problems (firmware version < 5.06.100). Later on, you will copy the folder locally to
your device.
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Writing the IGEL Smartcard

Assigning the Profile "Smartcard Creation" to the Device

1. Prepare one device which has a smartcard reader/writer.

2. Integrate this device in the UMS and put it into the folder "Smartcard Creation".
Now the device automatically receives the company key from the profile. It will be used when
writing the smartcard.

Ensuring That the Profile Assignment Was Successful

1. Open the local setup of your device.
2. Click Security > Logon > IGEL Smartcard.
You should now see a disabled field Company key with a lock symbol.

* Logon ™ IGEL Smartcard

Configuration
9 | @M = @s
EEEIER—— o
IGEL Active Auto Logoff
Wi AR e Smartcard Directonyk...
- L
= -'

. Security A (] Login with IGEL Smart Card
Password [] Enable IGEL Smart Card without Locking Desktop

v Logon

IGEL Srmartcard Company Key |‘\1| kK

» o Active Directory/Kerber

Auto Logoff Start application to write IGEL Smart Cards:
oo Active Directory/Kerberos ||
R — — N S -
. System v | Smart Card Persanalization

Writing the Profiles to the Smartcard

1. Open the folder "Smartcard Creation" in the UMS.

2. Right-click your device.

3. Choose Take over settings from... to copy the profile settings to the device.
The dialog Copy settings from... opens.

4. Choose your profile from the folder "Smartcard Creation" > "Get settings from".

5. Enable Overwrite Sessions.

IGEL OS Articles 509 /823



Smartcard

Copy settings from ... E3

Zelect a profile

¥ Profiles (601) E
B o Misc (266)
¥ Smartcard Crestion (2)
¥ Get Settings from (1) /
_..- Example Seszion
_..- Smartcard Key
B o Smartcard Operation (1) E
@ Only Active Settings O Add Sessions
O Al Settings @ Creerwrite Sessions

6. Click OK to copy the profile with the settings and the company key to the device.

Writing the Smartcard

1. Open the local setup of your device.
2. Click Security > Logon > IGEL Smartcard.
3. Click Smartcard personalization.
The Smartcard personalization dialog opens.
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Smartcard Personalization

LLozd Sessions; Save Sessions

First name
Last Name
Require Password

Password

Available Sessions - Sessions on Smartcard |Autostart |Restart

[£] Browser
B caradigm Session

ICA Connection Center
Login

self-Service ==
genucard VPN Connection =
Java Manager

[®] RDP Session

EA rn Weh Acress | anin

Write smartcard | | X Close

ke

4. Enter the First name and the Last name of the smartcard holder that should appear at the login
prompt.

5. Activate Require password and specify the Password if a password has to be required for the
smartcard login.

6. Select the local sessions you want to write to the smartcard.

@ Usethe arrow buttons to add a session to the smartcard session list.

7. Activate Autostart for a session in the smartcard list if it should be automatically started at login.
Check Restart if desired.

@® The configuration of the sessions can be saved and reloaded at a later time.

8. Click Write smartcard to start the writing process with the defined settings.
9. Confirm the security question with Yes.
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Write Smartcard >

_ Writing the Smartcard overwrites all the Data
';' ! ;f on the Card. Do You want to go on?

P ]
. € No I @ ves
The notice Smartcard successfully written appears.
Write Smartcard b4
~—| Smartcard successfully written.
Lid

g 3
I ® Close !

Testing the New IGEL Smartcard

1. Go tothe UMS.

2. Register a new device in the UMS and putitin the folder "Smartcard Operation".
The device gets the company key and the profile information that authentication is only possible
with the IGEL smartcard.

3. Restart the device.
The Insert Smartcard... dialog opens.

4. Insert the IGEL smartcard into your device and verify the selected configuration.
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Smartcard Readers Supported by IGEL Smartcards
IGEL smartcards are supported by the following third-party smartcard readers:

« OMNIKEY CardMan 3111

+ OMNIKEY CardMan 3x21

« OMNIKEY CardMan 3621

« OMNIKEY CardMan 6121

« OMNIKEY CardMan 3821

+ USB CCID Smart Card Reader

« USB CCID Smart Card Reader Keyboard

+ Fujitsu Siemens Computers SmartCard-Reader USB 2A
+ Fujitsu Siemens Computers SmartCard-Reader Keyboard USB 2A
+ Fujitsu Siemens Computers SmartCard-Reader USB 2C
« Cherry SmartBoard XX44

« OMNIKEY CardMan 5121

+ OMNIKEY CardMan 5x21

+ HID Global OMNIKEY 3x21 Smart Card Reader

+ Cherry KC 1000 SC

+ Cherry KC 1000 SC/DI

« Cherry KC1000SCZ

« Cherry KC 1000 SC/DI Z

« Cherry SmartTerminal XX44 v2

« Cherry SmartTerminal XX44

+ OMNIKEY CardMan

+ CCID SC Reader

+ Cherry SC Reader.
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Smartcard Authentication

Certificate Authentication

The smartcards discussed here can hold digital certificates (x.509) and corresponding private keys. The private key
cannot be read from the card, but it can be used by the card itself for signing and decryption of data.

This enables the use of what is known as two-factor authentication: the user not only possesses the smartcard, he
or she can also prove the knowledge of the smartcard PIN by signing data using the private key stored on the
smartcard.

If you want to use Active Directory (AD), the certificate chain used by the key distribution center (domain controller)
must be available on the device. For instructions on deploying certificate files, see Registering a File on the UMS
Server (set Classification to "SSL Certificate") and Transferring a File to a Device.

Smartcard Readers

Smartcards are accessed via smartcard readers, using either a contact or contactless interface. The IGEL Third Party
Database® lists the readers that are supported by the Linux firmware.

PC/SC Resource Manager

The PC/SC Resource Manager is a common Application Programming Interface (API) that is available on Windows
and Linux operating systems. It provides a standardized way for applications to handle smartcards and readers.

The PC/SC Resource Manager is active by default in the Linux-based firmware and can be controlled via the Activate
PC/SC Daemon parameter on IGEL Setup > Devices > Smartcard > PC/SC or IGEL Setup > Security > Smartcard >
PC/SC or IGEL Setup > Security > Smartcard > Services (depending on the firmware version).

Smartcard Middleware

In order to provide a generalized interface to different types of smartcard hardware, there is an additional software
layer called smartcard middleware.

There are different types of middleware:

Windows Linux
CSP, Cryptographic Service Provider v
PKCS#11, Public-Key Cryptographic Standards v V4

51 https://www.igel.com/linux-3rd-party-hardware-database/
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Smartcard

Application

SC Middleware
CSP or PKCSH11

PC/SCResource
Manager

Smartcard Reader
Driver

Smartcard Reader

Smartcard

Some of the smartcard authentication methods require smartcard middleware to be installed on the endpoint
device. The following modules are available:

« Gemalto SafeNet

« cryptovision sc/interface
+ Gemalto IDPrime

+ Athena IDProtect

+ A.E.T.SafeSign

« Secmaker Net iD

+ Coolkey

» OpenSC

« 90meter

() Licensed Feature

This feature requires an add-on license; see Add-On Licenses. Please contact your IGEL reseller.

For information on how to use a custom PKCS#11 library, refer to the article Using a Custom PKCS#11 Library (see
page 626).

+ Active Directory Logon with Smartcard (see page 517)
« Citrix StoreFront (see page 518)
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+ RDP Sessions (see page 520)
« Horizon Sessions (see page 521)
» Smartcard Authentication in Browser (see page 522)
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Active Directory Logon with Smartcard

See the how-to Passthrough Authentication (see page 795).
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Citrix StoreFront

In this scenario, Citrix Receiver 13.1 or newer is required. The root certificate of the web server certificate used by the
StoreFront server has to be known as the trusted root certificate on the endpoint device - see Deploying Trusted
Root Certificates (see page 484), Certificate Type SSL Certificate.

1. Under Sessions > Citrix > Citrix StoreFront > Server, specify the Server location.

Server locatio
umnmary Server location

ob n Options Protocol Store address Path to Store Store name

v
B citrix Client Selection
(|

» [ Citrix Legacy ICA S Citrix Store site address Path to Store

O
[
ﬁ Login

ﬁ Appearance

ntt . 443 CitriiStore

Store name

i Reconnect
‘ Refresh Ok Cancel
ﬁ Logofi

2. Choose Smartcard authentication as Authentication type under Sessions > Citrix > Citrix
StoreFront > Login.

Configuration Authentication type = card a ntica reFront only, not Web Interface)

Oniy for Citrix StoreFront

on Options rough authentication

B Citrix Client Selection
Im
» M Citrix Legacy IC:
vO
]
]

E s

Appearance

@ When used in combination with Active Directory Logon the enabled Use Passthrough
authentication activates single sign-on with smartcard.

3. Select the appropriate PKCS#11 module for the smartcard Security > Smartcard > Middleware.
« Gemalto/SafeNet eToken
« cryptovision sc/interface
+ Gemalto IDPrime
« Athena IDProtect
+ A.E.T. SafeSign
« Secmaker NetiD
* 90meter
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() Licensed Feature

This feature requires an add-on license; see Add-On Licenses. Please contact your IGEL
reseller.

« Custom PKCS#11 module. See here also Using a Custom PKCS#11 Library (see page 626).
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RDP Sessions
In this scenario, the smartcard middleware has to be installed on the server side.

1. Enable Activate PC/SC Daemon under Security > Smartcard > Services.
2. Check Enable Smartcard under Sessions > RDP > RDP Global > Mapping > Device Support.

Configuration Enable plugin support

slons summary
‘ Glob: ion Options
» [l Citrix
¥ O RDP
¥ [ RDP Global
ﬁ Gateway
n Local Logon
B Window
n Keyboard
¥ [ Mapping
n Drive Mapping
B cowPorts
n Printer
_ 8 Device Support v Enable smartcard
B sudio
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Horizon Sessions

In this scenario, the smartcard middleware has to be installed on the virtual desktops as well as configured on the
endpoint device side.

The View Connection Server has to be configured on the endpoint device side.

(@ TheView Connection Server has to be configured to accept connections via SSL/TLS secured https URLs.
The root certificate of the certificate used for this service has to be known as the trusted root certificate on
the thin client (see the how-to Deploying Trusted Root Certificates (see page 484), certificate type SSL
Certificate).

1. Select the appropriate PKCS#11 support for the smartcard under Sessions > Horizon Client >
Horizon Client Global > Smartcard.
« Gemalto/SafeNet eToken
« cryptovision sc/interface

+ Gemalto IDPrime
+ Athena IDProtect

+ A.E.T. SafeSign

+ Secmaker NetiD
+ Coolkey

» OpenSC

¢ 90meter

() Licensed Feature
This feature requires an add-on license; see Add-On Licenses. Please contact your IGEL
reseller.

For details on the custom PKCS#11 library, refer to the article Using a Custom PKCS#11 Library (see
page 626).

2. Configure the Server URL under Sessions > Horizon Client > Horizon Client Sessions > [session
name] > Connection settings.

@ startthe URLwith https:// !
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Smartcard Authentication in Browser
Itis possible to authenticate using a smartcard at websites, e. g. Citrix Web Interface or StoreFront.

When connecting via an SSL/TLS secured https URL, the root certificate of the web server certificate has to be
known as the Trusted Root Certificate on the endpoint device; see Deploying Trusted Root Certificates (see page
484), certificate types Web Browser Certificate and (!) SSL Certificate.

> Select the appropriate PKCS#11 module (security device) for the smartcard under Sessions > Browser >
Browser Global > Smartcard Middleware.

« Gemalto/SafeNet eToken
« cryptovision sc/interface
« Gemalto IDPrime

« Athena IDProtect

« A.E.T. SafeSign

« Secmaker Net iD

« Coolkey

» OpenSC

« 90meter

() Licensed Feature

This feature requires an add-on license; see Add-On Licenses. Please contact your IGEL reseller.

For details on the custom PKCS#11 library, refer to the article Using a Custom PKCS#11 Library (see page 626).
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+ Display Configuration for Shared Workplace (SWP) (see page 524)

+ Display Switch (see page 525)

« Multimonitor (see page 529)

+ Showing and Hiding the On-Screen Software Keyboard Automatically (see page 541)

« Overcoming the Restrictions of a Full-Screen Session with the in-Session Control Bar (see page 542)
+ Screen Issues When Redocking Notebook (see page 544)
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Display Configuration for Shared Workplace (SWP)

As of IGEL Universal Desktop Linux version 4.14.100 and version 5.06.100, Shared Workplace allows user specific
screen resolutions and configurations. Resolution, layout, refresh rate, rotation, number of screens, monitor
connectors (DVI, VGA, ...) can be set per user, but color depth cannot.

() There are technical limitations to user-specific settings: For VIA graphics drivers/hardware, the maximum
desktop sizeis setinthe Screen section of the X confi guration file. The name and location of the X
configuration file depends on the firmware version:

+ IGEL Linux version 10: /config/Xserver/xorg.conf-0

+ IGEL Linux version5: /config/Xserver/xorg.conf-0 or /etc/X11/
xorg.conf (thisisasymboliclink that pointsto /config/Xserver/xorg.conf-0)
Inthe Screen section of the above-mentioned configuration file, you can find a line

suchas Virtual 1920 1200 .Thesize defined here cannot be changed dynamically;
itis a hard limit for the overall desktop size.

Best practice

It is recommended to set the initial desktop configuration to the maximum number of screens and the resolutions
to A utodetect . This way the user specific resolutions will not be restricted.

Debugging

If the total framebuffer size of the user specific resolutions exceeds the limits of the Virtual [width]

[height] settingfrom /config/Xserver/xorg.conf-0 (or /etc/X11l/xorg.conf ),the userspecific
resolutions cannot be activated and the screen configurations are not changed dynamically.

There is no warning dialog or anything else to alert the user to this restriction. But you can find related log
messagesvia journalctl orin /var/log/messages:

XRANDR: ERROR: CANNOT APPLY CHANGES ->

XRANDR: ERROR: -> Selected modes ([width]x[height]) would exceed the maximum
framebuffer size ([width]x[height])
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Display Switch

If you are using a notebook with IGEL UDC2, UDC3, or UD Pocket, you might want to connect an additional monitor.
If you are using an IGEL thin client (UD series), you might want to use two monitors. Any thinkable display mode,
like clone mode/mirroring or extended mode, is possible. Moreover, you can change between the display modes
quickly.

Configure a Starter for the Display Switch

There are many ways to start the display switch. The following example shows how to define a hotkey typical for a
notebook.

1. Open the Setup and go to Accessories > Display Switch.
2. Activate Hotkey.

Configuration Session Name

Starting Methods for Session
Start Menu Start Menu
Application Launcher v Applicat
op Desktop Context Menu

Start Panel

None

B commands

By default, [Fn]+[F7] ( XF86D1isplay ) is defined as the hotkey for starting the display switch. You
can change the hotkey by selecting or entering different keys in Modifiers and Key.

@ Toenter akey that does not have a visible character, e. g. the [Tab] key, open a terminal,
logonas user andenter xev -event keyboard .Pressthe key to be used for the

hotkey. The text in brackets that begins with keysym contains the key symbol for the
Key field. Example: Tab in (keysym Oxff09, Tab)

3. Press Apply or Ok.

Configure the Display Switch

1. Open the Setup and go to Accessories > Display Switch > Options.
2. Consider the following settings:
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+ Dialog Type: In most cases, you can leave it at Minimal Dialog. The user can always switch
to the advanced dialog, provided that Advanced in the Minimal Dialog area is activated.

« Smart display configuration: Activate this option, if you want to save all your display
configurations.

+ Preserve settings over reboot: Activate this if the settings made by the display switch are
to remain unchanged after reboot.

+ Configure new displays when connected: Activate this if you want the display switch to

start automatically as soon as a new monitor is connected.

To fine-tune the minimal dialog, change the settings under Buttons in Minimal Dialog.

Dialog Type Minimal Dialog
ciation service should run on output hotplug
er reboot

when connected

Buttons in Minimal Dialog
Vv Mirror dis

Use the Display Switch

The minimal dialog will look similar to this; details depend on your specific setup:
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IGEL Display Switch (A)(x]

)
H i

- Mouse settings
[ Lefthand Mode  Pointer speed 50 = Double click| 300 |

1: VGA (524C650) 2: HDMI (524B420) |Identify Displays|
Advanced | Reset | | Close |
Button Function

Uses only display 1.

2 Shows the same content on all screens, i.e. clone mode or
1 mirroring.

1 2 \ Extends the display area to the screen on the right.

Extends the display area to the screen on the left

T Uses only display 2.
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NG |

L]

For more information, see the manual chapter Using Display Switch

Rotates the selected display to the left or to the right.

HO ML

1680x1050

2Z0P4LPY/AUS1435009584

The P marks the primary Display.
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Multimonitor
Working with two or more screens is becoming increasingly popular in professional working environments.
You can find out how to configure several screens and an extended desktop with the IGEL setup here.

There are different screen configuration options:

+ Automatic Configuration (see page 530)

+ Manual Configuration (see page 532)

+ Additional Settings (see page 534)

+ Auto Switch Monitor Configuration for Laptops (see page 539)

If you work with IGEL Universal Desktop or supported UDC2 hardware, multimonitor support is guaranteed.

Difficulties may arise if you work with UDC2 hardware and your hardware is not fully supported by IGEL.

(@ Multimonitor configuration for unsupported hardware only works if native graphic driver support
functions properly. You must ensure that the native driver really does work because the fallback VESA
driver does not allow multimonitor configuration. Click About in the Application Launcher to determine
which graphic chipset you work with. If VESA is listed there, the native driver will not work and
multimonitor configuration will not be possible.

» Seethe Linux 3rd party hardware database® for supported graphic cards.

52 https://www.igel.com/linux-3rd-party-hardware-database/
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Automatic Configuration
The firmware recognizes the native graphic driver and will apply the screens automatically by default.
Define two or more monitors:

1. Goto User Interface > Display in the structure tree.
2. Select 2 (or more) under Number of screens.

() Thenumber of monitors that you can select depends on your hardware. Using the Universal
Management Suite (UMS), you can choose up to 8 monitors.

3. Choose the screen under Selected screen or by clicking it with a mouse.

The selected screen is highlighted with a blue frame:
a

Number of screens |2 v

H==Z2dEE

1|2

Selected screen (1 =

©
Screen resolution = i ‘ i ‘ ] i ] 0 A i ] i ! i ! i A 10 0 ‘ 1T ! i Autodatect

¥ Advanced ...

] Detect rafresh rate autamatical by

Graphic card |Card 1 M

Monitor [Automatic M

4. Set Screen Resolution to Autodetect (default setting).
The operating system reads out the EDID (Extended Display Identification Data) of the monitors
through DDC (Display Data Channel). With these data, the correct resolution for the monitors can
be recognized and set.

@ If the Autodetect resolution is not available check Monitor probing (DDC) under User
Interface > Display > Options. The Monitor probing (DDC) must be enabled (default
setting).

© With more than 2 monitors, the screen resolution has to be specified for each screen manually.

5. Enable Detect refresh rate automatically (default setting) under Advanced.
6. Set Monitor to Automatic.
The selected screen is automatically assigned to the graphic connector (monitor).
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7. Dragand drop the rectangles to position the screens.
() Screenlisalways the primary screen where the taskbar is situated.

8. Click Apply or OK to save the settings.
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Manual Configuration

During automatic configuration, the following problems can sometimes arise:

+ One of the screens remains black.
« There is the same display on all screens.

In this case, you can set the screens manually:

1. Goto User Interface > Display in the structure tree.

2.
3.

a
Mumber of screens |2 v

H==0 8RR

Selected screen |2

Screen resolution U
[ [ | T [ | 1 [ | [ | 1 1

¥ Advanced...

[] Detect refresh rate automatically

Refresh rate |60 M|
Graphic card | Card 1 M|
Monitor HDMI()

Automatic
HDMICI)

Select a screen number under Selected screen.
Specify the resolution manually under Screen resolution.

@ The standard resolution setting is Autodetect.

i 12B80x768

() FromIGEL Linux Version 10.03.100, you have the option of defining your own resolutions via the
registry ( x . xserver0.custom_resolution ). In order for the values set there to take effect,
the resolution must be set to Autodetect (the slider at the far left). The following parameters apply

to the entry in the registry:
« WxH :W=width, H=height (example: 1920x1080)

« WxHE@R :W=width, H=height, R =refresh rate (example: 1920x1080@60 or

1920x1200@59.8)
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4. Select for all screens the respective connector under Monitor. The manual configuration can take
effect only if you assign the monitor connector to all screens.

@ Ifyou adjust the settings directly in IGEL Setup, only the connected monitors will be
available in the selection list. If you want to configure the screens using the UMS profile, all
possible connectors will be shown in the selection list and you will not know which one is
relevant for your device.

Tip:

> Click “ in your client setup to obtain information about the connector names, screen resolutions and screen
numbers.

(@ This configuration cannot be accessed from the UMS.

The black field belongs to the screen number on the left side:

COnnector name _l

scresn resolution

DVI-D

S24B420/HAMDBODES4

1920x1200

Close

scresn number
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Additional Settings

A number of useful tips are provided below:

+ Rotating a Screen (Pivot) (see page 535)
+ Setting Different Backgrounds (see page 536)
+ Useful Window Settings (see page 537)
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Rotating a Screen (Pivot)
1. Click on a monitor field.

2. Select E (Rotates the selected screen counterclockwise) or (Rotates the selected screen
clockwise).

(@ Two screens with autodetected resolutions are automatically aligned to the top.

> Alignment: If you enter the correct resolution, you can see the real size of the screens and you will be able to
align them the way you want.

@ Theindividual screen areas must however be in contact with each other at one edge and corner, and
cannot overlap.
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Setting Different Backgrounds

You can easily set different backgrounds for your screens.

» Click User Interface > Desktop > Background in the structure tree of the setup.
There is a configuration page for each screen.

Configuration Wallpaper (1st monitor) blue {
Wallpaper Style (15t Monitor) Streched

Color Style (1st Monitor) Solid color

Desktop Color (1st Monitor) Choose color

2nd Desktop Color (1st Monitor) Choose color

I Options €) V' Custom wallpaper download (1st monitor)

vO
= Custom Wallpaper file (1st Monitor) I:l

> Select the wallpaper and define the style.

@ You may also upload your own Custom Wallpaper, e.g. a background with your corporate design. See
Creating Your Own Wallpaper (see page 638).
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Useful Window Settings

Setting the Start Monitor or Full-screen Mode:

1. Click the name of your session under Sessions in the IGEL Setup, e.g. RDP > RDP Sessions.

2. lick [Session Name] > Window to configure the window settings.

Mumber of colors

| Global setting

Window size

Desktop scale factor

Display resolution
Start monitor

Multi-monitor fullscreen mode

€} fullscreen

Global setting

[Same as window size

| No configuration

| Global setting

@ Forthe function "2nd monitor as Start monitor" the Window size has to be set to full-

screen.

Setting the Multimonitor Full-screen Mode

1. Click Window in the global folder of your session, e.g. RDP > RDP Global > Window.

2. Configure the window settings.

Number of Colors
Window size

Desktop scale factor

[+/] Enable Display Control
[] control bar for RDP sessions

| Millions

fullscreen

auto

Multi Monitor

Multi-monitor fullscreen mode

Defining the Taskbar

1. Click User Interface > Desktop > Taskbar.
2. Define the Taskbar settings.

IGEL OS Articles
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] Use Taskbar

Taskbar Position

Vertical Taskbar Mode

Taskbar Height/width

MNumber of rows/columns in taskbar
Multi Monitor Taskbar Size

Maonitor

[] Taskbar an top of all windows

| Bottom

Deskbar

40

Automatic

[Restrict taskbar onto one monitor

1st monitor

[] Taskbar Auto Hide
Auto Hide Behavior
Taskbar Show Delay

Taskbar Hide Delay

Intelligently

600

@ If you want to expand the taskbar onto all monitors, you have to ensure that the screens
are aligned to the bottom. Otherwise, you will see only half of the taskbar on one monitor.

IGEL OS Articles

538/823



Desktop and Display

Auto Switch Monitor Configuration for Laptops
This ist one example of how to configure auto switch monitor for Laptops.

1. Connect the device and close/open lid.
2. Open the Display Switch utility (which has already been activated under Accessories > Display
Switch).

IGEL Display Switch

)

Display Switch

|Ident|fy D|sp|ays|

|Advanced| | Close |

3. Inthe advanced mode, you can drag & drop the displays for your intended configuration.
The display will snap adjacent to others.

4. If adisplay should not be used, it can be dragged to the Disabled area on the top right - the screen
will be reactivated when it is dragged back to the active area.

5. To show the same content on multiple displays, one display should be dragged onto an other
active screen.
The interface will show Mirrors. The mirroring monitor will be displayed on the lower right.

6. Press Apply to save the setting

7. Press Yes on the Keep configuration dialog so that the current settings will be saved to persistent
storage and associated with the profile.
You can configure advanced functionality (e. g. panning, scaling and resolutions) in drop-down
boxes (hidden in a drawer on the right side)

+ Klick the > button on the right edge.
8. GoinIGEL Setup under Accessories > Display Switch > Options.
9. Enable Preserve settings over reboot and Smart display configuration. (Default: disabled)

IGEL Setup 10.05.500.01 (Build 5.9.18)

Switch ™ Options

Dialog Type [Minima\ Dialog vJ

£} (V] Preserve settings over reboot

) (V] configure new displays when connected

Buttons in Minimal Dialog
[ Mirror displays
(] Extend to the left
(] Extend to the right
] Rotate displays (Page orientation)

B IcA Connection Center
» I Terminals
» [ Change Smartcard Pass
» [ Change Password
» Il Setup
» [ Quick Settings
¥ [ Display Switch
B options
» [ Application Launcher
» Il Sound Preferences
» Il System Log Viewer
. UMS Registration
B Tauchserasn Calibration

[J Mouse options
] advanced
[2] Reset
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10. TheIGEL Display Switch utility is now used for NVIDIA graphic devices as well.

Configuration of the display setting for Notebook lid handling

You can configure the lid handling of a notebook so that the notebook goes into standby mode by closing the lid,
regardless of whether the notebook is plugged in or not.

Settings of the Standby Mode

If you want your notebook to go into standby mode by closing the lid, while your notebook is plugged in, you have
to do following setting:

1. Gounder IGEL Setup to System > Registry > system > actions > lid > ac.
2. SetLid close action while plugged in to Suspend.(Default: Turn off display)
3. Click Apply or Ok to save the setting.

If you want your notebook to go into standby mode by closing the lid, while your notebook isn't plugged in, you
have to do following setting:

1. Gounder IGEL Setup to System > Registry > system > actions > lid > battery.
2. SetLid close action while not plugged in to Suspend.(Default: Turn off display)
3. Click Apply or Ok to save the setting.

() Ifyou want that the notebook turn off display after closing the lid, it makes sense to set the following
setting to switch off the notebook internally:

1. Gounder IGEL Setup to System > Registry > sessions > user_display0 > options >
lid_events.

2. Enable React on lid open and close event.

3. Click Apply or Ok to save the setting.
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Showing and Hiding the On-Screen Software Keyboard Automatically

You can configure the on-screen software keyboard to appear or disappear automatically when an input box is
selected or deselected (e. g. Firefox or screenlock).

Showing Automatically
With the following setting, a software keyboard will be shown automatically when an input box is focused.
1. Inthe Setup, go to Registry > userinterface > softkeyboard > autoshow (parameter:

userinterface.softkeyboard.autoshow).
2. Enable Automatically show on-screen keyboard when text field is selected.

Hiding Automatically

With the following setting, the software keyboard will be hidden automatically when an input box is not focused
anymore.

1. Inthe Setup, go to Registry > userinterface > softkeyboard > autohide (parameter:
userinterface.softkeyboard.autohide)
2. Enable Automatically hide on-screen keyboard when text field is deselected.

If there are any problems, e. g. the keyboard does not hide automatically, you have to disable Automatically hide
on-screen keyboard when text field is deselected and make sure that the following Setup parameters have been
enabled:

+ Accessories > On-Screen Keyboard > Autostart
+ Accessories > On-Screen Keyboard > Restart
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Overcoming the Restrictions of a Full-Screen Session with the in-Session
Control Bar

Running a session in full-screen mode gives you the advantage that the complete real estate of your monitor is at
the disposal of that session. However, you might still want to eject a hotplug drive, or to minimize or end the
current session. The solution provided by IGEL Linux is called in-session control bar.

Activating the in-session control bar:

1. Open the Setup and go to User Interface > Desktop > In-Session Control Bar.

2. Activate Use in-session control bar in all supported sessions if you want to have an in-session
control bar in all session types for which it is supported. If you want to have an in-session control
bar only in sessions of certain types, activate the appropriate options, e.g. Control bar for RDP

sessions.
Iﬂ ] Use In-session control bar in all supported sessions I

Start Monitor | Automatic )

[ ] contral bar for RDP sessions

[ ] control bar for Citrix sessions

[] control bar for ThinLinc sessions

[] contral bar for MX sessions

[] control bar for Parallels Client sessions

3. Inthe Start Monitor choice, select the display on which you want the in-session control bar to

appear. If unsure, leave it at Automatic.
#) (/] Use In-session control bar in all supported sessions

| start Monitor | Automatic - ||

[ ] contral bar for RDP sessions

[ ] control bar for Citrix sessions

[] control bar for ThinLinc sessions

[] Contral bar for MX sessions

[] control bar for Parallels Client sessions

4. Click Apply or Ok.

Using the in-session control bar:

1. Move the mouse to the upper edge of the desktop.
The in-session control bar appears.

) § dokuw7HS 4 3 X

2. To perform the desired action, click the appropriate icon:
« Toeject a USB device, click £ .
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« To minimize the session view, click * .
« To end the session, click X .
« To make the in-session control bar visible permanently, click * .
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Screen Issues When Redocking Notebook

Environment
UDC-converted notebooks running IGEL Linux 5 and above.
Issue

When you take a notebook off the dock, e. g. to move to meeting rooms or other locations, and redock the
notebook, the screen resolution ends up wrong, sometimes with a black screen and other similar screen issues.

Solution

1. In Setup, go to Accessories > Display Switch > Options.

2. Enable Configure new Displays when connected.
The display switch will start when the notebook is redocked.

3. Use the display switch to configure the display appropriately. For further information, see the Tips
& Tricks article Display Switch.

4. Click Ok to save the settings.

& LegalNote
IGEL's Terms & Conditions® apply.

53 https://www.igel.com/terms-conditions/
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Customizing

« Custom Partition Tutorial (see page 546)

+ Using a Custom PKCS#11 Library (see page 626)

+ Adding an Icon for Browsing Removable Storage (see page 628)

« Adding an Icon for the Image Viewer (see page 630)

+ Creating a Timed Command (Cron Replacement) (see page 632)

« Customizing IGEL OS Desktop (see page 634)

+ How to Change the Font Color of the Desktop Icons (see page 657)

« How to Set Up a Countdown to Prevent an Undesired Screen Lock In IGEL OS (see page 659)
« Installing a Calculator on IGEL Linux (see page 671)

+ Keyboard Shortcuts for Managing Windows (see page 672)

+ Make Frequent User Actions Easier by Defining Hotkeys (see page 673)

« Shutdown/Suspend Devices Automatically at the End of a Session (see page 675)
+ Suspend to RAM - Wake Up by USB Mouse (see page 676)

« Taking Screenshots on IGEL Linux (see page 677)

+ Setting the Device's System Time (see page 678)

+ Updating Timezone Information (Daylight Saving Time, DST) (see page 679)

« Adding or Changing a MIME Type Handler (see page 683)

+ Regional Settings in Sessions (see page 687)
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Custom Partition Tutorial

The Custom Partition mechanism solves the task of supplying additional software or other files to IGEL OS while still
being able to update the system in the regular way.

This tutorial describes creating content for a Custom Partition for IGEL OS 11.01.100 or newer. In the examples, IGEL
0S 11.03.500 is used. You may also find it useful for updating existing Custom Partitions in order to make them work
on IGEL 0S 11.01.100 or newer, as some details have changed.

& ThelGEL Support Team offers support for the deployment of Custom Partitions. However, it is not possible
to offer support for any third-party software that is installed on a Custom Partition.

© Ifyou want to build a Custom Partition and give it to third parties, make sure you have redistribution
permission for the software. This is usually the case for Open Source / Free Software, but not for
proprietary software. Read the license agreements and respect them.

This tutorial contains the following sections:

A First Simple Custom Partition (see page 547)
Packaging the Custom Partition (see page 557)

A Real-World CP: Chromium (see page 573)

Zoom as a Custom Partition (see page 588)

Microsoft Teams as a Custom Partition (see page 608)
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A First Simple Custom Partition

As a first step, this tutorial will guide you through creating a simple Custom Partition. It will open a message window
greeting the user, which can be run by clicking a desktop icon. You will learn about some basic mechanisms of
Custom Partitions in this section.

Read all the following chapters in the order given and follow the instructions.

1. Development Environment (see page 548)

Activating the Custom Partition Functionality (see page 549)
"Hello World" Program (see page 550)

Creating the Custom Application (see page 552)

Using a Partition Parameter (see page 555)

ok wn
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Development Environment

For this first simple Custom Partition, you only need root access to a device with IGEL OS version 11.01.100 or
higher.

Next Step

>> Activating the Custom Partition Functionality (see page 549)
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Activating the Custom Partition Functionality
First, you must activate the Custom Partition functionality. It is deactivated by default.

1. Open the Setup and go to System > Firmware Customization > Custom Partition > Partition.
2. Check Enable Partition.

3. Setthe Size to "10M" Megabyte).

4

Leave the Mount Point at /custom
IGEL Setup 11.03.500.01 (Build 6.4.2) ] EJ[ES]
m ™ Firmware Customization ™ Custom Partition ™ Partition

€) V Enable Partition

Size £} [10M]

Mount Point

Partitions Parameters

Name Value

v
b
v
v
v
v
F

I L e LT e

Search

5. Click Apply.
The Custom Partition is created on the device's mass storage, which is indicated by a message.
When the Custom Partition is created and successfully mounted, the message reads:

Custom Partition

Successfully mounted.

Next Step

>>"Hello World" Program (see page 550)
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"Hello World" Program

Your first Custom Partition will contain a simple shell script that displays the message "Hello, world!" with the help
of the gtkmessage utility.

1. Open the local terminal on your device and login as root . If the local terminal has not been
configured yet, see Terminals.
2. Changeintothe /custom directory: cd /custom

Local Termina

login as "user" or "root": root
root@ITCOGEGCS1C5087 :~# cd /custom
root@ITCOGERCS1CE087 : /custom# I

3. Makea hello directory for your Custom Partition contents: mkdir hello
[root@ITCOREAC51C5087 : /custom# mkdir hello |

4. Changeintothe hello directory: cd hello/
[roct@ITCEEEGCS1C5087 : /custom# cd hello/||

5. Open a new plaintext file using the GNU nano editor: nano hello.sh
|root@ITCOREACS51C5087 : /custom/hello# nano hello.shlj |

@ Thecolors used by default for syntax highlighting in nano may be inconvenient for reading. You can
change the colors with the following command: sed -i "s#color cyan#color bluef#;

s#tcolor brightyellow#color red#" /usr/share/nano/sh.nanorc

Also, you can use the vi editor as an alternative; the commands for exiting and saving a file will be
different then.

6. Put this contentinto the file:
#!/bin/bash
gtkmessage -m "Hello, World!" -t "Hello" -o "Close"
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GNU nano 2.5.3 File: hello.sh

B! /bin/bash
gtkmessage -m "Hello $(customparam get NAME)!" -t "Hello" -o "Close"

€ Get Help @t Write Out @l Where Is gy Cut Text g Justify a® Cur Pos
i Exit i Read File gl Replace @Y Uncut Text @ To Linter gl Go To Line

7. Save the file by pressing [Ctrl]+[o], [Return].
8. Exit the GNU nano editor by pressing [Ctrl]+[x].

9. Make the file executable: chmod a+x hello.sh
|root@ITC@@EGC51C5@8?:fcustom{hello# chmod a+x hello.shl

10. Run the shell script from the command line to testit: . /hello.sh
|root@ITC@®EGC51C5@8?:/custom[hello# ./hello.shjj

A message window like this should open:

Hello world!

You can close it with the Close button.

Next Step

>> Creating the Custom Application (see page 552)
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Creating the Custom Application

In the previous step, you have created a little application and executed it from the command line. Now make it
more convenient for end-users: Create a custom application and place an icon on the desktop that users can click.

1. Inthe Setup, go to System > Firmware Customization > Custom Application.

2. In the Custom Applications list, click .+ to add an application.
IGEL Setup 11.03.500.01 (Build 6.4.2)

tem ™ Firmware Customization ™ Custom Application

Custom Applications

sion name

Search

The Desktop Integration page opens.
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3. Enter Hello Application asthe Session name.
IGEL Setup 11.03.500.01 (Build 6.4.2)

am * Firmw tic n Application » om Appli
nname

Starting Methods for Session
U

Menu folder

Application Laun

Hotkey

Search v

4, Click Apply.
5. Goto Settings.

6. Enter /custom/hello/hello.sh asthe Command.
IGEL Setup 11.03.500.01 (Build 6.4.2)

eam * Firmw n n Application * Hello App

Icon name

Command

Search v

7. Click OK.
A Hello Application icon has appeared on the desktop.
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N

Hello Application

8. Double-click the icon.
The "Hello" message window should open.

Hello =2 [%]

Hello world!

Next Step

>> Using a Partition Parameter (see page 555)
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Using a Partition Parameter

When you roll out the same Custom Partition contents to many devices, you may still want the application to use
different data or options on some of the devices. Partition parameters allow you to do this.

This is how you add a partition parameter to our "Hello World" program.

Setting a Partition Parameter in the Setup

1. Go to System > Firmware Customization > Custom Partition > Partition.
2. In the Partitions Parameters list, click . T .

m * Firmw; ization C m Partition ® Partition

€} ¥ Enable Partition
Size € 10M

Mount Point Jcustom

Partitions Parame

Name Value

Application
m Commands

Apply ok Cancel

3. Inthedialogthat opens, enter NAME asthe Nameand Alice asthe Value. Click OK.

Mame €3 MNAME

Value

4. Click Apply.

Getting the Value of a Partition Parameter

This is the command line for getting or setting a Partition Parameter's value:
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customparam [get|set] PARAMETER_NAME [PARAMETER_VALUE]

1. Changethe hello.sh scriptto use thiscommand to get the parameter value:

#!/bin/bash

gtkmessage -m "Hello $(customparam get NAME)!" -t "Hello" -o "Close"
2. Click the Hello Application desktop icon.
You should see the following:
Hello =2 [%]
@ Hello Alice!
556 /823
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Packaging the Custom Partition

In the previous section, you developed Custom Partition contents locally on a device. Now, package it in order to
deploy it to many devices via the Universal Management Suite (UMS).

Read all the following chapters in the order given and follow the instructions.

1. Development Environment (see page 558)

Compressing the Custom Partition Contents (see page 559)
Writing the *.inf Metadata File (see page 560)

Uploading the Files to the UMS (see page 561)

Creating a Profile for the Custom Partition (see page 566)
6. Assigning the Profile (see page 571)

ok wn

When you have built this Custom Partition successfully, you can continue with a real-world partition. The following
Custom Partitions are described in our tutorial:

» Chromium (see page 573)
e Z00Om (see page 588)
» Microsoft Teams (see page 608)
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Development Environment
For this section, you need:

+ asystem with IGEL 0S 11.01.100 or newer
+ Universal Management Suite (UMS) 6.01.100 or newer

Next Step

>> Compressing the Custom Partition Contents (see page 559)
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Compressing the Custom Partition Contents

The contents of a Custom Partition are packaged as a compressed tar file. Create it on the Linux command line,
e.g.on a device that is running IGEL OS:

1. Inthelocal terminal, become root andchangetothe /custom directory: cd /custom
|root@ITCE]E]EEJC51C5E]8?:~# cd /customl

2. Compressthe contents of the hello/ directoryinto an archive file named hello.tar.bz2:

tar cjvf hello.tar.bz2 hello/
[root@ITCEEERC51C5087 : /custom# tar cjvf hello.tar.bz?2 hello/l

Theresultisa hello.tar.bz2 file,sitting side-by-side with the hello/ directory. You will
upload it to UMS later.

Next Step

>> Writing the *.inf Metadata File (see page 560)
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Writing the *.inf Metadata File

In addition to the compressed archive that you created in the previous step, a plain text file with essential
information for the endpoint device is necessary. In this, step you will create the hello.inf file.

1. Change to the directory that contains the compressed contents of our Custom Partition

(hello.tar.bz2): cd /custom/
|root@ITCG@EGC51C5GB7:/custom# cd /custom/

2. Create anew filenamed hello.1inf and putthe followinginto it:
[INFO]
[PART]
file="hello.tar.bz2"
version="1.0_1igell"
size="160M"
name="hello"
minfw="11.01.100"
The individual entries and their meaning are:
[INFO] Mandatory string
[PART] Mandatory string
file Thefilenameofthe x.tar.bz2 archive

version The version of the contents, consisting of the vendor version (let's say this is "hello

1.0") and the IGEL package version (the first package we produced of the software), joined with an
underscore.

size Size of the decompressed contents

name Name of this content, used for naming the subdirectory within the custom partition and for
keeping track of installed contents
minfw Minimum firmware version required for these contents
3. Save thefile.

Next Step
>> Uploading the Files to the UMS (see page 561)
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Uploading the Files to the UMS

In this step, you upload the compressed hello.tar.bz2 archiveandthe hello.inf metadata file to the

UMS, which will serve them to other devices via HTTPS. To make the file available, you have to create a file object
after transferring the physical file.

Transferring the Files to the UMS

1. Inthe structure tree of the UMS Console, go to the device on which you have created the files and
select Other commands > Device File->UMS.

nfiguration Change Status

contral

GEL O3 11 (0}
UMS Administration
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IGEL

2. Inthe Device File->UMS dialog, under Device file location, enter the complete path and file name
of the bz2 archive: "/custom/hello.tar.bz2"

Device File->UMS

Device File-=1UMS

 TCOOEQCS

File information

Devices file location | fcustormshellotar bz2

Target URL

Device File-=LIWMS ance

3. Click - next to the Target URL to define the file path on the UMS Server.
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4. Inthe Save dialog, select ums_filetransfer as the directory.

Save

Loak In:

ums_filetransfer

Files of Type:  All Files

5. Enter "hello.tar.bz2" as the File Name and click Save.

Save

Files of Type:  All Files
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6. Back in the Device File->UMS dialog, click Device File->UMS.
Device File->UMS

Device File-=UMS

Tooo

File information

De file location  feustomdhello tarbz2

Target URL

Device File-=LMS

7. Repeat steps 1to 6 for the metadata file hello.inf.

Creating File Objects

1. Inthe UMS Console, right-click the Files folder in the structure tree and select New File from the
context menu.
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v B Files 1™
o

. chi
. chir
. clie
. clie
. rlie
. [n}=1)

The New file dialog opens.
2. Activate Select from UMS server and click IEM next to this option to open the file chooser.
3. Select ums_filetransfer.

Open

Look In: wehoday

Al Files

Open

4. Select "hello.tar.bz2" and click Open.
5. Backin the New file dialog, click Ok.

6. Repeat steps 1to 4 forthe metadata file hello.inf.

Next Step

>> Creating a Profile for the Custom Partition (see page 566)
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Creating a Profile for the Custom Partition

After you have uploaded the Custom Partition files to the UMS, you can now make the settings that will install the
Custom Partition on any number of devices. For this purpose, we will create a profile.

Activating the Custom Partition

1.

2.

No ook

In the structure tree of the UMS Console, right-click the Profiles folder and select New Profile
from the context menu.

In the New Profile dialog, enter "Hello" as the Profile Name and something like "Installs the Hello
Custom Partition" as the Description. You can leave the remaining fields.

Mew Profile
Profile Hame  Hello
Description nstalls the Hello tom Padition

Based on [GELOS511 11.0

* Expert mode

Click OK.

The configuration dialog opens, where you will make the settings for this profile.

Go to System > Firmware Customization > Custom Partition > Partition.

Unlock the Enable Partition setting by clicking the orange triangle so that it turns blue.
Check Enable Partition.

Unlock the Size setting by clicking the orange triangle so that it turns blue, and enter "10M".
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8. Leave the Mount Point at "/custom".

e » Firm mization ™ Custorn Partition ™ Partition

€) / V Enable Partition

rvey

- v

]
|y
i}
M Re
B Lo
.
]
v

Apply and send to device Save Cancel

Setting the Download Source
For this step, you need to determine the HTTPS download address for the hello.inf filefirst.

1. Tofind out the IP address of your UMS, go to System > Remote Management in the configuration
dialog. You will find the IP address of the UMS Server your device is registered with.
2. Open a web browser and visit the following URL:

https://[IP or name of your UMS host]:8443/ums_filetransfer

3. When prompted, authenticate with your UMS username and password.
You will see a directory listing of the files that can be downloaded from the UMS.
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@ Directory Listing For [/] X =+ B = X

& C A Notsecure | 172.30.92.9:8443/ums_filetransfer w e :

Directory Listing For [/]

Filename Size Last Modified
601813, 9py 1138.8 kb Fri, 29 Nov 201% 15:16:26 GMT
chromium-browser 64.0.3283.167.inf 0.1 kb Tue, 10 Mar 2020 15:35:45 GMT
chromium-browser 64.0.3282.167.tar.bz2 &3553.5 kb Tue, 10 Mar 2020 15:34:09%9 GMT
client—cert.pem 0.6 kb Thu, 12 Dec 201% 12:21:12 GMT
client-kevy.pem 0.2 kb Thu, 12 Dec 2019% 12:28:08 GMT
clientca-cert.pem 0.6 kb Thu, 12 Dec 201% 11:47:20 GMT
hellc.inf 0.1 kb Mon, 11 May 2020 12:24:08 GMT
hello.tar.bz2 0.2 kb Mon, 11 May 2020 12:17:42 GMT
IGEL 03 11-11.03.110/ Wed, 11 Mar 2020 16:42:20 GMT
:GEL_UniveIsal_DesktDD_LX—lG.05.500’ Fri, 15 Mar 2019 13:55:11 GMT
IGEL Universal Desktop ©5_3-10.05.100/ Mon, 18 Mar 2019 07:07:51 GMT
IGEL Universsl Desktop OS5 _3-10.06.130 Thu, 30 Jan 2020 16:09:01 GMT
installer—2.01.100.rc2.bin 3895964.0 kb Thu, 10 Cct 201% 10:04:02 GMT
journalctl.txt 218.8 kb Fri, 20 Mar 2020 15:29:32 GMT
1x 10.05.700.rc7 public.zip E56088.0 kb Fri, 05 Apr 2015 14:15:46 GMT
o3c.iso 2184736.0 kb Wed, 29 Apr 2020 14:06:05 GMT
R-201%0712.pem 0.7 kb Thu, 12 Dec 201% 11:44:08 GMT .

4. Right-clickthe hello.inf entryand select Copy link address (or the like, depending on your

browser).
5. Inthe profile's settings, go to System > Firmware Customization > Custom Partition >
Download.
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6. Next to Partitions Data Sources, click [+].

Configuration

7. The Add dialog opens.
8. Paste the URL you copied from the browser into URL.

Enter the User name and Password so that the device has access to your UMS.
You can ignore the Initial action and Final action fields for the time being.

Automatic

8-, 7

hello.inf

Br narme 2] «  admin

O

Initial action Ve

Final action Vi

10. Click OK.
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Creating a Custom Application

> Add a custom application to the profile by following the steps in Creating the Custom Application (see page 552).

Next Step

>> Assigning the Profile (see page 571)
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Assigning the Profile

Now that you have put all the settings for installing the Custom Partition on a device into a profile, it is time to
assign the profile.

1. Inthe UMS structure tree, drag and drop the icon of your profile onto the icon of a device.

The Update time dialog opens.
2. Select Now and click Ok.

Update time

When should these changes take effect?

05 aon next reboat (and dan't show this dialog againd

The device receives the settings of the profile, creates the Custom Partition, downloads the
contents of the Custom Partition and uncompresses them.
The Hello Application icon appears on the desktop.

3. Inthe device's local Setup, go to System > Firmware Customization > Custom Partition >
Partition.

4. Add a Partition Parameter with the Name "NAME" and a Value of your choice.

E3

Name €3 NAME

5. Backin the Setup, click Ok.
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6. Click theicon to test the application.
It should open, displaying a text containing the name of your choice.

Hello =[]

@ Hello Bob!
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A Real-World CP: Chromium

The previous example was simplified, but it taught you a lot of the IGEL Custom Partition fundamentals. Now build
on top of these and try your hand at a real-world CP: the Chromium web browser - the Open Source sibling of
Google Chrome, a complex application with a variety of features.

@ Asyou will be working with original Ubuntu packages, actual version numbers (or packages) may differ
from this tutorial, as Ubuntu frequently update their packages. The method for building the CP, however,
remains the same.

« Development Environment (see page 574)

+ Getting the Ubuntu Package (see page 575)

+ Unpacking the Ubuntu Package (see page 576)

+ Creating a Larger CP (see page 577)

+ Setting Up Library Paths via Script (see page 578)
+ The First Run (see page 580)

+ Obtaining Libatomic (see page 581)

+ Installing Libatomic (see page 582)

« Another Test Run (see page 583)

+ Providing Libffmpeg (see page 584)

« Chromium Starts Successfully (see page 585)

+ Packaging the Custom Application (see page 586)
« Advanced (see page 587)
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Development Environment

For this section you need

a system with IGEL OS version 10.03.100 or newer,
a Windows or Linux workstation with Universal Management Suite (UMS) in version 5.07.100 or
newer,

a Debian or Ubuntu Linux workstation for unpacking the *.deb package (can be the same as the

Linux workstation hosting UMS),

a method to exchange files between the thin client and the workstation.

While a USB pen or disk drive would do the trick, it is more convenient to have either a
+ Windows fileshare or
« an NFS export

that you can access both from the thin client and the workstation in order to exchange files.
Learn how to mount network drives in the IGEL OS Manual.**

54 http://edocs.igel.com/11105.htm
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Getting the Ubuntu Package

As the Chromium web browser is Free Software it can be found in the package repositories of Linux distributions. To
build Custom Partitions, use the software packages from exactly that Ubuntu version on which your version of IGEL
0S is based. From IGEL OS 10.04 up to IGEL OS 11.03, this is Ubuntu 16.04 (Xenial Xerus). You need packages for the

amd64 (also known as x86_64 ) architecture.
This is how to find the right package and download it to your Linux workstation:

1. Inaweb browser,goto https://packages.ubuntu.com
2. Use the Search package directories form to search

a. Set Keywordto chromium

b. SetDistributionto xenial

c. Click Search.

Search

Search package directories

Keyword: | chromium Search || Resst

Search on: '® Package names only Descriptions Source package names

Cnly show exact matches:
Distribution: | xenial ¥ | Section: | any v

3. Ontheresults page, click the chromium-browser package to go to its details page.
4. Atthe bottom of the details page, click the amd64 link to download the package to a local
directory on your Linux workstation.
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Unpacking the Ubuntu Package
Extract the Ubuntu package on your Debian/Ubuntu Linux workstation in order to access its files:

1. Open aterminal emulator.
2. Change to the directory where you saved the Ubuntu package.
3. Create a directory to extract the files to:

mkdir chromium-browser

4. Extract the package to the new directory:
dpkg -x *.deb chromium-browser/

5. Run the following command to see how much space the package contents need in total (in MB):
du -cms chromium-browser/*

The total is 255 MB (your package may differ slightly). To be on the safe side let's memorize that we
need approximately 400 MB of space for the CP contents.
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Creating a Larger CP
Create a larger Custom Partiton so we can put all the Chromium package files into it.

1. Onthe thin client, make sure that you have closed all Local Terminal windows.

In UMS Console, navigate to your target thin client.

In Assigned Objects, remove the Hello CP profile from this thin client.

When prompted When should these changes take effect? select Now.

The existing Custom Partition is deleted.

Right-click the thin client and select Edit Configuration.

In Setup go to System > Firmware Customization > Custom Partition > Partition.
Check Enable Partition.

Set the Sizeto 400M (Megabyte) to be on the safe side.

Call S

o © N w;

Leave the Mount Point at /custom

10. Click Save.
The new Custom Partition is created.

11. Onthethin client, open a Local Terminal and loginas root
12. Change into the Custom Partition: cd /custom

13. Check the size of the Custom partition: df -h ./

It should be roughly 400M - if it is still roughly 10M, close Local Terminal and use Setup to first
disable and then re-create the Custom Partition again.

14. Copythe complete chromium-browser/ directory with all its contents from the Debian/
Ubuntu machine into the Custom Partition on the thin client.
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Setting Up Library Paths via Script

With the whole package contents in place, you need to make sure that Chromium will be able to find its libraries
and other needed files. There is a pre-fabricated script for this.

1. Loginto Local Terminalas root .

2. Changeintothe /custom/chromium-browser directory.

3. Enterthecommand 1s -1.

4. You will see that instead of a single script as in the previous example there are the etc/ and
usr/ directories. They include many libraries and other files that Chromium will need to run.
However, it expects these directories not within the /custom/chromium-browser/

directory, but in the filesystem root, where system directories suchas /usr are located. The
Initialization Script for the Custom Partition will fix this by setting up symbolic links, so that for
example /custom/chromium-browser/usr/lib/library.so willappeartobein /

usr/lib/library.so ,where Chromium expects it.
5. Use the GNU nano editor to create the file custompart-chromium-browser and putthe
following contents into it - alternatively, edit the file elsewhere and copy itinto /custom/

chromium-browser/ :

#!/bin/sh
ACTION="custompart-chromium-browser_${1}"
# mount point path
MP=$(get custom_partition.mountpoint)
# custom partition path
CP="${MP}/chromium-browser"
# output to systemlog with ID amd tag
LOGGER="1logger -it ${ACTION}"
echo "Starting" | $LOGGER
case "$1" in
init)
# Initial permissions
chown -R root:root "${CP}" | $LOGGER
chmod 755 "${MP}" | $LOGGER
# Linking files and folders on proper path
find "${CP}" | while read LINE
do
DEST=$(echo -n "${LINE}" | sed -e "s|${CP}||g")
if [ ! -z "${DEST}" -a ! -e "${DEST}" ]; then
# Remove the last slash, if it is a dir
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e

IGE

[ -d SLINE ] && DEST=$(echo "${DEST}" | sed -e "s/\/
$//9") | $LOGGER
if [ ! -z "${DEST}" ], then
1n -sv "${LINE}" "${DEST}" | $LOGGER

fi
fi
done
ldconfig
stop)
killall -q -SIGTERM chromium-browser
sleep 1

killall -g -SIGKILL chromium-browser
i
esac
echo "Finished" | $LOGGER
exit 0

@ Usethis as a script template for your Custom Partitions, replacing all instances of
chromium-browser with the directory name of your CP.

6. Make the script executable with the following command:
chmod a+x custompart-chromium-browser

7. Runthe script:
./custompart-chromium-browser 1init

It should run and finish without any errors.
The library paths are set up now.
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The First Run

Now that the paths for the complete Chromium package contents have been set up, try running the program for the
first time:

1. Loginto Local Terminalas root .

2. Changeintothe /custom/chromium-browser/ directory.

3. The usr/bin/ and usr/1lib/ directories are good candidates for Chromium's main
executable. Try to run the following command:
.Jusr/lib/chromium-browser/chromium-browser
You will see the following error message:
/Jusr/lib/chromium-browser/chromium-browser: error while loading
shared libraries:
libatomic.so.1l: cannot open shared object file: No such file or
directory

This tells you that the program tries to load the shared library libatomic.so.1,butcan'tfind
it.
You will need to obtain libatomic.so.1l andinstallit.
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Obtaining Libatomic

The source for Libatomic will be Ubuntu Package Search again:

1. Inaweb browser,goto https://packages.ubuntu.com
2. This time use the Search the contents of packages form to search.
a. SetKeywordto libatomic.so.1l
. Select packages that contain files named like this.
. Set Distributionto xenial

b
C
d. SetArchitectureto amdé64
e

. Click Search.
Keyﬂ.l.rnrd:|libatc:mic.sc.1| Search | Reset |
Display:

@ packages that contain files named like this
O packages that contain files whose names end with the keyword

O packages that contain files whose names contain the keyword

Distribution: xenial |v|ﬂ.rchitecture: amdad |v|

3. This time the results page lists a lot of packages. But with the background knowledge that IGEL OS
libraries are located in /usr/1lib/x86_64-1linux-gnu/ you will find that libatomic1 is the
desired package. Download it to a local directory on your Linux workstation.

Jusrflib/gcc-snapshot/libx32/libatomic.so. goc-snapshot
usrflib/x86_64-linux-gnu/libatomic.so.1 libatomic1
Jusrflib32/libatomic.so.1 lib32atomict
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Installing Libatomic
This step installs Libatomic and sets up a symbolic link so the Chromium will find it.

1. Extract the package contents with this command:

dpkg —-x libatomic*.deb libatomic
2. Change into the extracted contents:

cd libatomicl/usr/1lib/x86_64-linux-gnu/
3. Listits contentsin longform: 1s -1

lrwxrwxrwx 1 huber huber 18 Nov 3 2816 -» libatomic.so0.1.1.8
-mw-r--r-- 1 huber huber 26760 Nov 3 2016 libatomic.so.1.1.8

This shows you that the library file is actually named 1libatomic.so.1.1.0 andthat
libatomic.so.1l isasymboliclinktoit. We will recreate the link on the thin client later.
4. Transferthe libatomic.so.1.1.0 fileto thethinclientand placeitin:
/custom/chromium-browser/usr/lib/chromium-browser/
5. Change into the directory:
cd /custom/chromium-browser/usr/lib/chromium-browser/
6. Create the symbolic link:

ln -s libatomic.so0.1.1.0 libatomic.so.1l
Now Libatomic is set up to be used by Chromium.
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Another Test Run
Test whether Chromium now has everything it needs to run.

1. Change into the Custom Partition directory on the thin client:
cd /custom/chromium-browser

2. Run Chromium:
.Jusr/1lib/chromium-browser/chromium-browser

3. You will see this error message:
/Jusr/lib/chromium-browser/chromium-browser: error while loading

shared libraries:

libffmpeg.so: cannot open shared object file: No such file or
directory

It seems Libatomic is no longer a problem, but now Chromium needs a further library:
libffmpeg.so
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Providing Libffmpeg

To obtain Libffmpeg, repeat the process for obtaining Libatomic (see page 581). Hint: The Ubuntu package is named
chromium-codecs-ffmpeg . It contains thefile 1ibffmpeg.so ,which you need to transfer to the thin

client. Placeitin /custom/chromium-browser/usr/1lib/chromium-browser/.

(@ Thisisaprocedure that you need to repeat until you have supplied all required libraries:
« Run the application from the commandline.
+ Scan the error message for needed libraries.

Obtain and install the required libraries.

Run the application from the commandline.
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Chromium Starts Successfully

Now you are ready to give running Chromium another try. It does not like to be started by root , becauseitis

much safer to run it as the non-privileged user .

1. Loginto Local Terminalas user .

2. Changeintothe /custom/chromium-browser directory.

3. Enter the following command:

./usr/1lib/chromium-browser/chromium-browser
Chromium starts for the first time. Congratulations, you now have working Chromium installation.
Welcome to Chromium - Chromium

/ [ welcome to Chromi x \
| / \

C | & Chromium | chrome://welcome wl o

Welcome to Chromium

Sign in to Chrome with your Google Account to get your

bookmarks, history, passwords, and other settings on

Mo thanks

all your devices.

The next step will package the Custom Partition so it can be deployed to any number of thin clients from UMS:
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Packaging the Custom Application

Now that the hardest part of creating the Custom Partition is done, package the CP for UMS. You are already
familiar with most of the steps from earlier in this tutorial.

Compress the CP Contents (see page 559) into chromium-browser.tar.bz2
Upload the compressed file to UMS as a new File.

Write the *.inf Metadata File (see page 560) with 400M as size.

Upload the *.inf Metadata File to UMS as a new File.
Create a Profile for the CP (see page 566) with the Initializing Action set to:

ok W

/custom/chromium-browser/custompart-chromium-browser 1init
and the Finalizing Action set to:
/custom/chromium-browser/custompart-chromium-browser stop
6. Create a Custom Application (see page 552) with the Command set to:
/custom/chromium-browser /usr/lib/chromium-browser/chromium-browser
7. Assign the CP to a new thin client in order to test everything.

IGEL OS Articles 586 /823



Customizing

Advanced

Here are some advanced topics for you to try after you have completed this tutorial.

Using ldd to Find Required Libraries

Using the 1dd command is another way of determining the libraries that a binary requires.

1.
2.

3.

Loginto Local Terminalas root .
Find out which file the main binary of the Custom Partition is. It is usually found in bin/, usr/

bin/ or usr/lib/ andisnamed similar to the application name.
Run the following command:
ldd /custom/[name]/[binary] | grep 'not found'

This command line contains a filter, so that it will only show you those libraries that could not be

found.
Local Terminal - A X

root@GEORGE : /# 1dd /custom/chromium-browser/usr/lib/chromium-browser/chromium-browser
| grep 'not found'

libatomic.so.l == not found

libffmpeg.so == not found

libffmpeg.so == not found

libffmpeg.so == not found
root@GEORGE : /# ||

-~

Auto-updating Custom Partitions

The Custom Partition mechanism in IGEL OS can update the Custom Partition contents automatically when a newer
version is available on UMS. To activate it, follow these steps:

1.

o Lk wN

In Setup, go to System > Firmware Customization > Custom Partitition > Download.
Open the CP entry in the Partitions Data Sources list.

Enable Automatic Update.

Click OK.

Click Apply or Save in the Setup window.

On UMS, increase the version propertyinthe x.inf metadatafile.

When booting, the thin client checks whether there is a higher version of the Custom Partition
available on UMS. If so, the new CP version will be downloaded automatically.
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Zoom as a Custom Partition

Now that you have learned the IGEL Custom Partition fundamentals, build on top of these and try your hand at a
real-world Custom Partition: Zoom.

Read all the following chapters in the order given and follow the instructions.

=

Development Environment (see page 589)

Getting the Packages (see page 590)

Unpacking the Packages (see page 591)

Creating the Initialization Script (see page 592)

Compressing the Custom Partition Contents (see page 595)
Writing the *.inf Metadata File (see page 596)

Uploading the Files to the UMS (see page 597)

Creating a Profile for the Custom Partition (see page 600)
Assigning the Profile and Testing the Application (see page 607)

RNk WwN
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Development Environment
For this section, you need

+ asystem with IGEL OS 11.01.100 or newer,
Universal Management Suite (UMS) 6.01.100 or newer,

a Debian or Ubuntu workstation for unpacking the *.deb package (can be the same as the Linux

workstation hosting the UMS. Ideally, the machine is running Ubuntu 18.04 LTS.
a method to exchange files between the endpoint device and the workstation.
While a USB memory stick or disk drive would do the trick, it is more convenient to have either a
+ Windows fileshare or
« an NFS export
that you can access both from the endpoint device and the workstation in order to exchange files.
Learn how to mount network drives in the IGEL OS Manual.

Next Step

>> Getting the Packages (see page 590)
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Getting the Packages

Get the required packages for Ubuntu. Apart from the Zoom package, you need the package libxcb-
xtestO[version].deb (containsthe shared libraries 1ibxcb-test.so0.0 and libxcb-

test.so0.0.0.0 whicharerequired by the Zoom package).

1. Open https://zoom.us/download?os=linux in a browser and select the following:
+ Linux Type: "Ubuntu"
+ OS Architecture: "64 bit"
+ Version: "16.04+"

2. Download the Ubuntu/Debian package zoom_amdé64.deb
() Version 5.0.399860.0429 has been tested by IGEL. Newer versions should work, too.

3. Change to the download directory on your workstation (typically /home/[username]/
Downloads ).
4. Download libxcb-xtest@[version].deb with the following command:

apt download libxcbh-xtest®

Next Step

>> Unpacking the Packages (see page 591)
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Unpacking the Packages
In this step, you extract the Ubuntu packages on your Linux workstation in order to access their files:

1. Open aterminal.
2. Change to the directory where you saved the packages.
3. Create a directory to extract the files to:

mkdir zoom
4. Extract the packages to the new directory:
dpkg -x zoomx.deb zoom/
dpkg —-x libx*.deb zoom/
5. Run the following command to see how much space the package contents need in total (in MB):
du -cms zoom/=*

The total is 151 MB (your package may differ slightly). To be on the safe side, let's memorize that
we need approximately 500 MB of storage space for the Custom Partition contents.

Next Step

>> Creating the Initialization Script (see page 592)
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Creating the Initialization Script

In this step, you will create an initialization script that enables the application to work inside a Custom Partition. In
aregular installation, the files of the Zoom application would be located in /usr, /opt andsoon,whereasin

the Custom Partition, they are located under /custom/zoom/usr, /custom/zoom/opt andsoon.
The initialization script will fix this by creating symbolic links so that for example /custom/zoom/usr/lib/

library.so willappeartobein /usr/1lib/library.so ,where Zoom expects it.

1. Onyour workstation, go to the directory where the zoom directory is located.
2. Open your text editor of choice and enter the following script:

#!/bin/sh
ACTION="custompart-zoom_${11}"

# mount point path
MP=$ (get custom_partition.mountpoint)

# custom partition path
CP="${MP}/zoom"

# wfs for persistent login and history
WFS="/wfs/user/.zoom/data"

# .zoom directory
Z00M="/userhome/.zoom/"

# output to systemlog with ID amd tag
LOGGER="1ogger -it ${ACTION}"

echo "Starting" | $LOGGER

case "$1" 1n
init)
# Linking files and folders on proper path
find ${CP} | while read LINE
do
DEST=$(echo -n "${LINE}" | sed -e "s|S${CP}||g")
if [ ! -z "${DEST}" -a ! -e "S${DEST}" ]; then
# Remove the last slash, if it is a dir
[ -d SLINE ] && DEST=$(echo "${DEST}" | sed -e "s/\/$//
g") | $LOGGER
if [ ! -z "${DEST}" ]; then
1n -sv "${LINE}" "${DEST}" | S$SLOGGER
fi
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fi
done

# Linking /userhome/.zoom/data to /wfs/user/.zoom/data for some basic
persistency
mkdir -p ${WFS}
chown -R user:users ${WFS}
mkdir -p ${ZOOM}/data
chown -R user:users ${ZOOM}/data
mkdir -p ${ZOOM}/data/VirtualBkgnd_Custom
chown -R user:users ${ZOOM}/data/VirtualBkgnd_Custom
mkdir -p ${ZOOM}/data/VirtualBkgnd_Default
chown -R user:users ${ZOOM}/data/VirtualBkgnd_Default

1n -sv ${WFS}/zoomus.db ${ZOOM}/data/zoomus.db | $LOGGER

1n -sv ${WFS}/zoommeeting.db ${ZOOM}/data/zoommeeting.db | $LOGGER
In -sv ${WFS}/VirtualBkgnd_Custom ${ZOOM}/data/ | S$LOGGER

1n -sv ${WFS}/VirtualBkgnd_Default ${ZOOM}/data/ | $LOGGER

chown user:users /wfs/user/.zoom
1n -sv /wfs/user/.zoom/zoomus.conf /userhome/.config/zoomus.conf |
$LOGGER

# remove all com.zoom.ipc*x files from /wfs/user/.zoom/data - might
cause ‘issues when updating zoom
rm ${WFS}/com.zoom.ipcx

# add /opt/zoom to ld_library
echo "${CP}/opt/zoom" > /etc/ld.so.conf.d/zoom.conf
ldconfig

${MP}/zoom_postinst | $LOGGER

55
stop)
# unlink linked files
find ${CP} | while read LINE
do
DEST=$(echo -n "${LINE}" | sed -e "s|S${CP}||g")
unlink $DEST | $LOGGER
done

# remove zoom.conf because it is not needed anymore
rm /etc/ld.so.conf.d/zoom.conf

i

esac

echo "Finished" | $LOGGER
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exit O

@ The codeline echo "${CP}/opt/zoom" > /etc/ld.so.conf.d/zoom.conf tellsthe
Zoom application via the configuration file zoom.conf to search for librariesin /custom/

opt/zoom . Thisis expected by the Zoom application.

3. Savethefileas custompart-zoom

Next Step

>> Compressing the Custom Partition Contents (see page 595)
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Compressing the Custom Partition Contents
To make the unpackaged software package usable in a Custom Partition, make the application files executable and
put them into a compressed tar file.
1. Onyour Linux workstation, open a terminal and change to the directory that contains the zoom/
directory with the application files and the initialization script custompart-zoom.
2. Make thefilesin zoom/ and theinitialization script executable:
chmod -R +x zoom
chmod +x custompart-zoom
3. Compressthe zoom/ directory and the initialization script into an archive file named
zoom_[version].tar.bz2 (inourexample: zoom_5.0.399860.0429.tar.bz2 ):

tar cjvf zoom_5.0.399860.0429.tar.bz2 zoom custompart-zoom

Next Step

>> Writing the *.inf Metadata File (see page 596)
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Writing the *.inf Metadata File

In addition to the compressed archive that you created in the previous step, a plain text file with essential
information for the endpoint device is necessary. In this, step you will create the zoom.inf file.

1. Change to the directory that contains the compressed contents of our Custom Partition.
2. Create anew filenamed zoom.inf and putthe following into it:

[INFO]
[PART]
file="zoom_5.0.399860.0429.tar.bz2"

version="5.0.399860.0429_igell"
size="500M"

name="zoom"

minfw="11.01.100"

() Foran explanation of the settings, see the corresponding page in the section about building a
simple Custom Partition: Writing the *.inf Metadata File (see page 560).

Next Step
>> Uploading the Files to the UMS (see page 597)
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Uploading the Files to the UMS

In this step, you upload the compressed zoom_[version].tar.bz2 archiveandthe zoom_[version] .1

nf metadata file to the UMS, which will serve them to other devices via HTTPS. To make the file available, you have
to create a file object after transferring the physical file.

Transferring the Files to the UMS

1. Make sure that the Zoom files can be accessed from the machine that hosts the UMS Console.
2. In the structure tree of the UMS Console, go to Files and select New file in the context menu.

2 to IGEL 05 11

Eenarme

control

. client-ce
. clie

. clie

B helo.

. hello tar hz2
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IGEL

3. Click | next to the Local file field, select zoom_[version].tar.bz2 onyourlocal
machine, and click Open.

Open

Look |n: Tutarial

File Mame: Zoom_5.0. B0.0429 tar bz2

ype:  AllFiles

COpen Cancel

4. Click - next to the Target URL to define the file path on the UMS Server.
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5. Review the file name at Local file and click Ok.
MNew file

File source

® Upload local file to L

Lacal file W OHSDe s ktapllh stam PartitionsiTutorializoom_5

no=ums_

File location (LIRL)

File target

Undefined

Access rights

Read Write

owRer <

Others

e

6. Repeatsteps1to5for zoom_[version].inf

Next Step

>> Creating a Profile for the Custom Partition (see page 600)
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Creating a Profile for the Custom Partition

After you have uploaded the Custom Partition files to the UMS, you can now make the settings that will install the
Custom Partition on any number of devices. For this purpose, you create a profile.

Activating the Custom Partition

1. Inthe structure tree of the UMS Console, right-click the Profiles folder and select New Profile
from the context menu.

2. Inthe New Profile dialog, enter a Profile Name, e. g. "Zoom" followed by the version name, and
click Ok.

New Profile
Frofile Mame | Zoom
Diescriptian

Based on IGEL QS 11 11.01.100.01

* Expert mode

Go to System > Firmware Customization > Custom Partition > Partition.

Unlock the Enable Partition setting by clicking the orange triangle so that it turns blue.
Check Enable Partition.

Unlock the Size setting by clicking the orange triangle so that it turns blue, and enter "500M".

oA W
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7. Leave the Mount Point at "/custom".
Zoom 5.0.399860.0429

< > ~ i 5 ir zation * Customn Partition ™ Parition

Configuration €) /S Y Enable Partition

Size

Mount Point

Fartitions Parameters

MName

Search

Setting the Download Source

£ /  500m

send to device

For this step, you need to determine the HTTPS download address for the zoom.inf filefirst.

1. Tofind out the IP address of your UMS, go to System > Remote Management in the configuration
dialog. You will find the UMS Server your device is registered with and its IP address.

2. Open a web browser and visit the following URL:

https://[IP or name of your UMS host]:8443/ums_filetransfer

3. When prompted, authenticate with your UMS username and password.
You will see a directory listing of the files that can be downloaded from the UMS.
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4. Right-click the zoom_[version].inf entry and select Copy link address (or the like, depending on
your browser).

Last Modified

15:16:26 GMT

Filename

£01813.3pg Fri, 2% Nov

chromium-browser 64.0.3282.167.inf 0.1 kb Tue, 10 Mar 2020 15:35:45 GMT
chromium-prowser 64.0.3252.167.tar.bzd 839553.5 kb Tue=, 10 Mar 2020 15:34:09 GMT
client-cert.pem 0.6 kb Thu, 12 Dec 2015 12:21:12 GMT
client-kev.pem 0.2 kb Thu, 12 Dec 2 :28:06 GMT
clientca-cert.pem 0.6 kb Thu, 12 Dec 2018 11:47:20 GMT
hello.in 0.1 k& Mon, 11 May 2020 12:24:086 GMT
hello.tar.bz2 0.2 kb Mon, 11 May 2020 12:17:42 GMT
:SEL_CE_ll—ll‘GS.llﬁf Wed, 11 Mar 42:20 GMT
IGEL Universal Desktop IX-10.05.500/ Fri, 15 Mar 2019 13:55:11 GMT
LGEL Uniwversal Desktop ©5 3-10.0 Mon, 18 Mar 07
IGEL Universal Desktop OS5 _3-10.06.130 Thu, 30 Jan 2020 16:09:01 GMT
installer-2.01.100.rc2.bin 38964.0 :02 GMT
journalctl . tXt 21E.8 kb Fri, 20 Mar 2020 15:29:32 GMT
1x_10.05. 8.0 kb Fri, 05 Epr 2019 14:15:46 GMT
osc.iso .0 kb Wed, 29 AZpr 2020 14:06:05 GMT
p-20180712 .pem a. Thu, 12 Dec 2 144:08 GMT
SecureboardRootCA. DEM 0.7 kb Thu, 12 Dec 2019 11:40:35 GMI
supportinfo/ Wed, 03 Rpr 27 GMT
tc_files for support OOEOCS36327EE.zip 133.7 kb Wed, 29 Apr 2020 09:48:15 GMT
Thu, 12 Dec » GMT
0.2 kb Thu, 12 Dec 2019 11:33:20 GMT

0.6 ko

Thu, 12 Dec 20195 16:30:59 GMT

526E67.5 kb Thu, 14 May 2020 11:40:32 GMT
0.1 ko Thu, 14 May 2020 11:42:20 GMT
P
zocm 5.0.3398: 526E67.5 kb Thu, 14 May 2020 12:55:31 GMT

Open link in new window

Open link in incognito window
[Apache Tomcat/8]

Save link as...

Inspect Ctrl+Shift+

5. Back in the profile, go to System > Firmware Customization > Custom Partition > Download.
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6. Next to Partitions Data Sources, click [+].
Zoom 5.0.399860.0429

> Fas P m i Customization ® Custom Parition  ® Do

Configuration Partiions Data Sourc

Autornati

Search

The Add dialog opens.
7. Edit the settings as follows:
+ URL: Paste the URL you copied from the browser.
+ User name: Username for accessing the UMS
« Password: Password for the username
« Initial action: Enter "/custom/custompart-zoom init".
Final action: Enter "/custom/custompart-zoom stop".

Initial action

Final action

8. Click OK.
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Configuring the Custom Application

To create a convenient starting method for the user, create a custom application that includes a starter icon on the
desktop.

1. Go to System > Firmware Customization > Custom Application.

2. In the Custom Applications list, click T+ to add an application.
IGEL Setup 11.03.500.01 (Build 6.4.2

em P Firmware C zation tom Application

Custom Applications

Session name

B Time and Date
» [l Upd
» Il Remo

Search

The Desktop Integration page opens.
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3. Enter "Zoom" as the Session name.
Zoom 5.0.399860.0429

> A

Configuration

enu

n Launcher

Menu folder

tion Launch

Mane

Search % Antnstart

4. Go to Settings.
5. Edit the settings as follows:
+ Icon name: Enter "/usr/share/pixmaps/Zoom.png".
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« Command: Enter "zoom".
Zoom 5.0.399860.0429

> ~ i

Configuration lcon name 8N

Comrmand ) S zoom

Time and Date

Search

6. Click Save.

Next Step

>> Assigning the Profile and Testing the Application (see page 607)
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Assigning the Profile and Testing the Application

Now that you have put all the settings for installing the Custom Partition on a device into a profile, it is time to
assign the profile.

1. Inthe UMS structure tree, drag and drop the icon of your profile onto the icon of a device.

Scheduled firmware upgrade to IGEL 05 11

k& Template k 1 Groups (1)

Firrm mizations {0

L J |E.' E'E!'

L [Tcone

g lrmpaort (0)

The Update time dialog opens.
2. Select Now and click Ok.

Update time

hould these changes take effect?

ehoot (and dan't ¢ = dialog againg

The device receives the settings of the profile, creates the Custom Partition, downloads the
contents of the Custom Partition, and uncompresses them.
On the desktop of the endpoint device, the Zoom icon should appear:

Zoom

3. Click on the Zoom icon to test the Zoom application.
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Microsoft Teams as a Custom Partition

Now that you have learned the IGEL Custom Partition fundamentals, build on top of these and try your hand at a
real-world Custom Partition: Microsoft Teams.

If you want to get an impression of how Microsoft Teams works on IGEL OS, watch this video:

Sorry, the widget is not supported in this export.
But you can reach it using the following URL:

https://m.youtube.com/watch?v=3X0IKKu5eZY

Read all the following chapters in the order given and follow the instructions.

=

Development Environment (see page 609)

Getting the Package (see page 610)

Unpacking the Packages (see page 611)

Creating the Initialization Script (see page 612)

Compressing the Custom Partition Contents+1 (see page 614)
Writing the *.inf Metadata File 1 (see page 615)

Uploading the Files to the UMS (see page 616)

Creating a Profile for the Custom Partition (see page 619)
Assigning the Profile and Testing the Application (see page 625)

RN WN
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Development Environment
For this section, you need

+ asystem with IGEL OS 11.01.100 or newer,
Universal Management Suite (UMS) 6.01.100 or newer,

a Debian or Ubuntu workstation for unpacking the *.deb package (can be the same as the Linux

workstation hosting the UMS). Ideally, the machine is running Ubuntu 18.04 LTS.
a method to exchange files between the endpoint device and the workstation.
While a USB memory stick or disk drive would do the trick, it is more convenient to have either a
+ Windows fileshare or
« an NFS export
that you can access both from the endpoint device and the workstation in order to exchange files.
Learn how to mount network drives in the IGEL OS Manual.

Next Step

>> Getting the Package (see page 610)
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Getting the Package
Get the required package for Ubuntu.
1. Open https://www.microsoft.com/en-us/microsoft-365/microsoft-teams/download-
app#allDevicesSection in a browser and click Linux DEB (64-bit).

(@ When you open the URL from a Windows machine, the Linux download button will probably not
appear.

2. Download the package teams_[version]_amd64.deb (example:
teams_1.3.00.5153_amd64.deb)
3. Change to the download directory on your workstation (typically /home/[username]/

Downloads ).

Next Step

>> Unpacking the Package (see page 611)
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Unpacking the Packages
In this step, you extract the packages on your Linux workstation in order to access their files:
1. Open aterminal.

2. Change to the directory where you saved the packages.
3. Create a directory to extract the files to:

mkdir teams

4. Extract the packages to the new directory:
dpkg -x teams*.deb teams/

5. Run the following command to see how much space the package contents need in total (in MB):
du -cms teams/x*

The total is 237 MB (your package may differ slightly). To be on the safe side, let's memorize that
we need approximately 500 MB of storage space for the Custom Partition contents.

Next Step

>> Creating the Initialization Script (see page 612)
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Creating the Initialization Script

In this step, you will create an initialization script that enables the application to work inside a Custom Partition. In
aregular installation, the files of the Teams application would be located in /usr , whereasin the Custom

Partition, they are located under /custom/teams/usr . Theinitialization script will fix this by creating symbolic
links so that for example /custom/teams/usr/share/libffmpeg.so willappeartobein /usr/share/

libffmpeg.so , where Teams expects it.

1. Onyour workstation, go to the directory where the teams directory is located.
2. Open your text editor of choice and enter the following script:

#!/bin/sh
ACTION="custompart-teams_s${1}"

# mount point path
MP=$ (get custom_partition.mountpoint)

# custom partition path
CP="${MP}/teams"

# only needed if application has an executable
BIN="/usr/bin/teams"

# output to systemlog with ID amd tag
LOGGER="1ogger -it ${ACTION}"

echo "Starting" | $LOGGER

case "$1" 1n
init)
# Linking files and folders on proper path
find ${CP} | while read LINE
do
DEST=$(echo -n "${LINE}" | sed -e "s|S${CP}||g")
if [ ! -z "${DEST}" -a ! -e "S${DEST}" ]; then
# Remove the last slash, if it is a dir
[ -d SLINE ] && DEST=$(echo "${DEST}" | sed -e "s/\/$//
g") | $LOGGER
if [ ! -z "${DEST}" ]; then
1n -sv "${LINE}" "${DEST}" | S$SLOGGER
fi
fi
done
i

stop)

IGEL OS Articles 612 /823



Customizing sl'
IGEL
# unlink linked files
find ${CP} | while read LINE
do
DEST=$(echo -n "${LINE}" | sed -e "s|S${CP}||g")
unlink $DEST | $LOGGER
done
55
esac

echo "Finished" | $LOGGER
exit O

3. Savethefileas custompart-teams

Next Step

>> Compressing the Custom Partition Contents (see page 614)

IGEL OS Articles 613 /823



Customizing

Compressing the Custom Partition Contents

To make the unpackaged software package usable in a Custom Partition, make the application files executable and
put them into a compressed tar file.

1. Onyour Linux workstation, open a terminal and change to the directory that contains the
teams/ directory with the application files and the initialization script custompart-teams
2. Makethefilesin teams/ and the initialization script executable:
chmod -R +x teams
chmod +x custompart-teams
3. Compressthe teams/ directory and the initialization script into an archive file named
teams_[version].tar.bz2 (inourexample: teams_1.3.00.5153.tar.bz2):

tar cjvf teams_1.3.00.5153.tar.bz2 teams custompart-teams

Next Step

>> Writing the *.inf Metadata File (see page 615)
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Writing the *.inf Metadata File

In addition to the compressed archive that you created in the previous step, a plain text file with essential
information for the endpoint device is necessary. In this, step you will create the teams.inf file.

1. Change to the directory that contains the compressed contents of our Custom Partition.
2. Create anew filenamed teams.inf and putthe followinginto it:

[INFO]

[PART]
file="teams_1.3.00.5153.tar.bz2"
version="1.3.00.5153_1igell"
size="500M"

name="teams"

minfw="11.01.100"

() Foran explanation of the settings, see the corresponding page in the section about building a
simple Custom Partition: Writing the *.inf Metadata File (see page 560).

Next Step
>> Uploading the Files to the UMS (see page 616)
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Uploading the Files to the UMS

In this step, you upload the compressed teams_[version].tar.bz2 archiveandthe teams_[version]

inf metadata file to the UMS, which will serve them to other devices via HTTPS. To make the file available, you
have to create a file object after transferring the physical file.

Transferring the Files to the UMS

1. Make sure that the Teams files can be accessed from the machine that hosts the UMS Console.
2. In the structure tree of the UMS Console, go to Files and select New file in the context menu.

2 to IGEL 05 11

Eenarme

control

. client-ce
. clie

. clie

B helo.

. hello tar hz2
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3. Click | next to the Local file field, select teams_[version].tar.bz2 onyourlocal
machine, and click Open.

Open

Look |n: Tutarial

COpen Cancel

4. Click - next to the Target URL to define the file path on the UMS Server.
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5. Review the file name at Local file and click Ok.
MNew file

File source

& Upload lacal file to L

Laocal file

File location (LIRL)

File target

Undefined

Access rights

Read Write

owRer v

Others

e

6. Repeatstepslto5for teams_[version].inf

Next Step

>> Creating a Profile for the Custom Partition (see page 619)

IGEL OS Articles 618 /823



Customizing

Creating a Profile for the Custom Partition

After you have uploaded the Custom Partition files to the UMS, you can now make the settings that will install the
Custom Partition on any number of devices. For this purpose, you create a profile.

Activating the Custom Partition

1.

2.

oA W

In the structure tree of the UMS Console, right-click the Profiles folder and select New Profile
from the context menu.

In the New Profile dialog, enter a Profile Name, e. g. "Teams" followed by the version name, and
click Ok.

New Profile
Frofile Marme
Diescriptian

Based on IGEL 25 11 11.04.100.

» Expert mode

Go to System > Firmware Customization > Custom Partition > Partition.

Unlock the Enable Partition setting by clicking the orange triangle so that it turns blue.
Check Enable Partition.

Unlock the Size setting by clicking the orange triangle so that it turns blue, and enter "500M".
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7. Leave the Mount Point at "/custom".
Teams 1.3.00.5153

* Parlition

4 > A e m irm ‘ustomization ™ Custom Parition

This feature requires an active Enterprise Management Pack subscription.

Configuration
€ ./ V Enable Pattition

Size

Maount Paoint

Fartitior

Mame

Search

Setting the Download Source

For this step, you need to determine the HTTPS download address for the teams.inf file first.

Cancel

1. Tofind out the IP address of your UMS, go to System > Remote Management in the configuration
dialog. You will find the UMS Server your device is registered with and its IP address.

2. Open a web browser and visit the following URL:

https://[IP or name of your UMS host]:8443/ums_filetransfer

3. When prompted, authenticate with your UMS username and password.
You will see a directory listing of the files that can be downloaded from the UMS.
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4. Right-click the teams_[version].inf entry and select Copy link address (or the like, depending on
your browser).

= O *

@ Directory Listing For [/] X +

& C A Notsecure | 172.30.92.9:8443/ums_filetransfer hd e

Directory Listing For [/]

Filename Size Last Modified
ovepn test.ovpn 3.6 kb Tue, 26 May 2020 14:34:07 GMT
supportinfo/ Tue, 26 May 2020 14:17:34 GMT

0.1 kb Fri, 12 Jun 2020 10:03:40 GMT

" Open link in new tab
team: 795929.4 kb Wed, 10 Jun 2020 10:31:14 GMT
Open link in new window
Leam: Open link in incognito window 34073.% kb Fri, 12 Jun 2020 10:03:10 GMT
apache [N Gt L
Copy link address
Inspect Ctrl+Shift+|

5. Back in the profile, go to System > Firmware Customization > Custom Partition > Download.
6. Next to Partitions Data Sources, click [+].
Teams 1.3.00.5153

omization ® Custom Parition  ® Dow)

Configuration

The Add dialog opens.
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7. Editthe settings as follows:

+ URL: Paste the URL you copied from the browser.

+ User name: Username for accessing the UMS

+ Password: Password for the username

+ Initializing action: Enter "/custom/custompart-teams init".
Finalizing action: Enter "/custom/custompart-teams stop".

Autarmatic Update
) S 23 43ums_filetransferteams.inf
ame €) /  admin

ord ) S T

Initializing Action 'ﬂ' j- fcustomicustompan-teams init

Finalizing Action ) S

8. Click OK.

Configuring the Custom Application

To create a convenient starting method for the user, create a custom application that includes a starter icon on the
desktop.

1. Go to System >Firmware Customization > Custom Application.
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2. In the Custom Applications list, click T to add an application.
IGEL Setup 11.03.500.01 (Build 6.4.2)

PN | ® System ® Firmware Customization ®™ Custom Application

Configuration Custom Applications

: Session name
Sessions

Accessories
User Interface
Network
Devices
Security
System
B Time and Date
+ [l Update
» [l Remote management
I Remote Access
B Logging
» [l Power Options
v [ Firmware Custoemization
» Il Custom Partition

I custom Application
» [ Custom Commands

B rarnneaba T

Search

Cancel

The Desktop Integration page opens.
3. Enter "Teams" as the Session name.
Teams 1.3.00.5153

> A i ® gystem ™ Fimnware Customization ™ Custom Application ™ Teams

Configuration Session Mame s Teams

Sessions
Accessories Starting Methods for Session

User Interface sV Starthenu g Start Menu's Systern tab

Metwork
s V¥ Application Launcher - Application Launcher's Systern tab

Devices

Security < V' Deskiop 3 Desktop Context Mann
Sessian will oceur in the

Ve Quick Start Panel
B Time and Date
» B Update Menu foldar
» Il Remote management
» Il Remote Access Application Launcher falder
B Remote Sysiog
» BB Fower Options Desktop folder

Passward Pratection

Hotkey

» M Custom Commands
» I Corporate Design
Search \¥ X Auitnstart

Apply and send to device Save Cancel
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4. Go to Settings.
5. Edit the settings as follows:
+ lcon name: Enter "/usr/share/pixmaps/teams.png".
+ Command: Enter "teams".
Teams 1.3.00.5153

< ) ~ ! * Firmnw ization * Cu ication ™ Teams

Configuration lcon name
[ ‘

Commanid

Search

6. Click Save.

Next Step

>> Assigning the Profile and Testing the Application (see page 625)
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Assigning the Profile and Testing the Application

Now that you have put all the settings for installing the Custom Partition on a device into a profile, it is time to
assign the profile.

1. Inthe UMS structure tree, drag and drop the icon of your profile onto the icon of a device.

nd Groups (1)

stomizations {0

erti IGEL OS5 11 (0)
[ :|;_‘ Irport (7
¥ [ Bl dowcas (10
L1 mconEDC:

The Update time dialog opens.
2. Select Now and click Ok.

Update time

hould these changes

oot (and don't 5 dialog again)

The device receives the settings of the profile, creates the Custom Partition, downloads the
contents of the Custom Partition, and uncompresses them.
On the desktop of the endpoint device, the Microsoft Teams icon should appear:

T

@

#'!
Microsoft Teams

3. Click on the Microsoft Teams icon to test the application.
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Using a Custom PKCS#11 Library

Issue

You want to use your own PKCS#11 library.

Problem

In the Setup, you cannot find how to activate a custom PKCS#11 library.

Solution

& Incaseof theinstallation of a custom PKCS#11 library, the file(s) must be placed on the endpoint device
either via UMS file transfer or Custom Partition (see page 546).

The use of the /wfs folderis NOT recommended because of its space limit.

Using with Kerberos and/or Citrix StoreFront Logon
To use a custom PKCS#11 library with Kerberos and/or Citrix StoreFront Logon:

+ In Setup, go to Security > Smartcard > Middleware.
+ Select Custom PKCS#11 module.

« Under Path to the library, enter the path to your PKCS#11 library. Example: /usr/1lib/
pkcsll/[name of the library].so

Using with VMware Horizon
To use a custom PKCS#11 library with VMware Horizon:

+ In Setup, go to System > Registry.
+ Enable theregistry key vmware.view.pkcsll.use_custom.

+ Settheregistry key vmware.view.pkcsll.custom_path tothe pathtoyour PKCS#11
library. Example: /usr/1lib/pkcsll/[name of the library].so

Using with Firefox Browser
To use a custom PKCS#11 library with the Firefox browser:

+ In Setup, go to System > Registry.
+ Enable theregistry key browserglobal.security_device.custom.enable.
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+ Settheregistry key browserglobal.security_device.custom.device_name tothe

name of your PKCS#11 library.
+ Settheregistry key browserglobal.security_device.custom. lib_path tothe path

to your PKCS#11 library. Example: /usr/lib/pkcsll/[name of the library].so
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Adding an Icon for Browsing Removable Storage

Symptom

There is no obvious way of viewing files from removable media locally on the thin client.

Problem

You want to view files from removable media locally on the thin client.

Solution
Create a custom application that opens the contents of removable media in the File Manager.

1. Go to System >Firmware Customization > Custom Application in Setup.

2. Click the star symbol to create a new Custom Application.

3. Enter a name, e.g. Removable Media, and choose desktop integration options for the application.
4

. Enter folder asthelconnameand thunar asthe Command in the Settings dialog:

4 p2 A | » System ™ Firmware Customization * Custom Application ™ Custom Application ™ Settings

Configuration Icon name ) [folder

Command 2] |thunar

Accessories
User Interface
Network
Devices
Security
System
B Time and Date
» I Update
» [l Remote management
» I Remote Access
n Remote Syslog
» [ Fower Options
¥ 3 Firmware Customization
¥ [ custom Partition
B Fartition
B Download
¥ 3 Custom Application
¥ [ custom Application
‘ Settings
B Desktop Integratid
» [ Custom Commands

5. Save the settings.
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6. Insert a removable medium such as a USB stick into the thin client.

userhome - File Manager

Remowvable Media . .
Desktop Directories Downloads

B,

vmwareview.jpg

D]

Image Viewer

7. Click the new Removable Media icon. This opens File Manager and lets you browse the contents.
Clicking a file will open it in the application configured by the MIME type handler (as of IGEL LINUX
5.06.100, see FAQ (see page 683)).
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Adding an Icon for the Image Viewer

Symptom

You want to view images locally on the thin client.

Problem

The image viewer contained in IGEL Linux as from version 5.06.100 on has no desktop icon or menu entry.

Solution
Create a custom application that opens the Image Viewer.

1. Go to System >Firmware Customization > Custom Application in Setup.
2. Click to create a new Custom Application.

3. Entera name, e.g. Image Viewer, and choose desktop integration options for the application.
4. Go to Image Viewer > Settings:

> ~ [ * System ® Firmware Customization * Custom Application ™ Image Viewer * Settings

lcon name £) |gpicview

Configuration

Sessions Command £) |gpicview
Accessories

User Interface

Metwork

Devices

Security
System

B Time and Date
» Il Update
» Il FRemote management
» Bl Remote Access
B Remote Syslog
» Il Fower Options
¥ [ Firmware Customization
» Il Custom Partition
¥ 3 custom Application
» [l Removable Media
¥ [ Image Viewer
. Settings
B Desktop Integratis
» I Custom Commands

5. Enter gpicview asboththe lcon name and the Command in the Settings dialog.
6. Save the settings.
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7. Click the newly created icon for Image Viewer.
8. The Image Viewer opens.
9. Click the Open File symbol to open a file.

Igel. PNG (789%592) 71%

Image Viewer

.

ILocal Terminal

RDP Session
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Creating a Timed Command (Cron Replacement)

You can define one or more commands which are executed at a defined time. The configuration is similar to that of
a cron job. Theimplementationin IGEL OS uses systemd to execute the command.

To define a timed command:

1. Inthe Setup, go to System > Registry > system > cron > cronjob%

2. Activate enable_cron.

3. If you want to define paths to executables in addition to the existing path environment variable,
add them under path, separated by ":".

4. Click Add Instance.
The instance "cronjob1" is created, which will be renamed to "cronjob0" when the device has
restarted.

5. Set the parameters for your timed command according to your needs:

+ command: Command to be executed. Example for testing purposes: gtkmessage -m

"Here is your cron replacement"

« day_of_month: Day of the month
Possible values:
-"1"..."31": The command is executed on the defined day. To select a list of days for
execution, enter a comma-separated list, e.g. "1,8". To enter a range of days, use a hyphen,
e.g."1-3".
-"*": The command is executed every day of the month.

+ day_of_week: Day of a week
Possible values;
-"1" ... "7": The command is executed on the defined day. "0" and "7" both mean
Sunday. To select a list of days for execution, enter a comma-separated list, e.g. "1,3". To
enter a range of days, use a hyphen, e.g. "1-3".
- """ The command is executed every day of the week.

+ hour
Possible values:
-"0"..."23": The command is executed in the defined hour. Example: "15" means 3 p.m,
plus the minutes defined under minute. To select a list of hours for execution, enter a
comma-separated list, e.g. "9,17". To enter a range of hours, use a hyphen, e.g. "9-17".
-"*": The command is executed every hour.

+ minute
Possible values:
-"0"..."59": The command is executed in the defined minute. To select a list of minutes for
execution, enter a comma-separated list, e.g. "15,45". To enter a range of minutes, use a
hyphen, e.g. "5-10".
-"*" The command is executed every minute.

« month
Possible values:
-"1"..."12"; The command is executed in the defined month. To select a list of months for
execution, enter a comma-separated list, e.g. "1,4". To enter a range of months, use a
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hyphen, e.g. "1-3".
- """ The command is executed every month.

+ user: The user under which the command is executed
Possible options:

-"root"
- "user"

+ year: Year in 4-digit format. Example: "2019". To select a list of years for execution, enter a
comma-separated list, e.g. "2019,2020". To enter a range of years, use a hyphen, e.g.
"2019-2021". If the command is to be executed each year, enter "*".

6. Click Apply or Ok.
7. Restart the device.
After the device has restarted, the command will be executed as configured.
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Customizing IGEL OS Desktop

You want to give your IGEL OS desktops a more individual look and feel. This document shows how to customize
your IGEL OS desktops using the Universal Management Suite (UMS). There are two ways to do it:

« via a firmware customization;
« via a profile.

() With afirmware customization function, you can change your desktop design much easier and quicker
than with a profile.
For an example, see Creating Your Own Wallpaper via Firmware Customization (see page 639). See also
Firmware Customizations and Create Firmware Customization in the UMS Reference Manual.

For information on customizing IGEL OS desktops via a profile, see:

« Introduction (see page 635)

+ Creating Your Own Wallpaper (see page 638)

« How to Create a Custom Bootsplash for IGEL OS Devices via the UMS (see page 642)
+ Creating Your Own Screensaver (see page 647)

+ Assigning Your Own Company Logos (see page 652)

+ Creating Your Own Taskbar (see page 654)

+ Customizing Desktop Icons (see page 655)

IGEL Tech Video

Sorry, the widget is not supported in this export.
But you can reach it using the following URL:

https://www.youtube.com/watch?v=qFQttefMIX8

IGEL OS Articles 634 /823


https://www.youtube.com/watch?v=qFQttefMlX8

Customizing

Introduction

If you want to roll out your complete corporate design changes and apply them to multiple devices, you can create
one single profile for all settings.

Before defining special profiles, you must take the following steps:

+ Uploading a Picture (see page 636)
+ Creating a Profile (see page 637)
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Uploading a Picture

Upload your image files to the UMS server, then assign them to the relevant profile and also to your devices.

You can choose between the following formats for your pictures : BMP, JPG, GIF, TIF, PNG and SVG. Ensure that
the name of your image file has no blanks, otherwise the file will not be accepted. 25 MB of free storage space are
available for your pictures.

Upload your files:

1. Click New file on the context menu of the Files directory in the tree.
2. Browse to find your image in Local file.

File source

@ Upload local file to UMS server

Local file Clzers\Picturesthootstern jpg -
Upload location (URLY | Hitps:ALalGEL LOCAL 544 3ms_filetransfer! -_—
u Zelect file fram Uk= server
File: location (URL) e
File target
Classification | Undefined v|

Thin Cliert file location | fimagess

3. Browse to select a picture directory in Upload location (URL).
Since UMS version 5 you can use as upload location only /ums-filetransfer/ and its subdirectories.
4. Enter a Thin Client file location directory for the target device.
If you enter a directory which does not yet exist, it will be created automatically. If you do not enter
a specific directory, the image will be put in the root directory.
5. Click OK.
Your image will be listed in the list of Files.
6. Assign the image to your devices by dragging and dropping them or by adding them under
Assigned objects.

() Ifyou put more than one image in the Thin Client file location directory, all images will be
alternately shown by the screensaver (see page 647), one after the other.
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Creating a Profile
You have already uploaded your image file (see page 636).

As you work with the UMS, to manage several clients, you need to create a profile to assign the new settings to your
clients.

Create a Profile to assign your settings to the clients:

1. Click New profile in the context menu of the Profiles directory in the tree.
2. Enter a Profile Name.

3. Enter a Description and choose the firmware of your thin client under Based on.

New Profile x|
Profile Mame Wallpaper
Pl A create individual hackgruund|
Inherits Settings from | o Thin Clierts E
' ' B e A configuration sample
5w CE Devices
¥ & ES Devices
¥ o LX Devices
|ﬂ IGEL-000C29091 3CF
|ﬂ IGEL-000C29500018
| g
2 IGEL-000C29E2GER S |
Bazed on lIGEL Universal Desktop CE Standard-FTC 6.02.500 ']
@ Activate no Settings
() Activate all Settings
[j Owerwrite Sessions

4, Click OK.
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Creating Your Own Wallpaper
There are two ways how to create an own wallpaper:

+ Via a Firmware Customization (see page 639)
+ Via a Profile (see page 640)

With a Firmware Customization, setting up your own wallpaper is much easier than with a profile.
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Creating Your Own Wallpaper via Firmware Customization
This is how you can create your own wallpaper using a firmware customization function in the UMS:

1. Inthe UMS; right-click on Firmware Customizations > Create New Firmware Customization.
The Firmware Customization Details dialog opens.
2. Enter a Name for your wallpaper customization.
As Use Case, select Wallpaper.
4. Select the image file for each monitor:
« Click Choose file if you have already uploaded a file in the UMS.
+ Click Upload file if you want to upload a new file.

w

() Thefile name must not contain any blank spaces or special characters such as %, §, umlauts, etc.

5. Select yourimage file and click Open.

Check the image file location and click OK.

7. Optionally, click Next to directly apply this new firmware customization to a device or folder of
devices.

8. Click Finish to save your new firmware customization.

o
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Creating Your Own Wallpaper via a Profile

You have already uploaded your wallpaper picture; see Uploading a Picture (see page 636).

1.

2.
3.

Create a profile and name it, for example, Wallpaper; see Creating a Profile (see page 637).
The Profile Configuration window opens.

Set the wallpaper server location; see below "Setting the Wallpaper Server Location".
Configure the background of the client desktop; see below "Configuring the Background".

Setting the Wallpaper Server Location

1.

NoohkwnN

Click System > Firmware Customization > Corporate Designh > Background > Custom
Wallpaper Server.
Custom Wallpaper - Server Location

Protocol A [HTTR v
Server Mame a4 172309171

Semer Path QA. fums_filetransfers

Fart 0 Ay 900

ser name ﬂ_& igel

Pasgword 12 . W

Choose HTTP as Protocol.

Enter the Server name of your UMS Server.

Enter the path of your wallpaper directory as Server path.
The standard Port should be 9080.

Set your UMS administrator User name and Password.
Click Save to save the settings.

Configuring the Background

Eall

Open the profile.

Click System > Firmware Customization > Corporate Design > Background (1st Monitor).
Activate Custom wallpaper download.

Enter under Custom wallpaper file the name of the picture you want to define as your
background image.

@ Ifyou use more than one monitor, you have to assign the background image to each one
of them manually.

Assign the profile to your devices by dragging and dropping them or by adding them
under Assigned objects.
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Checking the Results

1. Choose the device in the UMS structure tree under Devices.

2. Goto User Interface > Desktop > Background.
You will see that the wallpaper has already been assigned by the profile; you cannot set it
manually any more.
Alternatively, you can shadow your thin client and you will see the new wallpaper.

This way, you can automatically assign background images to your devices. It is very easy to maintain them
because the only thing you have to do if you want to choose another image is to change it in the profile.
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How to Create a Custom Bootsplash for IGEL OS Devices via the UMS

IGEL

This document shows how you can create a custom bootsplash for your endpoint devices using the Universal
Management Suite (UMS). There are two ways to do it:

« via a firmware customization
« via a profile

With a firmware customization function, you can create your own bootsplash much easier and quicker than with a

profile.

How to Create a Custom Bootsplash via a Firmware Customization

This is how you can create your own bootsplash using a firmware customization function in the UMS:

1. Inthe UMS, right-click on Firmware Customizations > Create New Firmware Customization.

IGEL Universal Management Suite 6

Server - [Firmware Customiz.

Profiles (18) Wallpaper
Master Profiles (2)
Template Keys and Groups (2)
Firmware Custom
Wallpaper

J Devices (2)

¥

Mobile Devices (0
Shared Workplac O Paste

Views (9)

Jobs (1) Access control
Files (5) Logging: Messages
Universal Firmwa [™ mjaw Nirartane

Caarrh Hictnrw (R

UMS Admir

JFF Create New Firmware Customization

EXpOIL Fimwadre wusionmiZauons

The Firmware Customization Details dialog opens.

2. Enter a Name for your bootsplash customization.
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3. As Use case, select Bootsplash.

Firmware Customizations

Firmware Customization Details

Name: Bootsplash

Use case: | Select Use Case
Start button
Start menu
Taskbar background
Screensaver

Screensaver (custom partition) L
vare customization use case.

Bootsplash
Wallpaper

Please note:
If multiple use cases of the same type are assigned to the device,
only the use case with the highest priority is effective.

Example:

Itis possible to assign a wallpaper and a screensaver to a device.

Both customizations are used.

Furthermore, itis possible to assign two screensaver customizations to one device.
However, the firmware customization with the lesser ID will be ignored.

4. Select the image file for your bootsplash:
«+ Click Choose file if you have already uploaded a file to the UMS Server.
+ Click Upload file if you want to upload a new file.

® + The file name must not contain any blank spaces or special characters such as %, §,
umlauts, etc.
+ The file types supported for a bootsplash are JPG, BMP, and PNG.
« The optimum size of the picture is 800 x 600 pixels.
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Firmware Customizations

Firmware Customization Details

Name: Bootsplash

Use case: Bootsplash

+ Image bootsplash.png Choose file Upload file

Horizontal position

Vertical position

Progress horizontal position

Progress vertical position

5. Define the position of your bootsplash.
6. Optionally, click Next to assign this new firmware customization to a device or a device directory.

7. Click Finish to save your new firmware customization.

How to Create a Custom Bootsplash via a Profile
This is how you can create your own bootsplash using a profile in the UMS:
1. Upload your boot logo to the UMS Server; see Uploading a Picture (see page 636).
® « The file name must not contain any blank spaces or special characters such as %, §,
umlauts, etc.
« The optimum size of the picture is 800 x 600 pixels.

2. Create a new profile named Bootsplash; see Creating a Profile (see page 637).

3. Inthe profile configuration window, go to System > Firmware Customization > Corporate
Design > Custom Bootsplash to create your own bootsplash.

4. Activate Enable custom bootsplash.

5. Choose HTTP as Protocol.

6. Under Server name, enter the name or the IP address of your UMS Server.
7. Enter the path of your boot logo directory as Server path.

8. Specify your HTTP server port under Port.
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() Thedefault UMS HTTP server port is 9080. For more information on UMS ports, see IGEL UMS
Kommunikationsports.

9. Enter your UMS administrator User name and Password.
Bootsplash

) ~ / ® System ™ Firmware Customization ™ Corporate Design ™ Custom Bootsplash

Custom Bootsplash
Configuration
2 BVE

v Enable custom bootsplash

Sessions

CCESSones Custom Bootsplash - Server Location

erInterface :
Vo Use firmware update server location

Network
Protocol €) s HITP

Devices

Security Server name a « documentation.igel.local

Server path a < lums_filetransfer/
B Time and Date
» B Update Port a ~ 9080
» [ Remote management
» [ Remote Access e o A |ce\\
B Logging 5
» [ Power Options Password v
vO
» [ Custom Partition
Im Custom Application
» [ Custom Commands
O Custom bootsplash file Q /" bootsplash.png

Custom Bootsplash - Settings

10. Enterthe name of your bootsplash image under Custom bootsplash file.
11. Define Custom bootsplash style and Background color.

12. Define vertical and horizontal position for the bootsplash image and progress indicator.
The scale goes from 0 (left) to 100 (right); 50 means "centered".
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m P Firmware Customization ™ Corporate Design ™ Cus

wTiven nanme UL GV LISVl

Server path lums_filetransfer/

Port 9080

]

User Interface
User name

Network
Password
D

Security
Custom Bootsplash - Settings

n Time and Date
» [ Update
» I Remote management Custom bootsplash style
» B Remote Access
B Logging Background color
» B Power Options
vO
» [ Custom Partition
B Custom Application
» [ Custom Commands
v
&
» [ Background (1st Monitor) Size of progress indicator
. Company Logos
» [ Environment Variables
. Features Horizontal position of progress indicator

B Registry

Custom bootsplash file €) / bootsplash.png

/" Original

Horizontal position of bootsplash image

Vertical position of bootsplash image

Vertical position of progress indicator

Search

Apply and send to device

13. Save the settings.

14. Assign the profile to your devices by dragging and dropping them or by adding them
under Assigned objects. For more information on the profile assignment, see Wie kann ich IGEL
UMS Profile zuweisen?.

@ Iftheimage file or any setting of an existing custom bootsplash is changed, the bootsplash code has to be
rebuilt. You can trigger this from the UMS via Jobs > New Scheduled Job with the command Update
desktop customization.
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Creating Your Own Screensaver

This section describes how to configure an autostart screensaver with your own picture using the UMS.

Proceed as you did for the wallpaper:

1. Upload your logo to the UMS server. For details, see Uploading a Picture (see page 636).
() Thesize of the picture is irrelevant because it will be reduced automatically to 200 x 150 pixels.

2. Create a new Profile named Screensaver. For details, see Creating a Profile (see page 637).
3. Configure the profile settings.
There are four areas where you have to make settings in the screensaver profile:
+ Setting a Delay Time for Booting (see page 648)
+ Setting a Timeout for Autostart (see page 649)
+ Assigning the Custom Logo (see page 650)
+ Assigning the Custom Clock (see page 651)
4. Assign the profile to your devices by dragging and dropping them or by adding them under
Assigned objects.
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Setting a Delay Time for Booting
Configure Autostart in the screensaver profile under User Interface > Screenlock / Screensaver.

1. Enter a Session name, for example Screensaver.
2. Enable Autostart.
3. Enter the number of seconds of Delay.

() This setting tells the system that it must launch the autostart of this session with a certain delay
during booting.
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Setting a Timeout for Autostart

1. Click User Interface > Screenlock [ Screensaver > Options.
2. Enable Start automatically.
3. Enter a number of minutes for Timeout.

( With this setting, you decide how long the system has to wait before starting the screensaver after
the last input.
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Assigning the Custom Logo

1. Go to System > Firmware Customization > Corporate Designh > Company Logos.

2. Activate Enable image display.

3. Enter the Image file/directory you have defined under Thin Client file location. See Uploading a
Picture (see page 636).

() Ifyou enter afolder instead of a single image file as the source, all images in the folder will be
displayed as a slide show. The display time for the images can be configured.

4. Activate One image per monitor if you use more than one monitor and if you want to show
different pictures on each screen.
5. Under Image duration specify the time in seconds that you want to wait before the image is to be
changed.
6. Under Image display mode you can choose between the following different image actions:
+ Small-sized hopping: Small pictures are shown in changing positions.
+ Medium-sized hopping: Bigger pictures are shown in changing positions.
+ Full-screen center cut out: The pictures will be shown in full-screen mode. They may
possibly be cut at the border.
+ Full-screen letterbox: The pictures are shown in full size as large as possible according to
the screen.
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Assigning the Custom Clock

You can also configure a digital screensaver clock independently of the screen display.

1. Click User Interface > Screenlock / Screensaver > Screensaver.

2. Select the Clock display monitor where you want to display the clock.

3. Activate Show seconds if you want to see the digital time display, including seconds.
4. Define the size, position and color settings of your screensaver clock.
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Assigning Your Own Company Logos

You can set your own images for the start button and the company logo in the start menu.

Company logo

w @ Application Launcher

Browser

. Local Terminal
o
Logoff

Start button icon

(0 The Start buttonicon is customizable in IGEL Linux 5.08.100 and newer.

() To see astart menu with a company logo, you first have to set the Start Menu
Type on Advanced under User Interface > Desktop > Start Menu.
If you set the Start Menu Type on Auto and the device has a clock frequency of 1 GHz, the system will
choose the advanced type.

To assign your own icons via UMS:
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Upload your logos to the UMS server. For details, see Uploading a Picture (see page 636).

Create a new profile. For details, see Creating a Profile (see page 637).

The profile configuration window opens.

Go to System > Firmware Customization > Corporate Designh > Company Logos > Start Menu.
Enter the file name and the full path of the image under Start button icon.

Enter the file name and the full path of the image under Company logo in start menu.

Click Save or Apply and send to Thin Client to save the settings.

Assign the profile to your devices by dragging and dropping them or by adding them

under Assigned objects.

N

NoouhkWw

@ Analternative to this is the chapter Create Firmware Customization in the UMS manual.
Here you will find further configuration options for adapting the UMS to your
requirements.
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Creating Your Own Taskbar

You can apply your own design to a taskbar. To customize the taskbar on multiple devices, use the IGEL UMS and
proceed as follows:

1. Upload the desired image to the UMS server, see Uploading a Picture (see page 636).

2. Create a new profile, seeCreating a Profile (see page 637).

3. Assign the image to the profile by dragging and dropping it or by adding it under Assigned
objects.

4. In the profile configuration window, go to User Interface > Desktop > Taskbar Background.

5. Select Background image under Background style.

Background Style [Background Image T]

Background Image Path Mfsiuzer/corporoate_design/igelstar
6. Enter the full path of the desired image under Background image path.

7. Assign the profile to your devices by dragging and dropping them or by adding them
under Assigned objects.
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Customizing Desktop Icons

() Youcanonly customize the desktop icon of a session. The taskbar icon of a session cannot be customized
and will remain the default icon. Complete customization is not possible.

Prerequisites
You can use the following graphic formats and resolutions for a custom desktop icon:

+ PNG - common resolutions are 128x128, 96x96, 64x64, 48x48, 32x32, 24x24, 22x22, 16x16, but
others are also accepted and scaled accordingly.

() Werecommend at least a resolution of 64x64.

+ SVG - no resolutions because SVG contains freely scalable vector graphics.

() Eventhough other formats like BMP or JPEG are supported, only PNG and SVG are recommended because
these formats support transparency.

To customize the desktop icon of a session, proceed as follows:

1. Inthe Setup, go to System > Registry.
2. Inthe Registry, navigate to sessions.[session name].icon.

() Fortechnical reasons, some registry keys do not match the session's name. For example, RDP
sessions are found under the key winconnect[0-...] .

3. Enter under Icon name the absolute path to your custom icon as shown in the sample picture
below.
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< > A

Configuration

B Time and Date
» Il Update
» [ Remote management
» [l Remote Access
Fower Options
» [ Firmware Customization

B Regist

Search

4. Click Ok to save the changes.
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» [ webcaminfod
* [ winconnectd%
¥ 3 winconnecto
B spplaunch
B =pplaunch_path

B applaunch_system

B autostart

B deskiop

B deskiop_path
B finzl_action

B hotkey

B hotkeymodifier

1y

sesslons.winconnectO.lcon

lcon name

fwfsfcustom_icon.png

B icon

B init_action
B menu_path
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How to Change the Font Color of the Desktop Icons

Problem

You want to alter the font color of the desktop icons, but there is no obvious way to do that in the Setup.

Environment
+ IGEL0S 11.01.100 or higher

Instructions
To change the font color of the desktop icons:

1. Inthe Setup, go to System > Firmware Customization > Custom Commands > Base.
2. Under Initialization, enter the following command where red is the desired font color:

sed -i "/AXfdesktopIconView.label[ \tl*{/,/}/ s#"\([ \t]xcolor:
[ \t]l*\)white;#\1lred;#" /usr/share/themes/IGEL-Dark/gtk-3.0/xfdesktop.css

You can specify any other color which can be recognized by GTK>, e.g. blue, black, green,

etc.
Example:

sed -i "/~XfdesktopIconView.label[ \tl*{/,/}/ s#*\([ \tl*color:
[ \tl*\)white;#\1lgreen;#" /usr/share/themes/IGEL-Dark/gtk-3.0/
xfdesktop.css

3. Save the changes.

55 https://www.gtk.org/
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4. Reboot the device.
The font color of the desktop icons has been changed to red:
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How to Set Up a Countdown to Prevent an Undesired Screen Lock In IGEL
0S

In some situations, a screen lock that comes without a warning can cause disruption. Typically, this is the case
when a user who is logged in to a remote session does not interact with the device for some time, which results in
the screen lock kicking in. To circumvent this problem, you can set a visible countdown that is started before the
screen is locked, so the user can react in time.

() Review the timeouts in the power settings of your device to ensure that the display won't turn black before
the countdown is started; see System and Screen.

The configuration is described in the following sections:

+ Defining the Countdown's Behavior (see page 659)
+ Defining the Countdown's Appearance (see page 661)

For special purposes, like closing a remote session to prevent it from running unattended, you can configure an
additional set of commands. It consists of a command that determines whether the countdown should be started
(typically, check whether the remote session is running) and a command that will be executed when the countdown
reaches 0 (typically, close the remote session). The configuration is described in the following section:

+ Configuring a Conditional Countdown and Command (see page 663)

Defining the Countdown's Behavior
For a description of all options, see Options.
1. Inthe Setup or UMS configuration dialog, go to User Interface > Screenlock / Screensaver >
Options.

2. Activate Start automatically.

|+/| Start automatically

Timeout

In the Timeout field, specify after how many minutes the countdown should start.

(V] start automatically

Timeout
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4. Select the password to be used to unlock the screen:

+ None: The user can unlock the screen without a password. Please note that the countdown
will not be started when this option is selected!

+ User password: The user must enter the user password to unlock the screen. If you are
using Microsoft Active Directory (AD) resp. Kerberos for authentication, which is highly
recommended, the user's AD/Kerberos password will be used here. For details, see Active
Directory/Kerberos. If you are not using AD/Kerberos, the user password is configured in
Security > Password under User. Please note that the password should not, at any rate, be
set via a UMS profile, otherwise all affected devices would have the same password!

+ Local user password: The user must enter a special screen lock password to unlock the
screen; click Set to define this password. Please note that the password should not, at any
rate, be set via a UMS profile, otherwise all affected devices would have the same password!
This password is also used for Security > Logon > Local User > Login with local user
password; see Local User (see page 659).

If the user is logged in via Active Directory (AD), the AD credentials are used instead of this
password to unlock the screen.

If you are using Citrix Storefront, this password can be synchronized with the Citrix session
password by enabling Synchronize Citrix password with screen lock under Sessions >
Citrix > Citrix StoreFront > Login; see also Login Settings for Citrix StoreFront in IGEL OS.

Screenlock Password
a

Mone

® llser passw

Local user password

|| Different screenlock timeout

€)  Allow administrator password

5. Set the Countdown duration in seconds. The range is from 1 to 60.
Configuration example:
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v Start automatically

Timeout

Screenlock Password
2]

Mone

User password

Local user password

) Allow administrator password

Countdown duration in seconds _
7 Seconds

Countdown visual effect Dark screenshot

Countdown background image ) Jusr/sharefzenity/

6. Apply the settings to your devices or to your profile.

Defining the Countdown's Appearance

1. Inthe Setup, go to User Interface > Screenlock / Screensaver > Options.

2. If you want the current desktop as a background image during the countdown, select the visual

effect:
« Dark screenshot: The desktop screenshot is darkened.
+ Gray screenshot: The desktop screenshot is grayed out.

3. If you want a custom image as a background image during the countdown, enter a valid path and
file name. Example: /images/ .Iftheimageis not already residing on your device, you can

upload it using the UMS; see Uploading a Picture (see page 636).
Configuration example with custom image:
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Countdown duration in seconds _
7 Seconds

Countdown visual effect Dark screenshaot

Countdown background image topwatch.jpg

4. Go to User Interface > Screenlock / Screensaver > Screensaver.

5. Customize the countdown's appearance using the following parameters; these parameters define
the appearance of both the screensaver's clock and the countdown. For further information, see
Screensaver.

+ Image display mode: Position and scaling for the background image

+ Clock display monitor: Select the monitor(s) on which the countdown is to be shown.

« Show seconds: Define whether the seconds should be displayed on the clock.

+ Clock display size: Size of the countdown digits

+ Horizontal clock position: Horizontal position of the countdown digits

« Vertical clock position: Vertical position of the countdown digits

+ Clock background color: Color of the countdown background area. The countdown
background area is a rectangle with rounded corners.

+ Clock background opacity percentage: Set the opacity for the clock's background area
(defined by Clock background color),

+ Clock foreground color: Color of the countdown digits

Configuration example:

Image display mode Full-screen center cut out

Clock display monitor

Clock disp

Horizontal clock position

Vertical clock position

Clock background color
Clock background opacity percentage

Clock foreground color

IGEL OS Articles

All

Huge
Right
Top

Choose color
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6. Apply the settings to your devices or to your profile.
Here is an example of the countdown with a custom image:

Configuring a Conditional Countdown and Command

In our example, a Citrix session is running (e.g. in appliance mode), and the endpoint device has been idle for a
while. After the timeout, the system checks whether a Citrix session is running; this is to prevent the session from
running unattended. The Citrix session is detected, so the countdown kicks in. The user does not interact with the

device, so the countdown is not stopped. When the countdown has reached 0, the system kills the Citrix client; the
user is logged off.

In the following, we will first specify the command that determines whether the countdown should be started.
Then, we will specify the command that is executed when the countdown has reached 0.

Command That Determines the Condition under Which the Countdown Should Be Started

& Thiscommand only makes sense in combination with a command that is to be executed after the
countdown is done; see Command to Be Executed after the Countdown (see page 664).

1. Inthe Setup, go to System > Registry and open the registry key sessions > xlock0 > options >
countdown_condition_cmd

( sessions.xlock®.options.countdown_condition_cmd).
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2. Enterthe command in the field Countdown condition command. The user that issues the
commandsis user .If nocommand is defined here, the countdown will be started. Examples:

pgrep wfica (returns0if a Citrix session is present), pgrep igelrdp2

Countdown condition command

pgrep wfica

B changing p
B countdown_background _imz

B countdown condition_cmd
: tdow

3. Click Apply or Ok.
If the command returns 0, the countdown is started. When the countdown has reached 0, the
command specified with System > Registry > sessions > xlock0 > options >
countdown_done_cmd is executed (see Command to Be Executed after the Countdown (see page
664)).
If the command returns a non-zero value, the countdown is not started. A command that is
configured for execution after the countdown will therefore not be executed. The screen lock or
screensaver will be started.

Command to Be Executed after the Countdown

1. Inthe Setup, go to System > Registry and open the registry key sessions > xlock0 > options >
countdown_done_cmd ( sessions.xlock®.options.countdown_done_cmd ).

2. Enter the command in the field Countdown done command. The user that issues the commands
is user .Examples: killall wfica (terminatesthe Citrix ICAclient), Logoff

() Thecommand is executed synchronously before the countdown goes away. If the command
doesn't terminate quickly, it must be sent to the background by appending " & ".

Countdown done command
B changing p €2 [killall whical
B countdown_background imzs
B countdown_condition_cmd

B countdown done cmd

B countdown_done_cmd_conti
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3. (Optional) If you want to enforce the start of the screensaver after the Countdown done
command has been executed, open the registry key sessions > xlock0 > options >
countdown_done_cmd_continue
( sessions.xlock®.options.countdown_done_cmd_continue )and enable Continue
screensaver after countdown done command.

() Some applications stop the screensaver when they get restarted, so this does not always have the
desired effect.

B change_p _text Continue screensaver after countdown done command
B changing p:
B countdown_background ima

€) V Continue screensaver after count...

B countdown _condition cmd
B countdown done_cmd

g countdown_done _cmd conti

4, Click Apply or Ok.
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How to Set Up a Countdown in the IGEL OS

You can set up the countdown via the device's local Setup or via the IGEL Universal Management Suite (UMS). Itis
recommended to use the IGEL UMS and store your settings in a profile; this allows you to apply your settings to a
random number of devices in one go.

For more information about profiles, see the Profiles chapter in the IGEL UMS reference manual.

Defining the Countdown's Behavior

1. Inthe Setup, go to User Interface > Screenlock / Screensaver > Options.
2. Activate Start automatically.
3. Inthe Timeout field, set the idle timeout in minutes, after which the countdown should start.

4. Select the password to be used to unlock the screen:
+ None: The user can unlock the screen without a password.
+ User password: The user must enter the user password to unlock the screen. The user
password is configured in Security > Password.
+ Screenlock password: The user must enter a special screenlock password to unlock the
screen. Click Set to define the screenlock password.

5. Set the Countdown duration in seconds. The range is from 1 to 60.
Configuration example:

& (] Start automatically
Timeout & 1

Screen Lock Password
A O Nore

A O UserPassword

_ Set
A ®) Screen Lock Password

6. Apply the settings to your devices or to your profile.

Defining the Countdown's Appearance
1. Inthe Setup, go to User Interface > Screenlock / Screensaver > Options.
2. If you want the current desktop as a background image during the countdown, select the visual
effect:

« Dark screenshot: The desktop screenshot is darkened.
+ Gray screenshot: The desktop screenshot is grayed out.
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3. If you want a custom image as a background image during the countdown, enter a valid path and
file name. Example: /images/ .Iftheimage is not already residing on your device, you can

upload it using the UMS; see Uploading a Picture (see page 636).
Configuration example with custom image:

Countdown duration in seconds A 0 = - 10
Countdown visual effect & | Dark screenshot VJ
Countdown backaround image & fimagesistopwatch.jpg

4. Go to User Interface > Screenlock / Screensaver > Screensaver.

5. Customize the countdown's appearance using the following parameters; these parameters define
the appearance of both the screensaver's clock and the countdown. For further information, see
Screensaver.

+ Image display mode: Position and scaling for the background image

(@ This parameter is only relevant for IGEL Linux v5. With IGEL Linux version 10.03.500 or
higher, the Image display mode is set to "Full-screen letterbox".

+ Clock display monitor: Selects the monitor(s) on which the countdown is to be shown.

+ Clock display size: Size of the countdown digits

+ Horizontal clock position: Horizontal position of the countdown digits

« Vertical clock position: Vertical position of the countdown digits

+ Clock background color: Color of the countdown background area. The countdown
background area is a rectangle with rounded corners.

+ Clock foreground color: Color of the countdown digits

Configuration example:

Image display mode & | Full-screen center cut out YJ

Clock display monitar & |AII 'J
Show seconds

Clock display size é |Huge YJ

Horizontal clock position & |Right "J

Verical clock position & |T0p 'J

Clock background color

Clock hackground opacity percentage & Fiil

Clock foreground color
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6. Apply the settings to your devices or to your profile.
Here is an example of the countdown with a custom image:
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Configuring a Conditional Countdown and Command
You can specify an arbitrary command that is executed when the countdown has reached 0.
Additionally, you can specify a command that determines whether the countdown is to be started.

Example use case: The countdown is running, but the user does not interact with the device in order to make the
countdown stop. When the countdown has reached 0, the system checks whether a session is running, e.g. an
appliance mode Citrix session. If yes, the user is logged off from this session.

If no command is set to be executed after countdown, the screen will be locked instead.

The user that issues the commands depends on the firmware version in use:

« With IGEL Linux v5, the useris root.
« With IGEL OS Linux 10, the useris user .

To specify the command that determines the condition:
1. Inthe Setup, go to System > Registry and open the registry key sessions > xlock0 > options >
countdown_condition_cmd

( sessions.xlock®.options.countdown_condition_cmd).

2. Enterthe command in the field Countdown condition command. Example: pgrep wf-ica

(determines if a Citrix session is present)
3. Click Apply or Ok.
If the command returns 0, the countdown or commando is started.
If the command returns a non-zero value, the countdown or commando is not started.

To specify the command to be executed after the countdown:
1. Inthe Setup, go to System > Registry and open the registry key sessions > xlock0 > options >

countdown_done_cmd ( sessions.xlock®.options.countdown_done_cmd ).

2. Enter the command in the field Countdown done command. Example: killall wfica
(terminates the Citrix ICA client)

@ The command is executed synchronously before the countdown goes away. If the
command doesn't terminate quickly, it must be sent to the background by appending " & "

3. Open the registry key sessions > xlock0 > options > countdown_done_cmd_continue
( sessions.xlock®.options.countdown_done_cmd_continue )and specify whether
the screensaver should be started after the command has been started.

@ With IGEL Linux v5, the screensaver does not start immediately. It will be started after the

idle timeout defined under User Interface > Screen Lock/Saver > Options > Timeout.
With IGEL OS Linux 10, the screensaver is started immediately.
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The screensaver is started after the command has been started.
[ The screensaver will not be started.
4. Click Apply or Ok.
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Installing a Calculator on IGEL Linux

Issue

You may want to have a desktop calculator.

Solution

1. Download the opensource java calculator from: http://sourceforge.net/projects/simpcalc/

® The default download location of the local Firefox browser is /tmp/ .

2. OpenalLocal Terminaland loginas root
3. Copythedownloaded .jar filefromthe /tmp/ directoryto /wfs/simplecalc.jar:
cp /tmp/ /wfs/simplecalc.jar

Itis important to copy the fileto /wfs because otherwise the file would be flushed with a reboot.

4. Open IGEL Setup and create a new custom application: System > Firmware Customization >
Custom Application

5. SetCommandto java -jar /wfs/simplecalc.jar in Settings
6. Click the newly created icon on the desktop to run the custom application.

() Todistribute this application to several thin clients please use the file transfer option in
IGEL UMS and set up a profile with the custom application configuration.
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Keyboard Shortcuts for Managing Windows

Switching back and forth between open application windows by using keyboard shortcuts is a common way of
managing windows.

If you work in a fullscreen environment, you also need a way to switch to the desktop.
With IGEL Linux OS version 10.03.500, the device desktop was added to the window cycle of the window manager.

Use the following default shortcuts to switch from application windows to the desktop:

Task Default Shortcut
Switch between active windows using Task Switcher Ctrl +Alt + Tab

Switch between active windows using Task Switcher Ctrl+Alt+Shift+Tab
(backwards)

Switch focus to next window Ctrl + Esc

Switch focus to next window (2) Ctrl + Alt + UpArrow
Switch focus to next window (reverse order) Ctrl + Alt + DownArrow

(@ GotoIGEL Setup > User Interface > Hotkeys > Commands to change these shortcut combinations.

() Switching to the desktop minimizes all windows. Switching back to a window right after that restores all
windows.
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Make Frequent User Actions Easier by Defining Hotkeys

For common actions, such as switching between different windows, or lock the screen, you can use a hotkey. Some
hotkeys are preconfigured, but you can activate, deactivate, and modify them.

The following example shows how to find out or modify the hotkey for switching between windows:

4 > A | ™ User Interface ™ Hotkeys

Configuration

Se5

Accessories

User Interface
» [ Display
» [ Desktop

‘ Language
» I Screenlock / Screensave
» [ Input

¥ [ Hotkeys
B commands

Lot O

» Commands

List of Commands which can be made available for the User

Command Name

| Key

MNetwork
Devices

Security

Search

Open start menu
Open start menu (alternative)
Screenshot of active window

Hide all windows and show desktop
Mapping Ctri+Alt+End to Ctrl+Alt+Del for Citrix sess...

CtriMod4 + d

| Switch between active windows using Task Switcher

Ctrljalt + Tab |

Switch focus to next window

Volume down (multimedia key)
Wolume mute (multimedia key)
Volume up (multimedia key)

Switch between active windows using Task Switcher. ..

Switch focus to next window (alternative)
Switch focus to next window (reverse order)

Ctrijalt|Shift + Tab

Ctrl + Escape

Ctrljalt + Up

Ctrljalt + Down
¥F8saudioLowervolume
X¥F86AudioMute
XF86AudioRaiseVolume

Switch between active windows using ™ X

Modifiers

Key

[[] Appliance Mode Access

Ok Cancel

1. Open the setup and go to User Interface > Hotkeys > Commands.
2. Select Switch between active windows using Task Switcher.

3. Click on Modify.

A dialog window is opened.

4. Enable Hotkey, if not already enabled.
Select a modifier key or a combination of modifier keys under Modifiers.

o

6. Enter a Key.

Related Configurations

Accessories -
Comrmands

Ok Cancel

@ Ifyou want to enter a key that has no visible character assigned, e. g. the [Tab] key, open a
terminal, logon as user and enter xev -event keyboard . Pressthe key designated

for the hotkey. The text in brackets starting with keysym will contain the desired string
for the Key field; example: Tab in (keysym 0xff@9, Tab)
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7. Click on Ok.
8. Click on Apply or Ok.
The hotkey is ready for use.

The following example shows how to define a hotkey to lock the screen:

'4 > ~ / * User Interface * Screenlock / Screensaver

Configuration Session Name Lock Screen

S

Starting Methods for Session
] start Menu [[] start Menu's System tab
[] Application Launcher [_] Application Launcher's System tab
[] Desktop ] Desktop Context Menu
] Quick Start Panel

Accessories
User Interface
» I Display
» I Desktop

B Language
¥ [ Screenlock / Screensave

‘ Options
dskba

‘ Screensaver
» I Input

» I Hotkeys Password Protection
» Il Font Services

Network ) [/] Use Hotkey
Devices

Modifiers
Security

System iy

[ autostart

[[] Appliance Mode Access

Search

Apply Ok Cancel

Open the setup and go to User Interface > Screenlock/Screensaver.
Enable Hotkey.

Select a modifier key or a combination of modifier keys under Modifiers.
Enter a Key.

Click on Apply or Ok.

The hotkey is ready for use.

ok wnNE
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Shutdown/Suspend Devices Automatically at the End of a Session

Issue

You may want to shut down, suspend, restart or log off from the device automatically after ending a session.

Solution

You can define an "after-logoff-action" dependent on a session type. This action is performed after ending the last
instance of the defined session type.

Proceed as follows:

1. Inthe device's local Setup (or its UMS configuration or profile), navigate to System > Firmware
Customization > Custom Commands > Post Session.

2. Choose a Session type.

3. Choose a Post-session command.

4. Save the changes with Apply or OK.

If the last instance of the chosen session type is ended, the post-session command will be processed.

See also IGEL OS manual: Post Session

() The post-session command Shutdown/suspend will perform the default action defined under System >
Power Options > Shutdown > Default action. Please check this parameter before using the command.

() The post-session command Logoff is futile unless you define a login method under Security > Logon
(Smartcard, Active Directory/Kerberos, or IGEL Shared Workplace). The Logoff command also cannot be
used with an appliance - in this case, only Shutdown/suspend or Reboot commands are working.

() When using auto-logoff commands with an appliance, make sure to define the corresponding session type
- e.g. Horizon View when using the VMware Horizon View appliance.
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Suspend to RAM - Wake Up by USB Mouse

You can wake up your device by mouse click or key press.

() The wake-up functionality strongly depends on the hardware and BIOS version in use. We recommend
testing this function before using it. With devices converted by UDC3/0S Creator (OSC) or UD Pocket, it
only works when the hardware is fully supported.

Setting System Suspend as the Default Action

1. In Setup, go to System > Power Options > Shutdown.

Activate Allow system suspend.

Under Default action, select "Suspend".

Save the setting by clicking Apply or Ok.

From now on, the system will be suspended to RAM whenever it is shut down.

Eall

To use the wake-up functionality, the following steps must be performed:

Configuring the BIOS for PS/2 Mouse and Keyboard

1. Open the BIOS of your device and check if the power management section has parameters named
"PS/2 Wake up from S3" or similar.

2. If present, set the parameters to enabled.

3. Save the BIOS configuration and continue booting.

Configuring the BIOS for USB Mouse and Keyboard

1. Open the BIOS of your device and check if the power management section has parameters named
"USB Wake Up from S3" or similar.

2. If present, set the parameters to enabled.

3. Save the BIOS configuration and continue booting.

Enabling the Wake-Up Functionality

1. Inthe IGEL Setup, activate System > Registry > system > acpi_wakeup > enabled > Wakeup
from S3 by USB devices.
2. Click Apply or Ok.

To check if the wake-up functionality works, click > , wait a few minutes, and try to wake up the device
using a mouse click or a key press.
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Taking Screenshots on IGEL Linux

Issue

For support or documentation purposes, the user wants to take a screenshot in IGEL Linux without accessing the
client via VNC.

Solution
On IGEL Linux 5.08.100 and newer or IGEL Linux 10.01.100 and newer, use the pre-installed Screenshot Tool.

On earlier versions:
1. Download the tool Rapid Screenshot®,
® The default download location of local Firefox is /tmp/ .

2. Open alLocal Terminaland login as root.
3. Copythedownloaded. jar filefromthe /tmp/ directoryto /wfs/screenshot.jar:

cp /tmp/ /wfs/screenshot.jar

Itis important to copy the fileto /wfs because otherwise the file would be flushed with a reboot.

4. Open IGEL setup and create a new custom application:
System > Firmware Customization > Custom Application

5. SetCommandto java -jar /wfs/screenshot.jar inSettings.
6. Click the new icon on the desktop to run the custom application.

To distribute this application to several thin clients use the file transfer option in IGEL UMS and set up a profile with
the custom application configuration.

1. HOW TO USE Easy Screenshot Maker:
a. Startthe application.
b. Make a screenshot.
c. Savethefile forexampleas test.png.

2. HOW TO USE Rapid Screenshot:
a. Startthe application.
b. Click Save in to configure the path to store screenshots.
c. Click button Click.

The screenshot will be saved automaticallyas .jpg.

() Please note the licenses for both screenshot capture tools mentioned on the websites of these specific
tools!

56 https://sourceforge.net/projects/screenshot/?source=directory
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Setting the Device's System Time

Issue

The thin client's system time is not correct.

Solution

1.

oW

Open the thin client's configuration either locally or in UMS.
Go to System > Time and Date
Choose your Continent/Area (e.g. America).
Choose your Location (e.g. New York).
Set time and date

a. either manually by clicking Set time and date

b. orautomatically by configuring an NTP Time Server.
Click OK or Apply to save your settings.

@ Note: If choosing General as Time Zone Area you have to set your GMT time zone
(Location) following the POSIX standard (as usual in Linux) - which means you have to
invert the offset of your common UTC time zone! (See tool tip for Location as well.)
Therefore it is preferable to set the system's time zone by choosing the corresponding
area and location instead of defining the GMT offset.

Example for America/New York: In POSIX standard GMT+5 is the time zone 5 hours west of Greenwich and
corresponds to UTC-5

a

Legal Note
IGEL's Terms & Conditions®” apply.

57 https://www.igel.com/terms-conditions/
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Updating Timezone Information (Daylight Saving Time, DST)

Symptom

The device is showing an incorrect time of day for your location, although you have set the correct time zone.

Problem

The time zone or the regulation for Daylight Saving Time (DST) for your location has changed.

Solution
Update the time zone information files via IGEL Universal Management Suite (UMS). This is known to work for

« |IGEL Linux version 10.01.100 or newer

« IGEL Linux version 5.04.100 or newer

« IGEL Linux version 4.14.100 or newer

+ |IGEL Linux ARM version 1.09.100 or newer.

Retrieving current time zone information files:

On Windows

+ Use your web browser to download the following package files:
« http://packages.ubuntu.com/xenial-updates/all/tzdata/download for IGEL Linux version

10.x

« http://packages.ubuntu.com/trusty-updates/all/tzdata/download (for IGEL Linux version
5.X)

« http://packages.ubuntu.com/precise-updates/all/tzdata/download (for IGEL Linux version
4.x)

« Extract the package contents using the program 7-Zip (freely available from http://www.7-zip.org).
+ Find the file for your location in the extracted directoryin usr/share/zoneinfo/ ,e.g. usr/

share/zoneinfo/Africa/Casablanca for Morocco.

On Linux

+ Update your system time zone information with these commands: sudo apt-get update

sudo apt-get install tzdata
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+ Find the file for your location in the system directory /usr/share/zoneinfo/ ,e.g. /usr/

share/zoneinfo/Africa/Casablanca forMorocco.

Distributing the files from IGEL Universal Management Suite

+ Select System > New > New File from the UMS Console menu bar or go to Files in the tree
structure and select New File from the context menu.

+ Select the time zone file for your location under Local File.

+ Select Undefined under Classification.

+ Specify /wfs/zoneinfo/ asthe Devices file location.

« Setthe Access rights to Read and Write for the Owner, and to Read for Others.
+ Select Root as the Owner.
+ Click OK to confirm the settings.
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MNew file
File source
#® |ploadlocal file to LUMS senver

Local file

Upload location (URL)  hitpsiii=serverport=fums_filetransfer
Select file fromUMS server

File location (URL)
File target
Classification Lndefined
Devicesfile location  fwfsizoneinfol

Access rights
Read Write Execute
Cwner

Others

Owner | Root

Cancel

On a device, you can verify the transfer and activation of the new time zone information files:

+ Inthe Local Terminal, enter grep 'timezone_config' /var/log/messages

® on IGEL Linux version 10.x, use: journalctl | grep 'timezone_config'

+ The output should look like the following:
Feb 27 11:28:13 (none) timezone_config: loading /wfs/zoneinfo/

Casablanca to /usr/share/zoneinfo/Africa/Casablanca
Feb 27 11:28:13 (none) timezone_config: loading /wfs/zoneinfo/

Casablanca to /usr/share/zoneinfo/posix/Africa/Casablanca
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Feb 27 11:28:13 (none) timezone_config: configure timezone Africa/

Casablanca
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Adding or Changing a MIME Type Handler

Symptom

Files or protocols are opened with the wrong application

Problem

The MIME type handler for the file type or the protocol is missing or misconfigured.

Solution
Change the MIME type handler or add a new one.

MIME type handlers are defined by *.desktop filesinthe /usr/share/applications.mime/ directory.
Toadd anew *.desktop file, use the following sample and edit it according to your needs:

[Desktop Entry]

Version=1.0

Encoding=UTF-8

Type=Application

Name=Browser//A name for the MIME type handler

Categories=Application

Exec=/usr/bin/firefox %u//The binary to execute on opening an associated file
MimeType=x-scheme-handler/http;x-scheme-handler/https;text/html;application/
xhtml+xml;//A list of MIME types separated by semicolon

Terminal=false

StartupNotify=false

NoDisplay=true

You can find out more about *.desktop filesina specification at freedesktop.org (see page 683).

These are the default handlers on IGEL Linux:Images (opened via gpicview)

+ image/bmp;
+ image/gif;

« image/jpeg;
« image/jpg;

« image/png;

+ image/x-bmp;
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+ image/x-pcx;

+ image/x-tga;

+ image/x-portable-pixmap;
+ image/x-portable-bitmap;
+ image/x-targa;

+ image/x-portable-greymap;
+ application/pcx;

+ image/svg+xml;

+ image/svg-xml;

Videos and Music (opened via /services/mplr/bin/mediaplayer )

Notethat /services/mplr/bin/mediaplayer callseither /config/sessions/mediaplayer0 if

existentor totem ifthisis notthe case

« application/mxf;

+ application/ogg;

« application/ram;

« application/sdp;

« application/smil;

« application/smil+xml;

« application/vnd.ms-wpl;

« application/vnd.rn-realmedia;
« application/x-extension-m4a;
« application/x-extension-mp4;
+ application/x-flac;

+ application/x-flash-video;

+ application/x-matroska;

+ application/x-netshow-channel;
+ application/x-ogg;

« application/x-quicktime-media-link;
« application/x-quicktimeplayer;
« application/x-shorten;

« application/x-smil;

+ application/xspf+xml;

+ audio/3gpp;

+ audio/ac3;

« audio/AMR;

+ audio/AMR-WB;

+ audio/basic;

+ audio/midi;

+ audio/mp4;

+ audio/mpeg;

+ audio/mpegurl;

+ audio/ogg;

+ audio/prs.sid;
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+ audio/vnd.rn-realaudio;
+ audio/x-ape;

+ audio/x-flac;

+ audio/x-gsm;

« audio/x-it;

+ audio/x-m4a;

+ audio/x-matroska;

+ audio/x-mod;

+ audio/x-mp3;

+ audio/x-mpeg;

+ audio/x-mpegurl;

+ audio/x-ms-asf;

+ audio/x-ms-asx;

+ audio/x-ms-wax;

+ audio/x-ms-wma;

+ audio/x-musepack;

+ audio/x-pn-aiff;

+ audio/x-pn-au;

+ audio/x-pn-realaudio;
+ audio/x-pn-realaudio-plugin;
+ audio/x-pn-wav;

+ audio/x-pn-windows-acm;
+ audio/x-realaudio;
 audio/x-real-audio;
 audio/x-sbc;

+ audio/x-scpls;

+ audio/x-speex;

+ audio/x-tta;

+ audio/x-wav;

+ audio/x-wavpack;

+ audio/x-vorbis;

+ audio/x-vorbis+ogg;

+ audio/x-xm;

+ image/vnd.rn-realpix;

+ image/x-pict;

« misc/ultravox;

+ text/google-video-pointer;
+ text/x-google-video-pointer;
+ video/3gpp;
 video/dv;

« video/fli;

« video/flv;

+ video/mp4;

+ video/mp4v-es;

+ video/mpeg;

+ video/msvideo;

+ video/ogg;
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video/quicktime;
video/vivo;
video/vnd.divx;
video/vnd.rn-realvideo;
video/vnd.vivo;
video/x-anim;
video/x-avi;
video/x-flc;
video/x-fli;
video/x-flic;
video/x-flv;
video/x-m4v;
video/x-matroska;
video/x-mpeg;
video/x-ms-asf;
video/x-ms-asx;
video/x-msvideo;
video/x-ms-wm;
video/x-ms-wmv;
video/x-ms-wmx;
video/x-ms-wvx;
video/x-nsv;
video/x-ogm+ogg;
video/x-theora+ogg;
video/x-totem-stream;
x-content/video-dvd;
x-content/video-vcd;
x-content/video-svcd;

Documents (openedvia /usr/bin/evince)

application/pdf;
image/tiff

Web (openedvia /usr/bin/firefox -remote)

x-scheme-handler/http;
x-scheme-handler/https;
text/html;
application/xhtml+xml;
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Regional Settings in Sessions

Symptom

If you set a certain keyboard language it has no effect on the regional settings.

Problem

In the IGEL setup there are several input fields for regional settings. You would like to understand which setting has
what effect in the sessions.

Solution

Defining general regional settings:

> Goto IGEL Setup > User Interface > Language.

« Language: Select one of the languages offered for the graphical user interface.

+ Keyboard Layout: Select the country-specific assignment of keys, e.g. English(US).

+ Input Language: Set the language you are going to write in, e.g. English(Australia).

« Standards and Formats: Select country-specific formats, e.g. for date and time or currency.

Defining session-specific regional settings:

» Gotothe settings of your session, e.g. Citrix: IGEL Setup > Sessions > Citrix > Citrix Global > Keyboard.

() The default settings are those you defined under User Interface > Language.

> Specify Keyboard Layout and Input Language for your Citrix Session.
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o Monitor (see page 689)

« Webcam Redirection and Optimization (see page 708)

« Webcam Information (see page 719)

« Bluetooth Tool (see page 721)

+ How to Deploy a Jabra Xpress Package (see page 725)

« Connecting Signature Pads (see page 729)

+ Using a Kofax / Wacom Signature Pad (see page 730)

+ Using a StepOver Signature Pad (see page 731)

« eGK/KVK - Card Reader (see page 737)

+ Using Mobile Device Access (see page 745)

« Swapping Function of Mouse Buttons (e.g. When Using an Evoluent Mouse) (see page 754)
« Using Natural Scrolling (reverse Scrolling Direction) (see page 756)

« Connecting a Serial Barcode Scanner (see page 757)

+ Using DriveLock with IGEL Devices (see page 759)

+ Restricting the Mounting of Hotplug Storage Devices on IGEL Linux (see page 760)
« When to Use USB Redirection (see page 761)

+ How to Configure USB Access Control (see page 765)

« Issues with USB IDs in USB Devices Rules (see page 768)
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Monitor

« Touchscreen Calibration (see page 690)

« Touchscreen in Multimonitor Environment (see page 703)

Solving Hotplugging Issues with DisplayPort Monitors (see page 704)

No Sound When Using a DisplayPort Monitor (see page 705)

« Connecting Three DVI Monitors to UD7 with Passive DisplayPort Adapters (see page 707)
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Touchscreen Calibration

For setting up a touchscreen, you have to enable the touchscreen function and select a specific touchscreen driver.

(@ Theinitial configuration should take place with a mouse and keyboard connected to ensure that you can
open the setup and navigate within it.

To set up a touchscreen:

1. InIGEL Setup, go to User Interface > Input > Touchscreen.
2. Activate Enable touchscreen.
3. Select your touchscreen driver under Touchscreen type.

Depending on the selected driver, you have different configuration options. For further information, click the
appropriate link:

» EvTouch (USB) (see page 691)

» eGalax (see page 695)

» Elo Multitouch (USB) (see page 697)
+ Elo Singletouch (USB) (see page 699)
» TSHARC (USB) (see page 701)
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EvTouch (USB)

Supported Devices

Supported touch monitors and touchscreen controllers:

Vendor Product Name

0x16FD 0x5453 Reakin, TS2005F USB TouchController

0x7374 0x0001

Ox04E7 0x0020 Elo TouchSystems, Touchscreen Interface (2700)

0x1870 0x0001 Nexio Co., Ltd, iNexio Touchscreen controller

0x10F0 0x2002 Nexio Co., Ltd, iNexio Touchscreen controller

0x0664 0x0306 ET&T Technology Co., Ltd., Groovy Technology Corp. GTouch Touch
Screen

0x0664 0x0309 ET&T Technology Co., Ltd. Groovy Technology Corp. GTouch Touch

Screen
0x14C8 0x0003 Zytronic, Unknown device
0x1AC7  0x0001
0x0F92 0x0001
0x08F2 Ox00F4 Gotop Information Inc., Unknown device

0x08F2 0x00CE Gotop Information Inc., Unknown device
0x08F2 0x007F Gotop Information Inc., Super Q2 Tablet

O0xODFC 0x0001 GeneralTouch Technology Co., Ltd, Touchscreen
0x1391 0x1000 IdealTEK, Inc., URTC-1000

0x6615 0x0001 IRTOUCHSYSTEMS Co. Ltd., Touchscreen
0x595A 0x0001 IRTOUCHSYSTEMS Co. Ltd., Touchscreen

Ox0AFA Ox03E8
0x0637 0x0001
0x1234 0x5678 Brain Actuated Technologies, Unknown device
Ox16E3 OxF9OE9

0x0403 OxF9E9 Future Technology Devices International, Ltd, Unknown device
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Vendor Product Name

0x0596 0x0001 MicroTouch Systems, Inc., Touchscreen

0x134C 0x0004 PanJit International Inc., Touch Panel Controller

0x134C 0x0003 PanJit International Inc., Touch Panel Controller

0x134C 0x0002 PanJit International Inc., Touch Panel Controller

0x134C 0x0001 PanJit International Inc., Touch Panel Controller

0x1234 0x0002 Brain Actuated Technologies, Unknown device

0x1234 0x0001 Brain Actuated Technologies Unknown device

OXOEEF 0x0002 D-WAV Scientific Co., Ltd, Touchscreen Controller(Professional)
OxOEEF 0x0001 D-WAV Scientific Co., Ltd, eGalax TouchScreen

0x0123 0x0001
0x3823 0x0002
0x3823 0x0001

Setup Parameters

+ Touchscreen type
More

IGEL Setup > User Interface > Input > Touchscreen

> Touchscreen type userinterface.touchscreen.driver

+ Swap Xand Y values
More

IGEL Setup > User Interface > Input > Touchscreen

>Swap Xand Y values userinterface.touchscreen.swapxy enabled / disabled

+ Set driver specific defaults for resetting calibration values.

Calibration / Reset

Calibrating the touchscreen:
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1. Goto IGEL Setup > User Interface > Input > Touchscreen.
2. Set Touchscreen already calibrated to 'false’.
More

IGEL Setup > User Interface > Touchscreen

> Touchscreen already calibrated userinterface.touchscreen.calibrat enabled / disabled
ed

3. Set Touchscreen type to EvTouch (USB).
More

IGEL Setup > User Interface > Input > Touchscreen

> Touchscreen type userinterface.touchscreen.driver

4. Reboot the device or click IGEL Setup > Accessories > Touchscreen Calibration to use the IGEL
touchscreen calibration tool.

This will call the xinput_calibrator calibration tool which is located at /usr/bin/

xinput_calibrator . The calibration parameter will be saved in IGEL setup.

Hold-to-Right-Click Feature
To activate the feature:

1. Enable the option Emulate right button under User Interface > Input > Touchscreen.
More

IGEL Setup > User Interface > Input > Touchscreen

> Emulate right userinterface.touchscreen.emulatethirdbutton enabled / disabled
button

2. Setunder Right button timeout the time after which right-click is generated.
More

IGEL Setup > User Interface > Input > Touchscreen

> Right button userinterface.touchscreen.emulatethirdbuttonti Default: 1000
timeout meout msec
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Multimonitor

Multimonitor configuration is not supported.
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eGalax

Supported Devices

EETI eGalax eMPIA USB touchscreens.

Setup Parameters

+ Touchscreen type
More

IGEL Setup > User Interface > Input > Touchscreen

> Touchscreen type userinterface.touchscreen.driver

Calibration / Reset
Calibrating the touchscreen:

1. Go to IGEL Setup > User Interface > Input > Touchscreen.
2. Set Touchscreen already calibrated to 'false’.
More

IGEL Setup > User Interface > Touchscreen

> Touchscreen already calibrated userinterface.touchscreen.calibrat enabled / disabled
ed

3. Set Touchscreen type to eGalax.
More

IGEL Setup > User Interface > Input > Touchscreen

> Touchscreen type userinterface.touchscreen.driver

4. Reboot the device or click IGEL Setup > Accessories > Touchscreen Calibration to use the IGEL
touchscreen calibration tool.

This will call the proprietary EETI calibration tool, which is located at /usr/bin/eCalib .The

calibration parameter will be saved in /wfs/egtouch.d.
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Hold-to-Right-Click Feature
To activate the feature:

1. Enable the option Emulate right button under User Interface > Input > Touchscreen.
More

IGEL Setup > User Interface > Input > Touchscreen

> Emulate right userinterface.touchscreen.emulatethirdbutton enabled / disabled
button

2. Setunder Right button timeout the time after which right-click is generated.
More

IGEL Setup > User Interface > Input > Touchscreen

> Right button userinterface.touchscreen.emulatethirdbuttonti Default: 1000
timeout meout msec

Multimonitor

Multimonitor configuration is not supported.
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Elo Multitouch (USB)

Supported Devices

IntelliTouch Plus/iTouch Plus 2515-07(non HID), 2521 (HID), 2515-00(HID) PCAP 2 touch, 4 touch and 10 touch
controllers.

Setup Parameters
+ Touchscreen type

More

IGEL Setup > User Interface > Input > Touchscreen

> Touchscreen type userinterface.touchscreen.driver

Calibration / Reset
Calibrating the touchscreen:

1. Go to IGEL Setup > User Interface > Input > Touchscreen.
2. Set Touchscreen already calibrated to 'false’.
More

IGEL Setup > User Interface > Touchscreen

> Touchscreen already userinterface.touchscreen.calibrated enabled / disabled
calibrated

3. Set Touchscreen type to Elo Multitouch (USB).
More

IGEL Setup > User Interface > Input > Touchscreen

> Touchscreen type userinterface.touchscreen.driver

4. Reboot the device or click in IGEL Setup Accessories > Touchscreen Calibration to use the IGEL
touchscreen calibration tool.

This will call the proprietary ELO Multitouch calibration tool which is located at /etc/opt/
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elo-mt-usb/elova . The calibration parameter will be saved in /wfs/elo-usb.d/MT-

USBConfigData.

Hold-to-Right-Click Feature
To activate the feature:

1. Enable the option Emulate right button under User Interface > Input > Touchscreen.
More

IGEL Setup > User Interface > Input > Touchscreen

> Emulate right userinterface.touchscreen.emulatethirdbutton enabled /
button disabled

2. Set under Right button timeout the time after which right-click is generated.
More

IGEL Setup > User Interface > Input > Touchscreen

> Right button userinterface.touchscreen.emulatethirdbuttontimeou Default: 1000
timeout t msec

Multimonitor

Multiple ELO Multitouch (USB) touchscreens on a single IGEL device are supported. Calibration of the second ELO
Multitouch USB touchscreen can be done viacommand line by using: /etc/opt/elo-mt-usb/elova --

videoscreen=2 where 2 isthe second ELO Multitouch touchscreen connected to the IGEL device.

® To view a list of video and USB touchscreen devices available for calibration, use the command: /etc/

opt/elo-mt-usb/elova --viewdevices.
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Elo Singletouch (USB)

Supported Devices
Elo Smartset USB Controllers:

« IntelliTouch(R) 2701, 2700, 2600, 2500U

« CarrollTouch(R) 4500U, 4000U

+ Accutouch(R) 2216, 3000U, 2218

« Surface Capacitive 5020, 5010, 5000

+ Accoustic Pulse Recognition(APR) Smartset 7010
« Other Elo Smartset USB controllers

Setup Parameters
Touchscreen type

More

IGEL Setup > User Interface > Input > Touchscreen

> Touchscreen type userinterface.touchscreen.driver

Calibration / Reset
Calibrating the touchscreen:

1. Go to IGEL Setup > User Interface > Input > Touchscreen.
2. Set Touchscreen already calibrated to 'false’.
More

IGEL Setup > User Interface > Touchscreen

>Touchscreen already  userinterface.touchscreen.calibrated enabled / disabled
calibrated

3. Set Touchscreen type to Elo Singletouch (USB).
More

IGEL Setup > User Interface > Input > Touchscreen

> Touchscreen type userinterface.touchscreen.driver
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4. Reboot the device or click in IGEL Setup Accessories > Touchscreen Calibration to use the IGEL
touchscreen calibration tool.

This will call the proprietary ELO Singletouch calibration tool which is located at /etc/opt/
elo-usb/elova . The calibration parameter will be saved in /wfs/elo-usb.d/

USBConfigData .

Hold-to-Right-Click Feature

The feature is not supported.

Multimonitor

Multiple ELO Singletouch USB touchscreens on a single IGEL device are supported. Calibration of the second ELO
Singletouch USB touchscreen can be done via command line by using: /etc/opt/elo-usb/elova —--

videoscreen=2 where 2 is the second ELO Singletouch USB touchscreen connected to the IGEL device.

® Toview a list of video and USB touchscreen devices available for calibration, use the command: /etc/

opt/elo-usb/elova --viewdevices.
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TSHARC (USB)

Supported Devices

Hampshire TSHARC USB touchscreens.

Setup Parameters

+ Touchscreen type
More

IGEL Setup > User Interface > Input > Touchscreen

> Touchscreen type userinterface.touchscreen.driver

Calibration / Reset
Calibrating the touchscreen:

1. Go to IGEL Setup > User Interface > Input > Touchscreen.
2. Disable Touchscreen already calibrated.
More

IGEL Setup > User Interface > Touchscreen

>Touchscreen already  userinterface.touchscreen.calibrated enabled / disabled
calibrated

3. Set Touchscreen type to TSharc.
More

IGEL Setup > User Interface > Input > Touchscreen

> Touchscreen type userinterface.touchscreen.driver

4. Reboot the device or click IGEL Setup > Accessories > Touchscreen Calibration to use the IGEL
touchscreen calibration tool.

This will call the proprietary Hampshire calibration tool, which is located at /usr/bin/tscal.

The calibration parameter will be savedin /wfs/tsharc.d.
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Hold-to-Right-Click Feature
To activate the feature:

1. Enable the option Emulate right button under User Interface > Input > Touchscreen.
More

IGEL Setup > User Interface > Input > Touchscreen

> Emulate right userinterface.touchscreen.emulatethirdbutton enabled /
button disabled

2. Setunder Right button timeout the time after which right-click is generated.
More

IGEL Setup > User interface > Input > Touchscreen

> Right button userinterface.touchscreen.emulatethirdbuttontimeou Default: 1000
timeout t msec

Multimonitor

Multimonitor configuration is not supported.
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Touchscreen in Multimonitor Environment

Symptom

You are using a touchscreen in a multimonitor environment. In this case, it can happen that the touchscreen
coordinate matrix expands over both monitors, with the result that the monitor interprets the touch pointin a
wrong way.

Problem

You touch the touchscreen in its center and the cursor moves between the two screens.

Solution

To avoid the unrequested expansion of the touchscreen matrix you have to select the correct touchscreen
connection type in the setup:

1. Click User Interface > Input > Touchscreen in the IGEL setup.
2. Select the correct connection type under Multi Monitor > Touchscreen Monitor.
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Solving Hotplugging Issues with DisplayPort Monitors

Symptom

On IGEL Linux, in a dual view configuration, the following problem occurs: If a monitor connected via DisplayPort is
only switched on after booting the device, it will remain black.

Problem

The DisplayPort standard allows for a powered-off monitor to be undetectable by the graphics card.

Solution

The following checks whether a monitor contained in the configuration is missing (i.e. powered off) and makes it
usable as soon as it appears (i.e. is powered on):

1. Ifyou are using IGEL Linux 5, make sure you are running version 5.10.410 or newer.
If you are using IGEL Linux 10 you do not need to upgrade.
2. In Setup, go to System > Registry > Parameter >

session.user_display%.options.enhanced_hotplug

3. Make sure the parameterissetto true (default).

() Thereis another setting you can use if you do not want IGEL Linux to change the display settings every
time a DisplayPort monitor is switched on/off:
« Go to System > Registry > Parameter >

s essions.user_display%.options.disable_hotplug
» Setitto DP_Disconnect_Only.
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No Sound When Using a DisplayPort Monitor

Symptom

You do not hear any sound from your IGEL UD5 or UD6 device. You are using a monitor connected via DisplayPort.

Problem

Some DisplayPort monitors misleadingly report support for display audio although they do not have loudspeakers.
Therefore IGEL Linux will try to play back audio via the monitor.

Solution

1. Right-click on the loudspeaker icon in the panel and open Sound Preferences.
2. Inthe Output tab select Speakers [ Built-in Audio.

Sound Preferences A
Output velume: 1) L_J ) T Mute
100%
Output | Input = Applications
Play sound through Settings for Speakers
HDMI [ DisplayPort 2 Balance: ' -
Built+4n Audio Left Right
1 Speakers Fade: ’ L
[ Built4n Audio Rear Front
ﬁ Analog Output Subwoofer: C
Built-n Audio Minimum Maximum
Test Sound |
| *® Close

3. Click Test Sound to test the new setting. Check if you hear a voice saying "Front Left" and "Front
Right" on the device speakers.
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Connecting Three DVI Monitors to UD7 with Passive DisplayPort Adapters

Problem

When three DVI monitors are connected to a UD7 thin client over passive DisplayPort adapters, only one or two
monitors are detected.

Solution

() Thissolution is only persistent if energy saving is switched off.

1. Open the thin client's Setup.
2. Go to System > Registry > x > xserver0 > force_reconfig (Registry key:
x.xserver0@.force_reconfig)and setthe value to never.

3. Click Ok to save the setting and close the Setup.
4, Restart the device.
All three monitors should be detected.
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Webcam Redirection and Optimization

Overview

This article provides an overview and best-practice recommendations for the use of webcams on IGEL OS within
remote sessions such as Citrix, VMware Horizon, and RDP.

In general, webcam support on IGEL OS can be divided into three categories:

Unoptimized

Optimization type 1

Optimization type 2

The raw data from the webcam is sent over the network via USB
redirection. The raw data from the webcam is highly affected by
network latency between the client and the server and takes up
a lot of bandwidth, requires the correct drivers on the server-
side, increases the server's CPU and RAM load.

Example: Native USB Redirection for RDP sessions

In this case, the video and audio data is compressed on the
client side. This optimization type makes the webcam stream
far more efficient and reliable, although the data stream must
still pass via the VDI server in addition to the cloud servers of
the particular communication software (Teams, Zoom, etc.).

Examples: HDX RealTime Webcam redirection for Citrix
sessions, Real Time Audio Video (RTAV) for VMware Horizon
sessions

In this case, the video and audio data is also compressed on the
client side. However, unlike type 1, this optimization type
offloads the data stream from the VDI server and sends it
directly to Teams/Zoom/etc. in the cloud, i.e. "single-hop". This
allows for the best performance and also removes the server
load, but relies on the correct optimization pack being present
on the client and is specific to each communication suite. It may
also require a more complex network configuration because the
endpoint has to be able to communicate directly with the
communication cloud server and not only the VDI server.

Examples: Microsoft Teams optimization and Zoom Media
plugin for Citrix sessions

& Inthe case of optimization type 1 or type 2, it isimportant to ensure that the agent/component on the
server side is installed and is compatible with the client-side version. For details on the latter, see the
"Component Versions" section of the IGEL OS release notes.
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General Recommendations

For optimal performance of webcams on IGEL OS, the correct optimization pack has to be enabled for the specific
application, e.g. Microsoft Teams optimization, Zoom Media plugin, Cisco Webex Teams VDI, etc. However,
optimization packs are not available for all session types.

© USB Redirection

If no optimization pack exists for your session type or the optimization pack available does not function
correctly, you can try to use USB redirection - either the Native USB Redirection or the less frequently
used Fabulatech USB Redirection (not both together), - but ONLY as a LAST RESORT, when no other
solution is possible.
In general, where USB redirection is available as an option inside the VDI session options, it should be
disabled for the webcam devices.
+ Set Default rule to Deny
+ OR, if the Default rule is Allow (NOT recommended), go to Device Rules and add
Deny rules for the specific Vendor ID and Product ID of the webcam.
How to Find Out Vendor and Product IDs

To get Vendor/Product IDs, use the command lsusb in the terminal. You can also use the

System Information tool, see Using “System Information” Function.

€) v Native USB redirection

Default rule £ | Alow

Class Rules Add

Rule Class ID Rule a ‘ Deny

VendorlD €} 046d

ProductiD €} 0825

Device Rules Name Policy Rule

Rule Vendor ID ProductID

This is necessary because USB redirection will block the webcam from being correctly optimized (if
optimization is possible).

& Do not forget to check and adjust settings and policies on the server side. Otherwise, your webcam may
not work, even if all settings in the IGEL OS are configured correctly.

@ Always check the IGEL OS release notes for specific remarks, especially in the case of private builds. Always
try to use the latest firmware, see IGEL download server®®,

() Incertain cases, some of the settings described later on in this article may not be visible even though you
have selected the correct firmware version for the profile in the UMS. In this case, update the UMS to the
latest version.

58 https://www.igel.com/software-downloads/workspace-edition/
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Citrix

Option 1: Unified Communications (Best Choice)

Microsoft Teams Optimization

Zoom Media Plugin

Path: Sessions > Citrix > Citrix Global > Unified
Communications > VDI Solutions > Microsoft Teams
optimization (see page 708) (enabled by default)

+ Available as of IGEL OS version 11.04.100.

« Depends on the version of Citrix Workspace App used.
For best results, the latest version should be preferred.
For the Citrix Workspace App versions included,
see IGEL OS release notes.

For server-side requirements for Microsoft
Teams optimization, see Microsoft Teams installation®.

To troubleshoot Microsoft Teams optimization in Citrix,
see:

+ Troubleshooting HDX Optimization for Microsoft
Teams®
« Peripherals in Microsoft Teams®!

Path: Sessions > Citrix > Citrix Global > Unified
Communications > VDI Solutions > Zoom Media
Plugin (see page 708)

+ Available as of IGEL OS version 11.04.100
+ Forthe Zoom Media Plugin versions included, see IGEL
OS release notes.

For more information about Zoom Media Plugin,
including server-side requirements, see Getting started
with VDI®,

59 https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/multimedia/opt-ms-teams.html#microsoft-teams-installation

60 https://support.citrix.com/article/CTX253754

61 https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/multimedia/opt-ms-teams.html#peripherals-in-microsoft-teams
62 https://support.zoom.us/hc/en-us/articles/360031096531-Getting-Started-with-VDI

IGEL OS Articles

710/823


https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/multimedia/opt-ms-teams.html#microsoft-teams-installation
https://support.citrix.com/article/CTX253754
https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/multimedia/opt-ms-teams.html#peripherals-in-microsoft-teams
https://support.zoom.us/hc/en-us/articles/360031096531-Getting-Started-with-VDI
https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/multimedia/opt-ms-teams.html#microsoft-teams-installation
https://support.citrix.com/article/CTX253754
https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/multimedia/opt-ms-teams.html#peripherals-in-microsoft-teams
https://support.zoom.us/hc/en-us/articles/360031096531-Getting-Started-with-VDI

Devices

Cisco Webex Meetings [ Teams VDI

Cisco JVDI Client

Skype for Business

e

IGE

Path: Sessions > Citrix > Citrix Global > Unified
Communications > Cisco > Cisco Webex Meetings VDI
or Cisco Webex Teams VDI

« Available as of IGEL OS version 11.04.100
+ For the Cisco Webex Meetings / Teams VDI versions
included, see IGEL OS release notes.

For more information about Cisco Webex products for
VDI, including supported environments, see:

« Cisco Webex Meetings Virtual Desktop Software®
« Overview of Webex Teams for VDI®*

Path: Sessions > Citrix > Citrix Global > Unified
Communications > Cisco > Cisco JVDI client

« Forthe Cisco JVDI client versions included, see IGEL OS
release notes.

For more information about Cisco JVDI client, see
Deployment and Installation Guide for Cisco Jabber
Softphone for VDI,

Path: Sessions > Citrix > Citrix Global > Unified
Communications > Skype for Business > HDX
RealTime Media Engine (enabled by default)

 Skype for Business webcam redirection relies on the Citrix
HDX Realtime Media Engine (client-side counterpart to
the Lync Optimization Pack).

+ This setting is the same as Sessions > Citrix > Citrix
Global > HDX Multimedia > HDX RealTime Media
Engine.

© IMPORTANT: Skype for Business Online will be
retired by Microsoft on July 31, 2021%. After this,
it will no longer be available, and Microsoft
Teams must be used instead.

63 https://help.webex.com/en-us/nfjsqzbb/Cisco-Webex-Meetings-Virtual-Desktop-Software
64 https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cloudCollaboration/wbxt/vdi/wbx-teams-vdi-deployment-guide/wbx-teams-vdi-

deployment-wbx-calling-EFT_chapter_00.html

65 https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/jvdi/12_9/dig/jvdi_b_deploy-install-jvdi-12-9/jvdi_b_deploy-install-

jvdi-12-9_chapter_01.html

66 https://techcommunity.microsoft.com/t5/microsoft-teams-blog/skype-for-business-online-to-be-retired-in-2021/ba-p/777833
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Option 2: HDX RealTime Webcam Redirection (Should Only Be Used If Optimization Packs under
Option 1 Are Not Applicable)

For other VDI programs which require the use of a webcam (e.g. the browser), HDX RealTime Webcam
redirection can be used. This option enables the compression of audio and video on the client side, which is
redirected to an HDX virtual webcam on the server side. It also allows for the resolution of the webcam to be
defined manually.

& Only One Option at a Time for a Particular Device

+ HDX RealTime Webcam redirection and HDX RealTime Media Engine should not be
enabled at the same time.

« If you use HDX or an application-specific optimization pack (e.g. Zoom Media
plugin), Native USB Redirection / Fabulatech USB Redirection should be disabled.

Settings on the Server Side Settings on the Client Side
The following policy settings must be enabled: 1. Go to Sessions > Citrix > Citrix Global > HDX
. . . Multimedia.
) Mgltlmedla co‘nferer?cmg‘ (enabled by default) 2. Enable Multimedia redirection (enabled by
+ Windows Media Redirection (enabled by default)

default) 3. Enable HDX RealTime Webcam redirection.
For details, see https://docs.citrix.com/en-us/ 4. Configure the webcam resolution, 352 x 288 by
citrix-virtual-apps-desktops/multimedia/ default, and other settings if required.

webcam-compression.html. .
A Certain webcam models may only

support specific resolutions. For more
information, see How to Configure
Webcam settings When Webcams are
Not Redirected Through HDX Real-
Time®'.

5. If the USB redirection is enabled (not
recommended), use Device Rules to forbid the
forwarding of the webcam via USB redirection.
See the section above (see page 709).

Dependencies

+ HDX RealTime Webcam Redirection is only supported for 32-bit applications on the server side
(limitation of Citrix Receiver/Workspace App for Linux). Deploy a 32-bit browser to verify the
webcam redirection online, e.g. www.webcamtests.com®®. See also https://support.citrix.com/
article/CTX223199.

67 https://support.citrix.com/article/CTX134772
68 http://www.webcamtests.com
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+ Webcam redirection generally works with or without HDX RealTime Media Engine (RTME).
However, to avoid conflicts and for the better performance of webcam redirection, disabling RTME
(enabled by default) is highly recommended.

+ Webcam usage is limited to one application. For instance, when Skype is running with a webcam
and GoToMeeting is started, you have to exit Skype to use the webcam with GoToMeeting.

Supported Video Conferencing Applications

+ Adobe Connect

+ Cisco Webex and Webex for Teams (Give preference to the optimization pack for Cisco Webex
Meetings / Teams VDI instead, see above (see page 710))

+ GoToMeeting

+ Google Hangouts and Hangouts Meet

+ IBM Sametime

+ Microsoft Skype for Business 2015, 2016, and 2019 (Give preference to the optimization pack
for Skype for Business instead, see above (see page 710))

+ Microsoft Lync 2010 and 2013

+ Microsoft Skype 7 or higher

+ Media Foundation-based video applications on Windows 8.x or higher and Windows Server 2012
R2 and higher

© HDXRealTime Webcam Redirection is NOT supported for Microsoft Teams. Use Microsoft Teams
optimization instead, see above (see page 710).

@ DoesWebcam Audio Work but Video Doesn't?

> Try to increase the graphics memory in the BIOS to 512 MB.

For more detailed information about HDX RealTime Webcam, see:

 https://support.citrix.com/article/CTX132764
« https://docs.citrix.com/en-us/citrix-workspace-app-for-linux/configure-xenapp.html#webcams
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VMware Horizon

Option 1 (Best Choice)

Zoom Media Plugin Path: System > Registry > vmware > view > vdzoom >
enable

+ Available as of IGEL OS version 11.04.200
+ Forthe Zoom Media Plugin versions included, see IGEL OS
release notes.

& Zoom Media Plugin will NOT function if you
enable HTML5 multimedia redirection (System
> Registry > vmware > view > html5mmr,
disabled by default).

For more information about Zoom Media Plugin,
including server-side requirements, see Getting started
with VDI®,

Cisco Webex Teams VDI Path: Sessions > Horizon Client > Horizon Client Global
> Unified Communications > Cisco > Cisco Webex Teams
VDI (see page 708)

« Available as of IGEL OS version 11.04.100
+ Forthe Cisco Webex Teams VDI versions included, see IGEL
OS release notes.

For more information, see Overview of Webex Teams for
VDI™,

Cisco JVDI Client Path: Sessions > Horizon Client > Horizon Client
Global> Unified Communications > Cisco > Cisco JVDI
client (see page 708)

» Forthe Cisco JVDI client versions included, see IGEL OS
release notes.

For more information about Cisco JVDI client, see
Deployment and Installation Guide for Cisco Jabber
Softphone for VDI™,

69 https://support.zoom.us/hc/en-us/articles/360031096531-Getting-Started-with-VDI

70 https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cloudCollaboration/wbxt/vdi/wbx-teams-vdi-deployment-guide/wbx-teams-vdi-
deployment-wbx-calling-EFT_chapter_00.html

71 https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/jvdi/12_9/dig/jvdi_b_deploy-install-jvdi-12-9/jvdi_b_deploy-install-
jvdi-12-9_chapter_01.html
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Skype for Business Path: Sessions > Horizon Client > Horizon Client Global
> Unified Communications > Skype for Business >
Virtualization Pack Skype for Business (enabled by
default)

© IMPORTANT: Skype for Business Online will be
retired by Microsoft on July 31, 20217, After this, it
will no longer be available, and Microsoft Teams
must be used instead.

Option 2: Real-Time Audio-Video (RTAV)

Real-time Audio-Video (RTAV) is the optimization pack for audio and video calls inside VMware Horizon sessions.
RTAV compresses audio and video on the client side and sends it to the Horizon server, where a VMware Virtual
Webcam instance is created.

(@ Like for Citrix sessions, USB redirection should be disabled if RTAV is to be used.

» Enable Sessions > Horizon Client > Horizon Client Global > Multimedia > Real Time Audio Video (RTAV).

& RTAVisonly available when connecting via PColP or VMware Blast.

& Note that only one webcam will be redirected (limitation of Horizon client for Linux). If multiple webcams
are available on the client, the preferred webcam can be defined in the IGEL Setup under System >
Registry > vmware.view.rtav-webcam-id. For details, see Select a Preferred Webcam or Microphone on
a Linux Client System,

For more information about RTAV, see Configuring Real-Time Audio-Video™,

() Microsoft Teams

Microsoft Teams can be used with RTAV in "Fallback Mode". This configuration is not an optimal solution
as the data makes multiple hops between the Horizon client, server, and Microsoft Teams server. For more
information, see Configuring Microsoft Teams with Real-Time Audio-Video™.

Microsoft Teams media optimization (single-hop or "Optimized Mode") in Horizon sessions is currently
only supported with the Horizon client for Windows 10 in conjunction with Horizon 8 (2006). For more
information, see Microsoft Teams Optimization with VMware Horizon®,

72 https://techcommunity.microsoft.com/t5/microsoft-teams-blog/skype-for-business-online-to-be-retired-in-2021/ba-p/777833

73 https://docs.vmware.com/en/VMware-Horizon-7/7.9/horizon-remote-desktop-features/GUID-C8C17975-AA1E-4378-A305-00E02FF93201.html
74 https://docs.vmware.com/en/VMware-Horizon-7/7.6/horizon-remote-desktop-features/GUID-D6FD6AD1-D326-4387-A6F0-152C7D844AA0.html
75 https://docs.vmware.com/en/VMware-Horizon/2006/horizon-remote-desktop-features/GUID-E64B3E85-BA1E-4FB7-9DB4-FF9B7B7A892C.html
76 https://techzone.vmware.com/resource/microsoft-teams-optimization-vmware-horizon
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RDP

There is currently no optimization available for webcam redirection in RDP sessions. It may be possible to redirect
webcams via USB redirection, e.g. Native USB Redirection. However, each webcam has to be individually tested
forif it functions with this method. It often depends on the webcam itself and its Windows driver whether they can
cope with the higher latencies that occur with USB redirections compared to the real USB bus.

(®» Insomesituations, webcams may not be redirected correctly due to network latency, bandwidth
limitations, or the lack of compatible drivers on the server.

© Unoptimized Webcam Support

+ Note that because USB redirection is not designed for redirecting video devices, the
bandwidth usage and server CPU load may increase significantly.

« Forthisreason, itis recommended to use webcams that output directly H.264 or H.265
streams, and not MJPEG, in order to reduce the data volume.

Native USB Redirection

1. Enable Sessions > RDP > RDP Global > Native USB Redirection > Enable native USB redirection.

2. Set the Default rule to Deny.
3. Under Device Rules, add the specific Vendor ID and Product ID of the device to be redirected.

() Getting USB Device Information

To find out the Class ID, Subclass ID, Vendor ID and Product ID of the connected USB device, you
can use the System Information tool. For further information, see Using “System Information”

Function.
System Information example:
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Devic

Information View Help
(:) Refresh Generate Report

g_ Computer
@ Summary
@ Operating System
Security
@ Kernel Modules
@ Boots

m Languages

= filesystems

@ Display

[z] Environment Variables

Memoary Usage

Devices
=] system DMI

@ Monitors

&3 Interfaces
. | .
Done.

es - USB Devices - System Information

|_|:| Copy to Clipboard | Synchronize

il 001:001 | Linux |2.0 root hub

002:001 1.1 root hub

() 002:002 [WMware Virtual Mouse

.
&) 002:004 logitech 960 Headset

Device Information
Product [0x0002] 2.0 root hub
Vendor [0x1d6b] Linux Foundation
 Linux|
Device EHCI Host Controller
Manufacturer Linux 5.12.19 ehci_hcd
[ Linux |
Max Current 0 mA
USB Version 2.00

Speed 480 Mbys

Alternatively, you can use the command lsusb (or lsusb | grep -i [search term])

in the terminal.
Example for lsusb :

Local Terminal

Fle

Edit

View Terminal

Tabs

Help

IGEL OS Articles

root@ITCOO5056930CAD:~# 1lsusb | grep -1 logitech
ID 046d:0a45 Inc.

Bus 002 Device 004:
root@ITCOO5056930CAD: ~# [

On RDS servers, the following may be helpful:

» Disable the setting Do not allow supported Plug and Play device redirection under Computer
Configuration > Administrative Templates > Windows Components > Remote Desktop Services >
Remote Desktop Session Host > Device and Resource Redirection.

For Microphone (e.g. Headset)

» Enable Sessions > RDP > RDP Global > Mapping > Audio > Audio recording.

960 Headset
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@ Custom Partition as a Local Alternative

You can also use Custom Partitions (see page 546) for Microsoft Teams or Zoom, e.g. in order to save backend
resources, which may be a good choice in slow RDP backends. The Custom Partition is locally installed but
is easy to access in the remote session.
« For details, see Microsoft Teams as a Custom Partition (see page 608), Zoom as a Custom
Partition (see page 588).
« Contact the IGEL Support Team to get support for the deployment of Custom Partitions.

For how to open up the webcam in Windows 10, see Open the Camera in Windows 107",

For a video overview on using webcams and other USB devices in remote sessions, see:

English
Sorry, the widget is not supported in this export.
But you can reach it using the following URL:
https://www.youtube.com/watch?v=PYCU1AEfS-g&feature=youtu.be
German

Sorry, the widget is not supported in this export.
But you can reach it using the following URL:

https://www.youtube.com/watch?v=caNhFib5cuA&feature=youtu.be

77 https://support.microsoft.com/en-us/windows/open-the-camera-in-windows-10-8da044ed-c4a8-2fb4-
da51-232362e4126d#:~:text=To%200pen%20up%20your%20webcam,Let%20apps%20use%20my%20camera.
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Webcam Information

If you are running a device with IGEL Linux version 5.3.100 or higher, you can configure and test a webcam using a
built-in tool. This tool is called Webcam Information.

> To configure a starter for Webcam Information, open the IGEL Setup and go to Accessories > Webcam
Information.

To determine and change the width, height, and frame rate of your webcam:

1. Start the Webcam Information tool.
The following values are shown:
+ Width: Width of the image in pixels
+ Height: Height of the image in pixels
+ Rate: Frame rate in fps (frames per second). Example: 1/30 means 30 single images per
second.

Webcam Information

D UWVC Camera (046d:0825)

w15 ||

‘ Test H ® Close ‘

2. Click on on one of the fields to change the value. In doing so, the supported values are shown.
3. Click Test.

Width Height ;480 Rate

” Test ® Close ‘

The video image generated with the current settings is shown.
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Webcam Test

To check if the webcam is working in a session (e.g. via Citrix HDX webcam redirection), open a
browser in the session and go to https://www.onlinemictest.com/webcam-test/.
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Bluetooth Tool

As of IGEL Linux version 5.10.100, you can connect or disconnect Bluetooth devices conveniently using the

Bluetooth tool. The Bluetooth tool supports the following pairing methods:

« Pairing with PIN entry (for most keyboards)

« Pairing with fixed PIN (for most headsets, mice or GPS devices)
+ Pairing with automatic PIN allocation

For further information, please refer to the manual chapter Bluetooth Tool.

In the following example, we will connect a Bluetooth device with PIN entry:

1. Make sure that the following preconditions are met:

+ A Bluetooth USB adapter is connected to your device.
« The Bluetooth device is ready.

« The options Setup > Devices > Activate Bluetooth and Setup > Devices > Tray Icon are

enabled.

2. Launch the Bluetooth Tool from the IGEL menu via System > Bluetooth Tool or another

launch option, if available.

The Device search dialog will be shown. After a few seconds, the Bluetooth devices found by the

device are displayed.

Bluetooth

— I“ x

Devices

= lbyone Keyboard

Type
Keyboard

‘¥ Searching for devices...

PIM Cptions

‘ ® cancel ‘ » Forward
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3. Highlight the desired Bluetooth device and click on Forward.

IGEL

Bluetooth

Device search

. {

Devices

Tvpe

— 1lbyone Keyboard

Keyboard

# Searching for devices...

PIM Cptions

‘ ® cancel

‘ ®» Forward \

A PIN will be shown on the Device setup dialog.
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Device setup

4. Enter the PIN into your Bluetooth device.
If everything went well, the status of the connection will be shown.
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Setup summary

5. Click on Close.

Your Bluetooth device is ready for use. By right-clicking the a icon in the system tray, you can
start the Bluetooth tool again, e.g. to pair another Bluetooth device or to unpair a device.
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How to Deploy a Jabra Xpress Package

Jabra Xpress is a solution for the remote mass-deployment of Jabra USB headsets that enables creating and
deploying packages containing settings, firmware updates, etc. for Jabra devices. For more information, see
https://www.jabra.com/supportpages/jabra-xpress#/.

Deployment of a Jabra Xpress package involves the following steps:

1. Making the package available for download over the FTP(S) or HTTP(S) protocol (see page 725)
2. Configuring the source URL in the IGEL Setup (see page 725)
3. Triggering the deployment process in the UMS (see page 726)

Making the Jabra Xpress Package Available for Download

1. Create a package on the Jabra Xpress portal and download it.
2. Place the ZIP archive onto your FTP(S) or HTTP(S) server.
If you want to use the UMS as a source location, register the ZIP archive in the UMS under Files
> New file. For details, see Registering a File on the UMS Server.
Jobs (0)
v B Files (1)
B background.
» Universal Firmm
» @ Search History
[T Recycle Bin (6)
UMsS

Access control

[ Paste

Logging: Messages
[ New Diractar

B Newfile

Messages

Time

Configuring the Source URL
Now you have to configure the download location:

1. Inthe IGEL Setup or in the configuration dialog in the UMS, go to Devices > Unified
Communications > Jabra > Jabra Xpress.

2. Under Device Dashboard URL, you can optionally specify the URL of the dashboard server of the
Jabra device.

3. Under Package, enter the file name of the Jabra Xpress package.

Example: xpress_package_20190109_144111.zip.

IGEL OS Articles 725/823


https://www.jabra.com/supportpages/jabra-xpress#/

Devices 1
S

IGE

A

r

4. Under Source URL, specify the URL to the directory containing the Xpress package.
Example: https://172.30.92.5:8443/ums_filetransfer/ ifyou usethe UMS asthe
source location.

5. Disable Check SSL certificate if you use the UMS as the source for your Xpress package or a self-

signed certificate.
6. Under User name, specify the user name for accessing the Xpress package that resides under the

Source URL.
7. Under Password, specify the password for accessing the Xpress package that resides under the

Source URL.

s P Unified Communications ™ Jabra ™ Jabra Xpress

Configuration Device Dashboard URL

Xpress Package

Package €) xpress_package_20190109_144111zip

User Interface Source URL s:172.3 5:8443lums_filetransfer/
Network ) Check SSL certificate

Devices User name
» I Printer
» Il Storage Devices
B Biuetooth
B USB Access Control
v [ Unified Communications
v [ Jabra
B Jabra Xpress
ﬁ Options

Password

Apply and send to device

8. Save the settings.

Triggering the Deployment Process
Finally, you have to trigger the deployment process. There are two possibilities:

» Inthe UMS, go to Devices > [context menu of the device] > Specific Device Command and select Deploy Jabra
Xpress Package.
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Specific Device Command

IGEL Universal Management Suite 6
Profiles (10) - techdoc_RD1

Master Profiles (1)

Select specific device command

Template Keys and Grot ") Edit Configuration Deploy Jabra Xpress package

® Rename
Delete

!) Clear "Configuration Change Status’ flag

Eirmware Customization S1arm Login enterprise iIauncner

¥ B® Augsburg (1)
C techdoc_RD1 25| Access control

Mobile Devices (0) db Cut
Shared Workplace User |—;-_,I Copy

( ﬂ Paste

Jobs (0) Shadow

Files (1) Secure Terminal

Universal Firmware Upd Suspend

Search History (1) Shutdown

Recycle Bin (6) Wake up
Reboot
Update & snapshot commands
Other commands
Specific Device Command

Take over settings from ...

OR

» Inthe UMS, go to Jobs > New Scheduled Job and select Deploy Jabra Xpress package as Command. Assign
the job to the necessary devices, see Assignment.

IGEL Universal Management Suite 6 New Scheduled Job
Profiles (10) Details
Master Profil 1)

. Name
X Template Ke nd Groups (0)

Firmware Customizations (0) omunans STULEUE NNCS PRI
B Devices (1) Execution time 17:00 Start date v Enabled
¥ F® Augsburg (1) Comment
- techdoc_RD1
Mobile Devices (0) Options
Shared Workplace Users v Log results Retry next boot
3) Max. Threa Delay

Jobs (0) Timeout
B Files (1) Job-nfo

Universal Fi
® Search Hist

Job ID

B Access control

Next Execution Jun 8, 2020 5:00 PM

O Paste e

Logging: Messages

| 2 New Directory
£ New Scheduled Job

() Notethatitis not possible to reverse the deployment process, e.g. to remove an Xpress package from the
Jabra device. If you require the previous settings, you have to configure and deploy a new Jabra Xpress
package with the old headset firmware and configuration.
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See also Jabra Xpress in the IGEL OS reference manual.
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Connecting Signature Pads

You can connect signature pads from the following manufacturers:

» StepOver;
« signotec.

» Toenable them, go to Setup > User Interface > Input > Signature Pad.

> To configure a serial connection in order to be able to use USB signature pads from these manufacturers,
proceed as follows:

1. Enable COM port mapping under:
« Setup > Sessions > Citrix > Citrix Global > Mapping > COM Ports for Citrix sessions;
+ Setup > Sessions > RDP > RDP Global > Mapping > COM Ports for RDP sessions.
2. Clickon Add [+].
3. Click Detect Devices... .
4. Select your device.
Your signature pad can now be used.
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Using a Kofax / Wacom Signature Pad

You can use a Kofax / Wacom signature pad in Citrix sessions using the Kofax SPVC signature pad channel. The
Virtual Serial Sign Pad method is no longer supported.

On the Device

1. Connect the signature pad to one of the device's USB ports.
Go to Sessions > Citrix > Citrix Global > Mapping > Device Support.

3. Enable Kofax SPVC signature pad channel.

channel for dictation

1ature pad channel

Search v channel

On the VDI Server (Windows)

> Install the required software from Kofax / Wacom.
The driver contained in this software will listen for signature pads on a virtual channel. Applications such as

SignDoc will be able to use the signature pad.
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Using a StepOver Signature Pad

You can use a StepOver signature pad in Citrix and RDP sessions. There are two different means to achieve this:

« With StepOver TCP Client (see page 732)
+ With StepOver Signature Pad Channel (see page 736)

Only one of the methods can be used at a given time. Which of the two you need is determined by your applications
on the server side.

See also StepOver Signature Pads Compatibility.
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With StepOver TCP Client

On the Device

> Connect the signature pad to one of the device's USB ports.
» Go to User Interface > Input > Signature Pad in IGEL Setup.
» Enable StepOver TCP Client.

> Modify Listening TCP Port if needed. (Default: 8888)

€) (V] Enable Stepover TCP Client

Listening TCP port 5288

[ ] Enable signotec WCOM Dasmon

() Youcan check whether the StepOver TCP Client is running on the device by entering the following in a
localterminal: ps waux | grep sotcp .Theresultshould containan sotcp process.

On the VDI Server (Windows)

» Locatethe sodc.exe program on the server. It is the part of StepOver eSignature Office and can be found in
[Your Program Files Directory]\StepOver\eSignatureOffice [version]\driver\.

> If you are using a non-standard TCP port, changeitinthe config.in1i file located in the same directory.
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) Driver-Uninskall

. encrypk

2}25/2015 4:38 PM
2}25/2015 2:17 PM

File folder
File folder

a config.ini

|| hidkeys.imp

|| SO Capture. di
& sodc.exe

|| sodc.exe.manil
%) S0OPad. dI

|%| SopadComn.dl
|%| soServer.di

|%| StepCrversigna

18)2015 1:45 PM
A bytes

|%| nsUiCompiler.dll

{2015 1:45 PM

Configuration settings

0/10/2014 3:22 PM IMP File

12/2/2014 8:37 &AM Application extension

) nsUiDriver,dll = e
— |B config.ini - Notepad _ O

File Edit Format Wiew Help

rReplace the IF/Port with the one from your Client .|
[server]
Tp=172.30.91. 206
I
mu!e=cunnect

Togrile="cC:\templogshsoserver. Tog"
logeEnabTled=1

recpen=1

1D?LenMax=2D48

poTTingInt=1

1] | v 4

» Execute sodc.exe .The StepOver Pad Test window will open. Use its buttons to search and select your
signature pad and try writing into the provided field.
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StepOver Pad Test Ed

— Signaturgerat

[erate-Typ: HID: StepOwver GmbH
Senennummer:  0F1126701
Firrware werzion;

Pad auswahlen...

— Unterschriftenerfazzung

Step - Over

Search completed!

% StepOver GmbH (071126101)

Info Presz QK 1o zave the settings of this pad.

Search for zenial devices

Yersion 5.5
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StepOver Pad Test | x| |

— Signaturgerat

Gerate-Typ:
Senennummer;
Firrnwware version:

HID: StepOver GmbH
071126101

Pad auzwahlen...

— Unterzchrftenerfazzung

Test ztarten
E Wiederholen
Stop
Irfa... | Schlieben

The status LED of the pad will turn to green when the connection is successful. The signature pad is now ready to be

used with enabled applications such as StepOver eSignature Office.
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With StepOver Signature Pad Channel

StepOver signature pad channel is applicable to Citrix sessions only. It activates StepOver Citrix Client and
enables the redirection via Citrix virtual channel.

On the Device
» In the IGEL Setu p, go to Sessions > Citrix > Citrix Global > Mapping > Device Support.

> Enable StepOver signature pad channel and save the changes.

On the Server

> Du ring the installation of the StepOver software, select the option "Citrix".
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eGK/KVK - Card Reader

The IGEL Linux thin clients support the reading of German electronic health cards (eGK), health insurance cards
(KVK) and the German card for allied health professions (HBA) by a variety of readers connected via RDP or ICA.
Configuration and functionality vary according to the reader type.

The following tested solutions are available:

Reader Port Client/server connection
Cherry G80-1502 Serial COM port mapping

Cherry ST-2052 USB Smartcard mapping

Cherry ST-1503 and Cherry G87-1504 UsB Cherry Virtual Channel (IGEL

Linux v5 only)

SICCT via LAN provided by the Cherry USB2LAN
proxy (IGEL Linux version 5.12.100 and IGEL
Linux version 10.03.100 onwards)

ORGA 910/920 M usB COM port mapping
ORGA 6041 L eGK eHealth-BCS usB COM port mapping
SCM Microsystems eHealth200 usB Smartcard mapping
SCM Microsystems eHealth500 usB COM port mapping
celectronic CARD STAR /medic2 Serial COM port mapping
celectronic CARD STAR /memo3 USB COM port mapping

» Cherry G80-1502 at the Serial Port (see page 738)

» Cherry ST-2052 (see page 739)

+ Cherry ST-1503 und G87-1504 (USB) (see page 740)
+ Orga910/920 M (see page 741)

+ Orga6041L eGK eHealth-BC S (see page 742)

» celectronic CARD STAR / medic2 (see page 743)

» celectronic CARD STAR/ memo3 (see page 744)
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Cherry G80-1502 at the Serial Port

Connecting the keyboard
> Connect the keyboard to both the PS/2 port and the serial port of the thin client.

(@ Firmware version 1.19 of the keyboard must be present and the keyboard must be in mode S1. Refer to
http://www.cherry.de/files/manual/Cherry_G80-1502_mit_eGK.pdf.

Functionality
Software: Cherry eHealth eGK/KVK software

Device/server connection: COM port mapping

Configuring the device
In IGEL Setup, add the COM port device to which the keyboard is connected:
1. Click Sessions > RDP > RDP Global > Mapping > COM Ports

2. Click €,
3. Select a COM port device (COM1, COM2,...).

Configuring the server

1. Install the eGK-KVK software by Cherry.

See also http://www.cherry.de/files/manual/eHealth_Client-Server_Einbindung.pdf
2. Start the program CT-API configuration.
3. Select the appropriate port number for the G80-1502.
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Cherry ST-2052

Functionality

USB ID: 046a:003e

Software: Cherry eHealth eGK/KVK software
Device/server connection: Smartcard (PC/SC) mapping
Configuring the device

> Select Activate PC/SC Daemon in Setup under Security > Smartcard > Services:

q A @ Activate PC/SC Daemon
Configuration

M ¥ Sessions Currently active PC/SC devices:

» I Parallels Client
» I FowerTerm WebConneg
» Il FowerTerm Terminal Er
» I IEM iSeriesAccess
M 1BM iAccess Client
» I Thinlinc
M ssH
» Il VNG Viewer
Ml VERDE Sessions
» I Browser
» [ Media Flayer
M WS Sessions
» [ volF Client

Accessories

OMNIKEY CardMan 3121 00 00

Refresh dew

[V Cherry USB2LAN Proxy

MWetwork Interface auto |:]

User Interface
Network
Devices
Security

B Password
» [ Logon

» [ Active Directory/Kerbert
¥ [ Smartcard

i Services

B viddleware

Configuring the server

1. Install the eGK-KVK software by Cherry.

See also http://www.cherry.de/files/manual/eHealth_Client-Server_Einbindung.pdf
2. Start the program CT-API configuration.
3. Select port number 1 for the ST-2052.
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Cherry ST-1503 und G87-1504 (USB)

Functionality

USB ID: 046a:0080 for ST-1503
046a:0081 for G87-1504
Software: Cherry eHealth eGK/KVK software
Client/server connection: SICCT via LAN provided by the Cherry USB2LAN proxy

Cherry USB2LAN proxy: Makes Cherry electronic health card devices available in the network via SICCT. The
communication between card reader and server takes place independently of the VDI connections.

Configuring the Thin Client for Using the Cherry USB2LAN Proxy

1. Activate Security > Smartcard > Services > Cherry USB2LAN Proxy:
(/] Cherry USB2LAN Prowy

MHetwork Interface auto m

Configuring the Server for the Cherry USB2LAN Proxy

1. Install the eGK-KVK software by Cherry.
2. Configuration according to chapter 6 in http://www.cherry.de/files/manual/eHealth_Client-
Server_Einbindung.pdf.
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Orga 910/920 M

Functionality

USB ID: 0780:1202
Software: CT-API by Orga
Device/server connection: COM port mapping

Configuring the device

1. Click Sessions > RDP > RDP Global > Mapping > COM Ports for RDP
2. Select Enable Com Port Mapping:
3. Click (€.

] Enable COM Fort Mapping

Configuration

Server Com Port starts with oMl v
Sessions

‘ Sessions Summary COM Port Devices
» [ Citrix XenDesktop / Xen,
¥ [J RDP
¥ [ RDP Global
‘ Gateway
‘ Local Logon
B window
B Keyboard
¥ [ Mapping

B comPorts

‘ Printer Com Port Device |E]

‘ Device Support

B 2udio i
‘ Performance
‘ Options
[ N

labivim 11€0 DAdira

Local Device

| Server Device

4. Select USB COM 1 as a new COM port device ( /dev/ttyUSBO ).

Configuring the server

1. Download the appropriate driver for Orga 910/920 M from the download page:
http://healthcare-eid.ingenico.com/de/treiber_anleitungen.aspx™
2. Install the driver.

78 https://ingenico.de/healthcare/downloads
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Orga 6041 L eGK eHealth-BC S

Functionality

USB ID: 0780:1302
Software: CT-API by Orga
Device/server connection: COM port mapping

Configuring the device

1. Click Sessions > RDP > RDP Global > Mapping > COM Ports for RDP.
2. Select Enable Com Port Mapping:
3. Click (€.

] Enable COM Fort Mapping

Configuration

Server Com Port starts with oMl v
Sessions

‘ Sessions Summary COM Port Devices
» [ Citrix XenDesktop / Xen,
¥ [J RDP
¥ [ RDP Global
‘ Gateway
‘ Local Logon
B window
B Keyboard
¥ [ Mapping

B comPorts

B Printer Com Port Device |E] Detect Devices...

‘ Device Support

B 2udio i
‘ Performance
‘ Options
[ N

labivim 11€0 DAdira

Local Device

| Server Device

4. Select USB COM 1 as a new COM port device ( /dev/ttyUSBO ).

Configuring the server

1. Download the appropriate driver for Orga 6041 L eGK eHealth-BC S from the download page:
http://healthcare-eid.ingenico.com/de/treiber_anleitungen.aspx™
2. Install the driver.

79 https://ingenico.de/healthcare/downloads
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celectronic CARD STAR / medic2

Connecting the reader

» Connect the reader to the COM port of the thin client.

(@ Thereader must be set to host/PC serial interface.

Functionality

Software: CT-API by celectronic

Device/server connection: COM port mapping

Configuring the device
In IGEL Setup, add the COM port device to which the keyboard is connected:
1. Click Sessions > RDP > RDP Global > Mapping > COM Ports for RDP.

| Enable COM Port Mapping

Server Com Port starts with COM1 v

B sessions summary COM Port Devices
> I Citrix XenDesktop / Xen, Local Device | Server Device
v 3 RODP

¥ [ RDF Global

‘ Gateway

B Local Logon

. Window

B Keyboard
¥ (3 Mapping

B coMPorts
‘ Printer Com Port Device |E] Detect Devices...

B Device Support

B 2udio i
B Ferformance
‘ Options

K fibian 1120 Dadica

2. Click €.
3. Select a COM port device (COM1, COM2,...).

Configuration

Configuring the server

1. Download the appropriate driver for celectronic CARD STAR /medic2 from the download page:
https://www.ccv.eu/de/
2. Install the driver.
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celectronic CARD STAR/ memo3

Functionality

USB ID: 152a:8180

Software: CT-API by celectronic
Device/server connection: COM port mapping
Configuring the device

1. Click Sessions > RDP > RDP Global > Mapping > COM Ports for RDP.
2. Select Enable Com Port Mapping:
3. Click (€.

] Enable COM Fort Mapping

Configuration

Server Com Port starts with oMl v
Sessions

‘ Sessions Summary COM Port Devices
» [ Citrix XenDesktop / Xen,
¥ [J RDP
¥ [ RDP Global
‘ Gateway
‘ Local Logon
B window
B Keyboard
¥ [ Mapping

B comPorts
B Printer Com Port Device |E] Detect Devices...

‘ Device Support

B 2udio i
‘ Performance
‘ Options
[ N

labivim 11€0 DAdira

Local Device

| Server Device

4. Select USB COM 1 as a new COM port device ( /dev/ttyUSBO ).

Configuring the server

1. Download the appropriate driver for celectronic CARD STAR memo3 from the download page:
https://www.ccv.eu/*

2. Install the driver.

80 https://www.ccv.eu/de/
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Using Mobile Device Access

You can access your mobile device file structure via USB, e.g. to make it available in a session.

€@ Feature with limited support! The mobile device access feature comes with “limited support”. This
feature is offered 'as is' without any warranty. Any support for this feature is provided on a non-binding,
“best effort” basis.

The following device types can be used:

« Smartphones with Android (via MTP / PTP) oriOS
+ Tablets with Android via MTP / PTP) oriOS
+ Digital cameras

() The functionality may differ according to the specific device and operating system version.

Environment
+ IGEL Universal Desktop (UD) with IGEL 0S10.04.100 or higher

() 1Z devices are not supported!

+ IGEL Universal Desktop Converter 3 (UDC3) with IGEL Linux 10.04.100 or higher
+ UD Pocket with IGEL Linux 10.04.100 or higher
+ To configure the feature via UMS, UMS version 5.08.110 is required.

« Enabling Mobile Device Access (see page 746)

+ Disabling Mobile Device Access (see page 747)

« Mapping a Mobile Device for a Session (see page 748)

« Connecting Your Mobile Device (see page 749)

+ Accessing the Mobile Device USB Window from a Session (see page 750)
+ Viewing the Files and Directories Locally (see page 751)

+ Safely Removing the Mobile Device (see page 753)
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Enabling Mobile Device Access

1.

ok wnN

Ensure that the settings under System > Update > Firmware Update are correct. The Server Path
must point to the firmware version that is currently installed. This is required because the software
package for mobile device access must be downloaded in order to deploy the feature.

Go to System > Firmware Customization > Features and activate Mobile Device Access USB.
Confirm the warning dialog with Ok.

Click Ok in the main window.

Reboot the device.

On reboot, the device downloads and installs the software package for the mobile device access
feature.

If mobile device access should be available permanently, make sure that Autostart is activated
under Accessories > Mobile Device Access. The other start options are described in the manual
under Mobile Device Access.

® If you want to use mobile device access in appliance mode, you must enable autostart or
configure a hotkey. Autostart is recommended.

Configure the start options for mobile device access according to your requirements.
If you have activated Autostart as the only start option, restart the device.

When the mobile device access is activated, the smartphone symbol [g is shown in the task bar.
For appliance mode sessions, the in-session control bar is available; see Accessing the Mobile
Device USB Window from a Session (see page 750).
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Disabling Mobile Device Access

Disabling Mobile Device Access

» In the context menu of the tray icon, click Quit.
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Mapping a Mobile Device for a Session
There are two alternative options to map a mobile device to a drive in a session:

+ Automatic Drive Mapping
« Manual Mapping to a Specific Drive

Automatic Drive Mapping

You can use dynamic client drive mapping to have a drive automatically mapped to your mobile device. The
directories and files on your mobile device will be accessible under this drive.

1. Inthe IGEL Setup, go to Devices > Storage Devices > Storage Hotplug and enable Storage
hotplug.

2. Set Client drive mapping to "Dynamic".

3. Click OK.

You can access the directories and files on your mobile device like with a regular hotplug storage device.

For further information, see the manual chapter Storage Hotplug.

Manual Mapping to a Specific Drive
You can specifiy a drive letter under which the directories and files on your mobile device will be accessible.

1. If the session will run in fullscreen mode, open the IGEL Setup, go to User Interface > Desktop and
activate In-Session Control Bar.

2. Ifthe session will run in fullscreen mode or appliance mode, ensure that Autostart under
Accessories > Mobile Device Access is enabled. See here also Enabling Mobile Device Access (see
page 746).

3. Go to the Drive Mapping page for your session type. Example: With RDP sessions, the setup path is

Sessions > RDP > RDP Global > Mapping > Drive Mapping.

Activate Enable drive mapping.

Click L™ Add to bring up the mapping window.

Click Enabled to enable the drive connection.

Select a Drive to map from the list under which the local device or the folder is to be mapped.

Enter /media asthe Local Drive Path.
9. Click OK.

You can access the directories and files on your mobile device like with a regular hotplug storage device.

© No U oA
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Connecting Your Mobile Device

1. If mobile device access is not started already, use one of the start options configured under
Accessories > Mobile Devices Access.

2. Connect your mobile device with your thin client.

3. Allow file transfer on your phone, e. g. Transfer Files (Android smartphones) or Trust The
Computer (Apple iPhone).
The directories of your mobile device are mounted.
You can view the contents; see Viewing the Files and Directories Locally (see page 751).
You can remove the mobile device securely; see Safely Removing the Mobile Device (see page 753).
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Accessing the Mobile Device USB Window from a Session

Non-Fullscreen Session

> Click !I to open the Mobile Device Access USB window.
The Mobile Device Access USB window appears.
You can view the directories and files on your mobile device or safely remove the device; see Safely Removing the
Mobile Device (see page 753).

Fullscreen Session

In a session that is running in fullscreen mode or appliance in a fullscreen session, you can use the in-session
control bar to open the Mobile Device Access USB window.

1. Move the mouse pointer to the upper edge of the screen.
The in-session control bar appears.

' § Harald w7 0

FEN
ar
X

2. Click the smartphone symbol.
The Mobile Device Access USB window appears.
You can view the directories and files on your mobile device or safely remove the device.

Appliance Mode Session

In a session that is running in appliance mode, you can use the in-session control bar to open the Mobile Device
Access USB window.

1. Move the mouse pointer to the upper edge of the screen.
The in-session control bar appears.

) § % Desktop

»
O

2. Click the smartphone symbol.
The Mobile Device Access USB window appears.
You can view the directories and files on your mobile device or safely remove the device.

IGEL OS Articles 750/ 823



Devices

Viewing the Files and Directories Locally
» Select View in the context menu.

Mobile Device Access USB

& Refresh

ID Name Mountpoint

Eject

The directories on your smartphone are displayed. Access is read-only, i. e. you can only view the directories and
files.
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Safely Removing the Mobile Device

> Click Eject in the context menu for the device in question.

1D

Mobile Device Access USB

£¥Refresh

Name

Mountpoint

/media/mtpdeuo
.‘.

View
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Swapping Function of Mouse Buttons (e.g. When Using an Evoluent
Mouse)

The assignment of mouse buttons for Evoluent Mouse 3 changed between firmware versions 5.04.130 and 5.05.100.

Problem

Users have become used to the assignment as it was up to 5.04.130, so you want to reproduce the same assignment
in 5.05.100.0.

Solution
A. To manually analyze the assignment and determine how it needs to be adjusted:

1. Openalocal terminal.
2. Find the mouse ID: xinput list

The output should look something like this:| Virtual core pointerid=2[master
pointer (3)] |- Virtual core XTEST pointer id=4[slave pointer (2)]

| - Logitech USB Optical Mouse id=10[slave pointer (2)] - Virtual
core keyboardid=3[master keyboard (2)] - Virtual core XTEST keyboard
id=5[slave keyboard (3)] - Power Buttonid=6[slave keyboard (3)] -
Video Busid=7[slave keyboard (3)] - Power Buttonid=8[slave keyboard
(3)] - Sleep Buttonid=9[slave keyboard (3)] - Logitech USB
Keyboardid=11[slave keyboard (3)] - Logitech USB Keyboardid=12[slave

keyboard (3)]

3. Find your mouse and its ID in the output (here: Logitech USB Optical Mouse, id=10).

4. Check the number of buttons in the button map: xinput get-button-map [ID] (wherelD
is the ID of your mouse device).

5. Now check which button number is set for the buttons in question: xev

A test window will appear.
6. Click into the window using the buttons that you want to swap. Look for the button numbers in the

terminal output: ButtonPress event, serial 39, synthetic NO, window
0x3200001, root Oxae, subw 0x0, time 25542794, (114,113), root:
(2884,634), state 0x10, button 1, same_screen YES ButtonRelease
event, serial 39, synthetic NO, window 0x3200001, root Oxae, subw
Ox0, time 25542898, (114,113), root:(2884,634), state 0x110, button

1, same_screen YES ButtonPress event, serial 39, synthetic NO,
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window 0x3200001, root Oxae, subw 0x0, time 25543218, (114,113),
root: (2884,634), state 0x10, button 3, same_screen YES
ButtonRelease event, serial 39, synthetic NO, window 0x3200001,
root Oxae, subw 0Ox0, time 25543330, (114,113), root:(2884,634),

state 0x410, button 3, same_screen YES
In the above example the buttons number 1 and 3 were used.

B. To change the assigment of the mouse buttons on the local thin client:

1. Setanew button map for the mouse in Setup > System > Firmware Customization > Custom
Commands > Desktop Commands > Final.

2. Swap the buttons in the map. To swap e.g. the buttons 1 and 3, change the setting from xinput
set-button-map [ID] 1 2 3 4 5 6 7 to xinput set-button-map [ID] 3 2 1
4567

C. To automatically change the assignment using a UMS profile:
As the ID of the mouse may be different on each client, you cannot use the command as shown in B2 but need to
use a script that will automatically map the correct input device.

1. Runthe following command in alocal terminal: xinput --Tlist

2. Make a note of the complete name of the mouse.
3. Create a profile in Setup > System > Firmware Customization > Custom Commands > Desktop

Commands > Final with a custom command: MouseID=$(xinput --list --id-only

"NAME OF MOUSE') xinput set-button-map $MouseID 3 2 1 4 56 7
4. Replace NAME OF MOUSE with the name of the mouse as determined in step C1.
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Using Natural Scrolling (reverse Scrolling Direction)

Issue

You are using a touchpad instead of a mouse and you want to reverse the scrolling direction to have natural
scrolling - with the screen content moving synchronously to the fingers' movement on the touchpad.

Problem

There is no "reverse scrolling" parameter in IGEL Setup.

Solution

1. Open the device's configuration either locally or in the UMS.

2. Go to System > Firmware Customization > Custom Commands > Desktop > Final desktop
command.

3. Enter the following command:

echo "pointer =12 35467 8 9 10 11 12" > ~/.Xmodmap && xmodmap

~/ .Xmodmap
4. Save the settings and restart your device.

& This will reverse the scrolling direction of a mouse wheel as well. Swapping 4 and 5 will reverse
vertical scrolling, swapping 6 and 7 will reverse horizontal scrolling as well (if supported).
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Connecting a Serial Barcode Scanner

Connecting Barcode Scanner via COM Port

1. Determine to which COM port of the device the barcode reader is physically connected.
2. Open the IGEL Setup, go to System > Registry > devices > serial > inputattach and enable the
relevant key, according to the COM port in use:

+ COM1( /dev/ttySO ): devices.serial.inputattach.com0.enabled

« COM2( /dev/ttyS1 ):devices.serial.inputattach.coml.enabled
+ COM3,COM4...: Add a new instance by clicking devices.serial.inputattach.com% > Add
Instance and define the port appropriately, e.g. /dev/ttyS2 for COM3.

3. Ifthe device's baud differs from 9600 (default), enter the correct baud
under devices.serial.inputattach.como0.baud.

( With most barcode readers, you can change the baud by scanning a specific bar code.

4. Inthe Setup, click Apply or Ok to submit the new settings. To make absolutely sure that the new
settings are effective, you can reboot the device.
5. Checkif the barcode scanner is working.

Connecting Barcode Scanner via USB

If the barcode scanner is connected over USB, the challenge is to identify the device which is assigned to it.
Depending on your specific device and environment, your mileage may vary. Start with the simple procedure (see
page 757). If you are lucky, this will do it. If not, continue with the extended procedure (see page 758).

Simple Procedure

1. Connectthe barcode to a USB port. This will trigger an event which will be logged and reported by
dmesg.

2. Open a terminal on your endpoint device. For further information on the device's terminal, see
Terminals.

3. Tofind theright device file, enter dmesg | grep tty intheterminal.
If you are lucky, the relevant device file is listed. Its name is either ttyUSB<NUM> or

ttyACM<NUM> . Example: ttyUSBO

If the relevant device file is not listed, try the extended procedure (see page 758) below.
4. Open the IGEL Setup, go to System > Registry > devices > serial > inputattach.
5. Setthe devices.serial.inputattach.com0.port to the device file you have found. Example: If the

devicefileis ttyUSBO ,enter /dev/ttyUSBO
6. Activate devices.serial.inputattach.com0.enabled.

IGEL OS Articles 757 /823



Devices

7. If the device's baud differs from 9600 (default), enter the correct baud under
devices.serial.inputattach.como0.baud.

( With most barcode readers, you can change the baud by scanning a specific bar code.

8. Click Apply or Ok to submit the new settings. To make absolutely sure that the new settings are
effective, you can reboot the endpoint device.
9. Checkif the barcode scanner is working.

Extended Procedure: Device File Was Not Found on the First Go

If the device file could not be found using the simple procedure, try loading the device driver manually. As the
explicit loading of the driver must be executed with every system start, a custom command must be added.

1. Inthe terminal, enter the following commands, one after the other:
modprobe cdc-acm

dmesg | grep tty
The relevant device file is listed. Its name is either ttyUSB<KNUM> or ttyACM<NUM> .

Example: ttyACMO

2. Open the IGEL Setup, go to System > Registry > devices > serial > inputattach.
3. Setthe devices.serial.inputattach.com0.port to the device file you have found. Example: If the

devicefileis ttyUSBO ,enter /dev/ttyACMO

4. Activate devices.serial.inputattach.comO0.enabled.
5. If the device's baud differs from 9600 (default), enter the correct rate
under devices.serial.inputattach.como0.baud.

() With most barcode readers, you can change the baud by scanning a specific barcode.

6. Go to System > Firmware Customization > Custom Commands > Base and under Initialization,
enter modprobe cdc-acm

7. Click Apply or Ok to submit the new settings. Reboot the device.
8. Check if the barcode scanner is working.
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Using DriveLock with IGEL Devices

Issue

DriveLock allows the system administrator to control access to removable devices within Citrix or RDP sessions.
This is possible for USB devices; as of IGEL OS version 10.04.100, SATA devices are also supported.

Problem

How to integrate DriveLock solution with IGEL OS devices?

Solution

After configuring the Citrix or RDP server according to the original documentation, you have to activate the
DriveLock virtual channel in the Setup.
See the original DriveLock documentation.

Using DriveLock with RDP:

1. In Devices > Storage Devices > Storage Hotplug, change the settings as follows:
+ Deactivate Enable dynamic client drive mapping.
+ Set Number of storage hotplug devices to 1 or higher.
+ Activate Private drive letter for each storage drive.

2. In Sessions > RDP > RDP Global > Mapping > Drive Mapping, change the settings as follows:
+ Activate Enable Drive Mapping.

3. In Sessions > RDP > RDP Global > Mapping > Device Support, change the settings as follows:
+ Activate DriveLock channel.

Using DriveLock with Citrix:

1. In Devices > Storage Devices > Storage Hotplug, change the settings as follows:
+ Deactivate Enable dynamic client drive mapping.
+ Set Number of storage hotplug devices to 1 or higher.
+ Activate Private drive letter for each storage drive.

2. In Sessions > Citrix > Citrix Global > Mapping > Drive Mapping, change the settings as follows:
+ Enable Activate Drive Mapping.

3. In Sessions > Citrix > Citrix Global > Mapping > Device Support, change the settings as follows:
+ Activate DriveLock channel.
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Restricting the Mounting of Hotplug Storage Devices on IGEL Linux

Goal:

You want to restrict the mounting of hotplug storage devices.

Solution:

As of IGEL Linux version 5.10.100, the following registry keys let you disable the mounting of hotplug storage devices
based on the device class (floppy, optical, harddisk, flash, other).

+ devices.hotplug.enable_floppy

+ devices.hotplug.enable_optical
+ devices.hotplug.enable_harddisk
+ devices.hotplug.enable_flash

+ devices.hotplug.enable_other

These are all of type bool. Their default value is true. If true, mounting volumes on floppies, optical media,
harddisks, flash memory devices, and others is enabled respectively.

() Evenifthe above settings allow mounting hotplug storage devices, the following settings may still restrict
it:
» Devices > USB access control
« Devices > Storage Devices > Storage Hotplug

In order to disable mounting of a device class system-wide:

1. Insetup, go to System > Registry.
2. Inthe Parameter tree, open Devices > hotplug.
3. Todisable the mounting of a device class, uncheck its Enable hotplug [...] parameter.
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When to Use USB Redirection

& Solution Based on Experience from the Field

This article provides a solution that has not been approved by the IGEL Research and Development
department. Therefore, official support cannot be provided by IGEL. Where applicable, test the solution
before deploying it to a productive environment.

Document Purpose

In general, USB redirection is not needed for standard functionality such as; audio, video, HID input, etc. However,
in some special circumstances, a device may need to be redirected into a VDI session for full functionality, or if it
requires a specific driver to function.

® Forwebcams, see Webcam Redirection and Optimization (see page 708).

Use USB redirection ONLY WHEN ABSOLUTELY REQUIRED.

In this document, we will define the best practices for using USB redirection in a VDI environment, and go through
the process with an example.

() The example described here is for VMWare Horizon, but it is similar for Citrix, RDS, and most other VDI
technologies as well.

Best Practices for USB Redirection

Below are some general rules that, if followed, will provide the best performance and reliability when using USB
redirection.

+ ALWAYS set the default rule to "Deny".

+ DO use VID and PID to redirect devices whenever possible. This is the best way to make sure that a
device is redirected and that the USB virtual channels are not flooded with excess redirection.

+ Enable USB redirection for the minimal amount of devices required to support user workflows

« Asarule, the USB classes below should NEVER be redirected. Instead, redirect individual devices in
these classes using Device Rules.

Audio Audio (input) Audio (output) Bluetooth
HID Bootable HID Imaging USB Hubs
PDA Physical Security Smart Card
Video (input) Wireless Wireless USB

+ The following classes may be redirected in specific circumstances:
+ Printers

+ Only if CUPS configurations or a third party does not fill this requirement
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» Storage
+ Only if mass storage options do not meet the requirements for user workflows or
software compatibility

() Rules are meant to be broken, right? If redirecting these classes is the only way things work, take a deeper
look and see if there is a better way. If there is no obvious better way, then test thoroughly before moving
into production.

Example: Redirecting a Nuance Powermic (Dictaphone)

Below we will run through the basic process of redirecting a single device into a Horizon VDI session from an IGEL
device.

() Some devices, including the Nuance Powermic, require custom split rules in Horizon, which will not be
covered in this article. The splitting can be done with Horizon Group Policy on the VM, or as additional
settings on IGEL. Please contact your vendor for their best practice for the devices.

Prerequisites

1. Make sure that Devices > USB Access Control is disabled on the IGEL devices, or make sure there
are no USB access control rules restricting access to the USB device. More information about IGEL
USB access can be found under USB Access Control.

2. USB redirection policies for Horizon/Citrix/RDS must be configured to allow redirection to happen
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The VDI image must have compatible drivers installed for the devices being redirected into the
session

Getting Device Information from IGEL

The first step that needs to be done, is to identify the device's vendor ID and product ID which will be used to create
our redirection rule.

1.

o v bk~ wnN

Plug in the USB device to an IGEL terminal.
Connect to the IGEL device using SSH or IGEL Secure Terminal.
Log in as user with the user password set by the IGEL profile.

Type su to switch to the root account and provide the root password when prompted.

Run lsusb todisplay a list of devices and locate the device.
Note the ID numbers separated by a colon ":"
a. Inthe Dictaphone example, thisis 6554 and 1001 .

b. The first number is the vendor ID (VID) and the second is the product ID (PID).

) . ASM1874 SuperSpeed hub
@ root hub

Prolific Technology, Inc.

Bus 881 Device B06: ID B8431:2836 Texas Instruments, Inc. TUSB

If the device cannot be easily identified by name, then disconnect the device and run lsusb again to see
which one disappeared.

Configuring the IGEL Profile

Call

o

Create a new profile in UMS called "USB Redirection".

Go to the USB Redirection page for your session.

Set USB Redirection to "on" and set the Default rule to "Deny".

Make sure that both Automatically connect at startup and Automatically connect when
inserted are both enabled.

Clear out any existing Class Rules that may have previously existed (if using an existing profile).
Add a Device Rule using the Vendor ID and Product ID collected in the previous section, and set it
to "Allow".

@ Tomakeiteasy, set the name of the rule to match the device name.

Apply the new profile to the device, and reboot for safe measures.
The device should now be reflected in the Windows Device manager in the VDI session. If so, then
the redirection rule is correct and working as expected.
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Default rule

a ./

Device Rules

& fthe device shows up as unknown then most likely a driver will need to be installed in the OS to support

the device.
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How to Configure USB Access Control

You can allow and prohibit the use of USB devices on your endpoint device. Specific rules for individual devices or
device classes are possible.

& The activation of USB Access Control and setting the Default rule to Deny will block the use of USB
devices locally and in the session and, thus, might disable devices needed for the users. Therefore, activate
the USB access control only if your security policy requires that. In this case, set Default rule to Deny and
configure Allow rules for the required USB devices and USB device classes.

It is recommended to make settings for USB Access Control as the last step in the device configuration.
Before activating the USB access control, check that all your other settings for printers, Unified
Communication, USB redirections, mapping settings for USB devices are working as expected.

Note that the USB access control is completely separate than USB redirection for remote sessions, see
When to Use USB Redirection (see page 761).

Take also notice that the feature does not disable a USB port physically, i.e. power delivery will still work.

Enable USB Access Control

1. Open the Setup and go to Devices > USB Access Control.

2. Enable the option Enable.

3. Select the Default Rule. The default rule specifies whether the use of USB devices is generally
allowed or prohibited.

4. Create one or more rules for classes of devices or individual devices.

Create a Class Rule

1. Tocreate a new rule, click in the Class Rules area.

2. Choose arule. The rule specifies whether use of the device class defined here is allowed or
prohibited.

3. Under Class ID, select the class of device for which the rule should apply. Examples: Audio,
Printer, Mass Storage.

4. Under Name, give a name for the rule.

Click OK.

6. Save the changes.
Therule is active.

o

Create a Device Rule

() Whenaruleis defined, at least one of the properties Vendor ID or Product ID or UUID must be given.
1. Tocreate a new rule, click in the Device Rules area.

2. Choose arule. The rule specifies whether use of the device defined here is allowed or prohibited.
3. Give the Vendor ID of the device as a hexadecimal value.
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4, Give the Product ID of the device as a hexadecimal value.

®

Getting USB Device Information

To find out the Class ID, Subclass ID, Vendor ID and Product ID of the connected USB device, you
can use the System Information tool. For further information, see Using “System Information”
Function.
System Information example:

Devices - USB Devices - System Information

Information View Help

(:) Refresh Generate Report |_|:| Copy to Clipboard | Synchronize

g_ Computer

@ Summary

@ Operating System

Security

@ Kernel Modules

@ Boots

m Languages

Memory Usage

== Filesystems

@ Display

[z] Environment Variables

Devices

g_ System DMI Product [0x0002] 2.0 root hub
Vendor [0x1d6b] Linux Foundation

Device EHCI Host Controller

il 001:001 | Linux |2.0 root hub

002:001 1.1 root hub

() 002:002 [WMware Virtual Mouse

.
&) 002:004 logitech 960 Headset

Device Information

Manufacturer Linux 5.12.19 ehci_hcd

Max Current 0 mA

USB Version 2.00

Speed 480 Mbys

. ) -

Done.

Alternatively, you can use the command lsusb (or lsusb | grep -i [search term])
in the terminal.
Example for lsusb :
Local Terminal
File Edit View Terminal Tabs Help
root@ITCOO5056930CAD:~# 1lsusb | grep -1 logitech

Bus 002 Device 004: ID 046d:0ad5 , Inc. 960 Headset
root@ITCO05056930CAD:~# [

5. Give the Device UUID (Universal Unique Identifier) of the device.
6. Specify Permissions for the device.
Possible values:
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+ Global setting: The default setting for hotplug storage devices is used; see Default
permission parameter under Devices > Storage Devices > Storage Hotplug.

+ Readonly
+ Read/Write

7. Under Name, give a name for the rule.

Click OK.

9. Save the changes.

The rule is active.

o

Example

+ The set rule prohibits the use of USB devices on the device.

+ Aclass rule allows the use of all entry devices (HID = Human Interface Devices).

+ Adevice rule allows the use of the USB storage device with the UUID 67FC-FDC6.

+ The use of all other USB devices, for example, storage devices or printers, is prohibited.

ﬂ@Enable

Default rule QILDE"'}’ I ']

Default permission [Readerite v]

Rule | Class ID | Name

Allow HID (Human Interface Device) Allow HID

Device Rules

Rule |Vend0r D | Product ID | Device uuid | Permission | Name
Allow 5YFC-FDCS Read/Write Storage Device
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Issues with USB IDs in USB Devices Rules

Symptom

USB Device Rules you configured do not take effect.

Problem

The System Information tool in IGEL OS up to version 11.04.100 omits leading zeros in USB vendor and product
IDs. These are shown only three hexadecimal digits long.

USB Devices - System Information - A X

Information Wiew Help

O Refresh |_|:| Copy to Clipboard

- g Computer
*HCI Host Controller:

o Summary :
*HCl Host Controller:

% Operating System
@ Kernel Modules

m Languages USE Keyboard

xHCI Host Controller:
USB Optical Mouse

|§| Display
[Q Environment “ariables =l Misc :
USBE Version £ 2,00
E Users :
) Class - 0x0
- E Dewvices ;
wendor : 0x46d
BeE Processor ;
Product ID - Oxc05a
& Memory 5
Bus 01
[ . :
Done
Solution

If you see three-digit USB IDs in System Information, use the lsusb command:

1. Open Local Terminal.
2. Enterthe lsusb command.

3. Look for the device in question, possibly using grep tosearchinthe lsusb output:

lsusb | grep -i [search term]
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Local Terminal

user@Mathias:~$ lsush | grep -i Mose

Bus 001 Device 0G03: IDlﬁdﬁd:cGEa Logitech, Inc.

user@Mathias:~$ [

4. Use the four-digit IDs that lsusb

IGEL OS Articles
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Printer

« CUPS: Mapping Local Printer to Citrix or RDP Sessions (see page 771)
+ Print Server Configuration (see page 772)
+ Installing a Custom CUPS Driver (see page 775)
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CUPS: Mapping Local Printer to Citrix or RDP Sessions

Issue

How to map a locally connected PCL/PS-based printer to a Citrix or RDP session?

Problem

The CUPS driver does not support all printer functions such as duplex, color profiles, etc.

Solution

=

Open local IGEL Setup or UMS configuration or profile.

Go to Devices > Printer > CUPS > Printers.

Create a new printer and define a Printer Name.

Select the Printer Port your printer is connected to.

Set Manufacturer = Generic.

Set Printer names = Raw Queue.

Switch to the tab Mapping in sessions.

Enable Map Printer in ICA Sessions or Map Printer in RDP Sessions.

Enable the radio button Use Custom Windows Driver Name.

Enter the exact name of the Windows driver installed on the server.

. Check if Sessions > Citrix > Citrix Global > Mapping > Printer > Client printer mapping or
Sessions > RDP > RDP Global > Mapping > Printer > Enable Client Printer Mapping is enabled.

Start the ICA or RDP session and install the printer driver with the redirected port named TS00x/
ClientPort.

WeNoOkWwN

[
= o

=
N
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Print Server Configuration

Prerequisites

« IGEL OS version 10 or higher
+ Printer with the integrated PCL/PS controller.

Recommendation

Assign a fixed IP address to the IGEL device or reserve one for it via DHCP.

Instructions

To use the IGEL device as a print server for locally connected printers, follow the steps below:

1. Inthe IGEL Setup, go to Devices > Printer > TCP/IP.
2. Select the port to which the printer is connected.

« COM1

+ COM2

« Additional Serial Ports

« LPT1

« USBLP1
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Configuration

User Interface
Metworl
Devices

B Hardware Info
v 3 Printer
» Il CUPS
")
W COM1
B com2
B 2dditional Serial Ports
B L2
B uselr1
= Il Thinprint
i PrinterLogic

ge evices

3. Enable Activate TCP/IP Printer on this Port.
Enter the TCP/IP port number on which the print server service is listening. (Windows default:

9100)
Poll Criterion and Poll Frequency must only be adjusted if required by the environment.

4. Click Apply or Ok to save the settings.
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IGEL Setup 11.03.100.r 01 (Build 6.3.7)
£ > [ ) » Pri

€} (V) Activate TCP/IP Printer on this Port

TCP/IP port number

Poll Criterion

Width
Use RTS/CTS flow control

Use DSR flo ntrol

Search

1

8

XOFF flow control

The printer can be installed and used by other systems like a regular network printer.
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Installing a Custom CUPS Driver

Environment
IGEL Linux v5 and higher.

Issue

Your printer is not included in the CUPS default configuration.

Solution

You can install a custom driver from your manufacturer.

Copying the PPD Driver File to the Device

> Copy the driver file (PPD file) to the folder /wfs usingthe UMS file transfer mechanism, see Files.

Adding a New CUPS Driver

Now that you have copied the driver file to the device, you have to add a new printer and set the PPD file as the
driver definition. To do so, proceed as follows:

(@) Foradetailed description of the CUPS configuration options, see CUPS.

1.
2.
3.

In Setup, go to Devices > Printer > CUPS > Printer.

Click L*] to get to Add dialogue.
Define the following settings:

+ Printer name: Name of the printer.

+ Printer port: Port to which the printer is connected. Depending on which type you select,
you will have to provide additional information, e.g. server and port in the case of TCP
Printer Port.

+ Manufacturer: Choose Custom, which will bring up the Driver definition field.

« Driver definition: Enter the absolute path to the PPD file.

Click Ok to save the settings.
Restart your device.
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UD Pocket

« Running IGEL OS from UD Pocket on a Dell WYSE ZX0D (aka 7010) Device (see page 777)

« Running UD Pocket on an Acer Chromebook C910 (see page 778)

« UD Pocket Seems to Break Microsoft Surface (see page 779)

« How to Boot from the UD Pocket on Mac mini, MacBook Air 2018, MacBook Pro (see page 781)
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Running IGEL OS from UD Pocket on a Dell WYSE ZX0D (aka 7010) Device

Here you can learn which settings you have to make on the Dell WYSE ZXoD (aka 7010) to be able to start the device
with a UD pocket.

1. Boot up the Dell device.

In the BIOS go to the Advanced tab.

Enable Boot From USB.

Change to the Boot tab.

Change the boot priority to make USB HDD the default by moving it to the top.
Save the settings

Put in the UD Pocket

oA WD

~

See this video:

https://www.youtube.com/watch?v=CONWdjVE1RI
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Running UD Pocket on an Acer Chromebook C910

You can use the IGEL UD Pocket with the Acer Chromebook C910. This requires installation of a BIOS extension
which enables the device to boot into an alternative operating system.

() The procedures described here have been tested with the Acer Chromebook C910; the procedures may

differ for other Chromebook types.

For further information, refer to MrChromebox.tech®.

Enabling Your Device to Boot from UD Pocket

1.
2.

N o ook

10.

11.
12.

13.

Ensure that you have a WiFi connection; this is required for downloading the SeaBIOS extension.
Boot into recovery mode by pressing [ESC] + Il (Refresh) + ) (Power) simultaneously.

The recovery mode screen is shown, which states that the OS is broken.

Press [Ctrl] + [D] to enter developer mode.

The developer mode screen is shown, confirming that OS verification is off.

Open a root-capable shell by pressing [Ctrl] + [Alt] + ER (F2).

Login as chronos ; no password is required unless one has been set.

Changeto /tmp: cd /tmp.

Download the ChromeOS firmware utility script: curl -LO https://mrchromebox.tech/
firmware-util.sh

Start the script with root permissions: sudo bash firmware-util.sh

Enter 1 to select the first option.

Enter y to confirm.

The RW_Legacy firmware is downloaded to your device.
When the download has completed, press [Enter].

Enter r toreboot.

The device reboots into developer mode.
To boot from UD Pocket, press [Ctrl] + [L].

Booting from UD Pocket

1.

Ensure that the device is in developer mode. This should be the case if the device has been
configured according to the procedures described above, and if since then no changes were made
that have affected the developer mode.

Press [Ctrl] + [L] to boot from UD Pocket.

81 https://mrchromebox.tech

IGEL OS Articles 778 /823


https://mrchromebox.tech
https://mrchromebox.tech

UD Pocket

UD Pocket Seems to Break Microsoft Surface

@ Please note that this device is not officially supported. Therefore, we can not offer any guarantee or
support for the procedures described in this article.

Tested Environment

The following information describes the exact environment on which the issue and the troubleshooting method
have been tested. However, the method will probably work on similar versions.

« Microsoft Surface Book 1
« Windows 10 build 1903 4/25/2019 18362.267
« IGEL UD Pocket with IGEL 0S 11.02.100

Issue

After having booted successfully into UD Pocket once, the Microsoft Surface notebook is not able to boot into
Windows anymore.

Solution

With the following procedures, you can set your Microsoft Surface to boot from USB storage permanently or,
alternatively, on-demand.

For detailed information, see How do | use the BIOS/UEFI?82 by Microsoft.

Enabling Boot from USB Storage Permanently

1. Ensure that your Microsoft Surface has shut down.
2. Press and hold down the volume + (up) button and at the same time, power up the Microsoft
Surface.
3. When the Surface logo appears, release the volume + (up) button.
The UEFI menu is displayed.
4. Under Configure boot device order, move USB Storage to the top using drag & drop.
5. Under Advanced options, change the settings as follows:
« Enable alternate boot sequence: On
« Enable Boot from USB devices: On
« Enable Boot Configuration Lock: On
Your UEFI settings should look like this:

82 https://support.microsoft.com/en-ae/help/4023532/surface-how-do-i-use-the-bios-uefi
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UD Pocket

ﬁFﬁQUI’E boot device order

To change the onder devices ane searched for a bootabie operating
ML Ui the chexckbox to enable or diabbe 3 boot option Chck the

Swips et 0n a device 10 boot thist device unsiiechately "

6. Exit the UEFI settings.
7. Insertthe UD Pocket into the USB port of your Microsoft Surface.
8. Reboot your Microsoft Surface.

Your Microsoft Surface boots from your UD Pocket.

Booting from USB Storage On-Demand

1. Ensure that your Microsoft Surface has shut down.

2. Insert the UD Pocket into the USB port of your Microsoft Surface.

3. Press and hold down the volume + (up) button and at the same time, power up the Microsoft
Surface.

4. When spinning dots appear beneath the Surface logo, release the volume + (up) button.
Your Microsoft Surface boots from your UD Pocket.
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How to Boot from the UD Pocket on Mac mini, MacBook Air 2018,
MacBook Pro

& Solution Based on Experience from the Field

This article provides a solution that has not been approved by the IGEL Research and Development
department. Therefore, official support cannot be provided by IGEL. Where applicable, test the solution
before deploying it to a productive environment.

Environment

» Mac devices with an Apple T2 Security Chip, e.g. Mac mini, MacBook Pro, MacBook Air 2018, iMac
Pro

Problem

The secure boot implemented with the Apple T2 Security Chip does not allow to boot Linux on the above-
mentioned devices. For details, see the German overview https://www.computerbase.de/2018-11/apple-t2-linux-
installation-umgehung/. Therefore, some configuration changes on these devices are required to boot from the UD
Pocket.

Solution
Via the recovery menu, it is possible to disable the secure boot option. To do this, proceed as follows:

1. To getinto the macOS recovery menu, press and hold the command key [d£] + [R] during the boot
process as soon as the Apple logo appears.

2. Under Utilities, select the Startup Security Utility.

3. Use an administrator account to deactivate the secure boot option under Secure Boot > No
Security.

For more information about the Startup Security Utility on Mac devices, see https://support.apple.com/en-us/
HT208198.
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Miscellaneous

« Sending Device Log Files to IGEL Support (see page 783)

« Exporting the Local Device Configuration (see page 791)

« Which Unified Communication Solutions Does IGEL OS Support? (see page 794)
+ Passthrough Authentication (see page 795)

« Hardware Video Acceleration on IGEL OS (see page 810)

+ Running Commands before or after a Session (see page 813)

« Copy Sessions in Setup or UMS (see page 815)

+ 1Z1 and UD2-MM Usage of RAM (see page 816)

« Starting UMS Console Crashes NX Session (see page 817)

+ Accessing IGEL Setup within Appliance Mode (see page 818)

« An Application Window Cannot Be Repositioned (see page 819)

« Updating IGEL UMD: Error "not compatible with System5" (see page 821)

« Will My Session Be Closed When My IGEL OS Endpoint Device Enters Suspend Mode? (see page 822)
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Sending Device Log Files to IGEL Support

When the IGEL support team asks you to provide your device's log files, follow the instructions below.

There are two possibilities to send log files to the support team, one that uses the IGEL Universal Management Suite
(UMS) and one that works locally with a USB memory stick:

o With UMS (see page 783)
« Without UMS (see page 788)

With UMS

1. Start the UMS Console and enter your User Name and Password.

Z* IGEL Universal Management Suite - Connect to ...

Senver

Port 8443
PQ Username admin

Universal Management Suite

Connect Cancel

2. Click Connect.

Z* IGEL Universal Management Suite - Connect to ...

Server

Port 8443
FQ Username admin

Universal Managemeant Suite

Connect Cancel

The UMS Console window opens.
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3. Open the Help submenu and select Save device files for support.

I;I ITCODEOC51C9F05

Sy stem Information

License Information

Unlimited License present

Firmware Description

The dialog Save device files for support opens.

4. Select the device in question and click Next.
Save device files for support

Select devices

Find:

Path
V| ITCOOEOCH1COF05 Devices!

Cancel

The dialog Select a target directory for the zipped files opens.

IGEL OS Articles

Help

User Manual Whole Text
r Manual (offline)
EL Knowledge Base Y o=

ave support information...
Save device files for support

MNotifica

Third party li
UMS Update
Info

Indirec gned objects

Directory MName
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5. Select a directory suitable for saving the zipped log files, and click Next.

Save device files for support

Select a target directory for the zipped files

Look In: U
® | ocal Di

Libraries
lacadmin
OneDrive

Folder Name:  Wsclientil

Files of Type:

Cancel

A confirmation dialog shows the path and file name under which the log files are
stored. Depending on your system, you can copy the path using [Ctrl] + [C] and paste it into the File
Explorer's address bar.
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Save device files for support

Finished zipping of the device files

The archive with the device files was stored as
nf\LN\ic_files_for_support . d542c0d-4855- 829a-47108921593hb zip

Flease attach the archive to your support ticket for th e

() Depending on your network, hardware, and the amount and size of the log files, the collection and
the upload of the files might take up to a few minutes.
In the case of failure, try the following:

+ If you are using UMS 6.10.110 or higher: Go to UMS Administration > Global
Configuration > Device Network Settings and change the parameter Timeout for
the device support file upload action (seconds) to a higher value. The maximum
is 9000 seconds.

« Check if port 8443 is open for TCP connections.

+ If everything should fail, try the method described under Without UMS (see page 788).
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6. Open your system's File Explorer, go to the path portion of the file location.

o = | Uon ITGGEABYMWX4019

Home

« v =

Share

7 Quick access
[ Desktop
; Downloads
|‘:f] Documents
| Pictures

J! Music

== U on ITGGEABVMW

B videos

[z OneDrive

% % % %

[ This PC
[ Desktop
|j§ Documents
; Downloads
I! Music
=/ Pictures
= U on ITGGEABVMW
m Videos
‘i Local Disk (C:)

¥ Network

2 items

WView

> ThisPC » Uon [TGGEABYMWXA019

MName

Date modified

' tc file_s’_for support 351&&‘32-03:&4:46—...'

|j UMSLicensinglD.cert

v 0
Type Size

Compressed (zipp...
CERT File

Search U on [TGGEABVMW

4. o

7. Send the ZIP file to the IGEL support team.
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8. Close the confirmation dialog by clicking Finish.

Save device files for support
Finished zipping of the device files

stored as

Please attach the archive to your supponrt ticket for this

‘ Finish ‘

() Theabove procedure collects only those logs that have been written since the last system start. To allow
persistent logs, you can configure a dedicated partition for debug logs. For more information, also on
adding additional logs, see Extended Logging With Syslog, Tcpdump and Netlog (see page 383).

Without UMS

When the UMS is not accessible or there is an issue with network connectivity, you can still extract system logs from
a device and send them to support. You will need a USB stick, preferably formatted to NTFS format, to transfer the
logs to.

Setting Up the Device

1. Inthe IGEL Setup, go to Devices > Storage Devices > Storage Hotplug and enable Storage
Hotplug.
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* Storage De * Storage Hotplug

V' Storage plug
Default pe 1

Client Drive Mapping

Notification
V' Hotplug beep
¥ Hotplug me

Timeout

Terminal

on name

[j Local Terminal

Identifying the USB Stick

Read/Write

#) Dynamic

1. Plugthe USB stick into the IGEL OS device and start the terminal session.

2. Loginas root (bydefault, no password).

[Login as "user" or "root": root
root@ITCEBERC5193A90: ~# [

Local Terminal

3. Enter the following commands:
cd /userhome/media

1s -1
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4, Note the name of the USB stick:

login as "user" or "root": root

root@ITCOREBGCS5193A90:~# cd /userhome/media
root@ITCOOEOCS5193A90 : /userhome/media# 1s -1

total 4
drwxr-xr-x 1 user users 4096 Nov 10 lE:@lINEw VOLUME I
root@ITCOOEAC5193A90 : /userhome/media# |}

Writing the Log File
1. Intheterminal, run the command cd /userhome/media/[Name of your USB stick].
If there are spaces in the device name, use quotation marks "". Example: cd /userhome/

media/"NEW VOLUME"

If there are no spaces in the device name, quotation marks are not required.

2. Runthecommand journalctl > logfile.txt .Thiswill create the system log files on the
USB stick with the filename logfile.txt.

Local Terminal

root@ITCOBEGCS5193A50:/# cd /userhome/media/"NEW VOLUME"
root@ITCOOGEGC5193A90: /userhome/media/NEW VOLUME# journalctl > logfile.txt
root@ITCOOEOC5193A90 : /userhome/media/NEW VOLUME# [§

3. Safely eject the USB stick from the IGEL OS device.
You can now examine this log file yourself or send it to IGEL support for analysis.
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Exporting the Local Device Configuration

Issue

There is a specific support case and you need to read out the current local configuration of the device.

Solution

If you need to read out the current local configuration of the device (e.g. during a support case), you can copy the
two local files setup.ini and group.ini eitherlocally orviathe IGEL UMS.

Option 1: Via UMS Console > Help > Save device files for support

You can transferthe setup.ini and group.ini filestogether with the device's log files as described in the
section "With UMS" under Sending Thin Client Log Files to IGEL Support (see page 791).

Option 2: Via UMS Console > [device's context menu] > Export Device Settings

Alternatively, you can export the effective settings that affect the device (i.e. the interaction of local settings and all
profiles) as an XML file: UMS Console > [device's context menu] > Export Device Settings.
The IGEL Support can import this file into the UMS as a profile and view the effective settings directly in the UMS

Console.

> Firmware Customi =

v B Devices (2) O Delets
@ Clear "Configuration Change Status’ flag
Access control

¥ Pm Augsburg (2)
¥ fp techdoc (2)

v e RD (2) &% Cut
v t4-RD0 [ Copy
LJtRD0 [ Paste

» 8 Bremen (0)
Mobile Devices (0)

Shared Workplace

» K vie

- ek san

UMS Admil

Messages

Time
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Secure Terminal

Suspend

Shutdown

Wake up

Reboot

Update & snapshot commands
ICG Configuration

Other commands

Specific Device Command
Take over eaftinns frnm
Export Device Settings
Save device files for support

Logging
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Option 3: Via UMS Console > [device's context menu] > Other commands > Device File->UMS
You can also transmit the setup.ini and group.ini filesfrom the device to the UMS as follows:

1. Inthe UMS Console, select Other commands > Device File->UMS from the device's context menu
or under Devices in the menu bar.

2. Under Device file location, specify /wfs/ asthe source.

Example: /wfs/setup.ini
3. Under Target URL, select the destination on the UMS Server and enter the name of the transferred
file under File Name.

Example: https://umsserver.domain:8443/ums_filetransfer/setup.ini
4. Click Device File->UMS.
The file will be transferred to /rmguiserver/webapps/ums_filetransfer.

Option 4: Via copying to a USB storage device
You can also save the files locally on a FAT32-formatted USB stick:

1. Inthe IGEL Setup, go to Devices > Storage Devices > Storage Hotplug and enable Storage
Hotplug.
If you use static client drive mapping, make sure that the Number of drives is greater than zero.
See Storage Hotplug.

2. Create a terminal session under Accessories > Terminals.

Connect your USB stick.

4. Open theterminaland loginas root.

w

(O Tofind out the name of the USB stick, you can use the commands:
cd /userhome/media

1s -1

If there are spaces in the device name, you'll have to include it later in the quotation marks "".
If there are no spaces in the device name, quotation marks will not be required.

5. Type cp /wfs/*.ini /media/[name of USB storage device]/ and press[Return]

tocopyall .1ini filesfrom your endpoint device, incl. setup.ini and group.ini,tothe
USB stick.
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6. Type sync and press [Return]. Wait a few seconds before safely ejecting the USB stick from the
endpoint device.

Local Terminal (=)[™)[x]
login as "user™ or "root": root -
root@TD-RDO3:~# cd Suserhome/media

root@ID-RDO3: fuserhome/media# 1s -1

total 16

drwxr-xr-x 4 user users 16384 Jan 1 1970 "NEW VOLUME'

root@TD-RDO3: fuserhome/media# cd

root@lD-RDO3:~# cp /wfs/*.ini /media/"NEW VOLUME"/

root@lD-RDO3:~# sync

root@TD-RDO3:~# | =
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Which Unified Communication Solutions Does IGEL OS Support?

This article provides an overview of the Unified Communication software and hardware solutions that are
supported by IGEL OS.

Hardware

» Jabra Handsets / Headsets
+ Poly Headsets
« EPOS/Sennheiser

Virtual Desktop Optimizations

The virtual desktop optimizations provide the endpoint device with a media engine and redirect the audio and
video streams so that they are exchanged directly between the endpoint devices. This results in higher performance
and a lower server load.

For Citrix Sessions

« Skype for Business; for configuration, see the chapter Skype for Business in the IGEL OS Reference
Manual.

« Cisco Jabber (JVDI Client); for configuration, see the chapter Cisco Jabber in the IGEL OS
Reference Manual.

For Horizon Sessions

« Skype for Business; for configuration, see the chapter Skype for Business in the IGEL OS Reference
Manual.

Local Installation on the Endpoint Device with a Custom Partition

In contrast to the virtual desktop optimizations, where the Unified Communication apps are installed on the VDI
server, this approach involves installing the apps on the endpoint device. This is achieved by using the Custom
Partition mechanism of IGEL OS.

For building a Custom Partition by yourself, see the Custom Partition Tutorial (see page 546).
You can acquire any of the following Custom Partitions free of cost; just ask your IGEl contact:

+ TeamViewer
« Zoom (see also Zoom as a Custom Partition (see page 588) in the Custom Partition Tutorial (see page
546))
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Passthrough Authentication

Passthrough authentication is a convenient single sign-on method. With this function, an IGEL user logs in once and
gains access to all sessions without having to explicitly authenticate themselves again for each of them.

This document explains what basic settings are necessary for passthrough authentication and where you can
enable the single sign-on method in the relevant sessions.

« Introduction (see page 796)
+ Basic configuration (see page 798)
+ Session Configuration (see page 805)

IGEL Tech Video

Sorry, the widget is not supported in this export.
But you can reach it using the following URL:

https://www.youtube.com/watch?v=JxGOEGAb3LI
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Introduction

Two methods of single sign-on for a session are available:

Kerberos Passthrough Real Kerberos authentication with clients that support Kerberos.

Within a session, you can access network resources, e.g. file servers,
without having to authenticate yourself again; this works automatically
via Kerberos.

Passthrough Uses cached credentials (user name and password) from local log-on for
authentication.

For access to network resources within sessions, you have to enter your
credentials again.

Kerberos is an authentication service. It operates with user, service and computer entities which are known as
principals. These principals all belong to a realm, an administrative unit. Each principal has a unique principal
name within the realm. To provide the authentication system, a service known as key distribution center is used.

As an example, Microsoft Windows Domains form a realm. The Windows Domain name is the realm name (in upper
case letters), e.g. EXAMPLE.COM . A user principal would be for example user@EXAMPLE.COM . The domain
controllers take on the role of the key distribution centers.

When logging in, a user obtains a ticket granting ticket from the key distribution center. This ticket expires after a
certain time (usually 1 day). When the user starts an ICA session for example, the client can obtain a so-called

service ticket from the key distribution center with the aid of the ticket granting ticket. With this service ticket,
authentication for the ICA server is accomplished.

IGEL OS Articles 796 /823



Miscellaneous

User requests a Ticket
Granting Ticket TGT, gives
password

Authentication Service verifies
the user and grants a TGT

User wishes to connect to a
server and sends TGT to the
Ticket Granting Service
requesting a Service Ticket ST

TGS verifies user TGT and
grants ST

User sends ticket to server

Server verifies user, then
verifies itself to the user

The communication is
established

- .-
Z Z
U Key Distribution Ticket Granting Server
Ser Center Service
— D
— @
TGT sT? —
< st!
- —J
i ST i >
i
< Verification

To enable passthrough authentication you have to make certain settings:

1. Modify certain basic settings which are necessary to fulfill the conditions for Kerberos passthrough

authentication. (see page 798)
2. Enable passthrough authentication in the relevant session. (see page 805)
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Basic configuration
Your client configuration must fulfill certain conditions before you can enable passthrough authentication.

« Set the time correctly on all involved hosts and clients. (see page 799)

+ Configure the domain. (see page 800)
+ Activate login to the Active Directory domain. (see page 802)

@ When activating the Smartcard login method, some additional configuration may be necessary (see page
803).
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Time
The time must be set correctly on all involved hosts and clients.
The best practice procedure is as follows:

1. Activate Use NTP Time Server under System > Time and Date in the setup.
2. Specify the NTP Time Server.

® AWindows domain controller can be used for this, if applicable.
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Domains/Realms
To configure the domain(s) proceed as follows:

1. Click Security > Active Directory/Kerberos.
2. Activate enable to enable Kerberos.
3. Enter the fully qualified domain name under Default Domain, e.g. EXAMPLE.COM (upper case

letters).
. Enable DNS Lookup for Domain Controller and DNS Lookup for Domain.

N

(@ These settings are sufficient for the domain setup when the DNS servers, e.g. the domain
integrated MS DNS servers, are aware of the Active Directory.

Otherwise you may configure up to 4 domains/realms:

1. Click Security > Active Directory/Kerberos > Domainl...4.
2. Enter the fully qualified domain name, e.g. EXAMPLE.COM (upper case letters).

3. Specify at least one Windows domain controller (Kerberos key distribution center) in the Domain
Controller List.
It can be a DNS name or an IP address.

Fully Qualified Domain Name ) 'EmMPLE.COM

Domain Controller List

Domain Controller

Domain Controller €) | dc.example.com

0Ok Cancel

4. Click Security > Active Directory/Kerberos > Domain Realm Mapping to define the mapping
between Active Directory domain names and DNS names.
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5. Activate Use default DNS Domain - Active Directory Domain Mapping.

(/] Use default DNS Domain - Active Directory Domain Mapping

Domain Realm Mapping

DMS Host or Domain Name |Actiue Directory Domain Name

Add »

DMS Host or Domain Name

Active Directory Domain Name

Ok Cancel

® Ifboth names match, i.e. if a hostin the domain EXAMPLE.COM has the DNS name

host.example.com, nothing needs to be done here and the default setting is sufficient. Otherwise an
appropriate entry in the Domain Realm Mapping list has to be created.
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Login

1. Click Security > Logon > Active Directory/Kerberos.
2. Activate Login to Active Directory Domain.
3. Choose one or more of the following login options:
+ Explicit: A login dialog is presented to the user.
+ Remember last user name: The login dialog will be prepopulated with the last user name
that logged in. This option can be checked for convenience if Explicit Login is selected.
+ Smartcard: Login with smartcard and related smartcard PIN.
4. Underneath Logout Shortcut Locations, specify where a log-out button will appear.
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Smartcard

For using the Smartcard login method, some additional configuration is necessary:

1. Under Security > Logon > Active Directory/Kerberos, activate Smartcard.
2. Under Smartcard removal action, define what should happen when the smartcard is removed:
+ Log out: Performs a disconnect or log out of running sessions, removes all user related data

from the device and prepares the device for the next user login.
+ Lock device: Locks the screen during sessions. Only the user who is already logged in can
unlock the device with his smartcard and PIN. Additionally, select User password under
User Interface > Screenlock [ Screensaver > Options, to make the setting effective.
3. Choose an appropriate PKCS#11 module under Security > Smartcard > Middleware.

@ The smartcards for this login must be supported by a PKCS#11 module which can access
the certificates on the smartcard.

Kerberos login with a smartcard involves certificates. The root certificate of the certificate used by the key
distribution center (domain controller) must therefore be available on the device. Either the root certificate is one
of the public trusted certificate authorities or it must be deployed to the device, see Deploying Trusted Root

Certificates (see page 484).

@ When using Windows 2000 or Windows Server 2003-based domain controllers in combination with
smartcard login, the parameter auth.krb5.realms.pkinit.pkinit_win2k hasto be activated

in the registry. This enables the use of an earlier protocol version of PKINIT preauthentication.
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Kerberos Ports

The following Kerberos ports are relevant for Linux environments:

UDP Port TCP Port
Getting tickets including the initial TGT 88 88
Changing password from UNIX/Linux 749
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Session Configuration
For single sign-on with sessions, two methods are available:

+ Kerberos Passthrough: Uses real Kerberos authentication with clients that support Kerberos.
+ Passthrough: Uses cached user name and password from local logon for authentication.

(@ Currently, real Kerberos authentication is only available in Citrix sessions.
In the following sections, you can find how to activate passthrough authentication in sessions that support it:
« Citrix StoreFront/Web Interface (see page 806)
* RDP (see page 807)

» Horizon Client (see page 808)
+ Parallels Client (see page 809)
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Citrix StoreFront/Web Interface

1. Go to Sessions > Citrix > Citrix Global > StoreFront Login.

2. Select the Authentication type:

+ Password authentication: To enable passthrough, this option must be selected, and Use
Passthrough authentication must be activated.

+ Kerberos passthrough authentication

« Smartcard authentication (StoreFront only, not Web Interface): Authentication via
smartcard will only work with StoreFront, not with Web Interface.

« Citrix authentication mechanism (instead of IGEL), Smartcard disabled

« Citrix authentication mechanism (instead of IGEL), Smartcard enabled

See also StoreFront Login.
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RDP
For RDP sessions, passthrough is supported. Kerberos passthrough is not yet supported.

1. Goto Sessions > RDP > RDP Sessions > [session name] > Logon.
2. Enable Use passthrough authentication for this session.
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Horizon Client
For Horizon sessions, passthrough is supported. Kerberos passthrough is not yet supported.

1. Goto Sessions > Horizon Client > Horizon Client Sessions > [session name] > Connection
settings.
2. Enable Use passthrough authentication for this session.
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Parallels Client
For Parallels Client sessions, passthrough is supported. Kerberos passthrough is not yet supported.

1. Goto Sessions > Parallels Client > Parallels Client Sessions > [session name] > Connection.
2. Enable Use system credentials to use the passthrough authentication.
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Hardware Video Acceleration on IGEL OS

Question

Does my hardware with IGEL OS offer video acceleration?

Answer

Open Application Launcher > About to look up your product ID and device type:

Application Launcher

Product

Copyright

Firmware Release Date

Firmware Version

IGEL Technology GmbH
Mittwoch, 5. August 2020
11.04.100.01

IProduct ID

UD3-LX 51

Product Name

Website

License Information

Workspace Edition Maintenance Expiration Date
Enterprise Management Pack Expiration Date
Workspace Edition Add-on Teradici Expiration Date
Network

Local Name

Default gateway

DNS Server 1

DNS Server 2

Universal Management Suite

Interface 1 (eth0)
Description

Hardware Address

IP Address
Hardware

Boot Mode
CPU Model

IGELOS 11

https:/fwww.igel.com

@ Freitag, 12. Marz 2021
@ Freitag, 12. Marz 2021
@ Donnerstag, 3. September 2020

ITCOOEQOCS20986A

Realtek Semiconductor Co., Ltd.
RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller

00:E0:C5:20:98:6A

EFI
AMD GX-424CC SOC with Radeon(TM) RSE Graphics (4 CPUs)

I Device Type

IGEL M340C |

Flash size

Graphics Chipset

IGEL OS Articles
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IGEL

In version 5.07.100 and newer and version 10.01.100 and newer, IGEL OS offers hardware video acceleration for

+ Media Player

« Citrix Multimedia Redirection

« RDP Multimedia Redirection (TSMF and EVOR)
« VMware Horizon Multimedia Redirection

on selected devices. This allows playing back HD video with a maximum of 20% CPU usage.

() The Multimedia Codec Pack (MMCP) is required for this feature if your IGEL OS version is lower than
11.01.100.

Hardware video acceleration is supported on the following IGEL devices:

ProductID Device Type Chipset IGEL Linux >=IGEL Linux >=IGEL OS IGEL OS

v5.07.100  v5.09.100 10 11
|Z2-HDX/RFX/ IGEL D220 Intel Bay Trail v/ v V4 V'™ (see
HORIZON page 812)
40" (see page
812)
1Z3-HDX/RFX/ IGEL M330C  VIAVX900 v
HORIZON 41,

42

1Z3-HDX/RFX/ IGELM340C  ATI Mullins v4 v V" (see

HORIZON page 812)

50* (see page

812)

1Z3-HDX/RFX/ IGELM340C  ATI Mullins 4 V'* (see

HORIZON page 812)

51* (see page

812)

UD2-LX 40 IGEL D220 Intel Bay Trail v/ v v 4

UD2-LX 50,51 IGEL M250C Intel HD v
Graphics

UD3-LX 40 IGEL M320C  VIA VX900 v

UD3-LX 41,42 IGELM330C  VIAVX900 v

UD3-LX 50 IGEL M340C  ATI Mullins v V4 v

UD3-LX 51 IGEL M340C  ATI Mullins v V4
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IGEL

ProductID Device Type Chipset IGEL Linux >=IGEL Linux >=IGEL OS IGEL OS
v5.07.100 v5.09.100 10 11
UD3-LX 60 IGEL M350C  AMD Radeon v
Vega 3
Graphics
UD5-LX 40 IGEL H820C Intel Sandy v v v4
Bridge
UD5-LX 50 IGEL H830C  Intel Bay Trail v/ v v v
(Dualcore CPU
Model)
UD6-LX 51 IGEL H830C  Intel Bay Trail v/ v v v
(Quadcore CPU
Model)
UD7-LX 10 IGEL H850C AMD Radeon v4 v
Graphics
UD7-LX 11 IGEL H850C AMD Radeon V4
Graphics
UD7-LX 20 IGEL H860C AMD Radeon v
Vega 8
Graphics
UD9-LX 40, IGELUD9 BT Intel Bay Trail V4 v v
UD9-LX 41
Touch
UD10-LX IGELUD10 VIA VX900 v V4
TC236

(@ On3rd-party hardware with UDC3, IGEL OS Creator (OSC), and UD Pocket, hardware video acceleration
depends on the graphics chipset of the device.

Codecs
The following codecs are supported:

« MPEG-2 (simple and main profiles)

+ H.264 (baseline, main and high profiles)

« WVC1/WMV3 (simple, main and advanced profiles)

« MPEG-4 (DivX/Xvid): only on VIA VX900 and ATI Mullins

* To upgrade your IZ device to IGEL OS 11, please contact your IGEL sales representative. See also https://
www.igel.com/tradeup/ and The IGEL OS 11 Migration Plan.
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Running Commands before or after a Session

Symptom

You want to run shell commands before a specific session is started or after it has terminated.

Problem

You need hooks which will call your shell commands.

Solution

As of IGEL Universal Desktop Linux 5.06.100 there is a generic mechanism for calling shell commands before and
after a session. It works with Citrix ICA, RDP and VNC Viewer sessions.

This feature is accessible only through the Registry.

Open Setup at System > Registry. Use either the Registry tree or the Search parameter ... function to locate the
following Registry keys:

for VNCviewer:

sessions.vncviewerx*.init_action

sessions.vncviewerx,.final_action

for RDP:

sessions.winconnect*.init_action

sessions.winconnectx.final_action

for Citrix/ICA:

sessions.icax*x.init_action

sessions.icax.final_action
(where * is the related session number, e.g. 0,1,2,3,...)

The init_action isexecuted before the session is started. The final_action isexecuted after the session
has been terminated. Enter shell commands or the path to a custom script or executable:
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“ IGEL Setup 5.06.100.rc5.01 (Build 4.9.1) -0 X
a 2 g =" Th
= = = "8 ii' )
Tirme and Date  Update Remote Shadow  Remote Energy Firrmweare Registry
management Access Customization
- >
|sessions.winconnecto.init_action |
) ¥ winconnectd o
~ Time and Date 1 ~ applaunch
» o Update ' ~ applaunch_system
> - Remote management ~ autostart
init action
~ Shadow ~ desktop
» - Remote Access  desktop_path U |,vwf5,rmy_script.sh
> o Energy ) -
» o Firmware Customization & final_action
- Registry ~ hotkey
~ hotkeymodifier
~ icon
~ init_action
|
P rmeni nath
. L7 Addinstonce  Delete stance

(@ The Registry keys for newly created sessions only appear after a restart of Setup.

® Your init_action scripts or executables have to return before the session will start. Alternatively,

background your command by adding '&' to the end of the commandline.
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Copy Sessions in Setup or UMS

Sometimes you want to create a session that differs from another only in a few details. /IGEL Linux version 5.10.100 or
newer and UMS version 5.02.100 or newer let you copy complete sessions. Once the session is copied, you can easily
adapt the required settings.

Copying is available in the Sessions section of IGEL Setup (and occasionally in some other sections) as well as in the
Edit Configuration function in UMS.

To copy a session, proceed as follows:

1. Inthe setup, open the menu path Sessions > [Session Type] > [Session Type] Sessions.
Example: Sessions > RDP > RDP Sessions
The existing sessions are shown.

2. Highlight the session that you want to copy.

3. Click .
A copy of the session will be created within the same folder.
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1Z1 and UD2-MM Usage of RAM

How is RAM used by processes in UD2-MM and 1Z1 (also known as ARM or SoC devices)?

Atotal of 1024 MB main memory is divided as follows:

« ~128 MBiis used for graphics
« ~362 MB is used for internal processes such as communication between DSP and ARM processor
« ~534 MB is available for user processes
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Starting UMS Console Crashes NX Session

Symptom:

When you are connected to an Ubuntu host via NX, starting UMS console on the Ubuntu host crashes the NX
session.

Solution:

1.
2.

ok W

Become Root on the Ubuntu host.
Open the configuration file /opt/IGEL/RemoteManager/rmclient/

RemoteManager.bin.config inatexteditor.

Add the line vmparam -Dsun.java2d.xrender=false to thefile.

Save the file.
Become a regular user.
Start UMS Console.
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Accessing IGEL Setup within Appliance Mode

Symptom

When using the appliance mode, IGEL Setup is not accessible directly.

Problem

Within the appliance mode, all other local applications are hidden; the system's hotkey [Ctrl+Alt+s] does not work
either.

Solution
To start the IGEL Setup within the appliance mode, press hotkey [Ctrl+Alt+F2].
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An Application Window Cannot Be Repositioned

Symptom

Some application windows, e.g. VMware Horizon windows, are placed at startup in the upper left corner instead of
being displayed in the middle. In case of frameless applications, the window cannot then be moved and may
conceal the icons.

% vMware Horizon

= ) |I 57 o857

Problem

Either the screen is too small or the selected resolution is too low.

Solution

1. Go to System > Registry.
2. Select the registry key windowmanager.wmO.variables.placement_ratio.

3. Specify a higher percentage value under Maximum window size for which the preferred
placement should apply. This entry refers to the total work area.

() The preferred placement is defined with the registry
key windowmanager.wm@.variables.placement_mode .
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< >

= - er.wm0.variables.placement_ratio
Configuration Mo.v ] ment_|

nt should apply.

. Registry

opaquel
B opaque

t_mode
. placement_ratio

Search B preventfo

Delete Ir

Apply Ok

Example

Session: VMware Horizon Client
Screen resolution: 1366x768
Value for Maximum window size for which the preferred placement should apply: at least 40%
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IGEL

Updating IGEL UMD: Error "not compatible with System5"

Symptom
Universal Multi Display firmware (IGEL UMD) can't be updated to version 4.13.100.

Error Message:

Firmware not compatible.
dmx_networkd: Slave #0 (MAC) not compatible with System5

Solution

Delete file /tmp/NOT_SYS_5_COMPATIBLE from UMD master client and update again without rebooting.
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Will My Session Be Closed When My IGEL OS Endpoint Device Enters
Suspend Mode?

This article will teach you how to configure your IGEL OS device so that your session is not interrupted when your
device goes into suspend mode.

Session Disconnection on Suspend

When an IGEL OS endpoint device goes into suspend mode (S3), remote sessions like Citrix, Microsoft Windows RDP,
or VMware Horizon, for instance, will be disconnected.

IGEL Environment

+ Endpoint device with IGEL OS 11
+ Remote session, e.g. Citrix, Microsoft Windows RDP, or VMware Horizon

Avoiding Possible Issues

Modern server-based or cloud-based systems provide remote session resume features on the server side. Check out
the relevant documentation for your system.

Configuring Suspend Mode

» To allow or disallow suspend mode, go to System > Power Options > Shutdown and set the following
parameters according to your needs:

+ Allow system suspend

+ Default action: Select the action when the Dialog timeout has expired.
¥ Allow system shutdown
V' Allow system suspend

Vv Allow canceling of shutdown process

Default action | Suspend

Shutdown

Without dial>g Suspend Dialog timeout
Cancel
Mothing

> 1o configure suspend or shutdown on inactivity, go to System > Power Options > System and set the following
parameters according to your needs:
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IGEL

+ System suspend/shutdown on inactivity: Set the timeout after which the system shuts down or
enters suspend mode.

+ System action on inactivity: Define whether the system should enter suspend mode or shut
down after the timeout.

System suspend/shutdown on inactivity ) |.ﬂ~1‘ter 10 mins

System action on inactivity Suspend

Without dialog

On Battery
CPU Power Plan Balanced (recommended)

Tray lcon
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