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Overview: First Steps with IGEL OS 11
The following article provides a short overview of how to get started with an IGEL device or a third-party device that 
you want to convert to IGEL OS. The steps are generally the same, but in the case of a third-party device you will 
need to use the IGEL OS Creator. 



Overview: First Steps with IGEL OS 11

1 https://www.igel.com/software-downloads/workspace-edition/
2 https://www.youtube.com/watch?v=3YJnFiE7y5w
3 https://www.youtube.com/watch?v=p52CxtB_0ok
4 https://www.youtube.com/watch?v=j31c8dzBMAg
5 https://www.youtube.com/watch?v=01N-9b3P4wo
6 https://www.youtube.com/watch?v=Sc38mRv5Z1s
7 https://www.youtube.com/watch?v=6WfLVgYBTHg
8 https://www.igel.com/software-downloads/workspace-edition/
9 https://www.youtube.com/watch?v=3YJnFiE7y5w
10 https://www.youtube.com/watch?v=p52CxtB_0ok
11 https://www.igel.com/software-downloads/workspace-edition/
12 https://www.youtube.com/watch?v=xVqcX6QTZ5g
13 https://www.youtube.com/watch?v=j31c8dzBMAg
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IGEL Device 3d-Party Device

Step 1: Download and install the UMS
IGEL Download Server1

Instruction: Installing an IGEL UMS Server
Video: UMS installation on a Windows Server2 
Video: UMS installation on a Linux operating 
system3 

Step 2: Activate your IGEL OS 11

with the Setup Assistant (free 
evaluation license):

Instruction: Setup Assistant for IGEL OS, 
section "Register for Demo License". See also 
Getting a Demo License.
Video: Acquire a Demo License Including 
Workspace Edition and Enterprise 
Management Pack4

via UMS (purchased license):

Deploy licenses using automatic or manual 
license deployment method.
Video: Register an endpoint in the UMS and 
assign a license to it5

Step 3: Configure your device

with the UMS:

Create a profile with the required settings 
and assign it to the device. See also Profiles.
Video: Configure an endpoint in the UMS 
using profiles6

without the UMS:

Use the IGEL Setup on the device, e.g. to 
configure User Interface and Sessions.
Video: Configuring an Endpoint with IGEL OS 
117

Step 1: Download and install the UMS
IGEL Download Server8

Instruction: Installing an IGEL UMS Server
Video: UMS installation on a Windows Server9 
Video: UMS installation on a Linux operating 
system10 

Step 2: Download IGEL OS 11
IGEL Download Server11, section OS 11 > OS  
Creator

Step 3: Convert your device to IGEL OS 11
IGEL OS Creator Manual
Video: Converting an x86-Endpoint Using the 
IGEL OS Creator12

Step 4: Activate your IGEL OS 11

with the Setup Assistant (free 
evaluation license):

Instruction: Setup Assistant for IGEL OS, 
section "Register for Demo License". See also 
Getting a Demo License.
Video: Acquire a Demo License Including 
Workspace Edition and Enterprise 
Management Pack13

via UMS (purchased license):

Deploy licenses using automatic or manual 
license deployment method.

https://www.igel.com/software-downloads/workspace-edition/
https://www.youtube.com/watch?v=3YJnFiE7y5w
https://www.youtube.com/watch?v=p52CxtB_0ok
https://www.youtube.com/watch?v=j31c8dzBMAg
https://www.youtube.com/watch?v=01N-9b3P4wo
https://www.youtube.com/watch?v=Sc38mRv5Z1s
https://www.youtube.com/watch?v=6WfLVgYBTHg
https://www.igel.com/software-downloads/workspace-edition/
https://www.youtube.com/watch?v=3YJnFiE7y5w
https://www.youtube.com/watch?v=p52CxtB_0ok
https://www.igel.com/software-downloads/workspace-edition/
https://www.youtube.com/watch?v=xVqcX6QTZ5g
https://www.youtube.com/watch?v=j31c8dzBMAg
https://www.igel.com/software-downloads/workspace-edition/
https://www.youtube.com/watch?v=3YJnFiE7y5w
https://www.youtube.com/watch?v=p52CxtB_0ok
https://www.youtube.com/watch?v=j31c8dzBMAg
https://www.youtube.com/watch?v=01N-9b3P4wo
https://www.youtube.com/watch?v=Sc38mRv5Z1s
https://www.youtube.com/watch?v=6WfLVgYBTHg
https://www.igel.com/software-downloads/workspace-edition/
https://www.youtube.com/watch?v=3YJnFiE7y5w
https://www.youtube.com/watch?v=p52CxtB_0ok
https://www.igel.com/software-downloads/workspace-edition/
https://www.youtube.com/watch?v=xVqcX6QTZ5g
https://www.youtube.com/watch?v=j31c8dzBMAg


Overview: First Steps with IGEL OS 11

14 https://www.youtube.com/watch?v=01N-9b3P4wo
15 https://www.youtube.com/watch?v=Sc38mRv5Z1s
16 https://www.youtube.com/watch?v=6WfLVgYBTHg
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IGEL Device 3d-Party Device

Video: Register an endpoint in the UMS and 
assign a license to it14

Step 5: Configure your device

with the UMS:

Create a profile with the required settings 
and assign it to the device. See also Profiles.
Video: Configure an endpoint in the UMS 
using profiles15

without the UMS:

Use the IGEL Setup on the device, e.g. to 
configure User Interface and Sessions
Video: Configuring an Endpoint with IGEL OS 
1116

https://www.youtube.com/watch?v=01N-9b3P4wo
https://www.youtube.com/watch?v=Sc38mRv5Z1s
https://www.youtube.com/watch?v=6WfLVgYBTHg
https://www.youtube.com/watch?v=01N-9b3P4wo
https://www.youtube.com/watch?v=Sc38mRv5Z1s
https://www.youtube.com/watch?v=6WfLVgYBTHg
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Update and Upgrade
Adapting IGEL OS 11.04 or Higher for Devices with Small Storage (see page 7)
Upgrading UDC3 or UD Pocket from IGEL OS 10.06 to IGEL OS 11 via Universal Firmware Update (see 
page 10)
Upgrading from IGEL OS 10 to IGEL OS 11 (see page 64)
Buddy Update (see page 224)
Firmware Update (see page 231)
Updating IGEL OS Using a USB Storage Device (see page 234)
Updating the Firmware using the Linux Console (see page 236)
Error: "Not enough space on local drive" when Updating to IGEL OS 11.04 or Higher (see page 239)
Error: "legacy ICG Root (CA) certificate" When Updating to Igel OS 11.04 on Devices Connected via 
ICG (see page 241)
Device Does Not Connect to ICG after Update to IGEL OS 11.04 or Higher (see page 243)
IGEL OS Automatic Update Service for Device Evaluation (see page 245)
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Adapting IGEL OS 11.04 or Higher for Devices with Small Storage

Environment
This article is valid for the following environment:

IGEL OS 11.04 or higher
UMS 6.05 or higher (recommended)
Endpoint device that is supported by IGEL OS 11.04.100 or higher but the free storage is lesser than 
required by the full feature set

Overview
For IGEL OS 11.04.100 or higher with the full feature set, a minimum of 2 GB storage is required. If your device has 
less free storage than required, e.g. because of large custom partitions, you can reduce the feature set so that the 
firmware fits on your device's storage. 

Perform these two steps:

Determining Which Features to Deactivate (see page 7)
Reducing the feature set by one of the following methods:

Using a UMS Profile (see page 7)
Using the Preconfigured Reduced INF File (see page 8)
Customizing the INF File (see page 8)

Determining Which Features to Deactivate
 Determine the storage requirements of the individual IGEL OS features using one of these methods:

Go to IGEL OS Release Notes, select the "Notes for Release" of your firmware version, then select 
"Component Versions...", and go to the "Services" section. The "Reduced Firmware" column 
indicates for each feature whether it is included in the preconfigured reduced feature set or not.
Open the readme[version].txt  in your update source directory and search for "Reduced 
Firmware". 

Reducing the Feature Set

Using a UMS Profile

Buddy Update Server

When you download a firmware that has been reduced with the UMS (or the device's Setup) on a buddy 
update server, the buddy server itself will have the full feature set anyway. Hence, all devices that are used 
as update servers must have sufficient free storage. 


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Choose an appropriate profile that is assigned to all relevant devices, or create a new profile. For 
further information, see Creating Profiles.
Go to  System > Firmware Customization > Features and deactivate all features that are not 
needed. 

Using the Preconfigured Reduced INF File

Replace the lxos.inf  file as follows:

Go to the directory that contains the source files for the firmware update. If you use the WebDav 
capability of the UMS, this is <UMS installation 

directory>\rmguiserver\webapps\ums_filetransfer\<firmware version> ; 

example:  C:\Program 

Files\IGEL\RemoteManager\rmguiserver\webapps\ums_filetransfer\IGEL_O

S_11-11.04.100

Delete lxos.inf

Copy  lxos-reduced.inf  to  lxos.inf
Start the firmware update as usual.

Customizing the INF File

Reduced Feature Set Cannot Be Changed by Setup/UMS

When you have reduced the firmware using this method, you cannot reactivate features via the Setup resp. 
the UMS configuration dialog. To recover the complete feature set, you must copy lxos-full.inf  to 

lxos.inf  and then start the firmware update.



Buddy Update Server

When you have downloaded a reduced firmware on a buddy update server, also the buddy server itself has 
the reduced feature set. To recover the complete feature set on the buddy server, you must copy lxos-

full.inf  to lxos.inf  in the update source and then update the buddy update server again.



It is safe to delete lxos.inf  because there is a backup file named lxos-full.inf  

Reduced Feature Set Cannot Be Changed by Setup/UMS

When you have reduced the firmware using this method, you cannot reactivate features via the Setup resp. 
the UMS configuration dialog. To recover the complete feature set, you must copy lxos-full.inf  to 

lxos.inf  and then start the firmware update.


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To customize the INF file:

Open lxos.inf

In the  [INFO]  section, add the following line:

custom="true"

Delete the [PART]  section of every partition you want to exclude, but do this ONLY IF the section 
has both of the following entries:
dispensable="true"

type="squashfs-auto"

Save lxos.inf  and start the firmware update as usual.

Buddy Update Server

When you have downloaded a reduced firmware on a buddy update server, also the buddy server itself has 
the reduced feature set. To recover the complete feature set on the buddy server, you must copy lxos-

full.inf  to lxos.inf  in the update source and then update the buddy update server again.


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Upgrading UDC3 or UD Pocket from IGEL OS 10.06 to IGEL OS 11 via 
Universal Firmware Update
This document describes how to upgrade UDC3 or UD Pocket devices from IGEL OS 10.06 to IGEL OS 11 via the 
Universal Firmware Update feature of the UMS (Universal Management Suite).

Since a new licensing model has been introduced with IGEL OS 11, a license from an IGEL Workspace Edition 
Product Pack must be available for each device. If you have valid maintenance for your devices, you can convert 
your existing UDC3 or UD Pocket Product Packs to Workspace Edition (WE) Product Packs; see Converting UDC3 or 
UD Pocket Licenses for Upgrading to IGEL OS 11.

Read all the following chapters in the order given and follow the instructions.

Devices That Can Be Upgraded to IGEL OS 11 (see page 11)
Important! Consider This Before Upgrading (see page 24)
Getting the UMS Ready (see page 26)
Deploying the Licenses (see page 27)
Creating the Universal Firmware Update (see page 28)
Creating an Upgrade Profile (see page 39)
Assigning the Upgrade Profile and the Universal Firmware Update to the Test Devices (see page 48)
Testing the Upgrade (see page 52)
Unassigning the Upgrade Profile and the Universal Firmware Update (see page 54)
If Applicable: Restoring Custom Partition and Custom Applications (see page 55)
Upgrading All Devices (see page 56)
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Devices That Can Be Upgraded to IGEL OS 11
In this section, you find the general hardware requirements for IGEL OS 11 and a list of third-party devices officially 
supported by IGEL OS 11.

Core Requirements

CPU with 64-bit support
CPU speed: ≥ 1 GHz
Memory (RAM): ≥ 2 GB

Storage: Depends on the release version of IGEL OS 11. The details are listed below: 2 GB 
minimum; ≥ 4 GB recommended

Up to IGEL OS 11.03: 2 GB minimum; ≥ 4 GB recommended
From IGEL OS 11.04 to IGEL OS 11.07: If the full feature set is applied, at least 2.4 GB of 
storage is required. For instructions on how to reduce the feature set, see Error: "Not 
enough space on local drive" when Updating to IGEL OS 11.08 or Higher.
From IGEL OS 11.08 onwards: If the full feature set is applied, at least 2.4 GB of storage is 
required. For instructions on how to reduce the feature set, see Error: "Not enough space on 
local drive" when Updating to IGEL OS 11.08 or Higher. TODO Add URL when published

No VIA graphic adapter; VIA graphics support is discontinued in IGEL OS.
Legacy Bios and EFI/UEFI are supported.

Devices Supported by OSC and UD Pocket with IGEL OS 11

•
•
•

RAM size higher than 2 GB is recommended if you use any of the following:
Unified Communications optimizations (uses a client-side media engine)
High-resolution graphics output
More than two monitors



With devices that have 2 GB RAM and shared video memory, a maximum of 512 MB may be 
used as video memory.



The following list only includes those devices that are tested by IGEL (with each major release of IGEL OS).
By no means it implies that the devices which are not included in this list but meet the minimum 
requirements will not function with IGEL OS: Any x86-64 hardware endpoint device that meets the IGEL-
stated minimum hardware requirements for IGEL OS (for example, the processor speed and RAM) can be 
expected to work adequately with IGEL OS and should be considered a candidate for repurposing from 
another OS. With an IGEL OS subscription or active maintenance, customers can expect IGEL to make any 
necessary “best effort” to support, regardless of whether the endpoints in question are specifically listed 
within the IGEL Knowledge Base or elsewhere (e.g. on the IGEL Ready Showcase at https://www.igel.com/
ready/showcase-categories/endpoints/).
For any devices not listed here or on the IGEL Ready showcase, you can contact your hardware vendor and 
request those devices to be added to the IGEL Ready program.



https://www.igel.com/ready/showcase-categories/endpoints/
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ADS-Tec

Name Endpoint Type Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

DVG-
VMT9010

Industrial PC/
Terminal

4 GB

8 GB

64 GB eMMC Intel Atom® x7-
E3950

11.02.100

DVG-
VMT9012

Industrial PC/
Terminal

4 GB

8 GB

64 GB eMMC Intel Atom® x7-
E3950

11.02.100

DVG-
VMT9015

Industrial PC/
Terminal

4 GB

8 GB

64 GB eMMC Intel Atom® x7-
E3950

11.02.100

DVG-
VMT9112

Industrial PC/
Terminal

4 GB

8 GB

64 GB eMMC Intel Atom® x7-
E3950

11.02.100

Integrated drivers and supported peripherals are listed in the Third-Party Hardware Database17. For more 
solutions compatible with IGEL OS, see Partner Solutions.

HP, Lenovo, and LG device models are available from the factory with pre-installed IGEL OS 11. Please 
contact IGEL Ready18 to get information on which device models are available with pre-installed IGEL OS.



For some of the devices listed here, Flash memory must be extended to ≥ 2 GB. For these devices, an 
appropriate note is added.



On modern computers such as secured-core PCs (see e.g. https://www.microsoft.com/en-us/windows/
business/devices?col=secured-core-pcs), there may be a BIOS setting related to Secure Boot that allows 
the use of Microsoft’s 3rd party UEFI Secure Boot Certificate. The usual description of such a BIOS setting is 
"Allow Microsoft 3rd Party UEFI CA". This setting must be set to enabled, as IGEL uses the 3rd party 
certificate to support UEFI Secure Boot. If UEFI Secure Boot is enabled, but "Allow Microsoft 3rd Party UEFI 
CA" is not enabled, you may be unable to boot IGEL OS Creator or UD Pocket. Similarly, if the setting 
"Allow Microsoft 3rd Party UEFI CA" is disabled after a previous installation of IGEL OS, IGEL OS will fail to 
boot. For how to enable the setting, see Secured-Core PCs: Microsoft 3rd-Party UEFI Certificate for Secure 
Boot.



[Fn] keys may not work on some supported and listed laptop/notebook models.

https://www.igel.com/linux-3rd-party-hardware-database/
https://www.igel.com/technology-partners/
https://www.igel.com/linux-3rd-party-hardware-database/
https://www.igel.com/technology-partners/
https://www.microsoft.com/en-us/windows/business/devices?col=secured-core-pcs
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Advantech

Name Endpoint Type Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

POC-W213L Medical All in 
One

4 GB 128 GB Intel Core 
i7-7300U

11.01.100

POC-
W243L* (see 
page 22)

Medical All in 
One

4 GB 32 GB Intel Kaby Lake 
Core i5-7300U

11.01.110

POC-
W243L* (see 
page 22)

Medical All in 
One

4 GB 128 GB Intel Core 
i7-7300U

11.01.100

Advantech-DLoG

Name Endpoint Type Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

DLT-V6210 Industrial PC/
Terminal

4 GB 32 GB Intel Atom 11.01.100

DLT-V7210 K Industrial PC/
Terminal

4 GB 4 GB Intel Atom 
E3845

11.01.100

Dell / Wyse

Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage 
Size

Processor Supported 
from IGEL OS 
Version

Note

5040 / 5212 All in One 2 GB 2 GB AMD G-T48E 11.01.100

3040 Thin Client 2 GB 8 GB Intel Atom 
x5-Z8350

11.01.100

5020 Thin Client 2 GB 8 GB AMD G-Series 
SoC

11.02.140

5060 Thin Client 4 GB 8 GB AMD 
GX-424CC

11.01.100

5070 Thin Client 8 GB 32 GB Intel Celeron 
J4105

11.01.100
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Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage 
Size

Processor Supported 
from IGEL OS 
Version

Note

Latitude 
5510

Laptop/
Notebook

8 GB 256 GB Intel Core 
i5-10210U

11.05.100 Wake-on-LAN 
functionality is 
not supported.

Optiplex 
3000

Thin Client 4 GB 32 GB Intel Celeron 
N5105

11.08.200

Dynabook

Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

Portegé X20W-
D

Laptop/
Notebook

8 GB 256 GB Intel Core 
i5-7200U

11.01.100

Portegé X30-D Laptop/
Notebook

8 GB 256 GB Intel Core 
i5-7300U

11.01.100

Tecra C50 Laptop/
Notebook

4 GB 500 GB Intel i5-4210U 11.01.100

Tecra Z50-D Laptop/
Notebook

8 GB 256 GB Intel Core 
i5-7200U

11.01.100

SATELLITE R50 Laptop/
Notebook

4 GB 500 GB Intel i3-6006U 11.01.100

Elo

Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

i2 Touch
(15 and 22 
inches)

All in One 8 GB 128 GB  Intel Core 
i3-8100T

11.05.100
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Fujitsu

Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

Q957 Desktop PC 8 GB 500 GB Intel Core 
i3-6100

11.02.100

FUTRO S740 Thin Client 4 GB 8 GB Intel Celeron 
J4105

11.04.100

HP

Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage 
Size

Processor Supported 
from IGEL OS 
Version

Note

HP t420 Thin Client 2 GB 8 GB AMD 
Embedded G-
Series 
GX-209JA

11.02.100

HP t430 Thin Client 2 GB 16 GB Intel®Celeron®
N4020

11.01.110

HP t530 Thin Client 4 GB 8 GB AMD GX-215JJ 
Dual-Core

11.01.100

HP t630 Thin Client 4 GB 8 GB AMD GX-420GI 11.01.100

HP t730 Thin Client 16 GB 8 GB AMD 
RX-427BB APU

11.01.100

HP t820 Thin Client 16 GB 16 GB Intel Core 
i5-4570S

11.01.100

HP t640 Thin Client 4 GB 16 GB AMD Ryzen 
R1505G

11.04.100

HP t540 Thin Client 16 GB 16 GB AMD Ryzen 
Embedded 
R1305G

11.06.100
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Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage 
Size

Processor Supported 
from IGEL OS 
Version

Note

HP mt46 Mobile Thin 
Client

8 GB 32 GB AMD Ryzen 3 
PRO 4450U

11.07.100 Excluding 
support for 
WWAN 
and Wake-on-
LAN (both 
features are 
planned)

HP Elite 
t655

Thin Client 4 GB / 8 GB 32 GB AMD Ryzen 
Embedded 
R2314

11.07.160

HP Elite 
mt645 G7

Mobile Thin 
Client

8 GB 256 GB AMD Ryzen 3 
5425U

11.08.230 Support for 
WWAN Intel XMM 
7560 R+ (as of 
11.08.330)

Excluding 
support for 
Wake-on-LAN 
(feature is 
planned)

Excluding 
support for built-
in fingerprint 
sensor

AMD Ryzen 5 
5625U

11.08.330

HP t740 Thin Client 8 GB 16 GB AMD Ryzen 
Embedded 
V1756B

11.08.290

HP Pro t550 Thin Client 4 GB 32 GB Intel Celeron 
J6412

11.08.330

HP Pro 
mt440 G3

Mobile Thin 
Client

8 GB 128 GB Intel Celeron 
7305

11.08.440 Excluding 
support for 
WWAN Intel XMM 
7560 R+ (feature 
is planned)
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HP Docking Stations 

Name Supported from IGEL OS Version

HP USB-C Docking Station G5 11.08.230

HP USB-C G5 Essential Dock 11.08.290

Intel

Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

NUC 5i5MYHEDesktop PC 2 GB 32 GB Intel i5-5300U 11.01.100

NUC 5i3RYH Desktop PC 2 GB 2 GB Intel i3-5010U 11.01.100

NUC 7CJYH Desktop PC 2 GB 4 GB Intel Celeron 
J4005

11.01.100

Lenovo

Name Endpoint 
Type

Minimum 
Memory
(RAM) 
Size

Storage 
Size

Processor Wi-Fi Chip Supported 
from IGEL 
OS Version

Note

ThinkCentre 
M625q

Desktop 
PC

4 GB 32 GB AMD 
E2-9000e

Intel AC9260 11.04.100

8 GB 128 GB AMD 
A4-9120e

QCA6174 
802.11ac

11.04.100

ThinkCentre 
M75n

Desktop 
PC

8 GB 256 GB AMD Ryzen 
3 
Pro 3300U

Intel AC9260 11.05.100

ThinkCentre 
M70q Gen1

Desktop 
PC

16 GB 256 GB Intel 
i5-10500t

Comet Lake 
PCH CNVi 
WiFi, Intel

11.05.100

ThinkCentre 
M70q Gen 3

Desktop 
PC

16 GB 256 GB Intel Core 
i5-12500T

Intel AX201 11.08.240

ThinkCentre 
M75q Gen 2

Desktop 
PC

4 GB 128 GB AMD Ryzen 
3 Pro 
5350GE

Intel AX200 11.08.240
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Name Endpoint 
Type

Minimum 
Memory
(RAM) 
Size

Storage 
Size

Processor Wi-Fi Chip Supported 
from IGEL 
OS Version

Note

K14 AMD 
Gen 1

Laptop/
Notebook

8 GB 256 GB AMD Ryzen 
5 PRO 
5650U

Mediatek 
MT7921

11.08.240

ThinkPad 
L14 AMD 
Gen 1 

Laptop/
Notebook

64 GB 1 TB AMD Ryzen 
7 Pro 
4750U

Wi-Fi 6 
AX200, Intel

11.05.100

14w Laptop/
Notebook

4 GB 64 GB AMD 
A6-9220C

QCA6174 
802.11ac

11.05.100

ThinkPad 
L14 AMD 
Gen 3

Laptop/
Notebook

16 GB 256 GB AMD Ryzen 
5 5625U

AMD RZ616 
2X2AX (WiFi 
6E)

11.08.230 Excluding 
support for 
WWAN

ThinkCentre 
Neo50q  
Gen 4

Thin 
Client

8 GB 256 GB Intel Core 
i3-1215U

Wi-Fi 6 
RTL8852BE

11.08.240

4 GB 256 GB Intel 
Celeron 
7305

Wi-Fi 6 AX201

K14 Intel 
Gen 1

Laptop/
Notebook

16 GB 256 GB Intel Core 
i5-1135G7

Intel AX210 
WiFi / BT 
combo

11.08.290

ThinkPad 
L14 Intel 
Gen 3

Laptop/
Notebook

16 GB 512 GB Intel Core 
i5-1235U

Intel Wi-Fi 6 
AX201 2x2 AX 
vPro

11.08.330 LTE support 
as of 
11.08.360

ThinkEdge 
SE10

Thin 
Client

8 GB 1 TB Intel Atom 
x6425RE

MediaTek 
MT7921LEN 

11.08.360

256 GB Intel Atom 
x6214RE

Intel AX210 11.08.360

ThinkPad 
L14 AMD 
Gen 4 

Thin 
Client

8 GB 256 GB AMD Ryzen 
3 Pro 
7330U

AMD RZ616 11.08.440 Quectel 
EM05-G 4G 
CAT4

Realtek 
RTL8852CE

ThinkPad 
L15 AMD 
Gen4

Thin 
Client

8 GB 256 GB AMD Ryzen 
3 Pro 
7330U

AMD RZ616 11.08.440 Quectel 
EM05-G 4G 
CAT4

Realtek 
RTL8852CE
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Name Endpoint 
Type

Minimum 
Memory
(RAM) 
Size

Storage 
Size

Processor Wi-Fi Chip Supported 
from IGEL 
OS Version

Note

ThinkPad 
L14 Intel 
Gen 4

Laptop/
Notebook

8 GB 256 GB Intel Core 
i3-1315U

Intel AX211 11.09.100 Quectel 
EM05-G 4G 
CAT4

ThinkPad 
L15 Intel 
Gen 4

Laptop/
Notebook

8 GB 256 GB Intel Core 
i3-1315U

Intel AX211 11.09.100 Quectel 
EM05-G 4G 
CAT4

Lenovo Docking Stations

Name Supported from IGEL OS Version

ThinkPad USB-C Hybrid Dock 11.07.100

IOBOX 11.07.100

Lenovo Universal USB-C Dock 11.08.440

LG

Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

24CK550N*
* (see page 
22)

All in One 4 GB 32 GB AMD G-Series 
GX-212JJ

11.01.100

24CK550W*
* (see page 
22)

All in One 4 GB 32 GB AMD G-Series 
GX-212JJ

11.01.100

24CK560N*
* (see page 
22)

All in One 4 GB 32 GB AMD G-Series 
GX-212JJ

11.01.100

CK500W Thin Client 4 GB 32 GB AMD G-Series 
GX-212JJ

11.01.100

38CK950N All in One 8 GB 128 GB AMD Ryzen 3  11.02.100

38CK900N All in One 8 GB 128 GB AMD Ryzen 3  11.02.100
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Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

CL600N Thin Client 4 GB 16 GB Intel® Celeron 
J4105 

11.03.100

CL600W Thin Client 8 GB 128 GB Intel® Celeron 
J4105 

11.03.100

34CN650N All in One 4 GB 16 GB Intel® Celeron 
J4105 

11.05.100

24CN650N All in One 8 GB 16 GB Intel® Celeron 
J4105 

11.05.100

27CN650N All in One 8 GB 16 GB Intel® Celeron 
J4105

11.05.100

CQ600I Thin Client 4 GB 16 GB Intel Celeron 
N5105

11.08.330

24CQ650I All in One 4 GB 16 GB Intel Celeron 
N5105

11.08.330

CQ601I Thin Client 4 GB 16 GB Intel Pentium 
Silver N6005

11.08.360

24CR670I All in One 4 GB 16 GB Intel Celeron 
N5105

11.09.110

LG Docking Stations 

Name Supported from IGEL OS Version

LG USB Multi Port Hub 11.09.100

OnLogic

Name Endpoint Type Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

CL210G-10 Industrial PC/
Terminal

4 GB 32 GB Intel Celeron 
N3350

11.04.100

KARBON 300 Desktop PC 4 GB 32 GB Intel Atom x5-
E3930

11.04.100
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Onyx Healthcare

Name Endpoint Type Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

Venus 223 Medical All in 
One

4 GB 128 GB Intel Quad-Core 
J1900

11.01.100

Pepperl+Fuchs

Name Endpoint Type Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

BTC12N Industrial Box 
Thin Client

4 GB 32 GB Intel Apollo Lake 
N4200 

11.09.100

BTC14N Industrial Box 
Thin Client

4 GB 32 GB AMD Ryzen 
Embedded 
V1202B 

11.09.100

Rein Medical

Name Endpoint TypeMinimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

Silenio C122 All in One 8 GB 128 GB Intel® Core™ i5 – 
6th Generation

11.01.110

Silenio C124 All in One 8 GB 128 GB Intel® Core™ i5 – 
6th Generation

11.01.110

Clinio S 
522TCT

Medical All in 
One

8 GB 16 GB Intel® Pentium® 
Silver J5005

11.04.100

Clinio S 
524TCT

Medical All in 
One

8 GB 16 GB Intel® Pentium® 
Silver J5005

11.04.100
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•

1.
2.
3.

Secunet

Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

SINA Workstation 
S EliteDesk 800 G2

Workstation 16 GB 256 GB Intel Core 
i7-6700

11.01.100

USB Memory Sticks That Can Be Used as Alternative UD Pocket Hardware

DIGITTRADE

Name Storage Supported from IGEL OS Version

Kobra Stick ≥ 4GB 11.05.133

Officially Supported Virtual Environments

Tested with Ubuntu (64-bit) and default settings

Name Memory
(RAM)

Storage Type Supported from IGEL OS 
Version

Oracle VM VirtualBox ≥ 2 GB ≥ 4 GB Linux 11.04.100

VMware Workstation ≥ 2 GB ≥ 4 GB Linux 11.04.100

* Delock Adapter DP 1.2 to DVI does not work. 

** When using an additional 4k screen with this device, please edit the BIOS settings as follows:

Go to the Chipset screen.
Set Integrated Graphics to “Force”.
Set UMA Frame Buffer Size to “256M” or higher

Note that the use of a UD Pocket within a virtual machine is not supported by IGEL.

For some features, more than 2 GB RAM is required. Example: if you use dual monitor environments, a 
virtual machine must have at least 8 GB RAM.


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Check List

 The devices you want to upgrade meet the hardware requirements for IGEL OS 11.

Next Step
>> Important! Consider This Before Upgrading (see page 24)
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Important! Consider This Before Upgrading
To make sure that your upgrade can be successful, check the following warnings and notes; a warning symbol 
indicates that irreversible damage can be done to your devices.

Existing partitions: Any existing partition on the target drive of your device will be deleted. The installer 
will repartition the target device. The overall size of the newly created partitions will be calculated based 
on the available disk space. The minimum disk usage is 2 GB, the maximum is 16 GB.



No Downgrade

You cannot restore your IGEL OS 10 system once you have migrated to IGEL OS 11. The device storage is 
overwritten completely with a new partitioning scheme.



Features (e.g. Clients)

IGEL OS 11 does not have the complete feature set of IGEL OS 10. Make sure that the current version of 
IGEL OS 11 meets your requirements. For details, refer to the appropriate release notes.



Custom Partitions

The contents of Custom Partitions will be deleted by the upgrade. Make sure that the Custom Partition is 
restored after the upgrade has finished. Besides becoming dysfunctional after the upgrade, applications 
and kernel drivers in a Custom Partition might corrupt the upgrade. For this reason, make sure to first test 
the upgrade on a characteristic device.



Custom Commands

The persistence of custom commands cannot be guaranteed. Besides becoming dysfunctional after the 
upgrade, custom commands might corrupt the upgrade. For this reason, make sure to first test the 
upgrade on a characteristic device. In general, custom commands must be adapted for IGEL OS 11. We 
recommend that you disable custom commands when upgrading; you can enable them once the upgrade 
has been successfully completed.



Power Supply

Ensure that the device is not running on battery power, i.e. it must be connected to a power supply during 
the complete upgrade process.



•

Network

All devices must be connected to a LAN or WLAN. LAN is the recommended option. The device will not be 
upgraded if OpenVPN, OpenConnect, mobile broadband, or genucard is configured. To be sure, check if 
the following parameters are deactivated resp. no session is configured:

Network > VPN Open VPN (registry: sessions.openvpn% )


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Check List
 The limitations and conditions are understood and do not constitute a problem.

Next Step
>> Getting the UMS Ready (see page 26)

•
•

•

Network > VPN > OpenConnect VPN (registry: sessions.openconnect% )
Network > Mobile Broadband, checkbox Enable Mobile Broadband (registry: 
network.interfaces.mobile_broadband.enabled )

Network > VPN > genucard (registry: 
network.interfaces.genucard_vpn_connector.autostart_enabled )

When you have changed the settings, restart the device to enable the upgrade.
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1.

2.

Getting the UMS Ready
To upgrade your devices to IGEL OS 11, you need the appropriate version of the UMS. Also, the devices must be 
registered with the UMS to receive their licenses. 

If you have not already done so, update your UMS to version 6.01.130 or higher. For instructions, 
see Updating a UMS Installation.
Make sure that your devices are registered with the UMS. For more information, see the 
chapter Registering Devices on the UMS Server in the UMS Manual.

Check List
 Your Universal Management Suite (UMS) version is 6.01.130 or higher.

 All devices that will be upgraded are registered in the UMS.

Next Step
>> Deploying the Licenses (see page 27)
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•
•

•

•

•

•

Deploying the Licenses

Checking If the Required Licenses Are Available

 Ensure that you have the following licenses:

A valid license from an IGEL Workspace Edition (WE) Product Pack for each device.
Depending on the features you want to use, you might need IGEL Enterprise Management (EMP) 
licenses in addition. For further information, see IGEL Software License Overview.

Deploying the Licenses

 Choose one of the following methods:

If you want to deploy a license quickly on a single device: See Manual License Deployment for IGEL 
OS without UMS; start from step 5.
If you have a smaller or medium number of devices and want to control exactly which device 
should get a license: See Manual License Deployment for IGEL OS.
If you have a medium or greater number of devices, and you are planning to add new devices/
licenses regularly: See Set up Automatic License Deployment (ALD) with ALD Token.
If you have a medium or greater number of devices, and you are planning to add new devices/
licenses frequently (licensing can be managed completely in the IGEL License Portal): See Setting 
up Automatic License Deployment (ALD).

Check List
 The licenses have been purchased.

 License deployment is set up.

Next Step
>> Creating the Universal Firmware Update (see page 28)
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•
•

1.

Creating the Universal Firmware Update
In this step, we will create a Universal Firmware Update that will be used for testing the upgrade and for rolling out 
the upgrade on all relevant machines.

Choose the procedure that suits your needs:

Configuring the Universal Firmware Update with Files Hosted by the UMS (see page 28)
Configuring the Universal Firmware Update with Files Hosted by FTP Server (Required for ICG) (see 
page 33)

Configuring the Universal Firmware Update with Files Hosted by the UMS

Go to Server - [UMS address] > Universal Firmware Update and in the context menu, select 
Check for new firmware updates.

If you use the High Availability Extension, note that Universal Firmware Updates are NOT synchronized, 
that is why you have to either download them to all HA nodes or configure an external (FTP) server.


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2. Select the entry for the IGEL OS 11 firmware and then select Download. (In the example, IGEL OS 
11.03.110 is used.)
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3. Read and confirm the disclaimer. (IGEL OS 11.03.100 or higher only)
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4. Confirm the status message.

In the main window, you can monitor the download process.
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When the status is Finished, your Universal Firmware Update is ready for use.
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1.
2.

3.

Configuring the Universal Firmware Update with Files Hosted by FTP Server (Required for ICG)
You can use an FTP server instead of the UMS to host the firmware files. If you are using IGEL Cloud Gateway (ICG), 
an FTP server is required.

To configure an FTP server as update source:

In the UMS, go to UMS Administration > Universal Firmware Update and click Edit.
Enter the data required for accessing the FTP server and click Save.

Click Test server connection to test your settings.
If everything went well, a success message is shown both for the IGEL download server and for the 
FTP server:



Update and Upgrade

IGEL OS Articles   34 / 1017

4.

5.

Go to Server - [UMS address] > Universal Firmware Update and in the context menu, select 
Check for new firmware updates.

Select the entry for the IGEL OS 11 firmware, click   to select the FTP server selected in step 2 
and then select Download.
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6. Read and confirm the disclaimer. (IGEL OS 11.03.100 or higher only)
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7. Confirm the status message.

The firmware is transferred to the FTP server. In the main window, you can monitor the download 
process.
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When the status is Finished, your Universal Firmware Update is ready for use.
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Check List
 The Universal Firmware Update has been created successfully.

Next Step
>> Creating an Upgrade Profile (see page 39)
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•
•

1.

2.
•
•
•

Creating an Upgrade Profile
The upgrade profile varies, depending on whether the devices are in the same network as the UMS or connected via 
ICG. Choose the appropriate procedure:

For Devices that Are in the UMS Network (see page 39)
For Devices that Are Connected via ICG (see page 43)

For Devices That Are in the UMS Network

In the UMS structure tree, go to Profiles, open the context menu and select New Profile.

Enter the following data:
Profile Name: Name for the profile, e. g. "Upgrade to IGEL OS 11".
Description: Optional description for the profile.
Based on: Firmware version for the profile; select the current firmware of your devices, that 
is, "IGEL UD Pocket 10.06.100".
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3.

4.
•
•
•

5.
6.
7.

•

Click Ok.

Go to System > Update > Firmware Update and change the settings as follows:
Select "HTTPS" as the Protocol.
Activate Automatic update check on boot.
Ensure that Automatic update check on shutdown is deactivated. Otherwise, the device 
will shut down when the update is finished.

Go to System > Update > Firmware Update > OS 11 Upgrade.
Activate Upgrade to OS 11.
Make the following settings according to your needs:

If you want the device to retry the upgrade immediately after a failed attempt, 
activate Upgrade to OS 11 even if a previous upgrade attempt failed. With this setting, 
the device will retry the upgrade 5 times. When the 5th attempt has failed, a message will be 
shown in the upgrade tool window.
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•

•

•

•

•

8.

If your device has a PowerTerm license, and you want to upgrade to IGEL OS 11 even 
though IGEL OS 11 does not support PowerTerm, you must activate Upgrade to OS 11 even 
if PowerTerm is enabled.
Under Require an Enterprise Management Pack license to upgrade to OS 11, select the 
appropriate option:

If you are using IGEL Cloud Gateway (ICG) or Shared Workplace (SWP) or a Custom 
Partition and want to make sure that the upgrade is performed only if these features 
can be used furthermore, select Smart. When Smart is selected, and one of these 
features is activated, the upgrade is performed only if the device succeeded in 
fetching a license from an Enterprise Management Pack.
If you want to force the device to fetch a license from an Enterprise Management 
Pack and make sure that the upgrade is performed only if this license has been 
fetched, select Always.
If you want the device to upgrade to IGEL OS 11 without fetching a license from 
an Enterprise Management Pack, disregarding the features, select Never.

Under Timeout waiting for OS 11 license to start automatic upgrade, set the time period the 
device will wait for a license in a mass deployment scenario. This setting prevents the device from 
starting the upgrade at an inappropriate time as a result of the license just being deployed. This 
way, the setting prevents unwanted interruptions at work. For a mass deployment scenario, the 
default value 10 Minutes is recommended.
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9.

10.

If you have a Custom Partition, go to Firmware Customization > Custom Partition > Partition
and deactivate Enable Partition. 

If you have custom applications, go to Firmware Customization > Custom Application and, for 
each custom application, deactivate Autostart. This is to prevent the custom application from 
interfering with the device's system before it can be tested properly.
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11.

1.

 

Click Save.

For Devices That Are Connected via ICG

In the UMS structure tree, go to Profiles, open the context menu and select New Profile.
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2.
•
•
•

3.

4.
•
•
•

5.
6.

Enter the following data:
Profile Name: Name for the profile, e. g. "Upgrade to IGEL OS 11".
Description: Optional description for the profile.
Based on: Firmware version for the profile; select the current firmware of your devices, that 
is, "IGEL UD Pocket 10.06.100".

Click Ok.

Go to System > Update > Firmware Update and change the settings as follows:
Select "FTP" as Protocol.
Activate Automatic update check on boot.
Ensure that Automatic update check on shutdown is deactivated. Otherwise, the device 
will shut down when the update is finished.

Go to System > Update > Firmware Update > OS 11 Upgrade.
Activate Upgrade to OS 11.
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7.
•

•

•

•

•

•

8.

Make the following settings according to your needs:
If you want the device to retry the upgrade immediately after a failed attempt, 
activate Upgrade to OS 11 even if a previous upgrade attempt failed. With this setting, 
the device will retry the upgrade 5 times. When the 5th attempt has failed, a message will be 
shown in the upgrade tool window.
If your device has a PowerTerm license, and you want to upgrade to IGEL OS 11 even 
though IGEL OS 11 does not support PowerTerm, you must activate Upgrade to OS 11 even 
if PowerTerm is enabled.
Under Require an Enterprise Management Pack license to upgrade to OS 11, select the 
appropriate option:

If you are using IGEL Cloud Gateway (ICG) or Shared Workplace (SWP) or a Custom 
Partition and want to make sure that the upgrade is performed only if these features 
can be used furthermore, select Smart. When Smart is selected, and one of these 
features is activated, the upgrade is performed only if the device succeeded in 
fetching a license from an Enterprise Management Pack.
If you want to force the device to fetch a license from an Enterprise Management 
Pack and make sure that the upgrade is performed only if this license has been 
fetched, select Always.
If you want the device to upgrade to IGEL OS 11 without fetching a license from an 
Enterprise Management Pack, disregarding the features, select Never.

Under Timeout waiting for OS 11 license to start automatic upgrade, set the time period the 
device will wait for a license in a mass deployment scenario. This setting prevents the device from 
starting the upgrade at an inappropriate time as a result of the license just being deployed. This 
way, the setting prevents unwanted interruptions at work. For a mass deployment scenario, the 
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9.

default value 10 Minutes is recommended.

If you have a Custom Partition, go to Firmware Customization > Custom Partition > Partition
and deactivate Enable Partition. 
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10.

11.

If you have custom applications, go to Firmware Customization > Custom Application and, for 
each custom application, deactivate Autostart. This is to prevent the custom application from 
interfering with the device's system before it can be tested properly.
 

Click Save.

Check List
 The upgrade profile is configured properly for your needs.

Next Step
>> Assigning the Upgrade Profile and the Universal Firmware Update to the Test Devices (see page 48)
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1.

Assigning the Upgrade Profile and the Universal Firmware Update to the Test 
Devices

If you have not already created a directory as a distribution condition while setting up Automatic 
License Deployment (ALD): In the Devices node of the UMS structure tree, create a directory and 
name it "Upgrade to IGEL OS 11", for instance. For more information about distribution conditions, 
see Configuring the Distribution Conditions, section "Distributing Licenses to Devices in a 
Specified Directory". 
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2.

3.

4.

Put the devices that are to be updated into the new directory. You can use drag & drop.

In the Update time dialog, select Now and click Ok.
The directory change is communicated immediately to the device.
 

Select the directory and in the Assigned objects area, click  .
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5.

6.

Assign the upgrade profile and the Universal Firmware Update for IGEL OS 11.03 to the directory 
and click Ok.

In the Update time dialog, select Now and click Ok.
The changes are sent to the devices immediately.



Update and Upgrade

IGEL OS Articles   51 / 1017

In the Assigned objects area, the profile and the Universal Firmware Update are shown:

Check List
 The test devices are in a directory to which the upgrade profile and the Universal Firmware Update are assigned.

Next Step
>> Testing the Upgrade (see page 52)

If you are using Automatic License Deployment (ALD), it might be feasible to confine the distribution of 
licenses to the current directory. For more information, see Configuring the Distribution Conditions, 
section "Distributing Licenses to Devices in a Specified Directory".


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1.

Testing the Upgrade
In the UMS, select the directory containing the test devices and select Reboot.
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2.

3.

In the Reboot devices dialog, click Reboot.

If no IGEL OS 11 licenses have been deployed on the devices yet, the licenses are deployed within a 
few minutes. The upgrade will be started when the licenses are deployed. The maximum time 
period the device will wait for a license is configured by the parameter Timeout waiting for OS 11 
license to start automatic upgrade; for details, see Creating an Upgrade Profile (see page 39), step 
8.
The parameter Automatic update check on boot makes the devices look for new firmware 
again. Although two Universal Firmware Updates are assigned to the devices, the UMS offers the 
IGEL OS 11 firmware, because the ID of the IGEL OS 11 firmware is higher than the ID of the IGEL OS 
10 firmware.
The upgrade is completed.
Check whether all features and functions of your test devices are working as expected.

Check List
 All features and functions of your test devices are working as expected.

Next Step
>> Unassigning the Upgrade Profile and the Universal Firmware Update (see page 54)
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1.

2.

Unassigning the Upgrade Profile and the Universal Firmware Update
The upgrade profile and the Universal Firmware Update should be unassigned from the devices after they have 
been upgraded to IGEL OS 11 successfully.

To unassign upgrade profile and the Universal Firmware Update:

 Move the devices to a different folder.

In the Update time dialog, select Now and click Ok.
The directory change is communicated immediately to the devices.

 
If a device had a Custom Partition before, it will be downloaded by the device and activated again.

Check List
If a device had a Custom Partition before:

 The Custom Partition has been downloaded by the device and activated.

Next Step
If some devices have a Custom Partition:

>> If Applicable: Restoring Custom Partition and Custom Application (see page 55)

If no device has a Custom Partition:

>> Upgrading All Devices (see page 56)
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1.

2.

If Applicable: Restoring Custom Partition and Custom Applications
If a device had a custom partition before the upgrade, it has been downloaded and activated again after the 
upgrade profile has been unassigned; see Unassigning the Upgrade Profile and the Universal Firmware Update (see 
page 54). It cannot be ruled out that custom commands and the applications and drivers of a Custom Partition 
disturb your device's system. Therefore, it is very important to check the Custom Partition, the custom applications, 
and the device's basic functionality.

Test the Custom Partition and the custom applications. If errors should occur, modify the Custom 
Partition and the custom applications accordingly.
Check if all other functions are still working properly.

Check List
 The Custom Partition and the custom applications are enabled and can be used.

  All other functions are working properly.

Next Step
>> Upgrading All Devices (see page 56)
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1.

Upgrading All Devices

Assigning the Upgrade Profile and the Universal Firmware Update to the Devices

Put the devices that are to be upgraded into the directory you have created for the test devices. It 
is recommended to use cut and paste.
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2.

3.

In the Update time dialog, select Now and click Ok.
The directory change, the upgrade profile and the Universal Firmware Update are communicated 
immediately to the devices.

In the UMS, select the directory with the devices and select Reboot.
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4.

1.

In the Reboot devices dialog, click Reboot.

If no IGEL OS 11 licenses have been deployed on the devices yet, the licenses are deployed within a 
few minutes. The upgrade will be started when the licenses are deployed. The maximum time 
period a device will wait for a license is configured by the parameter Timeout waiting for OS 11 
license to start automatic upgrade; for details, see Creating an Upgrade Profile (see page 39), step 
8.
The parameter Automatic update check on boot makes the devices look for new firmware 
again. Although two Universal Firmware Updates are assigned to the devices, the UMS offers the 
IGEL OS 11 firmware, because the ID of the IGEL OS 11 firmware is higher than the ID of the IGEL OS 
10 firmware.

Unassigning the Upgrade Profile and the Universal Firmware Update

To unassign the upgrade profile and the Universal Firmware Update, move the devices to a 
different folder.
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2.

3.

In the Update time dialog, select Now and click Ok.
The directory change is communicated immediately to the device.

 
If a device had a Custom Partition before the upgrade, it has been downloaded and activated 
again after the upgrade profile has been unassigned.
If applicable, restore the required custom applications; see If Applicable: Restoring Custom 
Partition and Custom Applications (see page 55).



Update and Upgrade

IGEL OS Articles   63 / 1017

Check List
 All devices have been upgraded to IGEL OS 11.

 All required functionality is available, including custom applications.
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•
•

Upgrading from IGEL OS 10 to IGEL OS 11
Upgrading UDC3 Devices from IGEL OS 10 to IGEL OS 11 (see page 65)
Upgrading IGEL Devices from IGEL OS 10 to IGEL OS 11 (see page 154)
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•

•

•

Upgrading UDC3 Devices from IGEL OS 10 to IGEL OS 11
This document describes how to upgrade any number of devices (UDC3) from IGEL OS 10 to IGEL OS 11.

IGEL OS 10.05.800 or higher is required for upgrading to IGEL OS 11. If you have an older version of IGEL OS 10, you 
need to update to version 10.05.800 or a higher version first. 

Since a new licensing model has been introduced with IGEL OS 11, a license from an IGEL Workspace Edition 
Product Pack must be available for each device. If you have a valid maintenance for your devices, you can convert 
your existing UDC3 or UD Pocket Product Packs to Workspace Edition (WE) Product Packs; see Converting UDC3 or 
UD Pocket Licenses for Upgrading to IGEL OS 11.

The following methods of mass deployment are described here:

Zero-Touch Deployment Using Universal Firmware Update (see page 66): Mass upgrade from any 
version of IGEL OS 10 to IGEL OS 11 in one step using Universal Firmware Update. This method can 
be started immediately or as a scheduled job (wake up or reboot).
Zero-Touch Deployment Using Buddy Update (see page 104): Mass upgrade from any version of IGEL 
OS 10 to IGEL OS 11 in one step using two devices as update buddies. This method can be started 
immediately or as a scheduled job (wake up or reboot).
Zero-Touch Deployment Using a Scheduled Job (see page 134): Upgrade devices that are already 
running IGEL OS 10.05.800 (or higher) using a specific scheduled job.
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1.
2.
3.
4.
5.
6.
7.
8.
9.

10.

Zero-Touch Deployment Using Universal Firmware Update
This method is the most convenient way to upgrade from IGEL OS 10 to IGEL OS 11. The method uses the Universal 
Firmware Update feature of the UMS (Universal Management Suite) and a profile.

Read all the following chapters carefully and follow the instructions.

Devices That Can Be Upgraded to Igel OS 11 (see page 67)
Important! Consider This Before Upgrading (see page 79)
Preparing the Upgrade (see page 80)
Testing the Upgrade (see page 85)
Checking the Requirements (see page 89)
Creating the Universal Firmware Updates (see page 90)
Creating a Profile (see page 94)
Deploying the Licenses (see page 99)
Putting It All Together (see page 100)
Executing the Upgrade (see page 102)
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•
•
•

•

•
•

•

•
•

Devices That Can Be Upgraded to Igel OS 11

Core Requirements

CPU with 64-bit support
CPU speed: ≥ 1 GHz
Memory (RAM): ≥ 2 GB

Storage: Depends on the release version of IGEL OS 11. The details are listed below: 2 GB 
minimum; ≥ 4 GB recommended

Up to IGEL OS 11.03: 2 GB minimum; ≥ 4 GB recommended
From IGEL OS 11.04 to IGEL OS 11.07: If the full feature set is applied, at least 2.4 GB of 
storage is required. For instructions on how to reduce the feature set, see Error: "Not 
enough space on local drive" when Updating to IGEL OS 11.08 or Higher.
From IGEL OS 11.08 onwards: If the full feature set is applied, at least 2.4 GB of storage is 
required. For instructions on how to reduce the feature set, see Error: "Not enough space on 
local drive" when Updating to IGEL OS 11.08 or Higher. TODO Add URL when published

No VIA graphic adapter; VIA graphics support is discontinued in IGEL OS.
Legacy Bios and EFI/UEFI are supported.

Devices Supported by OSC and UD Pocket with IGEL OS 11

•
•
•

RAM size higher than 2 GB is recommended if you use any of the following:
Unified Communications optimizations (uses a client-side media engine)
High-resolution graphics output
More than two monitors



With devices that have 2 GB RAM and shared video memory, a maximum of 512 MB may be 
used as video memory.



The following list only includes those devices that are tested by IGEL (with each major release of IGEL OS).
By no means it implies that the devices which are not included in this list but meet the minimum 
requirements will not function with IGEL OS: Any x86-64 hardware endpoint device that meets the IGEL-
stated minimum hardware requirements for IGEL OS (for example, the processor speed and RAM) can be 
expected to work adequately with IGEL OS and should be considered a candidate for repurposing from 
another OS. With an IGEL OS subscription or active maintenance, customers can expect IGEL to make any 
necessary “best effort” to support, regardless of whether the endpoints in question are specifically listed 
within the IGEL Knowledge Base or elsewhere (e.g. on the IGEL Ready Showcase at https://www.igel.com/
ready/showcase-categories/endpoints/).
For any devices not listed here or on the IGEL Ready showcase, you can contact your hardware vendor and 
request those devices to be added to the IGEL Ready program.
Integrated drivers and supported peripherals are listed in the Third-Party Hardware Database19. For more 
solutions compatible with IGEL OS, see Partner Solutions.



https://www.igel.com/linux-3rd-party-hardware-database/
https://www.igel.com/ready/showcase-categories/endpoints/
https://www.igel.com/linux-3rd-party-hardware-database/
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ADS-Tec

Name Endpoint Type Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

DVG-
VMT9010

Industrial PC/
Terminal

4 GB

8 GB

64 GB eMMC Intel Atom® x7-
E3950

11.02.100

DVG-
VMT9012

Industrial PC/
Terminal

4 GB

8 GB

64 GB eMMC Intel Atom® x7-
E3950

11.02.100

DVG-
VMT9015

Industrial PC/
Terminal

4 GB

8 GB

64 GB eMMC Intel Atom® x7-
E3950

11.02.100

DVG-
VMT9112

Industrial PC/
Terminal

4 GB

8 GB

64 GB eMMC Intel Atom® x7-
E3950

11.02.100

Advantech

HP, Lenovo, and LG device models are available from the factory with pre-installed IGEL OS 11. Please 
contact IGEL Ready20 to get information on which device models are available with pre-installed IGEL OS.



For some of the devices listed here, Flash memory must be extended to ≥ 2 GB. For these devices, an 
appropriate note is added.



On modern computers such as secured-core PCs (see e.g. https://www.microsoft.com/en-us/windows/
business/devices?col=secured-core-pcs), there may be a BIOS setting related to Secure Boot that allows 
the use of Microsoft’s 3rd party UEFI Secure Boot Certificate. The usual description of such a BIOS setting is 
"Allow Microsoft 3rd Party UEFI CA". This setting must be set to enabled, as IGEL uses the 3rd party 
certificate to support UEFI Secure Boot. If UEFI Secure Boot is enabled, but "Allow Microsoft 3rd Party UEFI 
CA" is not enabled, you may be unable to boot IGEL OS Creator or UD Pocket. Similarly, if the setting 
"Allow Microsoft 3rd Party UEFI CA" is disabled after a previous installation of IGEL OS, IGEL OS will fail to 
boot. For how to enable the setting, see Secured-Core PCs: Microsoft 3rd-Party UEFI Certificate for Secure 
Boot.



[Fn] keys may not work on some supported and listed laptop/notebook models.

https://www.igel.com/technology-partners/
https://www.igel.com/technology-partners/
https://www.microsoft.com/en-us/windows/business/devices?col=secured-core-pcs


Update and Upgrade

IGEL OS Articles   69 / 1017

Name Endpoint Type Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

POC-W213L Medical All in 
One

4 GB 128 GB Intel Core 
i7-7300U

11.01.100

POC-
W243L* (see 
page 78)

Medical All in 
One

4 GB 32 GB Intel Kaby Lake 
Core i5-7300U

11.01.110

POC-
W243L* (see 
page 78)

Medical All in 
One

4 GB 128 GB Intel Core 
i7-7300U

11.01.100

Advantech-DLoG

Name Endpoint Type Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

DLT-V6210 Industrial PC/
Terminal

4 GB 32 GB Intel Atom 11.01.100

DLT-V7210 K Industrial PC/
Terminal

4 GB 4 GB Intel Atom 
E3845

11.01.100

Dell / Wyse

Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage 
Size

Processor Supported 
from IGEL OS 
Version

Note

5040 / 5212 All in One 2 GB 2 GB AMD G-T48E 11.01.100

3040 Thin Client 2 GB 8 GB Intel Atom 
x5-Z8350

11.01.100

5020 Thin Client 2 GB 8 GB AMD G-Series 
SoC

11.02.140

5060 Thin Client 4 GB 8 GB AMD 
GX-424CC

11.01.100

5070 Thin Client 8 GB 32 GB Intel Celeron 
J4105

11.01.100
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Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage 
Size

Processor Supported 
from IGEL OS 
Version

Note

Latitude 
5510

Laptop/
Notebook

8 GB 256 GB Intel Core 
i5-10210U

11.05.100 Wake-on-LAN 
functionality is 
not supported.

Optiplex 
3000

Thin Client 4 GB 32 GB Intel Celeron 
N5105

11.08.200

Dynabook

Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

Portegé X20W-
D

Laptop/
Notebook

8 GB 256 GB Intel Core 
i5-7200U

11.01.100

Portegé X30-D Laptop/
Notebook

8 GB 256 GB Intel Core 
i5-7300U

11.01.100

Tecra C50 Laptop/
Notebook

4 GB 500 GB Intel i5-4210U 11.01.100

Tecra Z50-D Laptop/
Notebook

8 GB 256 GB Intel Core 
i5-7200U

11.01.100

SATELLITE R50 Laptop/
Notebook

4 GB 500 GB Intel i3-6006U 11.01.100

Elo

Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

i2 Touch
(15 and 22 
inches)

All in One 8 GB 128 GB  Intel Core 
i3-8100T

11.05.100

Fujitsu
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Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

Q957 Desktop PC 8 GB 500 GB Intel Core 
i3-6100

11.02.100

FUTRO S740 Thin Client 4 GB 8 GB Intel Celeron 
J4105

11.04.100

HP

Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage 
Size

Processor Supported 
from IGEL OS 
Version

Note

HP t420 Thin Client 2 GB 8 GB AMD 
Embedded G-
Series 
GX-209JA

11.02.100

HP t430 Thin Client 2 GB 16 GB Intel®Celeron®
N4020

11.01.110

HP t530 Thin Client 4 GB 8 GB AMD GX-215JJ 
Dual-Core

11.01.100

HP t630 Thin Client 4 GB 8 GB AMD GX-420GI 11.01.100

HP t730 Thin Client 16 GB 8 GB AMD 
RX-427BB APU

11.01.100

HP t820 Thin Client 16 GB 16 GB Intel Core 
i5-4570S

11.01.100

HP t640 Thin Client 4 GB 16 GB AMD Ryzen 
R1505G

11.04.100

HP t540 Thin Client 16 GB 16 GB AMD Ryzen 
Embedded 
R1305G

11.06.100
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Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage 
Size

Processor Supported 
from IGEL OS 
Version

Note

HP mt46 Mobile Thin 
Client

8 GB 32 GB AMD Ryzen 3 
PRO 4450U

11.07.100 Excluding 
support for 
WWAN 
and Wake-on-
LAN (both 
features are 
planned)

HP Elite 
t655

Thin Client 4 GB / 8 GB 32 GB AMD Ryzen 
Embedded 
R2314

11.07.160

HP Elite 
mt645 G7

Mobile Thin 
Client

8 GB 256 GB AMD Ryzen 3 
5425U

11.08.230 Support for 
WWAN Intel XMM 
7560 R+ (as of 
11.08.330)

Excluding 
support for 
Wake-on-LAN 
(feature is 
planned)

Excluding 
support for built-
in fingerprint 
sensor

AMD Ryzen 5 
5625U

11.08.330

HP t740 Thin Client 8 GB 16 GB AMD Ryzen 
Embedded 
V1756B

11.08.290

HP Pro t550 Thin Client 4 GB 32 GB Intel Celeron 
J6412

11.08.330

HP Pro 
mt440 G3

Mobile Thin 
Client

8 GB 128 GB Intel Celeron 
7305

11.08.440 Excluding 
support for 
WWAN Intel XMM 
7560 R+ (feature 
is planned)

HP Docking Stations 
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Name Supported from IGEL OS Version

HP USB-C Docking Station G5 11.08.230

HP USB-C G5 Essential Dock 11.08.290

Intel

Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

NUC 5i5MYHEDesktop PC 2 GB 32 GB Intel i5-5300U 11.01.100

NUC 5i3RYH Desktop PC 2 GB 2 GB Intel i3-5010U 11.01.100

NUC 7CJYH Desktop PC 2 GB 4 GB Intel Celeron 
J4005

11.01.100

Lenovo

Name Endpoint 
Type

Minimum 
Memory
(RAM) 
Size

Storage 
Size

Processor Wi-Fi Chip Supported 
from IGEL 
OS Version

Note

ThinkCentre 
M625q

Desktop 
PC

4 GB 32 GB AMD 
E2-9000e

Intel AC9260 11.04.100

8 GB 128 GB AMD 
A4-9120e

QCA6174 
802.11ac

11.04.100

ThinkCentre 
M75n

Desktop 
PC

8 GB 256 GB AMD Ryzen 
3 
Pro 3300U

Intel AC9260 11.05.100

ThinkCentre 
M70q Gen1

Desktop 
PC

16 GB 256 GB Intel 
i5-10500t

Comet Lake 
PCH CNVi 
WiFi, Intel

11.05.100

ThinkCentre 
M70q Gen 3

Desktop 
PC

16 GB 256 GB Intel Core 
i5-12500T

Intel AX201 11.08.240

ThinkCentre 
M75q Gen 2

Desktop 
PC

4 GB 128 GB AMD Ryzen 
3 Pro 
5350GE

Intel AX200 11.08.240
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Name Endpoint 
Type

Minimum 
Memory
(RAM) 
Size

Storage 
Size

Processor Wi-Fi Chip Supported 
from IGEL 
OS Version

Note

K14 AMD 
Gen 1

Laptop/
Notebook

8 GB 256 GB AMD Ryzen 
5 PRO 
5650U

Mediatek 
MT7921

11.08.240

ThinkPad 
L14 AMD 
Gen 1 

Laptop/
Notebook

64 GB 1 TB AMD Ryzen 
7 Pro 
4750U

Wi-Fi 6 
AX200, Intel

11.05.100

14w Laptop/
Notebook

4 GB 64 GB AMD 
A6-9220C

QCA6174 
802.11ac

11.05.100

ThinkPad 
L14 AMD 
Gen 3

Laptop/
Notebook

16 GB 256 GB AMD Ryzen 
5 5625U

AMD RZ616 
2X2AX (WiFi 
6E)

11.08.230 Excluding 
support for 
WWAN

ThinkCentre 
Neo50q  
Gen 4

Thin 
Client

8 GB 256 GB Intel Core 
i3-1215U

Wi-Fi 6 
RTL8852BE

11.08.240

4 GB 256 GB Intel 
Celeron 
7305

Wi-Fi 6 AX201

K14 Intel 
Gen 1

Laptop/
Notebook

16 GB 256 GB Intel Core 
i5-1135G7

Intel AX210 
WiFi / BT 
combo

11.08.290

ThinkPad 
L14 Intel 
Gen 3

Laptop/
Notebook

16 GB 512 GB Intel Core 
i5-1235U

Intel Wi-Fi 6 
AX201 2x2 AX 
vPro

11.08.330 LTE support 
as of 
11.08.360

ThinkEdge 
SE10

Thin 
Client

8 GB 1 TB Intel Atom 
x6425RE

MediaTek 
MT7921LEN 

11.08.360

256 GB Intel Atom 
x6214RE

Intel AX210 11.08.360

ThinkPad 
L14 AMD 
Gen 4 

Thin 
Client

8 GB 256 GB AMD Ryzen 
3 Pro 
7330U

AMD RZ616 11.08.440 Quectel 
EM05-G 4G 
CAT4

Realtek 
RTL8852CE

ThinkPad 
L15 AMD 
Gen4

Thin 
Client

8 GB 256 GB AMD Ryzen 
3 Pro 
7330U

AMD RZ616 11.08.440 Quectel 
EM05-G 4G 
CAT4

Realtek 
RTL8852CE
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Name Endpoint 
Type

Minimum 
Memory
(RAM) 
Size

Storage 
Size

Processor Wi-Fi Chip Supported 
from IGEL 
OS Version

Note

ThinkPad 
L14 Intel 
Gen 4

Laptop/
Notebook

8 GB 256 GB Intel Core 
i3-1315U

Intel AX211 11.09.100 Quectel 
EM05-G 4G 
CAT4

ThinkPad 
L15 Intel 
Gen 4

Laptop/
Notebook

8 GB 256 GB Intel Core 
i3-1315U

Intel AX211 11.09.100 Quectel 
EM05-G 4G 
CAT4

Lenovo Docking Stations

Name Supported from IGEL OS Version

ThinkPad USB-C Hybrid Dock 11.07.100

IOBOX 11.07.100

Lenovo Universal USB-C Dock 11.08.440

LG

Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

24CK550N*
* (see page 
78)

All in One 4 GB 32 GB AMD G-Series 
GX-212JJ

11.01.100

24CK550W*
* (see page 
78)

All in One 4 GB 32 GB AMD G-Series 
GX-212JJ

11.01.100

24CK560N*
* (see page 
78)

All in One 4 GB 32 GB AMD G-Series 
GX-212JJ

11.01.100

CK500W Thin Client 4 GB 32 GB AMD G-Series 
GX-212JJ

11.01.100

38CK950N All in One 8 GB 128 GB AMD Ryzen 3  11.02.100

38CK900N All in One 8 GB 128 GB AMD Ryzen 3  11.02.100
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Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

CL600N Thin Client 4 GB 16 GB Intel® Celeron 
J4105 

11.03.100

CL600W Thin Client 8 GB 128 GB Intel® Celeron 
J4105 

11.03.100

34CN650N All in One 4 GB 16 GB Intel® Celeron 
J4105 

11.05.100

24CN650N All in One 8 GB 16 GB Intel® Celeron 
J4105 

11.05.100

27CN650N All in One 8 GB 16 GB Intel® Celeron 
J4105

11.05.100

CQ600I Thin Client 4 GB 16 GB Intel Celeron 
N5105

11.08.330

24CQ650I All in One 4 GB 16 GB Intel Celeron 
N5105

11.08.330

CQ601I Thin Client 4 GB 16 GB Intel Pentium 
Silver N6005

11.08.360

24CR670I All in One 4 GB 16 GB Intel Celeron 
N5105

11.09.110

LG Docking Stations 

Name Supported from IGEL OS Version

LG USB Multi Port Hub 11.09.100

OnLogic

Name Endpoint Type Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

CL210G-10 Industrial PC/
Terminal

4 GB 32 GB Intel Celeron 
N3350

11.04.100

KARBON 300 Desktop PC 4 GB 32 GB Intel Atom x5-
E3930

11.04.100
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Onyx Healthcare

Name Endpoint Type Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

Venus 223 Medical All in 
One

4 GB 128 GB Intel Quad-Core 
J1900

11.01.100

Pepperl+Fuchs

Name Endpoint Type Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

BTC12N Industrial Box 
Thin Client

4 GB 32 GB Intel Apollo Lake 
N4200 

11.09.100

BTC14N Industrial Box 
Thin Client

4 GB 32 GB AMD Ryzen 
Embedded 
V1202B 

11.09.100

Rein Medical

Name Endpoint TypeMinimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

Silenio C122 All in One 8 GB 128 GB Intel® Core™ i5 – 
6th Generation

11.01.110

Silenio C124 All in One 8 GB 128 GB Intel® Core™ i5 – 
6th Generation

11.01.110

Clinio S 
522TCT

Medical All in 
One

8 GB 16 GB Intel® Pentium® 
Silver J5005

11.04.100

Clinio S 
524TCT

Medical All in 
One

8 GB 16 GB Intel® Pentium® 
Silver J5005

11.04.100

Secunet
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•

1.
2.
3.

Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

SINA Workstation 
S EliteDesk 800 G2

Workstation 16 GB 256 GB Intel Core 
i7-6700

11.01.100

USB Memory Sticks That Can Be Used as Alternative UD Pocket Hardware

DIGITTRADE

Name Storage Supported from IGEL OS Version

Kobra Stick ≥ 4GB 11.05.133

Officially Supported Virtual Environments

Tested with Ubuntu (64-bit) and default settings

Name Memory
(RAM)

Storage Type Supported from IGEL OS 
Version

Oracle VM VirtualBox ≥ 2 GB ≥ 4 GB Linux 11.04.100

VMware Workstation ≥ 2 GB ≥ 4 GB Linux 11.04.100

* Delock Adapter DP 1.2 to DVI does not work. 

** When using an additional 4k screen with this device, please edit the BIOS settings as follows:

Go to the Chipset screen.
Set Integrated Graphics to “Force”.
Set UMA Frame Buffer Size to “256M” or higher

When you have confirmed that your devices can be upgraded to IGEL OS 11, make sure to consider Important! 
Consider This Before Upgrading (see page 79).

Note that the use of a UD Pocket within a virtual machine is not supported by IGEL.

For some features, more than 2 GB RAM is required. Example: if you use dual monitor environments, a 
virtual machine must have at least 8 GB RAM.


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Important! Consider This Before Upgrading

To make sure that your upgrade can be successful, check the following warnings and notes; a warning symbol 
indicates that irreversible damage can be done to your devices.

When you have considered everything that is relevant, continue with Preparing the Upgrade (see page 80).

Existing partitions: Any existing partition on the target drive of your device will be deleted. The installer 
will repartition the target device. The overall size of the newly created partitions will be calculated based 
on the available disk space. The minimum disk usage is 2 GB, the maximum is 16 GB.



No Downgrade

You cannot restore your IGEL OS 10 system once you have migrated to IGEL OS 11. The device storage is 
overwritten completely with a new partitioning scheme.



Features (e.g. Clients)

IGEL OS 11 does not have the complete feature set of IGEL OS 10. Make sure that the current version of 
IGEL OS 11 meets your requirements. For details, refer to the appropriate release notes.



Custom Partitions

The contents of custom partitions will be deleted by the upgrade. Make sure to back up the contents and 
restore them after the upgrade has finished. Besides becoming dysfunctional after the upgrade, 
applications and kernel drivers in a custom partition might corrupt the upgrade. For this reason, make 
sure to first test the upgrade on a characteristic device. We recommend that you disable custom partitions 
when upgrading; you can enable them once the upgrade has been successfully completed.



Custom Commands

The persistence of custom commands cannot be guaranteed. Besides becoming dysfunctional after the 
upgrade, custom commands might corrupt the upgrade. For this reason, make sure to first test the 
upgrade on a characteristic device. In general, custom commands must be adapted for IGEL OS 11. We 
recommend that you disable custom commands when upgrading; you can enable them once the upgrade 
has been successfully completed.



Power Supply

Ensure that the device is not running on battery power, i.e. it must be connected to a power supply during 
the complete upgrade process.



Network

All devices must be connected to a WLAN or LAN. LAN is the recommended option. The device will not be 
upgraded if connected to OpenVPN, OpenConnect, genucard or mobile broadband.


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1.
2.
3.
4.

Preparing the Upgrade

This section describes the required preparations and tests before any productive devices can be updated. The 
testing should be done with at least one device that is characteristic of your environment. This device should have 
every custom partition and every custom command that may possibly exist in any of your devices.

To prepare the upgrade, perform the following steps:

Preparing the UMS (see page 81)
Adjusting the Setup (see page 82)
Deploying a License (see page 83)
Configuring the Update Source (see page 84)
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1.

2.

Preparing the UMS

To upgrade your devices to IGEL OS 11, you need the appropriate version of the UMS. Also, the devices must be 
registered with the UMS to receive their licenses. 

If you have not already done so, update your UMS to version 6.01.130 or higher. For instructions, 
see Updating UMS.
Make sure that your devices are registered with the UMS. For more information, see the 
chapter Registering IGEL OS Devices on the UMS Server in the UMS Manual.

When the UMS is ready, continue with Adjusting the Setup (see page 82).
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1.
2.

•

•

•

•

•

•

•

•

3.

Adjusting the Setup

Depending on the features that are in use now or will be used in the future, a specific set of parameters must be set 
in the device's Setup.

In the Setup, go to System > Firmware Update > OS 11 Upgrade.
Make your settings as appropriate:

Activate Upgrade to OS 11.

If you want the device to retry the upgrade immediately after a failed attempt, 
activate Upgrade to OS 11 even if a previous upgrade attempt failed. The device will retry 
the upgrade 5 times. When the 5th attempt has failed, a message will be shown in the 
upgrade tool window.
If your device has a PowerTerm license, and you want to upgrade to IGEL OS 11 even though 
it does not support PowerTerm, you must activate Upgrade to OS 11 even if PowerTerm is 
enabled.
Under Require an Enterprise Management Pack license to upgrade to OS 11, select the 
appropriate option:

If you are using IGEL Cloud Gateway (ICG) or Shared Workplace (SWP) or a Custom 
Partition and want to make sure that the upgrade is performed only if these features 
can be used furthermore, select Smart. When this option is selected, and any of these 
features is activated, the upgrade is performed only if the device could fetch a license 
from an Enterprise Management Pack.
If you want to force the device to fetch a license from an Enterprise Management 
Pack and make sure that the upgrade is performed only if the license could be 
fetched, select Always.
If you want the device to upgrade to IGEL OS 11 without fetching an Enterprise 
Management Pack, disregarding the features that might be activated, select Never.

Under Timeout waiting for OS 11 license to start automatic upgrade, set the time period 
the device will wait for a license in a mass deployment scenario (see Zero-Touch 
Deployment Using Universal Firmware Update (see page 66), Zero-Touch Deployment Using 
Buddy Update (see page 104) and Mass Deployment Using a Scheduled Job (see page 207)). This 
setting prevents the device from starting the upgrade at an inappropriate time as a result of 
the license just being deployed. This way, the setting prevents unwanted interruptions at 
work. For a mass deployment scenario, the default value 10 Minutes is recommended.

Click Apply.

When the Setup is adjusted, continue with Deploying a License (see page 83).

When Upgrade to OS 11 is activated, the device checks for a Workspace Edition license and 
stops checking for a legacy UDC3 or UD Pocket license. Therefore, in the UMS, it is displayed 
as an unlicensed device until a Workspace Edition license has been deployed.


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•

•

•

•

•

•

Deploying a License

To upgrade from IGEL OS 10 to IGEL OS 11,  you need an appropriate license. Depending on your requirements, one 
or more of these licenses will be needed for each device:

One Workspace Edition license for basic functionality. For further information, see Workspace 
Edition
If IGEL Cloud Gateway (ICG), or Shared Workplace (SWP) will be used: One Enterprise Management 
Pack license. For further information, see Enterprise Management Pack.
Custom Partition - if IGEL OS 11.03.100 or lower is the target version; in IGEL OS 11.03.500 or 
higher, the Custom Partition feature is included in the Workspace Edition.

 Deploy the licenses for IGEL OS 11 using the method that suits your needs:

Manual License Deployment: Licenses are created and deployed manually. For instructions, 
see Manual License Deployment for IGEL OS.
Automatic License Deployment (ALD): Licenses are created and deployed automatically to each 
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).
Download three demo licenses from https://www.igel.com/download/.

When the device has a license, continue with Configuring the Update Source (see page 84).

https://www.igel.com/download/
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1.

2.

Configuring the Update Source

In the Setup, go to System > Update > Firmware Update and configure the update source for 
IGEL OS 11. For more information, see the Firmware Update chapter in the IGEL OS Manual.
Click Ok.

When the correct update source is configured, continue with Testing the Upgrade (see page 85).
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1.

2.

•

•

Testing the Upgrade

Click   System and then Upgrade to OS 11. The OS 11 Upgrade Tool starts and indicates 
whether all requirements are met.

Check the output of the OS 11 Upgrade Tool and continue appropriately:

If each requirement has an   icon, click OS Upgrade to start the upgrade process.

If one or more requirements have an   icon, check the messages and resolve the 
issues. Afterwards, click Check again. If all requirements are met, the button changes to OS 

You can change the starting the starting methods for the OS 11 Upgrade Tool in the Setup under 
Accessories > OS11 Upgrade.





Update and Upgrade

IGEL OS Articles   86 / 1017

3.

Upgrade, and you can start the upgrade.

When you start the upgrade, a warning dialog is shown.
Click OK to continue.

A warning dialog with a timeout is shown. If you click Cancel before the timeout expires, the 
upgrade is canceled. If you click OK or just wait for the timeout to expire, the upgrade is started

After the warning dialog has been confirmed or the timeout has expired, the device reboots into a 
special IGEL OS 10 environment, in which the system upgrade is executed. The Upgrade window 
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show the progress.

During the critical phase, the device must not be powered off. At this stage in the progress, an 
additional warning is shown.

When the base system is upgraded successfully, a message is shown.

The remaining components of the firmware are installed, which is indicated by update messages. 

When the installation is completed, the Upgrade window looks like this:
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After a few seconds the device reboots into IGEL OS 11.

When the upgrade test has been successful, you are ready to set up the mass upgrade. Continue with Checking the 
Requirements (see page 89).
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•
•
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•

•

Checking the Requirements

The following requirements must be met:

The upgrade has been tested with characteristic devices.
UMS 6.01.130 or higher is available.
The firmware IGEL OS 10.05.800 (or higher) is known to the UMS. For this purpose, a device 
with this firmware version must be registered in the UMS. This is already the case if you tested the 
upgrade with the same UMS with which you are about to do the mass upgrade. If not, you must 
register a device with the appropriate firmware version now.
All devices are connected to a regular LAN (not OpenVPN, OpenConnect, genucard, NCP VPN or 
mobile broadband).
All devices are in a safe environment where the upgrade process cannot be disrupted, e.g. by 
powering off the devices.

When all requirements are met, continue with Creating the Universal Firmware Updates (see page 90).
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1.
2.

1.
2.

Creating the Universal Firmware Updates

For detailed information, see the chapter Universal Firmware Update in the UMS Manual.

Create a Universal Firmware Update for IGEL OS 10.05.800 (or higher).
After you have created the Universal Firmware Update for IGEL OS 10.05.800 (or higher), create a 
Universal Firmware Update for IGEL OS 11.

Configuring the Universal Firmware Update for ICG

If you are using IGEL Cloud Gateway (ICG), an FTP server that is accessible to all devices must be configured as an 
update source.

To configure an FTP server as update source:

In the UMS, go to UMS Administration > Universal Firmware Update and click .
Enter the data required for accessing the FTP server and click Save.

If you use the High Availability Extension, note that Universal Firmware Updates are NOT synchronized, 
that is why you have to either download them to all HA nodes or configure an external (FTP) server.



The order of creation is crucial because the IGEL OS 11 firmware must have a higher ID in order to 
be chosen by the device. For details, see Executing the Upgrade (see page 102).


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3.

4.

Go to Server - [UMS address] > Universal Firmware Update and in the context menu, select 
Check for new firmware updates.

Select the entry for the IGEL OS 10.05.800 (or higher) firmware, click   to select the FTP server 
selected in step 2 and then select Download.
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5.

6.

The firmware is transferred to the FTP server.

Under Server - [UMS address] > Universal Firmware Update, in the context menu, select Check 
for new firmware updates again.
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7.

8.

Select the entry for the IGEL OS 11 firmware, click   to select the FTP server selected in step 2 
and select Download.

The firmware is transferred to the FTP server.

The devices can download the firmware from the FTP server,

When the Universal Firmware Update is ready, continue with Creating a Profile (see page 94).
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1.

2.

•

•
•
•

Creating a Profile

Create a profile that is based on the IGEL OS 10 firmware (10.08.800 or higher). Find a suitable 
name for the profile, e.g. "Firmware upgrade to IGEL OS 11".

In the profile's configuration dialog, go to System > Update > Firmware Update and change the 
settings according to your environment:

If the UMS and the devices are in one and the same network and no IGEL Cloud Gateway 
(ICG) is used:

Select "HTTPS" as Protocol.
Activate Automatic Update Check on Boot.
Ensure that Automatic Update Check on Shutdown is deactivated. Otherwise, the 
device will shut down when the update is finished.
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•
•
•
•

If IGEL Cloud Gateway (ICG) is used:
Select "FTP" as Protocol.
Activate Automatic Update Check on Boot.
Ensure that Automatic Update Check on Shutdown is deactivated. Otherwise, the 
device will shut down when the update is finished.
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3.

•
•
•
•

•

Go to System > Update > OS 11 Upgrade and change the following settings according to your 
successful upgrade test (for details of the settings, see Adjusting the Setup (see page 82)):

Activate Upgrade to OS 11.
Set Upgrade to OS 11 even if PowerTerm is enabled according to your needs.
Set Upgrade to OS 11 even if a previous upgrade attempt failed according to your needs.
Set Require an Enterprise Management Pack license to upgrade to OS 11 according to 
your needs.
Ensure that the Timeout waiting for OS 11 license to start automatic upgrade is set to 10 
Minutes.
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4.
•
•

Go to System > Remote Management and change the settings as follows:
Deactivate Display 'Apply changes' dialog on boot.
Set Default action on boot to Apply changed configuration immediately.
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5. Click Save.

When the profile is created, continue with Deploying the Licenses (see page 99).
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•

Deploying the Licenses

Deploy the licenses for IGEL OS 11 using the method that suits your needs:

Automatic License Deployment (ALD): Licenses are created and deployed automatically to each 
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).
Manual License Deployment: Licenses are created and deployed manually. For instructions, 
see Manual License Deployment for IGEL OS.

When the license deployment is set up, continue with Putting It All Together (see page 100).
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1.

2.

Putting It All Together

Put all devices that are to be updated into a directory.

Select the directory and in the Assigned objects area, click  .
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3.

4.

5.

Assign the profile (see Creating a Profile (see page 94)) and the two Universal Firmware Updates 
(see Creating the Universal Firmware Updates (see page 90)) to the directory and click Ok.

In the context menu of the assignment, select Now.

In the Assigned objects area, the profile and the Universal Firmware Updates are shown:

If you are using Automatic License Deployment (ALD), it might be feasible to confine the 
distribution of licenses to the current directory. For more information, see Configuring the 
Distribution Conditions, section "Distributing Licenses to Devices in a Specified Directory".

When everything is in place, continue with Executing the Upgrade (see page 102).
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1.

2.

Executing the Upgrade

In the UMS, select the directory containing all devices that are to be upgraded and reboot them.

On reboot or wake up, the devices update to the appropriate IGEL OS 10 firmware (10.05.800 or 
higher). With this version, the Upgrade to OS 11 parameter is recognized by the devices; also, the 
devices request IGEL OS 11 licenses from the UMS (Workspace Edition and, if required, Enterprise 
Management Pack). 
If no IGEL OS 11 licenses have been deployed on the devices yet, the licenses are deployed within a 
few minutes. The upgrade will be started when the licenses are deployed. The maximum time 
period the device will wait for a license is configured by the parameter Timeout waiting for OS 11 
license to start automatic upgrade; for details, see Adjusting the setup (see page 82).
The parameter Automatic update check on boot causes the devices look for new firmware 
again. Although two Universal Firmware Updates are assigned to the devices, the UMS offers the 
IGEL OS 11 firmware, because the ID of the IGEL OS 11 firmware is higher than the ID of the IGEL OS 
10 firmware.
When all devices have been upgraded successfully, remove the "Firmware upgrade to IGEL OS 11" 
profile and the two Universal Firmware Updates from the directory.

Alternatively, you can create a scheduled job for reboot or wake up and assign it to the 
devices or the directory containing these devices. For more information, see Jobs


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The upgrade is completed.
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1.
2.
3.
4.
5.
6.
7.
8.
9.

10.

Zero-Touch Deployment Using Buddy Update
This method uses the buddy update feature of IGEL OS. One or more devices that are configured as an update 
buddy access the main server and download the firmware. The other devices are configured to download their 
firmware from an update buddy.

Read all the following chapters carefully and follow the instructions.

Devices That Can Be Upgraded to IGEL OS 11 (see page 105)
Important! Consider This Before Upgrading (see page 117)
Preparing the Upgrade (see page 118)
Testing the Upgrade (see page 123)
Checking the Requirements (see page 127)
Configuring Two Update Buddies (see page 128)
Creating a Profile (see page 129)
Deploying the Licenses (see page 131)
Putting It All Together (see page 132)
Executing the Upgrade (see page 133)
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•
•
•

•

•
•

•

•
•

Devices That Can Be Upgraded to IGEL OS 11

Core Requirements

CPU with 64-bit support
CPU speed: ≥ 1 GHz
Memory (RAM): ≥ 2 GB

Storage: Depends on the release version of IGEL OS 11. The details are listed below: 2 GB 
minimum; ≥ 4 GB recommended

Up to IGEL OS 11.03: 2 GB minimum; ≥ 4 GB recommended
From IGEL OS 11.04 to IGEL OS 11.07: If the full feature set is applied, at least 2.4 GB of 
storage is required. For instructions on how to reduce the feature set, see Error: "Not 
enough space on local drive" when Updating to IGEL OS 11.08 or Higher.
From IGEL OS 11.08 onwards: If the full feature set is applied, at least 2.4 GB of storage is 
required. For instructions on how to reduce the feature set, see Error: "Not enough space on 
local drive" when Updating to IGEL OS 11.08 or Higher. TODO Add URL when published

No VIA graphic adapter; VIA graphics support is discontinued in IGEL OS.
Legacy Bios and EFI/UEFI are supported.

Devices Supported by OSC and UD Pocket with IGEL OS 11

•
•
•

RAM size higher than 2 GB is recommended if you use any of the following:
Unified Communications optimizations (uses a client-side media engine)
High-resolution graphics output
More than two monitors



With devices that have 2 GB RAM and shared video memory, a maximum of 512 MB may be 
used as video memory.



The following list only includes those devices that are tested by IGEL (with each major release of IGEL OS).
By no means it implies that the devices which are not included in this list but meet the minimum 
requirements will not function with IGEL OS: Any x86-64 hardware endpoint device that meets the IGEL-
stated minimum hardware requirements for IGEL OS (for example, the processor speed and RAM) can be 
expected to work adequately with IGEL OS and should be considered a candidate for repurposing from 
another OS. With an IGEL OS subscription or active maintenance, customers can expect IGEL to make any 
necessary “best effort” to support, regardless of whether the endpoints in question are specifically listed 
within the IGEL Knowledge Base or elsewhere (e.g. on the IGEL Ready Showcase at https://www.igel.com/
ready/showcase-categories/endpoints/).
For any devices not listed here or on the IGEL Ready showcase, you can contact your hardware vendor and 
request those devices to be added to the IGEL Ready program.
Integrated drivers and supported peripherals are listed in the Third-Party Hardware Database21. For more 
solutions compatible with IGEL OS, see Partner Solutions.



https://www.igel.com/linux-3rd-party-hardware-database/
https://www.igel.com/ready/showcase-categories/endpoints/
https://www.igel.com/linux-3rd-party-hardware-database/
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ADS-Tec

Name Endpoint Type Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

DVG-
VMT9010

Industrial PC/
Terminal

4 GB

8 GB

64 GB eMMC Intel Atom® x7-
E3950

11.02.100

DVG-
VMT9012

Industrial PC/
Terminal

4 GB

8 GB

64 GB eMMC Intel Atom® x7-
E3950

11.02.100

DVG-
VMT9015

Industrial PC/
Terminal

4 GB

8 GB

64 GB eMMC Intel Atom® x7-
E3950

11.02.100

DVG-
VMT9112

Industrial PC/
Terminal

4 GB

8 GB

64 GB eMMC Intel Atom® x7-
E3950

11.02.100

Advantech

HP, Lenovo, and LG device models are available from the factory with pre-installed IGEL OS 11. Please 
contact IGEL Ready22 to get information on which device models are available with pre-installed IGEL OS.



For some of the devices listed here, Flash memory must be extended to ≥ 2 GB. For these devices, an 
appropriate note is added.



On modern computers such as secured-core PCs (see e.g. https://www.microsoft.com/en-us/windows/
business/devices?col=secured-core-pcs), there may be a BIOS setting related to Secure Boot that allows 
the use of Microsoft’s 3rd party UEFI Secure Boot Certificate. The usual description of such a BIOS setting is 
"Allow Microsoft 3rd Party UEFI CA". This setting must be set to enabled, as IGEL uses the 3rd party 
certificate to support UEFI Secure Boot. If UEFI Secure Boot is enabled, but "Allow Microsoft 3rd Party UEFI 
CA" is not enabled, you may be unable to boot IGEL OS Creator or UD Pocket. Similarly, if the setting 
"Allow Microsoft 3rd Party UEFI CA" is disabled after a previous installation of IGEL OS, IGEL OS will fail to 
boot. For how to enable the setting, see Secured-Core PCs: Microsoft 3rd-Party UEFI Certificate for Secure 
Boot.



[Fn] keys may not work on some supported and listed laptop/notebook models.

https://www.igel.com/technology-partners/
https://www.igel.com/technology-partners/
https://www.microsoft.com/en-us/windows/business/devices?col=secured-core-pcs
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Name Endpoint Type Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

POC-W213L Medical All in 
One

4 GB 128 GB Intel Core 
i7-7300U

11.01.100

POC-
W243L* (see 
page 116)

Medical All in 
One

4 GB 32 GB Intel Kaby Lake 
Core i5-7300U

11.01.110

POC-
W243L* (see 
page 116)

Medical All in 
One

4 GB 128 GB Intel Core 
i7-7300U

11.01.100

Advantech-DLoG

Name Endpoint Type Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

DLT-V6210 Industrial PC/
Terminal

4 GB 32 GB Intel Atom 11.01.100

DLT-V7210 K Industrial PC/
Terminal

4 GB 4 GB Intel Atom 
E3845

11.01.100

Dell / Wyse

Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage 
Size

Processor Supported 
from IGEL OS 
Version

Note

5040 / 5212 All in One 2 GB 2 GB AMD G-T48E 11.01.100

3040 Thin Client 2 GB 8 GB Intel Atom 
x5-Z8350

11.01.100

5020 Thin Client 2 GB 8 GB AMD G-Series 
SoC

11.02.140

5060 Thin Client 4 GB 8 GB AMD 
GX-424CC

11.01.100

5070 Thin Client 8 GB 32 GB Intel Celeron 
J4105

11.01.100
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Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage 
Size

Processor Supported 
from IGEL OS 
Version

Note

Latitude 
5510

Laptop/
Notebook

8 GB 256 GB Intel Core 
i5-10210U

11.05.100 Wake-on-LAN 
functionality is 
not supported.

Optiplex 
3000

Thin Client 4 GB 32 GB Intel Celeron 
N5105

11.08.200

Dynabook

Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

Portegé X20W-
D

Laptop/
Notebook

8 GB 256 GB Intel Core 
i5-7200U

11.01.100

Portegé X30-D Laptop/
Notebook

8 GB 256 GB Intel Core 
i5-7300U

11.01.100

Tecra C50 Laptop/
Notebook

4 GB 500 GB Intel i5-4210U 11.01.100

Tecra Z50-D Laptop/
Notebook

8 GB 256 GB Intel Core 
i5-7200U

11.01.100

SATELLITE R50 Laptop/
Notebook

4 GB 500 GB Intel i3-6006U 11.01.100

Elo

Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

i2 Touch
(15 and 22 
inches)

All in One 8 GB 128 GB  Intel Core 
i3-8100T

11.05.100

Fujitsu
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Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

Q957 Desktop PC 8 GB 500 GB Intel Core 
i3-6100

11.02.100

FUTRO S740 Thin Client 4 GB 8 GB Intel Celeron 
J4105

11.04.100

HP

Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage 
Size

Processor Supported 
from IGEL OS 
Version

Note

HP t420 Thin Client 2 GB 8 GB AMD 
Embedded G-
Series 
GX-209JA

11.02.100

HP t430 Thin Client 2 GB 16 GB Intel®Celeron®
N4020

11.01.110

HP t530 Thin Client 4 GB 8 GB AMD GX-215JJ 
Dual-Core

11.01.100

HP t630 Thin Client 4 GB 8 GB AMD GX-420GI 11.01.100

HP t730 Thin Client 16 GB 8 GB AMD 
RX-427BB APU

11.01.100

HP t820 Thin Client 16 GB 16 GB Intel Core 
i5-4570S

11.01.100

HP t640 Thin Client 4 GB 16 GB AMD Ryzen 
R1505G

11.04.100

HP t540 Thin Client 16 GB 16 GB AMD Ryzen 
Embedded 
R1305G

11.06.100
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Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage 
Size

Processor Supported 
from IGEL OS 
Version

Note

HP mt46 Mobile Thin 
Client

8 GB 32 GB AMD Ryzen 3 
PRO 4450U

11.07.100 Excluding 
support for 
WWAN 
and Wake-on-
LAN (both 
features are 
planned)

HP Elite 
t655

Thin Client 4 GB / 8 GB 32 GB AMD Ryzen 
Embedded 
R2314

11.07.160

HP Elite 
mt645 G7

Mobile Thin 
Client

8 GB 256 GB AMD Ryzen 3 
5425U

11.08.230 Support for 
WWAN Intel XMM 
7560 R+ (as of 
11.08.330)

Excluding 
support for 
Wake-on-LAN 
(feature is 
planned)

Excluding 
support for built-
in fingerprint 
sensor

AMD Ryzen 5 
5625U

11.08.330

HP t740 Thin Client 8 GB 16 GB AMD Ryzen 
Embedded 
V1756B

11.08.290

HP Pro t550 Thin Client 4 GB 32 GB Intel Celeron 
J6412

11.08.330

HP Pro 
mt440 G3

Mobile Thin 
Client

8 GB 128 GB Intel Celeron 
7305

11.08.440 Excluding 
support for 
WWAN Intel XMM 
7560 R+ (feature 
is planned)

HP Docking Stations 
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Name Supported from IGEL OS Version

HP USB-C Docking Station G5 11.08.230

HP USB-C G5 Essential Dock 11.08.290

Intel

Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

NUC 5i5MYHEDesktop PC 2 GB 32 GB Intel i5-5300U 11.01.100

NUC 5i3RYH Desktop PC 2 GB 2 GB Intel i3-5010U 11.01.100

NUC 7CJYH Desktop PC 2 GB 4 GB Intel Celeron 
J4005

11.01.100

Lenovo

Name Endpoint 
Type

Minimum 
Memory
(RAM) 
Size

Storage 
Size

Processor Wi-Fi Chip Supported 
from IGEL 
OS Version

Note

ThinkCentre 
M625q

Desktop 
PC

4 GB 32 GB AMD 
E2-9000e

Intel AC9260 11.04.100

8 GB 128 GB AMD 
A4-9120e

QCA6174 
802.11ac

11.04.100

ThinkCentre 
M75n

Desktop 
PC

8 GB 256 GB AMD Ryzen 
3 
Pro 3300U

Intel AC9260 11.05.100

ThinkCentre 
M70q Gen1

Desktop 
PC

16 GB 256 GB Intel 
i5-10500t

Comet Lake 
PCH CNVi 
WiFi, Intel

11.05.100

ThinkCentre 
M70q Gen 3

Desktop 
PC

16 GB 256 GB Intel Core 
i5-12500T

Intel AX201 11.08.240

ThinkCentre 
M75q Gen 2

Desktop 
PC

4 GB 128 GB AMD Ryzen 
3 Pro 
5350GE

Intel AX200 11.08.240
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Name Endpoint 
Type

Minimum 
Memory
(RAM) 
Size

Storage 
Size

Processor Wi-Fi Chip Supported 
from IGEL 
OS Version

Note

K14 AMD 
Gen 1

Laptop/
Notebook

8 GB 256 GB AMD Ryzen 
5 PRO 
5650U

Mediatek 
MT7921

11.08.240

ThinkPad 
L14 AMD 
Gen 1 

Laptop/
Notebook

64 GB 1 TB AMD Ryzen 
7 Pro 
4750U

Wi-Fi 6 
AX200, Intel

11.05.100

14w Laptop/
Notebook

4 GB 64 GB AMD 
A6-9220C

QCA6174 
802.11ac

11.05.100

ThinkPad 
L14 AMD 
Gen 3

Laptop/
Notebook

16 GB 256 GB AMD Ryzen 
5 5625U

AMD RZ616 
2X2AX (WiFi 
6E)

11.08.230 Excluding 
support for 
WWAN

ThinkCentre 
Neo50q  
Gen 4

Thin 
Client

8 GB 256 GB Intel Core 
i3-1215U

Wi-Fi 6 
RTL8852BE

11.08.240

4 GB 256 GB Intel 
Celeron 
7305

Wi-Fi 6 AX201

K14 Intel 
Gen 1

Laptop/
Notebook

16 GB 256 GB Intel Core 
i5-1135G7

Intel AX210 
WiFi / BT 
combo

11.08.290

ThinkPad 
L14 Intel 
Gen 3

Laptop/
Notebook

16 GB 512 GB Intel Core 
i5-1235U

Intel Wi-Fi 6 
AX201 2x2 AX 
vPro

11.08.330 LTE support 
as of 
11.08.360

ThinkEdge 
SE10

Thin 
Client

8 GB 1 TB Intel Atom 
x6425RE

MediaTek 
MT7921LEN 

11.08.360

256 GB Intel Atom 
x6214RE

Intel AX210 11.08.360

ThinkPad 
L14 AMD 
Gen 4 

Thin 
Client

8 GB 256 GB AMD Ryzen 
3 Pro 
7330U

AMD RZ616 11.08.440 Quectel 
EM05-G 4G 
CAT4

Realtek 
RTL8852CE

ThinkPad 
L15 AMD 
Gen4

Thin 
Client

8 GB 256 GB AMD Ryzen 
3 Pro 
7330U

AMD RZ616 11.08.440 Quectel 
EM05-G 4G 
CAT4

Realtek 
RTL8852CE
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Name Endpoint 
Type

Minimum 
Memory
(RAM) 
Size

Storage 
Size

Processor Wi-Fi Chip Supported 
from IGEL 
OS Version

Note

ThinkPad 
L14 Intel 
Gen 4

Laptop/
Notebook

8 GB 256 GB Intel Core 
i3-1315U

Intel AX211 11.09.100 Quectel 
EM05-G 4G 
CAT4

ThinkPad 
L15 Intel 
Gen 4

Laptop/
Notebook

8 GB 256 GB Intel Core 
i3-1315U

Intel AX211 11.09.100 Quectel 
EM05-G 4G 
CAT4

Lenovo Docking Stations

Name Supported from IGEL OS Version

ThinkPad USB-C Hybrid Dock 11.07.100

IOBOX 11.07.100

Lenovo Universal USB-C Dock 11.08.440

LG

Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

24CK550N*
* (see page 
116)

All in One 4 GB 32 GB AMD G-Series 
GX-212JJ

11.01.100

24CK550W*
* (see page 
116)

All in One 4 GB 32 GB AMD G-Series 
GX-212JJ

11.01.100

24CK560N*
* (see page 
116)

All in One 4 GB 32 GB AMD G-Series 
GX-212JJ

11.01.100

CK500W Thin Client 4 GB 32 GB AMD G-Series 
GX-212JJ

11.01.100

38CK950N All in One 8 GB 128 GB AMD Ryzen 3  11.02.100

38CK900N All in One 8 GB 128 GB AMD Ryzen 3  11.02.100
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Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

CL600N Thin Client 4 GB 16 GB Intel® Celeron 
J4105 

11.03.100

CL600W Thin Client 8 GB 128 GB Intel® Celeron 
J4105 

11.03.100

34CN650N All in One 4 GB 16 GB Intel® Celeron 
J4105 

11.05.100

24CN650N All in One 8 GB 16 GB Intel® Celeron 
J4105 

11.05.100

27CN650N All in One 8 GB 16 GB Intel® Celeron 
J4105

11.05.100

CQ600I Thin Client 4 GB 16 GB Intel Celeron 
N5105

11.08.330

24CQ650I All in One 4 GB 16 GB Intel Celeron 
N5105

11.08.330

CQ601I Thin Client 4 GB 16 GB Intel Pentium 
Silver N6005

11.08.360

24CR670I All in One 4 GB 16 GB Intel Celeron 
N5105

11.09.110

LG Docking Stations 

Name Supported from IGEL OS Version

LG USB Multi Port Hub 11.09.100

OnLogic

Name Endpoint Type Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

CL210G-10 Industrial PC/
Terminal

4 GB 32 GB Intel Celeron 
N3350

11.04.100

KARBON 300 Desktop PC 4 GB 32 GB Intel Atom x5-
E3930

11.04.100
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Onyx Healthcare

Name Endpoint Type Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

Venus 223 Medical All in 
One

4 GB 128 GB Intel Quad-Core 
J1900

11.01.100

Pepperl+Fuchs

Name Endpoint Type Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

BTC12N Industrial Box 
Thin Client

4 GB 32 GB Intel Apollo Lake 
N4200 

11.09.100

BTC14N Industrial Box 
Thin Client

4 GB 32 GB AMD Ryzen 
Embedded 
V1202B 

11.09.100

Rein Medical

Name Endpoint TypeMinimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

Silenio C122 All in One 8 GB 128 GB Intel® Core™ i5 – 
6th Generation

11.01.110

Silenio C124 All in One 8 GB 128 GB Intel® Core™ i5 – 
6th Generation

11.01.110

Clinio S 
522TCT

Medical All in 
One

8 GB 16 GB Intel® Pentium® 
Silver J5005

11.04.100

Clinio S 
524TCT

Medical All in 
One

8 GB 16 GB Intel® Pentium® 
Silver J5005

11.04.100

Secunet
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•

1.
2.
3.

Name Endpoint 
Type

Minimum 
Memory
(RAM) Size

Storage Size Processor Supported from 
IGEL OS Version

SINA Workstation 
S EliteDesk 800 G2

Workstation 16 GB 256 GB Intel Core 
i7-6700

11.01.100

USB Memory Sticks That Can Be Used as Alternative UD Pocket Hardware

DIGITTRADE

Name Storage Supported from IGEL OS Version

Kobra Stick ≥ 4GB 11.05.133

Officially Supported Virtual Environments

Tested with Ubuntu (64-bit) and default settings

Name Memory
(RAM)

Storage Type Supported from IGEL OS 
Version

Oracle VM VirtualBox ≥ 2 GB ≥ 4 GB Linux 11.04.100

VMware Workstation ≥ 2 GB ≥ 4 GB Linux 11.04.100

* Delock Adapter DP 1.2 to DVI does not work. 

** When using an additional 4k screen with this device, please edit the BIOS settings as follows:

Go to the Chipset screen.
Set Integrated Graphics to “Force”.
Set UMA Frame Buffer Size to “256M” or higher

When you have confirmed that your devices can be upgraded to IGEL OS 11, make sure to consider Important! 
Consider This Before Upgrading (see page 117).

Note that the use of a UD Pocket within a virtual machine is not supported by IGEL.

For some features, more than 2 GB RAM is required. Example: if you use dual monitor environments, a 
virtual machine must have at least 8 GB RAM.


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Important! Consider This Before Upgrading

To make sure that your upgrade can be successful, check the following warnings and notes; a warning symbol 
indicates that irreversible damage can be done to your devices.

When you have considered everything that is relevant, continue with Preparing the Upgrade (see page 118).

Existing partitions: Any existing partition on the target drive of your device will be deleted. The installer 
will repartition the target device. The overall size of the newly created partitions will be calculated based 
on the available disk space. The minimum disk usage is 2 GB, the maximum is 16 GB.



No Downgrade

You cannot restore your IGEL OS 10 system once you have migrated to IGEL OS 11. The device storage is 
overwritten completely with a new partitioning scheme.



Features (e.g. Clients)

IGEL OS 11 does not have the complete feature set of IGEL OS 10. Make sure that the current version of 
IGEL OS 11 meets your requirements. For details, refer to the appropriate release notes.



Custom Partitions

The contents of custom partitions will be deleted by the upgrade. Make sure to back up the contents and 
restore them after the upgrade has finished. Besides becoming dysfunctional after the upgrade, 
applications and kernel drivers in a custom partition might corrupt the upgrade. For this reason, make 
sure to first test the upgrade on a characteristic device. We recommend that you disable custom partitions 
when upgrading; you can enable them once the upgrade has been successfully completed.



Custom Commands

The persistence of custom commands cannot be guaranteed. Besides becoming dysfunctional after the 
upgrade, custom commands might corrupt the upgrade. For this reason, make sure to first test the 
upgrade on a characteristic device. In general, custom commands must be adapted for IGEL OS 11. We 
recommend that you disable custom commands when upgrading; you can enable them once the upgrade 
has been successfully completed.



Power Supply

Ensure that the device is not running on battery power, i.e. it must be connected to a power supply during 
the complete upgrade process.



Network

All devices must be connected to a WLAN or LAN. LAN is the recommended option. The device will not be 
upgraded if connected to OpenVPN, OpenConnect, genucard or mobile broadband.


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1.
2.
3.
4.

Preparing the Upgrade

This section describes the required preparations and tests before any productive devices can be updated. The 
testing should be done with at least one device that is characteristic of your environment. This device should have 
every custom partition and every custom command that may possibly exist in any of your devices.

To prepare the upgrade, perform the following steps:

Preparing the UMS (see page 119)
Adjusting the Setup (see page 120)
Deploying a License (see page 121)
Configuring the Update Source (see page 122)
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1.

2.

Preparing the UMS

To upgrade your devices to IGEL OS 11, you need the appropriate version of the UMS. Also, the devices must be 
registered with the UMS to receive their licenses. 

If you have not already done so, update your UMS to version 6.01.130 or higher. For instructions, 
see Updating UMS.
Make sure that your devices are registered with the UMS. For more information, see the 
chapter Registering IGEL OS Devices on the UMS Server in the UMS Manual.

When the UMS is ready, continue with Adjusting the Setup (see page 120).
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1.
2.

•

•

•

•

•

•

•

•

3.

Adjusting the Setup

Depending on the features that are in use now or will be used in the future, a specific set of parameters must be set 
in the device's Setup.

In the Setup, go to System > Firmware Update > OS 11 Upgrade.
Make your settings as appropriate:

Activate Upgrade to OS 11.

If you want the device to retry the upgrade immediately after a failed attempt, 
activate Upgrade to OS 11 even if a previous upgrade attempt failed. The device will retry 
the upgrade 5 times. When the 5th attempt has failed, a message will be shown in the 
upgrade tool window.
If your device has a PowerTerm license, and you want to upgrade to IGEL OS 11 even though 
it does not support PowerTerm, you must activate Upgrade to OS 11 even if PowerTerm is 
enabled.
Under Require an Enterprise Management Pack license to upgrade to OS 11, select the 
appropriate option:

If you are using IGEL Cloud Gateway (ICG) or Shared Workplace (SWP) or a Custom 
Partition and want to make sure that the upgrade is performed only if these features 
can be used furthermore, select Smart. When this option is selected, and any of these 
features is activated, the upgrade is performed only if the device could fetch a license 
from an Enterprise Management Pack.
If you want to force the device to fetch a license from an Enterprise Management 
Pack and make sure that the upgrade is performed only if the license could be 
fetched, select Always.
If you want the device to upgrade to IGEL OS 11 without fetching an Enterprise 
Management Pack, disregarding the features that might be activated, select Never.

Under Timeout waiting for OS 11 license to start automatic upgrade, set the time period 
the device will wait for a license in a mass deployment scenario (see Zero-Touch 
Deployment Using Universal Firmware Update (see page 66), Zero-Touch Deployment Using 
Buddy Update (see page 104) and Mass Deployment Using a Scheduled Job (see page 207)). This 
setting prevents the device from starting the upgrade at an inappropriate time as a result of 
the license just being deployed. This way, the setting prevents unwanted interruptions at 
work. For a mass deployment scenario, the default value 10 Minutes is recommended.

Click Apply.

When the Setup is adjusted, continue with Deploying a License (see page 121).

When Upgrade to OS 11 is activated, the device checks for a Workspace Edition license and 
stops checking for a legacy UDC3 or UD Pocket license. Therefore, in the UMS, it is displayed 
as an unlicensed device until a Workspace Edition license has been deployed.





Update and Upgrade

IGEL OS Articles   121 / 1017

•

•

•

•

•

•

Deploying a License

To upgrade from IGEL OS 10 to IGEL OS 11,  you need an appropriate license. Depending on your requirements, one 
or more of these licenses will be needed for each device:

One Workspace Edition license for basic functionality. For further information, see Workspace 
Edition
If IGEL Cloud Gateway (ICG), or Shared Workplace (SWP) will be used: One Enterprise Management 
Pack license. For further information, see Enterprise Management Pack.
Custom Partition - if IGEL OS 11.03.100 or lower is the target version; in IGEL OS 11.03.500 or 
higher, the Custom Partition feature is included in the Workspace Edition.

 Deploy the licenses for IGEL OS 11 using the method that suits your needs:

Manual License Deployment: Licenses are created and deployed manually. For instructions, 
see Manual License Deployment for IGEL OS.
Automatic License Deployment (ALD): Licenses are created and deployed automatically to each 
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).
Download three demo licenses from https://www.igel.com/download/.

When the device has a license, continue with Configuring the Update Source (see page 122).

https://www.igel.com/download/


Update and Upgrade

IGEL OS Articles   122 / 1017

1.

2.

Configuring the Update Source

In the Setup, go to System > Update > Firmware Update and configure the update source for 
IGEL OS 11. For more information, see the Firmware Update chapter in the IGEL OS Manual.
Click Ok.

When the correct update source is configured, continue with Testing the Upgrade (see page 123).
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1.

2.

•

•

Testing the Upgrade

Click   System and then Upgrade to OS 11. The OS 11 Upgrade Tool starts and indicates 
whether all requirements are met.

Check the output of the OS 11 Upgrade Tool and continue appropriately:

If each requirement has an   icon, click OS Upgrade to start the upgrade process.

If one or more requirements have an   icon, check the messages and resolve the 
issues. Afterwards, click Check again. If all requirements are met, the button changes to OS 

You can change the starting the starting methods for the OS 11 Upgrade Tool in the Setup under 
Accessories > OS11 Upgrade.


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3.

Upgrade, and you can start the upgrade.

When you start the upgrade, a warning dialog is shown.
Click OK to continue.

A warning dialog with a timeout is shown. If you click Cancel before the timeout expires, the 
upgrade is canceled. If you click OK or just wait for the timeout to expire, the upgrade is started

After the warning dialog has been confirmed or the timeout has expired, the device reboots into a 
special IGEL OS 10 environment, in which the system upgrade is executed. The Upgrade window 
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show the progress.

During the critical phase, the device must not be powered off. At this stage in the progress, an 
additional warning is shown.

When the base system is upgraded successfully, a message is shown.

The remaining components of the firmware are installed, which is indicated by update messages. 

When the installation is completed, the Upgrade window looks like this:
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After a few seconds the device reboots into IGEL OS 11.

When the upgrade test has been successful, you are ready to set up the mass upgrade. Continue with Checking the 
Requirements (see page 127).
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•
•
•

•

•

Checking the Requirements

The following requirements must be met:

The upgrade has been tested with characteristic devices.
UMS 6.01.130 or higher is available.
The firmware IGEL OS 10.05.800 (or higher) is known to the UMS. For this purpose, a device 
with this firmware version must be registered in the UMS. This is already the case if you tested the 
upgrade with the same UMS with which you are about to do the mass upgrade. If not, you must 
register a device with the appropriate firmware version now.
All devices are connected to a regular LAN (not OpenVPN, OpenConnect, genucard, NCP VPN or 
mobile broadband).
All devices are in a safe environment where the upgrade process cannot be disrupted, e.g. by 
powering off the devices.

When all requirements are met, continue with Configuring Two Update Buddies (see page 128).
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1.

2.

Configuring Two Update Buddies

For setting up buddy updates, see the how-to Buddy Update (see page 224).

Update one device to the appropriate IGEL OS 10 firmware (10.05.800 or higher) and configure it as 
an update buddy.
Upgrade another device to IGEL OS 11 and configure it as an update buddy. Make sure that the 
IGEL OS 11 update buddy has the same User Name and Password in System > Update > Buddy 
Update as the IGEL OS 10 update buddy.

When the update buddies are configured, continue with Creating a Profile (see page 129).

Ensure that the network contains only the update buddies and the devices that are to be updated. This 
prevents other devices from updating inadvertently.


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1.

2.

•
•
•
•

•

3.

•
•
•

•
4.

•
•

Creating a Profile

Create a profile that is based on the appropriate IGEL OS 10 version (10.05.800 or higher). Find a 
suitable name for the profile, e.g. "Firmware upgrade to IGEL OS 11".
In the profile's configuration dialog, go to System > Update > Firmware Update and change the 
settings as follows:

Select "FTP" as Protocol.
Enter User Name and Password according to the update buddy server.
Activate Automatic Update Check on Boot.
Ensure that Automatic Update Check on Shutdown is deactivated. Otherwise, the device 
will shut down when the upgrade to OS 10.05.800 is finished.
Activate Automatic Buddy Detection.

Go to System > Update > OS 11 Upgrade and change the following settings according to your 
successful upgrade test (for details, see Adjusting the Setup (see page 120)):

Activate Upgrade to OS 11.
Set Upgrade to OS 11 even if PowerTerm is enabled according to your needs.
Set Require an Enterprise Management Pack license to upgrade to OS 11 according to 
your needs.
Set Timeout waiting for OS 11 license to start automatic upgrade to 10 Minutes.

Go to System > Remote Management and change the settings as follows:
Deactivate Display 'Apply changes' dialog on boot.
Set Default action on boot to Apply changed configuration immediately.
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5. Click Save.

When the profile es created, continue with Deploying the Licenses (see page 131).
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•

•

Deploying the Licenses

Deploy the licenses for IGEL OS 11 using the method that suits your needs:

Automatic License Deployment (ALD): Licenses are created and deployed automatically to each 
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).
Manual License Deployment: Licenses are created and deployed manually. For instructions, 
see Manual License Deployment for IGEL OS.

When the license deployment is set up, continue with Putting It All Together (see page 132).
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1.

2.
3.

Putting It All Together

Assign the profile to all devices that are to be upgraded. This can be done by assigning the profile 
to the directory that contains these devices.

In the context menu of the assignment, select Now.
For Automatic license deployment, a condition can be set to the directory. For more information, 
see Configuring the Distribution Conditions, section "Distributing Licenses to Devices in a 
Specified Directory".

When everything is in place, continue with Executing the Upgrade (see page 133).

Do not assign the profile to the update buddies.
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1.

2.

Executing the Upgrade

In the UMS, select all devices that are to be upgraded and reboot them.

On reboot or wake up, the devices choose the IGEL OS 10 buddy. They ignore the IGEL OS 11 buddy 
at this stage because this version is not known to them yet. The devices update to the appropriate 
IGEL OS 10 version (10.05.800 or higher). With this version, the Upgrade to OS 11 parameter is 
recognized by the devices; also, the devices request IGEL OS 11 licenses from the UMS (Workspace 
Edition and, if required, Enterprise Management Pack). 
If no IGEL OS 11 licenses have been deployed on the devices yet, the licenses are deployed within a 
few minutes. The upgrade will be started when the licenses are deployed. The maximum time 
period the device will wait for a license is configured by the parameter Timeout waiting for OS 11 
license to start automatic upgrade; for details, see Adjusting the Setup (see page 120).
The parameters Automatic update check on boot and Automatic buddy detection cause the 
devices to look for a new firmware and wait for an IGEL OS 11 update buddy to reply. When an IGEL 
OS 11 update buddy is found, the devices start the upgrade process.
When all devices have been upgraded successfully, remove the "Firmware upgrade to IGEL OS 11" 
profile.

The upgrade is completed.

Alternatively, you can create a scheduled job for reboot or wake up and assign it to the devices or 
the directory containing these devices; for more information, see Jobs.


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1.
2.
3.
4.
5.

Mass Deployment Using a Scheduled Job
This scenario is appropriate if you already have a working environment with IGEL OS 10.05.800 (or higher) and want 
to update all devices to IGEL OS 11 at a defined time.

Read all the following chapters carefully and follow the instructions.

Checking the Requirements (see page 135)
Creating a Profile (see page 136)
Deploying the Licenses (see page 140)
Assigning the Profile (see page 141)
Creating the Scheduled Job (see page 143)
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•
•
•

•

•

Checking the Requirements

The following requirements must be met:

The upgrade has been tested with characteristic devices.
UMS 6.01.130 or higher is available.
The firmware IGEL OS 10.05.800 (or higher) is known to the UMS. For this purpose, a device 
with this firmware version must be registered in the UMS. This is already the case if you tested the 
upgrade with the same UMS with which you are about to do the mass upgrade. If not, you must 
register a device with the appropriate firmware version now.
All devices are connected to a regular LAN (not OpenVPN, OpenConnect, genucard, NCP VPN or 
mobile broadband).
All devices are in a safe environment where the upgrade process cannot be disrupted, e.g. by 
powering off the devices.

When all requirements are met, continue with Creating a Profile (see page 136).
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1.

2.

•

•

Creating a Profile

Create a profile that is based on the appropriate IGEL OS 10 firmware version (10.05.800 or higher). 
Find a suitable name for the profile, e.g. "Scheduled firmware upgrade to IGEL OS 11".

In the profile's configuration dialog, go to System > Update > Firmware Update and change the 
settings according to your environment:

Select an update source for IGEL OS 11. For further information, see Firmware Update.

Ensure that Automatic Update Check on Boot and Automatic Update Check on 
Shutdown are deactivated. 

If you use Universal Firmware Update (see page 170) for OS 11, you do not need to configure the 
settings described in this step.



If you use FILE as the protocol (local file or network drive), the device will show an error 
message and go through an additional reboot. Apart from that, the upgrade will work 
normally.



In the following screenshot, FTP is used as an example. The other protocols can be used as 
well.


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3.

•
•
•
•

•

Go to System > Update > OS 11 Upgrade and change the following settings according to your 
successful upgrade test:

Activate Upgrade to OS 11.
Set Upgrade to OS 11 even if PowerTerm is enabled according to your needs.
Set Upgrade to OS 11 even if a previous upgrade attempt failed according to your needs.
Set Require an Enterprise Management Pack license to upgrade to OS 11 according to 
your needs.
Ensure that the Timeout waiting for OS 11 license to start automatic upgrade is set to 10 
Minutes.
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4.
•
•

Go to System > Remote Management and change the settings as follows:
Deactivate Display 'Apply changes' dialog on boot.
Set Default action on boot to Apply changed configuration immediately.
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5. Click Save.

When the profile is created, continue with Deploying the Licenses (see page 99).
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•

•

Deploying the Licenses

Deploy the licenses for IGEL OS 11 using the method that suits your needs:

Automatic License Deployment (ALD): Licenses are created and deployed automatically to each 
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).
Manual License Deployment: Licenses are created and deployed manually. For instructions, 
see Manual License Deployment for IGEL OS.

When the license deployment is set up, continue with Assigning the Profile (see page 141).
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1.

2.

Assigning the Profile

Put all devices that are to be updated into a directory.

Select the directory and in the Assigned objects area, click  .
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3.

4.

Assign the profile (see Creating a Profile (see page 136)) to the directory and click Ok.

In the context menu of the assignment, select Now.

When the profile is assigned, continue with Creating the Scheduled Job (see page 143).
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1.

Creating the Scheduled Job

In the UMS, select Jobs > New Scheduled Job.
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2. Under Name, enter a suitable name for the job, e. g. "Upgrade to IGEL OS 11".
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3. Under Command, select OS 11 Upgrade.
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4. Under Execution time and Start date, set the time at which the upgrade should be executed, and 
click Next.
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5. Review the execution time and click Next.
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6. Assign the directory containing the devices to the job and click Finish.

The upgrade is completed.
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•
•
•
•

Troubleshooting
This section describes possible error cases and solutions.

Regaining a Usable System (see page 150)
Getting Error Messages (see page 151)
Starting an New Upgrade Attempt (see page 152)
Starting Another Upgrade Attempt after 5 Retries (see page 153)
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Regaining a Usable System

Here you can find typical upgrade failures and the appropriate methods to regain a usable system.

Device Has Upgraded to Igel OS 11, but Does Not Boot Any More

To get a working IGEL OS 11 system:

 Use the IGEL OS Creator to recover the IGEL OS 11 system. For more information, see the IGEL OS Creator 
Manual.

IGEL OS 10 Rescue System Fails to Update Missing Partitions

If a severe error has occurred during the upgrade process, the device boots into a minimal IGEL OS 10 (10.05.800 or 
higher) rescue system. If unattended, the device tries to download and update the missing partitions and reboots 
on failure.

To regain a full IGEL OS 10 system, you have two possibilities:

 In the rescue system, start the Setup, go to System > Update > Firmware Update and set a valid update source 
for the appropriate IGEL OS 10 firmware (10.05.800 or higher).

Or:

 Configure a UMS profile that contains a valid update source for the appropriate IGEL OS 10 firmware (10.05.800 
or higher) under System > Update > Firmware Update and assign it to the device.
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Getting Error Messages

 Open the OS 11 Upgrade Tool (default path: click   System and then Upgrade to OS 11).

The OS 11 Upgrade Tool shows the error messages. The most important message is prefixed with Retries; see the 
example below:

 For more information, review the main migration log under /wfs/migration.log

You can use the system log viewer to review the migration log (see the chapter System Log Viewer in the 
IGEL OS Manual) or save the log files in order to send them to the IGEL Support Team (see the chapter Save 
Device Files for Support support).





Update and Upgrade

IGEL OS Articles   152 / 1017

1.

2.

Starting an New Upgrade Attempt

If you want the device to start multiple upgrade attempts (and the device is not already configured to do so):

In the UMS profile or in the Setup, go to System > Update > OS 11 Upgrade and activate Upgrade 
to OS 11 even if a previous upgrade attempt failed. 
Reboot the device.
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1.

2.

Starting Another Upgrade Attempt after 5 Retries

When the Upgrade to OS 11 even if a previous upgrade attempt failed option is set and the upgrade has failed 
each time, the system will stop trying after 5 attempts.

To reset the retry counter:

In the Setup or the UMS profile, go to System > Update > OS 11 Upgrade and deactivate Upgrade 
to OS 11 even if a previous upgrade attempt failed.
When the setting is effective on the devices, go to System > Update > OS 11 Upgrade again and 
activate Upgrade to OS 11 even if a previous upgrade attempt failed..
The retry counter is reset, and the devices will try upgrading another 5 times, if necessary.
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•

•

•

Upgrading IGEL Devices from IGEL OS 10 to IGEL OS 11
This document describes how to upgrade any number of IGEL Universal Desktop devices (UD) from IGEL OS 10 to 
IGEL OS 11.

IGEL OS 10.05.700 or higher is required for upgrading to IGEL OS 11. If you have an older version of IGEL OS 10, you 
need to update to version 10.05.700 or a higher version first. 

The following methods of mass deployment are described here:

Zero-Touch Deployment Using Universal Firmware Update (see page 155): Mass upgrade from any 
version of IGEL OS 10 to IGEL OS 11 in one step using Universal Firmware Update. This method can 
be started immediately or as a scheduled job (wake up or reboot).
Zero-Touch Deployment Using Buddy Update (see page 186): Mass upgrade from any version of IGEL 
OS 10 to IGEL OS 11 in one step using two devices as update buddies. This method can be started 
immediately or as a scheduled job (wake up or reboot).
Mass Deployment Using a Scheduled Job (see page 207): Upgrade devices that are already running 
IGEL OS 10.05.700 (or higher) using a specific scheduled job.



Update and Upgrade

IGEL OS Articles   155 / 1017

1.
2.
3.
4.
5.
6.
7.
8.
9.

10.

Zero-Touch Deployment Using Universal Firmware Update
This method is the most convenient way to upgrade from IGEL OS 10 to IGEL OS 11. The method uses the Universal 
Firmware Update feature of the UMS (Universal Management Suite) and a profile.

Read all the following chapters carefully and follow the instructions.

IGEL Devices That Can Be Upgraded to IGEL OS 11 (see page 156)
Important! Consider This Before Upgrading (see page 158)
Preparing the Upgrade (see page 160)
Testing the Upgrade (see page 165)
Checking the Requirements (see page 169)
Creating the Universal Firmware Updates (see page 170)
Creating a Profile (see page 175)
Deploying the Licenses (see page 180)
Putting It All Together (see page 181)
Executing the Upgrade (see page 184)
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•
•
•

•

IGEL Devices That Can Be Upgraded to IGEL OS 11

Core Requirements for IGEL OS 11

CPU with 64-bit support 
CPU speed: ≥ 1 GHz
Memory (RAM): ≥ 2 GB

Storage: 2 GB minimum; ≥ 4 GB recommended

IGEL Devices Supported by IGEL OS 11

IGEL UD (Universal Desktop)

Product Line Device Type Hardware ID 64 Bit Memory
(RAM)

Storage HW Video 
Acceleration

UD2 D220 40 Yes 2 GB 4 GB Yes

UD2 M250C 50 Yes 2 GB 4 GB Yes

UD2 M250C 51 / 52*** (see 
page 157)

Yes 2 or 4 GB 8 GB Yes

UD3* (see page 
157)

M340C 50 Yes 2 GB 4 GB Yes

UD3 M340C 51 Yes 2 GB 4 GB Yes

UD3 M350C 60 Yes 4 GB 8 GB Yes

UD5* (see page 
157)

H830C 50 Yes 2 GB 4 GB Yes

•
•

•

RAM size higher than 2 GB is recommended if you use any of the following:
Unified Communications optimizations (uses a client-side media engine)
High-resolution graphics output
For details on the supported graphics-related characteristics of IGEL devices, 
see Graphics on IGEL Devices or, for older devices, Graphics on Legacy IGEL 
Devices. 
More than two monitors



Storage Requirements for IGEL OS 11.04 or Higher

IGEL OS 11.04.100 or higher requires at least 2.4 GB storage if the full feature set is applied. Thus, 
the feature set must be modified accordingly; for more information, see Error: "Not enough space 
on local drive" when Updating to IGEL OS 11.04 or Higher.





Update and Upgrade

IGEL OS Articles   157 / 1017

Product Line Device Type Hardware ID 64 Bit Memory
(RAM)

Storage HW Video 
Acceleration

UD6 H830C 51 Yes 2 GB 4 GB Yes

UD7 H850C 10 Yes 4 GB 4 GB Yes

UD7** (see page 
157)

H850C 11 Yes 4 GB 4 GB Yes

UD7 H860C 20 Yes 8 GB 8 GB Yes

UD9* (see page 
157)

TC215B 40 / 41 (Touch) Yes 2 GB 4 GB Yes

* IGEL UD3-LX 50 and UD5-LX 50 are officially supported up to IGEL OS 11.05, incl. private builds. IGEL UD9-LX 40 / 41 
(Touch) devices are officially supported up to IGEL OS 11.07.910.

** As of December 2019, IGEL UD7 model H850C is equipped with the AMD Secure Processor; for further information, 
see UD7 Model H850C.

*** IGEL UD2-LX 52 is supported with IGEL OS 11.06.140 and later.

IGEL Zero

Product 
Line

Device 
Type

Hardware 
ID

64 Bit Memory
(RAM)

Storage UEFI Secure 
Boot Support

HW Video 
Acceleration

IZ2 D220 40 Yes 2 GB 4 GB Yes Yes

IZ3 M340C 50 Yes 2 GB 4 GB Yes Yes

IZ3 M340C 51 Yes 2 GB 4 GB Yes Yes

When you have confirmed that your devices can be upgraded to IGEL OS 11, make sure to consider Important! 
Consider This Before Upgrading (see page 158).

Note on IZ Devices

The IZ devices listed below can be upgraded to IGEL OS 11. To upgrade your IZ devices to IGEL OS 11, 
please contact your IGEL sales representative. See also https://www.igel.com/os11migration/.



https://www.igel.com/os11migration/
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Important! Consider This Before Upgrading

To make sure that your upgrade can be successful, check the following warnings and notes; a warning symbol 
indicates that irreversible damage can be done to your devices.

No Downgrade

You cannot restore your IGEL OS 10 system once you have migrated to IGEL OS 11. The device storage is 
overwritten completely with a new partitioning scheme.



Features (e.g. Clients)

IGEL OS 11 does not have the complete feature set of IGEL OS 10. Make sure that the current version of 
IGEL OS 11 meets your requirements. For details, refer to the appropriate release notes.



Custom Partitions

The contents of custom partitions will be deleted by the upgrade. Make sure to back up the contents and 
restore them after the upgrade has finished. Besides becoming dysfunctional after the upgrade, 
applications and kernel drivers in a custom partition might corrupt the upgrade. For this reason, make 
sure to first test the upgrade on a characteristic device. We recommend that you disable custom partitions 
when upgrading; you can enable them once the upgrade has been successfully completed.



Custom Commands

The persistence of custom commands cannot be guaranteed. Besides becoming dysfunctional after the 
upgrade, custom commands might corrupt the upgrade. For this reason, make sure to first test the 
upgrade on a characteristic device. In general, custom commands must be adapted for IGEL OS 11. We 
recommend that you disable custom commands when upgrading; you can enable them once the upgrade 
has been successfully completed.



Network

All devices must be connected to a WLAN or LAN. LAN is the recommended option. The device will not be 
upgraded if connected to OpenVPN, OpenConnect, genucard, NCP VPN or mobile broadband.



Hardware Support

Make sure that your devices support IGEL OS 11; please refer to IGEL Devices Supported by IGEL OS 11. 
This document describes upgrading methods for IGEL UD and IGEL IZ devices. Upgrading methods for IGEL 
UDC3 and UD Pocket are described under Upgrading UDC3 Devices from IGEL OS 10 to IGEL OS 11.



License
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When you have considered everything that is relevant, continue with Preparing the Upgrade (see page 160).

•

•

A valid license from an IGEL Workspace Edition (WE) Product Pack must be available for 
each device. For general information, see IGEL Software License Overview. For deploying 
licenses, see Setting up Automatic License Deployment (ALD) or Manual License 
Deployment for IGEL OS.
IZ devices are not allowed to upgrade to IGEL OS 11. Please contact your IGEL sales 
representative for a UD Upgrade License which allows you to upgrade your IZ devices.

UMS Version

UMS version 6.01.130 or higher is required for upgrading from IGEL OS 10 to IGEL OS 11.

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Preparing the Upgrade

This section describes the required preparations and tests before any productive devices can be updated. The 
testing should be done with at least one device that is characteristic of your environment. This device should have 
every custom partition and every custom command that may possibly exist in any of your devices.

First of all, you should check thoroughly if IGEL OS 11 has all features required for your purposes.

 Continue with Preparing the UMS (see page 161).
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1.

2.

Preparing the UMS

To upgrade your devices to IGEL OS 11, you need the appropriate version of the UMS. Also, the devices must be 
registered with the UMS to receive their licenses. 

If you have not already done so, update your UMS to version 6.01.130 or higher. For instructions, 
see Updating a UMS Installation.
Make sure that your devices are registered with the UMS. For more information, see the 
chapter Registering Devices on the UMS Server in the UMS Manual.

When the UMS is prepared, continue with Adjusting the Setup (see page 162).
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1.
2.

•
•

•

•

•

•

•

•

3.
4.

Adjusting the Setup

Depending on the features that are in use now or will be used in the future, a specific set of parameters must be set 
in the device's Setup.

In the Setup, go to System > Update > OS 11 Upgrade.
Make your settings as appropriate:

Activate Upgrade to OS 11.
If you want the device to retry the upgrade immediately after a failed attempt, 
activate Upgrade to OS 11 even if a previous upgrade attempt failed. The device will retry 
the upgrade 5 times. When the 5th attempt has failed, a message will be shown in the 
upgrade tool window.
If your device has a PowerTerm license, and you want to upgrade to IGEL OS 11 even though 
it does not support PowerTerm, you must activate Upgrade to OS 11 even if PowerTerm is 
enabled.
Under Require an Enterprise Management Pack license to upgrade to OS 11, select the 
appropriate option:

If you are using IGEL Cloud Gateway (ICG) or Shared Workplace (SWP) or a Custom 
Partition and want to make sure that the upgrade is performed only if these features 
can be used furthermore, select Smart. When this option is selected, and any of these 
features is activated, the upgrade is performed only if the device could fetch a license 
from an Enterprise Management Pack.
If you want to force the device to fetch a license from an Enterprise Management 
Pack and make sure that the upgrade is performed only if the license could be 
fetched, select Always.
If you want the device to upgrade to IGEL OS 11 without fetching an Enterprise 
Management Pack, disregarding the features that might be activated, select Never.

Under Timeout waiting for OS 11 license to start automatic upgrade, set the time period 
the device will wait for a license in a mass deployment scenario (see Zero-Touch 
Deployment Using Universal Firmware Update (see page 155), Zero-Touch Deployment Using 
Buddy Update (see page 186) and Mass Deployment Using a Scheduled Job (see page 207)). This 
setting prevents the device from starting the upgrade at an inappropriate time as a result of 
the license just being deployed. This way, the setting prevents unwanted interruptions at 
work. For a mass deployment scenario, the default value 10 Minutes is recommended.

Click Apply.
Continue with Deploying a License (see page 163).
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•
•

•
•
•

•

•

•

Deploying a License

To upgrade from IGEL OS 10 to IGEL OS 11,  you need an appropriate license. Depending on your requirements, one 
or more of these licenses will be needed for each device:

One Workspace Edition license for basic functionality; see Workspace Edition
If one of the following features is used, one Enterprise Management Pack license is required 
(see Enterprise Management Pack):

IGEL Cloud Gateway (ICG)
Shared Workplace (SWP)
Custom Partition - if IGEL OS 11.03.100 or lower is the target version; in IGEL OS 11.03.500 or 
higher, the Custom Partition feature is included in the Workspace Edition.

Proceed as follows:

Deploy the licenses for IGEL OS 11 using the method that suits your needs:

Manual License Deployment: Licenses are created and deployed manually. For instructions, 
see Manual License Deployment for IGEL OS.
Automatic License Deployment (ALD): Licenses are created and deployed automatically to each 
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).
Download three demo licenses from https://www.igel.com/download/.

When the device has a license, continue with Configuring the Update Source (see page 164).

https://www.igel.com/download/
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1.

2.

Configuring the Update Source

In the Setup, go to System > Update > Firmware Update and configure the update source for 
IGEL OS 11. For more information, see the Firmware Update chapter in the IGEL OS Manual.
Click Ok.

When the correct update source is configured, continue with Testing the Upgrade (see page 165).
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1.

2.

•

•

Testing the Upgrade

Click   System and then Upgrade to OS 11. The OS 11 Upgrade Tool starts and indicates 
whether all requirements are met.

Check the output of the OS 11 Upgrade Tool and continue appropriately:

If each requirement has an   icon, click OS Upgrade to start the upgrade process.

If one or more requirements have an   icon, check the messages and resolve the 
issues. Afterwards, click Check again. If all requirements are met, the button changes to OS 

You can change the starting the starting methods for the OS 11 Upgrade Tool in the Setup under 
Accessories > OS11 Upgrade.


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3.

Upgrade, and you can start the upgrade.

When you start the upgrade, a warning dialog is shown.
Click OK to continue.

A warning dialog with a timeout is shown. If you click Cancel before the timeout expires, the 
upgrade is canceled. If you click OK or just wait for the timeout to expire, the upgrade is started

After the warning dialog has been confirmed or the timeout has expired, the device reboots into a 
special IGEL OS 10 environment, in which the system upgrade is executed. The Upgrade window 
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shows the progress.

During the critical phase, the device must not be powered off. At this stage in the progress, an 
additional warning is shown.

When the base system is upgraded successfully, a message is shown.

The remaining components of the firmware are installed, which is indicated by update messages. 

When the installation is completed, the Upgrade window looks like this:
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After a few seconds the device reboots into IGEL OS 11.

When the upgrade test has been successful, you are ready to set up the mass upgrade. Continue with Checking the 
Requirements (see page 169).
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•
•
•

•

•

Checking the Requirements

The following requirements must be met:

The upgrade has been tested with characteristic devices.
UMS 6.01.130 or higher is available.
The appropriate IGEL OS 10 firmware version (10.05.700 or higher) is known to the UMS. For this 
purpose, a device with this firmware version must be registered in the UMS. This is already the 
case if you tested the upgrade with the same UMS with which you are about to do the mass 
upgrade. If not, you must register a device with the appropriate IGEL OS 10 firmware version now.
All devices are connected to a regular LAN (not OpenVPN, OpenConnect, genucard, or mobile 
broadband).
All devices are in a safe environment where the upgrade process cannot be disrupted, e.g. by 
powering off the devices.

When all the requirements are met, continue with Creating the Universal Firmware Updates (see page 170).
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1.
2.

1.
2.

Creating the Universal Firmware Updates

For detailed information, see the chapter Universal Firmware Update in the UMS Manual.

Create a Universal Firmware Update for the appropriate IGEL OS 10 firmware (10.05.700 or higher).
After you have created the Universal Firmware Update for IGEL OS 10, create a Universal Firmware 
Update for IGEL OS 11.

Configuring the Universal Firmware Update for ICG

If you are using IGEL Cloud Gateway (ICG), an FTP server that is accessible to all devices must be configured as the 
update source.

To configure an FTP server as update source:

In the UMS, go to UMS Administration > Universal Firmware Update and click .
Enter the data required for accessing the FTP server and click Save.

If you use the High Availability Extension, note that Universal Firmware Updates are NOT synchronized, 
that is why you have to either download them to all HA nodes or configure an external (FTP) server.



The order of creation is crucial because the IGEL OS 11 firmware must have a higher ID in order to 
be chosen by the device. For details, see Executing the Upgrade (see page 184).


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3.

4.

Go to Server - [UMS address] > Universal Firmware Update and in the context menu, select 
Check for new firmware updates.

Select the entry for the appropriate IGEL OS firmware, click   to select the FTP server selected 
in step 2  and select Download.
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5.

6.

The firmware is transferred to the FTP server.

Under Server - [UMS address] > Universal Firmware Update, in the context menu, select Check 
for new firmware updates again.
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7. Select the entry for the IGEL OS 11 firmware, click   to select the FTP server selected in step 2  
and select Download.



Update and Upgrade

IGEL OS Articles   174 / 1017

8. The firmware is transferred to the FTP server.

The devices can download the firmware from the FTP server.

When the Universal Firmware Update is ready, continue with Creating a Profile (see page 175).
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1.

2.

•

•
•
•

Creating a Profile

Create a profile that is based on the appropriate IGEL OS 10 firmware version (10.05.700 or higher). 
Find a suitable name for the profile, e.g. "Firmware upgrade to IGEL OS 11".

In the profile's configuration dialog, go to System > Update > Firmware Update and change the 
settings according to your environment:

If the UMS and the devices are in one and the same network, and no IGEL Cloud Gateway 
(ICG) is used:

Select "HTTPS" as Protocol.
Activate Automatic Update Check on Boot.
Ensure that Automatic Update Check on Shutdown is deactivated. Otherwise, the 
device will shut down when the update is finished.
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•
•
•
•

If IGEL Cloud Gateway (ICG) is used:
Select "FTP" as Protocol.
Activate Automatic Update Check on Boot.
Ensure that Automatic Update Check on Shutdown is deactivated. Otherwise, the 
device will shut down when the update is finished.
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3.

•
•
•
•

•

Go to System > Update > OS 11 Upgrade and change the following settings according to your 
successful upgrade test:

Activate Upgrade to OS 11.
Set Upgrade to OS 11 even if PowerTerm is enabled according to your needs.
Set Upgrade to OS 11 even if a previous upgrade attempt failed according to your needs.
Set Require an Enterprise Management Pack license to upgrade to OS 11 according to 
your needs.
Ensure that the Timeout waiting for OS 11 license to start automatic upgrade is set to 10 
Minutes.
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4.
•
•

Go to System > Remote Management and change the settings as follows:
Deactivate Display 'Apply changes' dialog on boot.
Set Default action on boot to Apply changed configuration immediately.
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5. Click Save.

When the profile es created, continue with Deploying the Licenses (see page 180).
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•

•

Deploying the Licenses

Deploy the licenses for IGEL OS 11 using the method that suits your needs:

Automatic License Deployment (ALD): Licenses are created and deployed automatically to each 
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).
Manual License Deployment: Licenses are created and deployed manually. For instructions, 
see Manual License Deployment for IGEL OS.

When the license deployment is setup up, continue with Putting It All Together (see page 181).
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1.

2.

Putting It All Together

Put all devices that are to be updated into a directory.

Select the directory and in the Assigned objects area, click  .
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3.

4.

Assign the profile (see Creating a Profile (see page 175)) and the two Universal Firmware Updates 
(see Creating the Universal Firmware Updates (see page 170)) to the directory and click Ok.

In the context menu of the assignment, select Now.

In the Assigned objects area, the profile and the Universal Firmware Updates are shown:



Update and Upgrade

IGEL OS Articles   183 / 1017

5.
 
If you are using Automatic License Deployment (ALD), it might be feasible to confine the 
distribution of licenses to the current directory. For more information, see Configuring the 
Distribution Conditions, section "Distributing Licenses to Devices in a Specified Directory".

When everything is in place, continue with Executing the Upgrade (see page 184).
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1.

Executing the Upgrade

In the UMS, select the directory containing all devices that are to be upgraded and reboot them.

On reboot or wake up, the devices update to the appropriate IGEL OS firmware version (10.05.700 
or higher). With this version, the Upgrade to OS 11 parameter is recognized by the devices; also, 
the devices request IGEL OS 11 licenses from the UMS (Workspace Edition and, if required, 
Enterprise Management Pack). 
If no IGEL OS 11 licenses have been deployed on the devices yet, the licenses are deployed within a 
few minutes. The upgrade will be started when the licenses are deployed. The maximum time 
period the device will wait for a license is configured by the parameter Timeout waiting for OS 11 
license to start automatic upgrade; for details, see Adjusting the Setup (see page 162).
The parameter Automatic update check on boot causes the devices to look for new firmware 
again. Although two Universal Firmware Updates are assigned to the devices, the UMS offers the 
IGEL OS 11 firmware, because the ID of the IGEL OS 11 firmware is higher than the ID of the IGEL OS 
10 firmware.

Alternatively, you can create a scheduled job for reboot or wake up and assign it to the 
devices or the directory containing these devices. For more information, see Jobs.


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2. When all devices have been upgraded successfully, remove the "Firmware upgrade to IGEL OS 11" 
profile and the two Universal Firmware Updates from the directory.

The upgrade is completed.
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1.
2.
3.
4.
5.
6.
7.
8.
9.

10.

Zero-Touch Deployment Using Buddy Update
This method uses the buddy update feature of IGEL OS. One or more devices that are configured as an update 
buddy access the main server and download the firmware. The other devices are configured to download their 
firmware from an update buddy.

Read all the following chapters carefully and follow the instructions.

IGEL Devices That Can Be Upgraded to IGEL OS 11 (see page 187)
Important! Consider This Before Upgrading (see page 158)
Preparing the Upgrade (see page 160)
Testing the Upgrade (see page 165)
Checking the Requirements (see page 169)
Configuring Two Update Buddies (see page 201)
Creating a Profile (see page 202)
Deploying the Licenses (see page 204)
Putting It All Together (see page 205)
Executing the Upgrade (see page 206)



Update and Upgrade

IGEL OS Articles   187 / 1017

•
•
•

•

IGEL Devices That Can Be Upgraded to IGEL OS 11

Core Requirements for IGEL OS 11

CPU with 64-bit support 
CPU speed: ≥ 1 GHz
Memory (RAM): ≥ 2 GB

Storage: 2 GB minimum; ≥ 4 GB recommended

IGEL Devices Supported by IGEL OS 11

IGEL UD (Universal Desktop)

Product Line Device Type Hardware ID 64 Bit Memory
(RAM)

Storage HW Video 
Acceleration

UD2 D220 40 Yes 2 GB 4 GB Yes

UD2 M250C 50 Yes 2 GB 4 GB Yes

UD2 M250C 51 / 52*** (see 
page 188)

Yes 2 or 4 GB 8 GB Yes

UD3* (see page 
188)

M340C 50 Yes 2 GB 4 GB Yes

UD3 M340C 51 Yes 2 GB 4 GB Yes

UD3 M350C 60 Yes 4 GB 8 GB Yes

UD5* (see page 
188)

H830C 50 Yes 2 GB 4 GB Yes

•
•

•

RAM size higher than 2 GB is recommended if you use any of the following:
Unified Communications optimizations (uses a client-side media engine)
High-resolution graphics output
For details on the supported graphics-related characteristics of IGEL devices, 
see Graphics on IGEL Devices or, for older devices, Graphics on Legacy IGEL 
Devices. 
More than two monitors



Storage Requirements for IGEL OS 11.04 or Higher

IGEL OS 11.04.100 or higher requires at least 2.4 GB storage if the full feature set is applied. Thus, 
the feature set must be modified accordingly; for more information, see Error: "Not enough space 
on local drive" when Updating to IGEL OS 11.04 or Higher.


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Product Line Device Type Hardware ID 64 Bit Memory
(RAM)

Storage HW Video 
Acceleration

UD6 H830C 51 Yes 2 GB 4 GB Yes

UD7 H850C 10 Yes 4 GB 4 GB Yes

UD7** (see page 
188)

H850C 11 Yes 4 GB 4 GB Yes

UD7 H860C 20 Yes 8 GB 8 GB Yes

UD9* (see page 
188)

TC215B 40 / 41 (Touch) Yes 2 GB 4 GB Yes

* IGEL UD3-LX 50 and UD5-LX 50 are officially supported up to IGEL OS 11.05, incl. private builds. IGEL UD9-LX 40 / 41 
(Touch) devices are officially supported up to IGEL OS 11.07.910.

** As of December 2019, IGEL UD7 model H850C is equipped with the AMD Secure Processor; for further information, 
see UD7 Model H850C.

*** IGEL UD2-LX 52 is supported with IGEL OS 11.06.140 and later.

IGEL Zero

Product 
Line

Device 
Type

Hardware 
ID

64 Bit Memory
(RAM)

Storage UEFI Secure 
Boot Support

HW Video 
Acceleration

IZ2 D220 40 Yes 2 GB 4 GB Yes Yes

IZ3 M340C 50 Yes 2 GB 4 GB Yes Yes

IZ3 M340C 51 Yes 2 GB 4 GB Yes Yes

When you have confirmed that your devices can be upgraded to IGEL OS 11, make sure to consider Important! 
Consider This Before Upgrading (see page 189).

Note on IZ Devices

The IZ devices listed below can be upgraded to IGEL OS 11. To upgrade your IZ devices to IGEL OS 11, 
please contact your IGEL sales representative. See also https://www.igel.com/os11migration/.



https://www.igel.com/os11migration/
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Important! Consider This Before Upgrading

To make sure that your upgrade can be successful, check the following warnings and notes; a warning symbol 
indicates that irreversible damage can be done to your devices.

No Downgrade

You cannot restore your IGEL OS 10 system once you have migrated to IGEL OS 11. The device storage is 
overwritten completely with a new partitioning scheme.



Features (e.g. Clients)

IGEL OS 11 does not have the complete feature set of IGEL OS 10. Make sure that the current version of 
IGEL OS 11 meets your requirements. For details, refer to the appropriate release notes.



Custom Partitions

The contents of custom partitions will be deleted by the upgrade. Make sure to back up the contents and 
restore them after the upgrade has finished. Besides becoming dysfunctional after the upgrade, 
applications and kernel drivers in a custom partition might corrupt the upgrade. For this reason, make 
sure to first test the upgrade on a characteristic device. We recommend that you disable custom partitions 
when upgrading; you can enable them once the upgrade has been successfully completed.



Custom Commands

The persistence of custom commands cannot be guaranteed. Besides becoming dysfunctional after the 
upgrade, custom commands might corrupt the upgrade. For this reason, make sure to first test the 
upgrade on a characteristic device. In general, custom commands must be adapted for IGEL OS 11. We 
recommend that you disable custom commands when upgrading; you can enable them once the upgrade 
has been successfully completed.



Network

All devices must be connected to a WLAN or LAN. LAN is the recommended option. The device will not be 
upgraded if connected to OpenVPN, OpenConnect, genucard, NCP VPN or mobile broadband.



Hardware Support

Make sure that your devices support IGEL OS 11; please refer to IGEL Devices Supported by IGEL OS 11. 
This document describes upgrading methods for IGEL UD and IGEL IZ devices. Upgrading methods for IGEL 
UDC3 and UD Pocket are described under Upgrading UDC3 Devices from IGEL OS 10 to IGEL OS 11.



License
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When you have considered everything that is relevant, continue with Preparing the Upgrade (see page 191).

•

•

A valid license from an IGEL Workspace Edition (WE) Product Pack must be available for 
each device. For general information, see IGEL Software License Overview. For deploying 
licenses, see Setting up Automatic License Deployment (ALD) or Manual License 
Deployment for IGEL OS.
IZ devices are not allowed to upgrade to IGEL OS 11. Please contact your IGEL sales 
representative for a UD Upgrade License which allows you to upgrade your IZ devices.

UMS Version

UMS version 6.01.130 or higher is required for upgrading from IGEL OS 10 to IGEL OS 11.

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1.
2.
3.
4.

Preparing the Upgrade

This section describes the required preparations and tests before any productive devices can be updated. The 
testing should be done with at least one device that is characteristic of your environment. This device should have 
every custom partition and every custom command that may possibly exist in any of your devices.

To prepare the upgrade, perform the following steps:

Preparing the UMS (see page 192)
Adjusting the Setup (see page 193)
Deploying a License (see page 194)
Configuring the Update Source (see page 195)
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1.

2.

Preparing the UMS

To upgrade your devices to IGEL OS 11, you need the appropriate version of the UMS. Also, the devices must be 
registered with the UMS to receive their licenses. 

If you have not already done so, update your UMS to version 6.01.130 or higher. For instructions, 
see Updating a UMS Installation.
Make sure that your devices are registered with the UMS. For more information, see the 
chapter Registering Devices on the UMS Server in the UMS Manual.

When the UMS is ready, continue with Adjusting the Setup (see page 193).
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1.
2.

•
•

•

•

•

•

•

•

3.

Adjusting the Setup

Depending on the features that are in use now or will be used in the future, a specific set of parameters must be set 
in the device's Setup.

In the Setup, go to System > Update > OS 11 Upgrade.
Make your settings as appropriate:

Activate Upgrade to OS 11.
If you want the device to retry the upgrade immediately after a failed attempt, 
activate Upgrade to OS 11 even if a previous upgrade attempt failed. The device will retry 
the upgrade 5 times. When the 5th attempt has failed, a message will be shown in the 
upgrade tool window.
If your device has a PowerTerm license, and you want to upgrade to IGEL OS 11 even though 
it does not support PowerTerm, you must activate Upgrade to OS 11 even if PowerTerm is 
enabled.
Under Require an Enterprise Management Pack license to upgrade to OS 11, select the 
appropriate option:

If you are using IGEL Cloud Gateway (ICG) or Shared Workplace (SWP) or a Custom 
Partition and want to make sure that the upgrade is performed only if these features 
can be used furthermore, select Smart. When this option is selected, and any of these 
features is activated, the upgrade is performed only if the device could fetch a license 
from an Enterprise Management Pack.
If you want to force the device to fetch a license from an Enterprise Management 
Pack and make sure that the upgrade is performed only if the license could be 
fetched, select Always.
If you want the device to upgrade to IGEL OS 11 without fetching an Enterprise 
Management Pack, disregarding the features that might be activated, select Never.

Under Timeout waiting for OS 11 license to start automatic upgrade, set the time period 
the device will wait for a license in a mass deployment scenario (see Zero-Touch 
Deployment Using Universal Firmware Update (see page 155), Zero-Touch Deployment Using 
Buddy Update (see page 186) and Mass Deployment Using a Scheduled Job (see page 207)). This 
setting prevents the device from starting the upgrade at an inappropriate time as a result of 
the license just being deployed. This way, the setting prevents unwanted interruptions at 
work. For a mass deployment scenario, the default value 10 Minutes is recommended.

Click Apply.

When the Setup is adjusted, continue with Deploying a License (see page 194).
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•
•

•
•
•

•

•

•

Deploying a License

To upgrade from IGEL OS 10 to IGEL OS 11,  you need an appropriate license. Depending on your requirements, one 
or more of these licenses will be needed for each device:

One Workspace Edition license for basic functionality; see Workspace Edition
If one of the following features is used, one Enterprise Management Pack license is required 
(see Enterprise Management Pack):

IGEL Cloud Gateway (ICG)
Shared Workplace (SWP)
Custom Partition - if IGEL OS 11.03.100 or lower is the target version; in IGEL OS 11.03.500 or 
higher, the Custom Partition feature is included in the Workspace Edition.

Proceed as follows:

Deploy the licenses for IGEL OS 11 using the method that suits your needs:

Manual License Deployment: Licenses are created and deployed manually. For instructions, 
see Manual License Deployment for IGEL OS.
Automatic License Deployment (ALD): Licenses are created and deployed automatically to each 
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).
Download three demo licenses from https://www.igel.com/download/.

When the device has a license, continue with Configuring the Update Source (see page 195).

https://www.igel.com/download/
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1.

2.

Configuring the Update Source

In the Setup, go to System > Update > Firmware Update and configure the update source for 
IGEL OS 11. For more information, see the Firmware Update chapter in the IGEL OS Manual.
Click Ok.

When the correct update source is configured, continue with Testing the Upgrade (see page 196).
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1.

2.

•

•

Testing the Upgrade

Click   System and then Upgrade to OS 11. The OS 11 Upgrade Tool starts and indicates 
whether all requirements are met.

Check the output of the OS 11 Upgrade Tool and continue appropriately:

If each requirement has an   icon, click OS Upgrade to start the upgrade process.

If one or more requirements have an   icon, check the messages and resolve the 
issues. Afterwards, click Check again. If all requirements are met, the button changes to OS 

You can change the starting the starting methods for the OS 11 Upgrade Tool in the Setup under 
Accessories > OS11 Upgrade.


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3.

Upgrade, and you can start the upgrade.

When you start the upgrade, a warning dialog is shown.
Click OK to continue.

A warning dialog with a timeout is shown. If you click Cancel before the timeout expires, the 
upgrade is canceled. If you click OK or just wait for the timeout to expire, the upgrade is started

After the warning dialog has been confirmed or the timeout has expired, the device reboots into a 
special IGEL OS 10 environment, in which the system upgrade is executed. The Upgrade window 
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shows the progress.

During the critical phase, the device must not be powered off. At this stage in the progress, an 
additional warning is shown.

When the base system is upgraded successfully, a message is shown.

The remaining components of the firmware are installed, which is indicated by update messages. 

When the installation is completed, the Upgrade window looks like this:
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After a few seconds the device reboots into IGEL OS 11.

When the upgrade test has been successful, you are ready to set up the mass upgrade. Continue with Checking the 
Requirements (see page 200).
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•
•
•

•

•

Checking the Requirements

The following requirements must be met:

The upgrade has been tested with characteristic devices; see Testing the Upgrade (see page 165).
UMS 6.01.130 or higher is available.
The firmware IGEL OS 10.05.700 or 10.05.800 is known to the UMS. For this purpose, a device 
with OS 10.05.700 or 10.05.800 must be registered in the UMS. This is already the case if you tested 
the upgrade (see Testing the Upgrade (see page 165)) with the same UMS with which you are about to 
do the mass upgrade. If not, you must register a device with OS 10.05.700 or 10.05.800 now.
All devices are connected to a regular LAN (not OpenVPN, OpenConnect, genucard, NCP VPN or 
mobile broadband).
All devices are in a safe environment where the upgrade process cannot be disrupted, e.g. by 
powering off the devices.



Update and Upgrade

IGEL OS Articles   201 / 1017

1.

2.

Configuring Two Update Buddies

For setting up buddy updates, see the How-To Buddy Update (see page 224).

Update one device to the appropriate IGEL OS 10 firmware (10.05.700 or higher) and configure it as 
an update buddy.
Upgrade another device to IGEL OS 11 and configure it as an update buddy. Make sure that the 
IGEL OS 11 update buddy has the same User Name and Password in System > Update > Buddy 
Update as the IGEL OS 10 update buddy.

When the update buddies are configured, continue with Creating a Profile (see page 202).

Ensure that the network contains only the update buddies and the devices that are to be updated. This 
prevents other devices from updating inadvertently.


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1.

2.

•
•
•
•

•

3.

•
•
•

•
4.

•
•

Creating a Profile

Create a profile which is based on the appropriate IGEL OS 10 firmware version (10.05.700 or 
higher). Find a suitable name for the profile, e.g. "Firmware upgrade to IGEL OS 11".
In the profile's configuration dialog, go to System > Update > Firmware Update and change the 
settings as follows:

Select "FTP" as Protocol.
Enter User Name and Password according the update buddy server.
Activate Automatic Update Check on Boot.
Ensure that Automatic Update Check on Shutdown is deactivated. Otherwise, the device 
will shut down when the update is finished.
Activate Automatic Buddy Detection.

Go to System > Update > OS 11 Upgrade and change the following settings according to your 
successful upgrade test:

Activate Upgrade to OS 11.
Set Upgrade to OS 11 even if PowerTerm is enabled according to your needs.
Set Require an Enterprise Management Pack license to upgrade to OS 11 according to 
your needs.
Set Timeout waiting for OS 11 license to start automatic upgrade to 10 Minutes.

Go to System > Remote Management and change the settings as follows:
Deactivate Display 'Apply changes' dialog on boot.
Set Default action on boot to Apply changed configuration immediately.
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5. Click Save.

When the profile is created, continue with Deploying the Licenses (see page 204).
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•

•

Deploying the Licenses

Deploy the licenses for IGEL OS 11 using the method that suits your needs:

Automatic License Deployment (ALD): Licenses are created and deployed automatically to each 
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).
Manual License Deployment: Licenses are created and deployed manually. For instructions, 
see Manual License Deployment for IGEL OS.

When the license deployment is set up, continue with Putting It All Together (see page 205).
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1.

2.
3.

Putting It All Together

Assign the profile to all devices that are to be upgraded. This can be done by assigning the profile 
to the directory that contains these devices.

In the context menu of the assignment, select Now.
For Automatic license deployment, a condition can be set to the directory. For more information, 
see Configuring the Distribution Conditions, section "Distributing Licenses to Devices in a 
Specified Directory".

When everything is in place, continue with Executing the Upgrade (see page 206).

Do not assign the profile to the update buddies.
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1.

2.

Executing the Upgrade

In the UMS, select all devices that are to be upgraded and reboot them.

On reboot or wake up, the devices choose the IGEL OS 10 buddy. They ignore the IGEL OS 11 buddy 
at this stage because this version is not known to them yet. The devices update to the appropriate 
version of IGEL OS 10 (10.05.700 or higher). With this version, the Upgrade to OS 11 parameter is 
recognized by the devices; also, the devices request IGEL OS 11 licenses from the UMS (Workspace 
Edition and, if required, Enterprise Management Pack). 
If no IGEL OS 11 licenses have been deployed on the devices yet, the licenses are deployed within a 
few minutes. The upgrade will be started when the licenses are deployed. The maximum time 
period the device will wait for a license is configured by the parameter Timeout waiting for OS 11 
license to start automatic upgrade; for details, see Adjusting the Setup (see page 162).
The parameters Automatic update check on boot and Automatic buddy detection cause the 
devices to look for a new firmware and wait for an IGEL OS 11 update buddy to reply. When an IGEL 
OS 11 update buddy is found, the devices start the upgrade process.
When all devices have been upgraded successfully, remove the "Firmware upgrade to IGEL OS 11" 
profile.

The upgrade is complete.

Alternatively you can create a scheduled job for reboot or wake up and assign it to the devices or 
the directory containing these devices; for more information, see Jobs.


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1.
2.
3.
4.
5.

Mass Deployment Using a Scheduled Job
This scenario is appropriate if you already have a working environment with IGEL OS 10.05.700 (or higher) and want 
to update all devices to IGEL OS 11 at a defined time.

Read all the following chapters carefully and follow the instructions.

Checking the Requirements (see page 208)
Creating a Profile (see page 209)
Deploying the Licenses (see page 213)
Assigning the Profile (see page 214)
Executing the Upgrade (see page 184)
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•
•
•

•

•

Checking the Requirements

The following requirements must be met:

The upgrade has been tested with characteristic devices.
UMS 6.01.130 or higher is available.
The appropriate IGEL OS 10 firmware version (10.05.700 or higher) is known to the UMS. For this 
purpose, a device with this firmware version must be registered in the UMS. This is already the 
case if you tested the upgrade with the same UMS with which you are about to do the mass 
upgrade. If not, you must register a device with the appropriate IGEL OS 10 firmware version now.
All devices are connected to a regular LAN (not OpenVPN, OpenConnect, genucard, or mobile 
broadband).
All devices are in a safe environment where the upgrade process cannot be disrupted, e.g. by 
powering off the devices.

When all requirements are met, continue with Creating a Profile (see page 209).
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1.

2.

•

•

Creating a Profile

Create a profile that is based on the appropriate IGEL OS 10 firmware version (10.05.700 or higher). 
Find a suitable name for the profile, e.g. "Scheduled firmware upgrade to IGEL OS 11".

In the profile's configuration dialog, go to System > Update > Firmware Update and change the 
settings according to your environment:

Select an update source for IGEL OS 11. For further information, see Firmware Update.

Ensure that Automatic Update Check on Boot and Automatic Update Check on 
Shutdown are deactivated. 

If you use Universal Firmware Update (see page 170) for OS 11, you do not need to configure the 
settings described in this step.



If you use FILE as the protocol (local file or network drive), the device will show an error 
message and go through an additional reboot. Apart from that, the upgrade will work 
normally.



In the following screenshot, FTP is used as an example. The other protocols can be used as 
well.


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3.

•
•
•
•

•

Go to System > Update > OS 11 Upgrade and change the following settings according to your 
successful upgrade test (for details of the settings, see Adjusting the Setup (see page 162)):

Activate Upgrade to OS 11.
Set Upgrade to OS 11 even if PowerTerm is enabled according to your needs.
Set Upgrade to OS 11 even if a previous upgrade attempt failed according to your needs.
Set Require an Enterprise Management Pack license to upgrade to OS 11 according to 
your needs.
Ensure that the Timeout waiting for OS 11 license to start automatic upgrade is set to 10 
Minutes.
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4.
•
•

Go to System > Remote Management and change the settings as follows:
Deactivate Display 'Apply changes' dialog on boot.
Set Default action on boot to Apply changed configuration immediately.
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5. Click Save.

When the profile is created, continue with Deploying the Licenses (see page 213).



Update and Upgrade

IGEL OS Articles   213 / 1017

•

•

Deploying the Licenses

Deploy the licenses for IGEL OS 11 using the method that suits your needs:

Automatic License Deployment (ALD): Licenses are created and deployed automatically to each 
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).
Manual License Deployment: Licenses are created and deployed manually. For instructions, 
see Manual License Deployment for IGEL OS.

When the license deployment is set up, continue with Assigning the Profile (see page 214).
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1.

2.

Assigning the Profile

Put all devices that are to be updated into a directory.

Select the directory and in the Assigned objects area, click  .
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3.

4.

Assign the profile (see Creating a Profile (see page 209)) to the directory and click Ok.

In the context menu of the assignment, select Now.

When the profile is assigned, continue with Creating the Scheduled Job (see page 216).
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1.

2.

Creating the Scheduled Job

In the UMS, select Jobs > New Scheduled Job.

Under Name, enter a suitable name for the job, e. g. "Upgrade to IGEL OS 11".
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3.

4.

Under Command, select OS 11 Upgrade.

Under Execution time and Start date, set the time at which the upgrade should be executed, and 
click Next.
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5.

6.

Review the execution time and click Next.

Assign the directory containing the devices to the job and click Finish.
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•
•
•
•

Troubleshooting
This section describes possible error cases and solutions.

Regaining a Usable System (see page 220)
Getting Error Messages (see page 221)
Starting a New Upgrade Attempt (see page 222)
Starting Another Upgrade Attempt after 5 Retries (see page 223)
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Regaining a Usable System

Here you can find typical upgrade failures and the appropriate methods to regain a usable system.

Device Has Upgraded to Igel OS 11, but Does Not Boot Any More

To get a working IGEL OS 11 system:

 Use the IGEL OS Creator to recover the IGEL OS 11 system. For more information, see the IGEL OS Creator 
Manual.

IGEL OS 10 Rescue System Fails to Update Missing Partitions

If a severe error has occurred during the upgrade process, the device boots into a minimal 10.05.700 (or higher) 
rescue system. If unattended, the device tries to download and update the missing partitions and reboots on 
failure.

To regain a full IGEL OS 10 system, you have two possibilities:

 In the rescue system, start the Setup, go to System > Update > Firmware Update and set a valid update source 
for the appropriate IGEL OS 10 firmware version (10.05.700 or higher).

Or:

 Configure a UMS profile that contains a valid update source for the appropriate IGEL OS 10 firmware version 
(10.05.700 or higher) under System > Update > Firmware Update and assign it to the device.
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Getting Error Messages

 Open the OS 11 Upgrade Tool (default path: click   System and then Upgrade to OS 11).

The OS 11 Upgrade Tool shows the error messages. The most important message is prefixed with Retries; see the 
example below:

 For more information, review the main migration log under /wfs/migration.log

You can use the system log viewer to review the migration log (see the chapter System Log Viewer in the 
IGEL OS Manual) or save the log files in order to send them to the IGEL Support Team (see the chapter Save 
Device Files for Support support).


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1.

2.

Starting a New Upgrade Attempt

If you want the device to start multiple upgrade attempts (and the device is not already configured to do so):

In the UMS profile or in the Setup, go to System > Update > OS 11 Upgrade and activate Upgrade 
to OS 11 even if a previous upgrade attempt failed. 
Reboot the device.
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1.

2.

Starting Another Upgrade Attempt after 5 Retries

When the Upgrade to OS 11 even if a previous upgrade attempt failed option is set and the upgrade has failed 
each time, the system will stop trying after 5 attempts.

To reset the retry counter:

In the Setup or the UMS profile, go to System > Update > OS 11 Upgrade and deactivate Upgrade 
to OS 11 even if a previous upgrade attempt failed.
When the setting is effective on the devices, go to System > Update > OS 11 Upgrade again and 
activate Upgrade to OS 11 even if a previous upgrade attempt failed..
The retry counter is reset, and the devices will try upgrading another 5 times, if necessary.
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Buddy Update
A certain number of devices that are running IGEL OS in your company regularly need to be updated. If every device 
accesses the main update server individually, maybe even over a great geographical distance, the update could 
take quite a long time and might overload the entire connection.

Set up one of your devices as a so-called buddy update server. In the future, only this client will access the main 
server to download the updates. All other clients access the local buddy update server from within the network and 
will no longer offload the network outside.
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For the configuration details, see:

Configuring the Buddy Update Server (see page 227)
Configuring the Buddy Update Client (see page 229)

TechChannel

The buddy update server is always an FTP server.
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Sorry, the widget is not supported in this export.
But you can reach it using the following URL:

https://www.youtube.com/watch?v=IVUlFtOT5uE

https://www.youtube.com/watch?v=IVUlFtOT5uE
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Configuring the Buddy Update Server

Basic Configuration

In the Setup, go to System > Update > Buddy Update.
Activate Enable Update Server.
Enter the credentials User Name and Password.
Specify the maximum number of Concurrent Logins allowed.
Click Save to confirm the changes.
Perform a complete firmware update on the server.
Reboot the server.

Configuration for Different Firmware Versions
This feature is available for the following versions of IGEL OS:

IGEL OS 10: 10.06.100 or higher
IGEL OS 11: 11.02.100 or higher

If you have an environment which requires two or more different firmware versions running simultaneously, you 
can use the buddy update method to provide each buddy update client device with the appropriate firmware 
version. A typical use case might be two groups of employees, of which one requires an older version of the 
browser, or an older version of the Citrix receiver, whereas the other group should get the newest version of IGEL 
OS. This is achieved by dividing both the clients and the servers into groups. To each group, a specific firmware 
version is assigned by first installing that version on the group's update servers. As an example, you can assign 
group 1 to IGEL OS 10.07.100, and group 2 to IGEL OS 10.08.100.

In the following description, the local Setup is used for simplicity reasons; however, in a productive environment, it 
is recommended to use profiles. For further information, see Profiles.

To assign a server to a group:

Configure the server as described above (Basic Configuration (see page 227)), using the firmware that 
is to be assigned to this group.
In the Setup, go to Registry > update > ftp > buddy_group_id.
In the field Buddy Group ID, set the appropriate group id. Unsigned integers are allowed.

No Downgrade from IGEL OS 11.03

It is not possible to downgrade from IGEL OS 11.03 or higher to any version before IGEL OS 11.03, except 
IGEL OS 11.02.200. This is because, from IGEL OS 11.03 onwards, the system partitions are signed to 
guarantee their integrity; it is not possible to change from a system with signed partitions to a system with 
unsigned partitions. IGEL OS 11.02.200 is a special variant of IGEL OS 11.02 that has signed system 
partitions. IGEL OS 11.02.200 is only available from the IGEL Support Team.



Whenever a buddy update server has received a firmware update, it needs to be rebooted 
before it can distribute the new firmware to other devices.


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Click Ok. 
Reboot the device.
The device will provide the firmware update for the group it is assigned to.

For client configuration, see Configuring the Buddy Update Client (see page 229), "Configuration for Different Firmware 
Versions".
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Configuring the Buddy Update Client

Basic Configuration

In the Setup, go to System > Update > Firmware Update.
Set the following parameters:
Server Name: IP address of the buddy update server 
Port: 21 (default with FTP protocol) 
Server Path: - 
User Name: User name of the buddy update server
Password: Password of the buddy update server

Activate Automatic Update Check if you want the client to check automatically during the boot 
process whether new updates are available on the server.
Activate Automatic Buddy Detection if you want the client to look for a buddy update server on 
its own. 
This is useful if you work with more than one buddy update server and do not wish to determine a 
specific one.
In this case, you do not need to define the Server Name, Port and Server Path. If you enter a 
server name anyway, the system treats this server as a fall-back. Thus, you can be sure that the 
system accesses at least this one server if it cannot find any others.
Click Ok. 
Continue with further configuration changes or reboot the device.

Configuration for Different Firmware Versions
The feature is available for the following versions of IGEL OS:

IGEL OS 10: 10.06.100 or higher
IGEL OS 11: 11.02.100 or higher

This feature is described under Configuring the Buddy Update Server (see page 227), "Configuration for Different 
Firmware Versions". 

In the following description, the local Setup is used for simplicity reasons; however, in a productive environment, it 
is recommended to use profiles. For further information, see Profiles.

To assign a client to a group:

In the Setup, go to Registry > update > ftp > buddy_group_id.
In the field Buddy Group ID, set the id of the group to which the desired firmware is assigned.
Click Ok. 
Reboot the device.
The device will use the firmware update for the group it is assigned to.

Ensure that all servers in the network use the same credentials. For security reasons, you 
have to enter them in the upper mask, even if you did not specify a server.


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Balancing the Server Load
This feature is available for the following versions of IGEL OS:

IGEL OS 10: 10.06.100 or higher
IGEL OS 11: 11.02.100 or higher

It is possible to balance the load between several buddy update servers. If System > Update > Firmware Update 
> Automatic Buddy Detection is activated, the clients send a broadcast in their network to determine which buddy 
servers are available. Each server that responds within a fixed timeout is added to a list whose maximum length can 
be defined. When the list is complete, either because its maximum length is reached or because the timeout has 
expired, the client selects a random server from the list. This way, the load of the buddy servers is distributed 
evenly.

To configure a client for balancing the server load:

In the Setup, go to Registry > update > ftp > buddy_server_candidates.
In the field Buddy Update Server Candidates, enter the maximum number of servers the client 
should collect. If the number is 1, the server that responds first is selected.
Click Ok. 
Reboot the device.
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Firmware Update
Here we show you the best practice of downloading a firmware update from our download server and distributing it 
to various devices in your company:

Check our download server23 to see whether there are new updates which are relevant for your 
applications.
Download the relevant update files.
Install an update directory for them on the UMS server or on your FTP server.
Assign this update directory to your devices.
Start the update process manually or via a Scheduled Job (see page 233).

Downloading Updates and Storing them on an FTP Server (see page 232)
Executing an Update Process (see page 233)

https://www.igel.com/software-downloads/
https://www.igel.com/software-downloads/
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Downloading Updates and Storing them on an FTP Server
You can save the update files either directly on the UMS server or you can put them on your captive FTP server. If 
you have many devices to be updated, you should work with the FTP server because it makes it easier to distribute 
large amounts of data in the local network.

Preparation

Click Universal Firmware Update in the UMS Administration area of UMS console.
Click Edit... .
Enter your FTP server under Host, to save the update files in this location.
Add further details like storage path and access data for the server.
Save your settings and click Test Server Connection.

Downloading updates

Right-click Universal Firmware Update on the UMS console tree.
Choose Check for new firmware updates from the context menu. 
A window opens with a list of all updates associated with the firmware versions registered in the 
UMS database.
Choose a Version in the drop-down-list.
Click Information to see the release notes of each update.
Activate the check box Include for downloading a certain update.
Click Download to start the process.
The update will be added to the tree and the current processing status will be shown. 
The unpacked firmware files are finally in the target directory on the FTP server.

Assigning updates to the thin clients
Assign the downloaded update by dragging and dropping to your device directory. Now, if you click this directory 
you can see the firmware update in the right window under Assigned objects. The devices will now know where to 
find the firmware update in the event of an update command.

No Downgrade from IGEL OS 11.03

It is not possible to downgrade from IGEL OS 11.03 or higher to any version before IGEL OS 11.03, except 
IGEL OS 11.02.200. This is because, from IGEL OS 11.03 onwards, the system partitions are signed to 
guarantee their integrity; it is not possible to change from a system with signed partitions to a system with 
unsigned partitions. IGEL OS 11.02.200 is a special variant of IGEL OS 11.02 that has signed system 
partitions. IGEL OS 11.02.200 is only available from the IGEL Support Team.


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Executing an Update Process
Create one or more new Views to distinguish which thin clients will get the new update.
Create a new Job, called "firmware update" for example.
Specify on the Schedule tab when you want the update to be performed.

Add one or more Views on the Assignment tab.
Save the job.

The update process will be performed according to the schedule specified in the job.

The Repeat job option should not be activated for Update, Update on boot or Update on 
shutdown commands.


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Updating IGEL OS Using a USB Storage Device
You can use a USB storage device to update IGEL OS locally. This method is particularly suitable if only one device 
or only a few devices are to be updated and it would not be worth installing an FTP or HTTP server purely for the 
update.

To update the device's firmware without having access to the local setup, follow Updating the Firmware using the 
Linux Console (see page 236).

To update IGEL OS using a USB storage device, proceed as follows:

Download the update file (.zip) for your device from the  IGEL download server24.

Unpack the update files and save them to a USB storage device.

Open the IGEL Setup on the device and select Devices > Storage Devices > Storage Hotplug. 

Set Client Drive Mapping to Static.

Enable Private drive letter for each storage drive.

Set Number of drives to at least 1.

Apply the changes so that they are effective for the device.

Connect the USB storage device to the device and wait until the device has been detected.

Go to System > Update > Firmware Update.

Set Protocol to FILE.

Start the file chooser (Server path) and navigate to  /userhome/media/label of the 

USB storage device / lxos.inf  and click Open.

You can find the officially supported file systems under Storage Hotplug.

You can find more information under Storage Hotplug.

Do NOT use spaces in the USB device name.

https://www.igel.com/software-downloads/workspace-edition/
https://www.igel.com/software-downloads/workspace-edition/
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12. Click Update firmware and confirm the warning message.
The device will reboot while updating the firmware. Do not remove the USB device until the 
update has finished.

Make sure you do not boot from the USB storage device. You might need to change the boot order in the 
BIOS/UEFI.


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Updating the Firmware using the Linux Console

Issue
You have to update the device's firmware without IGEL Universal Management Suite or local IGEL Setup application.

Solution
The device's firmware update can also be carried out directly on the Linux console itself without IGEL Setup:

Restart the device.
Press [ESC ]key during booting to bring up the boot menu.
Select Verbose Boot from the boot menu.
When instructed, switch to the console by pressing [CTRL-ALT-F11] or [CTRL-ALT-F12].
Press [RETURN ]key to log in.
You may have to enter your password.

Carry out the update. The exact procedure varies according to the protocol which is to be used, that is, FILE, HTTP, 
or FTP; see the instructions below. You can check whether the correct parameter values have been passed using the 
get command, e.g. get update.protocol

HTTP

If necessary, set up a static IP address (DHCP is active by default) 
setparam network.interfaces.ethernet.device0.usedhcp false  

setparam network.interfaces.ethernet.device0.manual true  

setparam network.interfaces.ethernet.device0.ipaddr  

setparam network.interfaces.ethernet.device0.netmask 
Configure the update server 
setparam update.protocol http  

setparam update.http.server  

setparam update.http.port 

setparam update.http.path  

setparam update.http.user  

setcryptparam update.http.crypt_password 

The default UMS port is 9080
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Start the update process in the / directory using the command update

FTP

If necessary, set up a static IP address (DHCP is active by default) 
setparam network.interfaces.ethernet.device0.usedhcp false  

setparam network.interfaces.ethernet.device0.manual true  

setparam network.interfaces.ethernet.device0.ipaddr  

setparam network.interfaces.ethernet.device0.netmask 
Configure the update server 
setparam update.protocol ftp  

setparam update.ftp.server  

setparam update.ftp.port 

setparam update.ftp.path  

setparam update.ftp.user  

setcryptparam update.ftp.crypt_password 

Start the update process in the / directory using the command update

FILE

Configure at least one hotplug USB device:
setparam devices.hotplug.usb-storage.numdevices 1

Apply your changes:
kill_postsetupd

Connect the USB storage device to the device.
Wait for the USB storage device to be mounted automatically.
Determine the mount point:
ls /media/

Configure the update parameters:
setparam  update.protocol file  

setparam update.file.path /media/<name of USB storage device>

The default port is 21

Requirement: The unpacked update files are available in the root directory of a USB storage device.



Update and Upgrade

IGEL OS Articles   238 / 1017

7. Start the update process in the / directory using the command update
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Error: "Not enough space on local drive" when Updating to IGEL OS 11.04 
or Higher

Symptom
You have tried to update a device to IGEL OS 11.04.100 or higher, but the update fails with the error message "Not 
enough space on local drive".

Problem
IGEL OS 11.04.100 or higher requires more than 2 GB storage; your device has less storage than required.

Environment
This article is valid for the following environment:

IGEL OS 11.04 or higher
UMS 6.05 or higher (recommended)
Endpoint device that is supported by IGEL OS 11.04.100 or higher but has a storage size lesser than 
the storage size required by the full feature set

Solution
The recommended storage size for IGEL OS 11.04.100 or higher is 4 GB. However, you can update an endpoint 
device with lesser storage than required by a regular IGEL OS installation. This can be done by reducing the feature 
set. A modified INF file ( lxos-reduced.inf ) in the update source defines a reduced feature set that makes the 
firmware fit into your endpoint device's storage.

As an alternative to the preconfigured INF file, you can customize the INF file yourself to define your own reduced 
feature set.

Reduced Feature Set Cannot Be Changed by Setup/UMS

When you have reduced the firmware as described below, you cannot reactivate features via the Setup 
resp. the UMS configuration dialog. To recover the complete feature set, you must copy lxos-

full.inf  to lxos.inf  and then start the firmware update.



Buddy Update

When you have downloaded a reduced firmware on a buddy update server by mistake, also the buddy 
server itself has the limited feature set. To recover the complete feature set on the buddy server, you 
must copy lxos-full.inf  to lxos.inf  in the update source and then update the buddy update 
server again.





Update and Upgrade

IGEL OS Articles   240 / 1017

1.

2.

3.
4.

1.
2.

3.

4.

Using the Preconfigured INF File

 To find out which features are included in the reduced feature set, open the readme[version].txt  in 
your update source directory and search for "Reduced Firmware". The table shows the features, the storage size 
they require, and whether they are included in the reduced feature set.

Replace the lxos.inf  file as follows:

Go to the directory that contains the source files for the firmware update. If you use the WebDav 
capability of the UMS, this is <UMS installation 

directory>\rmguiserver\webapps\ums_filetransfer\<firmware version> ; 

example:  C:\Program 

Files\IGEL\RemoteManager\rmguiserver\webapps\ums_filetransfer\IGEL_O

S_11-11.04.100

Delete lxos.inf

Copy  lxos-reduced.inf  to  lxos.inf
Start the firmware update as usual.

Customizing the INF File

 To get a list of all features and their storage requirement, go to IGEL OS Release Notes, look up your version of 
IGEL OS, go to "Component Versions [your version]", and find the "Services" section.

To customize the INF file:

Open lxos.inf
In the [INFO] section, add the following line:
custom="true"

Delete the [PART]  section of every partition you want to exclude, but do this ONLY IF the section 
has both of the following entries:
dispensable="true"

type="squashfs-auto"

Save lxos.inf  and start the firmware update as usual.

It is safe to delete lxos.inf  because there is a backup file named lxos-full.inf  
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Error: "legacy ICG Root (CA) certificate" When Updating to Igel OS 11.04 
on Devices Connected via ICG

Possible Problem
If you update to IGEL OS 11.04 or higher, devices might fail to connect to the ICG afterward because the CA root 
certificate does not have the CA flag (i.e. X509v3 BasicConstraint extension "is_ca" is set to "false"). This is the case 
when the certificate has been created with UMS 5.07 or UMS 5.08. 

Environment
UMS 5.07 or higher (update to UMS 6.06 or higher will be required if not already present)
ICG with older root certificates that have been created with UMS 5.07 or UMS 5.08

Diagnosis
Open the UMS Console, go to UMS Administration > Global Configuration > Cloud Gateway 
Configuration (UMS 5.07 to UMS 6.05) or UMS Administration > Global Configuration > 
Certificate Management > Cloud Gateway (UMS 6.06 or higher) and select your ICG root 
certificate. 

Click   to review the content of the certificate. 



Update and Upgrade

IGEL OS Articles   242 / 1017

3.

1.
2.
3.
4.
5.

If Certificate Authority: is false, find further instructions under Solution (see page 242).

Solution
Request IGEL OS 11.04.221DER from the IGEL Support team.
Update your devices to IGEL OS 11.04.221DER.
Update your UMS to version 6.06.100, if you have not already done so.
Exchange the root certificate for the ICG connection; see Exchanging the Root Certificate for ICG.
Update your devices to IGEL OS 11.04.240 or higher.



Update and Upgrade

IGEL OS Articles   243 / 1017

•
•
•

1.

2.

Device Does Not Connect to ICG after Update to IGEL OS 11.04 or Higher

Symptom
After an update to IGEL OS 11.04 or higher, the device fails to connect to the UMS via ICG. The log journal shows a 
message similar to this:

igelrm_agent[9824]: [2020/11/11 17:56:16:0140] ERR: SSL error: invalid CA 

certificate (preverify_ok=0;err=24;depth=1)

Environment
UMS 5.07 or higher
ICG with older root certificates that have been created with UMS 5.07 or UMS 5.08
Devices that have just been updated to IGEL OS 11.04 or higher

Problem/Possible Cause
CA root certificates for ICG that have been created with UMS 5.07 or UMS 5.08 are not accepted by IGEL OS 11.04. 
This is because version 1.1 of the OpenSSL library does not accept certificates as CA certificates if they do not have 
the CA flag (i.e. X509v3 BasicConstraint extension "is_ca" is set to "false"). As a consequence, IGEL OS 11.04 or 
higher refuses to use such a certificate.

Diagnosis
Open the UMS Console, go to UMS Administration > Global Configuration > Cloud Gateway 
Configuration (UMS 5.07 to UMS 6.05) or UMS Administration > Global Configuration > 
Certificate Management > Cloud Gateway (UMS 6.06 or higher) and select your ICG root 
certificate. 

Click   to review the content of the certificate. 
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If Certificate Authority: is false, find further instructions under Solution (see page 244).

Solution
ReInstall the ICG using an appropriate root certificate. For details, see the following articles:

Providing the Certificates
Installing the IGEL Cloud Gateway

Register the devices again. For details, see Connecting the Devices.
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IGEL OS Automatic Update Service for Device Evaluation

Overview
The automatic update service checks for available firmware updates periodically; if a firmware update is available, 
the user is prompted to start the update. The firmware is provided by IGEL via a download server that is known by 
the automatic update service. Alternatively, you can use a download server of your own.

The automatic update service is only available for devices with an evaluation license; when the device receives a 
Workspace Edition license, the service is deactivated.

Environment
Endpoint device with IGEL OS 11.06.100 or higher

Configuring the Automatic Update Service
In the UMS configuration dialog or the local Setup, go to System > Registry > update > auto-
service > enable and ensure that Enable automatic update service is set to "During evaluation 
only". 

Set the following parameters according to your requirements:
interval: Time interval in hours in which the device should check for firmware updates 
during runtime. When the value is 0, the device only checks on boot.
max_delays: Maximal times the user can postpone an update. Example: When this value is 
set to 9, the user can postpone the update 9 times before the update will be forced. When 
the value is 0, the update will be forced immediately.
randomized_delay: Delay time that is added to the interval to avoid an excessive amount 
of requests to the server at the same time. 
server: If you want to use an update server of your own, enter its address here. If the field is 
empty, the public update server provided by IGEL will be used.
user_dialog_timeout: Timeout in seconds before the user dialog is closed and the update 
is started. When set to 0, the dialog remains open until the user closes it.
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version: The target version to which the device should be updated. If the field is left empty, 
the current version will be used. Example: "11.05.133"

Click Apply or Ok to confirm your settings.
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Citrix
Performance (see page 248)
Mouse (see page 255)
How to Configure Citrix Native USB Redirection (see page 262)
Citrix Fabulatech Scanner Redirection in IGEL OS (see page 264)
Mapping USB Storage Media into Citrix Sessions (see page 266)
Auto-Hide Toolbar in Appliance Mode (see page 268)
Create a Seamless, Transparent User Experience with Appliance Mode (see page 269)
Connecting to a Citrix Farm (see page 270)
Create a Self-Service Setup for the User with Quick Settings (see page 276)
Login Failed because of the Expired AD Password (see page 278)
Configuring Auto Logon for Citrix Virtual Desktops (see page 280)
Force Citrix Logout Using Hotkey (see page 284)
Citrix: Freeze at Logout (see page 285)
Warning Message: [Citrix Store] Could Not Connect to the Citrix Server (see page 287)
Setting up Citrix Sessions with Hardware-Accelerated H.264 Deep Compression Codec (see page 289)
Using Font Smoothing (ClearType) in Citrix Sessions (see page 290)
Highly Secured XenServer has Problems with LD_BIND_NOW Workaround (see page 292)
Workaround for Citrix Receiver X Error (see page 293)
Citrix HTML5 Receiver Issue (see page 294)
Macbook Keyboard Layout inside Citrix Session (see page 295)
Citrix Feature Matrix (see page 296)
Using Lync / Skype for Business with Citrix HDX RealTime Optimization Pack (see page 300)
Unexpected Keyboard Layout in a Citrix Session (see page 301)
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Performance
Poor Performance: Black Blocks and Stripes in Citrix Sessions (see page 249)
Poor Performance with Citrix XenDesktop 7.6 Deep Compression (see page 250)
Citrix Receiver: Grey Blocks in Excel 2013 (see page 251)
Bar Code Scanning is Slow via Citrix (see page 252)
Slow Performance of Citrix Session in a Cloud Environment (see page 253)
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Poor Performance: Black Blocks and Stripes in Citrix Sessions

Symptom
In the Citrix session, you sometimes experience a problem with black blocks, frames, or stripes.

Problem
Poor performance is often connected with the delayed or slow refreshing of the screen content.

Solution

 In the IGEL Setup or the configuration dialog in the UMS, activate one of the following parameters or all of them 
under Sessions > Citrix > Citrix Global > Options:

Use server redraw
Backing store
Deferred screen update mode

See also Options in the manual chapter for Citrix.



Citrix

IGEL OS Articles   250 / 1017

Poor Performance with Citrix XenDesktop 7.6 Deep Compression

Symptom
When using XenDesktop 7.6 on Windows Server 2008R2 with Citrix Receiver 13.0.4, 13.1.4 or 13.2.1 with H.264 Deep 
Compression Codec, dragged Windows lag and the performance is generally poor.

Problem
Server and/or client do not have enough computing power for the H.264 Deep Compression Codec.

Solution
Enable the legacy graphics mode on the XenDesktop 7.6 server via a policy.
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Citrix Receiver: Grey Blocks in Excel 2013

Symptom
When using Microsoft Excel 2013 on XenDesktop 7.6 with Citrix Receiver 13.1.3, 13.1.4 or 13.2, grey blocks appear 
especially if you mark multiple cells.

Problem
Codec parameters may not be optimal for this use case.

Solution

In IGEL Setup, go to Sessions > Citrix  > Citrix Global > Codec.
Disable Text Tracking.
Disable Small Frames Feature.
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Bar Code Scanning is Slow via Citrix

Issue
Bar code scanning is slow via Citrix.

Environment

Firmware version: any
UMS version: any

Description
USB attached bar code scanner is very slow via Citrix.

Solution
In order to pass the Bar Code scanner through correctly, you want it to be a HID so it passes through as a HID 
instead of using Native USB Redirection. A quick way to determine that would be to open a terminal in IGEL OS and 
simply scan something. If it populates data in the terminal, then it is configured as HID. Also, check the 
configuration guide for the particular scanner that you are using. The config guide is simply a bunch of barcodes 
that the device can scan. Once a code is scanned, the device beeps twice, and that changes the config on the 
scanner. On some devices, there is a setting for Alternate OS Linux/MACOS. The default setting for the scanner 
usually doesn't enable this. Once the setting was set, everything scanned very fast and that same speed was shown 
in Citrix. 

Solution Based on Experience from the Field

This article provides a solution that has not been approved by the IGEL Research and Development 
department. Therefore, official support cannot be provided by IGEL. Where applicable, test the solution 
before deploying it to a productive environment.


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1.

Slow Performance of Citrix Session in a Cloud Environment

Symptom
Your cloud-based Citrix session is very slow.

Environment

IGEL OS 10.05 or higher, up to IGEL OS 11.05 (with IGEL OS 11.06 or higher, the default setting has 
changed)
Citrix client is connected to a cloud server. NOT affected: On-premises and Netscaler 
environments 

Problem
The HDX transport protocol is set to "UDP with fallback to TCP", which causes slow performance. 

Solution

Open the UMS configuration dialog or the local Setup and go to Citrix > Citrix Global > Options.
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2. Set HDX Adaptive Transport over EFT to"TCP only UDP disabled" and click Apply or Ok.

When the Citrix client is started again, the performance should be better.
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Mouse
Changing Middle Mouse Button Function for Citrix Session and Local Firefox Browser (see page 256)
How to Connect a SpaceMouse with a Citrix Session (see page 257)
Solve SpaceMouse USB Reset Problem (see page 259)
Wireless Mouse Keyboard Set Logitech k520 Freezes in Citrix Session (see page 260)
Black Box Next to the Mouse Cursor (see page 261)
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Changing Middle Mouse Button Function for Citrix Session and Local Firefox 
Browser
Middle mouse button cannot be used for smooth scrolling within applications like Excel or Internet Explorer within a 
Citrix session or with the local Firefox browser.

The default function of the middle mouse button is copy and paste.

 Open IGEL registry in local client setup or UMS.

 For Citrix sessions change:

System > Registry > ica.wfclient.mousesendscontrolv

 For local Firefox browser change:

System > Registry > browserglobal.app.middlemouse_contentloadurl
System > Registry > browserglobal.app.middlemouse_paste

More information on the Firefox parameters can be found at

http://kb.mozillazine.org/Middlemouse.contentLoadURL

http://kb.mozillazine.org/Middlemouse.paste

The changes will take effect after rebooting the thin client.

http://kb.mozillazine.org/Middlemouse.contentLoadURL
http://kb.mozillazine.org/Middlemouse.paste
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4.
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How to Connect a SpaceMouse with a Citrix Session
This article describes how to use a 3Dconnexion SpaceMouse in a Citrix session.

To configure the SpaceMouse for Citrix sessions:

In Setup, go to Sessions > Citrix > Citrix Global > Native USB Redirection.
Activate the checkbox Native USB Redirection.
Set the Default rule to Deny.
Add a device exception rule as in the following screenshot with the Vendor ID and Product ID of 
your specific SpaceMouse:
SpaceMouse products included (VID, PID, Vendor, Product)

0x046D; 0xC603; Logitech, Inc.; 3Dconnexion Spacemouse Plus XT
0x046D; 0xC605; Logitech, Inc.; 3Dconnexion CADman
0x046D; 0xC606; Logitech, Inc.; 3Dconnexion Spacemouse Classic
0x046D; 0xC621; Logitech, Inc.; 3Dconnexion Spaceball 5000
0x046D; 0xC623; Logitech, Inc.; 3Dconnexion Space Traveller 3D Mouse
0x046D; 0xC625; Logitech, Inc.; 3Dconnexion Space Pilot 3D Mouse
0x046D; 0xC626; Logitech, Inc.; 3Dconnexion Space Navigator 3D Mouse
0x046D; 0xC627; Logitech, Inc.; 3Dconnexion Space Explorer 3D Mouse
0x046D; 0xC628; Logitech, Inc.; 3Dconnexion Space Navigator for Notebooks
0x046D; 0xC629; Logitech, Inc.; 3Dconnexion SpacePilot Pro 3D Mouse
0x046D; 0xC62B; Logitech, Inc.; 3Dconnexion Space Mouse Pro
0x256F; *; 3Dconnexion; SpaceMouse

Always use a SpaceMouse only as an additional, i.e. second, mouse.

From version 10.06.100 or 11.02.100 on, the SpaceMouse does not interfere anymore with the local 
mouse pointer because of a registry key which is enabled by default.
This registry parameter ignores the SpaceMouse for the IGEL graphical user interface:
IGEL Setup System > Registry
Parameter Deactivates 3Dconnexion/Logitech SpaceMouse 

products as a standard mouse
Registry Key userinterface.mouse.spacemouse.x11_igno

re
Value enabled/disabled
Info "enabled" means that the SpaceMouse is passed 

through to the session and ignored by the local GUI.
"disabled" means that the SpaceMouse is also used for 
the local GUI.


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5. Save the settings.

Now, the SpaceMouse is ready for use.

1.
2.

To achieve that the mouse behaves as usual in CAD programs, change the configuration as follows:
Go to IGEL Setup > System > Registry > ica.wfclient.mousesendscontrolv.
Set the parameter to disable.



If the SpaceMouse does not function properly after the previous Citrix session, the USB reset of 
the SpaceMouse must additionally be configured. Follow the instructions in Solve 3Dconnexion 
SpaceMouse USB Reset Problem (see page 259).


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1.
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3.

Solve SpaceMouse USB Reset Problem

Environment
Valid for IGEL hardware H850C, H830C, and M340C

Problem
After a previous Citrix session, the SpaceMouse does not function properly (e.g. after the end of the Citrix session, 
the reset of the SpaceMouse does not take place; as a result, the display of the SpaceMouse always remains bright).

Solution
Use a power cycle command to automatically turn all USB devices off and on again:

In IGEL Setup, go to System > Firmware Customization > Custom Commands > Post Session.
Under Session type, select Citrix.
Under Post session command, enter the following command:  /etc/igel/usb-power-

reset/igel-usb-power-ctl -p cycle

As a result of the configured USB power cycle, after the end of the Citrix session, the display of the SpaceMouse 
should become dark for about 1 second and then bright again.

See also How to Connect a SpaceMouse with a Citrix Session (see page 257).

You do not need root permissions for this action.
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Wireless Mouse Keyboard Set Logitech k520 Freezes in Citrix Session

Issue
Wireless Mouse Keyboard Set Logitech k520 freezes in Citrix XenDesktop session.

Environment

IGEL OS 11
UMS 6.01 and higher

Description
If the Wireless Mouse Keyboard's infrared signal is disturbed, it freezes.

Solution
This particular device uses infrared dongle. BT devices should work fine as a workaround and we suggest using 
those. Citrix discourages the use of the IR dongles.

Solution Based on Experience from the Field

This article provides a solution that has not been approved by the IGEL Research and Development 
department. Therefore, official support cannot be provided by IGEL. Where applicable, test the solution 
before deploying it to a productive environment.


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Black Box Next to the Mouse Cursor

Symptom
With certain programs (Adobe Reader, Visual Studio, ...) a black box is always displayed next to the cursor 
in XenDesktop VMs.

Problem
This only happens when a connection is made to an IGEL device and disappears when a Windows device is 
connected. The box is only visible directly on the client (not via VNC).
The problem occurs on the UD7 as well as on Intel NUCs.

Solution

 In the IGEL Setup disable the parameter Disable RENDER Extension (for ICA only) under System > Registry > 
ica.wfclient.disablexrender:

See also at Citrix: https://support.citrix.com/article/CTX212013

https://support.citrix.com/article/CTX212013
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1.
2.
3.

•
•

4.

How to Configure Citrix Native USB Redirection
Native USB Redirection redirects most popular USB devices to the Citrix session. To use this feature, you must 
have at least XenDesktop 7.6 installed. In addition, the guidelines for USB redirection must be defined. More 
information can be found on the following pages

Citrix Generic USB Redirection Configuration Guide25

Generic USB redirection and client drive considerations26

The following types of USB device are not supported by default for use in a Citrix Virtual Apps and Desktops
session:

Bluetooth dongles
Integrated NICs
USB hubs

The following types of device are supported directly in a Citrix Virtual Apps and Desktops session, and so do not 
use USB support:

Keyboards
Mice
Smart cards
Headsets
Webcams

In addition to the server policies, the USB redirection must also be activated at the client:

In Setup, go to Sessions > Citrix > Citrix Global > Native USB Redirection.
Enable Native USB Redirection.
Set the Default rule to Deny or Allow:

Allow: All devices that are allowed by default are redirected. 
Deny: No device is redirected.

To customize the USB redirection, you can create classes or device rules to redirect e.g. Bloomberg 
keyboards or 3D Spacemouse.

Tip

To secure your endpoint, it is generally recommended to set Default rule to Deny and to 
configure Allow rules only for the required USB devices and USB device classes. 



Getting USB Device Information

To find out the Class ID, Subclass ID, Vendor ID and Product ID of the connected USB device, you can use 
the System Information tool. For further information, see Using “System Information” Function.
System Information example:



https://support.citrix.com/article/CTX137939
https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/general-content-redirection/usb.html
https://support.citrix.com/article/CTX137939
https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/general-content-redirection/usb.html
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Alternatively, you can use the command lsusb  (or lsusb | grep -i [search term] ) in the 
terminal.
Example for lsusb :

For a device exception rule, use the SpaceMouse Guide (see page 257).
For more information about USB redirection rules, see Native USB Redirection and the documentation of 
the respective Citrix Workspace app.


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2.

Citrix Fabulatech Scanner Redirection in IGEL OS
The following article details how you can activate Fabulatech scanner redirection for Citrix sessions.

How to Enable Fabulatech Scanner Redirection for Citrix
In the IGEL Setup, go to System > Firmware Customization > Features and make sure that 
Scanner support /SANE (Limited support - functionality "as is", see product documentation 
for details) is activated.

If the option is already activated, continue with step 2.

If the option has not been activated before, the software component must be downloaded 
first. For this purpose, make sure that the source of the current firmware is set correctly:

If you are using Universal Firmware Update, make sure that the device is assigned to 
the current firmware. For details, see Universal Firmware Update and Assigning 
Updates.
If you are not using Universal Firmware Update, make sure that System > Update > 
Firmware Update is set to the source of the current firmware. For details, see 
Firmware Update.

After clicking OK to confirm your changes, you must reboot the system.  

In the IGEL Setup, go to Sessions > Citrix > Citrix Global > Fabulatech Scanner Redirection.

Note that Fabulatech Scanner for Remote Desktop must also be installed on the backend server. For more 
information and a free trial version, see https://www.scanner-for-remote-desktop.com/.



https://www.scanner-for-remote-desktop.com/
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3.

4.

Check Fabulatech Scanner for Remote Desktop.

Click Apply or Ok to confirm the settings.
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Mapping USB Storage Media into Citrix Sessions
How to configure USB storage mapping so that users can access USB storage media attached to the IGEL OS device 
within Citrix sessions?

Basic Configuration of the Client

Within the IGEL Setup or a UMS profile, you basically need to configure these parameters:

 Activate Devices > Storage Devices > Storage Hotplug > Client drive mapping > Dynamic. This option 
activates dynamic client drive mapping. It automatically recognizes new storage media as they are connected to 
the endpoint device. The endpoint device beeps and shows a notification while it mounts the new device. The 
storage devices automatically become usable on the endpoint and in Citrix ICA Sessions.

Additional Parameters to Check

 The following parameters are set by default, thus storage mapping will work, but maybe for some reason you 
have changed these and need to adjust them to allow the storage mapping:

The mapping of USB storage devices is possible for "USB mass storage class" devices. The storage of 
smartphones and digital cameras is usually accessed via the MTP protocol. Mobile device access via MTP is 
available with IGEL Linux 10.04.100 or higher; for more information see the how-to Using Mobile Device 
Access (see page 916).



Mounted devices need to be unmounted before they are removed to ensure data integrity. This can be 
done via the Disk Utility, the Disk Removal tool, or a tray icon.


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Sessions > Citrix > Citrix Global > Mapping > Drive Mapping > Drive mapping (set checkmark) 

Sessions > Citrix > Citrix Global > Native USB Redirection > Native USB redirection (remove checkmark) 

Sessions > Citrix > Citrix Global > Fabulatech USB Redirection > Fabulatech USB redirection (remove 
checkmark) 

Devices > USB access control > Enable (remove checkmark) 

Sessions > RDP > RDP Sessions > [session name] > USB Redirection > Enable Native USB Redirection (set 
to Global setting) 

Sessions > RDP > RDP Sessions > [session name] > Mapping > Enable Drive Mapping (set to Global setting)

Assigning a Drive Letter within the Session (Optional)
 In case you not only want to see the drive in the session as e.g. "A on IGEL-123456789", but want to address the 

drive with a real drive letter within the session, you may run one of these commands:
subst T: \\tsclient\t  

or 
net use T: \\tsclient\t  

In this example, "T on IGEL-123456789" is assigned to drive letter T: within the session. You may also assign the 
mapped drive to another drive letter than is used in its name.

Configuration on the Server Side
On the server side, e.g. with Windows Server 2008R2, a user in the group "Users" with access to the terminal server 
will have the mapping default. This is true for a newly installed server. But the mapping can be prevented by 
changing the policies:

Do not allow drive redirection specifies whether to prevent the mapping of client drives in a Remote 
Desktop Services session (drive redirection). By default, an RD Session Host server maps client drives 
automatically upon connection. Mapped drives appear in the session folder tree in Windows Explorer or 
Computer in the format [driveletter] on [computername]. You can use this setting to override this 
behavior." Source: https://technet.microsoft.com/de-de/library/ee791794%28v=ws.10%29.aspx



https://technet.microsoft.com/de-de/library/ee791794%28v=ws.10%29.aspx
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Auto-Hide Toolbar in Appliance Mode

Environment
IGEL Linux v5.x or newer

Problem
In the appliance mode, the toolbar at the top of the screen is permanently displayed.

You want to configure the toolbar to hide automatically after it loses the focus of the mouse pointer.

Solution
In IGEL Setup, go to System > Registry > 
userinterface.igel_toolbar.show_always_in_appliance_mode.
Disable Show toolbar always in appliance mode.
Click Ok to save the changes.

For the changes to take effect, you need to restart active appliance mode sessions.
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1.
2.
3.

Create a Seamless, Transparent User Experience with Appliance Mode
With appliance mode, you can confine a device to a specific session. In appliance mode, the device itself fades in the 
background, and the session is presented to the user in the most straighforward way. The user will not have to deal 
with a Linux desktop, multiple login procedures, switching between windows, or device configuration.

Use the appliance mode to allow access only to one specific session. On device startup, the user is directed 
immediately to the login screen of the virtual desktop.

The appliance mode can be applied to the following session types:

VMware Horizon
Citrix Self-Service (for published desktops only, not for published applications)
RHEV/Spice
Imprivata
RDP MultiPoint Server
XDMCP for this display

To configure a session that runs in appliance mode:

Open the setup and go to Sessions > Appliance mode.
Choose the session type of the desired session using the drop-down menu Appliance mode.
Configure your appliance mode session as appropriate.

For further information, see the manual chapter Appliance Mode.
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Connecting to a Citrix Farm
By connecting a Citrix farm, your data and applications are kept centrally on a Citrix farm. Applications must now be 
delivered instantly to users anywhere on any device.

There are several ways of connecting to a Citrix farm and starting sessions. We describe three best practice variants 
below:

Citrix StoreFront (see page 271): Integrates published applications into the IGEL GUI.
Citrix Self-Service (see page 272): Users will be directed to a web interface where they will find pre-
defined published applications and they will be able to add more published applications the 
server provides.
Appliance Mode (see page 275): Shows only the web interface of the farm and hides the IGEL GUI 
completely.
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11.

12.

Citrix StoreFront

Prerequisites:

Trust root certificate in directory /wfs/ca-certs (see Deploying Trusted Root Certificates (see page 
604))

Connecting via StoreFront:

Click Sessions in the configuration tree of the IGEL setup.
Click Citrix > Citrix StoreFront > Server.
Click the ADD icon in the Server location window.
The ADD mask opens.
Enter the names or IP addresses of the services sites.
Confirm with OK.
Click Citrix StoreFront > Desktop Integration.
Enter "Citrix Storefront" under Login Session Name.
Choose Desktop as the starting method.
Click OK to save the changes.
Setup closes.
Doubleclick the Citrix icon on the desktop.
The login window opens.
Enter the credentials of a user in the login window.
The published applications of the Citrix farm will appear on the desktop.
Doubleclick an application icon on the desktop to start the program.
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11.

Citrix Self-Service

Prerequisites:

Trust root certificate in directory /wfs/ca-certs (see Deploying Trusted Root Certificates)

Connecting via StoreFront:

Click Sessions in the configuration tree of the IGEL setup.
Click Citrix > Citrix Self-Service > Server.
Enter the Server, the Path to Store and the Store name of the services sites.
Confirm with OK.
Click Citrix Self-Service > Desktop Integration.
Enter "Citrix Self-Service" under Login Session Name.
Choose Desktop as the starting method.
Click OK to save the changes.
Setup closes.
Doubleclick the Citrix icon on the desktop.
The login window opens.
Enter the credentials of a user in the login window.
The published application icons of the Citrix farm will appear in the Self-Service UI.
Doubleclick an application icon to start the program.
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•

Using Citrix Self-Service

Start Citrix Self-Service e.g. with desktop icon.
Log on to the server.
Add published applications to the list (+-button on the left).
Click a published application to start.
Use the search bar to find a published application.
Use the user's menu to change preferences, server etc.

Configure Full-Screen Mode (see page 274)
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Configure Full-Screen Mode

Use following parameter in your Custom Command script to activate the full-screen mode for Citrix Self-Service:

 $ICADIR/storebrowse -c FullscreenMode=[0/1/2]

With following options:

0  = The window is not displayed full-screen

1  = The window is displayed full-screen

2  = The window is displayed maximized and undecorated, which does not mask the desktop 
environment's taskbar
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Appliance Mode

Connecting Citrix via Selfservice:

Click Sessions > Appliance Mode in the configuration tree of the IGEL setup.
Select Citrix Self-Service under Appliance mode.
Enter the URL of the delivery server.
Click OK to save the changes and close setup.
Follow the instructions on the screen.
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Create a Self-Service Setup for the User with Quick Settings
Usually, the user should not have full access to the thin client's setup. However, it may prove useful to enable users 
to quickly change certain settings by themselves, without even needing a password. Typical examples are settings 
for keyboard, mouse, or screen. This can be done using the Quick Settings.

Here is how to select setup pages for quick setup:

Open the setup and go to Accessories > Quick Settings > Setup User Permissions.
Select the setup pages to which the user should have access, e. g. User Interface > Input > Mouse, 
or Screenlock / Screensaver.

Click Apply or Ok.
When the user starts Quick Settings, the previously selected options are presented.
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Quick settings set permissions for setup screens. If you want to set permissions for individual 
parameters, you can use UMS profiles. For more information, see Profiles.
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Login Failed because of the Expired AD Password

Problem
When you try to log in to a native Citrix Storefront session, you get the error message "Login Failed!" because your 
Active Directory password expired. 
You are unable to change your password, because the local login does not provide an option for that.

Solution
Enable Active Directory/Kerberos authentication for the Storefront session. The next time you try to log in to IGEL 
OS, you will be prompted to change your expired password.

Changing an Expired Active Directory Password

Enabling Active Directory/Kerberos Authentication for Storefront Sessions

In IGEL setup, go to Security > Login > Active Directory/Kerberos.
Enable Login to Active Directory domain.
Go to Security > Active Directory/Kerberos.
Activate Enable.
Fill in the Default domain (fully qualified domain name).
Go to Sessions > Citrix > Citrix Storefront > Login.
Enable Use passthrough authentication.
Click Apply or Ok.

•
•

Before you follow these instructions, check that the ports are open, maybe you can fix the problem by 
that: 

Login to Client -> Port: 88
Change password -> Port: 464

Here you find an overview of ports of the domain controller: Required Ports to Communicate with Domain 
Controller27



When using sessions with passthrough authentication, it is essential that you lock your device's screen 
when leaving it unattended.



Please note that the client must now be locked locally and no longer in the session to prevent another 
person from entering the session via the passthrough without specifying the password.



https://social.technet.microsoft.com/Forums/windows/en-US/1c6a59de-c1fe-4946-bb4e-1fe36fd40b08/required-ports-to-communicate-with-domain-controller?forum=winserverDS
https://social.technet.microsoft.com/Forums/windows/en-US/1c6a59de-c1fe-4946-bb4e-1fe36fd40b08/required-ports-to-communicate-with-domain-controller?forum=winserverDS
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Enabling Screenlock

In the IGEL setup go to User Interface > Screenlock / Screensaver.
Enable Use hotkey.
Under Modifiers select  Win .
Under Hotkey enter "L".
Got to User Interface > Screenlock / Screensaver > Options.
Enable User password.

So the "Win + L" hotkey locks the IGEL client instead of the session desktop.

The AD password must be entered to activate the IGEL clients.
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Configuring Auto Logon for Citrix Virtual Desktops
This how-to describes how to configure Auto Logon for Citrix Virtual Desktops.

Steps
In IGEL Setup, go to Sessions > Citrix > Citrix StoreFront > Server.

Add your Server Location.
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3.

4.

5.

Add your Active Directory domain to Domains, making sure that you use its Fully Qualified Domain 
Name (FQDN).

Go to Sessions > Citrix > Citrix StoreFront > Login.

Set Authentication type to Password authentication.
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6.

7.

Activate Auto Login.

Set User Name to the Active Directory user name.
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Set the Password.

Set Domain to your Active Directory domain's FQDN, the same as in step 3.
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Force Citrix Logout Using Hotkey
You will find the instructions under Citrix: Freeze at Logout (see page 285).

This page is due for deletion. Please check the above link and use it in the future.
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Citrix: Freeze at Logout

Symptom
A user tries to log out from a Citrix session but the session does not respond.

Example: Once you connect to a Citrix session, everything works. After having reconnected and disconnected 
several times, you log out. The window freezes while the logout screen is shown.

Solution
 Select TCP only - UDP disabled under Sessions > Citrix > Citrix Global > Options > HDX Adaptive Transport 

over EDT.

OR

 Try to use another Citrix Receiver version: Sessions > Citrix > Citrix Client Selection > Citrix client version.

OR

 Troubleshoot the issue with your Citrix infrastructure to discover why the session is not closing when 
the  wfica  process makes the call for disconnection.

Workaround
As a less recommended alternative, you can configure a hotkey to force a logout in such situations. Note, however, 
that this workaround can cause issues with hung sessions on the Citrix servers.

To configure a logout hotkey:

In IGEL Setup, go to System > Firmware Customization > Custom Application. 
Click   to create a new Custom Application and name it e.g. "Kill Citrix Sessions".
Disable all Starting Methods for this session.
Enable Hotkey.
Choose e.g.  Ctrl|Alt  as Modifiers and define C  (for "Citrix) as Key.
Go to System > Firmware Customization > Custom Application > Kill Citrix Sessions > Settings.
Enter an Icon name.
Enter  /tmp/kill_citrix  as Command.
Go to System > Firmware Customization > Custom Commands > Desktop. 
In the field Desktop initialization enter following command in one line: 
echo -e "#! /bin/bash\n\nps -eo comm,pid | grep ^wfica | while read 

c p tail; do echo \$p; done | xargs -r kill -TERM" >/tmp/

kill_citrix; chmod 755 /tmp/kill_citrix
Click Apply and reboot the device.
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To configure the hotkey for a group of devices, you can alternatively create a profile or use this 
one: profile_KillCitrixSessionsViaHotkey.xml.

Here you can learn how to import a profile: Importing a Profile and Firmware.
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Warning Message: [Citrix Store] Could Not Connect to the Citrix Server

Environment
You are using Citrix Receiver 13.0.x or newer.
You have a session of the type Citrix StoreFront configured.

Symptom
When establishing the connection, a warning message appears:
Warning: [Citrix Store] Could not connect to the Citrix server.  

or
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Problem
Citrix Receiver 13.0.x or newer on Linux only supports connections via HTTPS, and you have to make sure the device 
has a valid root certificate of the Certificate Authority (CA) available. If the root certificate is missing, the connection 
will fail.

Solution
Install an appropriate root certificate on the device to allow HTTPS connections to your Citrix Server.

For information on how to distribute the certificate, see Deploying Trusted Root Certificates (see page 604).
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1.
2.
3.
4.
5.
6.
7.

Setting up Citrix Sessions with Hardware-Accelerated H.264 Deep 
Compression Codec
This document describes how to activate a hardware-accelerated H.264 deep compression codec for Citrix sessions.

Prerequisites
Licensed IGEL Multimedia Codec Pack
IGEL UD device offering hardware video acceleration, see the FAQ Hardware Video Acceleration on 
IGEL OS.
Citrix XenApp / XenDesktop server with active H.264 display mode
See http://support.citrix.com/article/CTX200370 to learn how to determine the display mode.

Activating the Codec
In Setup, go to System > Firmware Customization > Features.
Enable Hardware Video Acceleration.
Go to Sessions > Citrix > Citrix Client Selection.
Select the Citrix Client Version.
Go to Sessions > Citrix > Citrix Global > Codec.
Set Graphical Codec to H.264 Deep Compression Codec.
Enable Accelerated H.264 Deep Compression Codec.

•

•
•
•

Known issues on VIA-based IGEL devices UD3-LX 40/41/42 and UD10-LX:
Hardware-accelerated HDX only works with 256 MB video memory or more. Video memory 
must be adjusted in the system BIOS. The default is 128 MB.
Seamless window mode is not supported.
Desktop sessions spanning 2 monitors are not supported.
Desktop sessions on rotated screens may flicker (depending on the screen resolution).



If you use the Citrix Receiver 13.5 or older in combination with a Citrix Server 7.15, the Always Lossless
option for the Visual Quality policy will not work under Linux.
With IGEL Linux version 10.05.100 the Build to Lossless option for the Visual Quality policy will work on 
the condition that you are using Citrix Receiver 13.6 or younger and the Use Video Codec policy is set to 
For actively changing regions.



http://support.citrix.com/article/CTX200370
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1.

2.
3.
4.

1.

2.
3.
4.

•

•

Using Font Smoothing (ClearType) in Citrix Sessions

Symptom
You have set Font Smoothing to ClearType in
IGEL Setup > Sessions > Citrix > Citrix Global > Window > Font smoothing (Off / Standard / 
ClearType)
ClearType does not work for Citrix PNAgent / Webinterface sessions.

Problem
ClearType is not supported in PNAgent / Webinterface sessions because Citrix Receiver uses Windows settings which 
are not present on the Linux client.

Solution
All Citrix Receivers up to version 12.x do not use wfclient.ini  to configure Font Smoothing. To force 
Webinterface, PNAgent/XenApp to enable Font Smoothing proceed as follows:

PNAgent / XenApp:

On the Citrix server open C:

\inetpub\wwwroot\citrix\pnagent\config\default.ica  .
Go to section Application .
Add new line FontSmoothingType=3  .
Save and close the file.

Webinterface:

On the Citrix server open C:

\inetpub\wwwroot\citrix\xenapp\config\default.ica  .
Go to section Application .
Add new line FontSmoothingType=3  .
Save and close the file.

FontSmoothingType parameter options:

0  = No smoothing

1  = No smoothing

If you installed the Webinterface site to a different location, please change the path 
accordingly.


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•

•

2  = Standard smoothing

3  = ClearType (horizontal sub-pixel) smoothing (default)

Legal Note

IGEL's Terms & Conditions28 apply.


https://www.igel.com/terms-conditions/
https://www.igel.com/terms-conditions/
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1.

2.
3.

Highly Secured XenServer has Problems with LD_BIND_NOW Workaround

Problem
You want to launch multiple desktop sessions with RTME and H.264 acceleration, but it doesn't work.

Solution
In IGEL Setup, go to System > Registry > ica > workaround-dual-rtme (Search 
parameter: ica.workaround-dual-rtme)
Enable Activate workaround for dual RTME sessions and H264 acceleration.
Click Apply or Ok to save the changes. 

This registry key should not be used if "Enable Secure ICA" is active for the specific delivery group. You 
have to decide if you want to use the registry key or to reduce security.


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1.
2.
3.
4.

Workaround for Citrix Receiver X Error

Problem
When starting Citrix XenApp you get the following Citrix Receiver errors on your IGEL OS devices:

The X Request 55.0 caused error: "9: BadDrawable (invalid Pixmap or Window 

parameter)"

The X Request 60.0 caused error: "13: BadGC (invalid GC parameter)".

Environment
Citrix XenApp 7.15  
Citrix Receiver e.g. 13.2, 13.3, 13.7, 13.8 

Solution
Two parameters have to be activated in IGEL Setup:

Go to System > Registry > ica > forceignorexerrors.
Activate Suppress X error message boxes.
Go to System > Registry > ica > wfclient > ignorexerrors.
Activate IgnoreXErrors and pass the parameters:  55.0/9, 60.0/13

See also the corresponding entry in the Citrix forum29.

https://discussions.citrix.com/topic/393872-possible-workaround-citrix-receiver-x-error-on-linux-thin-clients/
https://discussions.citrix.com/topic/393872-possible-workaround-citrix-receiver-x-error-on-linux-thin-clients/
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1.

2.

Citrix HTML5 Receiver Issue

Affected Versions
IGEL OS 10.05.100 or higher
IGEL OS 11.01.100 or higher 

Issue
Due to the abolition of plugin technology in Firefox 60+, the Workspace app installed under Linux is no longer 
automatically recognized.

Solution
If your device has IGEL OS 10.05, update to IGEL OS 10.06; if applicable, you can also upgrade to 
IGEL OS 11.02. If your device has IGEL OS 11.01, update to IGEL OS 11.02. 
IGEL OS 10.06 and IGEL OS 11.02 have been adapted for a workaround that requires server-side 
modifications.
Change the server-side settings according to the instructions under https://support.citrix.com/
article/CTX237727.

https://support.citrix.com/article/CTX237727
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1.
2.

Macbook Keyboard Layout inside Citrix Session
To get the Macbook keyboard layout working correctly inside Citrix sessions, proceed as follows:

Under Sessions > Citrix > Citrix Global > Keyboard > Keyboard mapping file, select "Linux".
Under User Interface > Input > Keyboard > Keyboard type, select "Macbook".
All other keyboard layout settings can be left unchanged, i.e. as set by default.

In order to type special characters like € and #, use the right-hand Alt/Option key, not the left-hand key.
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Citrix Feature Matrix
According to the details provided by the vendor, the following Citrix Client features are supported with Citrix 
Workspace App 2009:

Category Feature Supported

Citrix Workspace Citrix Virtual Apps yes

Citrix Virtual Desktops yes

Citrix Content Collaboration (Citrix Files) no

Citrix Access Control Service no

Citrix Workspace Browser no

SaaS/Webapps with SSO yes

Citrix Mobile Apps no

Intelligent Workspace features no

Endpoint

Management

Auto configure using DNS for Email Discovery no

Centralized Management Settings yes

App Store Updates / Citrix Auto updates no

UI Desktop Viewer/Toolbar yes

Multi-tasking yes

Follow Me Sessions (Workspace Control) yes

HDX Host Core Adaptive transport yes

SDWAN support yes

Session reliability yes

Auto-client Reconnect yes

Bi-directional Content redirection no

URL redirection yes

File open in Citrix Workspace app yes

For details on the Citrix Clients that are built into your version of IGEL OS, see IGEL OS Release Notes > 
Notes for Release [your version] > Component Versions [your version].
See also the original document at https://www.citrix.com/content/dam/citrix/en_us/documents/data-
sheet/citrix-workspace-app-feature-matrix.pdf.



https://www.citrix.com/content/dam/citrix/en_us/documents/data-sheet/citrix-workspace-app-feature-matrix.pdf
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Category Feature Supported

Browser content redirection yes

Multiport ICA yes

HDX IO / Devices / 
Printing

Local Printing yes

Generic USB Redirection yes

Client drive mapping / File Transfer**** yes

HDX Integration Local App Access no

Multi-touch no

Mobility Pack no

HDX Insight yes

HDX Insight with NSAP VC yes

EUEM Experience Matrix yes

Session Sharing yes

HDX Multi-media Audio Playback yes

Bi-directional Audio (VoIP) yes

Web-cam redirection yes

Video playback yes

Flash redirection yes

Microsoft Teams Optimization yes

Skype for business Optimization pack yes

Cisco Jabber Unified Communications Optimization yes

Windows Multimedia redirection yes

UDP Audio yes (not with 
NSG)

Security TLS 1.2 yes

TLS 1.0/1.1 yes

DTLS 1.0 yes

DTLS 1.2 no

SHA2 Cert yes
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Category Feature Supported

Smart Access yes

Remote Access via Citrix Gateway yes

Workspace for Web Access yes

IPV6 yes

HDX Graphics H.264-enhanced SuperCodec yes

Client hardware acceleration yes

3DPro Graphics yes

External Monitor Support yes

Desktop Composition redirection no

True Multi Monitor yes

Location Based Services (Location available via API-
description)

no

Authentication Federated Authentication (SAML/Azure AD) yes

NetScaler Full VPN yes

RSA Soft Token no

Challenge Response SMS (Radius) no

User Cert Auth via NetScaler Gateway (via Browser 
Only)

no

Smart Card (CAC,PIV Etc.) yes

Proximity/Contactless Card yes

Credential insertion (E.g.. Fast Connect, Storebrowse) yes

Pass Through Authentication no

Save credentials *(on prem and only SF) no

NetScaler nFactor Authentication yes

Netscaler Native OTP yes

Biometric Authentication (Touch ID, Face ID..) no

Single Sign-On to Citrix Files App no

Single Sign on to Citrix Mobile apps no
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Category Feature Supported

Anonymous Store Access yes

Keyboard 
Enhancements

Dynamic Keyboard Layout Synchronization with 
Windows VDA

Note: Dynamic keyboard layout sync for non-
Windows receivers requires enablement of the 
Unicode Keyboard Layout Mapping
feature on the Windows VDA.

yes

Unicode Keyboard Layout Mapping with Windows 
VDA

yes

Client IME Enhancements with Windows VDA no

Language Bar Show/Hide with Windows VDA 
Applications

no

Option Key mapping for server-side IME input mode 
on

Windows VDA

no

Dynamic Keyboard Layout Synchronization with Linux 
VDA

yes

Client IME Enhancements with Linux VDA no

Language Bar support for Linux VDA Applications yes
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Using Lync / Skype for Business with Citrix HDX RealTime Optimization 
Pack

Issue
You want to use Microsoft Lync or Skype for Business via a Citrix session with IGEL OS devices.

Solution
IGEL OS comes with Citrix HDX RealTime Media Engine (RTME) preinstalled: Setup > Sessions > Citrix > Citrix 
Global > Unified Communications > Skype for Business. See also HDX Multimedia.

IGEL OS 11.02.100 and higher contains RTME 2.8 (activated by default).
IGEL OS 11.01.100 contains RTME 2.7 (disabled by default).

IGEL OS 10.06.100 contains RTME 2.8 (disabled by default).
IGEL OS 10.05.500 contains RTME 2.6 (disabled by default).
IGEL OS 10.05.100 contains RTME 2.6 (disabled by default).

For further information, see Citrix HDX RealTime Optimization Pack30.

https://docs.citrix.com/en-us/hdx-optimization/
https://docs.citrix.com/en-us/hdx-optimization/


Citrix

IGEL OS Articles   301 / 1017

•
•

•

1.

Unexpected Keyboard Layout in a Citrix Session

Problem
When a Citrix session has started, the keyboard layout changes in an unexpected way. On the local system, the 
keyboard layout may still be as expected.

The problem has been reported for the following keyboard layouts:

English(International) with dead keys enabled
Polish (Programmers)

Environment
Devices with IGEL OS 11.07.110 or higher (all IGEL OS versions that contain Citrix Workspace App 
2203 or higher)

Solution
Open the UMS configuration dialog or the local Setup, go to User Interface > Input > Keyboard, 
and make sure that the correct Keyboard layout is set.
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2.

3.

Go to System > Registry > ica > module > virtualdriver > keyboardsync > enable and disable 
Keyboard layout synchronization.

Go to System > Registry > ica > wfclient> keyboardsyncmode, set Configure keyboard layout 
synchronization to Once, and then confirm your settings with Save.
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4. If the Update time dialog comes up, set it to Now and continue.

When the user logs in to the Citrix session, the keyboard layout should be correct.



RDP

IGEL OS Articles   304 / 1017

•
•
•
•
•
•
•
•
•

RDP
Mapping USB Storage Media into RDP Sessions (see page 305)
What Is the String for Token-Based Load Balancing? (see page 308)
RDP Fabulatech Scanner Redirection (see page 309)
RDP RemoteApp Parameter Settings (see page 310)
RDP Performance Enhancements (see page 311)
RDP Session playing Sound: Error RDPSND_NEGOTIATE (see page 312)
Crackling and Audio Dropouts in RDP Sessions (see page 313)
Login Failed Because of Expired AD Password (see page 315)
User Has to Provide Credentials Twice for RDP Logon (see page 317)
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Mapping USB Storage Media into RDP Sessions
How to configure USB Storage mapping so that users can access USB storage media attached to the IGEL LX Client 
within RDP sessions?

Solution:

Basic Configuration of the Client

Within the IGEL Setup or an UMS profile you basically need to configure these parameters:

 Activate Devices > Storage Devices > Storage Hotplug > Client drive mapping > Dynamic. This option 
activates dynamic client drive mapping. It automatically recognizes new storage media as they are connected to 
the thin client. The thin client beeps and shows a notification while it mounts the new device. The storage devices 
automatically become usable on the thin client and in Citrix ICA Sessions.

The mapping of USB storage devices is possible for "usb mass storage class" devices. The storage of 
smartphones and digital cameras is usually accessed via the MTP protocol. Mobile device access via MTP is 
available with IGEL Linux 10.04.100 or higher; for more information see the how-to Using Mobile Device 
Access.



Mounted devices need to be unmounted before they are removed to ensure data integrity. This can be 
done via the Disk Utility, the new Safely Remove Hardware Tool or a tray icon.


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Additional Parameters to Check
 The following parameters are set by default, thus storage mapping will work, but maybe for some reason you 

have changed these and need to adjust them to allow the storage mapping:

 
Sessions > RDP > RDP Global > Mapping > Drive Mapping > Enable Drive mapping (set checkmark) 

Sessions > RDP > RDP Global > Native USB Redirection > Enable Native USB redirection (remove checkmark) 

Sessions > RDP > RDP Global > Fabulatech USB Redirection > Enable Fabulatech USB redirection (remove 
checkmark) 

Devices > USB access control > Enable (remove checkmark) 

Sessions > RDP > RDP Sessions > [session name] > USB Redirection > Enable Native USB Redirection (global 
setting) 

Sessions > RDP > RDP Sessions > [session name] > Mapping > Enable Drive Mapping (global setting)

Assigning a Drive Letter within the Session (Optional)

 In case you not only want to see the drive in the session as e.g. "A on IGEL-123456789", but want to address the 
drive with a real drive letter within the session, you may run one of these commands:
subst T: \\tsclient\t  

or 
net use T: \\tsclient\t  

In this example "T on IGEL-123456789" is assigned to drive letter T: within the session. You may also assign the 
mapped drive to another drive letter than is used in its name.

Configuration on the Server Side
On the server side, e.g. with Windows Server 2008R2, a user in the group "Users" with access to the terminal server 
will have the mapping default. This is true for a newly installed server. But the mapping can be prevented by 
changing the policies:

Do not allow drive redirection Specifies whether to prevent the mapping of client drives in a Remote 
Desktop Services session (drive redirection). By default, an RD Session Host server maps client drives 
automatically upon connection. Mapped drives appear in the session folder tree in Windows Explorer or 


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Computer in the format [driveletter] on [computername]. You can use this setting to override this 
behavior." Source: https://technet.microsoft.com/de-de/library/ee791794%28v=ws.10%29.aspx

https://technet.microsoft.com/de-de/library/ee791794%28v=ws.10%29.aspx
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What Is the String for Token-Based Load Balancing?

Environment
A token-based mechanism is used as a load balancing method. This document does not apply to other load 
balancing methods.

Question
What string should be entered in Sessions > RDP > RDP Sessions > [Session name] > Options to make token-
based load balancing work?

Answer

IGEL OS 10.05.700 or Higher, IGEL OS 11.01.110 or Higher

 Under Sessions > RDP > RDP Sessions > [Session name] > Options > Collection, simply enter the name of 
your RDS collection. The collection name has been defined by the server administrator.

IGEL OS 10.01 to 10.05.500, 11.01.100

 Under Sessions > RDP > RDP Sessions > [Session name] > Options > Load balancing routing token, 
enter  tsv://MS Terminal Services Plugin.1.[collection name] , where

tsv://MS Terminal Services Plugin.1.  is the routing token 
and
[collection name]  is the name of the RDS collection, defined by the server administrator.

tsv://MS Terminal
tsv://MS Terminal
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1.
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•

•

•
2.
3.

4.

RDP Fabulatech Scanner Redirection

Enabling Fabulatech Scanner Redirection
In the IGEL Setup, go to System > Firmware Customization > Features and make sure that 
Scanner support /SANE (Limited support - functionality "as is", see product documentation 
for details) is activated.

If the option is already activated, continue with step 2.
If the option has not been activated before, the software component must be downloaded 
first. For this purpose, make sure that the source of the current firmware is set correctly:

If you are using Universal Firmware Update, make sure that the device is assigned to 
the current firmware. For details, see Universal Firmware Update and Assigning 
Updates.
If you are not using Universal Firmware Update, make sure that System > Update > 
Firmware Update is set to the source of the current firmware. For details, see 
Firmware Update.

After clicking OK to confirm your changes, you must reboot the system.   
In the IGEL Setup, go to Sessions > RDP > RDP Global > Fabulatech Scanner Redirection.
Check Fabulatech Scanner for Remote Desktop.

Click Apply or Ok to confirm the settings.
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1.

2.

RDP RemoteApp Parameter Settings

Symptom
RemoteApp is not starting or closes immediately after login.

Problem
Missing or incomplete session settings on server or device

Solution
Set an ALIAS for the RemoteApp with the RemoteApp Management Console on the 
Terminalserver.

Use that ALIAS value in the device's setting in Setup > Sessions > RDP > RDP Sessions > (Session 
Name) > Server > Application.

Add two pipe-characters ( || ) at the beginning of the ALIAS value.
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RDP Performance Enhancements

Symptom
RDP users have performance issues (bad user experience).

For example:

Mouse is lagging
Screen is building up very slow
Session uses high bandwidth
Several other performance issues

Problem
There are many different causes that can result in bad performance.

Solution
The following settings can be used as a single option and also in combination.

Basics

The color depth should be the same on the server, the device, and in the session (best: 32 bit).
In the BIOS, set the VGA shared memory to 64 MB or more.

Optimizations for a LAN Environment

Under Sessions > RDP > RDP Global > Performance, edit the settings as follows:
Disable Compression. (Increases performance, generates about 30% more traffic)
If RemoteFX 8 is available, activate Enable RemoteFX.
If RemoteFX 8 is available, set RemoteFX codec mode to "Optimized for LAN".

If Windows Server 2012 R2 or lower or Windows 8.1 or lower is used: Under Sessions > RDP > RDP 
Global > Multimedia, activate Enable Video Redirection.

Optimization for a WAN Environment

Under Sessions > RDP > RDP Global > Performance, edit the settings as follows:
Enable Compression. (Generates about 30% less traffic, consumes more local resources)
If RemoteFX 8 is available, activate Enable RemoteFX.
If RemoteFX 8 is available, set RemoteFX codec mode to "Optimized for WAN".
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1.
2.

RDP Session playing Sound: Error RDPSND_NEGOTIATE

Symptom
If the user plays some sound within the RDP session the connection terminates on some devices with error 
message:

ERROR: RDPSND: Extra RDPSND_NEGOTIATE in the middle of a session

ERROR: TCP Connection: Cannot receive data (Keep alive timeout)

Problem
This may happen if during data transmission the connection fails.

Solution
Try a different sound driver for RDP session:

Go to System > Registry > rdp.winconnect.sound-driver
Choose OSS or ALSA
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1.

2.

Crackling and Audio Dropouts in RDP Sessions

Symptom
The user experience with RDP sessions is disturbed by crackling noises and glitches.

Environment
Device with a sound card that has a small buffer, e. g. IGEL UD3 (M340C)
Required for the solution: IGEL OS 11.03.500 or higher 

Problem 
The crackling noises, or audio glitches, result from buffer underruns. This occurs when new audio data are not 
delivered fast enough and the sound card buffer has no more audio data left to play. Thus, it is not possible to 
bridge the replay gap. This is more likely to happen with sound cards that have a relatively small buffer.

Solution
To enable the device to bridge bigger gaps, buffer capacity must be added. This can be done by increasing the 
buffer of the RDP client, which implies increasing the latency. However, high latency can lead to a problem with 
interactive applications, such as calls or video conferences. Thus, the latency should be increased in small steps.

To increase the latency of the RDP client:

Open the Setup and go to System > Registry > rdp > winconnect > sound-latency (registry key: 
rdp.winconnect.sound-latency ).

Increase the Latency by about 50 milliseconds (recommended) and click Apply.
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3.
4.

 
Restart the RDP session and test the audio playback.
If the audio quality is good, click Ok to close the Setup. If there are still crackling noises, repeat 
steps 2 and 3 until the audio quality is acceptable.
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1.
2.
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4.
5.
6.
7.
8.

Login Failed Because of Expired AD Password

Issue
When you try to log in to a RDP session, you get the error message "Login Failed!" because your Active Directory 
password expired. 
You are unable to change your password because the local logon does not provide an option for that.

Solution
Enable Active Directory/Kerberos authentication for the RDP session. The next time you try to log in to IGEL OS, 
you will be prompted to change your expired password.

Changing an Expired Active Directory Password

Enabling Active Directory/Kerberos Authentication for RDP Sessions

In IGEL setup, go to Security > Logon > Active Directory/Kerberos.
Enable Login to Active Directory Domain.
Go to Security > Active Directory/Kerberos.
Activate enable.
Fill in the Default Domain (Fully Qualified Domain Name).
Go to Sessions > RDP > RDP sessions > [RDP session] > Logon.
Enable Use passthrough authentication for this session.
Click Appy or Ok.

•
•

Before following these instructions, check the ports:
Login to Client -> Port 88
Change password -> Port 464

Here you find an overview of ports of the Domain Controller: Required Ports to Communicate with Domain 
Controller31



When using sessions with passthrough authentication, it is essential that you lock your device's screen 
when leaving it unattended.



Please note that the client must now be locked locally and no longer in the session to prevent another 
person from entering the session via the passthrough without specifying the password.



https://social.technet.microsoft.com/Forums/windows/en-US/1c6a59de-c1fe-4946-bb4e-1fe36fd40b08/required-ports-to-communicate-with-domain-controller?forum=winserverDS
https://social.technet.microsoft.com/Forums/windows/en-US/1c6a59de-c1fe-4946-bb4e-1fe36fd40b08/required-ports-to-communicate-with-domain-controller?forum=winserverDS
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1.
2.
3.
4.
5.
6.

Enabling Screen Lock

In the IGEL setup go to User Interface > Screenlock / Screensaver.
Enable Use Hotkey.
Under Modifiers select Win .
Under Hotkey enter "I".
Got to User Interface > Screenlock / Screensaver > Options.
Enable User Password.

So the "Win + L" hotkey locks the IGEL client instead of the session desktop.

The AD password must be entered to activate the IGEL clients.
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1.

2.

3.

User Has to Provide Credentials Twice for RDP Logon

Issue
When you connect to a Windows terminal server, you are asked to provide your credentials twice.

Cause
This behavior is caused by the way RDS load balancing works. The crucial point to understand is that the terminal 
server does not communicate with the session broker directly.

Instead, the scenario is the following:

The client connects to terminal server 1 and authenticates with terminal server 1. This is the first 
time the user is asked for their credentials.
Since we have a load balancing setup, terminal server 1 will talk to the session broker and ask if 
the client can use terminal server 1 or if it should be redirected to a different terminal server.
If redirection occurs, the client will also have to authenticate with the terminal server the client 
was redirected to (terminal server 2 in the figure below). This is the second time the user is asked 
for their credentials.
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Solution
The issue can be resolved by activating Kerberos/Active Directory authentication. For further information, 
see Active Directory/Kerberos.



VMware Horizon

IGEL OS Articles   319 / 1017

•
•
•
•
•
•
•

VMware Horizon
Setting up VMware Blast Sessions (see page 320)
Use NLA (Network Layer Authentication) for Logon with Horizon Client Sessions (see page 321)
Workaround for Hotkeys in Horizon Sessions (see page 322)
Multimedia Acceleration with VMware Horizon View in VESA Mode (see page 323)
Horizon Feature Matrix (see page 324)
Troubleshooting the Horizon Client (see page 331)
VMware Horizon Authentication Issues (Certificate Revocation List) (see page 332)
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Setting up VMware Blast Sessions

Prerequisites
Device offering hardware video acceleration, see the FAQ Hardware Video Acceleration on IGEL OS.
VMware Horizon 7 Server
For further information about the server configuration, refer to VMware's documents at http://
pubs.vmware.com/horizon-7-view/index.jsp

Activating VMware Blast

In Setup, go to System > Firmware Customization > Features.
Enable Hardware Video Acceleration.
Go to Sessions > Horizon Client > Horizon Client Global > Server Options.
Set Preferenced desktop protocol to VMware Blast.
Click Apply or Ok.

http://pubs.vmware.com/horizon-7-view/index.jsp
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1.

2.

Use NLA (Network Layer Authentication) for Logon with Horizon Client 
Sessions
Starting a session, even just presenting a logon screen, has quite an impact on resources. Each time a user tries to 
logon, processes are started on the remote machine, no matter whether the user's credentials are valid or not. You 
can save resources and prevent Denial of Service (DoS) attacks by using Network Layer Authentication (NLA). NLA 
checks whether a user is the right person before any logon processes is started.

For more information about NLA, see https://technet.microsoft.com/en-us/magazine/hh750380.aspx.

NLA for Horizon Client Sessions is available from IGEL Linux version 5.08.100 upwards.

To use NLA for a Horizon Client session:

Open the setup and go to Sessions > Horizon Client > Horizon Client Sessions > [Session Name] 
> Options.
Activate Network Level Authentication.

https://technet.microsoft.com/en-us/magazine/hh750380.aspx
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1.

2.
3.

Workaround for Hotkeys in Horizon Sessions

Issue
You want to switch from the VMware Horizon session to the IGEL desktop with the key combination [Ctrl] 
+ [Windows] + [D]. While the key combination [Ctrl] + [Windows] + [D] can be realized with IGEL OS 11.01.100 or 
lower (Horizon Client 4.x), this is not possible for IGEL OS 11.01.110 or higher (Horizon Client 5.x). 

Solution
Press [Ctrl] + [Alt] and release the keys.
The focus is switched from the VMware Horizon session to the local system. 
Use [Ctrl] + [Windows] + [D] to switch to the IGEL desktop.
To switch the focus back to the VMware Horizon session, click into the VMWare Horizon session 
window.
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Multimedia Acceleration with VMware Horizon View in VESA Mode

Symptom
You did install IGEL Universal Desktop OS 2 on not fully supported hardware using IGEL Universal Desktop 
Converter 2. Multimedia acceleration is not working within a VMware Horizon View session.

Problem
The graphics chip of your hardware is not supported and as a fallback the VESA mode is used.

Solution
There is no other solution to the problem than using fully supported hardware. Information on supported hardware 
can be found in the UDC2 manual.32

You can also access IGEL's 3rd party hardware support database33 to find fully supported graphic chips.

http://edocs.igel.com/index.htm#11873.htm
https://www.igel.com/linux-3rd-party-hardware-database/
http://edocs.igel.com/index.htm#11873.htm
https://www.igel.com/linux-3rd-party-hardware-database/
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Horizon Feature Matrix
According to the details provided by the vendor, the following Horizon Client features are supported with Horizon 
Client 5.4:

Category Feature Supported

Client Appearance and 
Workflow

Customer branding no

Kiosk mode yes

English localization yes

Language localization yes

Broker Connectivity XML-API version 15

SSL yes

SSL certificate verification yes

Disclaimer dialog yes

Security Server compatibility yes

UAG compatibility yes

Multi-broker/Multi-site redirection - DaaS yes

Client info yes

Phonehome yes

Broker Authentication Password authentication yes

Password change yes

Certificate authentication no

RSA authentication yes

Radius yes

Integrated RSA SecurID token generator no

Single Sign On yes

For details on the Horizon Clients that are built into your version of IGEL OS, see IGEL OS Release Notes > 
Notes for Release [your version] > Component Versions [your version].
See also the original document at https://kb.vmware.com/s/article/78810.



https://kb.vmware.com/s/article/78810
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Category Feature Supported

Log in as current user no

Nested log in as current user no

Biometric authentication no

Unauthentication access yes

Smartcard x.509 certificate authentication (Smart 
Card)

yes

CAC support no

.Net support yes

PIV support yes

Java support no

Purebred derived credentials no

Desktop Operations Reset only supported with VDI

Restart only supported with VDI

Log off yes

Session Management 
(Blast Extreme & PCoIP)

Switch desktops yes

Multiple Connections yes

App Launch on Multiple end points yes

Auto-Retry yes

Auto-Retry 5+ minutes yes

Fullscreen mode yes

Fullscreen toolbar yes

Windowed mode yes

Time Zone Synchronization yes

Jumplist integration (Windows 7-
Windows 10)

no

Client Customization Command Line Options yes

URI Schema yes

Preference File yes
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Category Feature Supported

Non Interactive Mode yes

GPO-based customization no

Protocols supported Blast Extreme yes

   H.264 - HW decode yes

   H.265 - HW decode no

   Blast Codec yes

   JPEG / PNG yes

   Switch Encoder yes

   BENIT yes

   Blast Extreme Adaptive Transportation yes

RDP 8.x, 10.x yes

PCoIP yes

Protocol Enhancements RDP-VC Bridge yes

Session Enhancement SDK yes

Monitors / Displays Dynamic Display Resizing yes

Multiple Monitor Support yes

External Monitor Support yes

Display Pivot yes

Multiple Aspect Ratio support yes

Number of displays supported 4

Maximum Resolution 3840x2160

Video out yes

High DPI scaling only supported with VDI

DPI Sync yes

Exclusive Mode no

Multiple Monitor Selection yes

Input Device (Keyboard / 
Mouse)

Relative mouse yes

External Mouse Support yes
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Category Feature Supported

Local buffer text input box no

Keyboard Mapping yes

Unicode Keyboard Support no

International Keyboard Support yes

Input Method local/remote switching no

IME Sync yes

Clipboard Services Clipboard Text yes

Clipboard Graphics no

Clipboard memory size configuration yes

Drag and Drop text no

Drag and Drop images no

Client Caching View Agent to Client-side caching yes

Connection Management Blast network recovery yes

IPv6 translation with UAG no

IPv6 only network support no

PCoIP IP roaming yes

High-Level Device 
Redirection

Serial (COM) Port Redirection yes

Client Drive Redirection/File Transfer yes

Scanner (TWAIN/WIA) Redirection yes

x.509 Certificate (Smart Card) yes

Gyro Sensor Redirection no

Real-Time Audio-Video Analog in (input) yes

Real-Time Audio-Video yes

Multiple webcams no
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Category Feature Supported

USB Redirection Generic USB / HID yes

Policy: ConnectUSBOnInsert only supported with VDI

Policy: ConnectUSBOnStartup only supported with VDI

Connect/Disconnect UI yes

USB device filtering (client side) yes

Isochronous Device Support only supported with VDI

Split device support yes

Bloomberg Keyboard compatibility only supported with VDI

Smartphone sync only supported with VDI

USB 3.0 yes

USB Redirection USB storage devices yes

Unified Communications Cisco UC Jabber only supported with VDI

Avaya UC One-X Desktop only supported with VDI

Mitel UCA no

Microsoft Lync 2013 no

Skype for business yes

Microsoft Teams RTAV yes

Multimedia Support Multimedia Redirection (MMR) yes

Flash URL Redirection (Unicast/Multicast) only supported with VDI

Flash Redirection no

HTML5 Redirection yes

Directshow Redirection no

Graphics vDGA only supported with VDI

vSGA only supported with VDI

NVIDIA GRID VGPU yes

Intel vDGA only supported with VDI

AMD vGPU only supported with VDI
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Category Feature Supported

Mobile Support Client-side soft keyboard no

Client-side soft touchpad no

Full Screen Trackpad no

Gesture Support no

Multi-touch Redirection no

Presentation Mode no

Unity Touch no

Printing Printer Redirection yes

VMware Integrated Printing yes

Location Based Printing yes

Native Driver Support yes

Security FIPS-140-2 Mode Support yes

Imprivata Integration no

Opswat agent yes

Opswat on-demand agent no

TLS 1.1 yes

TLS 1.2 yes

Session Collaboration Session Collaboration yes

Read-only Collaboration yes

Update Update notifications no

App Store update no
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Category Feature Supported

Other Smart Policies yes

File Type Association no

URL content redirection yes

Browser content redirection no

Remember credentials no

Access to Linux Desktop - Blast Protocol 
Only

only supported with VDI

Audio Playback yes

Seamless Window yes

Launching multiple client instances using 
URI

yes

Parameter pass-through to RDSH apps yes

Performance Tracker only supported with VDI

Shortcuts from server no

Pre-install shortcuts from server no

Workspace ONE mode yes



VMware Horizon

IGEL OS Articles   331 / 1017

•

1.

2.

3.

4.

5.
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Troubleshooting the Horizon Client

Symptom
There are some issues with the performance of the Horizon client.

Environment
IGEL OS 10 or higher

Problem 
You don't know how to collect the log files and send them to the IGEL Support team.

Solution
In the Setup, go to System > Registry > sessions > vdmcient% > options > debug and activate 
Save debug information (registry parameter: sessions.vdm_client%.options.debug ).
  
Go to System > Registry > vmware > USB > log and set Set VMware Horizon USB debug level to 
"debug" (registry parameter:   vmware.view.usb.log ). 
Go to System > Registry > vmwarevdmapp > debug and activate Save debug 
informations (registry parameter: vmwarevdmapp.debug ).

The log files are created in the /tmp  directory and can be found using the following patterns:

/tmp/vvdm *

/tmp/vmware-*

Change to /tmp  and put the log files into a compressed tar file:  tar -czf vmware-

logs.tar.gz [logfiles]
In the structure tree of the UMS Console, go to the device and select Device File->UMS the context 
menu.
Under Devices file location, enter "/tmp/vmware-logs.tar.gz".
Under Target URL, select the location on the UMS Server where the file is to be stored.
Click Device->UMS.

Solution Based on Experience from the Field

This article provides a solution that has not been approved by the IGEL Research and Development 
department. Therefore, official support cannot be provided by IGEL. Where applicable, test the solution 
before deploying it to a productive environment.


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VMware Horizon Authentication Issues (Certificate Revocation List)
Newer versions of VMware Horizon Client for Linux attempt to download a Certificate Revocation List (CRL) for any 
certificates used to connect to a VMware Horizon environment. Sometimes, this can cause a problem on lower-
powered devices or on devices that do not have access to a CRL address.

The following article explains how to disable the CRL download if you have problems with authentication for 
VMware Horizon sessions in IGEL OS.

Problem
You face the following issues:

The VMware Horizon Client "hangs" during authentication.
OR
The VMware Horizon Client takes a long time to authenticate (in some cases, over 1 minute).
OR
You are using a certificate issued by the domain's CA (certificate authority) and get the following 
error message:
" Failed to connect to the connection server. The server provided an 

invalid certificate. Unsupported URI in CRL distribution points 

extension, only http/https are supported. "

Solution
These issues usually occur due to the default setting for CRL download for the VMware Client for Linux. If you 
experience the above issues, it is recommended to disable downloading of the CRL.

To disable the download of the CRL, proceed as follows:

In IGEL Setup or in the configuration dialog in the UMS, go to System > Registry.

Enable the registry key  vmware.view.skip-crl-revocation-check , i.e. Skip download 
of the certificate revocation list (CRL).
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3.

4.

Apply the settings. If you have created a profile, assign the profile to the required devices.

Reboot the devices and test the connection again.
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Authenticating with Evidian Authentication Manager (see page 335)
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12.

Authenticating with Evidian Authentication Manager
You can connect to Citrix, RDP and VMware Horizon roaming sessions using RFID badges with Evidian 
Authentication Manager (AuthMgr). Custom commands are supported as well.

Prerequisites
IGEL Universal Desktop Linux 5.06.100 or newer on the device.
An installed and running Evidian SSO Controller, version 10.0 or higher
When using HTTPS (IGEL Linux 5.07.100 or newer), the User Access Server's CA root certificate 
saved locally on the device.
The device and the server(s) have to be part of the same Active Directory domain.
A supported RFID reader (e.g. OMNIKEY 5022 CL, OMNIKEY 5421), connected to the device.
RFID badges that are already enrolled.

Configuring an Evidian Authentication Manager Session
In IGEL Setup, go to Sessions > Evidian AuthMgr > Evidian AuthMgr Sessions.
Add a new session.
Go to Sessions > Evidian AuthMgr > Evidian AuthMgr Sessions > [Session Name] > Connection.
Choose the Protocol used for the user access service (e.g. HTTP).
Enter the IP address or DNS name used for the user access service under Server.
Choose the Port for the user access service (e.g. 9764).
Under Path to service, enter the path for the user access service (e.g. /soap ).
Under CA certificate, enter the path to the CA certificate, including its name, or path of the 
certification authority (e.g. /wfs/ca-certs/ca.crt ). The certificate is required for HTTPS 
connections.
Enter the secret for the Roaming session secret.
When using HTTPS, select CA certificate as the user access server's CA root certificate on the 
device.
Under Evidian AuthMgr > Evidian AuthMgr Sessions > [Session Name] > Options, select the 
desired Session type. 
This will make Evidian Authentication Manager use the first configured session of its type, e.g. RDP. 
Make sure that a session is configured.

Start the new session by clicking on its icon in the Start Menu. Alternatively, reboot the device. In 
the default autostart setting the Evidian Authentication Manager for your session will start 
automatically and wait for an RFID badge to be placed on the reader.

If you choose the user-defined session type, you need to supply the custom commands; see 
Custom Commands (see page 337). For further options, see Options in the IGEL OS Reference Manual.



You can only start a single instance of an Evidian Authentication Manager session.
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3.

Configuring Citrix/RDP/VMware Horizon Sessions
 Configure the session that you want to use with Evidian Authentication Manager as the first session of its kind. 

The shortcuts to the session settings are provided in the Setup section Related Configurations:

Using a Custom Configuration File
Instead of using the settings provided by IGEL Setup, you can enable a custom configuration file under Sessions > 
Evidian AuthMgr > Evidian AuthMgr Sessions > [Session Name] > Options > Use configuration file. Then all the 
other session settings will be ignored. You find a commented template for the configuration file at /etc/

rsUserAuth/rsUserAuth.ini.

Logging in with Evidian Authentication Manager

Place your RFID badge on the RFID reader (or tap the reader with it if you configured Tapping 
Mode)
Your Citrix/RDP/VMware Horizon session will open if an active roaming session for your user 
already exists. If it does not, you will be presented with a password prompt for the user's Active 
Directory password.
Remove your RFID badge (or tap the reader again) to disconnect from the session.
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Custom Commands
The following simple shell scripts illustrate how to write custom commands that receive username and domain as 
parameters from Evidian Authentication Manager.

In order to use them

Save the scripts in /wfs/.

Make them executable with chmod a+x [filename].

Enter their full path (e.g. /wfs/start.sh ) in Sessions > Evidian > [Session name] > Options.

Start Script

#!/bin/sh

# Sample start script

if [ $# -eq 3 ] ; then

   # Start "session"

   gtkmessage –t "Evidian Authentifcation Manager Login" –m "Login as user '$1' 

with domain '$3'."

else

   exit 1

fi

exit 0

Stop Script

#!/bin/sh

# Sample stop script

# Close running "session"

pkill gtkmessage

gtkmessage -t "Evidian Authentication Manager Logout" -s 5 -S –m "Logout user 

'$1'."

exit 0
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Debugging and Troubleshooting

Debugging

Enable Debug mode in Sessions > Evidian > [Session Name] > Options in Setup and set the level 
of detail.
Kill the Evidian Authentication Manager process (see Further Troubleshooting).
Start the desired Evidian session from the Start Menu.
Watch the output with tail -F /var/log/user/rsuserauth[Session 

Number].debug in Local Terminal. Alternatively, add the file to System Log Viewer.

Further Troubleshooting

Open Local Terminal
Enter  ps fax | grep rsuserauth | grep -v grep  to look for Evidian Authentication 
Manager processes.
Use the Evidian AuthMgr Restart session to restart all Evidian sessions if neccesary
OR kill unwanted processes by entering kill [process ID]  in the terminal, start desired 
processes via the Evidian entries in the Start Menu.

The session number starts with 0, not 1. To watch the output of the first configured session, use 
thus tail -F /var/log/user/rsuserauth0.debug


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IBM iAccess
Editing the List of Visible Menu Entries for IBM iAccess (see page 340)
Key Mapping for IBM iAccess Client (see page 342)
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1.

Editing the List of Visible Menu Entries for IBM iAccess
You can simplify the menu of an IBM iAccess client session by removing items from the menu tree. You also can 
restore the original menu.

Removing Menu Items
In the IGEL Setup, go to System > Registry > sessions > iaccess[NUMBER] > options > 
deletemenus (Registry key: sessions.iaccess[NUMBER].options.deletemenus ). 
[NUMBER] is the instance number of the session you want to configure; 0, for instance, stands for 
the first session, 1 for the the second session, etc.
In the List of visible menu entries, using the mouse, mark the line with the entry you want to 
delete:

Press the backspace [←] or delete [Del] key.
The menu item is deleted:

To remove further menu items, repeat steps 2 and 3. 
Click Apply or Ok.
Start or restart the IBM iAccess client to check your changes.

Restoring the Original Menu

In the IGEL Setup, go to System > Registry > sessions > iaccess[NUMBER] > options > 
deletemenus (Registry key:  sessions.iaccess[NUMBER].options.deletemenus ). [N
UMBER] is the instance number of the session whose menu you want to restore; 0, for instance, 
stands for the first session, 1 for the the second session, etc.

If you delete a menu item that has subitems, the subitems will be invisible, too.
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2.

3.

In the List of visible menu entries, click the following symbol:

The original menu is restored.
Click Apply or Ok.
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1.

Key Mapping for IBM iAccess Client

Problem
When you change the key mapping in the IBM iAccess client, the changes are not retained when the client is 
restarted.

Applying the changes via IGEL Setup is not possible.

Environment/Prerequisites
IGEL OS 10.05.100 or higher
UMS 5.09.110 or higher
IBM iAccess Client session is set up

Solution
Save the settings made in the IBM iAccess client in a file and distribute that file via the UMS.

Editing the Key Mappings 
Open the IBM iAccess session and log on to your remote environment.
In the IBM iAccess client, go to Edit > Preferences > Keyboard.
On the Key Assignment tab, create the desired key bindings.
When you are finished creating key bindings, click Save as....
In the save dialog, choose File and edit the file path as follows:  /userhome/IBM/

iAccessClient/Emulator/IBMi.kmp
Click OK.
The IBM iAccess client will recognize the file  IBMi.kmp  as the default key.

Importing the Configuration File to the UMS

Open the UMS.
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2. In the navigation tree, find the thin client with the  IBMi.kmp  file and select Other Thin Client 
commands > File TC->UMS in the context menu.
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3. Under Thin Client file location, enter  /userhome/IBM/iAccessClient/Emulator/

IBMi.kmp
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4. Click   to open the Save dialog.
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5. Choose a file location within the ums_filetransfer  folder. 
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6. Under File Name, enter  IBMi.kmp  and click Save.
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7. Click TC->UMS.

The file is stored within the UMS. Next, we will make it available as an object.
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1.

Creating the File Object in the UMS

In the navigation tree, go to Files, open the context menu and choose New file.
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2. In the New file dialog, choose Select file from UMS server and click   to open the file dialog.
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3. In the file dialog, find the file IBMi.kmp  you created previously, and click Open.
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Back in the New file dialog, enter the Thin Client file location as follows:  /userhome/IBM/

iAccessClient/Emulator/

Ensure that the Access rights and Owner are set as follows:
Owner rights: Read, Write, Execute
Owner: "User"
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1.

Click Ok.

The file object "IBMi.kmp" is created.

Assigning the File Object to Thin Clients

In the navigation tree, select the file object "IBMi.kmp" and click   in the Assigned objects area 
(upper right).
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2. In the Select assignable objects dialog, select the thin clients to which you want to assign the new 
key mapping and add them to the Selected objects area.
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4.

Click Ok.

In the Update time dialog, choose whether the file should be assigned to the thin clients at next 
reboot or immediately; then, click Ok.

The file is transferred to the thin clients. 
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Imprivata
Imprivata: Clear the Imprivata Data Partition (see page 358)
Imprivata: Session Customization (see page 359)
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Imprivata: Clear the Imprivata Data Partition
The function that explicitly clears the Imprivata data partition has been removed. However, you can simply emulate 
this feature by disabling and re-enabling the Imprivata appliance mode.

If you already have a valid appliance running and want to delete the Imprivata data partition, take the following 
steps:

In the IGEL Setup, go to Sessions > Appliance Mode.
Set Appliance mode to "Disabled".

Click Ok to save the setting.
Click Yes to confirm the Apply Settings dialog.

Normal desktop mode is active. The Imprivata data partition is void now.
In the IGEL Setup, go to Sessions > Appliance Mode.
Set Appliance Mode to "Imprivata".
In the Set the URL to the Server field, enter the new server address.

Click Ok and confirm the Apply Settings dialog.
Now you have a fresh Imprivata appliance mode without any outdated data.
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Imprivata: Session Customization
You can make the same settings in the IMPRIVATA_RDP (IGEL Setup > RDP > RDP Sessions > Imprivata_RDP) and 
IMPRIVATA_VMware (IGEL Setup > Horizon Client > Horizon Client Sessions > IMPRIVATA_VMware) sessions as 
in the standard sessions (see the description for RDP Session and Horizon Client Session).

However, the changes under the following subsections will be ignored:

Imprivata_VMware Session
Connection Settings

Imprivata_RDP Session
Server
Logon

IMPRIVATA_RDP and IMPRIVATA_VMware will be shown in the IGEL Setup when Imprivata is selected 
under Setup > Sessions > Appliance Mode, see Imprivata.


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Windows Virtual Desktop
This IGEL release is a build of IGEL OS which includes the Microsoft WVD client as a configurable method for 
connecting to Windows Virtual Desktops.

Feature Matrix: WVD (RDP3) for IGEL OS 11 (see page 361)
How to Connect IGEL OS to Windows Virtual Desktop (see page 363)
Importance of Keeping IGEL OS Firmware Up-to-Date for Microsoft AVD and Windows 365 
CloudPC (see page 371)
Microsoft Teams Feature Comparison for IGEL OS (see page 385)
Remove Expired DigiCert Certificate (see page 388)
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Feature Matrix: WVD (RDP3) for IGEL OS 11
The following matrix shows a selection of features and their state of implementation.

Feature Linux RD 
Core 
SDK by 
Microsof
t

IGEL OS 
RDP3 
Client

Notes

Folder 
redirection

yes yes Folder Redirection is bound to the /media  folder, so 
that locally mounted storage devices, including USB sticks, 
will be forwarded to the remote session. 

Dynamic folder 
redirection

no no User may select specific drives/folders to redirect at run 
time.

Smart card 
redirection

no no Smart card redirection is implemented but not working.  
The problem exists in the RD Core SDK.

Clipboard 
redirection (text 
and images)

no limited Clipboard redirection works with text and images (JPEG 
and Bitmap); however, PNG images do not work.  
The problem exists in the RD Core SDK.

Clipboard 
redirection 
(files)

no no

Microphone 
redirection

yes yes

Speaker 
redirection

yes yes

Webcam 
redirection

no no

Printer 
redirection

no no

USB redirection no no

Mouse input yes yes

Keyboard input 
(scancodes)

yes yes
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Feature Linux RD 
Core 
SDK by 
Microsof
t

IGEL OS 
RDP3 
Client

Notes

Keyboard Input 
(Unicode)

yes yes

Teams 
conferencing 
redirection

no no Teams redirection will be added as soon as it is available in 
the RD Core SDK.

Multitouch 
redirection

no no No multitouch API present in the Linux RD Core SDK by 
Microsoft.

AVC Codec 
support 
(hardware 
acceleration)

yes Work in 
progress

Dynamic display 
change

yes yes

Monitor DPI 
sync

no no

Monitor Layout 
Sync (multimon)

yes yes

Restrict full-
screen sessions 
to single display

not 
applicabl
e

yes

On-premises 
services

not 
applicabl
e

Work in 
progress

RemoteApps no Work in 
progress

Target Release: IGEL OS 11.04
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•
•

1.
2.

How to Connect IGEL OS to Windows Virtual Desktop

Quick Start Guide
This section describes how to set up a Windows Virtual Desktop (WVD) session with IGEL’s WVD client based on 
Microsoft’s RD Core SDK for Linux which can be used to connect to a WVD deployment in Azure.

Requirements

Device with IGEL OS 11.03.261 (or higher); download the latest version at igel.com/wvd34

Windows Virtual Desktop deployment in Azure

Instructions

Open the Setup or the configuration dialog in the UMS and go to Sessions > WVD > WVD Sessions.
Click the  symbol to create a new WVD session instance.

https://www.igel.com/igel-solution-family/windows-virtual-desktop/
https://www.igel.com/igel-solution-family/windows-virtual-desktop/
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3.

4.

Enter a Session name and configure the starting methods according to your needs.

If the login is to be started automatically on session startup, go to Sessions > WVD > WVD 
Sessions > [Session name] and enter your credentials under User name and Password.
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5. If a specific resource is to be started automatically, enter its name under Resource to 
automatically start when connected.
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6. Go to Sessions > WVD > WVD Sessions > [Session name] > Options and enable or disable features 
and redirections according to your needs.
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7. Go to Sessions > WVD > WVD Sessions > [Session name] > Gateway and ensure that the fields are 
empty.
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8. If you do not want to run the WVD client on all available screens in fullscreen, go to System > 
Registry > sessions > wvd[your session number, e.g. 0] > options and change the settings 
under monitor, multimonitor and resolution according to your needs.
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9. Click Apply or OK.
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The WVD session is configured and can be started with the starting methods you have configured 
in step 3.

The session is configured and ready to run. If you want to configure further WVD sessions, start again from step 2.



Windows Virtual Desktop

35 http://www.igel.com/avd
36 http://www.igel.com/avd

IGEL OS Articles   371 / 1017

•
•
•

1.

Importance of Keeping IGEL OS Firmware Up-to-Date for Microsoft AVD 
and Windows 365 CloudPC
If you are running the Microsoft Azure Virtual Desktop (AVD) client on an IGEL OS-powered endpoint (PC, laptop, or 
client), it is important to ensure that the client version is up-to-date.

Why Is It Important to Keep Your Igel OS Firmware Updated?
If the client version is not up-to-date, changes on the Microsoft AVD's server-side could lead to functionality issues. 
The latest IGEL OS firmware version is, in most cases, the current official build. To find the latest version, 
see https://www.igel.com/software-downloads/workspace-edition/ > click OS 11 to expand the relevant 
section.

However, an IGEL OS private build may be released to adapt for server-side changes that have been introduced 
between IGEL OS releases. This way, we maintain existing functionality and support new features/functionality. 
Therefore, please refer to www.igel.com/avd35 for the latest Microsoft AVD / Windows 365 CloudPC specific IGEL OS 
releases.

IGEL Environment
Endpoints with IGEL OS 11
IGEL AVD client is used for Azure Virtual Desktop (AVD) and Windows 365 CloudPC by Microsoft
Universal Management Suite (UMS) 6.08 or higher

How to Check for the Latest IGEL OS Firmware Version
Open the web browser and go to www.igel.com/avd36.

http://www.igel.com/avd
http://www.igel.com/avd
https://www.igel.com/software-downloads/workspace-edition/
http://www.igel.com/avd
http://www.igel.com/avd
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2.

3.

Fill in the form to register for AVD client access and submit it.

After a few minutes, you will receive a confirmation mail from IGEL.

In the confirmation mail, click Update for current IGEL OS 11 installations.
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4.

The IGEL OS firmware with the latest AVD client is downloaded (official or private build). 

Note the version number that can be derived from the file name. 
Example: When the file name is lxos_11.06.100_public.zip , the version is 11.06.100. 

How to Check If the IGEL OS Version Is Out-of-Date
We will create a view to find out which endpoint devices are running a firmware version lower than the one with the 
latest AVD client.
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1.

2.

Open the UMS console and in the structure tree, go to Views.

Select New View.
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3. Enter an appropriate Name and click Next.
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4.

5.

In the search field, enter "firm", select Firmware version, and click Next.

Select below, enter the version number of the firmware you have downloaded beforehand, and 
click Next.
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6.

1.

Click Finish.
The matching endpoint devices are shown.

How to Update IGEL OS Endpoint Devices to the Latest Firmware Version
In the following instructions, we will use the Universal Firmware Update feature of the UMS. For alternative 
methods, see Firmware Update (see page 231), Buddy Update (see page 224), Updating IGEL OS Using a USB Storage 
Device (see page 234), and Updating the Firmware using the Linux Console (see page 236).

Make sure that the firmware file (in our example: lxos_11.06.100_public.zip ) can be 
accessed from the machine that hosts the UMS Console (via local file or network drive).
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2.

3.

In the structure tree of the UMS Console, go to Universal Firmware Update and select Firmware 
archive (zip file) -> Universal Firmware Update.

Make sure that Firmware archive (zip file) -> Universal Firmware Update is selected and click 
Next.
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4.

5.

Click the file chooser icon, find the firmware file and click Open.

Click Select directory,,, to define the target directory at the UMS Server.
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6.

7.

Select the directory, typically ums_filetransfer , and click Open.

Click Ok to confirm the creation of the Universal Firmware Update.

If everything went well, the new Universal Firmware Update is displayed.
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8. Go to the view you have created beforehand, open the context menu, and select Assign objects to 
the devices of the view....
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9.

10.

Select the Universal Firmware Update and click Ok.

Select the update time and click Ok.
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11. Confirm the message window.

On the next reboot, the endpoint devices will update their firmware.

Whether you are implementing classic VDI, virtual apps, DaaS, or in this case AVD, it is always a good practice to 
make sure you are running the very latest version of IGEL OS to take advantage of the latest features.
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Microsoft Teams Feature Comparison for IGEL OS

Feature IGEL OS 
AVD / 
Windows 
365

IGEL OS
Citrix

IGEL 
OS** (see 
page 387)

Windows 
10 AVD / 
Windows 
365

Windows 
10 Native

Comments

Audio Calls

One-to-One 
Call

yes yes yes yes yes

Group Call (3+ 
users)

yes yes yes yes yes

Video Calls

One-to-One 
Call

yes yes yes yes yes

Group Call (3+ 
users)

yes yes* yes* yes* yes * Random minor issues 
with the video feeds of 
users connected to 
media-optimized Teams 
sessions. Resizing the 
Teams application 
window and/or turning 
webcams on/off often 
solves the problems.

Gallery View yes yes yes yes yes

Large Gallery 
View

yes yes yes yes not 
applicable

Together 
Mode

yes yes yes yes yes

Rolling Release Info: OS 11.07.110

The information provided here is valid with IGEL OS 11.07.110 and higher.


The information presented here reflects the state on May 12, 2022.
The information was mostly obtained from https://support.microsoft.com/en-us/office/teams-features-
by-platform-debe7ff4-7db4-4138-b7d0-fcc276f392d3



https://support.microsoft.com/en-us/office/teams-features-by-platform-debe7ff4-7db4-4138-b7d0-fcc276f392d3
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Feature IGEL OS 
AVD / 
Windows 
365

IGEL OS
Citrix

IGEL 
OS** (see 
page 387)

Windows 
10 AVD / 
Windows 
365

Windows 
10 Native

Comments

Desktop 
Sharing

yes* yes* no* yes yes * Presenter's webcam 
feed not available while 
sharing desktop; 
presenter must also 
restart webcam after 
stopping desktop share.

Presentation 
Point Sharing 
(PowerPoint)

yes yes no yes yes

Application 
Sharing (Non-
PowerPoint)

yes* yes* yes yes* yes* * OneDrive and 
SharePoint are the 
available applications.

User Remote 
Control

yes yes no yes no

Chat 
Functions

no no no no yes

Whiteboard 
Display

no no no no yes

Whiteboard 
Sharing

yes yes no yes no Full Teams client does not 
offer a white whiteboard 
sharing

Document 
Whiteboard 
Sharing

yes yes no yes yes Full Teams client offers to 
share a scanned 
document or document 
camera

Background 
Blur

yes yes no yes yes

Background 
Virtual

no no no no yes
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Feature IGEL OS 
AVD / 
Windows 
365

IGEL OS
Citrix

IGEL 
OS** (see 
page 387)

Windows 
10 AVD / 
Windows 
365

Windows 
10 Native

Comments

Device Button 
Support

no no no no yes Pressing the mute button 
on the headset is 
reflected in the Teams 
mute (button) 
functionality

**Requires an unsupported Custom Partition which needs to be created and included by yourself. For instructions 
on how to create a Custom Partition, see the Custom Partition Tutorial (see page 689).
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•

1.

Remove Expired DigiCert Certificate

Symptoms
On March 8th of 2023, devices with IGEL OS were unable to connect to specific services. This includes, but may not 
be limited to the following:

Microsoft Azure Virtual Desktop (AVD)
Citrix cloud infrastructure

Affected Versions
All IGEL OS Public releases up to 11.08.230
Some private builds based on 11.08.230

Cause
A copy of an expired DigiCert SHA-2 Secure Server CA intermediate certificate was included in the Citrix Workspace 
client for Linux that was integrated into IGEL OS.

Due to the prioritization of certificates in IGEL OS, this copy took precedence over the one included in the main IGEL 
OS operating system. Since the fingerprint of the valid certificate and the third-party certificate matched, the 
primary certificate was not loaded into the secure stores, and the applications were unable to utilize them.

Solution
Upgrade to the latest version of IGEL OS.

If this doesn't fix the Issue, a custom command can be deployed that will remove the expired DigiCert root 
certificate. IGEL has created a profile that contains the command, which you can download and deploy in your 
environment.

Prerequisites

All affected devices are connected to the IGEL Universal Management Suite (UMS).
No other custom commands are configured for the affected devices.

Removing the Expired Certificate

In the UMS, review all affected devices and make sure that the following fields do not contain any 
commands:
System > Firmware Customization > Custom Commands > Desktop > Before Desktop Start

To make sure that everything works properly, test the fix on one or two devices before you deploy it on all 
affected devices.


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2.

3.

4.

System > Firmware Customization > Custom Commands > Reconfiguration section

Download the profile IGEL_AVD_fix-authentication-issue.zip and make it available to the machine 
that hosts your UMS.

In the UMS console, click System > Import > Import Profiles.

Select the profile on your file system and click Open.
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5. If this dialog appears, click Ok. Explanation: The profile is based on IGEL OS 11.11.08.230, but this 
version is not registered in your UMS. To resolve this conflict, your UMS will modify the profile 
accordingly; the profile is then based on an IGEL OS version that is known to your UMS.
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6. Assign the profile to the affected devices.
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7.

8.

In the Update time dialog, select Now.

Reboot the devices.



Windows Virtual Desktop

IGEL OS Articles   393 / 1017

1.

2.

Installing the New Certifcate

Open https://www.digicert.com/kb/digicert-root-certificates.htm, look for the certificate with the 
following data, and download it. 
Issuer: DigiCert Global Root CA 
Valid until 22/Sep/2030 
Serial #: 02:74:2e:aa:17:ca:8e:21:c7:17:bb:1f:fc:fd:0c:a0 
SHA1 Fingerprint: : 62:6D:44:E7:04:D1:CE:AB:E3:BF:0D:53:39:74:64:AC:80:80:14:2C 
SHA256 Fingerprint: C1:AD: 
77:78:79:6D:20:BC:A6:5C:88:9A:26:55:02:11:56:52:8B:B6:2F:F5:FA:43:E1:B8:E5:A8:3E:3D:2E:AA

 In the UMS console, select Files > New file.

https://www.digicert.com/kb/digicert-root-certificates.htm
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3. Select Upload local file to UMS server and get the certificate file from your file system.
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4. Set the Classification to Common Certificate (all Purpose).
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5.

6.

Click Ok to upload the certificate file to the UMS server.

Assign the certificate to the affected devices.
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7. In the Update time dialog, select Now.

The certificate is transferred to the devices.
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SSH
Enable Weaker Algorithms in the Built-in OpenSSH Server (see page 399)
Enable Weaker Algorithms in the SSH Client (see page 400)
SSH: Deprecation of Weak Algorithms as of IGEL Linux 10.04.100 (see page 401)
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1.
2.

•
•
•

•
•

Enable Weaker Algorithms in the Built-in OpenSSH Server

Problem
You are trying to connect to the built-in OpenSSH server of IGEL OS with an SSH client which does not support the 
strong algorithms of the server.

Solution
To enable weaker encryption algorithms, proceed as follows:

In Setup, go to System > Registry > network > ssh_server.
Change the settings according to your requirements:

disable_weak_encryption: Disable this option to enable weaker encryption.
disable_weak_hostkey_algos: Disable this option to enable weaker host key algorithms.
disable_weak_kexalgorithms: Disable this option to enable weaker key exchange 
algorithms.
disable_weak_macs: Disable this option to enable weaker MACs.
minimal_encryption_level: The minimal level of encryption
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1.
2.

•
•
•

•
•

Enable Weaker Algorithms in the SSH Client

Environment
IGEL Linux 10.04.100 or higher

Problem
You are trying to connect to an SSH server which does not support the strong algorithms enabled by default in the 
SSH client.

Solution
To enable weaker encryption algorithms, proceed as follows:

In Setup, go to System > Registry > network > ssh_client.
Change the settings according to your requirements:

disable_weak_encryption: Disable this option to enable weaker encryption.
disable_weak_hostkey_algos: Disable this option to enable weaker host key algorithms.
disable_weak_kexalgorithms: Disable this option to enable weaker key exchange 
algorithms.
disable_weak_macs: Disable this option to enable weaker MACs.
minimal_encryption_level: The minimal level of encryption



SSH

IGEL OS Articles   401 / 1017

•
•
•
•
•

•
•
•
•
•
•

•
•
•
•
•
•
•
•
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•

SSH: Deprecation of Weak Algorithms as of IGEL Linux 10.04.100
As of IGEL Linux 10.04.100, certain older, less secure algorithms are deprecated in both the SSH client and server.

The following table shows the algorithms enabled by default as of IGEL Linux version 10.04.100.

Key exchange algorithms curve25519-sha256@libssh.org
ecdh-sha2-nistp521
ecdh-sha2-nistp384
ecdh-sha2-nistp256
diffie-hellman-group-exchange-sha256

Message authentication codes 
(MACs)

hmac-sha2-512-etm@openssh.com
hmac-sha2-256-etm@openssh.com
umac-128-etm@openssh.com
hmac-sha2-512
hmac-sha2-256
umac-128@openssh.com

Host keys ssh-ed25519-cert-v01@openssh.com
ssh-rsa-cert-v01@openssh.com
ssh-ed25519
ssh-rsa
ecdsa-sha2-nistp521-cert-v01@openssh.com
ecdsa-sha2-nistp384-cert-v01@openssh.com
ecdsa-sha2-nistp256-cert-v01@openssh.com
ecdsa-sha2-nistp521
ecdsa-sha2-nistp384
ecdsa-sha2-nistp256

If you need to enable weaker algorithms, see Enable Weaker Algorithms in the SSH client (see page 400) and/or Enable 
Weaker Algorithms in the Built-in OpenSSH Server (see page 399).
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Amazon WorkSpaces - Teradici PCoIP Sessions
Amazon WorkSpaces is a managed, secure desktop-as-a-service (DaaS) solution. With Amazon WorkSpaces, 
Windows or Linux desktops can be deployed in minutes and quickly scaled to provide thousands of desktops to 
workers around the world.

The following articles contain everything you need to know about Amazon WorkSpaces in conjunction with IGEL 
devices:

Connecting IGEL OS Devices with Amazon WorkSpaces via PCoIP (see page 403)
Use IGEL Setup for Configuration – Connecting with AWS via PCoIP (see page 407)
Broker Types – Amazon WorkSpaces (see page 409)
How Can I Use H.264 Acceleration in a Teradici PCoIP Session? (see page 410)
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1.
2.
3.
4.

5.

Connecting IGEL OS Devices with Amazon WorkSpaces via PCoIP
You can set up and use IGEL OS devices via PCoIP with Amazon WorkSpaces. 

Set Up the Device Connection
Before you connect the device to the Amazon WorkSpaces for the first time, you might need to change some 
settings. Your Amazon WorkSpaces administrator can provide you with additional setup instructions that are 
needed for your particular environment.

Session Connection
To set the session connection:

In the IGEL Setup, go to Sessions > Teradici PCoIP Client > PCoIP Sessions.
Click   to create a new session.
Go to Connection Settings.
Set Server certificate verification mode to "Warn but allow".

Click Apply.

If you do not enable Use IGEL Setup for configuration, you have to enter the host address or code 
in the Teradici PCoIP Client login window. See the screenshot under "Connecting to Amazon 
WorkSpaces". 
If you activate Use IGEL Setup for configuration, see Use IGEL Setup for Configuration – 
Connecting with AWS via PCoIP (see page 407).



For more information about the connection with the Broker type "PCoIP broker" or "Hardhost", 
see Broker Types – Amazon WorkSpaces (see page 409).


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6.

1.

2.

3.

Go to Login and set Authentication type to "Password authentication". Afterward, click Apply.

Connecting to Amazon WorkSpaces
Double-click on the Amazon WorkSpaces icon on your desktop.

The Teradici PCoIP Client dialog opens.
Enter the Host Address or Code that has been sent to you in the welcome e-mail from Amazon 
WorkSpaces. 
Enter the Connection Name and click SAVE.
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4.
5.

6.

Enter your Amazon WorkSpaces credentials.
Enter the Multi-Factor Authentication (MFA) Token.

Click Ok.
The Amazon WorkSpaces desktop is shown. 

Multi-factor authentication is a proof of user identity which combines two different components 
(factors) that are independent from one another.



If you do not use multi-factor authentication, you still need to enter something in the MFA field, 
even when it is just a number or "1234". 
Otherwise, no connection to Amazon WorkSpaces can be established.



See also our video description on youtube:
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Sorry, the widget is not supported in this export.
But you can reach it using the following URL:
https://www.youtube.com/watch?v=NDQxTEKLPZE

https://www.youtube.com/watch?v=NDQxTEKLPZE
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1.
2.

a.
•
•

b.
•
•

3.
4.
5.

Use IGEL Setup for Configuration – Connecting with AWS via PCoIP

Configuring in the IGEL Setup
If you want to use the IGEL Setup for the configuration, proceed as follows: 

Enable Use IGEL Setup for Configuration.
Select the Broker type you want to connect to Amazon WorkSpace.

Broker type: Direct hardhost
Enter the AWS WorkSpace's Registration Code as Server.
Set Server certificate verification mode to "Warn but allow".

Broker type: PCoIP broker
Enter the server from the PCoIP broker as Server.
Set Server certificate verification mode to "Warn but allow".

Click Apply.
Go to Login and set Authentication type to "Password authentication".
Click Apply.

For more information about the broker types, see Broker Types – Amazon 
WorkSpaces (see page 409).


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1.

2.
3.
4.

Connecting to Amazon WorkSpaces
Double-click on the AWS WorkSpaces icon on your desktop.

The Teradici PCoIP Client mask takes over the information you entered in the IGEL Setup.
Click SAVE.
Now enter your Amazon WorkSpace credentials. 

For the rest of the procedure, see aws.amazon.com37.

https://aws.amazon.com/de/?nc2=h_lg
https://aws.amazon.com/de/?nc2=h_lg
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Broker Types – Amazon WorkSpaces
You can choose between two broker types with which you connect to Amazon WorkSpaces.  

PCoIP Broker
PCoIP broker is a resource manager that dynamically assigns host PCs to zero clients based on the identity of the 
user establishing from the zero client. Connection brokers are also used to allocate a pool of hosts to a group of 
zero clients in a PCoIP deployment are configured to always connect to the same host (i.e., a static one-to-one 
pairing), then a connection broker is not required.

Direct Hardhost
A direct hardhost is a direct connection between a zero client and a remote workstation containing a PCoIP Remote 
Workstation Card. You can specify a host's DNS name or IP address, or you can configure clients to use Service 
Location Protocol (SLP) to discover a host. You can also configure clients to automatically reconnect to a host when 
a session is lost. 
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1.
2.

3.
•
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•

1.
2.

3.

How Can I Use H.264 Acceleration in a Teradici PCoIP Session?

Question
How must I configure the client and the server to get H.264 acceleration in a Teradici PCoIP Session?

Environment
This article is valid for the following environment:

IGEL OS 11.04 or higher
UMS 6.04 or higher
Teradici PCoIP Graphics Agent for Windows 20.04

Answer

Server-side

Open the Group Policy Editor (gpedit.msc).
Go to Local Computer Policy > Administrative Templates > PCoIP Session Variables > 
Overridable Administrator Defaults.
Edit the settings as follows:

Set Configure PCoIP image quality levels to "Enabled".
Set Configure PCoIP image quality levels > YUV chroma subsampling to "4:2:0".
Set Enable PCoIP Ultra GPU optimization to "Enabled".

Client-side

Open the Setup or the UMS configuration dialog.
Go to System > Registry > pcoip > codec_h264 and activate H.264 codec (registry parameter: 
pcoip.codec_h264 ).

Save your settings.
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Login Enterprise Configuration
With Login Enterprise Launcher, you can test changes that affect the performance of desktop and 
application logins, as well as the current processing of both applications and specific tasks inside of a given 
application before you implement them on real devices. 

Login Enterprise Launcher in IGEL OS (see page 412)
Getting the Secret for Login Enterprise Launcher (see page 417)
Using the Login Enterprise Launcher within a VMware Horizon Session (see page 420)
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1.
2.

Login Enterprise Launcher in IGEL OS

Requirements
Firmware IGEL OS 11.03.100

Uploading the SSL Certificate
In order to use Login Enterprise Launcher, you need to download the SSL certificate first from  https://

loginpi.yourserverURL/contentDelivery/content/CA.crt . Click Go on to the 
webpage. Download the certificate.

Open the UMS Console.
Select New File in the Files context menu.

You have to rename the file name from CA.crt to LoginPI.crt.
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3.
4.

The window New file opens.

Select the Local file under Upload local file to UMS server.
Choose SSL Certificate under Classification and click Ok.
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1.

2.

3.

Configuration of Login Enterprise Launcher
Under Devices in the UMS structure tree, choose the device and click Edit Configuration in its 
context menu.

Go to System > Registry >  debug.tools.login_pi.crypt_password . 
Enter the Secret, see Getting the Secret for Login Enterprise Launcher (see page 417).

Go to System > Registry >  debug.tools.login_pi.server_url . Enter the Server URL of 
your Login PI server.

In Registry, you will not find the name Login Enterprise but Login PI, this has been communicated 
to us by Login Enterprise. 





Login Enterprise Configuration

IGEL OS Articles   415 / 1017

4.

1.

Click Apply or Ok.

Starting the Login Enterprise Launcher from the UMS
After the Login Enterprise server has been set up, you can create a job in the UMS for the automatic start of your 
Login PI Launcher at a defined time.

Select Jobs in the UMS structure tree and choose New Scheduled Job in the context menu.

The New Scheduled Job window opens.

See also Login PI documentation at http://www.loginvsi.com. 

If you want to use the Login Enterprise Launcher within a VMware session, see Using VMware 
Horizon View in Login PI Launcher (see page 420)



http://www.loginvsi.com
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2.
3.

4.
5.
6.

Under Name, enter the name for the job, e.g. "Login Enterprise".
Choose Start Login Enterprise launcher under Command.

Select the Execution time and Start date. 
Click Next and assign the devices.
Click Finish to save the job.
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1.

2.

Getting the Secret for Login Enterprise Launcher
This how-to explains how to get a Secret (see page 414) to configure Login Enterprise Launcher.

Go to  https://yourServerURL .

Enter  admin  as a username and password and click LOGIN.

Go to Launchers.
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3.

4.

Download a required  .zip  file under Download Launcher Setup and unpack it.

Open the  appsettings.json  file in the editor.
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Here you find the Secret for your Login Enterprise Launcher.

Use the Secret without the quotation marks "".
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1.

2.

Using the Login Enterprise Launcher within a VMware Horizon Session
If you want to use the Login Enterprise Launcher within a VMware Horizon Session on your IGEL OS device, note the 
following:

Go to  https://yourServerURL  and log in.

Go to Manage Tests.
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3.

4.
5.

Click Add new environment.

Enter an Environment name.
Select VMware Horizon View under Connector.
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6.

7.

Enter the Server URL and the Resource.

Copy the following:

"/services/vvdm/bin/vmware-view" --serverURL={serverurl} --userName="{username}" --
password="{password}" --domainName="{domain}" --desktopName="{resource}" --nonInteractive

and paste it under Connection command line.
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For more information on the configuration, see http://www.loginvsi.com.

This is important if you use the Login Enterprise Launcher for IGEL OS devices!

http://www.loginvsi.com
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1.

2.

Nutanix
Nutanix enables IT teams to build and operate high-performance multi-cloud architectures. The enterprise cloud 
OS software combines private, public and distributed cloud operating environments and provides centralized 
control to manage IT infrastructures and applications of all sizes.

Nutanix solutions are 100 % software-based and leverage the indurstry's most popular hyper-converged 
infrastructure (HCI) technology.

They provide a complete infrastructure stack that combines computing, virtualization, storage, networking, and 
security to run any application of any size. 

The Software runs across multiple cloud environments to harmonize IT operations and proved smooth mobility for 
all applications. For more informations, see nutanix.com38.

Frame on Nutanix
Frame ist the easiest way to run virtual apps and desktops on your choice of infrastrutcture.

It's a new option to use Frame Desktop-as-a-Service (DaaS) with apps, desktops, and user data hosted on your 
Nutanix (AHV) infrastructure.

You have to create a browser profile and put in the address of your frame broker.

Setting up Frame Connection
In the IGEL Setup go to Sessions > Browser.

Click  to add a Browser Session.
For more Information about the set up, see Browser Session.

hyper-converged infrastructure (HCI)

Hyper-convergent infrastructures are a further development of convergent infrastructures in which 
hardware and software are also bundled.



https://www.nutanix.com/en
https://www.nutanix.com/en
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1.
2.
3.

4.
5.

Running the Nutanix Test Drive on IGEL
Open the Firefox browser.
Enter https://www.nutanix.com39.
Click Test Drive.

Enter the required data.
Click Launch Test Drive.

https://www.nutanix.com/en
https://www.nutanix.com/en
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6. Your Nutanix Test Drive information is shown.
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7.

8.

Click Start Test Drive.

Enter your credentials in the PRISM (Planning tool for Resource Integration, Synchronization 
and Management) login window.

For the next steps, follow the instructions of Nutanix.
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Browser
How Can I Use H.264 Hardware Acceleration for Chromium or Firefox Browsers on IGEL OS 
Endpoint Devices? (see page 429)
Define Multiple Start Pages for Your Browser (see page 432)
Touchscreen: Multitouch/Gesture Support for Firefox (see page 433)
Set Advanced User Preferences for the Browser (see page 434)
Use the Browser in Kiosk Mode (see page 436)
SSL/TLS Error with Firefox in Appliance Mode (see page 439)
Browser Cannot Download Files (see page 440)
Some PDFs are not opened by Firefox (see page 441)
Can I Install Firefox Extensions? (see page 443)
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How Can I Use H.264 Hardware Acceleration for Chromium or Firefox 
Browsers on IGEL OS Endpoint Devices?
IGEL OS allows you to play videos from YouTube or other Internet resources with hardware acceleration, provided 
the videos are encoded with H.264. Due to license restrictions, either Chromium or Firefox can use H.264 hardware 
acceleration, but not both of them.

This article provides detailed information on how to configure H.264 hardware acceleration for Chromium or 
Firefox.

Checking Whether Hardware Video Acceleration Is Enabled Globally
 Make sure that System > Firmware Customization > Features > parameter Hardware Video Acceleration is 

enabled (enabled by default).

Checking Whether Hardware Video Acceleration Is Enabled for Chromium
 If you want to use hardware video acceleration with the Chromium browser, make sure that Sessions > 

Chromium Browser > Chromium Browser Global > parameter Hardware Video Acceleration is enabled (enabled 
by default),
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•

Does the Default Browser Setting Matter?
If Chromium and Firefox both have the number of sessions configured, the default browser matters. Example: If 
Firefox and Chromium both have three sessions, and Firefox is set as the default browser, Firefox will get H.264 
hardware acceleration.

Exception: If browser content redirection is activated, Chromium will always get H.264 hardware acceleration; see 
Browser Content Redirection for Citrix Sessions (see page 430).

The Browser with the Higher Number of Configured Sessions Gets Hardware Video 
Acceleration
The browser that has more sessions configured is the one that gets H.264 hardware acceleration. Example: If two 
sessions are configured for Chromium and three sessions are configured for Firefox, Firefox will get H.264 hardware 
video acceleration.

Exception: If browser content redirection is activated, Chromium will always get H.264 hardware acceleration; 
see Browser Content Redirection for Citrix Sessions (see page 430).

Browser Content Redirection for Citrix Sessions Forces Hardware Video 
Acceleration for Chromium 
The Chromium browser always gets H.264 hardware acceleration, regardless of the number of configured sessions, 
if all of these conditions are met:

Sessions > Citrix > Citrix Global > HDX Multimedia > parameter Browser content redirection is 
activated.



Browser

IGEL OS Articles   431 / 1017

•

•

•

•

System > Registry > ica > allregions > usecefbrowser > Use Chromium Embedded Framework 
(CEF) is set to "True".

Setting Chromium to Select the H.264 Video Stream
Generally, the default setting, which allows the Chromium browser to choose the video stream automatically, is 
recommended. Alternatively, you can set the Chromium browser to prefer the H.264 video stream even if hardware 
video acceleration is not enabled, or not prefer the H.264 video stream, disregarding the availability of hardware 
video acceleration.  

 Go to System > Registry > force_264 and set Force H.264 according to your needs:

"Auto": The Chromium browser prefers the H.264 video stream if hardware video acceleration is 
enabled.
"Enabled": The Chromium browser always prefers the H.264 video stream, regardless of whether 
hardware video acceleration is enabled or not.
"Disabled": The Chromium browser never prefers the H.264 video stream.
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1.
2.
3.
4.

Define Multiple Start Pages for Your Browser
In some cases, a fixed set of start pages displayed in separate tabs may prove useful. For instance, if the browser is 
working in kiosk mode, reusing a set of tabs from an earlier session is not an option.

Here is how to define multiple start pages to be opened at browser startup:

Open the setup and go to Browser > Browser Global.
Set When Firefox starts to Show my home page.
Set Homepage to the URLs that the browser should open at startup. Use "|" as a separator.
Click Apply or Ok.
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1.

2.

3.
4.

5.
6.

Touchscreen: Multitouch/Gesture Support for Firefox
You can use multitouch/gestures in the Firefox browser that is built into IGEL OS 10 and IGEL OS 11. This is done by 
adding an environment variable.

To enable multitouch:

Open the local Setup or the UMS configuration dialog and go to System > Firmware 
Customization > Environment Variables > Predefined.
In the first free Variable name field, enter MOZ_USE_XINPUT2

In the corresponding Value field, enter 1
Click Ok.

Reboot the device.
To check if multitouch is working, open the Firefox browser and go to https://www.paulirish.com/
demo/multi.

https://www.paulirish.com/demo/multi
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1.
2.

3.
4.
5.

6.

•
•
•

Set Advanced User Preferences for the Browser
The Mozilla Firefox browser included in IGEL OS offers a vast array of configuration options. They range from the 
sorting order of bookmarks over encryption algorithms to fixing quirks in web applications that are important to 
you. In total, they are too many to present them as individual items in IGEL Setup. However, as of IGEL Linux version 
5.09.100, IGEL Setup lets you set any browser user preference in a generic way.

You will find information regarding the configuration parameters for Firefox in the MozillaZine Knowledge Base 
under Firefox About:config entries40.

In Setup, go to Sessions > Browser > Browser Global > Advanced.
In the Custom preferences area, click on Add.

Using the Active option, specify whether the configuration parameter is to be active.
Specify the Mode of the configuration parameter - for many cases pref will do.
Under Custom preference, give the name of the configuration parameter. Example: 
ui.textSelectBackground

Specify the Type of the configuration parameter.
Possible values:

String: The value is a string of characters.
Integer: The value is a whole number.
Boolean: The value is a Boolean value, i.e. true  or false .

Changes to the advanced Firefox browser settings can impair its stability, security, and speed. IGEL 
Support is not responsible for problems caused by changing the browser configuration, even if the 
browser configuration was changed in IGEL Setup.



http://kb.mozillazine.org/About:config_entries
http://kb.mozillazine.org/About:config_entries
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7.

8.

Specify the Value of the configuration parameter. The possible entries depend on the Type
selected.
Click Ok.
The configuration parameter will take effect the next time that the browser is launched.
For more details on browser configuration, refer to the section Browser Global in the IGEL OS 
reference manual.
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Use the Browser in Kiosk Mode
Browser kiosk mode is an option when you are operating any kind of public terminal with anonymous access, e.g.:

Educational service in a museum
Service terminals or ticket vending machines for public transport
Entry portal for a corporate intranet

Albeit configuring an IGEL OS device for browser kiosk mode may seem quite extensive, you have the possibility to 
define your own flavor of kiosk mode. Consider the following settings.

Settings under Sessions > Browser > Browser Sessions > [Session Name]
 Activate Autostart.

Settings under Sessions > Browser > Browser Sessions > [Session Name] > Settings
 Set When browser starts to Show my home page.

 Set Homepage to the desired home page.

 If necessary, select the correct Start Monitor.

Settings under Sessions > Browser > Browser Global > Tabs

 Set New pages should be opened in to the current window or to a new tab.

Settings under Sessions > Browser > Browser Global > Content
 If applicable, activate Block pop-up windows.

 Activate Load images automatically.

 Activate Enable JavaScript if desired, and adapt the actions permitted for JavaScript according to your needs.

Settings under Sessions > Browser > Browser Global > Privacy
 Set Save Browsing History (in days) to Do not save History.

 Deactivate Save information entered in forms and the Search bar.

 Deactivate Remember Passwords.

 Activate Clear private data when closing browser.

 Activate all items in the area Select the items to be cleared.
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 If you want to suppress any tracking of the user's activities, activate Allow private browsing feature and 
Always start in private browsing mode.

 If applicable, activate Enable "Do Not Track" feature.

 To make the browser block domains and websites which are known for tracking users, activate Enable built-in 
tracking protection.

Settings under Sessions > Browser > Browser Global > Security

 To enable phishing protection, activate Safe Browsing.

 To enable protection against malicious downloads, activate Malware Protection.

Settings under Sessions > Browser > Browser Global > Restart
 Activate Restart. The browser will restart automatically if a user closes the browser window.

 If you want the browser to restart automatically after some idle time, activate Restart after idle time and set 
Idle time after which a restart occurs in minutes or seconds.

Settings under Sessions > Browser > Browser Global > Window
 If the browser shall run in full-screen mode, activate Start in fullscreen mode.

 Activate Hide local filesystem.

 Activate Hide configuration page of the browser.

Settings under Sessions > Browser > Browser Global > Menus & Toolbars

 Activate Hide App Menu/Menu Bar.

 Select which menus and toolbars are to be hidden.

 Deactivate User Customization of toolbars.

Disabling Access to Developer Tools
To disable access to the developer tools, add the following custom preference.

For general instructions on adding custom preferences, see Set Advanced User Preferences for the Browser (see page 
434).

Mode pref

Custom 
preference

devtools.toolbox.host
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Type String

Value (leave the value field empty)

Disabling Crash Reports
To disable crash reports, add the following three custom preferences.

For general instructions on adding custom preferences, see Set Advanced User Preferences for the Browser (see page 
434).

Mode pref

Custom 
preference

datareporting.policy.dataSubmission

Type Boolean

Value false

Mode pref

Custom 
preference

datareporting.healthreport.upload

Type Boolean

Value false

Mode pref

Custom 
preference

toolkit.telemetry 

Type Boolean

Value false
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1.

2.

SSL/TLS Error with Firefox in Appliance Mode

Symptom
Firefox on IGEL Linux 5.07.100 warns of an SSL/TLS error in appliance mode that does not occur in normal window 
mode. The error code is ssl_error_unsupported_version. This does not happen on IGEL Linux 5.06.x.

Problem
You cannot connect to the affected HTTPS service.

Solution
As a workaround you can instruct Firefox to ignore issues with SSL/TLS versions:

In IGEL Setup, go to System > Firmware Customization > Custom Commands > Base 
Commands
Enter the following command into the After Session Configuration input field:
echo "clearPref(\"security.tls.version.min\");" >> /services/fbrw/

firefox/firefox.cfg

There is also an IGEL Linux private build that addresses this issue.
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Browser Cannot Download Files

Symptom
You are trying to view or download a file with the browser, but you get error messages instead.

Problem
The browser has no permissions for the file path you have selected for download. This is because the Firefox 
browser is being guarded by AppArmor for security reasons. 

Solution
Check whether one of the following possibilities for downloading files is applicable/available:

Storage hotplug device (USB flash drive) which is mounted to  /media/[device name]  or /

userhome/media/[device name]
For hotplug storage configuration, see Storage Hotplug.
Network drive which is mounted to /mnt/[folder name]

Folder /userhome  in the local file system; not persistent



Browser

IGEL OS Articles   441 / 1017

1.
2.

3.
4.
5.

Some PDFs are not opened by Firefox

Symptom
When opening some PDFs from the Internet, the Mozilla Firefox browser opens a new window or tab, but fails to 
display the PDF contents.

Problem
This can be due to a malfunction of the mozplugger Firefox component.

Solution
Disable mozplugger. Firefox will download the PDF document and open it with a local application (IGEL Linux
5.07.100 or newer):

Go to System > Registry in IGEL Setup.
Use Search Parameter ... to find the parameter 
browserglobal.app.dom_ipc_plugins_enabled_mozplugger_so .

Check Completely disable mozplugger.
Confirm the setting with Apply or OK.
Restart Firefox.
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Can I Install Firefox Extensions?

Question
Can Firefox extensions be installed?

Answer
The installation of Firefox extensions is not possible. This applies to any version of both IGEL Linux v5.x and IGEL OS.
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System
Resetting a Device with Unknown Administrator Password (see page 445)
Error: "Unknown filesystem..." (see page 447)
Custom Boot Commands Are Still Active after Factory Reset (see page 448)
Solving Issues with Signed Partitions (see page 449)
How to Show the Boot Mode of IGEL OS (see page 456)
Disabling Features to Reduce Firmware Size (see page 457)
Fabulatech USB Redirection Server Component (see page 458)
Which Features of IGEL OS Will Be Affected If the UMS Is Down? (see page 459)
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1.

2.

3.

Resetting a Device with Unknown Administrator Password

Symptom
An administrator password has been set on IGEL OS (via Setup > Security > Password > Administrator) but it has 
been lost.

Problem
The local setup is not accessible without the password. Also, resetting the device to factory defaults seems 
impossible.

Solution
Change the administrator password using IGEL UMS via Setup > Security > Password > 
Administrator
or
Reset the device using IGEL UMS via Devices > Other commands > Reset to Factory Defaults in 
the UMS menu.
or
Reset the thin client locally using a reset to defaults key provided by IGEL (as described below):

Press the [ESC] key repeatedly in rapid succession while the device is booting.
This will bring up the boot menu.

Choose Reset to factory defaults and press [Enter].
The following will be displayed:

Press [Enter] three times without supplying a password.
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4.

5.
•
•
•
•

6.
7.

8.

9.

Enter [c] and press [Enter].
The software will then display a terminal key. Make a note of it, as you need it for requesting the 
reset to defaults key from IGEL.
Request a reset to defaults key from IGEL. Write an email to license@igel.com41 containing

your terminal key
your email address as registered with IGEL support
your company address
your phone number

IGEL will send you the reset to defaults key.
In the current session, enter [e] and press [Enter] to shut down the device.
On receiving the reset to defaults key, repeat steps 1 to 3 to boot the device with the same 
terminal key.
Enter [c] and press [Enter]. You will be prompted to enter the reset to defaults key.

Enter the reset to defaults key. Enter yes  and press [Enter] to confirm resetting the client. All 
local thin client settings will be lost.

Should you enter the wrong key or mistype the key you will have to resume from step 1.

mailto:license@igel.com
mailto:license@igel.com
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Error: "Unknown filesystem..."

Symptom
The boot process is aborted at an early stage; the error message is "Unknown filesystem. Couldn't find valid IGEL 
partition..."

Environment
IGEL OS (any version)

Problem 
One or more system partitions could not be found or are not valid.

Solution
 Install IGEL OS anew on the device with IGEL OS Creator (OSC). For instructions, see the Installation chapter of 

the IGEL OS Creator Manual.

Preserve Your Settings

To prevent the device's settings from being deleted, ensure that Migrate Old Settings is activated in the 
installation settings; see Installation procedure.



•
•

Data That Will Be Lost

When IGEL OS is installed anew, the following data will be lost:

All data on the writable partition /wfs
All data that has been stored in a Custom Partition since its deployment; Custom 
Partitions will be reset to their original state.



Licenses Will Be Lost

In this scenario, the licenses stored on the device will be lost. However, the licenses are cached in the UMS, 
so that they will be restored when the device registers with the UMS.


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1.
2.

Custom Boot Commands Are Still Active after Factory Reset

Symptom
You have reset your device to factory defaults, but the custom boot commands are still active.

Problem
After a factory reset, the following settings will still be available:

boot_id

uptime_total

product

force_Legacy

The bootreg entry Splash  will be set to  1

Solution
You can delete these settings manually with the following command:

Open a local terminal and log in as root.
Enter the following command to delete the settings: 
bootreg delete /dev/igfdisk boot_cmd

For further information about custom boot commands, see Custom Boot Command.
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Solving Issues with Signed Partitions
Error: "Partition couldn't be loaded due to invalid signature" (see page 450)
Error: Device Plays a Beep Code Instead of Booting (see page 451)
Error: "The new firmware is not signed. Update not allowed." (see page 454)
Error: "Invalid signature - Failed to read from partition" (see page 455)
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1.

2.

Error: "Partition couldn't be loaded due to invalid signature"

Symptom
During operation, a system message like this appears:

Environment

IGEL OS 11.03 or higher

Problem 
A system partition has been invalidated, which prevents system components from being loaded.

Solution

Ensure that a valid update source is configured under System > Update > Firmware Update and 
the correct firmware is stored on the server. (For detailed information, see Firmware Update.) If 
the local Setup is not accessible, use the UMS.
Reboot the device.
The device fetches the valid partition from the update source.
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1.
2.

Error: Device Plays a Beep Code Instead of Booting

Symptom
The boot process fails, and a beep code is played. Two beep codes are possible:

3 short and 1 long beep, repeated 2 times (whole sequence repeats up to 1 minute)
Long beep is played for 1,1 seconds, then 2,9 seconds pause (repeats up to 1 minute) 

Environment

IGEL OS 11.03 or higher

Problem 

3 short and 1 long beep, repeated 2 times (whole sequence repeats up to 1 minute): The signature 
of the found system partition is invalid.
Long beep is played for 1,1 seconds, then 2,9 seconds pause (repeats up to 1 minute): After up to 
120 tries, no suitable system partition has been found at all.

Diagnosis
To obtain further details:

Reboot the device and press [ESC] repeatedly.
Select Verbose Boot.
When the signature of the found system partition is invalid, the output looks like this:
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When no suitable system partition has been found at all, the output looks like this:

Solution

 Install IGEL OS anew on the device with IGEL OS Creator (OSC). For instructions, see the Installation chapter of 
the IGEL OS Creator Manual.

Preserve Your Settings
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To prevent the device's settings from being deleted, ensure that Migrate Old Settings is activated in the 
installation settings; see Installation procedure.

•
•

Data That Will Be Lost

When IGEL OS is installed anew, the following data will be lost:

All data on the writable partition /wfs
All data that has been stored in a Custom Partition since its deployment; Custom 
Partitions will be reset to their original state.



Preservation of Licenses

When IGEL OS is installed anew, any licenses stored on the device are preserved, provided that the 
relevant partition is valid. 


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Error: "The new firmware is not signed. Update not allowed."

Symptom
During the update process, the following error messages are shown:

Environment

IGEL OS 11.03 or higher

Problem 
The system expects signed system partitions, but the partitions of the update source are not signed. This will occur 
when you have tried to downgrade from IGEL OS 11.03 or higher to an older version of IGEL OS 11. 

Solution

 If you want to downgrade from IGEL OS 11.03 to IGEL OS 11.02, e. g. because you need certain older client 
versions, set the update source to IGEL OS 11.02.200.

IGEL OS 11.02.200 is a special variant of IGEL OS 11.02 which has signed partitions; this version can only be obtained 
from the IGEL Support Team.
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1.

2.

Error: "Invalid signature - Failed to read from partition"

Symptom
During operation, a system message like this appears:

Environment
IGEL OS 11.03 or higher

Problem 
A system partition has been invalidated, which prevents system components from being loaded.

Solution

Ensure that a valid update source is configured under System > Update > Firmware Update and 
the correct firmware is stored on the server. (For detailed information, see Firmware Update.) If 
the local Setup is not accessible, use the UMS.
Reboot the device.
The device fetches the valid partition from the update source.
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3.

How to Show the Boot Mode of IGEL OS
To check the boot mode of IGEL OS, proceed as follows:

Open the IGEL start menu.
Click the i-icon.
The About dialog opens.
Find the parameter Boot Mode under the Hardware section.
Example: BIOS
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1.
2.
3.
4.
5.

Disabling Features to Reduce Firmware Size

Symptom
You want to update your IGEL OS firmware to a higher release version, but the firmware update requires more disk 
space. Updating devices with less disk space than required leads to an error: Not enough space on local 

drive .

Problem
The size of the new firmware

with all enabled software features included
with the NVIDIA graphics driver
with the Firefox profile partition
possibly with a custom partition
possibly with custom wallpaper and bootsplash

exceeds the device's disk space (e.g. 2 GB).

Solution
Disable firmware features not needed for productive operation to reduce the size of the firmware:

In IGEL Setup, go to System > Firmware Customization > Features.
Disable features not needed in your environment.
Activate your settings with Apply or OK.
Reboot the device.
Update the device.

Use profiles with UMS in order to deactivate features on a group of devices.
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Fabulatech USB Redirection Server Component

Issue
For Fabulatech USB Redirection, a special Fabulatech server component must be installed on the Citrix or RDP 
server (USB for Remote Desktop IGEL Edition). More detailed information on the function can be found on the 
Fabulatech partner site42. On this site the server component is available for download.

Current versions are (as of 2017-05-29):

USB for Remote Desktop IGEL Edition Ver.3.1.5
USB for Remote Desktop IGEL Edition V5 Ver. 5.0.2

Problem
Which version is suitable for which IGEL Linux device?

Release notes of IGEL Linux only name the version of the Fabulatech client included but miss out the necessary 
server component version.

Solution
 All Fabulatech clients version 3.x require server component version 3.x

 All Fabulatech clients version 5.x require server component version 5.x

So for IGEL Linux thin clients following requirements apply:

IGEL Linux v4 devices up to current version 4.13.270 require server component version 3.x
IGEL Linux v5 devices up to version 5.02.100 require server component version 3.x
IGEL Linux v5 devices from version 5.03.100 and later require server component version 5.x
IGEL Linux 10.x requires server component version 5.x.

http://www.usb-over-network.com/partners/igel/
http://www.usb-over-network.com/partners/igel/
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Which Features of IGEL OS Will Be Affected If the UMS Is Down?

Overview
In general, IGEL OS works independently of the Unified Management Suite (UMS). This includes, for instance, all 
remote desktop clients like Citrix, RDP, or VMware Horizon, and browsers.

Any configuration changes that are made via the UMS are stored on the device and thus remain stable when the 
UMS is down.

However, the Shared Workplace (SWP) feature and administration functions are affected by a UMS outage. 

The following sections list the details.

Productivity Features That Are Affected If the UMS Is Down
Login via Shared Workplace (SWP); see Shared Workplace (SWP)

Administration Functions That Are Affected If the UMS Is Down
Configuration changes
License Management
Secure Shadowing
Secure Terminal
Universal Firmware Update
Firmware Customizations
Transfer of files to the device, including Custom Partitions
Remote commands, such as Wake-on-LAN or restart
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Network
Configuring Open VPN Sessions (see page 461)
Running the OpenVPN Client with a Preconfigured Configuration File (see page 473)
How Can I Configure OpenVPN with an .ovpn or .conf File for IGEL OS Devices? (see page 475)
Configuring Wi-Fi Network Roaming (see page 481)
Connecting to a Wi-Fi Network with Hidden SSID (see page 483)
Improving WiFi Connectivity (see page 484)
Preventing Permanent Storage of Wireless Network Keys (see page 488)
Using WPA Enterprise / WPA2 Enterprise with TLS Client Certificates (see page 489)
IPv6 Settings (see page 493)
Extended Logging With Syslog, Tcpdump and Netlog (see page 497)
Making a Telnet Connection from IGEL Linux (see page 511)
Configuring Dynamic DNS Updates via DDNS (see page 512)
Changing the SMB protocol version (see page 514)
How to Launch the Wireless Manager within IGEL OS when the Taskbar Is Hidden (see page 515)
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Configuring Open VPN Sessions
This document describes how to configure the OpenVPN Client on IGEL Linux.

Prerequisites
A configured and running OpenVPN 2.x server
Information about the OpenVPN server configuration (e.g. authentication method)
A thin client with IGEL Linux 10.01.100 or newer
The certificate and private key files for the client, along with the root certificate of the CA that 
signed the client and server certificates.
Optionally, a Smartcard or eToken supported by IGEL Linux.
To learn how to distribute keys and certificates to the thin clients, refer to the How-To document 
"Securely Distributing Keys and Certificates (see page 472)".

Authenticating with TLS Certificates (see page 462)
Authenticating with Name/Password (see page 463)
Authenticating with Name/Password with TLS Certificates (see page 464)
Authenticating with Static Key (see page 465)
Options and TLS Options (see page 466)
DNS and Routing Options (see page 467)
Proxy (see page 468)
Checking the VPN Connection (see page 469)
Automatically Starting the VPN During Boot (see page 470)
Further Information (see page 471)
Securely Distributing Keys and Certificates for OpenVPN (see page 472)
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1.
2.

3.
4.
5.
6.

7.

Authenticating with TLS Certificates
Go to Network > VPN > OpenVPN and create a new connection.
In the Session section for the new connection, enter the name or public IP address of the 
OpenVPN Server.
Select TLS-Certificates as the Authentication Type.
Select the client certificate as the Client Certificate file.
Select the root certficate of the CA as the Certificate Authority (CA) file .
Select the client's private key as the Private Key file. Enter the passphrase in Private Key 
password if the key is protected with one.

Click an icon for the newly created session (e.g. in the Start Menu) to initiate the connection.

If a PKCS12 file is available, which includes the client certificate, the certificate authority 
and the private key, then you just need to enter the PKCS12 file name in the three 
corresponding fields. The advantage is that you only have to roll out one single file instead 
of three different files.


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8.

Authenticating with Name/Password
Go to Network > VPN > OpenVPN and create a new connection.
In the Session section for the new connection, enter the name or public IP address of the 
OpenVPN Server.
Select Name/Password as the Authentication Type.
Enter the Username. If you leave this field blank the user will be prompted for the Username when 
connecting.
Check Password required.
Enter the Password. If you leave this field blank the user will be prompted for the password when 
connecting.
Select the root certficate file of the CAAs the Certificate Authority (CA) file.

Click an icon for the newly created session (e.g. in the Start Menu) to initiate the connection.
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10.

Authenticating with Name/Password with TLS Certificates
Go to Network > VPN > OpenVPN and create a new connection.
In the Session section for the new connection, enter the name or public IP address of the 
OpenVPN Server.
Select Name/Password with TLS-Certificates as the Authentication Type.
Enter the Username. If you leave this field blank the user will be prompted for the username when 
connecting.
Check Password required.
Enter the Password. If you leave this field blank the user will be prompted for the password when 
connecting.
Select the client certificate as the Client Certificate file.
Select the root certficate of the CA as the Certificate Authority (CA) file.
Select the client's private key as the Private Keyfile. Enter the passphrase in Private Key 
password if the key is protected with one.

Click an icon for the newly created session (e.g. in the Start Menu) to initiate the connection.

If a PKCS12 file is available, which includes the client certificate, the certificate authority 
and the private key, then you just need to enter the PKCS12 file name in the three 
corresponding fields. The advantage is that you only have to roll out one single file instead 
of three different files.


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Authenticating with Static Key
Go to Network > VPN > OpenVPN and create a new connection.
In the Session section for the new connection, enter the name or public IP address of the 
OpenVPN Server.
Select Static Key as the Authentication Type.
Select the static key file as the Private Key.
Select None as the Key Direction.
Enter the server's VPN IP address as Remote IP Address.
Enter your client's VPN IP address as Local IP Address.

Click an icon for the newly created session (e.g. in the Start Menu) to initiate the connection.
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Options and TLS Options

Options
Under Network > VPN > OpenVPN > [Session Name] > Options, you can set various options for the OpenVPN 
client. Usually, you can leave the default settings as they are. If the server uses compression, enable Use LZO data 
compression.

TLS Options
Under Network > VPN > OpenVPN > [Session Name] > TLS-Options, you can set various TLS-related options. In 
particular, you can configure whether the remote peer certificate will be verified.
For details about these settings, refer to Configuring Open VPN Sessions (see page 461) or OpenVPN.

When using a proxy, set Protocol used for communication to the host to tcp-client.
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DNS and Routing Options
By default, OpenVPN automatically uses the server's settings for DNS and routing.

If you want to change these settings, go to Network > VPN > Open VPN > [Session Name] > IPv4. Here you can:

Deactivate Automatic DNS
Add Extra nameserver(s)
Add Extra search domains
Deactivate Automatic Routes
Deactivate VPN is the default route

Additionally, you can enable three custom routes in Network > VPN > Open VPN > [Session Name] > Route 
[0,1,2]. For each enabled route you can configure:

whether it is a Network Route or a Host Route
Network/Host IP
Network Mask (for Network Route only)
Optional: Gateway
Optional: Metric (a quality rating used for routing decisions, 0 being the best)



Network

IGEL OS Articles   468 / 1017

•
•
•

•
•

Proxy
If you wish to configure a proxy for your VPN connection, go to Network > VPN > OpenVPN > [Session Name] > 
Proxy. Here you can configure:

Proxy Type: SOCKS or HTTP, by default this is set to None
Proxy Address and Proxy Port
Retry indefinitely when errors occur

If you select the HTTP proxy type you can configure:

Proxy Username
Proxy Password

When using a proxy, set Options > Protocol used for communication to the host to tcp-
client.



When experiencing issues with OpenVPN, read the messages in /var/log/messages , 
e.g. using the System Log Viewer.


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Checking the VPN Connection
As soon as a VPN connection is established, a lock icon with connected plugs is shown in the panel:

However, this only serves as an indicator. To be sure that the VPN connection really exists:

Open a Local Terminal.
Run the command ifconfig.

Check whether the output contains a tun device with an IP address from the private network.

Additionally, check whether you can ping the VPN server's private IP address.
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Automatically Starting the VPN During Boot

Go to Network > VPN > OpenVPN.
Check Enable Autostart During Boot.
Select one of the configured sessions.
Click Set Auto.
The session will be marked in the Auto column. 
Click Set Auto again to dectivate autostarting the session.

If you want to update the firmware via the VPN, you need to enable Autostart During Boot. Enabling 
Autostart of the control application in Network > VPN > OpenVPN > [session name] is not adequate!



The system will prompt you for key pass phrases or the eToken/smartcard PIN if 
necessary.


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Further Information
Further information about OpenVPN can be found in

the OpenVPN how-to43 and
the OpenVPN manual page44

maintained by the OpenVPN project.

https://openvpn.net/index.php/open-source/documentation/howto.html
https://openvpn.net/community-resources/reference-manual-for-openvpn-2-0/
https://openvpn.net/index.php/open-source/documentation/howto.html
https://openvpn.net/community-resources/reference-manual-for-openvpn-2-0/
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Securely Distributing Keys and Certificates for OpenVPN
Use the file distribution mechanism in the Universal Management Suite (UMS) to securely distribute keys and 
certificates to the thin clients:

Select Undefined as the Classification.
Enter /wfs/OpenVPN/  as the thin client file location.
Enable the Read permission for the Owner exclusively, and uncheck all remaining permissions.
Select Root as the Owner.
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Running the OpenVPN Client with a Preconfigured Configuration File

This article describes a basic solution for getting the built-in OpenVPN client running with a preconfigured 
configuration file. This is an alternative to using the Setup for configuration.

Environment
This article is valid for the following environment:

IGEL OS 10 or higher
OpenVPN server

Setting up an OpenVPN Connection with a Preconfigured Configuration File 
In the UMS Console, open the context menu on Files and select New File.
Select your .ovpn  file in the file system.
In the File target section, under Devices file location, enter "/wfs/".
Click Ok.
The file is uploaded to the UMS.
Assign the file object to your device by clicking the "+" symbol in the Assigned objects area (upper 
right).
Create a profile with a suitable name, e. g. "OpenVPN Connection".
In the profile, go to System > Firmware Customization > Custom Commands > Network.
In the Final network command field, enter the following code, replacing  example.ovpn  with 
the correct filename:

while :; do if [ -z $(pgrep openvpn) ]; then echo "openvpn is not 

running"; openvpn --config /wfs/example.ovpn --auth-user-pass 

<(echo -e $(zenity --forms --text="Enter your VPN credentials" --

add-entry=Username --add-password=Password --title=OpenVPN) | sed 

's/|/\n/'); else echo "openvpn is running"; fi; sleep 1; done &

Click Save to save the profile.
Assign the profile to your device by clicking the "+" symbol in the Assigned objects area.
Reboot the device.
After reboot, you should see a login window for OpenVPN.

Solution Based on Experience from the Field

This article provides a solution that has not been approved by the IGEL Research and Development 
department. Therefore, official support cannot be provided by IGEL. Where applicable, test the solution 
before deploying it to a productive environment.


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12. Enter your OpenVPN credentials.
If the login was successful, a Network connecting popup appears briefly. No other indicator is 
shown. You can disconnect only by rebooting the device.
If the login has failed, the login window reappears.

Removing the OpenVPN Connection
 To remove the OpenVPN connection from the settings, unassign the profile from the device and reboot it.
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How Can I Configure OpenVPN with an .ovpn or .conf File for IGEL OS 
Devices?
You can use the  .ovpn  or the .conf  file from your firewall to configure OpenVPN for your IGEL OS device.

Creating a Profile

Open the .ovpn  or the .conf  file in “Microsoft Visual Studio Code” (freeware) or any other 
editor that can save files in UTF-8 and uses LF (not CR-LF) for a newline.

In the UMS, create a profile with an appropriate name, e.g. "OS11_OpenVPN".

Go to Network > VPN > Open VPN and click   to create an OpenVPN session.

Edit the settings of Network > VPN > Open VPN > [your OpenVPN session] > Session as follows:

Solution Based on Experience from the Field

This article provides a solution that has not been approved by the IGEL Research and Development 
department. Therefore, official support cannot be provided by IGEL. Where applicable, test the solution 
before deploying it to a productive environment.


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5. Go to Network > VPN > Open VPN > [your OpenVPN session] > Options and edit the settings as 
follows:
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2.

Go to Network > VPN > Open VPN > [your OpenVPN session] > TLS Options and edit the settings 
as follows:

Creating the Certificate/Key Files
If you already have the following files, you can skip this section and jump to Transferring the Files to the UMS (see 
page 479):

ca.crt

client.crt

client.key

If the certificates and the key are embedded in your .ovpn  file, extract the certificates and key as follows:

 Open the .ovpn  file in your editor (must be able to save as UTF-8 and use LF, not CR-LF, for a 
newline).

Go to the section tagged as <ca> ... </ca>  and copy the marked certificate, including 

----BEGIN CERTIFICATE----- and -----END CERTIFICATE----- .
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5.

Paste the text to the editor and save it to a file named  ca.crt  (file type "All files").

Go to the section tagged as <cert> ... </cert>  and copy the marked certificate, including 

----BEGIN CERTIFICATE----- and -----END CERTIFICATE----- .

Paste the text to the editor and save it to a file named  client.crt  (file type "All files").
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1.

Go to the section tagged as <key> ... </key>  and copy the marked key, including ----

BEGIN PRIVATE KEY----- and -----END PRIVATE KEY----- .

Paste the text to the editor and save it to a file named  client.key  (file type "All files").

Transferring the Files to the UMS
In the UMS, go to Files > [context menu] > New file and create a file object for each certificate/key 
file; set Classification to "Common Certificate (all purpose)". 

Assign the file objects to the endpoint devices on which you want to use the OpenVPN connection.

For detailed information on how to create file objects in the UMS and transfer them to devices, see Files - 
Registering Files on the IGEL UMS Server and Transferring Them to Devices.

Adjust the Profile
In the UMS, open the profile you have created for your OpenVPN connection and go to Network > 
VPN > Open VPN > [your OpenVPN connection] > Session.
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Edit the file locations as follows:

Apply the profile to the endpoint devices on which you want to use the OpenVPN connection.
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Configuring Wi-Fi Network Roaming

Issue
Different wireless network instances have been configured for a mobile device. The device should switch over to the 
strongest network automatically.

Solution
Parameters to configure Wi-Fi roaming options can be found in the IGEL registry (Setup > System > Registry). 
These settings should be changed by experts only.

Parameters for better control of Wi-Fi roaming capabilities with access points that share the same 
SSID:
network.interfaces.wirelesslan.device0.lock_initial 
Default: false  

If true , the device will stick to the access point it is connected to even if candidates with better 
signal quality are present. 
Setting this parameter to true is a last resort for problems that are caused by too much 
roaming. 

network.interfaces.wirelesslan.device0.bgscan.module 
Default: default  (Perserving the unpachted NM's behaviour)
Possible values: 
default  : No background scanning is done. 

simple : The Wi-Fi module tries to scan for a potentially better signal in the background. 

bgscan.module simple provides following options: 

network.interfaces.wirelesslan.device0.bgscan.simple.signal_strength (default: -45 dBm ) 
This defines a threshold that determines which of the following two parameters shall be effective: 

network.interfaces.wirelesslan.device0.bgscan.simple.short_interval (default: 30 s ) 
Interval between background scans (in seconds) if the actual signal level of the currently 
connected access point is worse than signal_strength. 

network.interfaces.wirelesslan.device0.bgscan.simple.long_interval (default: 300 s ) 
Interval between background scans (in seconds) if the actual signal level of the currently 
connected access point is better than signal_strength.
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• Parameters to control Wi-Fi roaming between Wi-Fi networks with different SSIDs:
network.interfaces.wirelesslan.device0.mssid_check_interval (default: 10 s ) 
The interval in seconds between checking if automatic roaming might be neccessary. This includes 
detecting that a connection has been lost and a new one should be established. 

network.interfaces.wirelesslan.device0.mssid_quality_threshold (default: 20 ) 
If the current connection's quality percentage is below this value, scanning will be performed to 
find a potentially better network. 

network.interfaces.wirelesslan.device0.mssid_quality_difference_threshold (default: 40 ) 
A candidate for automatic roaming is only considered if its quality percentage is this much better 
than the current connection's quality.

network.interfaces.wirelesslan.device0.mssid_previously_used_threshold (default: 55 ) 
During boot: If the previously used SSID's quality percentage is above this threshold, it is preferred. 

network.interfaces.wirelesslan.device0.mssid_user_selection (default: false ) 

If true , the user can initiate roaming to a network via the Wi-Fi tray icon's context menu (must 
be enabled). 

If automatic roaming shall not interfere with the user's choice, the following values are 
appropriate: 
network.interfaces.wirelesslan.device0.mssid_quality_threshold = 0  

network.interfaces.wirelesslan.device0.mssid_quality_difference_threshold = 101  

network.interfaces.wirelesslan.device0.mssid_previously_used_threshold = 0

If parameter lock_initial is true , it is recommended to set bgscan.module to none .
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Connecting to a Wi-Fi Network with Hidden SSID

Symptom
The device does not connect to a wireless network with hidden SSID.

Problem
An option in the device's network configuration is missing.

Solution
If you need to configure a hidden access point, proceed as follows:

Start IGEL Setup or open the device configuration dialog in the UMS.
Go to Network > LAN Interfaces > Wireless > Default Wi-Fi network (or Additional Wi-Fi 
networks depending on your configuration).
Choose Enable WPA Encryption.
Set parameter AP Scan mode  to "no broadcast".
Click Apply or Ok to save the settings.
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Improving WiFi Connectivity

Problem
Your WiFi connection is unstable, or weak, or both.

Environment
UDC with IGEL Linux v5??? or IGEL OS??? or higher???
UD Pocket IGEL Linux v5??? or IGEL OS??? or higher???

Possible Causes and Solutions
There are many circumstances and parameters which influence the quality of a device's WiFi connection. To find a 
suitable solution to your problem, check out the following collection of possible causes and suggested solutions, 
workarounds and hints for debugging.

Several Access Points (APs) Are Using the Same Channel
If more than one Access Points visible to the thin client are using the same WiFi channel, interference issues may 
arise.

 Reconfigure the Access Point (AP) in question to use different channels.

Roaming within One Network (Same SSID)
When the device is configured to roam within its network, it tries to make sure that it is using the strongest/nearest 
Access Point (AP) within its network. Dependent on the given situation, it might be feasible to disable or to optimize 
roaming.

See also Configuring Wi-Fi Network Roaming (see page 481).

Avoid Roaming

 In the Setup, go to System > Registry > network > interfaces > wirelesslan > device0 > lock_initial (Registry 
key: network.interfaces.wirelesslan.device0.lock_initial ) and activate Avoid roaming 
within the same network.

If roaming is deactivated, System > Registry > network > interfaces > wirelesslan > device0 > bgscan > 
module should be set to none.


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Select the Access Point with the Best Signal

With the following setting, the thin client selects the Access Point that emits the best signal when the device starts 
up.

 In the Setup, go to System > Registry > network > interfaces > wirelesslan > device0 > bssid (Registry 
key:  network.interfaces.wirelesslan.device0.bssid ) and enter bestsignal  in the BSSID field.

Automatic Roaming

Automatic roaming is feasible if the device is moved around frequently, and several Access Points are available.

In the following example, the device is configured to start scanning for another Access Point 10 seconds after the 
signal of the current Access Point has dropped below -78 db, while a routine scan is executed every 60 seconds, :

In the Setup, go to System > Registry > network > interfaces > wirelesslan > device0 > bgscan > 
module (Registry key: network.interfaces.wirelesslan.device0.bgscan.module )
 and select simple.
Set System > Registry > network > interfaces > wirelesslan > device0 > bgscan > module > 
simple > long_interval (Registry 
key:  network.interfaces.wirelesslan.device0.bgscan.module.simple.long_

interval ) to 60.
Set System > Registry > network > interfaces > wirelesslan > device0 > bgscan > module > 
simple > short_interval (Registry 
key:  network.interfaces.wirelesslan.device0.bgscan.module.simple.shor

t_interval ) to 10.
Set System > Registry > network > interfaces > wirelesslan > device0 > bgscan > module > 
simple > signal_strength (Registry 
key:  network.interfaces.wirelesslan.device0.bgscan.module.simple.sign

al_strength ) to -78.

40 MHz Bandwidth in the 2.4 GHz Band
With some Access Points, it may be feasible to disable the 40 MHz bandwidth in the 2.4 GHz band.

 In the Setup, go to System > Registry > network > interfaces > wirelesslan > device0 > driver > cfg80211 
> cfg80211_disable_40mhz_24ghz (Registry 
key:  network.interfaces.wirelesslan.device0.driver.cfg80211.cfg80211_disable_40mh

z_24ghz ) and deactivate Disable 40 MHz channel bandwidth in 2.4 GHz band.

High Throughput Option
In some environments, the high throughput functionality built into the driver may not produce optimal results. You 
can disable this functionality and check if the connection has improved.
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 In the Setup, go to System > Registry > network > interfaces > wirelesslan > device0 > driver > 
disable_ht (Registry key:  network.interfaces.wirelesslan.device0.driver.disable_ht ) and 
deactivate Disable HT. 

2.4 GHz Band Only
In some environments, it might be better to use only the 2.4 GHz band.

 In the Setup, go to System > Registry > network > interfaces > wirelesslan > device0 > band (Registry key: 
network.interfaces.wirelesslan.device0.band ) and select 2.4 GHz.

If one or more alternative WiFi networks (SSIDs) are configured, do the following for each alternative SSID:

 In the Setup, go to System > Registry > network > interfaces > wirelesslan > device0 > alt_ssid[number] > 
band (Registry key:  network.interfaces.wirelesslan.device0.alt_ssid[number].band ) and 
select 2.4 GHz.

Frame Aggregation
It might be helpful to disable the frame aggregation feature of IEEE 802.11n.

 Disable frame aggregation on your Access Point (AP).

WiFi Driver Scans And Selects Access Point
By default, the WPA supplicant initiates scanning and the selection of an Access Point. You can change this behavior 
and assign this task to the driver.

In the Setup, go to System > Registry > network > interfaces > wirelesslan > device0 > wpa > 
ap_scan (Registry key: network.interfaces.wirelesslan.device0.wpa.ap_scan ) 
and select WLAN driver initiates scanning and AP selection.
Restart the thin client.

Whitelist of BSSIDs
You can restrict the number of Access Points to be scanned by creating a whitelist. This whitelist contains only the 
BSSIDs of those Access Points that the device should scan.

In the Setup, go to System > Registry > network > interfaces > wirelesslan > device0 > bssid_whitelist (Registry 
key: network.interfaces.wirelesslan.device0.bssid_whitelist ) and enter the BSSIDs of those 
Access Points that should be scanned, separated by whitespaces.

On your Access Point, this feature may have a different name.
Also note that IGEL cannot give a guarantee that the Access Point will function properly after the 
suggested configuration changes.


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Debugging
If none of the methods described above work, you can create a log file and send it to the IGEL Support Team.

In the Setup, go to System > Registry > network > interfaces > wirelesslan > device0 > wpa > 
debug (Registry key: network.interfaces.wirelesslan.deviceo.wpa.debug ) and 
select very verbose.
Restart the thin client.
Send the file   /tmp/wpa_debug.all  to the IGEL Support Team.
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Preventing Permanent Storage of Wireless Network Keys
This document describes how to prevent users from storing wireless network keys/passwords for Wireless 
Manager on the endpoint device.

In Setup, go to System > Registry.
Go to the network.applet.wireless.allow_storing_credentials  parameter.
Uncheck Allow permanently storing credentials, which is checked by default.
Click Apply.

This will affect the Wireless Manager dialogs for wireless networks with the network authentication methods in 
their variants requiring passwords:

WPA Personal
WPA Enterprise
WPA2 Personal
WPA2 Enterprise

In particular, users will not have check boxes labeled Permanently store identity and password or Permanently 
store network key available.
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Using WPA Enterprise / WPA2 Enterprise with TLS Client Certificates
This document describes how to use UMS to configure Wi-Fi connections on IGEL OS with WPA Enterprise / WPA2 
Enterprise and TLS client certificates.

There are two options for supplying client certificates and keys to devices:

Via SCEP (NDES)
SCEP allows the automatic provisioning of client certificates via an SCEP server and a certification authority (CA).

Learn how to configure it, using How-To Certificate Enrollment and Renewal with SCEP (NDES) (see page 584).

Via Files Served from UMS
You need:

a client certificate in PEM (base64) format
a client private key (needs to be passphrase-protected) in PEM (base64) format

Alternatively,

a PKCS#12 file containing both client certificate and private key (needs to be passphrase-
protected).

Deploying Client Certificates and Keys (see page 490)
Configuring the Network Interface (see page 491)

In both cases, SCEP and files from UMS, the device needs to have a working Ethernet or Wi-Fi connection 
to the SCEP server or the UMS first, so that it can fetch the necessary certificates before it can connect to 
the target Wi-Fi.


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Deploying Client Certificates and Keys
To deploy client certificates and keys via UMS, follow these steps for the client certificate and client private key files 
(or the PKCS#12 files containing both):

In the UMS Console navigation tree, right-click Files and select New file from the context menu.
The New file dialog opens
Under File source, use the file chooser to choose the file as the Local file.
Under File target, leave the classification as Undefined.
Set the Thin Client file location to /wfs/wpa-tls/
Under Access rights, set check Read and Write for the Owner and none for Others.
Set the Owner to Root.
Click OK to upload the file.
Drag the file icon onto a thin client or thin client directory in order to assign the file.
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Configuring the Network Interface
This describes how to configure the Wi-Fi interface.

Using SCEP (NDES)

In Setup go to Network > LAN Interfaces > Wireless.
Check Activate Wireless Interface.
Go to Default WiFi-network.
Select Enable WPA Encryption.
Enter the Wireless Network Name (SSID).
Select WPA Enterprise or WPA2 Enterprise according to your preferences.
Set EAP Type to TLS
or set EAP Type to PEAP and Auth Method to TLS.

Leave Validate Server Certificate enabled.
Enter the path to a CA Root Certificate if you use a CA other than those supported by IGEL OS (see 
page 604).
Check Manage Certificates with SCEP (NDES).
Click Save.

Using Certificate and Key Files

In Setup go to Network > LAN Interfaces > Wireless.
Check Activate Wireless Interface.
Go to Default Wi-Fi network.
Select Enable WPA Encryption.
Enter the Wireless Network Name (SSID).
Select WPA Enterprise or WPA2 Enterprise according to your preferences.
Set EAP Type to TLS
or set EAP Type to PEAP and Auth Method to TLS

Leave Validate Server Certificate enabled. Enter the path to a CA Root Certificate if you use a CA 
other than those supported by IGEL OS (see page 604).

In both cases, SCEP and files from UMS, the device needs to have a working Ethernet or Wi-Fi connection 
to the SCEP server or the UMS first, so that it can fetch the necessary certificates before it can connect to 
the target Wi-Fi.



IGEL OS supports both EAP-TLS and PEAP-EAP-TLS. Choose one that is supported by your 
infrastructure.



IGEL OS supports both EAP-TLS and PEAP-EAP-TLS. Choose one that is supported by your 
infrastructure.


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Enter the path to the Client Certificate file in PEM (base64) format, e.g. /wfs/wpa-tls/

client.crt .
Leave this field blank if you use a PKCS#12 file containing both certificate and private key.
Enter the path to the Private Key file in PEM (base64) format.
If you use a PKCS#12 file containing both certificate and private key, enter its path here.
Specify the Identity to be used if your key/certificate contains more than one entry.
Enter the Private Key Password.
Click Save.
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IPv6 Settings
IGEL Linux version 5.07.100 or newer and IGEL Linux version 10.01.100 or newer offer new options for configuring 
network interfaces for IPv6.

Application Scenario
IGEL devices cannot so far communicate with the UMS via IPv6. Therefore, the major application scenario for IPv6 is 
as follows:

Devices still receive their IPv4 configuration and potentially IGEL-specific DHCP options from a 
DHCPv4 server.
Most of the settings are received from the UMS via IPv4.
Only the default options are requested from the DHCPv6 server. These are as follows:

IPv6 address
nameservers
DNS search list.

Regarding DNS, only IPv6 nameserver addresses should be delivered (in router advertisements or 
DHCPv6 options). The resolver should be able to use these for retrieving AAAA records and also A 
records if necessary.
Clients and servers use IPv6 if they are prepared to do so.
Examples:

An NTP server (System > Time and date > NTP time server) can be specified as an IPv6 
address or as a name for which the DNS has only an AAAA record available.
Similarly, in a web browser session, IPv6 will be used when the DNS has AAAA records 
available for servers.

Available Configurations (see page 494)
Timeouts in Automatic Configuration (see page 496)
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Available Configurations
IPv6 support is configured by network interface in Network > LAN Interfaces:

The following configurations are available:

Value Effect

Compatibilty 
mode

Equivalent to former versions of IGEL Linux: NetworkManager ignores the 
device, but the kernel performs some basic configuration. In particular, it 
assigns an IPv6 link local address to the device.

Disabled IPv6 is disabled completely.

Automatic The device tries to perform an IPv6 stateless or stateful autoconfiguration 
based on router advertisements. Depending on the router advertisements, 
this involves DHCPv6 (see RFC 4861).
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DHCPv6 This option is supported by NetworkManager. It can be used when a DHCPv6 
server is available but no router advertisements. Routing has to be 
configured by other means. In most cases Automatic will be preferable.

In all cases IPv4 is configured in the usual way.
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Timeouts in Automatic Configuration
If Automatic is selected, there is a configurable timeout for the dual stack mode. This is the time that the system 
waits after the first of the stacks IPv4 or IPv6 has completed its configuration for the other stack to complete its own 
configuration. After this time has elapsed, it runs the scripts that depend on the network being up. The default 
timeout value is 15 seconds.

The timeout can be configured with the following parameters in System > Registry:

Parameter Device

network.interfaces.ethernet.device0.dual_stack_ 

timeout

First ethernet device

network.interfaces.ethernet.device1.dual_stack_ 

timeout

Second ethernet device

network.interfaces.wirelesslan.device0.dual_ 

stack_timeout

Wireless LAN device

Use the Search parameter ... function with the string dual_stack  to find these parameters quickly.
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Extended Logging With Syslog, Tcpdump and Netlog
The IGEL OS Registry offers a number of extended logging options that can help customers, Support and PreSales 
debug system and network issues.

For instructions on how to send log files to the IGEL support team via the UMS, see Sending Thin Client Log Files to 
IGEL Support (see page 497).

Debuglog Partition (see page 498)
Syslog (see page 500)
Tcpdump (see page 501)
Netlog (see page 504)
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Debuglog Partition
Logfiles can get very large quite fast. This is why they are stored in a separate partition. It is mounted at /

debuglog .

Enabling and Configuring the Debuglog Partition
The partition is enabled and configured in the Registry:

IGEL Setup > System > Registry

> Enable debuglog 
partition

debug.tools.log_partition.enabled enabled / disabled

Enables the debuglog partition.

IGEL Setup > System > Registry

> Size of debuglog 
partition in MiB

debug.tools.log_partition_size 50 ... 500 / 100

 

Debuglog Partition Contents

Depending on which logging options you enable (see the following topics), you may find the following files in the 
debuglog partition:

Syslog
messages  (the current syslog)

messages[1-9].gz  (compressed and rotated syslog)
Ethtool

netlog-ethtool-[device].log
Ping

netlog-host-[0-9]-ping.log  (ping log)

netlog-host-[0-9]-ping[n].log.gz  (compressed and rotated ping log)
Ifconfig

netlog-ifconfig-[device].log
Netstat

Resizing the debuglog partition will delete its contents!
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netlog-netstat.log  (netstat log)

netlog-netstat[n].log.gz  (compressed and rotated netstat log)
Socket Status

netlog-socket_status.log  (socket status log)

netlog-socket_status[n].log.gz  (compressed and rotated socket status log)
Tcpdump

tcpdump[0-3]_capture_current[n]  (tcpdump capture)

tcpdump[0-3]_capture-[n].pcap.{lzo,gz,bzip2,xz}  (compressed and 
rotated tcpdump captures)

Tcpdump triggered by an error
ERROR_[timestamp]/tcpdump[0-3]_capture-[n].pcap.

{lzo,gz,bzip2,xz}  (compressed and preserved tcpdump captures)
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Syslog
It is possible to send all syslog messages that are written to /var/log/message  (IGEL Linux version 5.10.250 
and versions 5.11.x) or to the systemd journal (IGEL Linux version 10.01.100) to the debuglog partition as well. The 
logfile will be rotated and compressed as needed. This preserves the log if the thin client crashes, and logs from 
several previous boots.

Configure it in the Registry:

IGEL Setup > System > Registry

> Enable syslog log to 
debuglog partition

debug.tools.syslog0.enabled true/ false

 

IGEL Setup > System > Registry

> Number of Rotate Files debug.tools.syslog0.num_rotate_files 2 ... 9

Number of files to be kept while rotating.

IGEL Setup > System > Registry

> Logfile rotate size in 
MiB

debug.tools.syslog0.rotate_size 2, 4 , 8, 16

Rotate when the size of the compressed file reaches this size in MiB.
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Tcpdump
Tcpdump will help you debug network issues by capturing packets from up to 4 individual network interfaces.

Find out more about Tcpdump from its homepage45.

IGEL Setup > Registry

> Resolve addresses/ports to 
names

debug.tools.tcpdump[0-3].

address_resolution

enabled / disabled

IGEL Setup > Registry

> Compression Method debug.tools.tcpdump[0-3].

compression

lzop, gzip, bzip2, xz

The compression method affects file size as well as system performance while compressing. The 
default lzop methiod is relatively light on the CPU.

IGEL Setup > Registry

> Interface for tcpdump 
logging

debug.tools.tcpdump[0-

3].interface

user editable string / eth0

IGEL Setup > Registry

> Number of Rotate Files debug.tools.tcpdump[0-3].num_rota

te_files

3 ... 10

Number of files to be kept while rotating.

IGEL Setup > Registry

Using the Netlog (see page 504) facility, it is possible to copy capture files to a subdirectory, triggered by an 
error in another log, so the captures before and after the error will be preserved for your analysis.



You can use Wireshark on an external system for analyzing capture files.

http://www.tcpdump.org
http://www.tcpdump.org
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> Only Log Package Headers debug.tools.tcpdump[0-3].

only_headers

enabled / disabled

IGEL Setup > Registry

> Enable promisc tcpdump 
logging

debug.tools.tcpdump[0-3]

.promisc

enabled / disabled

Enable promiscuous mode on the network interface to also capture packets not intended for 
this host.

IGEL Setup > Registry

> Logfile rotate size in MiB debug.tools.tcpdump[0-3

].rotate_size

10, 15 ,20 ,25 ,30 , 40

Rotate when the size of the uncompressed file reaches this size in MiB.

IGEL Setup > Registry

> Logfile rotate time in s debug.tools.tcpdump[0-3

].rotate_time

0 / user editable integer

Time in seconds after which the logfile is rotated and compressed. If set to 0 no time-based 
rotation happens.

IGEL Setup > Registry

> Additional Parameters for 
tcpdump

debug.tools.tcpdump[0-3]

.tcpdump_additional_param

eters

user editable string

Use with care.

IGEL Setup > Registry

> Enable tcpdump debug.tools.tcpdump[0-3].tc

pdump_enabled

enabled / disabled

IGEL Setup > Registry

> tcpdump filter expression debug.tools.tcpdump[0-3

].tcpdump_filter

user editable string
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Tcpdump filter expression. For the expression syntax, see the pcap-filter(7)46 manpage.

http://www.tcpdump.org/manpages/pcap-filter.7.html
http://www.tcpdump.org/manpages/pcap-filter.7.html
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Netlog
The netlog facility combines the following network diagnosis tools:

ethtool

ifconfig

netstat

ping

ss  (socket status)

It can also trigger tcpdump .

IGEL Setup > Registry

> Enable netlog logging debug.tools.netlog.enabled enabled / disabled

IGEL Setup > Registry

> period between netlog logs in 
s

debug.tools.netlog.period 1, 5, 10, 20, 30, 60, 120

Ping logging is not affected by this and uses its own timing.

Ethtool (see page 505)
Ifconfig (see page 506)
Netstat (see page 507)
Ping (see page 508)
Socket Status (ss) (see page 510)
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Ethtool
Ethtool is the standard Linux utility for getting diagnostic information about wired Ethernet devices and their 
drivers.

IGEL Setup > Registry

> Disable ethtool logging debug.tools.netlog.ethtool.disabled true / false

By default Ethtool logging is included in Netlog logging. However, you can disable it here.

IGEL Setup > Registry

> Log only if ethtool 
output changes

debug.tools.netlog.ethtool.log_on_changes
_only

true / false

Log only if ethtool output changes (on bootup there will always be at least one log entry)

IGEL Setup > Registry

> Number of Rotate Files debug.tools.netlog.ethtool.num_rotate_files 2 ... 4

Keep up to this number of rotated files (also compressed), the current log not included 
(which is limited to 600 lines)

IGEL Setup > Registry

> Logfile rotate size in 
MiB

debug.tools.netlog.ethtool.rotate_size 2, 4, 6

Rotate when the size of the uncompressed file reaches this size in MiB.
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Ifconfig

Ifconfig

Apart from configuring network devices, ifconfig also gives diagnostic information such as RX bytes, TX bytes and 
dropped packets.

IGEL Setup >

> Disable ifconfig logging debug.tools.netlog.ifconfig.disabled true / false

By default Ifconfig logging is included in Netlog logging. However, you can disable it here.

IGEL Setup >

> Log only if ifconfig 
output changes

debug.tools.netlog.ifconfig.log_on_changes
_only

no,error_counter,al
l

no: log on every netlog run
error_counter: log only if an error counter or the address changes
all: log on every change of ifconfig output

IGEL Setup >

> Number of Rotate files debug.tools.netlog.ifconfig.num_rotate_files 2 ... 4

Keep up to this number of rotated files (also compressed), the current log not included 
(which is limited to 600 lines).

IGEL Setup >

> Logfile rotate size in 
MiB

debug.tools.netlog.ifconfig.rotate_size 2, 4, 6

Rotate when the size of the uncompressed file reaches this size in MiB.

IGEL Setup >

> Trigger tcpdump log debug.tools.netlog.ifconfig.trigger_tcpdump
_save

true / false

Trigger the saving of tcpdump logs if an error counter increases or if the IP address changes.
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Netstat
Netstat displays a variety of network statistics for the local machine.

> Disable netstat logging debug.tools.netlog.netstat.disabled true / false

By default netstat -s  logging is included in Netlog logging. However, you can disable 
it here.

> Number of Rotate files debug.tools.netlog.netstat.num_rotate_file
s

2 ... 4

Keep up to this number of rotated files (also compressed), the current log not included 
(which is limited to 600 lines).

>Logfile rotate size in 
MiB

debug.tools.netlog.netstat.rotate_size 2, 4, 6

Rotate when the size of the uncompressed file reaches this size in MiB.

>Log only if triggered debug.tools.netlog.netstat.trigger_log net_error_changes, 
net_changes, 
ifconfig_changes, 
ethtool_changes, 
no_trigger

net_error_changes: log if ethtool output changes or ifconfig error counter or address 
changes
net_changes: log if ethtool or ifconfig output changes
ifconfig_changes: log if ifconfig output changes
ethtool_changes: log if ethtool output changes
no_trigger: log on every netlog run
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Ping

IGEL Setup >

> Enable ping check debug.tools.netlog.ping_host[0-9].enabled true / false

 

IGEL Setup >

> Log only if ping fails debug.tools.netlog.ping_host[0-9].log_only_o
n_error

true / false

Log only if any one of the configures pings [0-9 fails.]

IGEL Setup >

> Number of Rotate Files debug.tools.netlog.ping_host[0-9].num_rotate
_files

2 ... 4

Keep up to this number of rotated files (also compressed), the current log not included 
(which is limited to 600 lines).

IGEL Setup >

> Logfile rotate size in 
MiB

debug.tools.netlog.ping_host0.rotate_size 2 ... 4

Rotate when the size of the uncompressed file reaches this size in MiB.

IGEL Setup >

> Trigger tcpdump save debug.tools.netlog.ping_host0.trigger_tcpdum
p_save

2 ... 4

Trigger the saving of tcpdump logs if an error counter increases or if the IP address changes.

IGEL Setup >

> Ping target debug.tools.netlog.ping_host0.ping_target user-editable 
string

Target IP/hostname to ping (if none is given ping will be considered as disabled!)

IGEL Setup >

> Time between pings debug.tools.netlog.ping_host0.ping_time 1, 5, 10, 30, 60, 
120

Time between pings in seconds.
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IGEL Setup >

> Type of ping debug.tools.netlog.ping_host0.type icmp, http 
request, https 
request

icmp: use normal ping  command

http request: send an http request (fails if no  HTTP/*.* * OK  answer is received)

https request: send an https request (fails if no CONNECTED  is returned by openssl)
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Socket Status (ss)

Socket Status (ss)

IGEL Setup >

> Disable socket status 
Logging

debug.tools.netlog.socket_status.disabled true / false

By default socket_status logging is included in Netlog logging. However, you can disable it 
here.

IGEL Setup >

> Number of Rotate Files debug.tools.netlog.socket_status.num_rotate
_files

true / false

Keep up to this number of rotated files (also compressed), the current log not included 
(which is limited to 600 lines).

IGEL Setup >

> Logfile rotate size in 
MiB

debug.tools.netlog.socket_status.rotate_size true / false

Rotate when the size of the uncompressed file reaches this size in MiB.

IGEL Setup >

> Log only if triggered debug.tools.netlog.socket_status.trigger_log ping_errors, 
no_trigger

ping_errors: log only if ping test fails
no_trigger: log on every netlog run
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Making a Telnet Connection from IGEL Linux

Issue
You want to connect to a Telnet service and can't find a Telnet command on the device.

Solution
Using Ericom Powerterm (Requires the Ericom Powerterm Firmware Feature):

In Setup, go to Sessions > PowerTerm Terminal Emulation > PowerTerm Sessions.
Create a new session.
Edit the session.
Under Connection, make the following settings:

Select TELNET as Session Type.
Enter an IP adress or a name in Host Name.
If you want to use a graphical login dialog, activate Enable Login Dialog.

Under Desktop Integration enter a Session Name and enable the desired Starting Methods for 
the Session.
Click Apply to save your settings or OK to save and exit.
Start the new session and enter your username and password.
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Configuring Dynamic DNS Updates via DDNS

Issue:

You want to register a device's IP address with your DNS server.

You are not using DHCP.

Solution:

Use the DDNS tools contained in IGEL Linux, which can be configured by Setup.

Distribute your nameserver's shared TSIG key with the UMS:

Create a New File.
Set the Device Storage Path to /wfs/ddns .
Enable Read permission for the Owner and disable all other permissions.
Set the Owner to Root.

Set up Dynamic DNS Registration:

Go to Network > LAN Interfaces in Setup.
Enable Specify an IP Address.
Enter an IP Address and Network Mask.
Enter a Terminal Name.
Check Enable DNS.
Enter a Default Domain.
Enter at least one Nameserver IP address.
Enable Dynamic DNS Registration.
Select DNS as Dynamic DNS Registration Method.
If the nameserver expects a TSIG key: Select the TSIG key file.
Otherwise, leave the input field blank.
Click Apply or OK to confirm your settings.

This only works for BIND9 or other nameservers supporting TSIG, not for Microsoft Active Directory servers.
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4.

Changing the SMB protocol version
Depending on which Windows (Samba) server you are using, you will need a specific SMB protocol version.

IGEL Linux version 10.04.100 and higher offer several SMB protocol versions.

To change the version setting:

In the IGEL Setup go to System > Registry.
Go to parameter network.smbmount.smb_version .
Select the apropriate SMB protocol version.
Possible options:

1.0
2.0
2.1
3.0

Click Save or Apply and send to thin client.
The windows shares are configurable at IGEL Setup > Network > Network Drives > Windows 
Drive.

Due to security reasons, Microsoft recommends to disable SMB version 1.0 support on Windows ,so you 
need to switch to at least version 2.0 to be further able to access systems with disabled SMBV1.


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How to Launch the Wireless Manager within IGEL OS when the Taskbar Is 
Hidden

Problem
The taskbar or system tray has been disabled for some reason (User Interface > Desktop > Taskbar / Taskbar 
Items; also User Interface > Screenlock /Screensaver > Taskbar). As a result, a systray icon for the Wireless 
Manager can't be accessed anymore, and the user can't manage wireless networks. 

Environment
IGEL OS 10.06 or higher

Solution
You can configure the Wireless Manager as a custom application and define the way it can be launched.

Go to Network > LAN Interfaces > Wireless and check that the wireless interface and the Wireless 
Manager are enabled.
Go to System > Firmware Customization > Custom Application and click  .
Specify the Session name and configure the Starting methods according to your needs.
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4.

5.

Under Settings, specify the Icon name and enter the following Command: /bin/start-

wireless-manager

Click Apply or OK.
The Wireless Manager can now be launched via the configured starting methods.
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Security
Securing IGEL OS Endpoints (see page 518)
Secure Shell (SSH) Access to IGEL OS with Keys (see page 560)
Secure Terminal (Telnet with TLS/SSL) (see page 566)
Secure Shadowing (VNC with TLS/SSL) (see page 567)
Cherry eGK Channel Substitution (see page 571)
Single Sign-on for the Browser Proxy (see page 573)
Limiting the Number of Permitted Login Attempts (see page 576)
How to Deploy Device Encryption (see page 577)
Security: Timeout for Secure Shadowing and Secure Terminal (see page 581)
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Securing IGEL OS Endpoints
This document describes settings for IGEL OS that will increase security.

It applies to the following types of devices:

IGEL UD devices
Devices which are temporarily converted by UD Pocket
Devices which are permanently converted by IGEL OS Creator (OSC)

Introduction (see page 519)
Setting Passwords (see page 520)
Keeping the System Up-To-Date (see page 527)
Disabling Access to Components (see page 532)
Minimizing the Attack Surface (see page 537)
Configuring Remote Access and Management (see page 548)
Wi-Fi and Bluetooth (see page 556)
Using UD Pocket for BYOD Devices (see page 559)
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Introduction
This document describes various settings to make IGEL OS more secure. In general, the more of these settings you 
apply, the better device security will be. However, it is up to you to strike a balance between security and enabling 
your users to do their work. Some settings may even be inappropriate for your use case, e.g. if you use Bluetooth 
peripherals, it does not make sense to disable Bluetooth.

In order to configure multiple devices, put the relevant settings into a Universal Management Suite (UMS) master 
profile, which you can assign to any number of devices. For more information, see Master Profiles.
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Setting Passwords
You can restrict access to various system components by setting passwords.

Setting Local Passwords (see page 521)
Password-Protecting Sessions and Accessories (see page 522)
Using Screenlock (see page 523)
Do Not Save Session Passwords (see page 524)
Setting a UEFI Password (see page 525)
Using Two-Factor Authentication (2FA) (see page 526)
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1.
2.
3.
4.

5.

Setting Local Passwords

Rationale

Passwords protect the system against local changes. They restrict access to the Local Terminal, Setup, and to the 
rescue shells on the virtual consoles. The administrator password is also needed to reset the system to factory 
defaults.

These passwords are saved in a way (salted and hashed) that prevents them from being recovered from the local 
storage.

By default, no passwords are set on IGEL OS. Set at least an administrator password:

Instructions

In IGEL Setup go to Security > Password.
In the Administrator area, check Use Password.
Enter a password twice when prompted.
Optional: If you want to grant unprivileged user access to IGEL Setup check Use Password in the 
Setup user area and enter a password twice when prompted.
Click Apply.

For configuration of the User Account for Remote Access, see Using Secure SSH Settings (see page 554).

Find further information in the IGEL OS manual under Password - Restrict Access to IGEL OS Components.
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3.

Password-Protecting Sessions and Accessories

Rationale

Sessions can be used to access corporate resources, while the accessories in IGEL OS can be used to make changes 
to the local system. If you do not want to disable certain sessions or accessories completely, you can set passwords 
to restrict access to them.

Instructions

By default, sessions do not have passwords set. In IGEL Setup, you can set a password on the Desktop 
Integration page of a session or accessory.

To enable password protection:

In the Setup, go to the relevant Desktop Integration page. The path has the following 
pattern: Sessions > [session type] > [session name] > Desktop Integration.
For accessories, go to Accessories > [accessory name].
Set Password Protection to

Administrator to require the Administrator password, or
User to require the User password, or
Setup User to require the Setup User password.

Click Apply.
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Using Screenlock

Rationale

Leaving a screen unlocked enables attackers to access the system with the logged-in user's privileges. Manual or 
automatic locking the screen with a password prevents such access.

Instructions for Enabling Manual Locking

By default, there is no way for the user to manually lock the screen. To enable manual locking, follow these steps:

In the Setup, go to User Interface > Screenlock / Screensaver.
Do one or both of the following:

Activate the Quick start panel starting method to give the user a button for locking the 
screen manually.
Activate Use hotkey and set a combination of keys that lets the user lock the screen 
manually, e.g. [Ctrl+Shift+L].

Click Apply.

Instructions for Automatic Locking

By default, the screensaver is started automatically after 5 minutes, but the screen is not locked with a password. 
To enable locking, follow these instructions:

Go to User Interface > User Interface > Screenlock / Screensaver > Options.
Activate Start automatically.
Set the Timeout, i.e. the number of minutes of user inactivity before the screensaver starts 
automatically.
As a password, select User password (see Setting Local Passwords (see page 520)) or a separate 
Screenlock password (and set one).
If applicable, activate Allow administrator password to allow the administrator to unlock the 
screen.
Click Apply.
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Do Not Save Session Passwords

Rationale

Passwords for sessions should not be stored on the endpoint device.

Instructions

 When configuring a session, on the login page, leave the Password field empty. The user will then be prompted 
interactively for the password.

 Wherever possible use Two-Factor Authentication (2FA) (see page 526).
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Setting a UEFI Password

Rationale

In the UEFI settings you can modify very fundamental system properties, e.g. disable booting from USB. Access to 
these settings should be protected by a password.

Instructions for IGEL Devices

 If UEFI is not enabled, see the instructions under UEFI Secure Boot Enabling Guides.

By default no UEFI password is set on IGEL UD devices. To set a password, do the following:

Hold down the [Del] key ([F2] key for UD2) while booting.
The UEFI menu opens.
Using the arrow and return keys, go to SCU.
The Setup Utility opens.
Using the arrow and return keys, go to Security.
Use the arrow keys to select Set Supervisor Password.
Hit [Return].
Enter the desired UEFI password and hit [Return]
Enter the same UEFI password again and hit [Return] twice.
Hit [F10] in order to save and exit.
Confirm Exit Saving Changes? by hitting [Return].
The system boots, and the UEFI settings are now password-protected.

Instructions for 3rd-Party Devices Converted with OS Creator (OSC)

 Refer to the instructions of your BIOS/UEFI vendor.

Alternatively, try pressing [F12] (in general), [F10] (Intel devices), or [F9] (Hewlett-Packard devices) to 
access the BIOS/UEFI settings. If this does not work, try pressing [Del], [F1], or [F2] during booting.


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Using Two-Factor Authentication (2FA)

Rationale

Two-factor authentication (2FA) combines two different factors to prove the user's identity, often a hardware device 
such as smartcard or smart token and a password or PIN. This improves protection against impostors, as they 
would have to gain both possession of the hardware device and knowledge of the password or PIN.

Instructions

Use two-factor authentication with a smartcard or smart token where possible. IGEL OS supports this for the 
following sessions:

Smartcard authentication for sessions
Citrix Storefront (see page 638)
RDP Sessions (see page 640)
Horizon Sessions (see page 641)
Web browser (see page 642)

(Kerberos) Passthrough Authentication (see page 982)
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Keeping the System Up-To-Date

Rationale
Software updates fix newly discovered vulnerabilities in IGEL OS and applications. This means that keeping up with 
updates is one of the most important measures in securing IGEL OS systems.

To start and configure updates, you can use IGEL Setup and/or the Universal Firmware Update feature of the 
Universal Management Suite (UMS).

The instructions described on this page use the Universal Firmware Update feature of the UMS. For defining a 
scheduled job, see the section "As a Job" in Assigning Updates; for configuring the update on a device, see 
Firmware Update. 

Instructions

 To be notified of security-critical IGEL OS updates and to receive the IGEL Technical Newsletter, subscribe to 
IGEL communications on www.igel.com47.

The upgrade procedure consists of the following steps:

Getting the update from the IGEL download server
Testing the update on one or a few devices
Rolling out the update on all devices

Getting the Update from the IGEL Download Server

In the UMS Console, go to Universal Firmware Update, open the context menu, and select Check 
for new firmware updates.

http://www.igel.com/
http://www.igel.com/
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2. Activate the firmware you want to download and click Download.

The current status of the firmware download is shown.
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3.

4.

Click Ok.

When the download has succeeded, the firmware is registered and stored in the UMS.
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Testing the Update on One or a Few Devices

 In the UMS Console, go to Universal Firmware Update, select the desired firmware and drag and 
drop it on the test device or on the folder containing the test devices.

In the Update time dialog, select Now and click Ok.

The firmware is updated on the devices; during the update process, the devices reboot.

Rolling out the Update on All Devices

You can either start the update immediately or use a scheduled job to start it at a defined time.

To start the update immediately:
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In the UMS Console, go to Universal Firmware Update, select the desired firmware and drag and 
drop it on the folder containing the devices that are to be updated.

In the Update time dialog, select Now and click Ok.

The firmware is updated on the devices; during the update process, the devices reboot.
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Disabling Access to Components
You can hide IGEL OS components from the user that could be used to make changes to the system.

Disabling Local Terminal Access (see page 533)
Disabling Virtual Console Access (see page 534)
Using Appliance Mode (see page 535)
Hiding Unused Accessories (see page 536)
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Disabling Local Terminal Access

Rationale

The Local Terminal accessory allows the user to execute commands or make changes to the system. By default, the 
local terminal is disabled, that is, no local terminal session is configured. To enhance security, you should do one of 
the following:

Leave the local terminal disabled
If a local terminal session is configured, but not needed, disable it.
If a local terminal session is needed, password-protect it. 

Instructions

To remove an existing local terminal session:

In IGEL Setup, go to Accessories > Terminals.
Select a local terminal session you want to delete.
Click  to remove the selected session.
When prompted, confirm that you want to delete the session.
Click Apply.

Alternatively, you can password-protect the terminals.

To password-protect the local terminal:

Find the local terminal session under Accessories > Terminals.
Follow the instructions under Password-Protecting Sessions and Accessories (see page 522).
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Disabling Virtual Console Access

Rationale

The virtual consoles tty11  and tty12  give the user access to a shell. Disabling these makes it more diffcult to 
execute commands or make changes to the system.

Instructions

By default, the user can access the virtual consoles with the [Ctrl]+[Alt]+[F11] and [Ctrl]+[Alt]+[F12] keyboard 
commands. To disable access, do the following:

In IGEL Setup go to User Interface > Display > Access Control
Activate Disable Console switching (Default: Console switching enabled)
Click Apply.
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Using Appliance Mode

Rationale

By default, IGEL OS users are not presented with a full-screen remote session, but have access to the desktop and to 
the start menu. On the contrary, in the appliance mode, a single predefined session is presented full-screen to the 
user. As access to other applications is prevented, this reduces the system's potential exposure to attack.

Instructions

The appliance mode is available for the following session types:

VMware Horizon
Browser
Citrix Self-Service
RHEV/Spice
Imprivata
RDP MultiPoint Server
XDMCP for This Display

To enable the appliance mode for a session, proceed as follows:

In IGEL Setup, go to Sessions > Appliance Mode.
Pick the session and configure it according to the manual chapter Appliance Mode.

You can combine most of the appliance mode sessions with Two-factor Authentication (see page 526) for 
increased security.


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Hiding Unused Accessories

Rationale

Accessories can be used to make changes to the system. Restricting access to these accessories helps to keep the 
system secure.

Instructions

To hide individual accessories (both in the start menu and the Application Launcher):

In IGEL Setup go to Accessories > [accessory name].
Disable all Starting Methods for Session.
Click Apply.

To password-protect an accessory:

 Follow the instructions under Password-Protecting Sessions and Accessories (see page 522).

To hide the complete System icon of the start menu:

In IGEL Setup go to User Interface > Desktop > Start Menu.
Deactivate System tab.
Click Apply.

To hide the complete Application Launcher's System icon:

In IGEL Setup go to Accessories > Application Launcher > Application Launcher Configuration.
Activate Hide system page.
Click Apply.



Security

IGEL OS Articles   537 / 1017

•
•
•
•
•
•
•
•
•
•

Minimizing the Attack Surface
Removing unused features and disabling unneeded network services reduces the parts of the system that can be 
attacked.

Removing the Local Web Browser (see page 538)
Configuring the Browser (Kiosk Mode) (see page 539)
Disabling Java in the Browser (see page 540)
Disabling the PC/SC Daemon (see page 541)
Disabling X Server TCP Connections (see page 542)
Removing Unused Features (see page 543)
Disabling Storage Hotplug (see page 544)
Using USB Device Control (see page 545)
Disabling USB Boot (see page 546)
Leveraging AppArmor (see page 547)
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Removing the Local Web Browser

Rationale

The local web browser may expose vulnerabilities to the internet and can be an entry point for malware. If the 
browser is not needed, it is safer to remove it.

Instructions

By default, IGEL OS has a local web browser (Firefox) installed, even if no web browser session is configured. To 
remove the browser:

In the IGEL Setup go to System > Firmware Customization > Features.
Uncheck the Local Browser (Firefox) feature.
Click Apply.
Reboot the device.

Do not remove the local web browser if you use Citrix StoreFront sessions.
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Configuring the Browser (Kiosk Mode)

Rationale

If you want to offer a local web browser, there are some settings that improve its security. Additionally, these 
settings add up to a kiosk mode, hiding the rest of IGEL OS from the user.

Instructions

By default, the web browser makes all of its features and menus available. To achieve a restricted 'kiosk' mode, 
follow these instructions:

In the IGEL Setup, under Sessions > Browser > Browser Global > Security, activate the following 
options:

Safe Browsing
Malware Protection

Under Sessions > Browser > Browser Global > Restart, activate Restart.
Under Sessions > Browser > Browser Global > Window, activate the following options:

Start in fullscreen mode
Hide local filesystem
Hide configuration page of the browser

Under Sessions > Browser > Browser Global > Menus & Toolbars, activate Hide App Menu/Menu 
Bar.
Under Sessions > Browser > Browser Global > Context, activate Hide the browser's context 
menu.
Under Sessions > Browser > Browser Sessions > [session name] > Settings, activate Autostart.
Click Apply.
Reboot the device.
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Disabling Java in the Browser
Java Applets and Java Web Start may constitute a potential security threat and are now regarded as deprecated. As 
of IGEL OS version 10.06.100, they are no longer included in IGEL OS. The registry keys under System > Registry > 
java > deployment are obsolete.
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Disabling the PC/SC Daemon

Rationale

Unless you are running smartcard readers that use it, you can disable the PC/SC daemon. Running fewer daemons 
reduces the attack surface.

Instructions

To deactivate the PC/SC daemon:

In the IGEL Setup go to Security > Smartcard > Services.
Deactivate Activate PC/SC Daemon.
Click Apply.
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Disabling X Server TCP Connections

Rationale

The X graphics server in IGEL OS has network functionality that could allow others to see your screen and read 
keyboard input. Leave it disabled to keep your data confidential.

Instructions

By default the network functionality of the X server is disabled. To disable it again at a later time, do the following:

In IGEL Setup go to User Interface > Display > Access Control
Make sure that Access Control is activated. 
Make sure that Disable TCP connections is activated.
Click Apply.
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Removing Unused Features

Rationale

Reducing the amount of software running on a system reduces its attack surface. Therefore a basic security 
measure for IGEL OS 11 is to remove all unused features.

Instructions

To disable a feature:

In the IGEL Setup go to System > Firmware Customization > Features.
Deactivate all the features that you do not intend to use.
If you do not use local printers on the endpoint device that you want to share with others, activate:

Printing (Internet Printing Protocol CUPS)
Printing (Line Printer LPD)
Printing (TCP/IP)
Printing (ThinPrint)

Click Apply.
Reboot the device.

Do not remove the Custom Partition feature if you have a custom partition that contains 
software or data for which you have no backup copy. After disabling the feature and a 
reboot the contents of the custom partition will be lost.



Do not remove Fluendo Gstreamer Codec Plugins or Hardware Video Acceleration if 
you use sessions that make use of these features.


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Disabling Storage Hotplug

Rationale

Removable USB media can be used to steal data or to execute unauthorized software or even malware on the 
device.

Instructions

Storage hotplug is disabled by default. Should you want to disable it again at any later point, follow these 
instructions:

In IGEL Setup go to Devices > Storage Devices > Storage Hotplug.
Deactivate Storage Hotplug.
Click Apply.
Storage devices are no longer automatically mounted when they are plugged in.
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Using USB Device Control

Rationale

USB devices such as pen drives, wireless controllers, or printers can be used to steal data or to execute 
unauthorized software or even malware. Deactivating as many USB device classes as possible increases security.

Instructions

To enable and configure USB access control:

In IGEL Setup, go to Devices > USB Access Control.
Check Enable.

Set Default rule to Deny.
In combination with the preconfigured rule that allows Human Interface Devices (HID), no USB 
devices apart from e.g. mouse and keyboard are allowed.
Configure further rules as needed. For instructions, see How to Configure USB Access Control (see 
page 936).
Click Apply.
Reboot the device.

The activation of USB Access Control and setting the Default rule to Deny will block the use of 
USB devices locally and in the session and, thus, might disable devices needed for the users. 
Therefore, activate the USB access control only if your security policy requires that. In this case, set 
Default rule to Deny and configure Allow rules for the required USB devices and USB device 
classes. 
It is recommended to make settings for USB Access Control as the last step in the device 
configuration. Before activating the USB access control, check that all your other settings for 
printers, Unified Communication, USB redirections, mapping settings for USB devices are working 
as expected.
Note that the USB access control is completely separate than USB redirection for remote sessions, 
see When to Use USB Redirection (see page 932).
Take also notice that the feature does not disable a USB port physically, i.e. power delivery will still 
work.


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Disabling USB Boot

Rationale

Disabling USB ´boot prevents booting another operating system, which could be used to manipulate or (even 
accidentally) overwrite IGEL OS on mass storage.

Instructions for IGEL Devices

USB boot is disabled in the factory settings on IGEL UD LX devices. If it has been enabled and you want to disable it 
again, follow the instructions given here:

Hold down the [Del] key ([F2] key for UD2) while the system is booting.
The UEFI menu opens.
Use the arrow and return keys to go to SCU.
Enter the UEFI password if one is set.
The Setup Utility opens.
Go to Boot.
Set USB Boot to Disabled.
Press [F10].
Confirm Exit Saving Changes?
The device boots.

Instructions for 3rd-Party Devices Converted with OSC

 Refer to the instructions of your BIOS/UEFI vendor.

Additionally, set a UEFI Password (see page 525) so the boot settings cannot be changed 
back.



Alternatively, try pressing [F12] (in general), [F10] (Intel devices), or [F9] (Hewlett-Packard devices) to 
access the BIOS/UEFI settings. If this does not work, try pressing [Del], [F1], or [F2] during booting.


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Leveraging AppArmor
AppArmor controls which privileges should be granted to an application that is running on the system. This way 
even vulnerabilities that are yet unknown can be mitigated. 

The following applications are guarded by AppArmor:

Firefox browser
Cups print server
Evince pdf viewer

The following system programs are guarded by AppArmor:

tcpdump
haveged
dhclient

By default, AppArmor is enabled. They registry key is  system.security.apparmor
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Configuring Remote Access and Management
Remote management via UMS and remote access are powerful features of IGEL OS. Select secure settings and 
disable what you do not use.

Tying Endpoints to Your UMS instance (see page 549)
Disabling Shadowing (see page 550)
Using Secure VNC Settings (see page 551)
Disabling SSH Access (see page 552)
Disabling X11 Forwarding (see page 553)
Using Secure SSH Settings (see page 554)
Disabling Secure Terminal (see page 555)
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Tying Endpoints to Your UMS instance

Rationale

Devices that have remote management enabled but are not yet tied to a UMS instance can be taken over by an 
attacker's UMS. Make sure to register all IGEL devices on your network.

Instructions

By default, remote management is enabled on IGEL OS devices. Use automatic registration to catch all devices in 
your corporate network:

Assign the DNS entry igelrmserver  to the UMS host. For further instructions, see Registering 
Devices Automatically on the IGEL UMS.
In the UMS console go to UMS Administration > Global Configuration > Device Network 
Settings.
Activate Enable automatic registration (without mac address import)
Now all new IGEL devices, UD Pockets and devices converted with OSC that are booting up in the 
network will automatically register with your UMS instance.
Optionally, put newly registered devices into a quarantine directory automatically with UMS 
Default Directory Rules.
Optionally, assign a Master Profile to this directory, thereby enforcing secure settings, e.g. a local 
administrator password.

Alternatively you can disable remote management in the local IGEL Setup under System > 
Remote management. Of course this means losing one of the most powerful features of 
IGEL OS. However, this may be an option for particular devices.


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Disabling Shadowing

Rationale

Shadowing is made possible by a VNC server on IGEL OS, which is a network service. Reducing the number of 
running network services reduces the system's attack surface.

Instructions

By default, Shadowing is not active on IGEL OS. However, if you want to disable it at any time, follow these steps:

In the IGEL Setup go to System > Remote Access > Shadow
Deactivate Allow Remote Shadowing.
Click Apply.
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3.

Using Secure VNC Settings

Rationale

If you intend to use shadowing on IGEL OS, there are a number of options that can make it more secure.

Instructions

By default, Shadowing does not use encrypted network transport or a password. To activate these security features, 
do the following:

In IGEL Setup go to System > Remote Access > Shadow.
Make as many of the following settings as possible for your use case. Each setting improves 
security, and often also privacy:

Enable Secure Mode.
Enable Use Password and set a strong password (not needed in Secure Mode). The 
maximum length for this password is 8 characters.
Enable Prompt User to allow Remote Session.
Enable Allow User to disconnect Remote Shadowing.
Disable Allow Input from Remote.

Click Apply.

Secure mode for shadowing can be enabled globally in UMS under UMS Administration > 
Global Configuration > Remote Access. There you can also enable the logging of users 
who have used secure mode shadowing .


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Disabling SSH Access

Rationale

The SSH server on IGEL OS is a network service. Reducing the number of running network services reduces the 
system's attack surface. Even more so in this case, as SSH by design enables a remote user to execute commands 
on the system.

Instructions

By default, the SSH server is running on IGEL OS. To deactivate it, follow these steps:

In IGEL Setup go to System > Remote Access > SSH Access.
Deactivate Enable.
Click Apply.
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Disabling X11 Forwarding
 When X11 forwarding is disabled, graphic applications cannot be run over SSH. By default, X11 forwarding is 
disabled.

To ensure that X11 forwarding is disabled:

In the Setup, go to System > Remote Access > SSH Access and make sure that Permit X11 
forwarding is deactivated.
Click Apply or Ok.

If X11 forwarding is disabled, it is not possible to launch the IGEL Setup from an SSH session.
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Using Secure SSH Settings

Rationale

If you intend to allow SSH connections to IGEL OS, there are a number of options that can make these more secure.

Instructions

To secure the SSH settings of your devices, make as many of the following settings as possible for your use case

In IGEL Setup go to System > Remote Access > SSH.
Deactivate Permit empty passwords.
Deactivate Permit administrator login.
Deny User access for user , who can execute any command with regular user privileges.

Allow User access for ruser , whose access is restricted by the list Applications access for 
remote user 'ruser'.
Where needed, edit the list Applications access for remote user 'ruser'. It defines the commands 
that ruser  can run from remote. By default, a local shell ( localshell ) and IGEL Setup ( /

config/sessions/setup0 ) are allowed.
Click Apply.
Go to Security > Password, under User Account for Remote Access activate Use Password and 
set a password
Click Apply.
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Disabling Secure Terminal

Rationale

The secure terminal server on IGEL OS is a network service, providing a TLS/SSL-encrypted Telnet session. Reducing 
the number of running network services reduces the system's attack surface. Even more so in this case, as the 
secure terminal by design enables a remote user to execute commands on the system.

Instructions

By default, the secure terminal is not active. Should you want to deactivate it at any time, do the following:

In IGEL Setup go to System > Remote Access > Secure Terminal
Deactivate Secure Terminal.
Click Apply.

Secure Terminal can be enabled globally in the UMS under UMS Administration > Global 
Configuration > Remote Access. There you can also enable the logging of users of the 
secure terminal.


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Wi-Fi and Bluetooth
Rogue or unencrypted Wi-Fi access points can put your data at risk, as can Bluetooth devices. If your device has Wi-
Fi and Bluetooth, make sure to configure them securely or disable them.

Restricting Wi-Fi Access (see page 557)
Disabling Bluetooth (see page 558)
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2.
3.

4.
5.
6.
7.
8.
9.

10.

Restricting Wi-Fi Access

Rationale

Using an unencrypted Wi-Fi network or falling for a rogue access point puts your users' data at risk. Enable strong 
encryption and restrict Wi-Fi access to a default network and optionally employ a whitelist of additional networks in 
order to prevent this.

Instructions

By default, Wi-Fi is not activated on IGEL OS. To activate it and preconfigure one or more allowed networks, follow 
these instructions:

In IGEL Setup go to Network > LAN Interface > Wireless.
Activate Activate Wireless Interface.
Do not activate Enable wireless manager, as this would give the user free choice of Wi-Fi 
networks.
Click Apply.
Go to Network > LAN Interface > Wireless > Default Wi-Fi network.
Check Enable WPA Encryption.
Enter the Wireless network name (SSID).
Make authentication and encryption settings, see Default Wi-Fi Network in the IGEL OS Manual.
Click Apply.
If needed, add further networks under Network > LAN Interface > Wireless > Additional Wi-Fi 
networks.
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1.
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3.

Disabling Bluetooth

Rationale

If your device has a Bluetooth interface it may be used to access data. Disabling the interface reduces the risk of 
data theft.

Instructions

By default Bluetooth is deactivated on IGEL OS. Should you want to disable it at any time, do the following:

In the IGEL Setup go to Devices > Bluetooth.
Decativate Bluetooth.
Click Apply.
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Using UD Pocket for BYOD Devices

Rationale
Letting users access company resources with their own devices (BYOD) and software poses a security risk: These 
systems may have insecure configurations or even contain malware. In addition, company data should not be saved 
on users' private devices.

Instructions

 Use the IGEL UD Pocket. This ensures the use of secure and trusted software. As the UD Pocket does not access 
the device's mass storage, company data and private data will remain separated.

For details on the IGEL UD Pocket, see UD Pocket (UDP) Reference Manual.

For how to select the UD Pocket during the boot procedure, see Boot Settings and Starting Your UD Pocket.



Security

IGEL OS Articles   560 / 1017

•
•
•

Secure Shell (SSH) Access to IGEL OS with Keys
IGEL OS has a built-in OpenSSH server that can be activated and configured via the Setup application. It lets you 
connect securely to the device over the network in order to issue commands or transfer files. While authentication 
can be done with a username-password combination, using a private-public key pair can increase convenience 
and/or security. This document describes how to generate and distribute the keys required.

Generating the SSH Key Pair (see page 561)
Distributing the Public Key with UMS (see page 563)
Configuring SSH Access on the Device (see page 565)
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1.

2.

3.
•

•
4.

•

•

Generating the SSH Key Pair

Prerequisites

Linux/Unix operating system, typically on the administrator's workstation
OpenSSH client software installed

Introduction
The following procedure will generate two keys:

Public key: This key is distributed to all machines the administrator wants to connect to. It can be 
made public.
Private key: This key stays on the administrator's machine and has to be kept secret.

An easily understandable explanation of private and public keys can be found in a blog post by the 
programmer Blake Smith48.

Generating the Key Pair

Open a terminal session on your workstation as the user who is going to make the SSH 
connections to the devices.
Issue the following command:
ssh-keygen

When prompted for the location to store the key pair in, you can:
Hit return, which will accept the default file name ~/.ssh/id_rsa

Enter an absolute file path and key file name of your choice .
When prompted for a passphrase, you can

Enter a passphrase (twice)

Hit return in order to use no passphrase.

For the confidentiality of the encrypted connection to devices, it is essential to keep the 
private key secret.



Using the default name may overwrite existing SSH key pairs!

A passphrase protects the private key file in case it gets into the hands of an attacker. On 
the other hand, it may be inconvenient to enter the passphrase for every connection.



http://blakesmith.me/2010/02/08/understanding-public-key-private-key-concepts.html
http://blakesmith.me/2010/02/08/understanding-public-key-private-key-concepts.html


Security

IGEL OS Articles   562 / 1017

•

•

Two files have been generated (default names):
id_rsa  - the private key file

id_rsa.pub  - the public key file

This increases convenience because you will be able to log in without entering the 
passphrase. However, it weakens security: The private key file will be unprotected if it gets 
into the hands of an attacker.


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1.
2.
3.

4.
5.
6.
7.
8.

Distributing the Public Key with UMS
In UMS Console, right-click on Files in the navigation tree.
Select New File.
Upload the public key file ( *.pub ) as a Local File.

Set the Classification to Undefined.
Specify the Thin Client file location as /wfs/user/.ssh/authorized_keys
Leave the Access rights as Read, Write, Execute.
Leave the Owner as User.
Assign the file to the desired thin clients, profiles or directories.

Make sure that you do not upload the private key file by mistake.
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If you wish to authorize more keys for SSH connections to thin clients, prepare an 
authorized_keys  file containing all the public keys. Simply append them using a text 

editor.


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1.
2.
3.
4.

Configuring SSH Access on the Device
Go to System > Remote Access > SSH Access in the IGEL Setup or a profile.
Check Enable.
Optionally, if user has an empty password, check Permit empty passwords.
Set Deny to No in the User access entry for user.

Now you can connect to the device from the administrator's machine with the following 
command: 
ssh user@[client name or IP address]  

Depending on whether you set a passphrase for the key, you may have to enter it or not.

This configuration gives the remote user full shell access as if they were the local user on 
the client.


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Secure Terminal (Telnet with TLS/SSL)
IGEL Linux version 5.11.100 or newer and IGEL Linux version 10.01.100 or newer allow terminal access via UMS with 
transport encryption. In analogy to secure shadowing (see page 567), network traffic is encrypted with TLS/SSL. Secure 
terminal connections can only be initiated from the UMS whose certficate is stored on the device.

For details about setting up a secure terminal connection, see UMS manual Secure Terminal (Secure Shell).   

Secure Terminal is the best way to create a remote access from the UMS (on Linux or Windows installed) to Linux 
devices, without installing an additional terminal software. Because the UMS includes the software.
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Secure Shadowing (VNC with TLS/SSL)
The Secure Shadowing function improves security when remotely maintaining a device via VNC at a number of 
locations:

Encryption: The connection between the shadowing computer and the shadowed device is 
encrypted.
This is independent of the VNC viewer used.
Integrity: Only devices in the UMS database can be shadowed.
Authorization: Only authorized persons (UMS administrators with adequate authorizations) can 
shadow devices.
Direct shadowing without logging on to the UMS is not possible.
Limiting: Only the VNC viewer program configured in the UMS (internal or external VNC viewer) 
can be used for shadowing.
Direct shadowing of a device by another device is likewise not permitted.

Logging: Connections established via secure shadowing are recorded in the UMS server log.
In addition to the connection data, the associated user data (shadowing UMS administrator, 
optional) can be recorded in the log too.

Basic Principles and Requirements (see page 568)
Shadow Devices Securely (see page 569)
VNC Logging (see page 570)

In addition, IGEL Management Interface (IMI) in Version 2 or newer provides an API for 
Secure Shadowing.



Of course, this is only relevant to devices that meet the requirements for secure 
shadowing and have enabled the corresponding option. Other devices can be "freely" 
shadowed in a familiar manner and, if necessary, secured by requesting a password. If you 
would like to allow secure shadowing only, you can specify this in the UMS Console under 
UMS Administration > Global Configuration > Remote Access.


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Basic Principles and Requirements
The Secure Shadowing option can be enabled if the following requirements are met:

IGEL Linux as of version 5.03.190 and 10.01.100 or IGEL Windows Embedded Standard 7 from 
version 3.09.100
IGEL Universal Management Suite from version 4.07.100 onwards
The device is registered on the UMS Server
The device can communicate with the UMS Console and UMS Server (see below)

Basic Technical Principles
Unlike with "normal" shadowing, the connection between the VNC viewer and the VNC server (on the device) is not 
established directly during secure shadowing. Instead, it runs via two proxies – one for the UMS Console and one for 
the VNC server on the device. These proxies communicate via a TLS/SSL-encrypted channel, while the local 
communication, e.g. between the VNC viewer application and the UMS proxy, takes place in the conventional 
unencrypted manner. As a result, a secure connection can also be established with external VNC programs that do 
not support TLS/SSL connections.

The two proxies (UMS Console and device) communicate with TLS/SSL encryption via the same port as the 
"normal" VNC connection: 5900. As a result, no special rules for firewalls need to be configured in order to perform 
secure shadowing.

If secure shadowing is active for a device under Setup > System > Remote Access > Shadow > Secure mode), the 
device generates a certificate in accordance with the X.509 standard and transfers it to the UMS Server when the 
system is next started. The UMS Server checks subsequent requests for a secure VNC connection using the 
certificate. The certificate in PEM format can be found in the /wfs/client-certs/tc_ca.crt  directory on 

the device. The validity of the certificate can be checked on the (Linux) client using the command: x11vnc 

-sslCertInfo /wfs/client-certs/tc_ca.crt

If a UMS administrator calls up the Shadowing function in the UMS Console for the device, the console receives a 
signed request from the UMS Server which is then passed on to the device to be shadowed. This in turn passes on 
the request to the UMS Server which checks the validity of the request using the original certificate. If this check is 
successful, the console reports that the channel for the connection between the proxies can be established. The 
UMS proxy on the console connects to the server proxy on the device, and the server proxy, in turn, establishes on 
the device the connection to its VNC server.

Only when these connections have been established, the console calls up the VNC viewer which then connects to 
the console proxy. The VNC client and VNC server are now connected via the two proxies which transfer data with 
TLS/SSL encryption.

Secure shadowing can be enforced independently of the device configuration for all devices that support this 
function: UMS Administration > Global Configuration > Remote Access > Enable secure VNC globally.
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Shadow Devices Securely
In order to shadow a device securely (with encryption), the administrator must log on to the server via the UMS 
console. When doing so, it is irrelevant whether a purely local UMS administrator account is used or the user was 
adopted via an Active Directory for example. As always, however, the UMS administrator must have the permission 
to shadow the object, see Object-Related Access Rights.

The device to be shadowed is called up in the structure tree and, as usual, can be executed via Shadow in the 
context menu. The connection window, however, differs from the dialog for normal VNC shadowing. The IP and port 
of the client to be shadowed cannot be changed, and a password for the connection is not requested – this is 
superfluous after logging on to the console beforehand.

When a VNC connection has been established, the symbol in the connection tab indicates secure shadowing:
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VNC Logging
Connections via secure shadowing are always logged in the UMS. Via UMS Administration > Global Configuration 
> Remote Access > Secure VNC, you can configure whether the user name of the person shadowing is to be 
recorded in the log:

Log user for secure VNC
☑ The user name is included in the log.
☐ The user name is not included in the log. (default)

The VNC log can be called up via the context menu of a device or folder (for several devices, Logging > Logging: 
Secure Access Logs). The name, MAC address and IP address of the shadowed device, the time and duration of the 
procedure and, if configured accordingly, the user name of the shadowing UMS administrator are logged.

 To sort the list (e.g. according to user names), click on the relevant column header or filter the content shown 
by making entries in the Filter field.



Security

IGEL OS Articles   571 / 1017

•

•

•

Cherry eGK Channel Substitution
As of firmware version 10.05.100, the Cherry eGK Channel is no longer available. In the Igel Universal Desktop 
Firmware, Linux V5, the VirtualChannel for Cherry eGK devices is still included parallel to the Cherry USB2LAN Proxy.
If you want to continue using the G87-1504/ST-1503 as before, with firmware version 10.05.100 and higher you have 
to activate the proxy. All settings are automatically applied and run through the connector in the network.

Using the G87-1504/ST-1503 with firmware version 10.05.100 and higher:
Activate the proxy - this can also be done from the backend.

For IGEL Lx v5 and OS10:

Activate Cherry USB2LAN Proxy under IGEL Setup > Security > Smartcard > Services.

For IGEL Lx v5:

Disable Cherry Channel 0 and Cherry Channel 1 under IGEL Setup > Sessions > RDP > RDP 
Global > Mapping > Device Support.

•
•

Cherry USB2LAN Proxy (Under Smartcard) (see screenshot)
IGEL device, valid for Cherry devices G87-1505, G87-1504/ST-1503 to USB


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Do not activate smartcard.

Install the Cherry eGK KVK software on the server. See https://www.cherry.de/files/software/Cherry-eGK-
KVK_Software_33.zip

Install the Cherry Linux software on the device.

In the CT-API configuration the G87-1504/ST-1503 can be configured as network device. 
Link to Doku Client Server Integration: https://www.cherry.de/files/manual/
64410063-01_USBLANProxyClientServerUndCitrix.pdf 
Link to the software architecture documentation:: https://www.cherry.de/files/manual/Cherry-
eGK-KVK_Sofware-Architektur_Windows-20130927-v04.pdf

•
•

The VirtualChannel was replaced due to the following difficulties and the future application of the 
telematics infrastructure (see also gematik anforderung lan)

Independent of Citrix version (no need to check compatibility anymore)
Independent of the server version (2008, 2012...), if the connection runs via RDP



https://www.cherry.de/files/software/Cherry-eGK-KVK_Software_33.zip
https://www.cherry.de/files/manual/64410063-01_USBLANProxyClientServerUndCitrix.pdf
https://www.cherry.de/files/manual/Cherry-eGK-KVK_Sofware-Architektur_Windows-20130927-v04.pdf
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1.
2.

3.

Single Sign-on for the Browser Proxy
Using a proxy to handle a browser's internet traffic provides additional security and control. However, if the proxy is 
password-authenticated, the user has to enter their credentials, which adds some inconvenience.

With IGEL Linux version 5.08 or newer and IGEL Linux version 10.01.100 or newer, you can avoid this inconvenience 
by using the passthrough feature. As a prerequisite, user logon must be carried out via Kerberos.

To enable single sign-on for the browser proxy:

Open the Setup and go to Security > Logon > Active Directory/Kerberos.
Activate Login to Active Directory/Kerberos.

Go to Sessions > Browser > Browser Sessions > [name of the browser session] > Settings > 
Proxy.
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4.

5.
•
•
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•

In the Proxy Configuration choice, select Manual proxy configuration.

For an HTTP proxy, define the following settings:
HTTP proxy: IP address or hostname of the proxy to be used
Port: Port of the proxy for HTTP
No proxy for: IP addresses or hostnames of servers that can be accesses directly
Proxy realm: Area in which the browser authenticates itself for the proxy. Together with the 
user name and password, this information is necessary for authentication.

The Proxy realm field is internally pre-populated with the value moz-proxy://[HTTP 

Proxy]:[Port] . If the field is empty, this value will be used when authenticating the 
browser. If the proxy expects another unknown value for the proxy realm, you can 
determine this as follows: Leave the User name and Password fields empty and launch 
the browser. The dialog window which appears will contain the correct value for the 
Proxy realm field: 

 In the 


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Use passthrough authentication: Must be enabled to allow single sign-on for the browser 
proxy.
Do not prompt for proxy authentication if credentials are saved: Must be enabled to 
enable seamless single sign on for the browser proxy; suppresses the Authentication 
Required dialog.

The next time the user logs in to the device, the browser proxy is ready to use.

example above, the value for the Proxy realm field is as follows: moz-proxy://

172.30.178.10:8080
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3.
4.

Limiting the Number of Permitted Login Attempts

Symptom
Users can attempt logging in as often and as fast as they want at the screen unlock prompt and local login prompts 
(e.g. for Kerberos, Shared Workplace, IGEL Smartcard).

Problem
This leaves the system and remote sessions vulnerable to brute force login attacks.

Solution
In IGEL OS 10.03.100 and newer, the number of login attempts is limited to 5 within 30 seconds.

These values can be changed in the system registry:

In Setup, go to System > Registry
Go to the auth.login.lockout_threshold  parameter to set the maximum number of 
login attempts within the specified interval.
Go to the auth.login.lockout_duration  parameter to set the interval in seconds.
Click Apply or Ok.
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1.
2.

How to Deploy Device Encryption

Overview
IGEL OS 11.06 or higher offers strong device encryption that is derived from a user password. The encryption is 
applied to all partitions that can contain user data, e.g. browser history or Custom Partitions.

Instructions
In the UMS configuration dialog or the local Setup, go to Security > Device Encryption. 
Set the parameters to meet your requirements. For details, see Device Encryption for IGEL OS.

•

•
•

•
•

Important Notes on Downgrading

If you have encrypted your IGEL OS 11.06 device, downgrading to IGEL OS 11.05 or lower 
will imply data loss on the following partitions, due to different partition schemes: 

Browsing history of the browsers Firefox and Chromium
Custom Partitions

The device settings and the UMS connection are preserved.
The device encryption password must be entered by the user.


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3.

4.

Set Device encryption mode to "activate" and click Apply and send to device or Save.

When the settings have been sent to the device, a password dialog is presented to the user.
The user enters an encryption password that meets the requirements and clicks Apply.
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5.

Several partitions are re-encrypted. This might take up to 60 seconds, depending on your 
hardware capabilities and the size of your Custom Partition.
The user confirms the success message.
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6. On system start, the user must enter the device encryption password.



Security

IGEL OS Articles   581 / 1017

1.

2.
•
•

Security: Timeout for Secure Shadowing and Secure Terminal

Overview
To avoid a denial of service attack by blocking port 30022, which is used for secure shadowing (secure VNC) and 
secure terminal connections, a timeout can be configured. This timeout limits the establishing process for 
connections to port 30022. The duration is 180 seconds by default and can be changed via an environment variable.

Configuring the Timeout
Open the UMS configuration dialog or the local Setup and go to System > Firmware 
Customization > Environment Variables > Predefined.
Enter the following data and then click Ok:

Variable name:  IGEL_TLS_TUNNEL_TIMEOUT
Value: Timeout in seconds. The range is 0 to180. When the value is set to 0, there will be no 
timeout.
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Some services are restarted on the device. Afterward, the timeout is set.
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Certificates
Certificate Enrollment and Renewal with SCEP (NDES) (see page 584)
Deploying Trusted Root Certificates (see page 604)
Which CA Certificates Are Contained in IGEL OS? (see page 612)
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Certificate Enrollment and Renewal with SCEP (NDES)
SCEP is a protocol for certificate management which supports the secure issuance of certificates to network 
devices.

Requirements
SCEP server
The following SCEP server implementations can be used with IGEL Linux v5 or IGEL Linux 10:

Windows 2008 Server with the Network Device Enrollment Service (NDES) role
Windows 2012 Server
Windows 2016 Server

For information on how to deploy the NDES, see http://aka.ms/ndes.

Connection between the SCEP server and the certification authority (CA).

This document explains the enrollment of certificates with SCEP.

Technical Background (see page 585)
Client Enrollment Details (see page 587)
Configuration of the SCEP Client (see page 589)
Files Involved (see page 598)
Troubleshooting (see page 599)

http://aka.ms/ndes
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1.
2.

3.

4.

Technical Background
The Simple Certificate Enrollment Protocol (SCEP) defines a way of automatically enrolling certificates for the 
authentication of network devices or VPNs. The client uses HTTP requests to fetch root certificates, to send 
certificate requests, and to fetch client certificates from the server.

For an in-deep description, see the Microsoft technet article "Network Device Enrollment Service (NDES) in Active 
Directory Certificate Services (AD CS)" under http://aka.ms/ndes.

Here is a typical certificate enrollment process:

The device creates an RSA public-private key pair.
The administrator requests a challenge password from the SCEP service (e. g. NDES).

The SCEP server asks the domain controller if the administrator holds the required permissions for 
the configured certificate templates.
The domain controller confirms that the administrator holds the required permissions.

The challenge password is only required for the first enrollment request. For certificate 
renewal, the current certificate is used for authentication.



http://aka.ms/ndes
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5.

6.

7.

8.

9.
10.

The SCEP server creates a challenge password and hands it over to the administrator.

The administrator provides the device with the challenge password, the CA identifier, and the 
fingerprint of the CA certificate.
The device sends the enrollment request to the SCEP server, using the challenge password to 
authenticate with the SCEP server. This action is triggered by the administrator.
The SCEP server signs the enrollment request with its enrollment agent certificate and sends it to 
the CA.
The CA issues the desired certificate and returns it to the SCEP server.
The SCEP server returns the certificate to the device.

Typically, the challenge password expires after a defined time. With the NDES that is 
included in Windows 2008 Server, the default expiry time is 60 minutes.


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1.
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4.

5.

Client Enrollment Details
This section describes the actual certificate enrollment in detail. The process described here corresponds to step 7 
to 10 in the overall process (see page 585).

The client requests the CA's public certificate from the SCEP server.
The SCEP server sends the CA's public certificate to the client.
The client checks the CA's public certificate against the relevant fingerprint. The fingerprint has 
been provided by the administrator via a UMS profile; see Defining the Certification Authority (see 
page 594).
The client sends an enrollment request to the SCEP server. This enrollment request is an HTTP GET 
request that contains the following:
Signed data PKCS7 Enveloped data PKCS7 Certificate Signing Request 

(PKCS 10)

Version

Hashing algorithm

   Signed (unencrypted) data: Version

Recipient and related 
encrypted data encryption 
key; the recipient is the CA.

   Encrypted data:

(encrypted with a randomly 
generated key that is 
encrypted with the recipient's 
public key)

Version

Requested subject name

Public key of client

Challenge password

Requested extensions

Signature algorithm

Digital signature

Client certificate

Digital signature

If the request was successful, the HTTP response from the SCEP server includes the following data:

The enrollment request and the response from the CA that contains the req
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Signed data PKCS7 Enveloped data PKCS7 Degenerate Certificates (only 
PKCS7)

Version

Hashing algorithm

Signed (unencrypted) data: Version

List of recipients

Encrypted data: Version

Issued X.509 certificate

CA certificate

Digital signature
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Configuration of the SCEP Client
The configuration of the SCEP client on the IGEL OS device is carried out as follows:

Creating a Profile in the UMS (see page 590)
Activating the SCEP Client (see page 591)
Entering the Data for the Certificate Signing Request (CSR) (see page 592)
Defining the Certification Authority (CA) (see page 594)
Providing the SCEP Server Data (see page 595)
Applying the Profile to the Devices (see page 596)
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4.

Creating a Profile in the UMS

In the UMS structure tree, go to Profiles, open the context menu and select New Profile.
Enter an appropriate Profile Name.
In the Based on menu, select the firmware version that is installed on the devices in question.
Click OK.
The configuration dialog opens. The configuration dialog corresponds to the IGEL Setup available 
on the devices to which the profile is assigned.
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1.
2.

Activating the SCEP Client

Go to Network > SCEP Client (NDES).
Enable Manage Certificates with SCEP.
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•
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•

Entering the Data for the Certificate Signing Request (CSR)

 Go to Network > SCEP Client (NDES) > Certificate and enter the following data:

Type of CommonName/SubjectAltName: The characteristic for linking the certificate to the device.

IP address: The IP address of the device.
DNS name: The DNS name of the device.
IP address (auto): The IP address of the device (inserted automatically).
DNS name (auto): The DNS name of the device (inserted automatically).
Email address: An email address.
DNS name as UPN (auto)

The following parameter is available if Type of CommonName/SubjectAltName is set to IP address, DNS name, or 
Email address:

CommonName/SubjectAltName: Give a designation which matches the Type of CommonName/SubjectAltName. 
For certain types, this occurs automatically. No entry is then required.

The following parameter is available if Type of CommonName/SubjectAltName is set to IP address (auto), DNS 
name (auto), or DNS name as UPN (auto):

CommonName/SubjectAltName Suffix: Specifies a suffix that will be added to CommonName/SubjectAltName. 
Possible values:

"none": No suffix will be added.
"dot + DNS domain (auto)": The system's current DNS domain name separated with a dot will be 
added. Example: .igel.local
Free text entry: The manually entered suffix will be added. Take notice that the percent symbol 
"%" is used for introducing the escape sequence, and thus the following replacements take place 
automatically:

% D  is replaced by the system's DNS domain name at the time the certificate signing 

request (CSR) is created. Example: @% D  will be changed into @ igel.de if the system's 

current DNS domain name is igel.de .

%% will be replaced by %. Example: A %% B will be changed into A % B .

Other combinations with % are currently discarded. Example: A % BC will be changed 

into A C .

If the client automatically obtains its network name, DNS Name (auto) is a good type for the client 
certificate.


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Organizational unit: Stipulated by the certification authority.

Organization: A freely definable designation for the organization to which the client belongs.

Locality: Details regarding the device’s locality. Example: "Augsburg".

State: Details regarding the device’s locality. Example: "Bayern".

Country: Two-digit ISO 3166-1 country code. Example: "DE".

RSA key length (bits): Select a key length (one suited to the certification authority) for the certificate that is to be 
issued. 
Possible values:

"1024"
"2048"
"4096"

If you have to specify the suffix manually, make sure you enter the separator.

The RSA key length specified here must not be lower than the minimum key length configured on the 
server.


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Defining the Certification Authority (CA)

Go to Network > SCEP Client (NDES) > Certification Authority.
Enter the details for the certification authority (CA):

CA Identifier: FQDN (fully qualified domain name) of the CA
CA Certificate Fingerprint (MD5): Fingerprint of the CA certificate in the form 
01:02:03:04:05:06:07:08:09:0A:0B:0C:0D:0E:0F:10

If the CA certificate fingerprint is specified, the client will use it to check the integrity of the CA 
certificate it receives from the SCEP server.

You can get the fingerprint from your NDES server: https://<NDES Servername>/

certsrv/mscep_admin


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3.

Providing the SCEP Server Data

Go to Network > SCEP Client (NDES) > SCEP.
Enter the following data:

SCEP server URL: URL by which the SCEP client communicates with the SCEP server.

Proxy server for SCEP requests (optional): IP address or host name of the proxy server that 
is used for the communication between the device and the SCEP server. If a web application 
firewall is used instead of a proxy, its IP address or host name of the proxy server must be 
entered here.
Challenge password: Password that the SCEP client must present to the SCEP server in its 
request (CSR).

Certificate renewal period (days): Time interval before certificate expiry after which the 
certificate renewal procedure is started. (Default: 30)
Certificate expiry check interval (days): Specifies how often the certificate is checked 
against its expiry date. (Default: 1)

Save the settings.

HTTPS is not supported; however, all security critical data that are transferred between 
the SCEP client and other components are encrypted.



On a Microsoft NDES server, you can retrieve the password by default under https:///

certsrv/mscep_admin .



By default, the password on a Microsoft NDES server is valid for 1 hour and can be used only once. 
In order to use the password on numerous devices, additional settings must be made on the NDES 
server. For information, see the section "Password and Password Cache" on https://
social.technet.microsoft.com49.



https://social.technet.microsoft.com/wiki/contents/articles/9063.active-directory-certificate-services-ad-cs-network-device-enrollment-service-ndes.aspx
https://social.technet.microsoft.com/wiki/contents/articles/9063.active-directory-certificate-services-ad-cs-network-device-enrollment-service-ndes.aspx
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Applying the Profile to the Devices

In the UMS structure tree under Devices, select the devices you want to assign the profile to.
In the Assigned objects area, click .

In the Select assignable objects dialog, select the relevant profile and click  to assign it.
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4.
5.

Click Ok.
In the Update time dialog, select Now and click Ok.
The device performs the actions as described in Client Enrollment Details (see page 587).
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Files Involved
All files involved are stored in the directory /wfs/scep_certificates/cert0 . The following fixed file 
names are used:

cacert.pem CA certificate

racert_enc.pem RA certificate used for encryption (optional)

racert_sig.pem RA certificate used for signature (optional)

client.csr Certificate signing request

client.cert Client certificate

client.key Private key of client certificate
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Troubleshooting
Diagnostics (see page 600)
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Diagnostics

Preliminary: Tools

System Log Viewer

 In the start menu, select the system icon and then System Log Viewer to open the system log viewer.

For more information on starting, using, and configuring the system log viewer, see the System Log Viewer chapter 
of the IGEL OS Manual.

Local Terminal
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1.

2.

 In the start menu, select the Local Terminal.

If a local terminal session has not been set up on your device, proceed as follows:

Open the Setup and go to Accessories > Terminals.
Click   to create a local terminal session.
Click Ok to save the setting and exit the Setup.

For more information on starting and using the local terminal, see the Terminals chapter of the IGEL OS Manual.

Checking the Current Status of the Client Certificate Enrollment

 In the local terminal, enter the command  cert_show_status  

The status for each certificate relating to SCEP is shown:

CA certificate
RA encryption certificate
RA signature certificate
Client certificate

Reviewing Log Messages

Open the system log viewer and select /tmp/journal.log

Press [Ctrl] + [F] and enter cert_agent  to search for relevant messages.
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2.

1.

2.

1.

2.

1.

2.

1.

2.

3.

4.

Alternatively, you can open a local terminal and enter  journalctl | grep cert_agent

Reviewing the Certificates and Certificate Requests in the File System

Open a local terminal and login as  user .

Enter ls /wfs/scep-certificates/cert0/

Deleting a Certificate Request

Open a local terminal and login as  root .

Enter  rm –rf /wfs/scep-certificates/cert0/
The directory that includes the certificate request, received certificates (if existing), and the 
device's own private client key, is deleted. This can be useful for debugging purposes, and if SCEP 
is no longer used.

Checking the CA

Open a local terminal and login as  root .

Enter  scep_getca 0

Generating an SCEP Request Manually

Open a local terminal and login as  root .

Enter  scep_mkrequest 0

Enrolling a Certificate Manually

Open a local terminal and login as  root .

Enter  scep_enroll 0

Testing Certificate Renewal

Open a local terminal and login as  root .

Generate an SCEP request and append "new" to the key file name: scep_mkrequest 0 

“new”

An SCEP request is issued. In the directory /wfs/scep-certificates/cert0/ , the key file 

clientnew.key  is created.

Renew the certificate: scep_renew 0

Overwrite the old certificate with the new one: mv /wfs/scep-certificates/cert0/

clientnew.cert /wfs/scep-certificates/cert0/client.cert
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5. Overwrite the old key with the new one: mv /wfs/scep-certificates/cert0/

clientnew.key /wfs/scep-certificates/cert0/client.key
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Deploying Trusted Root Certificates

Purpose
IGEL OS comes with a number of trusted root certificates from certain Certificate Authorities (CA) pre-installed. For 
a complete list of pre-installed root certificates, see CA Certificates Contained in IGEL OS 11.03.

Certificates signed with these root certificates can be used for server authentication and encryption in ICA, RDP, 
Horizon and browser sessions. You can also verify the origin of Java applications.

Nevertheless, the root certificate you need might be missing. This document explains how to load and distribute it.

Requirements
The certificates must be available in the Base64 file format encoded with the file extension .pem , .crt  

or .cer .

To check the file format, open the certificate with a text editor. It should look like this:

Solution
We advise you to use the following file transfer types for distributing the certificates via the UMS; see also
Registering a File on the UMS Server:

Type To be used for

Undefined All-purpose class, you need to set the owner and 
access permissions manually.

Web Browser Certificate Server authentication/encryption of HTTPS 
websites in browsers

SSL Certificate Server authentication/encryption in ICA, RDP or 
Horizon sessions

Authentication via Active Directory (AD)

Java Certificate Authentication/encryption for Java applications
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IBM iAccess Certificate Server authentication/encryption for IBM iAccess 
sessions

Common Certificate (all-purpose) Multiple applications needing a certificate, e.g. if 
you want to launch an ICA session in a browser, or 
if you want to secure a Java session on a secure 
website.

With these file transfer types, you will not need to reboot after installing.

Deploying Certificates via UMS (see page 606)
Installing Certificates Manually (see page 609)
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Deploying Certificates via UMS
We advise you to use the Universal Management Suite for deploying certificates when you have a certain number of 
clients to be addressed.

Certificates can be deployed via the UMS in two steps:

Loading Certificates in the UMS (see page 607)
Assigning Certificates to IGEL Thin Clients (see page 608)
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Loading Certificates in the UMS

Open the UMS console.
Right-click Files.
Choose New file to open the New file mask.
Activate Upload local file to UMS server.
Browse your new certificate file under Local file.
Select the suitable Classification of the certificate under File target.
Confirm with OK.
Your certificate is now listed in the Files window.
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4.

Assigning Certificates to IGEL Thin Clients
After integrating the new certificates, you distribute them to the thin clients:

Choose one thin client or a group of thin clients in the UMS tree.
Click Add under Assigned objects.
The Select assignable object window opens.

Select the new certificate and confirm by clicking on OK.
Select the Update time and confirm by clicking on OK.
The new certificate is now assigned to every thin client of the group and is listed under Assigned 
objects.
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Installing Certificates Manually
Use the Firefox Certificate Manager in order to install web browser certificates; see Installing Web Browser 
Certificates (see page 611).

Also a USB flash drive can be used for the manual import.

Importing SSL Certificates (ICA, RDP, Horizon) (see page 610)
Installing Web Browser Certificates (see page 611)
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5.

6.

7.

8.

Importing SSL Certificates (ICA, RDP, Horizon)
If a CA certificate is missing for RDP, ICA or Horizon, you can copy it from a USB storage device to the thin client:

Connect your USB storage device to the thin client.
Launch a Terminal session or press [CTRL]+[ALT]+[F11] to log in as ROOT on the Linux console of 
the thin client.
Create a directory for certificates:
mkdir /wfs/ca-certs

Change to the directory:
cd /wfs/ca-certs

Get the name of your USB storage device:
ls /userhome/media

Copy the certificate to the client:
cp /userhome/media// /wfs/ca-certs

Check whether the certificate was transferred:
ls -al /wfs/ca-certs

End the terminal session or press [CTRL]+[ALT]+[F1] to exit the console.

The certificates you have saved will be available when you boot up the thin client next 
time.


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Installing Web Browser Certificates
Installing web browser certificates manually:

Open the IGEL Setup.
Click Sessions > Browser > Browser Global > Certificates > View Certificates to open the Firefox 
Certificate Manager.

Click Import... in the Authorities tab to import a new certificate from a directory or a USB flash 
drive.

Manually installed certificates will be saved permanently without any further configuration.
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Which CA Certificates Are Contained in IGEL OS?
The following CA certificates are contained in IGEL OS 11.03.100:

Certificate name Expiry date File in /etc/ssl/certs

ACCVRAIZ1 Dec 31 09:37:37 2030 GMT ACCVRAIZ1.crt

AC RAIZ FNMT-RCM Jan 1 00:00:00 2030 GMT AC_RAIZ_FNMT-RCM.crt

Actalis Authentication Root CA Sep 22 11:22:02 2030 GMT Actalis_Authentication_

Root_CA.crt

AddTrust External CA Root May 30 10:48:38 2020 GMT AddTrust_External_Root.

crt

AffirmTrust Commercial Dec 31 14:06:06 2030 GMT AffirmTrust_Commercial.

crt

AffirmTrust Networking Dec 31 14:08:24 2030 GMT AffirmTrust_Networking.

crt

AffirmTrust Premium Dec 31 14:10:36 2040 GMT AffirmTrust_Premium.crt

AffirmTrust Premium ECC Dec 31 14:20:24 2040 GMT AffirmTrust_Premium_ECC

.crt

Amazon Root CA 1 Jan 17 00:00:00 2038 GMT Amazon_Root_CA_1.crt

Amazon Root CA 2 May 26 00:00:00 2040 GMT Amazon_Root_CA_2.crt

Amazon Root CA 3 May 26 00:00:00 2040 GMT Amazon_Root_CA_3.crt

Amazon Root CA 4 May 26 00:00:00 2040 GMT Amazon_Root_CA_4.crt

Atos TrustedRoot 2011 Dec 31 23:59:59 2030 GMT Atos_TrustedRoot_2011.c

rt
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Certificate name Expiry date File in /etc/ssl/certs

Autoridad de Certificacion 
Firmaprofesional CIF A62634068

Dec 31 08:38:15 2030 GMT Autoridad_de_Certificac

ion_Firmaprofesional_CIF

_A62634068.crt

Baltimore CyberTrust Root May 12 23:59:00 2025 GMT Baltimore_CyberTrust_Ro

ot.crt

Buypass Class 2 Root CA Oct 26 08:38:03 2040 GMT Buypass_Class_2_Root_CA

.crt

Buypass Class 3 Root CA Oct 26 08:28:58 2040 GMT Buypass_Class_3_Root_CA

.crt

CA Disig Root R2 Jul 19 09:15:30 2042 GMT CA_Disig_Root_R2.crt

CFCA EV ROOT Dec 31 03:07:01 2029 GMT CFCA_EV_ROOT.crt

COMODO Certification Authority Dec 31 23:59:59 2029 GMT COMODO_Certification_Au

thority.crt

COMODO ECC Certification 
Authority

Jan 18 23:59:59 2038 GMT COMODO_ECC_Certificatio

n_Authority.crt

COMODO RSA Certification 
Authority

Jan 18 23:59:59 2038 GMT COMODO_RSA_Certificatio

n_Authority.crt

Certigna Jun 29 15:13:05 2027 GMT Certigna.crt

Certigna Root CA Oct 1 08:32:27 2033 GMT Certigna_Root_CA.crt

Certinomis - Root CA Oct 21 09:17:18 2033 GMT Certinomis_-

_Root_CA.crt

Class 2 Primary CA Jul 6 23:59:59 2019 GMT Certplus_Class_2_Primar

y_CA.crt
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Certificate name Expiry date File in /etc/ssl/certs

Certum Trusted Network CA Dec 31 12:07:37 2029 GMT Certum_Trusted_Network_

CA.crt

Certum Trusted Network CA 2 Oct 6 08:39:56 2046 GMT Certum_Trusted_Network_

CA_2.crt

Chambers of Commerce Root - 
2008

Jul 31 12:29:50 2038 GMT Chambers_of_Commerce_Ro

ot_-_2008.crt

AAA Certificate Services Dec 31 23:59:59 2028 GMT Comodo_AAA_Services_roo

t.crt

Cybertrust Global Root Dec 15 08:00:00 2021 GMT Cybertrust_Global_Root.

crt

D-TRUST Root Class 3 CA 2 2009 Nov 5 08:35:58 2029 GMT D-

TRUST_Root_Class_3_CA_2_

2009.crt

D-TRUST Root Class 3 CA 2 EV 
2009

Nov 5 08:50:46 2029 GMT D-

TRUST_Root_Class_3_CA_2_

EV_2009.crt

DST Root CA X3 Sep 30 14:01:15 2021 GMT DST_Root_CA_X3.crt

Deutsche Telekom Root CA 2 Jul 9 23:59:00 2019 GMT Deutsche_Telekom_Root_C

A_2.crt

DigiCert Global Root CA Nov 10 00:00:00 2031 GMT DigiCertGlobalRootCA.pe

m)

DigiCert Assured ID Root CA Nov 10 00:00:00 2031 GMT DigiCert_Assured_ID_Roo

t_CA.crt

DigiCert Assured ID Root G2 Jan 15 12:00:00 2038 GMT DigiCert_Assured_ID_Roo

t_G2.crt
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Certificate name Expiry date File in /etc/ssl/certs

DigiCert Assured ID Root G3 Jan 15 12:00:00 2038 GMT DigiCert_Assured_ID_Roo

t_G3.crt

DigiCert Global Root CA Nov 10 00:00:00 2031 GMT DigiCert_Global_Root_CA

.crt

DigiCert Global Root G2 Jan 15 12:00:00 2038 GMT DigiCert_Global_Root_G2

.crt

DigiCert Global Root G3 Jan 15 12:00:00 2038 GMT DigiCert_Global_Root_G3

.crt

DigiCert High Assurance EV Root 
CA

Nov 10 00:00:00 2031 GMT DigiCert_High_Assurance

_EV_Root_CA.crt

DigiCert Trusted Root G4 Jan 15 12:00:00 2038 GMT DigiCert_Trusted_Root_G

4.crt

E-Tugra Certification Authority Mar 3 12:09:48 2023 GMT E-

Tugra_Certification_Auth

ority.crt

EC-ACC Jan 7 22:59:59 2031 GMT EC-ACC.crt

EE Certification Centre Root CA Dec 17 23:59:59 2030 GMT EE_Certification_Centre

_Root_CA.crt

Entrust.net50 Certification 
Authority (2048)

Jul 24 14:15:12 2029 GMT Entrust.net_Premium_204

8_Secure_Server_CA.crt

Entrust Root Certification 
Authority

Nov 27 20:53:42 2026 GMT Entrust_Root_Certificat

ion_Authority.crt

Entrust Root Certification 
Authority - EC1

Dec 18 15:55:36 2037 GMT Entrust_Root_Certificat

ion_Authority_-_EC1.crt

http://Entrust.net
http://Entrust.net
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Certificate name Expiry date File in /etc/ssl/certs

Entrust Root Certification 
Authority - G2

Dec 7 17:55:54 2030 GMT Entrust_Root_Certificat

ion_Authority_-_G2.crt

GDCA TrustAUTH R5 ROOT Dec 31 15:59:59 2040 GMT GDCA_TrustAUTH_R5_ROOT.

crt

GTS Root R1 Jun 22 00:00:00 2036 GMT GTS_Root_R1.crt

GTS Root R2 Jun 22 00:00:00 2036 GMT GTS_Root_R2.crt

GTS Root R3 Jun 22 00:00:00 2036 GMT GTS_Root_R3.crt

GTS Root R4 Jun 22 00:00:00 2036 GMT GTS_Root_R4.crt

GeoTrust Global CA May 21 04:00:00 2022 GMT GeoTrust_Global_CA.crt

GeoTrust Primary Certification 
Authority

Jul 16 23:59:59 2036 GMT GeoTrust_Primary_Certif

ication_Authority.crt

GeoTrust Primary Certification 
Authority - G2

Jan 18 23:59:59 2038 GMT GeoTrust_Primary_Certif

ication_Authority_-

_G2.crt

GeoTrust Primary Certification 
Authority - G3

Dec 1 23:59:59 2037 GMT GeoTrust_Primary_Certif

ication_Authority_-

_G3.crt

GeoTrust Universal CA Mar 4 05:00:00 2029 GMT GeoTrust_Universal_CA.c

rt

GeoTrust Universal CA 2 Mar 4 05:00:00 2029 GMT GeoTrust_Universal_CA_2

.crt

GlobalSign Jan 19 03:14:07 2038 GMT GlobalSign_ECC_Root_CA_

-_R4.crt
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GlobalSign Jan 19 03:14:07 2038 GMT GlobalSign_ECC_Root_CA_

-_R5.crt

GlobalSign Root CA Jan 28 12:00:00 2028 GMT GlobalSign_Root_CA.crt

GlobalSign Dec 15 08:00:00 2021 GMT GlobalSign_Root_CA_-

_R2.crt

GlobalSign Mar 18 10:00:00 2029 GMT GlobalSign_Root_CA_-

_R3.crt

GlobalSign Dec 10 00:00:00 2034 GMT GlobalSign_Root_CA_-

_R6.crt

Global Chambersign Root - 2008 Jul 31 12:31:40 2038 GMT Global_Chambersign_Root

_-_2008.crt

Go Daddy Class 2 Certification 
Authority

Jun 29 17:06:20 2034 GMT Go_Daddy_Class_2_CA.crt

Go Daddy Root Certificate 
Authority - G2

Dec 31 23:59:59 2037 GMT Go_Daddy_Root_Certifica

te_Authority_-_G2.crt

Hellenic Academic and Research 
Institutions ECC RootCA 2015

Jun 30 10:37:12 2040 GMT Hellenic_Academic_and_R

esearch_Institutions_ECC

_RootCA_2015.crt

Hellenic Academic and Research 
Institutions RootCA 2011

Dec 1 13:49:52 2031 GMT Hellenic_Academic_and_R

esearch_Institutions_Roo

tCA_2011.crt

Hellenic Academic and Research 
Institutions RootCA 2015

Jun 30 10:11:21 2040 GMT Hellenic_Academic_and_R

esearch_Institutions_Roo

tCA_2015.crt
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Certificate name Expiry date File in /etc/ssl/certs

Hongkong Post Root CA 1 May 15 04:52:29 2023 GMT Hongkong_Post_Root_CA_1

.crt

ISRG Root X1 Jun 4 11:04:38 2035 GMT ISRG_Root_X1.crt

IdenTrust Commercial Root CA 1 Jan 16 18:12:23 2034 GMT IdenTrust_Commercial_Ro

ot_CA_1.crt

IdenTrust Public Sector Root CA 1 Jan 16 17:53:32 2034 GMT IdenTrust_Public_Sector

_Root_CA_1.crt

Imprivata Embedded Code 
Signing CA

Sep 7 16:20:00 2033 GMT Imprivata.crt

Izenpe.com51 Dec 13 08:27:25 2037 GMT Izenpe.com52.crt

LuxTrust Global Root 2 Mar 5 13:21:57 2035 GMT LuxTrust_Global_Root_2.

crt

Microsec e-Szigno Root CA 2009 Dec 30 11:30:18 2029 GMT Microsec_e-

Szigno_Root_CA_2009.crt

NetLock Arany (Class Gold) 
Főtanúsítvány

Dec 6 15:08:21 2028 GMT NetLock_Arany_=Class_Go

ld=_Főtanúsítvány.crt

Network Solutions Certificate 
Authority

Dec 31 23:59:59 2029 GMT Network_Solutions_Certi

ficate_Authority.crt

OISTE WISeKey Global Root GA CA Dec 11 16:09:51 2037 GMT OISTE_WISeKey_Global_Ro

ot_GA_CA.crt

OISTE WISeKey Global Root GB CA Dec 1 15:10:31 2039 GMT OISTE_WISeKey_Global_Ro

ot_GB_CA.crt

http://Izenpe.com
http://Izenpe.com
http://Izenpe.com
http://Izenpe.com
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Certificate name Expiry date File in /etc/ssl/certs

OISTE WISeKey Global Root GC CA May 9 09:58:33 2042 GMT OISTE_WISeKey_Global_Ro

ot_GC_CA.crt

QuoVadis Root Certification 
Authority

Mar 17 18:33:33 2021 GMT QuoVadis_Root_CA.crt

QuoVadis Root CA 1 G3 Jan 12 17:27:44 2042 GMT QuoVadis_Root_CA_1_G3.c

rt

QuoVadis Root CA 2 Nov 24 18:23:33 2031 GMT QuoVadis_Root_CA_2.crt

QuoVadis Root CA 2 G3 Jan 12 18:59:32 2042 GMT QuoVadis_Root_CA_2_G3.c

rt

QuoVadis Root CA 3 Nov 24 19:06:44 2031 GMT QuoVadis_Root_CA_3.crt

QuoVadis Root CA 3 G3 Jan 12 20:26:32 2042 GMT QuoVadis_Root_CA_3_G3.c

rt

SSL.com53 EV Root Certification 
Authority ECC

Feb 12 18:15:23 2041 GMT SSL.com_EV_Root_Certifi

cation_Authority_ECC.crt

SSL.com54 EV Root Certification 
Authority RSA R2

May 30 18:14:37 2042 GMT SSL.com_EV_Root_Certifi

cation_Authority_RSA_R2.

crt

SSL.com55 Root Certification 
Authority ECC

Feb 12 18:14:03 2041 GMT SSL.com_Root_Certificat

ion_Authority_ECC.crt

SSL.com56 Root Certification 
Authority RSA

Feb 12 17:39:39 2041 GMT SSL.com_Root_Certificat

ion_Authority_RSA.crt

SZAFIR ROOT CA2 Oct 19 07:43:30 2035 GMT SZAFIR_ROOT_CA2.crt

SecureSign RootCA11 Apr 8 04:56:47 2029 GMT SecureSign_RootCA11.crt

http://SSL.com
http://SSL.com
http://SSL.com
http://SSL.com
http://SSL.com
http://SSL.com
http://SSL.com
http://SSL.com
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Certificate name Expiry date File in /etc/ssl/certs

SecureTrust CA Dec 31 19:40:55 2029 GMT SecureTrust_CA.crt

Secure Global CA Dec 31 19:52:06 2029 GMT Secure_Global_CA.crt

Security Communication RootCA2 May 29 05:00:39 2029 GMT Security_Communication_

RootCA2.crt

Security Communication RootCA1 Sep 30 04:20:49 2023 GMT Security_Communication_

Root_CA.crt

Sonera Class2 CA Apr 6 07:29:40 2021 GMT Sonera_Class_2_Root_CA.

crt

Staat der Nederlanden EV Root CA Dec 8 11:10:28 2022 GMT Staat_der_Nederlanden_E

V_Root_CA.crt

Staat der Nederlanden Root CA - 
G2

Mar 25 11:03:10 2020 GMT Staat_der_Nederlanden_R

oot_CA_-_G2.crt

Staat der Nederlanden Root CA - 
G3

Nov 13 23:00:00 2028 GMT Staat_der_Nederlanden_R

oot_CA_-_G3.crt

Starfield Class 2 Certification 
Authority

Jun 29 17:39:16 2034 GMT Starfield_Class_2_CA.cr

t

Starfield Root Certificate Authority 
- G2

Dec 31 23:59:59 2037 GMT Starfield_Root_Certific

ate_Authority_-_G2.crt

Starfield Services Root Certificate 
Authority - G2

Dec 31 23:59:59 2037 GMT Starfield_Services_Root

_Certificate_Authority_-

_G2.crt

SwissSign Gold CA - G2 Oct 25 08:30:35 2036 GMT SwissSign_Gold_CA_-

_G2.crt
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Certificate name Expiry date File in /etc/ssl/certs

SwissSign Silver CA - G2 Oct 25 08:32:46 2036 GMT SwissSign_Silver_CA_-

_G2.crt

T-TeleSec GlobalRoot Class 2 Oct 1 23:59:59 2033 GMT T-

TeleSec_GlobalRoot_Class

_2.crt

T-TeleSec GlobalRoot Class 3 Oct 1 23:59:59 2033 GMT T-

TeleSec_GlobalRoot_Class

_3.crt

TUBITAK Kamu SM SSL Kok 
Sertifikasi - Surum 1

Oct 25 08:25:55 2043 GMT TUBITAK_Kamu_SM_SSL_Kok

_Sertifikasi_-

_Surum_1.crt

TWCA Global Root CA Dec 31 15:59:59 2030 GMT TWCA_Global_Root_CA.crt

TWCA Root Certification Authority Dec 31 15:59:59 2030 GMT TWCA_Root_Certification

_Authority.crt

Government Root Certification 
Authority

Dec 5 13:23:33 2032 GMT Taiwan_GRCA.crt

TeliaSonera Root CA v1 Oct 18 12:00:50 2032 GMT TeliaSonera_Root_CA_v1.

crt

TrustCor ECA-1 Dec 31 17:28:07 2029 GMT TrustCor_ECA-1.crt

TrustCor RootCert CA-1 Dec 31 17:23:16 2029 GMT TrustCor_RootCert_CA-1.

crt

TrustCor RootCert CA-2 Dec 31 17:26:39 2034 GMT TrustCor_RootCert_CA-2.

crt

Trustis FPS Root CA Jan 21 11:36:54 2024 GMT Trustis_FPS_Root_CA.crt
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Certificate name Expiry date File in /etc/ssl/certs

UCA Extended Validation Root Dec 31 00:00:00 2038 GMT UCA_Extended_Validation

_Root.crt

UCA Global G2 Root Dec 31 00:00:00 2040 GMT UCA_Global_G2_Root.crt

USERTrust ECC Certification 
Authority

Jan 18 23:59:59 2038 GMT USERTrust_ECC_Certifica

tion_Authority.crt

USERTrust RSA Certification 
Authority

Jan 18 23:59:59 2038 GMT USERTrust_RSA_Certifica

tion_Authority.crt

VeriSign Class 3 Public Primary 
Certification Authority - G4

Jan 18 23:59:59 2038 GMT VeriSign_Class_3_Public

_Primary_Certification_A

uthority_-_G4.crt

VeriSign Class 3 Public Primary 
Certification Authority - G5

Jul 16 23:59:59 2036 GMT VeriSign_Class_3_Public

_Primary_Certification_A

uthority_-_G5.crt

VeriSign Universal Root 
Certification Authority

Dec 1 23:59:59 2037 GMT VeriSign_Universal_Root

_Certification_Authority

.crt

VeriSign Class 3 Public Primary 
Certification Authority - G3

Jul 16 23:59:59 2036 GMT Verisign_Class_3_Public

_Primary_Certification_A

uthority_-_G3.crt

XRamp Global Certification 
Authority

Jan 1 05:37:19 2035 GMT XRamp_Global_CA_Root.cr

t

certSIGN ROOT CA Jul 4 17:20:04 2031 GMT certSIGN_ROOT_CA.crt

ePKI Root Certification Authority Dec 20 02:31:27 2034 GMT ePKI_Root_Certification

_Authority.crt
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Certificate name Expiry date File in /etc/ssl/certs

thawte Primary Root CA Jul 16 23:59:59 2036 GMT thawte_Primary_Root_CA.

crt

thawte Primary Root CA - G2 Jan 18 23:59:59 2038 GMT thawte_Primary_Root_CA_

-_G2.crt

thawte Primary Root CA - G3 Dec 1 23:59:59 2037 GMT thawte_Primary_Root_CA_

-_G3.crt
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Smartcard
Authentication with IGEL Smartcard (see page 625)
Smartcard Authentication (see page 634)



Smartcard

IGEL OS Articles   625 / 1017

•
•
•
•
•

Authentication with IGEL Smartcard
Smartcards make the user experience more convenient by providing a single device that supports multiple 
authentication products across the enterprise. The user only has to remember a single PIN that unlocks the smart 
card to access the network.

Prerequisites
Before using the IGEL smartcard, the relevant profiles and session information need to be written to the smartcard.

We describe a best practice way of how to proceed. The names of folders and profiles are only examples and can be 
changed individually.

It is useful to use following folders and profiles on the Universal Management Suite (UMS):

Folder Profile Purpose

Smartcard Creation Folder for devices which will be used for 
smartcard creation.

Smartcard Key This profile will apply the defined company key to 
the devices. This key will be written while creating 
the IGEL smartcard.

Smartcard Operation Folder for devices whose authentication process 
will work only via IGEL smartcard.

Smartcard Login This profile will apply the company key to the 
devices and will activate the login with IGEL 
smartcard.

 Create two folders under Profiles in the Universal Management Suite (UMS), e.g. "Smartcard Operation" and 
"Smartcard Creation".

 Create the profile "Smartcard Login" for "Smartcard Operation".

 Create the profile "Smartcard Key" for "Smartcard Creation".

_________________________

Creating IGEL Smartcard Folders (see page 626)
Folder "Smartcard Operation" (see page 627)
Folder "Smartcard Creation" (see page 628)
Writing the IGEL Smartcard (see page 629)
Smartcard Readers Supported by IGEL Smartcards (see page 633)
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Creating IGEL Smartcard Folders
First, add two new profile folders for creating profiles and assigning them to devices:

"Smartcard Operation";
"Smartcard Creation".
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Folder "Smartcard Operation"
In this folder, you create a new profile "Smartcard Login":

Right-click the folder "Smartcard Operation".
Choose New Profile.
Enter a Profile Name, e.g. "Smartcard Login".
Click Security > Logon > IGEL Smartcard.
Enable Login with IGEL smartcard.
Enter your Company key.

•
•

Later on, this profile will be applied to all devices where the authentication process shall work only 
with a smartcard.
This way, the device will receive:

the company key and
the information that the authentication is only possible with the smartcard.



The company key is a private key shared between devices and smartcards. It should be 
chosen similarly to a good password. If the smartcard does not hold the same company 
key as the device, authentication will not be possible. Remember this company key 
because you will need later to write exactly the same key to the smartcard.


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Folder "Smartcard Creation"
In this folder, you create a new profile "Smartcard Key":

Right-click the folder "Smartcard Creation".
Choose New Profile.
Enter a profile name, e.g. "Smartcard Key".
Click Security > Logon > IGEL Smartcard.
Enter the same Company key as in the profile "Smartcard Login".

Another additional folder is useful:

 Create the subfolder "Get settings from" under "Smartcard Creation".
In this folder, you create the profile with the session information you want to write to the smartcard.

You need this additional folder because the assignment of active profiles from the UMS to the IGEL 
smartcard can cause problems (firmware version < 5.06.100). Later on, you will copy the folder locally to 
your device.


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3.

4.
5.

Writing the IGEL Smartcard

Assigning the Profile "Smartcard Creation" to the Device

Prepare one device which has a smartcard reader/writer.
Integrate this device in the UMS and put it into the folder "Smartcard Creation".
Now the device automatically receives the company key from the profile. It will be used when 
writing the smartcard.

Ensuring That the Profile Assignment Was Successful

Open the local setup of your device.
Click Security > Logon > IGEL Smartcard.
You should now see a disabled field Company key with a lock symbol.

Writing the Profiles to the Smartcard

Open the folder "Smartcard Creation" in the UMS.
Right-click your device.
Choose Take over settings from... to copy the profile settings to the device.
The dialog Copy settings from... opens.
Choose your profile from the folder "Smartcard Creation" > "Get settings from".
Enable Overwrite Sessions.
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Click OK to copy the profile with the settings and the company key to the device.

Writing the Smartcard

Open the local setup of your device.
Click Security > Logon > IGEL Smartcard.
Click Smartcard personalization.
The Smartcard personalization dialog opens.
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6.

7.

8.
9.

Enter the First name and the Last name of the smartcard holder that should appear at the login 
prompt.
Activate Require password and specify the Password if a password has to be required for the 
smartcard login.
Select the local sessions you want to write to the smartcard.

Activate Autostart for a session in the smartcard list if it should be automatically started at login. 
Check Restart if desired.

Click Write smartcard to start the writing process with the defined settings.
Confirm the security question with Yes.

Use the arrow buttons to add a session to the smartcard session list.

The configuration of the sessions can be saved and reloaded at a later time.
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The notice Smartcard successfully written appears.

Testing the New IGEL Smartcard

Go to the UMS.
Register a new device in the UMS and put it in the folder "Smartcard Operation".
The device gets the company key and the profile information that authentication is only possible 
with the IGEL smartcard.
Restart the device.
The Insert Smartcard... dialog opens.
Insert the IGEL smartcard into your device and verify the selected configuration.
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Smartcard Readers Supported by IGEL Smartcards
IGEL smartcards are supported by the following third-party smartcard readers:

OMNIKEY CardMan 3111
OMNIKEY CardMan 3x21
OMNIKEY CardMan 3621
OMNIKEY CardMan 6121
OMNIKEY CardMan 3821
USB CCID Smart Card Reader
USB CCID Smart Card Reader Keyboard
Fujitsu Siemens Computers SmartCard-Reader USB 2A
Fujitsu Siemens Computers SmartCard-Reader Keyboard USB 2A
Fujitsu Siemens Computers SmartCard-Reader USB 2C
Cherry SmartBoard XX44
OMNIKEY CardMan 5121
OMNIKEY CardMan 5x21
HID Global OMNIKEY 3x21 Smart Card Reader
Cherry KC 1000 SC
Cherry KC 1000 SC/DI
Cherry KC 1000 SC Z
Cherry KC 1000 SC/DI Z
Cherry SmartTerminal XX44 v2
Cherry SmartTerminal XX44
OMNIKEY CardMan
CCID SC Reader
Cherry SC Reader.
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Smartcard Authentication

Certificate Authentication
The smartcards discussed here can hold digital certificates (x.509) and corresponding private keys. The private key 
cannot be read from the card, but it can be used by the card itself for signing and decryption of data.

This enables the use of what is known as two-factor authentication: the user not only possesses the smartcard, he 
or she can also prove the knowledge of the smartcard PIN by signing data using the private key stored on the 
smartcard.

If you want to use Active Directory (AD), the certificate chain used by the key distribution center (domain controller) 
must be available on the device. For instructions on deploying certificate files, see Registering a File on the UMS 
Server (set Classification to "SSL Certificate") and Transferring a File to a Device.

Smartcard Readers
Smartcards are accessed via smartcard readers, using either a contact or contactless interface. The IGEL Third Party 
Database57 lists the readers that are supported by the Linux firmware.

PC/SC Resource Manager
The PC/SC Resource Manager is a common Application Programming Interface (API) that is available on Windows
and Linux operating systems. It provides a standardized way for applications to handle smartcards and readers.

The PC/SC Resource Manager is active by default in the Linux-based firmware and can be controlled via the Activate 
PC/SC Daemon parameter on IGEL Setup > Devices > Smartcard > PC/SC or IGEL Setup > Security > Smartcard > 
PC/SC or IGEL Setup > Security > Smartcard > Services (depending on the firmware version).

Smartcard Middleware
In order to provide a generalized interface to different types of smartcard hardware, there is an additional software 
layer called smartcard middleware.

There are different types of middleware:

Windows Linux

CSP, Cryptographic Service Provider ✓
PKCS#11, Public-Key Cryptographic Standards ✓ ✓

https://www.igel.com/linux-3rd-party-hardware-database/
https://www.igel.com/linux-3rd-party-hardware-database/


Smartcard

IGEL OS Articles   635 / 1017

•
•
•
•
•
•
•
•
•

•
•

Some of the smartcard authentication methods require smartcard middleware to be installed on the endpoint 
device. The following modules are available:

Gemalto SafeNet
cryptovision sc/interface
Gemalto IDPrime
Athena IDProtect
A.E.T.SafeSign
Secmaker Net iD
Coolkey
OpenSC
90meter

For information on how to use a custom PKCS#11 library, refer to the article Using a Custom PKCS#11 Library (see 
page 769).

Active Directory Logon with Smartcard (see page 637)
Citrix StoreFront (see page 638)

Licensed Feature

This feature requires an add-on license; see Add-On Licenses. Please contact your IGEL reseller.

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RDP Sessions (see page 640)
Horizon Sessions (see page 641)
Smartcard Authentication in Browser (see page 642)
Local Login with Smartcard Certificate (see page 643)
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Active Directory Logon with Smartcard
See the how-to Passthrough Authentication (see page 974).
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Citrix StoreFront
In this scenario, Citrix Receiver 13.1 or newer is required. The root certificate of the web server certificate used by the 
StoreFront server has to be known as the trusted root certificate on the endpoint device - see Deploying Trusted 
Root Certificates (see page 604), Certificate Type SSL Certificate.

Under Sessions > Citrix > Citrix StoreFront > Server, specify the Server location.

Choose Smartcard authentication as Authentication type under Sessions > Citrix > Citrix 
StoreFront > Login.

Select the appropriate PKCS#11 module for the smartcard Security > Smartcard > Middleware.
Gemalto/SafeNet eToken
cryptovision sc/interface
Gemalto IDPrime
Athena IDProtect
A.E.T. SafeSign
Secmaker Net iD
90meter

When used in combination with Active Directory Logon the enabled Use Passthrough 
authentication activates single sign-on with smartcard.


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• Custom PKCS#11 module. See here also Using a Custom PKCS#11 Library (see page 769).

Licensed Feature

This feature requires an add-on license; see Add-On Licenses. Please contact your IGEL 
reseller.


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RDP Sessions
In this scenario, the smartcard middleware has to be installed on the server side.

Enable Activate PC/SC Daemon under Security > Smartcard > Services.
Check Enable Smartcard under Sessions > RDP > RDP Global > Mapping > Device Support.
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2.

Horizon Sessions
In this scenario, the smartcard middleware has to be installed on the virtual desktops as well as configured on the 
endpoint device side.

The View Connection Server has to be configured on the endpoint device side.

Select the appropriate PKCS#11 support for the smartcard under Sessions > Horizon Client > 
Horizon Client Global > Smartcard.

Gemalto/SafeNet eToken
cryptovision sc/interface
Gemalto IDPrime
Athena IDProtect
A.E.T. SafeSign
Secmaker Net iD
Coolkey
OpenSC
90meter

For details on the custom PKCS#11 library, refer to the article Using a Custom PKCS#11 Library (see 
page 769).
Configure the Server URL under Sessions > Horizon Client > Horizon Client Sessions > [session 
name] > Connection settings.

The View Connection Server has to be configured to accept connections via SSL/TLS secured https URLs. 
The root certificate of the certificate used for this service has to be known as the trusted root certificate on 
the thin client (see the how-to Deploying Trusted Root Certificates (see page 604), certificate type SSL 
Certificate).



Licensed Feature

This feature requires an add-on license; see Add-On Licenses. Please contact your IGEL 
reseller.



Start the URL with https:// !
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Smartcard Authentication in Browser
It is possible to authenticate using a smartcard at websites, e. g. Citrix Web Interface or StoreFront.

When connecting via an SSL/TLS secured https URL, the root certificate of the web server certificate has to be 
known as the Trusted Root Certificate on the endpoint device; see Deploying Trusted Root Certificates (see page 
604), certificate types Web Browser Certificate and (!) SSL Certificate.

 Select the appropriate PKCS#11 module (security device) for the smartcard under Sessions > Browser > 
Browser Global > Smartcard Middleware.

Gemalto/SafeNet eToken
cryptovision sc/interface
Gemalto IDPrime
Athena IDProtect
A.E.T. SafeSign
Secmaker Net iD
Coolkey
OpenSC
90meter

For details on the custom PKCS#11 library, refer to the article Using a Custom PKCS#11 Library (see page 769).

Licensed Feature

This feature requires an add-on license; see Add-On Licenses. Please contact your IGEL reseller.




Smartcard

IGEL OS Articles   643 / 1017

•
•

•
•

Local Login with Smartcard Certificate

Overview
This is a method for local login at the endpoint device with a smartcard holding a certificate. 

It can be used in two ways:

As a standalone authentification method; see Standalone Authentification Method (see page 644)
In combination with AD/Kerberos; see Combination with the "AD/Kerberos with Smartcard" 
Method (see page 652) (see also Passthrough Authentication (see page 974)). The AD/Kerberos login is 
tried first. If this has been successful, the login is successful. If not, login with the smartcard 
certificate is performed as a fallback.

For the login with a smartcard certificate, the pam_pkcs11 module is used. For reference, see https://github.com/
OpenSC/pam_pkcs11.

Standalone Authentification Method (see page 644)
Combination with the "AD/Kerberos with Smartcard" Method (see page 652)

https://github.com/OpenSC/pam_pkcs11
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Standalone Authentification Method

Prerequisites

The following files are required:

Root certificate and intermediate CA certificates, as applicable
File cn_map  which contains mappings of common names to UPN names for each smartcard 
certificate

Creating the cn_map File

 Create a file named cn_map  in which each line is in the format <common name> -> <logon name>
where

<common name>  is the common name part of the certificate's subject
Example from a client certificate:
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<logon name>  is the UPN name of the SubjectAltName extension of the certificate. The UPN 
name is dependent on whether Enterprise Kerberos names are enabled or disabled (the setting is 
described under Configuring the Devices (see page 650)):

When Enterprise Kerberos names are enabled, the user domain may differ from the default 
domain. In the following example, the user's domain is test.mail , while the default 

domain is MY.DOMAIN : testuser@test.mail@MY.DOMAIN

            

            Example from a client certificate:

When Enterprise Kerberos names are disabled, the user domain is the same as the default 
domain. Example: 

              testuser@MY.DOMAIN
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Example line: Test User -> testuser@test.mail@MY.DOMAIN

Transferring the cn_map File to the Devices

The cn_map  file must be located in the directory /etc/pam_pkcs11/cn_map . This can be achieved via UMS 
file transfer.

To transfer the  cn_map  file to the devices: 

In the UMS structure tree, go to Files and in the context menu, select New file.

In the New file dialog, configure the settings as follows:
Local file: Local file path of the certificate. Use the file chooser by clicking .
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5.

Device file location:  /etc/pam_pkcs11/cn_map  

Click Ok.
The file object is created in the UMS.
In the UMS structure tree, select the endpoints for which you want to configure the local login with 
a smartcard certificate. For mass deployment, it is recommended to use a directory containing the 
endpoint devices or a profile (see Creating Profiles).

In the  Assigned objects  area, click  .
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Under  Files, select the file object using the   button: 

Click Ok .
In the  Update time  dialog, select  Now  and click  Ok.
The  cn_map  file is transferred to the endpoint device.

Transferring the Certificate Files to the Devices

Registering the Certificate Files as File Objects

To transfer the certificate files to the devices, perform the following steps for each certificate file:
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3.

In the UMS structure tree, go to Files and in the context menu, select New file.

In the New file dialog, configure the settings as follows:
Local file: Local file path of the certificate. Use the file chooser by clicking .
Device file location:  /etc/pam_pkcs11/cacerts  /  

Click Ok.
The file object is created in the UMS.
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Assign the Certificate Files to the Devices

In the UMS structure tree, select the endpoints for which you want to configure the local login with 
a smartcard certificate. For mass deployment, it is recommended to use a directory containing the 
endpoint devices or a profile (see Creating Profiles).

In the  Assigned objects  area, click  .

Under  Files, select the required file objects using the   button: 

Click  Ok.
In the  Update time  dialog, select  Now  and click  Ok.
The certificates are transferred to the endpoint device.

Configuring the Devices

To enable local login with a smartcard certificate, you must configure the devices appropriately. For mass 
deployment, it is recommended to use a profile.

Go to Security > Smartcard > Middleware and select the middleware to be used.
Go to System > Registry > auth > login > pkcs11 (registry key: auth.login.pkcs11 ) and 
activate Login with smartcard certificate.
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Go to System > Registry > auth > login > pkcs11_cert_policy (registry key: 
auth.login.pkcs11_cert_policy ) and enter the methods for certificate verification that 

are to be used. For further information, see the documentation in https://github.com/OpenSC/
pam_pkcs11.
If Kerberos enterprise names are used, go to System > Registry > auth > login > 
krb5_enterprise and activate Allow enterprise names.

Debugging

 If you need to debug the smartcard certificate login, go to System > Registry > auth > login > 
pkcs11_debug (registry key: auth.login.pkcs11_debug ) and activate Enable debugging of smartcard 
certificate login.
Logging messages will be available via syslog.

https://github.com/OpenSC/pam_pkcs11
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Combination with the "AD/Kerberos with Smartcard" Method

Prerequisites

The following files are required:

Root certificate and intermediate CA certificates, as applicable
File cn_map  which contains mappings of common names to UPN names for each smartcard 
certificate

Creating the cn_map File

 Create a file named cn_map  in which each line is in the format <common name> -> <logon name>
where

<common name>  is the common name part of the certificate's subject
Example from a client certificate:
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<logon name>  is the UPN name of the SubjectAltName extension of the certificate. The UPN 
name is dependent on whether Enterprise Kerberos names are enabled or disabled (the setting is 
described under Configuring the Devices (see page 658)):

When Enterprise Kerberos names are enabled, the user domain may differ from the default 
domain. In the following example, the user's domain is test.mail , while the default 

domain is MY.DOMAIN : testuser@test.mail@MY.DOMAIN

         

        Example from a client certificate:

When Enterprise Kerberos names are disabled, the user domain is the same as the default 
domain. Example: testuser@MY.DOMAIN  

Example line: 

    Test User -> 
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    testuser@test.mail@MY.DOMAIN

  

Transferring the cn_map File to the Devices

The cn_map  file must be located in the directory /etc/pam_pkcs11/cn_map . This can be achieved via UMS 
file transfer.

To transfer the  cn_map  file to the devices: 

In the UMS structure tree, go to Files and in the context menu, select New file.

In the New file dialog, configure the settings as follows:
Local file: Local file path of the certificate. Use the file chooser by clicking .
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Device file location:  /etc/pam_pkcs11/cn_map  

Click Ok.
The file object is created in the UMS.
In the UMS structure tree, select the endpoints for which you want to configure the local login with 
a smartcard certificate. For mass deployment, it is recommended to use a directory containing the 
endpoint devices or a profile (see Creating Profiles).

In the  Assigned objects  area, click  .
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8.

Under  Files, select the file object using the   button: 

Click  Ok.
In the  Update time  dialog, select  Now  and click  Ok.
The  cn_map  file is transferred to the endpoint device.

Transferring the Certificate Files to the Devices

Registering the Certificate Files as File Objects

To transfer the certificate files to the devices, perform the following steps for each certificate file:
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•

3.

In the UMS structure tree, go to Files and in the context menu, select New file.

In the New file dialog, configure the settings as follows:
Local file: Local file path of the certificate. Use the file chooser by clicking .
Device file location:  /etc/pam_pkcs11/cacerts  /  

Click Ok.
The file object is created in the UMS.
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2.

3.

4.
5.

1.
2.

3.

Assign the Certificate Files to the Devices

In the UMS structure tree, select the endpoints for which you want to configure the local login with 
a smartcard certificate. For mass deployment, it is recommended to use a directory containing the 
endpoint devices or a profile (see Creating Profiles).

In the  Assigned objects  area, click  .

Under  Files, select the required file objects using the   button: 

Click  Ok.
In the  Update time  dialog, select  Now  and click  Ok.
The certificates are transferred to the endpoint device.

Configuring the Devices

To enable local login with a smartcard certificate, you must configure the devices appropriately. For mass 
deployment, it is recommended to use a profile.

Go to Security > Smartcard > Middleware and select the middleware to be used.
Go to Security > Active Directory/Kerberos, activate Enable, and set Default domain (fully 
qualified domain name). For details, see Active Directory/Kerberos.
Go to System > Registry > auth > login > pkcs11 (registry key: auth.login.pkcs11 ) and 
activate Login with smartcard certificate.
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4.

5.

Go to System > Registry > auth > login > pkcs11_cert_policy (registry key: 
auth.login.pkcs11_cert_policy ) and enter the methods for certificate verification that 

are to be used. For further information, see the documentation in https://github.com/OpenSC/
pam_pkcs11.
If Kerberos enterprise names are used, go to System > Registry > auth > login > 
krb5_enterprise and activate Allow enterprise names.

Debugging

 If you need to debug the smartcard certificate login, go to System > Registry > auth > login > 
pkcs11_debug (registry key: auth.login.pkcs11_debug ) and activate Enable debugging of smartcard 
certificate login.
Logging messages will be available via syslog.

https://github.com/OpenSC/pam_pkcs11
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Desktop and Display
Display Configuration for Shared Workplace (SWP) (see page 661)
Display Switch (see page 662)
Multimonitor (see page 666)
Showing and Hiding the On-Screen Software Keyboard Automatically (see page 678)
Overcoming the Restrictions of a Full-Screen Session with the in-Session Control Bar (see page 679)
Screen Issues When Redocking Notebook (see page 681)
Using an External NVIDIA Graphics Card (see page 682)
Bluelight Filter for Nighttime Display (see page 683)
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Display Configuration for Shared Workplace (SWP)
As of IGEL Universal Desktop Linux version 4.14.100 and version 5.06.100, Shared Workplace allows user specific 
screen resolutions and configurations. Resolution, layout, refresh rate, rotation, number of screens, monitor 
connectors (DVI, VGA, ...) can be set per user, but color depth cannot.

Best practice
It is recommended to set the initial desktop configuration to the maximum number of screens and the resolutions 
to A utodetect . This way the user specific resolutions will not be restricted.

Debugging

If the total framebuffer size of the user specific resolutions exceeds the limits of the Virtual [width] 

[height]  setting from /config/Xserver/xorg.conf-0  (or /etc/X11/xorg.conf ), the user specific 
resolutions cannot be activated and the screen configurations are not changed dynamically.

There is no warning dialog or anything else to alert the user to this restriction. But you can find related log 
messages via journalctl  or in /var/log/messages :

XRANDR: ERROR: CANNOT APPLY CHANGES ->

XRANDR: ERROR: -> Selected modes ([width]x[height]) would exceed the maximum 

framebuffer size ([width]x[height])

•

•

There are technical limitations to user-specific settings: For VIA graphics drivers/hardware, the maximum 
desktop size is set in the Screen  section of the X confi guration file. The name and location of the X 
configuration file depends on the firmware version:

IGEL Linux version 10: /config/Xserver/xorg.conf-0

IGEL Linux version 5: /config/Xserver/xorg.conf-0  or /etc/X11/

xorg.conf  (this is a symbolic link that points to /config/Xserver/xorg.conf-0 )

In the Screen  section of the above-mentioned configuration file, you can find a line 

such as Virtual 1920 1200 . The size defined here cannot be changed dynamically; 
it is a hard limit for the overall desktop size.


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1.
2.

3.

1.
2.

Display Switch
If you are using a notebook with IGEL UDC2, UDC3, or UD Pocket, you might want to connect an additional monitor. 
If you are using an IGEL thin client (UD series), you might want to use two monitors. Any thinkable display mode, 
like clone mode/mirroring or extended mode, is possible. Moreover, you can change between the display modes 
quickly.

Configure a Starter for the Display Switch
There are many ways to start the display switch. The following example shows how to define a hotkey typical for a 
notebook.

Open the Setup and go to Accessories > Display Switch.
Activate Hotkey.

By default, [Fn]+[F7] ( XF86Display ) is defined as the hotkey for starting the display switch. You 
can change the hotkey by selecting or entering different keys in Modifiers and Key.

Press Apply or Ok.

Configure the Display Switch
Open the Setup and go to Accessories > Display Switch > Options.
Consider the following settings:

To enter a key that does not have a visible character, e. g. the [Tab] key, open a terminal, 
log on as user  and enter xev -event keyboard . Press the key to be used for the 

hotkey. The text in brackets that begins with keysym  contains the key symbol for the 

Key field. Example: Tab  in (keysym 0xff09, Tab)


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•

•

•

Dialog Type: In most cases, you can leave it at Minimal Dialog. The user can always switch 
to the advanced dialog, provided that Advanced in the Minimal Dialog area is activated.
Smart display configuration: Activate this option, if you want to save all your display 
configurations.
Preserve settings over reboot: Activate this if the settings made by the display switch are 
to remain unchanged after reboot.
Configure new displays when connected: Activate this if you want the display switch to 
start automatically as soon as a new monitor is connected.
To fine-tune the minimal dialog, change the settings under Buttons in Minimal Dialog.

Use the Display Switch
The minimal dialog will look similar to this; details depend on your specific setup:
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Button Function

Uses only display 1.

Shows the same content on all screens, i.e. clone mode or 
mirroring.

Extends the display area to the screen on the right.

Extends the display area to the screen on the left

Uses only display 2.
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Rotates the selected display to the left or to the right.

For more information, see the manual chapter Using Display Switch

.

The P marks the primary Display.


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Multimonitor
Working with two or more screens is becoming increasingly popular in professional working environments.

You can find out how to configure several screens and an extended desktop with the IGEL setup here.

There are different screen configuration options:

Automatic Configuration (see page 667)
Manual Configuration (see page 669)
Additional Settings (see page 671)
Auto Switch Monitor Configuration for Laptops (see page 676)

If you work with IGEL Universal Desktop or supported UDC2 hardware, multimonitor support is guaranteed.

Difficulties may arise if you work with UDC2 hardware and your hardware is not fully supported by IGEL.

 See the Linux 3rd party hardware database58 for supported graphic cards.

Multimonitor configuration for unsupported hardware only works if native graphic driver support 
functions properly. You must ensure that the native driver really does work because the fallback VESA 
driver does not allow multimonitor configuration. Click About in the Application Launcher to determine 
which graphic chipset you work with. If VESA is listed there, the native driver will not work and 
multimonitor configuration will not be possible.



https://www.igel.com/linux-3rd-party-hardware-database/
https://www.igel.com/linux-3rd-party-hardware-database/
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3.

4.

5.
6.

Automatic Configuration
The firmware recognizes the native graphic driver and will apply the screens automatically by default.

Define two or more monitors:

Go to User Interface > Display in the structure tree.
Select 2 (or more) under Number of screens.

Choose the screen under Selected screen or by clicking it with a mouse.
The selected screen is highlighted with a blue frame:

Set Screen Resolution to Autodetect (default setting).
The operating system reads out the EDID (Extended Display Identification Data) of the monitors 
through DDC (Display Data Channel). With these data, the correct resolution for the monitors can 
be recognized and set.

Enable Detect refresh rate automatically (default setting) under Advanced.
Set Monitor to Automatic.
The selected screen is automatically assigned to the graphic connector (monitor).

The number of monitors that you can select depends on your hardware. Using the Universal 
Management Suite (UMS), you can choose up to 8 monitors.



If the Autodetect resolution is not available check Monitor probing (DDC) under User 
Interface > Display > Options. The Monitor probing (DDC) must be enabled (default 
setting).



With more than 2 monitors, the screen resolution has to be specified for each screen manually.
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7.

8.

Drag and drop the rectangles to position the screens.

Click Apply or OK to save the settings.

Screen 1 is always the primary screen where the taskbar is situated.
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1.

2.
3.

Manual Configuration
During automatic configuration, the following problems can sometimes arise:

One of the screens remains black.
There is the same display on all screens.

In this case, you can set the screens manually:

Go to User Interface > Display in the structure tree.

Select a screen number under Selected screen.
Specify the resolution manually under Screen resolution.

The standard resolution setting is Autodetect.

•

•

From IGEL Linux Version 10.03.100, you have the option of defining your own resolutions via the 
registry ( x.xserver0.custom_resolution ). In order for the values set there to take effect, 
the resolution must be set to Autodetect (the slider at the far left). The following parameters apply 
to the entry in the registry:

WxH  : W = width, H = height (example: 1920x1080)

WxH@R : W = width, H = height, R = refresh rate (example: 1920x1080@60 or 
1920x1200@59.8)


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4. Select for all screens the respective connector under Monitor. The manual configuration can take 
effect only if you assign the monitor connector to all screens.

Tip:

 Click   in your client setup to obtain information about the connector names, screen resolutions and screen 
numbers.

The black field belongs to the screen number on the left side:

If you adjust the settings directly in IGEL Setup, only the connected monitors will be 
available in the selection list. If you want to configure the screens using the UMS profile, all 
possible connectors will be shown in the selection list and you will not know which one is 
relevant for your device.



This configuration cannot be accessed from the UMS.
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Additional Settings
A number of useful tips are provided below:

Rotating a Screen (Pivot) (see page 672)
Setting Different Backgrounds (see page 673)
Useful Window Settings (see page 674)
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1.
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Rotating a Screen (Pivot)

Click on a monitor field.

Select (Rotates the selected screen counterclockwise) or   (Rotates the selected screen 
clockwise).

 Alignment: If you enter the correct resolution, you can see the real size of the screens and you will be able to 
align them the way you want.

Two screens with autodetected resolutions are automatically aligned to the top.

The individual screen areas must however be in contact with each other at one edge and corner, and 
cannot overlap.


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Setting Different Backgrounds
You can easily set different backgrounds for your screens.

 Click User Interface > Desktop > Background in the structure tree of the setup.
There is a configuration page for each screen.

 Select the wallpaper and define the style.

You may also upload your own Custom Wallpaper, e.g. a background with your corporate design. See 
Creating Your Own Wallpaper (see page 781).


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Useful Window Settings

Setting the Start Monitor or Full-screen Mode:

Click the name of your session under Sessions in the IGEL Setup, e.g. RDP > RDP Sessions.
lick [Session Name] > Window to configure the window settings.

Setting the Multimonitor Full-screen Mode

Click Window in the global folder of your session, e.g. RDP > RDP Global > Window.
Configure the window settings.

Defining the Taskbar

Click User Interface > Desktop > Taskbar.
Define the Taskbar settings.

For the function "2nd monitor as Start monitor" the Window size has to be set to full-
screen.


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If you want to expand the taskbar onto all monitors, you have to ensure that the screens 
are aligned to the bottom. Otherwise, you will see only half of the taskbar on one monitor.


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3.

4.

5.

6.
7.

•
8.
9.

Auto Switch Monitor Configuration for Laptops
This ist one example of how to configure auto switch monitor for Laptops.

Connect the device and close/open lid.
Open the Display Switch utility (which has already been activated under Accessories > Display 
Switch).

In the advanced mode, you can drag & drop the displays for your intended configuration.
The display will snap adjacent to others.
If a display should not be used, it can be dragged to the Disabled area on the top right - the screen 
will be reactivated when it is dragged back to the active area.
To show the same content on multiple displays, one display should be dragged onto an other 
active screen.
The interface will show Mirrors. The mirroring monitor will be displayed on the lower right.
Press Apply to save the setting
Press Yes on the Keep configuration dialog so that the current settings will be saved to persistent 
storage and associated with the profile.
You can configure advanced functionality (e. g. panning, scaling and resolutions) in drop-down 
boxes (hidden in a drawer on the right side)

Klick the > button on the right edge.
Go in IGEL Setup under Accessories > Display Switch > Options.
Enable Preserve settings over reboot and Smart display configuration. (Default: disabled)
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2.
3.

The IGEL Display Switch utility is now used for NVIDIA graphic devices as well.

Configuration of the display setting for Notebook lid handling
You can configure the lid handling of a notebook so that the notebook goes into standby mode by closing the lid, 
regardless of whether the notebook is plugged in or not.

Settings of the Standby Mode

If you want your notebook to go into standby mode by closing the lid, while your notebook is plugged in, you have 
to do following setting:

Go under IGEL Setup to System > Registry > system > actions > lid > ac.
Set Lid close action while plugged in to Suspend.(Default: Turn off display)
Click Apply or Ok to save the setting.

If you want your notebook to go into standby mode by closing the lid, while your notebook isn't plugged in, you 
have to do following setting:

Go under IGEL Setup to System > Registry > system > actions > lid > battery.
Set Lid close action while not plugged in to Suspend.(Default: Turn off display)
Click Apply or Ok to save the setting.

1.

2.
3.

If you want that the notebook turn off display after closing the lid, it makes sense to set the following 
setting to switch off the notebook internally:

Go under IGEL Setup to System > Registry > sessions > user_display0 > options > 
lid_events.
Enable React on lid open and close event.
Click Apply or Ok to save the setting.


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Showing and Hiding the On-Screen Software Keyboard Automatically
You can configure the on-screen software keyboard to appear or disappear automatically when an input box is 
selected or deselected (e. g. Firefox or screenlock). 

Showing Automatically
With the following setting, a software keyboard will be shown automatically when an input box is focused.

In the Setup, go to Registry > userinterface > softkeyboard > autoshow (parameter: 
userinterface.softkeyboard.autoshow ).

Enable Automatically show on-screen keyboard when text field is selected.

Hiding Automatically
With the following setting, the software keyboard will be hidden automatically when an input box is not focused 
anymore.

In the Setup, go to Registry > userinterface > softkeyboard > autohide (parameter: 
userinterface.softkeyboard.autohide )

Enable Automatically hide on-screen keyboard when text field is deselected.

If there are any problems, e. g. the keyboard does not hide automatically, you have to disable Automatically hide 
on-screen keyboard when text field is deselected and make sure that the following Setup parameters have been 
enabled:

Accessories > On-Screen Keyboard > Autostart 
Accessories > On-Screen Keyboard > Restart
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Overcoming the Restrictions of a Full-Screen Session with the in-Session 
Control Bar
Running a session in full-screen mode gives you the advantage that the complete real estate of your monitor is at 
the disposal of that session. However, you might still want to eject a hotplug drive, or to minimize or end the 
current session. The solution provided by IGEL Linux is called in-session control bar.

Activating the in-session control bar:
Open the Setup and go to User Interface > Desktop > In-Session Control Bar.
Activate Use in-session control bar in all supported sessions if you want to have an in-session 
control bar in all session types for which it is supported. If you want to have an in-session control 
bar only in sessions of certain types, activate the appropriate options, e.g. Control bar for RDP 
sessions.

In the Start Monitor choice, select the display on which you want the in-session control bar to 
appear. If unsure, leave it at Automatic.

Click Apply or Ok.

Using the in-session control bar:
Move the mouse to the upper edge of the desktop.
The in-session control bar appears.

To perform the desired action, click the appropriate icon:
To eject a USB device, click .
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To minimize the session view, click .
To end the session, click .
To make the in-session control bar visible permanently, click .
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Screen Issues When Redocking Notebook
Environment

UDC-converted notebooks running IGEL Linux 5 and above.

Issue

When you take a notebook off the dock, e. g. to move to meeting rooms or other locations, and redock the 
notebook, the screen resolution ends up wrong, sometimes with a black screen and other similar screen issues.

Solution

In Setup, go to Accessories > Display Switch > Options.
Enable Configure new Displays when connected.
The display switch will start when the notebook is redocked.
Use the display switch to configure the display appropriately. For further information, see the Tips 
& Tricks article Display Switch.
Click Ok to save the settings.

Legal Note

IGEL's Terms & Conditions59 apply.


https://www.igel.com/terms-conditions/
https://www.igel.com/terms-conditions/
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Using an External NVIDIA Graphics Card

Goal
You want to use an external NVIDIA graphics card for your endpoint device and need to connect it with all graphics 
outputs.

Environment
IGEL OS 11.04.100 or higher

Solution
In the IGEL Setup, go to System > Registry.
Set the registry key x.drivers.preferred_driver to nvidia .
Enable the registry key x.drivers.nvidia.use_modeset. This registry key should be used if you 
want to use PRIME.
Restart the device manually, e.g. by pressing the power switch.
Under User Interface > Display, orient and position your monitors.
For fine-tuning, use the Display Switch function, which can be enabled under Accessories > 
Display Switch. See Using Display Switch and Display Switch.

Then the onboard graphics ports as well as the ports of the NVIDIA card can be used, which is the recommended 
mode since everything is rendered on the NVIDIA GPU.
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Bluelight Filter for Nighttime Display
You can configure a blue light filter in your IGEL OS device to reduce your display's percentage of blue light display 
for nighttime use.

By default, the blue light filter is disabled.

Automatic Retrieval of the Geodata (Recommended)
When you select automatic mode, IGEL OS will collect the geo-coordinates for your device to determine the right 
time zone. For this purpose, Geoclue is used. Geoclue utilizes a variety of location sources, e.g. the Mozilla Location 
Service. For more information about  Geoclue, see https://gitlab.freedesktop.org/geoclue/geoclue/-/wikis/home. 
For more information about the Mozilla Location Service, see https://wiki.mozilla.org/CloudServices/Location.

Based on this data, it will switch the display to daylight brightness at sunrise time and switch it to nighttime 
brightness at sunset time.

Open the configuration dialog and set System > Registry > userinterface > bluelight_filter > 
mode to Auto. 

Continue with configuring the Daylight and Nightlight Brightness (see page 685).

Setting the Geodata Manually
Open the configuration dialog and set System > Registry > userinterface > bluelight_filter > 
mode to Manual. 

https://gitlab.freedesktop.org/geoclue/geoclue/-/wikis/home
https://wiki.mozilla.org/CloudServices/Location
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2. Set latitude to the latitude of your location.
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1.

Set longitude to the longitude of your location.

Continue with configuring the Daylight and Nightlight Brightness (see page 685).

Daylight and Nightlight Brightness
Go to daylight brightness and set the value according to your needs. Example: 1.0 = full 
brightness, high color temperature
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2. Go to nightlight brightness and set the value according to your needs. Example: 0.5 = 50% 
brightness, lower color temperature
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3. Click Apply or Ok to save your changes.



Customizing

IGEL OS Articles   688 / 1017

•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Customizing
Custom Partition Tutorial (see page 689)
Using a Custom PKCS#11 Library (see page 769)
Adding an Icon for Browsing Removable Storage (see page 771)
Adding an Icon for the Image Viewer (see page 773)
Creating a Timed Command (Cron Replacement) (see page 775)
Customizing IGEL OS Desktop (see page 777)
How to Change the Font Color of the Desktop Icons (see page 800)
How to Set Up a Countdown to Prevent an Undesired Screen Lock In IGEL OS (see page 803)
Installing a Calculator on IGEL Linux (see page 815)
Keyboard Shortcuts for Managing Windows (see page 816)
Make Frequent User Actions Easier by Defining Hotkeys (see page 817)
Shutdown/Suspend Devices Automatically at the End of a Session (see page 819)
Suspend to RAM - Wake Up by USB Mouse (see page 820)
Taking Screenshots on IGEL Linux (see page 821)
Setting the Device's System Time (see page 822)
Updating Timezone Information (Daylight Saving Time, DST) (see page 823)
Adding or Changing a MIME Type Handler (see page 826)
Regional Settings in Sessions (see page 830)
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Custom Partition Tutorial
The Custom Partition mechanism solves the task of supplying additional software or other files to IGEL OS while still 
being able to update the system in the regular way.

This tutorial describes creating content for a Custom Partition for IGEL OS 11.01.100 or newer. In the examples, IGEL 
OS 11.03.500 is used. You may also find it useful for updating existing Custom Partitions in order to make them work 
on IGEL OS 11.01.100 or newer, as some details have changed.

This tutorial contains the following sections:

A First Simple Custom Partition (see page 690)
Packaging the Custom Partition (see page 700)
A Real-World CP: Chromium (see page 716)
Zoom as a Custom Partition (see page 731)
Microsoft Teams as a Custom Partition (see page 751)

The IGEL Support Team offers support for the deployment of Custom Partitions. However, it is not possible 
to offer support for any third-party software that is installed on a Custom Partition.



If you want to build a Custom Partition and give it to third parties, make sure you have redistribution 
permission for the software. This is usually the case for Open Source / Free Software, but not for 
proprietary software. Read the license agreements and respect them.


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4.
5.

A First Simple Custom Partition
As a first step, this tutorial will guide you through creating a simple Custom Partition. It will open a message window 
greeting the user, which can be run by clicking a desktop icon. You will learn about some basic mechanisms of 
Custom Partitions in this section.

Read all the following chapters in the order given and follow the instructions.

Development Environment (see page 691)
Activating the Custom Partition Functionality (see page 692)
"Hello World" Program (see page 693)
Creating the Custom Application (see page 695)
Using a Partition Parameter (see page 698)
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Development Environment

For this first simple Custom Partition, you only need  root  access to a device with IGEL OS version 11.01.100 or 
higher.

Next Step

>> Activating the Custom Partition Functionality (see page 692)
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4.

5.

Activating the Custom Partition Functionality
First, you must activate the Custom Partition functionality. It is deactivated by default.

Open the Setup and go to System > Firmware Customization > Custom Partition > Partition.
Check Enable Partition.
Set the Size to "10M" Megabyte).
Leave the Mount Point at /custom

Click Apply.
The Custom Partition is created on the device's mass storage, which is indicated by a message.
When the Custom Partition is created and successfully mounted, the message reads:

Next Step

>> "Hello World" Program (see page 693)
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3.

4.

5.

6.

"Hello World" Program
Your first Custom Partition will contain a simple shell script that displays the message "Hello, world!" with the help 
of the gtkmessage utility.

Open the local terminal on your device and log in as root . If the local terminal has not been 
configured yet, see Terminals.
Change into the /custom  directory: cd /custom

Make a hello  directory for your Custom Partition contents: mkdir hello

Change into the hello  directory: cd hello/

Open a new plaintext file using the GNU nano editor: nano hello.sh

Put this content into the file:
#!/bin/bash
gtkmessage -m "Hello, World!" -t "Hello" -o "Close"

The colors used by default for syntax highlighting in nano may be inconvenient for reading. You can 
change the colors with the following command:  sed -i "s#color cyan#color blue#; 

s#color brightyellow#color red#" /usr/share/nano/sh.nanorc
Also, you can use the vi editor as an alternative; the commands for exiting and saving a file will be 
different then.


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10.

Save the file by pressing [Ctrl]+[o], [Return].
Exit the GNU nano editor by pressing [Ctrl]+[x].
Make the file executable: chmod a+x hello.sh

Run the shell script from the command line to test it: ./hello.sh

A message window like this should open: 

You can close it with the Close button.

Next Step

>> Creating the Custom Application (see page 695)
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Creating the Custom Application
In the previous step, you have created a little application and executed it from the command line. Now make it 
more convenient for end-users: Create a custom application and place an icon on the desktop that users can click.

In the Setup, go to System > Firmware Customization > Custom Application.
In the Custom Applications list, click  to add an application.

The Desktop Integration page opens.
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Enter Hello Application  as the Session name.

Click Apply.
Go to Settings.
Enter /custom/hello/hello.sh  as the Command.

Click OK.
A Hello Application icon has appeared on the desktop.
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8. Double-click the icon.
The "Hello" message window should open.

Next Step

>> Using a Partition Parameter (see page 698)
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Using a Partition Parameter
When you roll out the same Custom Partition contents to many devices, you may still want the application to use 
different data or options on some of the devices. Partition parameters allow you to do this.

This is how you add a partition parameter to our "Hello World" program.

Setting a Partition Parameter in the Setup

Go to System > Firmware Customization > Custom Partition > Partition.
In the Partitions Parameters list, click .

In the dialog that opens, enter NAME as the Name and Alice as the Value. Click OK.

Click Apply.

Getting the Value of a Partition Parameter

This is the command line for getting or setting a Partition Parameter's value:



Customizing

IGEL OS Articles   699 / 1017

1.

2.

customparam [get|set] PARAMETER_NAME [PARAMETER_VALUE]

Change the hello.sh  script to use this command to get the parameter value:

#!/bin/bash
gtkmessage -m "Hello $(customparam get NAME)!" -t "Hello" -o "Close"

Click the Hello Application desktop icon.
You should see the following:
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•

Packaging the Custom Partition
In the previous section, you developed Custom Partition contents locally on a device. Now, package it in order to 
deploy it to many devices via the Universal Management Suite (UMS).

Read all the following chapters in the order given and follow the instructions.

Development Environment (see page 701)
Compressing the Custom Partition Contents (see page 702)
Writing the *.inf Metadata File (see page 703)
Uploading the Files to the UMS (see page 704)
Creating a Profile for the Custom Partition (see page 709)
Assigning the Profile (see page 714)

When you have built this Custom Partition successfully, you can continue with a real-world partition. The following 
Custom Partitions are described in our tutorial:

Chromium (see page 716)
Zoom (see page 731)
Microsoft Teams (see page 751)
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Development Environment
For this section, you need:

a system with IGEL OS 11.01.100 or newer
Universal Management Suite (UMS) 6.01.100 or newer

Next Step

>> Compressing the Custom Partition Contents (see page 702)
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Compressing the Custom Partition Contents

The contents of a Custom Partition are packaged as a compressed tar  file. Create it on the Linux command line, 
e.g. on a device that is running IGEL OS:

In the local terminal, become root  and change to the /custom  directory: cd /custom

Compress the contents of the hello/  directory into an archive file named hello.tar.bz2 :

tar cjvf hello.tar.bz2 hello/  

The result is a hello.tar.bz2  file, sitting side-by-side with the hello/  directory. You will 
upload it to UMS later.

Next Step

>> Writing the *.inf Metadata File (see page 703)
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Writing the *.inf Metadata File
In addition to the compressed archive that you created in the previous step, a plain text file with essential 
information for the endpoint device is necessary. In this, step you will create the hello.inf  file.

Change to the directory that contains the compressed contents of our Custom Partition 
( hello.tar.bz2 ): cd /custom/

Create a new file named hello.inf  and put the following into it:

[INFO]

[PART]

file="hello.tar.bz2"

version="1.0_igel1"

size="10M"

name="hello"

minfw="11.01.100"
The individual entries and their meaning are:
[INFO]  Mandatory string

[PART]  Mandatory string

file  The filename of the *.tar.bz2  archive

version  The version of the contents, consisting of the vendor version (let's say this is "hello 
1.0") and the IGEL package version (the first package we produced of the software), joined with an 
underscore.
size  Size of the decompressed contents

name  Name of this content, used for naming the subdirectory within the custom partition and for 
keeping track of installed contents
minfw  Minimum firmware version required for these contents

Save the file.

Next Step

>> Uploading the Files to the UMS (see page 704)
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Uploading the Files to the UMS

In this step, you upload the compressed hello.tar.bz2  archive and the hello.inf  metadata file to the 
UMS, which will serve them to other devices via HTTPS. To make the file available, you have to create a file object 
after transferring the physical file.

Transferring the Files to the UMS

In the structure tree of the UMS Console, go to the device on which you have created the files and 
select Other commands > Device File->UMS.
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In the Device File->UMS dialog, under Device file location, enter the complete path and file name 
of the bz2 archive: "/custom/hello.tar.bz2"

Click   next to the Target URL to define the file path on the UMS Server.
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In the Save dialog, select ums_filetransfer as the directory.

Enter "hello.tar.bz2" as the File Name and click Save.
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Back in the Device File->UMS dialog, click Device File->UMS.

Repeat steps 1 to 6 for the metadata file hello.inf .

Creating File Objects

In the UMS Console, right-click the Files folder in the structure tree and select New File from the 
context menu.
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The New file dialog opens.
Activate Select from UMS server and click   next to this option to open the file chooser.
Select ums_filetransfer.

Select "hello.tar.bz2" and click Open.
Back in the New file dialog, click Ok.
Repeat steps 1 to 4 for the metadata file hello.inf .

Next Step

>> Creating a Profile for the Custom Partition (see page 709)
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Creating a Profile for the Custom Partition
After you have uploaded the Custom Partition files to the UMS, you can now make the settings that will install the 
Custom Partition on any number of devices. For this purpose, we will create a profile. 

Activating the Custom Partition

In the structure tree of the UMS Console, right-click the Profiles folder and select New Profile
from the context menu.

In the New Profile dialog, enter "Hello" as the Profile Name and something like "Installs the Hello 
Custom Partition" as the Description. You can leave the remaining fields.

Click OK.
The configuration dialog opens, where you will make the settings for this profile.
Go to System > Firmware Customization > Custom Partition > Partition.
Unlock the Enable Partition setting by clicking the orange triangle so that it turns blue.
Check Enable Partition.
Unlock the Size setting by clicking the orange triangle so that it turns blue, and enter "10M".
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Leave the Mount Point at "/custom".

Setting the Download Source

For this step, you need to determine the HTTPS download address for the hello.inf  file first.

To find out the IP address of your UMS, go to System > Remote Management in the configuration 
dialog. You will find the IP address of the UMS Server your device is registered with.
Open a web browser and visit the following URL:
https://[IP or name of your UMS host]:8443/ums_filetransfer

When prompted, authenticate with your UMS username and password.
You will see a directory listing of the files that can be downloaded from the UMS.
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Right-click the hello.inf  entry and select Copy link address (or the like, depending on your 
browser).
In the profile's settings, go to System > Firmware Customization > Custom Partition > 
Download.
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Next to Partitions Data Sources, click [+].

The Add dialog opens.
Paste the URL you copied from the browser into URL.
Enter the User name and Password so that the device has access to your UMS.
You can ignore the Initial action and Final action fields for the time being.

Click OK.



Customizing

IGEL OS Articles   713 / 1017

Creating a Custom Application

 Add a custom application to the profile by following the steps in Creating the Custom Application (see page 695).

Next Step

>> Assigning the Profile (see page 714)
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Assigning the Profile
Now that you have put all the settings for installing the Custom Partition on a device into a profile, it is time to 
assign the profile.

In the UMS structure tree, drag and drop the icon of your profile onto the icon of a device.

The Update time dialog opens.
Select Now and click Ok.

The device receives the settings of the profile, creates the Custom Partition, downloads the 
contents of the Custom Partition and uncompresses them. 
The Hello Application icon appears on the desktop.
In the device's local Setup, go to System > Firmware Customization > Custom Partition > 
Partition.
Add a Partition Parameter with the Name "NAME" and a Value of your choice.

Back in the Setup, click Ok.
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6. Click the icon to test the application.
It should open, displaying a text containing the name of your choice.
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A Real-World CP: Chromium
The previous example was simplified, but it taught you a lot of the IGEL Custom Partition fundamentals. Now build 
on top of these and try your hand at a real-world CP: the Chromium web browser - the Open Source sibling of 
Google Chrome, a complex application with a variety of features.

_____

Development Environment (see page 717)
Getting the Ubuntu Package (see page 718)
Unpacking the Ubuntu Package (see page 719)
Creating a Larger CP (see page 720)
Setting Up Library Paths via Script (see page 721)
The First Run (see page 723)
Obtaining Libatomic (see page 724)
Installing Libatomic (see page 725)
Another Test Run (see page 726)
Providing Libffmpeg (see page 727)
Chromium Starts Successfully (see page 728)
Packaging the Custom Application (see page 729)
Advanced (see page 730)

As you will be working with original Ubuntu packages, actual version numbers (or packages) may differ 
from this tutorial, as Ubuntu frequently update their packages. The method for building the CP, however, 
remains the same.


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Development Environment
For this section you need

a system with IGEL OS version 10.03.100 or newer,
a Windows or Linux workstation with Universal Management Suite (UMS) in version 5.07.100 or 
newer,
a Debian or Ubuntu Linux workstation for unpacking the *.deb  package (can be the same as the 
Linux workstation hosting UMS),
a method to exchange files between the thin client and the workstation.
While a USB pen or disk drive would do the trick, it is more convenient to have either a

Windows fileshare or
an NFS export

that you can access both from the thin client and the workstation in order to exchange files.
Learn how to mount network drives in the IGEL OS Manual.60

http://edocs.igel.com/11105.htm
http://edocs.igel.com/11105.htm
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Getting the Ubuntu Package
As the Chromium web browser is Free Software it can be found in the package repositories of Linux distributions. To 
build Custom Partitions, use the software packages from exactly that Ubuntu version on which your version of IGEL 
OS is based. From IGEL OS 10.04 up to IGEL OS 11.03, this is Ubuntu 16.04 (Xenial Xerus). You need packages for the 
amd64  (also known as x86_64 ) architecture.

This is how to find the right package and download it to your Linux workstation:

In a web browser, go to https://packages.ubuntu.com
Use the Search package directories form to search

Set Keyword to chromium

Set Distribution to xenial
Click Search.

On the results page, click the chromium-browser package to go to its details page.
At the bottom of the details page, click the amd64 link to download the package to a local 
directory on your Linux workstation.
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Unpacking the Ubuntu Package
Extract the Ubuntu package on your Debian/Ubuntu Linux workstation in order to access its files:

Open a terminal emulator.
Change to the directory where you saved the Ubuntu package.
Create a directory to extract the files to:
mkdir chromium-browser

Extract the package to the new directory:
dpkg -x *.deb chromium-browser/

Run the following command to see how much space the package contents need in total (in MB):
du -cms chromium-browser/*  

The total is 255 MB (your package may differ slightly). To be on the safe side let's memorize that we 
need approximately 400 MB of space for the CP contents.
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Creating a Larger CP
Create a larger Custom Partiton so we can put all the Chromium package files into it.

On the thin client, make sure that you have closed all Local Terminal windows.
In UMS Console, navigate to your target thin client.
In Assigned Objects, remove the Hello CP profile from this thin client.
When prompted When should these changes take effect? select Now.
The existing Custom Partition is deleted.
Right-click the thin client and select Edit Configuration.
In Setup go to System > Firmware Customization > Custom Partition > Partition.
Check Enable Partition.
Set the Size to 400M (Megabyte) to be on the safe side.

Leave the Mount Point at /custom
Click Save.
The new Custom Partition is created.
On the thin client, open a Local Terminal and log in as root

Change into the Custom Partition: cd /custom

Check the size of the Custom partition: df -h ./
It should be roughly 400M - if it is still roughly 10M, close Local Terminal and use Setup to first 
disable and then re-create the Custom Partition again.
Copy the complete chromium-browser/  directory with all its contents from the Debian/
Ubuntu machine into the Custom Partition on the thin client.
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Setting Up Library Paths via Script
With the whole package contents in place, you need to make sure that Chromium will be able to find its libraries 
and other needed files. There is a pre-fabricated script for this.

Log into Local Terminal as root .

Change into the /custom/chromium-browser  directory.

Enter the command ls -l .

You will see that instead of a single script as in the previous example there are the etc/  and 

usr/  directories. They include many libraries and other files that Chromium will need to run.

However, it expects these directories not within the /custom/chromium-browser/

directory, but in the filesystem root, where system directories such as /usr  are located. The 
Initialization Script for the Custom Partition will fix this by setting up symbolic links, so that for 
example /custom/chromium-browser/usr/lib/library.so  will appear to be in /

usr/lib/library.so , where Chromium expects it.

Use the GNU nano editor to create the file custompart-chromium-browser  and put the 

following contents into it - alternatively, edit the file elsewhere and copy it into /custom/

chromium-browser/ :

#!/bin/sh

ACTION="custompart-chromium-browser_${1}"

# mount point path

MP=$(get custom_partition.mountpoint)

# custom partition path

CP="${MP}/chromium-browser"

# output to systemlog with ID amd tag

LOGGER="logger -it ${ACTION}"

echo "Starting" | $LOGGER

case "$1" in

init)

    # Initial permissions

    chown -R root:root "${CP}" | $LOGGER

    chmod 755 "${MP}" | $LOGGER

    # Linking files and folders on proper path

    find "${CP}" | while read LINE

    do

        DEST=$(echo -n "${LINE}" | sed -e "s|${CP}||g")

        if [ ! -z "${DEST}" -a ! -e "${DEST}" ]; then

            # Remove the last slash, if it is a dir
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            [ -d $LINE ] && DEST=$(echo "${DEST}" | sed -e "s/\/

$//g") | $LOGGER

            if [ ! -z "${DEST}" ]; then

                ln -sv "${LINE}" "${DEST}" | $LOGGER

            fi

        fi

    done

    ldconfig

;;

stop)

    killall -q -SIGTERM chromium-browser

    sleep 1

    killall -q -SIGKILL chromium-browser

;;

esac

echo "Finished" | $LOGGER

exit 0

Make the script executable with the following command:
chmod a+x custompart-chromium-browser

Run the script:
./custompart-chromium-browser init  

It should run and finish without any errors. 
The library paths are set up now.

Use this as a script template for your Custom Partitions, replacing all instances of 
chromium-browser  with the directory name of your CP.


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The First Run
Now that the paths for the complete Chromium package contents have been set up, try running the program for the 
first time:

Log into Local Terminal as root .

Change into the /custom/chromium-browser/ directory.

The  usr/bin/  and usr/lib/  directories are good candidates for Chromium's main 
executable. Try to run the following command:
./usr/lib/chromium-browser/chromium-browser  

You will see the following error message:
/usr/lib/chromium-browser/chromium-browser: error while loading 

shared libraries:

libatomic.so.1: cannot open shared object file: No such file or 

directory

This tells you that the program tries to load the shared library libatomic.so.1 , but can't find 
it. 
You will need to obtain libatomic.so.1 and install it.
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Obtaining Libatomic
The source for Libatomic will be Ubuntu Package Search again:

In a web browser, go to https://packages.ubuntu.com
This time use the Search the contents of packages form to search.

Set Keyword to libatomic.so.1
Select packages that contain files named like this.
Set Distribution to xenial

Set Architecture to amd64
Click Search.

This time the results page lists a lot of packages. But with the background knowledge that IGEL OS 
libraries are located in /usr/lib/x86_64-linux-gnu/  you will find that libatomic1 is the 
desired package. Download it to a local directory on your Linux workstation.
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Installing Libatomic
This step installs Libatomic and sets up a symbolic link so the Chromium will find it.

Extract the package contents with this command:
dpkg -x libatomic*.deb libatomic

Change into the extracted contents:
cd libatomic1/usr/lib/x86_64-linux-gnu/

List its contents in long form:  ls -l

This shows you that the library file is actually named libatomic.so.1.1.0  and that 

libatomic.so.1  is a symbolic link to it. We will recreate the link on the thin client later.

Transfer the libatomic.so.1.1.0  file to the thin client and place it in:

/custom/chromium-browser/usr/lib/chromium-browser/
Change into the directory:
cd /custom/chromium-browser/usr/lib/chromium-browser/

Create the symbolic link:
ln -s libatomic.so.1.1.0 libatomic.so.1  

Now Libatomic is set up to be used by Chromium.
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Another Test Run
Test whether Chromium now has everything it needs to run.

Change into the Custom Partition directory on the thin client:
cd /custom/chromium-browser

Run Chromium:
./usr/lib/chromium-browser/chromium-browser

You will see this error message:
/usr/lib/chromium-browser/chromium-browser: error while loading 

shared libraries:
libffmpeg.so: cannot open shared object file: No such file or 

directory

It seems Libatomic is no longer a problem, but now Chromium needs a further library: 
libffmpeg.so
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Providing Libffmpeg
To obtain Libffmpeg, repeat the process for obtaining Libatomic (see page 724). Hint: The Ubuntu package is named 
chromium-codecs-ffmpeg . It contains the file libffmpeg.so , which you need to transfer to the thin 

client. Place it in /custom/chromium-browser/usr/lib/chromium-browser/.

•
•
•
•
•

This is a procedure that you need to repeat until you have supplied all required libraries:
Run the application from the commandline.
Scan the error message for needed libraries.
Obtain and install the required libraries.
Run the application from the commandline.
...


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Chromium Starts Successfully

Now you are ready to give running Chromium another try. It does not like to be started by root , because it is 

much safer to run it as the non-privileged user .

Log into Local Terminal as user .

Change into the /custom/chromium-browser  directory.
Enter the following command:
./usr/lib/chromium-browser/chromium-browser  

Chromium starts for the first time. Congratulations, you now have working Chromium installation.

The next step will package the Custom Partition so it can be deployed to any number of thin clients from UMS:
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Packaging the Custom Application
Now that the hardest part of creating the Custom Partition is done, package the CP for UMS. You are already 
familiar with most of the steps from earlier in this tutorial.

Compress the CP Contents (see page 702) into chromium-browser.tar.bz2
Upload the compressed file to UMS as a new File.
Write the *.inf Metadata File (see page 703) with 400M as size.
Upload the *.inf Metadata File to UMS as a new File.
Create a Profile for the CP (see page 709) with the Initializing Action set to:
/custom/chromium-browser/custompart-chromium-browser init

and the Finalizing Action set to: 
/custom/chromium-browser/custompart-chromium-browser stop

Create a Custom Application (see page 695) with the Command set to:
/custom/chromium-browser/usr/lib/chromium-browser/chromium-browser

Assign the CP to a new thin client in order to test everything.
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Advanced
Here are some advanced topics for you to try after you have completed this tutorial.

Using ldd to Find Required Libraries

Using the ldd  command is another way of determining the libraries that a binary requires.

Log into Local Terminal as root .

Find out which file the main binary of the Custom Partition is. It is usually found in bin/ , usr/

bin/  or usr/lib/  and is named similar to the application name.
Run the following command:
ldd /custom/[name]/[binary] | grep 'not found'  

This command line contains a filter, so that it will only show you those libraries that could not be 
found.

Auto-updating Custom Partitions

The Custom Partition mechanism in IGEL OS can update the Custom Partition contents automatically when a newer 
version is available on UMS. To activate it, follow these steps:

In Setup, go to System > Firmware Customization > Custom Partitition > Download.
Open the CP entry in the Partitions Data Sources list.
Enable Automatic Update.
Click OK.
Click Apply or Save in the Setup window.
On UMS, increase the version property in the  *.inf  metadata file.
When booting, the thin client checks whether there is a higher version of the Custom Partition 
available on UMS. If so, the new CP version will be downloaded automatically.
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Zoom as a Custom Partition
Now that you have learned the IGEL Custom Partition fundamentals, build on top of these and try your hand at a 
real-world Custom Partition: Zoom.

Read all the following chapters in the order given and follow the instructions.

Development Environment (see page 732)
Getting the Packages (see page 733)
Unpacking the Packages (see page 734)
Creating the Initialization Script (see page 735)
Compressing the Custom Partition Contents (see page 738)
Writing the *.inf Metadata File (see page 739)
Uploading the Files to the UMS (see page 740)
Creating a Profile for the Custom Partition (see page 743)
Assigning the Profile and Testing the Application (see page 750)
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Development Environment
For this section, you need

a system with IGEL OS 11.01.100 or newer,
Universal Management Suite (UMS) 6.01.100 or newer,
a Debian or Ubuntu workstation for unpacking the *.deb  package (can be the same as the Linux 
workstation hosting the UMS. Ideally, the machine is running Ubuntu 18.04 LTS.
a method to exchange files between the endpoint device and the workstation.
While a USB memory stick or disk drive would do the trick, it is more convenient to have either a

Windows fileshare or
an NFS export

that you can access both from the endpoint device and the workstation in order to exchange files.
Learn how to mount network drives in the IGEL OS Manual.

Next Step

>> Getting the Packages (see page 733)
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1.
•
•
•

2.

3.

4.

Getting the Packages

Get the required packages for Ubuntu. Apart from the Zoom package, you need the package  libxcb-

xtest0[version].deb  (contains the shared libraries libxcb-test.so.0  and libxcb-

test.so.0.0.0  which are required by the Zoom package).

Open https://zoom.us/download?os=linux in a browser and select the following:
Linux Type: "Ubuntu"
OS Architecture: "64 bit"
Version: "16.04+"

Download the Ubuntu/Debian package  zoom_amd64.deb

Change to the download directory on your workstation (typically  /home/[username]/

Downloads ).

Download libxcb-xtest0[version].deb  with the following command:

apt download libxcb-xtest0

Next Step

>> Unpacking the Packages (see page 734)

Version 5.0.399860.0429 has been tested by IGEL. Newer versions should work, too.

https://zoom.us/download?os=linux
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1.
2.
3.

4.

5.

Unpacking the Packages
In this step, you extract the Ubuntu packages on your Linux workstation in order to access their files:

Open a terminal.
Change to the directory where you saved the packages.
Create a directory to extract the files to:
mkdir zoom

Extract the packages to the new directory:
dpkg -x zoom*.deb zoom/

dpkg -x libx*.deb zoom/
Run the following command to see how much space the package contents need in total (in MB):
du -cms zoom/*  

The total is 151 MB (your package may differ slightly). To be on the safe side, let's memorize that 
we need approximately 500 MB of storage space for the Custom Partition contents.

Next Step

>> Creating the Initialization Script (see page 735)
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1.
2.

Creating the Initialization Script
In this step, you will create an initialization script that enables the application to work inside a Custom Partition. In 
a regular installation, the files of the Zoom application would be located in /usr , /opt  and so on, whereas in 

the Custom Partition, they are located under  /custom/zoom/usr ,   /custom/zoom/opt  and so on. 

The initialization script will fix this by creating symbolic links so that for example  /custom/zoom/usr/lib/

library.so  will appear to be in  /usr/lib/library.so , where Zoom expects it.

On your workstation, go to the directory where the zoom  directory is located.
Open your text editor of choice and enter the following script:

#!/bin/sh
 
ACTION="custompart-zoom_${1}"
 
# mount point path
MP=$(get custom_partition.mountpoint)
 
# custom partition path
CP="${MP}/zoom"
 
# wfs for persistent login and history
WFS="/wfs/user/.zoom/data"
 
# .zoom directory
ZOOM="/userhome/.zoom/"
 
# output to systemlog with ID amd tag
LOGGER="logger -it ${ACTION}"
 
echo "Starting" | $LOGGER
 
case "$1" in
init)
        # Linking files and folders on proper path
    find ${CP} | while read LINE
        do
                DEST=$(echo -n "${LINE}" | sed -e "s|${CP}||g")
                if [ ! -z "${DEST}" -a ! -e "${DEST}" ]; then
                        # Remove the last slash, if it is a dir
                        [ -d $LINE ] && DEST=$(echo "${DEST}" | sed -e "s/\/$//
g") | $LOGGER
                        if [ ! -z "${DEST}" ]; then
                                ln -sv "${LINE}" "${DEST}" | $LOGGER
                        fi
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                fi
        done
 
    # Linking /userhome/.zoom/data to /wfs/user/.zoom/data for some basic 
persistency
    mkdir -p ${WFS}
    chown -R user:users ${WFS}
    mkdir -p ${ZOOM}/data
    chown -R user:users ${ZOOM}/data
        mkdir -p ${ZOOM}/data/VirtualBkgnd_Custom
        chown -R user:users ${ZOOM}/data/VirtualBkgnd_Custom
        mkdir -p ${ZOOM}/data/VirtualBkgnd_Default
        chown -R user:users ${ZOOM}/data/VirtualBkgnd_Default
    
    ln -sv ${WFS}/zoomus.db ${ZOOM}/data/zoomus.db | $LOGGER
    ln -sv ${WFS}/zoommeeting.db ${ZOOM}/data/zoommeeting.db | $LOGGER
    ln -sv ${WFS}/VirtualBkgnd_Custom ${ZOOM}/data/ | $LOGGER
    ln -sv ${WFS}/VirtualBkgnd_Default ${ZOOM}/data/ | $LOGGER
        
        chown user:users /wfs/user/.zoom
        ln -sv /wfs/user/.zoom/zoomus.conf /userhome/.config/zoomus.conf | 
$LOGGER  
    
        # remove all com.zoom.ipc* files from /wfs/user/.zoom/data - might 
cause issues when updating zoom
        rm ${WFS}/com.zoom.ipc*
    
    # add /opt/zoom to ld_library
    echo "${CP}/opt/zoom" > /etc/ld.so.conf.d/zoom.conf
    ldconfig
 
    ${MP}/zoom_postinst | $LOGGER
 
;;
stop)
    # unlink linked files
    find ${CP} | while read LINE
        do
                DEST=$(echo -n "${LINE}" | sed -e "s|${CP}||g")
        unlink $DEST | $LOGGER
    done
 
    # remove zoom.conf because it is not needed anymore
    rm /etc/ld.so.conf.d/zoom.conf
 
 
;;
esac
 
echo "Finished" | $LOGGER
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3.

 
exit 0

Save the file as custompart-zoom

Next Step

>> Compressing the Custom Partition Contents (see page 738)

The code line  echo "${CP}/opt/zoom" > /etc/ld.so.conf.d/zoom.conf  tells the 

Zoom application via the configuration file zoom.conf  to search for libraries in /custom/

opt/zoom . This is expected by the Zoom application.


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1.

2.

3.

Compressing the Custom Partition Contents
To make the unpackaged software package usable in a Custom Partition, make the application files executable and 
put them into a compressed tar  file.

On your Linux workstation, open a terminal and change to the directory that contains the zoom/

directory with the application files and the initialization script custompart-zoom .

Make the files in zoom/  and the initialization script executable:

chmod -R +x zoom

chmod +x custompart-zoom

Compress the  zoom/  directory and the initialization script into an archive file named 

zoom_[version].tar.bz2  (in our example: zoom_5.0.399860.0429.tar.bz2 ): 

tar cjvf zoom_5.0.399860.0429.tar.bz2 zoom custompart-zoom

Next Step

>> Writing the *.inf Metadata File (see page 739)
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1.
2.

Writing the *.inf Metadata File
In addition to the compressed archive that you created in the previous step, a plain text file with essential 
information for the endpoint device is necessary. In this, step you will create the zoom.inf  file. 

Change to the directory that contains the compressed contents of our Custom Partition.
Create a new file named zoom.inf  and put the following into it:

[INFO]
[PART]
file="zoom_5.0.399860.0429.tar.bz2"
version="5.0.399860.0429_igel1"
size="500M"
name="zoom"
minfw="11.01.100"

Next Step

>> Uploading the Files to the UMS (see page 740)

For an explanation of the settings, see the corresponding page in the section about building a 
simple Custom Partition: Writing the *.inf Metadata File (see page 703).





Customizing

IGEL OS Articles   740 / 1017

1.
2.

Uploading the Files to the UMS

In this step, you upload the compressed  zoom_[version].tar.bz2  archive and the zoom_[version] .i

nf  metadata file to the UMS, which will serve them to other devices via HTTPS. To make the file available, you have 
to create a file object after transferring the physical file.

Transferring the Files to the UMS

Make sure that the Zoom files can be accessed from the machine that hosts the UMS Console.
In the structure tree of the UMS Console, go to Files and select New file in the context menu. 
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3.

4.

Click   next to the Local file field, select zoom_[version].tar.bz2  on your local 
machine, and click Open.

Click   next to the Target URL to define the file path on the UMS Server.
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5.

6.

Review the file name at Local file and click Ok.

Repeat steps 1 to 5 for zoom_[version].inf

Next Step

>> Creating a Profile for the Custom Partition (see page 743)
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1.

2.

3.
4.
5.
6.

Creating a Profile for the Custom Partition
After you have uploaded the Custom Partition files to the UMS, you can now make the settings that will install the 
Custom Partition on any number of devices. For this purpose, you create a profile. 

Activating the Custom Partition

In the structure tree of the UMS Console, right-click the Profiles folder and select New Profile
from the context menu.

In the New Profile dialog, enter a Profile Name, e. g. "Zoom" followed by the version name, and 
click Ok.

Go to System > Firmware Customization > Custom Partition > Partition.
Unlock the Enable Partition setting by clicking the orange triangle so that it turns blue.
Check Enable Partition.
Unlock the Size setting by clicking the orange triangle so that it turns blue, and enter "500M".
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7.

1.

2.

3.

Leave the Mount Point at "/custom".

Setting the Download Source

For this step, you need to determine the HTTPS download address for the zoom.inf  file first.

To find out the IP address of your UMS, go to System > Remote Management in the configuration 
dialog. You will find the UMS Server your device is registered with and its IP address.
Open a web browser and visit the following URL:
https://[IP or name of your UMS host]:8443/ums_filetransfer

When prompted, authenticate with your UMS username and password.
You will see a directory listing of the files that can be downloaded from the UMS.
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4.

5.

Right-click the zoom_[version].inf entry and select Copy link address (or the like, depending on 
your browser).

Back in the profile, go to System > Firmware Customization > Custom Partition > Download.
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6.

7.
•
•
•
•
•

8.

Next to Partitions Data Sources, click [+].

The Add dialog opens.
Edit the settings as follows:

URL: Paste the URL you copied from the browser.
User name: Username for accessing the UMS
Password: Password for the username
Initial action: Enter "/custom/custompart-zoom init".
Final action: Enter "/custom/custompart-zoom stop".

Click OK.



Customizing

IGEL OS Articles   747 / 1017

1.
2.

Configuring the Custom Application

To create a convenient starting method for the user, create a custom application that includes a starter icon on the 
desktop.

Go to System > Firmware Customization > Custom Application.
In the Custom Applications list, click  to add an application.

The Desktop Integration page opens.
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3.

4.
5.

•

Enter "Zoom" as the Session name.

Go to Settings.
Edit the settings as follows:

Icon name: Enter "/usr/share/pixmaps/Zoom.png".
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•

6.

Command: Enter "zoom".

Click Save.

Next Step

>> Assigning the Profile and Testing the Application (see page 750)
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1.

2.

3.

Assigning the Profile and Testing the Application
Now that you have put all the settings for installing the Custom Partition on a device into a profile, it is time to 
assign the profile.

In the UMS structure tree, drag and drop the icon of your profile onto the icon of a device.

The Update time dialog opens.
Select Now and click Ok.

The device receives the settings of the profile, creates the Custom Partition, downloads the 
contents of the Custom Partition, and uncompresses them. 
On the desktop of the endpoint device, the Zoom icon should appear:

Click on the Zoom icon to test the Zoom application.
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1.
2.
3.
4.
5.
6.
7.
8.
9.

Microsoft Teams as a Custom Partition
Now that you have learned the IGEL Custom Partition fundamentals, build on top of these and try your hand at a 
real-world Custom Partition: Microsoft Teams.

If you want to get an impression of how Microsoft Teams works on IGEL OS, watch this video:

Read all the following chapters in the order given and follow the instructions.

Development Environment (see page 752)
Getting the Package (see page 753)
Unpacking the Packages (see page 754)
Creating the Initialization Script (see page 755)
Compressing the Custom Partition Contents+1 (see page 757)
Writing the *.inf Metadata File 1 (see page 758)
Uploading the Files to the UMS (see page 759)
Creating a Profile for the Custom Partition (see page 762)
Assigning the Profile and Testing the Application (see page 768)

Sorry, the widget is not supported in this export.
But you can reach it using the following URL:

https://m.youtube.com/watch?v=3X0IKKu5eZY

https://m.youtube.com/watch?v=3X0IKKu5eZY
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•
•
•

•

•
•

Development Environment
For this section, you need

a system with IGEL OS 11.01.100 or newer,
Universal Management Suite (UMS) 6.01.100 or newer,
a Debian or Ubuntu workstation for unpacking the *.deb  package (can be the same as the Linux 
workstation hosting the UMS). Ideally, the machine is running Ubuntu 18.04 LTS.
a method to exchange files between the endpoint device and the workstation.
While a USB memory stick or disk drive would do the trick, it is more convenient to have either a

Windows fileshare or
an NFS export

that you can access both from the endpoint device and the workstation in order to exchange files.
Learn how to mount network drives in the IGEL OS Manual.

Next Step

>> Getting the Package (see page 753)
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1.

2.

3.

Getting the Package
Get the required package for Ubuntu.

Open https://www.microsoft.com/en-us/microsoft-365/microsoft-teams/download-
app#allDevicesSection in a browser and click Linux DEB (64-bit).

Download the package  teams_[version]_amd64.deb  (example: 

teams_1.3.00.5153_amd64.deb )

Change to the download directory on your workstation (typically  /home/[username]/

Downloads ).

Next Step

>> Unpacking the Package (see page 754)

When you open the URL from a Windows machine, the Linux download button will probably not 
appear.



https://www.microsoft.com/en-us/microsoft-365/microsoft-teams/download-app#allDevicesSection
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1.
2.
3.

4.

5.

Unpacking the Packages
In this step, you extract the packages on your Linux workstation in order to access their files:

Open a terminal.
Change to the directory where you saved the packages.
Create a directory to extract the files to:
mkdir teams

Extract the packages to the new directory:
dpkg -x teams*.deb teams/

Run the following command to see how much space the package contents need in total (in MB):
du -cms teams/*  

The total is 237 MB (your package may differ slightly). To be on the safe side, let's memorize that 
we need approximately 500 MB of storage space for the Custom Partition contents.

Next Step

>> Creating the Initialization Script (see page 755)
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1.
2.

Creating the Initialization Script
In this step, you will create an initialization script that enables the application to work inside a Custom Partition. In 
a regular installation, the files of the Teams application would be located in /usr , whereas in the Custom 

Partition, they are located under  /custom/teams/usr . The initialization script will fix this by creating symbolic 

links so that for example  /custom/teams/usr/share/libffmpeg.so  will appear to be in  /usr/share/

libffmpeg.so , where Teams expects it.

On your workstation, go to the directory where the teams  directory is located.
Open your text editor of choice and enter the following script:

#!/bin/sh
 
ACTION="custompart-teams_${1}"
 
# mount point path
MP=$(get custom_partition.mountpoint)
 
# custom partition path
CP="${MP}/teams"
 
# only needed if application has an executable
BIN="/usr/bin/teams"
 
# output to systemlog with ID amd tag
LOGGER="logger -it ${ACTION}"
 
echo "Starting" | $LOGGER
 
case "$1" in
init)
        # Linking files and folders on proper path
    find ${CP} | while read LINE
        do
                DEST=$(echo -n "${LINE}" | sed -e "s|${CP}||g")
                if [ ! -z "${DEST}" -a ! -e "${DEST}" ]; then
                        # Remove the last slash, if it is a dir
                        [ -d $LINE ] && DEST=$(echo "${DEST}" | sed -e "s/\/$//
g") | $LOGGER
                        if [ ! -z "${DEST}" ]; then
                                ln -sv "${LINE}" "${DEST}" | $LOGGER
                        fi
                fi
        done
;;
stop)
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3.

        # unlink linked files
        find ${CP} | while read LINE
            do
                DEST=$(echo -n "${LINE}" | sed -e "s|${CP}||g")
            unlink $DEST | $LOGGER
        done
;;
esac
 
echo "Finished" | $LOGGER
 
exit 0

Save the file as custompart-teams

Next Step

>> Compressing the Custom Partition Contents (see page 757)
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1.

2.

3.

Compressing the Custom Partition Contents
To make the unpackaged software package usable in a Custom Partition, make the application files executable and 
put them into a compressed tar  file.

On your Linux workstation, open a terminal and change to the directory that contains the 
teams/  directory with the application files and the initialization script custompart-teams

Make the files in teams/  and the initialization script executable:

chmod -R +x teams

chmod +x custompart-teams

Compress the  teams/  directory and the initialization script into an archive file named 

teams_[version].tar.bz2  (in our example: teams_1.3.00.5153.tar.bz2 ):

tar cjvf teams_1.3.00.5153.tar.bz2 teams custompart-teams

Next Step

>> Writing the *.inf Metadata File (see page 758)
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1.
2.

Writing the *.inf Metadata File
In addition to the compressed archive that you created in the previous step, a plain text file with essential 
information for the endpoint device is necessary. In this, step you will create the teams.inf  file. 

Change to the directory that contains the compressed contents of our Custom Partition.
Create a new file named teams.inf  and put the following into it:

[INFO]
[PART]
file="teams_1.3.00.5153.tar.bz2"
version="1.3.00.5153_igel1"
size="500M"
name="teams"
minfw="11.01.100"

Next Step

>> Uploading the Files to the UMS (see page 759)

For an explanation of the settings, see the corresponding page in the section about building a 
simple Custom Partition: Writing the *.inf Metadata File (see page 703).


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1.
2.

Uploading the Files to the UMS

In this step, you upload the compressed  teams_[version].tar.bz2  archive and the teams_[version] .

inf  metadata file to the UMS, which will serve them to other devices via HTTPS. To make the file available, you 
have to create a file object after transferring the physical file.

Transferring the Files to the UMS

Make sure that the Teams files can be accessed from the machine that hosts the UMS Console.
In the structure tree of the UMS Console, go to Files and select New file in the context menu. 
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3.

4.

Click   next to the Local file field, select teams_[version].tar.bz2  on your local 
machine, and click Open.

Click   next to the Target URL to define the file path on the UMS Server.
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5.

6.

Review the file name at Local file and click Ok.

Repeat steps 1 to 5 for teams_[version].inf

Next Step

>> Creating a Profile for the Custom Partition (see page 762)
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1.

2.

3.
4.
5.
6.

Creating a Profile for the Custom Partition
After you have uploaded the Custom Partition files to the UMS, you can now make the settings that will install the 
Custom Partition on any number of devices. For this purpose, you create a profile. 

Activating the Custom Partition

In the structure tree of the UMS Console, right-click the Profiles folder and select New Profile
from the context menu.

In the New Profile dialog, enter a Profile Name, e. g. "Teams" followed by the version name, and 
click Ok.

Go to System > Firmware Customization > Custom Partition > Partition.
Unlock the Enable Partition setting by clicking the orange triangle so that it turns blue.
Check Enable Partition.
Unlock the Size setting by clicking the orange triangle so that it turns blue, and enter "500M".
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7.

1.

2.

3.

Leave the Mount Point at "/custom".

Setting the Download Source

For this step, you need to determine the HTTPS download address for the teams.inf  file first.

To find out the IP address of your UMS, go to System > Remote Management in the configuration 
dialog. You will find the UMS Server your device is registered with and its IP address.
Open a web browser and visit the following URL:
https://[IP or name of your UMS host]:8443/ums_filetransfer

When prompted, authenticate with your UMS username and password.
You will see a directory listing of the files that can be downloaded from the UMS.
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4.

5.
6.

Right-click the teams_[version].inf entry and select Copy link address (or the like, depending on 
your browser).

Back in the profile, go to System > Firmware Customization > Custom Partition > Download.
Next to Partitions Data Sources, click [+].

The Add dialog opens.
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7.
•
•
•
•
•

8.

1.

Edit the settings as follows:
URL: Paste the URL you copied from the browser.
User name: Username for accessing the UMS
Password: Password for the username
Initializing action: Enter "/custom/custompart-teams init".
Finalizing action: Enter "/custom/custompart-teams stop".

Click OK.

Configuring the Custom Application

To create a convenient starting method for the user, create a custom application that includes a starter icon on the 
desktop.

Go to System > Firmware Customization > Custom Application.
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2.

3.

In the Custom Applications list, click  to add an application.

The Desktop Integration page opens.
Enter "Teams" as the Session name.
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4.
5.

•
•

6.

Go to Settings.
Edit the settings as follows:

Icon name: Enter "/usr/share/pixmaps/teams.png".
Command: Enter "teams".

Click Save.

Next Step

>> Assigning the Profile and Testing the Application (see page 768)
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1.

2.

3.

Assigning the Profile and Testing the Application
Now that you have put all the settings for installing the Custom Partition on a device into a profile, it is time to 
assign the profile.

In the UMS structure tree, drag and drop the icon of your profile onto the icon of a device.

The Update time dialog opens.
Select Now and click Ok.

The device receives the settings of the profile, creates the Custom Partition, downloads the 
contents of the Custom Partition, and uncompresses them. 
On the desktop of the endpoint device, the Microsoft Teams icon should appear:

Click on the Microsoft Teams icon to test the application.
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•
•
•

•
•

•

•
•

Using a Custom PKCS#11 Library

Issue
You want to use your own PKCS#11 library.

Problem
In the Setup, you cannot find how to activate a custom PKCS#11 library.

Solution

Using with Kerberos and/or Citrix StoreFront Logon
To use a custom PKCS#11 library with Kerberos and/or Citrix StoreFront Logon:

In Setup, go to Security > Smartcard > Middleware.
Select Custom PKCS#11 module.
Under Path to the library, enter the path to your PKCS#11 library. Example:  /usr/lib/

pkcs11/[name of the library].so

Using with VMware Horizon
To use a custom PKCS#11 library with VMware Horizon:

In Setup, go to System > Registry.
Enable the registry key  vmware.view.pkcs11.use_custom .

Set the registry key  vmware.view.pkcs11.custom_path  to the path to your PKCS#11 

library. Example:  /usr/lib/pkcs11/[name of the library].so

Using with Firefox Browser
To use a custom PKCS#11 library with the Firefox browser:

In Setup, go to System > Registry.
Enable the registry key browserglobal.security_device.custom.enable .

In case of the installation of a custom PKCS#11 library, the file(s) must be placed on the endpoint device 
either via UMS file transfer or Custom Partition (see page 689).
The use of the /wfs  folder is NOT recommended because of its space limit.


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•

•

Set the registry key  browserglobal.security_device.custom.device_name  to the 
name of your PKCS#11 library.
Set the registry key  browserglobal.security_device.custom.lib_path  to the path 

to your PKCS#11 library. Example:  /usr/lib/pkcs11/[name of the library].so
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1.
2.
3.
4.

5.

Adding an Icon for Browsing Removable Storage

Symptom
There is no obvious way of viewing files from removable media locally on the thin client.

Problem
You want to view files from removable media locally on the thin client.

Solution

Create a custom application that opens the contents of removable media in the File Manager.

Go to System > Firmware Customization > Custom Application in Setup.
Click the star symbol to create a new Custom Application.
Enter a name, e.g. Removable Media, and choose desktop integration options for the application.
Enter folder  as the Icon name and thunar  as the Command in the Settings dialog:

Save the settings.
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6.

7.

Insert a removable medium such as a USB stick into the thin client.

Click the new Removable Media icon. This opens File Manager and lets you browse the contents. 
Clicking a file will open it in the application configured by the MIME type handler (as of IGEL LINUX 
5.06.100, see FAQ (see page 826)). 
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1.
2.
3.
4.

5.
6.

Adding an Icon for the Image Viewer

Symptom
You want to view images locally on the thin client.

Problem
The image viewer contained in IGEL Linux as from version 5.06.100 on has no desktop icon or menu entry.

Solution
Create a custom application that opens the Image Viewer.

Go to System > Firmware Customization > Custom Application in Setup.
Click   to create a new Custom Application.
Enter a name, e.g. Image Viewer, and choose desktop integration options for the application.
Go to Image Viewer > Settings:

Enter gpicview as both the Icon name and the Command in the Settings dialog.
Save the settings.
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Click the newly created icon for Image Viewer. 
The Image Viewer opens.
Click the Open File symbol to open a file. 
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Creating a Timed Command (Cron Replacement)
You can define one or more commands which are executed at a defined time. The configuration is similar to that of 
a cron  job. The implementation in IGEL OS uses systemd  to execute the command.

To define a timed command:

In the Setup, go to System > Registry > system > cron > cronjob%
Activate enable_cron.
If you want to define paths to executables in addition to the existing path environment variable, 
add them under path, separated by ":".
Click Add Instance.
The instance "cronjob1" is created, which will be renamed to "cronjob0" when the device has 
restarted.
Set the parameters for your timed command according to your needs:

command: Command to be executed. Example for testing purposes: gtkmessage -m 

"Here is your cron replacement"
day_of_month: Day of the month 
Possible values:
- "1" ... "31": The command is executed on the defined day. To select a list of days for 
execution, enter a comma-separated list, e.g. "1,8". To enter a range of days, use a hyphen, 
e.g. "1-3".
- "*": The command is executed every day of the month. 
day_of_week: Day of a week
Possible values;
- "1" ... "7": The command is executed on the defined day. "0" and "7" both mean 
Sunday. To select a list of days for execution, enter a comma-separated list, e.g. "1,3". To 
enter a range of days, use a hyphen, e.g. "1-3".
- "*": The command is executed every day of the week. 
hour
Possible values:
- "0" ... "23": The command is executed in the defined hour. Example: "15" means 3 p.m, 
plus the minutes defined under minute. To select a list of hours for execution, enter a 
comma-separated list, e.g. "9,17". To enter a range of hours, use a hyphen, e.g. "9-17".
- "*":  The command is executed every hour.
minute
Possible values:
- "0" ... "59": The command is executed in the defined minute. To select a list of minutes for 
execution, enter a comma-separated list, e.g. "15,45". To enter a range of minutes, use a 
hyphen, e.g. "5-10".
- "*":  The command is executed every minute.
month
Possible values:
- "1" ... "12"; The command is executed in the defined month. To select a list of months for 
execution, enter a comma-separated list, e.g. "1,4". To enter a range of months, use a 
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hyphen, e.g. "1-3".
- "*": The command is executed every month.
user: The user under which the command is executed
Possible options:
- "root"
- "user"
year: Year in 4-digit format. Example: "2019". To select a list of years for execution, enter a 
comma-separated list, e.g. "2019,2020". To enter a range of years, use a hyphen, e.g. 
"2019-2021". If the command is to be executed each year, enter "*".

 Click Apply or Ok.
Restart the device.
After the device has restarted, the command will be executed as configured.
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Customizing IGEL OS Desktop
You want to give your IGEL OS desktops a more individual look and feel. This document shows how to customize 
your IGEL OS desktops using the Universal Management Suite (UMS). There are two ways to do it:

via a firmware customization;
via a profile.

For information on customizing IGEL OS desktops via a profile, see:

Introduction (see page 778)
Creating Your Own Wallpaper (see page 781)
How to Create a Custom Bootsplash for IGEL OS Devices via the UMS (see page 785)
Creating Your Own Screensaver (see page 790)
Assigning Your Own Company Logos (see page 795)
Creating Your Own Taskbar (see page 797)
Customizing Desktop Icons (see page 798)

IGEL Tech Video

With a firmware customization function, you can change your desktop design much easier and quicker 
than with a profile.
For an example, see Creating Your Own Wallpaper via Firmware Customization (see page 782). See also 
Firmware Customizations and Create Firmware Customization in the UMS Reference Manual.



Sorry, the widget is not supported in this export.
But you can reach it using the following URL:

https://www.youtube.com/watch?v=qFQttefMlX8

https://www.youtube.com/watch?v=qFQttefMlX8
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Introduction
If you want to roll out your complete corporate design changes and apply them to multiple devices, you can create 
one single profile for all settings.

Before defining special profiles, you must take the following steps:

Uploading a Picture (see page 779)
Creating a Profile (see page 780)
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Uploading a Picture
Upload your image files to the UMS server, then assign them to the relevant profile and also to your devices.

You can choose between the following formats for your pictures : BMP, JPG, GIF, TIF, PNG and SVG. Ensure that 
the name of your image file has no blanks, otherwise the file will not be accepted. 25 MB of free storage space are 
available for your pictures.

Upload your files:

Click New file on the context menu of the Files directory in the tree.
Browse to find your image in Local file.

Browse to select a picture directory in Upload location (URL).
Since UMS version 5 you can use as upload location only /ums-filetransfer/ and its subdirectories.
Enter a Thin Client file location directory for the target device.
If you enter a directory which does not yet exist, it will be created automatically. If you do not enter 
a specific directory, the image will be put in the root directory.
Click OK.
Your image will be listed in the list of Files.
Assign the image to your devices by dragging and dropping them or by adding them under 
Assigned objects.

If you put more than one image in the Thin Client file location directory, all images will be 
alternately shown by the screensaver (see page 790), one after the other.


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Creating a Profile
You have already uploaded your image file (see page 779).

As you work with the UMS, to manage several clients, you need to create a profile to assign the new settings to your 
clients.

Create a Profile to assign your settings to the clients:

Click New profile in the context menu of the Profiles directory in the tree.
Enter a Profile Name.
Enter a Description and choose the firmware of your thin client under Based on.

Click OK.
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Creating Your Own Wallpaper
There are two ways how to create an own wallpaper:

Via a Firmware Customization (see page 782)
Via a Profile (see page 783)

With a Firmware Customization, setting up your own wallpaper is much easier than with a profile.
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Creating Your Own Wallpaper via Firmware Customization
This is how you can create your own wallpaper using a firmware customization function in the UMS:

In the UMS, right-click on Firmware Customizations > Create New Firmware Customization.
The Firmware Customization Details dialog opens.
Enter a Name for your wallpaper customization.
As Use Case, select Wallpaper.
Select the image file for each monitor:

Click Choose file if you have already uploaded a file in the UMS.
Click Upload file if you want to upload a new file.

Select your image file and click Open.
Check the image file location and click OK.
Optionally, click Next to directly apply this new firmware customization to a device or folder of 
devices.
Click Finish to save your new firmware customization.

The file name must not contain any special characters such as %, §, umlauts, etc.
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Creating Your Own Wallpaper via a Profile
You have already uploaded your wallpaper picture; see Uploading a Picture (see page 779).

Create a profile and name it, for example, Wallpaper; see Creating a Profile (see page 780).
The Profile Configuration window opens.
Set the wallpaper server location; see below "Setting the Wallpaper Server Location".
Configure the background of the client desktop; see below "Configuring the Background".

Setting the Wallpaper Server Location

Click System > Firmware Customization > Corporate Design > Background > Custom 
Wallpaper Server.

Choose HTTP as Protocol.
Enter the Server name of your UMS Server.
Enter the path of your wallpaper directory as Server path.
The standard Port should be 9080.
Set your UMS administrator User name and Password.
Click Save to save the settings.

Configuring the Background

Open the profile.
Click System > Firmware Customization > Corporate Design > Background (1st Monitor).
Activate Custom wallpaper download.
Enter under Custom wallpaper file the name of the picture you want to define as your 
background image.

Assign the profile to your devices by dragging and dropping them or by adding them 
under Assigned objects.

If you use more than one monitor, you have to assign the background image to each one 
of them manually.


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Checking the Results

Choose the device in the UMS structure tree under Devices.
Go to User Interface > Desktop > Background.
You will see that the wallpaper has already been assigned by the profile; you cannot set it 
manually any more.
Alternatively, you can shadow your thin client and you will see the new wallpaper.

This way, you can automatically assign background images to your devices. It is very easy to maintain them 
because the only thing you have to do if you want to choose another image is to change it in the profile.
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How to Create a Custom Bootsplash for IGEL OS Devices via the UMS
This document shows how you can create a custom bootsplash for your endpoint devices using the Universal 
Management Suite (UMS). There are two ways to do it:

via a firmware customization
via a profile

With a firmware customization function, you can create your own bootsplash much easier and quicker than with a 
profile.

How to Create a Custom Bootsplash via a Firmware Customization
This is how you can create your own bootsplash using a firmware customization function in the UMS:

In the UMS, right-click on Firmware Customizations > Create New Firmware Customization.

The Firmware Customization Details dialog opens.

Enter a Name for your bootsplash customization.
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As Use case, select Bootsplash.

Select the image file for your bootsplash:
Click Choose file if you have already uploaded a file to the UMS Server.
Click Upload file if you want to upload a new file.

•

•
•

The file name must not contain any blank spaces or special characters such as %, §, 
umlauts, etc.
The file types supported for a bootsplash are JPG, BMP, and PNG.
The optimum size of the picture is 800 x 600 pixels.


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Define the position of your bootsplash.

Optionally, click Next to assign this new firmware customization to a device or a device directory.

Click Finish to save your new firmware customization.

How to Create a Custom Bootsplash via a Profile
This is how you can create your own bootsplash using a profile in the UMS:

Upload your boot logo to the UMS Server; see Uploading a Picture (see page 779).

Create a new profile named Bootsplash; see Creating a Profile (see page 780).

In the profile configuration window, go to System > Firmware Customization > Corporate 
Design > Custom Bootsplash to create your own bootsplash.

Activate Enable custom bootsplash.

Choose HTTP as Protocol.

Under Server name, enter the name or the IP address of your UMS Server.

Enter the path of your boot logo directory as Server path.

Specify your HTTP server port under Port.

•

•

The file name must not contain any blank spaces or special characters such as %, §, 
umlauts, etc.
The optimum size of the picture is 800 x 600 pixels.


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12.

Enter your UMS administrator User name and Password.

Enter the name of your bootsplash image under Custom bootsplash file.

Define Custom bootsplash style and Background color.

Define vertical and horizontal position for the bootsplash image and progress indicator.
The scale goes from 0 (left) to 100 (right); 50 means "centered".

The default UMS HTTP server port is 9080. For more information on UMS ports, see IGEL UMS 
Kommunikationsports.


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Save the settings.

Assign the profile to your devices by dragging and dropping them or by adding them 
under Assigned objects. For more information on the profile assignment, see Wie kann ich IGEL 
UMS Profile zuweisen?. 

If the image file or any setting of an existing custom bootsplash is changed, the bootsplash code has to be 
rebuilt. You can trigger this from the UMS via Jobs > New Scheduled Job with the command Update 
desktop customization.


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Creating Your Own Screensaver
This section describes how to configure an autostart screensaver with your own picture using the UMS.

Proceed as you did for the wallpaper:

Upload your logo to the UMS server. For details, see Uploading a Picture (see page 779).

Create a new Profile named Screensaver. For details, see Creating a Profile (see page 780).
Configure the profile settings.
There are four areas where you have to make settings in the screensaver profile:

Setting a Delay Time for Booting (see page 791)
Setting a Timeout for Autostart (see page 792)
Assigning the Custom Logo (see page 793)
Assigning the Custom Clock (see page 794)

Assign the profile to your devices by dragging and dropping them or by adding them under 
Assigned objects.

The size of the picture is irrelevant because it will be reduced automatically to 200 x 150 pixels.
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Setting a Delay Time for Booting
Configure Autostart in the screensaver profile under User Interface > Screenlock / Screensaver.

Enter a Session name, for example Screensaver.
Enable Autostart.
Enter the number of seconds of Delay.

This setting tells the system that it must launch the autostart of this session with a certain delay 
during booting.


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Setting a Timeout for Autostart

Click User Interface > Screenlock / Screensaver > Options.
Enable Start automatically.
Enter a number of minutes for Timeout.

With this setting, you decide how long the system has to wait before starting the screensaver after 
the last input.


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Assigning the Custom Logo

Go to System > Firmware Customization > Corporate Design > Company Logos.
Activate Enable image display.
Enter the Image file/directory you have defined under Thin Client file location. See Uploading a 
Picture (see page 779).

Activate One image per monitor if you use more than one monitor and if you want to show 
different pictures on each screen.
Under Image duration specify the time in seconds that you want to wait before the image is to be 
changed.
Under Image display mode you can choose between the following different image actions:

Small-sized hopping: Small pictures are shown in changing positions.
Medium-sized hopping: Bigger pictures are shown in changing positions.
Full-screen center cut out: The pictures will be shown in full-screen mode. They may 
possibly be cut at the border.
Full-screen letterbox: The pictures are shown in full size as large as possible according to 
the screen.

If you enter a folder instead of a single image file as the source, all images in the folder will be 
displayed as a slide show. The display time for the images can be configured.


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Assigning the Custom Clock
You can also configure a digital screensaver clock independently of the screen display.

Click User Interface > Screenlock / Screensaver > Screensaver.
Select the Clock display monitor where you want to display the clock.
Activate Show seconds if you want to see the digital time display, including seconds.
Define the size, position and color settings of your screensaver clock.
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Assigning Your Own Company Logos
You can set your own images for the start button and the company logo in the start menu.

To assign your own icons via UMS:

The Start button icon is customizable in IGEL Linux 5.08.100 and newer.

To see a start menu with a company logo, you first have to set the Start Menu 
Type on Advanced under User Interface > Desktop > Start Menu.
If you set the Start Menu Type on Auto and the device has a clock frequency of 1 GHz, the system will 
choose the advanced type.


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Upload your logos to the UMS server. For details, see Uploading a Picture (see page 779).
Create a new profile. For details, see Creating a Profile (see page 780).
The profile configuration window opens.
Go to System > Firmware Customization > Corporate Design > Company Logos > Start Menu.
Enter the file name and the full path of the image under Start button icon.
Enter the file name and the full path of the image under Company logo in start menu.
Click Save or Apply and send to Thin Client to save the settings.
Assign the profile to your devices by dragging and dropping them or by adding them 
under Assigned objects.

An alternative to this is the chapter Create Firmware Customization in the UMS manual. 
Here you will find further configuration options for adapting the UMS to your 
requirements.


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Creating Your Own Taskbar
You can apply your own design to a taskbar. To customize the taskbar on multiple devices, use the IGEL UMS and 
proceed as follows:

Upload the desired image to the UMS server, see Uploading a Picture (see page 779).
Create a new profile, seeCreating a Profile (see page 780).
Assign the image to the profile by dragging and dropping it or by adding it under Assigned 
objects.
In the profile configuration window, go to User Interface > Desktop > Taskbar Background.
Select Background image under Background style.

Enter the full path of the desired image under Background image path.
Assign the profile to your devices by dragging and dropping them or by adding them 
under Assigned objects.
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Customizing Desktop Icons

Prerequisites
You can use the following graphic formats and resolutions for a custom desktop icon:

PNG - common resolutions are 128x128, 96x96, 64x64, 48x48, 32x32, 24x24, 22x22, 16x16, but 
others are also accepted and scaled accordingly.

SVG - no resolutions because SVG contains freely scalable vector graphics.

To customize the desktop icon of a session, proceed as follows:

In the Setup, go to System > Registry.
In the Registry, navigate to sessions.[session name].icon.

Enter under Icon name the absolute path to your custom icon as shown in the sample picture 
below.

You can only customize the desktop icon of a session. The taskbar icon of a session cannot be customized 
and will remain the default icon. Complete customization is not possible.



We recommend at least a resolution of 64x64.

Even though other formats like BMP or JPEG are supported, only PNG and SVG are recommended because 
these formats support transparency.



For technical reasons, some registry keys do not match the session's name. For example, RDP 
sessions are found under the key  winconnect[0-...] .


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4. Click Ok to save the changes.
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How to Change the Font Color of the Desktop Icons

Overview
You want to alter the font color of the desktop icons. 

Environment
IGEL OS 11.05.100 or higher

Instructions
In the Setup, go to User Interface > Desktop. 

Beside Desktop icon font color, click Choose color and select the desired color using the color 
picker. Confirm your change with Ok.

As an alternative, you can enter the hexadecimal RGB hex value in System > Registry > 
windowmanager > defaulttheme > desktop_iconfont_color (registry key:
 windowmanager.defaulttheme.desktop_iconfont_color ). Example:  #FEC429


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The font color of the desktop icons is changed.
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How to Set Up a Countdown to Prevent an Undesired Screen Lock In IGEL 
OS
In some situations, a screen lock that comes without a warning can cause disruption. Typically, this is the case 
when a user who is logged in to a remote session does not interact with the device for some time, which results in 
the screen lock kicking in. To circumvent this problem, you can set a visible countdown that is started before the 
screen is locked, so the user can react in time.

The configuration is described in the following sections:

Defining the Countdown's Behavior (see page 803)
Defining the Countdown's Appearance (see page 805)

For special purposes, like closing a remote session to prevent it from running unattended, you can configure an 
additional set of commands. It consists of a command that determines whether the countdown should be started 
(typically, check whether the remote session is running) and a command that will be executed when the countdown 
reaches 0 (typically, close the remote session). The configuration is described in the following section:

Configuring a Conditional Countdown and Command (see page 807)

Defining the Countdown's Behavior
For a description of all options, see Options.

In the Setup or UMS configuration dialog, go to User Interface > Screenlock / Screensaver > 
Options.

Activate Start automatically.

In the Timeout field, specify after how many minutes the countdown should start.

Review the timeouts in the power settings of your device to ensure that the display won't turn black before 
the countdown is started; see System and Screen.


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Select the password to be used to unlock the screen:
None: The user can unlock the screen without a password. Please note that the countdown 
will not be started when this option is selected!
User password: The user must enter the user password to unlock the screen. If you are 
using Microsoft Active Directory (AD) resp. Kerberos for authentication, which is highly 
recommended, the user's AD/Kerberos password will be used here. For details, see Active 
Directory/Kerberos. If you are not using AD/Kerberos, the user password is configured in 
Security > Password under User. Please note that the password should not, at any rate, be 
set via a UMS profile, otherwise all affected devices would have the same password!
Local user password: The user must enter a special screen lock password to unlock the 
screen; click Set to define this password. Please note that the password should not, at any 
rate, be set via a UMS profile, otherwise all affected devices would have the same password! 
This password is also used for Security > Logon > Local User > Login with local user 
password; see Local User.
If the user is logged in via Active Directory (AD), the AD credentials are used instead of this 
password to unlock the screen.
If you are using Citrix Storefront, this password can be synchronized with the Citrix session 
password by enabling Synchronize Citrix password with screen lock under Sessions > 
Citrix > Citrix StoreFront > Login; see also Login Settings for Citrix StoreFront in IGEL OS. 

Set the Countdown duration in seconds. The range is from 1 to 60.
Configuration example:
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Apply the settings to your devices or to your profile.

Defining the Countdown's Appearance
In the Setup, go to User Interface > Screenlock / Screensaver > Options.

If you want the current desktop as a background image during the countdown, select the visual 
effect:

Dark screenshot: The desktop screenshot is darkened.
Gray screenshot: The desktop screenshot is grayed out.

If you want a custom image as a background image during the countdown, enter a valid path and 
file name. Example: /images/ . If the image is not already residing on your device, you can 
upload it using the UMS; see Uploading a Picture (see page 779).
Configuration example with custom image:



Customizing

IGEL OS Articles   806 / 1017

4.

5.

•
•
•
•
•
•
•

•

•

Go to User Interface > Screenlock / Screensaver > Screensaver.

Customize the countdown's appearance using the following parameters; these parameters define 
the appearance of both the screensaver's clock and the countdown. For further information, see 
Screensaver. 

Image display mode: Position and scaling for the background image
Clock display monitor: Select the monitor(s) on which the countdown is to be shown.
Show seconds: Define whether the seconds should be displayed on the clock.
Clock display size: Size of the countdown digits
Horizontal clock position: Horizontal position of the countdown digits
Vertical clock position: Vertical position of the countdown digits
Clock background color: Color of the countdown background area. The countdown 
background area is a rectangle with rounded corners.
Clock background opacity percentage: Set the opacity for the clock's background area 
(defined by Clock background color),
Clock foreground color: Color of the countdown digits

Configuration example:
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Apply the settings to your devices or to your profile.
Here is an example of the countdown with a custom image: 

Configuring a Conditional Countdown and Command
In our example, a Citrix session is running (e.g. in appliance mode), and the endpoint device has been idle for a 
while. After the timeout, the system checks whether a Citrix session is running; this is to prevent the session from 
running unattended. The Citrix session is detected, so the countdown kicks in. The user does not interact with the 
device, so the countdown is not stopped. When the countdown has reached 0, the system kills the Citrix client; the 
user is logged off.

In the following, we will first specify the command that determines whether the countdown should be started. 
Then, we will specify the command that is executed when the countdown has reached 0. 

Command That Determines the Condition under Which the Countdown Should Be Started

In the Setup, go to System > Registry and open the registry key sessions > xlock0 > options > 
countdown_condition_cmd 
( sessions.xlock0.options.countdown_condition_cmd ).

This command only makes sense in combination with a command that is to be executed after the 
countdown is done; see Command to Be Executed after the Countdown (see page 808).


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Enter the command in the field Countdown condition command. The user that issues the 
commands is user . If no command is defined here, the countdown will be started. Examples: 

pgrep wfica  (returns 0 if a Citrix session is present), pgrep igelrdp2

Click Apply or Ok.
If the command returns 0, the countdown is started. When the countdown has reached 0, the 
command specified with System > Registry > sessions > xlock0 > options > 
countdown_done_cmd is executed (see Command to Be Executed after the Countdown (see page 
808)).
If the command returns a non-zero value, the countdown is not started. A command that is 
configured for execution after the countdown will therefore not be executed. The screen lock or 
screensaver will be started.

Command to Be Executed after the Countdown

In the Setup, go to System > Registry and open the registry key sessions > xlock0 > options > 
countdown_done_cmd ( sessions.xlock0.options.countdown_done_cmd ).

Enter the command in the field Countdown done command. The user that issues the commands 
is user . Examples: killall wfica  (terminates the Citrix ICA client), logoff

The command is executed synchronously before the countdown goes away. If the command 
doesn't terminate quickly, it must be sent to the background by appending " & ".


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(Optional) If you want to enforce the start of the screensaver after the Countdown done 
command has been executed, open the registry key sessions > xlock0 > options > 
countdown_done_cmd_continue 
( sessions.xlock0.options.countdown_done_cmd_continue ) and enable Continue 
screensaver after countdown done command.

Click Apply or Ok.

Some applications stop the screensaver when they get restarted, so this does not always have the 
desired effect.


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•

How to Set Up a Countdown in the IGEL OS
You can set up the countdown via the device's local Setup or via the IGEL Universal Management Suite (UMS). It is 
recommended to use the IGEL UMS and store your settings in a profile; this allows you to apply your settings to a 
random number of devices in one go.

For more information about profiles, see the Profiles chapter in the IGEL UMS reference manual.

Defining the Countdown's Behavior

In the Setup, go to User Interface > Screenlock / Screensaver > Options.

Activate Start automatically.

In the Timeout field, set the idle timeout in minutes, after which the countdown should start.

Select the password to be used to unlock the screen:
None: The user can unlock the screen without a password.
User password: The user must enter the user password to unlock the screen. The user 
password is configured in Security > Password.
Screenlock password: The user must enter a special screenlock password to unlock the 
screen. Click Set to define the screenlock password.

Set the Countdown duration in seconds. The range is from 1 to 60.
Configuration example:

Apply the settings to your devices or to your profile.

Defining the Countdown's Appearance

In the Setup, go to User Interface > Screenlock / Screensaver > Options.

If you want the current desktop as a background image during the countdown, select the visual 
effect:

Dark screenshot: The desktop screenshot is darkened.
Gray screenshot: The desktop screenshot is grayed out.
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If you want a custom image as a background image during the countdown, enter a valid path and 
file name. Example: /images/ . If the image is not already residing on your device, you can 
upload it using the UMS; see Uploading a Picture (see page 779).
Configuration example with custom image:

Go to User Interface > Screenlock / Screensaver > Screensaver.

Customize the countdown's appearance using the following parameters; these parameters define 
the appearance of both the screensaver's clock and the countdown. For further information, see 
Screensaver.

Image display mode: Position and scaling for the background image

Clock display monitor: Selects the monitor(s) on which the countdown is to be shown.
Clock display size: Size of the countdown digits
Horizontal clock position: Horizontal position of the countdown digits
Vertical clock position: Vertical position of the countdown digits
Clock background color: Color of the countdown background area. The countdown 
background area is a rectangle with rounded corners.
Clock foreground color: Color of the countdown digits

Configuration example:

This parameter is only relevant for IGEL Linux v5. With IGEL Linux version 10.03.500 or 
higher, the Image display mode is set to "Full-screen letterbox".


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6. Apply the settings to your devices or to your profile.
Here is an example of the countdown with a custom image: 
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3.

Configuring a Conditional Countdown and Command
You can specify an arbitrary command that is executed when the countdown has reached 0.

Additionally, you can specify a command that determines whether the countdown is to be started.

Example use case: The countdown is running, but the user does not interact with the device in order to make the 
countdown stop. When the countdown has reached 0, the system checks whether a session is running, e.g. an 
appliance mode Citrix session. If yes, the user is logged off from this session.

If no command is set to be executed after countdown, the screen will be locked instead.

The user that issues the commands depends on the firmware version in use:

With IGEL Linux v5, the user is root .

With IGEL OS Linux 10, the user is user .

To specify the command that determines the condition:
In the Setup, go to System > Registry and open the registry key sessions > xlock0 > options > 
countdown_condition_cmd 
( sessions.xlock0.options.countdown_condition_cmd ).

Enter the command in the field Countdown condition command. Example: pgrep wfica
(determines if a Citrix session is present)
Click Apply or Ok.
If the command returns 0, the countdown or commando is started. 
If the command returns a non-zero value, the countdown or commando is not started.

To specify the command to be executed after the countdown:
In the Setup, go to System > Registry and open the registry key sessions > xlock0 > options > 
countdown_done_cmd ( sessions.xlock0.options.countdown_done_cmd ).

Enter the command in the field Countdown done command. Example: killall wfica
(terminates the Citrix ICA client)

Open the registry key sessions > xlock0 > options > countdown_done_cmd_continue 
( sessions.xlock0.options.countdown_done_cmd_continue ) and specify whether 
the screensaver should be started after the command has been started.

The command is executed synchronously before the countdown goes away. If the 
command doesn't terminate quickly, it must be sent to the background by appending " & "
.



With IGEL Linux v5, the screensaver does not start immediately. It will be started after the 
idle timeout defined under User Interface > Screen Lock/Saver > Options > Timeout. 
With IGEL OS Linux 10, the screensaver is started immediately.


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4.

☑ The screensaver is started after the command has been started.
☐ The screensaver will not be started.
Click Apply or Ok.
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Installing a Calculator on IGEL Linux

Issue

You may want to have a desktop calculator.

Solution

Download the opensource java calculator from: http://sourceforge.net/projects/simpcalc/

Open a Local Terminal and log in as root

Copy the downloaded .jar  file from the /tmp/  directory to /wfs/simplecalc.jar:

cp /tmp/ /wfs/simplecalc.jar  

It is important to copy the file to /wfs  because otherwise the file would be flushed with a reboot.
Open IGEL Setup and create a new custom application: System > Firmware Customization > 
Custom Application
Set Command to java -jar /wfs/simplecalc.jar in  Settings
Click the newly created icon on the desktop to run the custom application.

The default download location of the local Firefox browser is /tmp/ .

To distribute this application to several thin clients please use the file transfer option in 
IGEL UMS and set up a profile with the custom application configuration.



http://sourceforge.net/projects/simpcalc/
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Keyboard Shortcuts for Managing Windows
Switching back and forth between open application windows by using keyboard shortcuts is a common way of 
managing windows.

If you work in a fullscreen environment, you also need a way to switch to the desktop.

With IGEL Linux OS version 10.03.500, the device desktop was added to the window cycle of the window manager.

Use the following default shortcuts to switch from application windows to the desktop:

Task Default Shortcut

Switch between active windows using Task Switcher  Ctrl + Alt + Tab

Switch between active windows using Task Switcher 
(backwards)

Ctrl+Alt+Shift+Tab

Switch focus to next window Ctrl + Esc

Switch focus to next window (2) Ctrl + Alt + UpArrow

Switch focus to next window (reverse order) Ctrl + Alt + DownArrow

Go to IGEL Setup > User Interface > Hotkeys > Commands to change these shortcut combinations.

Switching to the desktop minimizes all windows. Switching back to a window right after that restores all 
windows.


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Make Frequent User Actions Easier by Defining Hotkeys
For common actions, such as switching between different windows, or lock the screen, you can use a hotkey. Some 
hotkeys are preconfigured, but you can activate, deactivate, and modify them.

The following example shows how to find out or modify the hotkey for switching between windows:

Open the setup and go to User Interface > Hotkeys > Commands.
Select Switch between active windows using Task Switcher.
Click on Modify.
A dialog window is opened.
Enable Hotkey, if not already enabled.
Select a modifier key or a combination of modifier keys under Modifiers.
Enter a Key.

If you want to enter a key that has no visible character assigned, e. g. the [Tab] key, open a 
terminal, logon as user and enter xev -event keyboard . Press the key designated 

for the hotkey. The text in brackets starting with keysym  will contain the desired string 

for the Key field; example: Tab  in (keysym 0xff09, Tab)


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Click on Ok.
Click on Apply or Ok.
The hotkey is ready for use.

The following example shows how to define a hotkey to lock the screen:

Open the setup and go to User Interface > Screenlock/Screensaver.
Enable Hotkey.
Select a modifier key or a combination of modifier keys under Modifiers.
Enter a Key.
Click on Apply or Ok.
The hotkey is ready for use.
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Shutdown/Suspend Devices Automatically at the End of a Session

Issue
You may want to shut down, suspend, restart or log off from the device automatically after ending a session.

Solution
You can define an "after-logoff-action" dependent on a session type. This action is performed after ending the last 
instance of the defined session type.

Proceed as follows:

In the device's local Setup (or its UMS configuration or profile), navigate to System > Firmware 
Customization > Custom Commands > Post Session.
Choose a Session type.
Choose a Post-session command.
Save the changes with Apply or OK.

If the last instance of the chosen session type is ended, the post-session command will be processed.

See also IGEL OS manual: Post Session

The post-session command Shutdown/suspend will perform the default action defined under System > 
Power Options > Shutdown > Default action. Please check this parameter before using the command.



The post-session command Logoff is futile unless you define a login method under Security > Logon
(Smartcard, Active Directory/Kerberos, or IGEL Shared Workplace). The Logoff command also cannot be 
used with an appliance – in this case, only Shutdown/suspend or Reboot commands are working.



When using auto-logoff commands with an appliance, make sure to define the corresponding session type 
– e.g. Horizon View when using the VMware Horizon View appliance.


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Suspend to RAM - Wake Up by USB Mouse
You can wake up your device by mouse click or key press.

Setting System Suspend as the Default Action
In Setup, go to System > Power Options > Shutdown.
Activate Allow system suspend.
Under Default action, select "Suspend".
Save the setting by clicking Apply or Ok.
From now on, the system will be suspended to RAM whenever it is shut down.

To use the wake-up functionality, the following steps must be performed:

Configuring the BIOS for PS/2 Mouse and Keyboard
Open the BIOS of your device and check if the power management section has parameters named 
"PS/2 Wake up from S3" or similar.
If present, set the parameters to enabled.
Save the BIOS configuration and continue booting.

Configuring the BIOS for USB Mouse and Keyboard
Open the BIOS of your device and check if the power management section has parameters named 
"USB Wake Up from S3" or similar.
If present, set the parameters to enabled.
Save the BIOS configuration and continue booting.

Enabling the Wake-Up Functionality
In the IGEL Setup, activate System > Registry > system > acpi_wakeup > enabled > Wakeup 
from S3 by USB devices.
Click Apply or Ok.

To check if the wake-up functionality works, click  > , wait a few minutes, and try to wake up the device 
using a mouse click or a key press.

The wake-up functionality strongly depends on the hardware and BIOS version in use. We recommend 
testing this function before using it. With devices converted by UDC3/OS Creator (OSC) or UD Pocket, it 
only works when the hardware is fully supported.


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Taking Screenshots on IGEL Linux

Issue
For support or documentation purposes, the user wants to take a screenshot in IGEL Linux without accessing the 
client via VNC.

Solution
On IGEL Linux 5.08.100 and newer or IGEL Linux 10.01.100 and newer, use the pre-installed Screenshot Tool.

On earlier versions:

Download the tool Rapid Screenshot61.

Open a Local Terminal and log in as root.
Copy the downloaded . jar file from the /tmp/ directory to /wfs/screenshot.jar :

cp /tmp/ /wfs/screenshot.jar  

It is important to copy the file to /wfs  because otherwise the file would be flushed with a reboot.
Open IGEL setup and create a new custom application:
System > Firmware Customization > Custom Application
Set Command to java -jar /wfs/screenshot.jar  in Settings.
Click the new icon on the desktop to run the custom application.

To distribute this application to several thin clients use the file transfer option in IGEL UMS and set up a profile with 
the custom application configuration.

HOW TO USE Easy Screenshot Maker:
Start the application.
Make a screenshot.
Save the file for example as test.png .

HOW TO USE Rapid Screenshot:
Start the application.
Click Save in to configure the path to store screenshots.
Click button Click.
The screenshot will be saved automatically as .jpg .

The default download location of local Firefox is /tmp/ .

Please note the licenses for both screenshot capture tools mentioned on the websites of these specific 
tools!



https://sourceforge.net/projects/screenshot/?source=directory
https://sourceforge.net/projects/screenshot/?source=directory
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Setting the Device's System Time

Issue
The thin client's system time is not correct.

Solution
Open the thin client's configuration either locally or in UMS.
Go to System > Time and Date
Choose your Continent/Area (e.g. America).
Choose your Location (e.g. New York).
Set time and date

either manually by clicking Set time and date
or automatically by configuring an NTP Time Server.

Click OK or Apply to save your settings.

Example for America/New York: In POSIX standard GMT+5 is the time zone 5 hours west of Greenwich and 
corresponds to UTC-5

Note: If choosing General as Time Zone Area you have to set your GMT time zone 
(Location) following the POSIX standard (as usual in Linux) - which means you have to 
invert the offset of your common UTC time zone! (See tool tip for Location as well.) 
Therefore it is preferable to set the system's time zone by choosing the corresponding 
area and location instead of defining the GMT offset.



Legal Note

IGEL's Terms & Conditions62 apply.


https://www.igel.com/terms-conditions/
https://www.igel.com/terms-conditions/
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Updating Timezone Information (Daylight Saving Time, DST)

Symptom
The device is showing an incorrect time of day for your location, although you have set the correct time zone.

Problem
The time zone or the regulation for Daylight Saving Time (DST) for your location has changed.

Solution
Update the time zone information files via IGEL Universal Management Suite (UMS).

Retrieving Current Time Zone Information Files
On Windows

Use your web browser to download the following package files:
http://packages.ubuntu.com/xenial-updates/all/tzdata/download for IGEL Linux version 
10.x

Extract the package contents using the program 7-Zip (freely available from http://www.7-zip.org).
Find the file for your location in the extracted directory in usr/share/zoneinfo/ , e.g. usr/

share/zoneinfo/Africa/Casablanca  for Morocco.

On Linux

Update your system time zone information with these commands: sudo apt-get update  

sudo apt-get install tzdata

Find the file for your location in the system directory /usr/share/zoneinfo/ , e.g. /usr/

share/zoneinfo/Africa/Casablanca  for Morocco.

Distributing the Files from IGEL Universal Management Suite

Select System > New > New File from the UMS Console menu bar or go to Files in the tree 
structure and select New File from the context menu.
Select the time zone file for your location under Local File.
Select Undefined under Classification.
Specify /wfs/zoneinfo/  as the Devices file location.
Set the Access rights to Read and Write for the Owner, and to Read for Others.
Select Root as the Owner.
Click OK to confirm the settings.

http://packages.ubuntu.com/xenial-updates/all/tzdata/download
http://www.7-zip.org
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On a device, you can verify the transfer and activation of the new time zone information files:

In the Local Terminal, enter grep 'timezone_config' /var/log/messages

The output should look like the following:
Feb 27 11:28:13 (none) timezone_config: loading /wfs/zoneinfo/

Casablanca to /usr/share/zoneinfo/Africa/Casablanca  

Feb 27 11:28:13 (none) timezone_config: loading /wfs/zoneinfo/

Casablanca to /usr/share/zoneinfo/posix/Africa/Casablanca  

On IGEL Linux version 10.x, use: journalctl | grep 'timezone_config'
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Feb 27 11:28:13 (none) timezone_config: configure timezone Africa/

Casablanca
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Adding or Changing a MIME Type Handler

Symptom
Files or protocols are opened with the wrong application.

Problem
The MIME type handler for the file type or the protocol is missing or misconfigured.

Solution
Change the MIME type handler or add a new one.

MIME type handlers are defined by *.desktop  files in the /usr/share/applications.mime/  directory.

To add a new *.desktop  file, use the following sample and edit it according to your needs:

[Desktop Entry]

Version=1.0

Encoding=UTF-8

Type=Application

Name=Browser//A name for the MIME type handler

Categories=Application

Exec=/usr/bin/firefox %u//The binary to execute on opening an associated file

MimeType=x-scheme-handler/http;x-scheme-handler/https;text/html;application/

xhtml+xml;//A list of MIME types separated by semicolon

Terminal=false

StartupNotify=false

NoDisplay=true

You can find out more about *.desktop  files in a specification at freedesktop.org (see page 826).

These are the default handlers on IGEL Linux:Images (opened via gpicview)

image/bmp;
image/gif;
image/jpeg;
image/jpg;
image/png;
image/x-bmp;
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image/x-pcx;
image/x-tga;
image/x-portable-pixmap;
image/x-portable-bitmap;
image/x-targa;
image/x-portable-greymap;
application/pcx;
image/svg+xml;
image/svg-xml;

Videos and Music (opened via /services/mplr/bin/mediaplayer )

Note that /services/mplr/bin/mediaplayer  calls either /config/sessions/mediaplayer0  if 

existent or totem if this is not the case

application/mxf;
application/ogg;
application/ram;
application/sdp;
application/smil;
application/smil+xml;
application/vnd.ms-wpl;
application/vnd.rn-realmedia;
application/x-extension-m4a;
application/x-extension-mp4;
application/x-flac;
application/x-flash-video;
application/x-matroska;
application/x-netshow-channel;
application/x-ogg;
application/x-quicktime-media-link;
application/x-quicktimeplayer;
application/x-shorten;
application/x-smil;
application/xspf+xml;
audio/3gpp;
audio/ac3;
audio/AMR;
audio/AMR-WB;
audio/basic;
audio/midi;
audio/mp4;
audio/mpeg;
audio/mpegurl;
audio/ogg;
audio/prs.sid;
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audio/vnd.rn-realaudio;
audio/x-ape;
audio/x-flac;
audio/x-gsm;
audio/x-it;
audio/x-m4a;
audio/x-matroska;
audio/x-mod;
audio/x-mp3;
audio/x-mpeg;
audio/x-mpegurl;
audio/x-ms-asf;
audio/x-ms-asx;
audio/x-ms-wax;
audio/x-ms-wma;
audio/x-musepack;
audio/x-pn-aiff;
audio/x-pn-au;
audio/x-pn-realaudio;
audio/x-pn-realaudio-plugin;
audio/x-pn-wav;
audio/x-pn-windows-acm;
audio/x-realaudio;
audio/x-real-audio;
audio/x-sbc;
audio/x-scpls;
audio/x-speex;
audio/x-tta;
audio/x-wav;
audio/x-wavpack;
audio/x-vorbis;
audio/x-vorbis+ogg;
audio/x-xm;
image/vnd.rn-realpix;
image/x-pict;
misc/ultravox;
text/google-video-pointer;
text/x-google-video-pointer;
video/3gpp;
video/dv;
video/fli;
video/flv;
video/mp4;
video/mp4v-es;
video/mpeg;
video/msvideo;
video/ogg;
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video/quicktime;
video/vivo;
video/vnd.divx;
video/vnd.rn-realvideo;
video/vnd.vivo;
video/x-anim;
video/x-avi;
video/x-flc;
video/x-fli;
video/x-flic;
video/x-flv;
video/x-m4v;
video/x-matroska;
video/x-mpeg;
video/x-ms-asf;
video/x-ms-asx;
video/x-msvideo;
video/x-ms-wm;
video/x-ms-wmv;
video/x-ms-wmx;
video/x-ms-wvx;
video/x-nsv;
video/x-ogm+ogg;
video/x-theora+ogg;
video/x-totem-stream;
x-content/video-dvd;
x-content/video-vcd;
x-content/video-svcd;

Documents (opened via /usr/bin/evince )

application/pdf;
image/tiff

Web (opened via /usr/bin/firefox -remote )

x-scheme-handler/http;
x-scheme-handler/https;
text/html;
application/xhtml+xml;
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Regional Settings in Sessions

Symptom
If you set a certain keyboard language it has no effect on the regional settings.

Problem
In the IGEL setup there are several input fields for regional settings. You would like to understand which setting has 
what effect in the sessions.

Solution

Defining general regional settings:

 Go to IGEL Setup > User Interface > Language.

Language: Select one of the languages offered for the graphical user interface.
Keyboard Layout: Select the country-specific assignment of keys, e.g. English(US).
Input Language: Set the language you are going to write in, e.g. English(Australia).
Standards and Formats: Select country-specific formats, e.g. for date and time or currency.

Defining session-specific regional settings:

 Go to the settings of your session, e.g. Citrix: IGEL Setup > Sessions > Citrix > Citrix Global > Keyboard.

 Specify Keyboard Layout and Input Language for your Citrix Session.

The default settings are those you defined under User Interface > Language.
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Devices
Monitor (see page 832)
Using a Cherry SECURE BOARD (see page 852)
Webcam Redirection and Optimization (see page 879)
Webcam Information (see page 890)
Bluetooth Tool (see page 892)
How to Deploy a Jabra Xpress Package (see page 896)
Connecting Signature Pads (see page 900)
Using a Kofax / Wacom Signature Pad (see page 901)
Using a StepOver Signature Pad (see page 902)
eGK/KVK - Card Reader (see page 908)
Using Mobile Device Access (see page 916)
Swapping Function of Mouse Buttons (e.g. When Using an Evoluent Mouse) (see page 925)
Using Natural Scrolling (reverse Scrolling Direction) (see page 927)
Connecting a Serial Barcode Scanner (see page 928)
Using DriveLock with IGEL Devices (see page 930)
Restricting the Mounting of Hotplug Storage Devices on IGEL Linux (see page 931)
When to Use USB Redirection (see page 932)
How to Configure USB Access Control (see page 936)
Issues with USB IDs in USB Devices Rules (see page 939)
How Can I Fix Touchpad Issues? (see page 941)
How Do I Configure a Fujitsu PalmSecure Vein Scanner with IGEL OS? (see page 944)
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Monitor
Touchscreen Calibration (see page 833)
Touchscreen in Multimonitor Environment (see page 846)
USB-Powered ASUS Monitor and IGEL OS 11 (see page 847)
Solving Hotplugging Issues with DisplayPort Monitors (see page 848)
No Sound When Using a DisplayPort Monitor (see page 849)
Connecting Three DVI Monitors to UD7 with Passive DisplayPort Adapters (see page 851)
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Touchscreen Calibration
For setting up a touchscreen, you have to enable the touchscreen function and select a specific touchscreen driver.

To set up a touchscreen:

In IGEL Setup, go to User Interface > Input > Touchscreen.
Activate Enable touchscreen.
Select your touchscreen driver under Touchscreen type.

Depending on the selected driver, you have different configuration options. For further information, click the 
appropriate link:

EvTouch (USB) (see page 834)
eGalax (see page 838)
Elo Multitouch (USB) (see page 840)
Elo Singletouch (USB) (see page 842)
TSHARC (USB) (see page 844)

The initial configuration should take place with a mouse and keyboard connected to ensure that you can 
open the setup and navigate within it.


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EvTouch (USB)

Supported Devices

Supported touch monitors and touchscreen controllers:

Vendor Product Name

0x16FD 0x5453 Reakin, TS2005F USB TouchController

0x7374 0x0001

0x04E7 0x0020 Elo TouchSystems, Touchscreen Interface (2700)

0x1870 0x0001 Nexio Co., Ltd, iNexio Touchscreen controller

0x10F0 0x2002 Nexio Co., Ltd, iNexio Touchscreen controller

0x0664 0x0306 ET&T Technology Co., Ltd., Groovy Technology Corp. GTouch Touch 
Screen

0x0664 0x0309 ET&T Technology Co., Ltd.  Groovy Technology Corp. GTouch Touch 
Screen

0x14C8 0x0003 Zytronic, Unknown device

0x1AC7 0x0001

0x0F92 0x0001

0x08F2 0x00F4 Gotop Information Inc., Unknown device

0x08F2 0x00CE Gotop Information Inc., Unknown device

0x08F2 0x007F Gotop Information Inc., Super Q2 Tablet

0x0DFC 0x0001 GeneralTouch Technology Co., Ltd, Touchscreen

0x1391 0x1000 IdealTEK, Inc., URTC-1000

0x6615 0x0001 IRTOUCHSYSTEMS Co. Ltd., Touchscreen

0x595A 0x0001 IRTOUCHSYSTEMS Co. Ltd., Touchscreen

0x0AFA 0x03E8

0x0637 0x0001

0x1234 0x5678 Brain Actuated Technologies, Unknown device

0x16E3 0xF9E9

0x0403 0xF9E9 Future Technology Devices International, Ltd, Unknown device
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Vendor Product Name

0x0596 0x0001 MicroTouch Systems, Inc., Touchscreen

0x134C 0x0004 PanJit International Inc., Touch Panel Controller

0x134C 0x0003 PanJit International Inc., Touch Panel Controller

0x134C 0x0002 PanJit International Inc., Touch Panel Controller

0x134C 0x0001 PanJit International Inc., Touch Panel Controller

0x1234 0x0002 Brain Actuated Technologies, Unknown device

0x1234 0x0001 Brain Actuated Technologies  Unknown device

0x0EEF 0x0002 D-WAV Scientific Co., Ltd, Touchscreen Controller(Professional)

0x0EEF 0x0001 D-WAV Scientific Co., Ltd, eGalax TouchScreen

0x0123 0x0001

0x3823 0x0002

0x3823 0x0001

Setup Parameters

Touchscreen type
More

IGEL Setup > User Interface > Input > Touchscreen

> Touchscreen type userinterface.touchscreen.driver

Swap X and Y values
More

IGEL Setup > User Interface > Input > Touchscreen

> Swap X and Y values userinterface.touchscreen.swapxy enabled / disabled

Set driver specific defaults for resetting calibration values.

Calibration / Reset

Calibrating the touchscreen:
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1.
2.

3.

4.

1.

2.

Go to IGEL Setup > User Interface > Input > Touchscreen.
Set Touchscreen already calibrated to 'false'.
More

IGEL Setup > User Interface > Touchscreen

> Touchscreen already calibrated userinterface.touchscreen.calibrat
ed

enabled / disabled

Set Touchscreen type to EvTouch (USB).
More

IGEL Setup > User Interface > Input > Touchscreen

> Touchscreen type userinterface.touchscreen.driver

Reboot the device or click IGEL Setup > Accessories > Touchscreen Calibration to use the IGEL 
touchscreen calibration tool. 
This will call the xinput_calibrator calibration tool which is located at /usr/bin/

xinput_calibrator . The calibration parameter will be saved in IGEL setup.

Hold-to-Right-Click Feature

To activate the feature:

Enable the option Emulate right button under User Interface > Input > Touchscreen.
More

IGEL Setup > User Interface > Input > Touchscreen

> Emulate right 
button

userinterface.touchscreen.emulatethirdbutton enabled / disabled

Set under Right button timeout the time after which right-click is generated.
More

IGEL Setup > User Interface > Input > Touchscreen

> Right button 
timeout

userinterface.touchscreen.emulatethirdbuttonti
meout

Default: 1000 
msec
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Multimonitor

Multimonitor configuration is not supported.
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3.

4.

eGalax

Supported Devices

EETI eGalax eMPIA USB touchscreens.

Setup Parameters

Touchscreen type
More

IGEL Setup > User Interface > Input > Touchscreen

> Touchscreen type userinterface.touchscreen.driver

Calibration / Reset

Calibrating the touchscreen:

Go to IGEL Setup > User Interface > Input > Touchscreen.
Set Touchscreen already calibrated to 'false'.
More

IGEL Setup > User Interface > Touchscreen

> Touchscreen already calibrated userinterface.touchscreen.calibrat
ed

enabled / disabled

Set Touchscreen type to eGalax.
More

IGEL Setup > User Interface > Input > Touchscreen

> Touchscreen type userinterface.touchscreen.driver

Reboot the device or click IGEL Setup > Accessories > Touchscreen Calibration to use the IGEL 
touchscreen calibration tool. 
This will call the proprietary EETI calibration tool, which is located at /usr/bin/eCalib . The 

calibration parameter will be saved in /wfs/egtouch.d .
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1.

2.

Hold-to-Right-Click Feature

To activate the feature:

Enable the option Emulate right button under User Interface > Input > Touchscreen.
More

IGEL Setup > User Interface > Input > Touchscreen

> Emulate right 
button

userinterface.touchscreen.emulatethirdbutton enabled / disabled

Set under Right button timeout the time after which right-click is generated.
More

IGEL Setup > User Interface > Input > Touchscreen

> Right button 
timeout

userinterface.touchscreen.emulatethirdbuttonti
meout

Default: 1000 
msec

Multimonitor

Multimonitor configuration is not supported.



Devices

IGEL OS Articles   840 / 1017

•

1.
2.
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4.

Elo Multitouch (USB)

Supported Devices

IntelliTouch Plus/iTouch Plus 2515-07(non HID), 2521 (HID), 2515-00(HID) PCAP 2 touch, 4 touch and 10 touch 
controllers.

Setup Parameters

Touchscreen type

More

IGEL Setup > User Interface > Input > Touchscreen

> Touchscreen type userinterface.touchscreen.driver

Calibration / Reset

Calibrating the touchscreen:

Go to IGEL Setup > User Interface > Input > Touchscreen.
Set Touchscreen already calibrated to 'false'.
More

IGEL Setup > User Interface > Touchscreen

> Touchscreen already 
calibrated

userinterface.touchscreen.calibrated enabled / disabled

Set Touchscreen type to Elo Multitouch (USB).
More

IGEL Setup > User Interface > Input > Touchscreen

> Touchscreen type userinterface.touchscreen.driver

Reboot the device or click in IGEL Setup Accessories > Touchscreen Calibration to use the IGEL 
touchscreen calibration tool. 
This will call the proprietary ELO Multitouch calibration tool which is located at /etc/opt/
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elo-mt-usb/elova . The calibration parameter will be saved in /wfs/elo-usb.d/MT-

USBConfigData .

Hold-to-Right-Click Feature

To activate the feature:

Enable the option Emulate right button under User Interface > Input > Touchscreen.
More

IGEL Setup > User Interface > Input > Touchscreen

> Emulate right 
button

userinterface.touchscreen.emulatethirdbutton enabled / 
disabled

Set under Right button timeout the time after which right-click is generated.
More

IGEL Setup > User Interface > Input > Touchscreen

> Right button 
timeout

userinterface.touchscreen.emulatethirdbuttontimeou
t

Default: 1000 
msec

Multimonitor

Multiple ELO Multitouch (USB) touchscreens on a single IGEL device are supported. Calibration of the second ELO 
Multitouch USB touchscreen can be done via command line by using: /etc/opt/elo-mt-usb/elova --

videoscreen=2  where 2 is the second ELO Multitouch touchscreen connected to the IGEL device.

To view a list of video and USB touchscreen devices available for calibration, use the command: /etc/

opt/elo-mt-usb/elova --viewdevices .


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1.
2.

3.

Elo Singletouch (USB)

Supported Devices

Elo Smartset USB Controllers:

IntelliTouch(R) 2701, 2700, 2600, 2500U
CarrollTouch(R) 4500U, 4000U
Accutouch(R) 2216, 3000U, 2218
Surface Capacitive 5020, 5010, 5000
Accoustic Pulse Recognition(APR) Smartset 7010
Other Elo Smartset USB controllers

Setup Parameters

Touchscreen type

More

IGEL Setup > User Interface > Input > Touchscreen

> Touchscreen type userinterface.touchscreen.driver

Calibration / Reset

Calibrating the touchscreen:

Go to IGEL Setup > User Interface > Input > Touchscreen.
Set Touchscreen already calibrated to 'false'.
More

IGEL Setup > User Interface > Touchscreen

> Touchscreen already 
calibrated

userinterface.touchscreen.calibrated enabled / disabled

Set Touchscreen type to Elo Singletouch (USB).
More

IGEL Setup > User Interface > Input > Touchscreen

> Touchscreen type userinterface.touchscreen.driver
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4. Reboot the device or click in IGEL Setup Accessories > Touchscreen Calibration to use the IGEL 
touchscreen calibration tool. 
This will call the proprietary ELO Singletouch calibration tool which is located at /etc/opt/

elo-usb/elova . The calibration parameter will be saved in /wfs/elo-usb.d/

USBConfigData .

Hold-to-Right-Click Feature

The feature is not supported.

Multimonitor

Multiple ELO Singletouch USB touchscreens on a single IGEL device are supported. Calibration of the second ELO 
Singletouch USB touchscreen can be done via command line by using: /etc/opt/elo-usb/elova --

videoscreen=2  where 2 is the second ELO Singletouch USB touchscreen connected to the IGEL device.

To view a list of video and USB touchscreen devices available for calibration, use the command: /etc/

opt/elo-usb/elova --viewdevices .





Devices

IGEL OS Articles   844 / 1017

•

1.
2.

3.

4.

TSHARC (USB)

Supported Devices

Hampshire TSHARC USB touchscreens.

Setup Parameters

Touchscreen type
More

IGEL Setup > User Interface > Input > Touchscreen

> Touchscreen type userinterface.touchscreen.driver

Calibration / Reset

Calibrating the touchscreen:

Go to IGEL Setup > User Interface > Input > Touchscreen.
Disable Touchscreen already calibrated.
More

IGEL Setup > User Interface > Touchscreen

> Touchscreen already 
calibrated

userinterface.touchscreen.calibrated enabled / disabled

Set Touchscreen type to TSharc.
More

IGEL Setup > User Interface > Input > Touchscreen

> Touchscreen type userinterface.touchscreen.driver

Reboot the device or click IGEL Setup > Accessories > Touchscreen Calibration to use the IGEL 
touchscreen calibration tool. 
This will call the proprietary Hampshire calibration tool, which is located at /usr/bin/tscal . 

The calibration parameter will be saved in /wfs/tsharc.d .
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Hold-to-Right-Click Feature

To activate the feature:

Enable the option Emulate right button under User Interface > Input > Touchscreen.
More

IGEL Setup > User Interface > Input > Touchscreen

> Emulate right 
button

userinterface.touchscreen.emulatethirdbutton enabled / 
disabled

Set under Right button timeout the time after which right-click is generated.
More

IGEL Setup > User interface > Input > Touchscreen

> Right button 
timeout

userinterface.touchscreen.emulatethirdbuttontimeou
t

Default: 1000 
msec

Multimonitor

Multimonitor configuration is not supported.
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1.
2.

Touchscreen in Multimonitor Environment

Symptom
You are using a touchscreen in a multimonitor environment. In this case, it can happen that the touchscreen 
coordinate matrix expands over both monitors, with the result that the monitor interprets the touch point in a 
wrong way.

Problem
You touch the touchscreen in its center and the cursor moves between the two screens.

Solution
To avoid the unrequested expansion of the touchscreen matrix you have to select the correct touchscreen 
connection type in the setup:

Click User Interface > Input > Touchscreen in the IGEL setup.
Select the correct connection type under Multi Monitor > Touchscreen Monitor.
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USB-Powered ASUS Monitor and IGEL OS 11

Issue
USB-powered monitor

Environment

IGEL OS 11 (11.03.100)
UMS 6.01 and higher

Description
Recommendation for a USB-powered monitor

Solution
In the following link, you can find the USB-powered ASUS monitor that works plug and play with IGEL OS https://
www.asus.com/us/Monitors/MB168B/.

Solution Based on Experience from the Field

This article provides a solution that has not been approved by the IGEL Research and Development 
department. Therefore, official support cannot be provided by IGEL. Where applicable, test the solution 
before deploying it to a productive environment.



https://www.asus.com/us/Monitors/MB168B/
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1.

2.

3.

Solving Hotplugging Issues with DisplayPort Monitors

Symptom
On IGEL Linux, in a dual view configuration, the following problem occurs: If a monitor connected via DisplayPort is 
only switched on after booting the device, it will remain black.

Problem
The DisplayPort standard allows for a powered-off monitor to be undetectable by the graphics card.

Solution
The following checks whether a monitor contained in the configuration is missing (i.e. powered off) and makes it 
usable as soon as it appears (i.e. is powered on):

If you are using IGEL Linux 5, make sure you are running version 5.10.410 or newer.
If you are using IGEL Linux 10 you do not need to upgrade.
In Setup, go to System > Registry > Parameter > 
session.user_display%.options.enhanced_hotplug

Make sure the parameter is set to true (default).

•

•

There is another setting you can use if you do not want IGEL Linux to change the display settings every 
time a DisplayPort monitor is switched on/off:

Go to System > Registry > Parameter >
s essions.user_display%.options.disable_hotplug
Set it to DP_Disconnect_Only.


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1.
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3.

No Sound When Using a DisplayPort Monitor

Symptom
You do not hear any sound from your IGEL UD5 or UD6 device. You are using a monitor connected via DisplayPort.

Problem
Some DisplayPort monitors misleadingly report support for display audio although they do not have loudspeakers. 
Therefore IGEL Linux will try to play back audio via the monitor.

Solution

Right-click on the loudspeaker icon in the panel and open Sound Preferences.
In the Output tab select Speakers / Built-in Audio.

Click Test Sound to test the new setting. Check if you hear a voice saying "Front Left" and "Front 
Right" on the device speakers.
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4.

Connecting Three DVI Monitors to UD7 with Passive DisplayPort Adapters

Problem
When three DVI monitors are connected to a UD7 thin client over passive DisplayPort adapters, only one or two 
monitors are detected.

Solution

Open the thin client's Setup.
Go to System > Registry > x > xserver0 > force_reconfig (Registry key: 
x.xserver0.force_reconfig ) and set the value to never. 

Click Ok to save the setting and close the Setup.
Restart the device.
All three monitors should be detected. 

This solution is only persistent if energy saving is switched off.
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1.
2.
3.
4.

Using a Cherry SECURE BOARD

Overview
Cherry SECURE BOARD 1.0 provides a secure keyboard input mode which safeguards against hardware keylogging
and "Bad USB" attacks.

The following security features are available when an IGEL OS 11 device is connected to a Cherry SECURE BOARD 1.0 
in secure mode:

Your IGEL OS 11 devices will accept keyboard input only from a personalized Cherry SECURE 
BOARD with secure mode enabled.
The keyboard traffic between the keyboard and the endpoint is transmitted over a TLS 1.3 
encrypted connection.
Optionally, the keyboard can be configured so that it will only accept endpoints that have the right 
certificates.

For further details on the Cherry SECURE BOARD, see https://www.cherry-world.com/cherry-secure-board-1-0.html.

Prerequisites
Devices with IGEL OS 11.03 or higher
UMS 6.01 or higher

Getting the Cherry SECURE BOARD to Work in Secure Mode
To set up a number of Cherry SECURE BOARD keyboards, you must first configure one endpoint that will be used for 
personalizing the keyboards. The personalization process implies deploying the appropriate certificates to every 
Cherry SECURE BOARD keyboard that will be used in secure mode. 

In addition, the endpoints that are to be connected to the Cherry SECURE BOARD keyboards must be provisioned 
with the appropriate certificates. 

To set up and use Cherry SECURE BOARD keyboards, perform the following steps:

Getting the Certificates (see page 853)
Setting Up the Personalization Machine (see page 868)
Personalizing the Cherry SECURE BOARD (see page 870)
Setting Up the Endpoints (see page 874)

If you want to put a Cherry SECURE BOARD keyboard into its original state, see Resetting the Cherry SECURE BOARD 
to Its Original State (see page 878).

https://www.cherry-world.com/cherry-secure-board-1-0.html


Devices

IGEL OS Articles   853 / 1017

•

•

•
•

Getting the Certificates
Secure mode requires a set of certificates being present both on the endpoint and the keyboard. First, all required 
certificates are transferred to the endpoint. Then, the endpoint installs a user certificate and the corresponding key 
on the keyboard; optionally, the client root CA certificate is also installed. This installation of certificates is referred 
to as personalization.

Downloading the Device Certificates

Download all certificates from https://github.com/secureboard10/secureboard-ca:

Device root CA certificate: SecureboardRootCA.pem  

Device intermediate CA certificates:  p-20190712.pem ,  p-20191030  etc.

Creating the Custom Certificates
According to "CHERRY SECUREBOARD 1.0, Software Developer's Guide", chapter 9.5, all certificate and key pairs 
that are sent to the keyboard must meet the following requirements:

X509 Version 3 using ECDSA over NIST curve prime256v1 with corresponding keys
Size: Maximum of 572 bytes resp. 475 bytes in DER format

 Create the following custom certificates:

An example how-to for OpenSSL can be found in "CHERRY SECUREBOARD 1.0, Software Developer's 
Guide", chapter 9.5; see https://www.cherry.de/files/manual/SECUREBOARD_SwDev_Guide_en-0.4.pdf.
Also, the SECURE BOARD 1.0 Quick Installation Package contains a ready-made shell script that creates 
example certificates. Download the package from https://www.cherry.de/files/software/
Cherry_Secureboard_1.0_Quick_Installation_Package_V1.0.zip, unzip the file, and use Cherry 

Secureboard 1.0 cert-package V1.0/secureboard_linx/create_certs.sh  (Linux) 

or  Cherry Secureboard 1.0 cert-package V1.0/secureboard_windows/

create_certs.bat  (Windows).



https://github.com/secureboard10/secureboard-ca
https://www.cherry.de/files/manual/SECUREBOARD_SwDev_Guide_en-0.4.pdf
https://www.cherry.de/files/software/Cherry_Secureboard_1.0_Quick_Installation_Package_V1.0.zip
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Certifi
cate

Required/
Optional

Requirements Encoding/
Extension
 

Max. 
File 
Size*

File 
Name

Remarks

User 
root CA 
certific
ate

required not specified PEM not 
specifi
ed

not 
specifie
d

If this certificate is also used as 
the client root CA certificate for 
mutual authentication, it must 
meet the requirements for 
certificates that are sent to the 
keyboard: X509 Version 3 using 
ECDSA over NIST curve 
prime256v1 with corresponding 
keys; max. 475 bytes

Interm
ediate 
CA 
certific
ates

optional 
(accordin
g to the 
certificate 
chain that 
is to be 
used)

not specified PEM not 
specifi
ed

not 
specifie
d

User 
certific
ate 
(keybo
ard)

required X509 Version 3 
using ECDSA over 
NIST curve 
prime256v1 with 
corresponding 
keys

DER 
(binary)

572 
bytes

user-

cert.

der

Corres
pondin
g user 
key 
(keybo
ard)

required X509 Version 3 
using ECDSA over 
NIST curve 
prime256v1 with 
corresponding 
keys

PEM 
(without a 
passphras
e)

not 
specifi
ed

user-

key.p

em

Client 
root CA 
certific
ate 
(keybo
ard)

optional; 
for 
mutual 
authentic
ation** (se
e page 855)

X509 Version 3 
using ECDSA over 
NIST curve 
prime256v1 with 
corresponding 
keys

PEM 475 
bytes

not 
specifie
d

Can be identical with the user 
root CA certificate
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1.

2.

Certifi
cate

Required/
Optional

Requirements Encoding/
Extension
 

Max. 
File 
Size*

File 
Name

Remarks

Client 
certific
ate 
(endpo
int)

optional; 
for 
mutual 
authentic
ation** (se
e page 855)

X509 Version 3 
using ECDSA over 
NIST curve 
prime256v1 with 
corresponding 
keys

PEM 475 
bytes

clien

t-

cert.

pem

Client 
key 
(endpo
int)

optional; 
for 
mutual 
authentic
ation** (se
e page 855)

X509 Version 3 
using ECDSA over 
NIST curve 
prime256v1 with 
corresponding 
keys

PEM 
(without a 
passphras
e)

not 
specifi
ed

clien

t-

key.p

em

* The relevant value is the file size that the certificate has when it is stored in binary format.

** When these certificates are installed, the keyboard can verify if the endpoint is authentic. Without the optional 
certificates, only the verification of the keyboard's authenticity by the endpoint will be carried out.

Provisioning the Personalization Machine
The following instructions describe how to transfer the required certificates to the personalization machine. 
The personalization machine will deploy the certificates to the keyboard. The UMS will be used for this purpose.

First, a file object is created for each certificate or key file so that the files can be handled by the UMS.

Second, the file objects are assigned to the personalization machine, which results in the files being transferred to 
that machine.

Creating the File Object for the Device Root CA Certificate

In the UMS structure tree, go to Files and in the context menu, select New file.

In the New file dialog, configure the settings as follows:
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•
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•
•

3.

Local file: Local file path of SecureboardRootCA.pem . Use the file chooser by clicking 

.
Device file location:  /wfs/cherry/ca-certs/
Access rights - Owner: Read, Write
Access rights - Others: Read
Owner: Root

Click Ok.
In the UMS, the file object SecureBoardRootCA.pem is created.
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1.

2.
•

•
•
•
•

Creating the File Object for the Device Intermediate CA Certificate

In the UMS structure tree, go to Files and in the context menu, select New file.

In the New file dialog, configure the settings as follows:
Local file: Local file path of p-20190712.pem . Use the file chooser by clicking .

Device file location:  /wfs/cherry/ca-certs/
Access rights - Owner: Read, Write
Access rights - Others: Read
Owner: Root
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3.

1.

2.
•

•
•
•

Click Ok.
In the UMS, the file object p-20190712.pem is created.

Creating the File Object for the Device Client CA Certificate (Optional)

In the UMS structure tree, go to Files and in the context menu, select New file.

In the New file dialog, configure the settings as follows:
Local file: Local file path of clientca-cert.pem . Use the file chooser by clicking .

Device file location:  /wfs/cherry/ca-certs/
Access rights - Owner: Read, Write
Access rights - Others: Read
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3.

1.

2.

Owner: Root

Click Ok.
In the UMS, the file object clientca-cert.pem is created.

Creating the File Object for the User Certificate (Keyboard)

To transfer the certificate file  user-cert.der  to the directory /wfs/cherry/client-certs/  on the 
personalization machine, proceed as follows:

In the UMS structure tree, go to Files and in the context menu, select New file.

In the New file dialog, configure the settings as follows:
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3.

Local file: Local file path of user-cert.der . Use the file chooser by clicking .

Device file location:  /wfs/cherry/client-certs/
Access rights - Owner: Read, Write
Access rights - Others: Read
Owner: Root

Click Ok.
In the UMS, the file object user-cert.der is created.
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•
•

Creating the File Object for the User Key (Keyboard)

In the UMS structure tree, go to Files and in the context menu, select New file.

In the New file dialog, configure the settings as follows:
Local file: Local file path of user-key.pem . Use the file chooser by clicking .

Device file location:  /wfs/cherry/client-certs/
Access rights - Owner: Read, Write
Access rights - Others: -
Owner: Root
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1.

2.
•
•
•
•

Click Ok.
In the UMS, the file object user-key.pem is created.

Provisioning the Endpoints for Using the SECURE BOARD
The following instructions describe how to transfer the required certificates to the endpoints which will be 
connected to the SECURE BOARD in secure mode.

Creating the File Object for the User Root CA Certificate

In the UMS structure tree, go to Files and in the context menu, select New file.

In the New file dialog, configure the settings as follows:
Local file: Local file path of the certificate file. Use the file chooser by clicking .
Device file location:  /wfs/cherry/ca-certs/
Access rights - Owner: Read, Write
Access rights - Others: Read
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•

3.

1.

2.
•
•

Owner: Root

Click Ok.
In the UMS, the file object is created. The name of the file object is derived from the file name.

Creating the File Object for the Client Root CA Certificate (Optional)

In the UMS structure tree, go to Files and in the context menu, select New file.

In the New file dialog, configure the settings as follows:
Local file: Local file path of the certificate file. Use the file chooser by clicking .
Device file location:  /wfs/cherry/ca-certs/
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•
•
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3.

1.

2.

Access rights - Owner: Read, Write
Access rights - Others: Read
Owner: Root

Click Ok.
In the UMS, the file object is created. The name of the file object is derived from the file name.

Creating the File Object for the Client Certificate (Endpoint) (Optional)

In the UMS structure tree, go to Files and in the context menu, select New file.

In the New file dialog, configure the settings as follows:
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•

•
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•

3.

Local file: Local file path of client-cert.pem . Use the file chooser by clicking .

Device file location:  /wfs/cherry/client-certs/
Access rights - Owner: Read, Write
Access rights - Others: Read
Owner: Root

Click Ok.
In the UMS, the file object is created. The name of the file object is derived from the file name.
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1.
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•

•
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•
•

Creating the File Object for the Client Key (Endpoint) (Optional)

In the UMS structure tree, go to Files and in the context menu, select New file.

In the New file dialog, configure the settings as follows:
Local file: Local file path of client-key.pem . Use the file chooser by clicking .

Device file location:  /wfs/cherry/client-certs/
Access rights - Owner: Read, Write
Access rights - Others: -
Owner: Root
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3. Click Ok.
In the UMS, the file object is created. The name of the file object is derived from the file name.
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•
•
•
•
•
•
•

4.

Setting Up the Personalization Machine

Setting Up the Local Terminal
If a local terminal session has already been configured on the designated personalization machine, you can skip this 
step.

Open the device's Setup and go to Accessories >Terminals.
Select  .
Click Ok.
On the desktop and in the Application Starter, a starter for the terminal session is created.

Assigning the File Objects to the Personalization Machine

In the UMS structure tree, select the endpoint that will act as the personalization machine.

In the Assigned objects area, click . 

Under Files, select the file objects using the  button:
SecureboardRootCA.pem 
Device intermediate CA certificates; here: p-20190712.pem
user-cert.der
user-key.pem
client-cert.pem (optional)
client-key.pem (optional)
Device client CA certificate; here: clientca-cert.pem (optional)

Click Ok.
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5. In the Update time dialog, select Now and click Ok.
The certificate and key files are transferred to the personalization machine. The personalization 
machine is ready for operation.
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Personalizing the Cherry SECURE BOARD

Overview

Personalization Machine Verifies if the Keyboard Is a Genuine Cherry SECURE BOARD

Personalization Machine Installs the Certificates on the Keyboard
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•

1.

Prerequisites

The machine has been prepared as described under Setting Up the Personalization Machine (see 
page 868).
The Cherry SECURE BOARD keyboards are in factory state or have been reset (see Resetting the 
Cherry SECURE BOARD to Its Original State (see page 878)). 

Instructions

Start the local terminal and log in as root .
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2. Enter the command  secureboard_personalize

If all required certificates and the optional certificates for mutual authentication are present, the 
personalization facility is ready.

 

In case only the required certificates are present, the personalization facility is ready, but a 
message stating the absence of the optional certificates for mutual authentication is shown:



Devices

IGEL OS Articles   873 / 1017

3.

4.

5.

Plug in a Cherry SECURE BOARD.
A message confirms that the keyboard has been detected; you are prompted to start the 
personalization.

 

Enter y  to start the personalization process.
During the personalization process, a few messages are shown. If everything has gone well, a 
message about the successful personalization appears.

Unplug the personalized Cherry SECURE BOARD and proceed with the next Cherry SECURE BOARD.
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1.

2.
•
•

3.

Setting Up the Endpoints

Creating a Profile for the Endpoints

In the UMS structure tree, open the context menu for Profiles and select New Profile.

In the New Profile dialog, enter the required data and click Ok:
Profile Name: Name for the profile
Based on: Select the version of IGEL OS that is installed on your devices (IGEL OS 11.03.100 
or higher). 

In the configuration dialog of the profile, go to System > Registry > devices > 
cherry_secureboard > enable and activate Secure keyboard input with Cherry SECURE 
BOARD (registry key: devices.cherry_secureboard.enable ). (From UMS 6.03.130 or 
higher, the parameter can be found under User Interface > Input > Keyboard)
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4.
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6.

7.
•
•
•
•

Click Ok to save and close the profile.
Make sure that the profile is selected in the UMS structure tree.

In the Assigned objects area, click  . 

Under Files, select the file objects using the   button:
User root CA certificate; here: userca-cert.pem
Client root CA certificate; here: clientca-cert.pem (optional)
Client certificate; here: client-cert.pem 
Client key; here: client-key.pem
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8.
9.

1.

2.

3.

4.
5.

Click Ok.
In the Update time dialog, select Now and click Ok.
The certificate and key files are assigned to the profile.

Assigning the Profile to the Endpoints

In the UMS structure tree, select the devices that are to be connected to the Cherry SECURE Board 
keyboards.

In the Assigned objects area, click  . 

Under Profiles, select the appropriate profile using the   button.

Click Ok.
In the Update time dialog, select Now and click Ok.
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The settings and certificate and key files are transferred to the endpoints. The endpoints are ready 
for connecting to the Cherry SECURE BOARD keyboards.

Operation
The endpoint verifies if the Cherry SECURE BOARD has the right certificates. When the optional client certificates 
have been installed, too, the Cherry SECURE BOARD verifies if the endpoint has the right certificates. When 
everything went well, the endpoint and the Cherry SECURE BOARD work in secure mode.

On the keyboard side, the secure mode is indicated by the red light next to the lock symbol. On the endpoint side, 
the secure mode is indicated by an icon on the system tray.
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1.
2.

Resetting the Cherry SECURE BOARD to Its Original State
To reset the Cherry SECURE BOARD to its factory settings:

Disconnect the keyboard from the endpoint.
Hold the keys [D], [J] and [RGUI] (right Windows key) and, at the same time, connect the keyboard 
to the endpoint.
When the reset has been successful, all LEDs flash for about 1 second. After that, the keyboard 
starts normally, and the certificate store is emptied. The keyboard can be personalized again.
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Webcam Redirection and Optimization

Overview
This article provides an overview and best-practice recommendations for the use of webcams on IGEL OS within 
remote sessions such as Citrix, VMware Horizon, and RDP.

In general, webcam support on IGEL OS can be divided into three categories:

Unoptimized The raw data from the webcam is sent over the network via USB 
redirection. The raw data from the webcam is highly affected by 
network latency between the client and the server and takes up 
a lot of bandwidth, requires the correct drivers on the server-
side, increases the server's CPU and RAM load.

Example: Native USB Redirection for RDP sessions

Optimization type 1 In this case, the video and audio data is compressed on the 
client side. This optimization type makes the webcam stream 
far more efficient and reliable, although the data stream must 
still pass via the VDI server in addition to the cloud servers of 
the particular communication software (Teams, Zoom, etc.).

Examples: HDX RealTime Webcam redirection for Citrix 
sessions, Real Time Audio Video (RTAV) for VMware Horizon 
sessions

Optimization type 2 In this case, the video and audio data is also compressed on the 
client side. However, unlike type 1, this optimization type 
offloads the data stream from the VDI server and sends it 
directly to Teams/Zoom/etc. in the cloud, i.e. "single-hop". This 
allows for the best performance and also removes the server 
load, but relies on the correct optimization pack being present 
on the client and is specific to each communication suite. It may 
also require a more complex network configuration because the 
endpoint has to be able to communicate directly with the 
communication cloud server and not only the VDI server.

Examples: Microsoft Teams optimization and Zoom Media 
plugin for Citrix sessions

In the case of optimization type 1 or type 2, it is important to ensure that the agent/component on the 
server side is installed and is compatible with the client-side version. For details on the latter, see the 
"Component Versions" section of the IGEL OS release notes.


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General Recommendations
For optimal performance of webcams on IGEL OS, the correct optimization pack has to be enabled for the specific 
application, e.g. Microsoft Teams optimization, Zoom Media plugin, Cisco Webex Teams VDI, etc. However, 
optimization packs are not available for all session types.

•
•

USB Redirection

If no optimization pack exists for your session type or the optimization pack available does not function 
correctly, you can try to use USB redirection – either the Native USB Redirection or the less frequently 
used Fabulatech USB Redirection (not both together), – but ONLY as a LAST RESORT, when no other 
solution is possible.
In general, where USB redirection is available as an option inside the VDI session options, it should be 
disabled for the webcam devices.

Set Default rule to Deny
OR, if the Default rule is Allow (NOT recommended), go to Device Rules and add 
Deny rules for the specific Vendor ID and Product ID of the webcam.
How to Find Out Vendor and Product IDs
To get Vendor/Product IDs, use the command lsusb  in the terminal. You can also use the 
System Information tool, see Using “System Information” Function.

This is necessary because USB redirection will block the webcam from being correctly optimized (if 
optimization is possible).



Do not forget to check and adjust settings and policies on the server side. Otherwise, your webcam may 
not work, even if all settings in the IGEL OS are configured correctly.



Always check the IGEL OS release notes for specific remarks, especially in the case of private builds. Always 
try to use the latest firmware, see IGEL download server63.



In certain cases, some of the settings described later on in this article may not be visible even though you 
have selected the correct firmware version for the profile in the UMS. In this case, update the UMS to the 
latest version.



https://www.igel.com/software-downloads/workspace-edition/
https://www.igel.com/software-downloads/workspace-edition/
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•
•

•

•

•
•

Citrix

Option 1: Unified Communications (Best Choice)

Microsoft Teams Optimization Path: Sessions > Citrix > Citrix Global > Unified 
Communications > VDI Solutions > Microsoft Teams 
optimization (see page 879) (enabled by default)

Available as of IGEL OS version 11.04.100.
Depends on the version of Citrix Workspace App used. 
For best results, the latest version should be preferred. 
For the Citrix Workspace App versions included, 
see IGEL OS release notes.

For server-side requirements for Microsoft 
Teams optimization, see Microsoft Teams installation64.

To troubleshoot Microsoft Teams optimization in Citrix, 
see:

Troubleshooting HDX Optimization for Microsoft 
Teams65

Peripherals in Microsoft Teams66

Zoom Media Plugin Path: Sessions > Citrix > Citrix Global > Unified 
Communications > VDI Solutions > Zoom Media 
Plugin (see page 879)

Available as of IGEL OS version 11.04.100
For the Zoom Media Plugin versions included, see IGEL 
OS release notes.

For more information about Zoom Media Plugin, 
including server-side requirements, see Getting started 
with VDI67.

https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/multimedia/opt-ms-teams.html#microsoft-teams-installation
https://support.citrix.com/article/CTX253754
https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/multimedia/opt-ms-teams.html#peripherals-in-microsoft-teams
https://support.zoom.us/hc/en-us/articles/360031096531-Getting-Started-with-VDI
https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/multimedia/opt-ms-teams.html#microsoft-teams-installation
https://support.citrix.com/article/CTX253754
https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/multimedia/opt-ms-teams.html#peripherals-in-microsoft-teams
https://support.zoom.us/hc/en-us/articles/360031096531-Getting-Started-with-VDI
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•
•

•
•

•

•

•

Cisco Webex Meetings / Teams VDI Path: Sessions > Citrix > Citrix Global > Unified 
Communications > Cisco > Cisco Webex Meetings VDI
or Cisco Webex Teams VDI

Available as of IGEL OS version 11.04.100
For the Cisco Webex Meetings / Teams VDI versions 
included, see IGEL OS release notes.

For more information about Cisco Webex products for 
VDI, including supported environments, see:

Cisco Webex Meetings Virtual Desktop Software68

Overview of Webex Teams for VDI69

Cisco JVDI Client Path: Sessions > Citrix > Citrix Global > Unified 
Communications > Cisco >  Cisco JVDI client

For the Cisco JVDI client versions included, see IGEL OS 
release notes.

For more information about Cisco JVDI client, see 
Deployment and Installation Guide for Cisco Jabber 
Softphone for VDI70.

Skype for Business Path: Sessions > Citrix > Citrix Global > Unified 
Communications > Skype for Business > HDX 
RealTime Media Engine (enabled by default)

Skype for Business webcam redirection relies on the Citrix 
HDX Realtime Media Engine (client-side counterpart to 
the Lync Optimization Pack).
This setting is the same as Sessions > Citrix > Citrix 
Global > HDX Multimedia > HDX RealTime Media 
Engine.

IMPORTANT: Skype for Business Online will be 
retired by Microsoft on July 31, 202171. After this, 
it will no longer be available, and Microsoft 
Teams must be used instead.



https://help.webex.com/en-us/nfjsqzbb/Cisco-Webex-Meetings-Virtual-Desktop-Software
https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cloudCollaboration/wbxt/vdi/wbx-teams-vdi-deployment-guide/wbx-teams-vdi-deployment-wbx-calling-EFT_chapter_00.html
https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/jvdi/12_9/dig/jvdi_b_deploy-install-jvdi-12-9/jvdi_b_deploy-install-jvdi-12-9_chapter_01.html
https://techcommunity.microsoft.com/t5/microsoft-teams-blog/skype-for-business-online-to-be-retired-in-2021/ba-p/777833
https://help.webex.com/en-us/nfjsqzbb/Cisco-Webex-Meetings-Virtual-Desktop-Software
https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cloudCollaboration/wbxt/vdi/wbx-teams-vdi-deployment-guide/wbx-teams-vdi-deployment-wbx-calling-EFT_chapter_00.html
https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/jvdi/12_9/dig/jvdi_b_deploy-install-jvdi-12-9/jvdi_b_deploy-install-jvdi-12-9_chapter_01.html
https://techcommunity.microsoft.com/t5/microsoft-teams-blog/skype-for-business-online-to-be-retired-in-2021/ba-p/777833
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•

1.

2.

3.
4.

5.

•

Option 2: HDX RealTime Webcam Redirection (Should Only Be Used If Optimization Packs under 
Option 1 Are Not Applicable)
For other VDI programs which require the use of a webcam (e.g. the browser), HDX RealTime Webcam 
redirection can be used. This option enables the compression of audio and video on the client side, which is 
redirected to an HDX virtual webcam on the server side. It also allows for the resolution of the webcam to be 
defined manually.

Settings on the Server Side Settings on the Client Side

The following policy settings must be enabled:

Multimedia conferencing (enabled by default)
Windows Media Redirection (enabled by 
default)

For details, see https://docs.citrix.com/en-us/
citrix-virtual-apps-desktops/multimedia/
webcam-compression.html.

Go to Sessions > Citrix > Citrix Global > HDX 
Multimedia.
Enable Multimedia redirection (enabled by 
default).
Enable HDX RealTime Webcam redirection.
Configure the webcam resolution, 352 x 288 by 
default, and other settings if required.

If the USB redirection is enabled (not 
recommended), use Device Rules to forbid the 
forwarding of the webcam via USB redirection. 
See the section above (see page 880).

Dependencies

HDX RealTime Webcam Redirection is only supported for 32-bit applications on the server side 
(limitation of Citrix Receiver/Workspace App for Linux). Deploy a 32-bit browser to verify the 
webcam redirection online, e.g. www.webcamtests.com73. See also https://support.citrix.com/
article/CTX223199.

•

•

Only One Option at a Time for a Particular Device

HDX RealTime Webcam redirection and HDX RealTime Media Engine should not be 
enabled at the same time.
If you use HDX or an application-specific optimization pack (e.g. Zoom Media 
plugin), Native USB Redirection / Fabulatech USB Redirection should be disabled.



Certain webcam models may only 
support specific resolutions. For more 
information, see How to Configure 
Webcam settings When Webcams are 
Not Redirected Through HDX Real-
Time72.



https://support.citrix.com/article/CTX134772
http://www.webcamtests.com
https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/multimedia/webcam-compression.html
http://www.webcamtests.com
https://support.citrix.com/article/CTX223199
https://support.citrix.com/article/CTX134772
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•
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•
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•
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•
•

•
•

Webcam redirection generally works with or without HDX RealTime Media Engine (RTME). 
However, to avoid conflicts and for the better performance of webcam redirection, disabling RTME
(enabled by default) is highly recommended.
Webcam usage is limited to one application. For instance, when Skype is running with a webcam 
and GoToMeeting is started, you have to exit Skype to use the webcam with GoToMeeting.

Supported Video Conferencing Applications

Adobe Connect
Cisco Webex and Webex for Teams (Give preference to the optimization pack for Cisco Webex 
Meetings / Teams VDI instead, see above (see page 881))
GoToMeeting
Google Hangouts and Hangouts Meet
IBM Sametime
Microsoft Skype for Business 2015, 2016, and 2019 (Give preference to the optimization pack 
for Skype for Business instead, see above (see page 881))
Microsoft Lync 2010 and 2013
Microsoft Skype 7 or higher
Media Foundation-based video applications on Windows 8.x or higher and Windows Server 2012 
R2 and higher

For more detailed information about HDX RealTime Webcam, see:

https://support.citrix.com/article/CTX132764
https://docs.citrix.com/en-us/citrix-workspace-app-for-linux/configure-xenapp.html#webcams

HDX RealTime Webcam Redirection is NOT supported for Microsoft Teams. Use Microsoft Teams 
optimization instead, see above (see page 881).



Does Webcam Audio Work but Video Doesn't?

 Try to increase the graphics memory in the BIOS to 512 MB.



https://support.citrix.com/article/CTX132764
https://docs.citrix.com/en-us/citrix-workspace-app-for-linux/configure-xenapp.html#webcams
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•
•

•
•

•

VMware Horizon

Option 1 (Best Choice)

Zoom Media Plugin Path: System > Registry > vmware > view > vdzoom > 
enable

Available as of IGEL OS version 11.04.200
For the Zoom Media Plugin versions included, see IGEL OS 
release notes.

For more information about Zoom Media Plugin, 
including server-side requirements, see Getting started 
with VDI74.

Cisco Webex Teams VDI Path: Sessions > Horizon Client > Horizon Client Global 
> Unified Communications > Cisco > Cisco Webex 
Teams VDI

Available as of IGEL OS version 11.04.100
For the Cisco Webex Teams VDI versions included, see IGEL 
OS release notes.

For more information, see Overview of Webex Teams for 
VDI75.

Cisco JVDI Client Path: Sessions > Horizon Client > Horizon Client 
Global> Unified Communications > Cisco >  Cisco JVDI 
client

For the Cisco JVDI client versions included, see IGEL OS 
release notes.

For more information about Cisco JVDI client, see 
Deployment and Installation Guide for Cisco Jabber 
Softphone for VDI76.

Zoom Media Plugin will NOT function if you 
enable HTML5 multimedia redirection (System 
> Registry > vmware > view > html5mmr, 
disabled by default). 



https://support.zoom.us/hc/en-us/articles/360031096531-Getting-Started-with-VDI
https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cloudCollaboration/wbxt/vdi/wbx-teams-vdi-deployment-guide/wbx-teams-vdi-deployment-wbx-calling-EFT_chapter_00.html
https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/jvdi/12_9/dig/jvdi_b_deploy-install-jvdi-12-9/jvdi_b_deploy-install-jvdi-12-9_chapter_01.html
https://support.zoom.us/hc/en-us/articles/360031096531-Getting-Started-with-VDI
https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cloudCollaboration/wbxt/vdi/wbx-teams-vdi-deployment-guide/wbx-teams-vdi-deployment-wbx-calling-EFT_chapter_00.html
https://www.cisco.com/c/en/us/td/docs/voice_ip_comm/jvdi/12_9/dig/jvdi_b_deploy-install-jvdi-12-9/jvdi_b_deploy-install-jvdi-12-9_chapter_01.html
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79 https://docs.vmware.com/en/VMware-Horizon-7/7.6/horizon-remote-desktop-features/GUID-D6FD6AD1-D326-4387-A6F0-152C7D844AA0.html
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Skype for Business Path: Sessions > Horizon Client > Horizon Client Global 
> Unified Communications > Skype for Business > 
Virtualization Pack Skype for Business (enabled by 
default)

Option 2: Real-Time Audio-Video (RTAV)
Real-time Audio-Video (RTAV) is the optimization pack for audio and video calls inside VMware Horizon sessions. 
RTAV compresses audio and video on the client side and sends it to the Horizon server, where a VMware Virtual 
Webcam instance is created. 

 Enable Sessions > Horizon Client > Horizon Client Global > Multimedia > Real Time Audio Video (RTAV).

For more information about RTAV, see Configuring Real-Time Audio-Video79.

IMPORTANT: Skype for Business Online will be 
retired by Microsoft on July 31, 202177. After this, it 
will no longer be available, and Microsoft Teams 
must be used instead.



Like for Citrix sessions, USB redirection should be disabled if RTAV is to be used.

RTAV is only available when connecting via PCoIP or VMware Blast.

Note that only one webcam will be redirected (limitation of Horizon client for Linux). If multiple webcams 
are available on the client, the preferred webcam can be defined in the IGEL Setup under System > 
Registry > vmware.view.rtav-webcam-id. For details, see Select a Preferred Webcam or Microphone on 
a Linux Client System78.



Microsoft Teams

Microsoft Teams can be used with RTAV in "Fallback Mode". This configuration is not an optimal solution 
as the data makes multiple hops between the Horizon client, server, and Microsoft Teams server. For more 
information, see Configuring Microsoft Teams with Real-Time Audio-Video80.
Microsoft Teams media optimization (single-hop or "Optimized Mode") in Horizon sessions is currently 
only supported with the Horizon client for Windows 10 in conjunction with Horizon 8 (2006). For more 
information, see Microsoft Teams Optimization with VMware Horizon81.



https://techcommunity.microsoft.com/t5/microsoft-teams-blog/skype-for-business-online-to-be-retired-in-2021/ba-p/777833
https://docs.vmware.com/en/VMware-Horizon-7/7.9/horizon-remote-desktop-features/GUID-C8C17975-AA1E-4378-A305-00E02FF93201.html
https://docs.vmware.com/en/VMware-Horizon-7/7.6/horizon-remote-desktop-features/GUID-D6FD6AD1-D326-4387-A6F0-152C7D844AA0.html
https://docs.vmware.com/en/VMware-Horizon/2006/horizon-remote-desktop-features/GUID-E64B3E85-BA1E-4FB7-9DB4-FF9B7B7A892C.html
https://techzone.vmware.com/resource/microsoft-teams-optimization-vmware-horizon
https://docs.vmware.com/en/VMware-Horizon-7/7.6/horizon-remote-desktop-features/GUID-D6FD6AD1-D326-4387-A6F0-152C7D844AA0.html
https://techcommunity.microsoft.com/t5/microsoft-teams-blog/skype-for-business-online-to-be-retired-in-2021/ba-p/777833
https://docs.vmware.com/en/VMware-Horizon-7/7.9/horizon-remote-desktop-features/GUID-C8C17975-AA1E-4378-A305-00E02FF93201.html
https://docs.vmware.com/en/VMware-Horizon/2006/horizon-remote-desktop-features/GUID-E64B3E85-BA1E-4FB7-9DB4-FF9B7B7A892C.html
https://techzone.vmware.com/resource/microsoft-teams-optimization-vmware-horizon
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RDP
There is currently no optimization available for webcam redirection in RDP sessions. It may be possible to redirect 
webcams via USB redirection, e.g. Native USB Redirection. However, each webcam has to be individually tested 
for if it functions with this method. It often depends on the webcam itself and its Windows driver whether they can 
cope with the higher latencies that occur with USB redirections compared to the real USB bus.

Native USB Redirection

Enable Sessions > RDP > RDP Global > Native USB Redirection > Enable native USB redirection.
Set the Default rule to Deny.
Under Device Rules, add the specific Vendor ID and Product ID of the device to be redirected.

In some situations, webcams may not be redirected correctly due to network latency, bandwidth 
limitations, or the lack of compatible drivers on the server.



•

•

Unoptimized Webcam Support

Note that because USB redirection is not designed for redirecting video devices, the 
bandwidth usage and server CPU load may increase significantly. 
For this reason, it is recommended to use webcams that output directly H.264 or H.265 
streams, and not MJPEG, in order to reduce the data volume.



Getting USB Device Information

To find out the Class ID, Subclass ID, Vendor ID and Product ID of the connected USB device, you 
can use the System Information tool. For further information, see Using “System Information” 
Function.
System Information example:


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Alternatively, you can use the command lsusb  (or lsusb | grep -i [search term] ) 
in the terminal.
Example for lsusb :

On RDS servers, the following may be helpful:
 Disable the setting Do not allow supported Plug and Play device redirection under Computer 

Configuration > Administrative Templates > Windows Components > Remote Desktop Services > 
Remote Desktop Session Host > Device and Resource Redirection.



For Microphone (e.g. Headset)

 Enable Sessions > RDP > RDP Global > Mapping > Audio > Audio recording.


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For how to open up the webcam in Windows 10, see Open the Camera in Windows 1082.

For a video overview on using webcams and other USB devices in remote sessions, see:
English

German

•

•

Custom Partition as a Local Alternative

You can also use Custom Partitions (see page 689) for Microsoft Teams or Zoom, e.g. in order to save backend 
resources, which may be a good choice in slow RDP backends. The Custom Partition is locally installed but 
is easy to access in the remote session.

For details, see Microsoft Teams as a Custom Partition (see page 751), Zoom as a Custom 
Partition (see page 731).
Contact the IGEL Support Team to get support for the deployment of Custom Partitions.



Sorry, the widget is not supported in this export.
But you can reach it using the following URL:

https://www.youtube.com/watch?v=PYCU1AEfS-g&feature=youtu.be

Sorry, the widget is not supported in this export.
But you can reach it using the following URL:

https://www.youtube.com/watch?v=caNhFib5cuA&feature=youtu.be

https://support.microsoft.com/en-us/windows/open-the-camera-in-windows-10-8da044ed-c4a8-2fb4-da51-232362e4126d#:~:text=To%20open%20up%20your%20webcam,Let%20apps%20use%20my%20camera.
https://support.microsoft.com/en-us/windows/open-the-camera-in-windows-10-8da044ed-c4a8-2fb4-da51-232362e4126d#:~:text=To%20open%20up%20your%20webcam,Let%20apps%20use%20my%20camera.
https://www.youtube.com/watch?v=PYCU1AEfS-g&feature=youtu.be
https://www.youtube.com/watch?v=caNhFib5cuA&feature=youtu.be
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•
•
•

2.
3.

Webcam Information
If you are running a device with IGEL Linux version 5.3.100 or higher, you can configure and test a webcam using a 
built-in tool. This tool is called Webcam Information.

 To configure a starter for Webcam Information, open the IGEL Setup and go to Accessories > Webcam 
Information.

To determine and change the width, height, and frame rate of your webcam:

Start the Webcam Information tool.
The following values are shown:

Width: Width of the image in pixels
Height: Height of the image in pixels
Rate: Frame rate in fps (frames per second). Example: 1/30 means 30 single images per 
second.

Click on on one of the fields to change the value. In doing so, the supported values are shown.
Click Test.

The video image generated with the current settings is shown.
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To check if the webcam is working in a session (e.g. via Citrix HDX webcam redirection), open a 
browser in the session and go to https://www.onlinemictest.com/webcam-test/.

https://www.onlinemictest.com/webcam-test/
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•
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1.
•
•
•

2.

Bluetooth Tool
As of IGEL Linux version 5.10.100, you can connect or disconnect Bluetooth devices conveniently using the 
Bluetooth tool. The Bluetooth tool supports the following pairing methods:

Pairing with PIN entry (for most keyboards)
Pairing with fixed PIN (for most headsets, mice or GPS devices)
Pairing with automatic PIN allocation
For further information, please refer to the manual chapter Bluetooth Tool.

In the following example, we will connect a Bluetooth device with PIN entry:

Make sure that the following preconditions are met:
A Bluetooth USB adapter is connected to your device.
The Bluetooth device is ready.
The options Setup > Devices > Activate Bluetooth and Setup > Devices > Tray Icon are 
enabled.

Launch the Bluetooth Tool from the IGEL menu   via System > Bluetooth Tool or another 
launch option, if available.
The Device search dialog will be shown. After a few seconds, the Bluetooth devices found by the 
device are displayed.
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3. Highlight the desired Bluetooth device and click on Forward.

A PIN will be shown on the Device setup dialog.
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4. Enter the PIN into your Bluetooth device.
If everything went well, the status of the connection will be shown.
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5. Click on Close.

Your Bluetooth device is ready for use. By right-clicking the  icon in the system tray, you can 
start the Bluetooth tool again, e.g. to pair another Bluetooth device or to unpair a device.
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1.
2.
3.

1.
2.

1.

2.

3.

How to Deploy a Jabra Xpress Package
Jabra Xpress is a solution for the remote mass-deployment of Jabra USB headsets that enables creating and 
deploying packages containing settings, firmware updates, etc. for Jabra devices. For more information, see 
https://www.jabra.com/supportpages/jabra-xpress#/. 

Deployment of a Jabra Xpress package involves the following steps:

Making the package available for download over the FTP(S) or HTTP(S) protocol (see page 896)
Configuring the source URL in the IGEL Setup (see page 896)
Triggering the deployment process in the UMS (see page 897)

Making the Jabra Xpress Package Available for Download
Create a package on the Jabra Xpress portal and download it.
Place the ZIP archive onto your FTP(S) or HTTP(S) server.
If you want to use the UMS as a source location, register the ZIP archive in the UMS under Files 
> New file. For details, see Registering a File on the UMS Server. 

Configuring the Source URL
Now you have to configure the download location:

In the IGEL Setup or in the configuration dialog in the UMS, go to Devices > Unified 
Communications > Jabra > Jabra Xpress.
Under Device Dashboard URL, you can optionally specify the URL of the dashboard server of the 
Jabra device.
Under Package, enter the file name of the Jabra Xpress package. 
Example:  xpress_package_20190109_144111.zip .

https://www.jabra.com/supportpages/jabra-xpress#/
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4.

5.

6.

7.

8.

Under Source URL, specify the URL to the directory containing the Xpress package. 
Example:  https://172.30.92.5:8443/ums_filetransfer/  if you use the UMS as the 
source location.
Disable Check SSL certificate if you use the UMS as the source for your Xpress package or a self-
signed certificate.
Under User name, specify the user name for accessing the Xpress package that resides under the 
Source URL.
Under Password, specify the password for accessing the Xpress package that resides under the 
Source URL.

Save the settings.

Triggering the Deployment Process
Finally, you have to trigger the deployment process. There are two possibilities:

 In the UMS, go to Devices > [context menu of the device] > Specific Device Command and select Deploy Jabra 
Xpress Package.
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OR

 In the UMS, go to Jobs > New Scheduled Job and select Deploy Jabra Xpress package as Command. Assign 
the job to the necessary devices, see Assignment.

Note that it is not possible to reverse the deployment process, e.g. to remove an Xpress package from the 
Jabra device. If you require the previous settings, you have to configure and deploy a new Jabra Xpress 
package with the old headset firmware and configuration. 


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See also Jabra Xpress in the IGEL OS reference manual.
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•

2.
3.
4.

Connecting Signature Pads
You can connect signature pads from the following manufacturers:

StepOver;
signotec.

 To enable them, go to Setup > User Interface > Input > Signature Pad.

 To configure a serial connection in order to be able to use USB signature pads from these manufacturers, 
proceed as follows:

Enable COM port mapping under:
Setup > Sessions > Citrix > Citrix Global > Mapping > COM Ports for Citrix sessions;
Setup > Sessions > RDP > RDP Global > Mapping > COM Ports for RDP sessions.

Click on Add .
Click Detect Devices... .
Select your device.
Your signature pad can now be used.
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1.
2.
3.

Using a Kofax / Wacom Signature Pad
You can use a Kofax / Wacom signature pad in Citrix sessions using the Kofax SPVC signature pad channel. The 
Virtual Serial Sign Pad method is no longer supported.

On the Device
Connect the signature pad to one of the device's USB ports.
Go to Sessions > Citrix > Citrix Global > Mapping > Device Support.
Enable Kofax SPVC signature pad channel.

On the VDI Server (Windows)

 Install the required software from Kofax / Wacom. 
The driver contained in this software will listen for signature pads on a virtual channel. Applications such as 
SignDoc will be able to use the signature pad.
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Using a StepOver Signature Pad
You can use a StepOver signature pad in Citrix and RDP sessions. There are two different means to achieve this:

With StepOver TCP Client (see page 903)
With StepOver Signature Pad Channel (see page 907)

Only one of the methods can be used at a given time. Which of the two you need is determined by your applications 
on the server side.

See also StepOver Signature Pads Compatibility.
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With StepOver TCP Client

On the Device

 Connect the signature pad to one of the device's USB ports.

 Go to User Interface > Input > Signature Pad in IGEL Setup.

 Enable StepOver TCP Client.

 Modify Listening TCP Port if needed. (Default: 8888)

On the VDI Server (Windows)

 Locate the sodc.exe  program on the server. It is the part of StepOver eSignature Office and can be found in 
[Your Program Files Directory]\StepOver\eSignatureOffice [version]\driver\ .

 If you are using a non-standard  TCP port, change it in the config.ini  file located in the same directory.

You can check whether the StepOver TCP Client is running on the device by entering the following in a 
local terminal: ps waux | grep sotcp . The result should contain an sotcp process.





Devices

IGEL OS Articles   904 / 1017

 Execute sodc.exe . The StepOver Pad Test window will open. Use its buttons to search and select your 
signature pad and try writing into the provided field.
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The status LED of the pad will turn to green when the connection is successful. The signature pad is now ready to be 
used with enabled applications such as StepOver eSignature Office.



Devices

IGEL OS Articles   907 / 1017

With StepOver Signature Pad Channel
StepOver signature pad channel is applicable to Citrix sessions only. It activates StepOver Citrix Client and 
enables the redirection via Citrix virtual channel.

On the Device

 In the IGEL Setup, go to Sessions > Citrix > Citrix Global > Mapping > Device Support.

 Enable StepOver signature pad channel and save the changes.

On the Server

 During the installation of the StepOver software, select the option "Citrix".
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eGK/KVK - Card Reader
The IGEL Linux thin clients support the reading of German electronic health cards (eGK), health insurance cards 
(KVK) and the German card for allied health professions (HBA) by a variety of readers connected via RDP or ICA. 
Configuration and functionality vary according to the reader type.

The following tested solutions are available:

Reader Port Client/server connection

Cherry G80-1502 Serial COM port mapping

Cherry ST-2052 USB Smartcard mapping

Cherry ST-1503 and Cherry G87-1504 USB Cherry Virtual Channel (IGEL 
Linux v5 only)

SICCT via LAN provided by the Cherry USB2LAN 
proxy (IGEL Linux version 5.12.100 and IGEL 
Linux version 10.03.100 onwards)

ORGA 910/920 M USB COM port mapping

ORGA 6041 L eGK eHealth-BCS USB COM port mapping

SCM Microsystems eHealth200 USB Smartcard mapping

SCM Microsystems eHealth500 USB COM port mapping

celectronic CARD STAR /medic2 Serial COM port mapping

celectronic CARD STAR /memo3 USB COM port mapping

Cherry G80-1502 at the Serial Port (see page 909)
Cherry ST-2052 (see page 910)
Cherry ST-1503 und G87-1504 (USB) (see page 911)
Orga 910/920 M (see page 912)
Orga 6041 L eGK eHealth-BC S (see page 913)
celectronic CARD STAR / medic2 (see page 914)
celectronic CARD STAR/ memo3 (see page 915)



Devices

IGEL OS Articles   909 / 1017

1.
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3.

1.

2.
3.

Cherry G80-1502 at the Serial Port

Connecting the keyboard

 Connect the keyboard to both the PS/2 port and the serial port of the thin client.

Functionality

Software: Cherry eHealth eGK/KVK software

Device/server connection: COM port mapping

Configuring the device
In IGEL Setup, add the COM port device to which the keyboard is connected:

Click Sessions > RDP > RDP Global > Mapping > COM Ports

Click .
Select a COM port device (COM1, COM2,... ).

Configuring the server

Install the eGK-KVK software by Cherry. 
See also http://www.cherry.de/files/manual/eHealth_Client-Server_Einbindung.pdf
Start the program CT-API configuration.
Select the appropriate port number for the G80-1502.

Firmware version 1.19 of the keyboard must be present and the keyboard must be in mode S1. Refer to 
http://www.cherry.de/files/manual/Cherry_G80-1502_mit_eGK.pdf.



http://www.cherry.de/files/manual/eHealth_Client-Server_Einbindung.pdf
http://www.cherry.de/files/manual/Cherry_G80-1502_mit_eGK.pdf
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Cherry ST-2052
Functionality

USB ID: 046a:003e

Software: Cherry eHealth eGK/KVK software

Device/server connection: Smartcard (PC/SC) mapping

Configuring the device

 Select Activate PC/SC Daemon in Setup under Security > Smartcard > Services:

Configuring the server

Install the eGK-KVK software by Cherry.
See also http://www.cherry.de/files/manual/eHealth_Client-Server_Einbindung.pdf
Start the program CT-API configuration.
Select port number 1 for the ST-2052.

http://www.cherry.de/files/manual/eHealth_Client-Server_Einbindung.pdf
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Cherry ST-1503 und G87-1504 (USB)
Functionality

USB ID: 046a:0080 for ST-1503

046a:0081 for G87-1504

Software: Cherry eHealth eGK/KVK software

Client/server connection: SICCT via LAN provided by the Cherry USB2LAN proxy

Cherry USB2LAN proxy: Makes Cherry electronic health card devices available in the network via SICCT. The 
communication between card reader and server takes place independently of the VDI connections.

Configuring the Thin Client for Using the Cherry USB2LAN Proxy

Activate Security > Smartcard > Services > Cherry USB2LAN Proxy:

Configuring the Server for the Cherry USB2LAN Proxy

Install the eGK-KVK software by Cherry.
Configuration according to chapter 6 in http://www.cherry.de/files/manual/eHealth_Client-
Server_Einbindung.pdf.

http://www.cherry.de/files/manual/eHealth_Client-Server_Einbindung.pdf
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3.

4.

1.

2.

Orga 910/920 M
Functionality

USB ID: 0780:1202

Software: CT-API by Orga

Device/server connection: COM port mapping

Configuring the device

Click Sessions > RDP > RDP Global > Mapping > COM Ports for RDP
Select Enable Com Port Mapping:
Click .

Select USB COM 1 as a new COM port device ( /dev/ttyUSB0 ).

Configuring the server

Download the appropriate driver for Orga 910/920 M from the download page:
http://healthcare-eid.ingenico.com/de/treiber_anleitungen.aspx83

Install the driver.

https://ingenico.de/healthcare/downloads
https://ingenico.de/healthcare/downloads
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2.

Orga 6041 L eGK eHealth-BC S
Functionality

USB ID: 0780:1302

Software: CT-API by Orga

Device/server connection: COM port mapping

Configuring the device

Click Sessions > RDP > RDP Global > Mapping > COM Ports for RDP.
Select Enable Com Port Mapping:
Click .

Select USB COM 1 as a new COM port device ( /dev/ttyUSB0 ).

Configuring the server

Download the appropriate driver for Orga 6041 L eGK eHealth-BC S from the download page:
http://healthcare-eid.ingenico.com/de/treiber_anleitungen.aspx84

Install the driver.

https://ingenico.de/healthcare/downloads
https://ingenico.de/healthcare/downloads
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celectronic CARD STAR / medic2

Connecting the reader

 Connect the reader to the COM port of the thin client.

Functionality

Software: CT-API by celectronic

Device/server connection: COM port mapping

Configuring the device
In IGEL Setup, add the COM port device to which the keyboard is connected:

Click Sessions > RDP > RDP Global > Mapping > COM Ports for RDP.

Click .
Select a COM port device (COM1, COM2,... ).

Configuring the server

Download the appropriate driver for celectronic CARD STAR /medic2 from the download page:
https://www.ccv.eu/de/
Install the driver.

The reader must be set to host/PC serial interface.

https://www.ccv.eu/de/
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celectronic CARD STAR/ memo3
Functionality

USB ID: 152a:8180

Software: CT-API by celectronic

Device/server connection: COM port mapping

Configuring the device

Click Sessions > RDP > RDP Global > Mapping > COM Ports for RDP.
Select Enable Com Port Mapping:
Click .

Select USB COM 1 as a new COM port device ( /dev/ttyUSB0 ).

Configuring the server

Download the appropriate driver for celectronic CARD STAR memo3 from the download page:
https://www.ccv.eu/85

Install the driver.

https://www.ccv.eu/de/
https://www.ccv.eu/de/
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Using Mobile Device Access
You can access your mobile device file structure via USB, e.g. to make it available in a session.

The following device types can be used:

Smartphones with Android (via MTP / PTP) or iOS
Tablets with Android via MTP / PTP) or iOS
Digital cameras

Environment
IGEL Universal Desktop (UD) with IGEL OS10.04.100 or higher

IGEL Universal Desktop Converter 3 (UDC3) with IGEL Linux 10.04.100 or higher
UD Pocket with IGEL Linux 10.04.100 or higher
To configure the feature via UMS, UMS version 5.08.110 is required.

_________

Enabling Mobile Device Access (see page 917)
Disabling Mobile Device Access (see page 918)
Mapping a Mobile Device for a Session (see page 919)
Connecting Your Mobile Device (see page 920)
Accessing the Mobile Device USB Window from a Session (see page 921)
Viewing the Files and Directories Locally (see page 922)
Safely Removing the Mobile Device (see page 924)

Feature with limited support! The mobile device access feature comes with “limited support”. This 
feature is offered 'as is' without any warranty. Any support for this feature is provided on a non-binding, 
“best effort” basis.



The functionality may differ according to the specific device and operating system version.

IZ devices are not supported!
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7.
8.

Enabling Mobile Device Access
Ensure that the settings under System > Update > Firmware Update are correct. The Server Path
must point to the firmware version that is currently installed. This is required because the software 
package for mobile device access must be downloaded in order to deploy the feature.
Go to System > Firmware Customization > Features and activate Mobile Device Access USB.
Confirm the warning dialog with Ok.
Click Ok in the main window.
Reboot the device.
On reboot, the device downloads and installs the software package for the mobile device access 
feature.
If mobile device access should be available permanently, make sure that Autostart is activated 
under Accessories > Mobile Device Access. The other start options are described in the manual 
under Mobile Device Access.

Configure the start options for mobile device access according to your requirements.
If you have activated Autostart as the only start option, restart the device.

When the mobile device access is activated, the smartphone symbol  is shown in the task bar. 
For appliance mode sessions, the in-session control bar is available; see Accessing the Mobile 
Device USB Window from a Session (see page 921).

If you want to use mobile device access in appliance mode, you must enable autostart or 
configure a hotkey. Autostart is recommended.


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Disabling Mobile Device Access

Disabling Mobile Device Access

 In the context menu of the tray icon, click Quit.
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Mapping a Mobile Device for a Session
There are two alternative options to map a mobile device to a drive in a session:

Automatic Drive Mapping
Manual Mapping to a Specific Drive

Automatic Drive Mapping
You can use dynamic client drive mapping to have a drive automatically mapped to your mobile device. The 
directories and files on your mobile device will be accessible under this drive.

In the IGEL Setup, go to Devices > Storage Devices > Storage Hotplug and enable Storage 
hotplug.
Set Client drive mapping to "Dynamic".
Click OK.

You can access the directories and files on your mobile device like with a regular hotplug storage device.

For further information, see the manual chapter Storage Hotplug.

Manual Mapping to a Specific Drive
You can specifiy a drive letter under which the directories and files on your mobile device will be accessible.

If the session will run in fullscreen mode, open the IGEL Setup, go to User Interface > Desktop and 
activate In-Session Control Bar.
If the session will run in fullscreen mode or appliance mode, ensure that Autostart under 
Accessories > Mobile Device Access is enabled. See here also Enabling Mobile Device Access (see 
page 917).
Go to the Drive Mapping page for your session type. Example: With RDP sessions, the setup path is 
Sessions > RDP > RDP Global > Mapping > Drive Mapping.
Activate Enable drive mapping.
Click  Add to bring up the mapping window.
Click Enabled to enable the drive connection.
Select a Drive to map from the list under which the local device or the folder is to be mapped.
Enter /media  as the Local Drive Path.
Click OK.

You can access the directories and files on your mobile device like with a regular hotplug storage device.
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Connecting Your Mobile Device
If mobile device access is not started already, use one of the start options configured under 
Accessories > Mobile Devices Access.
Connect your mobile device with your thin client.
Allow file transfer on your phone, e. g. Transfer Files (Android smartphones) or Trust The 
Computer (Apple iPhone).
The directories of your mobile device are mounted. 
You can view the contents; see Viewing the Files and Directories Locally (see page 922). 
You can remove the mobile device securely; see Safely Removing the Mobile Device (see page 924).
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Accessing the Mobile Device USB Window from a Session

Non-Fullscreen Session

 Click  to open the Mobile Device Access USB window.
The Mobile Device Access USB window appears. 
You can view the directories and files on your mobile device or safely remove the device; see Safely Removing the 
Mobile Device (see page 924).

Fullscreen Session
In a session that is running in fullscreen mode or appliance in a fullscreen session, you can use the in-session 
control bar to open the Mobile Device Access USB window.

Move the mouse pointer to the upper edge of the screen.
The in-session control bar appears.

Click the smartphone symbol.
The Mobile Device Access USB window appears. 
You can view the directories and files on your mobile device or safely remove the device.

Appliance Mode Session
In a session that is running in appliance mode, you can use the in-session control bar to open the Mobile Device 
Access USB window.

Move the mouse pointer to the upper edge of the screen.
The in-session control bar appears.

Click the smartphone symbol.
The Mobile Device Access USB window appears. 
You can view the directories and files on your mobile device or safely remove the device.
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Viewing the Files and Directories Locally
 Select View in the context menu.

The directories on your smartphone are displayed. Access is read-only, i. e. you can only view the directories and 
files.
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Safely Removing the Mobile Device
 Click Eject in the context menu for the device in question.
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Swapping Function of Mouse Buttons (e.g. When Using an Evoluent 
Mouse)
The assignment of mouse buttons for Evoluent Mouse 3 changed between firmware versions 5.04.130 and 5.05.100.

Problem
Users have become used to the assignment as it was up to 5.04.130, so you want to reproduce the same assignment 
in 5.05.100.0.

Solution
A. To manually analyze the assignment and determine how it needs to be adjusted:

Open a local terminal.
Find the mouse ID: xinput list

The output should look something like this: |  Virtual core pointerid=2[master 

pointer (3)]  |- Virtual core XTEST pointer id=4[slave pointer (2)]  

|- Logitech USB Optical Mouse id=10[slave pointer (2)]  - Virtual 

core keyboardid=3[master keyboard (2)]  - Virtual core XTEST keyboard 

id=5[slave keyboard (3)]  - Power Buttonid=6[slave keyboard (3)]  - 

Video Busid=7[slave keyboard (3)]  - Power Buttonid=8[slave keyboard 

(3)]  - Sleep Buttonid=9[slave keyboard (3)]  - Logitech USB 

Keyboardid=11[slave keyboard (3)]  - Logitech USB Keyboardid=12[slave 

keyboard (3)]
Find your mouse and its ID in the output (here: Logitech USB Optical Mouse, id=10 ).
Check the number of buttons in the button map: xinput get-button-map [ID]  (where ID 
is the ID of your mouse device).
Now check which button number is set for the buttons in question: xev  
A test window will appear.
Click into the window using the buttons that you want to swap. Look for the button numbers in the 
terminal output: ButtonPress event, serial 39, synthetic NO, window 

0x3200001,  root 0xae, subw 0x0, time 25542794, (114,113), root:

(2884,634),  state 0x10, button 1, same_screen YES  ButtonRelease 

event, serial 39, synthetic NO, window 0x3200001,  root 0xae, subw 

0x0, time 25542898, (114,113), root:(2884,634),  state 0x110, button 

1, same_screen YES  ButtonPress event, serial 39, synthetic NO, 
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window 0x3200001,  root 0xae, subw 0x0, time 25543218, (114,113), 

root:(2884,634),  state 0x10, button 3, same_screen YES  

ButtonRelease event, serial 39, synthetic NO, window 0x3200001,  

root 0xae, subw 0x0, time 25543330, (114,113), root:(2884,634),  

state 0x410, button 3, same_screen YES  
In the above example the buttons number 1 and 3 were used.

B. To change the assigment of the mouse buttons on the local thin client:

Set a new button map for the mouse in Setup > System > Firmware Customization > Custom 
Commands > Desktop Commands > Final.
Swap the buttons in the map. To swap e.g. the buttons 1 and 3, change the setting from xinput 

set-button-map [ID] 1 2 3 4 5 6 7  to xinput set-button-map [ID] 3 2 1 

4 5 6 7

C. To automatically change the assignment using a UMS profile:

As the ID of the mouse may be different on each client, you cannot use the command as shown in B2 but need to 
use a script that will automatically map the correct input device.

Run the following command in a local terminal: xinput --list
Make a note of the complete name of the mouse.
Create a profile in Setup > System > Firmware Customization > Custom Commands > Desktop 
Commands > Final with a custom command: MouseID=$(xinput --list --id-only 

'NAME OF MOUSE')  xinput set-button-map $MouseID 3 2 1 4 5 6 7
Replace NAME OF MOUSE with the name of the mouse as determined in step C1.
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Using Natural Scrolling (reverse Scrolling Direction)

Issue
You are using a touchpad instead of a mouse and you want to reverse the scrolling direction to have natural 
scrolling – with the screen content moving synchronously to the fingers' movement on the touchpad.

Problem
There is no "reverse scrolling" parameter in IGEL Setup.

Solution
Open the device's configuration either locally or in the UMS.
Go to System > Firmware Customization > Custom Commands > Desktop > Final desktop 
command.
Enter the following command:
echo "pointer = 1 2 3 5 4 6 7 8 9 10 11 12" > ~/.Xmodmap && xmodmap 

~/.Xmodmap
Save the settings and restart your device.

This will reverse the scrolling direction of a mouse wheel as well. Swapping 4 and 5 will reverse 
vertical scrolling, swapping 6 and 7 will reverse horizontal scrolling as well (if supported).


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Connecting a Serial Barcode Scanner

Connecting Barcode Scanner via COM Port
Determine to which COM port of the device the barcode reader is physically connected.
Open the IGEL Setup, go to System > Registry > devices > serial > inputattach and enable the 
relevant key, according to the COM port in use:

COM1 ( /dev/ttyS0 ): devices.serial.inputattach.com0.enabled

COM2 ( /dev/ttyS1 ): devices.serial.inputattach.com1.enabled
COM3, COM4 ...:  Add a new instance by clicking devices.serial.inputattach.com% > Add 
Instance and define the port appropriately, e.g. /dev/ttyS2  for COM3.

If the device's baud differs from 9600 (default), enter the correct baud 
under devices.serial.inputattach.com0.baud.

In the Setup, click Apply or Ok to submit the new settings. To make absolutely sure that the new 
settings are effective, you can reboot the device.
Check if the barcode scanner is working.

Connecting Barcode Scanner via USB
If the barcode scanner is connected over USB, the challenge is to identify the device which is assigned to it. 
Depending on your specific device and environment, your mileage may vary. Start with the simple procedure (see 
page 928). If you are lucky, this will do it. If not, continue with the extended procedure (see page 929).

Simple Procedure

Connect the barcode to a USB port. This will trigger an event which will be logged and reported by 
dmesg.
Open a terminal on your endpoint device. For further information on the device's terminal, see 
Terminals.
To find the right device file, enter  dmesg | grep tty  in the terminal.

If you are lucky, the relevant device file is listed. Its name is either  ttyUSB<NUM>  or 

ttyACM<NUM> . Example: ttyUSB0
If the relevant device file is not listed, try the extended procedure (see page 929) below.
Open the IGEL Setup, go to System > Registry > devices > serial > inputattach.
Set the devices.serial.inputattach.com0.port to the device file you have found. Example: If the 
device file is ttyUSB0 , enter /dev/ttyUSB0   
Activate devices.serial.inputattach.com0.enabled.

With most barcode readers, you can change the baud by scanning a specific bar code.
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If the device's baud differs from 9600 (default), enter the correct baud under 
devices.serial.inputattach.com0.baud.

Click Apply or Ok to submit the new settings. To make absolutely sure that the new settings are 
effective, you can reboot the endpoint device.
Check if the barcode scanner is working.

Extended Procedure: Device File Was Not Found on the First Go
If the device file could not be found using the simple procedure, try loading the device driver manually. As the 
explicit loading of the driver must be executed with every system start, a custom command must be added.

In the terminal, enter the following commands, one after the other:
modprobe cdc-acm

dmesg | grep tty

The relevant device file is listed. Its name is either  ttyUSB<NUM>  or  ttyACM<NUM> . 

Example:  ttyACM0
Open the IGEL Setup, go to System > Registry > devices > serial > inputattach.
Set the devices.serial.inputattach.com0.port to the device file you have found. Example: If the 
device file is  ttyUSB0 , enter  /dev/ttyACM0
Activate devices.serial.inputattach.com0.enabled.
If the device's baud differs from 9600 (default), enter the correct rate 
under devices.serial.inputattach.com0.baud.

Go to System > Firmware Customization > Custom Commands > Base and under Initialization, 
enter  modprobe cdc-acm
Click Apply or Ok to submit the new settings. Reboot the device.
Check if the barcode scanner is working.

With most barcode readers, you can change the baud by scanning a specific bar code.

With most barcode readers, you can change the baud by scanning a specific barcode.
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Using DriveLock with IGEL Devices

Issue
DriveLock allows the system administrator to control access to removable devices within Citrix or RDP sessions. 
This is possible for USB devices; as of IGEL OS version 10.04.100, SATA devices are also supported.

Problem
How to integrate DriveLock solution with IGEL OS devices?

Solution
After configuring the Citrix or RDP server according to the original documentation, you have to activate the 
DriveLock virtual channel in the Setup. 
See the original DriveLock documentation.

Using DriveLock with RDP:

In Devices > Storage Devices > Storage Hotplug, change the settings as follows:
Deactivate Enable dynamic client drive mapping.
Set Number of storage hotplug devices to 1 or higher.
Activate Private drive letter for each storage drive.

In Sessions > RDP > RDP Global > Mapping > Drive Mapping, change the settings as follows:
Activate Enable Drive Mapping.

In Sessions > RDP > RDP Global > Mapping > Device Support, change the settings as follows:
Activate DriveLock channel.

Using DriveLock with Citrix:

In Devices > Storage Devices > Storage Hotplug, change the settings as follows:
Deactivate Enable dynamic client drive mapping.
Set Number of storage hotplug devices to 1 or higher.
Activate Private drive letter for each storage drive.

In Sessions > Citrix > Citrix Global > Mapping > Drive Mapping, change the settings as follows:
Enable Activate Drive Mapping.

In Sessions > Citrix > Citrix Global > Mapping > Device Support, change the settings as follows:
Activate DriveLock channel.
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Restricting the Mounting of Hotplug Storage Devices on IGEL Linux

Goal:
You want to restrict the mounting of hotplug storage devices.

Solution:
As of IGEL Linux version 5.10.100, the following registry keys let you disable the mounting of hotplug storage devices 
based on the device class (floppy, optical, harddisk, flash, other).

devices.hotplug.enable_floppy

devices.hotplug.enable_optical

devices.hotplug.enable_harddisk

devices.hotplug.enable_flash

devices.hotplug.enable_other

These are all of type bool. Their default value is true. If true, mounting volumes on floppies, optical media, 
harddisks, flash memory devices, and others is enabled respectively.

In order to disable mounting of a device class system-wide:

In setup, go to System > Registry.
In the Parameter tree, open Devices > hotplug.
To disable the mounting of a device class, uncheck its Enable hotplug [...] parameter.

•
•

Even if the above settings allow mounting hotplug storage devices, the following settings may still restrict 
it:

Devices > USB access control
Devices > Storage Devices > Storage Hotplug


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When to Use USB Redirection

Document Purpose
In general, USB redirection is not needed for standard functionality such as; audio, video, HID input, etc. However, 
in some special circumstances, a device may need to be redirected into a VDI session for full functionality, or if it 
requires a specific driver to function.

Use USB redirection ONLY WHEN ABSOLUTELY REQUIRED.

In this document, we will define the best practices for using USB redirection in a VDI environment, and go through 
the process with an example.

Best Practices for USB Redirection
Below are some general rules that, if followed, will provide the best performance and reliability when using USB 
redirection.

ALWAYS set the default rule to "Deny".
DO use VID and PID to redirect devices whenever possible. This is the best way to make sure that a 
device is redirected and that the USB virtual channels are not flooded with excess redirection.
Enable USB redirection for the minimal amount of devices required to support user workflows
As a rule, the USB classes below should NEVER be redirected. Instead, redirect individual devices in 
these classes using Device Rules.
Audio Audio (input) Audio (output) Bluetooth

HID Bootable HID Imaging USB Hubs

PDA Physical Security Smart Card

Video (input) Wireless Wireless USB

The following classes may be redirected in specific circumstances:
Printers

Only if CUPS configurations or a third party does not fill this requirement

Solution Based on Experience from the Field

This article provides a solution that has not been approved by the IGEL Research and Development 
department. Therefore, official support cannot be provided by IGEL. Where applicable, test the solution 
before deploying it to a productive environment.



For webcams, see Webcam Redirection and Optimization (see page 879).

The example described here is for VMWare Horizon, but it is similar for Citrix, RDS, and most other VDI 
technologies as well.


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Storage
Only if mass storage options do not meet the requirements for user workflows or 
software compatibility

Example: Redirecting a Nuance Powermic (Dictaphone)
Below we will run through the basic process of redirecting a single device into a Horizon VDI session from an IGEL 
device.

Prerequisites

Make sure that Devices > USB Access Control is disabled on the IGEL devices, or make sure there 
are no USB access control rules restricting access to the USB device. More information about IGEL 
USB access can be found under USB Access Control.
USB redirection policies for Horizon/Citrix/RDS must be configured to allow redirection to happen

Rules are meant to be broken, right? If redirecting these classes is the only way things work, take a deeper 
look and see if there is a better way. If there is no obvious better way, then test thoroughly before moving 
into production.



Some devices, including the Nuance Powermic, require custom split rules in Horizon, which will not be 
covered in this article. The splitting can be done with Horizon Group Policy on the VM, or as additional 
settings on IGEL. Please contact your vendor for their best practice for the devices.


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The VDI image must have compatible drivers installed for the devices being redirected into the 
session

Getting Device Information from IGEL
The first step that needs to be done, is to identify the device's vendor ID and product ID which will be used to create 
our redirection rule.

Plug in the USB device to an IGEL terminal.
Connect to the IGEL device using SSH or IGEL Secure Terminal.
Log in as user with the user password set by the IGEL profile.
Type  su  to switch to the root account and provide the root password when prompted.

Run  lsusb  to display a list of devices and locate the device.
Note the ID numbers separated by a colon ":"

In the Dictaphone example, this is  0554  and  1001 .
The first number is the vendor ID (VID) and the second is the product ID (PID).

Configuring the IGEL Profile

Create a new profile in UMS called "USB Redirection".
Go to the USB Redirection page for your session.
Set USB Redirection to "on" and set the Default rule to "Deny".
Make sure that both Automatically connect at startup and Automatically connect when 
inserted are both enabled.
Clear out any existing Class Rules that may have previously existed (if using an existing profile).
Add a Device Rule using the Vendor ID and Product ID collected in the previous section, and set it 
to "Allow".

Apply the new profile to the device, and reboot for safe measures.
The device should now be reflected in the Windows Device manager in the VDI session. If so, then 
the redirection rule is correct and working as expected.

If the device cannot be easily identified by name, then disconnect the device and run  lsusb  again to see 
which one disappeared.



To make it easy, set the name of the rule to match the device name.
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If the device shows up as unknown then most likely a driver will need to be installed in the OS to support 
the device.


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How to Configure USB Access Control
You can allow and prohibit the use of USB devices on your endpoint device. Specific rules for individual devices or 
device classes are possible.

Enable USB Access Control
Open the Setup and go to Devices > USB Access Control.
Enable the option Enable.
Select the Default Rule. The default rule specifies whether the use of USB devices is generally 
allowed or prohibited.
Create one or more rules for classes of devices or individual devices.

Create a Class Rule
To create a new rule, click  in the Class Rules area.
Choose a rule. The rule specifies whether use of the device class defined here is allowed or 
prohibited.
Under Class ID, select the class of device for which the rule should apply. Examples: Audio, 
Printer, Mass Storage.
Under Name, give a name for the rule.
Click OK.
Save the changes.
The rule is active.

Create a Device Rule

To create a new rule, click  in the Device Rules area.
Choose a rule. The rule specifies whether use of the device defined here is allowed or prohibited.
Give the Vendor ID of the device as a hexadecimal value.

The activation of USB Access Control and setting the Default rule to Deny will block the use of USB 
devices locally and in the session and, thus, might disable devices needed for the users. Therefore, activate 
the USB access control only if your security policy requires that. In this case, set Default rule to Deny and 
configure Allow rules for the required USB devices and USB device classes. 
It is recommended to make settings for USB Access Control as the last step in the device configuration. 
Before activating the USB access control, check that all your other settings for printers, Unified 
Communication, USB redirections, mapping settings for USB devices are working as expected.
Note that the USB access control is completely separate than USB redirection for remote sessions, see 
When to Use USB Redirection (see page 932).
Take also notice that the feature does not disable a USB port physically, i.e. power delivery will still work.



When a rule is defined, at least one of the properties Vendor ID or Product ID or UUID must be given.
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Give the Product ID of the device as a hexadecimal value.

Give the Device UUID (Universal Unique Identifier) of the device.
Specify Permissions for the device.
Possible values:

Getting USB Device Information

To find out the Class ID, Subclass ID, Vendor ID and Product ID of the connected USB device, you 
can use the System Information tool. For further information, see Using “System Information” 
Function.
System Information example:

Alternatively, you can use the command lsusb  (or lsusb | grep -i [search term] ) 
in the terminal.
Example for lsusb :


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Global setting: The default setting for hotplug storage devices is used; see Default 
permission parameter under Devices > Storage Devices > Storage Hotplug.
Read only
Read/Write

Under Name, give a name for the rule.
Click OK.
Save the changes.
The rule is active.

Example
The set rule prohibits the use of USB devices on the device.
A class rule allows the use of all entry devices (HID = Human Interface Devices).
A device rule allows the use of the USB storage device with the UUID 67FC-FDC6.
The use of all other USB devices, for example, storage devices or printers, is prohibited.
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Issues with USB IDs in USB Devices Rules

Symptom
USB Device Rules you configured do not take effect.

Problem
The System Information tool in IGEL OS up to version 11.04.100 omits leading zeros in USB vendor and product 
IDs. These are shown only three hexadecimal digits long.

Solution
If you see three-digit USB IDs in System Information, use the lsusb command:

Open Local Terminal.
Enter the lsusb command.

Look for the device in question, possibly using grep to search in the lsusb output:

lsusb | grep -i [search term]
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4. Use the four-digit IDs that lsusb reports.
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How Can I Fix Touchpad Issues?

Overview
On some notebooks, the touchpad does not work properly with IGEL OS. Some of these issues can be solved by 
adding or modifying parameters for the device driver. For usability, the parameter modifications are accessible via 
the Registry of the IGEL Setup.

Issues and Solutions

Issues with the i2c-i801 Driver

The Registry parameter:  system.module_params.i2c_i801.blacklist  defines whether the i2c-i801 
driver is to be blacklisted. The driver is blacklisted by default because it might cause system freezes. If the driver is 
blacklisted, some functions are not available.

In the Setup or the UMS configuration dialog, go to System > Registry > system > 
module_params > i2c_i801 > blacklist. and select the desired option:

"Default": The decision of whether the i2c-i801 driver is blacklisted or not may change 
dependent on the hardware you are using.
"Yes": The i2c-i801 driver is blacklisted.
"No": The i2c-i801 driver is not blacklisted.

Click Apply or Ok.

Touchpad Is a Synaptics Intertouch Device
If your notebook has a Synaptics Intertouch touchpad, the Registry 
parameter  system.module_params.psmouse.synaptics_intertouch  should be enabled.

In the Setup or the UMS configuration dialog, go to System > Registry > system > 
module_params > psmouse >synaptics_intertouch and activate Set this if touchpad is a 
synaptics intertouch device.
Click Apply or Ok.

Touchpad Needs the A4tech Workaround
If your touchpad needs the A4tech workaround, enable it with the Registry parameter 
system.module_params.psmouse.a4tech_workaround . If you are unsure whether you need the A4tech 

workaround, ask your hardware vendor.

If your changes do not seem to be effective after you confirmed them, reboot the device.
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In the Setup or the UMS configuration dialog, go to System > Registry > system > 
module_params > psmouse >a4tech_workaround and activate Set this if touchpad needs the 
a4tech workaround.
Click Apply or Ok.

Changing the Compat Protocol
A solution for touchpad issues might lie in changing the communication protocol; this is done with the Registry 
parameter system.module_params.psmouse.protocol .

In the Setup or the UMS configuration dialog, go to System > Registry > system > 
module_params > psmouse >protocol and select the desired option:

"Default": The system will detect the protocol automatically.
"PS/2"
"ImPS/2"
"ImExPS/2"

Click Apply or Ok.

Changing the Resolution
You can change the resolution for your touchpad via the Registry parameter 
system.module_params.psmouse.resolution .

In the Setup or the UMS configuration dialog, go to System > Registry > system > 
module_params > psmouse >resolution, parameter Resolution in dpi (0 means use default), 
and enter the desired resolution in dpi as an integer.
Click Apply or Ok.

Changing the Report Rate / Polling Rate
You can change the report rate resp. polling rate for your touchpad via the Registry parameter 
system.module_params.psmouse.rate .

In the Setup or the UMS configuration dialog, go to System > Registry > system > 
module_params > psmouse >rate, parameter Report rate in reports per second (0 means use 
default), and enter the desired report rate as an integer.
Click Apply or Ok.

Reset the Touchpad after a Defined Number of Lost Packages
You can force a reset of the touchpad after a defined number of data packages has been lost; the Registry 
parameter is system.module_params.psmouse.resetafter .

In the Setup or the UMS configuration dialog, go to System > Registry > system > 
module_params > psmouse >resetafter, parameter Reset device after so many packages (0 
means never), and enter the desired number of packages as an integer.
Click Apply or Ok.
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Forcing a Resync after a Defined Idle Time

In the Setup or the UMS configuration dialog, go to System > Registry > system > 
module_params > psmouse >resync_time, parameter Mouse idle time before forcing resync in 
seconds (0 means never), and enter the desired number of seconds as an integer.
Click Apply or Ok.
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How Do I Configure a Fujitsu PalmSecure Vein Scanner with IGEL OS?
You can use the Fujitsu PalmSecure Vein Scanner with IGEL OS endpoint devices to achieve highly secure 
authentication for remote sessions.

The following session types are supported:

Microsoft RDP
Citrix StoreFront
VMware Horizon

To configure the Fujitsu PalmSecure Vein Scanner, you must first configure the middleware and then enable the 
passthrough authentication for your session.

Environment
IGEL OS 11.03.100 or higher

Configuring the BioSec Middleware
Open the local Setup of your device or the configuration dialog of the IGEL Universal Management 
Suite (UMS).

Go to System > Firmware Customization > Features and make sure that Biosec BS Login is 
enabled.

•

•
•

If Biosec BS Login had been disabled beforehand, the firmware module must be downloaded first. 
Proceed as follows:

Make sure that the settings under System > Update > Firmware Update are 
correct; for details, see Firmware Update. If you are using Universal Firmware 
Update, the settings should be correct.
Save your changes.
Reboot the device.
The firmware module for BioSec login is downloaded on reboot.


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3.

 

Go to System > Registry > auth > login > biosec_bslogin and activate Login with Biosec BS 
Login.
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2.

Go to System > Registry > auth > biosec > lifepassserverurl and enter the URL of the LifePass 
server.

Enabling Passthrough

For RDP Sessions

Go to Sessions > RDP > RDP Sessions > [name of your RDP session] > Login and enable Use 
passthrough authentication for your session.

Save your changes.
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1.

For Citrix StoreFront Sessions

Go to Sessions > Citrix > Citrix StoreFront > Login and enable Use passthrough authentication.

Save your changes.

For VMWare Horizon Sessions

Go to Sessions > Horizon Client > Horizon Client Sessions > [name of your Horizon session] > 
Connection settings and enable Use passthrough authentication for this session.
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2. Save your changes.
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Printer
CUPS: Mapping Local Printer to Citrix or RDP Sessions (see page 950)
Print Server Configuration (see page 951)
Installing a Custom CUPS Driver (see page 954)
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CUPS: Mapping Local Printer to Citrix or RDP Sessions

Issue
How to map a locally connected PCL/PS-based printer to a Citrix or RDP session?

Problem
The CUPS driver does not support all printer functions such as duplex, color profiles, etc. 

Solution
Open local IGEL Setup or UMS configuration or profile.
Go to Devices > Printer > CUPS > Printers.
Create a new printer and define a Printer Name.
Select the Printer Port your printer is connected to.
Set Manufacturer = Generic.
Set Printer names = Raw Queue.
Switch to the tab Mapping in sessions.
Enable Map Printer in ICA Sessions or Map Printer in RDP Sessions.
Enable the radio button Use Custom Windows Driver Name.
Enter the exact name of the Windows driver installed on the server.
Check if Sessions > Citrix > Citrix Global > Mapping > Printer > Client printer mapping or 
Sessions > RDP > RDP Global > Mapping > Printer > Enable Client Printer Mapping is enabled.
Start the ICA or RDP session and install the printer driver with the redirected port named TS00x/

ClientPort .
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Print Server Configuration

Prerequisites
IGEL OS version 10 or higher
Printer with the integrated PCL/PS controller.

Recommendation
Assign a fixed IP address to the IGEL device or reserve one for it via DHCP.

Instructions
To use the IGEL device as a print server for locally connected printers, follow the steps below:

In the IGEL Setup, go to Devices > Printer > TCP/IP.
Select the port to which the printer is connected.

COM 1
COM 2
Additional Serial Ports
LPT 1
USBLP 1
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3.
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Enable Activate TCP/IP Printer on this Port.
Enter the TCP/IP port number on which the print server service is listening. (Windows default: 
9100)
Poll Criterion and Poll Frequency must only be adjusted if required by the environment.
Click Apply or Ok to save the settings.



Printer

IGEL OS Articles   953 / 1017

The printer can be installed and used by other systems like a regular network printer.
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4.
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Installing a Custom CUPS Driver

Environment
IGEL Linux v5 and higher.

Issue
Your printer is not included in the CUPS default configuration.

Solution
You can install a custom driver from your manufacturer.

Copying the PPD Driver File to the Device

 Copy the driver file (PPD file) to the folder /wfs  using the UMS file transfer mechanism, see Files.

Adding a New CUPS Driver
Now that you have copied the driver file to the device, you have to add a new printer and set the PPD file as the 
driver definition. To do so, proceed as follows:

In Setup, go to Devices > Printer > CUPS > Printer.
Click  to get to Add dialogue.
Define the following settings:

Printer name: Name of the printer.
Printer port: Port to which the printer is connected. Depending on which type you select, 
you will have to provide additional information, e.g. server and port in the case of TCP 
Printer Port.
Manufacturer: Choose Custom, which will bring up the Driver definition field.
Driver definition: Enter the absolute path to the PPD file.

Click Ok to save the settings.
Restart your device.

For a detailed description of the CUPS configuration options, see CUPS.
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UD Pocket
Running IGEL OS from UD Pocket on a Dell WYSE ZX0D (aka 7010) Device (see page 956)
Running UD Pocket on an Acer Chromebook C910 (see page 957)
UD Pocket Seems to Break Microsoft Surface (see page 958)
How to Boot from the UD Pocket on Mac mini, MacBook Air 2018, MacBook Pro (see page 960)
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Running IGEL OS from UD Pocket on a Dell WYSE ZX0D (aka 7010) Device
Here you can learn which settings you have to make on the Dell WYSE ZXoD (aka 7010) to be able to start the device 
with a UD pocket.

Boot up the Dell device.
In the BIOS go to the Advanced tab.
Enable Boot From USB.
Change to the Boot tab.
Change the boot priority to make USB HDD the default by moving it to the top.
Save the settings
Put in the UD Pocket

See this video:

 

Sorry, the widget is not supported in this export.
But you can reach it using the following URL:

https://www.youtube.com/watch?v=C0NWdjVE1RI

https://www.youtube.com/watch?v=C0NWdjVE1RI
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2.

Running UD Pocket on an Acer Chromebook C910
You can use the IGEL UD Pocket with the Acer Chromebook C910. This requires installation of a BIOS extension 
which enables the device to boot into an alternative operating system.

For further information, refer to MrChromebox.tech86.

Enabling Your Device to Boot from UD Pocket
Ensure that you have a WiFi connection; this is required for downloading the SeaBIOS extension.
Boot into recovery mode by pressing [ESC] +  (Refresh) +  (Power) simultaneously.
The recovery mode screen is shown, which states that the OS is broken.
Press [Ctrl] + [D] to enter developer mode.
The developer mode screen is shown, confirming that OS verification is off.
Open a root-capable shell by pressing [Ctrl] + [Alt] +  (F2).
Login as chronos ; no password is required unless one has been set.

Change to /tmp: cd /tmp .

Download the ChromeOS firmware utility script: curl -LO https://mrchromebox.tech/

firmware-util.sh

Start the script with root permissions: sudo bash firmware-util.sh

Enter 1  to select the first option.

Enter y  to confirm.
The RW_Legacy firmware is downloaded to your device.
When the download has completed, press [Enter].
Enter r  to reboot.
The device reboots into developer mode.
To boot from UD Pocket, press [Ctrl] + [L].

Booting from UD Pocket

Ensure that the device is in developer mode. This should be the case if the device has been 
configured according to the procedures described above, and if since then no changes were made 
that have affected the developer mode.
Press [Ctrl] + [L] to boot from UD Pocket.

The procedures described here have been tested with the Acer Chromebook C910; the procedures may 
differ for other Chromebook types.



https://mrchromebox.tech
https://mrchromebox.tech
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UD Pocket Seems to Break Microsoft Surface

Tested Environment
The following information describes the exact environment on which the issue and the troubleshooting method 
have been tested. However, the method will probably work on similar versions.  

Microsoft Surface Book 1
Windows 10 build 1903 4/25/2019 18362.267
IGEL UD Pocket with IGEL OS 11.02.100

Issue
After having booted successfully into UD Pocket once, the Microsoft Surface notebook is not able to boot into 
Windows anymore.

Solution
With the following procedures, you can set your Microsoft Surface to boot from USB storage permanently or, 
alternatively, on-demand.

For detailed information, see How do I use the BIOS/UEFI?87 by Microsoft.

Enabling Boot from USB Storage Permanently

Ensure that your Microsoft Surface has shut down.
Press and hold down the volume + (up) button and at the same time, power up the Microsoft 
Surface.
When the Surface logo appears, release the volume + (up) button.
The UEFI menu is displayed.
Under Configure boot device order, move USB Storage to the top using drag & drop.
Under Advanced options, change the settings as follows:

Enable alternate boot sequence: On
Enable Boot from USB devices: On
Enable Boot Configuration Lock: On
Your UEFI settings should look like this:

Please note that this device is not officially supported. Therefore, we can not offer any guarantee or 
support for the procedures described in this article. 



https://support.microsoft.com/en-ae/help/4023532/surface-how-do-i-use-the-bios-uefi
https://support.microsoft.com/en-ae/help/4023532/surface-how-do-i-use-the-bios-uefi
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Exit the UEFI settings.
Insert the UD Pocket into the USB port of your Microsoft Surface.
Reboot your Microsoft Surface.
Your Microsoft Surface boots from your UD Pocket.

Booting from USB Storage On-Demand

Ensure that your Microsoft Surface has shut down.
Insert the UD Pocket into the USB port of your Microsoft Surface.
Press and hold down the volume + (up) button and at the same time, power up the Microsoft 
Surface.
When spinning dots appear beneath the Surface logo, release the volume + (up) button.
Your Microsoft Surface boots from your UD Pocket.
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How to Boot from the UD Pocket on Mac mini, MacBook Air 2018, 
MacBook Pro

Environment
Mac devices with an Apple T2 Security Chip, e.g. Mac mini, MacBook Pro, MacBook Air 2018, iMac 
Pro

Problem
The secure boot implemented with the Apple T2 Security Chip does not allow to boot Linux on the above-
mentioned devices. For details, see the German overview https://www.computerbase.de/2018-11/apple-t2-linux-
installation-umgehung/. Therefore, some configuration changes on these devices are required to boot from the UD 
Pocket.

Solution
Via the recovery menu, it is possible to disable the secure boot option. To do this, proceed as follows:

To get into the macOS recovery menu, press and hold the command key [⌘] + [R] during the boot 
process as soon as the Apple logo appears.
Under Utilities, select the Startup Security Utility. 
Use an administrator account to deactivate the secure boot option under Secure Boot > No 
Security.

For more information about the Startup Security Utility on Mac devices, see https://support.apple.com/en-us/
HT208198.

Solution Based on Experience from the Field

This article provides a solution that has not been approved by the IGEL Research and Development 
department. Therefore, official support cannot be provided by IGEL. Where applicable, test the solution 
before deploying it to a productive environment.



https://www.computerbase.de/2018-11/apple-t2-linux-installation-umgehung/
https://support.apple.com/en-us/HT208198
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Miscellaneous
Sending Device Log Files to IGEL Support (see page 962)
Exporting the Local Device Configuration (see page 970)
Which Unified Communication Solutions Does IGEL OS Support? (see page 973)
Passthrough Authentication (see page 974)
Hardware Video Acceleration on IGEL OS (see page 989)
Running Commands before or after a Session (see page 992)
Copy Sessions in Setup or UMS (see page 994)
IZ1 and UD2-MM Usage of RAM (see page 995)
Using Symantec Ghost to Deploy IGEL OS (see page 996)
Starting UMS Console Crashes NX Session (see page 998)
Accessing IGEL Setup within Appliance Mode (see page 999)
Application Is Terminated with Message "Low memory! Killing process ..." (see page 1000)
An Application Window Cannot Be Repositioned (see page 1001)
Updating IGEL UMD: Error "not compatible with System5" (see page 1003)
IGEL Endpoint Partners: Ensuring Image Integrity with a Checksum (see page 1004)
Will My Session Be Closed When My IGEL OS Endpoint Device Enters Suspend Mode? (see page 1005)
Microsoft Remote Desktop Client: Comparison of IGEL OS with Other Vendors (see page 1007)
IGEL OS Third Party Integrations (see page 1016)
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Sending Device Log Files to IGEL Support
When the IGEL support team asks you to provide your device's log files, follow the instructions below.

There are two possibilities to send log files to the support team, one that uses the IGEL Universal Management Suite 
(UMS) and one that works locally with a USB memory stick:

With UMS (see page 962)
Without UMS (see page 967)

With UMS
Start the UMS Console and enter your User Name and Password.

Click Connect.

The UMS Console window opens.
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3.
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Open the Help submenu and select Save device files for support.

The dialog Save device files for support opens.

Select the device in question and click Next.

The dialog Select a target directory for the zipped files opens.
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5. Select a directory suitable for saving the zipped log files, and click Next.

A confirmation dialog shows the path and file name under which the log files are 
stored. Depending on your system, you can copy the path using [Ctrl] + [C] and paste it into the File 
Explorer's address bar.
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Depending on your network, hardware, and the amount and size of the log files, the collection and 
the upload of the files might take up to a few minutes.
In the case of failure, try the following:

If you are using UMS 6.10.110 or higher: Go to UMS Administration > Global 
Configuration > Device Network Settings and change the parameter Timeout for 
the device support file upload action (seconds) to a higher value. The maximum 
is 9000 seconds.
Check if port 8443 is open for TCP connections.
If everything should fail, try the method described under Without UMS (see page 967).


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Open your system's File Explorer, go to the path portion of the file location.

Send the ZIP file to the IGEL support team.
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Close the confirmation dialog by clicking Finish.

Without UMS
When the UMS is not accessible or there is an issue with network connectivity, you can still extract system logs from 
a device and send them to support. You will need a USB stick, preferably formatted to NTFS format, to transfer the 
logs to.

Setting Up the Device

In the IGEL Setup, go to Devices > Storage Devices > Storage Hotplug and enable Storage 
Hotplug.

The above procedure collects only those logs that have been written since the last system start. To allow 
persistent logs, you can configure a dedicated partition for debug logs. For more information, also on 
adding additional logs, see Extended Logging With Syslog, Tcpdump and Netlog (see page 497).


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2.
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Under Accessories > Terminals, click   to create a terminal session.

Identifying the USB Stick

Plug the USB stick into the IGEL OS device and start the terminal session.

Log in as root  (by default, no password).

Enter the following commands: 
cd /userhome/media 

ls -l
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Note the name of the USB stick:

Writing the Log File

In the terminal, run the command cd /userhome/media/[Name of your USB stick] .
 
If there are spaces in the device name, use quotation marks "". Example:  cd /userhome/

media/"NEW VOLUME"
If there are no spaces in the device name, quotation marks are not required.

Run the command journalctl > logfile.txt . This will create the system log files on the 

USB stick with the file name  logfile.txt .

Safely eject the USB stick from the IGEL OS device.
You can now examine this log file yourself or send it to IGEL support for analysis.
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Exporting the Local Device Configuration

Issue
There is a specific support case and you need to read out the current local configuration of the device.

Solution
If you need to read out the current local configuration of the device (e.g. during a support case), you can copy the 
two local files setup.ini and group.ini  either locally or via the IGEL UMS.

Option 1: Via UMS Console > Help > Save device files for support

You can transfer the  setup.ini  and group.ini  files together with the device's log files as described in the 
section "With UMS" under Sending Thin Client Log Files to IGEL Support (see page 970).

Option 2: Via UMS Console > [device's context menu] > Export Device Settings
Alternatively, you can export the effective settings that affect the device (i.e. the interaction of local settings and all 
profiles) as an XML file: UMS Console > [device's context menu] > Export Device Settings.
The IGEL Support can import this file into the UMS as a profile and view the effective settings directly in the UMS 
Console.
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Option 3: Via UMS Console > [device's context menu] > Other commands > Device File->UMS

You can also transmit the  setup.ini  and group.ini  files from the device to the UMS as follows:

In the UMS Console, select Other commands > Device File->UMS from the device's context menu 
or under Devices in the menu bar.
Under Device file location, specify /wfs/  as the source. 

Example:  /wfs/setup.ini
Under Target URL, select the destination on the UMS Server and enter the name of the transferred 
file under File Name. 
Example:  https://umsserver.domain:8443/ums_filetransfer/setup.ini
Click Device File->UMS.
The file will be transferred to /rmguiserver/webapps/ums_filetransfer .

Option 4: Via copying to a USB storage device
You can also save the files locally on a FAT32-formatted USB stick:

In the IGEL Setup, go to Devices > Storage Devices > Storage Hotplug and enable Storage 
Hotplug. 
If you use static client drive mapping, make sure that the Number of drives is greater than zero. 
See Storage Hotplug.
Create a terminal session under Accessories > Terminals.
Connect your USB stick.
Open the terminal and log in as root .

Type cp /wfs/*.ini /media/[name of USB storage device]/  and press [Return] 

to copy all .ini  files from your endpoint device, incl.  setup.ini  and  group.ini , to the 
USB stick.

To find out the name of the USB stick, you can use the commands:
cd /userhome/media 

ls -l
If there are spaces in the device name, you'll have to include it later in the quotation marks "". 
If there are no spaces in the device name, quotation marks will not be required.


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6. Type sync  and press [Return]. Wait a few seconds before safely ejecting the USB stick from the 
endpoint device.
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Which Unified Communication Solutions Does IGEL OS Support?
This article provides an overview of the Unified Communication software and hardware solutions that are 
supported by IGEL OS.

Hardware
Jabra Handsets / Headsets
Poly Headsets
EPOS/Sennheiser

Virtual Desktop Optimizations
The virtual desktop optimizations provide the endpoint device with a media engine and redirect the audio and 
video streams so that they are exchanged directly between the endpoint devices. This results in higher performance 
and a lower server load.

For Citrix Sessions

Skype for Business; for configuration, see the chapter Skype for Business in the IGEL OS Reference 
Manual.
Cisco Jabber (JVDI Client); for configuration, see the chapter Cisco Jabber in the IGEL OS 
Reference Manual.

For Horizon Sessions

Skype for Business; for configuration, see the chapter Skype for Business in the IGEL OS Reference 
Manual.
Cisco Jabber (JVDI Client); for configuration, see the chapter Cisco Jabber in the IGEL OS 
Reference Manual.

Local Installation on the Endpoint Device with a Custom Partition
In contrast to the virtual desktop optimizations, where the Unified Communication apps are installed on the VDI 
server, this approach involves installing the apps on the endpoint device. This is achieved by using the Custom 
Partition mechanism of IGEL OS. 

For building a Custom Partition by yourself, see the Custom Partition Tutorial (see page 689).

You can acquire any of the following Custom Partitions free of cost; ask contact your IGEL contact:

TeamViewer
Zoom (see also Zoom as a Custom Partition (see page 731) in the Custom Partition Tutorial (see page 
689))
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Passthrough Authentication
Passthrough authentication is a convenient single sign-on method. With this function, an IGEL user logs in once and 
gains access to all sessions without having to explicitly authenticate themselves again for each of them.

This document explains what basic settings are necessary for passthrough authentication and where you can 
enable the single sign-on method in the relevant sessions.

Introduction (see page 975)
Basic configuration (see page 977)
Session Configuration (see page 984)

IGEL Tech Video

Sorry, the widget is not supported in this export.
But you can reach it using the following URL:

https://www.youtube.com/watch?v=JxGOEGAb3LI

https://www.youtube.com/watch?v=JxGOEGAb3LI
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Introduction
Two methods of single sign-on for a session are available:

Kerberos Passthrough Real Kerberos authentication with clients that support Kerberos.

Within a session, you can access network resources, e.g. file servers, 
without having to authenticate yourself again; this works automatically 
via Kerberos.

Passthrough Uses cached credentials (user name and password) from local log-on for 
authentication.

For access to network resources within sessions, you have to enter your 
credentials again.

Kerberos is an authentication service. It operates with user, service and computer entities which are known as 
principals. These principals all belong to a realm, an administrative unit. Each principal has a unique principal 
name within the realm. To provide the authentication system, a service known as key distribution center is used.

As an example, Microsoft Windows Domains form a realm. The Windows Domain name is the realm name (in upper 
case letters), e.g. EXAMPLE.COM . A user principal would be for example user@EXAMPLE.COM . The domain 
controllers take on the role of the key distribution centers.

When logging in, a user obtains a ticket granting ticket from the key distribution center. This ticket expires after a 
certain time (usually 1 day). When the user starts an ICA session for example, the client can obtain a so-called 
service ticket from the key distribution center with the aid of the ticket granting ticket. With this service ticket, 
authentication for the ICA server is accomplished.
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To enable passthrough authentication you have to make certain settings:

Modify certain basic settings which are necessary to fulfill the conditions for Kerberos passthrough 
authentication. (see page 977)
Enable passthrough authentication in the relevant session. (see page 984)
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Basic configuration
Your client configuration must fulfill certain conditions before you can enable passthrough authentication.

Set the time correctly on all involved hosts and clients. (see page 978)
Configure the domain. (see page 979)
Activate login to the Active Directory domain. (see page 981)

When activating the Smartcard login method, some additional configuration may be necessary (see page 
982).


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Time
The time must be set correctly on all involved hosts and clients.

The best practice procedure is as follows:

Activate Use NTP Time Server under System > Time and Date in the setup.
Specify the NTP Time Server.

A Windows domain controller can be used for this, if applicable.
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Domains/Realms
To configure the domain(s) proceed as follows:

Click Security > Active Directory/Kerberos.
Activate enable to enable Kerberos.
Enter the fully qualified domain name under Default Domain, e.g. EXAMPLE.COM  (upper case 
letters).
Enable DNS Lookup for Domain Controller and DNS Lookup for Domain.

Otherwise you may configure up to 4 domains/realms:

Click Security > Active Directory/Kerberos > Domain1...4.
Enter the fully qualified domain name , e.g. EXAMPLE.COM  (upper case letters).
Specify at least one Windows domain controller (Kerberos key distribution center) in the Domain 
Controller List. 
It can be a DNS name or an IP address.

Click Security > Active Directory/Kerberos > Domain Realm Mapping to define the mapping 
between Active Directory domain names and DNS names.

These settings are sufficient for the domain setup when the DNS servers, e.g. the domain 
integrated MS DNS servers, are aware of the Active Directory.


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5. Activate Use default DNS Domain - Active Directory Domain Mapping.

If both names match, i.e. if a host in the domain EXAMPLE.COM  has the DNS name 

host.example.com , nothing needs to be done here and the default setting is sufficient. Otherwise an 
appropriate entry in the Domain Realm Mapping list has to be created.


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Login

Click Security > Logon > Active Directory/Kerberos.
Activate Login to Active Directory Domain.
Choose one or more of the following login options:

Explicit: A login dialog is presented to the user.
Remember last user name: The login dialog will be prepopulated with the last user name 
that logged in. This option can be checked for convenience if Explicit Login is selected.
Smartcard: Login with smartcard and related smartcard PIN.

Underneath Logout Shortcut Locations, specify where a log-out button will appear.
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3.

Smartcard
For using the Smartcard login method, some additional configuration is necessary:

Under Security > Logon > Active Directory/Kerberos, activate Smartcard.
Under Smartcard removal action, define what should happen when the smartcard is removed:

Log out: Performs a disconnect or log out of running sessions, removes all user related data 
from the device and prepares the device for the next user login.
Lock device: Locks the screen during sessions. Only the user who is already logged in can 
unlock the device with his smartcard and PIN. Additionally, select User password under 
User Interface > Screenlock / Screensaver > Options, to make the setting effective.

Choose an appropriate PKCS#11 module under Security > Smartcard > Middleware.

Kerberos login with a smartcard involves certificates. The root certificate of the certificate used by the key 
distribution center (domain controller) must therefore be available on the device. Either the root certificate is one 
of the public trusted certificate authorities or it must be deployed to the device, see Deploying Trusted Root 
Certificates (see page 604).

The smartcards for this login must be supported by a PKCS#11 module which can access 
the certificates on the smartcard.



When using Windows 2000 or Windows Server 2003-based domain controllers in combination with 
smartcard login, the parameter auth.krb5.realms.pkinit.pkinit_win2k  has to be activated 

in the registry. This enables the use of an earlier protocol version of PKINIT preauthentication .


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Kerberos Ports
The following Kerberos ports are relevant for Linux environments:

UDP Port TCP Port

Getting tickets including the initial TGT 88 88

Changing password from UNIX/Linux 749
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Session Configuration
For single sign-on with sessions, two methods are available:

Kerberos Passthrough: Uses real Kerberos authentication with clients that support Kerberos.
Passthrough: Uses cached user name and password from local logon for authentication.

In the following sections, you can find how to activate passthrough authentication in sessions that support it:

Citrix StoreFront/Web Interface (see page 985)
RDP (see page 986)
Horizon Client (see page 987)
Parallels Client (see page 988)

Currently, real Kerberos authentication is only available in Citrix sessions.
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Citrix StoreFront/Web Interface

Go to Sessions > Citrix > Citrix Global > StoreFront Login.
Select the Authentication type:

Password authentication: To enable passthrough, this option must be selected, and Use 
Passthrough authentication must be activated.
Kerberos passthrough authentication
Smartcard authentication (StoreFront only, not Web Interface): Authentication via 
smartcard will only work with StoreFront, not with Web Interface.
Citrix authentication mechanism (instead of IGEL), Smartcard disabled
Citrix authentication mechanism (instead of IGEL), Smartcard enabled

See also StoreFront Login.
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RDP
For RDP sessions, passthrough is supported. Kerberos passthrough is not yet supported.

Go to Sessions > RDP > RDP Sessions > [session name] > Logon.
Enable Use passthrough authentication for this session.
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Horizon Client
For Horizon sessions, passthrough is supported. Kerberos passthrough is not yet supported.

Go to Sessions > Horizon Client > Horizon Client Sessions > [session name] > Connection 
settings.
Enable Use passthrough authentication for this session.
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Parallels Client
For Parallels Client sessions, passthrough is supported. Kerberos passthrough is not yet supported.

Go to Sessions > Parallels Client > Parallels Client Sessions > [session name] > Connection.
Enable Use system credentials to use the passthrough authentication.
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Hardware Video Acceleration on IGEL OS

Question
Does my hardware with IGEL OS offer video acceleration?

Answer
Open Application Launcher > About to look up your product ID and device type:
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In version 5.07.100 and newer and version 10.01.100 and newer, IGEL OS offers hardware video acceleration for

Media Player
Citrix Multimedia Redirection
RDP Multimedia Redirection (TSMF and EVOR)
VMware Horizon Multimedia Redirection

on selected devices. This allows playing back HD video with a maximum of 20% CPU usage.

Hardware video acceleration is supported on the following IGEL devices:

Product ID Device Type Chipset IGEL Linux >= 
v5.07.100

IGEL Linux >= 
v5.09.100

IGEL OS 
10

IGEL OS 
11

IZ2-HDX/RFX/
HORIZON 
40* (see page 
991)

IGEL D220 Intel Bay Trail ✓ ✓ ✓ ✓* (see 
page 991)

IZ3-HDX/RFX/
HORIZON 41, 
42

IGEL M330C VIA VX900 ✓

IZ3-HDX/RFX/
HORIZON 
50* (see page 
991)

IGEL M340C ATI Mullins ✓ ✓ ✓* (see 
page 991)

IZ3-HDX/RFX/
HORIZON 
51* (see page 
991)

IGEL M340C ATI Mullins ✓ ✓* (see 
page 991)

UD2-LX 40 IGEL D220 Intel Bay Trail ✓ ✓ ✓ ✓
UD2-LX 50, 51 IGEL M250C Intel HD 

Graphics
✓

UD3-LX 40 IGEL M320C VIA VX900 ✓ ✓
UD3-LX 41, 42 IGEL M330C VIA VX900 ✓ ✓
UD3-LX 50 IGEL M340C ATI Mullins ✓ ✓ ✓
UD3-LX 51 IGEL M340C ATI Mullins ✓ ✓

The Multimedia Codec Pack (MMCP) is required for this feature if your IGEL OS version is lower than 
11.01.100.


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Product ID Device Type Chipset IGEL Linux >= 
v5.07.100

IGEL Linux >= 
v5.09.100

IGEL OS 
10

IGEL OS 
11

UD3-LX 60 IGEL M350C AMD Radeon 
Vega 3 
Graphics

✓

UD5-LX 40 IGEL H820C Intel Sandy 
Bridge

✓ ✓ ✓

UD5-LX 50 IGEL H830C 
(Dualcore CPU 
Model)

Intel Bay Trail ✓ ✓ ✓ ✓

UD6-LX 51 IGEL H830C 
(Quadcore CPU 
Model)

Intel Bay Trail ✓ ✓ ✓ ✓

UD7-LX 10 IGEL H850C AMD Radeon 
Graphics

✓ ✓

UD7-LX 11 IGEL H850C AMD Radeon 
Graphics

✓

UD7-LX 20 IGEL H860C AMD Radeon 
Vega 8 
Graphics

✓

UD9-LX 40, 
UD9-LX 41 
Touch

IGEL UD9 BT Intel Bay Trail ✓ ✓ ✓

UD10-LX IGEL UD10 
TC236

VIA VX900 ✓ ✓

Codecs
The following codecs are supported:

MPEG-2 (simple and main profiles)
H.264 (baseline, main and high profiles)
WVC1/WMV3 (simple, main and advanced profiles)
MPEG-4 (DivX/Xvid): only on VIA VX900 and ATI Mullins

* To upgrade your IZ device to IGEL OS 11, please contact your IGEL sales representative. See also https://
www.igel.com/tradeup/ and The IGEL OS 11 Migration Plan.

On 3rd-party hardware with UDC3, IGEL OS Creator (OSC), and UD Pocket, hardware video acceleration 
depends on the graphics chipset of the device.



https://www.igel.com/tradeup/


Miscellaneous

IGEL OS Articles   992 / 1017

Running Commands before or after a Session

Symptom

You want to run shell commands before a specific session is started or after it has terminated.

Problem

You need hooks which will call your shell commands.

Solution

As of IGEL Universal Desktop Linux 5.06.100 there is a generic mechanism for calling shell commands before and 
after a session. It works with Citrix ICA, RDP and VNC Viewer sessions.

This feature is accessible only through the Registry.

Open Setup at System > Registry. Use either the Registry tree or the Search parameter ... function to locate the 
following Registry keys:

for VNCviewer:

sessions.vncviewer*.init_action

sessions.vncviewer*.final_action

for RDP:

sessions.winconnect*.init_action

sessions.winconnect*.final_action

for Citrix/ICA:

sessions.ica*.init_action

sessions.ica*.final_action

(where * is the related session number, e.g. 0,1,2,3,...)

The init_action  is executed before the session is started. The final_action  is executed after the session 
has been terminated. Enter shell commands or the path to a custom script or executable:
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The Registry keys for newly created sessions only appear after a restart of Setup.

Your  init_action  scripts or executables have to return before the session will start. Alternatively, 

background your command by adding '&'  to the end of the commandline.


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Copy Sessions in Setup or UMS
Sometimes you want to create a session that differs from another only in a few details. IGEL Linux version 5.10.100 or 
newer and UMS version 5.02.100 or newer let you copy complete sessions. Once the session is copied, you can easily 
adapt the required settings.

Copying is available in the Sessions section of IGEL Setup (and occasionally in some other sections) as well as in the 
Edit Configuration function in UMS.

To copy a session, proceed as follows:

In the setup, open the menu path Sessions > [Session Type] > [Session Type] Sessions.
Example: Sessions > RDP > RDP Sessions 
The existing sessions are shown.
Highlight the session that you want to copy.
Click .
A copy of the session will be created within the same folder.
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IZ1 and UD2-MM Usage of RAM
How is RAM used by processes in UD2-MM and IZ1 (also known as ARM or SoC devices)?

A total of 1024 MB main memory is divided as follows:

~128 MB is used for graphics
~362 MB is used for internal processes such as communication between DSP and ARM processor
~534 MB is available for user processes
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Using Symantec Ghost to Deploy IGEL OS

Topic of discussion/Issue
Using Symantec Ghost to Deploy IGEL OS

Firmware version
OS10 and OS11 (11.02.100)

UMS version
6.01

Description
This is in lieu of SCCM and our Deployment Appliance

Solution
We are deploying and capturing our IGEL base installation to/from a virtual machine using:

vSphere Client 6.0, version 11 VM:

8 GB RAM
4 CPUs (1 socket, 4 cores)
Video: 1 display, 4 MB memory
SCSI Controller Type: LSI Logic SAS
CD/DVD Drive 1: IGEL_UDC_10.05.500.ISO
CD/DVD Drive 2: Symantec WinPE
HDD: SCSI, Thick Provision Lazy Zeroed, 20 GB
Network Adapter: VMXNET 3
Boot Options/Firmware: EFI

Boot to CD/DVD drive 1 and navigate through the UDC installation options:

UDC Installation
Language: English
EULA: I Agree
Force Legacy Installation: Not selected

Solution Based on Experience from the Field

This article provides a solution that has not been approved by the IGEL Research and Development 
department. Therefore, official support cannot be provided by IGEL. Where applicable, test the solution 
before deploying it to a productive environment.


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Force MS-DOS partitioning during installation: Selected
Migrate old settings: Not selected
Install Firmware
Shutdown (do NOT reboot)

Boot to CD/DVD drive 2:

Boot to WinPE
Capture HDD image using Ghost command: ghost64.exe -sure 

-clone,mode=create,src=1,dst=s:\igel\igel 10.05.500-

YYYYMMDD_HHMMSS-0.gho -ial -ibg -nolilo

-ial  = Forces a sector-by-sector copy of Linux partitions. Other paritions are copied 
normally.
-ibg  = Ignore Ghost Boot partition.

-nolilo  = Does not attempt to patch the LILO or GRUB boot loader after a clone. If you 
use the -NOLILO switch, you can restart your computer from a storage device after a clone 
and then  run/sbin/lilo  or GRUB install script as the root user to reinstall the boot 
loader.

 To deploy to a physical client:

Boot to WinPE
Execute Diskpart:

select Disk 0
clean
exit

Deploy HDD image using Ghost command:  ghost64.exe -sure 

-clone,mode=restore,dst=1,src=s:

\igel\igel 10.05.500-20190510_185741-0.gho -ial -ibg -nolilo

-ial  = Forces a story-by-sector copy of Linux partitions. Other partitions are copied 
normally.
-ibg  = Ignore Ghost Boot partition.

-nolilo  = Does not attempt to patch the LILO or GRUB boot loader after a clone. If you 
use the -NOLILO switch, you can restart your computer from a storage device after a clone 
and then run  /sbin/lilo  or the GRUB install script as the root user to reinstall the boot 
loader.
-szee  = Forces Norton Ghost to keep the sizes of all destination partitions the same as in 

the source partition (no resizing).

We don't do any image prep other than the diskpart clean  command.
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Starting UMS Console Crashes NX Session
Symptom:

When you are connected to an Ubuntu host via NX, starting UMS console on the Ubuntu host crashes the NX 
session.

Solution:

Become Root on the Ubuntu host.
Open the configuration file /opt/IGEL/RemoteManager/rmclient/

RemoteManager.bin.config  in a text editor.

Add the line vmparam -Dsun.java2d.xrender=false  to the file.
Save the file.
Become a regular user.
Start UMS Console.
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Accessing IGEL Setup within Appliance Mode

Symptom
When using the appliance mode, IGEL Setup is not accessible directly.

Problem
Within the appliance mode, all other local applications are hidden; the system's hotkey [Ctrl+Alt+s] does not work 
either.

Solution
To start the IGEL Setup within the appliance mode, press hotkey [Ctrl+Alt+F2].
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Application Is Terminated with Message "Low memory! Killing process ..."

Symptom
A local application or session is killed, and a message that reads Low memory! Killing process [...] is shown.

Example:

Environment
IGEL OS 11.04 or higher

Problem 
The system is running out of memory. As a countermeasure, the system has terminated the application.

Solution
 Close other applications that are not needed and restart the application.

 If the terminated application is Chromium or Firefox, restart it and try using fewer open tabs.

 If the issue occurs often, consider extending the memory size of the devices.
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An Application Window Cannot Be Repositioned

Symptom
Some application windows, e.g. VMware Horizon windows, are placed at startup in the upper left corner instead of 
being displayed in the middle. In case of frameless applications, the window cannot then be moved and may 
conceal the icons.

Problem
Either the screen is too small or the selected resolution is too low.

Solution
Go to System > Registry.
Select the registry key  windowmanager.wm0.variables.placement_ratio .
Specify a higher percentage value under Maximum window size for which the preferred 
placement should apply. This entry refers to the total work area.

The preferred placement is defined with the registry 
key  windowmanager.wm0.variables.placement_mode .


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Example
Session: VMware Horizon Client
Screen resolution: 1366x768
Value for Maximum window size for which the preferred placement should apply: at least 40%
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Updating IGEL UMD: Error "not compatible with System5"

Symptom
Universal Multi Display firmware (IGEL UMD) can't be updated to version 4.13.100.

Error Message:

Firmware not compatible.

dmx_networkd: Slave #0 (MAC) not compatible with System5

Solution
Delete file /tmp/NOT_SYS_5_COMPATIBLE  from UMD master client and update again without rebooting.
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IGEL Endpoint Partners: Ensuring Image Integrity with a Checksum

Overview
To ensure the integrity of your master image, it is recommended to create checksums and compare them between 
the original image and the images derived from it. This article describes how to create checksums for IGEL OS 
images that have been created using the IGEL OS Creator (OSC).

Requirements
IGEL OS Creator (OSC) with IGEL OS 11.05.120 or higher

Instructions
For IGEL OS images that have been created with IGEL OSC Creator (OSC), partition 4 of the main device must be 
checked with the checksum method.

In the following example, the main device is /dev/sda :

Open a terminal on the device that contains the image. For more information, see Terminals.
In the terminal, enter  sha512sum /dev/sda4
The result should look like this:
7d5a25fac1756ef81ac78398d49db197904f60a0cf6594eac92071a5f6a8d6d4562

fd3c8dc127cf22f89f6894000ca94918703c7143bfb11f1dd2ec052eaa52d /dev/

sda4
Repeat this process for all IGEL OS image copies you want to check and compare their checksums. 
If the checksums are identical, the images can be deployed.
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Will My Session Be Closed When My IGEL OS Endpoint Device Enters 
Suspend Mode?
This article will teach you how to configure your IGEL OS device so that your session is not interrupted when your 
device goes into suspend mode.

Session Disconnection on Suspend
When an IGEL OS endpoint device goes into suspend mode (S3), remote sessions like Citrix, Microsoft Windows RDP, 
or VMware Horizon, for instance, will be disconnected.

IGEL Environment
Endpoint device with IGEL OS 11
Remote session, e.g. Citrix, Microsoft Windows RDP, or VMware Horizon

Avoiding Possible Issues
Modern server-based or cloud-based systems provide remote session resume features on the server side. Check out 
the relevant documentation for your system. 

Configuring Suspend Mode
 To allow or disallow suspend mode, go to System > Power Options > Shutdown and set the following 

parameters according to your needs:

Allow system suspend

Default action: Select the action when the Dialog timeout has expired. 

 To configure suspend or shutdown on inactivity, go to System > Power Options > System and set the following 
parameters according to your needs:
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System suspend/shutdown on inactivity: Set the timeout after which the system shuts down or 
enters suspend mode.

System action on inactivity: Define whether the system should enter suspend mode or shut 
down after the timeout.
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Microsoft Remote Desktop Client: Comparison of IGEL OS with Other 
Vendors

The following table shows the features currently available in Microsoft Remote Desktop Client, including IGEL OS 
which is built with the Microsoft RD Core for Linux.

Feature Windows 10 Microso
ft Store
Client

And
roid

iOS macOS IGEL OS Comments

RDP AVD / 
W365

Native Nat
ive

Web 
client

Nati
ve

AVD / 
W365

Citr
ix

VM
war
e

Common

Remote 
Desktop 
sessions

yes yes yes yes yes yes yes yes yes yes The desktop of a 
remote computer is 
presented in a full 
screen or windowed 
mode

Rolling Release Info: OS 11.07.110

The information provided here is valid with IGEL OS 11.07.110 and higher.


•

•

•

•

•

•
•

The information provided here reflects the state on May 13, 2022.
The information was mostly obtained from the following sources:
Microsoft:

https://support.microsoft.com/en-us/office/teams-features-by-platform-
debe7ff4-7db4-4138-b7d0-fcc276f392d3
https://docs.microsoft.com/en-us/windows-server/remote/remote-desktop-services/
clients/remote-desktop-features
https://docs.microsoft.com/en-us/windows-server/remote/remote-desktop-services/
clients/remote-desktop-app-compare

Citrix:
https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/multimedia/opt-ms-
teams.html
https://www.citrix.com/content/dam/citrix/en_us/documents/data-sheet/citrix-
workspace-app-feature-matrix.pdf

VMWare:
https://kb.vmware.com/s/article/86475
https://kb.vmware.com/s/article/80386?lang=en_US



https://support.microsoft.com/en-us/office/teams-features-by-platform-debe7ff4-7db4-4138-b7d0-fcc276f392d3
https://docs.microsoft.com/en-us/windows-server/remote/remote-desktop-services/clients/remote-desktop-features
https://docs.microsoft.com/en-us/windows-server/remote/remote-desktop-services/clients/remote-desktop-app-compare
https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/multimedia/opt-ms-teams.html
https://www.citrix.com/content/dam/citrix/en_us/documents/data-sheet/citrix-workspace-app-feature-matrix.pdf
https://kb.vmware.com/s/article/86475
https://kb.vmware.com/s/article/80386?lang=en_US
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Integrate
d 
RemoteA
pp 
sessions

yes yes no no no yes no no yes no Individual remote 
apps are integrated 
into the local desktop 
as if they are running 
locally

Immersiv
e 
RemoteA
pp 
sessions

no no yes yes yes no yes yes (no 
taskbar)

no yes Individual remote 
apps are presented in 
a window or 
maximized to a full 
screen

Multiple 
monitors

16 
monit
or 
limit

16 
monit
or 
limit

no no no 16 
monit
or 
limit

no 16 
monitor 
limit

8 
mo
nito
r 
limi
t

8 
mo
nito
r 
limi
t

Allows the user to run 
a remote desktop or 
remote apps on all 
local monitors

Dynamic 
resolution

yes yes yes no no yes yes yes yes yes The resolution and 
orientation of local 
monitors are 
dynamically reflected 
in the remote session. 
If the client is running 
in windowed mode, 
the remote desktop is 
resized dynamically to 
the size of the client 
window.

Smart 
sizing

yes yes yes no no yes no yes yes yes The remote desktop in 
windowed mode is 
dynamically scaled to 
the window's size

Localizati
on

no yes yes Eng
lish 
only

yes yes yes English 
only

yes no The client user 
interface is available 
in multiple languages

Multi-
factor 
authentic
ation

no yes yes yes yes yes yes yes yes* yes Supports multi-factor 
authentication for 
remote connections
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Prioritize
d 
datastrea
ms

no no no no no no no no yes no Admins can configure 
the priority for certain 
data streams

* Targeting Citrix Storefront directly, smartcards and federated authentication (SAML/AzureAD) 
are supported. Using Citrix ADC, multiple MFA-Providers and methods are supported.

Input Redirection

Keyboard yes yes yes yes yes yes yes yes yes yes

Mouse yes yes yes yes yes* yes yes yes yes yes

Touchscr
een

yes yes yes yes yes no yes 
(exc
ept 
IE)

no yes no

Pen yes yes no yes 
(as 
tou
ch)

yes 
(as 
touc
h)

no no no yes*
*

no

* View the list of supported input devices for the Remote Desktop iOS client:
https://docs.microsoft.com/en-us/windows-server/remote/remote-desktop-services/clients/
remote-desktop-ios#supported-input-devices

** Depending on the pen

Port Redirection

COM Port yes yes no no no no no no yes yes

USB yes yes no no no no no yes* yes yes *Fabulatech USB 
Redirection

Other Redirections (devices, etc.)

Cameras yes yes no no yes yes no yes* yes yes *Fabulatech Webcam 
Redirection

Enhanced 
Camera 
Redirectio
n

no no no no no no no no yes no Allows configuration 
of camera parameters 
to be used within the 
remote session

Clipboard yes yes yes TextText, 
imag
es

yes Text yes yes yes

https://docs.microsoft.com/en-us/windows-server/remote/remote-desktop-services/clients/remote-desktop-ios#supported-input-devices
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Local 
drive/
storage

yes yes no yes yes yes no yes yes yes

Location yes yes no no no no no no no no

Micropho
nes

yes yes yes yes yes yes yes yes yes yes

Multi-
audio

no no no no no no no no yes no Allows the redirection 
of multiple local audio 
devices into VDI

Printers yes yes no no no yes 
(CUPS
)

PDF 
Prin
t

yes 
(CUPS 
only)

yes 
(CU
PS)

yes

Scanners yes yes no no no no no yes* yes* yes *Fabulatech Scanner 
Optimization

Smartcar
ds

yes yes no no no yes 
(Wind
ows
logon 
not 
suppo
rted)

no yes yes yes

Speakers yes yes yes yes yes yes yes 
(exc
ept
IE)

yes yes yes

Browser 
Content

no yes* no no no no no no yes no Allows execution of 
e.g. browser-based 
multimedia content 
on the client device to 
reduce load and traffic 
within the datacenter

*Multimedia 
redirection for AVD 
(preview)
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GPU 
accelerati
on

no yes 2 no no no no no no yes 
1

yes Allows running 
graphics-heavy 
applications running 
in 
virtualized environme
nts utilizing the 
server's GPU and 
lossless compression 
for e.g. CAD 
applications
1 Citrix HDX 3D Pro 
requires Citrix Virtual 
Apps and Desktops 
Platinum License

2 GPU-optimized AVD 
host (pool) with GPU-
accelerated app-
rendering, GPU-
accelerated frame 
encoding, or 
fullscreen video 
encoding

Additional Features (UI / UX / Security)

Screen 
pinning

no no no no no no no no yes no Save complete display 
layout on Storefront 
servers (also supports 
Geo load balancing)

Keyboard 
layout 
synchroni
zation

yes yes no no no no no yes yes yes The keyboard layout 
within the VDI is set 
according to the 
client's keyboard

Keyloggin
g 
protectio
n

no no no no no no no no yes yes A keylogger on the 
client only sees 
encrypted keystrokes
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Screensh
ot 
preventio
n

no no no no no no no no yes yes Screenshots created 
on the endpoint will 
only show blank 
content 
when capturing a VDI 
screen.

UC Optimization

Feature Wind
ows 
10

Wind
ows 
10

Microso
ft Store
Client

And
roid

iOS macOS IGEL OS Comments

RDP AVD / 
W365

Native Nat
ive

Web cl
ient

Nati
ve

AVD / 
W365

Citr
ix

VM
war
e

MS Teams no yes no no no no no yes yes yes Media optimizations 
for Microsoft Teams to 
provide high-quality 
calls and screen-
sharing. Learn more at 
Use Microsoft Teams 
on Azure Virtual 
Desktop.88

Cisco 
Jabber

no no no no no no no no yes no Optimization enables 
the physical client to 
directly communicate 
and offload webcam 
and audio from the 
server to the client 
completely 
transparent to the 
user

https://docs.microsoft.com/en-us/azure/virtual-desktop/teams-on-avd
https://docs.microsoft.com/en-us/azure/virtual-desktop/teams-on-avd
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Cisco 
Webex 
Meetings / 
Teams

no no no no no no no no yes yes The Cisco Webex 
media engine 
redirects audio and 
video streams so 
that they are 
exchanged directly, 
without going through 
the hosted virtual 
desktop in the 
datacenter

Skype for 
Business

no no no no no no no no yes yes Signaling information 
is sent via a virtual 
channel to the client's 
RealTime media 
engine. That allows 
RealTime media to be 
executed directly on 
the user's device.

Zoom no yes no no no no no yes yes yes The Zoom plugin on 
the client will offload 
video encoding and 
decoding 
and communication 
directly to the Zoom 
cloud
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Avaya IX 
Workplac
e

no yes 1 no no no no no yes 1  2 yes 
1

yes 
1

VDI optimization for 
customers using 
Avaya UC Client within 
their environment. 
Control information 
gets exchanged via the 
remote desktop 
protocol (ICA or Blast). 
Calls take place via SIP 
directly, surpassing 
the VDI.
1 Avaya IX Workplace 
for IGEL OS is not 
generally available 
because of the Avaya 
distribution policy/
license agreement. 
The customer needs 
to get in contact with 
Avaya support to 
receive custom 
partition files and 
support

2 Not approved. Needs 
to be verified/tested.

Estos 
ProCall

no no no no no no no no yes 
1  2

no 1 Audio datastream 
(UDP Opus or G.711a) 
between the ProCall 
Client (WebRTC Stack) 
and the UC Media 
Server is routed 
through the Citrix 
Server(s) and 
transferred via Citrix 
HDX-Audio to the 
endpoint.

2 Not officially tested/
verified by IGEL
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WebRTC 
(in 
general)

no yes 2 no no no no no no yes 
1

yes 
2

Optimize WebRTC to 
offload webcam and 
audio to the client
1 Using Citrix BCR 
feature

2 Part of Teams 
optimization (based 
on WebRTC). Needs to 
be verified.
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IGEL OS Third Party Integrations

The following table shows the 3rd party features included in IGEL OS that are currently supported with the listed VDI 
connections.

Feature IGEL OS
AVD / 
W365

IGEL 
OS
Citrix

IGEL OS
VMwar
e

IGEL 
OS
RDP

Comments

Cisco JVDI Client no yes yes no

Cisco WebEx Meetings 
VDI

no yes yes no

Cisco WebEx VDI no yes yes no

Zoom VDI Media 
Plugin

yes yes yes no

Microsoft Teams 
Optimization

yes yes yes no

Fabulatech USB 
Redirection

yes yes yes yes

Fabulatech Camera 
Redirection

yes yes no no

Fabulatech Scanner 
Redirection

yes yes yes yes

deviceTRUST yes* yes yes* no *  Will be available soon

DriveLock no yes no yes

Diktamen no yes partially
*

yes *  Dictation supported, but no virtual 
channel initiated

Grundig dictation no yes partially
*

yes *  Dictation supported, but no virtual 
channel initiated

Nuance dictation no yes partially
*

no *  Dictation supported, but no virtual 
channel initiated

Rolling Release Info: OS 11.07.110

The information provided here is valid with IGEL OS 11.07.110 and higher.




Miscellaneous

IGEL OS Articles   1017 / 1017

Feature IGEL OS
AVD / 
W365

IGEL 
OS
Citrix

IGEL OS
VMwar
e

IGEL 
OS
RDP

Comments

Olympus dictation no yes partially
*

yes *  Dictation supported, but no virtual 
channel initiated

Philips dictation no yes partially
*

yes *  Dictation supported, but no virtual 
channel initiated

SpeechWrite no yes partially
*

no *  Dictation supported, but no virtual 
channel initiated

Signotec signature no yes yes* yes *  Using VMware HID Optimization

StepOver signature no yes yes* yes *  Using VMware HID Optimization

Kofax signature 
(Wacom)

no yes yes* yes *  Using VMware HID Optimization

Lakeside SysTrack yes yes yes yes Using client virtual channels

PrinterLogic no yes no yes

ThinPrint yes* yes yes yes *  Using ezeep for Azure

Tricerat yes* no no no *  Using Tricerat custom partition for 
IGEL


	Overview: First Steps with IGEL OS 11
	Update and Upgrade
	Adapting IGEL OS 11.04 or Higher for Devices with Small Storage
	Environment
	Overview
	Determining Which Features to Deactivate
	Reducing the Feature Set

	Upgrading UDC3 or UD Pocket from IGEL OS 10.06 to IGEL OS 11 via Universal Firmware Update
	Devices That Can Be Upgraded to IGEL OS 11
	Important! Consider This Before Upgrading
	Getting the UMS Ready
	Deploying the Licenses
	Creating the Universal Firmware Update
	Creating an Upgrade Profile
	Assigning the Upgrade Profile and the Universal Firmware Update to the Test Devices
	Testing the Upgrade
	Unassigning the Upgrade Profile and the Universal Firmware Update
	If Applicable: Restoring Custom Partition and Custom Applications
	Upgrading All Devices

	Upgrading from IGEL OS 10 to IGEL OS 11
	Upgrading UDC3 Devices from IGEL OS 10 to IGEL OS 11
	Upgrading IGEL Devices from IGEL OS 10 to IGEL OS 11

	Buddy Update
	TechChannel
	Configuring the Buddy Update Server
	Configuring the Buddy Update Client

	Firmware Update
	Downloading Updates and Storing them on an FTP Server
	Executing an Update Process

	Updating IGEL OS Using a USB Storage Device
	Updating the Firmware using the Linux Console
	Issue
	Solution

	Error: "Not enough space on local drive" when Updating to IGEL OS 11.04 or Higher
	Symptom
	Problem
	Environment
	Solution

	Error: "legacy ICG Root (CA) certificate" When Updating to Igel OS 11.04 on Devices Connected via ICG
	Possible Problem
	Environment
	Diagnosis
	Solution

	Device Does Not Connect to ICG after Update to IGEL OS 11.04 or Higher
	Symptom
	Environment
	Problem/Possible Cause
	Diagnosis
	Solution

	IGEL OS Automatic Update Service for Device Evaluation
	Overview
	Environment
	Configuring the Automatic Update Service


	Citrix
	Performance
	Poor Performance: Black Blocks and Stripes in Citrix Sessions
	Poor Performance with Citrix XenDesktop 7.6 Deep Compression
	Citrix Receiver: Grey Blocks in Excel 2013
	Bar Code Scanning is Slow via Citrix
	Slow Performance of Citrix Session in a Cloud Environment

	Mouse
	Changing Middle Mouse Button Function for Citrix Session and Local Firefox Browser
	How to Connect a SpaceMouse with a Citrix Session
	Solve SpaceMouse USB Reset Problem
	Wireless Mouse Keyboard Set Logitech k520 Freezes in Citrix Session
	Black Box Next to the Mouse Cursor

	How to Configure Citrix Native USB Redirection
	Citrix Fabulatech Scanner Redirection in IGEL OS
	How to Enable Fabulatech Scanner Redirection for Citrix

	Mapping USB Storage Media into Citrix Sessions
	Basic Configuration of the Client
	Additional Parameters to Check
	Assigning a Drive Letter within the Session (Optional)
	Configuration on the Server Side

	Auto-Hide Toolbar in Appliance Mode
	Environment
	Problem
	Solution

	Create a Seamless, Transparent User Experience with Appliance Mode
	Connecting to a Citrix Farm
	Citrix StoreFront
	Citrix Self-Service
	Appliance Mode

	Create a Self-Service Setup for the User with Quick Settings
	Login Failed because of the Expired AD Password
	Problem
	Solution
	Changing an Expired Active Directory Password

	Configuring Auto Logon for Citrix Virtual Desktops
	Steps

	Force Citrix Logout Using Hotkey
	Citrix: Freeze at Logout
	Symptom
	Solution
	Workaround

	Warning Message: [Citrix Store] Could Not Connect to the Citrix Server
	Environment
	Symptom
	Problem
	Solution

	Setting up Citrix Sessions with Hardware-Accelerated H.264 Deep Compression Codec
	Prerequisites
	Activating the Codec

	Using Font Smoothing (ClearType) in Citrix Sessions
	Symptom
	Problem
	Solution

	Highly Secured XenServer has Problems with LD_BIND_NOW Workaround
	Problem
	Solution

	Workaround for Citrix Receiver X Error
	Problem
	Environment
	Solution

	Citrix HTML5 Receiver Issue
	Affected Versions
	Issue
	Solution

	Macbook Keyboard Layout inside Citrix Session
	Citrix Feature Matrix
	Using Lync / Skype for Business with Citrix HDX RealTime Optimization Pack
	Issue
	Solution

	Unexpected Keyboard Layout in a Citrix Session
	Problem
	Environment
	Solution


	RDP
	Mapping USB Storage Media into RDP Sessions
	Solution:
	Basic Configuration of the Client
	Additional Parameters to Check
	Configuration on the Server Side

	What Is the String for Token-Based Load Balancing?
	Environment
	Question
	Answer

	RDP Fabulatech Scanner Redirection
	Enabling Fabulatech Scanner Redirection

	RDP RemoteApp Parameter Settings
	Symptom
	Problem
	Solution

	RDP Performance Enhancements
	Symptom
	Problem
	Solution

	RDP Session playing Sound: Error RDPSND_NEGOTIATE
	Symptom
	Problem
	Solution

	Crackling and Audio Dropouts in RDP Sessions
	Symptom
	Environment
	Problem 
	Solution

	Login Failed Because of Expired AD Password
	Issue
	Solution
	Changing an Expired Active Directory Password

	User Has to Provide Credentials Twice for RDP Logon
	Issue
	Cause
	Solution


	VMware Horizon
	Setting up VMware Blast Sessions
	Prerequisites

	Use NLA (Network Layer Authentication) for Logon with Horizon Client Sessions
	Workaround for Hotkeys in Horizon Sessions
	Issue
	Solution

	Multimedia Acceleration with VMware Horizon View in VESA Mode
	Symptom
	Problem
	Solution

	Horizon Feature Matrix
	Troubleshooting the Horizon Client
	Symptom
	Environment
	Problem 
	Solution

	VMware Horizon Authentication Issues (Certificate Revocation List)
	Problem
	Solution


	Evidian
	Authenticating with Evidian Authentication Manager
	Prerequisites
	Configuring an Evidian Authentication Manager Session
	Configuring Citrix/RDP/VMware Horizon Sessions
	Custom Commands
	Debugging and Troubleshooting


	IBM iAccess
	Editing the List of Visible Menu Entries for IBM iAccess
	Removing Menu Items

	Key Mapping for IBM iAccess Client
	Problem
	Environment/Prerequisites
	Solution
	Editing the Key Mappings 


	Imprivata
	Imprivata: Clear the Imprivata Data Partition
	Imprivata: Session Customization
	Imprivata_VMware Session
	Imprivata_RDP Session


	Windows Virtual Desktop
	Feature Matrix: WVD (RDP3) for IGEL OS 11
	How to Connect IGEL OS to Windows Virtual Desktop
	Quick Start Guide

	Importance of Keeping IGEL OS Firmware Up-to-Date for Microsoft AVD and Windows 365 CloudPC
	Why Is It Important to Keep Your Igel OS Firmware Updated?
	IGEL Environment
	How to Check for the Latest IGEL OS Firmware Version
	How to Check If the IGEL OS Version Is Out-of-Date
	How to Update IGEL OS Endpoint Devices to the Latest Firmware Version

	Microsoft Teams Feature Comparison for IGEL OS
	Remove Expired DigiCert Certificate
	Symptoms
	Affected Versions
	Cause
	Solution


	SSH
	Enable Weaker Algorithms in the Built-in OpenSSH Server
	Problem
	Solution

	Enable Weaker Algorithms in the SSH Client
	Environment
	Problem
	Solution

	SSH: Deprecation of Weak Algorithms as of IGEL Linux 10.04.100

	Amazon WorkSpaces - Teradici PCoIP Sessions
	Connecting IGEL OS Devices with Amazon WorkSpaces via PCoIP
	Set Up the Device Connection
	Connecting to Amazon WorkSpaces

	Use IGEL Setup for Configuration – Connecting with AWS via PCoIP
	Configuring in the IGEL Setup
	Connecting to Amazon WorkSpaces

	Broker Types – Amazon WorkSpaces
	PCoIP Broker
	Direct Hardhost

	How Can I Use H.264 Acceleration in a Teradici PCoIP Session?
	Question
	Environment
	Answer


	Login Enterprise Configuration
	Login Enterprise Launcher in IGEL OS
	Requirements
	Uploading the SSL Certificate
	Configuration of Login Enterprise Launcher
	Starting the Login Enterprise Launcher from the UMS

	Getting the Secret for Login Enterprise Launcher
	Using the Login Enterprise Launcher within a VMware Horizon Session

	Nutanix
	Frame on Nutanix
	Setting up Frame Connection

	Running the Nutanix Test Drive on IGEL

	Browser
	How Can I Use H.264 Hardware Acceleration for Chromium or Firefox Browsers on IGEL OS Endpoint Devices?
	Checking Whether Hardware Video Acceleration Is Enabled Globally
	Checking Whether Hardware Video Acceleration Is Enabled for Chromium
	Does the Default Browser Setting Matter?
	The Browser with the Higher Number of Configured Sessions Gets Hardware Video Acceleration
	Browser Content Redirection for Citrix Sessions Forces Hardware Video Acceleration for Chromium 
	Setting Chromium to Select the H.264 Video Stream

	Define Multiple Start Pages for Your Browser
	Touchscreen: Multitouch/Gesture Support for Firefox
	Set Advanced User Preferences for the Browser
	Use the Browser in Kiosk Mode
	Settings under Sessions > Browser > Browser Sessions > [Session Name]
	Settings under Sessions > Browser > Browser Sessions > [Session Name] > Settings
	Settings under Sessions > Browser > Browser Global > Tabs
	Settings under Sessions > Browser > Browser Global > Content
	Settings under Sessions > Browser > Browser Global > Privacy
	Settings under Sessions > Browser > Browser Global > Security
	Settings under Sessions > Browser > Browser Global > Restart
	Settings under Sessions > Browser > Browser Global > Window
	Settings under Sessions > Browser > Browser Global > Menus & Toolbars
	Disabling Access to Developer Tools
	Disabling Crash Reports

	SSL/TLS Error with Firefox in Appliance Mode
	Symptom
	Problem
	Solution

	Browser Cannot Download Files
	Symptom
	Problem
	Solution

	Some PDFs are not opened by Firefox
	Symptom
	Problem
	Solution

	Can I Install Firefox Extensions?
	Question
	Answer


	System
	Resetting a Device with Unknown Administrator Password
	Symptom
	Problem
	Solution

	Error: "Unknown filesystem..."
	Symptom
	Environment
	Problem 
	Solution

	Custom Boot Commands Are Still Active after Factory Reset
	Symptom
	Problem
	Solution

	Solving Issues with Signed Partitions
	Error: "Partition couldn't be loaded due to invalid signature"
	Error: Device Plays a Beep Code Instead of Booting
	Error: "The new firmware is not signed. Update not allowed."
	Error: "Invalid signature - Failed to read from partition"

	How to Show the Boot Mode of IGEL OS
	Disabling Features to Reduce Firmware Size
	Symptom
	Problem
	Solution

	Fabulatech USB Redirection Server Component
	Issue
	Problem
	Solution

	Which Features of IGEL OS Will Be Affected If the UMS Is Down?
	Overview
	Productivity Features That Are Affected If the UMS Is Down
	Administration Functions That Are Affected If the UMS Is Down


	Network
	Configuring Open VPN Sessions
	Prerequisites
	Authenticating with TLS Certificates
	Authenticating with Name/Password
	Authenticating with Name/Password with TLS Certificates
	Authenticating with Static Key
	Options and TLS Options
	DNS and Routing Options
	Proxy
	Checking the VPN Connection
	Automatically Starting the VPN During Boot
	Further Information
	Securely Distributing Keys and Certificates for OpenVPN

	Running the OpenVPN Client with a Preconfigured Configuration File
	Environment
	Setting up an OpenVPN Connection with a Preconfigured Configuration File 
	Removing the OpenVPN Connection

	How Can I Configure OpenVPN with an .ovpn or .conf File for IGEL OS Devices?
	Creating a Profile
	Creating the Certificate/Key Files
	Transferring the Files to the UMS
	Adjust the Profile

	Configuring Wi-Fi Network Roaming
	Issue
	Solution

	Connecting to a Wi-Fi Network with Hidden SSID
	Symptom
	Problem
	Solution

	Improving WiFi Connectivity
	Problem
	Environment
	Possible Causes and Solutions

	Preventing Permanent Storage of Wireless Network Keys
	Using WPA Enterprise / WPA2 Enterprise with TLS Client Certificates
	Via SCEP (NDES)
	Via Files Served from UMS
	Deploying Client Certificates and Keys
	Configuring the Network Interface

	IPv6 Settings
	Application Scenario
	Available Configurations
	Timeouts in Automatic Configuration

	Extended Logging With Syslog, Tcpdump and Netlog
	Debuglog Partition
	Syslog
	Tcpdump
	Netlog

	Making a Telnet Connection from IGEL Linux
	Issue
	Solution

	Configuring Dynamic DNS Updates via DDNS
	Changing the SMB protocol version
	How to Launch the Wireless Manager within IGEL OS when the Taskbar Is Hidden
	Problem
	Environment
	Solution


	Security
	Securing IGEL OS Endpoints
	Introduction
	Setting Passwords
	Keeping the System Up-To-Date
	Disabling Access to Components
	Minimizing the Attack Surface
	Configuring Remote Access and Management
	Wi-Fi and Bluetooth
	Using UD Pocket for BYOD Devices

	Secure Shell (SSH) Access to IGEL OS with Keys
	Generating the SSH Key Pair
	Distributing the Public Key with UMS
	Configuring SSH Access on the Device

	Secure Terminal (Telnet with TLS/SSL)
	Secure Shadowing (VNC with TLS/SSL)
	Basic Principles and Requirements
	Shadow Devices Securely
	VNC Logging

	Cherry eGK Channel Substitution
	Using the G87-1504/ST-1503 with firmware version 10.05.100 and higher:

	Single Sign-on for the Browser Proxy
	Limiting the Number of Permitted Login Attempts
	Symptom
	Problem
	Solution

	How to Deploy Device Encryption
	Overview
	Instructions

	Security: Timeout for Secure Shadowing and Secure Terminal
	Overview
	Configuring the Timeout


	Certificates
	Certificate Enrollment and Renewal with SCEP (NDES)
	Requirements
	Technical Background
	Client Enrollment Details
	Configuration of the SCEP Client
	Files Involved
	Troubleshooting

	Deploying Trusted Root Certificates
	Purpose
	Requirements
	Solution
	Deploying Certificates via UMS
	Installing Certificates Manually

	Which CA Certificates Are Contained in IGEL OS?

	Smartcard
	Authentication with IGEL Smartcard
	Prerequisites
	Creating IGEL Smartcard Folders
	Folder "Smartcard Operation"
	Folder "Smartcard Creation"
	Writing the IGEL Smartcard
	Smartcard Readers Supported by IGEL Smartcards

	Smartcard Authentication
	Certificate Authentication
	Smartcard Readers
	PC/SC Resource Manager
	Smartcard Middleware
	Active Directory Logon with Smartcard
	Citrix StoreFront
	RDP Sessions
	Horizon Sessions
	Smartcard Authentication in Browser
	Local Login with Smartcard Certificate


	Desktop and Display
	Display Configuration for Shared Workplace (SWP)
	Best practice

	Display Switch
	Configure a Starter for the Display Switch
	Configure the Display Switch
	Use the Display Switch

	Multimonitor
	Automatic Configuration
	Manual Configuration
	Additional Settings
	Auto Switch Monitor Configuration for Laptops

	Showing and Hiding the On-Screen Software Keyboard Automatically
	Showing Automatically
	Hiding Automatically

	Overcoming the Restrictions of a Full-Screen Session with the in-Session Control Bar
	Activating the in-session control bar:
	Using the in-session control bar:

	Screen Issues When Redocking Notebook
	Using an External NVIDIA Graphics Card
	Goal
	Environment
	Solution

	Bluelight Filter for Nighttime Display
	Automatic Retrieval of the Geodata (Recommended)
	Setting the Geodata Manually
	Daylight and Nightlight Brightness


	Customizing
	Custom Partition Tutorial
	A First Simple Custom Partition
	Packaging the Custom Partition
	A Real-World CP: Chromium
	Zoom as a Custom Partition
	Microsoft Teams as a Custom Partition

	Using a Custom PKCS#11 Library
	Issue
	Problem
	Solution

	Adding an Icon for Browsing Removable Storage
	Symptom

	Adding an Icon for the Image Viewer
	Symptom
	Problem
	Solution

	Creating a Timed Command (Cron Replacement)
	Customizing IGEL OS Desktop
	IGEL Tech Video
	Introduction
	Creating Your Own Wallpaper
	How to Create a Custom Bootsplash for IGEL OS Devices via the UMS
	Creating Your Own Screensaver
	Assigning Your Own Company Logos
	Creating Your Own Taskbar
	Customizing Desktop Icons

	How to Change the Font Color of the Desktop Icons
	Overview
	Environment
	Instructions

	How to Set Up a Countdown to Prevent an Undesired Screen Lock In IGEL OS
	Defining the Countdown's Behavior
	Defining the Countdown's Appearance
	Configuring a Conditional Countdown and Command
	How to Set Up a Countdown in the IGEL OS
	Configuring a Conditional Countdown and Command

	Installing a Calculator on IGEL Linux
	Keyboard Shortcuts for Managing Windows
	Make Frequent User Actions Easier by Defining Hotkeys
	Shutdown/Suspend Devices Automatically at the End of a Session
	Issue
	Solution

	Suspend to RAM - Wake Up by USB Mouse
	Setting System Suspend as the Default Action
	Configuring the BIOS for PS/2 Mouse and Keyboard
	Configuring the BIOS for USB Mouse and Keyboard
	Enabling the Wake-Up Functionality

	Taking Screenshots on IGEL Linux
	Issue
	Solution

	Setting the Device's System Time
	Issue
	Solution

	Updating Timezone Information (Daylight Saving Time, DST)
	Symptom
	Problem
	Solution

	Adding or Changing a MIME Type Handler
	Symptom
	Problem
	Solution

	Regional Settings in Sessions
	Symptom
	Problem
	Solution


	Devices
	Monitor
	Touchscreen Calibration
	Touchscreen in Multimonitor Environment
	USB-Powered ASUS Monitor and IGEL OS 11
	Solving Hotplugging Issues with DisplayPort Monitors
	No Sound When Using a DisplayPort Monitor
	Connecting Three DVI Monitors to UD7 with Passive DisplayPort Adapters

	Using a Cherry SECURE BOARD
	Overview
	Prerequisites
	Getting the Cherry SECURE BOARD to Work in Secure Mode
	Getting the Certificates
	Setting Up the Personalization Machine
	Personalizing the Cherry SECURE BOARD
	Setting Up the Endpoints
	Resetting the Cherry SECURE BOARD to Its Original State

	Webcam Redirection and Optimization
	Overview
	General Recommendations
	Citrix
	VMware Horizon
	RDP

	Webcam Information
	Bluetooth Tool
	How to Deploy a Jabra Xpress Package
	Making the Jabra Xpress Package Available for Download
	Configuring the Source URL
	Triggering the Deployment Process

	Connecting Signature Pads
	Using a Kofax / Wacom Signature Pad
	On the Device
	On the VDI Server (Windows)

	Using a StepOver Signature Pad
	With StepOver TCP Client
	With StepOver Signature Pad Channel

	eGK/KVK - Card Reader
	Cherry G80-1502 at the Serial Port
	Cherry ST-2052
	Cherry ST-1503 und G87-1504 (USB)
	Orga 910/920 M
	Orga 6041 L eGK eHealth-BC S
	celectronic CARD STAR / medic2
	celectronic CARD STAR/ memo3

	Using Mobile Device Access
	Environment
	Enabling Mobile Device Access
	Disabling Mobile Device Access
	Mapping a Mobile Device for a Session
	Connecting Your Mobile Device
	Accessing the Mobile Device USB Window from a Session
	Viewing the Files and Directories Locally
	Safely Removing the Mobile Device

	Swapping Function of Mouse Buttons (e.g. When Using an Evoluent Mouse)
	Problem
	SolutionA. To manually analyze the assignment and determine how it needs to be adjusted:

	Using Natural Scrolling (reverse Scrolling Direction)
	Issue
	Problem
	Solution

	Connecting a Serial Barcode Scanner
	Connecting Barcode Scanner via COM Port
	Connecting Barcode Scanner via USB

	Using DriveLock with IGEL Devices
	Issue
	Problem
	Solution

	Restricting the Mounting of Hotplug Storage Devices on IGEL Linux
	Goal:
	Solution:

	When to Use USB Redirection
	Document Purpose
	Best Practices for USB Redirection
	Example: Redirecting a Nuance Powermic (Dictaphone)

	How to Configure USB Access Control
	Enable USB Access Control
	Create a Class Rule
	Create a Device Rule
	Example

	Issues with USB IDs in USB Devices Rules
	Symptom
	Problem
	Solution

	How Can I Fix Touchpad Issues?
	Overview
	Issues and Solutions

	How Do I Configure a Fujitsu PalmSecure Vein Scanner with IGEL OS?
	Environment
	Configuring the BioSec Middleware
	Enabling Passthrough


	Printer
	CUPS: Mapping Local Printer to Citrix or RDP Sessions
	Issue
	Problem
	Solution

	Print Server Configuration
	Prerequisites
	Recommendation
	Instructions

	Installing a Custom CUPS Driver
	Environment
	Issue
	Solution


	UD Pocket
	Running IGEL OS from UD Pocket on a Dell WYSE ZX0D (aka 7010) Device
	Running UD Pocket on an Acer Chromebook C910
	Enabling Your Device to Boot from UD Pocket

	UD Pocket Seems to Break Microsoft Surface
	Tested Environment
	Issue
	Solution

	How to Boot from the UD Pocket on Mac mini, MacBook Air 2018, MacBook Pro
	Environment
	Problem
	Solution


	Miscellaneous
	Sending Device Log Files to IGEL Support
	With UMS
	Without UMS

	Exporting the Local Device Configuration
	Issue
	Solution

	Which Unified Communication Solutions Does IGEL OS Support?
	Hardware
	Virtual Desktop Optimizations
	Local Installation on the Endpoint Device with a Custom Partition

	Passthrough Authentication
	Introduction
	Basic configuration
	Session Configuration

	Hardware Video Acceleration on IGEL OS
	Question
	Answer

	Running Commands before or after a Session
	Copy Sessions in Setup or UMS
	IZ1 and UD2-MM Usage of RAM
	Using Symantec Ghost to Deploy IGEL OS
	Topic of discussion/Issue
	Firmware version
	UMS version
	Description
	Solution

	Starting UMS Console Crashes NX Session
	Accessing IGEL Setup within Appliance Mode
	Symptom
	Problem
	Solution

	Application Is Terminated with Message "Low memory! Killing process ..."
	Symptom
	Environment
	Problem 
	Solution

	An Application Window Cannot Be Repositioned
	Symptom
	Problem
	Solution

	Updating IGEL UMD: Error "not compatible with System5"
	Symptom
	Solution

	IGEL Endpoint Partners: Ensuring Image Integrity with a Checksum
	Overview
	Requirements
	Instructions

	Will My Session Be Closed When My IGEL OS Endpoint Device Enters Suspend Mode?
	Session Disconnection on Suspend
	IGEL Environment
	Avoiding Possible Issues
	Configuring Suspend Mode

	Microsoft Remote Desktop Client: Comparison of IGEL OS with Other Vendors
	IGEL OS Third Party Integrations


