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UDC3 Reference Manual

UDC3 Reference Manual

() Forrolling out UDC3 via the IGEL Deployment Appliance, you need to have installed Deployment
Appliance version 4.1.

General Information (see page 4)

+ Devices Supported by UDC3 and UD Pocket (see page 5)
Licensing (see page 11)

Installation (see page 12)
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General Information

The IGEL Universal Desktop Converter (UDC3) software allows the migration of existing PC and thin client hardware
to create a functionally standardized IGEL Universal Desktop thin client infrastructure. In the process, the existing
operating system is replaced by IGEL Universal Desktop Linux. The devices can then be administered via the IGEL
Universal Management Suite (UMS).

© Installing the IGEL Linux operating system via UDC3 destroys all data on the target device’s mass storage
device (hard disk, flash memory, SSD).

This manual describes installation using UDC3. The installed system corresponds to IGEL Linux 10 and is described
in detail in the IGEL OS Reference Manual manual.
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Devices Supported by UDC3 and UD Pocket

Core Requirements

+ CPU with 64-bit support

+ CPUspeed:>1GHz
Memory (RAM): = 2 GB

@ With devices that have 2 GB RAM and shared video memory, a maximum of 512 MB may be

used as video memory.

Storage: =22 GB

+ NoVIA graphic adapter; VIA graphics support is discontinued in UDC3.

Devices Officially Supported by UDC3 and UD Pocket with IGEL OS 10

() Forsome of the devices listed here, Flash memory must be extended to = 2 GB. For these devices, an
appropriate note is added.

Acer

Name

Vertion N2110G

Advantech

Name

POC-W213
POC-W243

IGEL OS Creator

64-bit

yes

64-bit

yes

yes

Memor Storage

y
(RAM)

16GB 8GB

Memor Storage

y

(RAM)

4GB 128GB
4GB 128GB

Processor

AMD G-T56N

Processor

Intel Core i7-6600U
Intel Core i7-6600U

Supported from
IGEL OS version

10.01.100

Supported from

IGEL OS version

10.03.210
10.03.210
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Advantech-DLoG

Name

DLT-V6210
DLT-V7210
DLT-V7210 K
DLT-V7212

Dell / Wyse

Name

(AiO)* (see page 10) 5040

(=5212)
D10D
D50D
Z50D
790Q7
790QQ7
3040
5060
5070

Optiplex 9020
Latitude E6440

IGEL OS Creator

64-bit

yes
yes
yes

yes

64-bit

yes

yes
yes
yes
yes
yes
yes
yes

yes

yes

yes

Memor

y
(RAM)

4GB
4GB
4GB
4GB

Memor

(RAM)
2GB

2GB
2GB
2GB
4GB
4GB
2GB
4GB
8GB

8 GB
8 GB

Storage

32GB
4GB
4GB
4GB

Storage

2GB

2GB
8 GB
2GB
16 GB
16 GB
8GB
8GB
32GB

320GB
500 GB

Processor

Intel Atom

Intel Atom E3845
Intel Atom E3845
Intel Atom E3845

Processor

AMD G-T48E

AMD G-T48E

AMD G-T48E

AMD G-T56N

AMD GX-420CA

AMD GX-415GA

Intel Atom x5-Z8350
AMD GX-424CC

Intel Celeron J4105
1,5 GHz

Intel Core i5-4590S
Intel Corei5-4300M

Supported from
IGEL OS version

10.02.120
10.01.100
10.03.210
10.01.100

Supported from
IGEL OS version

10.04.270

10.01.100
10.01.100
10.01.100
10.01.100
10.01.100
10.04.270
10.01.100
10.05.500

10.06.130
10.06.130
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Fujitsu

Name

Futro S720
Futro S920
Futro X913

Futro X923

HP

Name

t520
t530

t610

t620

T630

t730

t820

EliteDesk 800 G3
EliteDesk 800 G3 mini
EliteDesk 800 G1 SFF
HP EliteBook 840 G3
Compagq Elite 8300

IGEL OS Creator

64-bit

yes
yes

yes

yes

64-bit

yes

yes

yes

yes
yes
yes
yes
yes
yes
yes
yes

yes

Memor

y
(RAM)

2GB
2GB
2GB

2GB

Memor

(RAM)
8GB
4GB

2GB

16 GB
4GB
16 GB
16 GB
8 GB
8 GB
4GB
16 GB
8 GB

Storage

2GB
2GB

Prozessor

AMD GX-222GA
AMD GX-415GA

=2 GB (Flash AMD G-T44R

extension
might be
necessary)

2GB

Storage

8GB
8 GB

AMD GX-415 GA

Processor

AMD GX-212JC

AMD GX-215JJ Dual-
Core

>2 GB (Flash AMD T56N APU

extension
might be
necessary)

8 GB
8 GB
8GB
16 GB
128 GB
256 GB
128 GB
256 GB
500 GB

AMD GX-217GA APU
AMD GX-420GlI

AMD RX-427BB APU
Intel Core i5-4570S
Intel Core i3 -i7

Intel Core i5-7500
Intel Core i5-4570
Intel® Core™ i7-6500U
Intel Core i5-3470

Supported from
IGEL OS version

10.01.100
10.01.100
10.01.100

10.01.100

Supported from
IGEL OS version

10.01.100
10.05.570

10.01.100

10.01.100
10.04.270
10.01.100
10.01.100
10.05.812
10.05.812
10.06.130
10.06.130
10.05.812
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Intel

Name

Compute Stick
STK2m3We4CC

NUC 5i5MYBE
NUC 5i3RYH
NUC 7CJYH

Lenovo

Name

ThinkCentre M700
Tiny M600

LG

Name 64-bit

(AiO)* (see page yes
10) 24CK550N

(AiO)* (see page yes
10) 24CK550W

CK500W yes

IGEL OS Creator

64-bit

y
(RAM)

yes 4GB

2GB
2GB
2GB

yes
yes

yes

64-bit

y
(RAM)

4GB
4GB

yes

yes

Memory
(RAM)
4GB
4GB

4GB

Memor Storage

64 GB

32GB
2GB
4GB

Memor Storage

500 GB
500 GB

Storage

32GB

32GB

32GB

Processor

Intel Core m3-6Y30

Intel i5-5300U
Intel i3-5010U
Intel Celeron J4005

Processor

Intel Core i3-6100T
Intel Pentium N3700

Supported from
IGEL OS version

10.02.120

10.04.270
10.04.270
10.04.270

Supported from

IGEL OS version

10.01.100
10.03.210

Processor Supported from IGEL
OS version

AMD G-Series 10.04.270

GX-212JJ

AMD G-Series 10.04.270

GX-212JJ

AMD G-Series 10.05.500

GX-212JJ
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Onyx Healthcare

Name 64-bit Memor Storage Processor Supported from
y IGEL OS version
(RAM)
Venus 222 yes 4/8 GB =2 GB (Flash Intel Celeron J1900  10.01.100
extension
might be
necessary)
Venus 223 yes 4GB 128GB Intel Quad-Core J1900 10.05.500
Secunet
Name 64-bit Memor Storage Processor Supported from
y IGEL OS version
(RAM)
SINA Workstation S yes 16GB 256 GB Intel Core i7-6700 10.03.500

EliteDesk 800 G2

Stone

Name 64-bit Memor Storage Processor Supported from
y IGEL OS version
(RAM)

N130 Notebook yes 8GB  750GB Intel Core i7-6700 10.01.100

Toshiba

Name 64-bit Memor Storage Processor Supported from
y IGEL OS version
(RAM)

Portegé X20W-D yes 8GB 256 GB Intel Core i5-7200U 10.03.210

Portegé X30-D yes 8GB  256GB Intel Core i5-7300U 10.03.210

Tecra C50 yes 4GB 500GB Intel i5-4210U 10.04.270

Tecra Z50-D yes 8GB 256 GB Intel Core i5-7200U 10.03.210

SATELLITE R50 yes 4GB 500GB Intel i3-6006U 10.04.270
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*Ai0O=Allin One

IGEL OS Creator 10/54



UDC3 Reference Manual

Licensing

UDC3 licensing is based on a subscription model. For further information, see Maintenance. For general
information, see IGEL Software License Overview.

You can distribute licenses for UDC3 to the devices using the IGEL Universal Management Suite (UMS). For
instructions on license deployment, see Licensing UDC3.
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Installation

() IGEL OS 11 Technical Preview

If you are looking for instructions on installing IGEL OS Technical Preview, please refer to this document:
IGEL OS Creator Manual-v6-20190123_112305.pdf

« Installation Requirements (see page 13)

» Create USB installation medium (Windows) (see page 14)
+ Create USB installation medium (Linux) (see page 17)

+ Create DVD installation medium (see page 19)

+ Boot settings (see page 20)

« Installation procedure (see page 21)

+ Installation Procedure for Factory Images (see page 23)
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Installation Requirements
In order to install the IGEL OS operating system via UDC3, the target device must meet the following requirements:

+ 64-bit-capable CPU

« CPUspeed=1GHz

+ Atleast 2 GB RAM

+ At least 2 GB mass storage space: hard disk, flash memory, SSD, eMMC or NVME.

+ Intel, ATI/AMD or Nvidia graphics chip
For information about supported graphics chipsets, see the IGEL Linux 3rd Party Hardware
Database!.

« USB 3.0 or 2.0 port from which the device can boot (alternatively a DVD drive)

+ Ethernet or wireless adapter

() Ifthese requirements are not fulfilled, the full functionality of the device with IGEL OS can not be
guaranteed, and technical support will not be provided by IGEL.

© Installing the IGEL Linux operating system via UDC3 destroys all data on the target device’s mass storage
device (hard disk, flash memory, SSD).

1 https://www.igel.com/linux-3rd-party-hardware-database/
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Create USB installation medium (Windows)

1. Download the Zip archive for UDC3 from our download server?:
« For new devices, use the standard installer.
+ Forolder devices or if you haven't been able to boot the installer at all (e.g. on Dell Wyse
DxO0D), use the legacy installer.
2. Unzip its contents into a local directory.
3. Connect a USB memory stick with at least 2 GB capacity to the computer.

© All existing data on the USB memory stick will be destroyed.

4. Double-clickthe preparestick.exe filefrom the unzipped directory (for IGEL Linux 10.01:

UDC2Stick.exe with similar operation).

@ Ifyou arein the "administrators" group, the program will start after you have confirmed a
dialog. If you are not in the "administrators" group, you must enter the administrator
password to start the program.

iy preparestick EI'E'@

File  View Help

Source

Isofile: | C:hUsers'elchDownloads®3.2.0.0hwdc10.02.100.s0 v]
Destination

Destination LISE-Stick: |G:\UDC3 -|

Start writing process

Progress of creating Bootstick

The dropdown-menu Isofile shows the ISO files contained in the unzipped directory.
5. Under Isofile, select the file udc[version].1iso,forexample, udcl0.02.120.17so0

2 https://www.igel.com/software-downloads/
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IGEL

6. Under Destination USB stick, select the USB storage medium on which you would like to save the

installation data.

© Itisrecommended that you only have one USB storage medium connected during this
procedure. If you accidentally select the wrong medium, all data on it will be lost.

@ Generally speaking, the list of available USB storage media is refreshed automatically. If,
however, you would like to refresh it manually, click on View > Refresh USB Device List.

7. Click on Start writing process.

In the program window, the progress of the process is shown.

File  View Help

Source
lscfile: | C:A\UsershelchDownldads'2.2.0.0dc10.02. 10050

Destination

Destination USB-Stick: |G UDC3

Progress of creating Bootstick

i preparestick E' =] @

Copying ..

When the process is finished, a message window is displayed.

Information @

:I Duplication process complete !

8. Close the message window and the program.
9. After about 3 seconds, remove the USB memory stick.

IGEL OS Creator
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|

IGE

A

r

© If youremove the USB memory stick immediately, there is a possibility that the writing
process has not been completed. In this case, the data on the memory stick gets
corrupted.
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Create USB installation medium (Linux)

1. Download the Zip archive for UDC3 from our download server?:
« For new devices, use the standard installer®.
+ Forolder devices or if you haven't been able to boot the installer at all (e.g. on Dell Wyse
Dx0D), use the legacy installer®,
2. Unzip the contents of the Zip archive into a local directory, either with a graphical tool or with the

unzip command.
From this directory, you will need the udc10.02.120.9so (or

udcl0.02.120_legacy.iso) fileto create abootable medium.
3. Connect a USB memory stick with at least 2 GB capacity to the computer.

© All existing data on the USB memory stick will be destroyed.

4. Open aterminal emulator and enter the command dmesg to determine the device name of the

USB memory stick.
Example output:

[...]

[19514.742229] scsi 3:0:0:0: Direct-Access JetFlash Transcend 8GB
1100 PQ: O ANSI: 6

[19514.742805] sd 3:0:0:0: Attached scsi generic sgl type 0
[19514.744688] sd 3:0:0:0: [sdb] 15425536 512-byte logical blocks:
(7.89 GB/7.35 GiB)

[19514.745370] sd 3:0:0:0: [sdb] Write Protect is off
[19514.745376] sd 3:0:0:0: [sdb] Mode Sense: 43 (0) 00 00 00
[19514.746040] sd 3:0:0:0: [sdb] Write cache: enabled, read cache:
enabled, doesn't support DPO or FUA

[19514.752438] sdb: sdbl

In this example, the device name searched foris /dev/sdb .

O Ensurethat you have determined the correct device name. Use of the dd command in
the next step can destroy your operating system if you use the wrong device name.

3 https://www.igel.com/software-downloads/
4 http://myigel.biz/index.php?dir=IGEL_UNIVERSAL_DESKTOP_CONVERTER/UDC3_Stick_V10/
5 http://myigel.biz/index.php2dir=IGEL_UNIVERSAL_DESKTOP_CONVERTER/UDC3_Stick_V10/legacy/
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5. The following command writes the installation data to the USB memory stick:
dd if=udcl10.02.120.1iso of=/dev/sdX bs=1M oflag=direct

Replace sdX with the device name of the USB memory stick that you have determined.

When the dd command has terminated, you can see the terminal emulator input prompt again.
6. Wait for about 3 seconds after the dd command has terminated, and remove the USB memory

stick.

© If youremove the USB memory stick immediately, there is a possibility that the writing
process has not been completed. In this case, the data on the memory stick gets
corrupted.

The USB memory stick for UDC3 installation is ready for use.
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Create DVD installation medium

The udcl0.02.120.179s0 (or udcl0.02.120_Tlegacy.iso) fileintheinstallation directory for UDC3isa

so-called hybrid image. It can not only be copied onto USB storage devices but can also be used to create a
bootable DVD.

Burn ISO image (Windows)

1. In Explorer, open the directory that contains the ISO file.
2. Right-clickonthe ISOfile.
3. Select Burn disc image.

B udc10.01, iiffnen 7] Wirtual CloneDrive 1.454,480 KB

) Suche mit OfficeScan

CifFren mit [ == Mount Files with Yirtual CloneDrive

8 ‘/indows-Erenner Fiir Datentragerabhilder

Image Datei laden (Mirtual Clonelrive E:

ity e e e e Standardprogramm auswablen. ..

Yorgangerversionen wiederherstelen

Burn ISO image (Linux)
Under Linux, various burning programs with a graphical user interface or for the command line are available.

The Ubuntu Wiki® explains how to burn an ISO image onto a DVD using a number of programs.

6 https://help.ubuntu.com/community/BurninglsoHowto
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Boot settings
UDC3 works on systems with BIOS and UEFI.

It is essential that your system supports booting from USB storage media. This may already be enabled, or you may
have to enable it yourself. The required key presses for this may vary from vendor to vendor. However, here are
some hints:

» While the device is booting, try pressing [F12] (in general), [F10] (Intel devices) or [F9] (Hewlett-Packard devices)
in order to access a list of boot devices and select your USB installation medium.

» |f the above does not work, access the BIOS settings via pressing [Del], [F1] or [F2] during boot and activate
booting from USB storage media and/or change the boot order.

> Seethe BIOS/UEFI documentation for your system for details of how to boot from USB storage media.

() Asof version 10.04.100, IGEL Linux supports UEFI Secure Boot. Refer to the manual of your device's
manufacturer to learn whether your device supports Secure Boot and how to enable it. Enabling Secure
Boot often consists of two steps. First, the boot mode has to be changed to UEFI Boot in the BIOS; after
that, Secure Boot can be activated, also in the BIOS. How to check whether Secure Boot has been properly
enabled you can learn here.

() IfuDC3 fails to boot in UEFI mode, try it in legacy/BIOS mode. IGEL Linux will then be installed in legacy/
BIOS mode.

(@ Forolderdevices orif you haven't been able to boot the installer at all (e.g. on Dell Wyse Dx0D), use the
legacy installer’.

7 http://myigel.biz/index.php?dir=IGEL_UNIVERSAL_DESKTOP_CONVERTER/UDC3_Stick_V10/legacy/
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Installation procedure

1. Connect the prepared USB memory stick to the target device and switch the target device on.
2. Select one of the following options from the boot menu:

UDC installation: Boots the system with just a few messages from the USB memory stick
and launches the installation program. (Default)

UDC installation (verbose): Boots the system from the USB memory stick and shows the
Linux boot messages in the process.

UDC Installation (Vesa only): Fallback mode to be used if the graphical boot screen cannot
be displayed.

Memtest86+: Memory test, only available in legacy/BIOS mode. This option does not carry
out an installation.

EFI debug shell: Available only in UEFI boot mode. If the hardware in use is EFl capable,
boot problems can be analyzed with that.

3. Choose your language: Select the language for the installation process.

4. Confirm the license agreement (up to IGEL Linux 10.03.100) resp. accept the EULA (from IGEL
Linux 10.04.100 onwards)

5. Installation program: Here, you can configure settings for the installation process and start it.
Check the target drive to ensure that the system is installed on the desired drive.

© Theinstallation will destroy all existing data on the target drive.

The following options are available:

Force legacy installation (only available after UEFI boot)
The legacy/BIOS version of IGEL Linux will be installed, even if the system was booted in
UEFI mode.

@ Remember to set the system to legacy/BIOS mode after installation.

L1 UEFI booting results in a UEFI installation, and legacy/BIOS booting in a legacy/BIOS
installation. (Default)

Force MS-DOS partitioning during installation

M Use a MS-DOS partition table instead of a GPT partition table.

0 Use a GPT partition table. (Default)

Migrate old settings

Carries over the settings from a previously installed IGEL Linux 10 system. (Default)
Edit: Open the IGEL setup where you can configure settings for the system to be installed.
Reset: Resets all changes to the setup made with Edit.

Install firmware: Starts the installation process.

Cancel: Cancels configuration for the installation and shuts down the device.

6. Click on Install firmware.
The installation program will set up IGEL Linux on the target drive. If you see the IGEL Universal
Desktop Converter build finished successfully message, the installation is complete.

7. Detach any external network adapters from the device.
In this way, you ensure that the unit ID for the device is derived from the built-in network adapter.

IGEL OS Creator
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IGEL

The unit ID will be saved on the device persistently, regardless of any external network adapter
that may be used in the future. This is important for licensing.
8. Click on Reboot at the bottom of the installation window.
9. Remove the USB memory stick.
10. Close the message window.
The system will shut down and then boot IGEL Linux.
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Installation Procedure for Factory Images

© Theinstallation will overwrite all existing data on the target drive. ]

Preparing the Image

1. Connect the prepared USB memory stick to the target device and switch on the target device.
2. Select Standard Installation + Recovery or Verbose Installation + Recovery.

Standard Installation + Recovery
Verbose Installation + Recovery

Failsafe Installation + Recovery

Memory Test
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3. Select the language for the installation process.
IGEL OS Creator

Please choose your language.

English -

The installation program IGEL OS Creator opens. Here, you can configure settings for the
installation process and start it.

4. Optional; only available if your device has booted in UEFI mode: If you want to install the legacy/
BIOS version of IGEL OS 11, activate Force Legacy Installation.

@ Ifyou have activated Force Legacy Installation, remember to set the system to legacy/
BIOS mode after installation.

IGEL OS Creator

ATTENTION: The contents of the target drive will be
o DESTROYED! Please backup all your data before you proceed
with the installation.

Installation Options

Force Legacy Installation - Target drive VMware_ Virtual_disk

Firmware IGEL 05 11 11.05.120
Force MS-DOS Partitioning - o . - -
Unknown hardware (limited driver support). Click on this
Hardware

. message for more details.
€ Feature Selection 4

39 of 39 feature ected

Thank you for choosing IGEL Technology!
You are about to install IGEL OS, the next-gen edge OS for cloud workspaces. After installation is
complete, you will have a fully working secure IGEL Workspace.

Initial Settings
2 You will be able to use your IGEL device unrestricted for the next 30 days. To take advantage of our
v . enhanced features, like multimedia codecs and hardware acceleration, be sure to register your IGEL
0S when you first boot your device. By registering, we’ll also extend your evalution period to 90 days.

Learn more about getting started with IGEL Technology at https:/fkb.igel.com/gettingstarted

T Reset

Migrate Old Settings

Migrate Lice

Factory Image
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IGEL

5. Optional; only available if your device has booted in UEFI mode: If you want to use an MS-DOS

partition table instead of a GPT partition table, activate Force MS-DOS Partitioning.
IGEL OS Creator

ATTENTION: The contents of the target drive will be
o DESTROYED! Please backup all your data before you proceed
with the installation.

Installation Options

Force Legacy Installation - Target drive VMware_ Virtual_disk
Firmware IGEL 05 11 11.05.120
Force MS-DOS Partitioning - o ; ; -
Unknown hardware (limited driver support). Click on this
Hardware

- i .
@ Feature Selection message for more details

39 of 39 featun

Thank you for choosing IGEL Technology!
You are about to install IGEL OS, the next-gen edge OS for cloud workspaces. After installation is
complete, you will have a fully working secure IGEL Workspace.
Initial Settings

2 You will be able to use your IGEL device unrestricted for the next 30 days. To take advantage of our
enhanced features, like multimedia codecs and hardware acceleration, be sure to register your IGEL

Migrate Old Settings 0S when you first boot your device. By registering, we’ll also extend your evalution period to 90 days.

QEdit Learn more about getting started with IGEL Technology at https:/fkb.igel.com/gettingstarted
B Reset
Migrate Licen

¥ Progress details
Factory Image
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6. Activate Factory Image and enter your factory ID.
IGEL OS Creator

ATTENTION: The contents of the target drive will be
o DESTROYED! Please backup all your data before you proceed
with the installation.

Installation Options

Force Legacy Installation Target drive VMware_ Virtual_disk

- Firmware IGEL 05 11 11.05.140

Force MS-DOS Partitioning

Hardware Unknown hardware (limited driver support). Click on this

- i .
@ Feature Selection message for more details
a4 e

3
) feat = Thank you for choosing IGEL Technology!

You are about to install IGEL OS, the next-gen edge 0OS for cloud workspaces. After installation is
complete, you will have a fully working secure IGEL Workspace.

Initial Settings : ; ;
You will be able to use your IGEL device unrestricted for the next 30 days. To take advantage of our
enhanced features, like multimedia codecs and hardware acceleration, be sure to register your IGEL
0S when you first boot your device. By registering, we’ll also extend your evalution period to 90 days.

Learn more about getting started with IGEL Technology at https:/fkb.igel.com/gettingstarted

Migrate Licen v .

Factory Image
u 9 ¥ Progress details

ctory ID for Factory Image =][2)

Enter Factory ID to enable the production of a standard IGEL
05 factory image.
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7. Check the Target drive to ensure that the system is installed on the desired drive.
IGEL OS Creator

DESTROYED! Please backup all your data before you proceed

u ATTENTION: The contents of the target drive will be
with the installation.

Installation Options

Force Legacy Installation - [Target drive VMware_VirtuaI_disk]
Firmware IGEL 0511 11.05.140
Force MS-DOS Partitioning - o ; ; -
Unknown hardware (limited driver support). Click on this
Hardware

- i .
@ Feature Selection message for more details

39 of 39 feat ected

Thank you for choosing IGEL Technology!

You are about to install IGEL OS, the next-gen edge 0OS for cloud workspaces. After installation is
complete, you will have a fully working secure IGEL Workspace.
Initial Settings
2 You will be able to use your IGEL device unrestricted for the next 30 days. To take advantage of our
enhanced features, like multimedia codecs and hardware acceleration, be sure to register your IGEL
0S when you first boot your device. By registering, we’ll also extend your evalution period to 90 days.

QEdit Learn more about getting started with IGEL Technology at https:/fkb.igel.com/gettingstarted

Factory Image
u 9 ¥ Progress details

8. If you want to exclude features of IGEL OS, e.g. to save storage space, click Feature Selection and
edit the settings as required.
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IGEL OS Creator

ATTENTION: The contents of the target drive will be
DESTROYED! Please backup all your data before you proceed
with the installation.

Installation Options

Firmware IGEL 05 11 11.05.140

tion - Target drive VMware_ Virtual_disk
Force MS-DOS Partitioning -

Hardware

- i .
@ Feature Selection message for more details

cted Thank you for choosing IGEL Technology!

You are about to install IGEL OS, the next-gen edge 0OS for cloud workspaces. After installation is
complete, you will have a fully working secure IGEL Workspace.

You will be able to use your IGEL device unrestricted for the next 30 days. To take advantage of our
enhanced features, like multimedia codecs and hardware acceleration, be sure to register your IGEL
0S when you first boot your device. By registering, we’ll also extend your evalution period to 90 days.

Learn more about getting started with IGEL Technology at https:/fkb.igel.com/gettingstarted

Factory Image
u 9 ¥ Progress details

er first boot

IGEL OS Creator 28 /54



UDC3 Reference Manual

Feature Selection

Q Disk size 17.2 GB, firmware size 2.7 GB

Select the set of features to be installed on the target device.

m Total size of all features: 1.9 GB

Install | Feature

Citrix ICA 301.7 MB
Imprivata 273.4 MB
Local browser (Chromium) 198.7 MB
VMware Horizon 137.6 MB
Local Browser (Firefox) 133.7 MB
NVIDIA graphics driver 132.9 MB
windows Virtual Desktop Client (WvD) 93.6 MB
IBM i Access Client Solutions 76.0 MB
VirtualBox 66.8 MB
Cisco JVDI client 64.7 MB
Zoom VDI 49.5 MB

Cisco Webex Teams VDI 45.9 MB

+ All: Select all features

+ None: Select no feature

+ Feature: Sort the list alphabetically

Size: Sort the list by the memory requirements of the features
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9. If you want to change initial settings for the devices you are about to deploy, click Edit.
IGEL OS Creator

ATTENTION: The contents of the target drive will be
o DESTROYED! Please backup all your data before you proceed
with the installation.

Installation Options

Force Legacy Installation - Target drive VMware_ Virtual_disk

Firmware IGEL 05 11 11.05.140
Force MS-DOS Partitioning - o ; ; -
Unknown hardware (limited driver support). Click on this
Hardware

- i .
@ Feature Selection message for more details

39 of 39 feature ected

Thank you for choosing IGEL Technology!

You are about to install IGEL OS, the next-gen edge 0OS for cloud workspaces. After installation is
complete, you will have a fully working secure IGEL Workspace.

Initial Settings : ; ;

You will be able to use your IGEL device unrestricted for the next 30 days. To take advantage of our
enhanced features, like multimedia codecs and hardware acceleration, be sure to register your IGEL
0S when you first boot your device. By registering, we’ll also extend your evalution period to 90 days.

QEdit Learn more about getting started with IGEL Technology at https:/fkb.igel.com/gettingstarted

Factory Image v .

Reset after first boot -

¥ Progress details

The IGEL Setup opens, enabling you to change the settings in the same way as with a regular IGEL
OS installation. The changes are stored on the USB memory stick from which the IGEL OS Creator
(OSC) is executed. For details about the settings, see the chapters Setup and the subsequent
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chapters in the IGEL OS Reference Manual.
IGEL Setup 11.05.140 (Build 6.7.5)

Language

Time and Date

LAM Interfaces

update

Search

ya o 9, IGEL Setup 11.05.140 (...
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10. If you want to undo your changes and restore the original settings, click Reset.

ATTENTION: The contents of the target drive will be
o DESTROYED! Please backup all your data before you proceed

with the installation.

Installation Options

Force Legacy Installation - Target drive VMware_ Virtual_disk
Firmware IGEL OS5 11 11.05.140
Force MS-DOS Partitioning - _ )
Unknown hardware (limited driver support). Click on this
Hardware

. message for more details.
€ Feature Selection - I -

39 of 39 feature ected

Thank you for choosing IGEL Technology!

You are about to install IGEL OS, the next-gen edge 0OS for cloud workspaces. After installation is
complete, you will have a fully working secure IGEL Workspace.

Initial Settings
2 You will be able to use your IGEL device unrestricted for the next 30 days. To take advantage of our

e Conbhi e - enhanced features, like multimedia codecs and hardware acceleration, be sure to register your IGEL
< IERE 0S when you first boot your device. By registering, we’ll also extend your evalution period to 90 days.

Learn more about getting started with IGEL Technology at https:/fkb.igel.com/gettingstarted

Factory Image v .

Reset after first boot -

11. If you want to change some device settings after the first boot for functional testing, enable Reset
after first boot. These changes will not be persistent; after the second boot, the image will be
restored to its initial state.

A Important Note

If Reset after first boot is activated in your factory preload image, the first boot of your devices
MUST take place BEFORE shipment to end customers!
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IGEL OS Creator

ATTENTION: The contents of the target drive will be
DESTROYED! Please backup all your data before you proceed
with the installation.

Installation Options

Firmware IGEL 05 11 11.05.140

tion - Target drive VMware_ Virtual_disk
Force MS-DOS Partitioning -

Hardware

- i .
@ Feature Selection message for more details

cted Thank you for choosing IGEL Technology!

You are about to install IGEL OS, the next-gen edge 0OS for cloud workspaces. After installation is
complete, you will have a fully working secure IGEL Workspace.

You will be able to use your IGEL device unrestricted for the next 30 days. To take advantage of our
enhanced features, like multimedia codecs and hardware acceleration, be sure to register your IGEL
0S when you first boot your device. By registering, we’ll also extend your evalution period to 90 days.

Learn more about getting started with IGEL Technology at https:/fkb.igel.com/gettingstarted

Factory Image
u 9 ¥ Progress details

er first boot
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12. Tostart theinstallation, click Install firmware.
IGEL OS Creator

ATTENTION: The contents of the target drive will be
o DESTROYED! Please backup all your data before you proceed
with the installation.

Installation Options

Target drive VMware_ Virtual_disk
Firmware IGEL OS5 11 11.05.140

Unknown hardware (limited driver support
message for more details.

Hardware

Thank you for choosing IGEL Technology!

You are about to install IGEL OS, the next-gen edge 0OS for cloud workspaces. After installation is
complete, you will have a fully working secure IGEL Workspace.

Initial Settings _ ) )
You will be able to use your IGEL device unrestricted for the next 30 days. To take advantage of our
enhanced features, like multimedia codecs and hardware acceleration, be sure to register your IGEL
0S when you first boot your device. By registering, we’ll also extend your evalution period to 90 days.

Learn more about getting started with IGEL Technology at https:/fkb.igel.com/gettingstarted

T Reset

Factory Image

¥ Progress details

13. Confirm the warning dialog.

Warning!

All the data on the disk will be destroyed.
Are you sure you want to continue the installation?

Boot partition found.
Target structure looks like Linux.

More info .
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IGEL OS Creator

The production of a standard IGEL OS factory image on your
targeted drive was successfully completed.
Installation Options

Target drive VMware_ Virtual_disk
Firmware IGEL OS5 11 11.05.140

Unknown hardware (limited driver support). Click on this
Hardware -
— ) message for more details.
Feature Selection

39 of 39 featur ected Thank you for choosing IGEL Technology!

You can use your IGEL device unrestricted for the next 30 days. To take advantage of our enhanced
features, like multimedia codecs and hardware acceleration, be sure to register your IGEL 0OS when
Initial Settings you first boot your device. By registering, we’ll also extend your evalution period to 90 days.

Learn more about getting started with IGEL Technology at https://kb.igel.com/gettingstarted

@ Edit

T Reset

¥ Progress details

The installation program will set up IGEL OS 11 on the target drive. If you see the success message,
the installation is complete.
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14. Click on Shutdown.
IGEL OS Creator

The production of a standard IGEL OS factory image on your
targeted drive was successfully completed.
Installation Options

Target drive VMware_ Virtual_disk
Firmware IGEL OS5 11 11.05.140

Unknown hardware (limited driver support). Click on this
message for more details.

Hardware

Feature Selection

39 of 39 feature Thank you for choosing IGEL Technology!

You can use your IGEL device unrestricted for the next 30 days. To take advantage of our enhanced
features, like multimedia codecs and hardware acceleration, be sure to register your IGEL 0OS when
Initial Settings you first boot your device. By registering, we’ll also extend your evalution period to 90 days.

Learn more about getting started with IGEL Technology at https://kb.igel.com/gettingstarted

@ Edit

T Reset

¥ Progress details

15. Read out the image from your device to deploy it on the units.

16. Toensure the integrity of the image, you should create checksums of the original image and of the
images that are deployed, and then compare them. For details, see IGEL Third-party Endpoint
Partners: Ensuring Image Integrity with Checksums (see page 23).

17. Proceed as appropriate:

« If Reset after first boot is inactive, you can deploy the images on the units and roll them
out straight away. The deployment should include comparing the checksums.

« If Reset after first boot has been activated, deploy the images on the units and continue
with Unit Testing (see page 36). (see page 0)

Unit Testing

Perform the following procedure on the original device and on every unit on which the image has been deployed.
& Important Note

The first boot test MUST take place with each unit BEFORE it is rolled out. (Otherwise, the device would
present the green test screen instead of the IGEL Setup Assistant.)
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1. Start the device and review the green test screen.

Info

B 0

2. Click OK.

You can access IGEL OS in a regular way and perform your tests.
3. Shutthe device down.

The device is ready for roll-out.
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UDC 3 How-Tos

« Café Wireless (Wi-Fi) (see page 39)

+ Reduce CPU Power Consumption (see page 43)

+ Installing UDC3 on Secunet SINA Workstation (see page 44)
+ Setting up UDC3 on Mobile Devices (see page 46)
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Café Wireless (Wi-Fi)

When you use your mobile device frequently at different Wi-Fi hotspots, automatic Wi-Fi roaming may be useful.
This is what IGEL Café Wireless does. The IGEL Café Wireless feature can be used, for instance, with IGEL UDC3. After
you have configured your wireless networks, your mobile device is ready to roam.

For optimizing the network switchover, please see Configuring Wi-Fi Network Roaming.
If the network's SSID is hidden, see Connecting to a Wi-Fi Network with Hidden SSID.

See also the manual chapter "Wireless".

To configure a wireless network with the Wireless Manager:

1. Open Network > LAN interfaces > Wireless in the Setup.
2. Enable Activate wireless interface.
3. Activate Enable Wireless Manager.

oy
4, Click the trayicon . and select Manage wireless networks.

[(] more details

Manage wireless networks 3

< \Y

The Wireless networks dialog opens. After a few seconds, all wireless networks within reach are
shown, sorted by signal strength. Previously configured connections are flagged with a tick in the
Configured column. The connection currently active is flagged with a symbol under Connected.

¥ ITGA-GUEST
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SX Q0
Wireless Network Name (SSID) | Configured
UniFi

I BS-GAST

DIRECT-40-HP Officejet 4650
LBS-BST-215

Rennsemmel

ITGA-M

WLAN-04ADE4

TGA-P

E5832-5-d6c7

Quality

44

4499999494

Connected

¥ Close

5. Double-click the network to be configured.

IGEL OS Creator
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Wireless networks

CR 2 G

I BS-GAST

DIRECT-40-HP Officejet 4650
LBS-BST-215

Rennsemmel

ITGA-M

WLAN-04ADE4

TGA-P

449999949494

E5832-5-d6c7

Wireless Network Name (SSID) | Configured Quality Connected =

ITGA-GUEST \/
¥ Close
A dialog named with the name (SSID) of the desired network opens.
UniFi a
Permanently store network key %
Metwork key E
X Cancel v OK

6. Activate Permanently store network key so that your mobile device remembers the network key.

7. Enter the Network key. To have the network key displayed while typing, click

Click OK.
9. Repeat the steps described above for the remaining networks.

o

IGEL OS Creator

Ol

41/54



UDC 3 How-Tos

To connect to a configured network manually:

> Highlight the network and click on P in the Wireless networks dialog.

Wireless networks

[lr xa o

Wireless Metwork Name (SSID) | Configured

ta

Quality Connected

I BS-GAST

DIRECT-40-HP Officejet 4650
LBS-BST-215

Rennsemmel

ITGA-M

WLAN-04ADE4

TGA-P

E5832-5-d6c7

449999949494

TGA-GUEST v

¥ Close

Your mobile device is connected to the wireless network. The icon ' shows the network's current signal

strength.

IGEL OS Creator
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Reduce CPU Power Consumption

Reduce CPU Power Consumption

When you are using the IGEL Universal Desktop Converter (UDC2) on a mobile device in battery mode, you might

want to reduce power consumption. One major power consumer is your CPU.

=
You can easily gain some control over the power consumption of your CPU using the tray icon i&i (CPU Power
Plan) on your taskbar.

» Ifthe tray icon is not displayed, open the IGEL Setup, go to System > Power Options > System and activate
Tray lcon.

To change the CPU power settings:

1. Click on i,

2. Select the appropriate option. High Performance gives you the highest performance, but also the
highest CPU power consumption, Power Saver results in lowest performance and lowest CPU
power consumption. The other options are in between.

For further information about the power plan settings, see the system (see page 43) chapter in the
manual.
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Installing UDC3 on Secunet SINA Workstation

To install IGEL Universal Desktop Converter 3 on a SINA workstation, proceed as follows:

1. Download the UDC3 zip file under IGEL Software Download® and unzip the file.
Copy the ISO image to an USB stick.
Start the SINA workstation
Click Administration > Volumes in the navigation bar.
Click + Add item at the bottom of the screen to add a new item.
Enter a distinct name for the volume in the Name field top right.
The target drive is already specified.
7. Click New CFS under Select volume type.
The form expands.
8. Choose the preconfigured Security domain, Cipher algorithm and Hash algorithm.
9. Click Define Guest system under CFS content.
The form expands.
10. Enter a distinct name for the system under Guest system name.
11. Choose 2 GiB as minimum for the Guest system size.
12. Select Disabled under Quarantine.
13. Click Create.

oA WD

The system will now create the volume. This may take a while - depending on the size of the guest system.

1. Go to Administration > Volumes and click the new volume.
Next to it a little form opens.

2. Open Guest systems.
You will see the volume you've created.

3. Click Local under Add guest system from... to add the ISO image to this volume.
The form expands.

4. Plugthe USB Stick with the ISO image into the workstation.

5. Choose the stick as Device and the ISO image as Guest system image.

6. Click Add at the bottom of the form.

The system now adds the ISO image to your new volume. This will take a while.

1. Switch to the Workplaces menu.
2. Click + Add item at the bottom of the screen.
3. Enter a distinct name for the workplace in the Name field top right.
4. Choose the Guest system you've created. It has a small hard disk icon.
5. Choose the ISO image under Secondary guest system. It should have a small CD icon.
6. Select Secured networking under Network mode.
7. Choose your prefered settings under Display layout, Workplace hotkey and Audio mode.
8. Select CD/DVD under Boot order.
9. Select Automatic reservation under IP to claim and MAC to claim.
10. Select Ubuntu as OS type.
11. Itis not necessary to activate the Detailed settings.

8 https://www.igel.com/software-downloads/
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12. Click Create.
The system now creates the workplace.

1. Klick on the new workplace.

Next to it a little form opens.
2. Click Launch to start the workplace.

The IGEL Universal Desktop Converter starts.
3. After a few second you will see this screen:

F1 Help F2 Language F3 Video Mode

4. Keep the first selected item Boot IGEL UD Converter.
The conversion process starts.
Next you will see the blue IGEL Linux background.
A little popup appears.

5. Choose your desired language.

. Agree the license agreement.

7. Install the IGEL Linux OS to the workspace.

[¢)]

() Beaware, that all data of the volume will be deleted. That’s why you should always create a new
volume for the IGEL Linux OS.
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Setting up UDC3 on Mobile Devices

« Multi Monitor Environment (see page 47)

« Presentation Mode (see page 48)

« Display Brightness (see page 49)

+ Power Management (see page 50)

« Wireless Manager (Café Wireless) (see page 51)

« Shortening Network Timeouts in Mobile Scenarios (see page 52)
+ Battery Level Control (see page 54)

IGEL OS Creator 46 /54



UDC 3 How-Tos

Multi Monitor Environment
If you use your notebook in an office workstation, you can use a multi monitor environment.
To configure the display for multiple screens, use the Display Switch.

Respective Tray Icon:

Tray Icon Name Icon Where to configure
Display Switch Menu path: Setup > Accessories > Display
Switch

Activating the Display Switch:

1. Enable the Display Switch in the IGEL Setup under Accessories > Display Switch.
2. Select Quick Start Panel as a starting method.
The Display Switch icon is shown in the quick start panel.
3. Click theicon to open the display configuration dialogue.
4. Switch between simple and advanced settings.

() Foradetailed description, see the manual, chapter Display Switch.
Here you can find additional instructions concerning monitor settings:

« How-To Multimonitor
« Manual topic RDP Global > Window
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Presentation Mode

You are using your mobile device for a presentation. You neither want the monitor to enter power saving mode nor
to start the screensaver during the presentation.

For this situation, use the Presentation Mode which disables the DPMS and the screen saver.

Respective Tray Icon:

Tray Icon Name Icon Where to configure
Notebook BAT Menu path: Setup > System > Power
Options > Battery

Activating the Presentation Mode:

1. Right-click the battery symbolin the system tray.
The context menu opens:

2. Click Presentation Mode to enable/disable it.
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Display Brightness
In order to preserve the battery you want to reduce the display brightness.

Respective Tray Icon:

Tray Icon Name Icon Where to configure
Notebook BAT Menu path: Setup > System > Power
Options > Battery

1. Right-click the battery symbolin the system tray.
The context menu opens.
2. Click the slider of the brightness display to reduce the Display Brightness.

IGEL OS Creator 49 /54



UDC 3 How-Tos

Power Management
You are using your mobile device in battery mode and need to reduce power consumption to preserve the battery.
To save power, set CPU power options to scale the CPU frequency down.

Respective Tray Icon:

Tray Icon Name Icon Where to configure
CPU Power Plan Menu path: Setup > System > Power
Options > System

Setting CPU power options:

1. Click the CPU Power Plan icon in the system tray.
The context menu opens.

2. Select the appropriate mode.

() Hereyou can find additional instructions concerning the power management:
« Define the CPU Power Plan, Critical Battery Level, Standby Time or Suspend
Time, Brightness reduction, and Shut-down Options. See the manual, chapter System >
Power Option > System.
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Wireless Manager (Café Wireless)
If you are traveling with your notebook, you need to handle different WiFi connections.
You can use Café wireless to configure different wireless network connections.

Respective Tray Icon:

Tray Icon Name Icon Where to configure
Wireless Network Connection Menu path: Setup > Network > LAN
Interfaces > Wireless

Defining Café wireless:

1. Enable the Wireless Manager under Network > LAN Interface > Wireless.
Set all options:

2. Click the WiFi tray icon in the right corner of the panel.
3. Open the Wireless Manager dialog.

(@ You can find the complete instruction in the manual, chapter Wireless Manager.
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Shortening Network Timeouts in Mobile Scenarios

When on the road with their UDC2 mobile device, users often experience slow system startup. This is due to the
system waiting for network connections or the UMS which are not available in the mobile scenario. This document
describes how to minimize waiting by shortening various timeouts.

Don't Wait for Wired Network

When an Ethernet interface is configured but not physically connected, startup is delayed by default. The goal is to
give the user an opportunity to plug in the network cable. If this is not desired, as of IGEL Linux version
5.10.100waiting can be turned off.

1. In Setup, go to System > Registry.

2. Gotothe network.interfaces.ethernet.device[number].nolink_nowait regist

ry key. Replace [number] with:
« 0 forethO, the first Ethernet interface
« 1forethl, the second Ethernet interface
3. Enable No waiting without physical link. By default, this option is disabled.

Don't Contact UMS Unless Specific Network Devices Are Up

Startup is also delayed because the system tries to contact UMS by default, which may not be available in a mobile
scenario. You can configure IGEL Linux version 5.10.100 to contact UMS only if one of the network devicesin a
whitelist is up.

1. In Setup, go to System > Registry.

2. Gotothe system.remotemanager.device_whitelist registrykey.

3. Put aspace-separated device list into the Network device whitelist field. Only if at least one of
these devices is up, the system will try to contact UMS. Device names:

« First Ethernet adapter: eth0

+ Second Ethernet adapter: ethl
+ Wireless: wlan0
+ Mobile broadband: pppl0

» OpenVPN: tun0
Don't Contact UMS Unless Specific Networks Are Available
You can configure IGEL Linux version 5.10.100 to contact UMS only if one of the networks in a whitelist is reachable.

1. In Setup, go to System > Registry.
2. Gotothe system.remotemanager.network_whitelist registry key.

3. Enter a space-separated list of networks in CIDR notation into the Network whitelist input field,
e.g.172.30.0.0/16 192.168.100.0/24. If there are entries in this field, the system will only try to
contact UMS if one of the device's current IP addresses happens to be in one of these ranges.

Shorten the UMS Timeout

When different environments cannot be distinguished by the previous two mechanisms, as of IGEL Linux version
5.10.100 the startup delay can be reduced by setting a shorter timeout for connections to the UMS.

1. In Setup, go to System > Registry.

IGEL OS Creator 52 /54



UDC 3 How-Tos

e

IGE

2. Gotothe system.remotemanager.rmagent_timeout registry key.
3. Enter aninteger number of seconds into IGEL Remote Management Timeout. The default is 90.
Don't Wait for All Network Interfaces

You can configure IGEL Linux to wait only for one of the network interfaces to be up instead of all. This also means
that error messages concerning Ethernet devices will only be displayed shortly.

1. In Setup, go to System > Registry.
2. Gotothe network.global.waitfor_interfaces registry key.
3. Disable Wait for interfaces to come up. By default, this option is enabled.
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Battery Level Control

Since Linux version 10.03.100 it is possible to display the battery level of a mobile device via UMS. The frequency of
the battery level reports sent by the device to the UMS can be adjusted: A report is triggered when the battery status
has changed at a specified percentage compared to the previously reported status. The percentage is specified by
the Battery status update frequency parameter.

Example use case: The IT administrator in a hospital has to take care of battery-powered medical devices. Using the
new feature, he can easily keep track of all these devices via the UMS, without any need of physical access or
mirroring VNC.

To adjust the report frequency:
1. In Setup, go to System > Registry.

2. Gotothe system.remotemanager.battery_report_frequency registry key.

3. Select the Battery status update frequency:
« Often
« Normal
+ Rarely
+ Very Rarely
* Never
4. Click Apply or Ok.
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