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Overview: First Steps with IGEL OS 11

e

IGE

Overview: First Steps with IGEL OS 11

The following article provides a short overview of how to get started with an IGEL device or a third-party device that
you want to convert to IGEL OS. The steps are generally the same, but in the case of a third-party device you will
need to use the IGEL OS Creator.
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Overview: First Steps with IGEL OS 11

IGEL Device
Step 1: Download and install the UMS

IGEL Download Server?

Instruction: Installing an IGEL UMS Server
Video: UMS installation on a Windows Server?
Video: UMS installation on a Linux operating
system?®

Step 2: Activate your IGEL 0S 11

with the Setup Assistant (free
evaluation license):

« Instruction: Setup Assistant for IGEL OS,
section "Register for Demo License". See also
Getting a Demo License.

« Video: Acquire a Demo License Including
Workspace Edition and Enterprise
Management Pack*

via UMS (purchased license):

+ Deploy licenses using automatic or manual
license deployment method.

+ Video: Register an endpoint in the UMS and
assign a license to it

Step 3: Configure your device
with the UMS:

+ Create a profile with the required settings
and assign it to the device. See also Profiles.

+ Video: Configure an endpoint in the UMS
using profiles®

without the UMS:

+ Use the IGEL Setup on the device, e.g. to
configure User Interface and Sessions.
+ Video: Configuring an Endpoint with IGEL OS
117
<z IILLIJD.// VVVVVV.yUuLuIJC.\.UIII/ WalLtciiiv=orJdi et yJVV
3 https://www.youtube.com/watch?v=p52CxtB_0ok
4 https://www.youtube.com/watch?v=j31c8dzBMAg
5 https://www.youtube.com/watch?v=01N-9b3P4wo
6 https://www.youtube.com/watch?v=Sc38mRv5Z1s
7 https://www.youtube.com/watch?v=6WfLVgYBTHg
8 https://www.igel.com/software-downloads/workspace-edition/
9 https://www.youtube.com/watch?v=3YJnFiE7y5w
10 https://www.youtube.com/watch?v=p52CxtB_0ok
11 https://www.igel.com/software-downloads/workspace-edition/
12 https://www.youtube.com/watch?v=xVqcX6QTZ5g
13 https://www.youtube.com/watch?v=j31c8dzBMAg
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3d-Party Device

Step 1: Download and install the UMS

IGEL Download Server®

Instruction: Installing an IGEL UMS Server
Video: UMS installation on a Windows Server®
Video: UMS installation on a Linux operating
system??

Step 2: Download IGEL OS 11

IGEL Download Server', section 0S 11> 0S
Creator

Step 3: Convert your device to IGEL OS 11

« IGEL OS Creator Manual

Video: Converting an x86-Endpoint Using the
IGEL OS Creator*

Step 4: Activate your IGEL OS 11

with the Setup Assistant (free
evaluation license):

Instruction: Setup Assistant for IGEL OS,
section "Register for Demo License". See also
Getting a Demo License.

Video: Acquire a Demo License Including
Workspace Edition and Enterprise
Management Pack®

via UMS (purchased license):

Deploy licenses using automatic or manual
license deployment method.
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IGEL Device 3d-Party Device

+ Video: Register an endpointin the UMS and
assign a license to it

Step 5: Configure your device
with the UMS:

+ Create a profile with the required settings
and assign it to the device. See also Profiles.

+ Video: Configure an endpointin the UMS
using profiles®

without the UMS:

+ Use the IGEL Setup on the device, e.g. to
configure User Interface and Sessions

+ Video: Configuring an Endpoint with IGEL OS
1116

14 https://www.youtube.com/watch?v=01N-9b3P4wo
15 https://www.youtube.com/watch?v=Sc38mRv5Z1s
16 https://www.youtube.com/watch?v=6WfLVgYBTHg
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Update and Upgrade

IGEL

Update and Upgrade

+ Adapting IGEL OS 11.04 or Higher for Devices with Small Storage (see page 7)

+ Upgrading UDC3 or UD Pocket from IGEL OS 10.06 to IGEL OS 11 via Universal Firmware Update (see
page 10)

« Upgrading from IGEL OS 10 to IGEL OS 11 (see page 65)

« Buddy Update (see page 230)

« Firmware Update (see page 237)

« Updating IGEL OS Using a USB Storage Device (see page 241)

+ Updating the Firmware using the Linux Console (see page 243)

«+ Error: "Not enough space on local drive" when Updating to IGEL OS 11.08 or Higher (see page 246)

« Error: "legacy ICG Root (CA) certificate"” When Updating to Igel OS 11.04 on Devices Connected via
ICG (see page 249)

+ Device Does Not Connect to ICG after Update to IGEL OS 11.04 or Higher (see page 251)

« IGEL OS Automatic Update Service for Device Evaluation (see page 253)
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Update and Upgrade

Adapting IGEL OS 11.04 or Higher for Devices with Small Storage

Environment
This article is valid for the following environment:

+ IGEL OS 11.04 or higher

+ UMS 6.05 or higher (recommended)

+ Endpoint device that is supported by IGEL OS 11.04.100 or higher but the free storage is lesser than
required by the full feature set

Overview

For IGEL OS 11.04.100 or higher with the full feature set, a minimum of 2 GB storage is required. If your device has
less free storage than required, e.g. because of large custom partitions, you can reduce the feature set so that the
firmware fits on your device's storage.

Perform these two steps:

1. Determining Which Features to Deactivate (see page 7)

2. Reducing the feature set by one of the following methods:
+ Using a UMS Profile (see page 7)
+ Using the Preconfigured Reduced INF File (see page 8)
+ Customizing the INF File (see page 8)

Determining Which Features to Deactivate

» Determine the storage requirements of the individual IGEL OS features using one of these methods:

+ Goto IGEL OS Release Notes, select the "Notes for Release" of your firmware version, then select
"Component Versions...", and go to the "Services" section. The "Reduced Firmware" column
indicates for each feature whether it is included in the preconfigured reduced feature set or not.

« Openthe readme[version].txt inyourupdate source directory and search for "Reduced
Firmware".

Reducing the Feature Set

Using a UMS Profile

& Buddy Update Server

When you download a firmware that has been reduced with the UMS (or the device's Setup) on a buddy
update server, the buddy server itself will have the full feature set anyway. Hence, all devices that are used
as update servers must have sufficient free storage.
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IGEL

1. Choose an appropriate profile that is assigned to all relevant devices, or create a new profile. For
further information, see Profile erstellen.

2. Goto System > Firmware Customization > Features and deactivate all features that are not
needed.

Using the Preconfigured Reduced INF File

& Reduced Feature Set Cannot Be Changed by Setup/UMS

When you have reduced the firmware using this method, you cannot reactivate features via the Setup resp.
the UMS configuration dialog. To recover the complete feature set, you must copy lxos-full.inf to

1xos.inf and then start the firmware update.

A Buddy Update Server

When you have downloaded a reduced firmware on a buddy update server, also the buddy server itself has
the reduced feature set. To recover the complete feature set on the buddy server, you must copy 1xos-

full.dinf to 1xos.1inf inthe update source and then update the buddy update server again.

Replace the 1xos.1inf file asfollows:

1. Go to the directory that contains the source files for the firmware update. If you use the WebDav
capability of the UMS, thisis <UMS -installation
directory>\rmguiserver\webapps\ums_filetransfer\<firmware version>;
example: C:\Program
Files\IGEL\RemoteManager\rmguiserver\webapps\ums_filetransfer\IGEL_O
S$_11-11.04.100

2. Delete 1xos.inf
@ Itissafetodelete 1xos.inf because thereisa backup file named 1xos-full.inf

3. Copy lxos-reduced.inf to lxos.1inf
4. Start the firmware update as usual.

Customizing the INF File

A Reduced Feature Set Cannot Be Changed by Setup/UMS

When you have reduced the firmware using this method, you cannot reactivate features via the Setup resp.
the UMS configuration dialog. To recover the complete feature set, you must copy lxos-full.inf to

1xos.inf and then start the firmware update.
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& Buddy Update Server

When you have downloaded a reduced firmware on a buddy update server, also the buddy server itself has
the reduced feature set. To recover the complete feature set on the buddy server, you must copy 1xos-

full.inf to 1xos.1inf inthe update source and then update the buddy update server again.

To customize the INF file:

1. Open 1lxos.inf
2. Inthe [INFO] section, add the following line:
custom="true"
3. Deletethe [PART] section of every partition you want to exclude, but do this ONLY IF the section

has both of the following entries:
dispensable="true"

type="squashfs-auto"

4. Save 1lxos.inf and startthe firmware update as usual.
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Upgrading UDC3 or UD Pocket from IGEL OS 10.06 to IGEL OS 11 via
Universal Firmware Update

This document describes how to upgrade UDC3 or UD Pocket devices from IGEL OS 10.06 to IGEL OS 11 via the
Universal Firmware Update feature of the UMS (Universal Management Suite).

Since a new licensing model has been introduced with IGEL OS 11, a license from an IGEL Workspace Edition
Product Pack must be available for each device. If you have valid maintenance for your devices, you can convert
your existing UDC3 or UD Pocket Product Packs to Workspace Edition (WE) Product Packs; see Converting UDC3 or
UD Pocket Licenses for Upgrading to IGEL OS 11.

Read all the following chapters in the order given and follow the instructions.

Devices That Can Be Upgraded to IGEL OS 11 (see page 11)

Important! Consider This Before Upgrading (see page 25)

Getting the UMS Ready (see page 27)

Deploying the Licenses (see page 28)

Creating the Universal Firmware Update (see page 29)

Creating an Upgrade Profile (see page 40)

Assigning the Upgrade Profile and the Universal Firmware Update to the Test Devices (see page 49)
Testing the Upgrade (see page 53)

Unassigning the Upgrade Profile and the Universal Firmware Update (see page 55)
If Applicable: Restoring Custom Partition and Custom Applications (see page 56)

. Upgrading All Devices (see page 57)

WoeNoOkwWwNE
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Devices That Can Be Upgraded to IGEL OS 11

In this section, you find the general hardware requirements for IGEL OS 11 and a list of third-party devices officially
supported by IGEL OS 11.

@ Partner Solutions for Peripherical Devices

For further supported hardware from IGEL partners, e.g. headsets, see Partner Solutions.

Core Requirements

+ CPU with 64-bit support
+ CPUspeed:>1GHz
« Memory (RAM): =2 GB

() RAMsize higherthan 2 GB is recommended if you use any of the following:
+ Unified Communications optimizations (uses a client-side media engine)
+ High-resolution graphics output
« More than two monitors

() With devices that have 2 GB RAM and shared video memory, a maximum of 512 MB may be
used as video memory.

+ Storage: Depends on the release version of IGEL OS 11. The details are listed below:

« UptoIGEL 0S 11.03: 2 GB minimum; =4 GB recommended

« From IGEL OS 11.04 to IGEL OS 11.07: If the full feature set is applied, at least 2.4 GB of
storage is required. For instructions on how to reduce the feature set, see Error: "Not
enough space on local drive" when Updating to IGEL OS 11.08 or Higher.

+ From IGEL OS 11.08 onwards: If the full feature set is applied, at least 4 GB of storage is
required. For instructions on how to reduce the feature set, see Error: "Not enough space on
local drive" when Updating to IGEL OS 11.08 or Higher.

+ NoVIA graphic adapter; VIA graphics support is discontinued in IGEL OS.
+ Legacy Bios and EFI/UEFI are supported.

Devices Supported by OSC and UD Pocket with IGEL OS 11

& Thefollowing list only includes those devices that are tested by IGEL (with each major release of IGEL OS).
By no means it implies that the devices which are not included in this list but meet the minimum
requirements will not function with IGEL OS: Any x86-64 hardware endpoint device that meets the IGEL-
stated minimum hardware requirements for IGEL OS (for example, the processor speed and RAM) can be
expected to work adequately with IGEL OS and should be considered a candidate for repurposing from
another OS. With an IGEL OS subscription or active maintenance, customers can expect IGEL to make any
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necessary “best effort” to support, regardless of whether the endpoints in question are specifically listed
within the IGEL Knowledge Base or elsewhere (e.g. on the IGEL Ready Showcase at https://www.igel.com/
ready/showcase-categories/endpoints/).

For any devices not listed here or on the IGEL Ready showcase, you can contact your hardware vendor and
request those devices to be added to the IGEL Ready program.

Integrated drivers and supported peripherals are listed in the Third-Party Hardware Database!’. For more
solutions compatible with IGEL OS, see Partner Solutions.

(@ HP,Lenovo, and LG device models are available from the factory with pre-installed IGEL OS 11. Please
contact IGEL Ready™® to get information on which device models are available with pre-installed IGEL OS.

() Forsome of the devices listed here, Flash memory must be extended to = 2 GB. For these devices, an
appropriate note is added.

() Onmodern computers such as secured-core PCs (see e.g. https://www.microsoft.com/en-us/windows/
business/devices?col=secured-core-pcs), there may be a BIOS setting related to Secure Boot that allows
the use of Microsoft’s 3rd party UEFI Secure Boot Certificate. The usual description of such a BIOS setting is
"Allow Microsoft 3rd Party UEFI CA". This setting must be set to enabled, as IGEL uses the 3rd party
certificate to support UEFI Secure Boot. If UEFI Secure Boot is enabled, but "Allow Microsoft 3rd Party UEFI
CA" is not enabled, you may be unable to boot IGEL OS Creator or UD Pocket. Similarly, if the setting
"Allow Microsoft 3rd Party UEFI CA" is disabled after a previous installation of IGEL OS, IGEL OS will fail to
boot. For how to enable the setting, see Secured-Core PCs: Microsoft 3rd-Party UEFI Certificate for Secure
Boot.

(@ [Fn] keys may not work on some supported and listed laptop/notebook models.

ADS-Tec

Name Device Minimum Storage Size Processor Supported from
Category Memory IGEL OS Version

(RAM) Size

DVG- Industrial PC/ 4GB 64 GB eMMC Intel Atom®x7- 11.02.100

VMT9010 Terminal 3GB E3950

DVG- Industrial PC/ 4GB 64 GB eMMC Intel Atom®x7- 11.02.100

VMT9012 Terminal 3GB E3950

DVG- Industrial PC/ 4GB 64 GB eMMC Intel Atom®x7- 11.02.100

VMT9015 Terminal E3950

8GB

17 https://www.igel.com/linux-3rd-party-hardware-database/
18 https://www.igel.com/technology-partners/
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Name

DVG-
VMT9112

Advantech

Name

Device
Category

Industrial PC/
Terminal

Device
Category

POC-W213L Medical Allin

POC-

One

Medical All in

W243L" (see One

page 24)
POC-

Medical All in

W243L* (see One

page 24)

Advantech-DLoG

Name

DLT-V6210

DLT-V7210 K Industrial PC/

Dell / Wyse

Name

5040 /5212 Allin One

3040

IGEL OS Articles

Minimum
Memory
(RAM) Size

4GB
8GB

Minimum
Memory
(RAM) Size

4GB

4GB

4GB

Device Category Minimum

Storage Size Processor

64 GB eMMC

Storage Size

128 GB

32GB

128 GB

Intel Atom® x7-
E3950

Processor

Intel Core
i7-7300U

Intel Kaby Lake
Corei5-7300U

Intel Core
i7-7300U

Storage Size Processor

Memory
(RAM) Size
Industrial PC/ 4GB 32GB Intel Atom
Terminal
4GB 4GB Intel Atom
Terminal E3845
Device Minimum Storage Processor Supported
Category Memory Size from IGEL OS
(RAM) Size Version
2GB 2GB AMD G-T48E 11.01.100
Thin Client 2 GB 8 GB Intel Atom  11.01.100
x5-78350

IGEL

Supported from
IGEL OS Version

11.02.100

Supported from
IGEL OS Version

11.01.100

11.01.110

11.01.100

Supported from
IGEL OS Version

11.01.100

11.01.100

Notes

13/1109
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Name Device Minimum Storage
Category Memory Size
(RAM) Size
5020 Thin Client 2 GB 8 GB
5060 Thin Client 4GB 8 GB
5070 Thin Client 8 GB 32GB
Latitude Laptop/ 8 GB 256 GB
5510 Notebook
Optiplex ThinClient 4 GB 32GB
3000
Dynabook
Name Device Minimum
Category Memory
(RAM) Size
Portegé X20W- Laptop/ 8 GB
D Notebook
Portegé X30-D Laptop/ 8 GB
Notebook
Tecra C50 Laptop/ 4GB
Notebook
Tecra Z50-D  Laptop/ 8 GB
Notebook
SATELLITE R50 Laptop/ 4GB
Notebook

IGEL OS Articles

Processor Supported Notes
from IGEL OS
Version
AMD G-Series 11.02.140
SoC
AMD 11.01.100
GX-424CC
Intel Celeron 11.01.100
J4105
Intel Core 11.05.100 Wake-on-LAN
i5-10210U functionality is

not supported.

Intel Celeron 11.08.200

N5105
Storage Size Processor Supported from
IGEL OS Version
256 GB Intel Core 11.01.100
i5-7200U
256 GB Intel Core 11.01.100
i5-7300U
500 GB Inteli5-4210U 11.01.100
256 GB Intel Core 11.01.100
i5-7200U
500 GB Inteli3-6006U 11.01.100
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Elo

Name

i2 Touch
(15and 22
inches)

Fujitsu

Name

Q957

FUTRO S740

HP

Name Device Minimu StoragProcessor

Device
Category

Allin One

Device
Category

Desktop PC

Thin Client

Minimum Storage Size Processor
Memory
(RAM) Size
8 GB 128 GB Intel Core
i3-8100T
Minimum Storage Size Processor
Memory
(RAM) Size
8 GB 500 GB Intel Core
i3-6100
4GB 8 GB Intel Celeron
J4105

Supported Wi-Fi

Catego m e Size from IGEL Chip
ry Memor OS Version
y
(RAM)
Size
HP Thin  2GB 8GB AMD 11.02.100
t420 Client Embedded G-
Series
GX-209JA
HP Thin  2GB  16GB Intel®Celeron 11.01.110  Intel
t430 Client ® AC9260
N4020
HP Thin 4GB 8GB AMD 11.01.100
t530  Client GX-215J
Dual-Core
HP Thin 4GB 8GB AMD 11.01.100
t630 Client GX-420GlI

IGEL OS Articles

Notes

Supported from
IGEL OS Version

11.05.100

Supported from
IGEL OS Version

11.02.100

11.04.100
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Name Device Minimu StoragProcessor

Catego m e Size
ry Memor
y
(RAM)
Size
HP Thin 16GB 8GB AMD
t730 Client RX-427BB
APU
HP Thin 16 GB 16 GB Intel Core
t820  Client i5-4570S
HP Thin 4GB 16 GB AMD Ryzen
t640 Client R1505G
HP Thin 16GB 16 GB AMD Ryzen
t540 Client Embedded
R1305G
HP Mobile 8 GB 32GB AMD Ryzen 3
mt46 Thin PRO 4450U
Client
HP Thin 4GB /8 32GB AMD Ryzen
Elite Client GB Embedded
t655 R2314
HP Mobile 8 GB 256 GB AMD Ryzen 3
Elite Thin 5425U
;n7t645 Client AMD Ryzen 5
5625U

IGEL OS Articles

Supported Wi-Fi Notes
from IGEL Chip

0OS Version

11.01.100

11.01.100

11.04.100 Intel This model is not
AC9260 supported with HP USB-C
Realtek Essential G5 Dock
RTL8852
AE

11.06.100 Intel
AC9260
Realtek
RTL8852
AE

11.07.100 Excluding support for

WWAN and Wake-on-LAN
(both features are
planned)

11.07.160 Realtek
RTL8852
BE

11.08.230  Realtek Support for WWAN Intel
RTL8852 XMM 7560 (as of 11.08.330)

11.08.330 BE Excluding support for

Wake-on-LAN (featureis
planned)

Excluding support for
built-in fingerprint sensor
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Name Device Minimu StoragProcessor Supported

Catego m
ry Memor
y
(RAM)
Size
HP Thin 8GB
t740 Client

HP Pro Thin 4 GB
t550 Client

HP Pro Mobile 8 GB

mt440 Thin

G3 Client

HP Thin 8GB
Elite Client

t755

HP Docking Stations

Name

e Size from IGEL
OS Version

16 GB AMD Ryzen 11.08.290
Embedded
V1756B

32 GB Intel Celeron 11.08.330
J6412

128 GB Intel Celeron 11.08.440
7305

128 GBAMD Ryzen  11.09.260
Embedded
V2546

Supported from IGEL OS
Version

HP USB-C Docking Station G5 11.08.230
HP USB-C G5 Essential Dock 11.08.290

Intel

Wi-Fi Notes
Chip

Realtek
RTL8852
AE

Realtek
RTL8852
CE
(Support
ed as of
11.09.150

)

Realtek Support for WWAN Intel
RTL8852 XMM 7560 (as of 11.09.260)
BE

Realtek This model offers no USB-
RTL8852 C docking support
CE

Notes

Not supported with HP t640

Name Device Minimum Storage Size Processor Supported from
Category Memory IGEL OS Version
(RAM) Size
NUC Desktop PC 2GB 32GB Inteli5-5300U  11.01.100
5i5MYHE
NUC 5i3RYH Desktop PC 2GB 2GB Inteli3-5010U  11.01.100

IGEL OS Articles
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Name Device Minimum
Category Memory
(RAM) Size

NUC7CJYH DesktopPC 2GB

Lenovo
Name Device  Minimum Storage
Category Memory Size
(RAM)
Size
ThinkCentreDesktop 4 GB 32GB
M625q PC
8 GB 128 GB
ThinkCentreDesktop 8 GB 256 GB
M75n PC
ThinkCentreDesktop 16 GB 256 GB
M70q Genl PC
ThinkCentreDesktop 16 GB 256 GB
M70q Gen 3 PC
ThinkCentreDesktop 4GB 128 GB
M75q Gen 2 PC
K14 AMD  Laptop/ 8GB 256 GB
Genl Notebook
ThinkPad Laptop/ 64GB 1TB
L14 AMD Notebook
Genl
14w Laptop/ 4GB 64 GB

Notebook

IGEL OS Articles

Storage Size Processor

IGEL

Supported from

IGEL OS Version

4GB Intel Celeron 11.01.100

J4005

Processor Wi-Fi Chip

AMD Intel AC9260
E2-9000e
AMD QCA6174

A4-9120e 802.11ac

AMD Ryzen Intel AC9260
3
Pro 3300U

Intel Comet Lake
i5-10500t PCH CNVi
WiFi, Intel

Intel Core Intel AX201
i5-12500T

AMD Ryzen Intel AX200
3 Pro
5350GE

AMD Ryzen Mediatek
5PRO MT7921
5650U

AMD Ryzen Wi-Fi 6

7 Pro AX200, Intel
4750U

AMD QCA6174

A6-9220C 802.11ac

Supported Notes
from IGEL
0S Version

11.04.100

11.04.100

11.05.100

11.05.100

11.08.240

11.08.240

11.08.240

11.05.100

11.05.100
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Minimum Storage

256 GB

256 GB

256 GB

256 GB

512 GB

1TB

256 GB

256 GB

256 GB

256 GB

256 GB

Name Device
Category Memory Size

(RAM)
Size

ThinkPad Laptop/ 16GB

L14 AMD Notebook

Gen3

ThinkCentreThin 8 GB

Neo50q Client

Gen4 4GB

K14 Intel Laptop/ 16GB

Genl Notebook

ThinkPad Laptop/ 16GB

L14 Intel Notebook

Gen3

ThinkEdge Thin 8 GB

SE10 Client

ThinkPad Thin 8 GB

L14 AMD Client

Gen4

ThinkPad Thin 8 GB

L15 AMD Client

Gen4

ThinkPad Laptop/ 8GB

L14 Intel Notebook

Gen 4

ThinkPad Laptop/ 8GB

L15 Intel Notebook

Gen 4

IGEL OS Articles

Processor

AMD Ryzen
55625U

Intel Core
i3-1215U

Intel
Celeron
7305

Intel Core
i5-1135G7

Intel Core
i5-1235U

Intel Atom
X6425RE

Intel Atom
X6214RE

AMD Ryzen
3 Pro
7330U

AMD Ryzen
3 Pro
7330U

Intel Core
i3-1315U

Intel Core
i3-1315U

Wi-Fi Chip Supported

from IGEL

OS Version

AMD RZ616
2X2AX (WiFi
6E)

Wi-Fi 6
RTL8852BE
Wi-Fi 6 AX201

11.08.230

11.08.240

Intel AX210
WiFi / BT
combo

Intel Wi-Fi6 11.08.330
AX201 2x2 AX
vPro

MediaTek
MTT7921LEN

Intel AX210

11.08.290

11.08.360

11.08.360

AMD RZ616

Realtek
RTL8852CE

AMD RZ616

Realtek
RTL8852CE

Intel AX211

11.08.440

11.08.440

11.09.100

Intel AX211  11.09.100

IGEL

Notes

Excluding
support for
WWAN

LTE support
as of
11.08.360

Quectel
EMO05-G 4G
CAT4

Quectel
EMO05-G 4G
CAT4

Quectel
EMO05-G 4G
CAT4

Quectel
EMO05-G 4G
CAT4
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Name Device  Minimum Storage Processor Wi-Fi Chip Supported Notes
Category Memory Size from IGEL
(RAM) OS Version
Size
ThinkPad Laptop/ 8GB 256 GB IntelCore IntelAX201 11.09.210 Quectel
L13Intel  Notebook i3-1315U EMO05-G 4G
Gen4 CAT4
No
integrated
LAN
ThinkPad Laptop/ 16GB 256 GB AMD Ryzen AMD RZ616 11.09.210  Quectel
L13 AMD Notebook 3 PRO EMO05-G 4G
Gen4 7330U CAT4
No
integrated
LAN

Lenovo Docking Stations

Name Supported from IGEL OS Version
ThinkPad USB-C Hybrid Dock 11.07.100
IOBOX 11.07.100
Universal USB-C Dock 11.08.440

Lenovo USB-C to Ethernet Adapter

Name Supported from IGEL OS Supported with
Version
USB-C to Ethernet Adapter 11.09.260 + ThinkPad L13 Intel Gen4

« ThinkPad L14 AMD Gen4

LG
Name Device Minimum Storage Size Processor Supported from
Category Memory IGEL OS Version
(RAM) Size
24CK550** All in One 4GB 32GB AMD G-Series 11.01.100
(see page 24) GX-212JJ
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Device
Category

Name

24CK560** All in One
(see page 24)

CK500 Thin Client

38CK950 AllinOne
38CK900 Allin One
CL600ON  Thin Client

CL600W  Thin Client
34CN650 Allin One
24CN650 Allin One
27CN650 Allin One
CQ600 Thin Client
24CQ650 Allin One
CQ601 Thin Client
24CR670 AllinOne

34CR650 Allin One

27CQ650 Allin One

IGEL OS Articles

Minimum
Memory
(RAM) Size
4GB

4GB

8GB
8 GB
4GB

8GB

4GB

8GB

8 GB

4GB

4GB

4GB

4GB

4GB

4GB

Storage Size Processor

32GB

32GB

128 GB
128 GB
16 GB

128 GB

16 GB

16 GB

16 GB

16 GB

16 GB

16 GB

16 GB

16 GB

16 GB

AMD G-Series
GX-212JJ

AMD G-Series
GX-212JJ

AMD Ryzen 3
AMD Ryzen 3

Intel® Celeron
J4105

Intel® Celeron
J4105

Intel® Celeron
J4105

Intel® Celeron
J4105

Intel® Celeron
J4105

Intel Celeron
N5105

Intel Celeron
N5105

Intel Pentium
Silver N6005

Intel Celeron
N5105

Intel Celeron
N5105

Intel Celeron
N5105

IGEL

Supported from
IGEL OS Version

11.01.100
11.01.100

11.02.100
11.02.100
11.03.100

11.03.100
11.05.100
11.05.100
11.05.100
11.08.330
11.08.330
11.08.360
11.09.110
11.09.210

11.09.210
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LG Docking Stations
Name

LG USB Multi Port Hub

Onlogic

Name Device
Category

CL210G-10 Industrial PC/

Terminal

KARBON 300 Desktop PC

Onyx Healthcare

Device
Category

Name

Venus 223 Medical Allin
One

Pepperl+Fuchs

Name Device Category

Industrial Box
Thin Client

BTC12N

Industrial Box
Thin Client

BTC14N

IGEL OS Articles

Minimum

Memory

(RAM) Size

4GB

4GB

Minimum
Memory

(RAM) Size

4GB

Minimum
Memory
(RAM) Size

4GB

4GB

Supported from IGEL OS Version

11.09.100

Storage Size Processor

32GB

32GB

Intel Celeron
N3350

Intel Atom x5-
E3930

Storage Size Processor

128 GB

Intel Quad-Core

J1900

Storage Size Processor

32GB

32GB

Intel Apollo Lake
N4200

AMD Ryzen
Embedded
V1202B

Supported from
IGEL OS Version

11.04.100

11.04.100

Supported from
IGEL OS Version

11.01.100

Supported from
IGEL OS Version

11.09.100

11.09.100
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Rein Medical
Name Device Minimum Storage Size Processor
Category Memory
(RAM) Size

Silenio C122 Allin One 8 GB 128 GB Intel® Core™ i5 -

6th Generation
Silenio C124 Allin One 8 GB 128 GB Intel® Core™ i5 -

6th Generation
Clinio S Medical Allin 8GB 16 GB Intel® Pentium®
522TCT One Silver J5005
Clinio S Medical Allin 8GB 16 GB Intel® Pentium®
524TCT One Silver J5005
Secunet
Name Device Minimum Storage Size Processor

Category Memory
(RAM) Size

SINA Workstation Workstation 16 GB 256 GB Intel Core

S EliteDesk 800 G2

i7-6700

USB Memory Sticks That Can Be Used as UD Pocket Hardware

DIGITTRADE
Name

Kobra Stick

Transcend

Name

Storage
>4GB 11.05.133

Powered by IGEL UD Pocket (see page 11)

Powered by IGEL UD Pocket 2 (see page 11)

Officially Supported Virtual Environments

+ Tested with Ubuntu (64-bit) and default settings

IGEL OS Articles

Supported from
IGEL OS Version

11.01.110

11.01.110

11.04.100

11.04.100

Supported from
IGEL OS Version

11.01.100

Supported from IGEL OS Version
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& Note that the use of a UD Pocket within a virtual machine is not supported by IGEL.

() Forsome features, more than 2 GB RAM is required. Example: if you use dual monitor environments, a
virtual machine must have at least 8 GB RAM.

Name Memory Storage Type Supported from IGEL OS
(RAM) Version

Oracle VM VirtualBox >2GB >4 GB Linux 11.04.100

VMware Workstation >2GB >4 GB Linux 11.04.100

* Delock Adapter DP 1.2 to DVI does not work.
** When using an additional 4k screen with this device, please edit the BIOS settings as follows:

1. Goto the Chipset screen.
2. SetIntegrated Graphics to “Force”.
3. Set UMA Frame Buffer Size to “256M” or higher

Check List

0 The devices you want to upgrade meet the hardware requirements for IGEL OS 11.

Next Step

>> |mportant! Consider This Before Upgrading (see page 25)
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Important! Consider This Before Upgrading

To make sure that your upgrade can be successful, check the following warnings and notes; a warning symbol
indicates that irreversible damage can be done to your devices.

@ Existing partitions: Any existing partition on the target drive of your device will be deleted. The installer
will repartition the target device. The overall size of the newly created partitions will be calculated based
on the available disk space. The minimum disk usage is 2 GB, the maximum is 16 GB.

© NoDowngrade

You cannot restore your IGEL OS 10 system once you have migrated to IGEL OS 11. The device storage is
overwritten completely with a new partitioning scheme.

© Features (e.g. Clients)

IGEL OS 11 does not have the complete feature set of IGEL OS 10. Make sure that the current version of
IGEL OS 11 meets your requirements. For details, refer to the appropriate release notes.

© Custom Partitions

The contents of Custom Partitions will be deleted by the upgrade. Make sure that the Custom Partition is
restored after the upgrade has finished. Besides becoming dysfunctional after the upgrade, applications
and kernel drivers in a Custom Partition might corrupt the upgrade. For this reason, make sure to first test
the upgrade on a characteristic device.

© Custom Commands

The persistence of custom commands cannot be guaranteed. Besides becoming dysfunctional after the
upgrade, custom commands might corrupt the upgrade. For this reason, make sure to first test the
upgrade on a characteristic device. In general, custom commands must be adapted for IGEL OS 11. We
recommend that you disable custom commands when upgrading; you can enable them once the upgrade
has been successfully completed.

© Power Supply

Ensure that the device is not running on battery power, i.e. it must be connected to a power supply during
the complete upgrade process.

() Network

All devices must be connected to a LAN or WLAN. LAN is the recommended option. The device will not be
upgraded if OpenVPN, OpenConnect, mobile broadband, or genucard is configured. To be sure, check if
the following parameters are deactivated resp. no session is configured:

+ Network > VPN Open VPN (registry: sessions.openvpn% )
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+ Network > VPN > OpenConnect VPN (registry: sessions.openconnect%)

+ Network > Mobile Broadband, checkbox Enable Mobile Broadband (registry:
network.interfaces.mobile_broadband.enabled)

+ Network > VPN > genucard (registry:
network.interfaces.genucard_vpn_connector.autostart_enabled)

When you have changed the settings, restart the device to enable the upgrade.

Check List

@ The limitations and conditions are understood and do not constitute a problem.

Next Step
>> Getting the UMS Ready (see page 27)
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Getting the UMS Ready

To upgrade your devices to IGEL OS 11, you need the appropriate version of the UMS. Also, the devices must be
registered with the UMS to receive their licenses.

1. Ifyou have not already done so, update your UMS to version 6.01.130 or higher. For instructions,
see Updating a UMS Installation.

2. Make sure that your devices are registered with the UMS. For more information, see the
chapter Registering Devices on the UMS Server in the UMS Manual.

Check List
0 Your Universal Management Suite (UMS) version is 6.01.130 or higher.
OAII devices that will be upgraded are registered in the UMS.

Next Step

>> Deploying the Licenses (see page 28)
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Deploying the Licenses

Checking If the Required Licenses Are Available

» Ensure that you have the following licenses:

+ Avalid license from an IGEL Workspace Edition (WE) Product Pack for each device.
+ Depending on the features you want to use, you might need IGEL Enterprise Management (EMP)
licenses in addition. For further information, see IGEL Software License Overview.

Deploying the Licenses

» Choose one of the following methods:

+ If you want to deploy a license quickly on a single device: See Manual License Deployment for IGEL
0S without UMS; start from step 5.

+ If you have a smaller or medium number of devices and want to control exactly which device
should get a license: See Manual License Deployment for IGEL OS.

+ If you have a medium or greater number of devices, and you are planning to add new devices/
licenses regularly: See Set up Automatic License Deployment (ALD) with ALD Token.

+ If you have a medium or greater number of devices, and you are planning to add new devices/
licenses frequently (licensing can be managed completely in the IGEL License Portal): See Setting
up Automatic License Deployment (ALD).

Check List
@ The licenses have been purchased.

0 License deployment is set up.

Next Step

>> Creating the Universal Firmware Update (see page 29)
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Creating the Universal Firmware Update

In this step, we will create a Universal Firmware Update that will be used for testing the upgrade and for rolling out
the upgrade on all relevant machines.

() Ifyou use the High Availability Extension, note that Universal Firmware Updates are NOT synchronized,
that is why you have to either download them to all HA nodes or configure an external (FTP) server.

Choose the procedure that suits your needs:

« Configuring the Universal Firmware Update with Files Hosted by the UMS (see page 29)
+ Configuring the Universal Firmware Update with Files Hosted by FTP Server (Required for ICG) (see
page 34)

Configuring the Universal Firmware Update with Files Hosted by the UMS

1. Goto Server - [UMS address] > Universal Firmware Update and in the context menu, select
Check f w firmware updates.

mware Update
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2. Select the entry for the IGEL OS 11 firmware and then select Download. (In the example, IGEL OS
11.03.110is used.)

Universal Firmware Updates

Ln

Include  Model
HTRL

HThL
HThiL

HimiL
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3. Read and confirm the disclaimer. (IGEL OS 11.03.100 or higher only)
Disclaimer of IGEL OS 11 11.03.110
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4. Confirm the status message.

Universal Update Download results

Mame Status Errar
IGEL 0S5 11-11.03.110

In the main window, you can monitor the download process.
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Firmware Update Settings

IGEL_INTER

HTHL

Firmware Update Settings
IGEL_INTER

Download Status

Error
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Configuring the Universal Firmware Update with Files Hosted by FTP Server (Required for ICG)

You can use an FTP server instead of the UMS to host the firmware files. If you are using IGEL Cloud Gateway (ICG),
an FTP server is required.

To configure an FTP server as update source:

1. Inthe UMS, go to UMS Administration > Universal Firmware Update and click Edit.
2. Enter the data required for accessing the FTP server and click Save.

Edit FTP Server Configuration

Universal update settings
The IGEL Un al Firr re downloaded fram: ‘fin

The FTP server settings where the files are downloaded to (optionalhy).

Host fips name

Directory

3. Click Test server connection to test your settings.
If everything went well, a success message is shown both for the IGEL download server and for the
FTP server:

The FTP server settings where the files are downloaded fo (optional).
Protocol

Host

Fort

Directory

Connection test  [Connection :
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4. Go to Server - [UMS address] > Universal Firmware Update and in the context menu, select
Check for new firmware updates.

Shared Workplace Users

5. Select the entry for the IGEL OS 11 firmware, click to select the FTP server selected in step 2
and then select Download.

Universal Firmware Updates

Uni Fir g
Include Mo
IG
IG ; . . > o
IGEL 0511 (G 3| 11.02.110 viflocalh i HTML
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6. Read and confirm the disclaimer. (IGEL OS 11.03.100 or higher only)
Disclaimer of IGEL OS 11 11.03.110
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7. Confirm the status message.

Universal Update Download results

Errar
25 11-11.03.110

The firmware is transferred to the FTP server. In the main window, you can monitor the download
process.
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sal Firmwa

Froduct  1GE
11.03.110
HTML T

Firmware Update Settings

ufu

Host  localhost
Part
Protocol

Target URL 11-11.03.110

Download Status
]
[ ]

:- Stared Diovenload the firmware update...

- .
Status =

Errar

When the status is Finished, your Universal Firmware Update is ready for use.
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al Firrr

Product

Haost

Fort
Protocol
Target LURL

shotfile

Download Status

Status

Error

Check List

0 The Universal Firmware Update has been created successfully.

Next Step

1-11.03.110

11.03.110

HThL

Settings
ufu
localhost
21
FTP

IGEL_O5_11-11.03.110

>> Creating an Upgrade Profile (see page 40)
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Creating an Upgrade Profile

The upgrade profile varies, depending on whether the devices are in the same network as the UMS or connected via
ICG. Choose the appropriate procedure:

« For Devices that Are in the UMS Network (see page 40)
« For Devices that Are Connected via ICG (see page 44)

For Devices That Are in the UMS Network

1. Inthe UMS structure tree, go to Profiles, open the context menu and select New Profile.
¥ £ |GEL Universal Management Suite &
¥ Profil
il

8 Impaort (03

2. Enter the following data:
+ Profile Name: Name for the profile, e. g. "Upgrade to IGEL OS 11".
« Description: Optional description for the profile.
« Based on: Firmware version for the profile; select the current firmware of your devices, that
is, "IGEL UD Pocket 10.06.100".
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3. Click Ok.

MNew Profile

Profile Marme | Upgrade to IGEL OF

Cescription

Based on [GEL LD Pocket 10.06.100.01

* Expert mode

4. Go to System > Update > Firmware Update and change the settings as follows:
« Select "HTTPS" as the Protocol.
« Activate Automatic update check on boot.
« Ensure that Automatic update check on shutdown is deactivated. Otherwise, the device
will shut down when the update is finished.
Upgrade to IGEL 0OS 11
< > A ur

. . d 5 Related Configurations
Configuration : —~ ]

Search

5. Go to System > Update > Firmware Update > OS 11 Upgrade.
6. Activate Upgrade to OS 11.
7. Make the following settings according to your needs:
« If you want the device to retry the upgrade immediately after a failed attempt,
activate Upgrade to OS 11 even if a previous upgrade attempt failed. With this setting,
the device will retry the upgrade 5 times. When the 5th attempt has failed, a message will be
shown in the upgrade tool window.
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« If your device has a PowerTerm license, and you want to upgrade to IGEL OS 11 even
though IGEL OS 11 does not support PowerTerm, you must activate Upgrade to OS 11 even
if PowerTerm is enabled.

+ Under Require an Enterprise Management Pack license to upgrade to OS 11, select the
appropriate option:

« If you are using IGEL Cloud Gateway (ICG) or Shared Workplace (SWP) or a Custom
Partition and want to make sure that the upgrade is performed only if these features
can be used furthermore, select Smart. When Smart is selected, and one of these
features is activated, the upgrade is performed only if the device succeeded in
fetching a license from an Enterprise Management Pack.

+ If you want to force the device to fetch a license from an Enterprise Management
Pack and make sure that the upgrade is performed only if this license has been
fetched, select Always.

+ If you want the device to upgrade to IGEL OS 11 without fetching a license from
an Enterprise Management Pack, disregarding the features, select Never.

8. Under Timeout waiting for OS 11 license to start automatic upgrade, set the time period the
device will wait for a license in a mass deployment scenario. This setting prevents the device from
starting the upgrade at an inappropriate time as a result of the license just being deployed. This
way, the setting prevents unwanted interruptions at work. For a mass deployment scenario, the
default value 10 Minutes is recommended.

Upgrade to IGEL OS 11

< > ~ ! ¥ Systen » Update » O35 11 Upgrade

Configuration

wen if 3 previous upgrade attempt failed

d send to device
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9. If you have a Custom Partition, go to Firmware Customization > Custom Partition > Partition
and deactivate Enable Partition.

Upgrade to IGEL OS 11

zation ® Custom Partition ™ Partition

5

v Enahle Partition

10. If you have custom applications, go to Firmware Customization > Custom Application and, for
each custom application, deactivate Autostart. This is to prevent the custom application from
interfering with the device's system before it can be tested properly.
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ITC14DDA94FE94E
> ~

Configuration

Panel

Mone

11. Click Save.

For Devices That Are Connected via ICG

1. Inthe UMS structure tree, go to Profiles, open the context menu and select New Profile.
IGEL Univer

contral

Migration UDC? Update Firrr

Scheduled firm Logging: b
ter Profil
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2. Enterthe following data:
+ Profile Name: Name for the profile, e. g. "Upgrade to IGEL OS 11".
+ Description: Optional description for the profile.
+ Based on: Firmware version for the profile; select the current firmware of your devices, that
is, "IGEL UD Pocket 10.06.100".
3. Click Ok.

MNew Profile

Profile Mame | Lip e to IGEL

Cescription

Based on [GEL LD Pocket 10.06.100.01

* Expert mode

4. Go to System > Update > Firmware Update and change the settings as follows:
+ Select "FTP" as Protocol.
« Activate Automatic update check on boot.
« Ensure that Automatic update check on shutdown is deactivated. Otherwise, the device
will shut down when the update is finished.
Upgrade to IGEL 0OS 11
< > A

. roto 4 igurations
Configuration i

[Z Features

Search

5. Go to System > Update > Firmware Update > 0S 11 Upgrade.
6. Activate Upgrade to OS 11.
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7. Make the following settings according to your needs:

+ If you want the device to retry the upgrade immediately after a failed attempt,
activate Upgrade to OS 11 even if a previous upgrade attempt failed. With this setting,
the device will retry the upgrade 5 times. When the 5th attempt has failed, a message will be
shown in the upgrade tool window.

+ If your device has a PowerTerm license, and you want to upgrade to IGEL OS 11 even
though IGEL OS 11 does not support PowerTerm, you must activate Upgrade to OS 11 even
if PowerTerm is enabled.

+ Under Require an Enterprise Management Pack license to upgrade to OS 11, select the
appropriate option:

+ Ifyou are using IGEL Cloud Gateway (ICG) or Shared Workplace (SWP) or a Custom
Partition and want to make sure that the upgrade is performed only if these features
can be used furthermore, select Smart. When Smart is selected, and one of these
features is activated, the upgrade is performed only if the device succeeded in
fetching a license from an Enterprise Management Pack.

+ If you want to force the device to fetch a license from an Enterprise Management
Pack and make sure that the upgrade is performed only if this license has been
fetched, select Always.

+ If you want the device to upgrade to IGEL OS 11 without fetching a license from an
Enterprise Management Pack, disregarding the features, select Never.

8. Under Timeout waiting for OS 11 license to start automatic upgrade, set the time period the
device will wait for a license in a mass deployment scenario. This setting prevents the device from
starting the upgrade at an inappropriate time as a result of the license just being deployed. This
way, the setting prevents unwanted interruptions at work. For a mass deployment scenario, the
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default value 10 Minutes is recommended.
Upgrade to IGEL OS 11

> ~ [ W Systermn * Update * 0511 Upgrade

Configuration € S ¥ Upgradeto 0511
Sessions a . .
€ /¥ Upgradeto 0S 11 even if a previous upgrade attempt failed
Accessories

User Interface A

Netwark Require an Enterprise Management Pack license to upgrade ta 05 11

Devices

Security Timeout waiting for 05 11 license to start automatic upgrade

System

B Time and Date
v O3 Update
B Firmware Update
B Buddy Update
[ o511 Upgrade
» Il Remote management
» I Remote Access
B Remote Sysing
» Il Power Options
» I Firmware Customization
B Registry

Search

Apply and send o device Save Cancel

9. If you have a Custom Partition, go to Firmware Customization > Custom Partition > Partition
and deactivate Enable Partition.
ITC14DDA94FES4E

> ~ [ W Systern ® Firmware Customization ® Custom Partition  ®* Parition

. . This feature requires an active Enterprise Management Pack subscription.
conflguratlon
Enable Partition
Sessions
Accessories
User Interface

Metwork
Paritions Parameters
Devices
Marme
Security

P4 4 4 4 4 4

Systerm

B Time and Date
+ I Update
» Il Remote management
» I Remote Access
B Logging
» Il Power Options
¥ [ Firmware Customization
¥ [ Custam Partition
B Fariition

» Il Custom Application

» I Custom Commands

» B Corporate Design

» Il Ervironment Variables
B Features

B Registry

Search

Apply and send to device Save Cancel
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10. If you have custom applications, go to Firmware Customization > Custom Application and, for
each custom application, deactivate Autostart. This is to prevent the custom application from
interfering with the device's system before it can be tested properly.

ITC14DDA94FES4E

> ~ I » M i zation ® Custorm Ap|

me
Configuration
Starting Methods for Session
it enu
n Launcher
1t Fanel
Menu folder
pplication Launcher folder
dop folder

wrotection Mone

Huotkey

Appliance

Search

11. Click Save.

Check List
0 The upgrade profile is configured properly for your needs.

Next Step

>> Assigning the Upgrade Profile and the Universal Firmware Update to the Test Devices (see page 49)
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Assigning the Upgrade Profile and the Universal Firmware Update to the Test
Devices

1. Ifyou have not already created a directory as a distribution condition while setting up Automatic
License Deployment (ALD): In the Devices node of the UMS structure tree, create a directory and
name it "Upgrade to IGEL OS 11", for instance. For more information about distribution conditions,
see Configuring the Distribution Conditions, section "Distributing Licenses to Devicesin a
Specified Directory".
Bl Devy
8 Impo
b Er" r"llE!'III'III'
e 1 Clear 'Configuration Change Status'flag
» [ Remote C AL

; control

‘% ITC14DDAI4FESAE
Clitc 7 A
Mobile C

. chromium-k i -

an for devices
I client-cert.pem

New Directory

Directory Mame Upgrade to I(GEL 05 11
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2. Putthe devices that are to be updated into the new directory. You can use drag & drop.

[ I|_-' [mpaort (0%

[ Mew

e ] =
I DAY4FERSE
IDAS4FES4E

3. Inthe Update time dialog, select Now and click Ok.
The directory change is communicated immediately to the device.

Update time

YWhen should these changes take effect?
4 Rebiont

settings on next reboot (and dan't show this dialog again)

Server - 172.30.92.9
1
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5. Assign the upgrade profile and the Universal Firmware Update for IGEL OS 11.03 to the directory
and click Ok.

Select assignable objects

6. Inthe Update time dialog, select Now and click Ok.
The changes are sent to the devices immediately.

Update time

uld th
Rehoot

w this dialog
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In the Assigned objects area, the profile and the Universal Firmware Update are shown:

() Ifyou are using Automatic License Deployment (ALD), it might be feasible to confine the distribution of
licenses to the current directory. For more information, see Configuring the Distribution Conditions,
section "Distributing Licenses to Devices in a Specified Directory".

Check List

O The test devices are in a directory to which the upgrade profile and the Universal Firmware Update are assigned.

Next Step

>> Testing the Upgrade (see page 53)
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Testing the Upgrade

1. Inthe UMS, select the directory containing the test devices and select Reboot.

0511 (1)
AFEB4E

UMS Administrati

Fonnected to 1
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2. Inthe Reboot devices dialog, click Reboot.

Reboot devices

o) |TCH \O4FEQ4E

Reboot Cancel

If no IGEL OS 11 licenses have been deployed on the devices yet, the licenses are deployed within a
few minutes. The upgrade will be started when the licenses are deployed. The maximum time
period the device will wait for a license is configured by the parameter Timeout waiting for 0S 11
license to start automatic upgrade; for details, see Creating an Upgrade Profile (see page 40), step
8.
The parameter Automatic update check on boot makes the devices look for new firmware
again. Although two Universal Firmware Updates are assigned to the devices, the UMS offers the
IGEL OS 11 firmware, because the ID of the IGEL OS 11 firmware is higher than the ID of the IGEL OS
10 firmware.
The upgrade is completed.

3. Check whether all features and functions of your test devices are working as expected.

Check List

0 All features and functions of your test devices are working as expected.

Next Step

>> Unassigning the Upgrade Profile and the Universal Firmware Update (see page 55)
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Unassigning the Upgrade Profile and the Universal Firmware Update

The upgrade profile and the Universal Firmware Update should be unassigned from the devices after they have
been upgraded to IGEL OS 11 successfully.

To unassign upgrade profile and the Universal Firmware Update:

1. Move the devices to a different folder.

2. Inthe Update time dialog, select Now and click Ok.
The directory change is communicated immediately to the devices.

Update time

should these changes take effect?

If a device had a Custom Partition before, it will be downloaded by the device and activated again.

Check List
If a device had a Custom Partition before:

@ The Custom Partition has been downloaded by the device and activated.

Next Step

If some devices have a Custom Partition:

>> |f Applicable: Restoring Custom Partition and Custom Application (see page 56)
If no device has a Custom Partition:

>> Upgrading All Devices (see page 57)
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If Applicable: Restoring Custom Partition and Custom Applications

If a device had a custom partition before the upgrade, it has been downloaded and activated again after the
upgrade profile has been unassigned; see Unassigning the Upgrade Profile and the Universal Firmware Update (see
page 55). It cannot be ruled out that custom commands and the applications and drivers of a Custom Partition
disturb your device's system. Therefore, it is very important to check the Custom Partition, the custom applications,
and the device's basic functionality.

1. Testthe Custom Partition and the custom applications. If errors should occur, modify the Custom
Partition and the custom applications accordingly.
2. Checkif all other functions are still working properly.

Check List
0 The Custom Partition and the custom applications are enabled and can be used.

0 All other functions are working properly.

Next Step

>> Upgrading All Devices (see page 57)
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Upgrading All Devices

Assigning the Upgrade Profile and the Universal Firmware Update to the Devices

1. Putthe devices that are to be upgraded into the directory you have created for the test devices. It
is recommended to use cut and paste.
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3.

L ITCooE

Ll mcoooecanssnl A

control

Ll
Mabile D

Specific Device Command

License manually...

Export Device Settings
Save device files for support

Logoing

In the Update time dialog, select Now and click Ok.
The directory change, the upgrade profile and the Universal Firmware Update are communicated
immediately to the devices.

Update time

changes take effect?

settings on next reboot (and don't show this dialog again

In the UMS, select the directory with the devices and select Reboot.
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4. Inthe Reboot devices dialog, click Reboot.

Rehboot devices

W TC14DDAS4FES4E

Rehboot Cancel

If no IGEL OS 11 licenses have been deployed on the devices yet, the licenses are deployed within a
few minutes. The upgrade will be started when the licenses are deployed. The maximum time
period a device will wait for a license is configured by the parameter Timeout waiting for 0S 11
license to start automatic upgrade; for details, see Creating an Upgrade Profile (see page 40), step
8.

The parameter Automatic update check on boot makes the devices look for new firmware

again. Although two Universal Firmware Updates are assigned to the devices, the UMS offers the
IGEL OS 11 firmware, because the ID of the IGEL OS 11 firmware is higher than the ID of the IGEL OS
10 firmware.

Unassigning the Upgrade Profile and the Universal Firmware Update

1. Tounassign the upgrade profile and the Universal Firmware Update, move the devices to a
different folder.
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lear 'Canfiguration Change Status'flag

contral
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Command

License manually...

LA A A,

2. Inthe Update time dialog, select Now and click Ok.
The directory change is communicated immediately to the device.

Update time

YWhen should the
t Rehoot

L ] r"u_l Oy

If a device had a Custom Partition before the upgrade, it has been downloaded and activated
again after the upgrade profile has been unassigned.

3. If applicable, restore the required custom applications; see |f Applicable: Restoring Custom
Partition and Custom Applications (see page 56).
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(D) Update Can Be Canceled After Timeout

An ongoing update can be canceled by the user if the "network online" status could not be reached
within 10 seconds after the firmware update has been started. When the user has canceled the
update, the normal desktop environment is started, just as before the update. This applies to the

following cases:
+ Regular firmware update, e.g. from IGEL OS 11.03.500 to IGEL OS 11.04

« Afeature has been activated, e.g. VPN OpenConnect.
« A Custom Partition has been activated or changed.

Check List
A evices have been upgraae to IGEL 11.
[l devi h b ded GEL OS

0 All required functionality is available, including custom applications.
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Upgrading from IGEL OS 10 to IGEL OS 11

+ Upgrading UDC3 Devices from IGEL OS 10 to IGEL OS 11 (see page 66)
+ Upgrading IGEL Devices from IGEL OS 10 to IGEL OS 11 (see page 159)
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Upgrading UDC3 Devices from IGEL OS 10 to IGEL OS 11

This document describes how to upgrade any number of devices (UDC3) from IGEL OS 10 to IGEL OS 11.

IGEL OS 10.05.800 or higher is required for upgrading to IGEL OS 11. If you have an older version of IGEL OS 10, you
need to update to version 10.05.800 or a higher version first.

Since a new licensing model has been introduced with IGEL OS 11, a license from an IGEL Workspace Edition
Product Pack must be available for each device. If you have a valid maintenance for your devices, you can convert
your existing UDC3 or UD Pocket Product Packs to Workspace Edition (WE) Product Packs; see Converting UDC3 or
UD Pocket Licenses for Upgrading to IGEL OS 11.

The following methods of mass deployment are described here:

« Zero-Touch Deployment Using Universal Firmware Update (see page 67): Mass upgrade from any
version of IGEL OS 10 to IGEL OS 11 in one step using Universal Firmware Update. This method can
be started immediately or as a scheduled job (wake up or reboot).

+ Zero-Touch Deployment Using Buddy Update (see page 107): Mass upgrade from any version of IGEL
0S 10 to IGEL OS 11 in one step using two devices as update buddies. This method can be started
immediately or as a scheduled job (wake up or reboot).

+ Zero-Touch Deployment Using a Scheduled Job (see page 139): Upgrade devices that are already
running IGEL OS 10.05.800 (or higher) using a specific scheduled job.
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Zero-Touch Deployment Using Universal Firmware Update

This method is the most convenient way to upgrade from IGEL OS 10 to IGEL OS 11. The method uses the Universal
Firmware Update feature of the UMS (Universal Management Suite) and a profile.

Read all the following chapters carefully and follow the instructions.

Devices That Can Be Upgraded to Igel OS 11 (see page 68)
Important! Consider This Before Upgrading (see page 82)
Preparing the Upgrade (see page 83)

Testing the Upgrade (see page 88)

Checking the Requirements (see page 92)

Creating the Universal Firmware Updates (see page 93)
Creating a Profile (see page 97)

Deploying the Licenses (see page 102)

Putting It All Together (see page 103)

Executing the Upgrade (see page 105)

WoeNoOkwWwNE

=
e
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Devices That Can Be Upgraded to Igel 0S 11

@ Partner Solutions for Peripherical Devices

For further supported hardware from IGEL partners, e.g. headsets, see Partner Solutions.

Core Requirements

« CPU with 64-bit support
« CPUspeed:=1GHz
+ Memory (RAM): =2 GB

() RAMsize higher than 2 GB is recommended if you use any of the following:
+ Unified Communications optimizations (uses a client-side media engine)
+ High-resolution graphics output
+ More than two monitors

@ With devices that have 2 GB RAM and shared video memory, a maximum of 512 MB may be
used as video memory.

+ Storage: Depends on the release version of IGEL OS 11. The details are listed below:

« UptoIGEL 0S 11.03:2 GB minimum; =4 GB recommended

« From IGEL OS 11.04 to IGEL OS 11.07: If the full feature set is applied, at least 2.4 GB of
storage is required. For instructions on how to reduce the feature set, see Error: "Not
enough space on local drive" when Updating to IGEL OS 11.08 or Higher.

« From IGEL OS 11.08 onwards: If the full feature set is applied, at least 4 GB of storage is
required. For instructions on how to reduce the feature set, see Error: "Not enough space on
local drive" when Updating to IGEL OS 11.08 or Higher.

+ NoVIA graphic adapter; VIA graphics support is discontinued in IGEL OS.
+ Legacy Bios and EFI/UEFI are supported.

Devices Supported by OSC and UD Pocket with IGEL OS 11

& Thefollowing list only includes those devices that are tested by IGEL (with each major release of IGEL OS).
By no means it implies that the devices which are not included in this list but meet the minimum
requirements will not function with IGEL OS: Any x86-64 hardware endpoint device that meets the IGEL-
stated minimum hardware requirements for IGEL OS (for example, the processor speed and RAM) can be
expected to work adequately with IGEL OS and should be considered a candidate for repurposing from
another OS. With an IGEL OS subscription or active maintenance, customers can expect IGEL to make any
necessary “best effort” to support, regardless of whether the endpoints in question are specifically listed
within the IGEL Knowledge Base or elsewhere (e.g. on the IGEL Ready Showcase at https://www.igel.com/
ready/showcase-categories/endpoints/).

For any devices not listed here or on the IGEL Ready showcase, you can contact your hardware vendor and
request those devices to be added to the IGEL Ready program.
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IGEL

Integrated drivers and supported peripherals are listed in the Third-Party Hardware Database!®. For more
solutions compatible with IGEL OS, see Partner Solutions.

(@ HP,Lenovo, and LG device models are available from the factory with pre-installed IGEL OS 11. Please
contact IGEL Ready® to get information on which device models are available with pre-installed IGEL OS.

() Forsome of the devices listed here, Flash memory must be extended to = 2 GB. For these devices, an
appropriate note is added.

() Onmodern computers such as secured-core PCs (see e.g. https://www.microsoft.com/en-us/windows/
business/devices?col=secured-core-pcs), there may be a BIOS setting related to Secure Boot that allows
the use of Microsoft’s 3rd party UEFI Secure Boot Certificate. The usual description of such a BIOS setting is
"Allow Microsoft 3rd Party UEFI CA". This setting must be set to enabled, as IGEL uses the 3rd party
certificate to support UEFI Secure Boot. If UEFI Secure Boot is enabled, but "Allow Microsoft 3rd Party UEFI
CA" is not enabled, you may be unable to boot IGEL OS Creator or UD Pocket. Similarly, if the setting
"Allow Microsoft 3rd Party UEFI CA" is disabled after a previous installation of IGEL OS, IGEL OS will fail to
boot. For how to enable the setting, see Secured-Core PCs: Microsoft 3rd-Party UEFI Certificate for Secure
Boot.

(@ [Fn] keys may not work on some supported and listed laptop/notebook models.

ADS-Tec

Name Device Minimum Storage Size Processor Supported from
Category Memory IGEL OS Version

(RAM) Size

DVG- Industrial PC/ 4GB 64 GB eMMC Intel Atom®x7- 11.02.100

VMT9010 Terminal 8GB E3950

DVG- Industrial PC/ 4GB 64 GB eMMC Intel Atom®x7- 11.02.100

VMT9012 Terminal 8GB E3950

DVG- Industrial PC/ 4GB 64 GB eMMC Intel Atom®x7- 11.02.100

VMT9015 Terminal 8GB E3950

DVG- Industrial PC/ 4GB 64 GB eMMC Intel Atom®x7- 11.02.100

VMT9112 Terminal 3GB E3950

19 https://www.igel.com/linux-3rd-party-hardware-database/
20 https://www.igel.com/technology-partners/
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Advantech

Name Device Minimum Storage Size Processor Supported from
Category Memory IGEL OS Version
(RAM) Size
POC-W213L Medical Allin 4GB 128 GB Intel Core 11.01.100
One i7-7300U
POC- Medical Allin 4GB 32GB Intel Kaby Lake  11.01.110
W243L* (see One Core i5-7300U
page 81)
POC- Medical Allin 4GB 128 GB Intel Core 11.01.100
W243L" (see One i7-7300U
page 81)
Advantech-DLoG
Name Device Category Minimum Storage Size Processor Supported from
Memory IGEL OS Version
(RAM) Size
DLT-V6210 Industrial PC/ 4GB 32GB Intel Atom 11.01.100
Terminal
DLT-V7210 K Industrial PC/ 4GB 4GB Intel Atom 11.01.100
Terminal E3845
Dell / Wyse
Name Device Minimum Storage Processor Supported Notes
Category Memory Size from IGEL OS
(RAM) Size Version
5040 /5212 AllinOne 2GB 2 GB AMD G-T48E 11.01.100
3040 Thin Client 2GB 8 GB Intel Atom 11.01.100
x5-78350
5020 Thin Client 2 GB 8 GB AMD G-Series 11.02.140
SoC
5060 Thin Client 4GB 8 GB AMD 11.01.100
GX-424CC
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Name Device Minimum Storage
Category Memory Size
(RAM) Size
5070 Thin Client 8 GB 32GB
Latitude Laptop/ 8 GB 256 GB
5510 Notebook
Optiplex ThinClient 4 GB 32GB
3000
Dynabook
Name Device Minimum
Category Memory
(RAM) Size
Portegé X20W- Laptop/ 8 GB
D Notebook
Portegé X30-D Laptop/ 8 GB
Notebook
Tecra C50 Laptop/ 4GB
Notebook
Tecra Z50-D  Laptop/ 8 GB
Notebook
SATELLITE R50 Laptop/ 4GB
Notebook
Elo
Name Device Minimum
Category Memory
(RAM) Size
i2 Touch Allin One 8 GB
(15and 22
inches)

Fujitsu

IGEL OS Articles

Processor

Supported
from IGEL OS

Version

Intel Celeron 11.01.100

J4105

Intel Core
i5-10210U

11.05.100

Intel Celeron 11.08.200

N5105

Storage Size

256 GB

256 GB

500 GB

256 GB

500 GB

Storage Size

128 GB

Processor

Intel Core
i5-7200U

Intel Core
i5-7300U

Intel i5-4210U
Intel Core

i5-7200U
Intel i3-6006U

Processor

Intel Core
i3-8100T

Notes

Wake-on-LAN
functionality is
not supported.

Supported from
IGEL OS Version

11.01.100

11.01.100

11.01.100

11.01.100

11.01.100

Supported from
IGEL OS Version

11.05.100
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Name

Q957

FUTRO S740 Thin Client

HP

Device Minimum
Category Memory
(RAM) Size
DesktopPC  8GB
4GB

Name Device Minimu StoragProcessor
Catego m

HP
£420

HP
t430

HP
t530

HP
t630

HP
t730

HP
t820

HP
t640

ry

Thin
Client

Thin
Client

Thin
Client

Thin
Client
Thin
Client

Thin
Client
Thin
Client

IGEL OS Articles

Memor

y

(RAM)

Size

2GB

2GB

4GB

4GB

16 GB

16 GB

4GB

e Size

8 GB

16 GB

8 GB

8 GB

8 GB

16 GB

16 GB

AMD

Embedded G-

Series
GX-209JA

Storage Size Processor

500 GB

8 GB

IGEL

Supported from
IGEL OS Version

Intel Core 11.02.100
i3-6100

Intel Celeron 11.04.100
J4105

Supported Wi-Fi Notes
from IGEL Chip

OS Version

11.02.100

Intel®Celeron 11.01.110

®

N4020

AMD
GX-215JJ
Dual-Core

AMD
GX-420GlI

AMD
RX-427BB
APU

Intel Core
i5-4570S

AMD Ryzen
R1505G

11.01.100

11.01.100

11.01.100

11.01.100

11.04.100

Intel
AC9260

Intel This model is not
AC9260 supported with HP USB-C
Essential G5 Dock
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Name Device Minimu StoragProcessor Supported
Catego m e Size from IGEL
ry Memor OS Version

y
(RAM)
Size
HP Thin 16 GB 16 GB AMD Ryzen 11.06.100
t540 Client Embedded
R1305G

HP Mobile 8 GB 32GB AMD Ryzen 3 11.07.100

mt46 Thin PRO 4450U
Client

HP Thin 4GB/8 32GB AMD Ryzen 11.07.160

Elite Client GB Embedded

t655 R2314

HP Mobile 8 GB 256 GB AMD Ryzen 3 11.08.230

Elite Thin 5425U

21;645 Client AMD Ryzen 5 11.08.330

5625U

HP Thin 8 GB 16 GB AMD Ryzen 11.08.290

t740 Client Embedded

V1756B

HP Pro Thin 4GB 32 GB Intel Celeron 11.08.330

t550 Client J6412

IGEL OS Articles

Wi-Fi
Chip

Realtek
RTL8852
AE

Intel
AC9260

Realtek
RTL8852
AE

Realtek
RTL8852
BE

Realtek
RTL8852
BE

Realtek
RTL8852
AE

Realtek
RTL8852
CE
(Support
ed as of
11.09.150

)

Notes

Excluding support for
WWAN and Wake-on-LAN
(both features are
planned)

Support for WWAN Intel
XMM 7560 (as of 11.08.330)

Excluding support for
Wake-on-LAN (feature is
planned)

Excluding support for
built-in fingerprint sensor
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Name Device Minimu StoragProcessor

Catego m e Size
ry Memor

y

(RAM)

Size

HP Pro Mobile 8 GB 128 GB Intel Celeron 11.08.440

mt440 Thin

G3 Client

HP Thin 8GB 128 GB AMD Ryzen
Elite Client

t755

HP Docking Stations

Name

HP USB-C Docking Station G5
HP USB-C G5 Essential Dock

Intel

Name Device

Category
NUC Desktop PC
5i5MYHE

NUC 5i3RYH Desktop PC
NUC 7CJYH Desktop PC

Lenovo

IGEL OS Articles

7305

Embedded

V2546

Supported from IGEL OS

Version

11.08.230
11.08.290

Minimum
Memory
(RAM) Size

2GB

2GB
2GB

Supported
from IGEL
0OS Version

11.09.260

Storage Size

32GB

2GB
4GB

Wi-Fi Notes
Chip

Realtek Support for WWAN Intel
RTL8852 XMM 7560 (as of 11.09.260)
BE

Realtek This model offers no USB-
RTL8852 C docking support
CE

Notes

Not supported with HP t640

Processor Supported from
IGEL OS Version

Inteli5-5300U  11.01.100
Inteli3-5010U  11.01.100

Intel Celeron 11.01.100
J4005
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Name Device

Minimum Storage

Category Memory Size

ThinkCentre Desktop
M625q PC

ThinkCentre Desktop
M75n PC

ThinkCentre Desktop
M70q Genl PC

ThinkCentre Desktop
M70q Gen 3 PC

ThinkCentre Desktop
M75q Gen 2 PC

K14 AMD  Laptop/

Genl Notebook

ThinkPad Laptop/

L14 AMD Notebook

Genl
14w Laptop/

Notebook

ThinkPad Laptop/

L14 AMD Notebook

Gen3

ThinkCentreThin
Neo50q Client
Gen4

IGEL OS Articles

(RAM)

Size

4GB

8GB

8 GB

16 GB

16 GB

4GB

8GB

64 GB

4GB

16 GB

8 GB

4GB

32GB

128 GB

256 GB

256 GB

256 GB

128 GB

256 GB

1TB

64 GB

256 GB

256 GB

256 GB

Processor

AMD
E2-9000e

AMD
A4-9120e

AMD Ryzen
3
Pro 3300U

Intel
i5-10500t

Intel Core
i5-12500T

AMD Ryzen
3 Pro
5350GE

AMD Ryzen
5PRO
5650U

AMD Ryzen
7 Pro
4750U

AMD
A6-9220C

AMD Ryzen
55625U

Intel Core
i3-1215U

Intel
Celeron
7305

Wi-Fi Chip Supported
from IGEL
0S Version

Intel AC9260 11.04.100

QCA6174 11.04.100
802.11ac

Intel AC9260 11.05.100

Comet Lake 11.05.100
PCH CNVi
WiFi, Intel

Intel AX201  11.08.240

Intel AX200 11.08.240

Mediatek 11.08.240
MT7921

Wi-Fi 6 11.05.100
AX200, Intel

QCA6174 11.05.100
802.11ac

AMD RZ616 11.08.230
2X2AX (WiFi
6E)

Wi-Fi 6 11.08.240
RTL8852BE

Wi-Fi 6 AX201

IGEL

Notes

Excluding
support for
WWAN

75/ 1109



Update and Upgrade

Name

K14 Intel
Gen1l

ThinkPad
L14 Intel
Gen3

ThinkEdge
SE10

ThinkPad
L14 AMD
Gen 4

ThinkPad
L15 AMD
Gen4

ThinkPad
L14 Intel
Gen4

ThinkPad
L15 Intel
Gen4

ThinkPad
L13 Intel
Gen4

IGEL OS Articles

Minimum Storage

256 GB

512 GB

1TB

256 GB

256 GB

256 GB

Device

Category Memory Size
(RAM)
Size

Laptop/ 16GB

Notebook

Laptop/ 16GB

Notebook

Thin 8 GB

Client

Thin 8 GB

Client

Thin 8 GB

Client

Laptop/ 8GB
Notebook

Laptop/ 8GB
Notebook

Laptop/ 8GB
Notebook

256 GB

256 GB

256 GB

IGEL

Processor Wi-FiChip Supported Notes
from IGEL
OS Version
Intel Core Intel AX210 11.08.290
i5-1135G7 WiFi/BT
combo
Intel Core IntelWi-Fi6 11.08.330 LTE support
i5-1235U  AX201 2x2 AX as of
vPro 11.08.360
Intel Atom MediaTek 11.08.360
X6425RE  MTT7921LEN
Intel Atom Intel AX210 11.08.360
X6214RE
AMD Ryzen AMD RZ616 11.08.440  Quectel
3 Pro EMO05-G 4G
Realtek
7330U RTL8852CE CAT4
AMD Ryzen AMD RZ616 11.08.440 Quectel
3 Pro EMO05-G 4G
Realtek
7330U RTL8852CE CAT4
Intel Core Intel AX211 11.09.100 Quectel
i3-1315U EMO05-G 4G
CAT4
Intel Core Intel AX211 11.09.100 Quectel
i3-1315U EMO05-G 4G
CAT4
Intel Core Intel AX201 11.09.210  Quectel
i3-1315U EMO05-G 4G
CAT4
No
integrated
LAN
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IGEL

Name Device  Minimum Storage Processor Wi-Fi Chip Supported Notes
Category Memory Size from IGEL
(RAM) OS Version
Size

ThinkPad Laptop/ 16GB 256 GB AMD Ryzen AMD RZ616 11.09.210  Quectel

L13 AMD Notebook 3 PRO EMO05-G 4G

Gen 4 7330U CAT4
No
integrated
LAN

Lenovo Docking Stations

Name Supported from IGEL OS Version

ThinkPad USB-C Hybrid Dock 11.07.100

IOBOX 11.07.100

Universal USB-C Dock 11.08.440

Lenovo USB-C to Ethernet Adapter

Name Supported from IGEL OS Supported with

Version
USB-C to Ethernet Adapter 11.09.260 + ThinkPad L13 Intel Gen4

+ ThinkPad L14 AMD Gen4

LG

Name Device Minimum Storage Size Processor
Category Memory
(RAM) Size

24CK550** All in One 4GB 32GB AMD G-Series

(see page 81) GX-212JJ

24CK560** All in One 4GB 32GB AMD G-Series

(see page 81) GX-212JJ

CK500 Thin Client 4GB 32GB AMD G-Series
GX-212JJ

38CK950 AllinOne 8GB 128 GB AMD Ryzen 3

IGEL OS Articles

Supported from
IGEL OS Version

11.01.100

11.01.100

11.01.100

11.02.100

77/ 1109



Update and Upgrade

Device
Category

Name
38CK900 AllinOne
CL600N  Thin Client
CL600W  Thin Client
34CN650 Allin One
24CN650 Allin One
27CN650 Allin One
CQ600 Thin Client
24CQ650 AllinOne
CQ601 Thin Client
24CR670 AllinOne

34CR650 Allin One

27CQ650 Allin One

LG Docking Stations

Name

LG USB Multi Port Hub

OnLogic

IGEL OS Articles

Minimum
Memory
(RAM) Size

8GB
4GB

8GB

4GB

8GB

8GB

4GB

4GB

4GB

4GB

4GB

4GB

Storage Size Processor

128 GB
16 GB

128 GB

16 GB

16 GB

16 GB

16 GB

16 GB

16 GB

16 GB

16 GB

16 GB

AMD Ryzen 3

Intel® Celeron
J4105

Intel® Celeron
J4105

Intel® Celeron
J4105

Intel® Celeron
J4105

Intel® Celeron
J4105

Intel Celeron
N5105

Intel Celeron
N5105

Intel Pentium
Silver N6005

Intel Celeron
N5105

Intel Celeron
N5105

Intel Celeron
N5105

IGEL

Supported from
IGEL OS Version

11.02.100
11.03.100

11.03.100
11.05.100
11.05.100
11.05.100
11.08.330
11.08.330
11.08.360
11.09.110
11.09.210

11.09.210

Supported from IGEL OS Version

11.09.100
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Name Device Minimum Storage Size Processor Supported from
Category Memory IGEL OS Version
(RAM) Size
CL210G-10 IndustrialPC/ 4GB 32GB Intel Celeron 11.04.100
Terminal N3350
KARBON 300 Desktop PC 4GB 32GB Intel Atom x5- 11.04.100
E3930

Onyx Healthcare

Name Device Minimum Storage Size Processor Supported from
Category Memory IGEL OS Version
(RAM) Size
Venus 223 MedicalAllin 4GB 128 GB Intel Quad-Core 11.01.100
One J1900
Pepperl+Fuchs
Name Device Category Minimum Storage Size Processor Supported from
Memory IGEL OS Version
(RAM) Size
BTC12N Industrial Box 4GB 32GB Intel Apollo Lake 11.09.100
Thin Client N4200
BTC14N Industrial Box 4GB 32GB AMD Ryzen 11.09.100
Thin Client Embedded
V1202B
Rein Medical
Name Device Minimum Storage Size Processor Supported from
Category Memory IGEL OS Version
(RAM) Size
Silenio C122  Allin One 8GB 128 GB Intel® Core™i5-  11.01.110
6th Generation
Silenio C124 Allin One 8 GB 128 GB Intel® Core™i5- 11.01.110
6th Generation
Clinio S Medical Allin 8 GB 16 GB Intel® Pentium®  11.04.100
522TCT One Silver J5005
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Name Device Minimum Storage Size Processor Supported from

Category Memory IGEL OS Version
(RAM) Size

Clinio S Medical Allin 8 GB 16 GB Intel® Pentium®  11.04.100

524TCT One Silver J5005

Secunet

Name Device Minimum Storage Size Processor Supported from

Category Memory IGEL OS Version
(RAM) Size
SINA Workstation Workstation 16 GB 256 GB Intel Core 11.01.100
S EliteDesk 800 G2 i7-6700

USB Memory Sticks That Can Be Used as UD Pocket Hardware

DIGITTRADE

Name Storage Supported from IGEL OS Version
Kobra Stick > 4GB 11.05.133

Transcend

Name

Powered by IGEL UD Pocket (see page 68)
Powered by IGEL UD Pocket 2 (see page 68)

Officially Supported Virtual Environments
+ Tested with Ubuntu (64-bit) and default settings

A Notethat the use of a UD Pocket within a virtual machine is not supported by IGEL.

() Forsome features, more than 2 GB RAM is required. Example: if you use dual monitor environments, a
virtual machine must have at least 8 GB RAM.

Name Memory Storage Type Supported from IGEL OS
(RAM) Version
Oracle VM VirtualBox  =2GB >4 GB Linux 11.04.100
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Name Memory Storage Type Supported from IGEL OS
(RAM) Version
VMware Workstation >2GB >4 GB Linux 11.04.100

* Delock Adapter DP 1.2 to DVI does not work.
** When using an additional 4k screen with this device, please edit the BIOS settings as follows:

1. Goto the Chipset screen.
2. SetIntegrated Graphics to “Force”.
3. Set UMA Frame Buffer Size to “256M” or higher

When you have confirmed that your devices can be upgraded to IGEL OS 11, make sure to consider Important!
Consider This Before Upgrading (see page 82).
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Important! Consider This Before Upgrading

To make sure that your upgrade can be successful, check the following warnings and notes; a warning symbol
indicates that irreversible damage can be done to your devices.

© Existing partitions: Any existing partition on the target drive of your device will be deleted. The installer
will repartition the target device. The overall size of the newly created partitions will be calculated based
on the available disk space. The minimum disk usage is 2 GB, the maximum is 16 GB.

© NoDowngrade

You cannot restore your IGEL OS 10 system once you have migrated to IGEL OS 11. The device storage is
overwritten completely with a new partitioning scheme.

© Features (e.g. Clients)

IGEL OS 11 does not have the complete feature set of IGEL OS 10. Make sure that the current version of
IGEL OS 11 meets your requirements. For details, refer to the appropriate release notes.

© Custom Partitions

The contents of custom partitions will be deleted by the upgrade. Make sure to back up the contents and
restore them after the upgrade has finished. Besides becoming dysfunctional after the upgrade,
applications and kernel drivers in a custom partition might corrupt the upgrade. For this reason, make
sure to first test the upgrade on a characteristic device. We recommend that you disable custom partitions
when upgrading; you can enable them once the upgrade has been successfully completed.

© Custom Commands

The persistence of custom commands cannot be guaranteed. Besides becoming dysfunctional after the
upgrade, custom commands might corrupt the upgrade. For this reason, make sure to first test the
upgrade on a characteristic device. In general, custom commands must be adapted for IGEL OS 11. We
recommend that you disable custom commands when upgrading; you can enable them once the upgrade
has been successfully completed.

© Power Supply

Ensure that the device is not running on battery power, i.e. it must be connected to a power supply during
the complete upgrade process.

() Network

All devices must be connected to a WLAN or LAN. LAN is the recommended option. The device will not be
upgraded if connected to OpenVPN, OpenConnect, genucard or mobile broadband.

When you have considered everything that is relevant, continue with Preparing the Upgrade (see page 83).
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Preparing the Upgrade

This section describes the required preparations and tests before any productive devices can be updated. The
testing should be done with at least one device that is characteristic of your environment. This device should have
every custom partition and every custom command that may possibly exist in any of your devices.

To prepare the upgrade, perform the following steps:

1. Preparing the UMS (see page 84)

2. Adjusting the Setup (see page 85)

3. Deploying a License (see page 86)

4. Configuring the Update Source (see page 87)
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Preparing the UMS

To upgrade your devices to IGEL OS 11, you need the appropriate version of the UMS. Also, the devices must be
registered with the UMS to receive their licenses.

1. If you have not already done so, update your UMS to version 6.01.130 or higher. For instructions,
see Updating UMS.

2. Make sure that your devices are registered with the UMS. For more information, see the
chapter Registering IGEL OS Devices on the UMS Server in the UMS Manual.

When the UMS is ready, continue with Adjusting the Setup (see page 85).
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Adjusting the Setup

Depending on the features that are in use now or will be used in the future, a specific set of parameters must be set
in the device's Setup.

1. Inthe Setup, go to System > Firmware Update > OS 11 Upgrade.
2. Make your settings as appropriate:
+ Activate Upgrade to OS 11.

(0 When Upgrade to OS 11 is activated, the device checks for a Workspace Edition license and
stops checking for a legacy UDC3 or UD Pocket license. Therefore, in the UMS, it is displayed
as an unlicensed device until a Workspace Edition license has been deployed.

+ If you want the device to retry the upgrade immediately after a failed attempt,
activate Upgrade to OS 11 even if a previous upgrade attempt failed. The device will retry
the upgrade 5 times. When the 5th attempt has failed, a message will be shown in the
upgrade tool window.

+ If your device has a PowerTerm license, and you want to upgrade to IGEL OS 11 even though
it does not support PowerTerm, you must activate Upgrade to OS 11 even if PowerTerm is
enabled.

+ Under Require an Enterprise Management Pack license to upgrade to OS 11, select the
appropriate option:

+ Ifyou are using IGEL Cloud Gateway (ICG) or Shared Workplace (SWP) or a Custom
Partition and want to make sure that the upgrade is performed only if these features
can be used furthermore, select Smart. When this option is selected, and any of these
features is activated, the upgrade is performed only if the device could fetch a license
from an Enterprise Management Pack.

+ If you want to force the device to fetch a license from an Enterprise Management
Pack and make sure that the upgrade is performed only if the license could be
fetched, select Always.

+ If you want the device to upgrade to IGEL OS 11 without fetching an Enterprise
Management Pack, disregarding the features that might be activated, select Never.

+ Under Timeout waiting for OS 11 license to start automatic upgrade, set the time period
the device will wait for a license in a mass deployment scenario (see Zero-Touch
Deployment Using Universal Firmware Update (see page 67), Zero-Touch Deployment Using
Buddy Update (see page 107) and Mass Deployment Using a Scheduled Job (see page 212)). This
setting prevents the device from starting the upgrade at an inappropriate time as a result of
the license just being deployed. This way, the setting prevents unwanted interruptions at
work. For a mass deployment scenario, the default value 10 Minutes is recommended.

3. Click Apply.

When the Setup is adjusted, continue with Deploying a License (see page 86).
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Deploying a License

To upgrade from IGEL OS 10 to IGEL OS 11, you need an appropriate license. Depending on your requirements, one
or more of these licenses will be needed for each device:

+ One Workspace Edition license for basic functionality; see Workspace Edition
+ If one of the following features are used, one Enterprise Management Pack license is required
(see Enterprise Management Pack):
+ IGEL Cloud Gateway (ICG)
+ Shared Workplace (SWP)
+ Custom Partition if IGEL OS 11.03.100 or lower is the target version; if the target version is
IGEL OS 11.03.500 or higher, the Custom Partition feature is included in the Workspace
Edition.

Proceed as follows:

> Deploy the licenses for IGEL OS 11 using the method that suits your needs:

+ Manual License Deployment: Licenses are created and deployed manually. For instructions,
see Manual License Deployment for IGEL OS.
+ Automatic License Deployment (ALD): Licenses are created and deployed automatically to each
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).
+ Download three demo licenses from https://www.igel.com/download/.

When the device has a license, continue with Configuring the Update Source (see page 87).
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Configuring the Update Source

1. Inthe Setup, go to System > Update > Firmware Update and configure the update source for
IGEL OS 11. For more information, see the Firmware Update chapter in the IGEL OS Manual.
2. Click Ok.

When the correct update source is configured, continue with Testing the Upgrade (see page 88).
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e

IGE

Testing the Upgrade

1. Click E] System and then Upgrade to OS 11. The OS 11 Upgrade Tool starts and indicates
whether all requirements are met.

() You can change the starting the starting methods for the OS 11 Upgrade Tool in the Setup under
Accessories > 0S11 Upgrade.

0S 11 Upgrade x

Q Hardware
0 License
Q Setup

Q Update Source

o Network

IGELOST10->11

Close 05 Upgrade

2. Check the output of the OS 11 Upgrade Tool and continue appropriately:
« If each requirement has an o icon, click OS Upgrade to start the upgrade process.

+ If one or more requirements have an ® icon, check the messages and resolve the
issues. Afterwards, click Check again. If all requirements are met, the button changes to 0S
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Upgrade, and you can start the upgrade.
0S 11 Upgrade x

Q Hardware
o License
® Setup
® Powerterm

® Update Source

IGELOS10->11 |

Setup: PowerTerm will not be available in 05 11. To proceed, activate 'Upgrade to 05 11 even if PowerTerm is
enabled' at IGEL Setup = System > Update > 05 11 Upgrade.

Update Source: Please configure a valid OS 11 update source at 'System > Update = Firmware Update’ and
check your network connection.

Network: Please disable all VPN/Mobile Broadband network connectivity on the device. Otherwise it cannot be
guaranteed that your update source will be reachable after the upgrade.

Close Check again

When you start the upgrade, a warning dialog is shown.
3. Click OK to continue.

Confirm Upgrade to 0S 11

With this upgrade, IGEL 0S 11 will be installed on the device.
It is not possible to downgrade to IGEL OS 10 afterwards.

| ¥ Cancel

A warning dialog with a timeout is shown. If you click Cancel before the timeout expires, the
upgrade is canceled. If you click OK or just wait for the timeout to expire, the upgrade is started
Upgrade - A

Please note: With this upgrade, IGEL 0S 11 will be installed on
the device. It is not possible to downgrade to IGEL OS 10
afterwards.

This upgrade involves a critical phase in which the device
must not be powered off. The critical phase will be indicated
by a flashing warning. You will be notified after the upgrade
has finished successfully.

54 seconds remain

¥ Cancel

After the warning dialog has been confirmed or the timeout has expired, the device reboots into a
special IGEL OS 10 environment, in which the system upgrade is executed. The Upgrade window
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show the progress.
Upgrade

IGELOS

During the critical phase, the device must not be powered off. At this stage in the progress, an
additional warning is shown.

Upgrading base system.
DO NOT POWER OFF YOUR DEVICE!

When the base system is upgraded successfully, a message is shown.

0 Upgraded base system successfully.

The remaining components of the firmware are installed, which is indicated by update messages.

Firmware update

System

34%

When the installation is completed, the Upgrade window looks like this:
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Upgrade

IGELOS10->11

After a few seconds the device reboots into IGEL OS 11.

]

Local Terminal

\\m///ﬁ;
Z-1GEL

Congratulations
l The upgrade to IGEL OS 11 is now
complete

P X W |t 1020

When the upgrade test has been successful, you are ready to set up the mass upgrade. Continue with Checking the
Requirements (see page 92).
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Checking the Requirements
The following requirements must be met:

+ The upgrade has been tested with characteristic devices.

+ UMS6.01.130 or higher is available.

+ The firmware IGEL OS 10.05.800 (or higher) is known to the UMS. For this purpose, a device
with this firmware version must be registered in the UMS. This is already the case if you tested the
upgrade with the same UMS with which you are about to do the mass upgrade. If not, you must
register a device with the appropriate firmware version now.

+ All devices are connected to a regular LAN (not OpenVPN, OpenConnect, genucard, NCP VPN or
mobile broadband).

+ All devices are in a safe environment where the upgrade process cannot be disrupted, e.g. by
powering off the devices.

When all requirements are met, continue with Creating the Universal Firmware Updates (see page 93).
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Creating the Universal Firmware Updates

For detailed information, see the chapter Universal Firmware Update in the UMS Manual.

() Ifyou use the High Availability Extension, note that Universal Firmware Updates are NOT synchronized,
that is why you have to either download them to all HA nodes or configure an external (FTP) server.

1. Create a Universal Firmware Update for IGEL OS 10.05.800 (or higher).

2. After you have created the Universal Firmware Update for IGEL OS 10.05.800 (or higher), create a
Universal Firmware Update for IGEL OS 11.

© Theorder of creation is crucial because the IGEL OS 11 firmware must have a higher ID in order to
be chosen by the device. For details, see Executing the Upgrade (see page 105).

Configuring the Universal Firmware Update for ICG

If you are using IGEL Cloud Gateway (ICG), an FTP server that is accessible to all devices must be configured as an
update source.

To configure an FTP server as update source:

1. Inthe UMS, go to UMS Administration > Universal Firmware Update and click .
2. Enter the data required for accessing the FTP server and click Save.

Edit FTP Server Configuration

Universal update settings
The IGEL U zal Firr are downloaded from; ‘fia

Pram

The FTP server settings where the files are downloaded to {optionally).

Host fipSerername

Port

Directory

Cancel
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3. Goto Server - [UMS address] > Universal Firmware Update and in the context menu, select
Check for new firmware updates.

Shared Workplace Users

4. Select the entry for the IGEL OS 10.05.800 (or higher) firmware, click to select the FTP server
selected in step 2 and then select Download.

Universal Firmware Updates

Firmware Updates

IGELUD LX
IGELOS 11

Show only latest firmwe des already downlo
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5. The firmware is transferred to the FTP server.

IUniversal Firmware Update/IGEL Universal Desktop LX-1

Product  IGEL Uniy 1D op LX
Version 100 0
Release Notes  HTML Text
Firmware Update Settings
User fiplser
s
Host /ername
Part
Protocol
Target URL  ftpServerpath/IGEL_Unive
Snapshot file
Download Status
~

(]
Status -: .'

Error

Started Download the firmware update...

6. Under Server - [UMS address] > Universal Firmware Update, in the context menu, select Check

for new firmware updates again.

IGEL OS Articles

95 /1109



Update and Upgrade

IGEL

7. Select the entry for the IGEL OS 11 firmware, click to select the FTP server selected in step 2

and select Download.

Universal Firmware Updates

Universal Firmware Updates
Include Model
IGEL UD LX
IGELOS 11

Show only latest firmware versions (hides already downloaded versions)

8. The firmware is transferred to the FTP server.

Product IGEL

Version  11.01.100

Firmware Update Settings

User fipUser
jord

Host
Port

Protocol

Target URL  MpServerpath/IGE 1-11.01.100

Download Status
]
=< Started L Download the firmware update...

%

Error

The devices can download the firmware from the FTP server,

When the Universal Firmware Update is ready, continue with Creating a Profile (see page 97).
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Creating a Profile

1. Create a profile that is based on the IGEL OS 10 firmware (10.08.800 or higher). Find a suitable
name for the profile, e.g. "Firmware upgrade to IGEL 0S 11",

MNew Profile

Profile Mame
Diescriptian

Inhetits Settings fram

¥ @ Upgrade to 13
[ I |
L mcooEncst

Ga
Ll oo

Based on IGEL Universal Deskiop X 10.05.800

no Settings

Cancel

2. Inthe profile's configuration dialog, go to System > Update > Firmware Update and change the
settings according to your environment:
+ Ifthe UMS and the devices are in one and the same network and no IGEL Cloud Gateway
(ICG) is used:

+ Select "HTTPS" as Protocol.

« Activate Automatic Update Check on Boot.

« Ensure that Automatic Update Check on Shutdown is deactivated. Otherwise, the

device will shut down when the update is finished.
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Allow firmware upgrade te IGEL 0S5 11

» Update » Fi

Related Configurations

Search

« IfIGEL Cloud Gateway (ICG) is used:
+ Select "FTP" as Protocol.
+ Activate Automatic Update Check on Boot.
» Ensure that Automatic Update Check on Shutdown is deactivated. Otherwise, the
device will shut down when the update is finished.
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Allow firmware upgrade te IGEL 0S5 11
< > A

? al Related Configurations
uration

Search

3. Go to System > Update > 0OS 11 Upgrade and change the following settings according to your
successful upgrade test (for details of the settings, see Adjusting the Setup (see page 85)):
« Activate Upgrade to OS 11.
Set Upgrade to OS 11 even if PowerTerm is enabled according to your needs.
Set Upgrade to OS 11 even if a previous upgrade attempt failed according to your needs.
+ Set Require an Enterprise Management Pack license to upgrade to OS 11 according to
your needs.

Ensure that the Timeout waiting for OS 11 license to start automatic upgrade is set to 10
Minutes.
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Allow firmware upgrade te IGEL 0S5 11

> Upda

Require an Ente

Time

Search

4. Go to System > Remote Management and change the settings as follows:
« Deactivate Display 'Apply changes' dialog on boot.
+ Set Default action on boot to Apply changed configuration immediately.
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Allow firmware upgrade te IGEL 0S5 11
14 > A ! * Rel

Configuration

a0
Timeout

Defal

A

Timeout

Search

5. Click Save.

When the profile is created, continue with Deploying the Licenses (see page 102).
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Deploying the Licenses
Deploy the licenses for IGEL OS 11 using the method that suits your needs:

+ Automatic License Deployment (ALD): Licenses are created and deployed automatically to each
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).

+ Manual License Deployment: Licenses are created and deployed manually. For instructions,
see Manual License Deployment for IGEL OS.

When the license deployment is set up, continue with Putting It All Together (see page 103).
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Putting It All Together

1. Putall devices that are to be updated into a directory.

¥ |L—| Devices (4)
¥ B Remote Devices (1)
L ITCO0EDCST1 4345

g D3
¥ i Upgrade to IGEL OS5 11 (1)

1 ITCoonBCANSS01 8

WL (00

- ,' ITCOOEQCSTCA087
2. Select the directory and in the Assigned objects area, click @

Server-172.30.92.9

e 6

£l iTcoo.
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3. Assign the profile (see Creating a Profile (see page 97)) and the two Universal Firmware Updates
(see Creating the Universal Firmware Updates (see page 93)) to the directory and click Ok.

Select assignable obhjects

Cancel

Mame

L1 meoon.

5. If you are using Automatic License Deployment (ALD), it might be feasible to confine the
distribution of licenses to the current directory. For more information, see Configuring the
Distribution Conditions, section "Distributing Licenses to Devices in a Specified Directory".

When everything is in place, continue with Executing the Upgrade (see page 105).
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Executing the Upgrade

1. Inthe UMS,; select the directory containing all devices that are to be upgraded and reboot them.

@ Alternatively, you can create a scheduled job for reboot or wake up and assign it to the
devices or the directory containing these devices. For more information, see Jobs

e Status'flag

ommands

END]

On reboot or wake up, the devices update to the appropriate IGEL OS 10 firmware (10.05.800 or
higher). With this version, the Upgrade to OS 11 parameter is recognized by the devices; also, the
devices request IGEL OS 11 licenses from the UMS (Workspace Edition and, if required, Enterprise
Management Pack).

If no IGEL OS 11 licenses have been deployed on the devices yet, the licenses are deployed within a
few minutes. The upgrade will be started when the licenses are deployed. The maximum time
period the device will wait for a license is configured by the parameter Timeout waiting for 0S 11
license to start automatic upgrade; for details, see Adjusting the setup (see page 85).

The parameter Automatic update check on boot causes the devices look for new firmware

again. Although two Universal Firmware Updates are assigned to the devices, the UMS offers the
IGEL OS 11 firmware, because the ID of the IGEL OS 11 firmware is higher than the ID of the IGEL OS
10 firmware.

() Update Can Be Canceled After Timeout
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An ongoing update can be canceled by the user if the "network online" status could not be reached
within 10 seconds after the firmware update has been started. When the user has canceled the
update, the normal desktop environment is started, just as before the update. This applies to the
following cases:

« Regular firmware update, e.g. from IGEL OS 11.03.500 to IGEL OS 11.04

« Afeature has been activated, e.g. VPN OpenConnect.

« A Custom Partition has been activated or changed.

2. When all devices have been upgraded successfully, remove the "Firmware upgrade to IGEL OS 11"
profile and the two Universal Firmware Updates from the directory.

Assigned ohjects

Mame

The upgrade is completed.
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Zero-Touch Deployment Using Buddy Update

This method uses the buddy update feature of IGEL OS. One or more devices that are configured as an update
buddy access the main server and download the firmware. The other devices are configured to download their
firmware from an update buddy.

Read all the following chapters carefully and follow the instructions.

=

Devices That Can Be Upgraded to IGEL OS 11 (see page 108)
Important! Consider This Before Upgrading (see page 122)
Preparing the Upgrade (see page 123)

Testing the Upgrade (see page 128)

Checking the Requirements (see page 132)

Configuring Two Update Buddies (see page 133)

Creating a Profile (see page 134)

Deploying the Licenses (see page 136)

Putting It All Together (see page 137)

Executing the Upgrade (see page 138)

RNk WN

=
e
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Devices That Can Be Upgraded to IGEL OS 11

@ Partner Solutions for Peripherical Devices

For further supported hardware from IGEL partners, e.g. headsets, see Partner Solutions.

Core Requirements

« CPU with 64-bit support
« CPUspeed:=1GHz
+ Memory (RAM): =2 GB

() RAMsize higher than 2 GB is recommended if you use any of the following:
+ Unified Communications optimizations (uses a client-side media engine)
+ High-resolution graphics output
+ More than two monitors

@ With devices that have 2 GB RAM and shared video memory, a maximum of 512 MB may be
used as video memory.

+ Storage: Depends on the release version of IGEL OS 11. The details are listed below:

« UptoIGEL 0S 11.03:2 GB minimum; =4 GB recommended

« From IGEL OS 11.04 to IGEL OS 11.07: If the full feature set is applied, at least 2.4 GB of
storage is required. For instructions on how to reduce the feature set, see Error: "Not
enough space on local drive" when Updating to IGEL OS 11.08 or Higher.

« From IGEL OS 11.08 onwards: If the full feature set is applied, at least 4 GB of storage is
required. For instructions on how to reduce the feature set, see Error: "Not enough space on
local drive" when Updating to IGEL OS 11.08 or Higher.

+ NoVIA graphic adapter; VIA graphics support is discontinued in IGEL OS.
+ Legacy Bios and EFI/UEFI are supported.

Devices Supported by OSC and UD Pocket with IGEL OS 11

& Thefollowing list only includes those devices that are tested by IGEL (with each major release of IGEL OS).
By no means it implies that the devices which are not included in this list but meet the minimum
requirements will not function with IGEL OS: Any x86-64 hardware endpoint device that meets the IGEL-
stated minimum hardware requirements for IGEL OS (for example, the processor speed and RAM) can be
expected to work adequately with IGEL OS and should be considered a candidate for repurposing from
another OS. With an IGEL OS subscription or active maintenance, customers can expect IGEL to make any
necessary “best effort” to support, regardless of whether the endpoints in question are specifically listed
within the IGEL Knowledge Base or elsewhere (e.g. on the IGEL Ready Showcase at https://www.igel.com/
ready/showcase-categories/endpoints/).

For any devices not listed here or on the IGEL Ready showcase, you can contact your hardware vendor and
request those devices to be added to the IGEL Ready program.
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Integrated drivers and supported peripherals are listed in the Third-Party Hardware Database?!. For more
solutions compatible with IGEL OS, see Partner Solutions.

(@ HP,Lenovo, and LG device models are available from the factory with pre-installed IGEL OS 11. Please
contact IGEL Ready? to get information on which device models are available with pre-installed IGEL OS.

() Forsome of the devices listed here, Flash memory must be extended to = 2 GB. For these devices, an
appropriate note is added.

() Onmodern computers such as secured-core PCs (see e.g. https://www.microsoft.com/en-us/windows/
business/devices?col=secured-core-pcs), there may be a BIOS setting related to Secure Boot that allows
the use of Microsoft’s 3rd party UEFI Secure Boot Certificate. The usual description of such a BIOS setting is
"Allow Microsoft 3rd Party UEFI CA". This setting must be set to enabled, as IGEL uses the 3rd party
certificate to support UEFI Secure Boot. If UEFI Secure Boot is enabled, but "Allow Microsoft 3rd Party UEFI
CA" is not enabled, you may be unable to boot IGEL OS Creator or UD Pocket. Similarly, if the setting
"Allow Microsoft 3rd Party UEFI CA" is disabled after a previous installation of IGEL OS, IGEL OS will fail to
boot. For how to enable the setting, see Secured-Core PCs: Microsoft 3rd-Party UEFI Certificate for Secure
Boot.

(@ [Fn] keys may not work on some supported and listed laptop/notebook models.

ADS-Tec

Name Device Minimum Storage Size Processor Supported from
Category Memory IGEL OS Version

(RAM) Size

DVG- Industrial PC/ 4GB 64 GB eMMC Intel Atom®x7- 11.02.100

VMT9010 Terminal 8GB E3950

DVG- Industrial PC/ 4GB 64 GB eMMC Intel Atom®x7- 11.02.100

VMT9012 Terminal 8GB E3950

DVG- Industrial PC/ 4GB 64 GB eMMC Intel Atom®x7- 11.02.100

VMT9015 Terminal 8GB E3950

DVG- Industrial PC/ 4GB 64 GB eMMC Intel Atom®x7- 11.02.100

VMT9112 Terminal 3GB E3950

21 https://www.igel.com/linux-3rd-party-hardware-database/
22 https://www.igel.com/technology-partners/
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Advantech

Name Device Minimum Storage Size Processor Supported from
Category Memory IGEL OS Version
(RAM) Size
POC-W213L Medical Allin 4GB 128 GB Intel Core 11.01.100
One i7-7300U
POC- Medical Allin 4GB 32GB Intel Kaby Lake  11.01.110
W243L* (see One Core i5-7300U
page 121)
POC- Medical Allin 4GB 128 GB Intel Core 11.01.100
W243L" (see One i7-7300U
page 121)
Advantech-DLoG
Name Device Category Minimum Storage Size Processor Supported from
Memory IGEL OS Version
(RAM) Size
DLT-V6210 Industrial PC/ 4GB 32GB Intel Atom 11.01.100
Terminal
DLT-V7210 K Industrial PC/ 4GB 4GB Intel Atom 11.01.100
Terminal E3845
Dell / Wyse
Name Device Minimum Storage Processor Supported Notes
Category Memory Size from IGEL OS
(RAM) Size Version
5040 /5212 AllinOne 2GB 2 GB AMD G-T48E 11.01.100
3040 Thin Client 2GB 8 GB Intel Atom 11.01.100
x5-78350
5020 Thin Client 2 GB 8 GB AMD G-Series 11.02.140
SoC
5060 Thin Client 4GB 8 GB AMD 11.01.100
GX-424CC
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Name Device Minimum Storage
Category Memory Size
(RAM) Size
5070 Thin Client 8 GB 32GB
Latitude Laptop/ 8 GB 256 GB
5510 Notebook
Optiplex ThinClient 4 GB 32GB
3000
Dynabook
Name Device Minimum
Category Memory
(RAM) Size
Portegé X20W- Laptop/ 8 GB
D Notebook
Portegé X30-D Laptop/ 8 GB
Notebook
Tecra C50 Laptop/ 4GB
Notebook
Tecra Z50-D  Laptop/ 8 GB
Notebook
SATELLITE R50 Laptop/ 4GB
Notebook
Elo
Name Device Minimum
Category Memory
(RAM) Size
i2 Touch Allin One 8 GB
(15and 22
inches)

Fujitsu

IGEL OS Articles

Processor

Supported
from IGEL OS

Version

Intel Celeron 11.01.100

J4105

Intel Core
i5-10210U

11.05.100

Intel Celeron 11.08.200

N5105

Storage Size

256 GB

256 GB

500 GB

256 GB

500 GB

Storage Size

128 GB

Processor

Intel Core
i5-7200U

Intel Core
i5-7300U

Intel i5-4210U
Intel Core

i5-7200U
Intel i3-6006U

Processor

Intel Core
i3-8100T

Notes

Wake-on-LAN
functionality is
not supported.

Supported from
IGEL OS Version

11.01.100

11.01.100

11.01.100

11.01.100

11.01.100

Supported from
IGEL OS Version

11.05.100
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Name

Q957

FUTRO S740 Thin Client

HP

Device Minimum
Category Memory
(RAM) Size
DesktopPC  8GB
4GB

Name Device Minimu StoragProcessor
Catego m

HP
£420

HP
t430

HP
t530

HP
t630

HP
t730

HP
t820

HP
t640

ry

Thin
Client

Thin
Client

Thin
Client

Thin
Client
Thin
Client

Thin
Client
Thin
Client

IGEL OS Articles

Memor

y

(RAM)

Size

2GB

2GB

4GB

4GB

16 GB

16 GB

4GB

e Size

8 GB

16 GB

8 GB

8 GB

8 GB

16 GB

16 GB

AMD

Embedded G-

Series
GX-209JA

Storage Size Processor

500 GB

8 GB

IGEL

Supported from
IGEL OS Version

Intel Core 11.02.100
i3-6100

Intel Celeron 11.04.100
J4105

Supported Wi-Fi Notes
from IGEL Chip

OS Version

11.02.100

Intel®Celeron 11.01.110

®

N4020

AMD
GX-215JJ
Dual-Core

AMD
GX-420GlI

AMD
RX-427BB
APU

Intel Core
i5-4570S

AMD Ryzen
R1505G

11.01.100

11.01.100

11.01.100

11.01.100

11.04.100

Intel
AC9260

Intel This model is not
AC9260 supported with HP USB-C
Essential G5 Dock
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Name Device Minimu StoragProcessor Supported
Catego m e Size from IGEL
ry Memor OS Version

y
(RAM)
Size
HP Thin 16 GB 16 GB AMD Ryzen 11.06.100
t540 Client Embedded
R1305G

HP Mobile 8 GB 32GB AMD Ryzen 3 11.07.100

mt46 Thin PRO 4450U
Client

HP Thin 4GB/8 32GB AMD Ryzen 11.07.160

Elite Client GB Embedded

t655 R2314

HP Mobile 8 GB 256 GB AMD Ryzen 3 11.08.230

Elite Thin 5425U

21;645 Client AMD Ryzen 5 11.08.330

5625U

HP Thin 8 GB 16 GB AMD Ryzen 11.08.290

t740 Client Embedded

V1756B

HP Pro Thin 4GB 32 GB Intel Celeron 11.08.330

t550 Client J6412

IGEL OS Articles

Wi-Fi
Chip

Realtek
RTL8852
AE

Intel
AC9260

Realtek
RTL8852
AE

Realtek
RTL8852
BE

Realtek
RTL8852
BE

Realtek
RTL8852
AE

Realtek
RTL8852
CE
(Support
ed as of
11.09.150

)

Notes

Excluding support for
WWAN and Wake-on-LAN
(both features are
planned)

Support for WWAN Intel
XMM 7560 (as of 11.08.330)

Excluding support for
Wake-on-LAN (feature is
planned)

Excluding support for
built-in fingerprint sensor
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Name Device Minimu StoragProcessor

Catego m e Size
ry Memor

y

(RAM)

Size

HP Pro Mobile 8 GB 128 GB Intel Celeron 11.08.440

mt440 Thin

G3 Client

HP Thin 8GB 128 GB AMD Ryzen
Elite Client

t755

HP Docking Stations

Name

HP USB-C Docking Station G5
HP USB-C G5 Essential Dock

Intel

Name Device

Category
NUC Desktop PC
5i5MYHE

NUC 5i3RYH Desktop PC
NUC 7CJYH Desktop PC

Lenovo

IGEL OS Articles

7305

Embedded

V2546

Supported from IGEL OS

Version

11.08.230
11.08.290

Minimum
Memory
(RAM) Size

2GB

2GB
2GB

Supported
from IGEL
0OS Version

11.09.260

Storage Size

32GB

2GB
4GB

Wi-Fi Notes
Chip

Realtek Support for WWAN Intel
RTL8852 XMM 7560 (as of 11.09.260)
BE

Realtek This model offers no USB-
RTL8852 C docking support
CE

Notes

Not supported with HP t640

Processor Supported from
IGEL OS Version

Inteli5-5300U  11.01.100
Inteli3-5010U  11.01.100

Intel Celeron 11.01.100
J4005
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Name Device

Minimum Storage

Category Memory Size

ThinkCentre Desktop
M625q PC

ThinkCentre Desktop
M75n PC

ThinkCentre Desktop
M70q Genl PC

ThinkCentre Desktop
M70q Gen 3 PC

ThinkCentre Desktop
M75q Gen 2 PC

K14 AMD  Laptop/

Genl Notebook

ThinkPad Laptop/

L14 AMD Notebook

Genl
14w Laptop/

Notebook

ThinkPad Laptop/

L14 AMD Notebook

Gen3

ThinkCentreThin
Neo50q Client
Gen4

IGEL OS Articles

(RAM)

Size

4GB

8GB

8 GB

16 GB

16 GB

4GB

8GB

64 GB

4GB

16 GB

8 GB

4GB

32GB

128 GB

256 GB

256 GB

256 GB

128 GB

256 GB

1TB

64 GB

256 GB

256 GB

256 GB

Processor

AMD
E2-9000e

AMD
A4-9120e

AMD Ryzen
3
Pro 3300U

Intel
i5-10500t

Intel Core
i5-12500T

AMD Ryzen
3 Pro
5350GE

AMD Ryzen
5PRO
5650U

AMD Ryzen
7 Pro
4750U

AMD
A6-9220C

AMD Ryzen
55625U

Intel Core
i3-1215U

Intel
Celeron
7305

Wi-Fi Chip Supported
from IGEL
0S Version

Intel AC9260 11.04.100

QCA6174 11.04.100
802.11ac

Intel AC9260 11.05.100

Comet Lake 11.05.100
PCH CNVi
WiFi, Intel

Intel AX201  11.08.240

Intel AX200 11.08.240

Mediatek 11.08.240
MT7921

Wi-Fi 6 11.05.100
AX200, Intel

QCA6174 11.05.100
802.11ac

AMD RZ616 11.08.230
2X2AX (WiFi
6E)

Wi-Fi 6 11.08.240
RTL8852BE

Wi-Fi 6 AX201

IGEL

Notes

Excluding
support for
WWAN
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Name

K14 Intel
Gen1l

ThinkPad
L14 Intel
Gen3

ThinkEdge
SE10

ThinkPad
L14 AMD
Gen 4

ThinkPad
L15 AMD
Gen4

ThinkPad
L14 Intel
Gen4

ThinkPad
L15 Intel
Gen4

ThinkPad
L13 Intel
Gen4

IGEL OS Articles

Minimum Storage

256 GB

512 GB

1TB

256 GB

256 GB

256 GB

Device

Category Memory Size
(RAM)
Size

Laptop/ 16GB

Notebook

Laptop/ 16GB

Notebook

Thin 8 GB

Client

Thin 8 GB

Client

Thin 8 GB

Client

Laptop/ 8GB
Notebook

Laptop/ 8GB
Notebook

Laptop/ 8GB
Notebook

256 GB

256 GB

256 GB

IGEL

Processor Wi-FiChip Supported Notes
from IGEL
OS Version
Intel Core Intel AX210 11.08.290
i5-1135G7 WiFi/BT
combo
Intel Core IntelWi-Fi6 11.08.330 LTE support
i5-1235U  AX201 2x2 AX as of
vPro 11.08.360
Intel Atom MediaTek 11.08.360
X6425RE  MTT7921LEN
Intel Atom Intel AX210 11.08.360
X6214RE
AMD Ryzen AMD RZ616 11.08.440  Quectel
3 Pro EMO05-G 4G
Realtek
7330U RTL8852CE CAT4
AMD Ryzen AMD RZ616 11.08.440 Quectel
3 Pro EMO05-G 4G
Realtek
7330U RTL8852CE CAT4
Intel Core Intel AX211 11.09.100 Quectel
i3-1315U EMO05-G 4G
CAT4
Intel Core Intel AX211 11.09.100 Quectel
i3-1315U EMO05-G 4G
CAT4
Intel Core Intel AX201 11.09.210  Quectel
i3-1315U EMO05-G 4G
CAT4
No
integrated
LAN
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IGEL

Name Device  Minimum Storage Processor Wi-Fi Chip Supported Notes
Category Memory Size from IGEL
(RAM) OS Version
Size

ThinkPad Laptop/ 16GB 256 GB AMD Ryzen AMD RZ616 11.09.210  Quectel

L13 AMD Notebook 3 PRO EMO05-G 4G

Gen 4 7330U CAT4
No
integrated
LAN

Lenovo Docking Stations

Name Supported from IGEL OS Version

ThinkPad USB-C Hybrid Dock 11.07.100

IOBOX 11.07.100

Universal USB-C Dock 11.08.440

Lenovo USB-C to Ethernet Adapter

Name Supported from IGEL OS Supported with

Version
USB-C to Ethernet Adapter 11.09.260 + ThinkPad L13 Intel Gen4

+ ThinkPad L14 AMD Gen4

LG

Name Device Minimum Storage Size Processor
Category Memory
(RAM) Size

24CK550** All in One 4GB 32GB AMD G-Series

(see page GX-212JJ

121)

24CK560** All in One 4GB 32GB AMD G-Series

(see page GX-212JJ

121)

CK500 Thin Client 4GB 32GB AMD G-Series
GX-212JJ

IGEL OS Articles

Supported from

IGEL OS Version

11.01.100

11.01.100

11.01.100
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Device
Category

Name

Allin One
Allin One
Thin Client

38CK950
38CK900

CL600ON
CL600W  Thin Client
34CN650 Allin One
24CN650 Allin One
27CN650 Allin One
CQ600 Thin Client
24CQ650 Allin One
CQ601 Thin Client
24CR670 AllinOne
34CR650 AllinOne

27CQ650 Allin One

LG Docking Stations

Name

LG USB Multi Port Hub

OnLogic

IGEL OS Articles

Minimum
Memory
(RAM) Size

8GB
8GB
4GB

8 GB

4GB

8GB

8GB

4GB

4GB

4GB

4GB

4GB

4GB

Storage Size Processor

128 GB
128 GB
16 GB

128 GB

16 GB

16 GB

16 GB

16 GB

16 GB

16 GB

16 GB

16 GB

16 GB

AMD Ryzen 3
AMD Ryzen 3

Intel® Celeron
J4105

Intel® Celeron
J4105

Intel® Celeron
J4105

Intel® Celeron
J4105

Intel® Celeron
J4105

Intel Celeron
N5105

Intel Celeron
N5105

Intel Pentium
Silver N6005

Intel Celeron
N5105

Intel Celeron
N5105

Intel Celeron
N5105

IGEL

Supported from
IGEL OS Version

11.02.100
11.02.100
11.03.100

11.03.100

11.05.100

11.05.100

11.05.100

11.08.330

11.08.330

11.08.360

11.09.110

11.09.210

11.09.210

Supported from IGEL OS Version

11.09.100
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IGEL

Name Device Minimum Storage Size Processor Supported from
Category Memory IGEL OS Version
(RAM) Size
CL210G-10 IndustrialPC/ 4GB 32GB Intel Celeron 11.04.100
Terminal N3350
KARBON 300 Desktop PC 4GB 32GB Intel Atom x5- 11.04.100
E3930

Onyx Healthcare

Name Device Minimum Storage Size Processor Supported from
Category Memory IGEL OS Version
(RAM) Size
Venus 223 MedicalAllin 4GB 128 GB Intel Quad-Core 11.01.100
One J1900
Pepperl+Fuchs
Name Device Category Minimum Storage Size Processor Supported from
Memory IGEL OS Version
(RAM) Size
BTC12N Industrial Box 4GB 32GB Intel Apollo Lake 11.09.100
Thin Client N4200
BTC14N Industrial Box 4GB 32GB AMD Ryzen 11.09.100
Thin Client Embedded
V1202B
Rein Medical
Name Device Minimum Storage Size Processor Supported from
Category Memory IGEL OS Version
(RAM) Size
Silenio C122  Allin One 8GB 128 GB Intel® Core™i5-  11.01.110
6th Generation
Silenio C124 Allin One 8 GB 128 GB Intel® Core™i5- 11.01.110
6th Generation
Clinio S Medical Allin 8 GB 16 GB Intel® Pentium®  11.04.100
522TCT One Silver J5005
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IGEL

Name Device Minimum Storage Size Processor Supported from

Category Memory IGEL OS Version
(RAM) Size

Clinio S Medical Allin 8 GB 16 GB Intel® Pentium®  11.04.100

524TCT One Silver J5005

Secunet

Name Device Minimum Storage Size Processor Supported from

Category Memory IGEL OS Version
(RAM) Size
SINA Workstation Workstation 16 GB 256 GB Intel Core 11.01.100
S EliteDesk 800 G2 i7-6700

USB Memory Sticks That Can Be Used as UD Pocket Hardware

DIGITTRADE

Name Storage Supported from IGEL OS Version
Kobra Stick > 4GB 11.05.133

Transcend

Name

Powered by IGEL UD Pocket (see page 108)
Powered by IGEL UD Pocket 2 (see page 108)

Officially Supported Virtual Environments
+ Tested with Ubuntu (64-bit) and default settings

A Notethat the use of a UD Pocket within a virtual machine is not supported by IGEL.

() Forsome features, more than 2 GB RAM is required. Example: if you use dual monitor environments, a
virtual machine must have at least 8 GB RAM.

Name Memory Storage Type Supported from IGEL OS
(RAM) Version
Oracle VM VirtualBox  =2GB >4 GB Linux 11.04.100
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IGEL

Name Memory Storage Type Supported from IGEL OS
(RAM) Version
VMware Workstation >2GB >4 GB Linux 11.04.100

* Delock Adapter DP 1.2 to DVI does not work.
** When using an additional 4k screen with this device, please edit the BIOS settings as follows:

1. Goto the Chipset screen.
2. SetIntegrated Graphics to “Force”.
3. Set UMA Frame Buffer Size to “256M” or higher

When you have confirmed that your devices can be upgraded to IGEL OS 11, make sure to consider Important!
Consider This Before Upgrading (see page 122).
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Important! Consider This Before Upgrading

To make sure that your upgrade can be successful, check the following warnings and notes; a warning symbol
indicates that irreversible damage can be done to your devices.

© Existing partitions: Any existing partition on the target drive of your device will be deleted. The installer
will repartition the target device. The overall size of the newly created partitions will be calculated based
on the available disk space. The minimum disk usage is 2 GB, the maximum is 16 GB.

© NoDowngrade

You cannot restore your IGEL OS 10 system once you have migrated to IGEL OS 11. The device storage is
overwritten completely with a new partitioning scheme.

© Features (e.g. Clients)

IGEL OS 11 does not have the complete feature set of IGEL OS 10. Make sure that the current version of
IGEL OS 11 meets your requirements. For details, refer to the appropriate release notes.

© Custom Partitions

The contents of custom partitions will be deleted by the upgrade. Make sure to back up the contents and
restore them after the upgrade has finished. Besides becoming dysfunctional after the upgrade,
applications and kernel drivers in a custom partition might corrupt the upgrade. For this reason, make
sure to first test the upgrade on a characteristic device. We recommend that you disable custom partitions
when upgrading; you can enable them once the upgrade has been successfully completed.

© Custom Commands

The persistence of custom commands cannot be guaranteed. Besides becoming dysfunctional after the
upgrade, custom commands might corrupt the upgrade. For this reason, make sure to first test the
upgrade on a characteristic device. In general, custom commands must be adapted for IGEL OS 11. We
recommend that you disable custom commands when upgrading; you can enable them once the upgrade
has been successfully completed.

© Power Supply

Ensure that the device is not running on battery power, i.e. it must be connected to a power supply during
the complete upgrade process.

() Network

All devices must be connected to a WLAN or LAN. LAN is the recommended option. The device will not be
upgraded if connected to OpenVPN, OpenConnect, genucard or mobile broadband.

When you have considered everything that is relevant, continue with Preparing the Upgrade (see page 123).
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Preparing the Upgrade

This section describes the required preparations and tests before any productive devices can be updated. The
testing should be done with at least one device that is characteristic of your environment. This device should have
every custom partition and every custom command that may possibly exist in any of your devices.

To prepare the upgrade, perform the following steps:

1. Preparing the UMS (see page 124)

2. Adjusting the Setup (see page 125)

3. Deploying a License (see page 126)

4. Configuring the Update Source (see page 127)
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Preparing the UMS

To upgrade your devices to IGEL OS 11, you need the appropriate version of the UMS. Also, the devices must be
registered with the UMS to receive their licenses.

1. If you have not already done so, update your UMS to version 6.01.130 or higher. For instructions,
see Updating UMS.

2. Make sure that your devices are registered with the UMS. For more information, see the
chapter Registering IGEL OS Devices on the UMS Server in the UMS Manual.

When the UMS is ready, continue with Adjusting the Setup (see page 125).
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Adjusting the Setup

Depending on the features that are in use now or will be used in the future, a specific set of parameters must be set
in the device's Setup.

1. Inthe Setup, go to System > Firmware Update > OS 11 Upgrade.
2. Make your settings as appropriate:
+ Activate Upgrade to OS 11.

(0 When Upgrade to OS 11 is activated, the device checks for a Workspace Edition license and
stops checking for a legacy UDC3 or UD Pocket license. Therefore, in the UMS, it is displayed
as an unlicensed device until a Workspace Edition license has been deployed.

+ If you want the device to retry the upgrade immediately after a failed attempt,
activate Upgrade to OS 11 even if a previous upgrade attempt failed. The device will retry
the upgrade 5 times. When the 5th attempt has failed, a message will be shown in the
upgrade tool window.

+ If your device has a PowerTerm license, and you want to upgrade to IGEL OS 11 even though
it does not support PowerTerm, you must activate Upgrade to OS 11 even if PowerTerm is
enabled.

+ Under Require an Enterprise Management Pack license to upgrade to OS 11, select the
appropriate option:

+ Ifyou are using IGEL Cloud Gateway (ICG) or Shared Workplace (SWP) or a Custom
Partition and want to make sure that the upgrade is performed only if these features
can be used furthermore, select Smart. When this option is selected, and any of these
features is activated, the upgrade is performed only if the device could fetch a license
from an Enterprise Management Pack.

+ If you want to force the device to fetch a license from an Enterprise Management
Pack and make sure that the upgrade is performed only if the license could be
fetched, select Always.

+ If you want the device to upgrade to IGEL OS 11 without fetching an Enterprise
Management Pack, disregarding the features that might be activated, select Never.

+ Under Timeout waiting for OS 11 license to start automatic upgrade, set the time period
the device will wait for a license in a mass deployment scenario (see Zero-Touch
Deployment Using Universal Firmware Update (see page 67), Zero-Touch Deployment Using
Buddy Update (see page 107) and Mass Deployment Using a Scheduled Job (see page 212)). This
setting prevents the device from starting the upgrade at an inappropriate time as a result of
the license just being deployed. This way, the setting prevents unwanted interruptions at
work. For a mass deployment scenario, the default value 10 Minutes is recommended.

3. Click Apply.

When the Setup is adjusted, continue with Deploying a License (see page 126).
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Deploying a License

To upgrade from IGEL OS 10 to IGEL OS 11, you need an appropriate license. Depending on your requirements, one
or more of these licenses will be needed for each device:

+ One Workspace Edition license for basic functionality; see Workspace Edition
+ If one of the following features are used, one Enterprise Management Pack license is required
(see Enterprise Management Pack):
+ IGEL Cloud Gateway (ICG)
+ Shared Workplace (SWP)
+ Custom Partition if IGEL OS 11.03.100 or lower is the target version; if the target version is
IGEL OS 11.03.500 or higher, the Custom Partition feature is included in the Workspace
Edition.

Proceed as follows:

> Deploy the licenses for IGEL OS 11 using the method that suits your needs:

+ Manual License Deployment: Licenses are created and deployed manually. For instructions,
see Manual License Deployment for IGEL OS.
+ Automatic License Deployment (ALD): Licenses are created and deployed automatically to each
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).
+ Download three demo licenses from https://www.igel.com/download/.

When the device has a license, continue with Configuring the Update Source (see page 127).
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Configuring the Update Source

1. Inthe Setup, go to System > Update > Firmware Update and configure the update source for
IGEL OS 11. For more information, see the Firmware Update chapter in the IGEL OS Manual.
2. Click Ok.

When the correct update source is configured, continue with Testing the Upgrade (see page 128).
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e

IGE

Testing the Upgrade

1. Click E] System and then Upgrade to OS 11. The OS 11 Upgrade Tool starts and indicates
whether all requirements are met.

() You can change the starting the starting methods for the OS 11 Upgrade Tool in the Setup under
Accessories > 0S11 Upgrade.

0S 11 Upgrade x

Q Hardware
0 License
Q Setup

Q Update Source

o Network

IGELOST10->11

Close 05 Upgrade

2. Check the output of the OS 11 Upgrade Tool and continue appropriately:
« If each requirement has an o icon, click OS Upgrade to start the upgrade process.

+ If one or more requirements have an ® icon, check the messages and resolve the
issues. Afterwards, click Check again. If all requirements are met, the button changes to 0S
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Upgrade, and you can start the upgrade.
0S 11 Upgrade x

Q Hardware
o License
® Setup
® Powerterm

® Update Source

IGELOS10->11 |

Setup: PowerTerm will not be available in 05 11. To proceed, activate 'Upgrade to 05 11 even if PowerTerm is
enabled' at IGEL Setup = System > Update > 05 11 Upgrade.

Update Source: Please configure a valid OS 11 update source at 'System > Update = Firmware Update’ and
check your network connection.

Network: Please disable all VPN/Mobile Broadband network connectivity on the device. Otherwise it cannot be
guaranteed that your update source will be reachable after the upgrade.

Close Check again

When you start the upgrade, a warning dialog is shown.
3. Click OK to continue.

Confirm Upgrade to 0S 11

With this upgrade, IGEL 0S 11 will be installed on the device.
It is not possible to downgrade to IGEL OS 10 afterwards.

| ¥ Cancel

A warning dialog with a timeout is shown. If you click Cancel before the timeout expires, the
upgrade is canceled. If you click OK or just wait for the timeout to expire, the upgrade is started
Upgrade - A

Please note: With this upgrade, IGEL 0S 11 will be installed on
the device. It is not possible to downgrade to IGEL OS 10
afterwards.

This upgrade involves a critical phase in which the device
must not be powered off. The critical phase will be indicated
by a flashing warning. You will be notified after the upgrade
has finished successfully.

54 seconds remain

¥ Cancel

After the warning dialog has been confirmed or the timeout has expired, the device reboots into a
special IGEL OS 10 environment, in which the system upgrade is executed. The Upgrade window
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show the progress.
Upgrade

IGELOS

During the critical phase, the device must not be powered off. At this stage in the progress, an
additional warning is shown.

Upgrading base system.
DO NOT POWER OFF YOUR DEVICE!

When the base system is upgraded successfully, a message is shown.

0 Upgraded base system successfully.

The remaining components of the firmware are installed, which is indicated by update messages.

Firmware update

System

34%

When the installation is completed, the Upgrade window looks like this:
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Upgrade

IGELOS10->11

After a few seconds the device reboots into IGEL OS 11.

]

Local Terminal

\\m///ﬁ;
Z-1GEL

Congratulations
l The upgrade to IGEL OS 11 is now
complete

P X W |t 1020

When the upgrade test has been successful, you are ready to set up the mass upgrade. Continue with Checking the
Requirements (see page 132).
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Checking the Requirements
The following requirements must be met:

+ The upgrade has been tested with characteristic devices.

+ UMS6.01.130 or higher is available.

+ The firmware IGEL OS 10.05.800 (or higher) is known to the UMS. For this purpose, a device
with this firmware version must be registered in the UMS. This is already the case if you tested the
upgrade with the same UMS with which you are about to do the mass upgrade. If not, you must
register a device with the appropriate firmware version now.

+ All devices are connected to a regular LAN (not OpenVPN, OpenConnect, genucard, NCP VPN or
mobile broadband).

+ All devices are in a safe environment where the upgrade process cannot be disrupted, e.g. by
powering off the devices.

When all requirements are met, continue with Configuring Two Update Buddies (see page 133).
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Configuring Two Update Buddies
For setting up buddy updates, see the how-to Buddy Update (see page 230).

© Ensure that the network contains only the update buddies and the devices that are to be updated. This
prevents other devices from updating inadvertently.

1. Update one device to the appropriate IGEL OS 10 firmware (10.05.800 or higher) and configure it as
an update buddy.

2. Upgrade another device to IGEL OS 11 and configure it as an update buddy. Make sure that the
IGEL OS 11 update buddy has the same User Name and Password in System > Update > Buddy
Update as the IGEL OS 10 update buddy.

When the update buddies are configured, continue with Creating a Profile (see page 134).
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Creating a Profile

1.

Create a profile that is based on the appropriate IGEL OS 10 version (10.05.800 or higher). Find a
suitable name for the profile, e.g. "Firmware upgrade to IGEL OS 11".
In the profile's configuration dialog, go to System > Update > Firmware Update and change the
settings as follows:

+ Select "FTP" as Protocol.

+ Enter User Name and Password according to the update buddy server.

+ Activate Automatic Update Check on Boot.

« Ensure that Automatic Update Check on Shutdown is deactivated. Otherwise, the device

will shut down when the upgrade to 0S 10.05.800 is finished.
+ Activate Automatic Buddy Detection.

Allow firmware upgrade te IGEL 0S5 11

Related Configurations

A
A

A

€ » FIPUSER

Search

3. Go to System > Update > 0OS 11 Upgrade and change the following settings according to your

successful upgrade test (for details, see Adjusting the Setup (see page 125)):
« Activate Upgrade to OS 11.
+ Set Upgrade to OS 11 even if PowerTerm is enabled according to your needs.
+ Set Require an Enterprise Management Pack license to upgrade to OS 11 according to
your needs.
+ Set Timeout waiting for OS 11 license to start automatic upgrade to 10 Minutes.

4. Go to System > Remote Management and change the settings as follows:

« Deactivate Display 'Apply changes' dialog on boot.
+ Set Default action on boot to Apply changed configuration immediately.
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Allow firmware upgrade te IGEL 0S5 11
14 > A ! * Rel

Configuration

a0
Timeout

Defal

A

Timeout

Search

5. Click Save.

When the profile es created, continue with Deploying the Licenses (see page 136).
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Deploying the Licenses
Deploy the licenses for IGEL OS 11 using the method that suits your needs:

+ Automatic License Deployment (ALD): Licenses are created and deployed automatically to each
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).

+ Manual License Deployment: Licenses are created and deployed manually. For instructions,
see Manual License Deployment for IGEL OS.

When the license deployment is set up, continue with Putting It All Together (see page 137).
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Putting It All Together

1. Assign the profile to all devices that are to be upgraded. This can be done by assigning the profile
to the directory that contains these devices.

© Do notassign the profile to the update buddies.

2. Inthe context menu of the assignment, select Now.
3. For Automatic license deployment, a condition can be set to the directory. For more information,
see Configuring the Distribution Conditions, section "Distributing Licenses to Devices in a

Specified Directory".

When everything is in place, continue with Executing the Upgrade (see page 138).
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Executing the Upgrade

1. Inthe UMS,; select all devices that are to be upgraded and reboot them.

() Alternatively, you can create a scheduled job for reboot or wake up and assign it to the devices or
the directory containing these devices; for more information, see Jobs.

On reboot or wake up, the devices choose the IGEL OS 10 buddy. They ignore the IGEL OS 11 buddy
at this stage because this version is not known to them yet. The devices update to the appropriate
IGEL OS 10 version (10.05.800 or higher). With this version, the Upgrade to OS 11 parameter is
recognized by the devices; also, the devices request IGEL OS 11 licenses from the UMS (Workspace
Edition and, if required, Enterprise Management Pack).

If no IGEL OS 11 licenses have been deployed on the devices yet, the licenses are deployed within a
few minutes. The upgrade will be started when the licenses are deployed. The maximum time
period the device will wait for a license is configured by the parameter Timeout waiting for 0S 11
license to start automatic upgrade; for details, see Adjusting the Setup (see page 125).

The parameters Automatic update check on boot and Automatic buddy detection cause the
devices to look for a new firmware and wait for an IGEL OS 11 update buddy to reply. When an IGEL
0S 11 update buddy is found, the devices start the upgrade process.

() Update Can Be Canceled After Timeout

An ongoing update can be canceled by the user if the "network online" status could not be reached
within 10 seconds after the firmware update has been started. When the user has canceled the
update, the normal desktop environment is started, just as before the update. This applies to the
following cases:

+ Regular firmware update, e.g. from IGEL OS 11.03.500 to IGEL OS 11.04

« Afeature has been activated, e.g. VPN OpenConnect.

« A Custom Partition has been activated or changed.

2. When all devices have been upgraded successfully, remove the "Firmware upgrade to IGEL OS 11"
profile.

The upgrade is completed.
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Mass Deployment Using a Scheduled Job

This scenario is appropriate if you already have a working environment with IGEL OS 10.05.800 (or higher) and want
to update all devices to IGEL OS 11 at a defined time.

Read all the following chapters carefully and follow the instructions.

1. Checking the Requirements (see page 140)
Creating a Profile (see page 141)
Deploying the Licenses (see page 145)
Assigning the Profile (see page 146)
Creating the Scheduled Job (see page 148)

ok wnN
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Checking the Requirements
The following requirements must be met:

+ The upgrade has been tested with characteristic devices.

+ UMS6.01.130 or higher is available.

+ The firmware IGEL OS 10.05.800 (or higher) is known to the UMS. For this purpose, a device
with this firmware version must be registered in the UMS. This is already the case if you tested the
upgrade with the same UMS with which you are about to do the mass upgrade. If not, you must
register a device with the appropriate firmware version now.

+ All devices are connected to a regular LAN (not OpenVPN, OpenConnect, genucard, NCP VPN or
mobile broadband).

+ All devices are in a safe environment where the upgrade process cannot be disrupted, e.g. by
powering off the devices.

When all requirements are met, continue with Creating a Profile (see page 141).
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Creating a Profile

1. Create a profile that is based on the appropriate IGEL OS 10 firmware version (10.05.800 or higher).
Find a suitable name for the profile, e.g. "Scheduled firmware upgrade to IGEL OS 11".

MNew Profile
Profile Name Scheduled firrrware upgrade to IGEL 0F 11
Diescriptian

Inhetits Settings fram Profiles (11

Ipgrade to IGEL 05 11

Based on IGEL Universal Desktop

Cancel
2. Inthe profile's configuration dialog, go to System > Update > Firmware Update and change the

settings according to your environment:

() Ifyouuse Universal Firmware Update (see page 175) for OS 11, you do not need to configure the
settings described in this step.

+ Select an update source for IGEL OS 11. For further information, see Firmware Update.

() Ifyou use FILE as the protocol (local file or network drive), the device will show an error
message and go through an additional reboot. Apart from that, the upgrade will work
normally.

« Ensure that Automatic Update Check on Boot and Automatic Update Check on
Shutdown are deactivated.

(@ Inthefollowing screenshot, FTP is used as an example. The other protocols can be used as
well.
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Scheduled firmware upgrade to IGEL OS 11

< > ~ pdate * Fir

. Related Configurations
Configuration B

Search

3. Go to System > Update > 0OS 11 Upgrade and change the following settings according to your
successful upgrade test:

« Activate Upgrade to OS 11.
+ Set Upgrade to OS 11 even if PowerTerm is enabled according to your needs.
+ Set Upgrade to OS 11 even if a previous upgrade attempt failed according to your needs.

+ Set Require an Enterprise Management Pack license to upgrade to OS 11 according to
your needs.

« Ensure that the Timeout waiting for OS 11 license to start automatic upgrade is set to 10
Minutes.
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Scheduled firmware upgrade to IGEL OS 11

> Upda

Search

4. Go to System > Remote Management and change the settings as follows:
« Deactivate Display 'Apply changes' dialog on boot.
+ Set Default action on boot to Apply changed configuration immediately.
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Allow firmware upgrade te IGEL 0S5 11
14 > A ! * Rel

Configuration

a0
Timeout

Defal

A

Timeout

Search

5. Click Save.

When the profile is created, continue with Deploying the Licenses (see page 102).
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Deploying the Licenses
Deploy the licenses for IGEL OS 11 using the method that suits your needs:

+ Automatic License Deployment (ALD): Licenses are created and deployed automatically to each
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).

+ Manual License Deployment: Licenses are created and deployed manually. For instructions,
see Manual License Deployment for IGEL OS.

When the license deployment is set up, continue with Assigning the Profile (see page 146).
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Assigning the Profile

1. Putall devices that are to be updated into a directory.

¥ |L—| Devices (4)
¥ B Remote Devices (1)
L ITCO0EDCST1 4345

g D3
¥ i Upgrade to IGEL OS5 11 (1)

1 ITCoonBCANSS01 8

WL (00

- ,' ITCOOEQCSTCA087
2. Select the directory and in the Assigned objects area, click @

Server-172.30.92.9

e 6

£l iTcoo.
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IGEL

3. Assign the profile (see Creating a Profile (see page 141)) to the directory and click Ok.
New Scheduled Job

Select assignable objects

4,

When the profile is assigned, continue with Creating the Scheduled Job (see page 148).
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Creating the Scheduled Job
1. Inthe UMS, select Jobs > New Scheduled Job.

Server -172.30.92.9

T
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New Scheduled Job

Details

Mame
Command
cution tire  11:53 Start date  2013- V' Enahled

Comment

Options
v Lo gre

Timeaut

Joh-Info

Joh 1D

Mext Execution  Apr10, 201911

Liser
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3. Under Command, select OS 11 Upgrade.
New Scheduled Job

Details
Marme
Cammand
cution firme  11°53 Start dlate 2018 v Enabled

Comment

Options
v Lo gre

Tirmeaut
Joh-Info

Joh 1D

Mext Execution  Apr10, 201911

Liser
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IGEL

4. Under Execution time and Start date, set the time at which the upgrade should be executed, and
click Next.

New Scheduled Job

Details

Mame

Command | 1 Upgrade

Execution time  11:53 Start date  2013- V' Enahled

Comment

Options
v Log
Max. Thres
Timeaut
Joh-Info
Joh 1D

Apr1o, 201911
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5. Review the execution time and click Next.
New Scheduled Job
Schedule

tion tirme 11: Sit: 2019-04-10

wpiration date

hour

Comment

Cancel jobh execution
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6. Assign the directory containing the devices to the job and click Finish.

New Scheduled Job

Select assignable objects

Finish

() Update Can Be Canceled After Timeout

An ongoing update can be canceled by the user if the "network online" status could not be reached
within 10 seconds after the firmware update has been started. When the user has canceled the
update, the normal desktop environment is started, just as before the update. This applies to the
following cases:

+ Regular firmware update, e.g. from IGEL OS 11.03.500 to IGEL OS 11.04

« Afeature has been activated, e.g. VPN OpenConnect.

« A Custom Partition has been activated or changed.

The upgrade is completed.
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Troubleshooting

This section describes possible error cases and solutions.
+ Regaining a Usable System (see page 155)
+ Getting Error Messages (see page 156)

+ Starting an New Upgrade Attempt (see page 157)
+ Starting Another Upgrade Attempt after 5 Retries (see page 158)
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Regaining a Usable System

Here you can find typical upgrade failures and the appropriate methods to regain a usable system.

Device Has Upgraded to Igel OS 11, but Does Not Boot Any More
To get a working IGEL OS 11 system:

» Use the IGEL OS Creator to recover the IGEL OS 11 system. For more information, see the IGEL OS Creator
Manual.

IGEL OS 10 Rescue System Fails to Update Missing Partitions

If a severe error has occurred during the upgrade process, the device boots into a minimal IGEL OS 10 (10.05.800 or
higher) rescue system. If unattended, the device tries to download and update the missing partitions and reboots
on failure.

To regain a full IGEL OS 10 system, you have two possibilities:

» In the rescue system, start the Setup, go to System > Update > Firmware Update and set a valid update source
for the appropriate IGEL OS 10 firmware (10.05.800 or higher).

Or:

> Configure a UMS profile that contains a valid update source for the appropriate IGEL OS 10 firmware (10.05.800
or higher) under System > Update > Firmware Update and assign it to the device.
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Getting Error Messages

> Open the 0S 11 Upgrade Tool (default path: click E] System and then Upgrade to OS 11).

The OS 11 Upgrade Tool shows the error messages. The most important message is prefixed with Retries; see the
example below:

05 11 Upgrade

& Hardware
ﬁ License
I:E!::I SEtup

ﬁ Lipdate Saiante

IGELOS10-211

Stup: The upgrade Lo OS 11 has faled previously. To try sgain acthvate Upgrade to IGEL 05 11 even f a
mwmwm‘w?w} m.
Retries: Could not write the new System partition to permanent Storage.

Closa Chachk again

> Formore information, review the main migration log under /wfs/migration.log

() You can use the system log viewer to review the migration log (see the chapter System Log Viewer in the
IGEL OS Manual) or save the log files in order to send them to the IGEL Support Team (see the chapter Save
Device Files for Support support).
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Starting an New Upgrade Attempt
If you want the device to start multiple upgrade attempts (and the device is not already configured to do so):

1. Inthe UMS profile or in the Setup, go to System > Update > OS 11 Upgrade and activate Upgrade
to OS 11 even if a previous upgrade attempt failed.
2. Reboot the device.
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Starting Another Upgrade Attempt after 5 Retries

When the Upgrade to OS 11 even if a previous upgrade attempt failed option is set and the upgrade has failed
each time, the system will stop trying after 5 attempts.

To reset the retry counter:

1. Inthe Setup or the UMS profile, go to System > Update > OS 11 Upgrade and deactivate Upgrade
to OS 11 even if a previous upgrade attempt failed.

2. When the setting is effective on the devices, go to System > Update > OS 11 Upgrade again and
activate Upgrade to OS 11 even if a previous upgrade attempt failed..
The retry counter is reset, and the devices will try upgrading another 5 times, if necessary.
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Upgrading IGEL Devices from IGEL OS 10 to IGEL OS 11

This document describes how to upgrade any number of IGEL Universal Desktop devices (UD) from IGEL OS 10 to
IGEL OS 11.

IGEL OS 10.05.700 or higher is required for upgrading to IGEL OS 11. If you have an older version of IGEL OS 10, you
need to update to version 10.05.700 or a higher version first.

The following methods of mass deployment are described here:

« Zero-Touch Deployment Using Universal Firmware Update (see page 160): Mass upgrade from any
version of IGEL OS 10 to IGEL OS 11 in one step using Universal Firmware Update. This method can
be started immediately or as a scheduled job (wake up or reboot).

+ Zero-Touch Deployment Using Buddy Update (see page 191): Mass upgrade from any version of IGEL
0S 10 to IGEL OS 11 in one step using two devices as update buddies. This method can be started
immediately or as a scheduled job (wake up or reboot).

+ Mass Deployment Using a Scheduled Job (see page 212): Upgrade devices that are already running
IGEL OS 10.05.700 (or higher) using a specific scheduled job.
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Zero-Touch Deployment Using Universal Firmware Update

This method is the most convenient way to upgrade from IGEL OS 10 to IGEL OS 11. The method uses the Universal
Firmware Update feature of the UMS (Universal Management Suite) and a profile.

Read all the following chapters carefully and follow the instructions.

IGEL Devices That Can Be Upgraded to IGEL OS 11 (see page 161)
Important! Consider This Before Upgrading (see page 163)
Preparing the Upgrade (see page 165)

Testing the Upgrade (see page 170)

Checking the Requirements (see page 174)

Creating the Universal Firmware Updates (see page 175)
Creating a Profile (see page 180)

Deploying the Licenses (see page 185)

Putting It All Together (see page 186)

Executing the Upgrade (see page 189)

WoeNoOkwWwNE

=
e
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IGEL Devices That Can Be Upgraded to IGEL OS 11

Core Requirements for IGEL OS 11

« CPU with 64-bit support
« CPUspeed:=1GHz
+ Memory (RAM): =2 GB

() RAMsize higher than 2 GB is recommended if you use any of the following:

+ Unified Communications optimizations (uses a client-side media engine)

+ High-resolution graphics output
For details on the supported graphics-related characteristics of IGEL devices,
see Graphics on IGEL Devices or, for older devices, Graphics on Legacy IGEL

Devices.

« More than two monitors

+ Storage: 2 GB minimum; =4 GB recommended

() Storage Requirements for IGEL OS 11.04 or Higher

IGEL OS 11.04.100 or higher requires at least 2.4 GB storage if the full feature set is applied. Thus,
the feature set must be modified accordingly; for more information, see Error: "Not enough space
on local drive" when Updating to IGEL OS 11.04 or Higher.

IGEL Devices Supported by IGEL OS 11

IGEL UD (Universal Desktop)

Product Line Device Type Hardware ID

UD2**** (see D220

page 162)

UD2" (see page M250C

162)

ubD2

M250C

UD3* (see page M340C

162)

UD3" (see page M340C

162)

uD3

IGEL OS Articles

M350C

40

50

51 /52" (see
page 162)

50

51

60

64 Bit

Yes

Yes

Yes

Yes

Yes

Yes

Memory
(RAM)
2GB
2GB
20r4GB
2GB

2GB

4GB

Storage

4GB

4GB

8 GB

4GB

4GB

8 GB

HW Video

Acceleration

Yes

Yes

Yes

Yes

Yes

Yes
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IGE

ProductLine Device Type HardwarelD 64Bit Memory  Storage HW Video

(RAM) Acceleration
UD5" (see page H830C 50 Yes 2GB 4GB Yes
162)
UD6™ (see page H830C 51 Yes 2GB 4GB Yes
162)
ub7 H850C 10 Yes 4GB 4GB Yes
UD7** (see page H850C 11 Yes 4GB 4GB Yes
162)
uD7 H860C 20 Yes 8 GB 8 GB Yes
UD9" (see page TC215B 40/ 41 (Touch) Yes 2GB 4GB Yes
162)

* IGEL UD3-LX 50 and UD5-LX 50 are supported up to IGEL OS 11.05, incl. private builds.
IGEL UD9-LX 40 / 41 (Touch) devices are supported up to IGEL OS 11.07.910.

IGEL UD2-LX 50 devices are supported up to IGEL OS 11.09.160.

IGEL UD3-LX 51 devices are supported up to IGEL OS 11.09.160.

IGEL UD6-LX 51 devices are supported up to IGEL OS 11.09.160.

** As of December 2019, IGEL UD7 model H850C is equipped with the AMD Secure Processor; for further information,
see UD7 Model H850C.

***|GEL UD2-LX 52 is supported with IGEL OS 11.06.140 and later.

**** UD2-LX 40 (model D220) is supported up to IGEL OS 11.08.200. For an overview of the end-of-sales (EOS) and
end-of-maintenance (EOM) dates for IGEL devices, see IGEL OS 11 or Higher (see page 161).

IGEL Zero

() NoteonIZDevices

The 1Z devices listed below can be upgraded to IGEL OS 11. To upgrade your IZ devices to IGEL OS 11,
please contact your IGEL sales representative. See also https://www.igel.com/os11migration/.

Product Device Hardware 64 Bit MemoryStorage UEFI Secure HW Video

Line Type ID (RAM) Boot Support Acceleration
1Z2 D220 40 Yes 2GB 4GB Yes Yes
1Z3 M340C 50 Yes 2GB 4GB Yes Yes
1Z3 M340C 51 Yes 2GB 4GB Yes Yes

When you have confirmed that your devices can be upgraded to IGEL OS 11, make sure to consider Important!
Consider This Before Upgrading (see page 163).
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Important! Consider This Before Upgrading

To make sure that your upgrade can be successful, check the following warnings and notes; a warning symbol
indicates that irreversible damage can be done to your devices.

© NoDowngrade

You cannot restore your IGEL OS 10 system once you have migrated to IGEL OS 11. The device storage is
overwritten completely with a new partitioning scheme.

© Features (e.g. Clients)

IGEL OS 11 does not have the complete feature set of IGEL OS 10. Make sure that the current version of
IGEL OS 11 meets your requirements. For details, refer to the appropriate release notes.

© Custom Partitions

The contents of custom partitions will be deleted by the upgrade. Make sure to back up the contents and
restore them after the upgrade has finished. Besides becoming dysfunctional after the upgrade,
applications and kernel drivers in a custom partition might corrupt the upgrade. For this reason, make
sure to first test the upgrade on a characteristic device. We recommend that you disable custom partitions
when upgrading; you can enable them once the upgrade has been successfully completed.

© Custom Commands

The persistence of custom commands cannot be guaranteed. Besides becoming dysfunctional after the
upgrade, custom commands might corrupt the upgrade. For this reason, make sure to first test the
upgrade on a characteristic device. In general, custom commands must be adapted for IGEL OS 11. We
recommend that you disable custom commands when upgrading; you can enable them once the upgrade
has been successfully completed.

() Network

All devices must be connected to a WLAN or LAN. LAN is the recommended option. The device will not be
upgraded if connected to OpenVPN, OpenConnect, genucard, NCP VPN or mobile broadband.

() Hardware Support

Make sure that your devices support IGEL OS 11; please refer to IGEL Devices Supported by IGEL OS 11.
This document describes upgrading methods for IGEL UD and IGEL 1Z devices. Upgrading methods for IGEL
UDC3 and UD Pocket are described under Upgrading UDC3 Devices from IGEL OS 10 to IGEL OS 11.

() License
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« Avalid license from an IGEL Workspace Edition (WE) Product Pack must be available for
each device. For general information, see IGEL Software License Overview. For deploying

licenses, see Setting up Automatic License Deployment (ALD) or Manual License
Deployment for IGEL OS.

+ |1Z devices are not allowed to upgrade to IGEL OS 11. Please contact your IGEL sales
representative for a UD Upgrade License which allows you to upgrade your IZ devices.

(@) UMS Version

UMS version 6.01.130 or higher is required for upgrading from IGEL OS 10 to IGEL OS 11.

When you have considered everything that is relevant, continue with Preparing the Upgrade (see page 165).
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Preparing the Upgrade

This section describes the required preparations and tests before any productive devices can be updated. The
testing should be done with at least one device that is characteristic of your environment. This device should have
every custom partition and every custom command that may possibly exist in any of your devices.

First of all, you should check thoroughly if IGEL OS 11 has all features required for your purposes.

> Continue with Preparing the UMS (see page 166).
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Preparing the UMS

To upgrade your devices to IGEL OS 11, you need the appropriate version of the UMS. Also, the devices must be
registered with the UMS to receive their licenses.

1. If you have not already done so, update your UMS to version 6.01.130 or higher. For instructions,
see Updating a UMS Installation.

2. Make sure that your devices are registered with the UMS. For more information, see the
chapter Registering Devices on the UMS Server in the UMS Manual.

When the UMS is prepared, continue with Adjusting the Setup (see page 167).
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Adjusting the Setup

Depending on the features that are in use now or will be used in the future, a specific set of parameters must be set
in the device's Setup.

1. Inthe Setup, go to System > Update > OS 11 Upgrade.
2. Make your settings as appropriate:

+ Activate Upgrade to OS 11.

+ If you want the device to retry the upgrade immediately after a failed attempt,
activate Upgrade to OS 11 even if a previous upgrade attempt failed. The device will retry
the upgrade 5 times. When the 5th attempt has failed, a message will be shown in the
upgrade tool window.

+ If your device has a PowerTerm license, and you want to upgrade to IGEL OS 11 even though
it does not support PowerTerm, you must activate Upgrade to OS 11 even if PowerTerm is
enabled.

+ Under Require an Enterprise Management Pack license to upgrade to OS 11, select the
appropriate option:

+ Ifyou are using IGEL Cloud Gateway (ICG) or Shared Workplace (SWP) or a Custom
Partition and want to make sure that the upgrade is performed only if these features
can be used furthermore, select Smart. When this option is selected, and any of these
features is activated, the upgrade is performed only if the device could fetch a license
from an Enterprise Management Pack.

+ If you want to force the device to fetch a license from an Enterprise Management
Pack and make sure that the upgrade is performed only if the license could be
fetched, select Always.

+ If you want the device to upgrade to IGEL OS 11 without fetching an Enterprise
Management Pack, disregarding the features that might be activated, select Never.

+ Under Timeout waiting for OS 11 license to start automatic upgrade, set the time period
the device will wait for a license in a mass deployment scenario (see Zero-Touch
Deployment Using Universal Firmware Update (see page 160), Zero-Touch Deployment Using
Buddy Update (see page 191) and Mass Deployment Using a Scheduled Job (see page 212)). This
setting prevents the device from starting the upgrade at an inappropriate time as a result of
the license just being deployed. This way, the setting prevents unwanted interruptions at
work. For a mass deployment scenario, the default value 10 Minutes is recommended.

3. Click Apply.
4. Continue with Deploying a License (see page 168).
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Deploying a License

To upgrade from IGEL OS 10 to IGEL OS 11, you need an appropriate license. Depending on your requirements, one
or more of these licenses will be needed for each device:

+ One Workspace Edition license for basic functionality; see Workspace Edition
+ If one of the following features is used, one Enterprise Management Pack license is required
(see Enterprise Management Pack):
+ IGEL Cloud Gateway (ICG)
+ Shared Workplace (SWP)
+ Custom Partition - if IGEL OS 11.03.100 or lower is the target version; in IGEL OS 11.03.500 or
higher, the Custom Partition feature is included in the Workspace Edition.

Proceed as follows:

> Deploy the licenses for IGEL OS 11 using the method that suits your needs:

+ Manual License Deployment: Licenses are created and deployed manually. For instructions,
see Manual License Deployment for IGEL OS.
+ Automatic License Deployment (ALD): Licenses are created and deployed automatically to each
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).
+ Download three demo licenses from https://www.igel.com/download/.

When the device has a license, continue with Configuring the Update Source (see page 169).
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Configuring the Update Source

1. Inthe Setup, go to System > Update > Firmware Update and configure the update source for
IGEL OS 11. For more information, see the Firmware Update Settings for IGEL OS chapter in the
IGEL OS Manual.

2. Click Ok.

When the correct update source is configured, continue with Testing the Upgrade (see page 170).
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Testing the Upgrade

1. Click E] System and then Upgrade to OS 11. The OS 11 Upgrade Tool starts and indicates
whether all requirements are met.

() You can change the starting the starting methods for the OS 11 Upgrade Tool in the Setup under
Accessories > 0S11 Upgrade.

0S 11 Upgrade x

Q Hardware
0 License
Q Setup

Q Update Source

o Network

IGELOST10->11

Close 05 Upgrade

2. Check the output of the OS 11 Upgrade Tool and continue appropriately:
« If each requirement has an o icon, click OS Upgrade to start the upgrade process.

+ If one or more requirements have an ® icon, check the messages and resolve the
issues. Afterwards, click Check again. If all requirements are met, the button changes to 0S
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Upgrade, and you can start the upgrade.
0S 11 Upgrade x

Q Hardware
o License
® Setup
® Powerterm

® Update Source

IGELOS10->11 |

Setup: PowerTerm will not be available in 05 11. To proceed, activate 'Upgrade to 05 11 even if PowerTerm is
enabled' at IGEL Setup = System > Update > 05 11 Upgrade.

Update Source: Please configure a valid OS 11 update source at 'System > Update = Firmware Update’ and
check your network connection.

Network: Please disable all VPN/Mobile Broadband network connectivity on the device. Otherwise it cannot be
guaranteed that your update source will be reachable after the upgrade.

Close Check again

When you start the upgrade, a warning dialog is shown.
3. Click OK to continue.

Confirm Upgrade to 0S 11

With this upgrade, IGEL 0S 11 will be installed on the device.
It is not possible to downgrade to IGEL OS 10 afterwards.

| ¥ Cancel

A warning dialog with a timeout is shown. If you click Cancel before the timeout expires, the
upgrade is canceled. If you click OK or just wait for the timeout to expire, the upgrade is started
Upgrade - A

Please note: With this upgrade, IGEL 0S 11 will be installed on
the device. It is not possible to downgrade to IGEL OS 10
afterwards.

This upgrade involves a critical phase in which the device
must not be powered off. The critical phase will be indicated
by a flashing warning. You will be notified after the upgrade
has finished successfully.

54 seconds remain

¥ Cancel

After the warning dialog has been confirmed or the timeout has expired, the device reboots into a
special IGEL OS 10 environment, in which the system upgrade is executed. The Upgrade window
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shows the progress.

Upgrade

n partition fo
m partition to

IGELOS

During the critical phase, the device must not be powered off. At this stage in the progress, an
additional warning is shown.

Upgrading base system.
DO NOT POWER OFF YOUR DEVICE!

When the installation is completed, the Upgrade window looks like this:

Upgrade

ng for upgrade tool to start
upgrade

IGELOS 10211
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After a few seconds the device reboots into IGEL OS 11.

]

Local Terminal

\\LH///
Z-1GEL

Congratulations
Z *  The upgrade to IGEL OS 11 is now
complete.

<) | 10:29

When the upgrade test has been successful, you are ready to set up the mass upgrade. Continue with Checking the
Requirements (see page 174).
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Checking the Requirements
The following requirements must be met:

+ The upgrade has been tested with characteristic devices.

+ UMS6.01.130 or higher is available.

+ The appropriate IGEL OS 10 firmware version (10.05.700 or higher) is known to the UMS. For this
purpose, a device with this firmware version must be registered in the UMS. This is already the
case if you tested the upgrade with the same UMS with which you are about to do the mass
upgrade. If not, you must register a device with the appropriate IGEL OS 10 firmware version now.

+ All devices are connected to a regular LAN (not OpenVPN, OpenConnect, genucard, or mobile
broadband).

+ All devices are in a safe environment where the upgrade process cannot be disrupted, e.g. by
powering off the devices.

When all the requirements are met, continue with Creating the Universal Firmware Updates (see page 175).
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Creating the Universal Firmware Updates

For detailed information, see the chapter Universal Firmware Update in the UMS Manual.

() Ifyou use the High Availability Extension, note that Universal Firmware Updates are NOT synchronized,
that is why you have to either download them to all HA nodes or configure an external (FTP) server.

1. Create a Universal Firmware Update for the appropriate IGEL OS 10 firmware (10.05.700 or higher).

2. After you have created the Universal Firmware Update for IGEL OS 10, create a Universal Firmware
Update for IGEL OS 11.

© Theorder of creation is crucial because the IGEL OS 11 firmware must have a higher ID in order to
be chosen by the device. For details, see Executing the Upgrade (see page 189).

Configuring the Universal Firmware Update for ICG

If you are using IGEL Cloud Gateway (ICG), an FTP server that is accessible to all devices must be configured as the
update source.

To configure an FTP server as update source:

1. Inthe UMS, go to UMS Administration > Universal Firmware Update and click .
2. Enter the data required for accessing the FTP server and click Save.

Edit FTP Server Configuration

Universal update settings
The IGEL U zal Firr are downloaded from; ‘fia

Pram

The FTP server settings where the files are downloaded to {optionally).

Host fipSerername

Port

Directory

Cancel
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3. Goto Server - [UMS address] > Universal Firmware Update and in the context menu, select
Check for new firmware updates.

Shared Workplace Users

4. Select the entry for the appropriate IGEL OS firmware, click to select the FTP server selected
in step 2 and select Download.

Universal Firmware Updates

Universal Firmware Updates
Include Model Target directory
v IGEL UD LX
IGELOS 11

Show only latest firmware versions (hides already downloaded versi

Download Cancel

IGEL OS Articles 176 /1109



Update and Upgrade

5. The firmware is transferred to the FTP server.

IUniversal Firmware Update/IGEL Universal Desktop LX-10.05.700

Product  IGEL Uniy 1D op LX
Wersion  10.05700
Release Notes  HTML Text
Firmware Update Settings
User fiplser
s
Host /ername
Part
Protocol
Target URL  ftpServerpath/IGEL_Unive Desktop_LX-10.0
Snapshot file
Download Status
~

(]
Status -: .'

Error

Started Download the firmware update...

6. Under Server - [UMS address] > Universal Firmware Update, in the context menu, select Check

for new firmware updates again.
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7. Select the entry for the IGEL OS 11 firmware, click to select the FTP server selected in step 2
and select Download.

Universal Firmware Updates

Universal Firmware Updates
Include Model
IGEL UD LX 00 y me21MpSe

IGEL O3 11 11.01.100 fip:iftpServername 21fpServerpath

Show only latest firmware versions (hides already downloaded
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8. Thefirmware is transferred to the FTP server.
IUniversal Firmware Update/GEL 0S5 11-11.01.100
Product  IGEL OS 11

Version  11.01.100

ase Notes  HTML

Firmware Update Settings

User fipUser

Host
Port
Protocol

Target URL | rverpath/lGE 1-11.01.100

Download Status
]
-:‘:- Started L Download the firmware update. .

Error

The devices can download the firmware from the FTP server.

When the Universal Firmware Update is ready, continue with Creating a Profile (see page 180).
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Creating a Profile

1. Create a profile that is based on the appropriate IGEL OS 10 firmware version (10.05.700 or higher).
Find a suitable name for the profile, e.g. "Firmware upgrade to IGEL OS 11",

New Profile

Cancel

2. Inthe profile's configuration dialog, go to System > Update > Firmware Update and change the
settings according to your environment:
« If the UMS and the devices are in one and the same network, and no IGEL Cloud Gateway
(ICG) is used:

+ Select "HTTPS" as Protocol.

« Activate Automatic Update Check on Boot.

« Ensure that Automatic Update Check on Shutdown is deactivated. Otherwise, the

device will shut down when the update is finished.
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Allow firmware upgrade te IGEL 0S5 11

» Update » Fi

Related Configurations

Search

« IfIGEL Cloud Gateway (ICG) is used:
+ Select "FTP" as Protocol.
+ Activate Automatic Update Check on Boot.
» Ensure that Automatic Update Check on Shutdown is deactivated. Otherwise, the
device will shut down when the update is finished.
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Allow firmware upgrade te IGEL 0S5 11
< > A

? al Related Configurations
uration

Search

3. Go to System > Update > 0OS 11 Upgrade and change the following settings according to your
successful upgrade test:
« Activate Upgrade to OS 11.
Set Upgrade to OS 11 even if PowerTerm is enabled according to your needs.
Set Upgrade to OS 11 even if a previous upgrade attempt failed according to your needs.
+ Set Require an Enterprise Management Pack license to upgrade to OS 11 according to
your needs.

Ensure that the Timeout waiting for OS 11 license to start automatic upgrade is set to 10
Minutes.
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Allow firmware upgrade te IGEL 0S5 11

> Upda

Require an Ente

Time

Search

4. Go to System > Remote Management and change the settings as follows:
« Deactivate Display 'Apply changes' dialog on boot.
+ Set Default action on boot to Apply changed configuration immediately.
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Allow firmware upgrade te IGEL 0S5 11
14 > A ! * Rel

Configuration

a0
Timeout

Defal

A

Timeout

Search

5. Click Save.

When the profile es created, continue with Deploying the Licenses (see page 185).
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Deploying the Licenses
Deploy the licenses for IGEL OS 11 using the method that suits your needs:

+ Automatic License Deployment (ALD): Licenses are created and deployed automatically to each
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).

+ Manual License Deployment: Licenses are created and deployed manually. For instructions,
see Manual License Deployment for IGEL OS.

When the license deployment is setup up, continue with Putting It All Together (see page 186).
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Putting It All Together

1. Putall devices that are to be updated into a directory.

Server -172.30.92.9

nagement Suite & 3 ho.. M r'o i.. .. Mame
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3. Assign the profile (see Creating a Profile (see page 180)) and the two Universal Firmware Updates
(see Creating the Universal Firmware Updates (see page 175)) to the directory and click Ok.

Select assignhable objects

Selected objects

Cancel

4. In the context menu of the assignment, select Now.
Update time

When should these ¢
ket Rehoot

) Mow

In the Assigned objects area, the profile and the Universal Firmware Updates are shown:
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Server-172.30.92.9

5. If you are using Automatic License Deployment (ALD), it might be feasible to confine the
distribution of licenses to the current directory. For more information, see Configuring the
Distribution Conditions, section "Distributing Licenses to Devices in a Specified Directory".

When everything is in place, continue with Executing the Upgrade (see page 189).
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Executing the Upgrade

1. Inthe UMS,; select the directory containing all devices that are to be upgraded and reboot them.

@ Alternatively, you can create a scheduled job for reboot or wake up and assign it to the
devices or the directory containing these devices. For more information, see Jobs.

e Status'flag

ammands

END]

On reboot or wake up, the devices update to the appropriate IGEL OS firmware version (10.05.700
or higher). With this version, the Upgrade to OS 11 parameter is recognized by the devices; also,
the devices request IGEL OS 11 licenses from the UMS (Workspace Edition and, if required,
Enterprise Management Pack).

If no IGEL OS 11 licenses have been deployed on the devices yet, the licenses are deployed within a
few minutes. The upgrade will be started when the licenses are deployed. The maximum time
period the device will wait for a license is configured by the parameter Timeout waiting for 0S 11
license to start automatic upgrade; for details, see Adjusting the Setup (see page 167).

The parameter Automatic update check on boot causes the devices to look for new firmware
again. Although two Universal Firmware Updates are assigned to the devices, the UMS offers the
IGEL OS 11 firmware, because the ID of the IGEL OS 11 firmware is higher than the ID of the IGEL OS
10 firmware.

2. | () Update Can Be Canceled After Timeout
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An ongoing update can be canceled by the user if the "network online" status could not be reached
within 10 seconds after the firmware update has been started. When the user has canceled the
update, the normal desktop environment is started, just as before the update. This applies to the
following cases:

« Regular firmware update, e.g. from IGEL OS 11.03.500 to IGEL OS 11.04

« Afeature has been activated, e.g. VPN OpenConnect.

« A Custom Partition has been activated or changed.

3. When all devices have been upgraded successfully, remove the "Firmware upgrade to IGEL OS 11"
profile and the two Universal Firmware Updates from the directory.

Assigned ohjects

Mame

The upgrade is completed.

IGEL OS Articles 190/1109



Update and Upgrade

Zero-Touch Deployment Using Buddy Update

This method uses the buddy update feature of IGEL OS. One or more devices that are configured as an update
buddy access the main server and download the firmware. The other devices are configured to download their
firmware from an update buddy.

Read all the following chapters carefully and follow the instructions.

IGEL Devices That Can Be Upgraded to IGEL OS 11 (see page 192)
Important! Consider This Before Upgrading (see page 163)
Preparing the Upgrade (see page 165)

Testing the Upgrade (see page 170)

Checking the Requirements (see page 174)

Configuring Two Update Buddies (see page 206)

Creating a Profile (see page 207)

Deploying the Licenses (see page 209)

Putting It All Together (see page 210)

Executing the Upgrade (see page 211)

WoeNoOkwWwNE

=
e
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IGEL Devices That Can Be Upgraded to IGEL OS 11

Core Requirements for IGEL OS 11

« CPU with 64-bit support
« CPUspeed:=1GHz
+ Memory (RAM): =2 GB

() RAMsize higher than 2 GB is recommended if you use any of the following:

+ Unified Communications optimizations (uses a client-side media engine)

+ High-resolution graphics output
For details on the supported graphics-related characteristics of IGEL devices,
see Graphics on IGEL Devices or, for older devices, Graphics on Legacy IGEL

Devices.

« More than two monitors

+ Storage: 2 GB minimum; =4 GB recommended

() Storage Requirements for IGEL OS 11.04 or Higher

IGEL OS 11.04.100 or higher requires at least 2.4 GB storage if the full feature set is applied. Thus,
the feature set must be modified accordingly; for more information, see Error: "Not enough space
on local drive" when Updating to IGEL OS 11.04 or Higher.

IGEL Devices Supported by IGEL OS 11

IGEL UD (Universal Desktop)

Product Line Device Type Hardware ID

UD2**** (see D220

page 193)

UD2" (see page M250C

193)

ubD2

M250C

UD3* (see page M340C

193)

UD3" (see page M340C

193)

uD3

IGEL OS Articles

M350C

40

50

51 /52" (see
page 193)

50

51

60

64 Bit

Yes

Yes

Yes

Yes

Yes

Yes

Memory
(RAM)
2GB
2GB
20r4GB
2GB

2GB

4GB

Storage

4GB

4GB

8 GB

4GB

4GB

8 GB

HW Video

Acceleration

Yes

Yes

Yes

Yes

Yes

Yes
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ProductLine Device Type HardwarelD 64Bit Memory  Storage HW Video

(RAM) Acceleration
UD5" (see page H830C 50 Yes 2GB 4GB Yes
193)
UD6™ (see page H830C 51 Yes 2GB 4GB Yes
193)
ub7 H850C 10 Yes 4GB 4GB Yes
UD7** (see page H850C 11 Yes 4GB 4GB Yes
193)
uD7 H860C 20 Yes 8 GB 8 GB Yes
UD9" (see page TC215B 40/ 41 (Touch) Yes 2GB 4GB Yes
193)

* IGEL UD3-LX 50 and UD5-LX 50 are supported up to IGEL OS 11.05, incl. private builds.
IGEL UD9-LX 40 / 41 (Touch) devices are supported up to IGEL OS 11.07.910.

IGEL UD2-LX 50 devices are supported up to IGEL OS 11.09.160.

IGEL UD3-LX 51 devices are supported up to IGEL OS 11.09.160.

IGEL UD6-LX 51 devices are supported up to IGEL OS 11.09.160.

** As of December 2019, IGEL UD7 model H850C is equipped with the AMD Secure Processor; for further information,
see UD7 Model H850C.

***|GEL UD2-LX 52 is supported with IGEL OS 11.06.140 and later.

**** UD2-LX 40 (model D220) is supported up to IGEL OS 11.08.200. For an overview of the end-of-sales (EOS) and
end-of-maintenance (EOM) dates for IGEL devices, see IGEL OS 11 or Higher (see page 192).

IGEL Zero

() NoteonIZDevices

The 1Z devices listed below can be upgraded to IGEL OS 11. To upgrade your IZ devices to IGEL OS 11,
please contact your IGEL sales representative. See also https://www.igel.com/os11migration/.

Product Device Hardware 64 Bit MemoryStorage UEFI Secure HW Video

Line Type ID (RAM) Boot Support Acceleration
1Z2 D220 40 Yes 2GB 4GB Yes Yes
1Z3 M340C 50 Yes 2GB 4GB Yes Yes
1Z3 M340C 51 Yes 2GB 4GB Yes Yes

When you have confirmed that your devices can be upgraded to IGEL OS 11, make sure to consider Important!
Consider This Before Upgrading (see page 194).
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Important! Consider This Before Upgrading

To make sure that your upgrade can be successful, check the following warnings and notes; a warning symbol
indicates that irreversible damage can be done to your devices.

© NoDowngrade

You cannot restore your IGEL OS 10 system once you have migrated to IGEL OS 11. The device storage is
overwritten completely with a new partitioning scheme.

© Features (e.g. Clients)

IGEL OS 11 does not have the complete feature set of IGEL OS 10. Make sure that the current version of
IGEL OS 11 meets your requirements. For details, refer to the appropriate release notes.

© Custom Partitions

The contents of custom partitions will be deleted by the upgrade. Make sure to back up the contents and
restore them after the upgrade has finished. Besides becoming dysfunctional after the upgrade,
applications and kernel drivers in a custom partition might corrupt the upgrade. For this reason, make
sure to first test the upgrade on a characteristic device. We recommend that you disable custom partitions
when upgrading; you can enable them once the upgrade has been successfully completed.

© Custom Commands

The persistence of custom commands cannot be guaranteed. Besides becoming dysfunctional after the
upgrade, custom commands might corrupt the upgrade. For this reason, make sure to first test the
upgrade on a characteristic device. In general, custom commands must be adapted for IGEL OS 11. We
recommend that you disable custom commands when upgrading; you can enable them once the upgrade
has been successfully completed.

() Network

All devices must be connected to a WLAN or LAN. LAN is the recommended option. The device will not be
upgraded if connected to OpenVPN, OpenConnect, genucard, NCP VPN or mobile broadband.

() Hardware Support

Make sure that your devices support IGEL OS 11; please refer to IGEL Devices Supported by IGEL OS 11.
This document describes upgrading methods for IGEL UD and IGEL 1Z devices. Upgrading methods for IGEL
UDC3 and UD Pocket are described under Upgrading UDC3 Devices from IGEL OS 10 to IGEL OS 11.

() License
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« Avalid license from an IGEL Workspace Edition (WE) Product Pack must be available for
each device. For general information, see IGEL Software License Overview. For deploying

licenses, see Setting up Automatic License Deployment (ALD) or Manual License
Deployment for IGEL OS.

+ |1Z devices are not allowed to upgrade to IGEL OS 11. Please contact your IGEL sales
representative for a UD Upgrade License which allows you to upgrade your IZ devices.

(@) UMS Version

UMS version 6.01.130 or higher is required for upgrading from IGEL OS 10 to IGEL OS 11.

When you have considered everything that is relevant, continue with Preparing the Upgrade (see page 196).
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Preparing the Upgrade

This section describes the required preparations and tests before any productive devices can be updated. The
testing should be done with at least one device that is characteristic of your environment. This device should have
every custom partition and every custom command that may possibly exist in any of your devices.

To prepare the upgrade, perform the following steps:

1. Preparing the UMS (see page 197)

2. Adjusting the Setup (see page 198)

3. Deploying a License (see page 199)

4. Configuring the Update Source (see page 200)
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Preparing the UMS

To upgrade your devices to IGEL OS 11, you need the appropriate version of the UMS. Also, the devices must be
registered with the UMS to receive their licenses.

1. If you have not already done so, update your UMS to version 6.01.130 or higher. For instructions,
see Updating a UMS Installation.

2. Make sure that your devices are registered with the UMS. For more information, see the
chapter Registering Devices on the UMS Server in the UMS Manual.

When the UMS is ready, continue with Adjusting the Setup (see page 198).
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Adjusting the Setup

Depending on the features that are in use now or will be used in the future, a specific set of parameters must be set
in the device's Setup.

1.

In the Setup, go to System > Update > 0OS 11 Upgrade.

2. Make your settings as appropriate:

+ Activate Upgrade to OS 11.
+ If you want the device to retry the upgrade immediately after a failed attempt,

activate Upgrade to OS 11 even if a previous upgrade attempt failed. The device will retry
the upgrade 5 times. When the 5th attempt has failed, a message will be shown in the
upgrade tool window.

If your device has a PowerTerm license, and you want to upgrade to IGEL OS 11 even though
it does not support PowerTerm, you must activate Upgrade to OS 11 even if PowerTerm is
enabled.

Under Require an Enterprise Management Pack license to upgrade to OS 11, select the
appropriate option:

+ Ifyou are using IGEL Cloud Gateway (ICG) or Shared Workplace (SWP) or a Custom
Partition and want to make sure that the upgrade is performed only if these features
can be used furthermore, select Smart. When this option is selected, and any of these
features is activated, the upgrade is performed only if the device could fetch a license
from an Enterprise Management Pack.

+ If you want to force the device to fetch a license from an Enterprise Management
Pack and make sure that the upgrade is performed only if the license could be
fetched, select Always.

+ If you want the device to upgrade to IGEL OS 11 without fetching an Enterprise
Management Pack, disregarding the features that might be activated, select Never.

Under Timeout waiting for OS 11 license to start automatic upgrade, set the time period
the device will wait for a license in a mass deployment scenario (see Zero-Touch
Deployment Using Universal Firmware Update (see page 160), Zero-Touch Deployment Using
Buddy Update (see page 191) and Mass Deployment Using a Scheduled Job (see page 212)). This
setting prevents the device from starting the upgrade at an inappropriate time as a result of
the license just being deployed. This way, the setting prevents unwanted interruptions at
work. For a mass deployment scenario, the default value 10 Minutes is recommended.

3. Click Apply.

When the Setup is adjusted, continue with Deploying a License (see page 199).
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Deploying a License

To upgrade from IGEL OS 10 to IGEL OS 11, you need an appropriate license. Depending on your requirements, one
or more of these licenses will be needed for each device:

+ One Workspace Edition license for basic functionality; see Workspace Edition
+ If one of the following features is used, one Enterprise Management Pack license is required
(see Enterprise Management Pack):
+ IGEL Cloud Gateway (ICG)
+ Shared Workplace (SWP)
+ Custom Partition - if IGEL OS 11.03.100 or lower is the target version; in IGEL OS 11.03.500 or
higher, the Custom Partition feature is included in the Workspace Edition.

Proceed as follows:

> Deploy the licenses for IGEL OS 11 using the method that suits your needs:

+ Manual License Deployment: Licenses are created and deployed manually. For instructions,
see Manual License Deployment for IGEL OS.
+ Automatic License Deployment (ALD): Licenses are created and deployed automatically to each
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).
+ Download three demo licenses from https://www.igel.com/download/.

When the device has a license, continue with Configuring the Update Source (see page 200).
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Configuring the Update Source

1. Inthe Setup, go to System > Update > Firmware Update and configure the update source for
IGEL OS 11. For more information, see the Firmware Update Settings for IGEL OS chapter in the
IGEL OS Manual.

2. Click Ok.

When the correct update source is configured, continue with Testing the Upgrade (see page 201).
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Testing the Upgrade

1. Click E] System and then Upgrade to OS 11. The OS 11 Upgrade Tool starts and indicates
whether all requirements are met.

() You can change the starting the starting methods for the OS 11 Upgrade Tool in the Setup under
Accessories > 0S11 Upgrade.

0S 11 Upgrade x

Q Hardware
0 License
Q Setup

Q Update Source

o Network

IGELOST10->11

Close 05 Upgrade

2. Check the output of the OS 11 Upgrade Tool and continue appropriately:
« If each requirement has an o icon, click OS Upgrade to start the upgrade process.

+ If one or more requirements have an ® icon, check the messages and resolve the
issues. Afterwards, click Check again. If all requirements are met, the button changes to 0S

IGEL OS Articles 201/1109



Update and Upgrade

Upgrade, and you can start the upgrade.
0S 11 Upgrade x

Q Hardware
o License
® Setup
® Powerterm

® Update Source

IGELOS10->11 |

Setup: PowerTerm will not be available in 05 11. To proceed, activate 'Upgrade to 05 11 even if PowerTerm is
enabled' at IGEL Setup = System > Update > 05 11 Upgrade.

Update Source: Please configure a valid OS 11 update source at 'System > Update = Firmware Update’ and
check your network connection.

Network: Please disable all VPN/Mobile Broadband network connectivity on the device. Otherwise it cannot be
guaranteed that your update source will be reachable after the upgrade.

Close Check again

When you start the upgrade, a warning dialog is shown.
3. Click OK to continue.

Confirm Upgrade to 0S 11

With this upgrade, IGEL 0S 11 will be installed on the device.
It is not possible to downgrade to IGEL OS 10 afterwards.

| ¥ Cancel

A warning dialog with a timeout is shown. If you click Cancel before the timeout expires, the
upgrade is canceled. If you click OK or just wait for the timeout to expire, the upgrade is started
Upgrade - A

Please note: With this upgrade, IGEL 0S 11 will be installed on
the device. It is not possible to downgrade to IGEL OS 10
afterwards.

This upgrade involves a critical phase in which the device
must not be powered off. The critical phase will be indicated
by a flashing warning. You will be notified after the upgrade
has finished successfully.

54 seconds remain

¥ Cancel

After the warning dialog has been confirmed or the timeout has expired, the device reboots into a
special IGEL OS 10 environment, in which the system upgrade is executed. The Upgrade window
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shows the progress.

Upgrade

n partition fo
m partition to

IGELOS

During the critical phase, the device must not be powered off. At this stage in the progress, an
additional warning is shown.

Upgrading base system.
DO NOT POWER OFF YOUR DEVICE!

When the installation is completed, the Upgrade window looks like this:

Upgrade

ng for upgrade tool to start
upgrade

IGELOS 10211
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After a few seconds the device reboots into IGEL OS 11.

]

Local Terminal

\\LH///
Z-1GEL

Congratulations
Z *  The upgrade to IGEL OS 11 is now
complete.

<) | 10:29

When the upgrade test has been successful, you are ready to set up the mass upgrade. Continue with Checking the
Requirements (see page 205).
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Checking the Requirements

The following requirements must be met:

The upgrade has been tested with characteristic devices; see Testing the Upgrade (see page 170).
UMS 6.01.130 or higher is available.

The firmware IGEL OS 10.05.700 or 10.05.800 is known to the UMS. For this purpose, a device

with OS 10.05.700 or 10.05.800 must be registered in the UMS. This is already the case if you tested
the upgrade (see Testing the Upgrade (see page 170)) with the same UMS with which you are about to
do the mass upgrade. If not, you must register a device with OS 10.05.700 or 10.05.800 now.

All devices are connected to a regular LAN (not OpenVPN, OpenConnect, genucard, NCP VPN or
mobile broadband).

All devices are in a safe environment where the upgrade process cannot be disrupted, e.g. by
powering off the devices.
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Configuring Two Update Buddies
For setting up buddy updates, see the How-To Buddy Update (see page 230).

© Ensure that the network contains only the update buddies and the devices that are to be updated. This
prevents other devices from updating inadvertently.

1. Update one device to the appropriate IGEL OS 10 firmware (10.05.700 or higher) and configure it as
an update buddy.

2. Upgrade another device to IGEL OS 11 and configure it as an update buddy. Make sure that the
IGEL OS 11 update buddy has the same User Name and Password in System > Update > Buddy
Update as the IGEL OS 10 update buddy.

When the update buddies are configured, continue with Creating a Profile (see page 207).
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Creating a Profile

1. Create a profile which is based on the appropriate IGEL OS 10 firmware version (10.05.700 or
higher). Find a suitable name for the profile, e.g. "Firmware upgrade to IGEL OS 11".
2. Inthe profile's configuration dialog, go to System > Update > Firmware Update and change the
settings as follows:
+ Select "FTP" as Protocol.
+ Enter User Name and Password according the update buddy server.
+ Activate Automatic Update Check on Boot.
« Ensure that Automatic Update Check on Shutdown is deactivated. Otherwise, the device
will shut down when the update is finished.
+ Activate Automatic Buddy Detection.

Allow firmware upgrade te IGEL 0S5 11

Related Configurations

A
A

A

€ » FIPUSER

Search

3. Go to System > Update > 0OS 11 Upgrade and change the following settings according to your
successful upgrade test:
« Activate Upgrade to OS 11.
+ Set Upgrade to OS 11 even if PowerTerm is enabled according to your needs.
+ Set Require an Enterprise Management Pack license to upgrade to OS 11 according to
your needs.
+ Set Timeout waiting for OS 11 license to start automatic upgrade to 10 Minutes.
4. Go to System > Remote Management and change the settings as follows:
« Deactivate Display 'Apply changes' dialog on boot.
+ Set Default action on boot to Apply changed configuration immediately.
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Allow firmware upgrade te IGEL 0S5 11
14 > A ! * Rel

Configuration

a0
Timeout

Defal

A

Timeout

Search

5. Click Save.

When the profile is created, continue with Deploying the Licenses (see page 209).
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Deploying the Licenses
Deploy the licenses for IGEL OS 11 using the method that suits your needs:

+ Automatic License Deployment (ALD): Licenses are created and deployed automatically to each
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).

+ Manual License Deployment: Licenses are created and deployed manually. For instructions,
see Manual License Deployment for IGEL OS.

When the license deployment is set up, continue with Putting It All Together (see page 210).
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Putting It All Together

1. Assign the profile to all devices that are to be upgraded. This can be done by assigning the profile
to the directory that contains these devices.

© Do notassign the profile to the update buddies.

2. Inthe context menu of the assignment, select Now.
3. For Automatic license deployment, a condition can be set to the directory. For more information,
see Configuring the Distribution Conditions, section "Distributing Licenses to Devices in a

Specified Directory".

When everything is in place, continue with Executing the Upgrade (see page 211).
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Executing the Upgrade

1.

2.

3.

In the UMS, select all devices that are to be upgraded and reboot them.

() Alternatively you can create a scheduled job for reboot or wake up and assign it to the devices or
the directory containing these devices; for more information, see Jobs.

On reboot or wake up, the devices choose the IGEL OS 10 buddy. They ignore the IGEL OS 11 buddy
at this stage because this version is not known to them yet. The devices update to the appropriate
version of IGEL OS 10 (10.05.700 or higher). With this version, the Upgrade to OS 11 parameter is
recognized by the devices; also, the devices request IGEL OS 11 licenses from the UMS (Workspace
Edition and, if required, Enterprise Management Pack).

If no IGEL OS 11 licenses have been deployed on the devices yet, the licenses are deployed within a
few minutes. The upgrade will be started when the licenses are deployed. The maximum time
period the device will wait for a license is configured by the parameter Timeout waiting for 0S 11
license to start automatic upgrade; for details, see Adjusting the Setup (see page 167).

The parameters Automatic update check on boot and Automatic buddy detection cause the
devices to look for a new firmware and wait for an IGEL OS 11 update buddy to reply. When an IGEL
0S 11 update buddy is found, the devices start the upgrade process.

(D) Update Can Be Canceled After Timeout

An ongoing update can be canceled by the user if the "network online" status could not be reached
within 10 seconds after the firmware update has been started. When the user has canceled the
update, the normal desktop environment is started, just as before the update. This applies to the
following cases:

+ Regular firmware update, e.g. from IGEL OS 11.03.500 to IGEL OS 11.04

« Afeature has been activated, e.g. VPN OpenConnect.

« A Custom Partition has been activated or changed.

When all devices have been upgraded successfully, remove the "Firmware upgrade to IGEL OS 11"
profile.

The upgrade is complete.
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Mass Deployment Using a Scheduled Job

This scenario is appropriate if you already have a working environment with IGEL OS 10.05.700 (or higher) and want
to update all devices to IGEL OS 11 at a defined time.

Read all the following chapters carefully and follow the instructions.

1. Checking the Requirements (see page 213)
Creating a Profile (see page 214)
Deploying the Licenses (see page 218)
Assigning the Profile (see page 219)
Executing the Upgrade (see page 189)

ok wnN
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Checking the Requirements
The following requirements must be met:

+ The upgrade has been tested with characteristic devices.

+ UMS6.01.130 or higher is available.

+ The appropriate IGEL OS 10 firmware version (10.05.700 or higher) is known to the UMS. For this
purpose, a device with this firmware version must be registered in the UMS. This is already the
case if you tested the upgrade with the same UMS with which you are about to do the mass
upgrade. If not, you must register a device with the appropriate IGEL OS 10 firmware version now.

+ All devices are connected to a regular LAN (not OpenVPN, OpenConnect, genucard, or mobile
broadband).

+ All devices are in a safe environment where the upgrade process cannot be disrupted, e.g. by
powering off the devices.

When all requirements are met, continue with Creating a Profile (see page 214).
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Creating a Profile

1. Create a profile that is based on the appropriate IGEL OS 10 firmware version (10.05.700 or higher).
Find a suitable name for the profile, e.g. "Scheduled firmware upgrade to IGEL OS 11".

New Profile

Prafile Marne Scheduled firrmware upgrade to IGEL 08 11

Cancel

2. Inthe profile's configuration dialog, go to System > Update > Firmware Update and change the
settings according to your environment:

@ Ifyouuse Universal Firmware Update (see page 175) for OS 11, you do not need to configure the
settings described in this step.

+ Select an update source for IGEL OS 11. For further information, see Firmware Update.
() Ifyou use FILE as the protocol (local file or network drive), the device will show an error
message and go through an additional reboot. Apart from that, the upgrade will work

normally.

« Ensure that Automatic Update Check on Boot and Automatic Update Check on
Shutdown are deactivated.

(@ Inthefollowing screenshot, FTP is used as an example. The other protocols can be used as
well.
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Scheduled firmware upgrade to IGEL OS 11
< > A

) ol Related Configurations
uration
ne €) » itgafileigellocal
a.v £11.01.100
a .,
|y -

Search

3. Go to System > Update > 0OS 11 Upgrade and change the following settings according to your
successful upgrade test (for details of the settings, see Adjusting the Setup (see page 167)):
« Activate Upgrade to OS 11.
Set Upgrade to OS 11 even if PowerTerm is enabled according to your needs.
Set Upgrade to OS 11 even if a previous upgrade attempt failed according to your needs.
+ Set Require an Enterprise Management Pack license to upgrade to OS 11 according to
your needs.

Ensure that the Timeout waiting for OS 11 license to start automatic upgrade is set to 10
Minutes.
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Scheduled firmware upgrade to IGEL OS 11

> Upda

Search

4. Go to System > Remote Management and change the settings as follows:
« Deactivate Display 'Apply changes' dialog on boot.
+ Set Default action on boot to Apply changed configuration immediately.
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Allow firmware upgrade te IGEL 0S5 11
14 > A ! * Rel

Configuration

a0
Timeout

Defal

A

Timeout

Search

5. Click Save.

When the profile is created, continue with Deploying the Licenses (see page 218).
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Deploying the Licenses
Deploy the licenses for IGEL OS 11 using the method that suits your needs:

+ Automatic License Deployment (ALD): Licenses are created and deployed automatically to each
device that needs a license. For instructions, see Setting up Automatic License Deployment (ALD).

+ Manual License Deployment: Licenses are created and deployed manually. For instructions,
see Manual License Deployment for IGEL OS.

When the license deployment is set up, continue with Assigning the Profile (see page 219).
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Assigning the Profile

1. Putall devices that are to be updated into a directory.

2. Select the directory and in the Assigned objects area, click @

Server -172.30.92.9
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3. Assign the profile (see Creating a Profile (see page 214)) to the directory and click Ok.
New Scheduled Job

Select assignable objects
Selected aohjects

¥ [ Deyi A4 8 Upgrade to IGEL 05 11

Finish

4. In the context menu of the assignment, select Now.

Update time

When the profile is assigned, continue with Creating the Scheduled Job (see page 221).
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Creating the Scheduled Job
1. Inthe UMS, select Jobs > New Scheduled Job.

Server -172.30.92.9

T

rade to IGELOS 11".
Mew Scheduled Job

Details

V' Enabled

Options
v Lc

I

Timeout

Job-Info

Joh D

Finish
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3. Under Command, select OS 11 Upgrade.
New Scheduled Job

Details

Mame Upgrade to IGEL

v Enabled

Options
VL
Th
Timeout
Job-Info

Joh D

Apri0,

Einish

4. Under Execution time and Start date, set the time at which the upgrade should be executed, and
click Next.
New Scheduled Job

Details

MName Upgrade to IGEL

Command 11 Upgrade

Execution time 11:02 Start date 201 12 v Enabled

Commaent

Options

v Log results Retry next boot

Max. Threads Delay 0 Seconds
Timeout

Job-Info

Job 1D

MNext Execution

User

Next Finish
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5. Review the execution time and click Next.
Mew Scheduled Job
Schedule
Execution time

ration date

Repeat Joh

1] day I hour

Mon

Comment

Cancel job execution

Einish

6. Assign the directory containing the devices to the job and click Finish.
New Scheduled Job

Select assignable objects

Finish

(D) Update Can Be Canceled After Timeout
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IGEL

An ongoing update can be canceled by the user if the "network online" status could not be reached
within 10 seconds after the firmware update has been started. When the user has canceled the
update, the normal desktop environment is started, just as before the update. This applies to the
following cases:

« Regular firmware update, e.g. from IGEL OS 11.03.500 to IGEL OS 11.04

« Afeature has been activated, e.g. VPN OpenConnect.

« A Custom Partition has been activated or changed.

IGEL OS Articles 224/1109



Update and Upgrade

Troubleshooting

This section describes possible error cases and solutions.
+ Regaining a Usable System (see page 226)
+ Getting Error Messages (see page 227)

+ Starting a New Upgrade Attempt (see page 228)
+ Starting Another Upgrade Attempt after 5 Retries (see page 229)
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Regaining a Usable System

Here you can find typical upgrade failures and the appropriate methods to regain a usable system.

Device Has Upgraded to Igel OS 11, but Does Not Boot Any More
To get a working IGEL OS 11 system:

» Use the IGEL OS Creator to recover the IGEL OS 11 system. For more information, see the IGEL OS Creator
Manual.

IGEL OS 10 Rescue System Fails to Update Missing Partitions

If a severe error has occurred during the upgrade process, the device boots into a minimal 10.05.700 (or higher)
rescue system. If unattended, the device tries to download and update the missing partitions and reboots on
failure.

To regain a full IGEL OS 10 system, you have two possibilities:

» In the rescue system, start the Setup, go to System > Update > Firmware Update and set a valid update source
for the appropriate IGEL OS 10 firmware version (10.05.700 or higher).

Or:

> Configure a UMS profile that contains a valid update source for the appropriate IGEL OS 10 firmware version
(10.05.700 or higher) under System > Update > Firmware Update and assign it to the device.
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Getting Error Messages

> Open the 0S 11 Upgrade Tool (default path: click E] System and then Upgrade to OS 11).

The OS 11 Upgrade Tool shows the error messages. The most important message is prefixed with Retries; see the
example below:

05 11 Upgrade

& Hardware
ﬁ License
I:E!::I SEtup

ﬁ Lipdate Saiante

IGELOS10-211

Stup: The upgrade Lo OS 11 has faled previously. To try sgain acthvate Upgrade to IGEL 05 11 even f a
mwmwm‘w?w} m.
Retries: Could not write the new System partition to permanent Storage.

Closa Chachk again

> Formore information, review the main migration log under /wfs/migration.log

() You can use the system log viewer to review the migration log (see the chapter System Log Viewer in the
IGEL OS Manual) or save the log files in order to send them to the IGEL Support Team (see the chapter Save
Device Files for Support support).
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Starting a New Upgrade Attempt
If you want the device to start multiple upgrade attempts (and the device is not already configured to do so):

1. Inthe UMS profile or in the Setup, go to System > Update > OS 11 Upgrade and activate Upgrade
to OS 11 even if a previous upgrade attempt failed.
2. Reboot the device.
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Starting Another Upgrade Attempt after 5 Retries

When the Upgrade to OS 11 even if a previous upgrade attempt failed option is set and the upgrade has failed
each time, the system will stop trying after 5 attempts.

To reset the retry counter:

1. Inthe Setup or the UMS profile, go to System > Update > OS 11 Upgrade and deactivate Upgrade
to OS 11 even if a previous upgrade attempt failed.

2. When the setting is effective on the devices, go to System > Update > OS 11 Upgrade again and
activate Upgrade to OS 11 even if a previous upgrade attempt failed..
The retry counter is reset, and the devices will try upgrading another 5 times, if necessary.
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Buddy Update

A certain number of devices that are running IGEL OS in your company regularly need to be updated. If every device
accesses the main update server individually, maybe even over a great geographical distance, the update could
take quite a long time and might overload the entire connection.

Update
Server

~ Internal network .

-
- -

Set up one of your devices as a so-called buddy update server. In the future, only this client will access the main
server to download the updates. All other clients access the local buddy update server from within the network and
will no longer offload the network outside.
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(@ Thebuddy update server is always an FTP server.

For the configuration details, see:

+ Configuring the Buddy Update Server (see page 233)
+ Configuring the Buddy Update Client (see page 235)

TechChannel
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Sorry, the widget is not supported in this export.
But you can reach it using the following URL:

https://www.youtube.com/watch?v=IVUIFtOT5uE
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Configuring the Buddy Update Server

© NoDowngrade from IGEL 0S 11.03

It is not possible to downgrade from IGEL OS 11.03 or higher to any version before IGEL OS 11.03, except
IGEL OS 11.02.200. This is because, from IGEL OS 11.03 onwards, the system partitions are signed to
guarantee their integrity; it is not possible to change from a system with signed partitions to a system with
unsigned partitions. IGEL OS 11.02.200 is a special variant of IGEL OS 11.02 that has signed system
partitions. IGEL OS 11.02.200 is only available from the IGEL Support Team.

Basic Configuration

1. Inthe Setup, go to System > Update > Buddy Update.

2. Activate Enable Update Server.

3. Enter the credentials User Name and Password.

4. Specify the maximum number of Concurrent Logins allowed.
5. Click Save to confirm the changes.

6. Perform a complete firmware update on the server.

7. Reboot the server.

@ Whenever a buddy update server has received a firmware update, it needs to be rebooted
before it can distribute the new firmware to other devices.

Configuration for Different Firmware Versions
This feature is available for the following versions of IGEL OS:

+ IGEL 0OS 10: 10.06.100 or higher
« IGEL0S 11:11.02.100 or higher

If you have an environment which requires two or more different firmware versions running simultaneously, you
can use the buddy update method to provide each buddy update client device with the appropriate firmware
version. A typical use case might be two groups of employees, of which one requires an older version of the
browser, or an older version of the Citrix receiver, whereas the other group should get the newest version of IGEL
0S. This is achieved by dividing both the clients and the servers into groups. To each group, a specific firmware
version is assigned by first installing that version on the group's update servers. As an example, you can assign
group 1 to IGEL 0S 10.07.100, and group 2 to IGEL OS 10.08.100.

In the following description, the local Setup is used for simplicity reasons; however, in a productive environment, it
is recommended to use profiles. For further information, see Profiles.

To assign a server to a group:

1. Configure the server as described above (Basic Configuration (see page 233)), using the firmware that
is to be assigned to this group.

2. Inthe Setup, go to Registry > update > ftp > buddy_group_id.

3. Inthe field Buddy Group ID, set the appropriate group id. Unsigned integers are allowed.
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4. Click Ok.
5. Reboot the device.
The device will provide the firmware update for the group it is assigned to.

For client configuration, see Configuring the Buddy Update Client (see page 235), "Configuration for Different Firmware
Versions".
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Configuring the Buddy Update Client

Basic Configuration

1. Inthe Setup, go to System > Update > Firmware Update.
2. Setthe following parameters:
Server Name: IP address of the buddy update server
Port: 21 (default with FTP protocol)
Server Path: -
User Name: User name of the buddy update server
Password: Password of the buddy update server

@ Ensure that all servers in the network use the same credentials. For security reasons, you
have to enter them in the upper mask, even if you did not specify a server.

3. Activate Automatic Update Check if you want the client to check automatically during the boot
process whether new updates are available on the server.

4. Activate Automatic Buddy Detection if you want the client to look for a buddy update server on
its own.
This is useful if you work with more than one buddy update server and do not wish to determine a
specific one.
In this case, you do not need to define the Server Name, Port and Server Path. If you enter a
server name anyway, the system treats this server as a fall-back. Thus, you can be sure that the
system accesses at least this one server if it cannot find any others.

5. Click Ok.

6. Continue with further configuration changes or reboot the device.

Configuration for Different Firmware Versions
The feature is available for the following versions of IGEL OS:

+ IGEL 0OS 10: 10.06.100 or higher
« IGEL0OS 11:11.02.100 or higher

This feature is described under Configuring the Buddy Update Server (see page 233), "Configuration for Different
Firmware Versions".

In the following description, the local Setup is used for simplicity reasons; however, in a productive environment, it
is recommended to use profiles. For further information, see Profiles.

To assign a client to a group:

1. Inthe Setup, go to Registry > update > ftp > buddy_group_id.
2. Inthe field Buddy Group ID, set the id of the group to which the desired firmware is assigned.
3. Click Ok.
4. Reboot the device.
The device will use the firmware update for the group it is assigned to.
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Balancing the Server Load
This feature is available for the following versions of IGEL OS:

+ IGEL OS 10:10.06.100 or higher
+ IGEL0OS 11:11.02.100 or higher

Itis possible to balance the load between several buddy update servers. If System > Update > Firmware Update

> Automatic Buddy Detection is activated, the clients send a broadcast in their network to determine which buddy
servers are available. Each server that responds within a fixed timeout is added to a list whose maximum length can
be defined. When the list is complete, either because its maximum length is reached or because the timeout has
expired, the client selects a random server from the list. This way, the load of the buddy servers is distributed
evenly.

To configure a client for balancing the server load:

1. Inthe Setup, go to Registry > update > ftp > buddy_server_candidates.

2. Inthe field Buddy Update Server Candidates, enter the maximum number of servers the client
should collect. If the number is 1, the server that responds first is selected.

Click Ok.

4. Reboot the device.

w
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Firmware Update

Here we show you the best practice of downloading a firmware update from our download server and distributing it
to various devices in your company:

1. Check our download server® to see whether there are new updates which are relevant for your
applications.

2. Download the relevant update files.
3. Install an update directory for them on the UMS server or on your FTP server.
4. Assign this update directory to your devices.
5. Start the update process manually or via a Scheduled Job (see page 240).
Download
server
A FTP
Server 3 Assign updates
o >
(2]
Q
g A
©
(o
=
> A
@©
o
E 2 Download updates
(O]
<
4 Execute updates

+ Downloading Updates and Storing them on an FTP Server (see page 238)
+ Executing an Update Process (see page 240)

23 https://www.igel.com/software-downloads/
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Downloading Updates and Storing them on an FTP Server

You can save the update files either directly on the UMS server or you can put them on your captive FTP server. If
you have many devices to be updated, you should work with the FTP server because it makes it easier to distribute
large amounts of data in the local network.

o

No Downgrade from IGEL OS 11.03

It is not possible to downgrade from IGEL OS 11.03 or higher to any version before IGEL OS 11.03, except
IGEL OS 11.02.200. This is because, from IGEL OS 11.03 onwards, the system partitions are signed to
guarantee their integrity; it is not possible to change from a system with signed partitions to a system with
unsigned partitions. IGEL OS 11.02.200 is a special variant of IGEL OS 11.02 that has signed system
partitions. IGEL OS 11.02.200 is only available from the IGEL Support Team.

a

Important Notes on Downgrading from IGEL OS 11.06 or Higher

+ If you have encrypted your IGEL OS 11.06 device, downgrading to IGEL OS 11.05 or lower
will imply data loss on the following partitions, due to different partition schemes:
+ Browsing history of the browsers Firefox and Chromium
« Custom Partitions
+ The device settings and the UMS connection are preserved.
« The device encryption password must be entered by the user.

Preparation

bk wnN

Click Universal Firmware Update in the UMS Administration area of UMS console.
Click Edit... .

Enter your FTP server under Host, to save the update files in this location.

Add further details like storage path and access data for the server.

Save your settings and click Test Server Connection.

Downloading updates

o UA W

Right-click Universal Firmware Update on the UMS console tree.

Choose Check for new firmware updates from the context menu.

A window opens with a list of all updates associated with the firmware versions registered in the
UMS database.

Choose a Version in the drop-down-list.

Click Information to see the release notes of each update.

Activate the check box Include for downloading a certain update.

Click Download to start the process.

The update will be added to the tree and the current processing status will be shown.

The unpacked firmware files are finally in the target directory on the FTP server.
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Assigning updates to the thin clients

Assign the downloaded update by dragging and dropping to your device directory. Now, if you click this directory
you can see the firmware update in the right window under Assigned objects. The devices will now know where to
find the firmware update in the event of an update command.
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Executing an Update Process

1. Create one or more new Views to distinguish which thin clients will get the new update.
2. Create a new Job, called "firmware update" for example.
3. Specify on the Schedule tab when you want the update to be performed.

(@ The Repeat job option should not be activated for Update, Update on boot or Update on
shutdown commands.

4. Add one or more Views on the Assignment tab.
5. Save thejob.

The update process will be performed according to the schedule specified in the job.

(0 Update Can Be Canceled After Timeout

An ongoing update can be canceled by the user if the "network online" status could not be reached within
10 seconds after the firmware update has been started. When the user has canceled the update, the
normal desktop environment is started, just as before the update. This applies to the following cases:

+ Regular firmware update, e.g. from IGEL OS 11.03.500 to IGEL OS 11.04

« Afeature has been activated, e.g. VPN OpenConnect.

« A Custom Partition has been activated or changed.
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Updating IGEL OS Using a USB Storage Device

You can use a USB storage device to update IGEL OS locally. This method is particularly suitable if only one device
oronly a few devices are to be updated and it would not be worth installing an FTP or HTTP server purely for the
update.

To update the device's firmware without having access to the local setup, follow Updating the Firmware using the
Linux Console (see page 243).

To update IGEL OS using a USB storage device, proceed as follows:

1.

10.

11.

Download the update file (.zip) for your device from the IGEL download server®,
Unpack the update files and save them to a USB storage device.
@ You can find the officially supported file systems under Storage Hotplug.
Open the IGEL Setup on the device and select Devices > Storage Devices > Storage Hotplug.
Set Client Drive Mapping to Static.
Enable Private drive letter for each storage drive.
Set Number of drives to at least 1.
Apply the changes so that they are effective for the device.
@ You can find more information under Storage Hotplug.
Connect the USB storage device to the device and wait until the device has been detected.
Go to System > Update > Firmware Update.

Set Protocol to FILE.

Start the file chooser (Server path) and navigateto /userhome/media/label of the

USB storage device/ lxos.inf andclick Open.

() Do NOT use spaces in the USB device name.

24 https://www.igel.com/software-downloads/workspace-edition/
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12. Click Update firmware and confirm the warning message.
The device will reboot while updating the firmware. Do not remove the USB device until the

update has finished.

& Make sure you do not boot from the USB storage device. You might need to change the boot order in the
BIOS/UEFI.
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Updating the Firmware using the Linux Console

Issue

You have to update the device's firmware without IGEL Universal Management Suite or local IGEL Setup application.

Solution
The device's firmware update can also be carried out directly on the Linux console itself without IGEL Setup:

1. Restartthe device.

Press [ESC ]key during booting to bring up the boot menu.

Select Verbose Boot from the boot menu.

When instructed, switch to the console by pressing [CTRL-ALT-F11] or [CTRL-ALT-F12].
Press [RETURN Jkey to login.

You may have to enter your password.

oW

Carry out the update. The exact procedure varies according to the protocol which is to be used, that is, FILE, HTTP,
or FTP; see the instructions below. You can check whether the correct parameter values have been passed using the

get command,e.g. get update.protocol

HTTP

1. If necessary, set up a static IP address (DHCP is active by default)
setparam network.interfaces.ethernet.device0.usedhcp false

setparam network.interfaces.ethernet.device®.manual true
setparam network.interfaces.ethernet.device0.ipaddr

setparam network.interfaces.ethernet.device®.netmask
2. Configure the update server
setparam update.protocol http

setparam update.http.server

setparam update.http.port

® The default UMS portis 9080

setparam update.http.path
setparam update.http.user

setcryptparam update.http.crypt_password
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3. Startthe update processinthe / directory usingthe command update

FTP

1. If necessary, set up a static IP address (DHCP is active by default)
setparam network.interfaces.ethernet.device0.usedhcp false

setparam network.interfaces.ethernet.device®.manual true
setparam network.interfaces.ethernet.device0.ipaddr

setparam network.interfaces.ethernet.device®.netmask
2. Configure the update server
setparam update.protocol ftp

setparam update.ftp.server

setparam update.ftp.port

® The default portis 21

setparam update.ftp.path
setparam update.ftp.user
setcryptparam update.ftp.crypt_password

3. Startthe update processinthe / directory usingthe command update

FILE

(@ Requirement: The unpacked update files are available in the root directory of a USB storage device.

1. Configure at least one hotplug USB device:

setparam devices.hotplug.usb-storage.numdevices 1
2. Apply your changes:

kill_postsetupd

Connect the USB storage device to the device.
Wait for the USB storage device to be mounted automatically.
5. Determine the mount point:

1ls /media/
6. Configure the update parameters:

> w

setparam update.protocol file

setparam update.file.path /media/<name of USB storage device>
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7. Startthe update processinthe / directory usingthe command update
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Error: "Not enough space on local drive" when Updating to IGEL OS 11.08
or Higher

Symptom

You have tried to update a device to IGEL OS 11.08 or higher, but the update fails with the error message "Not
enough space on local drive".

Problem

IGEL OS 11.08 or higher requires more than 4 GB storage; your device has less storage than required.

Environment
This article is valid for the following environment:

+ IGEL 0S 11.08 or higher

« UMS 6.05 or higher (recommended)

+ Endpoint device that is supported by IGEL OS 11.08 or higher but has a storage size of 4 GB or
lower, that is, lesser than the storage size required by the full feature set

Solution

The recommended storage size for IGEL OS 11.08 or higher is over 4 GB. However, you can update an endpoint
device with less storage than required by a regular IGEL OS installation. This can be done by reducing the feature

set. Amodified INF file ( 1xos-reduced.inf ) in the update source defines a reduced feature set that makes the
firmware fit into your endpoint device's storage.

As an alternative to the preconfigured INF file, you can customize the INF file yourself to define your own reduced
feature set.

& Reduced Feature Set Cannot Be Changed by Setup/UMS

When you have reduced the firmware as described below, you cannot reactivate features via the Setup
resp. the UMS configuration dialog. To recover the complete feature set, you must copy 1xos-

full.inf to lxos.inf and then start the firmware update.

A Buddy Update

When you have downloaded a reduced firmware on a buddy update server by mistake, the buddy server
itself has the reduced feature set. To recover the complete feature set on the buddy server, you must copy

Ixos—full.inf to lxos.inf inthe update source and then update the buddy update server again.
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Using the Preconfigured INF File

» To find out which features are included in the reduced feature set, openthe readme[version].txt in
your update source directory and search for "Reduced Firmware". The table shows the features, the storage size
they require, and whether they are included in the reduced feature set.

Replace the 1xos.1inf fileasfollows:

1. Go to the directory that contains the source files for the firmware update. If you use the WebDav
capability of the UMS, thisis <UMS -installation

directory>\rmguiserver\webapps\ums_filetransfer\<firmware version>;

example: C:\Program

(@)

Files\IGEL\RemoteManager\rmguiserver\webapps\ums_filetransfer\IGEL_
S 11-11.68.110

2. Delete 1xos.inf
@ Itissafetodelete 1xos.inf because thereisa backup file named 1xos-full.inf

3. Copy lxos-reduced.inf to lxos.inf
4, Start the firmware update as usual.

Customizing the INF File

> To get a list of all features and their storage requirement, go to IGEL OS Release Notes, look up your version of
IGEL OS, go to "Component Versions [your version]", and find the "Services" section.

To customize the INF file:
1. Open 1lxos.inf

2. Inthe [INFO] section, add the following line:
custom="true"

3. Deletethe [PART] section of every partition you want to exclude, but do this ONLY IF the section
has both of the following entries:
dispensable="true"

type="squashfs-auto"
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4. Save 1lxos.inf and startthe firmware update as usual.
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Error: "legacy ICG Root (CA) certificate" When Updating to Igel OS 11.04
on Devices Connected via ICG

Possible Problem

If you update to IGEL OS 11.04 or higher, devices might fail to connect to the ICG afterward because the CA root
certificate does not have the CA flag (i.e. X509v3 BasicConstraint extension "is_ca" is set to "false"). This is the case
when the certificate has been created with UMS 5.07 or UMS 5.08.

Environment

+ UMS5.07 or higher (update to UMS 6.06 or higher will be required if not already present)
+ ICG with older root certificates that have been created with UMS 5.07 or UMS 5.08

Diagnosis

1. Open the UMS Console, go to UMS Administration > Global Configuration > Cloud Gateway
Configuration (UMS 5.07 to UMS 6.05) or UMS Administration > Global Configuration >
Certificate Management > Cloud Gateway (UMS 6.06 or higher) and select your ICG root
certificate.

2. Click to review the content of the certificate.
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3. If Certificate Authority: is false, find further instructions under Solution (see page 250).

Certificate

Cedificate Authority:

Solution

1. Request IGEL OS 11.04.221DER from the IGEL Support team.

Update your devices to IGEL OS 11.04.221DER.

Update your UMS to version 6.06.100, if you have not already done so.

Exchange the root certificate for the ICG connection; see Exchanging the Root Certificate for ICG.
Update your devices to IGEL OS 11.04.240 or higher.

ok
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Device Does Not Connect to ICG after Update to IGEL OS 11.04 or Higher

Symptom

After an update to IGEL OS 11.04 or higher, the device fails to connect to the UMS via ICG. The log journal shows a
message similar to this:

igelrm_agent[9824]: [2020/11/11 17:56:16:0140] ERR: SSL error: 1invalid CA
certificate (preverify_ok=0;err=24;depth=1)

Environment

+ UMS5.07 or higher
« ICG with older root certificates that have been created with UMS 5.07 or UMS 5.08
+ Devices that have just been updated to IGEL OS 11.04 or higher

Problem/Possible Cause

CA root certificates for ICG that have been created with UMS 5.07 or UMS 5.08 are not accepted by IGEL OS 11.04.
This is because version 1.1 of the OpenSSL library does not accept certificates as CA certificates if they do not have
the CA flag (i.e. X509v3 BasicConstraint extension "is_ca" is set to "false"). As a consequence, IGEL 0OS 11.04 or
higher refuses to use such a certificate.

Diagnosis

1. Open the UMS Console, go to UMS Administration > Global Configuration > Cloud Gateway
Configuration (UMS 5.07 to UMS 6.05) or UMS Administration > Global Configuration >
Certificate Management > Cloud Gateway (UMS 6.06 or higher) and select your ICG root
certificate.

2. Click ﬁj to review the content of the certificate.
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3. If Certificate Authority: is false, find further instructions under Solution (see page 252).

Certificate

Cedificate Authority:

Solution

1. Relnstall the ICG using an appropriate root certificate. For details, see the following articles:
+ Providing the Certificates
+ Installing the IGEL Cloud Gateway

2. Register the devices again. For details, see Connecting the Devices.
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IGEL OS Automatic Update Service for Device Evaluation

Overview

The automatic update service checks for available firmware updates periodically; if a firmware update is available,
the user is prompted to start the update. The firmware is provided by IGEL via a download server that is known by
the automatic update service. Alternatively, you can use a download server of your own.

The automatic update service is only available for devices with an evaluation license; when the device receives a
Workspace Edition license, the service is deactivated.

Environment
+ Endpoint device with IGEL OS 11.06.100 or higher

Configuring the Automatic Update Service

1. Inthe UMS configuration dialog or the local Setup, go to System > Registry > update > auto-
service > enable and ensure that Enable automatic update service is set to "During evaluation

Enable automatic update service

> s

* [ thinlinc During evaluation only

» Il twox
¥ [ update
v [ auto-service
i enable
B interval
B max delays

2. Setthe following parameters according to your requirements:

« interval: Time interval in hours in which the device should check for firmware updates
during runtime. When the value is 0, the device only checks on boot.

« max_delays: Maximal times the user can postpone an update. Example: When this value is
set to 9, the user can postpone the update 9 times before the update will be forced. When
the value is 0, the update will be forced immediately.

« randomized_delay: Delay time that is added to the interval to avoid an excessive amount
of requests to the server at the same time.

« server: If you want to use an update server of your own, enter its address here. If the field is
empty, the public update server provided by IGEL will be used.

+ user_dialog_timeout: Timeout in seconds before the user dialog is closed and the update
is started. When set to 0, the dialog remains open until the user closes it.

IGEL OS Articles 253/1109



Update and Upgrade

IGEL

+ version: The target version to which the device should be updated. If the field is left empty,
the current version will be used. Example: "11.05.133"
3. Click Apply or Ok to confirm your settings.
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BIOS Tools

+ BIOS Tools for Supported HP Devices (see page 256)
+ BIOS Update for Devices Supported by LVFS (see page 299)
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BIOS Tools for Supported HP Devices

With the BIOS tools, you can manage and update the BIOS of specific Hewlett-Packard (HP) devices using the IGEL
Universal Management Suite (UMS).

We will use profiles and specific device commands to handle any number of devices simultaneously.

© BIOS Updates at Your Own Risk
IGEL is offering and supporting the BIOS Update mechanism - BIOS updates are performed at your own
risk!

(D The BIOS update mechanism is functional even with Secure Boot enabled and when a BIOS password is
set.

Supported Devices

& BIOS tools are only supported for the models listed here.

From OS version 11.08.330:

- HP t540
- HP t640

From OS version 11.09.150:

« HPt430

« HP Prot550
+ HP Elite t655
« HPt740

Requirements

+ UMS 6.10 or higher
+ Supported devices with IGEL OS 11.08.330 or higher

& ThelGEL OS needs to be installed directly on the device. BIOS tools are not supported if the IGEL
0S boots from a UD Pocket.

+ AWindows machine for creating the password file
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Setting up the File Source

Since not only updating the BIOS but also its configuration is done using files, we need to set up a file source that is
reachable by all devices.

The creation of the files is described in the relevant sections. The procedures described here are the same for all
files in question, that is:

« BIOS update file
+ BIOS settings file
« BIOS password file

& Security Note

If you use password files, make sure that the password file is not accessible longer than necessary.

Using an External Source (HTTP/HTTPS)

If you want to deploy the BIOS update file, the BIOS settings file, and the password file from an external source, you
cansetup an HTTP/HTTPS server.

You can secure the file access using a username and password. The devices can be configured to provide a
username and password; see If the External File Source Has Password Protection (see page 265).

Using a Local Storage Device (USB)

For more information on how to use a storage device with IGEL OS, see Storage Hotplug.

Using UMS File Transfer

The following example shows how to use the UMS file transfer facility for file deployment. In this example, a BIOS
update file is provided; the procedure is the same for settings and password files.

1. Inthe UMS Console, go to Files, open the context menu, and select New file.
J i3 - E Lldle

¥ B Files (1)
B IGEL CA.cert
¥ I Universal Firmware Update (1)
IGEL 0S5 11-11.06.100
® Search History (0)

B3 Access control

[ Paste
UMS Administrz
|_\_

Mew Directory

i
B New file
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2. Click the file chooser button.

New file

File source

# Upload local file to UM
Local file
Upload location (URL)  https://<=server:port=fums_filetransfer
Select file from UM:
File location (URL)
File target
Classification Undefined

D e file location

Access rights

Read Write E
Owner J v

Others

Owner
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3. Find the BIOS update file in your file system, select it, and click Open.

Open
Look In: Downloads

MN44 0208.bin

0-24.crt
.16.0+1.ipkg

File Name: MN44 0208.bin

Files of Type:  All Files

4. Inthe field Device file location, define the local path in which the file will be stored on the device,
e.g. /tmp/ .Afterward, click Ok.
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New file

File source

# Upload local file to UM

Local file

Upload location (URL)
Select file from LIM!

File location (URL)

File target

Classification Undefined

Device file location  ftmp/

Access rights

Write
Owner

Others

Owner
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5. Assign the file to your devices by assigning it to the profile we have created beforehand.

Name
BIOS Tools

Select assignable objects

Prafilas {171 BIOS Tools

BIOS Tools

Configuring the Devices
This section describes the necessary preparations for each use case.
First of all, the BIOS Tool feature must be enabled and installed.

Then, depending on the use case, specific parameters must be set and files must be created.

() Thefollowing registry parameters are currently not relevant to the procedures described here:
+ fwtools.bios_tools.allow_downgrade

+ fwtools.bios_tools.allow_only_trusted

« fwtools.bios_tools.allow_reinstall
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Enabling the BIOS Tool

1. Inthe UMS Console, go to Profiles, open the context menu, and select New Profile.

Server -
IGEL Universal Management Suite 12

Profiles 123

B Access control

[ Paste

HID | Update Firmwarevers
HF E Logging: Messages
IGEL ™ New Directory

IGEL 7 New Profile

IGEL

CAQOIT Frafiles

Media riaysi wraiuie;g

2. Provide the following data and then click Ok.
+ Profile Name: Display name of the profile
+ Based on: Select the IGEL OS version of the devices; must be IGEL OS 11.08.330 or higher.

Profile Name |BIOS Tools
Description

Based on IGELOS 11 11.08

» Expert mode

3. Make sure that the settings under System > Update > Firmware Update are valid since the device
will use this source for installing the BIOS Tools.

4. Go to System > Firmware Customization > Features, find BIOS Tools, click the yellow icon next
to the parameter (turns blue when active), enable it, and save the profile.
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HP BIOS Update

> A

Configuration

Search

Name

ption

on IGELOS 11 11.0
Profile ID 55487

» Expert mo
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Select assignable objects

v & D¢
@ Update (0)
oL C
| IT(
T

» B Fil
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6. Reboot the device.
stomizations (0)
®, Edit Configuration

Bename

onfiguration Change Status' flag
contraol

Trigge

umMs Admi

S s}

Shutdown
Wake up

Reboot
5 snapshot commands
guration

If the External File Source Has Password Protection

If your external source for the BIOS update file, the BIOS settings file, or the BIOS password file has password

protection, edit the configuration as follows:

1. Inthe BIOS Tools configuration profile, go to System > Registry > fwtools > bios_tools >
bios_download_username, click the yellow icon to activate the parameter (turns blue when

active), and enter the username.
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HP BIOS Update

fwtools. bic wnload_username

¥ [ Param
> I aut
-
> M bro global
m omiumglobal
[ om_partition
» I debug
i
i

L= Nawnlazad |sarname

o - Qv ]

B Registry

* I ibm

Search
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2. Go to System > Registry > fwtools > bios_tools > bios_download_crypt_password, click the
yellow icon to activate the parameter (turns blue when active), and enter the password.
HP BIOS Update

< > A | » System P Re

. . fwtools.bios tools.bios download crypt_passwort
Configuration Search par fwtools.bios_tools.bios_download_crypt_password

¥ [ Parameter
» I auth

Download

> I ibm

-

Search (w) Show only enabled Parameters

If Your BIOS is Password-Protected: Provide BIOS Password File to Make Changes

If your BIOS is protected by a password, a valid password file must be provided in order to allow any kind of
changes to the BIOS. For this purpose, you must create a password file and make it available to the device.

As a precondition, you must of course know the BIOS password of your devices.

1. OnaWindows machine, download the password tool from https://ftp.ext.hp.com/pub/caps-
softpag/cmit/HPQPswd.html and install it.

2. Create a password file with the known password and make it available as described under Setting
up the File Source (see page 257).

3. Inthe BIOS Tools configuration profile, go to System > Registry > fwtools > bios_tools >
bios_pwd_file, click the yellow icon to activate the parameter (turns blue when active), and enter
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the local or remote file path.
BIOS Tools

< > A

Configuration h para tools _tools.bios_pwd_file

» I ibm
> M ica

Search Show only enabled Parameters

Set a BIOS Password to Protect Your BIOS
If your BIOS is not protected by a password yet and you want to secure it with a BIOS password, proceed as follows:
1. OnaWindows machine, download the password tool from https://ftp.ext.hp.com/pub/caps-
softpag/cmit/HPQPswd.html and install it.

2. Create a password file with the new password and make it available as described under Setting up
the File Source (see page 257).

3. Inthe BIOS Tools configuration profile, go to System > Registry > fwtools > bios_tools >
bios_pwd_file, click the yellow icon to activate the parameter (turns blue when active), and enter
the local or remote file path.
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BIOS Tools
< > A

Configuration fwtools. bios_tools.bios_pwd_file

i Registry

» I ibm
> M ica

Search Show only enabled Parameters

4. Save your settings. Afterward, you can continue with Setting a BIOS Password (see page 291).

Change the BIOS Password
If your devices already have a BIOS password and you want to change it, proceed as follows:

1. OnaWindows machine, download the password tool from https://ftp.ext.hp.com/pub/caps-
softpag/cmit/HPQPswd.html and install it.

2. Create a password file with the current password and make it available as described under Setting
up the File Source (see page 257).

3. Create a password file with the new password and make it available as described under Setting up
the File Source (see page 257).

4. Inthe BIOS Tools configuration profile, go to System > Registry > fwtools > bios_tools >

bios_pwd_file_old, click the yellow icon to activate the parameter (turns blue when active), and
enter the local or remote file path of the password file with the current password.
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BIOS Tools
£ > ~

- - fwtools. bios tools.bios_pwd file olc
Configuration fwtools. bios_tools.bios_pwd_file_old

pw_old. bin

> M ibm
> M ica

Search Show only enabled Parameters

5. Go to System > Registry > fwtools > bios_tools > bios_pwd_file click the yellow icon to activate
the parameter (turns blue when active), and enter the local or remote file path of the password file
with the new password.
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BIOS Tools
> A

uration Search parameter ... et 2l Gloee s G

¥ O3 Parameter

» I ibm
> M ica

Search Show only enabled Parameters

6. Save your settings. Afterward, you can continue with Changing the BIOS Password (see page 293).

Reset the BIOS Password (Remove Password Protection)

If your devices have a BIOS password and you want to reset it so that the BIOS will be accessible without a
password, proceed as follows:

1. OnaWindows machine, download the password tool from https://ftp.ext.hp.com/pub/caps-
softpag/cmit/HPQPswd.html and install it.

2. Create a password file with the old password and make it available as described under Setting up
the File Source (see page 257).

3. Inthe BIOS Tools configuration profile, go to System > Registry > fwtools > bios_tools >

bios_pwd_file_old, click the yellow icon to activate the parameter (turns blue when active), and
enter the local or remote file path of the password file with the current password.
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BIOS Tools
£ > ~

Configuration fwtools. b s.bios_pwd_file_old

Qld BIOS

> M ibm
> M ica

Search ) Show only enabled P

4. Go to System > Registry > fwtools > bios_tools > bios_pwd_file click the yellow icon to activate
the parameter (turns blue when active), and enter

RESET_PASSWORD
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< > A

Configuration

fwtools. bios_tools.bios_pwd_file

BIOS Pas:

B . |RESET PAS

i Registry

» I ibm
> M ica
Search

Show only enabled Parameters

5. Save your settings. Afterward, you can continue with Resetting the BIOS Password (Removing
Password Protection) (see page 295).

BIOS Update

A Youcanreplace the current BIOS with a higher version, but not with the same version. Therefore, restoring
the original BIOS that had been installed on the device before is not possible.
Moreover, it is not possible to downgrade the BIOS.

1. Inthe BIOS Tools configuration profile, go to System > Registry > fwtools > bios_tools >

bios_update_file, click the yellow icon (turns blue when active), and enter the local path or URL
to the BIOS update file.
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< > A

i i fwtools.bios_tools.bios_update file
Configuration fwtools.bios_tools.bios_update file

BIOS Update fi

* I ibm
> M ica

Show only enabled Parame

Search

2. Save your settings. Afterward, you can continue with Updating the BIOS (see page 278).

Change the BIOS Settings

In this section, we will first define a local directory path in which the BIOS Tools facility will store the current
settings as a file when it has extracted them from the device's BIOS. Then, we will define a local directory path in
which the edited settings file will be stored so the BIOS tools facility can apply it to the device's BIOS.

1. Inthe BIOS Tools configuration profile, go to System > Registry > fwtools > bios_tools >
bios_settings_get_file, click the yellow icon (turns blue when active), and enter the path on the

device where the BIOS update file will be saved.
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BIOS Tools
4 > A

i i fwtools s tools.
Configuration fwtools.bios_t

> I ibm
> M ica

Search (w) Show only &

2. Go to System > Registry > fwtools > bios_tools > bios_settings_set_file, click the yellow icon
(turns blue when active), and enter the directory path on the device where the settings file will be

saved. The filename will be bios_settings<unit_id> ;example:

bios*settings*005056784DBA
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BIOS Tools

< > A

i i fwtools.bios tools.bios s
Configuration fwtools bios_tools.bios_

Set RIOS Set

eqgistry

> I ibm
> M ica

Search

3. Saveyour settings. Afterward, you can continue with Changing the BIOS Settings (see page 280).

Reset the BIOS Settings to Default
To reset the BIOS setting to default, proceed as follows:

1. Inthe BIOS Tools configuration profile, go to System > Registry > fwtools > bios_tools >
bios_settings_set_file, click the yellow icon (turns blue when active), and enter

RESET_SETTINGS

IGEL OS Articles 276 /1109



BIOS Tools

BIOS Tools
> A [ * System ® Registry

Configuration Search parameter ... fwtools bios_tools.bios_settings_set_file

Sessions
¥ [ Parameter

Accessories » BB auth

User Interface » B awsc
» I browserglobal
* I chromiumglobal
» B custom_partition
Security > B debug
: £ » B devices
B Time and Date » BB evidian
» B Update YO Set BIOS Settinas file
» [l Remote management O
» Ml Remote Access
B Logging
» B Power Options
¥ 3 Firmware Customization B zllow reinstall
» @ Custom Partition B bios_download crypt_password
B8 Custom Application B bios_download username
» Il Custom Ccmm?nds B bios_pwd file
» [ Corporate Design
» [ Ervironment Variables I bios_pwd file old
B Features _settings_get_file
‘ Registry

Network

Devices

a ., | RESET_SETTINGS

B zllow_downgrade
B allow_only trusted

_update_file

Search v) Show only enabled Parameters

Apply and send to device Save

2. Click Save.
BIOS Tools
> A | * System ® Registry

Configuration Search parameter fwtools bios_tools.bios_settings_set_file

Sessions
¥ [3J Parameter
Accessories » B auth

User Interface » Bl awsc
» Ml browserglobal
» B8 chromiumglobal
» B custom_partition
Security » BB debug
: » Il devices
B Time and Date » BB evidian
» BB Update = Set BIOS Settings file
» [ Remote management =
» [l Remote Access
B Logging
» [ Power Options
¥ O Firmware Customization B =llow_reinstall
» I8 Custom Partition B bios_download_crypt_password
B8 Custom Application B bios_download_username
» [ Custom Commands B bios_pwd_file
» I Corporate Design . .
» [ Environment Variables I bios pwd file_old
B Features _settings_get_file
B Registry

Network

Devices

a.v | RESET SETTINGS

B zllow downgrade
B zllow only trusted

_update_file

Search v) Show only enabled Parameters

Apply and send to device Save Cancel
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3. Saveyour settings. Afterward, you can continue with Resetting the BIOS Settings to Default (see
page 289).

Updating the BIOS

Getting the BIOS Update File from HP

1. Open https://support.hp.com/, select your device, click Software, Drivers and Firmware, and
follow the steps.

2. Download the file (example: sp126570.exe )and unzipit.

3. Inthe directories created by unzipping, look for a file with the ending .b1in, forinstance,

M44_0103.b1in,andstoreitin alocation that is reachable from your UMS machine.

Making the BIOS Update File Available

> Make the BIOS update available to your devices; see Setting up the File Source (see page 257).
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Triggering the BIOS Update

1. Inthe UMS, select the relevant devices (or directory), open the context menu, and select Specific

Device Command.
= De 3)

¥ System Information
J te

C1 [TCpanannsssens Attribute

Edit Configuration
# Bename

Copy

FPaste

Shadow

ecure Terminal
rd

Shutdown

_____ Wake up
Reboot

ettings from ...
Export O ttings
Save device files for support
Logging
License manually...

UMS Administration

can for devi
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2. Select BIOS - Trigger update and click Execute.

Specific Device Command

command

Start Login Enterprise Launcher
Update the firmware of an attached HP G5 Dock

ute Cancel

Changing the BIOS Settings

To change the BIOS configuration, you must first retrieve the BIOS settings from the device, then edit them, and

finally deploy the edited settings to the device.

Getting the BIOS Settings

1. Inthe UMS, select the relevant devices (or directory), open the context menu, and select Specific

Device Command.
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¥ System Information
Attribute
Edit Configuration

EEREINE]

Delete

Configuration Change Status' f

contral

Secure Terminal

Suspend
Shutdown
Wake up
Reboot

UMS Administration
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2. Select BIOS - Get settings and click Execute.

Specific Device Command

command

Start Login Enterpri auncher
Update the firmware of an attached HP G5 Dock

ute Cancel

Editing the BIOS Settings File

1. Look up your device in the UMS structure tree, open the context menu, and select Other

commands > Device File -> UMS.
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®, Edit Configuration

& Rename
'D' Delete
X ~onfiguration Change Status' flag
control

a6 Cut

(& Copy

O Paste
Shadow
Secure Terminal
suspend
Shutdown
Wake up
Reboot

ommand =
- Reset to Factory Defaults
Take over settings from ...

Export D 5
Save device files support

Logging

Settings UMS-=Device

stomization
Fila 1 IMS =MNavira
ice Se manually . . . .
License manually... Device File-=LMS

%) Scan for d

Download Flashplayer
Remove Flashplayer

Store UMS Certi

2. Under Device file location, provide the local path to which the settings file has been
stored; this location has been specified in the step Configuration for Editing the BIOS
Settings (see page 274).
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Device File-=UMS
D File-=UMS

el ITQ

File information

Device file location

Target URL

3. Define the path on the UMS machine under which the settings file should be stored so you
can retrieve and edit it.
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Device File-=UMS
File-=UMS

11TC

File information

ile location  /

Target URL

Afile chooser opens.

Save
Look In: ‘

ums_filetransfer

File Name:

Files of T
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4. Set the following parameters and click Save.
« Look in: File path on the UMS machine under which the settings file should be stored,
e.g. ums_filetransfer.
« File Name: The file name under which the settings file should be stored.

Save
Look In: ums_filetransfer

supportinfo
MN44 0208.bin

File Name:

Files of Type:
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5. Click Device File -> UMS to transfer the file from the device to the UMS machine.

Device File->UMS
D File-=UMS

L1 ITC

File information

Device file location fuserhome/config.txt

Target URL

6. Download and install the HP BIOS Configuration Utility. For information on the download
source and the use of the utility, see https://ftp.ext.hp.com/pub/caps-softpag/cmit/
whitepapers/BIOS_Configuration_Utility_User_Guide.pdf.

7. Edit the configuration file as desired.

() Make sure that the BIOS settings file is formatted properly and that the REPSET format is respected.
For further information, see https://ftp.ext.hp.com/pub/caps-softpaqg/cmit/whitepapers/
BIOS_Configuration_Utility_User_Guide.pdf

@ ltissufficient to specify only those BIOS setting you want to change so that your edited file
contains snippets instead of all possible settings.

8. Save the settings file, e.g. as config.txt . Make the edited file available as described
under Setting up the File Source (see page 257).
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Deploying the Changed Settings on the Device

1. Inthe UMS, select the relevant devices (or directory), open the context menu, and select Specific

Device Command.
= De 3)

¥ System Information
J te

C1 [TCpanannsssens Attribute

Edit Configuration
# Bename

Copy

FPaste

Shadow

ecure Terminal
rd

Shutdown

_____ Wake up
Reboot

ettings from ...
Export O ttings
Save device files for support
Logging
License manually...

UMS Administration

can for devi
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2. Select BIOS - Set settings and click Execute.

Specific Device Command
command
BIOS - Ge
RIOS - Set n

BIOS - Set settings

BIVS - [TIgYE]
Deploy Jabra

Start Login Enterpri auncher

Update the firmware of an attached HP G5 Dock

ute Cancel

Resetting the BIOS Settings to Default

1. Inthe UMS, select the relevant devices (or directory), open the context menu, and select Specific

Device Command.
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¥ System Information
Attribute
Edit Configuration

EEREINE]

Delete

Configuration Change Status' f

contral

Secure Terminal

Suspend
Shutdown
Wake up
Reboot

UMS Administration
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2. Select BIOS - Set password and click Execute.

Specific Device Command

command

Update the firmware of an attached HP G5 Dock

Cancel

Setting a BIOS Password

1. Inthe UMS, select the relevant devices (or directory), open the context menu, and select Specific

Device Command.

IGEL OS Articles

291/1109



BIOS Tools

IGEL OS Articles

¥ System Information
Attribute
Edit Configuration

EEREINE]

Delete

Configuration Change Status' f

contral

Secure Terminal

Suspend
Shutdown
Wake up
Reboot
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2. Select BIOS - Set password and click Execute.

Specific Device Command
command

RINS - (et catti

BIOS - Trigg

Deploy Jabra

Start Login Enterpri auncher

Update the firmware of an attached HP G5 Dock

ute Cancel

Changing the BIOS Password

1. Inthe UMS, select the relevant devices (or directory), open the context menu, and select Specific

Device Command.
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Attribute
Edit Configuration

EEREINE]

Delete

Configuration Change Status' f

contral

Secure Terminal

Suspend
Shutdown
Wake up
Reboot
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2. Select BIOS - Set password and click Execute.

Specific Device Command
command

RINS - (et catti

BIOS - Trigg

Deploy Jabra

Start Login Enterpri auncher

Update the firmware of an attached HP G5 Dock

ute Cancel

Resetting the BIOS Password (Removing Password Protection)

1. Inthe UMS, select the relevant devices (or directory), open the context menu, and select Specific

Device Command.
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¥ System Information
Attribute
Edit Configuration

EEREINE]

Delete

Configuration Change Status' f

contral

Secure Terminal

Suspend
Shutdown
Wake up
Reboot
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2. Select BIOS - Set password and click Execute.

Specific Device Command
command
BINS - ([et sattinne

BIOS - Set password

Update the firmware of an attached HP G5 Dock

Cancel

Command Line Interface (CLI) for the BIOS Tools

For testing the BIOS update on a single device, you can use the command line tool as an alternative to a scheduled
job from the UMS.

As a prerequisite, the steps described under Setting up the File Source (see page 257) and Configuration for the BIOS
Tool (see page 0) must be completed.

When the command has been executed, a dialog informs you that a reboot is required. You can choose between two
options:

- Perform the reboot and update right away

- Postpone the update to the next reboot

Usage

bios-tools [OPTIONS] COMMAND [ARGS]...
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Options

Option

--debug / --no-debug
--info / --no-info

--test / --no-test

-—help

Commands

Command Argument

password

settings
-c, —-configure
-d, —--default
-g, ——get
-—help

update

-e, —-enable

-d, —--disable
-s, —-show

-—help

IGEL OS Articles

Description

Show this message and exit

Description

Set BIOS password
Handle BIOS settings

Configure BIOS settings with a configuration
file

Reset BIOS settings to default
Get current BIOS settings
Show this message and exit
Handle BIOS update

Enable BIOS update. The update will be
triggered after a reboot.

Disable BIOS update
Show if BIOS update is enabled or not

Show this message and exit

298 /1109



BIOS Tools

BIOS Update for Devices Supported by LVFS

© BIOS Updates at Your Own Risk
IGEL is offering and supporting the LVFS BIOS Update mechanism - BIOS updates are performed at your
own risk!

A Legacy BIOS Not Supported
The LVFS BIOS update mechanism works only with EFI/UEFI, not with legacy BIOS.

e update mechanism is functional even with Secure Boot enabled and when a passwor
The LVFS BIOS upd hanism is fi i [ ith S B bled and wh BIOS d
is set.

If the BIOS of your devices is distributed via the Linux Vendor Firmware Service (LVFS), you can update, downgrade,
or reinstall it using the IGEL Universal Management Suite (UMS).

As the procedure for reinstalling and downgrading the BIOS are analogous to the update procedure, we will use the
term "update" in the following instructions.

Supported Devices

For a list of supported devices, see https://fwupd.org/lvfs/devices/

Requirements

+ UMS6.01 or higher

+ Device supports LVFS

+ The device has IGEL OS 11.08.100 or higher; it is recommended to use IGEL OS 11.08.230 due to
significant improvements in our implementation.

+ Ifthe device has IGEL OS 11.08.290 or higher, the BIOS Tools feature must be installed explicitly.
Instructions are provided under Configuring the BIOS Update (see page 300), step 3.

Getting the BIOS Update File from LVFS

> Look up the latest update file from https://fwupd.org/lvfs/devices/ and download it. If you want to use the UMS
for file distribution, store it in a location that is reachable from the machine on which your UMS Server is running.

Installing the BIOS Tools Feature (IGEL OS 11.08.290 or Higher)
With IGEL OS 11.08.290 or higher, the BIOS Tools feature must be installed first.

1. Inthe local Setup or, preferably, in a profile, go to
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Configuring the BIOS Update
We will create a profile to make the settings available for all relevant devices.
1. Inthe UMS Console, go to Profiles, open the context menu and select New Profile.

¥ /- IGEL Universal Management Suite 6
¥  Profiles (T
11.08

Screer
Sound

[ [ New Directory
Y EmBIOSU /& nNew Profile
L1ITCO  fF new Mobile Device Profile
' ITCOO1 Export Profiles

] ITCO0SU56930285

2. Provide the following data and then click Ok.
+ Profile Name: Display name of the profile
+ Based on: Select the IGEL OS version of the devices; must be IGEL OS 11.08 or higher

New Profile

Profile Name BIOS Update

Description |

Based on IGEL 0511 11.08.100.rc1.01

L4 cxpell mode

3. If your devices have IGEL OS 11.08.290 or higher, you must install the BIOS Tools feature first.
Perform the following steps:

a. Go to System > Firmware Customization > Features and click the yellow icon beside BIOS
Tools to activate the parameter (turns blue when active).
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BIOS Update

4 > A ystem rm tion » Features

Configuration

]

Search

b. Click Save.

BI0S Update
< > A r

Configuration

B

PEEPERPERPRRERRE-PRBRRD
g|

B Logging
» B Po opt

Search

c. Check if the settings under System > Update > Firmware Update are valid for all devices on
which you want to install the BIOS Tools.
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£ >

Configuration Related Configurations

4 Features

BIOS Update
ofile

omium Br

top client
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g. Confirm the update.

Update Firmware of devices

Update Firmware of de

The devices will download and install the BIOS Tools feature.

4. Go to System > Registry > fwtools > bios_tools > bios_update_file, click the yellow icon to

activate the parameter (turns blue when active), and enter the path or the URL of the update file.

| ™ System P Registry

Configuration

B Time and Date
» B Update

» [ Remote management
» [l Remote Access
B Logging
» [ Power Options
» [ Firmware Customization
B Registry

Search

IGEL OS Articles

rch parameter

» B browserglobal

» I8 chromiumglobal

» I custom_partition

> Il debug

> Il devices

> Il evidian

vO

vo

‘ allow_downgrade
B allow_reinstall
B bios_download_crypt_password
B bios_download_usemname
B bios_pwd_file
B bios_pwad_file_old
B bios_settings_get_file
B bios_settings_set_file
]

> I ibm

> B i

fwtools.bios_tools.bios_update_file

BIOS Update file

Q £ fuserhome/Downloads/dell-1.17 cab|

Show only enabled Parameters

Apply and se
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5. If you want to downgrade the BIOS, i.e. replace the BIOS with a lower version: Click the yellow icon
and activate System > Registry > fwtools > bios_tools > allow_downgrade.

fwtools.bios_tools.allow_downgrade

Allow installation of bios sion that's alder than current.

€ .~ [V]allow installation of bios version that's older than current.

» I ibm
> irn

Show only enabled Parameters

6. If you want to reinstall the BIOS, i.e. replace the BIOS with a fresh BIOS of the same version: Click
the yellow icon and activate System > Registry > fwtools > bios_tools > allow_reinstall.
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fwtools.bios_tools.allow_r

Allow llation of bio n th nt to current.

€ v [V]alowi ation of bios ths ivalent to current,

» I ibm
> i
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7. Click Save to write the profile.

fwtoo

obal
omiumglobal
om_partition

Allow i ation of bi ion ths

4« ¥ ¥ ¥ ¥ ¥y v 7

a v Allow allation of t

» I ibm
» Im
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Providing the BIOS Update File

Local Source
To transfer the BIOS update file to the device, we will use the UMS file transfer functionality.

1. Inthe UMS Consol

e, goto

Files, open the context menu, and select New file.

v B Files (1)
B IGEL CA.ce
Universal Firmware Update (1)
IGEL 05 11-11.1
® Search History (0)

ccess control

[ Paste
UMS Administre Logging: Mess:

|

Mew Directory

i
B New file
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2. Click the file chooser button.

New file

File source
* Upload local file to UM

Local file

Upload location (URL)  htips:i/f<serverport=/ums_filetransfer

Select file from UM®

File location (URL)

File target
Cl cation Undefined

D e file location

Access rights

Read Write Execute
Oowner v v v

Others

Owner Ser
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3. Find the BIOS update file in your file system, select it and click Ok.
Open

Look In: Downloads

A1 -natwnrl-mangger-all.yam| profilesSeb.zip

setup-igel-ums-linux_6.10.110.r
iygei-unn i log ip.bak. pbak
IGEL_CA.cert
M43 0112 bin

File Name: dell-1.17.cab

Files of Type:

All Files

4. Inthe field Device file location, define the local path in which the file will be stored on the device,
e.g. /userhome/Downloads/ . Afterward, click Ok.

& Itisrecommended NOTtouse /wfs/ to store the BIOS update file.

IGEL OS Articles

310/1109



BIOS Tools 1
S

New file

File source

® Upload local file to UMS server

Local file C\Users\locadmin\Downloads\dell-1.17.cab

Upload location (URL) hitps:/<server.port=fums_filetransfer
Select file from UMS server

File location (URL)

File target

Classification Undefined

Device file location |/userhome/Downloads/

Access rights

Read Write Execute

1 v

5. Click the icon to open the assignment dialog.

[Files/dell-1.17.cab Assigned objects

Name
Source URL

Classification Undefined
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6. Assign the file to your devices by assigning it to the profile we have created beforehand.

Select assignable objects

BIOS Update

JownloadSg

Remote Source

» Transfer the file to an HTTP server; ensure that the URL provided under System > Registry > fwtools >
bios_tools > bios_update_file is matched.

Triggering the BIOS Update

(@ Inthe following instruction, we will use a scheduled job to trigger the BIOS update.
Alternatively, you can trigger the BIOS update manually. For this purpose, select Specific Device
Command from the context menu of the device or the corresponding directory and then select BIOS -
Trigger update:
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Sound Pr EERENE

es (5) 'Configuration Change Status' flag
Y @ BIOS Upd B ontrol

LY

¥ cut

L& Copy

Co0s05
Ul

Mabile Devi Shutdown

Wake up
Reboot

Save d

Logging

™ YiFa e g
7 New Directory
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Specific Device Command

Select specific device command

BIOS -

lJp-'ia’r-: ’rh-= firmware of an attached HP G5 Dock

1.

ans {{J]l
» B Files (1)
v Universal Firmware Update (1)
IGEL0511-11.06,100
@ Secarch History (0)
yele Bin (0) 0 Paste

Logging: Messages

E Access control

UMS Administrati

i

[ New Directory
£ New Scheduled Job

2. Provide the following data and then click Next.
« Name: Display name for the job
« Command: Select BIOS - Trigger update.
« Execution time: Time at which the BIOS should be updated
« Start date: Date at which the BIOS should be updated
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« Enabled: Ensure that this is activated

New Scheduled Job

Details

Name

V' Enabled

Timeout
Job-Info
Job ID
Ne

ancel Finish

3. Make sure that Repeat Job is set to Never and click Next.
New Scheduled Job

Schedule
ution time ] Start date
Expiration date
Repeat Job
® Never
= 0 day 0 hour
Wed Thu

Comment

Cancel job execution

* N

Einish

4. Select the devices on which the BIOS update should be performed. You can select single devices,
directories, views, and search histories. Afterward, click Finish.
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New Scheduled Job

Select assignable objects

Cancel Einish

When the job is executed, a dialog informs the user that a reboot is required. The user can choose
between two options:

- Perform the reboot and update right away

- Postpone the update to the next reboot

Using the Command Line Tool (bios-tools)

For testing the BIOS update on a single device, you can use the command line tool as an alternative to a scheduled
job from the UMS.

As a prerequisite, the steps described under Getting the BIOS Update File from LVFS (see page 299), Configuring the
BIOS Update (see page 300), and Providing the BIOS Update File (see page 308) must be completed. As an alternative, you
can also use a USB storage device (see Storage Hotplug) or an NFS network drive (see NFS).

When the command has been executed, a dialog informs you that a reboot is required. You can choose between two
options:

- Perform the reboot and update right away

- Postpone the update to the next reboot

Usage
bios-tools [OPTIONS] COMMAND [ARGS]...
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Options
Option / Contrary Option Comment
——debug / --no-debug Provide extensive information (verbose mode)
——help Show the help text and exit
Commands
Command Argument (Short / Long Form) Comment
update Handle BIOS update
—e ——enable Enable BIOS update. Will be triggered
after reboot.
-d --disable Disable BIOS update
-5 ——show Show if BIOS update is enabled or not
——help Show the help text and exit
Example

The following command performs a BIOS update and displays extensive information:

update --debug -e
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Citrix

Performance (see page 319)

Mouse (see page 324)

How to Configure Citrix Native USB Redirection (see page 331)

Citrix Fabulatech Scanner Redirection in IGEL OS (see page 333)

Mapping USB Storage Media into Citrix Sessions (see page 335)

Auto-Hide Toolbar in Appliance Mode (see page 337)

Create a Seamless, Transparent User Experience with Appliance Mode (see page 338)
Connecting to a Citrix Farm (see page 339)

Create a Self-Service Setup for the User with Quick Settings (see page 345)

Login Failed because of the Expired AD Password (see page 347)

Configuring Auto Logon for Citrix Virtual Desktops (see page 349)

Force Citrix Logout Using Hotkey (see page 353)

Citrix: Freeze at Logout (see page 354)

Warning Message: [Citrix Store] Could Not Connect to the Citrix Server (see page 356)
Setting up Citrix Sessions with Hardware-Accelerated H.264 Deep Compression Codec (see page 358)
Using Font Smoothing (ClearType) in Citrix Sessions (see page 359)

Highly Secured XenServer has Problems with LD_BIND_NOW Workaround (see page 361)
Workaround for Citrix Receiver X Error (see page 362)

Citrix HTML5 Receiver Issue (see page 363)

Macbook Keyboard Layout inside Citrix Session (see page 364)

Citrix Feature Matrix (see page 365)

Using Lync / Skype for Business with Citrix HDX RealTime Optimization Pack (see page 369)
Citrix Advanced Endpoint Analysis (EPA) Client on IGEL OS (see page 370)

Citrix Netscaler Gateway Client (NSGClient) for Netscaler VPN Connections (see page 371)
Unexpected Keyboard Layout in a Citrix Session (see page 375)
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Performance

+ Poor Performance: Black Blocks and Stripes in Citrix Sessions (see page 320)

« Poor Performance with Citrix XenDesktop 7.6 Deep Compression (see page 321)
« Citrix Receiver: Grey Blocks in Excel 2013 (see page 322)

« Bar Code Scanning is Slow via Citrix (see page 323)
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Poor Performance: Black Blocks and Stripes in Citrix Sessions

Symptom

In the Citrix session, you sometimes experience a problem with black blocks, frames, or stripes.

Problem

Poor performance is often connected with the delayed or slow refreshing of the screen content.

Solution

» Inthe IGEL Setup or the configuration dialog in the UMS, activate one of the following parameters or all of them
under Sessions > Citrix > Citrix Global > Options:

+ Use server redraw
+ Backing store
« Deferred screen update mode

s P Citrix ™ Citrix Global ™ Options

ﬂ o Vv Use server redraw

ﬂ < V' Backing store

) ¥ Deferred screen update mode
Cache size in kB

rver Location
Login

Minimum bitmap size in bytes
Persistent cache path

Scrolling control

Audio bandwidth limit in StoreFront sessions

B Redirection A

Maximurm retries &

Apply and send to device Save Cancel

See also Options for an IGEL OS Citrix Session in the manual chapter for Citrix.

@ If this doesn't work, see also Black Box Next to the Mouse Cursor (see page 330).
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Poor Performance with Citrix XenDesktop 7.6 Deep Compression

Symptom

When using XenDesktop 7.6 on Windows Server 2008R2 with Citrix Receiver 13.0.4, 13.1.4 or 13.2.1 with H.264 Deep
Compression Codec, dragged Windows lag and the performance is generally poor.

Problem

Server and/or client do not have enough computing power for the H.264 Deep Compression Codec.

Solution

Enable the legacy graphics mode on the XenDesktop 7.6 server via a policy.
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Citrix Receiver: Grey Blocks in Excel 2013

Symptom

When using Microsoft Excel 2013 on XenDesktop 7.6 with Citrix Receiver 13.1.3, 13.1.4 or 13.2, grey blocks appear
especially if you mark multiple cells.

Problem

Codec parameters may not be optimal for this use case.

Solution

1. InIGEL Setup, go to Sessions > Citrix > Citrix Global > Codec.
2. Disable Text Tracking.
3. Disable Small Frames Feature.

Additional parameters for H.264 Deep Compression Codec
[] Accelerated H.264 Deep Compression Codec

€) [ ] Text Tracking

€) [} small Frames Feature
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Bar Code Scanning is Slow via Citrix

& Solution Based on Experience from the Field

This article provides a solution that has not been approved by the IGEL Research and Development
department. Therefore, official support cannot be provided by IGEL. Where applicable, test the solution
before deploying it to a productive environment.

Issue

Bar code scanning is slow via Citrix.

Environment

+ Firmware version: any
+ UMS version: any

Description

USB attached bar code scanner is very slow via Citrix.

Solution

In order to pass the Bar Code scanner through correctly, you want it to be a HID so it passes through as a HID
instead of using Native USB Redirection. A quick way to determine that would be to open a terminal in IGEL OS and
simply scan something. If it populates data in the terminal, then it is configured as HID. Also, check the
configuration guide for the particular scanner that you are using. The config guide is simply a bunch of barcodes
that the device can scan. Once a code is scanned, the device beeps twice, and that changes the config on the
scanner. On some devices, there is a setting for Alternate OS Linux/MACOS. The default setting for the scanner
usually doesn't enable this. Once the setting was set, everything scanned very fast and that same speed was shown
in Citrix.
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Mouse

« Changing Middle Mouse Button Function for Citrix Session and Local Firefox Browser (see page 325)
+ How to Connect a SpaceMouse with a Citrix Session (see page 326)

Solve SpaceMouse USB Reset Problem (see page 328)

Wireless Mouse Keyboard Set Logitech k520 Freezes in Citrix Session (see page 329)

Black Box Next to the Mouse Cursor (see page 330)
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Changing Middle Mouse Button Function for Citrix Session and Local Firefox
Browser

Middle mouse button cannot be used for smooth scrolling within applications like Excel or Internet Explorer within a
Citrix session or with the local Firefox browser.

The default function of the middle mouse button is copy and paste.

> Open IGEL registry in local client setup or UMS.

< > ' [ » System M Registry

Configuration Search parameter ... ica.wfclient. mousesendscontroly

=essions B keyboardtype :
S e B keypassthroughescapechar
User Interface B keypassthroughescapeshift
Metwork B argecachesizeink
T B lcgoffdesktopthrotwi
i B mousedoubleclickheight
= B mousedoublaclicktimer
ylem B mousedoubleclickwidth
Il Time and Date B mousesendscontroly
> I Update . mousetimer
: : 2:?2: :Cacr;zgsement B palettechangetimeout
» [ Power Options i persistentcacheminbitmap Allow Middle Button Paste
» I Firmware Customization B persistentcachepath . [ allow Middle Button Paste
‘ Registry i persistentcachepercent W
[ RN R

> For Citrix sessions change:

+ System > Registry > ica.wfclient.mousesendscontrolv

» For local Firefox browser change:

+ System > Registry > browserglobal.app.middlemouse_contentloadurl
« System > Registry > browserglobal.app.middlemouse_paste

More information on the Firefox parameters can be found at
http://kb.mozillazine.org/Middlemouse.contentLoadURL
http://kb.mozillazine.org/Middlemouse.paste

The changes will take effect after rebooting the thin client.
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How to Connect a SpaceMouse with a Citrix Session

This article describes how to use a 3Dconnexion SpaceMouse in a Citrix session.

© Always use a SpaceMouse only as an additional, i.e. second, mouse.

() From version 10.06.100 or 11.02.100 on, the SpaceMouse does not interfere anymore with the local
mouse pointer because of a registry key which is enabled by default.
This registry parameter ignores the SpaceMouse for the IGEL graphical user interface:

IGEL Setup System > Registry

Parameter Deactivates 3Dconnexion/Logitech SpaceMouse
products as a standard mouse

Registry Key userinterface.mouse.spacemouse.x11l_igno
re

Value enabled/disabled

"enabled" means that the SpaceMouse is passed
through to the session and ignored by the local GUI.
"disabled" means that the SpaceMouse is also used for
the local GUI.

To configure the SpaceMouse for Citrix sessions:

1. In Setup, go to Sessions > Citrix > Citrix Global > Native USB Redirection.

Activate the checkbox Native USB Redirection.

Set the Default rule to Deny.

Add a device exception rule as in the following screenshot with the Vendor ID and Product ID of
your specific SpaceMouse:

SpaceMouse products included (VID, PID, Vendor, Product)

Eall

+ 0x046D; 0xC603; Logitech, Inc.; 3Dconnexion Spacemouse Plus XT

+ 0x046D; 0xC605; Logitech, Inc.; 3Dconnexion CADman

+ 0x046D; 0xC606; Logitech, Inc.; 3Dconnexion Spacemouse Classic

+ 0x046D; 0xC621; Logitech, Inc.; 3Dconnexion Spaceball 5000

+ 0x046D; 0xC623; Logitech, Inc.; 3Dconnexion Space Traveller 3D Mouse
+ 0x046D; 0xC625; Logitech, Inc.; 3Dconnexion Space Pilot 3D Mouse

+ 0x046D; 0xC626; Logitech, Inc.; 3Dconnexion Space Navigator 3D Mouse
+ 0x046D; 0xC627; Logitech, Inc.; 3Dconnexion Space Explorer 3D Mouse

+ 0x046D; 0xC628; Logitech, Inc.; 3Dconnexion Space Navigator for Notebooks
+ 0x046D; 0xC629; Logitech, Inc.; 3Dconnexion SpacePilot Pro 3D Mouse

+ 0x046D; 0xC62B; Logitech, Inc.; 3Dconnexion Space Mouse Pro

+ 0x256F; *; 3Dconnexion; SpaceMouse
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Add

Rule v

VendoriD €} /

ProductiD €}

Name €) / SpaceMouse Pro

5. Save the settings.

Now, the SpaceMouse is ready for use.

() To achieve that the mouse behaves as usual in CAD programs, change the configuration as follows:
1. Go to IGEL Setup > System > Registry > ica.wfclient.mousesendscontrolv.
2. Setthe parameter to disable.

& fthe SpaceMouse does not function properly after the previous Citrix session, the USB reset of
the SpaceMouse must additionally be configured. Follow the instructions in Solve 3Dconnexion
SpaceMouse USB Reset Problem (see page 328).
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Solve SpaceMouse USB Reset Problem

Environment
Valid for IGEL hardware H850C, H830C, and M340C

Problem

After a previous Citrix session, the SpaceMouse does not function properly (e.g. after the end of the Citrix session,
the reset of the SpaceMouse does not take place; as a result, the display of the SpaceMouse always remains bright).

Solution
Use a power cycle command to automatically turn all USB devices off and on again:

1. InIGEL Setup, go to System > Firmware Customization > Custom Commands > Post Session.
2. Under Session type, select Citrix.

3. Under Post session command, enter the following command: /etc/igel/usb-power-

reset/igel-usb-power-ctl -p cycle

() Youdo not need root permissions for this action.
As a result of the configured USB power cycle, after the end of the Citrix session, the display of the SpaceMouse

should become dark for about 1 second and then bright again.

See also How to Connect a SpaceMouse with a Citrix Session (see page 326).
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Wireless Mouse Keyboard Set Logitech k520 Freezes in Citrix Session

& Solution Based on Experience from the Field

This article provides a solution that has not been approved by the IGEL Research and Development
department. Therefore, official support cannot be provided by IGEL. Where applicable, test the solution
before deploying it to a productive environment.

Issue

Wireless Mouse Keyboard Set Logitech k520 freezes in Citrix XenDesktop session.

Environment

+ IGELOS 11
+ UMS6.01 and higher

Description

If the Wireless Mouse Keyboard's infrared signal is disturbed, it freezes.

Solution

This particular device uses infrared dongle. BT devices should work fine as a workaround and we suggest using
those. Citrix discourages the use of the IR dongles.
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Black Box Next to the Mouse Cursor

Symptom

With certain programs (Adobe Reader, Visual Studio, ...) a black box is always displayed next to the cursor
in XenDesktop VMs.

Problem

This only happens when a connection is made to an IGEL device and disappears when a Windows device is
connected. The box is only visible directly on the client (not via VNC).
The problem occurs on the UD7 as well as on Intel NUCs.

Solution

» Inthe IGEL Setup disable the parameter Disable RENDER Extension (for ICA only) under System > Registry >
ica.wfclient.disablexrender:

Update

icawfclient disablexrender

ymmpollwaitinctime
 mmpoliwaitmax
ymmpollwaitmin

ymmwindor
Disable RENDER Extension (for ICA only)

€) ./ V] Disable RENDER Extension (for IGA only)

tomization

‘ Registry

B defaultprinter
B defaultprinterdriver
W deferredupdatemode

Search Show only enabled Parameters

Cancel

See also at Citrix: https://support.citrix.com/article/CTX212013
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How to Configure Citrix Native USB Redirection

Native USB Redirection redirects most popular USB devices to the Citrix session. To use this feature, you must
have at least XenDesktop 7.6 installed. In addition, the guidelines for USB redirection must be defined. More
information can be found on the following pages

« Citrix Generic USB Redirection Configuration Guide®
« Generic USB redirection and client drive considerations®®

The following types of USB device are not supported by default for use in a Citrix Virtual Apps and Desktops
session:

+ Bluetooth dongles
+ Integrated NICs
+ USB hubs

The following types of device are supported directly in a Citrix Virtual Apps and Desktops session, and so do not
use USB support:

+ Keyboards
+ Mice

« Smart cards
+ Headsets

+ Webcams

In addition to the server policies, the USB redirection must also be activated at the client:

1. In Setup, go to Sessions > Citrix > Citrix Global > Native USB Redirection.
2. Enable Native USB Redirection.
3. Set the Default rule to Deny or Allow:

+ Allow: All devices that are allowed by default are redirected.

« Deny: No device is redirected.

@ Tip
To secure your endpoint, it is generally recommended to set Default rule to Deny and to
configure Allow rules only for the required USB devices and USB device classes.

4. To customize the USB redirection, you can create classes or device rules to redirect e.g. Bloomberg
keyboards or 3D Spacemouse.

() Getting USB Device Information

To find out the Class ID, Subclass ID, Vendor ID and Product ID of the connected USB device, you can use
the System Information tool. For further information, see Using “System Information” Function.
System Information example:

25 https://support.citrix.com/article/CTX137939
26 https://docs.citrix.com/en-us/citrix-virtual-apps-desktops/general-content-redirection/usb.html
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Citrix

Devices - USB Devices - System Information

Information View Help

(:) Refresh Generate Report ||_:| Copy to Clipboard  |7¥| Synchronize

g_ Computer

Fil 001:001 | Linux | 2.0 root hub

@ summary 002:001 1.1 root hub
4% Operating System (&) 002:002 [WMware virtual Mouse
@ Security i ub

4§ Kemnel Modules ) 002:004 logitech 960 Headset

@ Boots |
m Languages
B Memory Usage

(== Filesystems

@ Display
[SJ Environment Variables
..... Devices Device Information
g_ System DMI Product [0x0002] 2.0 root hub
Vendor [0x1d6b] Linux Foundation

[ Linux.

@ Monitors Device EHCI Host Controller

Memory Devices Manufacturer Linux 5.12.19 ehci_hcd

o ' [ Linux |

Max Current 0 mA

) USB Version 2.00
S8 Interfaces Speed 480 Mbys
- d -

Done.

Alternatively, you can use the command lsusb (or lsusb | grep -i [search term] )inthe
terminal.
Example for lsusb :
Local Terminal
Fle Edit View Terminal Tabs Help
root@ITCOO5056930CAD :~# lsusb | grep -i logitech

Bus 002 Device 004: ID 046d:0a4d5 , Inc. 960 Headset
root@ITCOO5056930CAD: ~# [

() Foradevice exception rule, use the SpaceMouse Guide (see page 326).
For more information about USB redirection rules, see Native USB Redirection for Citrix Sessions in IGEL
0S and the documentation of the respective Citrix Workspace app.
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Citrix Fabulatech Scanner Redirection in IGEL OS

The following article details how you can activate Fabulatech scanner redirection for Citrix sessions.

& Notethat Fabulatech Scanner for Remote Desktop must also be installed on the backend server. For more
information and a free trial version, see https://www.scanner-for-remote-desktop.com/.

How to Enable Fabulatech Scanner Redirection for Citrix

1. IntheIGEL Setup, go to System > Firmware Customization > Features and make sure that

Scanner support /[SANE (Limited support - functionality "as is", see product documentation
for details) is activated.

ent -
v Printing (ThinPrint)

Vv RDP

ee product documentation for details)

» [ Environme
. Features
B Registry

« Ifthe option is already activated, continue with step 2.

+ If the option has not been activated before, the software component must be downloaded
first. For this purpose, make sure that the source of the current firmware is set correctly:

+ If you are using Universal Firmware Update, make sure that the device is assigned to
the current firmware. For details, see Universal Firmware Update and Assigning
Updates.

« If you are not using Universal Firmware Update, make sure that System > Update >
Firmware Update is set to the source of the current firmware. For details, see
Firmware Update Settings for IGEL OS.

« After clicking OK to confirm your changes, you must reboot the system.

2. Inthe IGEL Setup, go to Sessions > Citrix > Citrix Global > Fabulatech Scanner Redirection.
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Citrix

3. Check Fabhulatech Scanner for Remote Desktop.
< > ~

Configuration

lient Selection
lobal
StoreFront Login

B Fabulatech Scanner Re

B HDX Multimedia
B codsc

Search

4. Click Apply or Ok to confirm the settings.
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Mapping USB Storage Media into Citrix Sessions

How to configure USB storage mapping so that users can access USB storage media attached to the IGEL OS device
within Citrix sessions?

(@ The mapping of USB storage devices is possible for "USB mass storage class" devices. The storage of
smartphones and digital cameras is usually accessed via the MTP protocol. Mobile device access via MTP is
available with IGEL Linux 10.04.100 or higher; for more information see the how-to Using Mobile Device
Access (see page 992).

Basic Configuration of the Client

nfigurations
Read/Write i bal - Drive
pping

slobal - Drive

Client Drive Mapping €) Dynamic

Notification
¥ Hotplug b
v Hotplug m

Timeout
15 Seconds

Search

Apply Ok Cancel

Within the IGEL Setup or a UMS profile, you basically need to configure these parameters:

> Activate Devices > Storage Devices > Storage Hotplug > Client drive mapping > Dynamic. This option
activates dynamic client drive mapping. It automatically recognizes new storage media as they are connected to
the endpoint device. The endpoint device beeps and shows a notification while it mounts the new device. The
storage devices automatically become usable on the endpoint and in Citrix ICA Sessions.

© Mounted devices need to be unmounted before they are removed to ensure data integrity. This can be
done via the Disk Utility, the Disk Removal tool, or a tray icon.

Additional Parameters to Check

» The following parameters are set by default, thus storage mapping will work, but maybe for some reason you
have changed these and need to adjust them to allow the storage mapping:
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Sessions > Citrix > Citrix Global > Mapping > Drive Mapping > Drive mapping (set checkmark)
Sessions > Citrix > Citrix Global > Native USB Redirection > Native USB redirection (remove checkmark)

Sessions > Citrix > Citrix Global > Fabulatech USB Redirection > Fabulatech USB redirection (remove
checkmark)

Devices > USB access control > Enable (remove checkmark)

Sessions > RDP > RDP Sessions > [session name] > USB Redirection > Enable Native USB Redirection (set
to Global setting)

Sessions > RDP > RDP Sessions > [session name] > Mapping > Enable Drive Mapping (set to Global setting)

Assigning a Drive Letter within the Session (Optional)

» Incase you not only want to see the drive in the session as e.g. "A on IGEL-123456789", but want to address the
drive with a real drive letter within the session, you may run one of these commands:

subst T: \\tsclient\t

or

net use T: \\tsclient\t

In this example, "T on IGEL-123456789" is assigned to drive letter T: within the session. You may also assign the
mapped drive to another drive letter than is used in its name.

Configuration on the Server Side

On the server side, e.g. with Windows Server 2008R2, a user in the group "Users" with access to the terminal server
will have the mapping default. This is true for a newly installed server. But the mapping can be prevented by
changing the policies:

() Do not allow drive redirection specifies whether to prevent the mapping of client drives in a Remote
Desktop Services session (drive redirection). By default, an RD Session Host server maps client drives
automatically upon connection. Mapped drives appear in the session folder tree in Windows Explorer or
Computer in the format [driveletter] on [computername]. You can use this setting to override this
behavior." Source: https://technet.microsoft.com/de-de/library/ee791794%28v=ws.10%29.aspx
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Citrix

Auto-Hide Toolbar in Appliance Mode

Environment

IGEL Linux v5.x or newer

Problem
In the appliance mode, the toolbar at the top of the screen is permanently displayed.

You want to configure the toolbar to hide automatically after it loses the focus of the mouse pointer.

Solution

1. InIGEL Setup, go to System > Registry >
userinterface.igel_toolbar.show_always_in_appliance_mode.

2. Disable Show toolbar always in appliance mode.

3. Click Ok to save the changes.

(@ Forthe changes to take effect, you need to restart active appliance mode sessions.
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Create a Seamless, Transparent User Experience with Appliance Mode

With appliance mode, you can confine a device to a specific session. In appliance mode, the device itself fades in the
background, and the session is presented to the user in the most straighforward way. The user will not have to deal
with a Linux desktop, multiple login procedures, switching between windows, or device configuration.

Use the appliance mode to allow access only to one specific session. On device startup, the user is directed
immediately to the login screen of the virtual desktop.

The appliance mode can be applied to the following session types:

« VMware Horizon

« Citrix Self-Service (for published desktops only, not for published applications)
« RHEV/Spice

+ Imprivata

+ RDP MultiPoint Server

« XDMCP for this display

To configure a session that runs in appliance mode:

1. Open the setup and go to Sessions > Appliance mode.
2. Choose the session type of the desired session using the drop-down menu Appliance mode.
3. Configure your appliance mode session as appropriate.

For further information, see the manual chapter Appliance Mode.
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Connecting to a Citrix Farm

By connecting a Citrix farm, your data and applications are kept centrally on a Citrix farm. Applications must now be
delivered instantly to users anywhere on any device.

There are several ways of connecting to a Citrix farm and starting sessions. We describe three best practice variants
below:

« Citrix StoreFront (see page 340): Integrates published applications into the IGEL GUI.
« Citrix Self-Service (see page 341): Users will be directed to a web interface where they will find pre-
defined published applications and they will be able to add more published applications the

server provides.
« Appliance Mode (see page 344): Shows only the web interface of the farm and hides the IGEL GUI

completely.
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Citrix StoreFront

Prerequisites:

OS (see page 675))

Connecting via StoreFront:

WeNO b

10.

11.

12,

Click Sessions in the configuration tree of the IGEL setup.
Click Citrix > Citrix StoreFront > Server.

Click the ADD icon in the Server location window.
The ADD mask opens.

Enter the names or IP addresses of the services sites.
Confirm with OK.

Click Citrix StoreFront > Desktop Integration.
Enter "Citrix Storefront" under Login Session Name.
Choose Desktop as the starting method.

Click OK to save the changes.

Setup closes.

Doubleclick the Citrix icon on the desktop.

The login window opens.

Enter the credentials of a user in the login window.

The published applications of the Citrix farm will appear on the desktop.

Doubleclick an application icon on the desktop to start the program.

IGEL OS Articles
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Citrix Self-Service

Prerequisites:

+ Trust root certificate in directory /wfs/ca-certs (see Deploying Trusted Root Certificates)
Connecting via StoreFront:

1. Click Sessions in the configuration tree of the IGEL setup.
Click Citrix > Citrix Self-Service > Server.
Enter the Server, the Path to Store and the Store name of the services sites.
Confirm with OK.
Click Citrix Self-Service > Desktop Integration.
Enter "Citrix Self-Service" under Login Session Name.
Choose Desktop as the starting method.
Click OK to save the changes.
Setup closes.
9. Doubleclick the Citrix icon on the desktop.
The login window opens.
10. Enter the credentials of a user in the login window.
The published application icons of the Citrix farm will appear in the Self-Service Ul.
11. Doubleclick an application icon to start the program.

NGO A WN
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Using Citrix Self-Service

1. Start Citrix Self-Service e.g. with desktop icon.

Log on to the server.

Add published applications to the list (+-button on the left).
Click a published application to start.

Use the search bar to find a published application.

Use the user's menu to change preferences, server etc.

oA WD

©

Self-Service

Citrix Workspace HE)x

Alle Apps
=
7| —
Access 2013 - SRV1 Calculator - SRV2 Citrix HDX Monitor
\L'l ; W
Excel 2013 - SRV1 Internet Explorer 11 - SRV2 Media Player - SRV2
/ Details Details Sy /) Details
-~ L
Notepad - SRV2 Outlook 2013 - SRV1 Paint - SRV2
PowerPoint 2013 - SRV1 Publisher 2013 - SRV1 Skype for Business 2015

+ Configure Full-Screen Mode (see page 343)
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Configure Full-Screen Mode

Use following parameter in your Custom Command script to activate the full-screen mode for Citrix Self-Service:

> SICADIR/storebrowse —-c FullscreenMode=[0/1/2]

With following options:

+ 0 =Thewindow is not displayed full-screen
« 1 =Thewindow is displayed full-screen

+ 2 =Thewindow is displayed maximized and undecorated, which does not mask the desktop
environment's taskbar
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Appliance Mode

Connecting Citrix via Selfservice:

1. Click Sessions > Appliance Mode in the configuration tree of the IGEL setup.
Select Citrix Self-Service under Appliance mode.

Enter the URL of the delivery server.

Click OK to save the changes and close setup.

Follow the instructions on the screen.

ok N
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Create a Self-Service Setup for the User with Quick Settings

Usually, the user should not have full access to the thin client's setup. However, it may prove useful to enable users
to quickly change certain settings by themselves, without even needing a password. Typical examples are settings
for keyboard, mouse, or screen. This can be done using the Quick Settings.

Here is how to select setup pages for quick setup:

1. Open the setup and go to Accessories > Quick Settings > Setup User Permissions.
2. Select the setup pages to which the user should have access, e. g. User Interface > Input > Mouse,
or Screenlock / Screensaver.

L4 F_ﬁ Screenlock / Screensaver
v [l options
v ﬁ Taskbar
v m Screensaver
v v [l input
a

&
v m Mouse
a

-

3. Click Apply or Ok.
When the user starts Quick Settings, the previously selected options are presented.
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Configuration

User Interface

» I Display
+ Il Desktop
B Language
v £3 Screenlock / Screensaver
B options
B Taskbar
ﬁ Screensaver
¥ O Input
B xeyboard
B 2dditional keyboard layouts
‘ Mouse
» [ Touchpad

Quick settings set permissions for setup screens. If you want to set permissions for individual
parameters, you can use UMS profiles. For more information, see Profiles.
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Login Failed because of the Expired AD Password

Problem

When you try to log in to a native Citrix Storefront session, you get the error message "Login Failed!" because your
Active Directory password expired.
You are unable to change your password, because the local login does not provide an option for that.

() Beforeyou follow these instructions, check that the ports are open, maybe you can fix the problem by
that:
+ Login to Client -> Port: 88
+ Change password -> Port: 464

Here you find an overview of ports of the domain controller: Required Ports to Communicate with Domain
Controller?”

Solution

Enable Active Directory/Kerberos authentication for the Storefront session. The next time you try to login to IGEL
0S, you will be prompted to change your expired password.

Changing an Expired Active Directory Password

© When using sessions with passthrough authentication, it is essential that you lock your device's screen
when leaving it unattended.

Enabling Active Directory/Kerberos Authentication for Storefront Sessions

1. InIGEL setup, go to Security > Login > Active Directory/Kerberos.
Enable Login to Active Directory domain.

Go to Security > Active Directory/Kerberos.

Activate Enable.

Fill in the Default domain (fully qualified domain name).

Go to Sessions > Citrix > Citrix Storefront > Login.

Enable Use passthrough authentication.

Click Apply or Ok.

NGO A WN

() Please note that the client must now be locked locally and no longer in the session to prevent another
person from entering the session via the passthrough without specifying the password.

27 https://social.technet.microsoft.com/Forums/windows/en-US/1c6a59de-c1fe-4946-bb4e-1fe36fd40b08/required-ports-to-communicate-with-
domain-controller?forum=winserverDS
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Enabling Screenlock

ok W

6.

In the IGEL setup go to User Interface > Screenlock / Screensaver.
Enable Use hotkey.

Under Modifiers select Win .

Under Hotkey enter "L".

Got to User Interface > Screenlock / Screensaver > Options.
Enable User password.

So the "Win + L" hotkey locks the IGEL client instead of the session desktop.

The AD password must be entered to activate the IGEL clients.
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Configuring Auto Logon for Citrix Virtual Desktops

This how-to describes how to configure Auto Logon for Citrix Virtual Desktops.

Steps

1. InIGEL Setup, go to Sessions > Citrix > Citrix StoreFront > Server.

Configuration
Server location
Sessio

Protocol Store address
I sessions Summary

[ Global Session Options
vOc
nt Selection
bal
ix StoreFront
W server
B togin
B 2ppearance
B Reconnect
B Refresh
B Logoff
n Desktop Integration
» I Citrix Self-Service
> [l RDP

2. Add your Server Location.

Configuration
Server location

Protocol Store address

B Login
‘ Appearance
' Reconnect
B Refresh
B Logoft
B Desktop Integration
+ [N Citrix Self-Service
» Il RDP

Add

Citrix Store site address
|. http s:/f |

Store name

IGEL OS Articles

Path to Store Store name

Path to Store Store name

Path to Store
Citrix/Store

Cancel
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IGEL

3. Add your Active Directory domain to Domains, making sure that you use its Fully Qualified Domain
Name (FQDN).

Configuration
Server location .
Sessions
Protocol Store address Path to Store Store name
[ Sessions Summary

B Global Session Options

ent Selection
obal
itrix StoreFront
B server
‘ Login
n Appearance
B Reconnect
B Refresh
B Logoff
B Desktop Integration W
itrix Self-Service

B Appliance Mode
» M Evidian Auth
I NoMachine N

Domains

I ThinLinc
I ssH Handling of domain in login window normal
» Il VNC Viewer

Domain

Configuration hentication type Password authentication

Sessions Only for Citrix StoreFront
' Sessions Summary

Use passtl authenticati
B Global Session Options Use passthrough authentication

Auto login
rix Client Selection User name
% Global
Password

Domain

¥ Remember user name and domain
B Refresh
B Logoff
ktop Integration
» M Ci If-Service Start a single published application automatically
I rOP
» I Horizon Client Start following applications automatically after server connection is established
‘ Appliance Mode
an AuthMgr
achine NX

Synchronize Citrix password with screenlock

Relaunch Citrix login after logoff

5. Set Authentication type to Password authentication.
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Authentication type Password authentication

Only for Citrix StoreFront

Use passthrough authenticati
Auto login

User name
Password

Domain

6. Activate Auto Login.

Authentication type Password authentication

Only for Citrix StoreFront

Use passthrough authentication
€ V) Auto login

User name
Password

Domain

V' Remember user name and domain
rix password with screenlock
Relaunch Citrix login after logoff
Start a single published application autematically

Start following applications automatically after server connection is established

7. Set User Name to the Active Directory user name.

ication type Password authentication

Only for Citrix StoreFront

Use passthrough authentication
€) (V) Auto login
User name
Password
Domain
V' Remember user name and domain

Synchroniz rix password with screenlock
Relaunch Citrix login after logoff

Start a single published application automatically

Start following applications automatically after server connection is established
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8. Setthe Password.

Authentication type Password authentication

Only for Citrix StoreFront

Use passthrough authentication
€) (V) Auto login
User name
Password
Domain
¥ Remember user name and domain
Synchroniz % password with screenlock

Relaunch Citrix login after logoff

Start a single published application automatically

Start following applications automatically after server connection is established

9. Set Domain to your Active Directory domain's FQDN, the same as in step 3.

Authentication type Password authentication

Only for Citrix StoreFront

Use passthrough authentication
€) (V) Auto login
User name
Password
Domain
v Remember user name and domain

Synchronize Citrix password with screenlock
Relaunch Citrix login after legoff

Start a single published application automatically

Start following applications automatically after server connection is established
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Force Citrix Logout Using Hotkey

You will find the instructions under Citrix: Freeze at Logout (see page 354).

& This page is due for deletion. Please check the above link and use it in the future.
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Citrix: Freeze at Logout

Symptom
A user tries to log out from a Citrix session but the session does not respond.

Example: Once you connect to a Citrix session, everything works. After having reconnected and disconnected
several times, you log out. The window freezes while the logout screen is shown.

Solution

» Go to Sessions > Citrix > Citrix Global > Options > HDX Adaptive Transport over EDT and select TCP only -
UDP disabled. (Default as of 11.06.100)

OR
> Try to use another Citrix Receiver version: Sessions > Citrix > Citrix Client Selection > Citrix client version.

OR

» Troubleshoot the issue with your Citrix infrastructure to discover why the session is not closing when
the wfica process makes the call for disconnection.

Workaround

As a less recommended alternative, you can configure a hotkey to force a logout in such situations. Note, however,
that this workaround can cause issues with hung sessions on the Citrix servers.

To configure a logout hotkey:

1. InIGEL Setup, go to System > Firmware Customization > Custom Application.
Click L*] to create a new Custom Application and name it e.g. "Kill Citrix Sessions".
Disable all Starting Methods for this session.

Enable Hotkey.

Choosee.g. Ctr1|Alt asModifiers and define C (for "Citrix) as Key.

Go to System > Firmware Customization > Custom Application > Kill Citrix Sessions > Settings.
Enter an Icon name.

Enter /tmp/kill_citrix as Command.

Go to System > Firmware Customization > Custom Commands > Desktop.
10. In the field Desktop initialization enter following command in one line:

echo -e "#! /bin/bash\n\nps -eo comm,pid | grep *wfica | while read
c p tail; do echo \$p; done | xargs -r kill -TERM" >/tmp/
kill_citrix; chmod 755 /tmp/kill_citrix

11. Click Apply and reboot the device.

L o N A WN
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To configure the hotkey for a group of devices, you can alternatively create a profile or use this
one: profile_KillCitrixSessionsViaHotkey.xml.

Here you can learn how to import a profile: Importing a Profile and Firmware.
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Warning Message: [Citrix Store] Could Not Connect to the Citrix Server

Environment

+ You are using Citrix Receiver 13.0.x or newer.
+ You have a session of the type Citrix StoreFront configured.

Symptom
« When establishing the connection, a warning message appears:
Warning: [Citrix Store] Could not connect to the Citrix server.

Warning: [Citrix Store] A

Warning: [Citrix Store] Could not connect to the Citrix server.

-iiclick for more details
url supplied is not a valid store
Have you installed your root certiﬁcate?)

or
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Warning: [Citrix Store]

Warning: [Citrix Store] Could not connect to the Citrix server,

-iiClick for more details:

Have you installed your root certificate?

Error adding store:AM_ERROR_HTTP_SERVER_CERTIFICATE_NOT_TRUSTED[65150]

W Ok

Problem

Citrix Receiver 13.0.x or newer on Linux only supports connections via HTTPS, and you have to make sure the device
has a valid root certificate of the Certificate Authority (CA) available. If the root certificate is missing, the connection

will fail.

Solution

Install an appropriate root certificate on the device to allow HTTPS connections to your Citrix Server.

For information on how to distribute the certificate, see Deploying Trusted Root Certificates in IGEL OS (see page 675).

IGEL OS Articles
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Setting up Citrix Sessions with Hardware-Accelerated H.264 Deep
Compression Codec

This document describes how to activate a hardware-accelerated H.264 deep compression codec for Citrix sessions.

Prerequisites

+ Licensed IGEL Multimedia Codec Pack

+ IGEL UD device offering hardware video acceleration, see the FAQ Hardware Video Acceleration on
IGEL OS.

« Citrix XenApp / XenDesktop server with active H.264 display mode
See http://support.citrix.com/article/CTX200370 to learn how to determine the display mode.

Activating the Codec

1. In Setup, go to System > Firmware Customization > Features.
Enable Hardware Video Acceleration.

Go to Sessions > Citrix > Citrix Client Selection.

Select the Citrix Client Version.

Go to Sessions > Citrix > Citrix Global > Codec.

Set Graphical Codec to H.264 Deep Compression Codec.
Enable Accelerated H.264 Deep Compression Codec.

Noukwn

Known issues on VIA-based IGEL devices UD3-LX 40/41/42 and UD10-LX:
+ Hardware-accelerated HDX only works with 256 MB video memory or more. Video memory
must be adjusted in the system BIOS. The default is 128 MB.
+ Seamless window mode is not supported.
+ Desktop sessions spanning 2 monitors are not supported.
+ Desktop sessions on rotated screens may flicker (depending on the screen resolution).

©

() Ifyou use the Citrix Receiver 13.5 or older in combination with a Citrix Server 7.15, the Always Lossless
option for the Visual Quality policy will not work under Linux.
With IGEL Linux version 10.05.100 the Build to Lossless option for the Visual Quality policy will work on
the condition that you are using Citrix Receiver 13.6 or younger and the Use Video Codec policy is set to
For actively changing regions.
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Using Font Smoothing (ClearType) in Citrix Sessions

Symptom

+ You have set Font Smoothing to ClearType in
IGEL Setup > Sessions > Citrix > Citrix Global > Window > Font smoothing (Off / Standard /
ClearType)

+ ClearType does not work for Citrix PNAgent | Webinterface sessions.

Problem

ClearType is not supported in PNAgent / Webinterface sessions because Citrix Receiver uses Windows settings which
are not present on the Linux client.

Solution

All Citrix Receivers up to version 12.x do not use wfclient.ini to configure Font Smoothing. To force
Webinterface, PNAgent/XenApp to enable Font Smoothing proceed as follows:

PNAgent / XenApp:

1. Onthe Citrix server open C:

\inetpub\wwwroot\citrix\pnagent\config\default.ica .
2. Goto section Application.
3. Add new line FontSmoothingType=3 .
4. Save and close the file.

Webinterface:

1. Onthe Citrix server open C:

\inetpub\wwwroot\citrix\xenapp\config\default.1ica .
2. Go to section Application.
3. Add new line FontSmoothingType=3 .
4. Save and close thefile.

@ Ifyouinstalled the Webinterface site to a different location, please change the path
accordingly.

FontSmoothingType parameter options:

+ 0 =Nosmoothing

+ 1 =Nosmoothing
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+ 2 =Standard smoothing
+ 3 =ClearType (horizontal sub-pixel) smoothing (default)

A Legal Note
IGEL's Terms & Conditions®® apply.

28 https://www.igel.com/terms-conditions/
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Highly Secured XenServer has Problems with LD_BIND_NOW Workaround

Problem

You want to launch multiple desktop sessions with RTME and H.264 acceleration, but it doesn't work.

Solution

1. InIGEL Setup, go to System > Registry > ica > workaround-dual-rtme (Search
parameter: ica.workaround-dual-rtme)

2. Enable Activate workaround for dual RTME sessions and H264 acceleration.

3. Click Apply or Ok to save the changes.

() Thisregistry key should not be used if "Enable Secure ICA" is active for the specific delivery group. You
have to decide if you want to use the registry key or to reduce security.
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Workaround for Citrix Receiver X Error

Problem
When starting Citrix XenApp you get the following Citrix Receiver errors on your IGEL OS devices:
The X Request 55.0 caused error: "9: BadDrawable (invalid Pixmap or Window

parameter)"

The X Request 60.0 caused error: "13: BadGC (invalid GC parameter)".

Environment

« Citrix XenApp 7.15
« Citrix Receivere.g. 13.2,13.3,13.7,13.8

Solution
Two parameters have to be activated in IGEL Setup:

1. Go to System > Registry > ica > forceignorexerrors.

2. Activate Suppress X error message boxes.

3. Go to System > Registry > ica > wfclient > ignorexerrors.
4,

Activate IgnoreXErrors and pass the parameters: 55.0/9, 60.0/13

See also the corresponding entry in the Citrix forum?®,

29 https://discussions.citrix.com/topic/393872-possible-workaround-citrix-receiver-x-error-on-linux-thin-clients/

IGEL OS Articles 362 /1109


https://discussions.citrix.com/topic/393872-possible-workaround-citrix-receiver-x-error-on-linux-thin-clients/
https://discussions.citrix.com/topic/393872-possible-workaround-citrix-receiver-x-error-on-linux-thin-clients/

Citrix

Citrix HTML5 Receiver Issue

Affected Versions

+ IGEL 0S 10.05.100 or higher
+ IGEL0S 11.01.100 or higher

Issue

Due to the abolition of plugin technology in Firefox 60+, the Workspace app installed under Linux is no longer
automatically recognized.

Solution

1. Ifyour device has IGEL OS 10.05, update to IGEL OS 10.06; if applicable, you can also upgrade to
IGEL OS 11.02. If your device has IGEL 0S 11.01, update to IGEL 0OS 11.02.
IGEL 0S 10.06 and IGEL OS 11.02 have been adapted for a workaround that requires server-side
modifications.

2. Change the server-side settings according to the instructions under https://support.citrix.com/
article/CTX237727.
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Macbook Keyboard Layout inside Citrix Session
To get the Macbook keyboard layout working correctly inside Citrix sessions, proceed as follows:

1. Under Sessions > Citrix > Citrix Global > Keyboard > Keyboard mapping file, select "Linux".
2. Under User Interface > Input > Keyboard > Keyboard type, select "Macbook".
All other keyboard layout settings can be left unchanged, i.e. as set by default.

() Inorderto type special characters like € and #, use the right-hand Alt/Option key, not the left-hand key.
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Citrix Feature Matrix

According to the details provided by the vendor, the following Citrix Client features are supported with Citrix

Workspace App 2009:

() Fordetails on the Citrix Clients that are built into your version of IGEL OS, see IGEL OS Release Notes >
Notes for Release [your version] > Component Versions [your version].
See also the original document at https://www.citrix.com/content/dam/citrix/en_us/documents/data-
sheet/citrix-workspace-app-feature-matrix.pdf.

Category

Citrix Workspace

Endpoint
Management

Ul

HDX Host Core

IGEL OS Articles

Feature

Citrix Virtual Apps

Citrix Virtual Desktops

Citrix Content Collaboration (Citrix Files)
Citrix Access Control Service

Citrix Workspace Browser
SaaS/Webapps with SSO

Citrix Mobile Apps

Intelligent Workspace features

Auto configure using DNS for Email Discovery
Centralized Management Settings

App Store Updates / Citrix Auto updates
Desktop Viewer/Toolbar

Multi-tasking

Follow Me Sessions (Workspace Control)
Adaptive transport

SDWAN support

Session reliability

Auto-client Reconnect

Bi-directional Content redirection

URL redirection

File open in Citrix Workspace app

Supported
yes
yes
no
no
no
yes
no
no
no
yes
no
yes
yes
yes
yes
yes
yes
yes
no
yes

yes
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Category

HDX 10 / Devices /
Printing

HDX Integration

HDX Multi-media

Security

IGEL OS Articles

Feature

Browser content redirection
Multiport ICA

Local Printing

Generic USB Redirection
Client drive mapping / File Transfer****
Local App Access

Multi-touch

Mobility Pack

HDX Insight

HDX Insight with NSAP VC

EUEM Experience Matrix
Session Sharing

Audio Playback

Bi-directional Audio (VolP)
Web-cam redirection

Video playback

Flash redirection

Microsoft Teams Optimization

Skype for business Optimization pack

Cisco Jabber Unified Communications Optimization

Windows Multimedia redirection

UDP Audio

TLS1.2
TLS1.0/1.1
DTLS 1.0
DTLS 1.2
SHA2 Cert

IGEL

Supported
yes
yes
yes
yes
yes
no
no
no
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes

yes (not with
NSG)

yes
yes
yes
no

yes
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Category

HDX Graphics

Authentication

IGEL OS Articles

Feature

Smart Access

Remote Access via Citrix Gateway
Workspace for Web Access

IPV6

H.264-enhanced SuperCodec
Client hardware acceleration
3DPro Graphics

External Monitor Support
Desktop Composition redirection
True Multi Monitor

Location Based Services (Location available via API-
description)

Federated Authentication (SAML/Microsoft Entra ID)
NetScaler Full VPN

RSA Soft Token

Challenge Response SMS (Radius)

User Cert Auth via NetScaler Gateway (via Browser
Only)

Smart Card (CAC,PIV Etc.)

Proximity/Contactless Card

IGEL

Supported

yes
yes
yes
yes
yes
yes
yes
yes
no

yes

no

yes
yes
no
no

no

yes

yes

Credential insertion (E.g.. Fast Connect, Storebrowse) yes

Pass Through Authentication

Save credentials *(on prem and only SF)
NetScaler nFactor Authentication

Netscaler Native OTP

Biometric Authentication (Touch ID, Face ID..)
Single Sign-On to Citrix Files App

Single Sign on to Citrix Mobile apps

no
no
yes
yes
no
no

no
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Category

Keyboard
Enhancements

IGEL OS Articles

IGEL

Feature Supported
Anonymous Store Access yes
Dynamic Keyboard Layout Synchronization with yes
Windows VDA

Note: Dynamic keyboard layout sync for non-
Windows receivers requires enablement of the
Unicode Keyboard Layout Mapping

feature on the Windows VDA.

Unicode Keyboard Layout Mapping with Windows yes
VDA

Client IME Enhancements with Windows VDA no
Language Bar Show/Hide with Windows VDA no
Applications

Option Key mapping for server-side IME input mode no
on

Windows VDA

Dynamic Keyboard Layout Synchronization with Linuxyes
VDA

Client IME Enhancements with Linux VDA no

Language Bar support for Linux VDA Applications yes
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Using Lync / Skype for Business with Citrix HDX RealTime Optimization
Pack

Issue

You want to use Microsoft Lync or Skype for Business via a Citrix session with IGEL OS devices.

Solution

IGEL OS comes with Citrix HDX RealTime Media Engine (RTME) preinstalled: Setup > Sessions > Citrix > Citrix
Global > Unified Communications > Skype for Business. See also HDX Multimedia Settings for an IGEL OS Citrix
Session.

+ IGEL 0S 11.04.100 or higher contains RTME 2.9 (activated by default).
+ IGEL 0S 11.02.100 or higher contains RTME 2.8 (activated by default).
+ IGEL0S 11.01.100 contains RTME 2.7 (disabled by default).

+ IGEL 0S 10.06.100 contains RTME 2.8 (disabled by default).

+ IGEL 0S 10.05.500 contains RTME 2.6 (disabled by default).
+ IGEL 0S 10.05.100 contains RTME 2.6 (disabled by default).

For further information, see Citrix HDX RealTime Optimization Pack®,

30 https://docs.citrix.com/en-us/hdx-optimization/
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Citrix Advanced Endpoint Analysis (EPA) Client on IGEL OS

() Thisarticleisvalid for IGEL OS 11.08.290 or higher.

As of version 11.08.290, the Citrix Advanced Endpoint Analysis (EPA) client has been integrated into IGEL OS. On the
client side, no configuration is necessary. When the Netscaler URL is opened in the device's browser (Chromium or
Firefox), the NSEPA checks configured in Netscaler are performed automatically.

As dynamic updates are not possible in IGEL OS, due to the read-only system, you must disable the automatic
update in Netscaler.

» In Netscaler, set Linux EPA Plugin Upgrade to Never.

« VPN Virtual Server

Basic Settings

Name

Protocol

1P Address Type

IPAddress*

192 168 238

Maximum Users
0

Max Login Attempts

Failed Login Timeout

ICA Only

Enable Authentication
() Double Hop

() Down State Flush

IP Range IP Set settings

] Login Once

CTX-VERIDIUM-ICA-PROXY

(0] Logout On Smart Card Removal

T EP TS OrET e

DTLS

AppFlow Logging

() ICA Proxy Session Migration
State

SameSite

() Enable Device Certificate

CA for Device Certificate

Help

Advanced Settings

+ Content Switching Policies

+ SSL Profile

+ SSL Policies

=+ Intranet IP Addresses

Port
+ Intranet Applications
443
+ EULA
RDP Server Profile Windows EPA Plugin Upgrade
Add @
PColP VServer Profile Linux EPA Plugin Upgrade
Add Never @

IGEL OS Articles
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Citrix Netscaler Gateway Client (NSGClient) for Netscaler VPN
Connections

() Thisarticleisvalid for IGEL OS 11.08.290 or higher.

As of version 11.08.290, the Citrix Netscaler Gateway Client (NSGClient) for Netscaler VPN Connections has been
integrated into IGEL OS. On the client side, no configuration is necessary. When the Netscaler URL is opened in the
device's browser (Chromium or Firefox), the Citrix Netscaler Gateway Client is configured automatically.

Additionally, a starter icon can be configured.

Configuring a Starter Icon on the Desktop

1. Inthe UMS Profile Configurator or the local IGEL Setup, go to System > Registry > sessions >

nsgclient% and click Add Instance.
IGEL Setup 11.08.290.rc2.01 (Build 6.10.5)

B =pplaun
B =pplaun

osition

B pulldown
B pwprotected
B qu

artmenu
meantl svstam

Search

The instance nsgclientl is created.
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IGEL Setup 11.08.290.rc2.01 (Build 6.10.5)

. Registl

Search

Apply
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2. Click Apply or Ok to save your changes.

IGEL Setup 11.08.290.rc2.01 (Build 6.10.5)

. Registry

> [ pnapp0_
> [ pnappl
» [ pnap
* [ pnap
» [ pnapp4_

Search > W pnap

An starter icon is created on the device's desktop.

Netscaler
Gateway Client

Starting the Netscaler Gateway Client with the Starter Icon

1. Click on the starter icon of the Netscaler Gateway Client.

Netscaler
Gateway Client

Aniconis created in the system tray.
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2. Click on the system tray icon and select Logon.

It 4 12:01

Citrix Gateway - URL

Gateway URL

Es

https:/f

Cifrix.

Cancel
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Unexpected Keyboard Layout in a Citrix Session

Problem

When a Citrix session has started, the keyboard layout changes in an unexpected way. On the local system, the
keyboard layout may still be as expected.

The problem has been reported for the following keyboard layouts:

+ English(International) with dead keys enabled
+ Polish (Programmers)

Environment

+ Devices with IGEL OS 11.07.110 or higher (all IGEL OS versions that contain Citrix Workspace App
2203 or higher)

Solution

1. Open the UMS configuration dialog or the local Setup, go to User Interface > Input > Keyboard,

and make sure that the correct Keyboard layout is set.
IGEL Setup 11.08.330.rc2.01 (Build 12.1.101)

{ * Userinterface ™ Input ™ Keyboard

Enable dead keys

Show indicator in taskbar
Character Repeat
Repeat delay
short
Repeat rate
slow

Test

B xeyboard

B Additional keyboard layou v start with NumLock on

Secure keyboard input with Cherry SECURE BOARD

Network

Search

Apply
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2. Go to System > Registry > ica > module > virtualdriver > keyboardsync > enable and disable
Keyboard layout synchronization.
Keyboard Layout

> A s

Configuration

yslogt
udpaudioporthigh
B udpaudioportlow

» B multimedia
B Registry

Search 4 Show only enabled Param

3. Go to System > Registry > ica > wfclient> keyboardsyncmode, set Configure keyboard layout
synchronization to Once, and then confirm your settings with Save.
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Keyboard Layout

> A i

Configuration

Configure onization

a.v |

Search

alog again)

When the user logs in to the Citrix session, the keyboard layout should be correct.
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+ Mapping USB Storage Media into RDP Sessions (see page 379)

« What Is the String for Token-Based Load Balancing? (see page 382)

« RDP Fabulatech Scanner Redirection (see page 383)

« RDP RemoteApp Parameter Settings (see page 384)

« RDP Performance Enhancements (see page 385)

+ RDP Session playing Sound: Error RDPSND_NEGOTIATE (see page 386)
+ Crackling and Audio Dropouts in RDP Sessions (see page 387)

+ Login Failed Because of Expired AD Password (see page 389)

+ User Has to Provide Credentials Twice for RDP Logon (see page 391)
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Mapping USB Storage Media into RDP Sessions

How to configure USB Storage mapping so that users can access USB storage media attached to the IGEL LX Client
within RDP sessions?

Solution:

(@ The mapping of USB storage devices is possible for "usb mass storage class" devices. The storage of
smartphones and digital cameras is usually accessed via the MTP protocol. Mobile device access via MTP is
available with IGEL Linux 10.04.100 or higher; for more information see the how-to Using Mobile Device
Access.

Basic Configuration of the Client

< p 2 N ! ™ Devices ™ Storage Devices ™ Storage Hotplug

Configuration (] storage Hotplug

= Default permission [Read;’Write v]

Acc ries Client Drive Mapping ) | Dynamic ,.J

User Interface
Static Client Drive Mapping

Network ) D e s R S
F e |etter for each storage
Devices N 1
B Hardware Info
» I Printer Start storage drives with this drive letter A
¥ [ storage Devices IER rmit ik p e e kv el s ol i
CA readaccess 1or storage nOtplug aevices B
. Storage Hotplug
‘ Options ICA write access for storage hotplug devices Yes
B Slustooth Notificati
B UsE access control otfication
Eacirity [¥f] Hotplug beep
Hotplug message
System o S ?
—_0

Timeout
15 Seconds

Within the IGEL Setup or an UMS profile you basically need to configure these parameters:

> Activate Devices > Storage Devices > Storage Hotplug > Client drive mapping > Dynamic. This option
activates dynamic client drive mapping. It automatically recognizes new storage media as they are connected to
the thin client. The thin client beeps and shows a notification while it mounts the new device. The storage devices
automatically become usable on the thin client and in Citrix ICA Sessions.

€© Mounted devices need to be unmounted before they are removed to ensure data integrity. This can be
done via the Disk Utility, the new Safely Remove Hardware Tool or a tray icon.
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Additional Parameters to Check

» The following parameters are set by default, thus storage mapping will work, but maybe for some reason you
have changed these and need to adjust them to allow the storage mapping:

Sessions > RDP > RDP Global > Mapping > Drive Mapping > Enable Drive mapping (set checkmark)
Sessions > RDP > RDP Global > Native USB Redirection > Enable Native USB redirection (remove checkmark)

Sessions > RDP > RDP Global > Fabulatech USB Redirection > Enable Fabulatech USB redirection (remove
checkmark)

Devices > USB access control > Enable (remove checkmark)

Sessions > RDP > RDP Sessions > [session name] > USB Redirection > Enable Native USB Redirection (global
setting)

Sessions > RDP > RDP Sessions > [session name] > Mapping > Enable Drive Mapping (global setting)

Assigning a Drive Letter within the Session (Optional)

> Incase you not only want to see the drive in the session as e.g. "A on IGEL-123456789", but want to address the
drive with a real drive letter within the session, you may run one of these commands:

subst T: \\tsclient\t
or
net use T: \\tsclient\t

In this example "T on IGEL-123456789" is assigned to drive letter T: within the session. You may also assign the
mapped drive to another drive letter than is used in its name.

Configuration on the Server Side

On the server side, e.g. with Windows Server 2008R2, a user in the group "Users" with access to the terminal server
will have the mapping default. This is true for a newly installed server. But the mapping can be prevented by
changing the policies:

() Do not allow drive redirection Specifies whether to prevent the mapping of client drives in a Remote
Desktop Services session (drive redirection). By default, an RD Session Host server maps client drives
automatically upon connection. Mapped drives appear in the session folder tree in Windows Explorer or
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Computer in the format [driveletter] on [computername]. You can use this setting to override this
behavior." Source: https://technet.microsoft.com/de-de/library/ee791794%28v=ws.10%29.aspx

A

r
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What Is the String for Token-Based Load Balancing?

Environment

A token-based mechanism is used as a load balancing method. This document does not apply to other load
balancing methods.

Question

What string should be entered in Sessions > RDP > RDP Sessions > [Session name] > Options to make token-
based load balancing work?

Answer

IGEL OS 10.05.700 or Higher, IGEL OS 11.01.110 or Higher

» Under Sessions > RDP > RDP Sessions > [Session name] > Options > Collection, simply enter the name of
your RDS collection. The collection name has been defined by the server administrator.

IGEL OS 10.01 to 10.05.500, 11.01.100

» Under Sessions > RDP > RDP Sessions > [Session name] > Options > Load balancing routing token,
enter tsv://MS Terminal Services Plugin.l.[collection name] ,where

+ tsv://MS Terminal Services Plugin.1l. istheroutingtoken
and
+ [collection name] isthe name of the RDS collection, defined by the server administrator.
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RDP Fabulatech Scanner Redirection

Enabling Fabulatech Scanner Redirection

1. Inthe IGEL Setup, go to System > Firmware Customization > Features and make sure that
Scanner support /[SANE (Limited support - functionality "as is", see product documentation
for details) is activated.

» Il Remc v Printing (ThinPrint)
) v RDP

v O Firmware tomization

: 2d support - functionality " ee product documentation for details)
stomn Partition

« Ifthe option is already activated, continue with step 2.
« Ifthe option has not been activated before, the software component must be downloaded
first. For this purpose, make sure that the source of the current firmware is set correctly:
+ If you are using Universal Firmware Update, make sure that the device is assigned to
the current firmware. For details, see Universal Firmware Update and Assigning
Updates.
« If you are not using Universal Firmware Update, make sure that System > Update >
Firmware Update is set to the source of the current firmware. For details, see
Firmware Update Settings for IGEL OS.
« After clicking OK to confirm your changes, you must reboot the system.
2. Inthe IGEL Setup, go to Sessions > RDP > RDP Global > Fabulatech Scanner Redirection.
3. Check Fabulatech Scanner for Remote Desktop.

s » RDP * RDP Global * Fabulatech Scanner Redirection

€2 [/] Fabulatech Scanner for Remote Desktop

4. Click Apply or Ok to confirm the settings.

IGEL OS Articles 383/1109



RDP

RDP RemoteApp Parameter Settings

Symptom

RemoteApp is not starting or closes immediately after login.

Problem

Missing or incomplete session settings on server or device

Solution

1. Set an ALIAS for the RemoteApp with the RemoteApp Management Console on the
Terminalserver.

E RemoteApp-Eigenschaften

Eigenschaften |Benutzerzuweisung |

.
A Remotedpp-Mame:

I Microsoft Excel 2010

Pfad:

I %3 STEMDRIVE s \Program Files (oBaMicrosoft OfficeOfficel 41Exc

2. Usethat ALIAS value in the device's setting in Setup > Sessions > RDP > RDP Sessions > (Session
Name) > Server > Application.

€ O server (®) Enable RemoteApps mode

Server

ROP Port 3388
Application a IIIE)(CEL |

Command Line Parameters for the Executed Program

[[] changeable Server-URL on Local Logon

@® Add two pipe-characters (|| ) at the beginning of the ALIAS value.
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RDP Performance Enhancements

Symptom
RDP users have performance issues (bad user experience).
For example:

+ Mouse is lagging

+ Screen is building up very slow

+ Session uses high bandwidth

+ Several other performance issues

Problem

There are many different causes that can result in bad performance.

Solution

The following settings can be used as a single option and also in combination.

Basics

+ The color depth should be the same on the server, the device, and in the session (best: 32 bit).
+ Inthe BIOS, set the VGA shared memory to 64 MB or more.

Optimizations for a LAN Environment

+ Under Sessions > RDP > RDP Global > Performance, edit the settings as follows:
+ Disable Compression. (Increases performance, generates about 30% more traffic)
« If RemoteFX 8 is available, activate Enable RemoteFX.
+ If RemoteFX 8 is available, set RemoteFX codec mode to "Optimized for LAN".
+ If Windows Server 2012 R2 or lower or Windows 8.1 or lower is used: Under Sessions > RDP > RDP
Global > Multimedia, activate Enable Video Redirection.

Optimization for a WAN Environment

+ Under Sessions > RDP > RDP Global > Performance, edit the settings as follows:
« Enable Compression. (Generates about 30% less traffic, consumes more local resources)
« If RemoteFX 8 is available, activate Enable RemoteFX.
+ If RemoteFX 8 is available, set RemoteFX codec mode to "Optimized for WAN".
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RDP Session playing Sound: Error RDPSND_NEGOTIATE

Symptom

If the user plays some sound within the RDP session the connection terminates on some devices with error
message:

ERROR: RDPSND: Extra RDPSND_NEGOTIATE in the middle of a session

ERROR: TCP Connection: Cannot receive data (Keep alive timeout)

ERROR: RDPSND: Extra(RDPSND NEGOTIATE)in the middle of

a 5ession
ERROR: TCP Connection; Cannot receive data (Keep alive
timeout)

Problem

This may happen if during data transmission the connection fails.

Solution
Try a different sound driver for RDP session:

1. Go to System > Registry > rdp.winconnect.sound-driver
2. Choose 0SS or ALSA
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Crackling and Audio Dropouts in RDP Sessions

Symptom

The user experience with RDP sessions is disturbed by crackling noises and glitches.

Environment

+ Device with a sound card that has a small buffer, e. g. IGEL UD3 (M340C)
+ Required for the solution: IGEL OS 11.03.500 or higher

Problem

The crackling noises, or audio glitches, result from buffer underruns. This occurs when new audio data are not
delivered fast enough and the sound card buffer has no more audio data left to play. Thus, it is not possible to
bridge the replay gap. This is more likely to happen with sound cards that have a relatively small buffer.

Solution

To enable the device to bridge bigger gaps, buffer capacity must be added. This can be done by increasing the
buffer of the RDP client, which implies increasing the latency. However, high latency can lead to a problem with
interactive applications, such as calls or video conferences. Thus, the latency should be increased in small steps.

To increase the latency of the RDP client:

1. Open the Setup and go to System > Registry > rdp > winconnect > sound-latency (registry key:
rdp.winconnect.sound-latency ).
2. Increase the Latency by about 50 milliseconds (recommended) and click Apply.
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sound-latency

Configuration

Ir
Registry
Search

Apply [o]3

3. Restart the RDP session and test the audio playback.
4. If the audio quality is good, click Ok to close the Setup. If there are still crackling noises, repeat
steps 2 and 3 until the audio quality is acceptable.
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Login Failed Because of Expired AD Password

Issue

When you try to log in to a RDP session, you get the error message "Login Failed!" because your Active Directory
password expired.
You are unable to change your password because the local logon does not provide an option for that.

() Beforefollowing these instructions, check the ports:
+ Login to Client -> Port 88
+ Change password -> Port 464

Here you find an overview of ports of the Domain Controller: Required Ports to Communicate with Domain
Controller

Solution

Enable Active Directory/Kerberos authentication for the RDP session. The next time you try to log in to IGEL OS,
you will be prompted to change your expired password.

Changing an Expired Active Directory Password

© When using sessions with passthrough authentication, it is essential that you lock your device's screen
when leaving it unattended.

Enabling Active Directory/Kerberos Authentication for RDP Sessions

1. InIGEL setup, go to Security > Logon > Active Directory/Kerberos.
Enable Login to Active Directory Domain.

Go to Security > Active Directory/Kerberos.

Activate enable.

Fill in the Default Domain (Fully Qualified Domain Name).

Go to Sessions > RDP > RDP sessions > [RDP session] > Logon.
Enable Use passthrough authentication for this session.

Click Appy or Ok.

NGO A WN

() Please note that the client must now be locked locally and no longer in the session to prevent another
person from entering the session via the passthrough without specifying the password.

31 https://social.technet.microsoft.com/Forums/windows/en-US/1c6a59de-c1fe-4946-bb4e-1fe36fd40b08/required-ports-to-communicate-with-
domain-controller?forum=winserverDS
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Enabling Screen Lock

ok W

6.

In the IGEL setup go to User Interface > Screenlock / Screensaver.
Enable Use Hotkey.

Under Modifiers select Win .

Under Hotkey enter "I".

Got to User Interface > Screenlock / Screensaver > Options.
Enable User Password.

So the "Win + L" hotkey locks the IGEL client instead of the session desktop.

The AD password must be entered to activate the IGEL clients.
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User Has to Provide Credentials Twice for RDP Logon

Issue

When you connect to a Windows terminal server, you are asked to provide your credentials twice.

Cause

This behavior is caused by the way RDS load balancing works. The crucial point to understand is that the terminal
server does not communicate with the session broker directly.

Instead, the scenario is the following:

1. The client connects to terminal server 1 and authenticates with terminal server 1. This is the first
time the user is asked for their credentials.

2. Since we have a load balancing setup, terminal server 1 will talk to the session broker and ask if
the client can use terminal server 1 or if it should be redirected to a different terminal server.

3. Ifredirection occurs, the client will also have to authenticate with the terminal server the client
was redirected to (terminal server 2 in the figure below). This is the second time the user is asked
for their credentials.
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with Terminal
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Terminal Server 2
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Accaptslogonto - C:Irent auth entk.:ates again, this
- time with Terminal Server 2

Terminal Server 1
or redirects to
Terminal Server 2

Z
>

Sestion Broker

Solution

The issue can be resolved by activating Kerberos/Active Directory authentication. For further information,
see Active Directory/Kerberos.
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IGEL

VMware Horizon

+ Setting up VMware Blast Sessions (see page 394)

« Use NLA (Network Layer Authentication) for Logon with Horizon Client Sessions (see page 395)
+ Workaround for Hotkeys in Horizon Sessions (see page 396)

« Multimedia Acceleration with VMware Horizon View in VESA Mode (see page 397)

» Horizon Feature Matrix (see page 398)

« Troubleshooting the Horizon Client (see page 405)

« VMware Horizon Authentication Issues (Certificate Revocation List) (see page 406)
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Setting up VMware Blast Sessions

Prerequisites

+ Device offering hardware video acceleration, see the FAQ Hardware Video Acceleration on IGEL OS.
« VMware Horizon 7 Server
For further information about the server configuration, refer to VMware's documents at http://
pubs.vmware.com/horizon-7-view/index.jsp

Activating VMware Blast

1. In Setup, go to System > Firmware Customization > Features.

Enable Hardware Video Acceleration.

Go to Sessions > Horizon Client > Horizon Client Global > Server Options.
Set Preferenced desktop protocol to VMware Blast.

Click Apply or Ok.

oW
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Use NLA (Network Layer Authentication) for Logon with Horizon Client
Sessions

Starting a session, even just presenting a logon screen, has quite an impact on resources. Each time a user tries to
logon, processes are started on the remote machine, no matter whether the user's credentials are valid or not. You
can save resources and prevent Denial of Service (DoS) attacks by using Network Layer Authentication (NLA). NLA
checks whether a user is the right person before any logon processes is started.

For more information about NLA, see https://technet.microsoft.com/en-us/magazine/hh750380.aspx.

NLA for Horizon Client Sessions is available from IGEL Linux version 5.08.100 upwards.

To use NLA for a Horizon Client session:

1. Open the setup and go to Sessions > Horizon Client > Horizon Client Sessions > [Session Name]
> Options.
2. Activate Network Level Authentication.
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Workaround for Hotkeys in Horizon Sessions

Issue

You want to switch from the VMware Horizon session to the IGEL desktop with the key combination [Ctrl]
+ [Windows] + [D]. While the key combination [Ctrl] + [Windows] + [D] can be realized with IGEL OS 11.01.100 or
lower (Horizon Client 4.x), this is not possible for IGEL OS 11.01.110 or higher (Horizon Client 5.x).

Solution

1. Press [Ctrl] + [Alt] and release the keys.
The focus is switched from the VMware Horizon session to the local system.

2. Use [Ctrl] + [Windows] + [D] to switch to the IGEL desktop.

3. To switch the focus back to the VMware Horizon session, click into the VMWare Horizon session
window.
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Multimedia Acceleration with VMware Horizon View in VESA Mode

Symptom

You did install IGEL Universal Desktop OS 2 on not fully supported hardware using IGEL Universal Desktop
Converter 2. Multimedia acceleration is not working within a VMware Horizon View session.

Problem

The graphics chip of your hardware is not supported and as a fallback the VESA mode is used.

Solution

There is no other solution to the problem than using fully supported hardware. Information on supported hardware
can be found in the UDC2 manual.®

You can also access IGEL's 3rd party hardware support database® to find fully supported graphic chips.

32 http://edocs.igel.com/index.htm#11873.htm
33 https://www.igel.com/linux-3rd-party-hardware-database/

IGEL OS Articles 397/1109


http://edocs.igel.com/index.htm#11873.htm
https://www.igel.com/linux-3rd-party-hardware-database/
http://edocs.igel.com/index.htm#11873.htm
https://www.igel.com/linux-3rd-party-hardware-database/

VMware Horizon

Horizon Feature Matrix

According to the details provided by the vendor, the following Horizon Client features are supported with Horizon
Client 5.4:

() Fordetails on the Horizon Clients that are built into your version of IGEL OS, see IGEL OS Release Notes >
Notes for Release [your version] > Component Versions [your version].
See also the original document at https://kb.vmware.com/s/article/80386.

Category Feature Supported
Client Appearance and Customer branding no
Workflow
Kiosk mode yes
English localization yes
Language localization yes
Broker Connectivity XML-API version 15
SSL yes
SSL certificate verification yes
Disclaimer dialog yes
Security Server compatibility yes
UAG compatibility yes
Multi-broker/Multi-site redirection - DaaS yes
Clientinfo yes
Phonehome yes
Broker Authentication Password authentication yes
Password change yes
Certificate authentication no
RSA authentication yes
Radius yes

Integrated RSA SecurlID token generator no

Single Sign On yes
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Category

Smartcard

Desktop Operations

Session Management
(Blast Extreme & PColP)

Client Customization

IGEL OS Articles

Feature

Login as current user
Nested log in as current user
Biometric authentication
Unauthentication access

X.509 certificate authentication (Smart
Card)

CAC support

.Net support

PIV support

Java support

Purebred derived credentials
Reset

Restart

Log off

Switch desktops

Multiple Connections

App Launch on Multiple end points
Auto-Retry

Auto-Retry 5+ minutes
Fullscreen mode

Fullscreen toolbar
Windowed mode

Time Zone Synchronization

Jumplist integration (Windows 7-
Windows 10)

Command Line Options
URI Schema

Preference File

Supported
no

no

no

yes

yes

no

yes

yes

no

no

only supported with VDI
only supported with VDI
yes

yes

yes

yes

yes

yes

yes

yes

yes

yes

no

yes
yes

yes
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Category

Protocols supported

Protocol Enhancements

Monitors / Displays

Input Device (Keyboard /
Mouse)

IGEL OS Articles

Feature
Non Interactive Mode
GPO-based customization
Blast Extreme

H.264 - HW decode

H.265 - HW decode

Blast Codec

JPEG / PNG

Switch Encoder

BENIT

Blast Extreme Adaptive Transportation
RDP 8.x, 10.x
PColP
RDP-VC Bridge
Session Enhancement SDK
Dynamic Display Resizing
Multiple Monitor Support
External Monitor Support
Display Pivot
Multiple Aspect Ratio support
Number of displays supported
Maximum Resolution
Video out
High DPI scaling
DPI Sync
Exclusive Mode
Multiple Monitor Selection
Relative mouse

External Mouse Support

Supported
yes
no
yes
yes
no
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
yes
4
3840x2160

yes

only supported with VDI

yes
no

yes
yes

yes
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Category

Clipboard Services

Client Caching

Connection Management

High-Level Device
Redirection

Real-Time Audio-Video

IGEL OS Articles

Feature

Local buffer text input box

Keyboard Mapping

Unicode Keyboard Support
International Keyboard Support
Input Method local/remote switching
IME Sync

Clipboard Text

Clipboard Graphics

Clipboard memory size configuration
Drag and Drop text

Drag and Drop images

View Agent to Client-side caching
Blast network recovery

IPv6 translation with UAG

IPv6 only network support

PColP IP roaming

Serial (COM) Port Redirection

Client Drive Redirection/File Transfer
Scanner (TWAIN/WIA) Redirection
X.509 Certificate (Smart Card)

Gyro Sensor Redirection

Analogin (input)

Real-Time Audio-Video

Multiple webcams

Supported
no
yes
no
yes
no
yes
yes
no
yes
no
no
yes
yes
no
no
yes
yes
yes
yes
yes
no
yes
yes

no
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Category
USB Redirection

Unified Communications

Multimedia Support

Graphics

IGEL OS Articles

Feature

Generic USB/ HID

Policy: ConnectUSBOnInsert
Policy: ConnectUSBOnStartup
Connect/Disconnect Ul

USB device filtering (client side)
Isochronous Device Support

Split device support

Bloomberg Keyboard compatibility
Smartphone sync

USB 3.0

USB Redirection USB storage devices
Cisco UC Jabber

Avaya UC One-X Desktop

Mitel UCA

Microsoft Lync 2013

Skype for business

Microsoft Teams RTAV

Multimedia Redirection (MMR)

Supported

yes

only supported with VDI
only supported with VDI
yes

yes

only supported with VDI
yes

only supported with VDI
only supported with VDI
yes

yes

only supported with VDI
only supported with VDI
no

no

yes

yes

yes

Flash URL Redirection (Unicast/Multicast) only supported with VDI

Flash Redirection
HTML5 Redirection
Directshow Redirection
vDGA

VSGA

NVIDIA GRID VGPU

Intel vDGA

AMD vGPU

no
yes

no

only supported with VDI
only supported with VDI
yes

only supported with VDI
only supported with VDI
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Category
Mobile Support

Printing

Security

Session Collaboration

Update

IGEL OS Articles

Feature

Client-side soft keyboard
Client-side soft touchpad
Full Screen Trackpad
Gesture Support
Multi-touch Redirection
Presentation Mode

Unity Touch

Printer Redirection
VMware Integrated Printing
Location Based Printing
Native Driver Support
FIPS-140-2 Mode Support
Imprivata Integration
Opswat agent

Opswat on-demand agent
TLS1.1

TLS 1.2

Session Collaboration
Read-only Collaboration
Update notifications

App Store update

Supported
no
no
no
no
no
no
no
yes
yes
yes
yes
yes
no
yes
no
yes
yes
yes
yes
no

no
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Category Feature Supported
Other Smart Policies yes
File Type Association no
URL content redirection yes
Browser content redirection no
Remember credentials no

Access to Linux Desktop - Blast Protocol only supported with VDI

Only
Audio Playback yes
Seamless Window yes

Launching multiple client instances using yes
URI

Parameter pass-through to RDSH apps  yes

Performance Tracker only supported with VDI
Shortcuts from server no
Pre-install shortcuts from server no
Workspace ONE mode yes
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Troubleshooting the Horizon Client

& Solution Based on Experience from the Field

This article provides a solution that has not been approved by the IGEL Research and Development
department. Therefore, official support cannot be provided by IGEL. Where applicable, test the solution
before deploying it to a productive environment.

Symptom

There are some issues with the performance of the Horizon client.

Environment
+ IGEL OS 10 or higher

Problem

You don't know how to collect the log files and send them to the IGEL Support team.

Solution

1. Inthe Setup, go to System > Registry > sessions > vdmcient% > options > debug and activate
Save debug information (registry parameter: sessions.vdm_client%.options.debug).

2. Go to System > Registry > vmware > USB > log and set Set VMware Horizon USB debug level to
"debug" (registry parameter: vmware.view.usb.log).

3. Goto System > Registry > vmwarevdmapp > debug and activate Save debug
informations (registry parameter: vmwarevdmapp.debug ).

The log files are created in the /tmp directory and can be found using the following patterns:
/tmp/vvdm *
/tmp/vmware-*

4. Changeto /tmp and putthe logfilesinto a compressed tarfile: tar —-czf vmware-

logs.tar.gz [logfiles]

5. In the structure tree of the UMS Console, go to the device and select Device File->UMS the context
menu.

6. Under Devices file location, enter "/tmp/vmware-logs.tar.gz".

Under Target URL, select the location on the UMS Server where the file is to be stored.

8. Click Device->UMS.

~
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VMware Horizon Authentication Issues (Certificate Revocation List)

Newer versions of VMware Horizon Client for Linux attempt to download a Certificate Revocation List (CRL) for any
certificates used to connect to a VMware Horizon environment. Sometimes, this can cause a problem on lower-
powered devices or on devices that do not have access to a CRL address.

The following article explains how to disable the CRL download if you have problems with authentication for
VMware Horizon sessions in IGEL OS.

Problem
You face the following issues:

« The VMware Horizon Client "hangs" during authentication.
OR

« The VMware Horizon Client takes a long time to authenticate (in some cases, over 1 minute).
OR

+ You are using a certificate issued by the domain's CA (certificate authority) and get the following
error message:

"Failed to connect to the connection server. The server provided an
invalid certificate. Unsupported URI 1in CRL distribution points

extension, only http/https are supported. "

Solution

These issues usually occur due to the default setting for CRL download for the VMware Client for Linux. If you
experience the above issues, it is recommended to disable downloading of the CRL.

To disable the download of the CRL, proceed as follows:

1. InIGEL Setup or in the configuration dialog in the UMS, go to System > Registry.

2. Enable the registry key vmware.view.skip-crl-revocation-check,i.e. Skip download
of the certificate revocation list (CRL).
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3. Apply the settings. If you have created a profile, assign the profile to the required devices.

4. Reboot the devices and test the connection again.
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Evidian

+ Authenticating with Evidian Authentication Manager (see page 409)
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Authenticating with Evidian Authentication Manager

You can connect to Citrix, RDP and VMware Horizon roaming sessions using RFID badges with Evidian
Authentication Manager (AuthMgr). Custom commands are supported as well.

Prerequisites

+ IGEL Universal Desktop Linux 5.06.100 or newer on the device.

+ Aninstalled and running Evidian SSO Controller, version 10.0 or higher

+ When using HTTPS (IGEL Linux 5.07.100 or newer), the User Access Server's CA root certificate
saved locally on the device.

« The device and the server(s) have to be part of the same Active Directory domain.

+ Asupported RFID reader (e.g. OMNIKEY 5022 CL, OMNIKEY 5421), connected to the device.

+ RFID badges that are already enrolled.

Configuring an Evidian Authentication Manager Session

1. InIGEL Setup, go to Sessions > Evidian AuthMgr > Evidian AuthMgr Sessions.

Add a new session.

Go to Sessions > Evidian AuthMgr > Evidian AuthMgr Sessions > [Session Name] > Connection.
Choose the Protocol used for the user access service (e.g. HTTP).

Enter the IP address or DNS name used for the user access service under Server.

Choose the Port for the user access service (e.g. 9764).

Under Path to service, enter the path for the user access service (e.g. /soap ).
Under CA certificate, enter the path to the CA certificate, including its name, or path of the
certification authority (e.g. /wfs/ca-certs/ca.crt ). Thecertificate is required for HTTPS

© N oLk WwN

connections.
9. Enterthe secret for the Roaming session secret.

10. When using HTTPS, select CA certificate as the user access server's CA root certificate on the
device.

11. Under Evidian AuthMgr > Evidian AuthMgr Sessions > [Session Name] > Options, select the
desired Session type.
This will make Evidian Authentication Manager use the first configured session of its type, e.g. RDP.
Make sure that a session is configured.

() Ifyou choose the user-defined session type, you need to supply the custom commands; see
Custom Commands (see page 411). For further options, see Options in the IGEL OS Reference Manual.

12. Start the new session by clicking on its icon in the Start Menu. Alternatively, reboot the device. In
the default autostart setting the Evidian Authentication Manager for your session will start
automatically and wait for an RFID badge to be placed on the reader.

@ Youcan only start a single instance of an Evidian Authentication Manager session.
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Configuring Citrix/RDP/VMware Horizon Sessions

> Configure the session that you want to use with Evidian Authentication Manager as the first session of its kind.
The shortcuts to the session settings are provided in the Setup section Related Configurations:

SesnT e Select.. | Related Configurations

Configuration
» I Horizon Client
‘ Appliance Mode
O
» M Evidian AuthMgr Global
= Language selection Automatic
v

Custom catalog of messages

N Availability Message

Using a Custom Configuration File

Instead of using the settings provided by IGEL Setup, you can enable a custom configuration file under Sessions >
Evidian AuthMgr > Evidian AuthMgr Sessions > [Session Name] > Options > Use configuration file. Then all the
other session settings will be ignored. You find a commented template for the configuration fileat /etc/

rsUserAuth/rsUserAuth.ini.

Logging in with Evidian Authentication Manager

1. Place your RFID badge on the RFID reader (or tap the reader with it if you configured Tapping
Mode)

2. Your Citrix/RDP/VMware Horizon session will open if an active roaming session for your user
already exists. If it does not, you will be presented with a password prompt for the user's Active
Directory password.

3. Remove your RFID badge (or tap the reader again) to disconnect from the session.

IGEL OS Articles 410/1109



Evidian

Custom Commands

The following simple shell scripts illustrate how to write custom commands that receive username and domain as
parameters from Evidian Authentication Manager.

In order to use them

1. Savethescriptsin /wfs/.
2. Make them executable with chmod a+x [filename].

3. Enter their full path (e.g. /wfs/start.sh)in Sessions > Evidian > [Session name] > Options.

Start Script
#!/bin/sh
# Sample start script
if [ $# -eq 3 ] ; then
# Start "session"
gtkmessage -t "Evidian Authentifcation Manager Login" -m "Login as user '$1'
with domain '$3'."
else
exit 1
fi

exit 0O

Stop Script

#!/bin/sh

# Sample stop script

# Close running "session"

pkill gtkmessage

gtkmessage -t "Evidian Authentication Manager Logout" -s 5 -S -m "Logout user
1§10,

exit 0
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Debugging and Troubleshooting

Debugging

1. Enable Debug mode in Sessions > Evidian > [Session Name] > Options in Setup and set the level
of detail.

2. Kill the Evidian Authentication Manager process (see Further Troubleshooting).

3. Start the desired Evidian session from the Start Menu.

4. Watch the outputwith tail -F /var/log/user/rsuserauth[Session

Number] .debug in Local Terminal. Alternatively, add the file to System Log Viewer.

() The session number starts with 0, not 1. To watch the output of the first configured session, use
thus tail -F /var/log/user/rsuserauth0.debug

Further Troubleshooting
1. Open Local Terminal
2. Enter ps fax | grep rsuserauth | grep -v grep tolook for Evidian Authentication

Manager processes.
3. Use the Evidian AuthMgr Restart session to restart all Evidian sessions if neccesary

OR kill unwanted processes by entering kill [process ID] intheterminal, start desired
processes via the Evidian entries in the Start Menu.
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IBM iAccess

+ Editing the List of Visible Menu Entries for IBM iAccess (see page 414)
+ Key Mapping for IBM iAccess Client (see page 416)
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Editing the List of Visible Menu Entries for IBM iAccess

You can simplify the menu of an IBM iAccess client session by removing items from the menu tree. You also can
restore the original menu.

Removing Menu Items

1. Inthe IGEL Setup, go to System > Registry > sessions > iaccessINUMBER] > options >
deletemenus (Registry key: sessions.iaccess[NUMBER].options.deletemenus).

[NUMBER] is the instance number of the session you want to configure; 0, for instance, stands for

the first session, 1 for the the second session, etc.
2. Inthe List of visible menu entries, using the mouse, mark the line with the entry you want to

delete:
List of visible menu entries

Y Edit|Preferences|TabSetup i
Edit|Preferences|Watermark

€) | Edit|Preferences|TranslationTable
Wiew

E1N

3. Pressthe backspace [ —] or delete [Del] key.
The menu item is deleted:

List of visible menu entries

Edit|Preferences|TabSetup &

#) | Edit|Preferences|TranslationTable
Wigw

E1S

( Ifyou delete a menu item that has subitems, the subitems will be invisible, too.

4. To remove further menu items, repeat steps 2 and 3.

5. Click Apply or Ok.
6. Start or restart the IBM iAccess client to check your changes.

Restoring the Original Menu
1. Inthe IGEL Setup, go to System > Registry > sessions > iaccessINUMBER] > options >
deletemenus (Registry key: sessions.iaccess[NUMBER].options.deletemenus).[N

UMBER] is the instance number of the session whose menu you want to restore; 0, for instance,
stands for the first session, 1 for the the second session, etc.
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2. Inthe List of visible menu entries, click the following symbol:

List of visible menu entries

@

[=A=10 La

T [T T s v T

Edit|Preferences|TabSetup

Edit|Preferences|TranslationTable

L.ljﬂ.

The original menu is restored.

3. Click Apply or Ok.
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Key Mapping for IBM iAccess Client

Problem

When you change the key mapping in the IBM iAccess client, the changes are not retained when the client is
restarted.

Applying the changes via IGEL Setup is not possible.

Environment/Prerequisites

+ IGEL 0S 10.05.100 or higher
+ UMS5.09.110 or higher
« IBMiAccess Client session is set up

Solution

Save the settings made in the IBM iAccess client in a file and distribute that file via the UMS.

Editing the Key Mappings

1. Open the IBM iAccess session and log on to your remote environment.
In the IBM iAccess client, go to Edit > Preferences > Keyboard.

On the Key Assignment tab, create the desired key bindings.

When you are finished creating key bindings, click Save as....

In the save dialog, choose File and edit the file path as follows: /userhome/IBM/

iAccessClient/Emulator/IBMi.kmp
6. Click OK.
The IBM iAccess client will recognize the file IBM1 . kmp as the default key.

o kN

Importing the Configuration File to the UMS
1. Openthe UMS.
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2. Inthe navigation tree, find the thin client with the IBMi.kmp file and select Other Thin Client
commands > File TC->UMS in the context menu.
¥ 5 My Linux Thin Clients (3)

[ TCO00BCADSS
[ TCOnENCS114
L
¥ ' My Windows Thin
H |GEL-PEQ4BDS
[ TCO0ENCS139
o Mew devices (0)
12} ITCONEOCS36256
B mobile Devices (0)
S0 Shared Workplace s
B views (10
O Jobs (4
E Files 1)
" Universal Firmware U
® Search History (1)

T Recycle Bin (106

IGEL OS Articles

Mermary Size (MB)
Metwork Speed
Duplex Mode

=Y Edit Configuration

& Rename

] Delete

@ Clear '"Configuration Change Status' flag
ES Access control

2% cut
[&) Copy
[ Paste

Shadow

Secure Terminal
Suspend
Shutdown

Wake up
Rehoot

Lpdate & snapshot commands [
Other Thin Client commands

Send Message
Resetta Factary Defaults

Settings UMS-=TC
Settings TC-=UIMS
Lipdate deskiop customization

File LInS-=T0

File TC-=LIMS

Delete file from TG

Diowenload Flashplaver
Remaove Flashplayer

Store UMS Cedificate
Eemowve UMS Cerificate

Refresh license infarmation
Refresh system infarmation
Refresh Aszet Inventary data

sults

Take over settings from ...
Export Thin Client Settings

= Windows Updates and Hotfixes
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3. Under Thin Client file location, enter /userhome/IBM/iAccessClient/Emulator/

IBMi . kmp
File TC->UMS x
File TC-=mMS

TCOOEQCS362YEE

File information
& .Y

Thin Client file location § | fuserhomelBmMfiAccessClientEmulatorBMIi kmp |

Target LIRL -

File TC-=LIMS

LI TR B B L e B e B AR
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4. Click - to open the Save dialog. o

File TC->UMS x

File TC-=UmMS

[TCOOEQCA362TEE

File information
r Y

Thin Clientfile location | fuserhomelBwMfiAccessClientEmulatorBMI kmp |

Target URL -

File TC-=LIMS

LIS B B L e e B T
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5. Choose afile location within the ums_filetransfer folder.

File TC-=UMS
File TC-=LIMS

1 ITCODEDCA3627EE

File infor
—

Thin G

Look [n: lﬁ‘ wehday

v

Save x

- ]- ] Jojrs

ﬁ‘ ums_filetransfer

File Marme: |

Files of Type: | Al Files

Target URL

File TC-=LIMS
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6. Under File Name, enter IBM1i.kmp and click Save.

File TC->UMS
File TC-=UMS
[TCOOEQCAS362ZTEE
|
Look [n: lﬁ‘ ums_filetransfer "] m i
ﬁ‘ supportinfo lgelstart.jpg
6346891785 _17d4b31a9d_o.jpg kKyocera_FS-600_de.ppd
eDocs-Logo.png Maisons_Basques.jpg
elch.jpg stopweatch jpo
hedgehag-child_1920.jpa te_files_for_support 00EOCS13924
- L -
File Mame: |IElru1i.kmp |
Files of Type: | All Files v
File infor
F— [r—
Thin
Target URL -
File TC-=LIWMS
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7. Click TC->UMS. e

File TC->UMS x

File TC-=LIMS

[TCOOEOCA362VEE

File information
i i |

Thin Clientfile location | fuserhomelBwMfiAccessClientEmulatorBMI kmp |

Target LURL hitpsi1 72 .30 92 9:844 3fums_filetransferBMi kmp -

File TC-=LIMS

The file is stored within the UMS. Next, we will make it available as an object.
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Creating the File Object in the UMS

1. Inthe navigation tree, go to Files, open the context menu and choose New file.
5 Jobs ()
E

" Universal Firmware

Eename
Delete
Aecess contral

. Bearch History (13
T Recycle Bin (1063

- ot

[ Paste

Logoing: Messages

Connected to 1723092
[ Mew Directory
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A

r

2. Inthe New file dialq_g_l_, _;__hqg_sg__Sl_gl_e_q_f_ilgf[gln_\_9M§_§g[¥gr and click - to open the file gi_iglog.

File source
() Upload local file to UMS server
Lacal file -
Upload location (URL) |https:ﬁ{senfer:pnrtriums_ﬂletransfer |-

[ (® Selectfile from UMS ser\rer]
File location (URL) - |

File target

Classification [Undeﬂned "’]

Thin Client il location | |

Access rights

Read ‘Write Execute
owner [ [ &Y
others [ [ O

Cwiner .User b
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3. Inthefile dialog, find the file IBMi.kmp you created previously, and click Open.

New file

File source

Laocal

Chienigr

Others

O Lipload local file to UMS server

Liploa =
Laak |n: lﬁ ums_filetransfer '] [t i

® Selectf
File o IBMi_kmp tc_files_for_support
d_ojpg lgelstarnt.jpg tc_files_for_support
File target Kyocera_FS-600_de.ppd
mMaisons_Basgues.jpy
Clagsificat stopwatch,jpg
Thin Client - S
Accessrighi File Mame: B kmp |

R Files of Type: [ Al Files

[
[

Cwiner | Llser ¥
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4. Back in the New file dialog, enter the Thin Client file location as follows: /userhome/IBM/

iAccessClient/Emulator/

File source
O Lipload local file to UMS server

Lacal file -

Lipload location (URL) |https:Iksewer:pnrt:Iums_ﬂletransfer |-

(®) Selectfile from UMS server

File location (URL) ‘https:m 723092 8:8443ums_filetransferEmMi.kmp |-
File target
Classification [Undeﬂned ']

Thin Client file location |IuserhcumeJ‘IElMIiAccessCIienﬁEmulatnrﬂ |

Access rights

Read Wyrite Execute
owner ] [V &Y
others [ [ ]

Owner | User ¥

5. Ensure that the Access rights and Owner are set as follows:
« Owner rights: Read, Write, Execute
+ Owner: "User"
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File source
() Upload local file to UMS server

Lacal file -

Lipload location {(URL) |https:Iksewer:panIums_ﬂletransfer |-

® Selectfile from UMS server

File location (LURL) ‘https:m 723092 8:8443fums_filetransferBMi kmp |-
File target
Classification [Undeﬂned ']

Thin Client file location |IuserhcumeIIElMIiAccessClienﬁEmulatnrﬂ |

Access rights

(- Read “Wyrite E}:ecut;\
owner o ¥ &Y
others [ [ ]

Cwner .User v

J
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6. Click Ok.

File source
() Upload local file to UMS server

Lacal file -

Lipload location {(URL) |https:Iksewer:panIums_ﬂletransfer |-

® Selectfile from UMS server

File location (LURL) ‘https:m 723092 8:8443fums_filetransferBMi kmp |-
File target
Classification [Undeﬂned ']

Thin Client file location |IuserhcumeIIElMIiAccessClienﬁEmulatnrﬂ |

Access rights

Read Write Execute
owner o ¥ &Y
others [ [ ]

Owner | User ¥

The file object "IBMi.kmp" is created.
Assigning the File Object to Thin Clients

1. Inthe navigation tree, select the file object "IBMi.kmp" and click [ linthe Assigned objects area
(upper right).

IGEL OS Articles 428 /1109



IBM iAccess

IGEL

2. Inthe Select assignable objects dialog, select the thin clients to which you want to assign the new
key mapping and add them to the Selected objects area.

Select assignable objects x

Selected ahjects

= [ Master Profiles (2) [ ITCoOEDCET143A5
» [T Profiles (20) [ ITCONEDCA3R2TEE
¥ [ Thin Clients (&)
[ Import (o)
¥ E@ Wy Linux Thin Clients (3

L ITCO0EDCS] |

| N\
A E@ Wy Windowes Thin Clients (29 '

@ IGEL-PEQ4BDEYLY
@ ITCOOEQCS1 39243
[ New devices (0)
(‘.{z [TCOOEDCA362560
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3. Click Ok.
Select assignable objects x

+ [ Master Profiles (2
T Profiles (29)
¥ LI Thin Clients (5)
[ Import (o)
¥ F'E Wy Linux Thin Clients (3
[ TcoooeCADsant &
L ITCO0E 14345
L TCO0EDC
A F'E Wy Windowes Thin Clients (29
IGEL-PEQ4BDSYLY
[ 1TConEDCS1 39243
[ New devices (0)
‘ﬂ [TCODEDCS3E2460

Selected ahjects

[ ITCOOEDCET1 4348
[ ITCOOEDCA2GZ7EE

Cancel

4. Inthe Update time dialog, choose whether the file should be assigned to the thin clients at next

reboot orimmediately; then, click Ok.

When should these changes take effect?
() Mext Reboot

@ Mo

Update time bod

E] Alweays apply settings on next reboot (and don't show this dialog againg

Thefile is transferred to the thin clients.
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Imprivata

+ Imprivata: Clear the Imprivata Data Partition (see page 432)
« Imprivata: Session Customization (see page 433)

IGEL OS Articles 431/1109



Imprivata

Imprivata: Clear the Imprivata Data Partition

The function that explicitly clears the Imprivata data partition has been removed. However, you can simply emulate
this feature by disabling and re-enabling the Imprivata appliance mode.

If you already have a valid appliance running and want to delete the Imprivata data partition, take the following

steps:

1.
2.

o

In the IGEL Setup, go to Sessions > Appliance Mode.
Set Appliance mode to "Disabled".

Appliance mode || Disabled |-) l

Configuration

Sessions

n Sessions Summary

B Global Session Options
» Il Citrix
» I RDP
» [ Horizon Client

. Appliance Mode
» Il Caradigm

Click Ok to save the setting.
Click Yes to confirm the Apply Settings dialog.

Apply Settings b4
Do you want to let the settings take effect now?
This might terminate ongoing sessions.

Mo

Normal desktop mode is active. The Imprivata data partition is void now.
In the IGEL Setup, go to Sessions > Appliance Mode.

Set Appliance Mode to "Imprivata".

In the Set the URL to the Server field, enter the new server address.

Appliance mode ] [Impriuata ']

Set the URL to the Server |https:fr‘y0ur server |

Click Ok and confirm the Apply Settings dialog.
Now you have a fresh Imprivata appliance mode without any outdated data.
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Imprivata: Session Customization

You can make the same settings in the IMPRIVATA_RDP (IGEL Setup > RDP > RDP Sessions > Imprivata_RDP) and
IMPRIVATA_VMware (IGEL Setup > Horizon Client > Horizon Client Sessions > IMPRIVATA_VMware) sessions as
in the standard sessions (see the description for RDP Session and Horizon Client Session).

(» [IMPRIVATA_RDP and IMPRIVATA_VMware will be shown in the IGEL Setup when Imprivata is selected
under Setup > Sessions > Appliance Mode, see Imprivata.

However, the changes under the following subsections will be ignored:

Imprivata_VMware Session

+ Connection Settings

() Youcan also ignore the VMware protocol selected by the Imprivata appliance by activating the registry key
imprivata.ignore_horizon_protocol under System > Registry. Instead, the local selection under
Horizon Client > Horizon Client Global > Server Options > Preferred desktop protocol will be used.

Imprivata_RDP Session

« Server
e Logon
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Microsoft Azure Virtual Desktop (AVD)

This IGEL release is a build of IGEL OS which includes the AVD client as a configurable method for connecting to
Azure Virtual Desktops.

+ Feature Matrix: AVD (RDP3) for IGEL OS 11 (see page 435)

+ How to Connect IGEL OS to Azure Virtual Desktop (see page 439)

+ Importance of Keeping IGEL OS Firmware Up-to-Date for Microsoft AVD and Windows 365
CloudPC (see page 443)

+ Microsoft Teams Feature Comparison for IGEL OS (see page 457)

+ Authentication Issue with Microsoft Azure Virtual Desktop on IGEL OS (see page 460)
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Feature Matrix: AVD (RDP3) for IGEL OS 11

The following matrix shows a selection of features and their state of implementation.

Feature Linux RD IGEL OS Notes
Core RDP3
SDK by Client
Microsof
t
AzureAD not yes
authentication applicabl
e
Azure Resource yes yes
Manager v2
Feed support
Folder yes yes Folder redirection is bound to the /media folder, so that
redirection locally mounted storage devices, including USB sticks, will
be forwarded to the remote session.
Dynamic folder no no User may select specific drives/folders to redirect at run
redirection time.
Smartcard no no Smartcard redirection is implemented but not working.
redirection The problem exists in the RD Core SDK.
Clipboard yes yes
redirection (text
and images)
Clipboard no no
redirection
(files)
Microphone yes yes
redirection
Speaker yes yes
redirection
Webcam not yes Fabulatech webcam redirection is implemented.
redirection applicabl
e
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Feature Linux RD IGEL OS Notes
Core RDP3
SDK by Client
Microsof
t
Printer yes yes ezeep cloud printing is implemented. It is directly related
redirection to the ThinPrint configuration.
CUPS printer redirection is implemented.
USB redirection not yes Fabulatech USB redirection is implemented.
applicabl
e
Scanner not yes Fabulatech scanner redirection is implemented.
redirection applicabl
e
Mouse input yes yes
Keyboard input yes yes
(scancodes)
Keyboard input yes yes
(Unicode)
Keyboard input not yes

mapping of applicabl
dead/special e

keys
Teams yes yes The “Annotations” feature is currently not available.
conferencing
redirection
Zoom conferenc not yes Zoom redirection cannot be activated globally, but only
ing redirection applicabl for a specific session.
e
Multitouch no no No multitouch API present in the Linux RD Core SDK by
redirection Microsoft.
AVC Codec yes work in
support progress
(hardware

acceleration)
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Feature Linux RD IGEL OS Notes
Core RDP3
SDK by Client
Microsof
t
Dynamic display yes yes
change
Monitor DPI yes yes
sync
Monitor Layout yes yes

Sync (multimon)

Restrict full- not yes
screen sessions applicabl
to single display e

On-premises not work in
services applicabl progress
e
RemoteApps  yes limited Current userinterface for RemoteApps control is to be

further improved.

Seamless apps workin no

progress
Sessionauto  yes yes
reconnect
Proxy support yes yes
Local hostname yes yes
in a session
Launch asingle not yes A resource is launched if only one resource is returned.
resource applicabl
session/ e
application
Dynamic virtual yes work in
channel support progress

UDP network  workin no
support progress
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Feature

User-definable
hotkeys

Realtime user
experience
indicator

Configurable
AVD Resource
Feed

IGEL OS Articles

Linux RD IGEL OS

Core RDP3
SDK by Client
Microsof

t

not yes
applicabl

e

workin no
progress

yes yes

Notes

Session chooser, session switcher, minimize to taskbar
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How to Connect IGEL OS to Azure Virtual Desktop

Quick Start Guide

This section describes how to set up an Azure Virtual Desktop (AVD) session (formerly Windows Virtual Desktop,
WVD) with IGEL’s AVD client based on Microsoft’s RD Core SDK for Linux which can be used to connect to an AVD
deployment.

Requirements

« Device with IGEL OS 11.03.261 or higher; download the latest version at igel.com/avd*
+ Azure Virtual Desktop deployment

Instructions

1. Open the Setup or the configuration dialog in the UMS and go to Sessions > AVD > AVD Sessions.

2. Click the L*J symbol to create a new AVD session instance.
IGEL Setup 11.06.100.rc9.01 (Build 6.8.7)

ons * AVD * AVD

AVD Se

Session name

» [ Horizon
B ~p
» I AppliD

4 ¥ ¥y ¥y ¥y vy vy Yy yy

£ AVD Sessions

» I Amazon

34 https://www.igel.com/igel-solution-family/windows-virtual-desktop/
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n name
Starting Methods for Session

v Start Menu

n Launcher

B 2pplian e
» I Appli Menu folder
» M Evidian Authh .
Application Launcher folder

op folder

ord Protection

Hotkey

Autostart

mmunications

Search

4. If the login is to be started automatically on session startup, go to Sessions > AVD > AVD Sessions
> [Session name] > Logon and enter your credentials under Username@domain
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A

or @domain and Password. For details, see Logon.

< > ] / on * Logon

ok

€} AVD-Pool2

Y YYTYYVYYY

v

5. If a specific resource is to be started automatically, enter its name under Workspace resource to
automatically start when connected.
< >

Configuration

*k

¥} AVD-Pool2
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6. Go to Sessions > AVD > AVD Sessions > [Session name] > Options and enable or disable features
and redirections according to your needs.

V' audio autput redirection
Vv AAC Codec

V' Audio input redirection

7. If you do not want to run the AVD client on all available screens in fullscreen, go to Sessions > AVD
> AVD Sessions > [Session name] > Display and change the settings according to your needs.

Wwindow size full-screen
Start monitor Mo configuration
Multimonitor full-scree Multiple monitors

Scale Factor Automatic Scale

8. Go to Sessions > AVD > AVD Sessions > [Session name] > Plugins and enable features according
to your needs.

¥ Fabulatech Webcam/ScannerflUSE Redirection

Zoom VDI Media Plugin

9. Click Apply or OK.
The AVD session is configured and can be started with the starting methods you have configured in
step 3.

If you want to configure further AVD sessions, start again from step 2.

See also the reference manual chapter AVD Session.

IGEL OS Articles 442 /1109



Microsoft Azure Virtual Desktop (AVD)

e

IGE

Importance of Keeping IGEL OS Firmware Up-to-Date for Microsoft AVD
and Windows 365 CloudPC

If you are running the Microsoft Azure Virtual Desktop (AVD) client on an IGEL OS-powered endpoint (PC, laptop, or
client), itis important to ensure that the client version is up-to-date.

Why Is It Important to Keep Your Igel OS Firmware Updated?

If the client version is not up-to-date, changes on the Microsoft AVD's server-side could lead to functionality issues.
The latest IGEL OS firmware version is, in most cases, the current official build. To find the latest version,

see https://www.igel.com/software-downloads/workspace-edition/ > click OS 11 to expand the relevant
section.

However, an IGEL OS private build may be released to adapt for server-side changes that have been introduced
between IGEL OS releases. This way, we maintain existing functionality and support new features/functionality.
Therefore, please refer to www.igel.com/avd® for the latest Microsoft AVD / Windows 365 CloudPC specific IGEL OS
releases.

IGEL Environment

+ Endpoints with IGEL OS 11
+ IGEL AVD client is used for Azure Virtual Desktop (AVD) and Windows 365 CloudPC by Microsoft
+ Universal Management Suite (UMS) 6.08 or higher

How to Check for the Latest IGEL OS Firmware Version

1. Open the web browser and go to www.igel.com/avd*®.

35 http://www.igel.com/avd
36 http://www.igel.com/avd
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2. Fillin the form to register for AVD client access and submit it.

ke

e |
IGEL Technology Germany

(DE) Bayern -

Virtual Desktop Management tools currently being used. Please check all that apply.
¥ Citrix ¥ VMware & Microsoft

¥ Subscribe to IGEL communications

After a few minutes, you will receive a confirmation mail from IGEL.

3. Inthe confirmation mail, click Update for current IGEL OS 11 installations.
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Click here to view this message in a8 browser window.

\\LU%
Z:1GEL

Thank you for your registration!

Please see below the first version of the RD Core integration within the IGEL O5.

For further information, please see the current Feature Matrix and the Quick Start Guide.

Demo License can be fetched via the IGEL Setup Assistant (Eead more).

IGEL 05 11 Readme Notes

Click the links below to download and install the software:

Initial IGEL 05 11 deployment

Update for current IGEL 05 11 installations

IGEL Universal Management Suite

Copyright & 2021 IGEL Technology GmbH
Our address is Hermann-Ritter-Sir. 110, 28187 Bremen, Germany

If you do not wish to receive future email, click here.
("ou can also send your reqguest to Customer Care at the street address above.)

The IGEL OS firmware with the latest AVD client is downloaded (official or private build).

4, Note the version number that can be derived from the file name.
Example: When the file nameis 1xo0s_11.06.100_public.zip,theversionis 11.06.100.

How to Check If the IGEL OS Version Is Out-of-Date

We will create a view to find out which endpoint devices are running a firmware version lower than the one with the
latest AVD client.
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1. Open the UMS console and in the structure tree, go to Views.

5 absolute

2. Select New View.

¥ B views (4)

Paste

Logging: Me

Logging: Event Me

UMS Admi [ Mew Directory

¥ Newview
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3. Enter an appropriate Name and click Next.

Create new view

View name

MName

Description
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4. Inthe search field, enter "firm", select Firmware version, and click Next.
Create new view

Select criterion
firm

¥ Asset Inventory

Firmware Description Firmware Update (Relative) (®) Firmware Version

5. Select below, enter the version number of the firmware you have downloaded beforehand, and
click Next.
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Create new view

Version search

Wersion number exact above * below Mot like

11.06.100

6. Click Finish.
The matching endpoint devices are shown.

AVD client outdated

Firmware version is less than 11.6.100

Result list was last updated at 11:41 AM. Refresh

How to Update IGEL OS Endpoint Devices to the Latest Firmware Version

In the following instructions, we will use the Universal Firmware Update feature of the UMS. For alternative
methods, see Firmware Update (see page 237), Buddy Update (see page 230), Updating IGEL OS Using a USB Storage
Device (see page 241), and Updating the Firmware using the Linux Console (see page 243).

1. Make sure that the firmware file (in our example: 1xos_11.06.100_public.zip)canbe
accessed from the machine that hosts the UMS Console (via local file or network drive).
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IGEL

2. Inthe structure tree of the UMS Console, go to Universal Firmware Update and select Firmware
archive (zip file) -> Universal Firmware Update.

B Universal Firmware Upds:

_ ; Check for new firmware updates
® Search History (0)

Snapshot -= Universal Firmware Update
Firmware archive (zip file) - iversal Firmware Update

le Bin (0]

T

uUMS Administrati Access control

3. Make sure that Firmware archive (zip file) -> Universal Firmware Update is selected and click
Next.

Import or Register Firmware
Import Firmwares
ct this if you want to import firmwares which have been exported by another UMS

Snapshot -= Universal Firmware Update

Select this if you want to register a universal firmware update (downloaded/created snapshot)

Firmware archive (zip file) -= Universal Firmware Update

Select this if you want to register a universal firmware update (downloaded zip from igel.com)

IGEL OS Articles 450/1109



Microsoft Azure Virtual Desktop (AVD)

4. Click the file chooser icon, find the firmware file and click Open.

Open

Look In: Downloads

File Name: 5 11.06.100_public.zip

Files of Type:

5. Click Select directory,,, to define the target directory at the UMS Server.

Firmware archive (zip file) -> Universal Firmware Update
Firmware file

Firmware file  /home/ike/Downlo; wos 11.06.100_public.zip

Firmware attributes

Display name  Ixos 11.06.100 public

WebDAV target directory

WebDAV target directory
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6. Select the directory, typically ums_filetransfer ,and click Open.

Look In: webdav

Folder Name: fums_filetransfer/

Files of Type:  All Files

7. Click Ok to confirm the creation of the Universal Firmware Update.
Firmware archive (zip file) -> Universal Firmware Update
Firmware file

Firmware file  /homefike/Downloads; ' 11.06.100_public.zip

Firmware attributes

Display name  |xos_11.06.100_public

WebDAV target directory

WebDAV target directory  htips: 0.1.1:8443/ums_filetran

If everything went well, the new Universal Firmware Update is displayed.
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11.06.100_puhlic
Product  IGEL 05 11

Yersion

Firmware Update Settings

Hos
Frotocal HTTFS (LI

Fort

Target LRL

Shapshotfile

Download Status

Status Ik Finished

Errar

8. Go to the view you have created beforehand, open the context menu, and select Assign objects to
the devices of the view....
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B views (5)

}ﬁ AV client gutdatad {43 hamea

L) — I

AEREINE

O
ES

control

al Firmwa
IGELOS511-11
Search History ((

UMS Admin License manually...
Save as
Send view result as mail...
Save device files for support
Logging: Event Me:
Logging: M
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9. Select the Universal Firmware Update and click Ok.

Assign objects

IGEL 0S5 11-11.06.100

ustomizations (0)

al Firrmwara | I_r\."h:\f.-_jg (1)

IGEL 05 11-11.06.100

10. Select the update time and click Ok.

Update time

When should these changes take effect?
Mext Reboot

Always apply settings on next reboot (and don't show this dialog again)
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11. Confirm the message window.

Information x

L
1 Azsignment has been performed.

On the next reboot, the endpoint devices will update their firmware.

Whether you are implementing classic VDI, virtual apps, Daa$, or in this case AVD, it is always a good practice to
make sure you are running the very latest version of IGEL OS to take advantage of the latest features.
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Microsoft Teams Feature Comparison for IGEL OS

(» Rolling Release Info: 0S 11.07.110

The information provided here is valid with IGEL OS 11.07.110 and higher.

() Theinformation presented here reflects the state on May 12, 2022.
The information was mostly obtained from https://support.microsoft.com/en-us/office/teams-features-
by-platform-debe7ff4-7db4-4138-b7d0-fcc276f392d3

Feature IGELOS IGEL OS
AVD / Citrix
Windows
365
Audio Calls
One-to-One yes yes
Call
Group Call (3+yes yes
users)
Video Calls
One-to-One yes yes
Call
Group Call (3+yes yes*
users)
Gallery View yes yes
Large Gallery yes yes
View
Together yes yes
Mode

IGEL OS Articles

IGEL

OS™" (see

page 459)

yes

yes

yes

yes

yes

yes

yes

Windows Windows Comments
10AVD/ 10 Native

Windows

365

yes yes

yes yes

yes yes

yes* yes * Random minor issues
with the video feeds of
users connected to
media-optimized Teams
sessions. Resizing the
Teams application
window and/or turning
webcams on/off often
solves the problems.

yes yes

yes not

applicable
yes yes
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Feature IGELOS IGELOS IGEL
AVD / Citrix OS™" (see
Windows page 459)
365

Desktop yes* yes* no*

Sharing

Presentation yes yes no

Point Sharing
(PowerPoint)

Application  yes* yes yes
Sharing (Non-
PowerPoint)

User Remote yes yes no
Control

Chat no no no
Functions

Whiteboard no no no
Display

Whiteboard yes yes no
Sharing

Document  yes yes no
Whiteboard
Sharing

Background yes yes no
Blur

Background no no no
Virtual

IGEL OS Articles

Windows Windows Comments

10AVD/ 10 Native

Windows
365

yes

yes

yes

yes

no

no

yes

yes

yes

no

yes

yes

yes

no

yes

yes

no

yes

yes

yes

* Presenter's webcam
feed not available while
sharing desktop;
presenter must also
restart webcam after
stopping desktop share.

* OneDrive and
SharePoint are the
available applications.

Full Teams client does not
offer a white whiteboard
sharing

Full Teams client offers to
share a scanned
document or document
camera
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Feature IGELOS IGELOS |IGEL Windows Windows Comments

AVD / Citrix OS“*(sece 10AVD/ 10 Native

Windows page459)  Windows

365 365
Device Button no no no no yes Pressing the mute button
Support on the headset is

reflected in the Teams
mute (button)
functionality

**Requires an unsupported Custom Partition which needs to be created and included by yourself. For instructions
on how to create a Custom Partition, see the Custom Partition Tutorial (see page 758).
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Authentication Issue with Microsoft Azure Virtual Desktop on IGEL OS

The IGEL Azure Virtual Desktop client recently underwent critical client-side changes related to the Microsoft's RD
Client for Linux SDK to leverage a newly optimized Azure backend for the Azure Virtual Desktop service.

Microsoft updated the RD Client SDK on Nov 29, 2022 which is when they committed their Kestrel code. (commit
89f7e52).

& To avoid being impacted by this upcoming change, please upgrade to IGEL OS 11.08.330 or
newer before August 15 to avoid any impact from the Azure environment changes going into production.

If you want to update your IGEL OS, see Firmware Update Settings for IGEL OS.

Overview

IGEL OS Version Release Date Kestrel
11.08.230 13. December 2022 No
11.08.290 30. March 2023 Yes

IGEL OS 11.08.330 has other enhancements that make it the better choice for those upgrading.

& Microsoft and IGEL recommend that the AVD client be kept as current as possible and that customers
upgrade to make sure that compatibilities with new features and guarantee continued support.

For usage of Private Builds:

The first version of IGEL AVD client that we would consider safe would be 1.1.12.

@ Checkthe corresponding release notes or open a terminal and enter: /services/avd/bin/
igelrdp3 -v foradirect check.
The Version of the IGEL AVD client is also included in the release notes for private builds. They can be

foundin readme.<version>.txt underthe Component Versions section. See IGEL OS Release
Notes

What Happens If You Don't Update To the Latest IGEL OS Version?

Users who continue using older versions of the IGEL Azure Virtual Desktop client may experience frequent session
disconnections once Microsoft rolls out the backend changes into production.
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r

() Ifyouwantto learn more about the technical details regarding the change, please see A Heavy Lift:
Bringing Kestrel + YARP to Azure App Services (microsoft.com)®”.”
If you have any problems regarding the Update, please contact the support via the IGEL Customer Portal®,

37 https://devblogs.microsoft.com/dotnet/bringing-kestrel-and-yarp-to-azure-app-services/
38 https://cosmos.igel.com/csm
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SSH

+ Enable Weaker Algorithms in the Built-in OpenSSH Server (see page 463)
+ Enable Weaker Algorithms in the SSH Client (see page 464)
+ SSH: Deprecation of Weak Algorithms as of IGEL Linux 10.04.100 (see page 465)
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Enable Weaker Algorithms in the Built-in OpenSSH Server

Problem

You are trying to connect to the built-in OpenSSH server of IGEL OS with an SSH client which does not support the
strong algorithms of the server.

Solution
To enable weaker encryption algorithms, proceed as follows:

1. In Setup, go to System > Registry > network > ssh_server.
2. Change the settings according to your requirements:
+ disable_weak_encryption: Disable this option to enable weaker encryption.
+ disable_weak_hostkey_algos: Disable this option to enable weaker host key algorithms.
+ disable_weak_kexalgorithms: Disable this option to enable weaker key exchange
algorithms.
+ disable_weak_macs: Disable this option to enable weaker MACs.
« minimal_encryption_level: The minimal level of encryption
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Enable Weaker Algorithms in the SSH Client

Environment
IGEL Linux 10.04.100 or higher

Problem

You are trying to connect to an SSH server which does not support the strong algorithms enabled by default in the
SSH client.

Solution
To enable weaker encryption algorithms, proceed as follows:

1. In Setup, go to System > Registry > network > ssh_client.
2. Change the settings according to your requirements:
« disable_weak_encryption: Disable this option to enable weaker encryption.
+ disable_weak_hostkey_algos: Disable this option to enable weaker host key algorithms.
+ disable_weak_kexalgorithms: Disable this option to enable weaker key exchange
algorithms.
+ disable_weak_macs: Disable this option to enable weaker MACs.
« minimal_encryption_level: The minimal level of encryption
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SSH: Deprecation of Weak Algorithms as of IGEL Linux 10.04.100

As of IGEL Linux 10.04.100, certain older, less secure algorithms are deprecated in both the SSH client and server.

The following table shows the algorithms enabled by default as of IGEL Linux version 10.04.100.

Key exchange algorithms

Message authentication codes
(MACs)

Host keys

curve25519-sha256@libssh.org
ecdh-sha2-nistp521
ecdh-sha2-nistp384
ecdh-sha2-nistp256
diffie-hellman-group-exchange-sha256

hmac-sha2-512-etm@openssh.com
hmac-sha2-256-etm@openssh.com
umac-128-etm@openssh.com
hmac-sha2-512

hmac-sha2-256
umac-128@openssh.com

ssh-ed25519-cert-v01@openssh.com
ssh-rsa-cert-vOl@openssh.com

ssh-ed25519

ssh-rsa
ecdsa-sha2-nistp521-cert-v0l@openssh.com
ecdsa-sha2-nistp384-cert-vOl@openssh.com
ecdsa-sha2-nistp256-cert-v0l@openssh.com
ecdsa-sha2-nistp521

ecdsa-sha2-nistp384

ecdsa-sha2-nistp256

If you need to enable weaker algorithms, see Enable Weaker Algorithms in the SSH client (see page 464) and/or Enable

Weaker Algorithms in the Built-in OpenSSH Server (see page 463).

IGEL OS Articles

465/1109



Using Amazon WorkSpaces via the HP Anyware PColP Client

IGEL

Using Amazon WorkSpaces via the HP Anyware PColP Client

You can configure an Amazon WorkSpaces session under Sessions > Amazon > WorkSpaces > Amazon
WorkSpaces Session, see Amazon WorkSpaces.

Alternatively, you can use Amazon WorkSpaces via HP Anyware PColP. This is described in the following articles.

« Connecting Your IGEL OS Device to Amazon WorkSpaces with the HP Anyware PColP Client (see page
467)

« Configuring Your HP Anyware Client for Amazon WorkSpaces in IGEL OS (see page 471)

+ Broker Types for Connecting to Amazon WorkSpaces with the HP Anyware Client on IGEL OS (see
page 473)

+ How Can | Use H.264 Acceleration in an HP Anyware PColP Session? (see page 474)
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Connecting Your IGEL OS Device to Amazon WorkSpaces with the HP
Anyware PColP Client

You can use the HP Anyware PColP client to connect your IGEL OS device to Amazon WorkSpaces. The HP Anyware
PColP client is an alternative to the Amazon WorkSpaces client.

Set Up the Device Connection

Before you connect the device to Amazon WorkSpaces for the first time, you might need to change some settings.
Your Amazon WorkSpaces administrator can provide you with additional setup instructions that are required for
your particular environment.

Session Connection
To set the session connection:

1. Inthe IGEL Setup, go to Sessions > HP Anyware PColP Client > PColP Sessions.

2. Click . F to create a new session.
3. Go to Connection Settings.
4. Set Server certificate verification mode to "Warn but allow".

IGEL Setup 11.08.200.1c4.01 (Build 6.10.4)

s » HP Anyware PColP Client ™ PColP Se s ® PColP Session ™ Connection Settings

Use IGEL Setup for configuration

Server certificate verification mode

Warn but allow

FUITVE 1 [+1g]

sktop Integration
Search v
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() Ifyoudo notenable Use IGEL Setup for configuration, you have to enter the host address or code
in the HP Anyware client login window. See the screenshot under "Connecting to Amazon

WorkSpaces".
If you activate Use IGEL Setup for configuration, see Configuring Your HP Anyware Client for

Amazon WorkSpaces in IGEL OS (see page 471).

() Formoreinformation about the connection with the Broker type "PColP broker" or "Hardhost",
see Broker Types for Connecting to Amazon WorkSpaces with the HP Anyware Client on IGEL OS (see

page 473).

5. Go to Login and make sure that Authentication type is set to "Password authentication".
Afterward, click Apply.

IGEL Setup 11.08.200.1c4.01 (Build 6.10.4)
s * HF Anyware PColP Client (¢ sions 2 on * Login

Authentication type Password authentication

Search

IGEL Setup 11.0 0.rc4.01 (Build 6.10.4)
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Connecting to Amazon WorkSpaces

1. Onyour desktop, double-click on the icon of the PColP session.

PColP Session

The Anyware PColP Client dialog opens.

2. Enter the Host Address or Code that has been sent to you in the welcome e-mail from Amazon
WorkSpaces.

3. Enter the Connection Name and click SAVE.

4. Enter your Amazon WorkSpaces credentials.

5. Enter the Multi-Factor Authentication (MFA) Token.

IGEL OS Articles
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(@ Multi-factor authentication is a proof of user identity that combines two different components
(factors) that are independent of one another.

& fyou do not use multi-factor authentication, you still need to enter something in the MFA field,
even when itis just a number or "1234".
Otherwise, no connection to Amazon WorkSpaces can be established.

6. Click Ok.
The Amazon WorkSpaces desktop is shown.

() Seealso ourvideo description on youtube:

https://www.youtube.com/watch?v=NDQXTEKLPZE
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Configuring Your HP Anyware Client for Amazon WorkSpaces in IGEL OS

Configuring the Connection in the IGEL Setup
If you want to use the IGEL Setup for the configuration, proceed as follows:

1. Enable Use IGEL Setup for Configuration.

2. Select the Broker type you want to connect to Amazon WorkSpace.
a. Broker type: Direct hardhost
+ Enter the Registration Code for Amazon Workspaces as Server.
+ Set Server certificate verification mode to "Warn but allow".

€} ¥ Use IGEL Setup for configuration

¥} | Direct hardhost

Server certificate verification mode Warn but allow

b. Broker type: PColP broker
« Enter the server from the PColP broker as Server.
« Set Server certificate verification mode to "Warn but allow".

€} ¥ use IGEL Setup for configuration
Broke e \:PCUIF‘ broker

Server certificate verification mode ‘Warn but allow

() Formoreinformation about the broker types, see Broker Types for Connecting to
Amazon WorkSpaces with the HP Anyware Client on IGEL OS (see page 473).

3. Click Apply.

4. Goto Login and set Authentication type to "Password authentication".
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5. Click Apply.

IGEL Setup 11.08.200.rc4.01 (Build 6.10.4)

s * HP Anyware PColP Client *Ce sions *Ce on * Login

Authentication type Password authentication

Search

Connecting to Amazon WorkSpaces

1. Onyour desktop, double-click on the icon for your PColP session.

2. The HP Anyware PColP Client mask takes over the information you entered in the IGEL Setup.

3. Click SAVE.

4. Now enter your Amazon WorkSpace credentials.
For the rest of the procedure, see aws.amazon.com®,

39 https://aws.amazon.com/de/?nc2=h_lg
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Broker Types for Connecting to Amazon WorkSpaces with the HP
Anyware Client on IGEL OS

You can choose between two broker types for connecting to Amazon WorkSpaces with the HP Anyware Client on
IGEL OS.

PColP Broker

PColP broker is a resource manager that dynamically assigns host PCs to zero clients based on the identity of the
user established from the zero client. Connection brokers are also used to allocate a pool of hosts to a group of zero
clients in a PColP deployment. If the zero clients are configured to always connect to the same host (i.e., a static
one-to-one pairing), then a connection broker is not required.

€) V Use IGEL Setup for configuration

Broker = PColP broker
Server
Desktop

Server certificate verification mode Warn but allow

Direct Hardhost

Adirect hardhost is a direct connection between a zero client and a remote workstation containing a PColP Remote
Workstation Card. You can specify a host's DNS name or IP address, or you can configure clients to use the Service
Location Protocol (SLP) to discover a host. You can also configure clients to automatically reconnect to a host when
a session is lost.

#) V Use IGEL Setup for configuration
Broker type ) | Direct hardhost

Server

Server certificate verification mode Warn but allow
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How Can | Use H.264 Acceleration in an HP Anyware PColP Session?

Question

How must | configure the client and the server to get H.264 acceleration in an HP Anyware PColP Session?

Environment
This article is valid for the following environment:

+ IGEL 0S 11.04 or higher

() With IGEL 0S 11.08.200, the client was renamed from "Teradici PColP" to "HP Anyware PColP".
+ UMS 6.04 or higher
« HP Anyware PColP Graphics Agent for Windows 20.04

Answer

Server-side

1. Open the Group Policy Editor ( gpedit.msc).

2. Go to Local Computer Policy > Administrative Templates > PColP Session Variables >
Overridable Administrator Defaults.

3. Editthe settings as follows:
+ Set Configure PColP image quality levels to "Enabled".

+ Set Configure PColP image quality levels > YUV chroma subsampling to "4:2:0".
+ Set Enable PColP Ultra GPU optimization to "Enabled".

Client-side

1. Open the Setup or the UMS configuration dialog.

2. Go to System > Registry > pcoip > codec_h264 and activate H.264 codec (registry parameter:
pcoip.codec_h264).

3. Save your settings.
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Login Enterprise Configuration

With Login Enterprise Launcher (former Login Pl), you can test changes that affect the performance of desktop and
application logins, as well as the current processing of both applications and specific tasks inside of a given
application before you implement them on real devices.

+ Login Enterprise Launcher in IGEL OS (see page 476)

+ Getting the Secret for Login Enterprise Launcher (see page 481)
« Using the Login Enterprise Launcher within a VMware Horizon Session (see page 484)
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Login Enterprise Launcherin IGEL OS

Requirements
+ IGEL OS 11.03.100 or higher

Uploading the SSL Certificate

In order to use Login Enterprise Launcher (former Login PI), you need first to download the SSL certificate from your
Login Enterprise server: https://yourServerURL/contentDelivery/content/CA.crt .Click Goon
to the webpage. Download the certificate.

& You have to rename the file name from CA.crt to LoginPI.crt.

B = [ cartilicate emor Maviga 2 4w

e S o B hitgsyidginpi enteniDE rEnycantan AT

@ This site is not secure
This might mean that semeane’s Ering 1o fool you or steal any info

Yo send 1o the server. You should dose this site immediately.

£ Go i ponur S1an page

aetaiks

Your PC doesn’t trust chis website's securiny cerfificate.

The hostname in the website’s security certificate differs from fhe
mahisite van age Biaing bo visid,

Error Code: DLG_FLARS _IMvALIO Ch
OLG_FLaGs SEC _CERT_CN_LMWAL LD
I-.:-.:u::---u-.-..- i (RS P il e I

1. Openthe UMS Console.
2. Select New File in the Files context menu.
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E MIULNT EVILED )

,1 Shared Workplace Users
B Views (0)
£ Jobs (0)

vo| & Rename
B vo 7] Delete
B Unive ES Access control
@ Seard o Cut
0 Recyd [ Paste

Logging: Messages

Eﬂ MNew Directory

II Mew file I

The window New file opens.

3. Select the Local file under Upload local file to UMS server.
4. Choose SSL Certificate under Classification and click Ok.

New file x

File source
® Upload local file to UMS server

Local file fworkflogin_pi/LoginPl.crt

Upload location (URL) |https:!f-tserver:por‘trfums_ﬂletransfer |
) Select file from UMS server
File location (URL) | |C..

File target

Classification | SSL Certificate | v

Ok Cancel
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Configuration of Login Enterprise Launcher

1. Under Devices in the UMS structure tree, choose the device and click Edit Configuration in its
context menu. Or you can create a new profile with the required settings under Profiles and assign
it to the device, see Creating Profiles.

Firmware Customizations (0) Assetll
v [ Devices (2) TSR

@ Serial [
o & Edit Configuration |

B Mobile Devices (0| & Rename

~~ Shared Workplac 7 Delete
B views (0) (1) Clear ‘Configuration Change Status’ flag

2. Goto Accessories > Login Enterprise.
3. Enter the Server URL of your Login Enterprise server.
4. Enter the Secret, see Getting the Secret for Login Enterprise Launcher (see page 481).

{~v >v A I » Accessories * Login Enterprise

Configuration . Login Enterprise-Launcher
i S;;een;n;:'}oul 4 » This accessory can be enabled to act as a remote endpoint that can launch test sessions for the purpose of evaluating performance and availability of the
resources it connects to. In order to use this feature there must already be a Login Enterprise Virtual Appliance which this Launcher can connectto. To learn
» [ On-screen keyboard

more about using Login Enterprise with Igel go to www.loginvsi.com/igel
B WMonitor Calibration

R commanads

R Network Tools Server URL €} |https:ioginpi.igel.example
B Bluetooth Tool

B system Information Secret a

B Disk Utility

B DiskRemoval

B Mobile Device Access

B Firmware Update

B Smartcard personalization
B Webcam Information

B ICG Agent Setup

B Licensing

B Login Enterprise

B Connector ID Key Software

5. Save the settings.

© Ifyou wantto use the Login Enterprise Launcher within a VMware session, see Using the Login
Enterprise Launcher within a VMware Horizon Session (see page 484).

Starting the Login Enterprise Launcher from the UMS

After the Login Enterprise server has been set up, you can create a job in the UMS for the automatic start of your
Login Enterprise Launcher at a defined time.

1. Select Jobs in the UMS structure tree and choose New Scheduled Job in the context menu.
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B Mobile Devices (0)
& shared Workplace Users
B views (0)

» &% Jobs (21

> E Files Bename
5 Univ Delete
® sea Access control
W Recy cut

[] Paste

Logging: Messages
[3 Mew Directory

New Scheduled Job

|New Scheduledjob|

The New Scheduled Job window opens.

2. Under Name, enter the name for the job, e.g. "Login Enterprise".
3. Choose Start Login Enterprise Launcher under Command.

New Scheduled Job
Details
Name Login Enterprise
Command [Start Login Enterprise launcher ']
Execution time 15124 |5 start date [2020-0312 ] Enabled
Comment
Options
] Log results (] Retry next boot

Max. Threads E Delay [:]@ Seconds
Timeout E

Job-Info

Job ID

MNext Execution

User

Next Finish

Cancel

4, Select the Execution time and Start date.
5. Click Next and assign the devices.
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6. Click Finish to save the job.

To learn more about using Login Enterprise with IGEL, see https://www.loginvsi.com/igel/ and the following
webinar:

Sorry, the widget is not supported in this export.
But you can reach it using the following URL:

https://www.youtube.com/watch?v=N2L6z4nk8zQ
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Getting the Secret for Login Enterprise Launcher

This how-to explains how to get a Secret (see page 478) to configure Login Enterprise Launcher.

1. Goto https://yourServerURL .

Enter admin asausername and password and click LOGIN.

Welcome to Login Enterprise

Y LOGIN ENTERPRISE

admin

EII"—" YOUr Passwort

LOGIN

2. Go to Launchers.
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Welcome to Login Enterprise

RESULTS CONFIGURATION OTHERS
DASHBOARD MANAGE TESTS ACCOUNTS LICENSE P EXTERNAL NOTIFICATIONS
‘ @ AD AUTHENTICATION |Z‘l —

CONTINUOQUS TESTING LOAD TESTING RESULTS LAUNCHERS APPLICATIONS ABOUT SYSTEM

e o 49 H Y O

OGIN ENTERPRISE

3. Download arequired .zip file under Download Launcher Setup and unpack it.

MANAGE TESTS ACCOUNTS LAUNCHERS APPLICATIONS
LAUNCHERS
Machine name & Sessions Launcher version 0S Version

Download launcher setup from below to install the P1 launcher

Items per page: 1 1< < 111 » 3

LAUNCHER GROUPS Add new group

Group name & No. launcher Type Description

Mo groups to display.

ltems per page: 10 ¥ 1< ¢ 11 > 2
DOWNLOAD LAUNCHER SETUP
File name Description
Windows x64 Extract complete zip file to folder before running Setup.MSI =
Windows x86 Extract complete zip file to folder before running Setup.MSI &

4. Openthe appsettings.json fileinthe editor.
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Marme Typ

M:I appsettings JS50OM-Datei

- setup CAB-Datei

ﬁ'_::ﬁ Setup Windows Installer-Paket

Here you find the Secret for your Login Enterprise Launcher.

b

"ServerUrl”: "https://loginpi.

"IdentityProvider™: {
"ClientId": "Launcher",
"Scope": "microservice",
"Authority": "{ServerUrll/identityServer",

Secret”: "885FBD83DBBECTFE40288F I 1

Is
"Se

rvices™: {

"LaunchersUrl™: "{ServerlUrl}/launchers”,
"AccountsUrl™: "{ServerUrl}/accounts”,
"EnvironmentsUrl”: “{ServerUrl}/environments",

"CaccinnRennectellnl™ s "fSarvernllnll/fceccinnRennactc™

®

IGEL OS Articles
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Using the Login Enterprise Launcher within a VMware Horizon Session

If you want to use the Login Enterprise Launcher within a VMware Horizon Session on your IGEL OS device, note the
following:

1. Goto https://yourServerURL andlogin.

Welcome to Login Enterprise

Y LOGIN ENTERPRISE

admin

Enter your passwort

LOGIN

2. Go to Manage Tests.
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Welcome to Login Enterprise

RESULTS

CONFIGURATION OTHERS
DASHBOARD MANAGE TESTS ACCOUNTS LICENSE P EXTERNAL NOTIFICATIONS
‘ @ AD AUTHENTICATION |Z‘l —
CONTINUOQUS TESTING LOAD TESTING RESULTS LAUNCHERS APPLICATIONS ABOUT SYSTEM

RESULTS

O o

f

OGIN ENTERPRISE !

3. Click Add new environment.

MANAGE TESTS ACCOUNTS

CONTINUOUS TESTING 04 environments

LAUNCHERS

APPLICATIONS

Add new environment

Environment Name &

Schedule Connector Description
4, Enter an Environment name.
5. Select VMware Horizon View under Connector.
MANAGE TESTS ACCOUNTS LAUNCHERS APPLICATIONS
INFO Please define your environment
Environment name Connector Description
test_VMware_Horizon_view Citrix Metscaler 121 and 13.0
Citrix StoreFront
Custom connector
CANCEL SAVE
Desktop e —
Microsoft RDS
WMware Herizon View
IGEL OS Articles
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6. Enterthe Server URL and the Resource.

MANAGE TESTS ACCOUNTS LAUNCHERS APPLICATIONS
INFO test_VMware_Horizon_view
Environment name Connector Description
test_VMware_Horizon_view VMware Horizon View hd
Settings
Server Url ves71.horizon test
Resource sMartl

"/services/vvdm/bin/vmware-view" -serverURL={serverurl} —-userName="{usemname}" —

Connection command line password="{password}" —domainName="{domain}" —desktopMName="{resource}" —noninteractive ~
Accounts WM_horizon_users
Launchers All launchers

7. Copy the following:

"/services/vvdm/bin/vmware-view" --serverURL={serverurl} --userName="{username}" --
password="{password}" --domainName="{domain}" --desktopName="{resource}" --noninteractive

and paste it under Connection command line.
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MANAGE TESTS ACCOUNTS LAUNCHERS APPLICATIONS
INFO test_VMware_Horizon_view All environments Q
Environment name Connector Description
test_VMware_Horizon_view VMware Horizon View hd
Settings
Server Url ves71.horizon test
Resource sMartl
"/services/vvdm/bin/vmware-view" -serverURL={serverurl} —-userName="{usemname}" — -
Connection command line password="{password}" —domainName="{domain}" —desktopName="{resource}" —noninteractive ~
Accounts WM_horizon_users
Launchers All launchers

() Thisisimportant if you use the Login Enterprise Launcher for IGEL OS devices!

For more information on the configuration, see http://www.loginvsi.com.
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Nutanix

Nutanix enables IT teams to build and operate high-performance multi-cloud architectures. The enterprise cloud
0S software combines private, public, and distributed cloud operating environments and provides centralized
control to manage IT infrastructures and applications of all sizes.

Nutanix solutions are 100 % software-based and leverage the industry's most popular hyper-converged
infrastructure (HCI) technology.

() Hyper-converged infrastructure (HCI)

Hyper-convergent infrastructures are a further development of convergent infrastructures in which
hardware and software are also bundled.

They provide a complete infrastructure stack that combines computing, virtualization, storage, networking, and
security to run any application of any size.

The Software runs across multiple cloud environments to harmonize IT operations and proved smooth mobility for
all applications. For more information, see nutanix.com®,

Frame on Nutanix

Frame is the easiest way to run virtual apps and desktops on your choice of infrastructure.

It's a new option to use Frame Desktop-as-a-Service (DaaS) with apps, desktops, and user data hosted on your
Nutanix (AHV) infrastructure.

You have to create a browser profile and put in the address of your frame broker.

Setting Up Frame Connection

1. IntheIGEL Setup, go to Sessions > Firefox Browser > Firefox Browser Sessions.

40 https://www.nutanix.com/en
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2. Click to add a browser session.

For more information about the setup, see Firefox Browser Session.

s * Nutanix
n name

Starting Methods for Session

art Panel

Desktop folder
it

erm Terminal Emulation
ient

Passward protection None

Hotkey

Autostart

Search

IGEL Setup 11.03.100.rc6.01 (Build 6.3.7)

Nutanix

Cancel

Apply

Running the Nutanix Test Drive on IGEL

1. Open the Firefox browser.
2. Enter https://www.nutanix.com*.
3. Click Test Drive.

What We Do

NUTANIDI.

4. Enter the required data.
5. Click Launch Test Drive.

41 https://www.nutanix.com/en

IGEL OS Articles
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Test Drive Nutanix Software

First Name * Last Name *
Work Email *

Phone Number *

Company Name *

Job Title *

LAUNCH TEST DRIVE

Mutanix is caommitted to ensuring your privacy. Your email address will be used to deliver the
information you have requested and may be used to deliver other news about Nutanix. You
can unsubscribe at any time. Pleaze review our Privacy Statement for additional details.

6. Your Nutanix Test Drive information is shown.
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7. Click Start Test Drive.

Here is your Nutanix Test Drive
information!

Launch the test drive by proceeding through the certificate warning (IP addresses are
dynamically generated).

|‘ START TEST DRIVE

8. Enteryour credentials in the PRISM (Planning tool for Resource Integration, Synchronization
and Management) login window.

For the next steps, follow the instructions of Nutanix.
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« How Can | Use H.264 Hardware Acceleration for Chromium or Firefox Browsers on IGEL OS
Endpoint Devices? (see page 493)

+ Define Multiple Start Pages for Your Browser (see page 496)

« Touchscreen: Multitouch/Gesture Support for Firefox (see page 497)

« Set Advanced User Preferences for the Browser (see page 498)

« Use the Firefox Browser in Kiosk Mode (see page 499)

o SSL/TLS Error with Firefox in Appliance Mode (see page 507)

« Browser Cannot Download Files (see page 508)

+ Some PDFs are not opened by Firefox (see page 509)

« Can |l Install Firefox Extensions? (see page 511)

« Troubleshooting: Cannot Download Outlook E-mail Attachments (see page 512)

+ Troubleshooting: Cannot Log in to MS Teams in Chromium Browser (see page 513)
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How Can | Use H.264 Hardware Acceleration for Chromium or Firefox
Browsers on IGEL OS Endpoint Devices?

IGEL OS allows you to play videos from YouTube or other Internet resources with hardware acceleration, provided
the videos are encoded with H.264. Due to license restrictions, either Chromium or Firefox can use H.264 hardware
acceleration, but not both of them.

This article provides detailed information on how to configure H.264 hardware acceleration for Chromium or
Firefox.

Checking Whether Hardware Video Acceleration Is Enabled Globally

> Make sure that System > Firmware Customization > Features > parameter Hardware Video Acceleration is
enabled (enabled by default).

Fabulatech USE Redirection
Fabul: h Webcam for Remote Desktop

Fluendo Browser Codec Plugins

Fluendo GStreamer AAC

IGEL Multi Display 4 Display

Checking Whether Hardware Video Acceleration Is Enabled for Chromium

> If you want to use hardware video acceleration with the Chromium browser, make sure that Sessions >
Chromium Browser > Chromium Browser Global > parameter Hardware Video Acceleration is enabled (enabled
by default),

V' Use IGEL Setup for configuration

Default web browser €) Chromium Browser

V' Hardware Vide ration
Automatic art on exit

Show browser spla en
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Does the Default Browser Setting Matter?

If Chromium and Firefox both have the number of sessions configured, the default browser matters. Example: If
Firefox and Chromium both have three sessions, and Firefox is set as the default browser, Firefox will get H.264
hardware acceleration.

Exception: If browser content redirection is activated, Chromium will always get H.264 hardware acceleration; see
Browser Content Redirection for Citrix Sessions (see page 494).

The Browser with the Higher Number of Configured Sessions Gets Hardware Video

Acceleration
The browser that has more sessions configured is the one that gets H.264 hardware acceleration. Example: If two

sessions are configured for Chromium and three sessions are configured for Firefox, Firefox will get H.264 hardware
video acceleration.

Exception: If browser content redirection is activated, Chromium will always get H.264 hardware acceleration;
see Browser Content Redirection for Citrix Sessions (see page 494).

Browser Content Redirection for Citrix Sessions Forces Hardware Video
Acceleration for Chromium

The Chromium browser always gets H.264 hardware acceleration, regardless of the number of configured sessions,
if all of these conditions are met:

+ Sessions > Citrix > Citrix Global > HDX Multimedia > parameter Browser content redirection is
activated.
V' Multimedia redirection

HDX RealTime Webcam redirection

Browser content redirection (If enabled, Firefox will lose H.264 multimedia support)
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+ System > Registry > ica > allregions > usecefbrowser > Use Chromium Embedded Framework
(CEF) is setto "True".

Chromium Embedded Framework (CEF)

¢ default |
ory default is

False
True

Setting Chromium to Select the H.264 Video Stream

Generally, the default setting, which allows the Chromium browser to choose the video stream automatically, is
recommended. Alternatively, you can set the Chromium browser to prefer the H.264 video stream even if hardware
video acceleration is not enabled, or not prefer the H.264 video stream, disregarding the availability of hardware
video acceleration.

» Goto System > Registry > force_264 and set Force H.264 according to your needs:

+ "Auto": The Chromium browser prefers the H.264 video stream if hardware video acceleration is
enabled.

+ "Enabled": The Chromium browser always prefers the H.264 video stream, regardless of whether
hardware video acceleration is enabled or not.

+ "Disabled": The Chromium browser never prefers the H.264 video stream.
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Define Multiple Start Pages for Your Browser

In some cases, a fixed set of start pages displayed in separate tabs may prove useful. For instance, if the browser is
working in kiosk mode, reusing a set of tabs from an earlier session is not an option.

Here is how to define multiple start pages to be opened at browser startup.

Firefox

1. Open the IGEL Setup and go to Sessions > Firefox Browser > Firefox Browser Global.

2. Set When browser starts to Show my start page.
3. Set Start page to the URLs that the browser should open at startup. Use "|" as a separator.
4. Click Apply or Ok.
4 > » Fire er ™ Fire
Configuration When browser starts Show my start page
> B ThinLinc Start page http:/fkb.igel.com|https:/fwww.igel.com
» [l SSH
Minimum font
V' Show bre
Chromium

1. Open the IGEL Setup and go to Sessions > Chromium Browser > Chromium Browser Global >
General.

2. Set On Startup to Open a specific page or set of pages.

3. Set Startup page to the URLs that the browser should open at startup. Use "|" as a separator.

4. Click Apply or Ok.

< > ~ { » Chromium Br Chromium Browser Global ™ General

On Startup

Startup page

New tab page setting Open a blank page

Font size Medium (recommended)
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Touchscreen: Multitouch/Gesture Support for Firefox

You can use multitouch/gestures in the Firefox browser that is built into IGEL OS 10 and IGEL OS 11. This is done by
adding an environment variable.

To enable multitouch:

1. Open the local Setup or the UMS configuration dialog and go to System > Firmware
Customization > Environment Variables > Predefined.

2. Inthefirst free Variable name field, enter MOZ_USE_XINPUT2

3. Inthe corresponding Value field, enter 1
Click Ok.

IGEL Setup 11.03.258.01 (Build 6.3.11)

m ™ Firmware Cu: zation ™ Environmen es * Predefined

Variable name €) MOZ_USE XINPUTZ Value

Variable name Value
Variable name Value
Variable name Value
Variable name Value
Variable name Value
Variable name Value
Variable name Value
Variable name Value

Variable name Value

Search

5. Reboot the device.
6. To check if multitouch is working, open the Firefox browser and go to https://www.paulirish.com/
demo/multi.
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Set Advanced User Preferences for the Browser

The Mozilla Firefox browser included in IGEL OS offers a vast array of configuration options. They range from the
sorting order of bookmarks over encryption algorithms to fixing quirks in web applications that are important to
you. In total, they are too many to present them as individual items in IGEL Setup. However, as of IGEL Linux version
5.09.100, IGEL Setup lets you set any browser user preference in a generic way.

© Changes to the advanced Firefox browser settings can impair its stability, security, and speed. IGEL
Support is not responsible for problems caused by changing the browser configuration, even if the
browser configuration was changed in IGEL Setup.

You will find information regarding the configuration parameters for Firefox in the MozillaZine Knowledge Base
under Firefox About:config entries*,

1. In Setup, go to Sessions > Firefox Browser > Firefox Browser Global > Advanced.
2. Inthe Custom preferences area, click on Add.

> Firef

Y to redirect or reload the page

0On for multi-line controls

Disable OpenGL acceleration

Custom preferences Boolean

Active Mode Custom preference  Type value (roe

B Encryption
Using the Active option, specify whether the configuration parameter is to be active.
Specify the Mode of the configuration parameter - for many cases pref will do.
5. Under Custom preference, give the name of the configuration parameter. Example:

ui.textSelectBackground

6. Specify the Type of the configuration parameter.
Possible values:
+ String: The value is a string of characters.
+ Integer: The value is a whole number.

« Boolean: Thevalueis a Boolean value,i.e. true or false.

7. Specify the Value of the configuration parameter. The possible entries depend on the Type
selected.

8. Click Ok.
The configuration parameter will take effect the next time that the browser is launched.
For more details on browser configuration, refer to the section Firefox Browser Global in the IGEL
OS reference manual.

Hw

42 http://kb.mozillazine.org/About:config_entries
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Use the Firefox Browser in Kiosk Mode

Browser kiosk mode is an option when you are operating any kind of public terminal with anonymous access, e.g.:

+ Educational service in a museum
« Service terminals or ticket vending machines for public transport
« Entry portal for a corporate intranet

Albeit configuring an IGEL OS device for browser kiosk mode may seem quite extensive, you have the possibility to
define your own flavor of kiosk mode. Consider the following settings.

Settings under Sessions > Firefox Browser > Firefox Browser Sessions > [Session
Name]

er > Firefox Bre

n name

€) V Autostart
Autostart delay

v Autostart require

> Activate Autostart.
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Settings under Sessions > Firefox Browser > Firefox Browser Sessions > [Session
Name] > Settings

When br s sett Related Configurations

r Interface -

Start Monitor 1st monitor

€) ¥V Autostart

» Set When browser starts to Global setting.

> f necessary, select the correct Start Monitor.

Settings under Sessions > Firefox Browser > Firefox Browser Global

Related Configurations
rinterface -
Start page
olution
Minimum font

v Show

> Set When browser starts to Show my start page.

> Setstart Page to the desired start page.
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.
owser Global

he browser

> Set New pages should be opened in to the current window or to a new tab.

Settings under Sessions > Firefox Browser > Firefox Browser Global > Content
s ™ Fi > Fire Global ™ Content

€) (V) Block pop-up windows
¥ Load images automatically
Type of download directory user-defined path
Download path ftmp
ript

e or lower windows
[ ting

Languages for Web Pages

i applicable, activate Block pop-up windows.
> Activate Load images automatically.

> it required, activate Enable JavaScript and adapt the actions permitted for JavaScript according to your
needs.
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Settings under Sessions > Firefox Browser > Firefox Browser Global > Privacy

v Form
V' Saved P:

llow private bi

A
A

e n URL bar
in URL bar

> Set save Browsing History (in days) to Do not save History.

> Deactivate Save information entered in forms and the Search bar.
» Deactivate Remember Passwords.

> Activate Clear private data when closing browser.

> Activate all items in the area Select the items to be cleared.

> If you want to suppress any tracking of the user's activities, activate Allow private browsing feature and
Always start in private browsing mode.

> it applicable, activate Enable "Do Not Track" feature.

» To make the browser block domains and websites which are known for tracking users, activate Enable built-in
tracking protection.
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Settings under Sessions > Firefox Browser > Firefox Browser Global > Security

s P Firefox Browser ™ Firefox Browser Global ™ Security

€) V¥ safe Browsine
€) 7 Malware

er Global

> Toenable phishing protection, activate Safe Browsing.
» Toenable protection against malicious downloads, activate Malware Protection.

> Activate Hide local filesystem.

Settings under Sessions > Firefox Browser > Firefox Browser Global > Restart

] E R

Minutes

> Activate Restart. The browser will restart automatically if a user closes the browser window.

> If you want the browser to restart automatically after some idle time, activate Restart after idle time and
specify Idle time after which a restart occurs in minutes or seconds.
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Settings under Sessions > Firefox Browser > Firefox Browser Global > Window

Global * Window

Configuration

» EE 55H =
Default

B window
|

» |f the browser shall run in full-screen mode, activate Start in full-screen mode.

> Activate Hide configuration page of the browser.

Settings under Sessions > Firefox Browser > Firefox Browser Global > Menus &
Toolbars

s * Firefl er P Firef wser Global » Men

) (V] Hide App Menu/Menu Bar

Hide Mavigation Toolbar
v Hide Bookmarl
Hide Sidebar Hide the Toolbar fo hing the page

Toolbar ltems
Hide URL Input h Input
Hide "Print" Button w okmarks" and "RSS Feed" Button

Hide "Home" Button

Toalbarconfia

2] tomization of toolbars

Navigation Tooclbar
Application Menu

on configuration to

» Activate Hide App Menu/Menu Bar.

» Select which menus and toolbars are to be hidden. In the kiosk mode, all menus, toolbars, and the address bar
are commonly hidden.

» Deactivate User Customization of toolbars.
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Settings under Sessions > Firefox Browser > Firefox Browser Global > Context
s » Firefl wser * Firefox Browser Global ™ Context

Disable the following Items
i s in context menu

Disable button ve

er Global

Disable button for open new window/tab

ble button at d editing bookmarks
b

L3 - Chromium Browser

» Activate Hide the browser's context menu.

Disabling Access to Developer Tools
To disable access to the developer tools, add the following custom preference.

For general instructions on adding custom preferences, see Set Advanced User Preferences for the Browser (see page
498).

Mode pref

Custom preference devtools.toolbox.host
Type String

Value (leave the value field empty)

Disabling Crash Reports
To disable crash reports, add the following three custom preferences.

For general instructions on adding custom preferences, see Set Advanced User Preferences for the Browser (see page
498).

Mode pref

Custom preference datareporting.policy.dataSubmission
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Type
Value
Mode
Custom preference
Type
Value
Mode
Custom preference
Type

Value

IGEL OS Articles

Boolean
false
pref
datareporting.healthreport.upload
Boolean
false

pref

toolkit.telemetry

Boolean

false
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SSL/TLS Error with Firefox in Appliance Mode

Symptom

Firefox on IGEL Linux 5.07.100 warns of an SSL/TLS error in appliance mode that does not occur in normal window
mode. The error code is ssl_error_unsupported_version. This does not happen on IGEL Linux 5.06.x.

Problem

You cannot connect to the affected HTTPS service.

Solution
As a workaround you can instruct Firefox to ignore issues with SSL/TLS versions:

1. InIGEL Setup, go to System > Firmware Customization > Custom Commands > Base
Commands
2. Enter the following command into the After Session Configuration input field:

echo "clearPref(\"security.tls.version.min\");" >> /services/fbrw/

firefox/firefox.cfg

There is also an IGEL Linux private build that addresses this issue.
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Browser Cannot Download Files

Symptom

You are trying to view or download a file with the browser, but you get error messages instead.

Problem

The browser has no permissions for the file path you have selected for download. This is because the Firefox
browser is being guarded by AppArmor for security reasons.

Solution

Check whether one of the following possibilities for downloading files is applicable/available:

+ Storage hotplug device (USB flash drive) which is mounted to /media/[device name] or /

userhome/media/[device name]
For hotplug storage configuration, see Storage Hotplug.
« Network drive which is mountedto /mnt/[folder name]

+ Folder /userhome in the local file system; not persistent
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Some PDFs are not opened by Firefox

Symptom

When opening some PDFs from the Internet, the Mozilla Firefox browser opens a new window or tab, but fails to
display the PDF contents.

Problem

This can be due to a malfunction of the mozplugger Firefox component.

Solution

Disable mozplugger. Firefox will download the PDF document and open it with a local application (/GEL Linux
5.07.100 or newer):

1. Go to System > Registry in /GEL Setup.
2. Use Search Parameter ... to find the parameter
browserglobal.app.dom_ipc_plugins_enabled_mozplugger_so.

Check Completely disable mozplugger.
Confirm the setting with Apply or OK.
5. Restart Firefox.

> w
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< >

Configuration
s ons
Acc
User Interface
Network
Devices
Security
System

B Time and Date
» [ Update
» I Remote managemeant
» Il Remote Access
B Remote Syslog
» [l Power Options
» M Firmware Customization
‘ Registry

1y

IGEL Setup 10.05.500.01 (Build 5.9.18)

* Regis

Search amete

B conv_proxy_autoconfig_url
B conv_proxy_autologin
B conv_proxy_ftp
B conv proxy ftp_port
B conv_proxy_http
B conv proxy http_port

» [ conv_proxy_preset_cred
B conv proxy socks
B conv_prowy_socks_port
B conv_proxy_socks_version
B conv_proxy_ss!
B conv_proxy_ssl_port
B conv_proxy_type
B conv_save_browsehistory
B conv save forms
B conv_save_passwords

> I custom_config
B deactivate_hotkeys

B disablegstreamer
B disableopengl
B dom_disable_open_during_load

B dom_disable window flip

B dom_disable_window_move_resize

B dom event_contextmenu_enabled

B dom_ipc_plugins_enabled libflashplayer_so
B dom_ipc_plugins_enabled libnpjp2_so

B dom_ipc_plugins_enabled_libnptest_so

browserglobal.app.dom_ipc_plugins_enabled_mozplugger_so

Isolate PDF Viewer plugin process from the browser process

] Isolate PDF Viewer plugin process ...

B dom_ipc_plugins_enabled_libtotem-cone-plugin_s
B dom_ipc_plugins_enabled_libtotem-gmp-plugin_s
B dom_ipc_plugins_enabled_libtotem-mully-plugin_s
B dom_ipc_plugins_enabled libtotem-narrowspace-
B dom_ipc_plugins_enabled_mozplugger_so

B dom_ipc_plugins_enabled npica_so

B dom_ipc_plugins_timeoutsecs

Search

Ok Cancel
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Can | Install Firefox Extensions?

Question

Can Firefox extensions be installed?

Answer

The installation of Firefox extensions is not possible. This applies to any version of both IGEL Linux v5.x and IGEL OS.
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Troubleshooting: Cannot Download Outlook E-mail Attachments

Problem

When trying to download an attachment from e-mails in Outlook in Chromium Browser, Chromium only downloads
a file named with a uid.

Solution

Deactivate the dialog for accepting downloads by disabling the following registry key:

Parameter Enable IGEL Download Dialog

Path System > Registry

Registry chromiumglobal.app.enable_download_dialog
Value enabled (default) / disabled
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e

IGE

Troubleshooting: Cannot Log in to MS Teams in Chromium Browser

Problem
When you try to sign in to Microsoft Teams in Chromium Browser, the site loops continuously, and you can't sign in.

For more information, see https://learn.microsoft.com/en-us/microsoftteams/troubleshoot/teams-sign-in/sign-in-
loop#resolution.

Solution

For Microsoft Teams to work in Chromium Browser, it is required to allow the use of cookies. You can allow the use
of all third party cookies in Chromium Browser by disabling the Block third party cookies parameter under
Sessions > Chromium Browser > Chromium Browser Global > Privacy.

You can also configure cookie exceptions while keeping third party cookies blocked through adding a custom
policy:
1. Goto Sessions > Chromium Browser > Chromium Browser Global > Custom Setup > Policies.

2. Click L1 Add to create a policy.

3. For Policy name, enter: CookiesAllowedForUrls

4. In the Policy value field enter the following list of URLs: [[*.]microsoft.com; [*x.]micro
softonline.com; [*.]teams.skype.com; [*.]teams.microsoft.com; [*.]sf

bassets.com; [*.]skypeforbusiness.com]

5. Save the changes.
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System 1

System

+ Resetting a Device with Unknown Administrator Password (see page 515)

+ Error: "Unknown filesystem..." (see page 517)

+ Custom Boot Commands Are Still Active after Factory Reset (see page 518)

+ Solving Issues with Signed Partitions (see page 519)

« How to Show the Boot Mode of IGEL OS (see page 526)

+ Disabling IGEL OS Features to Reduce Firmware Size (see page 527)

+ Fabulatech Redirection Server Component (see page 529)

« Which Features of IGEL OS Will Be Affected If the UMS Is Down? (see page 530)
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Resetting a Device with Unknown Administrator Password

Symptom

An administrator password has been set on IGEL OS (via Setup > Security > Password > Administrator) but it has
been lost.

Problem

The local setup is not accessible without the password. Also, resetting the device to factory defaults seems
impossible.

Solution

+ Change the administrator password using IGEL UMS via Setup > Security > Password >
Administrator
or

+ Reset the device using IGEL UMS via Devices > Other commands > Reset to Factory Defaults in
the UMS menu.
or

+ Reset the thin client locally using a reset to defaults key provided by IGEL (as described below):

1. Pressthe [ESC] key repeatedly in rapid succession while the device is booting.
This will bring up the boot menu.

Juiet boot
Uerboze boot
Emergencg huut (Setup unlg]

RESE'I'. to facturg defaults j_

2. Choose Reset to factory defaults and press [Enter].
The following will be displayed:

Loading "German" keyboard layout.
The Administrator Password is required to reset the terminal settings.
If your Administrator Password is not available anymore, enter 3 times return.

Fassword :
Authentication: Authentication failure

Fassword :
Authentication: Authentication failure
Fassword: _

3. Press [Enter] three times without supplying a password.
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nter <{c> if guu want to continue and reset the terminal settings

in case your Administrator Password i= mot available anymore.
<r> Oor <cr. _

4. Enter[c] and press [Enter].
The software will then display a terminal key. Make a note of it, as you need it for requesting the
reset to defaults key from IGEL.
5. Request a reset to defaults key from IGEL. Write an email to license@igel.com® containing
« your terminal key
+ your email address as registered with IGEL support
« your company address
« your phone number

IGEL will send you the reset to defaults key.

6. Inthe current session, enter [e] and press [Enter] to shut down the device.

7. Onreceiving the reset to defaults key, repeat steps 1 to 3 to boot the device with the same
terminal key.

Enter [c] and press [Enter]. You will be prompted to enter the reset to defaults key.
3) enter now the “"reset to defaults key"”, you got by the service team
for "terminal key" 39099-53083-29440-48934 and firmware version 5.03.100.01
(you have only three tries to enter the key correctlyt)

1. Try: _

9. Enterthe reset to defaults key. Enter yes and press [Enter] to confirm resetting the client. All
local thin client settings will be lost.

Should you enter the wrong key or mistype the key you will have to resume from step 1.

43 mailto:license@igel.com
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Error: "Unknown filesystem..."

Symptom

The boot process is aborted at an early stage; the error message is "Unknown filesystem. Couldn't find valid IGEL
partition..."

Environment
+ IGEL OS (any version)

Problem

One or more system partitions could not be found or are not valid.

Solution

» Install IGEL OS anew on the device with IGEL OS Creator (OSC). For instructions, see the Installation chapter of
the IGEL OS Creator Manual.

() Preserve Your Settings

To prevent the device's settings from being deleted, ensure that Migrate Old Settings is activated in the
installation settings; see Installation Procedure.

() Data That Will Be Lost

When IGEL OS is installed anew, the following data will be lost:
« All data on the writable partition /wfs

« All data that has been stored in a Custom Partition since its deployment; Custom
Partitions will be reset to their original state.

() Licenses Will Be Lost

In this scenario, the licenses stored on the device will be lost. However, the licenses are cached in the UMS,
so that they will be restored when the device registers with the UMS.
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Custom Boot Commands Are Still Active after Factory Reset

Symptom

You have reset your device to factory defaults, but the custom boot commands are still active.

Problem
After a factory reset, the following settings will still be available:
+ boot_-id
« uptime_total
« product
+ force_Legacy

+ The bootregentry Splash willbesetto 1

Solution
You can delete these settings manually with the following command:

1. Open a local terminal and login as root.
2. Enter the following command to delete the settings:

bootreg delete /dev/igfdisk boot_cmd

For further information about custom boot commands, see Custom Boot Command.
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Solving Issues with Signed Partitions

« Error: "Partition couldn't be loaded due to invalid signature" (see page 520)
« Error: Device Plays a Beep Code Instead of Booting (see page 521)

Error: "The new firmware is not signed. Update not allowed." (see page 524)
« Error: "Invalid signature - Failed to read from partition" (see page 525)
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Error: "Partition couldn't be loaded due to invalid signature'
Symptom
During operation, a system message like this appears:

Partition couldn't be loaded
due to invalid signature.

Limited Support Features
Mobile Device Access USB

WPMN OpenConnet
nner support

Environment
+ IGEL 0S 11.03 or higher

Problem

A system partition has been invalidated, which prevents system components from being loaded.

Solution

1. Ensure that a valid update source is configured under System > Update > Firmware Update and
the correct firmware is stored on the server. (For detailed information, see Firmware Update.) If
the local Setup is not accessible, use the UMS.

2. Reboot the device.

The device fetches the valid partition from the update source.
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Error: Device Plays a Beep Code Instead of Booting

Symptom
The boot process fails, and a beep code is played. Two beep codes are possible:

+ 3shortand 1 long beep, repeated 2 times (whole sequence repeats up to 1 minute)
+ Longbeep is played for 1,1 seconds, then 2,9 seconds pause (repeats up to 1 minute)

Environment
+ IGEL 0S 11.03 or higher

Problem

+ 3shortand 1 long beep, repeated 2 times (whole sequence repeats up to 1 minute): The signature
of the found system partition is invalid.

+ Long beep is played for 1,1 seconds, then 2,9 seconds pause (repeats up to 1 minute): After up to
120 tries, no suitable system partition has been found at all.

Diagnosis
To obtain further details:

1. Reboot the device and press [ESC] repeatedly.
2. Select Verbose Boot.

When the signature of the found system partition is invalid, the output looks like this:
init: boot id from cmdline: 191204080936053974571
init: boot id from sdevsigfdisk: 191204080936053974571
[ 3.3569151 igel_flash: loading out-of-tree module taints kernel.
3.3593761 Going to add device for ’igf’
3.3865941 igel-loop: 1 -> verify_hash_info: -129
3.3873661 igel-loop: Signature verification failed: 1
3.388185] igel-loop: Not adding 1 because hash info couldn’t be built: -129
3.4406301 igel-loop: system partition rejected for non-verifiable partition signaturet

insmod: can not insmod ’//lib/moduless4.19.85/kernel/driverssblock/igel igel-flash.ko’ (errno 129): Key was rejected by service
[ 11.6509931 random: crng init done

ERROR: Invalid signature of found SY¥S partition found abort.

[ 13.649396]1 sd 0:0:0:0: [sdal Synchronizing SCSI cache

[ 13.0689051 reboot: System halted
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usbh devices (via alias)
usb devices (uvia alias)
devices (via module alias)
usb devices (uvia alias)
ush devices (via alias)
usb devices (uia alias)
devices (via module alias)
usb devices (via alias)
usb devices (via alias)
usbh devices (via alias)
devices (uia module alias)
ush devices (uia alias)
usb devices (uia alias)
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devices (uvia module alias)
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devices (uvia module alias)
usb devices (via alias)
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usb devices (via alias)
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devices (via module alias)
usb devices (via alias)
usb devices (via alias)
usb devices (via alias)
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usb devices (via alias)
usb devices (via alias)
usb devices (via alias)

= 1070

» Install IGEL OS anew on the device with IGEL OS Creator (OSC). For instructions, see the Installation chapter of
the IGEL OS Creator Manual.

() Preserve Your Settings
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IGEL

To prevent the device's settings from being deleted, ensure that Migrate Old Settings is activated in the
installation settings; see Installation Procedure.

() Data That Will Be Lost

When IGEL OS is installed anew, the following data will be lost:
« All data on the writable partition /wfs

+ All data that has been stored in a Custom Partition since its deployment; Custom
Partitions will be reset to their original state.

() Preservation of Licenses

When IGEL OS is installed anew, any licenses stored on the device are preserved, provided that the
relevant partition is valid.
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Error: "The new firmware is not signed. Update not allowed."

Symptom

During the update process, the following error messages are shown:

Error: The new firmware is not signed. Update not allowed..

¥ Click for more details
== Mon Dec 9 09:42:16 2019

Error: Firmware not signed.
Error: Cannot get info from the update location.
@ Error: Firmware update failed.

Error: The new firmware is not signed. Update not allowed..

" DK

Environment
+ IGEL OS 11.03 or higher

Problem

The system expects signed system partitions, but the partitions of the update source are not signed. This will occur
when you have tried to downgrade from IGEL OS 11.03 or higher to an older version of IGEL OS 11.

Solution

> If you want to downgrade from IGEL OS 11.03 to IGEL OS 11.02, e. g. because you need certain older client
versions, set the update source to IGEL OS 11.02.200.

IGEL OS 11.02.200 is a special variant of IGEL OS 11.02 which has signed partitions; this version can only be obtained
from the IGEL Support Team.
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Error: "Invalid signature - Failed to read from partition"

Symptom

During operation, a system message like this appears:

Invalid signature - Failed to
o read from partition.

MNWIDIA graphics driver

Environment
+ IGEL 0S 11.03 or higher

Problem

A system partition has been invalidated, which prevents system components from being loaded.

Solution

1. Ensure that a valid update source is configured under System > Update > Firmware Update and
the correct firmware is stored on the server. (For detailed information, see Firmware Update.) If
the local Setup is not accessible, use the UMS.

2. Reboot the device.

The device fetches the valid partition from the update source.
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How to Show the Boot Mode of IGEL OS

To check the boot mode of IGEL OS, proceed as follows:

1. Open the IGEL start menu.

2. Click thei-icon.
The About dialog opens.

3. Find the parameter Boot Mode under the Hardware section.
Example: BIOS

IGEL OS Articles 526/1109



System

Disabling IGEL OS Features to Reduce Firmware Size

You want to update your IGEL OS firmware to a higher release version, but the firmware update requires more disk
space. Updating devices with less disk space than required leads to an error: Not enough space on local

drive.

Problem
The size of the new firmware

+ with all enabled software features included

« with the NVIDIA graphics driver

+ with the Firefox profile partition

+ possibly with a custom partition

+ possibly with custom wallpaper and bootsplash

exceeds the device's disk space (e.g. 2 GB).

Solution
Disable firmware features not needed for the productive operation to reduce the size of the firmware:

1. InIGEL Setup, go to System > Firmware Customization > Features.
2. Disable features not needed in your environment.

3. Saveyour settings with Apply or OK.

4. Reboot the device.

5. Update the device.

@ Use profiles in order to deactivate features on a group of devices. For details on profiles,
see Profile.

& Alternative Method for Reducing the Feature Set as of IGEL OS 11.04
If you update to IGEL OS 11.04 or higher, you can alternatively use the method described under Error: "Not
enough space on local drive" when Updating to IGEL OS 11.08 or Higher (see page 246). The advantage of this
method in comparison to disabling features via the IGEL Setup is that you won't have to disable the
deactivated features once again in case you reset the endpoint device to factory defaults (see Reset to
Factory Defaults).
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IGEL Tech Video

Sorry, the widget is not supported in this export.
But you can reach it using the following URL:

https://www.youtube.com/watch?v=KmcCcdoGbNM
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System

Fabulatech Redirection Server Component

For Fabulatech USB Redirection and Scanner Redirection, a special Fabulatech server component must be installed
on the Citrix, Horizon, AVD, Amazon, RDP or HP Anyware PColP server (USB for Remote Desktop IGEL Edition).

You can find more detailed information on the function and download the component at the Fabulatech partner
site*,
Current versions:

« USB Redirection: https://www.fabulatech.com/usb-for-remote-desktop-
download.html#tab_usbrdp-lin-linux-current

+ Scanner Redirection: https://www.usb-over-network.com/partners/igel/scanner-for-remote-
desktop-download.html

You can find more information on Fabulatech Redirections in IGEL OS in the following articles:

Citrix: Fabulatech USB Redirection for Citrix in IGEL OS and Fabulatech Scanner Redirection

RDP: Fabulatech USB Redirection for RDP in IGEL OS and Fabulatech Scanner Redirection
Horizon: Fabulatech USB Redirection for Horizon in IGEL OS and Fabulatech Scanner Redirection
AVD: Fabulatech Redirection for AVD in IGEL OS

44 http://www.usb-over-network.com/partners/igel/
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System

Which Features of IGEL OS Will Be Affected If the UMS Is Down?

Overview

In general, IGEL OS works independently of the Unified Management Suite (UMS). This includes, for instance, all
remote desktop clients like Citrix, RDP, or VMware Horizon, and browsers.

Any configuration changes that are made via the UMS are stored on the device and thus remain stable when the
UMS is down.

However, the Shared Workplace (SWP) feature and administration functions are affected by a UMS outage.

The following sections list the details.

Productivity Features That Are Affected If the UMS Is Down
+ Login via Shared Workplace (SWP); see Shared Workplace (SWP)

Administration Functions That Are Affected If the UMS Is Down

+ Configuration changes

+ License Management

+ Secure Shadowing

+ Secure Terminal

« Universal Firmware Update

+ Firmware Customizations

« Transfer of files to the device, including Custom Partitions
+ Remote commands, such as Wake-on-LAN or restart
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« Configuring Open VPN Sessions (see page 532)

+ Running the OpenVPN Client with a Preconfigured Configuration File (see page 544)

+ How Can | Configure OpenVPN with an .ovpn or .conf File for IGEL OS Devices? (see page 546)
+ Configuring Wi-Fi Network Roaming (see page 552)

« Connecting to a Wi-Fi Network with Hidden SSID (see page 554)

« Improving WiFi Connectivity (see page 555)

+ Preventing Permanent Storage of Wireless Network Keys (see page 559)

« Using WPA Enterprise / WPA2 Enterprise with TLS Client Certificates (see page 560)

« |IPv6 Settings (see page 564)

« Extended Logging With Syslog, Tcpdump and Netlog (see page 568)

« Making a Telnet Connection from IGEL Linux (see page 582)

+ Configuring Dynamic DNS Updates via DDNS (see page 583)

« Changing the SMB protocol version (see page 585)

+ How to Launch the Wireless Manager within IGEL OS when the Taskbar Is Hidden (see page 586)
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Configuring Open VPN Sessions

This document describes how to configure the OpenVPN Client on IGEL Linux.

Prerequisites

+ A configured and running OpenVPN 2.x server

+ Information about the OpenVPN server configuration (e.g. authentication method)

+ Athin client with IGEL Linux 10.01.100 or newer

+ The certificate and private key files for the client, along with the root certificate of the CA that
signed the client and server certificates.

« Optionally, a Smartcard or eToken supported by IGEL Linux.
To learn how to distribute keys and certificates to the thin clients, refer to the How-To document
"Securely Distributing Keys and Certificates (see page 543)".

« Authenticating with TLS Certificates (see page 533)

« Authenticating with Name/Password (see page 534)

+ Authenticating with Name/Password with TLS Certificates (see page 535)
« Authenticating with Static Key (see page 536)

« Options and TLS Options (see page 537)

« DNS and Routing Options (see page 538)

» Proxy (see page 539)

« Checking the VPN Connection (see page 540)

« Automatically Starting the VPN During Boot (see page 541)

» Further Information (see page 542)

« Securely Distributing Keys and Certificates for OpenVPN (see page 543)
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Authenticating with TLS Certificates

1.

Go to Network > VPN > OpenVPN and create a new connection.

In the Session section for the new connection, enter the name or public IP address of the
OpenVPN Server.

Select TLS-Certificates as the Authentication Type.

Select the client certificate as the Client Certificate file.

Select the root certficate of the CA as the Certificate Authority (CA) file .

Select the client's private key as the Private Key file. Enter the passphrase in Private Key
password if the key is protected with one.

®* Opent'Ph Connection

OpenyPR Server(s) |1?2.3IZI.EI1 136 |

Configuration

B Mobie Broadband
» Il DHCP Client
¥ [ ven
O Open WPM
r[O Open'yPN Connection
. Session
‘ Options

Click anicon for the newly created session (e.g. in the Start Menu) to initiate the connection.

Sessions Authertication Type | TLE-Certificates v
-"—". SCESS "'.._:
AEEESSANES Clientt Centificate file |clier|t.u:rt |
User Interface
CA certificate file |ca.cr1 |
- . LAM Interfaces Private key file ||:Iier|t.ke3-' |

EEEEE

Private Key paz=ward

@ IfaPKCS12fileis available, which includes the client certificate, the certificate authority
and the private key, then you just need to enter the PKCS12 file name in the three
corresponding fields. The advantage is that you only have to roll out one single file instead
of three different files.
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Authenticating with Name/Password

1. Goto Network >VPN > OpenVPN and create a new connection.

2. Inthe Session section for the new connection, enter the name or public IP address of the
OpenVPN Server.

3. Select Name/Password as the Authentication Type.

4. Enter the Username. If you leave this field blank the user will be prompted for the Username when
connecting.

5. Check Password required.

6. Enter the Password. If you leave this field blank the user will be prompted for the password when

connecting.

Select the root certficate file of the CAAs the Certificate Authority (CA) file.

} ot i " network ™ VPN ™ Open PR P OpenPR Connection

Configuration Open'PM Server(s) | 172.30.91 136

Authertication Type lNamEJPasswcurd T]

Uzer name | client1 |

User Interface
[;_f] Passward recuired

Pazsward ******|

» I L&N Interfaces
B obile Broadband
» Il DHCP Client
¥ 3 ven
O3 Open VPN
A | Open'PH Connection
. Session
n Cptions

8. Click anicon for the newly created session (e.g. in the Start Menu) to initiate the connection.

CA& cedificate file ||:a.|:rt |
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Authenticating with Name/Password with TLS Certificates

1. Goto Network >VPN > OpenVPN and create a new connection.

2. Inthe Session section for the new connection, enter the name or public IP address of the
OpenVPN Server.

3. Select Name/Password with TLS-Certificates as the Authentication Type.

4. Enter the Username. If you leave this field blank the user will be prompted for the username when
connecting.

5. Check Password required.

6. Enter the Password. If you leave this field blank the user will be prompted for the password when
connecting.

7. Select the client certificate as the Client Certificate file.

8. Select the root certficate of the CA as the Certificate Authority (CA) file.

9. Select the client's private key as the Private Keyfile. Enter the passphrase in Private Key

password if the key is protected with one.

k- ® WP ® Open PR ® OpentPR Connection ® Session

Open'yPR Server(s) 1723091 136

Configuration

e Authertication Type | MamePassword with TLS-Certificates v|

Accessories i
User name client]
User Interface .
[;_F] Pazzwoard required

Pazzwoard FAERER

» [ LAN Interfaces .
‘ Nohile Broadband Client Certificate file client.crt
» I DHCP Cliert .
* [ veN CA certificate file ca.crt
¥ 8] WPMN [
B3 Open Private key file client key
* O Open''PM Connection
. Session Private Mey password fia
. Options

10. Click anicon for the newly created session (e.g. in the Start Menu) to initiate the connection.

@ IfaPKCS12fileis available, which includes the client certificate, the certificate authority
and the private key, then you just need to enter the PKCS12 file name in the three
corresponding fields. The advantage is that you only have to roll out one single file instead
of three different files.
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Authenticating with Static Key

Go to Network > VPN > OpenVPN and create a new connection.

In the Session section for the new connection, enter the name or public IP address of the
OpenVPN Server.

Select Static Key as the Authentication Type.

Select the static key file as the Private Key.

Select None as the Key Direction.

Enter the server's VPN IP address as Remote IP Address.

Enter your client's VPN IP address as Local IP Address.

> i® petwork ™ WPN P Open VPN ™ OpenPM Connection ™ Session

Cunﬁguratiun Openy'PH Server(s) |1T2.3EI.EI1 136

Authertication Type | Static Key v|
Private key file ||:Iier|t.kev
User Interface

Remaote [P Address |192.1 51231

» Il LAN Interfaces
B 'obile Broadband
» [l DHCP Client
* 3 wen
*xO Open VPN
*[O Open''PH Connection

I Session

‘ Options

Key Direction lNu:une v]

Local IP &ddress |192.1 B5.123.2

8. Click anicon for the newly created session (e.g. in the Start Menu) to initiate the connection.
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Options and TLS Options

Options

Under Network > VPN > OpenVPN > [Session Name] > Options, you can set various options for the OpenVPN
client. Usually, you can leave the default settings as they are. If the server uses compression, enable Use LZO data
compression.

() Ifestablishing a tunnel fails, try again with Use LZO data compression enabled.

& The --comp-lzo option is considered deprecated from OpenVPN v2.4 and should not be used any more.
For more information, see https://community.openvpn.net/openvpn/wiki/DeprecatedOptions#Option:--
comp-lzoStatus:Pendingremoval.

(@ When using a proxy, set Protocol used for communication to the host to tcp-client.

TLS Options

Under Network > VPN > OpenVPN > [Session Name] > TLS-Options, you can set various TLS-related options. In
particular, you can configure whether the remote peer certificate will be verified.
For details about these settings, refer to Configuring Open VPN Sessions (see page 532) or OpenVPN.
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DNS and Routing Options

By default, OpenVPN automatically uses the server's settings for DNS and routing.
If you want to change these settings, go to Network > VPN > Open VPN > [Session Name] > IPv4. Here you can:

+ Deactivate Automatic DNS

« Add Extra nameserver(s)

+ Add Extra search domains
Deactivate Automatic Routes
Deactivate VPN is the default route

Additionally, you can enable three custom routes in Network > VPN > Open VPN > [Session Name] > Route
[0,1,2]. For each enabled route you can configure:

+ whetheritis a Network Route or a Host Route

Network/Host IP

Network Mask (for Network Route only)

Optional: Gateway

Optional: Metric (a quality rating used for routing decisions, 0 being the best)
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If you wish to configure a proxy for your VPN connection, go to Network > VPN > OpenVPN > [Session Name] >
Proxy. Here you can configure:

« Proxy Type: SOCKS or HTTP, by default this is set to None
+ Proxy Address and Proxy Port
+ Retry indefinitely when errors occur

If you select the HTTP proxy type you can configure:
+ Proxy Username
+ Proxy Password

@ When using a proxy, set Options > Protocol used for communication to the host to tcp-
client.

® When experiencing issues with OpenVPN, read the messagesin /var/log/messages,
e.g. using the System Log Viewer.
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Checking the VPN Connection

As soon as a VPN connection is established, a lock icon with connected plugs is shown in the panel:

DE ll))l__ﬂ_," 11:21 | 4
L

However, this only serves as an indicator. To be sure that the VPN connection really exists:

1. Open aLocal Terminal.
2. Runthe command 1ifconfig.

3. Check whether the output containsa tun device with an IP address from the private network.

Terminal =k e

user@IGEL -Q0ABCAGS50027 :~$¢ ifconfig

eth@ Link encap:Ethernet HwWaddr 00:0b:ca:05:00:27
inet addr:172.30.91.219 Bcast:172.30.255.255 Mask:255.255.0.0
inet6 addr: feBO::20b:caff:fe@5:27/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:150@ Metric:1
RX packets:1091674 errors:0 dropped:47 overruns:0 frame:@
TX packets:125138 errors:0 dropped:@ overruns:@ carrier:@
collisions:0 txgueuelen:1000
RX bytes:79070067 (79.0 MB) TX bytes:58744380 (58.7 MB)
Interrupt:105 Base address:0xal@@@

lo Link encap:lLocal Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:85536 Metric:1
RX packets:108954 errors:0 dropped:@ overruns:@ frame:0
TX packets:108954 errors:0 dropped:@ overruns:@ carrier:0@
collisions:0 txgueuelen:@
RX bytes:45078307 (45.0 MB) TX bytes:45078307 (45.0 MB)

itun® Link encap:UNSPEC Hwaddr|GG-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet addr:192.168.123.10 |P-t-P:192.168.123.9 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:150@ Metric:1
RX packets:23080 errors:0 dropped:0 overruns:@ frame:0
TX packets:48007 errors:0 dropped:74 overruns:@ carrier:0@
collisions:0 txgueuelen:100
RX bytes:1266538 (1.2 MB) TX bytes:63784736 (63.7 MB)

user@lGEL -GO0BCAGSE027 :~% |

4. Additionally, check whether you can ping the VPN server's private IP address.
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Automatically Starting the VPN During Boot

(@ Ifyou want to update the firmware via the VPN, you need to enable Autostart During Boot. Enabling
Autostart of the control application in Network > VPN > OpenVPN > [session name] is not adequate!

Go to Network > VPN > OpenVPN.

Check Enable Autostart During Boot.

Select one of the configured sessions.

Click Set Auto.

The session will be marked in the Auto column.

Click Set Auto again to dectivate autostarting the session.

Rl e

@ The system will prompt you for key pass phrases or the eToken/smartcard PIN if
necessary.
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Further Information
Further information about OpenVPN can be found in

« the OpenVPN how-to* and
« the OpenVPN manual page*

maintained by the OpenVPN project.

45 https://openvpn.net/index.php/open-source/documentation/howto.html
46 https://openvpn.net/community-resources/reference-manual-for-openvpn-2-0/
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Securely Distributing Keys and Certificates for OpenVPN

Use the file distribution mechanism in the Universal Management Suite (UMS) to securely distribute keys and
certificates to the thin clients:

1. Select Undefined as the Classification.
. Enter /wfs/OpenVPN/ as the thin client file location.

2
3. Enable the Read permission for the Owner exclusively, and uncheck all remaining permissions.
4. Select Root as the Owner.

Mew file x

File source
@ Upload local file to UMS server

Local file Clsersiddministratoniclient?.key Q
Upload location (URL) | hitps:#172.30.91.23:8443/ums_filetransfer/ -
() Selectfile from UMS server
File location (URL) | [
File target
Classification [Undeﬁned .*]

Thin Client file location | swfs/OpenyVPR/

Access rights

Read Write Execute
owner [ [ U]
others [ [ ]

Owner |Root ¥
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Running the OpenVPN Client with a Preconfigured Configuration File

& Solution Based on Experience from the Field

This article provides a solution that has not been approved by the IGEL Research and Development
department. Therefore, official support cannot be provided by IGEL. Where applicable, test the solution
before deploying it to a productive environment.

This article describes a basic solution for getting the built-in OpenVPN client running with a preconfigured
configuration file. This is an alternative to using the Setup for configuration.

Environment
This article is valid for the following environment:

+ IGEL OS 10 or higher
¢ OpenVPN server

Setting up an OpenVPN Connection with a Preconfigured Configuration File

1. Inthe UMS Console, open the context menu on Files and select New File.
Selectyour .ovpn filein the file system.

In the File target section, under Devices file location, enter "/wfs/".

Click Ok.

The file is uploaded to the UMS.

5. Assign the file object to your device by clicking the "+" symbol in the Assigned objects area (upper
right).

6. Create a profile with a suitable name, e. g. "OpenVPN Connection".

7. Inthe profile, go to System > Firmware Customization > Custom Commands > Network.

8. Inthe Final network command field, enter the following code, replacing example.ovpn with

W

the correct filename:

while :; do if [ -z $(pgrep openvpn) ]; then echo "openvpn is not
running"; openvpn --config /wfs/example.ovpn --auth-user-pass
<(echo -e $(zenity --forms --text="Enter your VPN credentials" --
add-entry=Username --add-password=Password --title=0OpenVPN) | sed
's/|/\n/"); else echo "openvpn is running"; fi; sleep 1; done &

9. Click Save to save the profile.
10. Assign the profile to your device by clicking the "+" symbol in the Assigned objects area.
11. Reboot the device.
After reboot, you should see a login window for OpenVPN.
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12. Enter your OpenVPN credentials.
If the login was successful, a Network connecting popup appears briefly. No other indicator is
shown. You can disconnect only by rebooting the device.
If the login has failed, the login window reappears.

Removing the OpenVPN Connection

» To remove the OpenVPN connection from the settings, unassign the profile from the device and reboot it.
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How Can | Configure OpenVPN with an .ovpn or .conf File for IGEL OS
Devices?

You canusethe .ovpn orthe .conf filefrom your firewall to configure OpenVPN for your IGEL OS device.

a

Solution Based on Experience from the Field

This article provides a solution that has not been approved by the IGEL Research and Development
department. Therefore, official support cannot be provided by IGEL. Where applicable, test the solution
before deploying it to a productive environment.

Creating a Profile

1.

Openthe .ovpn orthe .conf filein “Microsoft Visual Studio Code” (freeware) or any other
editor that can save files in UTF-8 and uses LF (not CR-LF) for a newline.

In the UMS, create a profile with an appropriate name, e.g. "OS11_OpenVPN".

Go to Network > VPN > Open VPN and click L1 to create an OpenVPN session.

Edit the settings of Network > VPN > Open VPN > [your OpenVPN session] > Session as follows:

= configuration.conf

= configuration.conf

[TLS-CemﬂDa(eS
TLS-Cerificates
Name/Password

y infinite

mute
cipher AES-256-CBC
-name “C=mycountry, L-mylocation, 0=MYORG, CN-MYDOMAIN, emailAddress-mymail@ g
0511_OpenVPN

I ® Network ® VPN P OpenVPN » Op:

myopenvphserver.com 1 Related Configurations

Configuration OpenVPN Server(s)
o) Smarteard

Authentication Type A |15 Cortfcates 7] © nisaiswars

Client Cerificate file é dientert

» Il LAN Interfaces CA cerlificate file & cacrt

B Wobile Broadoand
» Il DHCP Client
M=)
¥ [ Open VPN
v [ OpenVPM Connection
B session
R Options
B TLS-Options
B Froy
B Pu
B Route 0
B Route 1
B Route 2
B Deskop Intearation
I NCP VPN Client

Private key file B cientiey

Private Key password A

Apply and send to device s:
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5. Go to Network > VPN > Open VPN > [your OpenVPN session] > Options and edit the settings as

follows:

= configuration.conf x

> configuration.conf
lient

remote myopenvpnserver.com 1194

proto udp

dev tun

mute 1@
pher AES-256-CB
rerify-x509 gry, L-mylocation,WgglYORG, CN-MYDOMAIN, CMgjlAddreS

Configuration
"

ories

ser Interface

> I LAN Interfaces
B Mobile Broadband
+ Il DHEP Client
M=
¥ O3 Open VPN
¥ [ OpenVPN Connection
B Session
B Ontions
B TLS-Options
B Proxy
B P
B Route 0
B Route 1
B Route2
I8 Deskiop Imegration
I NCP VPN Client

IGEL OS Articles

a11gmail. de”

Virtual network type
Use custom tunnel Maximum Trans missiol
UDF fragment size
A [ Restrict tunnne! TCP Maximum Segment Size (MSS)
A [ Randomize remots hosts
Cipher

HWAC Authentication

Apply and send to device Save
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6. Go to Network > VPN > Open VPN > [your OpenVPN session] > TLS Options and edit the settings
as follows:

configuration.conf

configuration.conf  x

= configuration.conf

mycountry, L=mylocat: ORG, CN=MYDOMAIN, emailAddress=mymailgmail.de"

0811_OpenVPN x

* Network ™ VPN > OpenVPN ™ Opei

Configuration Subject Match

¥ [ LAN Interfaces Remote peer certificate TLS type Da notverity

> I Interface 1 Do notverify
» B Inferface 2 Key file for aditional TLS authentication
» I Wireless Check for Client Certificate
B Mobile Broadband
+ B DHCP Client
M=
¥ O3 Open VPN
v [ OpenVPN Connection
B Session
W Options
B TLS-Options
B Proxy
B P
B Route 0
B Route 1
B Route 2
IR Desktop Integration

Key Direction

B NCP VPN Client
» I genucard

Search

Apply and send to device sae || cancel

Creating the Certificate/Key Files

If you already have the following files, you can skip this section and jump to Transferring the Files to the UMS (see
page 550):

e cCa.crt
« client.crt

« client.key
If the certificates and the key are embedded in your .ovpn file, extract the certificates and key as follows:

1. Openthe .ovpn fileinyoureditor (must be able to save as UTF-8 and use LF, not CR-LF, for a
newline).

2. Gotothesectiontaggedas <ca> ... </ca> and copy the marked certificate, including
—-——-BEGIN CERTIFICATE---—- 2l = END CERTIFICATE----- :
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= demo.ovpn X

-BEGIN CERTIFICATE-
MIICFDCCAeWgAWIBAZTJAMNMYKSMaiTUMABGCSqGSIb3DQEBBQUAMFExCzAIBENY

BAYTAMRIMRIWEAYDVQQHEW1EYXJtc3RhZHQXDDAKBENVBAOTABYSSZ ETMBEGALUE
AxMKRVILIFZQTiBDQTEZMBCGCSgGSIb3IDQEIARYKYWREQGVYaySkZTAeFwoOW0
MDgxMDOx> LMRIWEAYDVQQH
EwlEYXJt _IFZQTiBDQTEZ
MBCGCSqge IAQEFAADB QAW
gYkCgYEL IGAbQjpee/DLV
WZWIAOmn JELyWOe jMkUght
6CmfFLckH LAWEAAQNAMDAW
HQYDVREC — - MAMBAF SwDWYD
VREBRBAgwBoCEfwAAATANBgkqhkiGIweBAQUFAAOBZQCDbBYikbQe+Amv+yGgWsCo
XxW34Wm2h7qKiQcDhBZxw2d71GBNhnRhdPiWe01aulcbwl PnidxCsdBASHOiEL
TNNpXYXSSxiBE+LGQLsB1SSEKOSUVHMoxNXj]YgaoguYene04QXCBhQigFnSndcw
bZNFONw/E2H958b/yCqcid:

=END - CERTIFICATE-
<fca>

®oAo Ln 76, Col 26 (923 selected) Spacesi4 UTF-8 [F PlanTed A& 0Q
3. Paste the text to the editor and save it to a file named ca.crt (file type "All files").

4. Gotothesectiontaggedas <cert> ... </cert> and copythe marked certificate, including
----BEGIN CERTIFICATE----- and ——--- END CERTIFICATE----- :

BAYTAmMR 1IMRIWEAYDVQQHEW1EYXJtc2RhZHQxDDAKBENVBACTABVYS
AxMKRVILIFZQTiBDQTEZMBCGCSgGSIb3DQEIARYKYWREQGVYaySkZTAeFwBxNjA3
MDUxMTEBNDNaFwlzNjExMjIxMDQxMjIaMEAXC BgNVBAYTAMR1MRIWEAYDVQQH
DA1EYXJtCIRhTUNNNAYB A ID AAMA O IE € > EDMABEALLIE haatTme +AnBUMTIBIF AN
BgkqghkiGowe r6cgeuP+oSFw
8YbeRZwTS2L TIpkTcN78hdz
er/JIrXkqd n2cEb81rzkd
USTYvOvH3/ni 108Wg9Eww 1 yv
qRKkNB6ZQF4 rkZ7iNrwoD6q
Lmez FxiT7IE! )5 kSPWIDAQAB
04HOMIHLMBE! CQYDVREJBIG]
MIGGgEQhmhy ShMCZGUXEAQ
BENVBACTCUR i « SOt Mmoo SE MBI W e Tev e EwpF Uk s gy 180
IENBMRkwFWY JKoZIhvcNAQkBFgphZG1AZXIrLmR1ggkAw2Z gruwxg JNQWC!
BATwADALBgNVHQSEEBAMCBeAWDQYIKoZThvcNAQELBQADEYEAUG3GTT IsWwPCc7Fyr
JptP/eZwcI5BeIkScx9Zux/USjLYSrPmiysBqN+veD3DhBvh+M3ux
7GHVT468fRwaNfdedAgghinFgtcR8zmNyex0Oe/mObSbupg3I1q70t ImaRyWc2fwFV
6serglmVClcPZnEwd73jWlsQn0Og=

- sEMD - CERTIFICATE-----

GIN PRIVATE KEY-----
®OAD Ln 154, Col 26 (1252 selected) Spaces4 UTF-8 LF PainTet & 0

5. Paste the text to the editor and save it to afile named client.crt (file type "All files").
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6. Gotothe sectiontagged as <key> ... </key> and copy the marked key, including —---
BEGIN PRIVATE KEY---—- and ——--- END PRIVATE KEY----- :

————— BEGIN PRIVATE KEY-----
MIIEVQIBADANBgkqhkiGOwOBAQEFAASCBKCWEgSjAZEAAOIBAQCOWCVIivLbf jutw
YAq/pyp64/6hIXDRht5FnBNLYvalyALCFhiRPq4q8PKc1GU8x/ TQDXFESISHULZT
6HFkimRNw3vyF3N6vamtdap@revesfbTw3VCeLrMulunlgyCAdfgkxEmf+6auolk
ymJufZwRvzWvOR1RIhIB6E f+cwl@7mwrAFgnXZIBTtVYZNP228210QUFY1iPw/06P
uvR1DxaDeTDCXK+pEqQeHplAXhuCzWSEGCE8RR+3C3ERgY/UDYBE JHhuB1CdVYne
ZOXORNUI2vCgPqouZ7MXGIPsgRTG/VbF88Xec+yBa3BK21/VEABBeKBz1FyxnZPc
jauoyTk/ wjb91xradl
Coc+nJQK j1GMeS+Snb
rgcgveXF WSqj2INgT
V2HCUGAT MAVIXwrvn
3X6F4eVa N@3vFwz /2
Uxelkxfuh leRb3XxzHa
FOFxx27F '1542cA3gg
q1EzWWIh 'mkK7BePdN
NowCeYLp _Tms1cnmkU
Vwvauzilvz iL4JApogcl
kcg/ jM8K 111 3YbiGbx
y5jFRy32 :POxpUklml
TUSWNOSE wbqB8G3bC
VUnL8gVsPPRagXIAJxsHelAcU4bb5xx4AHFKbNFrkzpY6sX75tfOBbIBAOGBAT JW
qTgKT1hkEMOoXB8vWBKIXFOZWMOBUT SWYdd+GIME+Ae/XIwit2m327a05Lhs3eUtg
JmRjMbld/YHISTD+X+HjLs gj TBAKTRmF i PGwUXmYDPKFVVTOgr FWEWOru3 /X
5cgjqZ0Y18EQ/ 947 kf2Hmozq9qpBDj558AUQKdrz ADGAE38aX9P558/6NEBUN113
3KGe/dgmaeVz7Ws9tiDb6jFaévwypl/GDEBdePp]lkt7alGvY18HURFENZJOIAHF
TEdVMP64atacGIxh8Ipjoalstb2sKH1FyHMAWlks3anl3FgeBUd6SA K7 +ENZNN
mvhbjsCx/zHqytHSah+ Tqt8=

END- PRIVATE - KEY-----
<fkey>

@odo Ln 184, Col 26 (1703 selected) Spacess4 UTF-8 (F PlainText & 0

7. Paste the text to the editor and save itto a file named client.key (filetype "Allfiles").

Transferring the Files to the UMS

1. Inthe UMS, go to Files > [context menu] > New file and create a file object for each certificate/key
file; set Classification to "Common Certificate (all purpose)".

2. Assign the file objects to the endpoint devices on which you want to use the OpenVPN connection.

For detailed information on how to create file objects in the UMS and transfer them to devices, see Files -
Registering Files on the IGEL UMS Server and Transferring Them to Devices.

Adjust the Profile

1. Inthe UMS, open the profile you have created for your OpenVPN connection and go to Network >
VPN > Open VPN > [your OpenVPN connection] > Session.
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2. Edit the file locations as follows:

Configuration

* Open » OpenVPN Connection

OpenVPN Server(s)

q Authentication Type

res

User Interface

» Il LAN Interfaces
| Mobile Broadband
» Il DHCP Client
vOvPN
¥ [ Open VPN
¥ [ OpenVPN Conneg

B options
B TLS-Options
‘ Proxy
B P
n Route 0
B Route 1
B Route 2
B Desktop Integr:
I NCP VPN Client
» Il genucard
» [ SCEP Client (NDES)
» [ Routing
B Hosts

Search

L

ﬂ& ‘ myopenvpnserver.com

ﬂ é {Namea’Password with TLS-Cerlificates

i

Username
& (] Passwaord required
Password
Client Certificate file
CA certificate file
Private kay file

Private Key password

& |

|fwfsfca—ce rsiclient.crt h

| Iwfsica-certsica.crt

hwfsica-certsiclient key I

Apply and send to device

Related Configurations

Smartcard
Middlevware

Save Cancel

3. Apply the profile to the endpoint devices on which you want to use the OpenVPN connection.
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Configuring Wi-Fi Network Roaming

Issue

Different wireless network instances have been configured for a mobile device. The device should switch over to the
strongest network automatically.

Solution

Parameters to configure Wi-Fi roaming options can be found in the IGEL registry (Setup > System > Registry).
These settings should be changed by experts only.

Parameters for better control of Wi-Fi roaming capabilities with access points that share the same
SSID:
network.interfaces.wirelesslan.device0.lock_initial

Default: false

If true ,the device will stick to the access pointitis connected to even if candidates with better
signal quality are present.

Setting this parameterto true isa last resort for problems that are caused by too much
roaming.

network.interfaces.wirelesslan.device0.bgscan.module
Default: default (Perservingthe unpachted NM's behaviour)
Possible values:

default :Nobackground scanningisdone.

simple :The Wi-Fi module tries to scan for a potentially better signal in the background.

bgscan.module simple provides following options:

network.interfaces.wirelesslan.device0.bgscan.simple.signal_strength (default: -45 dBm)
This defines a threshold that determines which of the following two parameters shall be effective:

network.interfaces.wirelesslan.device0.bgscan.simple.short_interval (default: 30 s)

Interval between background scans (in seconds) if the actual signal level of the currently
connected access point is worse than signal_strength.

network.interfaces.wirelesslan.device0.bgscan.simple.long_interval (default: 300 s)

Interval between background scans (in seconds) if the actual signal level of the currently
connected access point is better than signal_strength.

IGEL OS Articles 552 /1109



Network

e

IGE

® i parameter lock_initialis true ,itis recommended to set bgscan.module to none .

« Parameters to control Wi-Fi roaming between Wi-Fi networks with different SSIDs:
network.interfaces.wirelesslan.device0.mssid_check_interval (default: 10 s)

The interval in seconds between checking if automatic roaming might be neccessary. This includes
detecting that a connection has been lost and a new one should be established.

network.interfaces.wirelesslan.device0.mssid_quality_threshold (default: 20 )

If the current connection's quality percentage is below this value, scanning will be performed to
find a potentially better network.

network.interfaces.wirelesslan.device0.mssid_quality_difference_threshold (default: 40 )

A candidate for automatic roaming is only considered if its quality percentage is this much better
than the current connection's quality.

network.interfaces.wirelesslan.device0.mssid_previously_used_threshold (default: 55 )
During boot: If the previously used SSID's quality percentage is above this threshold, it is preferred.

network.interfaces.wirelesslan.device0.mssid_user_selection (default: false)

If true ,theusercan initiate roaming to a network via the Wi-Fi tray icon's context menu (must
be enabled).

If automatic roaming shall not interfere with the user's choice, the following values are
appropriate:

network.interfaces.wirelesslan.device0.mssid_quality_threshold= 0
network.interfaces.wirelesslan.device0.mssid_quality_difference_threshold= 101

network.interfaces.wirelesslan.device0.mssid_previously_used_threshold= 0
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Connecting to a Wi-Fi Network with Hidden SSID

Symptom

The device does not connect to a wireless network with hidden SSID.

Problem

An option in the device's network configuration is missing.

Solution

If you need to configure a hidden access point, proceed as follows:

1.
2.

Hw

Start IGEL Setup or open the device configuration dialog in the UMS.

Go to Network > LAN Interfaces > Wireless > Default Wi-Fi network (or Additional Wi-Fi
networks depending on your configuration).

Choose Enable WPA Encryption.

Set parameter AP Scan mode to "no broadcast".

Click Apply or Ok to save the settings.

4 > ~ / * Network » LAN Interfaces * Wireless » Default Wi-Fi network

Configuration ﬂ . =
(U Disable Encryption () Enable WEP Encryption (® Enable WPA Encryption

wireless Network Name (SSID)

User Interface

Network Network authentication | wPa Persanal v|  Network key

¥ O LAN Interfaces Data encryption | Defautt Y] I AP Scan mode 8} [no broadcast M| I
» Il interface 1
» Il Interface 2
¥ [ wireless
i Default Wi-Fi network
B 2dditional Wi-Fi networks
B Wireless regulatory domain
B Mobile Broadband

Search

Cancel
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Improving WiFi Connectivity

Problem

Your WiFi connection is unstable, or weak, or both.

Environment

« UDC with IGEL Linux v5??? or IGEL OS??? or higher???
+ UD Pocket IGEL Linux v5??? or IGEL OS??? or higher???

Possible Causes and Solutions

There are many circumstances and parameters which influence the quality of a device's WiFi connection. To find a
suitable solution to your problem, check out the following collection of possible causes and suggested solutions,
workarounds and hints for debugging.

Several Access Points (APs) Are Using the Same Channel

If more than one Access Points visible to the thin client are using the same WiFi channel, interference issues may
arise.

> Reconfigure the Access Point (AP) in question to use different channels.

Roaming within One Network (Same SSID)

When the device is configured to roam within its network, it tries to make sure that it is using the strongest/nearest
Access Point (AP) within its network. Dependent on the given situation, it might be feasible to disable or to optimize
roaming.

See also Configuring Wi-Fi Network Roaming (see page 552).

Avoid Roaming

» Inthe Setu p, go to System > Registry > network > interfaces > wirelesslan > device0 > lock_initial (Registry
key: network.interfaces.wirelesslan.device0.lock_initial)and activate Avoid roaming
within the same network.

() Ifroamingis deactivated, System > Registry > network > interfaces > wirelesslan > device0 > bgscan >
module should be set to none.
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Select the Access Point with the Best Signal

With the following setting, the thin client selects the Access Point that emits the best signal when the device starts

up.

> In the Setu p, go to System > Registry > network > interfaces > wirelesslan > device0 > bssid (Registry

key: network.interfaces.wirelesslan.device0.bssid )andenter bestsignal inthe BSSID field.

Automatic Roaming

Automatic roaming is feasible if the device is moved around frequently, and several Access Points are available.

In the following example, the device is configured to start scanning for another Access Point 10 seconds after the
signal of the current Access Point has dropped below -78 db, while a routine scan is executed every 60 seconds, :

1. Inthe Setup, go to System > Registry > network > interfaces > wirelesslan > device0 > bgscan >

module (Registry key: network.interfaces.wirelesslan.device0.bgscan.module)
and select simple.

. Set System > Registry > network > interfaces > wirelesslan > device0 > bgscan > module >

simple > long_interval (Registry
key: network.interfaces.wirelesslan.device@.bgscan.module.simple.long_

interval)to60.

. Set System > Registry > network > interfaces > wirelesslan > device0 > bgscan > module >

simple > short_interval (Registry
key: network.interfaces.wirelesslan.device0.bgscan.module.simple.shor

t_interval)to 10.

. Set System > Registry > network > interfaces > wirelesslan > device0 > bgscan > module >

simple > signal_strength (Registry
key: network.interfaces.wirelesslan.device0.bgscan.module.simple.sign
al_strength)to-78.

40 MHz Bandwidth in the 2.4 GHz Band
With some Access Points, it may be feasible to disable the 40 MHz bandwidth in the 2.4 GHz band.

> In the Setu p, go to System > Registry > network > interfaces > wirelesslan > device0 > driver > cfg80211
> cfg80211_disable_40mhz_24ghz (Registry
key: network.interfaces.wirelesslan.device@.driver.cfg80211.cfg80211_disable_40mh

z_24ghz ) and deactivate Disable 40 MHz channel bandwidth in 2.4 GHz band.

High Throughput Option

In some environments, the high throughput functionality built into the driver may not produce optimal results. You
can disable this functionality and check if the connection has improved.
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> Inthe Setu p, g0 to System > Registry > network > interfaces > wirelesslan > device0 > driver >
disable_ht (Registry key: network.interfaces.wirelesslan.device0.driver.disable_ht)and
deactivate Disable HT.

2.4 GHz Band Only
In some environments, it might be better to use only the 2.4 GHz band.

» In the Setu p, go to System > Registry > network > interfaces > wirelesslan > device0 > band (Registry key:
network.interfaces.wirelesslan.device0.band )and select 2.4 GHz.

If one or more alternative WiFi networks (SSIDs) are configured, do the following for each alternative SSID:

> Inthe Setu p, go to System > Registry > network > interfaces > wirelesslan > device0 > alt_ssid[number] >
band (Registry key: network.interfaces.wirelesslan.device@.alt_ssid[number].band)and
select 2.4 GHz.

Frame Aggregation

It might be helpful to disable the frame aggregation feature of IEEE 802.11n.

> Disable frame aggregation on your Access Point (AP).

() OnyourAccess Point, this feature may have a different name.
Also note that IGEL cannot give a guarantee that the Access Point will function properly after the
suggested configuration changes.

WiFi Driver Scans And Selects Access Point

By default, the WPA supplicant initiates scanning and the selection of an Access Point. You can change this behavior
and assign this task to the driver.

1. Inthe Setup, go to System > Registry > network > interfaces > wirelesslan > device0 > wpa >
ap_scan (Registry key: network.interfaces.wirelesslan.device®O.wpa.ap_scan)

and select WLAN driver initiates scanning and AP selection.
2. Restart the thin client.

Whitelist of BSSIDs

You can restrict the number of Access Points to be scanned by creating a whitelist. This whitelist contains only the
BSSIDs of those Access Points that the device should scan.

In the Setup, go to System > Registry > network > interfaces > wirelesslan > device0 > bssid_whitelist (Registry
key: network.interfaces.wirelesslan.device0.bssid_whitelist )and enterthe BSSIDs of those
Access Points that should be scanned, separated by whitespaces.
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Debugging
If none of the methods described above work, you can create a log file and send it to the IGEL Support Team.
1. Inthe Setup, go to System > Registry > network > interfaces > wirelesslan > device0 > wpa >
debug (Registry key: network.interfaces.wirelesslan.deviceo.wpa.debug)and

select very verbose.
2. Restart the thin client.

3. Sendthefile /tmp/wpa_debug.all totheIGEL Support Team.
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Preventing Permanent Storage of Wireless Network Keys

This document describes how to prevent users from storing wireless network keys/passwords for Wireless
Manager on the endpoint device.
1. In Setup, go to System > Registry.
. Gotothe network.applet.wireless.allow_storing_credentials parameter.

2
3. Uncheck Allow permanently storing credentials, which is checked by default.
4. Click Apply.

This will affect the Wireless Manager dialogs for wireless networks with the network authentication methods in
their variants requiring passwords:

+ WPA Personal

« WPA Enterprise
+ WPA2 Personal
+ WPA2 Enterprise

In particular, users will not have check boxes labeled Permanently store identity and password or Permanently
store network key available.
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Using WPA Enterprise / WPA2 Enterprise with TLS Client Certificates

This document describes how to use UMS to configure Wi-Fi connections on IGEL OS with WPA Enterprise / WPA2
Enterprise and TLS client certificates.

There are two options for supplying client certificates and keys to devices:

Via SCEP (NDES)

SCEP allows the automatic provisioning of client certificates via an SCEP server and a certification authority (CA).

Learn how to configure it, using How-To Certificate Enrollment and Renewal with SCEP (NDES) (see page 656).

Via Files Served from UMS

You need:

+ aclient certificate in PEM (base64) format
+ aclient private key (needs to be passphrase-protected) in PEM (base64) format

Alternatively,

+ a PKCS#12 file containing both client certificate and private key (needs to be passphrase-
protected).

() Inboth cases, SCEP and files from UMS, the device needs to have a working Ethernet or Wi-Fi connection
to the SCEP server or the UMS first, so that it can fetch the necessary certificates before it can connect to
the target Wi-Fi.

+ Deploying Client Certificates and Keys (see page 561)
+ Configuring the Network Interface (see page 562)
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Deploying Client Certificates and Keys

To deploy client certificates and keys via UMS, follow these steps for the client certificate and client private key files
(or the PKCS#12 files containing both):

1.

PN G A~ WN

In the UMS Console navigation tree, right-click Files and select New file from the context menu.
The New file dialog opens

Under File source, use the file chooser to choose the file as the Local file.

Under File target, leave the classification as Undefined.

Set the Thin Client file locationto /wfs/wpa-tls/

Under Access rights, set check Read and Write for the Owner and none for Others.
Set the Owner to Root.

Click OK to upload the file.

Drag the file icon onto a thin client or thin client directory in order to assign the file.
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Configuring the Network Interface

This describes how to configure the Wi-Fi interface.

() Inboth cases, SCEP and files from UMS, the device needs to have a working Ethernet or Wi-Fi connection

to the SCEP server or the UMS first, so that it can fetch the necessary certificates before it can connect to
the target Wi-Fi.

Using SCEP (NDES)

NoohkwnN

10.
11.

In Setup go to Network > LAN Interfaces > Wireless.

Check Activate Wireless Interface.

Go to Default WiFi-network.

Select Enable WPA Encryption.

Enter the Wireless Network Name (SSID).

Select WPA Enterprise or WPA2 Enterprise according to your preferences.
Set EAP Type to TLS

or set EAP Type to PEAP and Auth Method to TLS.

(@ IGEL OS supports both EAP-TLS and PEAP-EAP-TLS. Choose one that is supported by your
infrastructure.

Leave Validate Server Certificate enabled.

Enter the path to a CA Root Certificate if you use a CA other than those supported by IGEL OS (see
page 675).

Check Manage Certificates with SCEP (NDES).

Click Save.

Using Certificate and Key Files

Nk~ wN

In Setup go to Network > LAN Interfaces > Wireless.

Check Activate Wireless Interface.

Go to Default Wi-Fi network.

Select Enable WPA Encryption.

Enter the Wireless Network Name (SSID).

Select WPA Enterprise or WPA2 Enterprise according to your preferences.
Set EAP Type to TLS

or set EAP Type to PEAP and Auth Method to TLS

@ IGEL OS supports both EAP-TLS and PEAP-EAP-TLS. Choose one that is supported by your
infrastructure.

Leave Validate Server Certificate enabled. Enter the path to a CA Root Certificate if you use a CA
other than those supported by IGEL OS (see page 675).
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9. Enter the path to the Client Certificate file in PEM (base64) format, e.g. /wfs/wpa-tls/

client.crt.

Leave this field blank if you use a PKCS#12 file containing both certificate and private key.
10. Enter the path to the Private Key file in PEM (base64) format.

If you use a PKCS#12 file containing both certificate and private key, enter its path here.
11. Specify the Identity to be used if your key/certificate contains more than one entry.
12. Enter the Private Key Password.
13. Click Save.
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IPv6 Settings

IGEL Linux version 5.07.100 or newer and IGEL Linux version 10.01.100 or newer offer new options for configuring
network interfaces for IPv6.

Application Scenario

IGEL devices cannot so far communicate with the UMS via IPv6. Therefore, the major application scenario for IPv6 is
as follows:

+ Devices still receive their IPv4 configuration and potentially /GEL-specific DHCP options from a
DHCPv4 server.
Most of the settings are received from the UMS via IPv4.
Only the default options are requested from the DHCPv6 server. These are as follows:
+ IPv6 address
« nameservers
+ DNSsearch list.
Regarding DNS, only IPv6 nameserver addresses should be delivered (in router advertisements or
DHCPv6 options). The resolver should be able to use these for retrieving AAAA records and also A
records if necessary.
Clients and servers use IPv6 if they are prepared to do so.
Examples:
« An NTP server (System > Time and date > NTP time server) can be specified as an IPv6
address or as a name for which the DNS has only an AAAA record available.
+ Similarly, in a web browser session, IPv6 will be used when the DNS has AAAA records
available for servers.

« Available Configurations (see page 565)
« Timeouts in Automatic Configuration (see page 567)
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Available Configurations

IPv6 support is configured by network interface in Network > LAN Interfaces:

“ DIIT Setup 5.07.100.rc8,01 (Build 4.9.12)

P LAN Interfaces ™ Interface 1

L . =
L]
SEEELEEIES Athentication  Wake On Lan
User Interface
¥ W3

- Metwork .
¥ LAM Interfaces T

» o Interface 1 Metwark Mask 255,255,255.0

o Interface 2

B Wireless
" SF'HI‘(-iP Client IPvB-Configuration
[ =
b o SCEF Client (NDES) C?"“E?t;blllty mode
» o Routing Disable .

~ Hosts Metwark Linktype Automnatic

i DHCPwS

> & Network Drives Force guto-negotiation

-~ Prowy

[ Enable tray icon
Search [¥/] Enable context menu ’

The following configurations are available:

Value Effect

Compatibilty

Equivalent to former versions of IGEL Linux: NetworkManager ignores the

mode device, but the kernel performs some basic configuration. In particular, it
assigns an IPv6 link local address to the device.

Disabled

Automatic

IPv6 is disabled completely.

The device tries to perform an IPv6 stateless or stateful autoconfiguration

based on router advertisements. Depending on the router advertisements,

this involves DHCPvV6 (see RFC 4861).
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DHCPv6 This option is supported by NetworkManager. It can be used when a DHCPv6
server is available but no router advertisements. Routing has to be
configured by other means. In most cases Automatic will be preferable.

@ Inallcases IPv4 is configured in the usual way.
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Timeouts in Automatic Configuration

If Automatic is selected, there is a configurable timeout for the dual stack mode. This is the time that the system
waits after the first of the stacks IPv4 or IPv6 has completed its configuration for the other stack to complete its own
configuration. After this time has elapsed, it runs the scripts that depend on the network being up. The default
timeout value is 15 seconds.

The timeout can be configured with the following parameters in System > Registry:

Parameter Device

network.interfaces.ethernet.device0.dual stack_ Firstethernetdevice

timeout

network.interfaces.ethernet.devicel.dual_stack_ Second ethernetdevice

timeout

network.interfaces.wirelesslan.device®.dual_ Wireless LAN device

stack_timeout

® Use the Search parameter ... function with the string dual_stack to find these parameters quickly.
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Extended Logging With Syslog, Tcpdump and Netlog

The IGEL OS Registry offers a number of extended logging options that can help customers, Support and PreSales
debug system and network issues.

For instructions on how to send log files to the IGEL support team via the UMS, see Sending Thin Client Log Files to
IGEL Support (see page 568).

Debuglog Partition (see page 569)
Syslog (see page 571)

« Tcpdump (see page 572)

Netlog (see page 575)

IGEL OS Articles 568 /1109



Network

Debuglog Partition

Logfiles can get very large quite fast. This is why they are stored in a separate partition. It is mounted at /

debuglog .

Enabling and Configuring the Debuglog Partition

The partition is enabled and configured in the Registry:

IGEL Setup > System > Registry

> Enable debuglog debug.tools.log_partition.enabled enabled / disabled
partition

Enables the debuglog partition.

IGEL Setup > System > Registry

> Size of debuglog debug.tools.log_partition_size 50...500/ 100
partition in MiB

© Resizing the debuglog partition will delete its contents!

Debuglog Partition Contents

Depending on which logging options you enable (see the following topics), you may find the following files in the
debuglog partition:

+ Syslog

+ messages (the currentsyslog)

+ messages[1-9].gz (compressed and rotated syslog)
Ethtool

+ netlog-ethtool-[device].log
+ Ping

+ netlog-host-[0-9]-ping.log (pinglog)
+ netlog-host-[0-9]-ping[n].log.gz (compressed and rotated ping log)
Ifconfig

+ netlog-ifconfig-[device].log
Netstat
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+ netlog-netstat.log (netstatlog)

+ netlog-netstat[n].log.gz (compressed and rotated netstat log)
+ Socket Status
+ netlog-socket_status.log (socketstatus log)

+ netlog-socket_status[n].log.gz (compressed and rotated socket status log)
« Tcpdump

+ tcpdump[0-3]_capture_current[n] (tcpdump capture)

+ tcpdump[0-3]_capture-[n].pcap.{lzo,gz,bzip2,xz} (compressed and

rotated tcpdump captures)
+ Tcpdump triggered by an error

« ERROR_[timestamp]/tcpdump[0-3]_capture-[n].pcap.

{1zo,gz,bzip2,xz} (compressed and preserved tcpdump captures)
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Syslog

It is possible to send all syslog messages that are writtento /var/log/message (IGEL Linux version 5.10.250

and versions 5.11.x) or to the systemd journal (IGEL Linux version 10.01.100) to the debuglog partition as well. The
logfile will be rotated and compressed as needed. This preserves the log if the thin client crashes, and logs from
several previous boots.

Configure it in the Registry:

IGEL Setup > System > Registry

> Enable syslog logto  debug.tools.syslog0.enabled true/ false
debuglog partition

IGEL Setup > System > Registry

> Number of Rotate Files debug.tools.syslog0.num_rotate_files 2..9
Number of files to be kept while rotating.

IGEL Setup > System > Registry

> Logfile rotate sizein  debug.tools.syslog0.rotate_size 2,4,8,16
MiB

Rotate when the size of the compressed file reaches this size in MiB.

IGEL OS Articles 571/1109



Network

Tcpdump

Tcpdump will help you debug network issues by capturing packets from up to 4 individual network interfaces.

(@ Usingthe Netlog (see page 575) facility, it is possible to copy capture files to a subdirectory, triggered by an
error in another log, so the captures before and after the error will be preserved for your analysis.

() Youcanuse Wireshark on an external system for analyzing capture files.

Find out more about Tcpdump from its homepage*'.

IGEL Setup > Registry

> Resolve addresses/ports to debug.tools. tcpdump[0-3]. enabled/disabled

names .
address_resolution

IGEL Setup > Registry

> Compression Method debug.tools. tcpdump[0-3] . 1zop, gzip, bzip2, xz

compression

The compression method affects file size as well as system performance while compressing. The
default [zop methiod is relatively light on the CPU.

IGEL Setup > Registry
> Interface for tcpdump debug.tools. tcpdump [0- user editable string / ethQ

loggin
gging 3].interface

Note: Names eth®, ethl, wlan0 , etc. are treated as symbolic names and will internally be
replaced by the correct PNINs automatically. For details on PNINs, see LAN Interfaces.
IGEL Setup > Registry
>Number of Rotate Files  jepug.tools.tcpdump[0-3].num_rota 3--10
te_files
Number of files to be kept while rotating.
IGEL Setup > Registry

47 http://www.tcpdump.org
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> Only Log Package Headers debug.tools.tcpdump[0-3] . enabled/disabled
only_headers

IGEL Setup > Registry
> Enable promisc tcpdump debug. tools. tcpdump [0-3] enabled/disabled
logging .

.promisc

Enable promiscuous mode on the network interface to also capture packets not intended for
this host.

IGEL Setup > Registry

].rotate_size

Rotate when the size of the uncompressed file reaches this size in MiB.
IGEL Setup > Registry
> Logfile rotate timeins debug. tools. tcpdump [0-3 O/ user editable integer

].rotate_time

Time in seconds after which the logfile is rotated and compressed. If set to 0 no time-based
rotation happens.

IGEL Setup > Registry
>Additional Parameters for  gepug.tools.tcpdump[0-3] usereditable string

tcpdum
P P .tcpdump_additional_param

eters
Use with care.
IGEL Setup > Registry
> Enable tcpdump debug.tools. tcpdump[0-3] . tc enabled/disabled
pdump_enabled
IGEL Setup > Registry

>tcpdump filter expression  depug. tools. tcpdump[0-3 User editable string

].tcpdump_filter
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Tcpdump filter expression. For the expression syntax, see the pcap-filter(7)* manpage.

48 http://www.tcpdump.org/manpages/pcap-filter.7.html
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Netlog

The netlog facility combines the following network diagnosis tools:

+ ethtool

- ifconfig

+ netstat

+ ping

+ ss (socket status)

It can also trigger tcpdump .

IGEL Setup > Registry
> Enable netlog logging debug.tools.netlog.enabled enabled / disabled
IGEL Setup > Registry

> period between netlog logs in debug.tools.netlog.period
3

1,5, 10, 20, 30, 60, 120

Ping logging is not affected by this and uses its own timing.

 Ethtool (see page 576)

+ Ifconfig (see page 577)

» Netstat (see page 578)

+ Ping (see page 579)

» Socket Status (ss) (see page 581)

IGEL OS Articles 575/1109



Network

Ethtool

Ethtool is the standard Linux utility for getting diagnostic information about wired Ethernet devices and their
drivers.

IGEL Setup > Registry
> Disable ethtool logging debug.tools.netlog.ethtool.disabled true / false
By default Ethtool logging is included in Netlog logging. However, you can disable it here.

IGEL Setup > Registry
> Log only if ethtool debug.tools.netlog.ethtool.log_on_changes true /false
output changes _only

Log only if ethtool output changes (on bootup there will always be at least one log entry)
IGEL Setup > Registry
> Number of Rotate Files debug.tools.netlog.ethtool.num_rotate_files2... 4

Keep up to this number of rotated files (also compressed), the current log not included
(which is limited to 600 lines)

IGEL Setup > Registry

> Logfile rotate sizein  debug.tools.netlog.ethtool.rotate_size 2,4,6
MiB

Rotate when the size of the uncompressed file reaches this size in MiB.
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Ifconfig

Apart from configuring network devices, ifconfig also gives diagnostic information such as RX bytes, TX bytes and
dropped packets.

IGEL Setup >
> Disable ifconfig logging debug.tools.netlog.ifconfig.disabled true / false
By default Ifconfig logging is included in Netlog logging. However, you can disable it here.

IGEL Setup >
> Log only if ifconfig debug.tools.netlog.ifconfig.log_on_changes no,error_counter,al
output changes _only l

» no:logon every netlog run
+ error_counter: log only if an error counter or the address changes
« all: log on every change of ifconfig output

IGEL Setup >
> Number of Rotate files debug.tools.netlog.ifconfig.num_rotate_files 2...4

Keep up to this number of rotated files (also compressed), the current log not included
(which is limited to 600 lines).

IGEL Setup >

> Logfile rotate sizein  debug.tools.netlog.ifconfig.rotate_size 2,4,6
MiB

Rotate when the size of the uncompressed file reaches this size in MiB.

IGEL Setup >

> Trigger tcpdump log  debug.tools.netlog.ifconfig.trigger_tcpdump true/false
_save

Trigger the saving of tcpdump logs if an error counter increases or if the IP address changes.
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Netstat

Netstat displays a variety of network statistics for the local machine.

> Disable netstat logging debug.tools.netlog.netstat.disabled true / false

By default netstat -s loggingisincluded in Netlog logging. However, you can disable
it here.

> Number of Rotate files debug.tools.netlog.netstat.num_rotate_file 2... 4
s

Keep up to this number of rotated files (also compressed), the current log not included
(which is limited to 600 lines).

>Logfile rotate sizein  debug.tools.netlog.netstat.rotate_size 2,4,6
MiB

Rotate when the size of the uncompressed file reaches this size in MiB.

>Log only if triggered  debug.tools.netlog.netstat.trigger_log net_error_changes,
net_changes,
ifconfig_changes,
ethtool_changes,
no_trigger

+ net_error_changes: log if ethtool output changes or ifconfig error counter or address
changes

+ net_changes: log if ethtool or ifconfig output changes

« ifconfig_changes: log if ifconfig output changes

+ ethtool_changes: log if ethtool output changes

+ no_trigger: log on every netlog run
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IGEL Setup >
> Enable ping check debug.tools.netlog.ping_host[0-9].enabled true / false

IGEL Setup >

> Logonly if ping fails  debug.tools.netlog.ping_host[0-9].log_only_o true/false
n_error

Log only if any one of the configures pings [0-9 fails.]
IGEL Setup >

> Number of Rotate Files debug.tools.netlog.ping_host[0-9].num_rotate 2... 4
_files

Keep up to this number of rotated files (also compressed), the current log not included
(which is limited to 600 lines).

IGEL Setup >

> Logfile rotate sizein  debug.tools.netlog.ping_host0.rotate_size 2..4
MiB

Rotate when the size of the uncompressed file reaches this size in MiB.

IGEL Setup >

> Trigger tcpdump save debug.tools.netlog.ping_host0.trigger_tcpdum?2 ... 4
p_save

Trigger the saving of tcpdump logs if an error counter increases or if the IP address changes.
IGEL Setup >

> Ping target debug.tools.netlog.ping_host0.ping_target  user-editable
string

Target IP/hostname to ping (if none is given ping will be considered as disabled!)
IGEL Setup >

>Time between pings  debug.tools.netlog.ping_host0.ping_time 1,5, 10,30, 60,
120

Time between pings in seconds.
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IGEL Setup >

> Type of ping debug.tools.netlog.ping_host0.type icmp, http
request, https
request

+ icmp: use normal ping command
« http request: send an http request (failsifno  HTTP/*.* % OK answer is received)

+ https request: send an https request (failsif no CONNECTED is returned by openssl)
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Socket Status (ss)

Socket Status (ss)
IGEL Setup >

> Disable socket status debug.tools.netlog.socket_status.disabled  true/false
Logging

By default socket_status logging is included in Netlog logging. However, you can disable it
here.

IGEL Setup >

> Number of Rotate Files debug.tools.netlog.socket_status.num_rotate true / false
_files

Keep up to this number of rotated files (also compressed), the current log not included
(which is limited to 600 lines).

IGEL Setup >

> Logfile rotate sizein  debug.tools.netlog.socket_status.rotate_size true/false
MiB

Rotate when the size of the uncompressed file reaches this size in MiB.

IGEL Setup >

> Logonly if triggered  debug.tools.netlog.socket_status.trigger_log ping_errors,
no_trigger

+ ping_errors: log only if ping test fails
+ no_trigger: log on every netlog run
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Making a Telnet Connection from IGEL Linux

Issue

You want to connect to a Telnet service and can't find a Telnet command on the device.

Solution
Using Ericom Powerterm (Requires the Ericom Powerterm Firmware Feature):

1. In Setup, go to Sessions > PowerTerm Terminal Emulation > PowerTerm Sessions.
2. Create a new session.
3. Editthe session.
4. Under Connection, make the following settings:
a. Select TELNET as Session Type.
b. Enteran IP adress or a name in Host Name.
c. If youwant to use a graphical login dialog, activate Enable Login Dialog.

kaessicm Type | TELMET hd

Parameters

Host Mame 172.30.61.153 Port Number 23
Terminal Name Keep Alive Timeout |0
[/] Enable Login Dialog [] Save last user name

[¥] set window Size
(] Force Binary Mode

5. Under Desktop Integration enter a Session Name and enable the desired Starting Methods for
the Session.

6. Click Apply to save your settings or OK to save and exit.

7. Start the new session and enter your username and password.
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Configuring Dynamic DNS Updates via DDNS

Issue:
You want to register a device's IP address with your DNS server.

You are not using DHCP.

Solution:

Use the DDNS tools contained in IGEL Linux, which can be configured by Setup.

(® This only works for BIND9 or other nameservers supporting TSIG, not for Microsoft Active Directory servers.

Distribute your nameserver's shared TSIG key with the UMS:

Create a New File.
Set the Device Storage Pathto /wfs/ddns .

Enable Read permission for the Owner and disable all other permissions.
Set the Owner to Root.

AL d =

Set up Dynamic DNS Registration:

Go to Network > LAN Interfaces in Setup.

Enable Specify an IP Address.

Enter an IP Address and Network Mask.

Enter a Terminal Name.

Check Enable DNS.

Enter a Default Domain.

Enter at least one Nameserver P address.

Enable Dynamic DNS Registration.

Select DNS as Dynamic DNS Registration Method.
If the nameserver expects a TSIG key: Select the TSIG key file.
Otherwise, leave the input field blank.

. Click Apply or OK to confirm your settings.

W Nk WNE

=
e

—
[
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] Activate default interface (Ethernet)

a

() Get IP from DHCP Server
(®) Specify an IP Address

IP &ddress 192.0.0.1
MNetwork Mask 255.255.255.0
Default Gateway [] enable

Terminal Name

¥} /] Enable DNS

Default Domain €) | dynamic.igel.local
Nameserver €) |172.30.178.1
Nameserver

[[] Manually overwrite DHCP settings
€ [V] Dynamic DNS Registration

Dynamic DNS Registration Method £} [DNS VJ

TSIG key file for additional DNS authentication ) | mfs/ddns/ddns.private

ok Cancel
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Changing the SMB protocol version

Depending on which Windows (Samba) server you are using, you will need a specific SMB protocol version.

(@ Due to security reasons, Microsoft recommends to disable SMB version 1.0 support on Windows ,so you
need to switch to at least version 2.0 to be further able to access systems with disabled SMBV1.

IGEL Linux version 10.04.100 and higher offer several SMB protocol versions.
To change the version setting:

1. Inthe IGEL Setup go to System > Registry.
2. Goto parameter network.smbmount.smb_version.

3. Select the apropriate SMB protocol version.
Possible options:
« 1.0
+ 2.0
« 2.1
« 3.0
4. Click Save or Apply and send to thin client.
The windows shares are configurable at IGEL Setup > Network > Network Drives > Windows
Drive.
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e

IGE

How to Launch the Wireless Manager within IGEL OS when the Taskbar Is
Hidden

Problem

The taskbar or system tray has been disabled for some reason (User Interface > Desktop > Taskbar / Taskbar
Items; also User Interface > Screenlock /Screensaver > Taskbar). As a result, a systray icon for the Wireless
Manager can't be accessed anymore, and the user can't manage wireless networks.

& Notice that also the Wi-Fi switch will be inaccessible if you disable the taskbar or system tray, see Switch
for the Wi-Fi Connection. See also "Enable Wi-Fi automatic switch" under Wireless.

Environment
+ IGEL 0S 10.06 or higher

Solution

You can configure the Wireless Manager as a custom application and define the way it can be launched.

1. Goto Network > LAN Interfaces > Wireless and check that the wireless interface and the Wireless
Manager are enabled.

2. Go to System > Firmware Customization > Custom Application and click [+].
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3. Specify the Session name and configure the Starting methods according to your needs.
< > / ystem

Configuration

B Time and Date
» I Update
» I Remote management
» Il Remote Access
R Logging
» [l Power Options
v [ Firmware Customization
» I Custom Partition
v [J Custom Application
[ WLAN Manager
B settings
B Desktop Integration
» Il Custom Commands
» Il Corporate Design
» [ Environment Variables
B Features
B Registry

4. Under Settings, specify the Icon name and enter the following Command:

> Firmware Customization » Custom Application » WLAN Manager

Session name

Starting Methods for Session
v Start Menu

7] Application Launcher
V' Desktop

Quick Start Panel

Menu folder

Desktop folder

Password protection

Hotkey

Autostart

Appliance Mode Access

wireless-manager
<

Configuration
Sessions
Accessories
User Interface

Network

B Time and Date
Im Update
I Remote management
I Remote Access
B Logging
I Power Options
v [ Firmware Customization
» I Custom Partition
v [ custom Application
v ] WLAN Manager
B settings
B Desktop Integration
» [ Custom Commands
» I Corporate Desian
Search

5. Click Apply or OK.

» Firmware Customization ™ Custom Application

lcon name

Command

* WLAN Manager

> Se

e

IGE

WLAN Manager |

Start Menu's System tab
Application Launcher's System tab
€) V Desktop Context Menu

/bin/start-

applications-other

€) /bin/start-wireless-manager

Cancel

The Wireless Manager can now be launched via the configured starting methods.
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Security

+ Securing IGEL OS Endpoints (see page 589)

+ Secure Shell (SSH) Access to IGEL OS with Keys (see page 632)

« Secure Terminal (Telnet with TLS/SSL) (see page 638)

+ Secure Shadowing (VNC with TLS/SSL) (see page 639)

+ Cherry eGK Channel Substitution (see page 643)

+ Single Sign-on for the Browser Proxy (see page 645)

+ Limiting the Number of Permitted Login Attempts (see page 648)

+ How to Deploy Device Encryption (see page 649)

«+ Security: Timeout for Secure Shadowing and Secure Terminal (see page 653)
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Securing IGEL OS Endpoints

This document describes settings for IGEL OS that will increase security.

It applies to the following types of devices:

IGEL UD devices
Devices which are temporarily converted by UD Pocket
Devices which are permanently converted by IGEL OS Creator (0SC)

Introduction (see page 590)

Setting Passwords (see page 591)

Keeping the System Up-To-Date (see page 598)

Disabling Access to Components (see page 603)

Minimizing the Attack Surface (see page 608)

Configuring Remote Access and Management (see page 620)
Wi-Fi and Bluetooth (see page 628)

Using IGEL UD Pocket for BYOD Devices (see page 631)
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Introduction

This document describes various settings to make IGEL OS more secure. In general, the more of these settings you
apply, the better device security will be. However, it is up to you to strike a balance between security and enabling
your users to do their work. Some settings may even be inappropriate for your use case, e.g. if you use Bluetooth
peripherals, it does not make sense to disable Bluetooth.

In order to configure multiple devices, put the relevant settings into a Universal Management Suite (UMS) master
profile, which you can assign to any number of devices. For more information, see Master Profiles.
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Setting Passwords

You can restrict access to various system components by setting passwords.

+ Setting Local Passwords (see page 592)

+ Password-Protecting Sessions and Accessories (see page 593)
+ Using Screenlock (see page 594)

» Do Not Save Session Passwords (see page 595)

+ Setting a UEFI Password (see page 596)

+ Using Two-Factor Authentication (2FA) (see page 597)
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Setting Local Passwords

Rationale

Passwords protect the system against local changes. They restrict access to the Local Terminal, Setup, and to the
rescue shells on the virtual consoles. The administrator password is also needed to reset the system to factory
defaults.

These passwords are saved in a way (salted and hashed) that prevents them from being recovered from the local
storage.

By default, no passwords are set on IGEL OS. Set at least an administrator password:

Instructions

1. InIGEL Setup go to Security > Password.

2. Inthe Administrator area, check Use Password.

3. Enter a password twice when prompted.

4. Optional: If you want to grant unprivileged user access to IGEL Setup check Use Password in the
Setup user area and enter a password twice when prompted.

5. Click Apply.

For configuration of the User Account for Remote Access, see Using Secure SSH Settings (see page 626).

Find further information in the IGEL OS manual under Password - Restrict Access to IGEL OS Components.
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Password-Protecting Sessions and Accessories

Rationale

Sessions can be used to access corporate resources, while the accessories in IGEL OS can be used to make changes
to the local system. If you do not want to disable certain sessions or accessories completely, you can set passwords
to restrict access to them.

Instructions

By default, sessions do not have passwords set. In IGEL Setup, you can set a password on the Desktop
Integration page of a session or accessory.

To enable password protection:

1. Inthe Setup, go to the relevant Desktop Integration page. The path has the following
pattern: Sessions > [session type] > [session name] > Desktop Integration.
For accessories, go to Accessories > [accessory name].
2. Set Password Protection to
« Administrator to require the Administrator password, or
+ User to require the User password, or
+ Setup User to require the Setup User password.
3. Click Apply.
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Using Screenlock

Rationale

Leaving a screen unlocked enables attackers to access the system with the logged-in user's privileges. Manual or
automatic locking the screen with a password prevents such access.

Instructions for Enabling Manual Locking

By default, there is no way for the user to manually lock the screen. To enable manual locking, follow these steps:

1.
2.

3.

In the Setup, go to User Interface > Screenlock [ Screensaver.
Do one or both of the following:
« Activate the Quick start panel starting method to give the user a button for locking the
screen manually.
« Activate Use hotkey and set a combination of keys that lets the user lock the screen
manually, e.g. [Ctrl+Shift+L].
Click Apply.

Instructions for Automatic Locking

By default, the screensaver is started automatically after 5 minutes, but the screen is not locked with a password.
To enable locking, follow these instructions:

1.
2.
3.

Go to User Interface > User Interface > Screenlock / Screensaver > Options.

Activate Start automatically.

Set the Timeout, i.e. the number of minutes of user inactivity before the screensaver starts
automatically.

As a password, select User password (see Setting Local Passwords (see page 591)) or a separate
Screenlock password (and set one).

If applicable, activate Allow administrator password to allow the administrator to unlock the
screen.

Click Apply.
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Do Not Save Session Passwords

Rationale

Passwords for sessions should not be stored on the endpoint device.

Instructions

» When configuring a session, on the login page, leave the Password field empty. The user will then be prompted
interactively for the password.

> Wherever possible use Two-Factor Authentication (2FA) (see page 597).
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Setting a UEFI Password

Rationale

In the UEFI settings you can modify very fundamental system properties, e.g. disable booting from USB. Access to
these settings should be protected by a password.

Instructions for IGEL Devices

» |f UEFIis not enabled, see the instructions under UEFI Secure Boot Enabling Guides.
By default no UEFI password is set on IGEL UD devices. To set a password, do the following:

1. Hold down the [Del] key ([F2] key for UD2) while booting.
The UEFI menu opens.

2. Usingthe arrow and return keys, go to SCU.

The Setup Utility opens.

Using the arrow and return keys, go to Security.

Use the arrow keys to select Set Supervisor Password.

Hit [Return].

Enter the desired UEFI password and hit [Return]

Enter the same UEFI password again and hit [Return] twice.

Hit [F10] in order to save and exit.

Confirm Exit Saving Changes? by hitting [Return].

The system boots, and the UEFI settings are now password-protected.

LN W

Instructions for 3rd-Party Devices Converted with OS Creator (OSC)

> Refer to the instructions of your BIOS/UEFI vendor.

() Alternatively, try pressing [F12] (in general), [F10] (Intel devices), or [F9] (Hewlett-Packard devices) to
access the BIOS/UEFI settings. If this does not work, try pressing [Del], [F1], or [F2] during booting.
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Using Two-Factor Authentication (2FA)

Rationale

Two-factor authentication (2FA) combines two different factors to prove the user's identity, often a hardware device
such as smartcard or smart token and a password or PIN. This improves protection against impostors, as they
would have to gain both possession of the hardware device and knowledge of the password or PIN.

Instructions

Use two-factor authentication with a smartcard or smart token where possible. IGEL OS supports this for the
following sessions:

« Smartcard authentication for sessions
« Citrix Storefront (see page 706)
+ RDP Sessions (see page 708)
» Horizon Sessions (see page 709)
» Web browser (see page 710)
+ (Kerberos) Passthrough Authentication (see page 1083)
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Keeping the System Up-To-Date

Rationale

Software updates fix newly discovered vulnerabilities in IGEL OS and applications. This means that keeping up with
updates is one of the most important measures in securing IGEL OS systems.

To start and configure updates, you can use IGEL Setup and/or the Universal Firmware Update feature of the
Universal Management Suite (UMS).

The instructions described on this page use the Universal Firmware Update feature of the UMS. For defining a
scheduled job, see the section "As a Job" in Assigning Updates; for configuring the update on a device, see
Firmware Update Settings for IGEL OS.

Instructions

> To be notified of secu rity-critical IGEL OS updates and to receive the IGEL Technical Newsletter, subscribe to
IGEL communications on www.igel.com®,

The upgrade procedure consists of the following steps:

+ Getting the update from the IGEL download server
+ Testing the update on one or a few devices
+ Rolling out the update on all devices

Getting the Update from the IGEL Download Server

1. Inthe UMS Console, go to Universal Firmware Update, open the context menu, and select Check
for new firmware updates.

e Lpdate {0}

49 http://www.igel.com/
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2. Activate the firmware you want to download and click Download.

Universal Firmware Updates

Ln

Include —
HTHL

HThL
HThL
HThL

The current status of the firmware download is shown.
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3. Click Ok.

Universal Update Download results

Errar
1-11.01.100

4. When the download has succeeded, the firmware is registered and stored in the UMS.

on  11.01.100

[t & Mo HThL Text

Firmware Update Settings

User  IGEL_INTEI

Host D
Port

Protocol  hitps

Errar
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IGEL

Testing the Update on One or a Few Devices

1. Inthe UMS Console, go to Universal Firmware Update, select the desired firmware and drag and

drop it on the test device or on the folder containing the test devices.
¥ Bp WoOL (7

CADES018

IGEL OS5 11-11.01.100
rsal Desktop L-10.05

The firmware is updated on the devices; during the update process, the devices reboot.

Rolling out the Update on All Devices
You can either start the update immediately or use a scheduled job to start it at a defined time.

To start the update immediately:
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IGEL

1. Inthe UMS Console, go to Universal Firmware Update, select the desired firmware and drag and
drop it on the folder containing the devices that are to be updated.

. EMP Expiry

required

IGEL LIni
GEL L

2. Inthe Update time dialog, select Now and click Ok.

Update time

1 should these chanoes take effect?
levt Reboot
f I

settings on next reboot (and don't showe this dialog again

The firmware is updated on the devices; during the update process, the devices reboot.
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Disabling Access to Components

You can hide IGEL OS components from the user that could be used to make changes to the system.

Disabling Local Terminal Access (see page 604)
Disabling Virtual Console Access (see page 605)
Using Appliance Mode (see page 606)

Hiding Unused Accessories (see page 607)
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Disabling Local Terminal Access

Rationale

The Local Terminal accessory allows the user to execute commands or make changes to the system. By default, the
local terminal is disabled, that is, no local terminal session is configured. To enhance security, you should do one of
the following:

+ Leave the local terminal disabled
+ If alocal terminal session is configured, but not needed, disable it.
« Ifalocal terminal session is needed, password-protect it.

Instructions
To remove an existing local terminal session:

1. InIGEL Setup, go to Accessories > Terminals.
2. Select a local terminal session you want to delete.

3. Click [ to remove the selected session.
4. When prompted, confirm that you want to delete the session.
5. Click Apply.

Alternatively, you can password-protect the terminals.
To password-protect the local terminal:

1. Find the local terminal session under Accessories > Terminals.
2. Follow the instructions under Password-Protecting Sessions and Accessories (see page 593).
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Disabling Virtual Console Access

Rationale

The virtual consoles ttyll and ttyl2 give the useraccessto ashell. Disabling these makes it more diffcult to
execute commands or make changes to the system.

Instructions

By default, the user can access the virtual consoles with the [Ctr{]+[Alt]+[F11] and [Ctrl]+[Alt]+[F12] keyboard
commands. To disable access, do the following:

1. InIGEL Setup go to User Interface > Display > Access Control
2. Activate Disable Console switching (Default: Console switching enabled)
3. Click Apply.
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Using Appliance Mode

Rationale

By default, IGEL OS users are not presented with a full-screen remote session, but have access to the desktop and to
the start menu. On the contrary, in the appliance mode, a single predefined session is presented full-screen to the
user. As access to other applications is prevented, this reduces the system's potential exposure to attack.

Instructions

The appliance mode is available for the following session types:

« VMware Horizon

« Browser

« Citrix Self-Service

« RHEV/Spice

+ Imprivata

« RDP MultiPoint Server
« XDMCP for This Display

To enable the appliance mode for a session, proceed as follows:

1. InIGEL Setup, go to Sessions > Appliance Mode.
2. Pick the session and configure it according to the manual chapter Appliance Mode.

() Youcan combine most of the appliance mode sessions with Two-factor Authentication (see page 597) for
increased security.
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Hiding Unused Accessories

Rationale

Accessories can be used to make changes to the system. Restricting access to these accessories helps to keep the
system secure.

Instructions
To hide individual accessories (both in the start menu and the Application Launcher):

1. InIGEL Setup go to Accessories > [accessory name].
2. Disable all Starting Methods for Session.
3. Click Apply.

To password-protect an accessory:

» Follow the instructions under Password-Protecting Sessions and Accessories (see page 593).
To hide the complete System icon of the start menu:

1. InIGEL Setup go to User Interface > Desktop > Start Menu.
2. Deactivate System tab.
3. Click Apply.

To hide the complete Application Launcher's System icon:

1. InIGEL Setup go to Accessories > Application Launcher > Application Launcher Configuration.
2. Activate Hide system page.
3. Click Apply.

IGEL OS Articles 607 /1109



Security

Minimizing the Attack Surface

Removing unused features and disabling unneeded network services reduces the parts of the system that can be
attacked.

+ Removing the Local Web Browser (see page 609)

« Configuring the Browser (Kiosk Mode) (see page 610)
+ Disabling Java in the Browser (see page 612)

+ Disabling the PC/SC Daemon (see page 613)

+ Disabling X Server TCP Connections (see page 614)

+ Removing Unused Features (see page 615)

+ Disabling Storage Hotplug (see page 616)

+ Using USB Device Control (see page 617)

+ Disabling USB Boot (see page 618)

+ Leveraging AppArmor (see page 619)
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Removing the Local Web Browser

Rationale

The local web browser may expose vulnerabilities to the internet and can be an entry point for malware. If the
browser is not needed, it is safer to remove it.

© Do notremove the local web browser if you use Citrix StoreFront sessions.

Instructions

By default, IGEL OS has a local web browser (Firefox and Chromium) installed, even if no web browser session is
configured. To remove the browser:

1. Inthe IGEL Setup, go to System > Firmware Customization > Features.

2. Uncheck the Local Browser (Firefox) and Local browser (Chromium) feature.
3. Click Apply.

4. Reboot the device.

IGEL OS Articles 609/1109



Security

Configuring the Browser (Kiosk Mode)

Rationale

If you want to offer a local web browser, there are some settings that improve its security. Additionally, these
settings add up to a kiosk mode, hiding the rest of IGEL OS from the user.

Instructions

By default, the web browser makes all of its features and menus available. To achieve a restricted 'kiosk' mode,
follow these instructions.

Firefox

1. Inthe IGEL Setup under Sessions > Firefox Browser > Firefox Browser Global >
Security, activate the following options:
+ Safe Browsing
« Malware Protection
+ Hide local filesystem
2. Under Sessions > Firefox Browser > Firefox Browser Global > Content, activate Block pop-up
windows, if required.
3. Under Sessions > Firefox Browser > Firefox Browser Global > Privacy, activate the following
options:
+ Clear private data when closing browser and all options in the area Select the items to
be cleared
+ Allow private browsing feature
« Always start in private browsing mode
« Enable "Do Not Track' feature and Enable built-in tracking protection, if necessary
4. Under Sessions > Firefox Browser > Firefox Browser Global > Restart, activate Restart.
5. Under Sessions > Firefox Browser > Firefox Browser Global > Window, activate the following
options:
« Startin full-screen mode
+ Hide configuration page of the browser
6. Under Sessions > Firefox Browser > Firefox Browser Global > Menus & Toolbars, activate Hide
App Menu/Menu Bar.
7. Under Sessions > Firefox Browser > Firefox Browser Global > Context, activate Hide the
browser's context menu.
8. Under Sessions > Firefox Browser > Firefox Browser Sessions > [session name] > Settings,
activate Autostart.
9. Click Apply.
10. Reboot the device.

For additional information, see also Use the Firefox Browser in Kiosk Mode (see page 499).
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Chromium

1. Inthe IGEL Setup under Sessions > Chromium Browser > Chromium Browser Global >
Security, activate Safe browsing and disable File access.
2. Under Sessions > Chromium Browser > Chromium Browser Global, activate Automatic
browser restart on exit.
3. Under Sessions > Chromium Browser > Chromium Browser Global > Content, activate Block
pop-ups and redirects, if required.
4. Under Sessions > Chromium Browser > Chromium Browser Global > Privacy, activate the
following options:
+ Clear browsing data and all options in the area Select the items to be cleared
+ "Forced" for the setting Allow incognito mode
+ Enable "Do Not Track" feature, if necessary
5. Under Sessions > Chromium Browser > Chromium Browser Global > Window, activate Enable
kiosk mode.
6. Under Sessions > Chromium Browser > Chromium Sessions > [session name], activate
Autostart.
7. Click Apply.
8. Reboot the device.
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Disabling Java in the Browser

Java Applets and Java Web Start may constitute a potential security threat and are now regarded as deprecated. As
of IGEL OS version 10.06.100, they are no longer included in IGEL OS. The registry keys under System > Registry >
java > deployment are obsolete.
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Disabling the PC/SC Daemon

Rationale

Unless you are running smartcard readers that use it, you can disable the PC/SC daemon. Running fewer daemons
reduces the attack surface.

Instructions
To deactivate the PC/SC daemon:

1. Inthe IGEL Setup go to Security > Smartcard > Services.
2. Deactivate Activate PC/SC Daemon.
3. Click Apply.
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Disabling X Server TCP Connections

Rationale

The X graphics server in IGEL OS has network functionality that could allow others to see your screen and read
keyboard input. Leave it disabled to keep your data confidential.

Instructions
By default the network functionality of the X server is disabled. To disable it again at a later time, do the following:

1. InIGEL Setup go to User Interface > Display > Access Control
2. Make sure that Access Control is activated.

3. Make sure that Disable TCP connections is activated.

4. Click Apply.
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Removing Unused Features

Rationale

Reducing the amount of software running on a system reduces its attack surface. Therefore a basic security
measure for IGEL OS 11 is to remove all unused features.

Instructions
To disable a feature:

1. Inthe IGEL Setup, go to System > Firmware Customization > Features.
2. Deactivate all the features that you do not intend to use.

3. If you do not use local printers on the endpoint device that you want to share with others, activate:
+ Printing (Internet Printing Protocol CUPS)
+ Printing (Line Printer LPD)
+ Printing (TCP/IP)
+ Printing (ThinPrint)

© Do not remove the Custom Partition feature if you have a custom partition that contains
software or data for which you have no backup copy. After disabling the feature and a
reboot the contents of the custom partition will be lost.

© Do notremove Fluendo Gstreamer Codec Plugins or Hardware Video Acceleration if
you use sessions that make use of these features.

4. Click Apply.

5. Reboot the device.

& Alternative Method for Reducing the Feature Set as of IGEL OS 11.04
If you update to IGEL OS 11.04 or higher, you can alternatively use the method described under Error: "Not
enough space on local drive" when Updating to IGEL OS 11.08 or Higher (see page 246). The advantage of this
method in comparison to disabling features via the IGEL Setup is that you won't have to disable the
deactivated features once again in case you reset the endpoint device to factory defaults (see Reset to
Factory Defaults).
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Disabling Storage Hotplug

Rationale

Removable USB media can be used to steal data or to execute unauthorized software or even malware on the
device.

Instructions

Storage hotplug is disabled by default. Should you want to disable it again at any later point, follow these
instructions:

1. InIGEL Setup go to Devices > Storage Devices > Storage Hotplug.
2. Deactivate Storage Hotplug.
3. Click Apply.
Storage devices are no longer automatically mounted when they are plugged in.
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Using USB Device Control

Rationale

USB devices such as pen drives, wireless controllers, or printers can be used to steal data or to execute
unauthorized software or even malware. Deactivating as many USB device classes as possible increases security.

Instructions
To enable and configure USB access control:

1. InIGEL Setup, go to Devices > USB Access Control.
2. Check Enable.

& The activation of USB Access Control and setting the Default rule to Deny will block the use of
USB devices locally and in the session and, thus, might disable devices needed for the users.
Therefore, activate the USB access control only if your security policy requires that. In this case, set
Default rule to Deny and configure Allow rules for the required USB devices and USB device
classes.

It is recommended to make settings for USB Access Control as the last step in the device
configuration. Before activating the USB access control, check that all your other settings for
printers, Unified Communication, USB redirections, mapping settings for USB devices are working
as expected.

Note that the USB access control is completely separate than USB redirection for remote sessions,
see When to Use USB Redirection (see page 1009).

Take also notice that the feature does not disable a USB port physically, i.e. power delivery will still
work.

3. Set Default rule to Deny.
In combination with the preconfigured rule that allows Human Interface Devices (HID), no USB
devices apart from e.g. mouse and keyboard are allowed.

4. Configure further rules as needed. For instructions, see How to Configure USB Access Control (see
page 1013).

5. Click Apply.

6. Reboot the device.
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Disabling USB Boot

Rationale

Disabling USB “boot prevents booting another operating system, which could be used to manipulate or (even
accidentally) overwrite IGEL OS on mass storage.

Instructions for IGEL Devices

USB boot is disabled in the factory settings on IGEL UD LX devices. If it has been enabled and you want to disable it
again, follow the instructions given here:

1.

w

No ok

Hold down the [Del] key ([F2] key for UD2) while the system is booting.
The UEFI menu opens.

Use the arrow and return keys to go to SCU.

Enter the UEFI password if one is set.

The Setup Utility opens.

Go to Boot.

Set USB Boot to Disabled.

Press [F10].

Confirm Exit Saving Changes?

The device boots.

© Additionally, set a UEFI Password (see page 596) S0 the boot settings cannot be changed
back.

Instructions for 3rd-Party Devices Converted with OSC

» Refer to the instructions of your BIOS/UEFI vendor.

(@ Alternatively, try pressing [F12] (in general), [F10] (Intel devices), or [F9] (Hewlett-Packard devices) to

access the BIOS/UEFI settings. If this does not work, try pressing [Del], [F1], or [F2] during booting.
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Leveraging AppArmor

AppArmor controls which privileges should be granted to an application that is running on the system. This way
even vulnerabilities that are yet unknown can be mitigated.

The following applications are guarded by AppArmor:

« Firefox browser
+ Cups print server
« Evince pdf viewer

The following system programs are guarded by AppArmor:

« tcpdump
+ haveged
+ dhclient

By default, AppArmor is enabled. They registry key is system.security.apparmor
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Configuring Remote Access and Management

Remote management via UMS and remote access are powerful features of IGEL OS. Select secure settings and
disable what you do not use.

+ Tying Endpoints to Your UMS instance (see page 621)
+ Disabling Shadowing (see page 622)

+ Using Secure VNC Settings (see page 623)

+ Disabling SSH Access (see page 624)

+ Disabling X11 Forwarding (see page 625)

+ Using Secure SSH Settings (see page 626)

+ Disabling Secure Terminal (see page 627)
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Tying Endpoints to Your UMS instance

Rationale

Devices that have remote management enabled but are not yet tied to a UMS instance can be taken over by an
attacker's UMS. Make sure to register all IGEL devices on your network.

Instructions

By default, remote management is enabled on IGEL OS devices. Use automatic registration to catch all devices in
your corporate network:

1. Assignthe DNSentry igelrmserver tothe UMS host. For further instructions, see Registering

Devices Automatically on the IGEL UMS.

2. Inthe UMS console go to UMS Administration > Global Configuration > Device Network
Settings.

3. Activate Enable automatic registration (without mac address import)
Now all new IGEL devices, UD Pockets and devices converted with OSC that are booting up in the
network will automatically register with your UMS instance.

4. Optionally, put newly registered devices into a quarantine directory automatically with UMS
Default Directory Rules.

5. Optionally, assign a Master Profile to this directory, thereby enforcing secure settings, e.g. a local
administrator password.

@ Alternatively you can disable remote management in the local IGEL Setup under System >

Remote management. Of course this means losing one of the most powerful features of
IGEL OS. However, this may be an option for particular devices.
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Disabling Shadowing

Rationale

Shadowing is made possible by a VNC server on IGEL OS, which is a network service. Reducing the number of
running network services reduces the system's attack surface.

Instructions
By default, Shadowing is not active on IGEL OS. However, if you want to disable it at any time, follow these steps:

1. Inthe IGEL Setup go to System > Remote Access > Shadow
2. Deactivate Allow Remote Shadowing.
3. Click Apply.
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Using Secure VNC Settings

Rationale

If you intend to use shadowing on IGEL OS, there are a number of options that can make it more secure.

Instructions

By default, Shadowing does not use encrypted network transport or a password. To activate these security features,
do the following:

1. InIGEL Setup go to System > Remote Access > Shadow.
2. Make as many of the following settings as possible for your use case. Each setting improves
security, and often also privacy:
+ Enable Secure Mode.
+ Enable Use Password and set a strong password (not needed in Secure Mode). The
maximum length for this password is 8 characters.
« Enable Prompt User to allow Remote Session.
« Enable Allow User to disconnect Remote Shadowing.
« Disable Allow Input from Remote.
3. Click Apply.

@ Secure mode for shadowing can be enabled globally in UMS under UMS Administration >

Global Configuration > Remote Access. There you can also enable the logging of users
who have used secure mode shadowing .
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Disabling SSH Access

Rationale

The SSH server on IGEL OS is a network service. Reducing the number of running network services reduces the
system's attack surface. Even more so in this case, as SSH by design enables a remote user to execute commands
on the system.

Instructions
By default, the SSH server is running on IGEL OS. To deactivate it, follow these steps:

1. InIGEL Setup go to System > Remote Access > SSH Access.
2. Deactivate Enable.
3. Click Apply.
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Disabling X11 Forwarding

When X11 forwarding is disabled, graphic applications cannot be run over SSH. By default, X11 forwarding is
disabled.

() IfX11forwardingisdisabled, itis not possible to launch the IGEL Setup from an SSH session.

To ensure that X11 forwarding is disabled:

1. Inthe Setup, go to System > Remote Access > SSH Access and make sure that Permit X11
forwarding is deactivated.
2. Click Apply or Ok.
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Using Secure SSH Settings

Rationale

If you intend to allow SSH connections to IGEL OS, there are a number of options that can make these more secure.

Instructions

To secure the SSH settings of your devices, make as many of the following settings as possible for your use case

1.
. Deactivate Permit empty passwords.
. Deactivate Permit administrator login.

2
3
4.
5

In IGEL Setup go to System > Remote Access > SSH.

Deny User access for user , who can execute any command with regular user privileges.

. Allow User access for ruser ,whose access is restricted by the list Applications access for

remote user 'ruser'.
Where needed, edit the list Applications access for remote user 'ruser’. It defines the commands

that ruser canrunfrom remote. By default, a local shell ( Localshell ) and IGEL Setup ( /

config/sessions/setup0d )are allowed.

Click Apply.

Go to Security > Password, under User Account for Remote Access activate Use Password and
set a password

Click Apply.
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Disabling Secure Terminal

Rationale

The secure terminal server on IGEL OS is a network service, providing a TLS/SSL-encrypted Telnet session. Reducing
the number of running network services reduces the system's attack surface. Even more so in this case, as the
secure terminal by design enables a remote user to execute commands on the system.

Instructions
By default, the secure terminal is not active. Should you want to deactivate it at any time, do the following:

1. InIGEL Setup go to System > Remote Access > Secure Terminal
2. Deactivate Secure Terminal.
3. Click Apply.

@ Secure Terminal can be enabled globally in the UMS under UMS Administration > Global

Configuration > Remote Access. There you can also enable the logging of users of the
secure terminal.
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Wi-Fi and Bluetooth

Rogue or unencrypted Wi-Fi access points can put your data at risk, as can Bluetooth devices. If your device has Wi-
Fi and Bluetooth, make sure to configure them securely or disable them.

» Restricting Wi-Fi Access (see page 629)
+ Disabling Bluetooth (see page 630)
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Restricting Wi-Fi Access

Rationale

Using an unencrypted Wi-Fi network or falling for a rogue access point puts your users' data at risk. Enable strong
encryption and restrict Wi-Fi access to a default network and optionally employ a whitelist of additional networks in
order to prevent this.

Instructions

By default, Wi-Fi is not activated on IGEL OS. To activate it and preconfigure one or more allowed networks, follow
these instructions:

1. InIGEL Setup go to Network > LAN Interface > Wireless.

2. Activate Activate Wireless Interface.

3. Do not activate Enable wireless manager, as this would give the user free choice of Wi-Fi

networks.

Click Apply.

Go to Network > LAN Interface > Wireless > Default Wi-Fi network.

Check Enable WPA Encryption.

Enter the Wireless network name (SSID).

Make authentication and encryption settings, see Default Wi-Fi Network in the IGEL OS Manual.

Click Apply.

10. If needed, add further networks under Network > LAN Interface > Wireless > Additional Wi-Fi
networks.

LNk
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Disabling Bluetooth

Rationale

If your device has a Bluetooth interface it may be used to access data. Disabling the interface reduces the risk of
data theft.

Instructions
By default Bluetooth is deactivated on IGEL OS. Should you want to disable it at any time, do the following:

1. Inthe IGEL Setup go to Devices > Bluetooth.
2. Decativate Bluetooth.
3. Click Apply.
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Using IGEL UD Pocket for BYOD Devices

The following document explains how you can ensure corporate security in a "bring your own device" (BYOD)
model simply by using IGEL UD Pocket.

Rationale

Letting users access company resources with their own devices and software poses a security risk: These systems
may have insecure configurations or even contain malware. In addition, company data should not be saved on
users' private devices.

Instructions

» Use the IGEL UD Pocket. This ensures the use of secure and trusted software. As the UD Pocket does not access
the device's mass storage, company data and private data will remain separated.

For details on the IGEL UD Pocket and on how to select it during the boot procedure, see IGEL UD Pocket Manual.
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Secure Shell (SSH) Access to IGEL OS with Keys

IGEL OS has a built-in OpenSSH server that can be activated and configured via the Setup application. It lets you
connect securely to the device over the network in order to issue commands or transfer files. While authentication
can be done with a username-password combination, using a private-public key pair can increase convenience
and/or security. This document describes how to generate and distribute the keys required.

+ Generating the SSH Key Pair (see page 633)

+ Distributing the Public Key with UMS (see page 635)
+ Configuring SSH Access on the Device (see page 637)
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Generating the SSH Key Pair

Prerequisites

+ Linux/Unix operating system, typically on the administrator's workstation
+ OpenSSH client software installed

Introduction
The following procedure will generate two keys:

+ Public key: This key is distributed to all machines the administrator wants to connect to. It can be
made public.
+ Private key: This key stays on the administrator's machine and has to be kept secret.

© Forthe confidentiality of the encrypted connection to devices, it is essential to keep the
private key secret.

An easily understandable explanation of private and public keys can be found in a blog post by the
programmer Blake Smith*.

Generating the Key Pair

1. Open aterminal session on your workstation as the user who is going to make the SSH
connections to the devices.
2. Issue the following command:

ssh-keygen
3. When prompted for the location to store the key pair in, you can:
+ Hit return, which will accept the default file name ~/.ssh/id_rsa

© Using the default name may overwrite existing SSH key pairs!

« Enter an absolute file path and key file name of your choice .

4. When prompted for a passphrase, you can
+ Enter a passphrase (twice)

@ Apassphrase protects the private key file in case it gets into the hands of an attacker. On
the other hand, it may be inconvenient to enter the passphrase for every connection.

« Hitreturnin order to use no passphrase.

50 http://blakesmith.me/2010/02/08/understanding-public-key-private-key-concepts.html
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© Thisincreases convenience because you will be able to log in without entering the
passphrase. However, it weakens security: The private key file will be unprotected if it gets
into the hands of an attacker.

Two files have been generated (default names):
« id_rsa -the private key file

+ id_rsa.pub -the publickey file
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Distributing the Public Key with UMS

o N oA

In UMS Console, right-click on Files in the navigation tree.
Select New File.

Upload the public key file ( *. pub ) as a Local File.

[ © Make sure that you do not upload the private key file by mistake. ]

Set the Classification to Undefined.
Specify the Thin Client file location as /wfs/user/.ssh/authorized_keys

Leave the Access rights as Read, Write, Execute.
Leave the Owner as User.
Assign the file to the desired thin clients, profiles or directories.

e ]

File source
(®) Upload local file to UMS server

Local file | C:Users\Administratorisample_rsa.pub | -

Upload location (LURL) | hitps IPM-MH-WINT-UMS.IGEL LOCAL 844 3iums_filetransfer/ | .

() Selectfile from UMS server

File location (URL) | -
File target
Classification | Undefined ‘l’]

Thin Client file location |M’stuseri.sshfauthnrized_keys |

Access rights

Read Write Execute
owner [ [V [+
Others [ [ U

Owner |User ¥

Ok Cancel
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@ If you wish to authorize more keys for SSH connections to thin clients, prepare an
authorized_keys file containing all the public keys. Simply append them using a text
editor.
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Configuring SSH Access on the Device

1. Go to System > Remote Access > SSH Access in the IGEL Setup or a profile.
Check Enable.
Optionally, if user hasanempty password, check Permit empty passwords.
Set Deny to No in the User access entry for user.

W

@ This configuration gives the remote user full shell access as if they were the local user on
the client.

Now you can connect to the device from the administrator's machine with the following
command:

ssh user@[client name or IP address]
Depending on whether you set a passphrase for the key, you may have to enter it or not.
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Secure Terminal (Telnet with TLS/SSL)

IGEL Linux version 5.11.100 or newer and IGEL Linux version 10.01.100 or newer allow terminal access via UMS with
transport encryption. In analogy to secure shadowing (see page 639), network traffic is encrypted with TLS/SSL. Secure
terminal connections can only be initiated from the UMS whose certficate is stored on the device.

For details about setting up a secure terminal connection, see UMS manual Secure Terminal (Secure Shell).

Secure Terminal is the best way to create a remote access from the UMS (on Linux or Windows installed) to Linux
devices, without installing an additional terminal software. Because the UMS includes the software.
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Secure Shadowing (VNC with TLS/SSL)

The Secure Shadowing function improves security when remotely maintaining a device via VNC at a number of
locations:

+ Encryption: The connection between the shadowing computer and the shadowed device is
encrypted.
This is independent of the VNC viewer used.

« Integrity: Only devices in the UMS database can be shadowed.

« Authorization: Only authorized persons (UMS administrators with adequate authorizations) can
shadow devices.
Direct shadowing without logging on to the UMS is not possible.

« Limiting: Only the VNC viewer program configured in the UMS (internal or external VNC viewer)
can be used for shadowing.
Direct shadowing of a device by another device is likewise not permitted.

@ Inaddition, IGEL Management Interface (IMl) in Version 2 or newer provides an API for
Secure Shadowing.

+ Logging: Connections established via secure shadowing are recorded in the UMS server log.
In addition to the connection data, the associated user data (shadowing UMS administrator,
optional) can be recorded in the log too.

(@ Of course, this is only relevant to devices that meet the requirements for secure
shadowing and have enabled the corresponding option. Other devices can be "freely"
shadowed in a familiar manner and, if necessary, secured by requesting a password. If you
would like to allow secure shadowing only, you can specify this in the UMS Console under
UMS Administration > Global Configuration > Remote Access.

« Basic Principles and Requirements (see page 640)
« Shadow Devices Securely (see page 641)
» VNC Logging (see page 642)
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Basic Principles and Requirements
The Secure Shadowing option can be enabled if the following requirements are met:

« IGEL Linux as of version 5.03.190 and 10.01.100 or IGEL Windows Embedded Standard 7 from
version 3.09.100

+ IGEL Universal Management Suite from version 4.07.100 onwards

+ The device is registered on the UMS Server

+ The device can communicate with the UMS Console and UMS Server (see below)

Basic Technical Principles

Unlike with "normal" shadowing, the connection between the VNC viewer and the VNC server (on the device) is not
established directly during secure shadowing. Instead, it runs via two proxies - one for the UMS Console and one for
the VNC server on the device. These proxies communicate via a TLS/SSL-encrypted channel, while the local
communication, e.g. between the VNC viewer application and the UMS proxy, takes place in the conventional
unencrypted manner. As a result, a secure connection can also be established with external VNC programs that do
not support TLS/SSL connections.

The two proxies (UMS Console and device) communicate with TLS/SSL encryption via the same port as the
"normal" VNC connection: 5900. As a result, no special rules for firewalls need to be configured in order to perform
secure shadowing.

If secure shadowing is active for a device under Setup > System > Remote Access > Shadow > Secure mode), the
device generates a certificate in accordance with the X.509 standard and transfers it to the UMS Server when the
system is next started. The UMS Server checks subsequent requests for a secure VNC connection using the

certificate. The certificate in PEM format can be found inthe /wfs/client-certs/tc_ca.crt directoryon
the device. The validity of the certificate can be checked on the (Linux) client using the command: x11lvnc

-sslCertInfo /wfs/client-certs/tc_ca.crt

If a UMS administrator calls up the Shadowing function in the UMS Console for the device, the console receives a
signed request from the UMS Server which is then passed on to the device to be shadowed. This in turn passes on
the request to the UMS Server which checks the validity of the request using the original certificate. If this check is
successful, the console reports that the channel for the connection between the proxies can be established. The
UMS proxy on the console connects to the server proxy on the device, and the server proxy, in turn, establishes on
the device the connection to its VNC server.

Only when these connections have been established, the console calls up the VNC viewer which then connects to
the console proxy. The VNC client and VNC server are now connected via the two proxies which transfer data with
TLS/SSL encryption.

Secure shadowing can be enforced independently of the device configuration for all devices that support this
function: UMS Administration > Global Configuration > Remote Access > Enable secure VNC globally.
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Shadow Devices Securely

In order to shadow a device securely (with encryption), the administrator must log on to the server via the UMS
console. When doing so, it is irrelevant whether a purely local UMS administrator account is used or the user was
adopted via an Active Directory for example. As always, however, the UMS administrator must have the permission
to shadow the object, see Object-Related Access Rights.

The device to be shadowed is called up in the structure tree and, as usual, can be executed via Shadow in the
context menu. The connection window, however, differs from the dialog for normal VNC shadowing. The IP and port
of the client to be shadowed cannot be changed, and a password for the connection is not requested - this is
superfluous after logging on to the console beforehand.

Connect with

Password

When a VNC connection has been established, the symbol in the connection tab indicates secure shadowing:

2= IGEL VNC Viewer

File Tab Help

j 10.201.1.123:
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VNC Logging

Connections via secure shadowing are always logged in the UMS. Via UMS Administration > Global Configuration
> Remote Access > Secure VNC, you can configure whether the user name of the person shadowing is to be
recorded in the log:

+ Log user for secure VNC
The user name is included in the log.
O The user name is not included in the log. (default)

The VNC log can be called up via the context menu of a device or folder (for several devices, Logging > Logging:
Secure Access Logs). The name, MAC address and IP address of the shadowed device, the time and duration of the
procedure and, if configured accordingly, the user name of the shadowing UMS administrator are logged.

Remote Access Logs x

Filter: [ I

Thin Clie... | MAC Address UnitID: | Thin ClientIP | User | Starttime | Durat .| Comment Protocal
ws-l-trunk  00:E0:C5:14:31:C0 00EOCS51431C0  172.30.91.129 Sep 30, 2016 11:54:29 AM 0 Unknown Error Secure VMC A
ws-lx-trunk  00:E0:C5:14:31:C0 00EOC51431C0 172.30.91.129 Sep 30, 2016 11:54:42 AM 58 Secure VMNC
ws-l-trunk  00:EQ0:CH:14:31:C0 00EOCH1431C0 172.30.91.129 Sep 30, 2016 11:56:31 AM 0 Shadowing triggered by IMI - Secure VMC
ws-lx-trunk 00:E0:C5:14:31:C0 O00EOCH1431C0 172.30.91.129 Sep 30, 2016 11:56:31 AM 0 Shadowing triggered by IMl - Secure VMC
ws-lx-trunk 00:E0:C5:14:31:C0 00EOCS51431C0 172.30.91.129 Sep 30, 2016 11:57:31 AM 0 Shadowing triggered by IMI - Secure VMC
ws-betrunk  00:E0:C5:14:31:C0 00EOC51431C0 172.30.91.129 Sep 30, 2016 12:03:34 PM 5 Secure VNC
ws-le-trunk  00:E0:C5:14:31:C0 00EOC51431C0 172.30.91.129 Sep 30, 2016 1:48:18 PM 219 Secure VNC
ws-letrunk  00:E0:C5:14:31:C0 00E0C51431C0 172.30.91.129 Sep 30, 2016 2:32:40 PM 1007 Secure VMNC
ws-lx-trunk 00:EQ0:C5:14:31:C0 00E0CS51431C0 172.30.91.129 Sep 30, 2016 3:25:24 PM 120 Secure VNG v

48 Logs found.

> Tosort the list (e.g. according to user names), click on the relevant column header or filter the content shown
by making entries in the Filter field.
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Cherry eGK Channel Substitution

As of firmware version 10.05.100, the Cherry eGK Channel is no longer available. In the Igel Universal Desktop
Firmware, Linux V5, the VirtualChannel for Cherry eGK devices is still included parallel to the Cherry USB2LAN Proxy.
If you want to continue using the G87-1504/ST-1503 as before, with firmware version 10.05.100 and higher you have
to activate the proxy. All settings are automatically applied and run through the connector in the network.

Using the G87-1504/ST-1503 with firmware version 10.05.100 and higher:

« Activate the proxy - this can also be done from the backend.

® « Cherry USB2LAN Proxy (Under Smartcard) (see screenshot)
« IGEL device, valid for Cherry devices G87-1505, G87-1504/ST-1503 to USB

For IGEL Lx v5 and OS10:
+ Activate Cherry USB2LAN Proxy under IGEL Setup > Security > Smartcard > Services.

V' Activate Pt Daemon

Configuration
€) [V] Cherry USB2LAN Proxy
Metwark Interface auto
User Interface
Metwork

Devices

‘ Password
» Il Logon
» I Active Directory/Kerberos
O
[

B Middleware

System

For IGEL Lx v5:

+ Disable Cherry Channel 0 and Cherry Channel 1 under IGEL Setup > Sessions > RDP > RDP
Global > Mapping > Device Support.
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« Do not activate smartcard.

Configuration

op / XenApp

‘ Local Logon
‘ Window

B Drive Mapping

B cowmPorts

ﬁ Printer

[

ﬁ Audio
‘ Performance
‘ Options
B nat edirection
B Fabuia SB Redire
B vutimedia

2] |zl Enable plugin support

2]

CenterTools DriveLock cl
Cherry Channel 0 for reading German eGK-KVK with ST-1503/G
Cherry Channel 1 for reading German with 5T-15
Grundig MMC channel for dictation with Grundig de
Channel for Dictation with Olympus Devi
5 SpeechMike Control Channel for Dictation
¥ Phili peechMike Audio Channel for Dictation

Legacy Philips SpeechMike Mixer Channel for Dictation ((

Legacy Philips Digital Pocket Memo Channel for Dictation (C

Philips Speech Channel for Dictation

Enable smartcard

Install the Cherry eGK KVK software on the server. See https://www.cherry.de/files/software/Cherry-eGK-

KVK_Software_33.zip

Install the Cherry Linux software on the device.

+ In the CT-API configuration the G87-1504/ST-1503 can be configured as network device.

+ Link to Doku Client Server Integration: https://www.cherry.de/files/manual/
64410063-01_USBLANProxyClientServerUndCitrix.pdf

« Link to the software architecture documentation:: https://www.cherry.de/files/manual/Cherry-
eGK-KVK_Sofware-Architektur_Windows-20130927-v04.pdf

() TheVirtualChannel was replaced due to the following difficulties and the future application of the
telematics infrastructure (see also gematik anforderung lan)
+ Independent of Citrix version (no need to check compatibility anymore)
+ Independent of the server version (2008, 2012...), if the connection runs via RDP

IGEL OS Articles

644 /1109



https://www.cherry.de/files/software/Cherry-eGK-KVK_Software_33.zip
https://www.cherry.de/files/manual/64410063-01_USBLANProxyClientServerUndCitrix.pdf
https://www.cherry.de/files/manual/Cherry-eGK-KVK_Sofware-Architektur_Windows-20130927-v04.pdf

Security

Single Sign-on for the Browser Proxy

Using a proxy to handle a browser's internet traffic provides additional security and control. However, if the proxy is
password-authenticated, the user has to enter their credentials, which adds some inconvenience.

With IGEL Linux version 5.08 or newer and IGEL Linux version 10.01.100 or newer, you can avoid this inconvenience
by using the passthrough feature. As a prerequisite, user logon must be carried out via Kerberos.
To enable single sign-on for the browser proxy:

1. Open the Setup and go to Security > Logon > Active Directory/Kerberos.
2. Activate Login to Active Directory/Kerberos.

IGEL Setup 10.01.120.01 (Build 5.3.27)

£ > ”~ / ™ Security * Logon ™ Active Directory/Kerberos

Configuration

B rirmware Update |

B smartcard Personalizat]
B dentify Monitors
B webcam Information
User Interface
Network
Devices
B Hardware Info
» Il Printer
¥ [J Storage Devices
B storage Hotplug
B Automount

4] Login to Active Directory Domain

B Elustooth
B USE access contral
Security
B Password
¥ [J Logen
B IGEL Smartcard
B Taskbar
|
B shared Workplace
¥ [ Active Directory/Kerbert

Login methods:

(] Explicit

] Remember last user name
[] smartcard

Logoff shortcut locations:
(/] start Menu
(] Application Launcher

[ start Menu's System tab
] Application Launcher's System tab

[ ] Desktop ] Desktop Context Menu
(] Quick Start Panel

Menu folder

Password Protection

[] Hotkey

Related Configurations

2] Active Directory /
Kerberos

Post Session
A
5] Command

Smartcard
& Middleware

Apply Ok Cancel

3. Go to Sessions > Browser > Browser Sessions > [name of the browser session] > Settings >

Proxy.
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4. In the Proxy Configuration choice, select Manual proxy configuration.
IGEL Setup 10.01.120,01 (Build 5.3.27)

s ™ Browser ™ Browser s » Browser ™ Settings ™ Proxy

Proxy Configuration | Manual proxy configuration Related Configurations

Proxy

Configuration

Im NoMachine NX Client FTP Proxy Port
» Il Parallels Client
» [ PowerTerm Terminal Ei
» I ThinLinc SSL Proxy
I ssH
» Bl VNC Viewer S0CKS Host

v 5 e SOCKS Protocal version [ SOCKS v5
¥ [ Browser Global

I Tabs No Proxy for localhost, 127.0.0.1
B content
B Frint Proxy Realm moz-proxy:{/172.30.178.10:8080
B Proxy [¥] Use Passthrough authentication
B Privacy o
B security
B Advanced Password
B Encryption
B commands [¥] Do not prompt for proxy authentication if credentials are saved
¥ [ Browser Sessions
¥ [ Browser
¥ [ settings
B Tabs
B content
| Frint
i Proxy
B Privacy
B Security
B Advanced
B Encryption
B Restart
B window
B Menus & Toolb -4
L

HTTP Proxy 172.30,178.10

Search v

Apply Ok Cancel

5. Foran HTTP proxy, define the following settings:
« HTTP proxy: IP address or hostname of the proxy to be used
+ Port: Port of the proxy for HTTP
+ No proxy for: IP addresses or hostnames of servers that can be accesses directly
+ Proxy realm: Area in which the browser authenticates itself for the proxy. Together with the
user name and password, this information is necessary for authentication.

® The Proxy realm field is internally pre-populated with the value moz-proxy://[HTTP

Proxy]: [Port] .Ifthefield is empty, this value will be used when authenticating the
browser. If the proxy expects another unknown value for the proxy realm, you can
determine this as follows: Leave the User name and Password fields empty and launch
the browser. The dialog window which appears will contain the correct value for the
Proxy realm field:

Authentication Required A X

The proxy moz-proxy:(/172.30.178.10:8080 is requesting a username and password. The
" site says:["'moz-proxy://172.30.178.10:8080"]

User Name: |

Password: | |

® cancel W 0K

In the
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example above, the value for the Proxy realm field is as follows: moz-proxy://

172.30.178.10:8080

+ Use passthrough authentication: Must be enabled to allow single sign-on for the browser

proxy.

+ Do not prompt for proxy authentication if credentials are saved: Must be enabled to
enable seamless single sign on for the browser proxy; suppresses the Authentication

Required dialog.

M NoMachine NX Client &
» [ Parallels Client
» Il PowerTerm Terminal E
» [l Thinlinc
B SSH
» [ VNC Viewer
v [ Browser
¥ [ Browser Global
B Tabs
B content
B rrint
B Proxy
B Privacy
B security
B Advanced
B Encryption
B commands
¥ [ Browser Sessions
v (3 Browser
¥ [ settings
B Tabs
B content
W Print
Prao:
B Frivacy
B security
B Advanced
B Encryption
B Restart
B window
B Menus & Toolb ‘;

Proxy Configuration

[Manua\ proxy configuration

M|

FTP Proxy Port

HTTP Proxy 172.30.178.10 Port 8080

SSL Proxy Port

S0CKS Host Port

SOCKS Protocol version |s0cKs vs M|

No Proxy for localhost, 127.0.0.1

Proxy Realm moz-proxy://172.30.178.10:8080

(] Use Passthrough authentication

(] Do not prompt for proxy authentication if credentials are saved ]

The next time the user logs in to the device, the browser proxy is ready to use.

IGEL OS Articles
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Limiting the Number of Permitted Login Attempts

Symptom

Users can attempt logging in as often and as fast as they want at the screen unlock prompt and local login prompts
(e.g. for Kerberos, Shared Workplace, IGEL Smartcard).

Problem

This leaves the system and remote sessions vulnerable to brute force login attacks.

Solution
In IGEL OS 10.03.100 and newer, the number of login attempts is limited to 5 within 30 seconds.
These values can be changed in the system registry:

1. In Setup, go to System > Registry

2. Gotothe auth.login.lockout_threshold parameter to set the maximum number of
login attempts within the specified interval.

3. Gotothe auth.login.lockout_duration parameterto settheintervalin seconds.

4. Click Apply or Ok.
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How to Deploy Device Encryption

Overview

IGEL OS 11.06 or higher offers strong device encryption that is derived from a user password. The encryption is
applied to all partitions that can contain user data, e.g. browser history or Custom Partitions.

& 'mportant Notes on Downgrading

+ If you have encrypted your IGEL OS 11.06 device, downgrading to IGEL OS 11.05 or lower
will imply data loss on the following partitions, due to different partition schemes:
+ Browsing history of the browsers Firefox and Chromium
« Custom Partitions
» The device settings and the UMS connection are preserved.
« The device encryption password must be entered by the user.

Instructions

1. Inthe UMS configuration dialog or the local Setup, go to Security > Device Encryption.
2. Setthe parameters to meet your requirements. For details, see Device Encryption for IGEL OS.

Device Encryption mode

Aauthentication type

Target time delay (ms)

Minimum password length

Minimum amount of upg

Minimum amount of numn
Minimum amount of 5 -haracters

Special characters allowed
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3. Set Device encryption mode to "activate" and click Apply and send to device or Save.

Minimum p:

Unwanted strings in pass nma separated)
The ord must contain

Minimurm amount of lower

Minimum amount of upper

Minimurm amount of numbers

Minimum amount of sg

When the settings have been sent to the device, a password dialog is presented to the user.
4. The user enters an encryption password that meets the requirements and clicks Apply.
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Device Encryption

The device encryption has been activated.

The password

* must be at least 8 characters long
» must contain at least 1 lower case letters

New password:

Password strength || jedium

Re-Enter new passw ord:|

‘esssscses

abec

Apply |

Several partitions are re-encrypted. This might take up to 60 seconds, depending on your

hardware capabilities and the size of your Custom Partition.

5. The user confirms the success message.
Information

Your credential was updated successfully.
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6. On system start, the user must enter the device encryption password.

Device encryption is active

Press ENTER to log in.
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Security: Timeout for Secure Shadowing and Secure Terminal

Overview

To avoid a denial of service attack by blocking port 30022, which is used for secure shadowing (secure VNC) and
secure terminal connections, a timeout can be configured. This timeout limits the establishing process for
connections to port 30022. The duration is 180 seconds by default and can be changed via an environment variable.

Configuring the Timeout

1. Open the UMS configuration dialog or the local Setup and go to System > Firmware
Customization > Environment Variables > Predefined.
2. Enter the following data and then click Ok:

« Variablename: IGEL TLS_ TUNNEL_TIMEOUT
+ Value: Timeout in seconds. The range is 0 t0180. When the value is set to 0, there will be no
timeout.
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Variable name #) IGEL_TLS_TUNNEL_TIMEOUT Value

\ariable name Value
Variable name Value
Variable name Value
Variable name Value
Variable name Value
‘ariable name WValue
Variable name Value
Variable name Value

Variable name Value

Apply

Some services are restarted on the device. Afterward, the timeout is set.
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+ Certificate Enrollment and Renewal with SCEP (NDES) (see page 656)
+ Deploying Trusted Root Certificates in IGEL OS (see page 675)
« Which CA Certificates Are Contained in IGEL OS? (see page 680)
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Certificate Enrollment and Renewal with SCEP (NDES)

SCEP is a protocol for certificate management that supports the secure issuance of certificates to network devices.

Requirements

& Applying Microsoft patch KB5014754%! to your NDES server may break requests for certificates from clients
using SCEP clients for authentication. This includes IGEL OS devices.
Currently, there is no official workaround or patch from Microsoft.

« SCEP server
The following SCEP server implementations can be used with IGEL OS:
« Windows 2008 Server with the Network Device Enrollment Service (NDES) role
« Windows 2012 Server
+ Windows 2016 Server
For information on how to deploy the NDES, see http://aka.ms/ndes.

« Connection between the SCEP server and the certification authority (CA).

This document explains the enrollment of certificates with SCEP.

Technical Background (see page 657)

Client Enrollment Details (see page 659)
Configuration of the SCEP Client (see page 661)
Files Involved (see page 670)

Troubleshooting (see page 671)

51 https://support.microsoft.com/en-us/topic/kb5014754-certificate-based-authentication-changes-on-windows-domain-controllers-
ad2c23b0-15d8-4340-a468-4d4f3b188f16
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Technical Background

The Simple Certificate Enrollment Protocol (SCEP) defines a way of automatically enrolling certificates for the
authentication of network devices or VPNs. The client uses HTTP requests to fetch root certificates, to send

certificate requests, and to fetch client certificates from the server.

For an in-deep description, see the Microsoft technet article "Network Device Enrollment Service (NDES) in Active

Directory Certificate Services (AD CS)" under http://aka.ms/ndes.

Here is a typical certificate enrollment process:
e

~m

CA Certilicate
i [T
L 2

Certification
Authority

Check pefmissions

(

‘

AN

Domain
Controller

Confirm permissions

Device Administator SCEP Server
—— Create key j
N Request
password
Provide
password

Set password

Send enrolln

ent request

Send RArequest _

_ Issue certificate

Return certificate

1. The device creates an RSA public-private key pair.

2. The administrator requests a challenge password from the SCEP service (e. g. NDES).

@ Thechallenge password is only required for the first enrollment request. For certificate
renewal, the current certificate is used for authentication.

3. The SCEP server asks the domain controller if the administrator holds the required permissions for

the configured certificate templates.

4. The domain controller confirms that the administrator holds the required permissions.
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e

IGE

5. The SCEP server creates a challenge password and hands it over to the administrator.

@ Typically, the challenge password expires after a defined time. With the NDES that is
included in Windows 2008 Server, the default expiry time is 60 minutes.

6. The administrator provides the device with the challenge password, the CA identifier, and the
fingerprint of the CA certificate.

7. The device sends the enrollment request to the SCEP server, using the challenge password to
authenticate with the SCEP server. This action is triggered by the administrator.

8. The SCEP server signs the enrollment request with its enrollment agent certificate and sends it to
the CA.

9. The CAissues the desired certificate and returns it to the SCEP server.

10. The SCEP server returns the certificate to the device.
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Client Enrollment Details

This section describes the actual certificate enrollment in detail. The process described here corresponds to step 7
to 10 in the overall process (see page 657).

(® Theenrollment request and the response from the CA that contains the req

1. Theclient requests the CA's public certificate from the SCEP server.

The SCEP server sends the CA's public certificate to the client.

3. Theclient checks the CA's public certificate against the relevant fingerprint. The fingerprint has
been provided by the administrator via a UMS profile; see Defining the Certification Authority (see
page 666).

4. The client sends an enrollment request to the SCEP server. This enrollment request isan HTTP GET
request that contains the following:

Signed data PKCS7 Enveloped data PKCS7 Certificate Signing Request
(PKCS 10)

N

Version
Hashing algorithm
Signed (unencrypted) data: Version

Recipient and related
encrypted data encryption
key; the recipient is the CA.

Encrypted data: Version

(encrypted with a randomly
generated key that is
encrypted with the recipient's
public key)

Requested subject name
Public key of client
Challenge password
Requested extensions
Signature algorithm
Digital signature

Client certificate

Digital signature

5. Ifthe request was successful, the HTTP response from the SCEP server includes the following data:
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Signed data PKCS7 Enveloped data PKCS7 Degenerate Certificates (only
PKCS7)

Version

Hashing algorithm

Signed (unencrypted) data:  Version
List of recipients

Encrypted data: Version
Issued X.509 certificate

CA certificate

Digital signature
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Configuration of the SCEP Client

The configuration of the SCEP client on the IGEL OS device is carried out as follows:

+ Creating a Profile in the UMS (see page 662)

+ Activating the SCEP Client (see page 663)

+ Entering the Data for the Certificate Signing Request (CSR) (see page 664)
« Defining the Certification Authority (CA) (see page 666)

+ Providing the SCEP Server Data (see page 667)

+ Applying the Profile to the Devices (see page 668)
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Creating a Profile in the UMS

1. Inthe UMS structure tree, go to Profiles, open the context menu and select New Profile.
Enter an appropriate Profile Name.
In the Based on menu, select the firmware version that is installed on the devices in question.

Click OK.
The configuration dialog opens. The configuration dialog corresponds to the IGEL Setup available

on the devices to which the profile is assigned.

Call S
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Activating the SCEP Client

1. Goto Network > SCEP Client (NDES).
2. Enable Manage Certificates with SCEP.

SCEP Certificate Enrollment

> ' I petwork * SCEP Client (NDES)

Configuration & (V] Manage Cerificates with SCEP

User Interface

» I LAN Interfaces
B Mobile Broadband
» Il DHCP Client
» Il VPN
v [ SCEF Client (MDES)
i Certificate
i Cerification Authority
B scer
» [ Routing
i Hosts
» Il Network Drives

n P rosxy

Security
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Entering the Data for the Certificate Signing Request (CSR)

» Go to Network > SCEP Client (NDES) > Certificate and enter the following data:

Type of CommonName/SubjectAltName: The characteristic for linking the certificate to the device.

IP address: The IP address of the device.

DNS name: The DNS name of the device.

IP address (auto): The IP address of the device (inserted automatically).
DNS name (auto): The DNS name of the device (inserted automatically).
Email address: An email address.

DNS name as UPN (auto)

If the client automatically obtains its network name, DNS Name (auto) is a good type for the client
certificate.

The following parameter is available if Type of CommonName/SubjectAltName is set to IP address, DNS name, or
Email address:

CommonName/SubjectAltName: Give a designation which matches the Type of CommonName/SubjectAltName.
For certain types, this occurs automatically. No entry is then required.

The following parameter is available if Type of CommonName/SubjectAltName is set to IP address (auto), DNS
name (auto), or DNS name as UPN (auto):

CommonName/SubjectAltName Suffix: Specifies a suffix that will be added to CommonName/SubjectAltName.
Possible values:

"none": No suffix will be added.
"dot + DNS domain (auto)": The system's current DNS domain name separated with a dot will be

added. Example: .1igel. local

Free text entry: The manually entered suffix will be added. Take notice that the percent symbol
"%" is used for introducing the escape sequence, and thus the following replacements take place
automatically:

+ % D isreplaced by the system's DNS domain name at the time the certificate signing
request (CSR) is created. Example: @% D will be changed into @ igel.de if the system's
current DNS domain nameis igel.de.

+ %% will be replaced by %. Example: A %% B will be changedinto A % B .

+ Other combinations with % are currently discarded. Example: A % BC will be changed
into A C.

IGEL OS Articles 664 /1109



Certificates

() Ifyou have to specify the suffix manually, make sure you enter the separator.

Organizational unit: Stipulated by the certification authority.

Organization: A freely definable designation for the organization to which the client belongs.
Locality: Details regarding the device’s locality. Example: "Augsburg".

State: Details regarding the device’s locality. Example: "Bayern".

Country: Two-digit ISO 3166-1 country code. Example: "DE".

RSA key length (bits): Select a key length (one suited to the certification authority) for the certificate that is to be
issued.
Possible values:

. "1024"
. "2048"
. "4096"

(@ TheRSAkey length specified here must not be lower than the minimum key length configured on the
server.

SCEP Certificate Enroliment

) ~ I ® Network ®™ SCEP Client (MDES) ™ Cerificate

Configuration Type of CommonMName/SubjectAliName DMNS name (auto)

CommonMame/SubjectAlthame Suffix

ries
Organizational Unit Technical Documentation
User Interface

Organization IGEL Technology

| Interfaces Locality Augsburg
bile Broadband

State Bayern
Country DE
RSA Key Length (bits)

n Authority

ts
» I Network Drives

‘ Proxy

Search

Apply and send to device Cancel
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Defining the Certification Authority (CA)

1. Goto Network > SCEP Client (NDES) > Certification Authority.
2. Enter the details for the certification authority (CA):
+ CAldentifier: FQDN (fully qualified domain name) of the CA
+ CA Certificate Fingerprint (MD5): Fingerprint of the CA certificate in the form

01:02:03:04:05:06:07:08:09:0A:0B:0C:0D:0E:0F:10

® Youcan get the fingerprint from your NDES server: https://<NDES Servername>/

certsrv/mscep_admin

ITCO00BCADS5018

) ~ I ® MNetwark ™ SCEP Client (MNDES) ™ Certification Authority

Configuration CA ldentifier |Ca-examp|8-com |

= ion CA Cerificate Fingerprint (MD5) |:lJ--i:DS:DE:D?:IJB:DEI:DA:DEI:DC:DD:DE:DF:1 D||

User Interface

» [l LAN Interfaces
B Mobile Broadband
» [ DHCP Client
» I VPN
¥ [ SCEP Client (NDES)
B Certificate
B certification Authority
B scer
» [ Routing
‘ Hosts
» [l Metwork Drives
‘ P roxy

Apply and send to thin client Save Cancel

If the CA certificate fingerprint is specified, the client will use it to check the integrity of the CA
certificate it receives from the SCEP server.
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Providing the SCEP Server Data

1. Goto Network > SCEP Client (NDES) > SCEP.
2. Enter the following data:
« SCEP server URL: URL by which the SCEP client communicates with the SCEP server.

@ HTTPS s not supported; however, all security critical data that are transferred between
the SCEP client and other components are encrypted.

+ Proxy server for SCEP requests (optional): IP address or host name of the proxy server that
is used for the communication between the device and the SCEP server. If a web application
firewall is used instead of a proxy, its IP address or host name of the proxy server must be
entered here.

« Challenge password: Password that the SCEP client must present to the SCEP server in its
request (CSR).

® 0n aMicrosoft NDES server, you can retrieve the password by default under https:///

certsrv/mscep_admin.

© By default, the password on a Microsoft NDES server is valid for 1 hour and can be used only once.
In order to use the password on numerous devices, additional settings must be made on the NDES
server. For information, see the section "Password and Password Cache" on https://
social.technet.microsoft.com®2,

+ Certificate renewal period (days): Time interval before certificate expiry after which the
certificate renewal procedure is started. (Default: 30)

« Certificate expiry check interval (days): Specifies how often the certificate is checked
against its expiry date. (Default: 1)

3. Save the settings.

52 https://social.technet.microsoft.com/wiki/contents/articles/9063.active-directory-certificate-services-ad-cs-network-device-enrollment-service-
ndes.aspx
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Applying the Profile to the Devices

1. Inthe UMS structure tree under Devices, select the devices you want to assign the profile to.
2. Inthe Assigned objects area, click €.

Z- IGEL Universal Management Suite 6
Help

< - c}’t’) Q"_I H '% J 5 Regex [ Whole Text

Server - 172.30.91.216 D O0EDC \ ned objects

¥/t IGEL Uniy nagement Suite 6

@ ITCOOEOC520986A

System Information
Advanced System Information

License Information
Monitor Information Indire
I Directory Name
Windows Updates and Hotfixes
¥ [ Devic
= Partial updates
] ITCODEOCS20986A

P 5 File Transfer status
UMS Administration

N
3. Inthe Select assignable objects dialog, select the relevant profile and click -~ to assign it.
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Select assignable objects

Selected objects

SCEP Certificate Enrollment
¥ = Firmware History (5)
10.04.100
500
10.06.100
11.01.100
11.02.100
SCEP Cerificate Enrollment
B ruesu)
Universal Firmware Upda

Firmware Customizations

4. Click Ok.
5. Inthe Update time dialog, select Now and click Ok.
The device performs the actions as described in Client Enrollment Details (see page 659).
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Files Involved

Allfiles involved are stored in the directory /wfs/scep_certificates/cert0 . The following fixed file

names are used:

cacert.pem
racert_enc.pem
racert_sig.pem
client.csr
client.cert

client.key

IGEL OS Articles

CA certificate

RA certificate used for encryption (optional)
RA certificate used for signature (optional)
Certificate signing request

Client certificate

Private key of client certificate
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Troubleshooting

+ Diagnostics (see page 672)
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Diagnostics
Preliminary: Tools

System Log Viewer

» Inthe start menu, select the system icon and then System Log Viewer.

gﬁrmware Update
ICG Agent Setup

Licensing

Network Tools

Safely Remowve Hardware

Screenshot Tool

0 Setup

Smartcard personalization

@ System Information

@System Log Viewerl
U ) Task Manager

Touchscreen Calibration
@UMS Registration
OWebcam Information

For more information on starting, using, and configuring the system log viewer, see the System Log Viewer chapter
of the IGEL OS Manual.

Local Terminal

» Start the local terminal, if available.
If a local terminal session has not been set up on your device, proceed as follows:

1. Open the Setup and go to Accessories > Terminals.
2. Click L*] to create a local terminal session.
3. Click Ok to save the setting and exit the Setup.

For more information on starting and using the local terminal, see the Terminals chapter of the IGEL OS Manual.
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Checking the Current Status of the Client Certificate Enrollment

» Inthe local terminal, enter the command cert_show_status
The status for each certificate relating to SCEP is shown:

CA certificate

RA encryption certificate
RA signature certificate
Client certificate

Reviewing Log Messages
1. Open the system log viewer and select /tmp/journal. log

2. Press [Ctrl] + [F] and enter cert_agent to search for relevant messages.

Alternatively, you can open a local terminal and enter journalctl | grep cert_agent

Reviewing the Certificates and Certificate Requests in the File System

1. Openalocal terminal and login as user .

2. Enter 1s /wfs/scep-certificates/cert0/

Deleting a Certificate Request

1. Openalocal terminal and login as root .

2. Enter rm -rf /wfs/scep-certificates/cert0/
The directory that includes the certificate request, received certificates (if existing), and the

device's own private client key, is deleted. This can be useful for debugging purposes, and if SCEP
is no longer used.

Checking the CA

1. Openalocalterminal and login as root .

2. Enter scep_getca 0

Generating an SCEP Request Manually

1. Open a local terminal and loginas root .

2. Enter scep_mkrequest 0

Enrolling a Certificate Manually

1. Opena local terminal and login as root .
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2. Enter scep_enroll 0

Testing Certificate Renewal

1. Opena local terminal and login as root .

2. Generate an SCEP request and append "new" to the key file name: scep_mkrequest 0
“new”
An SCEP request is issued. In the directory /wfs/scep-certificates/cert0/ ,thekeyfile

clientnew. key is created.

3. Renew the certificate: scep_renew 0

4. Overwrite the old certificate with the new one: mv /wfs/scep-certificates/certo/
clientnew.cert /wfs/scep-certificates/certd/client.cert

5. Overwrite the old key with the new one: mv /wfs/scep-certificates/cert0/

clientnew.key /wfs/scep-certificates/cert@/client.key

IGEL OS Articles 674 /1109



Certificates

Deploying Trusted Root Certificates in IGEL OS

IGEL OS comes with a number of trusted root certificates from certain Certificate Authorities (CA) pre-installed. For
a complete list of pre-installed root certificates, see Which CA Certificates Are Contained in IGEL OS? (see page 680)

Certificates signed with these root certificates can be used for server authentication and encryption in ICA, RDP,
Horizon, and browser sessions. You can also verify the origin of Java applications.

Nevertheless, the root certificate you need might be missing. This document explains how to load and distribute it.

Requirements

The certificates must be available in the Base64 file format encoded with the file extension .pem, .crt

or .cer.

To check the file format, open the certificate with a text editor. It should look like this:

—————BEGIM CERTIFICATE---—--
MIIDWzCCAkOQAWT BAQIQAGEd BwW7LVOGMDG
MROWEDYKCZIMI ZPyLGOEGRYEDGYZADET

EimjpsngJsngHMQmmyS'29285062u3
JUZN3 VT ZTUZ 50w+ Do H M O P2y D 2y
————— EMD CERTIFICATE-----

Solution

Deploying Certificates via the UMS

We recommend using IGEL Universal Management Suite (UMS) when you need to deploy certificates, especially if
you have to do this for multiple endpoint devices.

You can load certificates in the UMS Console via Files > New file: simply select your certificate file under Local file,
select the suitable Classification of the certificate, and assign the certificate file to the required devices; see Files -
Registering Files on the IGEL UMS Server and Transferring Them to Devices.

We advise you to use the following file transfer types for distributing the certificates via the UMS:

Type To be used for

Undefined All-purpose class, you need to set the owner and access
permissions manually.

Web Browser Certificate Server authentication/encryption of HTTPS websites in
browsers
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Type To be used for
SSL Certificate Server authentication/encryption in ICA, RDP, or Horizon
sessions

Authentication via Active Directory (AD)

Java Certificate Authentication/encryption for Java applications

IBM iAccess Certificate Server authentication/encryption for IBM iAccess
sessions

Common Certificate (all-purpose) Multiple applications needing a certificate, e.g. if you

want to launch an ICA session in a browser or if you want
to secure a Java session on a secure website.

With these file transfer types, you will not need to reboot after installing.

Providing Certificates Manually

If you want to install certificates manually, see Installing Certificates Manually in IGEL OS (see page 677).
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Installing Certificates Manually in IGEL OS

A certificate you require is not pre-installed in IGEL OS and, for some reason, you do not want to use the IGEL
Universal Management Suite (UMS) for certificate deployment, see Deploying Trusted Root Certificates in IGEL
OS (see page 675). In this case, you can install certificates manually. A USB flash drive can be used for the manual
import of certificates.

Importing SSL Certificates (ICA, RDP, Horizon)

If a CA certificate is missing for RDP, ICA, or VMware Horizon, you can copy it from a USB storage device to the
endpoint device:

1. Connect your USB storage device to the endpoint.

2. Launch a Terminal session or press [CTRL]+[ALT]+[F11] to log in as ROOT on the Linux console of
the endpoint.

3. Create a directory for certificates:
mkdir /wfs/ca-certs

4. Change to the directory:
cd /wfs/ca-certs

5. Get the name of your USB storage device:
1ls /userhome/media

6. Copy the certificate to the endpoint:
cp /userhome/media// /wfs/ca-certs

7. Check whether the certificate was transferred:
1ls -al /wfs/ca-certs

8. End the terminal session or press [CTRL]+[ALT]+[F1] to exit the console.

() The certificates you have saved will be available when you boot up the endpoint next time.
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Installing Web Browser Certificates
Use the Firefox Certificate Manager in order to manually install web browser certificates:

1. Open the IGEL Setup.

2. Click Sessions > Firefox Browser > Firefox Browser Global > Certificates > View Certificates to
open the Firefox Certificate Manager.

£ > ~ L ns * Fire er » Fi

Configuration When a we e rec e Select one automatically
» [ ThinLinc

Certificate Validation Validate a certificate if it specifies an OC

server connection fails, treat the certificate as invalid
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3. Inthe Authorities tab, click Import... to import a new certificate from a directory or a USB flash
drive.

Certificate Manager p ot

Your Certificates Authentication Decisions People Servers Authorities

You have certificates on file that identify these certificate authorities

Certificate Name | security Device |

o |

« AC Camerfirma S.A.

Chambers of Commerce Root - 2008 Builtin Object Token
Global Chambersign Root - 2008 Builtin Object Token
« AC Camerfirma SA CIF A8B2743287

Camerfirma Chambers of Commerce ... Builtin Object Token

Camerfirma Global Chambersign Root  Builtin Object Token

Ay

View... Edit Trust... Export... Delete or Distrust...

() Manually installed certificates will be saved permanently without any further configuration.
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Which CA Certificates Are Contained in IGEL OS?

The following CA certificates are contained in IGEL OS 11.08.330:

Certificate name

ACCVRAIZ1
AC RAIZ FNMT-RCM

AC RAIZ FNMT-RCM SERVIDORES
SEGUROS

ANF Secure Server Root CA

Actalis Authentication Root CA

AffirmTrust Commercial

AffirmTrust Networking

AffirmTrust Premium

AffirmTrust Premium ECC

Amazon Root CA 1
Amazon Root CA 2
Amazon Root CA3

Amazon Root CA 4

IGEL OS Articles

Expiry date File in /etc/ssl/certs
Dec 31 09:37:37 2030 GMT ACCVRAIZ1.crt
Jan 1 00:00:00 2030 GMT AC_RAIZ_FNMT-RCM.crt

Dec 20 09:37:33 2043 GMT AC_RAIZ_FNMT-

RCM_SERVIDORES_SEGUROS.c
rt

Aug 30 10:00:38 2039 GMT ANF_Secure_Server_Root_
CA.crt

Sep 2211:22:022030 GMT Actalis_Authentication._
Root_CA.crt

Dec 31 14:06:06 2030 GMT  Aff4rmTrust_Commercial.

crt

Dec 31 14:08:24 2030 GMT AffirmTrust_Networking.

crt
Dec 31 14:10:36 2040 GMT  Aff4irmTrust_Premium.crt

Dec 31 14:20:24 2040 GMT  Aff4irmTrust_Premium_ECC

.Ccrt

Jan 17 00:00:00 2038 GMT Amazon_Root_CA_l.Crt
May 26 00:00:00 2040 GMT Amazon_Root_CA_z.Crt
May 26 00:00:00 2040 GMT Amazon_Root_CA_3.Crt

May 26 00:00:00 2040 GMT Amazon_Root_CA_4 .Crt
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Certificates

Certificate name

Atos TrustedRoot 2011

Autoridad de Certificacion
Firmaprofesional CIF A62634068

Autoridad de Certificacion
Firmaprofesional CIF A62634068

Baltimore CyberTrust Root

Buypass Class 2 Root CA

Buypass Class 3 Root CA

CA Disig Root R2
CFCAEV ROOT

COMODO Certification Authority

COMODO ECC Certification
Authority

COMODO RSA Certification
Authority

Certainly Root E1

Certainly Root R1

IGEL OS Articles

e

IGE

Expiry date File in /etc/ssl/certs

Dec 3123:59:59 2030 GMT Atos TrustedRoot 2011.c

rt

Dec 3108:38:152030 GMT Ayutoridad_de_Certificac
jon_Firmaprofesional_CIF
_A62634068.crt

May 5 15:22:07 2036 GMT  Autoridad_de_Certificac
jon_Firmaprofesional_CIF

_A62634068_2.crt

May 12 23:59:00 2025 GMT Baltimore_CyberTrust_Ro

ot.crt

.crt
.crt

Jul 19 09:15:30 2042 GMT CA_Disig_Root_R2.crt

Dec 3103:07:01 2029 GMT CFCA_EV_ROOT.crt

Dec 3123:59:59 2029 GMT  cOMODO_Certification_Au
thority.crt

Jan 18 23:59:59 2038 GMT  cOMODO_ECC_Certificatio
n_Authority.crt

Jan 18 23:59:59 2038 GMT  cOMODO_RSA_Certificatio
n_Authority.crt

Apr100:00:00 2046 GMT  Certainly_Root_El.crt

Apr100:00:00 2046 GMT  Certainly_Root_R1l.crt
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Certificates

Certificate name

Certigna
Certigna Root CA
Certum EC-384 CA

Certum Trusted Network CA

Certum Trusted Network CA 2

Certum Trusted Root CA

AAA Certificate Services

D-TRUST BR Root CA 12020

D-TRUST EV Root CA 12020

D-TRUST Root Class 3 CA 2 2009

D-TRUST Root Class3CA2 EV
2009

DigiCert Global Root CA

IGEL OS Articles

Expiry date
Jun 29 15:13:05 2027 GMT

Oct 1 08:32:27 2033 GMT
Mar 26 07:24:54 2043 GMT

Dec 3112:07:37 2029 GMT

Oct 6 08:39:56 2046 GMT

Mar 16 12:10:13 2043 GMT

Dec 31 23:59:59 2028 GMT

Feb 11 09:44:59 2035 GMT

Feb 11 09:59:59 2035 GMT

Nov 5 08:35:58 2029 GMT

Nov 5 08:50:46 2029 GMT

File in /etc/ssl/certs

Certigna.crt
Certigna_Root_CA.crt
Certum_EC-384_CA.crt

Certum_Trusted_Network_

CA.crt

Certum_Trusted_ Network_
CA_2.crt

Certum_Trusted_Root_CA.

crt

Comodo_AAA_Services_roo

t.crt

D_
TRUST_BR_Root_CA_1_2020.

crt

D_
TRUST_EV_Root_CA_1_2020.

crt

D_
TRUST_Root_Class_3_CA_2_
2009.crt

D_
TRUST_Root_Class_3 CA_2_
EV_2009.crt

Nov 10 00:00:00 2031 GMT p4giCertGlobalRootCA.pe

m)
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Certificates

Certificate name

DigiCert Assured ID Root CA

DigiCert Assured ID Root G2

DigiCert Assured ID Root G3

DigiCert Global Root CA

DigiCert Global Root G2

DigiCert Global Root G3

DigiCert High Assurance EV Root

CA

DigiCert TLS ECC P384 Root G5

DigiCert TLS RSA4096 Root G5

DigiCert Trusted Root G4

E-Tugra Global Root CAECC v3

IGEL OS Articles

e

IGE

Expiry date File in /etc/ssl/certs

t_CA.crt

Jan 15 12:00:00 2038 GMT D-i g-i Ce rt_ASSU red_ID_Roo
t_G2.crt

t_G3.crt

Nov 10 00:00:00 2031 GMT pigiCert_Global Root_ CA

.Ccrt

Jan 1512:00:00 2038 GMT pigicCert_Global Root G2

.crt

Jan 15 12:00:00 2038 GMT p+ giCert_Global_Root_G3

.crt

Nov 10 00:00:00 2031 GMT DigiCert_High_Assurance
_EV_Root_CA.crt

Jan 14 23:59:59 2046 GMT  p4giCert_TLS_ECC_P384_R
oot_G5.crt

Jan 14 23:59:59 2046 GMT DigiCert_TLS_RSA4096_Ro
ot_G5.crt

Jan 1512:00:00 2038 GMT pigiCert_Trusted_Root_G
4.crt

Mar 12 09:46:58 2045 GMT g—
Tugra_Global_Root_CA_ECC

_v3.crt
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Certificates

Certificate name

E-Tugra Global Root CARSA v3

Entrust.net® Certification
Authority (2048)

Entrust Root Certification
Authority

Entrust Root Certification
Authority - EC1

Entrust Root Certification
Authority - G2

Entrust Root Certification
Authority - G4

GDCA TrustAUTH R5 ROOT

GLOBALTRUST 2020
GTS Root R1
GTS Root R2
GTS Root R3
GTS Root R4

GlobalSign

53 http://Entrust.net

IGEL OS Articles

Expiry date
Mar 12 09:07:17 2045 GMT

Jul 24 14:15:12 2029 GMT

File in /etc/ssl/certs

E_

Tugra_Global_Root_CA_RSA

_v3.crt

Entrust.net_Premium_204

8 Secure_Server_CA.crt

Nov 27 20:53:42 2026 GMT Entrust_Root_Certificat

Dec 18 15:55:36 2037 GMT

Dec 7 17:55:54 2030 GMT

Dec 27 11:41:16 2037 GMT

Dec 31 15:59:59 2040 GMT

Jun 10 00:00:00 2040 GMT

Jun 22 00:00:00 2036 GMT

Jun 22 00:00:00 2036 GMT

Jun 22 00:00:00 2036 GMT

Jun 22 00:00:00 2036 GMT

Jan 19 03:14:07 2038 GMT

jon_Authority.crt

Entrust_Root Certificat
jon_Authority_-_ECl.crt

Entrust_Root_Certificat
jon_Authority_-_G2.crt

Entrust_Root_Certificat
jon_Authority_-_G4.crt

GDCA_TrustAUTH_R5_ROOT.

crt
GLOBALTRUST_2020.crt
GTS_Root_Rl.crt
GTS_Root_R2.crt
GTS_Root_R3.crt
GTS_Root_R4.crt

GlobalSign_ECC_Root_CA_
- _R4.crt
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Certificates

Certificate name

GlobalSign

GlobalSign Root CA

GlobalSign

GlobalSign

GlobalSign Root E46
GlobalSign Root R46

Go Daddy Class 2 Certification
Authority

Go Daddy Root Certificate
Authority - G2
HARICA TLS ECC Root CA 2021

HARICA TLS RSA Root CA 2021

Hellenic Academic and Research
Institutions ECC RootCA 2015

Hellenic Academic and Research
Institutions RootCA 2015

HiPKI Root CA - G1

IGEL OS Articles

e

IGE

Expiry date File in /etc/ssl/certs

Jan 19 03:14:07 2038 GMT  G1lobalsSi gn_ECC_Root_CA_
- _R5.crt

Jan 28 12:00:00 2028 GMT  GlobalSign_Root_CA.crt

Mar 18 10:00:00 2029 GMT G1obalSign_Root_CA_-
_R3.crt

Dec 10 00:00:00 2034 GMT G1obalSign Root CA_-

_R6.crt
Mar 20 00:00:00 2046 GMT G1obalSign_Root_E46.crt
Mar 20 00:00:00 2046 GMT  G1obalSign_Root_R46.crt

Dec 3123:59:59 2037 GMT Go_paddy Root_Certdfica
te_Authority_-_G2.crt

Feb 13 11:01:09 2045 GMT HARICA TLS_ECC_Root_ CA_
2021.crt

Feb 13 10:55:37 2045 GMT HARICA_TLS_RSA_Root CA_
2021.crt

esearch_Institutions_ECC

_RootCA_2015.crt

Jun3010:11:21 2040 GMT  Hellenic_Academic_and_R
esearch_Institutions_Roo

tCA_2015.crt

Dec 31 15:59:59 2037 GMT H4pPKI_Root CA - Gl.crt
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Certificates

Certificate name

Hongkong Post Root CA 1

Hongkong Post Root CA 3

ISRG Root X1
ISRG Root X2

IdenTrust Commercial Root CA 1

IdenTrust Public Sector Root CA 1

Imprivata Embedded Code
Signing CA

lzenpe.com®

Microsec e-Szigno Root CA 2009

Microsoft ECC Root Certificate
Authority 2017

Microsoft RSA Root Certificate
Authority 2017

NAVER Global Root Certification
Authority

54 http://Izenpe.com
55 http://Izenpe.com

IGEL OS Articles

e

IGE

Expiry date File in /etc/ssl/certs

.crt

Jun 302:29:46 2042 GMT Hongkong_Post_Root_CA_3

.Ccrt

Jun411:04:382035GMT  1SRG_Root_X1l.crt

Sep 17 16:00:00 2040 GMT TSRG_Root_X2.crt

Jan 16 18:12:23 2034 GMT  1denTrust_Commercial_Ro
ot_CA_l.crt

Jan 16 17:53:32 2034 GMT  1denTrust_Public_Sector

_Root_CA_1l.crt

Sep 7 16:20:00 2033 GMT Imprivata.crt

Dec 13 08:27:25 2037 GMT Izenpe.com®.crt

Dec 30 11:30:18 2029 GMT yicrosec_e-

Szigno_Root_CA_2009.crt

Jul1823:16:04 2042 GMT M4 crosoft_ECC_Root_Cert

ificate_Authority_2017.c

rt
Jul1823:00:232042 GMT  Microsoft_RSA_Root_Cert
ificate_Authority_2017.c

rt

Aug 18 23:59:59 2037 GMT NAVER_Global Root_Certi

fication_Authority.crt
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Certificates

Certificate name

NetLock Arany (Class Gold)
F6tanusitvany

OISTE WISeKey Global Root GB CA Dec 1 15:10:31 2039 GMT

OISTE WISeKey Global Root GC CA May 9 09:58:33 2042 GMT

QuoVadis Root CA1G3

QuoVadis Root CA 2

QuoVadis Root CA2 G3

QuoVadis Root CA3

QuoVadis Root CA3 G3

SSL.com®® EV Root Certification
Authority ECC

SSL.com®” EV Root Certification

Authority RSA R2

SSL.com®® Root Certification
Authority ECC

56 http://SSL.com
57 http://SSL.com
58 http://SSL.com

IGEL OS Articles

e

IGE

Expiry date File in /etc/ssl/certs

Dec 615:08:212028 GMT  Netlock_Arany =Class_Go

ld=_F6tanusitvany.crt

OISTE_WISeKey_Global_Ro
ot_GB_CA.crt

OISTE_WISeKey_Global_Ro
ot_GC_CA.crt

rt
Nov 24 18:23:33 2031 GMT Qroad-i S_ROOt_CA_Z .crt
Jan 1218:59:322042 GMT QuoVvadis_Root_CA_2 G3.c

rt

Jan 12 20:26:32 2042 GMT Qroad-i S_ROOt_CA_3_G3 .C

rt
Feb 12 18:15:23 2041 GMT SS| . com_EV_Root_Certifi

cation_Authority_ECC.crt

May 30 18:14:37 2042 GMT 55| . com_EV_Root_Certifi
cation_Authority_RSA_R2.

crt

Feb 12 18:14:03 2041 GMT sS| . com_Root_Certificat
jon_Authority_ECC.crt
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http://SSL.com
http://SSL.com
http://SSL.com

Certificates

e

IGE

Certificate name Expiry date File in /etc/ssl/certs
Authority RSA . .
jon_Authority_RSA.crt
SZAFIR ROOT CA2 Oct1907:43:30 2035 GMT SZAFIR_ROOT_CA2.crt
SecureTrust CA Dec 31 19:40:552029 GMT secureTrust _CA.crt

Security Communication ECC Jan 18 05:15:28 2038 GMT  security_Communication_
RootCAl

ECC_RootCAl.crt

Security Communication RootCA2 May 29 05:00:39 2029 GMT Security_Communication_
RootCA2.crt

Security Communication RootCA3 Jan 18 06:17:16 2038 GMT Security_Communication_
RootCA3.crt

Security Communication RootCAl Sep 30 04:20:49 2023 GMT Security_Communication_
Root_CA.crt

Starfield Class 2 Certification Jun2917:39:16 2034 GMT starfield Class_2 CA.cr

Authority .

Starfield Root Certificate AuthorityDec 31 23:59:59 2037 GMT s+tarfield_Root_Certific

62 ate_Authority_-_G2.crt

Starfield Services Root Certificate Dec 3123:59:59 2037 GMT starfield _Services_Root

Authority - G2 L. .
_Certificate_Authority_-

_G2.crt
SwissSign Gold CA - G2 Oct 25 08:30:35 2036 GMT  SyissSign_Gold_CA_-
_G2.crt

59 http://SSL.com
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Certificates

Certificate name

SwissSign Silver CA - G2

T-TeleSec GlobalRoot Class 2

T-TeleSec GlobalRoot Class 3

TUBITAK Kamu SM SSL Kok

Sertifikasi - Surum 1

TWCA Global Root CA

e

IGE

Expiry date File in /etc/ssl/certs

Oct 25 08:32:46 2036 GMT SwissSign_Silver_CA_-
_G2.crt
Oct 123:59:59 2033 GMT  T-

TeleSec_GlobalRoot_Class
_2.crt

Oct123:59:59 2033 GMT  1-
TeleSec_GlobalRoot_Class
_3.crt

Oct 25 08:25:55 2043 GMT TUBITAK _Kamu_SM_SSL_Kok
_Sertifikasi_-

_Surum_1l.crt

TWCA Root Certification Authority Dec 31 15:59:59 2030 GMT TyCA Root_Certification

TeliaSonera Root CA vl

Telia Root CAv2
TrustCor ECA-1

TrustCor RootCert CA-1

TrustCor RootCert CA-2

Trustwave Global Certification
Authority

IGEL OS Articles

_Authority.crt

crt

Nov 29 11:55:54 2043 GMT Telia_Root CA v2.crt

Dec 3117:28:07 2029 GMT TrystCor ECA-1.crt

Dec3117:23:16 2029 GMT TrystCor_RootCert_CA-1.

crt

Dec 3117:26:39 2034 GMT TryustCor_RootCert_CA-2.

crt

Aug2319:34:122042GMT Trystwave_Global_Certif

ication_Authority.crt
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Certificates

Certificate name

Trustwave Global ECC P256
Certification Authority

Trustwave Global ECC P384
Certification Authority

TunTrust Root CA

UCA Extended Validation Root

UCA Global G2 Root

USERTrust ECC Certification
Authority

USERTrust RSA Certification
Authority

XRamp Global Certification
Authority

certSIGN ROOT CA
certSIGN ROOT CA G2

e-Szigno Root CA 2017

ePKI Root Certification Authority

emSign ECC Root CA-C3

IGEL OS Articles

e

IGE

Expiry date File in /etc/ssl/certs

Aug 23 19:35:10 2042 GMT Trystwave_Global_ECC_P2
56_Certification_Authori
ty.crt

Aug 23 19:36:43 2042 GMT Trystwave_Global ECC_P3
84 Certification_Authori
ty.crt

Apr 26 08:57:56 2044 GMT  TynTrust_Root_CA.crt

Dec 31 00:00:00 2038 GMT ycaA Extended Validation

_Root.crt

Jan 18 23:59:59 2038 GMT ySERTrust_ECC_Certifica
tion_Authority.crt

Jan 1823:59:59 2038 GMT ySERTrust_RSA_Certifica
tion_Authority.crt

Jan 105:37:19 2035 GMT XRamp_Global_CA_Root.Cr
t

Jul417:20:04 2031 GMT  certSIGN_ROOT_CA.crt

Feb 6 09:27:352042 GMT  certSIGN_Root_CA_G2