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Update and Upgrade

Update and Upgrade

+ Buddy Update (see page 4)

+ Firmware Update (see page 10)

+ Updating the Firmware using a USB Storage Device (see page 13)
+ Updating the Firmware using the Linux Console (see page 14)
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Update and Upgrade

Buddy Update

A certain number of IGEL thin clients or UDC3 converted devices in your company regularly need to be updated. If
every device accesses the main update server individually, maybe even over a great geographical distance, the
update could take quite a long time and might overload the entire connection.

Update
Server

~ Internal network e

-
- -

Set up one of your clients as a so-called buddy update server. In the future, only this client will access the main
server to download the updates. All other clients access the local buddy update server from within the network and
will no longer offload the network outside.
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Update and Upgrade

Update
Server

) - - o N N

7 - - ~
.7 Buddy Update
L7 (FTP-) Server ~.
4 Y
4 A Y
4 \
’ \
'

\
II A \‘
7 \
! 1
Y 1
] \
T 1
I 1
! 1
I 1
! |
" i
! 1
! 1
' 1
' I
\
\ Y r’
‘ I}
v ’
° ’
» ’
\
\ ,'
» ’
S ¢
N N . ’
) ’
S s
~ - -~
S o Internal network Phe

_________

(@ Thebuddy update server is always an FTP server.

For the configuration details, see:

+ Settings on the Buddy Update Server (see page 7)
+ Settings on the Client Side (see page 8)

TechChannel
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Update and Upgrade

Sorry, the widget is not supported in this export.
But you can reach it using the following URL:

https://www.youtube.com/watch?v=IVUIFtOT5uE
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Update and Upgrade 1

Settings on the Buddy Update Server
Configure the Buddy Update Server:
1. Click System > Update > Buddy Update.

Configuration ﬁ ﬂ l

Firmraeare Update Buddy Update

A

[z] Enable Update Server

Uzer Mame | igel
— !| Password ********l
— Time and Date
¥ Update M. Concurrert Logins |1III

= Firmwvare Update
~  Buddy Update
» o Remote management

Activate Enable Update Server.

Enter the credentials User Name and Password.

Specify the maximum number of Concurrent Logins allowed.
Click Save to confirm the changes.

Perform a complete Firmware Update on the server.

Reboot the server.

Nouohkwn

@ Whenever a buddy update server has received a firmware update, it needs to be rebooted
before it can distribute the new firmware to other clients.
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Update and Upgrade

Settings on the Client Side

Configure your clients:

1. Click System > Update > Firmware Update.
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¥ Update
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¥ ReaE =zer Name
k. Remote managemeant
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Power Management v () Automatic Update Check

[ ] automatic Buddy Detection

2. Setthe following parameters:
Server Name: IP-address of the buddy update server
Port: 21 (default with FTP protocol)
Server Path: -
User Name, Password of the buddy update server.

3. Activate Automatic Update Check if you want the client to check automatically during the boot
process whether new updates are available on the server.

4. Activate Automatic Buddy Detection if you want the client to look for a buddy update server on
its own.
This is useful if you work with more than one buddy update server and do not wish to determine a
specific one.
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Update and Upgrade

."._ Buddy Update
FTP Server

b

|nternal network

In this case, you do not need to define the Server Name, Port, and Server Path. If you enter a
server name anyway, the system treats this server as a fall-back. Thus, you can be sure that the
system accesses at least this one server if it cannot find any others.

@ Ensure that all servers in the network use the same credentials. For security reasons, you
have to enter them in the upper mask, even if you did not specify a certain server.
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Update and Upgrade

Firmware Update

Here we show you the best practice of downloading a firmware update from our download server and distributing it
to various devices in your company:

1. Check our download server! to see whether there are new updates which are relevant for your
applications.

2. Download the relevant update files.
3. Install an update directory for them on the UMS server or on your FTP server.
4. Assign this update directory to your devices.
5. Start the update process manually or via a Scheduled Job (see page 12).
Download
server
A FTP
Server 3 Assign updates
o >
(2]
Q
£ A
©
(o
=
> A
@©
o
E 2 Download updates
(O]
<
4 Execute updates

+ Downloading Updates and Storing them on an FTP Server (see page 11)
+ Executing an Update Process (see page 12)

1 https://www.igel.com/software-downloads/
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Update and Upgrade

Downloading Updates and Storing them on an FTP Server

You can save the update files either directly on the UMS server or you can put them on your captive FTP server. If
you have many devices to be updated, you should work with the FTP server because it makes it easier to distribute
large amounts of data in the local network.

Preparation

1. Click Universal Firmware Update in the UMS Administration area of UMS console.
Click Edit... .

Enter your FTP server under Host, to save the update files in this location.

Add further details like storage path and access data for the server.

Save your settings and click Test Server Connection.

ok N

Downloading updates

1. Right-click Universal Firmware Update on the UMS console tree.

2. Choose Check for new firmware updates from the context menu.

A window opens with a list of all updates associated with the firmware versions registered in the
UMS database.

Choose a Version in the drop-down-list.

Click Information to see the release notes of each update.

Activate the check box Include for downloading a certain update.

Click Download to start the process.

The update will be added to the tree and the current processing status will be shown.

The unpacked firmware files are finally in the target directory on the FTP server.

oA W

Assigning updates to the thin clients

Assign the downloaded update by dragging and dropping to your device directory. Now, if you click this directory
you can see the firmware update in the right window under Assigned objects. The devices will now know where to
find the firmware update in the event of an update command.
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Update and Upgrade

Executing an Update Process

1. Create one or more new Views to distinguish which thin clients will get the new update.
2. Create a new Job, called "firmware update" for example.
. Specify on the Schedule tab when you want the update to be performed.

w

(@ The Repeat job option should not be activated for Update, Update on boot or Update on
shutdown commands.

4. Add one or more Views on the Assignment tab.
5. Save thejob.

The update process will be performed according to the schedule specified in the job.

IGEL OS Articles 12 /543



Update and Upgrade

Updating the Firmware using a USB Storage Device

You can use a USB storage device to update the firmware locally. This method is particularly suitable if only one
device or only a few devices are to be updated and it would not be worth installing an FTP or HTTP server purely for
the update. Proceed as follows:

1. Download the update file (.zip) for your device from the IGEL download server?,
2. Unpack the update files and save them to a USB storage device.

@ You can find the officially supported file systems under Storage Hotplug.

In the local setup application select Devices > Storage Devices > Storage Hotplug.
Set Client Drive Mapping to Static

Enable Private drive letter for each storage drive.

Set Number of drives to at least 1.

Apply the changes so that they are effective for the device.

Noobhw

@ You can find more informations in the chapter Storage Hotplug.

8. Connect the USB storage device to the thin client and wait until the device has been detected.
9. Go to System > Update > Firmware Update.
10. SetProtocol to FILE.

11. Start the file chooser (Server Path) and navigateto /userhome/media/label of the

file system/udlx.inf andclick Open.
12. Click Update Firmware and confirm the warning message.

The device will reboot while updating the firmware. Do not remove the USB device until the update has finished.

& Make sure you do not boot from the USB storage device. You might need to change the boot order in the
BIOS/UEFI.

To update the device's firmware without having access to the local setup, follow FAQ Updating the Firmware using
the Linux Console (see page 14).

2 https://www.igel.com/software-downloads/workspace-edition/
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Update and Upgrade

Updating the Firmware using the Linux Console

Issue

You have to update the device's firmware without IGEL Universal Management Suite or local IGEL Setup application.

Solution
The device's firmware update can also be carried out directly on the Linux console itself without IGEL Setup:

1. Restartthe device.

Press [ESC ]key during booting to bring up the boot menu.

Select Verbose Boot from the boot menu.

When instructed, switch to the console by pressing [CTRL-ALT-F11] or [CTRL-ALT-F12].
Press [RETURN Jkey to login.

You may have to enter your password.

oW

Carry out the update. The exact procedure varies according to the protocol which is to be used, that is, FILE, HTTP,
or FTP; see the instructions below. You can check whether the correct parameter values have been passed using the

get command,e.g. get update.protocol

HTTP

1. If necessary, set up a static IP address (DHCP is active by default)
setparam network.interfaces.ethernet.device0.usedhcp false

setparam network.interfaces.ethernet.device®.manual true
setparam network.interfaces.ethernet.device0.ipaddr

setparam network.interfaces.ethernet.device®.netmask
2. Configure the update server
setparam update.protocol http

setparam update.http.server

setparam update.http.port

® The default UMS portis 9080

setparam update.http.path
setparam update.http.user

setcryptparam update.http.crypt_password
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Update and Upgrade

3. Startthe update processinthe / directory usingthe command update

FTP

1. If necessary, set up a static IP address (DHCP is active by default)
setparam network.interfaces.ethernet.device0.usedhcp false

setparam network.interfaces.ethernet.device®.manual true
setparam network.interfaces.ethernet.device0.ipaddr

setparam network.interfaces.ethernet.device®.netmask
2. Configure the update server
setparam update.protocol ftp

setparam update.ftp.server

setparam update.ftp.port

® The default portis 21

setparam update.ftp.path
setparam update.ftp.user
setcryptparam update.ftp.crypt_password

3. Startthe update processinthe / directory usingthe command update

FILE

(@ Requirement: The unpacked update files are available in the root directory of a USB storage device.

1. Configure at least one hotplug USB device:

setparam devices.hotplug.usb-storage.numdevices 1
2. Apply your changes:

kill_postsetupd

Connect the USB storage device to the device.
Wait for the USB storage device to be mounted automatically.
5. Determine the mount point:

1ls /media/
6. Configure the update parameters:

> w

setparam update.protocol file

setparam update.file.path /media/<name of USB storage device>
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7. Startthe update processinthe / directory usingthe command update
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Citrix
« Performance (see page 18)
* Mouse (see page 30)
« Mapping USB Storage Media into Citrix Sessions (see page 35)
+ Auto-Hide Toolbar in Appliance Mode (see page 37)
« Changing Appliance Mode Picture (see page 38)
+ Create a Seamless, Transparent User Experience with Appliance Mode (see page 40)
« Connecting to a Citrix Farm (see page 41)
+ Create a Self-Service Setup for the User with Quick Settings (see page 55)
« Citrix: Changing Password Issue (see page 57)
+ Login Failed because of the Expired AD Password (see page 58)
+ Configuring Auto Logon for XenDesktop (see page 60)
+ Force Citrix Logout Using Hotkey (see page 61)
« Citrix: Freeze at Logout (see page 62)
« Warning Message: [Citrix Store] Could Not Connect to the Citrix Server (see page 64)
« Setting up Citrix Sessions with Hardware-Accelerated H.264 Deep Compression Codec (see page 66)
+ Using Font Smoothing (ClearType) in Citrix Sessions (see page 67)
« Workaround for Citrix Receiver X Error (see page 69)
o Citrix HTML5 Receiver Issue (see page 70)
« ICA screen artifacts in Lotus Notes, OpenOffice, etc. (see page 71)
+ Macbook Keyboard Layout inside Citrix Session (see page 72)
+ Using Lync / Skype for Business with Citrix HDX RealTime Optimization Pack (see page 73)
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Performance

« Citrix Performance Enhancements (see page 19)

+ Poor Performance: Black Blocks and Stripes in Citrix Sessions (see page 22)

+ Poor Performance with Citrix XenDesktop 7.6 Deep Compression (see page 23)
« Citrix: Deep Compression Flickers (see page 24)

« Citrix Receiver: Grey Blocks in Excel 2013 (see page 25)

« Bar Code Scanning is Slow via Citrix (see page 26)

« Citrix Webinterface 5.x Delay on First Page (see page 27)

« Slow Performance of Citrix Session in a Cloud Environment (see page 28)
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Citrix

Citrix Performance Enhancements

Symptom

Citrix users have performance issues (bad user experience).

Problem

IMPORTANT: There is a big difference between locally defined ICA sessions on one hand, and Program
Neighborhood or Webinterface sessions on the other in terms of configuration:

+ Locally defined ICA sessions are configured in the Thin Client Setup or IGEL Universal Management
Suite (UMS), either with the configuration pages or in the registry.
« Program Neighborhood sessions are configured on the server side, by editing the file

default.ica (create abackup first!) thatis located in the folder c:

\inetpub\wwwroot\Citrix\PNAgent\conf (if you did not use the default settings during

Cirix Webinterface installation, the path may vary).
+ Webinterface sessions (which are started via browser or in Appliance Mode) are similar to Program

Neighborhood sessions, but the file default.ica islocatedin c:

\inetpub\wwwroot\Citrix\XenApp\conf (default path).

Solution
1. Reducing network load:

+ Compression:
Enabling the parameter Compression lowers used network bandwidth at the cost of increased
cpu load.
+ ICAsessions: Go to ICA > ICA Sessions > Name > Options, parameter Compress
« PN/Webinterface: Add Compress in the section [Application], values: On/Off
+ Persistent Cache:
Setting the parameter Persistent Cache Enabled has the potential to greatly reduce network load
in later sessions when using the same applications.
+ ICAsessions: Go to ICA > ICA Sessions > Name > Options, parameter Persistent Cache
Enabled
« PN/Webinterface: Add PersistentCacheEnabled in the section [Application] , values: On/
off

Please note that the persistent cache is located in the system's RAM by default - meaning it will
survive a suspend, but not a reboot or shutdown. If you want it to be truly persistent (may lower
lifetime of the system's flash module) you have to create a custom partition and set the parameter
PersistentCachePath accordingly.

« ICAsessions: Go to ICA > ICA Global > Options , parameter Persistent Cache Path
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Citrix

IGEL

« PN/Webinterface: Add PersistentCachePath in the section [Thinwire3.0], value: File
system path

The size of the cache can be controlled with the parameter Cache Size.
+ ICA sessions: Go to ICA > ICA Global > Options, parameter Cache Size (kB)
« PN/Webinterface: Add PersistentCacheSize in the section [Thinwire3.0], value: Cache size
(kB)

The minimum size of a bitmap to be cached can be controlled using the parameter Minimum
Bitmap Size (Byte).
+ ICA sessions: Go to ICA > ICA Global > Options, parameter Minimum Bitmap Size (Byte)
« PN/Webinterface: Add PersistentCacheMinBitmap in the section [Thinwire3.0]. value:
Minimum bitmap size (Byte)
Audio Bandwidth:
Adjusting the parameter Audio bandwidth limit directly affects network load for published
applications with much audio output.
+ ICA sessions: Go to ICA > ICA Sessions > Name > Options, parameter Audio Bandwidth
Limit
« PN/Webinterface: Add AudioBandwidthLimit in the section [Application], values: 0/1/2 for
High/Medium/Low
MouseTimer/Keyboard Timer:
The parameters MouseTimer and KeyboardTimer reduce the number of network packets by
gathering several mouse/keyboard events and putting them together into one network packet. For
the mouse, in older versions of IGEL Linux the default value was 100 (milliseconds), but this lead to
strange behavior in some applications. Now the default value is 0 (for mouse and keyboard). It is
not recommended to change this value for the keyboard, but if you have problems with your
network load and want to reduce the number of network packets, you could try a higher value like
100 or even more for the mouse.
+ Locally defined ICA sessions:
Registry path ica.wfclient.mousetimer (globally for all ICA sessions) or
sessions.icaN.appsrv.mousetimer (for single session N), value: Time (milliseconds) to
gather events
Registry path ica.wfclient.keyboardtimer (globally for all ICA sessions) or
sessions.icaN.appsrv.keyboardtimer (for single session N), value: Time (milliseconds) to
gather events
« PN/Webinterface: Add MouseTimer or KeyboardTimer in the section [Application], value:
Time (milliseconds) to gather events

Improving performance/user experience:

Speedscreen Latency Reduction:

The parameters Mouse Click Feedback and Local Text Echo could improve the user experience
for high latency network connections. Mouse Click Feedback shows a busy cursor when the user
presses a mouse button to give him an immediate visual feedback and prevent him from clicking
again. Local Text Echo lets the client pre-render the characters the user types to give the
impression of a smooth text input.
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e

IGE

+ ICA sessions: Go to ICA > ICA Sessions > Name > Options, parameter Mouse Click
Feedback or Local Text Echo
« PN/Webinterface: Add ZLMouseMode or ZLKeyboardMode in the section [Application],
values: 0/1/2 for Off/On/Automatic
+ Deferred screen update mode:
The parameter Deferred screen update mode defers graphical updates to the screen so that
several updates are done in one batch operation. This speeds up the updates especially on slow
machines with a poor refresh rate. The effect is very noticable when the screen contents refreshes
rapidly, e.g. during scrolling.
+ ICA sessions: Go to ICA > ICA Global > Options, parameter Deferred screen update mode
« PN/Webinterface: Add DeferredUpdateMode in the section [WFClient], values: True/False
+ Improve writing performance for redirected USB devices:
To speed up writing on redirected USB media, it is possible to deactivate the parameter
sync_option.

© Caution: Deactivating this parameter is not recommended. When it is disabled it is not
guaranteed that the write process has finished when the software indicates it. Some data
might still reside in the write buffer. If the user disconnects the USB device too early, the
written data might not be complete and the data file(s) may be corrupt. Some USB devices
have an LED that blinks when data is written. When it stops blinking, the write process
should be completed, but it is not guaranteed.

+ Go to IGEL registry devices.autofs.sync_option
+ Deactivate the parameter sync_option
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Citrix

Poor Performance: Black Blocks and Stripes in Citrix Sessions

Symptom

In the Citrix session, you sometimes experience a problem with black blocks, frames, or stripes.

Problem

Poor performance is often connected with the delayed or slow refreshing of the screen content.

Solution

» Inthe IGEL Setup or the configuration dialog in the UMS, activate one of the following parameters or all of them
under Sessions > Citrix XenDesktop/XenApp > HDX / ICA Global > Options:

+ Use server redraw
+ Allow backing store
« Deferred screen update mode

* Citrix XenDesktop / XenApp » HDX/ICA Global ™ Options

Configuration €} s V UseServerRedraw

B Global Session Options A
O
‘ Citrix Receiver Selection
O
‘ Server Location
B Local Logon Cache Size in kB

¥} + V Allow Backing Store

€} » v Defered screen update mode

‘ StoreFront Logon
‘ Window Minimum Bitmap Size in Bytes
‘ Keyboard
» [ Mapping
‘ Firewall

B Native USB Redirection

Persistent Cache Path

Scrolling control

Audio Bandwidth Limit in StoreFront sessions

and send to d

See also Options in the manual chapter for Citrix.
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Poor Performance with Citrix XenDesktop 7.6 Deep Compression

Symptom

When using XenDesktop 7.6 on Windows Server 2008R2 with Citrix Receiver 13.0.4, 13.1.4 or 13.2.1 with H.264 Deep
Compression Codec, dragged Windows lag and the performance is generally poor.

Problem

Server and/or client do not have enough computing power for the H.264 Deep Compression Codec.

Solution

Enable the legacy graphics mode on the XenDesktop 7.6 server via a policy.
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Citrix: Deep Compression Flickers

Symptom

When using XenDesktop 7.6 on Windows Server 2008R2 with Citrix Receiver 13.0.4, 13.1.4 or 13.2.1 with H.264 Deep
Compression Codec, the Windows start menu button flickers.

Problem

Known issue on the server side.

Solution

Enable the legacy graphics mode on the XenDesktop 7.6 server via a policy.
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Citrix Receiver: Grey Blocks in Excel 2013

Symptom

When using Microsoft Excel 2013 on XenDesktop 7.6 with Citrix Receiver 13.1.3, 13.1.4 or 13.2, grey blocks appear
especially if you mark multiple cells.

Problem

Codec parameters may not be optimal for this use case.

Solution

1. InIGEL Setup, go to Sessions > Citrix XenDesktop / XenApp > HDX / ICA Global > Codec.
2. Disable Text Tracking.
3. Disable Small Frames Feature.

Graphical Codec [H.264 Deep Compression Codec v]

Additional parameters for H.264 Deep Compression Codec
[[] Tesxt Tracking

[ ] small Frames Feature
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Citrix

Bar Code Scanning is Slow via Citrix

& Solution Based on Experience from the Field

This article provides a solution that has not been approved by the IGEL Research and Development
department. Therefore, official support cannot be provided by IGEL. Where applicable, test the solution
before deploying it to a productive environment.

Issue

Bar code scanning is slow via Citrix.

Environment

+ Firmware version: any
+ UMS version: any

Description

USB attached bar code scanner is very slow via Citrix.

Solution

In order to pass the Bar Code scanner through correctly, you want it to be a HID so it passes through as a HID
instead of using Native USB Redirection. A quick way to determine that would be to open a terminal in IGEL OS and
simply scan something. If it populates data in the terminal, then it is configured as HID. Also, check the
configuration guide for the particular scanner that you are using. The config guide is simply a bunch of barcodes
that the device can scan. Once a code is scanned, the device beeps twice, and that changes the config on the
scanner. On some devices, there is a setting for Alternate OS Linux/MACOS. The default setting for the scanner
usually doesn't enable this. Once the setting was set, everything scanned very fast and that same speed was shown
in Citrix.
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Citrix Webinterface 5.x Delay on First Page

Symptom
When opening the Citrix Webinterface in IGEL Linux Appliance Mode you only see an empty page.

Problem

The Webinterface is slow.

Solution:

See the following Citrix Support Knowledge Center entry: http://support.citrix.com/article/CTX117273
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Citrix

Slow Performance of Citrix Session in a Cloud Environment

Symptom

Your cloud-based Citrix session is very slow.

Environment

+ IGEL OS 10.05 or higher, up to IGEL OS 11.05 (with IGEL OS 11.06 or higher, the default setting has
changed)

« Citrix client is connected to a cloud server. NOT affected: On-premises and Netscaler
environments

Problem

The HDX transport protocol is set to "UDP with fallback to TCP", which causes slow performance.

Solution

1. Open the UMS configuration dialog or the local Setup and go to Citrix > Citrix Global > Options.
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<
.

IGE

tive Transport over EFT to"TCP only UDP disabled" and click Apply or Ok.

Global » Options

r

2. Set HDX Adap

Ll « ® Citri

lert sounds

Deferred en update mode

Cache size in kB 1024
Minimum bitmap n bytes 1024
Pe nt cache path $ICAROOT/cache
Scrolling control 100
Audio bandwidth limit in StoreFront se high

v Auto reconn
Maximum retries
Delay in seconds before reconnecting

V' Allow Kerberos passthrough authentication in StoreFront
CGP address disabled

Mu am

HDX Adaptive Transport over EDT | TCP only - UDP disabled
lI.JI':IP without fallback ta TCP
TCP only - UDP disabled
(9] Tallback to 1er

Apply

When the Citrix client is started again, the performance should be better.
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Mouse

+ Changing Middle Mouse Button Function for Citrix Session and Local Firefox Browser (see page 31)
« How to Connect a SpaceMouse with a Citrix Session (see page 33)
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Changing Middle Mouse Button Function for Citrix Session and Local Firefox
Browser

Middle mouse button cannot be used for smooth scrolling within applications like Excel or Internet Explorer within a
Citrix session or with the local Firefox browser.

The default function of the middle mouse button is copy and paste.

> Open IGEL registry in local client setup or UMS.

< > ' [ » System M Registry

Configuration Search parameter ... ica.wfclient. mousesendscontroly

=essions B keyboardtype :
S e B keypassthroughescapechar
User Interface B keypassthroughescapeshift
Metwork B argecachesizeink
T B lcgoffdesktopthrotwi
i B mousedoubleclickheight
= B mousedoublaclicktimer
ylem B mousedoubleclickwidth
Il Time and Date B mousesendscontroly
> I Update . mousetimer
: : 2:?2: :Cacr;zgsement B palettechangetimeout
» [ Power Options i persistentcacheminbitmap Allow Middle Button Paste
» I Firmware Customization B persistentcachepath ] allow Middle Button Paste
‘ Registry i persistentcachepercent W
[ RN R

> For Citrix sessions change:

+ System > Registry > ica.wfclient.mousesendscontrolv
+ System > Registry > sessions.ica%.appsrv.mousesendscontrolv

» For local Firefox browser change:

+ System > Registry > browserglobal.app.middlemouse_contentloadurl
« System > Registry > browserglobal.app.middlemouse_paste

More information on the Firefox parameters can be found at

http://kb.mozillazine.org/Middlemouse.contentLoadURL
http://kb.mozillazine.org/Middlemouse.paste
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Citrix

The changes will take effect after rebooting the thin client.
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How to Connect a SpaceMouse with a Citrix Session

This article describes how to use a 3Dconnexion SpaceMouse in a Citrix HDX Session.

© Citrix Workspace App 13.9 or older: Do not redirect the SpaceMouse if it is the only mouse connected to
your thin client! After redirecting, the local system would be without a mouse. Make sure to use a second
mouse for the local device in this scenario.

1. In Setup, go to Sessions > Citrix XenDesktop/ XenApp > HDX/ ICA Global > Native USB
Redirection

2. Activate the checkbox Enable native USB Redirection

Set the Default Rule to Deny.

4. Add a device exception rule as in the following screenshot with the Product- and Vendor-ID of your
specific SpaceMouse:

Rule A& | Alow 7|

VendorID g | 256f

w

ProductID g | c62b

Mame ﬂ SpaceMouse Pro

@ Inorderto find out the Vendor ID and Product ID, open a Local Terminal and issue the
command lsusb . This will show a list containing the connected USB-Devices and their
IDs.

The SpaceMouse is ready for use.

Additional Steps for IGEL Linux 10

If your device has IGEL Linux 10 / IGEL OS 10, the SpaceMouse is used as an additional mouse for the local system.
Because of this, the SpaceMouse will interfere with the local mouse pointer. You can prevent this by denying local
USB access.

To prevent the SpaceMouse from interfering:

1. In Setup, go to Devices > USB access control and activate Enable.
2. Inthe Device Rules area, click to add a new device rule.
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3. Set the device rule as follows:
* Rule: Deny
+ Vendor ID: 256f
« Product ID: c62b
4. Click Ok in the dialog and then Apply or Ok in the Setup.
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Mapping USB Storage Media into Citrix Sessions

How to configure USB Storage mapping so that users can access USB storage media attached to the IGEL LX Client
within Citrix sessions?

(@ The mapping of USB storage devices is possible for "USB mass storage class" devices. The storage of
smartphones and digital cameras is usually accessed via the MTP protocol. Mobile device access via MTP is
available with IGEL Linux 10.04.100 or higher; for more information see the how-to Using Mobile Device
Access (see page 474).

Basic Configuration of the Device

£ > ~ ! " Devices " Storage Devices ™ Storage Hotplug

Configuration (] storage Hotplug

Default permission [Readerite v]

3

Acc

Client Drive Mapping ) [Dynamic v]

User Interface L : ]
Static Client Drive Mapping
Network o

te drive letter for each storage drive

Devices

B Hardware Info
» Il Printer Start storage drives with this drive letter A

e s 1
MNUmper or arives 1

¥ [ storage Devices
. Storage Hotplug
‘ Options ICA write access for storage hotplug devices Yes
B clustooth
B UsE access control

Nty St B T S e T o
CA read access for storage hotplug devices fes

Notification

(/] Hotplug beep
/] Hotplug message

Security

System

Timeout
15 Seconds

Within the IGEL Setup or a UMS profile, you basically need to configure these parameters:

> Activate Devices > Storage Devices > Storage Hotplug > Client drive mapping > Dynamic. This option
activates dynamic client drive mapping. It automatically recognizes new storage media as they are connected to
the thin client. The thin client beeps and shows a notification while it mounts the new device. The storage devices
automatically become usable on the thin client and in Citrix ICA Sessions.

© Mounted devices need to be unmounted before they are removed to ensure data integrity. This can be
done via the Disk Utility, the Disk Removal Tool or a tray icon.
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Additional Parameters to Check

» The following parameters are set by default, thus storage mapping will work, but maybe for some reason you
have changed these and need to adjust them to allow the storage mapping:

Sessions > Citrix > Citrix Global > Mapping > Drive Mapping > Drive mapping (set checkmark)
Sessions > Citrix > Citrix Global > Native USB Redirection > Native USB redirection (remove checkmark)

Sessions > Citrix > ICA/HDX Global > Fabulatech USB Redirection > Fabulatech USB redirection (remove
checkmark)

Devices > USB access control > Enable (remove checkmark)

Sessions > RDP > RDP Sessions > [session name] > USB Redirection > Enable Native USB Redirection (global
setting)

Sessions > RDP > RDP Sessions > [session name] > Mapping > Enable Drive Mapping (global setting)

Assigning a Drive Letter within the Session (Optional)

» Incase you not only want to see the drive in the session as e.g. "A on IGEL-123456789", but want to address the
drive with a real drive letter within the session, you may run one of these commands:

subst T: \\tsclient\t

or

net use T: \\tsclient\t

In this example, "T on IGEL-123456789" is assigned to drive letter T: within the session. You may also assign the
mapped drive to another drive letter than is used in its name.

Configuration on the Server Side

On the server side, e.g. with Windows Server 2008R2, a user in the group "Users" with access to the terminal server
will have the mapping default. This is true for a newly installed server. But the mapping can be prevented by
changing the policies:

() Do not allow drive redirection Specifies whether to prevent the mapping of client drives in a Remote
Desktop Services session (drive redirection). By default, an RDP Session Host server maps client drives
automatically upon connection. Mapped drives appear in the session folder tree in Windows Explorer or
Computer in the format [driveletter] on [computername]. You can use this setting to override this
behavior." Source: https://technet.microsoft.com/de-de/library/ee791794%28v=ws.10%29.aspx
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Auto-Hide Toolbar in Appliance Mode

Environment

IGEL Linux v5.x or newer

Problem
In the appliance mode, the toolbar at the top of the screen is permanently displayed.

You want to configure the toolbar to hide automatically after it loses the focus of the mouse pointer.

Solution

1. InIGEL Setup, go to System > Registry >
userinterface.igel_toolbar.show_always_in_appliance_mode.

2. Disable Show toolbar always in appliance mode.

3. Click Ok to save the changes.

(@ Forthe changes to take effect, you need to restart active appliance mode sessions.
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Changing Appliance Mode Picture

The following shows you how to change the Appliance Mode appearance: pictures (XenDesktop and Horizon
View appliances), picture style (XenDesktop appliances), and desktop background color (XenDesktop appliances).

Pictures:

The pictures can be changed via Custom Command or UMS File Transfer.

« XenDesktop Appliance Mode uses following pictures located in /services/xen/share/

pixmaps (depending on User Interface > Language setting; "en_US" is used if there is no png

for selected language):
+ Standard Ctrl-Alt-Del dialogue picture:

ctrlaltdel_en_US.png
ctrlaltdel_de_DE.png
ctrlaltdel_zh_CN.png

ctrlaltdel_zh_HK.png
+ Smartcard setting if registry key xen.xenapp-morph.smartcard_enable is enabled:
smartcard_en_US.png

smartcard_de_DE.png
+ Error message if server is unreachable:
serverunreach_en_US.png

serverunreach_de_DE.png
serverunreach_zh_CN.png
serverunreach_zh_HK.png

+ Horizon View Appliance Mode picture: /usr/share/pixmaps/vmware-view—bg.png

Picture Style:

For XenDesktop Appliance Mode, the style of the dialog pictures can be adapted to the wallpaper style of the first
monitor. The wallpaper style of the first monitor can be configured under User Interface > Desktop > Background
(1st Monitor) > selection list Wallpaper style.
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Wallpaper (1st monitor) Desktop Color Light

Wallpaper style (15t monitor) | streched

Color style (1st monitor) Vertical gradient

Desktop coler (1st monitor) Choose color

2nd desktop color (1st monitor) Choose color

Custom wallpaper download (1st monitor)

> To make the style of the dialog pictures adapt to the first monitor's wallpaper style, activate the registry key
Xen.xenapp-morph.customization.use_wallpaper_style (xen > xenapp-morph > customization >
use_wallpaper_style).

If the registry key is deactivated, the dialog images are displayed centered without being resized.

Desktop Background:

For XenDesktop Appliance Mode, the background color can be adapted to the background color of the first monitor.
The background color of the first monitor can be configured under User Interface > Desktop > Background (1st
Monitor) > color picker Desktop Color (1st Monitor).

Wallpaper (1st monitor) Desktop Color Light
Wallpaper style (1st menitor) | Streched

Color style (1st monitor) Vertical gradient

Desktop color (1st monitor) Choose color

2nd desktop color (1st monitor) Choose color

Custom wallpaper download (15t monitor)

» To make the background color adapt to the desktop background color, activate the registry key xen.xenapp-
morph.customization.use_desktop_color (xen > xenapp-morph > customization > use_desktop_color).

If the registry key is deactivated, the background color is black.
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Create a Seamless, Transparent User Experience with Appliance Mode

With appliance mode, you can confine a device to a specific session. In appliance mode, the device itself fades in the
background, and the session is presented to the user in the most straighforward way. The user will not have to deal
with a Linux desktop, multiple login procedures, switching between windows, or device configuration.

Use the appliance mode to allow access only to one specific session. On device startup, the user is directed
immediately to the login screen of the virtual desktop.

The appliance mode can be applied to the following session types:

« VMware Horizon

« Citrix XenDesktop (for published desktops only, not for published applications)
« Citrix Self-Service

« RHEV/Spice

+ Imprivata

+ RDP MultiPoint Server

+ Caradigm

« XDMCP for this display

To configure a session that runs in appliance mode:

1. Open the setup and go to Sessions > Appliance mode.
2. Choose the session type of the desired session using the drop-down menu Appliance mode.
3. Configure your appliance mode session as appropriate.

For further information, see the manual chapter Appliance Mode.
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Connecting to a Citrix Farm

By connecting to a Citrix Farm your data and applications are kept centrally on a Citrix farm. Applications must now
be delivered instantly to users anywhere on any device.

There are several ways of connecting to a Citrix farm and starting sessions. We describe three best practice variants
below:

+ StoreFront/Web Interface (see page 42): Integrates published applications into the IGEL GUI.

« Citrix Self-Service (see page 43): Users will be directed to a web interface where they will find pre-
defined published applications and they will be able to add more published applications the
server provides.

« Appliance Mode (see page 54): Shows only the web interface of the farm and hides the IGEL GUI
completely.
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StoreFront/Web Interface

Prerequisites:

« Citrix XenDesktop 7.5 or newer
« Trust root certificate in directory /wfs/ca-certs (see Deploying Trusted Root Certificates (see page
280))

Connecting via StoreFront/Web Interface:

1. Click Sessions in the configuration tree of the IGEL setup.
2. Click ICA > Citrix StoreFront/Web Interface > Server.

I The range of supported server types depends on the
Configuration Citrix Receiver version (see page Citrix = Citrix Receiver Selection)

S

Citrix server type [Web Interface / Services Site v]

ﬁ Sessions Summary
¥ [ Citrix XenDesktop / Xen,

B citrix Receiver Select
» Bl HDX / ICA Global Protocol | Citrix XenApp S... | Path to config.... |[®==&r Farm N...

Add

» B Legacy ICA Sessions e
¥ [ Citrix StoreFront / We
B server |

‘ Logon
n Options
3. Click the staricon for ADD in the Server location window.
The ADD mask opens.
Enter the names or IP addresses of the services sites.
Confirm with OK.
Click Citrix StoreFront/Web Interface > Desktop Integration.
Enter "Citrix Storefront" under Login Session Name.
Choose Desktop as the starting method.
Click OK to save the changes.
Setup closes.
10. Doubleclick the Citrix icon on the desktop.
The login window opens.
11. Enter the credentials of a user in the login window.
The published applications of the Citrix farm will appear on the desktop.
12. Doubleclick an application icon on the desktop to start the program.

Server location

LNk
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Citrix Self-Service

Problem

You want your Citrix users to select the published applications they need to work with themselves instead of
defining applications for every single user profile.

Solution

Citrix Self-Service is the solution to go with. Users will be directed to a web interface where they will find pre-defined
published applications and they will be able to add more published applications the server provides. You can
configure the system to cache the user's selection of applications or reset available applications to a defined
default set. Activating the kiosk mode will restrict the user to preset applications.

() AsofIGEL Linux 5.09.100 Citrix Self-Service can be configured easily in IGEL Setup. See Citrix Self-Service in
the IGEL Linux 5 Manual.
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Prerequisites

Requirements and restrictions for using Citrix Self-Service:

@ AsofIGEL Linux 5.09.100 Citrix Self-Service can be configured easily in /GEL Setup. See Citrix Self-Service in
the IGEL Linux 5 Manual.

+ IGEL Linux firmware is 5.03.100 or newer

+ Citrix Receiver 13 is enabled

+ Program Neighborhood / Storefront is configured on the Citrix server

« IGEL's Citrix XenApp/Storefront feature can not be used concurrently with Self-Service

+ Global ICA settings such as mapping of devices or redirection of content are effective for Self-
Service as well

+ The local cache for XenApp 6.5 servers will store user-defined applications for all users (cumulated
cache)

(@ Please note the known issues regarding Citrix Receiver mentioned in the release notes of your /GEL Linux
firmware.
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Client Configuration

Citrix Self-Service configuration will be done by a Custom Command creating a personalized script. In the following
the different parts of the command will be explained - you will not need to use the complete section but only the
parts that are applicable to your solution.

() Commentsinthe command are tagged with a leading # . The comments can be skipped when copying
relevant parts of the script into the Custom Command field.
For more information please refer to Citrix' Linux OEM Guide (see page 45) (see comments below).

Preparation:

1. Make sure you are using IGEL Linux 5.03.100 or newer on your thin client

Enable Citrix Receiver 13 in Setup > Sessions > Citrix > Citrix Receiver Selection.
Go to Setup > System > Firmware Customization > Custom Application.

Add new application Citrix Self-Service and set

Call S

Settings >Ilcon Name= /usr/1lib/ICAClient/icons/manager.png

Settings > Command = /config/sessions/selfservice

5. Go to Setup > System > Firmware Customization > Custom Commands > Base Commands.
Enter applicable parts of the command options below to Custom Command Session Final.
7. Apply settings to the thin client and reboot the device.

o

The following template is available as plain text file as well: Citrix Self-Service Template (see page 45)

#
# The Custom Command template:
#

# IGEL Setup > System > Firmware Customization > Custom Command > Base Commands > Custom Command
Session Final

#

# Get Citrix Receiver 13 directory:
ICADIR="/usr/1lib/ICAClient"

#

# Create Citrix Receiver 13 cache directory:
mkdir -p /userhome/.ICAClient/cache/

#

# Remove (hide) Citrix Receiver configuration dialog (optional):

rm $ICADIR/util/configmgr
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echo "#!/bin/sh" > $ICADIR/util/configmgr

echo "gtkmessage -m \"You are not allowed to open the configuration dialog.\""
>> SICADIR/util/configmgr
chmod a+x $ICADIR/util/configmgr

#
# Store Citrix Receiver cache permanently (optional):

# The cache is NOT user-specific but cumulates the settings for all users who have logged on to a Citrix server via
Citrix Self-Service.

# The cache contains:

# - Configured server URLs

# - Selected published applications for XenApp 6.5 server

# XenDesktop 7.x selections are stored on server side and haven't to be cached.
# Itis not necessary to store the cache, if you use Self-Service

# in kiosk mode and the user can not change anything.

if [ ! -d /wfs/user/Stores ] ; then

mkdir -p /wfs/user/Stores

chown user:users /wfs/user/Stores

fi

1n -s /wfs/user/Stores /Juserhome/.ICAClient/cache/Stores

chown -R /userhome/.ICAClient/cache/

#

# Set one ore more server URLs:

SERVER_URL="http://./citrix/pnagent/config.xml"

SERVER_URL2="https://."

# If using HTTPS connections do not forget to store the SSL certificate on your thin client.

# See IGEL Knowledge Base for more information https://kb.igel.com/igelos/en/deploying-trusted-root-
certificates-2720919.html (see page 280)

#
# Create user script /config/sessions/selfservice to be started as Custom Application.
# (Up to next EOF at the end)

# Do not delete the hash sign (#) in the command below!
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cat < /config/sessions/selfservice
#!/bin/sh
#
# Storebrowse is not yet working stable, kill the running daemons and
# kill the AuthManagerDaemon, so the credentials of the last user are cleared:
killall storebrowse AuthManagerDaemon ServiceRecord
#
# See Linux-OEM-Guide-13.0-12-13-13.pdf page 58
# for ALL storebrowse options.
#
# Configure server URLs to be used in selfservice (optional:)
#1f no URLs are configured, the Citrix Receiver will ask the user to enter a URL.
# See Linux-OEM-Guide-13.0-12-13-13.pdf page 20
# IMPORTANT: Do not forget to install the root certificate for HTTPS connections!
# Configure a DefaultStore. Only one store can be default!

# In the example below STORE2 is set as default:

STORE=\ "SICADIR/storebrowse -a S$SSERVER_URL\"

#if [ "\$?" = "e" ] ; then

# eval SICADIR/storebrowse -c DefaultStore=\$STORE
#f1

STORE2=\ '$ICADIR/storebrowse -a $SERVER_URL2\"

if [ "\$?2" = "e" ] ; then

eval $ICADIR/storebrowse -c DefaultStore=\$STORE2
f4

#

# Delete dispensable server URLs (optional):

# In case the cache directory is stored permanently (see above) and

# a server URL should not be used anymore.
#SICADIR/storebrowse -d

#
# Configure gateway (optional, see Linux-OEM-Guide-13.0-12-13-13.pdf page 22):
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#SICADIR/storebrowse -g

#

# Preset published applications to be shown in Citrix Receiver (optional):

# Only valid for XenApp 6.5 and previous.

# For XenDesktop 7.x see section below.

# Especially needed if Self-Service runs in kiosk mode and the user can not add
# applications on his own.

# Get the "Resourcename" by running
# "/usr/1lib/ICAClient/storebrowse -E "

#in your Linux console (local terminal session).

# Example configuration with Windows Command Prompt (cmd) and Paint preset:

if [ | -f /userhome/.ICAClient/cache/Stores/PNAApplications.ctx ] ; then
mkdir -p /userhome/.ICAClient/cache/Stores

echo "" > /Juserhome/.ICAClient/cache/Stores/PNAApplications.ctx

echo -e "\t" >> /Juserhome/.ICAClient/cache/Stores/PNAApplications.ctx

echo -e "\t\t:cmd" >> /userhome/.ICAClient/cache/Stores/PNAApplications.ctx
echo -e "\t" >> /Juserhome/.ICAClient/cache/Stores/PNAApplications.ctx

echo -e "\t" >> /userhome/.ICAClient/cache/Stores/PNAApplications.ctx

echo -e "\t\t:Paint" >> /userhome/.ICAClient/cache/Stores/PNAApplications.ctx
echo -e "\t" >> /userhome/.ICAClient/cache/Stores/PNAApplications.ctx

echo "" >> /userhome/.ICAClient/cache/Stores/PNAApplications.ctx

chown user:users /userhome/.ICAClient/cache/Stores/PNAApplications.ctx

fi

#

# Preset published applications to be shown in Citrix Receiver (optional):

# Only valid for XenDesktop 7.x.

# For XenApp 6.5 and previous see section above.

# Especially needed if Self-Service runs in kiosk mode and the user can not add

# applications on his own.

# Get the "desktop or application ID" by running
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# "/usr/1lib/ICAClient/storebrowse -E "
#in your Linux console (local terminal session).

# Subscribe: $ICADIR/storebrowse -s
# Unsubscribe: $SICADIR/storebrowse -u

# List subscriptions: $ICADIR/storebrowse -S

#

# Add subscriptions which have not been added before:

SICADIR/storebrowse -S $SERVER_URL2 > /tmp/.subs.\$\$

# Example configuration with Windows Command Prompt (cmd), Calculator and WordPad preset:
grep "'XD71DevSite.Cmd'" /tmp/.subs.\$\$ || SICADIR/storebrowse -s
"XD71DevSite.Cmd" $SERVER_URL2

grep "'XD71DevSite.Write'" /tmp/.subs.\$\$ || $ICADIR/storebrowse -s
"XD71DevSite.Write" $SERVER_URL2

grep "'XD71lDevSite.Calc'" /tmp/.subs.\$\$ || $ICADIR/storebrowse -s
"XD71DevSite.Calc" S$SSERVER_URL2

rm /tmp/.subs.\$\$

#

# Configure Self-Service GUI options such as full-screen mode (optional):

# See Linux-OEM-Guide-13.0-12-13-13.pdf page 46

SICADIR/storebrowse -c SharedUserMode=False
SICADIR/storebrowse -c FullscreenMode=0

SICADIR/storebrowse —-c SelfSelection=True

#
# Configure reconnection options:

# See Linux-OEM-Guide-13.0-12-13-13.pdf page 23.
$ICADIR/storebrowse -c ReconnectOnLogon=False

SICADIR/storebrowse —-c ReconnectOnLaunchOrRefresh=False

#

# Display desktop sessions in full screen or window mode

#SICADIR/storebrowse -c SessionWindowedMode=True/False

IGEL OS Articles 49 /543



Citrix

#

# Run command to open the gui
SICADIR/selfservice

#

# End of user script /config/sessions/selfservice to be started as Custom Application:
EOF

#

# Change access rights for user script (executable):
chmod a+x /config/sessions/selfservice

#

# End of Custom Command template.
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Using Citrix Self-Service

1. Start Citrix Self-Service e.g. with desktop icon.

Log on to the server.

Add published applications to the list (+-button on the left).
Click a published application to start.

Use the search bar to find a published application.

Use the user's menu to change preferences, server etc.

)

Citrix Self Service

oA WD

Citrix Receiver

Citrix Receiver User

./ s

Paint Copy of Rechner
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Citrix Receiver - A X

Citrix Receiver User

=
L
-
#
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N
]
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« Configure Full-Screen Mode (see page 53)
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Configure Full-Screen Mode

Use following parameter in your Custom Command script (see page 45) to activate the full-screen mode for Citrix Self-
Service:

> SICADIR/storebrowse —-c FullscreenMode=[0/1/2]

With following options:

+ 0 =Thewindow is not displayed full-screen
« 1 =Thewindow is displayed full-screen

+ 2 =Thewindow is displayed maximized and undecorated, which does not mask the desktop
environment's taskbar
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Appliance Mode
There are two ways to connect to the Citrix Server in Appliance mode:

« Citrix Virtual Desktop: Connect to Citrix Farm via your browser.
« Citrix Selfservice: Connect to Citrix Farm via your Selfservice GUI.

Connecting Citrix via Browser

1. Click Sessions > Appliance Mode in the configuration tree of the IGEL setup.
2. Select Citrix Virtual Desktop under Appliance mode.

Appliance mode ﬂ | Citrix Virtual Desktop

Virtual Desktop delivery senver LURL hitp:ifxenserver

Smartcard Login

On-screen keyboard

Enter the URL of the delivery server.

Activate Smartcard Login if necessary.

Click OK to save the changes and close setup.
Follow the instructions on the screen.

o uhAwW

Connecting Citrix via Selfservice

1. Click Sessions > Appliance Mode in the configuration tree of the IGEL setup.
Select Citrix Self-Service under Appliance mode.

Enter the URL of the delivery server.

Click OK to save the changes and close setup.

Follow the instructions on the screen.

oW
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Create a Self-Service Setup for the User with Quick Settings

Usually, the user should not have full access to the device's setup. However, it may prove useful to enable users to
quickly change certain settings by themselves, without even needing a password. Typical examples are settings for
keyboard, mouse, or screen. This can be done using the Quick Settings.

Here is how to select setup pages for quick setup:

1. Open the setup and go to Accessories > Quick Settings > Setup User Permissions.
2. Select the setup pages to which the user should have access, e. g. User Interface > Input > Mouse,
or Screen Lock/Saver.

> Dﬂ Sessions
» [OF) Accessories
|‘r [i']mser Interface
» LY oisplay
» LF) pesktop
OFY Language
¥ M|} Screenlock / Screensaver
|1 options
VY Taskbar
W} Screensaver
v [ Input

Dﬂ—' board layouts
|1 Mouse

» O Touchpad
Dﬂ Touchscreen

3. Click Apply or Ok.
When the user starts Quick Settings, the previously selected options are presented.
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Configuration

Sessions
Accessories
User Interface

» Il Display
» Il Desktop
i Language

¥ [ Screenlock  Screensaver
‘ Options
B Taskbar
ﬁ Screensaver

¥ O3 Input
B Keyboard
B Additional keyboard la

B Mouse
Quick settings set permissions for setup screens. If you want to set permissions for individual
parameters, you can use UMS profiles. For more information, see Profiles.
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Citrix: Changing Password Issue

Symptom

A user has to change the password within session to Citrix XenDesktop 7.x or Virtual Desktop server and receives an

error message during the process: Warning: Could not connect to the Citrix server.

€) Please log on to Windows to change your expired password.

Citrix Receiver — A X

Warning: [Meine Apps] — A

Warning: [Meine Apps] Could not connect to the Citrix server.

-| Click for more details
Error: Please log on to Windows to change your expired
password.

Problem

The password change option is disabled on XenDesktop 7.x server (server default setting!).

Solution

Enable password change option on your Citrix server:

1.

ok wN

Go to Citrix StoreFront MMC

Open page Authentication

Set Authentication Method = User name and password

Click Manage Password Options (right panel)

Enable an option allowing the password change (Any time or When expired)
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Login Failed because of the Expired AD Password

Problem

When you try to log in to a native Citrix Storefront session, you get the error message "Login Failed!" because your
Active Directory password expired.
You are unable to change your password, because the local login does not provide an option for that.

() Beforeyou follow these instructions, check that the ports are open, maybe you can fix the problem by
that:
+ Login to Client -> Port: 88
+ Change password -> Port: 464

Here you find an overview of ports of the domain controller: Required Ports to Communicate with Domain
Controller®

Solution

Enable Active Directory/Kerberos authentication for the Storefront session. The next time you try to login to IGEL
0S, you will be prompted to change your expired password.

Changing an Expired Active Directory Password

© When using sessions with passthrough authentication, it is essential that you lock your device's screen
when leaving it unattended.

Enabling Active Directory/Kerberos Authentication for Storefront Sessions

1. InIGEL setup, go to Security > Login > Active Directory/Kerberos.
Enable Login to Active Directory domain.

Go to Security > Active Directory/Kerberos.

Activate Enable.

Fill in the Default domain (fully qualified domain name).

Go to Sessions > Citrix > Citrix Storefront > Login.

Enable Use passthrough authentication.

Click Apply or Ok.

NGO A WN

() Please note that the client must now be locked locally and no longer in the session to prevent another
person from entering the session via the passthrough without specifying the password.

3 https://social.technet.microsoft.com/Forums/windows/en-US/1c6a59de-c1fe-4946-bb4e-1fe36fd40b08/required-ports-to-communicate-with-
domain-controller?forum=winserverDS
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Enabling Screenlock

ok W

6.

In the IGEL setup go to User Interface > Screenlock / Screensaver.
Enable Use hotkey.

Under Modifiers select Win .

Under Hotkey enter "L".

Got to User Interface > Screenlock / Screensaver > Options.
Enable User password.

So the "Win + L" hotkey locks the IGEL client instead of the session desktop.

The AD password must be entered to activate the IGEL clients.
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Configuring Auto Logon for XenDesktop

This how-to describes how to configure Auto Logon for XenDesktop.

Steps

1.

w

WeNOL b

In IGEL Setup, go to Sessions > Citrix XenDesktop / XenApp > Citrix StoreFront [ Web Interface
> Server.

Add your Server Location.

Add your Active Directory domain to Domains, making sure that you use its Fully Qualified Domain
Name (FQDN).

Go to Sessions > Citrix XenDesktop / XenApp > Citrix StoreFront / Web Interface > Logon.

Set Authentication type to Password authentication.

Activate Auto Logon.

Set User Name to the Active Directory user name.

Set the Password.

Set Domain to your Active Directory domain's FQDN, the same as in step 3.
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Force Citrix Logout Using Hotkey

You will find the instructions under Citrix: Freeze at Logout (see page 62).

& This page is due for deletion. Please check the above link and use it in the future.
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Citrix: Freeze at Logout

Symptom
A user tries to log out from a Citrix session but the session does not respond.

Example: Once you connect to a Citrix session, everything works. After having reconnected and disconnected
several times, you log out. The window freezes while the logout screen is shown.

Solution

» Select TCP only - UDP disabled under Sessions > Citrix > Citrix Global > Options > HDX Adaptive Transport
over EDT.

OR
> Try to use another Citrix Receiver version: Sessions > Citrix > Citrix Client Selection > Citrix client version.

OR

» Troubleshoot the issue with your Citrix infrastructure to discover why the session is not closing when
the wfica process makes the call for disconnection.

Workaround

As a less recommended alternative, you can configure a hotkey to force a logout in such situations. Note, however,
that this workaround can cause issues with hung sessions on the Citrix servers.

To configure a logout hotkey:

1. InIGEL Setup, go to System > Firmware Customization > Custom Application.
Click L*] to create a new Custom Application and name it e.g. "Kill Citrix Sessions".
Disable all Starting Methods for this session.

Enable Hotkey.

Choosee.g. Ctr1|Alt asModifiers and define C (for "Citrix) as Key.

Go to System > Firmware Customization > Custom Application > Kill Citrix Sessions > Settings.
Enter an Icon name.

Enter /tmp/kill_citrix as Command.

Go to System > Firmware Customization > Custom Commands > Desktop.
10. In the field Desktop initialization enter following command in one line:

echo -e "#! /bin/bash\n\nps -eo comm,pid | grep *wfica | while read
c p tail; do echo \$p; done | xargs -r kill -TERM" >/tmp/
kill_citrix; chmod 755 /tmp/kill_citrix

11. Click Apply and reboot the device.

L o N A WN
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To configure the hotkey for a group of devices, you can alternatively create a profile or use this
one: profile_KillCitrixSessionsViaHotkey.xml.

Here you can learn how to import a profile: Importing a Profile and Firmware.
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Warning Message: [Citrix Store] Could Not Connect to the Citrix Server

Environment

+ You are using Citrix Receiver 13.0.x or newer.
+ You have a session of the type Citrix StoreFront configured.

Symptom
« When establishing the connection, a warning message appears:
Warning: [Citrix Store] Could not connect to the Citrix server.

Warning: [Citrix Store] A

Warning: [Citrix Store] Could not connect to the Citrix server.

-iiclick for more details
url supplied is not a valid store
Have you installed your root certiﬁcate?)

or
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Warning: [Citrix Store]

Warning: [Citrix Store] Could not connect to the Citrix server,

-iiClick for more details:

Have you installed your root certificate?

Error adding store:AM_ERROR_HTTP_SERVER_CERTIFICATE_NOT_TRUSTED[65150]

W Ok

Problem

Citrix Receiver 13.0.x or newer on Linux only supports connections via HTTPS, and you have to make sure the device
has a valid root certificate of the Certificate Authority (CA) available. If the root certificate is missing, the connection

will fail.

Solution

Install an appropriate root certificate on the device to allow HTTPS connections to your Citrix Server.

For information on how to distribute the certificate, see Deploying Trusted Root Certificates (see page 280).
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Setting up Citrix Sessions with Hardware-Accelerated H.264 Deep
Compression Codec

This document describes how to activate a hardware-accelerated H.264 deep compression codec for Citrix sessions.

Prerequisites

+ Licensed IGEL Multimedia Codec Pack

+ IGEL UD device offering hardware video acceleration, see the FAQ Hardware Video Acceleration on
IGEL OS.

« Citrix XenApp / XenDesktop server with active H.264 display mode
See http://support.citrix.com/article/CTX200370 to learn how to determine the display mode.

Activating the Codec

1. In Setup, go to System > Firmware Customization > Features.

Enable Hardware Video Acceleration.

Go to Sessions > Citrix XenDesktop / XenApp > Citrix Receiver Selection.
Select Citrix Receiver Version.

Go to Sessions > Citrix XenDesktop / XenApp > HDX / ICA Global > Codec.
Set Graphical Codec to H.264 Deep Compression Codec.

Enable Accelerated H.264 Deep Compression Codec.

Noukwn

() Known issues on VIA-based IGEL devices UD3-LX 40/41/42 and UD10-LX:
+ Hardware-accelerated HDX only works with 256 MB video memory or more. Video memory
must be adjusted in the system BIOS. The default is 128 MB.
+ Seamless window mode is not supported.
+ Desktop sessions spanning 2 monitors are not supported.
+ Desktop sessions on rotated screens may flicker (depending on the screen resolution).

() Ifyou use the Citrix Receiver 13.5 or older in combination with a Citrix Server 7.15, the Build to Lossless
option for Visual Quality will not work under Linux.
With IGEL Linux version 10.05.100 the Build to Lossless option for the Visual Quality policy will work on
the condition that you are using Citrix Receiver 13.6 or younger and the Use Video Codec policy is set to
For actively changing regions.
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Using Font Smoothing (ClearType) in Citrix Sessions

Symptom

+ You have set Font Smoothing to ClearType in
IGEL Setup > Sessions > ICA > ICA Global > Window > Font Smoothing (Off / Standard /
ClearType)

+ ClearType does not work for Citrix PNAgent | Webinterface sessions.

Problem

ClearType is not supported in PNAgent / Webinterface sessions because Citrix Receiver uses Windows settings which
are not present on the Linux client.

Solution

All Citrix Receivers up to version 12.x do not use wfclient.ini to configure Font Smoothing. To force
Webinterface, PNAgent/XenApp to enable Font Smoothing proceed as follows:

+ PNAgent/XenApp:

1. Onthe Citrix server open C:

\inetpub\wwwroot\citrix\pnagent\config\default.ica .
2. Goto section Application.
3. Add new line FontSmoothingType=3 .
4. Save and close the file.

« Webinterface:

1. Onthe Citrix server open C:

\inetpub\wwwroot\citrix\xenapp\config\default.ica .
2. Go to section Application.
3. Add new line FontSmoothingType=3 .
4. Save and close thefile.

@ Ifyouinstalled the Webinterface site to a different location, please change the path
accordingly.

FontSmoothingType parameter options:

+ 0 =Nosmoothing

+ 1 =Nosmoothing
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+ 2 =Standard smoothing
+ 3 =ClearType (horizontal sub-pixel) smoothing (default)
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Workaround for Citrix Receiver X Error

Problem
When starting Citrix XenApp you get the following Citrix Receiver errors on your IGEL OS devices:
The X Request 55.0 caused error: "9: BadDrawable (invalid Pixmap or Window

parameter)"

The X Request 60.0 caused error: "13: BadGC (invalid GC parameter)".

Environment

« Citrix XenApp 7.15
« Citrix Receivere.g. 13.2,13.3,13.7,13.8

Solution
Two parameters have to be activated in IGEL Setup:

1. Go to System > Registry > ica > forceignorexerrors.

2. Activate Suppress X error message boxes.

3. Go to System > Registry > ica > wfclient > ignorexerrors.
4,

Activate IgnoreXErrors and pass the parameters: 55.0/9, 60.0/13

See also the corresponding entry in the Citrix forum?®.

4 https://discussions.citrix.com/topic/393872-possible-workaround-citrix-receiver-x-error-on-linux-thin-clients/
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Citrix HTML5 Receiver Issue

Affected Versions

+ IGEL 0S 10.05.100 or higher
+ IGEL0S 11.01.100 or higher

Issue

Due to the abolition of plugin technology in Firefox 60+, the Workspace app installed under Linux is no longer
automatically recognized.

Solution

1. Ifyour device has IGEL OS 10.05, update to IGEL OS 10.06; if applicable, you can also upgrade to
IGEL OS 11.02. If your device has IGEL 0S 11.01, update to IGEL 0OS 11.02.
IGEL 0S 10.06 and IGEL OS 11.02 have been adapted for a workaround that requires server-side
modifications.

2. Change the server-side settings according to the instructions under https://support.citrix.com/
article/CTX237727.
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ICA screen artifacts in Lotus Notes, OpenOffice, etc.

Symptom

Some remote applications such as Lotus Notes or OpenOffice have artifacts, so that menus may look damaged. This
happens in IGEL Linux 5.05.x or newer on hardware with the Intel Sandy Bridge chipset in ICA Sessions with old
Citrix server versions such as Presentation Server or XenApp <= 6.0.

Problem

The graphics driver has issues.

Solution

As a workaround, disable hardware acceleration:

Bl A

Apply your changes

* I voIp
» B windowmanager
yOx
* I dmx
» I drivers
» I fontpaths
» [ global
» I hide_cursord
» M hide_cursor0
» B nfs_fontdird
¥ [ server

B fallback resolu
B flatpanel

B noaccel

» B xc_fontservice

IGEL OS Articles
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B =xanccomposit
B =:anodownloat
B =xancuploadta

B force sbit_ves:
B migrationheuri:

’

In IGEL Setup, go to System > Registry
Locatethe x.server.noaccel entry
Check Disable hardware acceleration

Disable hardware acceleration

€) [¥] Disable hardware acceleration
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Macbook Keyboard Layout inside Citrix Session
To get the Macbook keyboard layout working correctly inside Citrix sessions, proceed as follows:

1. Under Sessions > Citrix > Citrix Global > Keyboard > Keyboard mapping file, select "Linux".
2. Under User Interface > Input > Keyboard > Keyboard type, select "Macbook".
All other keyboard layout settings can be left unchanged, i.e. as set by default.

() Inorderto type special characters like € and #, use the right-hand Alt/Option key, not the left-hand key.
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Using Lync / Skype for Business with Citrix HDX RealTime Optimization
Pack

Issue

You want to use Microsoft Lync or Skype for Business via a Citrix session with IGEL OS devices.

Solution

IGEL OS comes with Citrix HDX RealTime Media Engine (RTME) preinstalled: Setup > Sessions > Citrix > Citrix
Global > Unified Communications > Skype for Business. See also HDX Multimedia.

+ IGEL 0S 11.02.100 and higher contains RTME 2.8 (activated by default).
IGEL 0S 11.01.100 contains RTME 2.7 (disabled by default).

IGEL OS 10.06.100 contains RTME 2.8 (disabled by default).
IGEL OS 10.05.500 contains RTME 2.6 (disabled by default).
IGEL OS 10.05.100 contains RTME 2.6 (disabled by default).

For further information, see Citrix HDX RealTime Optimization Pack®.

5 https://docs.citrix.com/en-us/hdx-optimization/
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RDP

+ Mapping USB Storage Media into RDP Sessions (see page 75)

+ What Is the String for Token-Based Load Balancing? (see page 78)

« RDP RemoteApp Parameter Settings (see page 79)

« RDP Performance Enhancements (see page 80)

« 1Z1 RFX Performance Enhancement (see page 81)

+ RDP Session playing Sound: Error RDPSND_NEGOTIATE (see page 82)
+ Login Failed Because of Expired AD Password (see page 83)

+ User Has to Provide Credentials Twice for RDP Logon (see page 85)
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Mapping USB Storage Media into RDP Sessions

How to configure USB Storage mapping so that users can access USB storage media attached to the IGEL LX Client
within RDP sessions?

Solution:

(@ The mapping of USB storage devices is possible for "usb mass storage class" devices. The storage of
smartphones and digital cameras is usually accessed via the MTP protocol. Mobile device access via MTP is
available with IGEL Linux 10.04.100 or higher; for more information see the how-to Using Mobile Device
Access (see page 474).

Basic Configuration of the Client

< p 2 N ! ™ Devices ™ Storage Devices ™ Storage Hotplug

Configuration (] storage Hotplug

= Default permission [Read;’Write v]

Acc ries Client Drive Mapping ) | Dynamic ,.J

User Interface
Static Client Drive Mapping

Network ) D e s R S
F e |etter for each storage
Devices N 1
B Hardware Info
» I Printer Start storage drives with this drive letter A
¥ [ storage Devices IER rmit ik p e e kv el s ol i
CA readaccess 1or storage nOtplug aevices B
. Storage Hotplug
‘ Options ICA write access for storage hotplug devices Yes
B Slustooth Notificati
B UsE access control otfication
Eacirity [¥f] Hotplug beep
Hotplug message
System o S ?
—_0

Timeout
15 Seconds

Within the IGEL Setup or an UMS profile you basically need to configure these parameters:

> Activate Devices > Storage Devices > Storage Hotplug > Client drive mapping > Dynamic. This option
activates dynamic client drive mapping. It automatically recognizes new storage media as they are connected to
the thin client. The thin client beeps and shows a notification while it mounts the new device. The storage devices
automatically become usable on the thin client and in Citrix ICA Sessions.

€© Mounted devices need to be unmounted before they are removed to ensure data integrity. This can be
done via the Disk Utility, the new Safely Remove Hardware Tool or a tray icon.
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Additional Parameters to Check

» The following parameters are set by default, thus storage mapping will work, but maybe for some reason you
have changed these and need to adjust them to allow the storage mapping:

Sessions > RDP > RDP Global > Mapping > Drive Mapping > Enable Drive mapping (set checkmark)
Sessions > RDP > RDP Global > Native USB Redirection > Enable Native USB redirection (remove checkmark)

Sessions > RDP > RDP Global > Fabulatech USB Redirection > Enable Fabulatech USB redirection (remove
checkmark)

Devices > USB access control > Enable (remove checkmark)

Sessions > RDP > RDP Sessions > [session name] > USB Redirection > Enable Native USB Redirection (global
setting)

Sessions > RDP > RDP Sessions > [session name] > Mapping > Enable Drive Mapping (global setting)

Assigning a Drive Letter within the Session (Optional)

> Incase you not only want to see the drive in the session as e.g. "A on IGEL-123456789", but want to address the
drive with a real drive letter within the session, you may run one of these commands:

subst T: \\tsclient\t
or
net use T: \\tsclient\t

In this example "T on IGEL-123456789" is assigned to drive letter T: within the session. You may also assign the
mapped drive to another drive letter than is used in its name.

Configuration on the Server Side

On the server side, e.g. with Windows Server 2008R2, a user in the group "Users" with access to the terminal server
will have the mapping default. This is true for a newly installed server. But the mapping can be prevented by
changing the policies:

() Do not allow drive redirection Specifies whether to prevent the mapping of client drives in a Remote
Desktop Services session (drive redirection). By default, an RD Session Host server maps client drives
automatically upon connection. Mapped drives appear in the session folder tree in Windows Explorer or
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Computer in the format [driveletter] on [computername]. You can use this setting to override this
behavior." Source: https://technet.microsoft.com/de-de/library/ee791794%28v=ws.10%29.aspx

A

r
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What Is the String for Token-Based Load Balancing?

Environment

A token-based mechanism is used as a load balancing method. This document does not apply to other load
balancing methods.

Question

What string should be entered in Sessions > RDP > RDP Sessions > [Session name] > Options to make token-
based load balancing work?

Answer

IGEL OS 10.01 to 10.05.500, 11.01.100

» Under Sessions > RDP > RDP Sessions > [Session name] > Options > Load balancing routing token,
enter tsv://MS Terminal Services Plugin.l.[collection name] ,where

+ tsv://MS Terminal Services Plugin.1l. istheroutingtoken
and
+ [collection name] isthe name of the RDS collection, defined by the server administrator.

IGEL OS 10.05.700 or Higher, IGEL OS 11.01.110 or Higher

» Under Sessions > RDP > RDP Sessions > [Session name] > Options > Collection, simply enter the name of
your RDS collection. The collection name has been defined by the server administrator.
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RDP RemoteApp Parameter Settings

Symptom

RemoteApp is not starting or closes immediately after login.

Problem

Missing or incomplete session settings on server or device

Solution

1. Set an ALIAS for the RemoteApp with the RemoteApp Management Console on the
Terminalserver.

E RemoteApp-Eigenschaften

Eigenschaften |Benutzerzuweisung |

.
A Remotedpp-Mame:

I Microsoft Excel 2010

Pfad:

I %3 STEMDRIVE s \Program Files (oBaMicrosoft OfficeOfficel 41Exc

2. Usethat ALIAS value in the device's setting in Setup > Sessions > RDP > RDP Sessions > (Session
Name) > Server > Application.

€ O server (®) Enable RemoteApps mode

Server

ROP Port 3388
Application a IIIE)(CEL |

Command Line Parameters for the Executed Program

[[] changeable Server-URL on Local Logon

@® Add two pipe-characters (|| ) at the beginning of the ALIAS value.
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RDP Performance Enhancements

Symptom
RDP users have performance issues (bad user experience).
For example:

+ Mouse is lagging

+ Screen is building up very slow

+ Session uses high bandwidth

+ Several other performance issues

Problem

There are many different causes that can result in bad performance.

Solution

The following settings can be used as a single option and also in combination.

Basics

+ The color depth should be the same on the server, the device, and in the session (best: 32 bit).
+ Inthe BIOS, set the VGA shared memory to 64 MB or more.

Optimizations for a LAN Environment

+ Under Sessions > RDP > RDP Global > Performance, edit the settings as follows:
+ Disable Compression. (Increases performance, generates about 30% more traffic)
« If RemoteFX 8 is available, activate Enable RemoteFX.
+ If RemoteFX 8 is available, set RemoteFX codec mode to "Optimized for LAN".
+ If Windows Server 2012 R2 or lower or Windows 8.1 or lower is used: Under Sessions > RDP > RDP
Global > Multimedia, activate Enable Video Redirection.

Optimization for a WAN Environment

+ Under Sessions > RDP > RDP Global > Performance, edit the settings as follows:
« Enable Compression. (Generates about 30% less traffic, consumes more local resources)
« If RemoteFX 8 is available, activate Enable RemoteFX.
+ If RemoteFX 8 is available, set RemoteFX codec mode to "Optimized for WAN".
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|Z1 RFX Performance Enhancement

Symptom

RDP session with IGEL 1Z1 RFX client to Microsoft Windows Server 2012/2012 R2 does not support RemoteFX 7
(Calista Codec) resulting in low session performance.

Problem

RemoteFX 7 (Calista Codec) is not active on the server.

Solution
Activate RemoteFX 7 (Calista Codec) on Microsoft Windows Server:

1. Change following parameters of your group policy (either local or as domain policy):

a. Goto Computer Configuration > Administrative Templates > Windows Components >
Remote Desktop Services > Remote Desktop Session Host > Remote Session
Environment

b. Enable Limit maximum Color Depth

c. Set Color Depth = Client Compatible

d. Enable RemoteFX encoding for RemoteFX client designed for Windows Server 2008 R2
SP1

2. Inthethin client's setup (or UMS profile) enable Sessions > RDP > RDP Global > Performance >
RemoteFX

(® Make sure your server provides sufficient amount of RAM.
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RDP Session playing Sound: Error RDPSND_NEGOTIATE

Symptom

If the user plays some sound within the RDP session the connection terminates on some devices with error
message:

ERROR: RDPSND: Extra RDPSND_NEGOTIATE in the middle of a session

ERROR: TCP Connection: Cannot receive data (Keep alive timeout)

ERROR: RDPSND: Extra(RDPSND NEGOTIATE)in the middle of

a 5ession
ERROR: TCP Connection; Cannot receive data (Keep alive
timeout)

Problem

This may happen if during data transmission the connection fails.

Solution
Try a different sound driver for RDP session:

1. Go to System > Registry > rdp.winconnect.sound-driver
2. Choose 0SS or ALSA
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Login Failed Because of Expired AD Password

Issue

When you try to log in to a RDP session, you get the error message "Login Failed!" because your Active Directory
password expired.
You are unable to change your password because the local logon does not provide an option for that.

() Beforefollowing these instructions, check the ports:
+ Login to Client -> Port 88
+ Change password -> Port 464

Here you find an overview of ports of the Domain Controller: Required Ports to Communicate with Domain
Controller®

Solution

Enable Active Directory/Kerberos authentication for the RDP session. The next time you try to log in to IGEL OS,
you will be prompted to change your expired password.

Changing an Expired Active Directory Password

© When using sessions with passthrough authentication, it is essential that you lock your device's screen
when leaving it unattended.

Enabling Active Directory/Kerberos Authentication for RDP Sessions

1. InIGEL setup, go to Security > Logon > Active Directory/Kerberos.
Enable Login to Active Directory Domain.

Go to Security > Active Directory/Kerberos.

Activate enable.

Fill in the Default Domain (Fully Qualified Domain Name).

Go to Sessions > RDP > RDP sessions > [RDP session] > Logon.
Enable Use passthrough authentication for this session.

Click Appy or Ok.

NGO A WN

() Please note that the client must now be locked locally and no longer in the session to prevent another
person from entering the session via the passthrough without specifying the password.

6 https://social.technet.microsoft.com/Forums/windows/en-US/1c6a59de-c1fe-4946-bb4e-1fe36fd40b08/required-ports-to-communicate-with-
domain-controller?forum=winserverDS
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Enabling Screen Lock

ok W

6.

In the IGEL setup go to User Interface > Screenlock / Screensaver.
Enable Use Hotkey.

Under Modifiers select Win .

Under Hotkey enter "I".

Got to User Interface > Screenlock / Screensaver > Options.
Enable User Password.

So the "Win + L" hotkey locks the IGEL client instead of the session desktop.

The AD password must be entered to activate the IGEL clients.
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User Has to Provide Credentials Twice for RDP Logon

Issue

When you connect to a Windows terminal server, you are asked to provide your credentials twice.

Cause

This behavior is caused by the way RDS load balancing works. The crucial point to understand is that the terminal
server does not communicate with the session broker directly.

Instead, the scenario is the following:

1. The client connects to terminal server 1 and authenticates with terminal server 1. This is the first
time the user is asked for their credentials.

2. Since we have a load balancing setup, terminal server 1 will talk to the session broker and ask if
the client can use terminal server 1 or if it should be redirected to a different terminal server.

3. Ifredirection occurs, the client will also have to authenticate with the terminal server the client
was redirected to (terminal server 2 in the figure below). This is the second time the user is asked
for their credentials.

IGEL OS Articles 85/543



RDP |

Authenticates -
with Terminal
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Tarminal Server 1
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Terminal Server 2
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Accaptslogonto - C:Irent auth entk.:ates again, this
- time with Terminal Server 2

Terminal Server 1
or redirects to
Terminal Server 2

Z
>

Sestion Broker

Solution

The issue can be resolved by activating Kerberos/Active Directory authentication. For further information,
see Active Directory/Kerberos.
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VMware Horizon

+ Setting up VMware Blast Sessions (see page 88)

Use NLA (Network Layer Authentication) for Logon with Horizon Client Sessions (see page 89)
Workaround for Hotkeys in Horizon Sessions (see page 90)

Multimedia Acceleration with VMware Horizon View in VESA Mode (see page 91)
Troubleshooting the Horizon Client (see page 92)
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Setting up VMware Blast Sessions

Prerequisites

+ Licensed IGEL Multimedia Codec Pack
+ Device offering hardware video acceleration, see the FAQ Hardware Video Acceleration on IGEL OS.
« VMware Horizon 7 Server
For further information about the server configuration, refer to VMware's documents at http://
pubs.vmware.com/horizon-7-view/index.jsp

Activating VMware Blast

1. In Setup, go to System > Firmware Customization > Features.

Enable Hardware Video Acceleration.

Go to Sessions > Horizon Client > Horizon Client Global > Server Options.
Set Preferenced desktop protocol to VMware Blast.

Click Apply or Ok.

ok
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VMware Horizon

|

IGE

A

r

Use NLA (Network Layer Authentication) for Logon with Horizon Client
Sessions

Starting a session, even just presenting a logon screen, has quite an impact on resources. Each time a user tries to
logon, processes are started on the remote machine, no matter whether the user's credentials are valid or not. You
can save resources and prevent Denial of Service (DoS) attacks by using Network Layer Authentication (NLA). NLA
checks whether a user is the right person before any logon processes is started.

For more information about NLA, see https://technet.microsoft.com/en-us/magazine/hh750380.aspx.

NLA for Horizon Client Sessions is available from IGEL Linux version 5.08.100 upwards.

To use NLA for a Horizon Client session:

1. Open the setup and go to Sessions > Horizon Client > Horizon Client Sessions > [Session Name]
> Options.
2. Activate Network Level Authentication.
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VMware Horizon

Workaround for Hotkeys in Horizon Sessions

Issue

You want to switch from the VMware Horizon session to the IGEL desktop with the key combination [Ctrl]
+ [Windows] + [D]. But, by default, hotkeys have no effect in VMware Horizon sessions.

Solution
Create a custom command that adds the hotkey the system. It is recommended to use a profile:

1. Create a new profile. For more information about profiles, see Profiles.
2. Go to System > Firmware Customization > Custom Commands > Base.

3. Under Initialization enter this command: echo '<ctrl><super>0x020' >> /etc/

vmware/view-keycombos-config

() Formore information about hotkeys, see VMware Docs’.

4. Assign the profile to your device and reboot.

7 https://docs.vmware.com/en/VMware-Horizon-Client-for-Linux/4.6/linux-client-installation/GUID-05FE2CCC-9D84-4B37-AC9B-
D8CEC43D8567.html
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VMware Horizon

Multimedia Acceleration with VMware Horizon View in VESA Mode

Symptom

You did install IGEL Universal Desktop OS 2 on not fully supported hardware using IGEL Universal Desktop
Converter 2. Multimedia acceleration is not working within a VMware Horizon View session.

Problem

The graphics chip of your hardware is not supported and as a fallback the VESA mode is used.

Solution

There is no other solution to the problem than using fully supported hardware. Information on supported hardware
can be found in the UDC2 manual 8

You can also access IGEL's 3rd party hardware support database® to find fully supported graphic chips.

8 http://edocs.igel.com/index.htm#11873.htm
9 https://www.igel.com/linux-3rd-party-hardware-database/
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VMware Horizon

Troubleshooting the Horizon Client

& Solution Based on Experience from the Field

This article provides a solution that has not been approved by the IGEL Research and Development
department. Therefore, official support cannot be provided by IGEL. Where applicable, test the solution
before deploying it to a productive environment.

Symptom

There are some issues with the performance of the Horizon client.

Environment
+ IGEL OS 10 or higher

Problem

You don't know how to collect the log files and send them to the IGEL Support team.

Solution

1. Inthe Setup, go to System > Registry > sessions > vdmcient% > options > debug and activate
Save debug information (registry parameter: sessions.vdm_client%.options.debug).

2. Go to System > Registry > vmware > USB > log and set Set VMware Horizon USB debug level to
"debug" (registry parameter: vmware.view.usb.log).

3. Goto System > Registry > vmwarevdmapp > debug and activate Save debug
informations (registry parameter: vmwarevdmapp.debug ).

The log files are created in the /tmp directory and can be found using the following patterns:
/tmp/vvdm *
/tmp/vmware-*

4. Changeto /tmp and putthe logfilesinto a compressed tarfile: tar —-czf vmware-

logs.tar.gz [logfiles]

5. In the structure tree of the UMS Console, go to the device and select Device File->UMS the context
menu.

6. Under Devices file location, enter "/tmp/vmware-logs.tar.gz".

Under Target URL, select the location on the UMS Server where the file is to be stored.

8. Click Device->UMS.

~
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+ Authenticating with Evidian Authentication Manager (see page 94)
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Authenticating with Evidian Authentication Manager

You can connect to Citrix, RDP and VMware Horizon roaming sessions using RFID badges with Evidian Authentication
Manager (AuthMgr). Custom commands are supported as well.

Prerequisites

IGEL Universal Desktop Linux 5.06.100 or newer on the thin client.

An installed and running Evidian SSO Controller.

When using HTTPS (/GEL Linux 5.07.100 or newer), the User Access Server's CA root certificate saved
locally on the thin client.

The thin client and the server(s) have to be part of the same Active Directory domain.

A supported RFID reader (e.g. OMNIKEY 5022 CL, OMNIKEY 5421), connected to the thin client

RFID badges that are already enrolled.

Configuring an Evidian Authentication Manager Session

Hwn

oo

Go to Sessions > Evidian AuthMgr > Evidian AuthMgr Sessions in the thin client setup.

Add a new session.

Go to Sessions > Evidian AuthMgr > Evidian AuthMgr Sessions > [Session Name] > Connection.
Enter the User Access Service URL including protocol, name or IP address and port number

( [protocol]://[host]:[port]/soap).

Enter the Roaming Session Secret.

When using HTTPS, select the User Access Server's CA root certificate on the thin client as CA
certificate.

Select the desired Session Type in Options.

This will make Evidian Authentication Manager use the first configured session of its type, e.g. RDP.
Make sure that a session is configured.

@ Ifyou choose Custom commands you need to supply the commands (see page 96). You can
find further options in the IGEL Universal Desktop Linux manual.

Start the new session by clicking on its icon in the Start Menu. Alternatively, reboot the thin client.
In the default autostart setting the Evidian Authentication Manager for your session will start
automatically and wait for an RFID badge to be placed on the reader.

@ Youcan only start a single instance of an Evidian Authentication Manager session.
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Configuring Citrix/RDP/VMware Horizon Sessions

> Configure the session that you want to use with Evidian Authentication Manager as the first session of its kind.
Related Configurations provide shortcuts to these settings.

Using a Custom Configuration File

Instead of using the settings provided by IGEL setup you can enable a Custom configuration file under Options.
Then all the other session settings will be ignored. You find a commented template for the configuration file at /

etc/rsUserAuth/rsUserAuth.ini.

Logging in with Evidian Authentication Manager

1. Place your RFID badge on the RFID reader (or tap the reader with it, if you configured Tapping
Mode)

2. Your Citrix/RDP/VMware Horizon session will open if an active roaming session for your user
already exists. If it does not, you will be presented with a password prompt for the user's Active
Directory password.

3. Remove your RFID badge (or tap the reader again) to disconnect from the session.
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Custom Commands

The following simple shell scripts illustrate how to write custom commands that receive username and domain as
parameters from Evidian Authentication Manager.

In order to use them

1. Savethescriptsin /wfs/.
2. Make them executable with chmod a+x [filename].

3. Enter their full path (e.g. /wfs/start.sh)in Sessions > Evidian > [Session name] > Options.

Start Script
#!/bin/sh
# Sample start script
if [ $# -eq 3 ] ; then
# Start "session"
gtkmessage -t "Evidian Authentifcation Manager Login" -m "Login as user '$1'
with domain '$3'."
else
exit 1
fi

exit 0O

Stop Script

#!/bin/sh

# Sample stop script

# Close running "session"

pkill gtkmessage

gtkmessage -t "Evidian Authentication Manager Logout" -s 5 -S -m "Logout user
1§10,

exit 0
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Debugging and Troubleshooting

Debugging

1. Enable Debug mode in Sessions > Evidian > [Session Name] > Options in Setup and set the level
of detail.

2. Kill the Evidian Authentication Manager process (see Further Troubleshooting).

3. Start the desired Evidian session from the Start Menu.

4. Watch the outputwith tail -F /var/log/user/rsuserauth[Session

Number] .debug in Local Terminal. Alternatively, add the file to System Log Viewer.

() The session number starts with 0, not 1. To watch the output of the first configured session, use
thus tail -F /var/log/user/rsuserauth0.debug

Further Troubleshooting
1. Open Local Terminal
2. Enter ps fax | grep rsuserauth | grep -v grep tolook for Evidian Authentication

Manager processes.
3. Use the Evidian AuthMgr Restart session to restart all Evidian sessions if neccesary

OR kill unwanted processes by entering kill [process ID] intheterminal, start desired
processes via the Evidian entries in the Start Menu.
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IBM iAccess

+ Editing the List of Visible Menu Entries for IBM iAccess (see page 99)
+ Key Mapping for IBM iAccess Client (see page 101)
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Editing the List of Visible Menu Entries for IBM iAccess

You can simplify the menu of an IBM iAccess client session by removing items from the menu tree. You also can
restore the original menu.

Removing Menu Items

1. Inthe IGEL Setup, go to System > Registry > sessions > iaccessINUMBER] > options >
deletemenus (Registry key: sessions.iaccess[NUMBER].options.deletemenus).

[NUMBER] is the instance number of the session you want to configure; 0, for instance, stands for

the first session, 1 for the the second session, etc.
2. Inthe List of visible menu entries, using the mouse, mark the line with the entry you want to

delete:
List of visible menu entries

Y Edit|Preferences|TabSetup i
Edit|Preferences|Watermark

€) | Edit|Preferences|TranslationTable
Wiew

E1N

3. Pressthe backspace [ —] or delete [Del] key.
The menu item is deleted:

List of visible menu entries

Edit|Preferences|TabSetup &

#) | Edit|Preferences|TranslationTable
Wigw

E1S

( Ifyou delete a menu item that has subitems, the subitems will be invisible, too.

4. To remove further menu items, repeat steps 2 and 3.

5. Click Apply or Ok.
6. Start or restart the IBM iAccess client to check your changes.

Restoring the Original Menu
1. Inthe IGEL Setup, go to System > Registry > sessions > iaccessINUMBER] > options >
deletemenus (Registry key: sessions.iaccess[NUMBER].options.deletemenus).[N

UMBER] is the instance number of the session whose menu you want to restore; 0, for instance,
stands for the first session, 1 for the the second session, etc.
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2. Inthe List of visible menu entries, click the following symbol:

List of visible menu entries

@

[=A=10 La

T [T T s v T

Edit|Preferences|TabSetup

Edit|Preferences|TranslationTable

L.ljﬂ.

The original menu is restored.

3. Click Apply or Ok.
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Key Mapping for IBM iAccess Client

Problem

When you change the key mapping in the IBM iAccess client, the changes are not retained when the client is
restarted.

Applying the changes via IGEL Setup is not possible.

Environment/Prerequisites

+ IGEL 0S 10.05.100 or higher
+ UMS5.09.110 or higher
« IBMiAccess Client session is set up

Solution

Save the settings made in the IBM iAccess client in a file and distribute that file via the UMS.

Editing the Key Mappings

1. Open the IBM iAccess session and log on to your remote environment.
In the IBM iAccess client, go to Edit > Preferences > Keyboard.

On the Key Assignment tab, create the desired key bindings.

When you are finished creating key bindings, click Save as....

In the save dialog, choose File and edit the file path as follows: /userhome/IBM/

iAccessClient/Emulator/IBMi.kmp
6. Click OK.
The IBM iAccess client will recognize the file IBM1 . kmp as the default key.

o kN

Importing the Configuration File to the UMS
1. Openthe UMS.
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IGEL

2. Inthe navigation tree, find the thin client with the IBMi.kmp file and select Other Thin Client
commands > File TC->UMS in the context menu.
¥ 5 My Linux Thin Clients (3)

[ TCO00BCADSS
[ TCOnENCS114
L
¥ ' My Windows Thin
H |GEL-PEQ4BDS
[ TCO0ENCS139
o Mew devices (0)
12} ITCONEOCS36256
B mobile Devices (0)
S0 Shared Workplace s
B views (10
O Jobs (4
E Files 1)
" Universal Firmware U
® Search History (1)

T Recycle Bin (106

IGEL OS Articles

Mermary Size (MB)
Metwork Speed
Duplex Mode

=Y Edit Configuration

& Rename

] Delete

@ Clear '"Configuration Change Status' flag
ES Access control

2% cut
[&) Copy
[ Paste

Shadow

Secure Terminal
Suspend
Shutdown

Wake up
Rehoot

Lpdate & snapshot commands [
Other Thin Client commands

Send Message
Resetta Factary Defaults

Settings UMS-=TC
Settings TC-=UIMS
Lipdate deskiop customization

File LInS-=T0

File TC-=LIMS

Delete file from TG

Diowenload Flashplaver
Remaove Flashplayer

Store UMS Cedificate
Eemowve UMS Cerificate

Refresh license infarmation
Refresh system infarmation
Refresh Aszet Inventary data

sults

Take over settings from ...
Export Thin Client Settings

= Windows Updates and Hotfixes
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3. Under Thin Client file location, enter /userhome/IBM/iAccessClient/Emulator/

IBMi . kmp
File TC->UMS x
File TC-=mMS

TCOOEQCS362YEE

File information
& .Y

Thin Client file location § | fuserhomelBmMfiAccessClientEmulatorBMIi kmp |

Target LIRL -

File TC-=LIMS

LI TR B B L e B e B AR
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4. Click - to open the Save dialog. o

File TC->UMS x

File TC-=UmMS

[TCOOEQCA362TEE

File information
r Y

Thin Clientfile location | fuserhomelBwMfiAccessClientEmulatorBMI kmp |

Target URL -

File TC-=LIMS

LIS B B L e e B T
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5. Choose afile location within the ums_filetransfer folder.

File TC-=UMS
File TC-=LIMS

1 ITCODEDCA3627EE

File infor
—

Thin G

Look [n: lﬁ‘ wehday

v

Save x

- ]- ] Jojrs

ﬁ‘ ums_filetransfer

File Marme: |

Files of Type: | Al Files

Target URL

File TC-=LIMS
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6. Under File Name, enter IBM1i.kmp and click Save.

File TC->UMS
File TC-=UMS
[TCOOEQCAS362ZTEE
|
Look [n: lﬁ‘ ums_filetransfer "] m i
ﬁ‘ supportinfo lgelstart.jpg
6346891785 _17d4b31a9d_o.jpg kKyocera_FS-600_de.ppd
eDocs-Logo.png Maisons_Basques.jpg
elch.jpg stopweatch jpo
hedgehag-child_1920.jpa te_files_for_support 00EOCS13924
- L -
File Mame: |IElru1i.kmp |
Files of Type: | All Files v
File infor
F— [r—
Thin
Target URL -
File TC-=LIWMS
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7. Click TC->UMS. e

File TC->UMS x

File TC-=LIMS

[TCOOEOCA362VEE

File information
i i |

Thin Clientfile location | fuserhomelBwMfiAccessClientEmulatorBMI kmp |

Target LURL hitpsi1 72 .30 92 9:844 3fums_filetransferBMi kmp -

File TC-=LIMS

The file is stored within the UMS. Next, we will make it available as an object.
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Creating the File Object in the UMS

1. Inthe navigation tree, go to Files, open the context menu and choose New file.
5 Jobs ()
E

" Universal Firmware

Eename
Delete
Aecess contral

. Bearch History (13
T Recycle Bin (1063

- ot

[ Paste

Logoing: Messages

Connected to 1723092
[ Mew Directory
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S

IGE

A

r

2. Inthe New file dialq_g_l_, _;__hqg_sg__Sl_gl_e_q_f_ilgf[gln_\_9M§_§g[¥gr and click - to open the file gi_iglog.

File source
() Upload local file to UMS server
Lacal file -
Upload location (URL) |https:ﬁ{senfer:pnrtriums_ﬂletransfer |-

[ (® Selectfile from UMS ser\rer]
File location (URL) - |

File target

Classification [Undeﬂned "’]

Thin Client il location | |

Access rights

Read ‘Write Execute
owner [ [ &Y
others [ [ O

Cwiner .User b
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3. Inthefile dialog, find the file IBMi.kmp you created previously, and click Open.

New file

File source

Laocal

Chienigr

Others

O Lipload local file to UMS server

Liploa =
Laak |n: lﬁ ums_filetransfer '] [t i

® Selectf
File o IBMi_kmp tc_files_for_support
d_ojpg lgelstarnt.jpg tc_files_for_support
File target Kyocera_FS-600_de.ppd
mMaisons_Basgues.jpy
Clagsificat stopwatch,jpg
Thin Client - S
Accessrighi File Mame: B kmp |

R Files of Type: [ Al Files

[
[

Cwiner | Llser ¥
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4. Back in the New file dialog, enter the Thin Client file location as follows: /userhome/IBM/

iAccessClient/Emulator/

File source
O Lipload local file to UMS server

Lacal file -

Lipload location (URL) |https:Iksewer:pnrt:Iums_ﬂletransfer |-

(®) Selectfile from UMS server

File location (URL) ‘https:m 723092 8:8443ums_filetransferEmMi.kmp |-
File target
Classification [Undeﬂned ']

Thin Client file location |IuserhcumeJ‘IElMIiAccessCIienﬁEmulatnrﬂ |

Access rights

Read Wyrite Execute
owner ] [V &Y
others [ [ ]

Owner | User ¥

5. Ensure that the Access rights and Owner are set as follows:
« Owner rights: Read, Write, Execute
+ Owner: "User"
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File source
() Upload local file to UMS server

Lacal file -

Lipload location {(URL) |https:Iksewer:panIums_ﬂletransfer |-

® Selectfile from UMS server

File location (LURL) ‘https:m 723092 8:8443fums_filetransferBMi kmp |-
File target
Classification [Undeﬂned ']

Thin Client file location |IuserhcumeIIElMIiAccessClienﬁEmulatnrﬂ |

Access rights

(- Read “Wyrite E}:ecut;\
owner o ¥ &Y
others [ [ ]

Cwner .User v

J
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6. Click Ok.

File source
() Upload local file to UMS server

Lacal file -

Lipload location {(URL) |https:Iksewer:panIums_ﬂletransfer |-

® Selectfile from UMS server

File location (LURL) ‘https:m 723092 8:8443fums_filetransferBMi kmp |-
File target
Classification [Undeﬂned ']

Thin Client file location |IuserhcumeIIElMIiAccessClienﬁEmulatnrﬂ |

Access rights

Read Write Execute
owner o ¥ &Y
others [ [ ]

Owner | User ¥

The file object "IBMi.kmp" is created.
Assigning the File Object to Thin Clients

1. Inthe navigation tree, select the file object "IBMi.kmp" and click [ linthe Assigned objects area
(upper right).
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2. Inthe Select assignable objects dialog, select the thin clients to which you want to assign the new
key mapping and add them to the Selected objects area.

Select assignable objects x

Selected ahjects

= [ Master Profiles (2) [ ITCoOEDCET143A5
» [T Profiles (20) [ ITCONEDCA3R2TEE
¥ [ Thin Clients (&)
[ Import (o)
¥ E@ Wy Linux Thin Clients (3

L ITCO0EDCS] |

| N\
A E@ Wy Windowes Thin Clients (29 '

@ IGEL-PEQ4BDEYLY
@ ITCOOEQCS1 39243
[ New devices (0)
(‘.{z [TCOOEDCA362560
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3. Click Ok.
Select assignable objects x

+ [ Master Profiles (2
T Profiles (29)
¥ LI Thin Clients (5)
[ Import (o)
¥ F'E Wy Linux Thin Clients (3
[ TcoooeCADsant &
L ITCO0E 14345
L TCO0EDC
A F'E Wy Windowes Thin Clients (29
IGEL-PEQ4BDSYLY
[ 1TConEDCS1 39243
[ New devices (0)
‘ﬂ [TCODEDCS3E2460

Selected ahjects

[ ITCOOEDCET1 4348
[ ITCOOEDCA2GZ7EE

Cancel

4. Inthe Update time dialog, choose whether the file should be assigned to the thin clients at next

reboot orimmediately; then, click Ok.

When should these changes take effect?
() Mext Reboot

@ Mo

Update time bod

E] Alweays apply settings on next reboot (and don't show this dialog againg

Thefile is transferred to the thin clients.
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SSH

« Enable Weaker Algorithms in the Built-in OpenSSH Server (see page 118)
+ Enable Weaker Algorithms in the SSH Client (see page 119)
+ SSH: Deprecation of Weak Algorithms as of IGEL Linux 10.04.100 (see page 120)
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Enable Weaker Algorithms in the Built-in OpenSSH Server

Problem

You are trying to connect to IGEL Linux's built-in OpenSSH server with an SSH client which does not support the
strong algorithms of the server.

Solution
To enable weaker encryption algorithms, proceed as follows:

1. In Setup, go to System > Registry > network > ssh_server.
2. Change the settings according to your requirements:
+ disable_weak_encryption: Disable this option to enable weaker encryption.
+ disable_weak_hostkey_algos: Disable this option to enable weaker host key algorithms.
+ disable_weak_kexalgorithms: Disable this option to enable weaker key exchange
algorithms.
+ disable_weak_macs: Disable this option to enable weaker MACs.
« minimal_encryption_level: The minimal level of encryption
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Enable Weaker Algorithms in the SSH Client

Environment
IGEL Linux 10.04.100 or higher

Problem

You are trying to connect to an SSH server which does not support the strong algorithms enabled by default in the
SSH client.

Solution
To enable weaker encryption algorithms, proceed as follows:

1. In Setup, go to System > Registry > network > ssh_client.
2. Change the settings according to your requirements:
« disable_weak_encryption: Disable this option to enable weaker encryption.
+ disable_weak_hostkey_algos: Disable this option to enable weaker host key algorithms.
+ disable_weak_kexalgorithms: Disable this option to enable weaker key exchange
algorithms.
+ disable_weak_macs: Disable this option to enable weaker MACs.
« minimal_encryption_level: The minimal level of encryption
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SSH: Deprecation of Weak Algorithms as of IGEL Linux 10.04.100

As of IGEL Linux 10.04.100, certain older, less secure algorithms are deprecated in both the SSH client and server.

The following table shows the algorithms enabled by default as of IGEL Linux version 10.04.100.

Key exchange algorithms

Message authentication codes
(MACs)

Host keys

curve25519-sha256@libssh.org
ecdh-sha2-nistp521
ecdh-sha2-nistp384
ecdh-sha2-nistp256
diffie-hellman-group-exchange-sha256

hmac-sha2-512-etm@openssh.com
hmac-sha2-256-etm@openssh.com
umac-128-etm@openssh.com
hmac-sha2-512

hmac-sha2-256
umac-128@openssh.com

ssh-ed25519-cert-v01@openssh.com
ssh-rsa-cert-vOl@openssh.com

ssh-ed25519

ssh-rsa
ecdsa-sha2-nistp521-cert-v0l@openssh.com
ecdsa-sha2-nistp384-cert-vOl@openssh.com
ecdsa-sha2-nistp256-cert-v0l@openssh.com
ecdsa-sha2-nistp521

ecdsa-sha2-nistp384

ecdsa-sha2-nistp256

If you need to enable weaker algorithms, see Enable Weaker Algorithms in the SSH client (see page 119) and/or Enable

Weaker Algorithms in the Built-in OpenSSH Server (see page 118).
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Caradigm

« How to Prepare Caradigm (see page 122)
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How to Prepare Caradigm

Basic Configuration

This document explains how to configure certificates for Caradigm using a Windows server environment.

First of all, you have to give basic information to the Caradigm authentication server:

1. Go tothe Caradigm authentication server (Vault).
2. Gotothe SSO & Context Management tab.

3. Click Tap Server.

The Tap Server screen opens.

4. Check the values for the Way2Care Parameters:

+ Default Group Name
+ Default Grace Period

5. Add the values for the Badge ID Mapping Parameters:
+ Identity Field Name: Vendor

+ Identity Field Value: IGEL
+ Badge ID Format: Decimal

Badge ID Mapping Parameters

| Identity Field Name

ldentity Field Value

Badge ID Format |

User Agent Header

WTOS*

Hex

“endor

IGEL

Decimal

« Enrollment of Certificates (see page 123)
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Enrollment of Certificates

This is an overview of the files and hosts involved in certificate enrollment:

Server Environment Admin Environment

Windows Server CA Cortificate

GT
—1
—
ol

CA Cortificate

1l

Cliert

o mrmta =
Private Cartificate

b'vm"

PR p——

=

J

Cartificate
R=quest

Cliert
Certificate

*

J

Cliert
Certificate

J

Three files are required:

« SSL client private key
o SSL client certificate
o CA certificate

(@ Thethin client needs all three files. The Caradigm authentication server requires only the SSL client
certificate for SSL certification validation.

These are the steps for rolling out the certificates:
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Getting the CA Certificate from Certificate Authority (see page 125)
Requesting the Client Certificate (see page 126)

Sending all Certificates to TC (see page 130)

Transferring the public Certificate to the Caradigm Vault (see page 131)
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Getting the CA Certificate from Certificate Authority

In your environment you need to meet the following requirements:

+ An enterprise certificate authority (CA) running Windows Server 2008 R2.
« A Certificate Enrollment Web Service running Windows Server 2008 R2.

Getting the CA certificate from your CA:

1.
2.

»

In your web browser, visitthe URL http:// with /certsrv to go to the certificate authority.

Enter the User Name and Password.

The Windows server welcome page opens.

Select the task Download a CA certificate, certificate chain, or CRL.
IMPORTANT: Choose BASE 64 as Encoding method.

Click Download CA certificate.

You will receive a file with the CA certificate.
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Requesting the Client Certificate

Generating a certificate signing request (CSR) with OpenSSL

openssl req -out igel_tc.csr -new -newkey rsa:2048 -nodes -keyout

igel_tc.key
This produces the following files:

+ aprivate key: igel_tc.key

+ a certificate signing request (CSR): igel_tc.csr

Example for the creation of a certificate request:
Generating a 2048 bit RSA private key

writing new private key to 'igel_tc.key'

> Generating a 2048 bit RSA private key

writing new private key to 'igel_tc.key'

() Youare about to be asked to enter information that will be incorporated into your certificate
request. What you are about to enter is what is called a Distinguished Name or a DN.

There are quite a few fields but you can leave some blank. For some fields there will be a default value.

If you enter "', the field will be left blank.

Country Name (2 letter code) [AU]:DE
State or Province Name (full name) [Some-State]:Augsburg

Locality Name (eg, city) []:

Organization Name (eg, company) [Internet Widgits Pty Ltd]:IGEL Technology GmbH

Organizational Unit Name (eg, section) []:
Common Name (e.g. server FQDN or YOUR name) []:igeltc
Email Address []:
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» Please enter the following 'extra’ attributes to be sent with your certificate request

+ Achallenge password []:
+ An optional company name []:

() Itisalso possible to create a so called wildcard certificate. A wildcard certifcate contains a possible
common name including a * character. It can be used for all thin clients.

© Wildcard SSL certs could cause a security issue.

Requesting a certificate

1. Go back to the welcome page of the Windows server.
2. Select the task Request a certificate.
The Request a Certificate mask opens:

Microsoft Active Directory Certificate Senices -- caradigm-CARADIGMDCO1-CA

Request a Certificate

Select the certificate type:
User Certificate

Or, submit an advanced certificate request.

3. Click advanced certificate request.
The Submit a Certificate Request or Renewal Request mask opens:
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Microsoft Active Directory Certificate Senices -- caradigm-CARADIGMDCO01

Submit a Certificate Request or Renewal Request

To submit a saved request to the CA, paste a base-64-encoded C
external source (such as a Web server) in the Saved Request box.

Saved Request:

whwOzorx8d JVACkO/uAYTT 3kcCgogv 3SKBeqlkD4Y
Base-64-encoded |gskt1076Zn10Vp7Dju2C2lqevtNfXIGyU7ZAISS /
certificate request | rCamSrlXudmxR7UnuYUhvc /aGTDEC8RY IWMycvcU

(CMC or dv959QbSXPI3Iy7ZAr7gpxsTzKooUIaCvedbzoal

PKCS #10 or YM1ZpDKQc9iJnlsbOm7CAMUSGNEWGS3NxLjCotok

PKCS #7). |----- END CERTIFICATE REQUEST-----
= ) |

Certificate Template:

|§"u'|.n"eb Server 4 |

Additional Attributes:

Aftributes:

| Submit = |

4. Copy the plain text content of the .csr -file into the Saved Request input field.

Choose Web Server under Certificate Template.
6. Click Submit.
The Certificate Issued screen opens:

o

Microsoft Active Directory Certificate Senices -- caradigm-CAR:

Certificate Issued

The certificate you requested was issued to you.

"'DER encoded or © Base 64 encoded

1 Download certificate
| Download certificate chain

LR

7. Choose Base 64 encoded.
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8. Click Download certificate.
You receive a file with the public certificate for your thin clients.
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Sending all Certificates to TC
Now you have generated these three files:

« CA certificate
« SSL client private key
o SSL client certificate

1. Copy these three files into the directory /wfs/ca-certs of yourthin clients.

@ Preferably roll them out via UMS file transfer.

2. Reboot the clients.
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Transferring the public Certificate to the Caradigm Vault

o

Go to the Caradigm authentication server (Vault).
Go to tab Appliance.

Click Thin Client Certificates.

The Thin Client Certificates screen opens.

Client Certificates [ mport a certificate |

| Owner Name | Issuer Name | Valid From | Valid Until [Delete

I cicct o T sciect expired T reset T apoly |

Click Import a Certificate.

Copy and paste the plain text contents of the client certificate.

Click Apply.

The Thin Client Certificates screen has been filled with the certificate's values.

Now everything is prepared for secure communication with the Caradigm appliance.
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+ Define Multiple Start Pages for Your Browser (see page 133)

« Touchscreen: Multitouch/Gesture Support for Firefox (see page 134)
« Set Advanced User Preferences for the Browser (see page 135)

« Use the Browser in Kiosk Mode (see page 137)

o SSL/TLS Error with Firefox in Appliance Mode (see page 145)

+ Some PDFs are not opened by Firefox (see page 146)

« Canl Install Firefox Extensions? (see page 148)
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Define Multiple Start Pages for Your Browser

In some cases, a fixed set of start pages displayed in separate tabs may prove useful. For instance, if the browser is
working in kiosk mode, reusing a set of tabs from an earlier session is not an option.

Here is how to define multiple start pages to be opened at browser startup:

Configuration When browser starts | show my homepage v Related Configurations
" " User Interface -
B BM iAccess Client 4 Homepage https:/fkb.igel.com|https:/iwww.igel.co E Displ
A - isplay

= I ThinLinc

i SsH
» B VNG Viewer Display resolution | System setting vJ
Ll Smnser Minimum font size [None v]

v [ Browser Global
B Tabs
n Content
B Frint
n Proxy
‘ Privacy
n Security
B Advanced
n Encryption
B certificates
n Smartcard Middley
B commands
I EBrowser Sessions
» Il Flugins
= M Media Player
| WS Sessions
» I olP Client

] show browser splash screen

User Interface
Network
Devices

Security

System

Search

Open the setup and go to Browser > Browser Global.

Set When Firefox starts to Show my home page.

Set Homepage to the URLs that the browser should open at startup. Use "|" as a separator.
Click Apply or Ok.

Rl e
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Touchscreen: Multitouch/Gesture Support for Firefox

You can use multitouch/gestures in the Firefox browser that is built into IGEL OS 10 and IGEL OS 11. This is done by
adding an environment variable.

To enable multitouch:

1. Open the local Setup or the UMS configuration dialog and go to System > Firmware
Customization > Environment Variables > Predefined.

2. Inthefirst free Variable name field, enter MOZ_USE_XINPUT2

3. Inthe corresponding Value field, enter 1
Click Ok.

IGEL Setup 11.03.258.01 (Build 6.3.11)

m ™ Firmware Cu: zation ™ Environmen es * Predefined

Variable name €) MOZ_USE XINPUTZ Value

Variable name Value
Variable name Value
Variable name Value
Variable name Value
Variable name Value
Variable name Value
Variable name Value
Variable name Value

Variable name Value

Search

5. Reboot the device.
6. To check if multitouch is working, open the Firefox browser and go to https://www.paulirish.com/
demo/multi.
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Set Advanced User Preferences for the Browser

The Mozilla Firefox browser included in /IGEL Linux offers a vast array of configuration options. They range from the
sorting order of Bookmarks over encryption algorithms to fixing quirks in web applications that a re important to
you. In total, they are too many to present them as individual items in IGEL Setup. However, as of IGEL Linux version
5.09.100 IGEL Setup lets you set any Browser user preference in a generic way.

© Changes to the advanced Firefox browser settings can impair its stability, security and speed. IGEL Support

is not responsible for problems caused by changing the browser configuration, even if the browser
configuration was changed in IGEL Setup.

You will find information regarding the configuration parameters for Firefox in the MozillaZine Knowledge Base
under Firefox About:config entriest®.

1.
2.

Hw

In Setup, go to Sessions > Browser > Browser Global > Advanced.
In the Custom preferences area, click on Add.

Configuration J @ — ((. - (r. =
% Sessions — — =2 14 =2

> Parallels Client

> PowerTerm WebConned
> PowerTerm Terminal E
»

>

Tabs Content Print Proxy Privacy  Security Advanced Encryption Commands

-l

IBM ISerieshccess
ThinLine
55H
> WHC Viewer
WERDE Sessions
v Browser
v Browser Global

[] use old searchbar
[[] Always use the cursor keys to navigate within pages

[ Find &s You Type

] warn me when websites try to redirect or reload the page

Check my spelling as | type {On for multi-line controls v]

Tabs
Content
Print [ Use autoscrolling
Proxy [[]J Use smooth scrolling
Privacy
SEBUIiEY [_] Disable GStreamer in Browser
Advanced
; [[] Disable OpenGL acceleration
Encryption
Commands
> Browser Sessions Custom preferences

3 Plugins
> Media Player
> WS Sessions
> WolP Client

Active | Mode Custom preference | Type | value

Accessories
Search

Apply m Cancel

Using the Active option, specify whether the configuration parameter is to be active.

Specify the Mode of the configuration parameter - for many cases pref will do.
Under Custom preference, give the name of the configuration parameter. Example:
ui.textSelectBackground

Specify the Type of the configuration parameter.
Possible values:

10 http://kb.mozillazine.org/About:config_entries
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« String: The value is a string of characters.
+ Integer: The value is a whole number.
+ Boolean: The valueis a Boolean value,i.e. true or false.

7. Specify the Value of the configuration parameter. The possible entries depend on the Type
selected.

8. Click Ok.
The configuration parameter will take effect the next time that the browser is launched.
For more details on Browser configuration, refer to its section in the IGEL Linux manual.
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Use the Browser in Kiosk Mode

Browser kiosk mode is an option when you are operating any kind public terminal with anonymous access, e. g.:

+ Educational service in a musem
« Service terminals or ticket vending machines for public transport
« Entry portal for a corporate intranet

Albeit configuring an IGEL Linux thin client for browser kiosk mode may seem quite extensive, you have the
possibility to define your own flavour of kiosk mode. Consider the following settings.

Settings in Setup > Sessions > Browser Sessions > [Session Name]

Configuration

Sessions

B sessions Summary

B Global Session Options
» Il Citrix XenDesktop / XenApp
» [ RDP
» I Horizon Client

B 2ppliance Mode
» Il caradigm

B Leostream

W AppliDis
» [ Evidian AuthMgr

I NoMachine MX Client
» [ Parallels Client

I EM iAccess Clisnt
» [ ThinLinec
» [ S5H
» B VNG Viewer
v [J Browser
» [ Browser Global
v [J Browser Sessions
» [ Kiosk
» [ Plugins
» [ Media Player
M WS Sessions
» I VoIP Client

> Activate Autostart.

> Activate Restart.

IGEL OS Articles

Session Name

Kiosk

» Il PowerTerm Terminal Emulation

Starting Methods for Session
[2] Start Menu

[¥] Application Launcher

[J Desktop

M) Quick Start Panel

[] start Menu's System tab
[[] Application Launcher's System tab
[[] Desktop Context Menu

Menu folder

Application Launcher folder
Desktop folde

Password Protection |Mone

M

[V Autostart requires network
] Hotkey

V] Autostart
V] Restart

Autostart Delay
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Related Configurations

When browser starts Show my homepage

¥ [ Browser
» I Browser Global
v [ Browser Sessions — Browser Global
¥ [ Kosk Display resolution | Global setting M|
» B Settings
B window
B Menus & Toolbars
B Hotkeys
B context
B Deskiop Integration |
» [ Plugins
» Il Media Player
I WS Sessions

E User Interface -
Display

e

Homepage http:fledocs.igel.com

Minimurn font size | Glebal setting |

» Set When browser starts to Show my home page.

» SetHome Page to the desired home page.

Settings in Setup > Sessions > Browser Sessions > [Session Name] > Settings > Tabs

< > ~ ! ¥ Sessions ™ Browser ™ Browser Sessions * Kiosk ™ Settings ™ Tabs

Configuration New pages should be opened in [the current window || | Related Configurations
¥ LI Browser ] Tabs
> I Erowser Global Warn me when closing multiple tabs |off v
v [ Browser Sessions —
v [ Kiosk Warn me when opening multiple tabs might slow down the browser | Off v
¥ O Settings
B Tabs
‘ Content
B Print
B Proxy
. Privacy ]
B security
B Advanced
B Encryption
B Restart
B window
B Menus & Toolbars

‘When a link is opened in a new tab, switch to it immediately | Off 'J

> Set New pages should be opened in to the current window or to a new tab.
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Settings in Setup > Sessions > Browser Sessions > [Session Name] > Settings >
Content

5 ® Browser ™ Brow ns * Kosk * Settings * Content

Configuration Block pop-up windows [on +|| Related Configurations
> I Thintine Load images automatically [on v tontent
» I SSH
» I VNG Viewer Type of download directory | Global setting v
¥ [ Browser =

» I Browser Global P

¥ [J Browser Sessions

¥ O Kiosk Enable JavaScript [on v
v Elaefrtlr;gs [] Raise or lower windows

. Cin:en[ ) Move or resize existing windows
B Frint [ Disable or replace context menus
‘ Proxy
B Privacy Languages for Web Pages
B security
B Advanced
B Encryption
B Restart

B window

Apply Ok

> f applicable, activate Block pop-up windows.

> Activate Load images automatically.

> Activate Enable JavaScript if desired, and adapt the actions permitted for JavaScript according to your needs.
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Settings in Setup > Sessions > Browser Sessions > [Session Name] > Settings >

Privacy

< > A [ *Sessions

Configuration
— —

» [ Parallels Client
» I PowerTerm Terminal Emulation
I IEM iAccess Client
» [ Thinlinc
» I SSH
» [l VN Viewer
v [ Browser
» [ Browser Global
¥ [ Browser Sessions
¥ O3 Kiosk
¥ [ Settings
B Tabs
B content
B Print
n Proxy

* Browser ™ Browse

Save Browsing History (in days)

Save information entered in forms and the Search Bar

Remember Passwords

* Settings

| Do not save History

| otf

(off

Clear private data when closing browser

Select the items to be cleared

Browsing History |on

J

Form & Search History [on

|

Saved Passwords [on

M

|on

Cookies

Cache

Active Logins

B Privacy

B security
B Advanced
B Encryption
‘ Restart
B window
B Menus & Toolbars
B Hotkeys
B context
B Desktop Integration
» [ Plugins
» [l Media Player
I jws Sessions
» [ volP Client

Accessaories

v v v v Y

Allow private browsing feature

Always start in private browsing mode

Enable "Do Not Track” feature

Enable built-in tracking protaction

Suggest visited sites in URL bar
Suggest only typed visited sites
Suggest bookmarked sites in URL bar

Suggest open pages in URL bar

Deactivate Remember Passwords.

Activate Clear private data when closing browser.

Activate all items in the area Select the items to be cleared.

| Global setting

| Global sstting

LGiobaI setting

| Global setting

Set Save Browsing History (in days) to Do not save History.

Deactivate Save information entered in forms and the Search bar.

Related Configurations

Privacy

> If you want to suppress any tracking of the user's activities, activate Allow private browsing feature and
Always start in private browsing mode.

> it applicable, activate Enable "Do Not Track" feature.

» To make the browser block domains and websites which are known for tracking users, activate Enable built-in

tracking protection.
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Settings in Setup > Sessions > Browser Sessions > [Session Name] > Settings >
Security

£ > -~ { ™ Sessions ™ Browser ™ Browser Sessions * Kiosk * Settings ™ Security

Safe Browsing Related Configurations

Malware Protection [on v Security

Configuration

> [ Parallels Client
» I PowerTerm Terminal Emulation
I 1BM iAccess Client
» I ThinLinc
» Il SSH
> I VNG Viewer
v [ Browser
» [ Browser Global
v [ Browser Sessions
v [ Kosk
¥ [ Settings
B Tabs
B content
B Print
B Proxy
B Frivacy
R Security |
B Advanced
. Encryption |
B Restart
B Window

» Toenable phishing protection, activate Safe Browsing.

» Toenable protection against malicious downloads, activate Malware Protection.

Settings in Setup > Browser Sessions > [Session Name] > Settings > Restart

( ) -~ { ™ Sessions ™ Browser ™ Browser Sessions ™ Kiosk ™ Settings ™ Restart

Configuration [ Autostart
SorTe SAS S LES ¥ Restart
» I Parallels Client

[/l Restart after idle time
» B PowerTerm Terminal Emulation

W BM iaccess Client Idle time after which a restart oceurs (30
» [ ThinLinc )
> Il SsH Unit | Minutes v

» [ VNC Viewer
¥ [ Browser
» [ Browser Global
¥ O Browser Sessions
¥ [ Kosk
vy Sample valie
B content
B Frint
R Proxy
B Privacy
B security
B Advanced
B Encryption |
B Restart ]
B Window

> Activate Restart. The browser will restart automatically if a user closes the browser window.

> If you want the browser to restart automatically after some idle time, activate Restart Timeout enabled and
set a Restart Timeout in minutes.
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sions * Klosk * Window

Configuration B start In fullscreen mode

» I ROP a ] Start Monitor | 1st monitor -
» Il Horizon Client

B 2ppliance Mode Firefox Translation | System setting M|
» [ Caradigm

W Leostream ] Hide local filesystem

I ~ppliDis V] Hide configuration page of the browser

» [ Evidian AuthMgr
I roMachine NX Client
» M Parallels Client
» [ PowerTerm Terminal Emulation
Il |EM iAccess Client
» Il ThinLinc
» Il SSH
» Il VNG Viewer
¥ [ Browser
» [l Browser Global
¥ [ Browser Sessions
v [ Kiosk
¥ 3 Settings |
B Tabs
B Content
B Print
R Proxy
B Privacy
n Security Q
B Advanced
R Encryption
B Restart
B window
B Menus & Toolbars

> |f the browser shall run in fullscreen mode, activate Start in Fullscreen Mode.
i necessary, select the correct Start Monitor.
> Activate Hide local filesystem.

> Activate Hide configuration page of the browser.
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Settings in Setup > Browser Sessions > [Session Name] > Settings > Menus & Toolbar

/ » Sessions ™ Browser ™ Browser Sessions ™ Kiosk ™ Menus & Toolbars

Configuration

» I RDP
» I Horizon Client
B 2ppliance Mode
» Il Caradigm
I Leostream
| AppliDis
» [ Evidian AuthMgr
I NoMachine MX Clisnt
» I Farallels Client

» Il PowerTerm Terminal Emulation

I IBM iAccess Client
» [ ThinLinc
» I ssH
» Il VIC Viewer
¥ [ Browser
» [ EBrowser Global
v [ Browser Sessions
v [ kiosk
¥ [ Settings
B Tzabs
B content
B Frint
‘ Proxy
B Privacy
B security
B Advancad
B Encryption
B Restart
B window

(] Hide App Menu/Menu Bar

[ Use old Menu Bar

Hide the following items in App Menu/Menu Bar

[] Hide Tabs Toolbar
[ Hide Bookmarks Toolbar
(] Hide Sidebar

Toolbar items

(] Hide URL Input

[¥] Hide "Print™ Button
[_] Hide "Home" Button

[[J Hide MNavigation Toolbar

[J Hide the Toolbar for searching the page

[] Hide Search Input
(/] Hide "Bookmarks® and "RSS Feed" Button

Toolbarconfig

] User Customization of toolbars

i Manus & Toolbars

B Hotkeys
B context
B Desktop Integration

Navigation Toolbar

Application Menu

> Activate Hide App Menu/Menu Bar.

» Select which menus and toolbars are to be hidden.

» Deactivate User Customization of toolbars.

Disabling Access to Developer Tools

Reset icon configuration to default

To disable access to the developer tools, add the following custom preference.

For general instructions on adding custom preferences, see Set Advanced User Preferences for the Browser (see page

135).

Mode pref

Custom devtools.toolbox.host
pference

Type String

Value (leave the value field empty)
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Disabling Crash Reports
To disable crash reports, add the following three custom preferences.

For general instructions on adding custom preferences, see Set Advanced User Preferences for the Browser (see page
135).

Mode pref

Custom datareporting.policy.dataSubmission
pference

Type Boolean

Value false

Mode pref

Custom datareporting.healthreport.upload
pference

Type Boolean

Value false

Mode pref

Custom toolkit.telemetry

pference

Type Boolean

Value false
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SSL/TLS Error with Firefox in Appliance Mode

Symptom

Firefox on IGEL Linux 5.07.100 warns of an SSL/TLS error in appliance mode that does not occur in normal window
mode. The error code is ssl_error_unsupported_version. This does not happen on IGEL Linux 5.06.x.

Problem

You cannot connect to the affected HTTPS service.

Solution
As a workaround you can instruct Firefox to ignore issues with SSL/TLS versions:

1. InIGEL Setup, go to System > Firmware Customization > Custom Commands > Base
Commands
2. Enter the following command into the After Session Configuration input field:

echo "clearPref(\"security.tls.version.min\");" >> /services/fbrw/

firefox/firefox.cfg

There is also an IGEL Linux private build that addresses this issue.
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Some PDFs are not opened by Firefox

Symptom

When opening some PDFs from the Internet, the Mozilla Firefox browser opens a new window or tab, but fails to
display the PDF contents.

Problem

This can be due to a malfunction of the mozplugger Firefox component.

Solution

Disable mozplugger. Firefox will download the PDF document and open it with a local application (/GEL Linux
5.07.100 or newer):

1. Go to System > Registry in /GEL Setup.
2. Use Search Parameter ... to find the parameter
browserglobal.app.dom_ipc_plugins_enabled_mozplugger_so.

Check Completely disable mozplugger.
Confirm the setting with Apply or OK.
5. Restart Firefox.

> w
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< >

Configuration
s ons
Acc
User Interface
Network
Devices
Security
System

B Time and Date
» [ Update
» I Remote managemeant
» Il Remote Access
B Remote Syslog
» [l Power Options
» M Firmware Customization
‘ Registry

1y

IGEL Setup 10.05.500.01 (Build 5.9.18)

* Regis

Search amete

B conv_proxy_autoconfig_url
B conv_proxy_autologin
B conv_proxy_ftp
B conv proxy ftp_port
B conv_proxy_http
B conv proxy http_port

» [ conv_proxy_preset_cred
B conv proxy socks
B conv_prowy_socks_port
B conv_proxy_socks_version
B conv_proxy_ss!
B conv_proxy_ssl_port
B conv_proxy_type
B conv_save_browsehistory
B conv save forms
B conv_save_passwords

> I custom_config
B deactivate_hotkeys

B disablegstreamer
B disableopengl
B dom_disable_open_during_load

B dom_disable window flip

B dom_disable_window_move_resize

B dom event_contextmenu_enabled

B dom_ipc_plugins_enabled libflashplayer_so
B dom_ipc_plugins_enabled libnpjp2_so

B dom_ipc_plugins_enabled_libnptest_so

browserglobal.app.dom_ipc_plugins_enabled_mozplugger_so

Isolate PDF Viewer plugin process from the browser process

] Isolate PDF Viewer plugin process ...

B dom_ipc_plugins_enabled_libtotem-cone-plugin_s
B dom_ipc_plugins_enabled_libtotem-gmp-plugin_s
B dom_ipc_plugins_enabled_libtotem-mully-plugin_s
B dom_ipc_plugins_enabled libtotem-narrowspace-
B dom_ipc_plugins_enabled_mozplugger_so

B dom_ipc_plugins_enabled npica_so

B dom_ipc_plugins_timeoutsecs

Search

Ok Cancel
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Can | Install Firefox Extensions?

Question

Can Firefox extensions be installed?

Answer

The installation of Firefox extensions is not possible. This applies to any version of both IGEL Linux v5.x and IGEL OS.
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System

+ Resetting a Device with Unknown Administrator Password (see page 150)

« How to Show the Boot Mode of IGEL OS (see page 152)

Disabling Features to Reduce Firmware Size (see page 153)

Fabulatech USB Redirection Server Component (see page 154)

Which Features of IGEL OS Will Be Affected If the UMS Is Down? (see page 155)
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Resetting a Device with Unknown Administrator Password

Symptom

An administrator password has been set on IGEL OS (via Setup > Security > Password > Administrator) but it has
been lost.

Problem

The local setup is not accessible without the password. Also, resetting the device to factory defaults seems
impossible.

Solution

+ Change the administrator password using IGEL UMS via Setup > Security > Password >
Administrator
or

+ Reset the device using IGEL UMS via Thin Clients > Other commands > Reset to Factory Defaults
in the UMS menu.
or

+ Reset the thin client locally using a reset to defaults key provided by IGEL (as described below):

1. Pressthe [ESC] key repeatedly in rapid succession while the device is booting.
This will bring up the boot menu.

Juiet boot
Uerboze boot
Emergencg huut (Setup unlg]

RESE'I'. to facturg defaults j_

2. Choose Reset to factory defaults and press [Enter].
The following will be displayed:

Loading "German" keyboard layout.
The Administrator Password is required to reset the terminal settings.
If your Administrator Password is not available anymore, enter 3 times return.

Fassword :
Authentication: Authentication failure

Fassword :
Authentication: Authentication failure
Fassword: _

3. Press [Enter] three times without supplying a password.
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nter <{c> if guu want to continue and reset the terminal settings

in case your Administrator Password i= mot available anymore.
<r> Oor <cr. _

4. Enter[c] and press [Enter].
The software will then display a terminal key. Make a note of it, as you need it for requesting the
reset to defaults key from IGEL.
5. Request a reset to defaults key from IGEL. Write an email to license@igel.com™ containing
« your terminal key
+ your email address as registered with IGEL support
« your company address
« your phone number

IGEL will send you the reset to defaults key.

6. Inthe current session, enter [e] and press [Enter] to shut down the device.

7. Onreceiving the reset to defaults key, repeat steps 1 to 3 to boot the device with the same
terminal key.

Enter [c] and press [Enter]. You will be prompted to enter the reset to defaults key.
3) enter now the “"reset to defaults key"”, you got by the service team
for "terminal key" 39099-53083-29440-48934 and firmware version 5.03.100.01
(you have only three tries to enter the key correctlyt)

1. Try: _

9. Enterthe reset to defaults key. Enter yes and press [Enter] to confirm resetting the client. All
local thin client settings will be lost.

Should you enter the wrong key or mistype the key you will have to resume from step 1.

11 mailto:license@igel.com
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How to Show the Boot Mode of IGEL OS

To check the boot mode of IGEL OS, proceed as follows:

1. Open the IGEL start menu.

2. Click thei-icon.
The About dialog opens.

3. Find the parameter Boot Mode under the Hardware section.
Example: BIOS

IGEL OS Articles 152 /543



System

Disabling Features to Reduce Firmware Size

Symptom
You want to update your IGEL OS firmware to a higher release version, but the firmware update requires more disk
space. Updating devices with less disk space than required leads to an error: Not enough space on local

drive.

Problem
The size of the new firmware

+ with all enabled software features included

+ with the Adobe Flash plugin partition

« with the Firefox profile partition

+ possibly with a custom partition

+ possibly with custom wallpaper and bootsplash

exceeds the device's disk space (e.g. 2 GB).

Solution
Disable firmware features not needed for productive operation to reduce the size of the firmware:

In IGEL Setup, go to System > Firmware Customization > Features.
Disable features not needed in your environment.

Activate your settings with Apply or OK.

Reboot the device.

Update the device.

ok wnNE

(@ Use profiles with UMS in order to deactivate features on a group of devices.
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Fabulatech USB Redirection Server Component

Issue

For Fabulatech USB Redirection, a special Fabulatech server component must be installed on the Citrix or RDP
server (USB for Remote Desktop IGEL Edition). More detailed information on the function can be found on the
Fabulatech partner site, On this site the server component is available for download.

Current versions are (as of 2017-05-29):

+ USB for Remote Desktop IGEL Edition Ver.3.1.5
+ USB for Remote Desktop IGEL Edition V5 Ver. 5.0.2

Problem
Which version is suitable for which IGEL Linux device?

Release notes of IGEL Linux only name the version of the Fabulatech client included but miss out the necessary
server component version.

Solution
> All Fabulatech clients version 3.x require server component version 3.x

> All Fabulatech clients version 5.x require server component version 5.x
So for IGEL Linux thin clients following requirements apply:

« IGEL Linux v4 devices up to current version 4.13.270 require server component version 3.x
« IGEL Linux v5 devices up to version 5.02.100 require server component version 3.x

+ IGEL Linux v5 devices from version 5.03.100 and later require server component version 5.x
+ IGEL Linux 10.x requires server component version 5.x.

12 http://www.usb-over-network.com/partners/igel/
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Which Features of IGEL OS Will Be Affected If the UMS Is Down?

Overview

In general, IGEL OS works independently of the Unified Management Suite (UMS). This includes, for instance, all
remote desktop clients like Citrix, RDP, or VMware Horizon, and browsers.

Any configuration changes that are made via the UMS are stored on the device and thus remain stable when the
UMS is down.

However, the Shared Workplace (SWP) feature and administration functions are affected by a UMS outage.

The following sections list the details.

Productivity Features That Are Affected If the UMS Is Down
+ Login via Shared Workplace (SWP); see Shared Workplace (SWP)

Administration Functions That Are Affected If the UMS Is Down

+ Configuration changes

+ License Management

+ Secure Shadowing

+ Secure Terminal

« Universal Firmware Update

+ Firmware Customizations

« Transfer of files to the device, including Custom Partitions
+ Remote commands, such as Wake-on-LAN or restart
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« Configuring Open VPN Sessions (see page 157)

+ Running the OpenVPN Client with a Preconfigured Configuration File (see page 169)
« Configuring Wi-Fi Network Roaming (see page 171)

« Connecting to a Wi-Fi Network with Hidden SSID (see page 173)

« Improving WiFi Connectivity (see page 174)

+ Preventing Permanent Storage of Wireless Network Keys (see page 178)

« Using WPA Enterprise / WPA2 Enterprise with TLS Client Certificates (see page 179)
« |IPv6 Settings (see page 183)

« Extended Logging With Syslog, Tcpdump and Netlog (see page 187)

« Making a Telnet Connection from IGEL Linux (see page 201)

+ Configuring Dynamic DNS Updates via DDNS (see page 202)

« Changing the SMB protocol version (see page 204)
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Configuring Open VPN Sessions

This document describes how to configure the OpenVPN Client on IGEL Linux.

Prerequisites

+ A configured and running OpenVPN 2.x server

+ Information about the OpenVPN server configuration (e.g. authentication method)

+ Athin client with IGEL Linux 10.01.100 or newer

+ The certificate and private key files for the client, along with the root certificate of the CA that
signed the client and server certificates.

« Optionally, a Smartcard or eToken supported by IGEL Linux.
To learn how to distribute keys and certificates to the thin clients, refer to the How-To document
"Securely Distributing Keys and Certificates (see page 168)".

« Authenticating with TLS Certificates (see page 158)

« Authenticating with Name/Password (see page 159)

+ Authenticating with Name/Password with TLS Certificates (see page 160)
« Authenticating with Static Key (see page 161)

« Options and TLS Options (see page 162)

« DNS and Routing Options (see page 163)

» Proxy (see page 164)

« Checking the VPN Connection (see page 165)

« Automatically Starting the VPN During Boot (see page 166)

o Further Information (see page 167)

« Securely Distributing Keys and Certificates for OpenVPN (see page 168)
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Authenticating with TLS Certificates

1.

Go to Network > VPN > OpenVPN and create a new connection.

In the Session section for the new connection, enter the name or public IP address of the
OpenVPN Server.

Select TLS-Certificates as the Authentication Type.

Select the client certificate as the Client Certificate file.

Select the root certficate of the CA as the Certificate Authority (CA) file .

Select the client's private key as the Private Key file. Enter the passphrase in Private Key
password if the key is protected with one.

®* Opent'Ph Connection

OpenyPR Server(s) |1?2.3IZI.EI1 136 |

Configuration

B Mobie Broadband
» Il DHCP Client
¥ [ ven
O Open WPM
r[O Open'yPN Connection
. Session
‘ Options

Click anicon for the newly created session (e.g. in the Start Menu) to initiate the connection.

Sessions Authertication Type | TLE-Certificates v
-"—". SCESS "'.._:
AEEESSANES Clientt Centificate file |clier|t.u:rt |
User Interface
CA certificate file |ca.cr1 |
- . LAM Interfaces Private key file ||:Iier|t.ke3-' |

EEEEE

Private Key paz=ward

@ IfaPKCS12fileis available, which includes the client certificate, the certificate authority
and the private key, then you just need to enter the PKCS12 file name in the three
corresponding fields. The advantage is that you only have to roll out one single file instead
of three different files.
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Authenticating with Name/Password

1. Goto Network >VPN > OpenVPN and create a new connection.

2. Inthe Session section for the new connection, enter the name or public IP address of the
OpenVPN Server.

3. Select Name/Password as the Authentication Type.

4. Enter the Username. If you leave this field blank the user will be prompted for the Username when
connecting.

5. Check Password required.

6. Enter the Password. If you leave this field blank the user will be prompted for the password when

connecting.

Select the root certficate file of the CAAs the Certificate Authority (CA) file.

} ot i " network ™ VPN ™ Open PR P OpenPR Connection

Configuration Open'PM Server(s) | 172.30.91 136

Authertication Type lNamEJPasswcurd T]

Uzer name | client1 |

User Interface
[;_f] Passward recuired

Pazsward ******|

» I L&N Interfaces
B obile Broadband
» Il DHCP Client
¥ 3 ven
O3 Open VPN
A | Open'PH Connection
. Session
n Cptions

8. Click anicon for the newly created session (e.g. in the Start Menu) to initiate the connection.

CA& cedificate file ||:a.|:rt |
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Authenticating with Name/Password with TLS Certificates

1. Goto Network >VPN > OpenVPN and create a new connection.

2. Inthe Session section for the new connection, enter the name or public IP address of the
OpenVPN Server.

3. Select Name/Password with TLS-Certificates as the Authentication Type.

4. Enter the Username. If you leave this field blank the user will be prompted for the username when
connecting.

5. Check Password required.

6. Enter the Password. If you leave this field blank the user will be prompted for the password when
connecting.

7. Select the client certificate as the Client Certificate file.

8. Select the root certficate of the CA as the Certificate Authority (CA) file.

9. Select the client's private key as the Private Keyfile. Enter the passphrase in Private Key

password if the key is protected with one.

k- ® WP ® Open PR ® OpentPR Connection ® Session

Open'yPR Server(s) 1723091 136

Configuration

e Authertication Type | MamePassword with TLS-Certificates v|

Accessories i
User name client]
User Interface .
[;_F] Pazzwoard required

Pazzwoard FAERER

» [ LAN Interfaces .
‘ Nohile Broadband Client Certificate file client.crt
» I DHCP Cliert .
* [ veN CA certificate file ca.crt
¥ 8] WPMN [
B3 Open Private key file client key
* O Open''PM Connection
. Session Private Mey password fia
. Options

10. Click anicon for the newly created session (e.g. in the Start Menu) to initiate the connection.

@ IfaPKCS12fileis available, which includes the client certificate, the certificate authority
and the private key, then you just need to enter the PKCS12 file name in the three
corresponding fields. The advantage is that you only have to roll out one single file instead
of three different files.
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Authenticating with Static Key

Go to Network > VPN > OpenVPN and create a new connection.

In the Session section for the new connection, enter the name or public IP address of the
OpenVPN Server.

Select Static Key as the Authentication Type.

Select the static key file as the Private Key.

Select None as the Key Direction.

Enter the server's VPN IP address as Remote IP Address.

Enter your client's VPN IP address as Local IP Address.

> i® petwork ™ WPN P Open VPN ™ OpenPM Connection ™ Session

Cunﬁguratiun Openy'PH Server(s) |1T2.3EI.EI1 136

Authertication Type | Static Key v|
Private key file ||:Iier|t.kev
User Interface

Remaote [P Address |192.1 51231

» Il LAN Interfaces
B 'obile Broadband
» [l DHCP Client
* 3 wen
*xO Open VPN
*[O Open''PH Connection

I Session

‘ Options

Key Direction lNu:une v]

Local IP &ddress |192.1 B5.123.2

8. Click anicon for the newly created session (e.g. in the Start Menu) to initiate the connection.
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Options and TLS Options

Options

Under Network > VPN > OpenVPN > [Session Name] > Options, you can set various options for the OpenVPN
client. Usually, you can leave the default settings as they are. If the server uses compression, enable Use LZO data
compression.

() When using a proxy, set Protocol used for communication to the host to tcp-client.

TLS Options

Under Network > VPN > OpenVPN > [Session Name] > TLS-Options, you can set various TLS-related options. In
particular, you can configure whether the remote peer certificate will be verified.
For details about these settings, refer to Configuring Open VPN Sessions (see page 157) or OpenVPN.
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DNS and Routing Options

By default, OpenVPN automatically uses the server's settings for DNS and routing.
If you want to change these settings, go to Network > VPN > Open VPN > [Session Name] > IPv4. Here you can:

+ Deactivate Automatic DNS

« Add Extra nameserver(s)

+ Add Extra search domains
Deactivate Automatic Routes
Deactivate VPN is the default route

Additionally, you can enable three custom routes in Network > VPN > Open VPN > [Session Name] > Route
[0,1,2]. For each enabled route you can configure:

+ whetheritis a Network Route or a Host Route

Network/Host IP

Network Mask (for Network Route only)

Optional: Gateway

Optional: Metric (a quality rating used for routing decisions, 0 being the best)
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Proxy

If you wish to configure a proxy for your VPN connection, go to Network > VPN > OpenVPN > [Session Name] >
Proxy. Here you can configure:

« Proxy Type: SOCKS or HTTP, by default this is set to None
+ Proxy Address and Proxy Port
+ Retry indefinitely when errors occur

If you select the HTTP proxy type you can configure:
+ Proxy Username
+ Proxy Password

@ When using a proxy, set Options > Protocol used for communication to the host to tcp-
client.

® When experiencing issues with OpenVPN, read the messagesin /var/log/messages,
e.g. using the System Log Viewer.
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Checking the VPN Connection

As soon as a VPN connection is established, a lock icon with connected plugs is shown in the panel:

DE ll))l__ﬂ_," 11:21 | 4
L

However, this only serves as an indicator. To be sure that the VPN connection really exists:

1. Open aLocal Terminal.
2. Runthe command 1ifconfig.

3. Check whether the output containsa tun device with an IP address from the private network.

Terminal =k e

user@IGEL -Q0ABCAGS50027 :~$¢ ifconfig

eth@ Link encap:Ethernet HwWaddr 00:0b:ca:05:00:27
inet addr:172.30.91.219 Bcast:172.30.255.255 Mask:255.255.0.0
inet6 addr: feBO::20b:caff:fe@5:27/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:150@ Metric:1
RX packets:1091674 errors:0 dropped:47 overruns:0 frame:@
TX packets:125138 errors:0 dropped:@ overruns:@ carrier:@
collisions:0 txgueuelen:1000
RX bytes:79070067 (79.0 MB) TX bytes:58744380 (58.7 MB)
Interrupt:105 Base address:0xal@@@

lo Link encap:lLocal Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:85536 Metric:1
RX packets:108954 errors:0 dropped:@ overruns:@ frame:0
TX packets:108954 errors:0 dropped:@ overruns:@ carrier:0@
collisions:0 txgueuelen:@
RX bytes:45078307 (45.0 MB) TX bytes:45078307 (45.0 MB)

itun® Link encap:UNSPEC Hwaddr|GG-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet addr:192.168.123.10 |P-t-P:192.168.123.9 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:150@ Metric:1
RX packets:23080 errors:0 dropped:0 overruns:@ frame:0
TX packets:48007 errors:0 dropped:74 overruns:@ carrier:0@
collisions:0 txgueuelen:100
RX bytes:1266538 (1.2 MB) TX bytes:63784736 (63.7 MB)

user@lGEL -GO0BCAGSE027 :~% |

4. Additionally, check whether you can ping the VPN server's private IP address.
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Automatically Starting the VPN During Boot

(@ Ifyou want to update the firmware via the VPN, you need to enable Autostart During Boot. Enabling
Autostart of the control application in Network > VPN > OpenVPN > [session name] is not adequate!

Go to Network > VPN > OpenVPN.

Check Enable Autostart During Boot.

Select one of the configured sessions.

Click Set Auto.

The session will be marked in the Auto column.

Click Set Auto again to dectivate autostarting the session.

Rl e

@ The system will prompt you for key pass phrases or the eToken/smartcard PIN if
necessary.
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Further Information
Further information about OpenVPN can be found in

« the OpenVPN how-to® and
« the OpenVPN manual page*

maintained by the OpenVPN project.

13 https://openvpn.net/index.php/open-source/documentation/howto.html
14 https://openvpn.net/community-resources/reference-manual-for-openvpn-2-0/
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Securely Distributing Keys and Certificates for OpenVPN

Use the file distribution mechanism in the Universal Management Suite (UMS) to securely distribute keys and
certificates to the thin clients:

1. Select Undefined as the Classification.
. Enter /wfs/OpenVPN/ as the thin client file location.

2
3. Enable the Read permission for the Owner exclusively, and uncheck all remaining permissions.
4. Select Root as the Owner.

Mew file x

File source
@ Upload local file to UMS server

Local file Clsersiddministratoniclient?.key Q
Upload location (URL) | hitps:#172.30.91.23:8443/ums_filetransfer/ -
() Selectfile from UMS server
File location (URL) | [
File target
Classification [Undeﬁned .*]

Thin Client file location | swfs/OpenyVPR/

Access rights

Read Write Execute
owner [ [ U]
others [ [ ]

Owner |Root ¥
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Running the OpenVPN Client with a Preconfigured Configuration File

& Solution Based on Experience from the Field

This article provides a solution that has not been approved by the IGEL Research and Development
department. Therefore, official support cannot be provided by IGEL. Where applicable, test the solution
before deploying it to a productive environment.

This article describes a basic solution for getting the built-in OpenVPN client running with a preconfigured
configuration file. This is an alternative to using the Setup for configuration.

Environment
This article is valid for the following environment:

+ IGEL OS 10 or higher
¢ OpenVPN server

Setting up an OpenVPN Connection with a Preconfigured Configuration File

1. Inthe UMS Console, open the context menu on Files and select New File.
Selectyour .ovpn filein the file system.

In the File target section, under Devices file location, enter "/wfs/".

Click Ok.

The file is uploaded to the UMS.

5. Assign the file object to your device by clicking the "+" symbol in the Assigned objects area (upper
right).

6. Create a profile with a suitable name, e. g. "OpenVPN Connection".

7. Inthe profile, go to System > Firmware Customization > Custom Commands > Network.

8. Inthe Final network command field, enter the following code, replacing example.ovpn with

W

the correct filename:

while :; do if [ -z $(pgrep openvpn) ]; then echo "openvpn is not
running"; openvpn --config /wfs/example.ovpn --auth-user-pass
<(echo -e $(zenity --forms --text="Enter your VPN credentials" --
add-entry=Username --add-password=Password --title=0OpenVPN) | sed
's/|/\n/"); else echo "openvpn is running"; fi; sleep 1; done &

9. Click Save to save the profile.
10. Assign the profile to your device by clicking the "+" symbol in the Assigned objects area.
11. Reboot the device.
After reboot, you should see a login window for OpenVPN.
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12. Enter your OpenVPN credentials.
If the login was successful, a Network connecting popup appears briefly. No other indicator is
shown. You can disconnect only by rebooting the device.
If the login has failed, the login window reappears.

Removing the OpenVPN Connection

» To remove the OpenVPN connection from the settings, unassign the profile from the device and reboot it.
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Configuring Wi-Fi Network Roaming

Issue

Different wireless network instances have been configured for a mobile device. The device should switch over to the
strongest network automatically.

Solution

Parameters to configure Wi-Fi roaming options can be found in the IGEL registry (Setup > System > Registry).
These settings should be changed by experts only.

Parameters for better control of Wi-Fi roaming capabilities with access points that share the same
SSID:
network.interfaces.wirelesslan.device0.lock_initial

Default: false

If true ,the device will stick to the access pointitis connected to even if candidates with better
signal quality are present.

Setting this parameterto true isa last resort for problems that are caused by too much
roaming.

network.interfaces.wirelesslan.device0.bgscan.module
Default: default (Perservingthe unpachted NM's behaviour)
Possible values:

default :Nobackground scanningisdone.

simple :The Wi-Fi module tries to scan for a potentially better signal in the background.

bgscan.module simple provides following options:

network.interfaces.wirelesslan.device0.bgscan.simple.signal_strength (default: -45 dBm)
This defines a threshold that determines which of the following two parameters shall be effective:

network.interfaces.wirelesslan.device0.bgscan.simple.short_interval (default: 30 s)

Interval between background scans (in seconds) if the actual signal level of the currently
connected access point is worse than signal_strength.

network.interfaces.wirelesslan.device0.bgscan.simple.long_interval (default: 300 s)

Interval between background scans (in seconds) if the actual signal level of the currently
connected access point is better than signal_strength.

IGEL OS Articles 171 /543



Network

e

IGE

® i parameter lock_initialis true ,itis recommended to set bgscan.module to none .

« Parameters to control Wi-Fi roaming between Wi-Fi networks with different SSIDs:
network.interfaces.wirelesslan.device0.mssid_check_interval (default: 10 s)

The interval in seconds between checking if automatic roaming might be neccessary. This includes
detecting that a connection has been lost and a new one should be established.

network.interfaces.wirelesslan.device0.mssid_quality_threshold (default: 20 )

If the current connection's quality percentage is below this value, scanning will be performed to
find a potentially better network.

network.interfaces.wirelesslan.device0.mssid_quality_difference_threshold (default: 40 )

A candidate for automatic roaming is only considered if its quality percentage is this much better
than the current connection's quality.

network.interfaces.wirelesslan.device0.mssid_previously_used_threshold (default: 55 )
During boot: If the previously used SSID's quality percentage is above this threshold, it is preferred.

network.interfaces.wirelesslan.device0.mssid_user_selection (default: false)

If true ,theusercan initiate roaming to a network via the Wi-Fi tray icon's context menu (must
be enabled).

If automatic roaming shall not interfere with the user's choice, the following values are
appropriate:

network.interfaces.wirelesslan.device0.mssid_quality_threshold= 0
network.interfaces.wirelesslan.device0.mssid_quality_difference_threshold= 101

network.interfaces.wirelesslan.device0.mssid_previously_used_threshold= 0
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Connecting to a Wi-Fi Network with Hidden SSID

Symptom

The device does not connect to a wireless network with hidden SSID.

Problem

An option in the device's network configuration is missing.

Solution

If you need to configure a hidden access point, proceed as follows:

1.
2.

Hw

Start IGEL Setup or open the device configuration dialog in the UMS.

Go to Network > LAN Interfaces > Wireless > Default Wi-Fi network (or Additional Wi-Fi
networks depending on your configuration).

Choose Enable WPA Encryption.

Set parameter AP Scan mode to "no broadcast".

Click Apply or Ok to save the settings.

4 > ~ / * Network » LAN Interfaces * Wireless » Default Wi-Fi network

Configuration ﬂ . =
(U Disable Encryption () Enable WEP Encryption (® Enable WPA Encryption

wireless Network Name (SSID)

User Interface

Network Network authentication | wPa Persanal v|  Network key

¥ O LAN Interfaces Data encryption | Defautt Y] I AP Scan mode 8} [no broadcast M| I
» Il interface 1
» Il Interface 2
¥ [ wireless
i Default Wi-Fi network
B 2dditional Wi-Fi networks
B Wireless regulatory domain
B Mobile Broadband

Search

Cancel
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Improving WiFi Connectivity

Problem

Your WiFi connection is unstable, or weak, or both.

Environment

« UDC with IGEL Linux v5??? or IGEL OS??? or higher???
+ UD Pocket IGEL Linux v5??? or IGEL OS??? or higher???

Possible Causes and Solutions

There are many circumstances and parameters which influence the quality of a device's WiFi connection. To find a
suitable solution to your problem, check out the following collection of possible causes and suggested solutions,
workarounds and hints for debugging.

Several Access Points (APs) Are Using the Same Channel

If more than one Access Points visible to the thin client are using the same WiFi channel, interference issues may
arise.

> Reconfigure the Access Point (AP) in question to use different channels.

Roaming within One Network (Same SSID)

When the device is configured to roam within its network, it tries to make sure that it is using the strongest/nearest
Access Point (AP) within its network. Dependent on the given situation, it might be feasible to disable or to optimize
roaming.

See also Configuring Wi-Fi Network Roaming (see page 171).

Avoid Roaming

» Inthe Setu p, go to System > Registry > network > interfaces > wirelesslan > device0 > lock_initial (Registry
key: network.interfaces.wirelesslan.device0.lock_initial)and activate Avoid roaming
within the same network.

() Ifroamingis deactivated, System > Registry > network > interfaces > wirelesslan > device0 > bgscan >
module should be set to none.
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Select the Access Point with the Best Signal

With the following setting, the thin client selects the Access Point that emits the best signal when the device starts

up.

> In the Setu p, go to System > Registry > network > interfaces > wirelesslan > device0 > bssid (Registry

key: network.interfaces.wirelesslan.device0.bssid )andenter bestsignal inthe BSSID field.

Automatic Roaming

Automatic roaming is feasible if the device is moved around frequently, and several Access Points are available.

In the following example, the device is configured to start scanning for another Access Point 10 seconds after the
signal of the current Access Point has dropped below -78 db, while a routine scan is executed every 60 seconds, :

1. Inthe Setup, go to System > Registry > network > interfaces > wirelesslan > device0 > bgscan >

module (Registry key: network.interfaces.wirelesslan.device0.bgscan.module)
and select simple.

. Set System > Registry > network > interfaces > wirelesslan > device0 > bgscan > module >

simple > long_interval (Registry
key: network.interfaces.wirelesslan.device@.bgscan.module.simple.long_

interval)to60.

. Set System > Registry > network > interfaces > wirelesslan > device0 > bgscan > module >

simple > short_interval (Registry
key: network.interfaces.wirelesslan.device0.bgscan.module.simple.shor

t_interval)to 10.

. Set System > Registry > network > interfaces > wirelesslan > device0 > bgscan > module >

simple > signal_strength (Registry
key: network.interfaces.wirelesslan.device0.bgscan.module.simple.sign
al_strength)to-78.

40 MHz Bandwidth in the 2.4 GHz Band
With some Access Points, it may be feasible to disable the 40 MHz bandwidth in the 2.4 GHz band.

> In the Setu p, go to System > Registry > network > interfaces > wirelesslan > device0 > driver > cfg80211
> cfg80211_disable_40mhz_24ghz (Registry
key: network.interfaces.wirelesslan.device@.driver.cfg80211.cfg80211_disable_40mh

z_24ghz ) and deactivate Disable 40 MHz channel bandwidth in 2.4 GHz band.

High Throughput Option

In some environments, the high throughput functionality built into the driver may not produce optimal results. You
can disable this functionality and check if the connection has improved.
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> Inthe Setu p, g0 to System > Registry > network > interfaces > wirelesslan > device0 > driver >
disable_ht (Registry key: network.interfaces.wirelesslan.device0.driver.disable_ht)and
deactivate Disable HT.

2.4 GHz Band Only
In some environments, it might be better to use only the 2.4 GHz band.

» In the Setu p, go to System > Registry > network > interfaces > wirelesslan > device0 > band (Registry key:
network.interfaces.wirelesslan.device0.band )and select 2.4 GHz.

If one or more alternative WiFi networks (SSIDs) are configured, do the following for each alternative SSID:

> Inthe Setu p, go to System > Registry > network > interfaces > wirelesslan > device0 > alt_ssid[number] >
band (Registry key: network.interfaces.wirelesslan.device@.alt_ssid[number].band)and
select 2.4 GHz.

Frame Aggregation

It might be helpful to disable the frame aggregation feature of IEEE 802.11n.

> Disable frame aggregation on your Access Point (AP).

() OnyourAccess Point, this feature may have a different name.
Also note that IGEL cannot give a guarantee that the Access Point will function properly after the
suggested configuration changes.

WiFi Driver Scans And Selects Access Point

By default, the WPA supplicant initiates scanning and the selection of an Access Point. You can change this behavior
and assign this task to the driver.

1. Inthe Setup, go to System > Registry > network > interfaces > wirelesslan > device0 > wpa >
ap_scan (Registry key: network.interfaces.wirelesslan.device®O.wpa.ap_scan)

and select WLAN driver initiates scanning and AP selection.
2. Restart the thin client.

Whitelist of BSSIDs

You can restrict the number of Access Points to be scanned by creating a whitelist. This whitelist contains only the
BSSIDs of those Access Points that the device should scan.

In the Setup, go to System > Registry > network > interfaces > wirelesslan > device0 > bssid_whitelist (Registry
key: network.interfaces.wirelesslan.device0.bssid_whitelist )and enterthe BSSIDs of those
Access Points that should be scanned, separated by whitespaces.
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Debugging
If none of the methods described above work, you can create a log file and send it to the IGEL Support Team.
1. Inthe Setup, go to System > Registry > network > interfaces > wirelesslan > device0 > wpa >
debug (Registry key: network.interfaces.wirelesslan.deviceo.wpa.debug)and

select very verbose.
2. Restart the thin client.

3. Sendthefile /tmp/wpa_debug.all totheIGEL Support Team.
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Preventing Permanent Storage of Wireless Network Keys

This document describes how to prevent users from storing wireless network keys/passwords for Wireless
Manager on the endpoint device.
1. In Setup, go to System > Registry.
. Gotothe network.applet.wireless.allow_storing_credentials parameter.

2
3. Uncheck Allow permanently storing credentials, which is checked by default.
4. Click Apply.

This will affect the Wireless Manager dialogs for wireless networks with the network authentication methods in
their variants requiring passwords:

+ WPA Personal

« WPA Enterprise
+ WPA2 Personal
+ WPA2 Enterprise

In particular, users will not have check boxes labeled Permanently store identity and password or Permanently
store network key available.
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Using WPA Enterprise / WPA2 Enterprise with TLS Client Certificates

This document describes how to use UMS to configure Wi-Fi connections on IGEL OS with WPA Enterprise / WPA2
Enterprise and TLS client certificates.

There are two options for supplying client certificates and keys to devices:

Via SCEP (NDES)

SCEP allows the automatic provisioning of client certificates via an SCEP server and a certification authority (CA).

Learn how to configure it, using How-To Certificate Enrollment and Renewal with SCEP (NDES) (see page 260).

Via Files Served from UMS

You need:

+ aclient certificate in PEM (base64) format
+ aclient private key (needs to be passphrase-protected) in PEM (base64) format

Alternatively,

+ a PKCS#12 file containing both client certificate and private key (needs to be passphrase-
protected).

() Inboth cases, SCEP and files from UMS, the device needs to have a working Ethernet or Wi-Fi connection
to the SCEP server or the UMS first, so that it can fetch the necessary certificates before it can connect to
the target Wi-Fi.

+ Deploying Client Certificates and Keys (see page 180)
+ Configuring the Network Interface (see page 181)
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Deploying Client Certificates and Keys

To deploy client certificates and keys via UMS, follow these steps for the client certificate and client private key files
(or the PKCS#12 files containing both):

1.

PN G A~ WN

In the UMS Console navigation tree, right-click Files and select New file from the context menu.
The New file dialog opens

Under File source, use the file chooser to choose the file as the Local file.

Under File target, leave the classification as Undefined.

Set the Thin Client file locationto /wfs/wpa-tls/

Under Access rights, set check Read and Write for the Owner and none for Others.
Set the Owner to Root.

Click OK to upload the file.

Drag the file icon onto a thin client or thin client directory in order to assign the file.
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Configuring the Network Interface

This describes how to configure the WiFi interface.

(® Inboth cases, SCEP and files from UMS, the device needs to have a working Ethernet or WiFi connection to
the SCEP server or the UMS first, so that it can fetch the necessary certificates before it can connect to the
target WiFi.

Using SCEP (NDES)

1. In Setup go to Network > LAN Interfaces > Wireless.

Check Activate Wireless Interface.

Go to Default WiFi-network.

Select Enable WPA Encryption.

Enter the Wireless Network Name (SSID).

Select WPA Enterprise or WPA2 Enterprise according to your preferences.
Set EAP Type to TLS

or set EAP Type to PEAP and Auth Method to TLS.

NoohkwnN

(@ IGEL OS supports both EAP-TLS and PEAP-EAP-TLS. Choose one that is supported by your
infrastructure.

8. Leave Validate Server Certificate enabled.
9. Enterthe path to a CA Root Certificate if you use a CA other than those supported by IGEL OS (see
page 280).
10. Check Manage Certificates with SCEP (NDES).
11. Click Save.

Using Certificate and Key Files

1. In Setup go to Network > LAN Interfaces > Wireless.

Check Activate Wireless Interface.

Go to Default Wi-Fi network.

Select Enable WPA Encryption.

Enter the Wireless Network Name (SSID).

Select WPA Enterprise or WPA2 Enterprise according to your preferences.
Set EAP Type to TLS

or set EAP Type to PEAP and Auth Method to TLS

Nk~ wN

@ IGEL OS supports both EAP-TLS and PEAP-EAP-TLS. Choose one that is supported by your
infrastructure.

8. Leave Validate Server Certificate enabled. Enter the path to a CA Root Certificate if you use a CA
other than those supported by IGEL OS (see page 280).
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9. Enter the path to the Client Certificate file in PEM (base64) format, e.g. /wfs/wpa-tls/

client.crt.

Leave this field blank if you use a PKCS#12 file containing both certificate and private key.
10. Enter the path to the Private Key file in PEM (base64) format.

If you use a PKCS#12 file containing both certificate and private key, enter its path here.
11. Specify the Identity to be used if your key/certificate contains more than one entry.
12. Enter the Private Key Password.
13. Click Save.
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IPv6 Settings

IGEL Linux version 5.07.100 or newer and IGEL Linux version 10.01.100 or newer offer new options for configuring
network interfaces for IPv6.

Application Scenario

IGEL devices cannot so far communicate with the UMS via IPv6. Therefore, the major application scenario for IPv6 is
as follows:

+ Devices still receive their IPv4 configuration and potentially /GEL-specific DHCP options from a
DHCPv4 server.
Most of the settings are received from the UMS via IPv4.
Only the default options are requested from the DHCPv6 server. These are as follows:
+ IPv6 address
« nameservers
+ DNSsearch list.
Regarding DNS, only IPv6 nameserver addresses should be delivered (in router advertisements or
DHCPv6 options). The resolver should be able to use these for retrieving AAAA records and also A
records if necessary.
Clients and servers use IPv6 if they are prepared to do so.
Examples:
« An NTP server (System > Time and date > NTP time server) can be specified as an IPv6
address or as a name for which the DNS has only an AAAA record available.
+ Similarly, in a web browser session, IPv6 will be used when the DNS has AAAA records
available for servers.

« Available Configurations (see page 184)
« Timeouts in Automatic Configuration (see page 186)
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Available Configurations

IPv6 support is configured by network interface in Network > LAN Interfaces:

“ DIIT Setup 5.07.100.rc8,01 (Build 4.9.12)

P LAN Interfaces ™ Interface 1

L . =
L]
SEEELEEIES Athentication  Wake On Lan
User Interface
¥ W3

- Metwork .
¥ LAM Interfaces T

» o Interface 1 Metwark Mask 255,255,255.0

o Interface 2

B Wireless
" SF'HI‘(-iP Client IPvB-Configuration
[ =
b o SCEF Client (NDES) C?"“E?t;blllty mode
» o Routing Disable .

~ Hosts Metwark Linktype Automnatic

i DHCPwS

> & Network Drives Force guto-negotiation

-~ Prowy

[ Enable tray icon
Search [¥/] Enable context menu ’

The following configurations are available:

Value Effect

Compatibilty

Equivalent to former versions of IGEL Linux: NetworkManager ignores the

mode device, but the kernel performs some basic configuration. In particular, it
assigns an IPv6 link local address to the device.

Disabled

Automatic

IPv6 is disabled completely.

The device tries to perform an IPv6 stateless or stateful autoconfiguration

based on router advertisements. Depending on the router advertisements,

this involves DHCPvV6 (see RFC 4861).
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DHCPv6 This option is supported by NetworkManager. It can be used when a DHCPv6
server is available but no router advertisements. Routing has to be
configured by other means. In most cases Automatic will be preferable.

@ Inallcases IPv4 is configured in the usual way.
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Timeouts in Automatic Configuration

If Automatic is selected, there is a configurable timeout for the dual stack mode. This is the time that the system
waits after the first of the stacks IPv4 or IPv6 has completed its configuration for the other stack to complete its own
configuration. After this time has elapsed, it runs the scripts that depend on the network being up. The default
timeout value is 15 seconds.

The timeout can be configured with the following parameters in System > Registry:

Parameter Device

network.interfaces.ethernet.device0.dual stack_ Firstethernetdevice

timeout

network.interfaces.ethernet.devicel.dual_stack_ Second ethernetdevice

timeout

network.interfaces.wirelesslan.device®.dual_ Wireless LAN device

stack_timeout

® Use the Search parameter ... function with the string dual_stack to find these parameters quickly.
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Extended Logging With Syslog, Tcpdump and Netlog

The IGEL OS Registry offers a number of extended logging options that can help customers, Support and PreSales
debug system and network issues.

For instructions on how to send log files to the IGEL support team via the UMS, see Sending Device Log Files to IGEL
Support (see page 506).

Debuglog Partition (see page 188)
Syslog (see page 190)

« Tcpdump (see page 191)

Netlog (see page 194)
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Debuglog Partition

Logfiles can get very large quite fast. This is why they are stored in a separate partition. It is mounted at /

debuglog .

Enabling and Configuring the Debuglog Partition

The partition is enabled and configured in the Registry:

IGEL Setup > System > Registry

> Enable debuglog debug.tools.log_partition.enabled enabled / disabled
partition

Enables the debuglog partition.

IGEL Setup > System > Registry

> Size of debuglog debug.tools.log_partition_size 50...500/ 100
partition in MiB

© Resizing the debuglog partition will delete its contents!

Debuglog Partition Contents

Depending on which logging options you enable (see the following topics), you may find the following files in the
debuglog partition:

+ Syslog

+ messages (the currentsyslog)

+ messages[1-9].gz (compressed and rotated syslog)
Ethtool

+ netlog-ethtool-[device].log
+ Ping

+ netlog-host-[0-9]-ping.log (pinglog)
+ netlog-host-[0-9]-ping[n].log.gz (compressed and rotated ping log)
Ifconfig

+ netlog-ifconfig-[device].log
Netstat
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+ netlog-netstat.log (netstatlog)

+ netlog-netstat[n].log.gz (compressed and rotated netstat log)
+ Socket Status
+ netlog-socket_status.log (socketstatus log)

+ netlog-socket_status[n].log.gz (compressed and rotated socket status log)
« Tcpdump

+ tcpdump[0-3]_capture_current[n] (tcpdump capture)

+ tcpdump[0-3]_capture-[n].pcap.{lzo,gz,bzip2,xz} (compressed and

rotated tcpdump captures)
+ Tcpdump triggered by an error

« ERROR_[timestamp]/tcpdump[0-3]_capture-[n].pcap.

{1zo,gz,bzip2,xz} (compressed and preserved tcpdump captures)
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Syslog

It is possible to send all syslog messages that are writtento /var/log/message (IGEL Linux version 5.10.250

and versions 5.11.x) or to the systemd journal (IGEL Linux version 10.01.100) to the debuglog partition as well. The
logfile will be rotated and compressed as needed. This preserves the log if the thin client crashes, and logs from
several previous boots.

Configure it in the Registry:

IGEL Setup > System > Registry

> Enable syslog logto  debug.tools.syslog0.enabled true/ false
debuglog partition

IGEL Setup > System > Registry

> Number of Rotate Files debug.tools.syslog0.num_rotate_files 2..9
Number of files to be kept while rotating.

IGEL Setup > System > Registry

> Logfile rotate sizein  debug.tools.syslog0.rotate_size 2,4,8,16
MiB

Rotate when the size of the compressed file reaches this size in MiB.
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Tcpdump

Tcpdump will help you debug network issues by capturing packets from up to 4 individual network interfaces.

(@ Usingthe Netlog (see page 194) facility, it is possible to copy capture files to a subdirectory, triggered by an
error in another log, so the captures before and after the error will be preserved for your analysis.

() Youcanuse Wireshark on an external system for analyzing capture files.

Find out more about Tcpdump from its homepage®.

IGEL Setup > Registry
> Resolve addresses/ports to debug.tools. tcpdump[0-3]. enabled/disabled

names .
address_resolution

IGEL Setup > Registry

> Compression Method debug.tools. tcpdump[0-3] . 1zop, gzip, bzip2, xz

compression

The compression method affects file size as well as system performance while compressing. The
default [zop methiod is relatively light on the CPU.

IGEL Setup > Registry
> Interface for tcpdump debug.tools. tcpdump [0- user editable string / ethQ
logging .
3] .interface
IGEL Setup > Registry

>Number of Rotate Files  gepug.tools.tcpdump[0-3].num_rota 310
te_files
Number of files to be kept while rotating.

IGEL Setup > Registry

15 http://www.tcpdump.org
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> Only Log Package Headers debug.tools.tcpdump[0-3] . enabled/disabled
only_headers

IGEL Setup > Registry
> Enable promisc tcpdump debug. tools. tcpdump [0-3] enabled/disabled
logging .

.promisc

Enable promiscuous mode on the network interface to also capture packets not intended for
this host.

IGEL Setup > Registry

].rotate_size

Rotate when the size of the uncompressed file reaches this size in MiB.
IGEL Setup > Registry
> Logfile rotate timeins debug. tools. tcpdump [0-3 O/ user editable integer

].rotate_time

Time in seconds after which the logfile is rotated and compressed. If set to 0 no time-based
rotation happens.

IGEL Setup > Registry
>Additional Parameters for  gepug.tools.tcpdump[0-3] usereditable string

tcpdum
P P .tcpdump_additional_param

eters
Use with care.
IGEL Setup > Registry
> Enable tcpdump debug.tools. tcpdump[0-3] . tc enabled/disabled
pdump_enabled
IGEL Setup > Registry

>tcpdump filter expression  depug. tools. tcpdump[0-3 User editable string

].tcpdump_filter
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Tcpdump filter expression. For the expression syntax, see the pcap-filter(7)*® manpage.

16 http://www.tcpdump.org/manpages/pcap-filter.7.html
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Netlog

The netlog facility combines the following network diagnosis tools:

+ ethtool

- ifconfig

+ netstat

+ ping

+ ss (socket status)

It can also trigger tcpdump .

IGEL Setup > Registry
> Enable netlog logging debug.tools.netlog.enabled enabled / disabled
IGEL Setup > Registry

> period between netlog logs in debug.tools.netlog.period
3

1,5, 10, 20, 30, 60, 120

Ping logging is not affected by this and uses its own timing.

 Ethtool (see page 195)

+ Ifconfig (see page 196)

» Netstat (see page 197)

+ Ping (see page 198)

» Socket Status (ss) (see page 200)
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Ethtool

Ethtool is the standard Linux utility for getting diagnostic information about wired Ethernet devices and their
drivers.

IGEL Setup > Registry
> Disable ethtool logging debug.tools.netlog.ethtool.disabled true / false
By default Ethtool logging is included in Netlog logging. However, you can disable it here.

IGEL Setup > Registry
> Log only if ethtool debug.tools.netlog.ethtool.log_on_changes true /false
output changes _only

Log only if ethtool output changes (on bootup there will always be at least one log entry)
IGEL Setup > Registry
> Number of Rotate Files debug.tools.netlog.ethtool.num_rotate_files2... 4

Keep up to this number of rotated files (also compressed), the current log not included
(which is limited to 600 lines)

IGEL Setup > Registry

> Logfile rotate sizein  debug.tools.netlog.ethtool.rotate_size 2,4,6
MiB

Rotate when the size of the uncompressed file reaches this size in MiB.
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Ifconfig

Ifconfig

Apart from configuring network devices, ifconfig also gives diagnostic information such as RX bytes, TX bytes and
dropped packets.

IGEL Setup >
> Disable ifconfig logging debug.tools.netlog.ifconfig.disabled true / false
By default Ifconfig logging is included in Netlog logging. However, you can disable it here.

IGEL Setup >
> Log only if ifconfig debug.tools.netlog.ifconfig.log_on_changes no,error_counter,al
output changes _only l

» no:logon every netlog run
+ error_counter: log only if an error counter or the address changes
« all: log on every change of ifconfig output

IGEL Setup >
> Number of Rotate files debug.tools.netlog.ifconfig.num_rotate_files 2...4

Keep up to this number of rotated files (also compressed), the current log not included
(which is limited to 600 lines).

IGEL Setup >

> Logfile rotate sizein  debug.tools.netlog.ifconfig.rotate_size 2,4,6
MiB

Rotate when the size of the uncompressed file reaches this size in MiB.

IGEL Setup >

> Trigger tcpdump log  debug.tools.netlog.ifconfig.trigger_tcpdump true/false
_save

Trigger the saving of tcpdump logs if an error counter increases or if the IP address changes.
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Netstat

Netstat displays a variety of network statistics for the local machine.

> Disable netstat logging debug.tools.netlog.netstat.disabled true / false

By default netstat -s loggingisincluded in Netlog logging. However, you can disable
it here.

> Number of Rotate files debug.tools.netlog.netstat.num_rotate_file 2... 4
s

Keep up to this number of rotated files (also compressed), the current log not included
(which is limited to 600 lines).

>Logfile rotate sizein  debug.tools.netlog.netstat.rotate_size 2,4,6
MiB

Rotate when the size of the uncompressed file reaches this size in MiB.

>Log only if triggered  debug.tools.netlog.netstat.trigger_log net_error_changes,
net_changes,
ifconfig_changes,
ethtool_changes,
no_trigger

+ net_error_changes: log if ethtool output changes or ifconfig error counter or address
changes

+ net_changes: log if ethtool or ifconfig output changes

« ifconfig_changes: log if ifconfig output changes

+ ethtool_changes: log if ethtool output changes

+ no_trigger: log on every netlog run
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Ping
IGEL Setup >
> Enable ping check debug.tools.netlog.ping_host[0-9].enabled true / false

IGEL Setup >

> Logonly if ping fails  debug.tools.netlog.ping_host[0-9].log_only_o true/false
n_error

Log only if any one of the configures pings [0-9 fails.]
IGEL Setup >

> Number of Rotate Files debug.tools.netlog.ping_host[0-9].num_rotate 2... 4
_files

Keep up to this number of rotated files (also compressed), the current log not included
(which is limited to 600 lines).

IGEL Setup >

> Logfile rotate sizein  debug.tools.netlog.ping_host0.rotate_size 2..4
MiB

Rotate when the size of the uncompressed file reaches this size in MiB.

IGEL Setup >

> Trigger tcpdump save debug.tools.netlog.ping_host0.trigger_tcpdum?2 ... 4
p_save

Trigger the saving of tcpdump logs if an error counter increases or if the IP address changes.
IGEL Setup >

> Ping target debug.tools.netlog.ping_host0.ping_target  user-editable
string

Target IP/hostname to ping (if none is given ping will be considered as disabled!)
IGEL Setup >

>Time between pings  debug.tools.netlog.ping_host0.ping_time 1,5, 10,30, 60,
120

Time between pings in seconds.
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IGEL Setup >

> Type of ping debug.tools.netlog.ping_host0.type icmp, http
request, https
request

+ icmp: use normal ping command
« http request: send an http request (failsifno  HTTP/*.* % OK answer is received)

+ https request: send an https request (failsif no CONNECTED is returned by openssl)
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Socket Status (ss)

Socket Status (ss)
IGEL Setup >

> Disable socket status debug.tools.netlog.socket_status.disabled  true/false
Logging

By default socket_status logging is included in Netlog logging. However, you can disable it
here.

IGEL Setup >

> Number of Rotate Files debug.tools.netlog.socket_status.num_rotate true / false
_files

Keep up to this number of rotated files (also compressed), the current log not included
(which is limited to 600 lines).

IGEL Setup >

> Logfile rotate sizein  debug.tools.netlog.socket_status.rotate_size true/false
MiB

Rotate when the size of the uncompressed file reaches this size in MiB.

IGEL Setup >

> Logonly if triggered  debug.tools.netlog.socket_status.trigger_log ping_errors,
no_trigger

+ ping_errors: log only if ping test fails
+ no_trigger: log on every netlog run
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Making a Telnet Connection from IGEL Linux

Issue

You want to connect to a Telnet service and can't find a Telnet command on the device.

Solution
Using Ericom Powerterm (Requires the Ericom Powerterm Firmware Feature):

1. In Setup, go to Sessions > PowerTerm Terminal Emulation > PowerTerm Sessions.
2. Create a new session.
3. Editthe session.
4. Under Connection, make the following settings:
a. Select TELNET as Session Type.
b. Enteran IP adress or a name in Host Name.
c. If youwant to use a graphical login dialog, activate Enable Login Dialog.

kaessicm Type | TELMET hd

Parameters

Host Mame 172.30.61.153 Port Number 23
Terminal Name Keep Alive Timeout |0
[/] Enable Login Dialog [] Save last user name

[¥] set window Size
(] Force Binary Mode

5. Under Desktop Integration enter a Session Name and enable the desired Starting Methods for
the Session.

6. Click Apply to save your settings or OK to save and exit.

7. Start the new session and enter your username and password.
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Configuring Dynamic DNS Updates via DDNS

Issue
You want to register a device's IP address with your DNS server.

You are not using DHCP.

Solution
Use the DDNS tools contained in IGEL Linux, which can be configured by Setup.

() This only works for BIND9 or other nameservers supporting TSIG, not for Microsoft Active Directory servers.

Distribute your nameserver's shared TSIG key with the UMS:

1. Create a New File.
. Set the Device Storage Pathto /wfs/ddns.

2
3. Enable Read permission for the Owner and disable all other permissions.
4. Set the Owner to Root.

Set up Dynamic DNS Registration:

Go to Network > LAN Interfaces in Setup.

Enable Specify an IP Address.

Enter an IP Address and Network Mask.

Enter a Terminal Name.

Check Enable DNS.

Enter a Default Domain.

Enter at least one Nameserver |P address.

Enable Dynamic DNS Registration.

Select DNS as Dynamic DNS Registration Method.
If the nameserver expects a TSIG key: Select the TSIG key file.
Otherwise, leave the input field blank.

. Click Apply or OK to confirm your settings.

LNk WNE

=
e
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=
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] Activate default interface (Ethernet)

a

() Get IP from DHCP Server
(®) Specify an IP Address

IP &ddress 192.0.0.1
MNetwork Mask 255.255.255.0
Default Gateway [] enable

Terminal Name

¥} /] Enable DNS

Default Domain €) | dynamic.igel.local
Nameserver €) |172.30.178.1
Nameserver

[[] Manually overwrite DHCP settings
€ [V] Dynamic DNS Registration

Dynamic DNS Registration Method £} [DNS VJ

TSIG key file for additional DNS authentication ) | mfs/ddns/ddns.private

ok Cancel
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Changing the SMB protocol version

Depending on which Windows (Samba) server you are using, you will need a specific SMB protocol version.

(@ Due to security reasons, Microsoft recommends to disable SMB version 1.0 support on Windows ,so you
need to switch to at least version 2.0 to be further able to access systems with disabled SMBV1.

IGEL Linux version 10.04.100 and higher offer several SMB protocol versions.
To change the version setting:

1. Inthe IGEL Setup go to System > Registry.
2. Goto parameter network.smbmount.smb_version.

3. Select the apropriate SMB protocol version.
Possible options:
« 1.0
+ 2.0
« 2.1
« 3.0
4. Click Save or Apply and send to thin client.
The windows shares are configurable at IGEL Setup > Network > Network Drives > Windows
Drive.
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Security

« Securing IGEL OS Endpoints (see page 206)

+ Secure Shell (SSH) Access to IGEL Linux with Keys (see page 242)
« Secure Terminal (Telnet with TLS/SSL) (see page 248)

+ Secure Shadowing (VNC with TLS/SSL) (see page 249)

+ Cherry eGK Channel Substitution (see page 253)

+ Single Sign-on for the Browser Proxy (see page 255)

+ Limiting the Number of Permitted Login Attempts (see page 258)
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Securing IGEL OS Endpoints

This document describes settings for IGEL OS that will increase security.

It applies to the following:

IGEL UD LX and IZ devices
UD Pocket
Devices converted with UDC3

Introduction (see page 207)

Setting Passwords (see page 208)

Keeping the System Up-To-Date (see page 215)

Disabling Access to Components (see page 216)

Minimizing the Attack Surface (see page 221)

Configuring Remote Access and Management (see page 231)
Wi-Fi and Bluetooth (see page 238)

Using UD Pocket for BYOD Devices (see page 241)
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Introduction

This document describes various settings to make IGEL OS more secure. In general the more of these settings you
apply the better endpoint security will be. However, it is up to you to strike a balance between security and
enabling your users to do their work. Some settings may even be inappropriate for your use case, e.g. if you use
Bluetooth peripherals it does not make sense to disable Bluetooth.

In order to configure more than one thin client, put one or more settings presented here into a Universal
Management Suite (UMS) master profile, which you can assign to any number of thin clients, enforcing the security
settings as a consequence.

Learn more about using master profiles here.
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Setting Passwords

You can restrict access to various system components by setting passwords.

+ Setting Local Passwords (see page 209)

+ Password-Protecting Sessions and Accessories (see page 210)
+ Using Screenlock (see page 211)

» Do Not Save Session Passwords (see page 212)

+ Setting a UEFI Password (see page 213)

+ Using Two-Factor Authentication (2FA) (see page 214)

IGEL OS Articles 208 /543



Security

Setting Local Passwords

Rationale

Passwords protect the system against local changes. They restrict access to the Local Terminal, Setup, and to the
rescue shells on the virtual consoles. The administrator password is also needed to reset the system to factory
defaults.

These passwords are saved in a way (salted and hashed) that prevents them from being recovered from the local
storage.

By default, no passwords are set on IGEL OS. Set at least an administrator password:

Instructions

1. InIGEL Setup go to Security > Password.

2. Inthe Administrator area, check Use Password.

3. Enter a password twice when prompted.

4. Optional: If you want to grant unprivileged user access to IGEL Setup check Use Password in the
Setup user area and enter a password twice when prompted.

5. Click Apply.

For configuration of the User Account for Remote Access, see Using Secure SSH Settings (see page 236).

Find further information on the Passwords page in the IGEL OS manual.
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Password-Protecting Sessions and Accessories

Rationale

Sessions can be used to access corporate resources, the accessories in IGEL OS can be used to make changes to the
local system. If you do not want to disable certain sessions or accessories completely, you can set passwords to
restrict access to them.

Instructions

By default, sessions do not have passwords set. To enable password protection for a session, follow these
instructions:

1. InIGEL Setup go to Sessions > [session type] > [session name] > Desktop Integration.
For accessories, go to Accessories > [accessory name].
2. Set Password Protection to
« Administrator to require the Administrator password, or
+ User to require the User password, or
+ Setup User to require the Setup User password.
3. Click Apply.
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Using Screenlock

Rationale

Leaving a screen unlocked enables attackers to access the system with the logged-in user's privileges. Manual or
automatic locking the screen with a password prevents such access.

Instructions for Enabling Manual Locking

By default, there is no way for the user to manually lock the screen. To enable manual locking, follow these steps:

1.
2.

3.

In IGEL Setup go to User Interface > Screenlock [ Screensaver
Do one or both of the following:
+ Activate the Quickstart panel starting method to give the user a button for locking the
screen manually.
« Activate Use hotkey and set a combination of keys that lets the user lock the screen
manually, e.g. [Ctrl-Shift-L].
Click Apply.

Instructions for Automatic Locking

By default, the screensaver is started automatically after 5 minutes, but the screen is not locked with a password.
To enable locking, follow these instructions:

1.
2.
3.

Go to User Interface > Screenlock [ Screensaver > Options.

Activate Start automatically.

Set the Timeout, i.e. the number of minutes of user inactivity before the screensaver starts
automatically. (Default: 5)

As a password select User password (see Setting Local Passwords (see page 209)) or a separate
Screenlock password (and set one). (Default: none)

Optionally, check Allow administrator password to allow the administrator to unlock a user's
screen. (Default: enabled)

Click Apply.
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Do Not Save Session Passwords

Rationale

Passwords for sessions should not be saved on the endpoint device.

Instructions

» When configuring a session, under Logon leave the Password field empty. The user will then be prompted
interactively for the password.

» Wherever possible use Two-Factor Authentication (2FA) (see page 214).
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Setting a UEFI Password

Rationale

In the UEFI settings you can modify very fundamental system properties, e.g. disable booting from USB. Access to
these settings should be protected by a password.

Instructions for IGEL UD LX devices

» |f UEFIis not enabled, see the instructions under UEFI Secure Boot Enabling Guides.
By default no UEFI password is set on IGEL UD devices. To set a password, do the following:

1. Hold down the [Del] key ([F2] key for UD2) while booting.
The UEFI menu opens.

2. Usingthe arrow and return keys, go to SCU.

The Setup Utility opens.

Using the arrow and return keys, go to Security.

Use the arrow keys to select Set Supervisor Password

Hit [Return].

Enter the desired UEFI password and hit [Return]

Enter the same UEFI password again and hit [Return] twice.

Hit [F10] in order to save and exit.

Confirm Exit Saving Changes? by hitting [Return].

The system boots, and the UEFI settings are now password-protected

LN W

Instructions for 3rd-party devices converted with UDC3

> Refer to the instructions of your BIOS/UEFI vendor

() Alternatively, try pressing [F12] (in general), [F10] (Intel devices) or [F9] (Hewlett-Packard devices) to
access the BIOS/UEFI settings. If this does not work, try pressing [Del], [F1] or [F2] during booting.
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Using Two-Factor Authentication (2FA)

Rationale

Two-factor authentication (2FA) combines two different factors to prove the user's identity, often a hardware device
such as smartcard or smart token and a password or PIN. This improves protection against impostors, as they
would have to gain both possession of the hardware device and knowledge of the password or PIN.

Instructions

Use two-factor authentication with a smartcard or smart token where possible. IGEL OS supports this for the
following sessions:

» Smartcard authentication for sessions (see page 313)
« Citrix Legacy ICA Sessions (see page 317)
+ Citrix Legacy ICA Sessions with Local Logon Window (see page 318)
« Citrix Storefront (see page 319)
« Citrix Xen Desktop Appliance Mode (see page 324)
» RDP Sessions (see page 321)
» Horizon Sessions (see page 322)
» Web browser (see page 323)
+ (Kerberos) Passthrough Authentication (see page 522)
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Keeping the System Up-To-Date

Rationale

Software updates fix newly discovered vulnerabilities in IGEL OS and applications. This means that keeping up with
updates is one of the most important measures in securing IGEL OS systems.

To start and configure updates, you can use IGEL Setup or the Universal Firmware Update feature of the Universal
Management Suite (UMS).

Instructions

> To be notified of secu rity-critical IGEL OS updates and to receive the IGEL Technical Newsletter, subscribe to
IGEL communications on www.igel.com®’.

() Youcan use the Universal Firmware Update feature in UMS to check for updates for your devices managed
by UMS.

@ TestanIGEL OS update on one or more sample devices to see whether all features you require work,
before you roll the update out to production.

1. Assign an update to one or more devices:
+ In UMS, drag and drop a Universal Firmware Update onto a device or a directory to assign
the update. See also Assigning Thin Client Updates.
OR
+ In IGEL Setup, go to System > Update > Firmware Update and configure an update source.
See Firmware Update.
2. Launch the update process:
+ Manually: In UMS, right-click a device or a directory and select Update & snapshot
commands > Update or Update on Shutdown from the context menu.
OR
As a scheduled job in UMS:
Right-click Jobs in the structure tree.
Select New Scheduled Job.
Enter a Name.
Select Update, Update on Boot or Update on Shutdown as the Command.
Complete the configuration of the task.
Assign the task to devices or directories.

-~® Q0 T W

17 http://www.igel.com/
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Security

Disabling Access to Components

You can hide IGEL OS components from the user that could be used to make changes to the system.

Disabling Local Terminal Access (see page 217)
Disabling Virtual Console Access (see page 218)
Using Appliance Mode (see page 219)

Hiding Unused Accessories (see page 220)

IGEL OS Articles 216 /543



Security

Disabling Local Terminal Access

Rationale

The local terminal accessory allows the user to execute commands or make changes to the system. Leave it
disabled.

Instructions

By default, the user does not find a local terminal session in the start menu or on the desktop. To remove an
existing local terminal session:

1. InIGEL Setup, go to Accessories > Terminals.

2. Select a local terminal session.

3. Click [*] to remove the selected session.

4. When prompted, confirm that you want to delete the session.
5. Click Apply.

Alternatively, you can password-protect the terminal, see Password-Protecting Sessions and Accessories (see page
210).
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Disabling Virtual Console Access

Rationale

The virtual consoles ttyll and ttyl2 give the useraccessto ashell. Disabling these makes it more diffcult to
execute commands or make changes to the system.

Instructions

By default, the user can access the virtual consoles with the [Ctr{]+[Alt]+[F11] and [Ctrl]+[Alt]+[F12] keyboard
commands. To disable access, do the following:

1. InIGEL Setup go to User Interface > Display > Access Control
2. Activate Disable Console switching (Default: Console switching enabled)
3. Click Apply.
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Using Appliance Mode

Rationale

By default, IGEL OS users are not presented with a full-screen remote session, but have access to the desktop and to
the start menu. On the contrary, in the appliance mode, a single predefined session is presented full-screen to the
user. As access to other applications is prevented, this reduces the system's potential exposure to attack.

Instructions

The appliance mode is available for the following session types:

« VMware Horizon

« Citrix XenDesktop

« Citrix Self-Service

« RHEV/Spice

+ Imprivata

« RDP MultiPoint Server
+ Caradigm

« XDMCP for This Display

To enable the appliance mode for a session, proceed as follows:

1. InIGEL Setup, go to Sessions > Appliance Mode.
2. Pick the session and configure it according to the manual chapter Appliance Mode.

() Youcan combine most of the appliance mode sessions with Two-factor Authentication (see page 214) for
increased security.
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Hiding Unused Accessories

Rationale

Accessories can be used to make changes to the system. Restricting access to these accessories helps to keep the
system secure.

Instructions for the Start Menu

By default the user can find a wide selection of accessories under the System icon of the start menu.To hide
individual accessories in the start menu:

1. Goto Accessories > [accessory name] in IGEL Setup.
2. Disable all Starting Methods for Session.
3. Click Apply.

Alternatively, you can set a password for the accessories, see Password-Protecting Sessions and
Accessories (see page 210).

To hide the complete System icon, which contains the accessories:

1. Goto User Interface > Desktop > Start Menu in IGEL Setup.
2. Uncheck System tab. (Default: enabled)
3. Click Apply.

Instructions for the Application Launcher
A wide selection of accessories can also be found under the System icon of the Application Launcher. To hide

individual accessories in the Application Launcher:

1. Go to Accessories > [accessory name] in IGEL Setup.
2. Disable all Starting Methods for Session.
3. Click Apply.

Alternatively, you can set a password for the accessories, see Password-Protecting Sessions and
Accessories (see page 210).

To hide the complete Application Launcher's System icon, which contains the accessories:

1. Go to Accessories > Application Launcher > Application Launcher Configuration in IGEL Setup.
2. Activate Hide system page. (Default: visible)
3. Click Apply.
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Minimizing the Attack Surface

Removing unused features and disabling unneeded network services minimizes the parts of the system that can be
attacked.

+ Removing the Local Web Browser (see page 222)

« Configuring the Browser (Kiosk Mode) (see page 223)
+ Disabling Java in the Browser and JWS (see page 224)
+ Disabling the PC/SC Daemon (see page 225)

+ Disabling X Server TCP Connections (see page 226)

+ Removing Unused Features (see page 227)

+ Disabling Storage Hotplug (see page 228)

+ Using USB Device Control (see page 229)

+ Disabling USB Boot (see page 230)
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Removing the Local Web Browser

Rationale

The local web browser may expose vulnerabilities to the Internet and can be an entry point for malware. If the
browser is not needed, it is safer to remove it.

© Do notremove the local web browser if you use Citrix StoreFront sessions.

Instructions

By default, IGEL OS has a local web browser (Firefox) installed, even if no web browser session is configured. To
remove the browser, follow these instructions:

1. Inthe IGEL Setup go to System > Firmware Customization > Features.
2. Uncheck the Local Browser (Firefox) feature.

3. Click Apply.

4. Reboot the endpoint device.
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Configuring the Browser (Kiosk Mode)

Rationale

If you want to offer a local web browser, there are some settings that improve its security. Additionally, these
settings add up to a kiosk mode, hiding the rest of IGEL OS from the user.

Instructions

By default, the web browser makes all of its features and menus available. To achieve a restricted 'kiosk' mode,
follow these instructions:

=

In the IGEL Setup go to Sessions > Browser > Browser Global > Security

Activate Safe Browsing (default: deactivated)

Activate Malware Protection (default: deactivated)

Go to Sessions > Browser > Browser Sessions > [session name] > Settings > Restart
Enable Autostart (default: deactivated)

Enable Restart(default: deactivated)

Go to Sessions > Browser > Browser Sessions > [session name] > Window

Enable Start in Fullscreen Mode (default: deactivated)

Enable Hide local filesystem (default: deactivated)

Enable Hide configuration page of the browser (default: enabled)

. Go to Sessions > Browser > Browser Sessions > [session name] > Settings > Menus & Toolbar
Activate Hide App Menu/Menu Bar (default: deactivated)

Go to Sessions > Browser > Browser Sessions > [session name] > Context

Check Hide the browser's context menu (default: deactivated)

Click Apply.

Reboot the endpoint device.

RNk WN
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Disabling Java in the Browser and JWS

Rationale

Java is a powerful programming language that can harm your data and system. Disabling the Java plugin in the web
browser and Java Web Start (JWS) protects you against execution of Java programs from the Web.

Instructions

By default, both the Java plugin in the web browser and Java Web Start are activated. Here is how to deactivate
them:

In the IGEL Setup, go to System > Registry

Go to the registry key java.deployment.webjava_enabled.

Uncheck Enable Java content in the browser.
Click Apply.
Reboot the device.

ok
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Disabling the PC/SC Daemon

Rationale

Unless you are running smartcard readers that use it, you can disable the PC/SC daemon. Running fewer daemons
reduces the attack surface.

Instructions
By default, the PC/SC daemon is activated. Follow these steps to deactivate it.

1. Inthe IGEL Setup go to Security > Smartcard > PC/SC
2. Uncheck Activate PC/SC Daemon (default: Activated).
3. Click Apply.

© Do notdisable the PC/SC daemon if you use smartcard readers that rely on it.
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Disabling X Server TCP Connections

Rationale

The X graphics server in IGEL OS has network functionality that could allow others to see your screen and read
keyboard input. Leave it disabled to keep your data confidential.

Instructions
By default the network functionality of the X server is disabled. To disable it again at a later time, do the following:

1. InIGEL Setup go to User Interface > Display > Access Control
2. Make sure that Access Control is enabled (default)

3. Make sure that Disable TCP connections is checked (default)
4. Click Apply.
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Removing Unused Features

Rationale

Reducing the amount of software running on a system reduces its attack surface. Therefore a basic security
measure for IGEL OS 10 is to remove all unused features.

Instructions

By default IGEL OS comes with a wide variety of features enabled. To disable any of these, do the following:

1. Inthe IGEL Setup go to System > Firmware Customization > Features.
2. Uncheck all the features that you do not intend to use.
If you do not use local printers on the endpoint device that you want to share with others,
uncheck:
+ Printing (Internet Printing Protocol CUPS)
+ Printing (Line Printer LPD)
+ Printing (TCP/IP)
+ Printing (ThinPrint)

© Do not remove the Custom Partition feature if you have a custom partition that contains
software or data for which you have no backup copy. After disabling the feature and a
reboot the contents of the custom partition will be lost.

© Do not remove Fluendo Gstreamer Codec Plugins or Hardware Video Acceleration if
you use sessions that make use of these features, see the FAQ IGEL Linux Features that
Require the Multimedia Codec Pack.

3. Click Apply.
4. Reboot the endpoint device.
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Disabling Storage Hotplug

Rationale

Removable USB media can be used to steal data or to execute unauthorized software or even malware on the
endpoint device.

Instructions

Storage Hotplug is disabled by default. Should you want to disable it again at any later point, follow these
instructions:

1. InIGEL Setup go to Devices > Storage Devices > Storage Hotplug.
2. Uncheck Enable dynamic client drive mapping (default: disabled)
3. Set Number of storage hotplug devicesto 0 (default: 0)
4

. Click Apply.
Storage devices are now no longer automatically mounted when they are plugged in.
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Using USB Device Control

Rationale

USB devices such as pen drives, wireless controllers, or printers can be used to steal data or to execute
unauthorized software or even malware. Deactivating as many USB device classes as possible increases security.

Instructions
To enable and configure USB access control:

1. InIGEL Setup, go to Devices > USB Access Control.
2. Check Enable.

& The activation of USB Access Control and setting the Default rule to Deny will block the use of
USB devices locally and in the session and, thus, might disable devices needed for the users.
Therefore, activate the USB access control only if your security policy requires that. In this case, set
Default rule to Deny and configure Allow rules for the required USB devices and USB device
classes.

It is recommended to make settings for USB Access Control as the last step in the device
configuration. Before activating the USB access control, check that all your other settings for
printers, Unified Communication, USB redirections, mapping settings for USB devices are working
as expected.

Note that the feature does not disable a USB port physically, i.e. power delivery will still work.

3. Set Default rule to Deny.
In combination with the preconfigured rule that allows Human Interface Devices (HID), no USB
devices apart from e.g. mouse and keyboard are allowed.

4. Configure further rules as needed. For instructions, see How to Configure USB Access Control (see
page 490).

5. Click Apply.

6. Reboot the device.
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Disabling USB Boot

Rationale

Disabling USB Boot prevents booting another operating system, which could be used to manipulate or (even
accidentally) overwrite IGEL OS on mass storage.

Instructions for IGEL UD LX Devices

USB Boot is disabled in the factory settings on IGEL UD LX devices. If you want to disable it at any time in the devices
lifetime, follow the instructions given here:

1. Hold down the [Del Jkey ([F2 ]key for UD2) while the system is booting.
The UEFI menu opens.

2. Use the arrow and return keys to go to SCU.

Optional: Enter the UEFI password (if one is set).

The Setup Utility opens.

Go to Boot.

Set USB Boot to Disabled.

Press [F10]

Confirm Exit Saving Changes?

The device boots.

w

© N GA

© Additionally, set a UEFI Password (see page 213) so the boot settings cannot be changed
back.

Instructions for 3rd-party devices converted with UDC3

» Refer to the instructions of your BIOS/UEFI vendor

(@ Alternatively, try pressing [F12] (in general), [F10] (Intel devices) or [F9] (Hewlett-Packard devices) to
access the BIOS/UEFI settings. If this does not work, try pressing [Del], [F1] or [F2] during booting.
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Configuring Remote Access and Management

Remote management via UMS and remote access are powerful features of IGEL OS. Select secure settings and
disable what you do not use.

+ Tying Endpoints to Your UMS instance (see page 232)
+ Disabling Shadowing (see page 233)

+ Using Secure VNC Settings (see page 234)

+ Disabling SSH Access (see page 235)

+ Using Secure SSH Settings (see page 236)

+ Disabling Secure Terminal (see page 237)
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Tying Endpoints to Your UMS instance

Rationale

Endpoint devices that have Remote Management enabled but are not yet tied to a UMS instance can be taken over
by an attacker's UMS. Make sure to register all IGEL endpoint devices on your network

Instructions

By default, Remote Management is enabled on IGEL OS endpoints. Use Autoregistration to catch all endpoint
devices in your corporate network:

1. Assignthe DNSentry igelrmserver tothe UMS host.

2. In UMS Console go to UMS Administration > Global Configuration > Thin Client Network
Settings.

3. Activate Enable automatic registration (without mac address import)
Now all new IGEL thin clients and devices converted with UDC3 booting up in the network will
automatically register with your UMS instance.

4. Optionally, put newly registered endpoint devices into a quarantine directory automatically with
UMS Default Directory Rules®,

5. Optionally, assign a Master Profile’® to this directory, thereby enforcing secure settings, e.g. a local
Administrator password.

@ Alternatively you can disable Remote Management in the local IGEL Setup under System >
Remote Management. Of course this means losing one of the most powerful features of
IGEL OS. However, this may be an option for particular endpoints.

18 http://edocs.igel.com/index.htm#9531.htm
19 http://edocs.igel.com/manuals/en/en_prof/index.htm
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Security

Disabling Shadowing

Rationale

Shadowing is made possible by a VNC server on IGEL OS, which is a network service. Reducing the number of
running network services reduces the system's attack surface.

Instructions
By default, Shadowing is not active on IGEL OS. However, if you want to disable it at any time, follow these steps:

1. Inthe IGEL Setup go to System > Remote Access > Shadow
2. Deactivate Allow Remote Shadowing.
3. Click Apply.
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Using Secure VNC Settings

Rationale

If you intend to use shadowing on IGEL OS, there are a number of options that can make it more secure.

Instructions

By default, Shadowing does not use encrypted network transport or a password. To activate these security features,
do the following:

1. InIGEL Setup go to System > Remote Access > Shadow
2. Make as many of the following settings as possible for your use case. Each setting improves
security, and often also privacy:
+ Enable Secure Mode.
+ Enable Use Passwordand set a strong password (not needed in Secure Mode)
« Enable Prompt User to allow Remote Session.
« Enable Allow User to disconnect Remote Shadowing.
« Disable Allow Input from Remote.
3. Click Apply.

@ Secure mode for shadowing can be enabled globally in UMS under UMS Administration >

Global Configuration > Remote Access. There you can also enable logging of users who
have used secure mode shadowing .
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Disabling SSH Access

Rationale

The SSH server on IGEL OS is a network service. Reducing the number of running network services reduces the
system's attack surface. Even more so in this case, as SSH by design enables a remote user to execute commands
on the system.

Instructions
By default, the SSH server is running on IGEL OS. To deactivate it, follow these steps:

1. InIGEL Setup go to System > Remote Access > SSH Access.
2. Uncheck Enable.
3. Click Apply.
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Using Secure SSH Settings

Rationale

If you intend to allow SSH connections to IGEL OS, there are a number of options that can make these more secure.

Instructions

1. InIGEL Setup go to System > Remote Access > SSH.

2. Make as many of the following settings as possible for your use case. Each one improves security:
+ Uncheck Permit empty passwords. (Default: deactivated)
+ Uncheck Permit administrator login. (Default: deactivated)

+ Deny User access for user ,who can execute any command with regular user privileges.
(Default: denied)
+ Instead, allow User access for ruser ,whose access is restricted by the list Applications

access for remote user 'ruser'. (Default: allowed)

« Optional: Edit the list Applications access for remote user 'ruser’. It defines the
commands that ruser can runfrom remote. (Default: a local shell and IGEL Setup).

+ Click Apply.

+ Go to Security > Password, under User Account for Remote Access activate Use
Password and set a password

+ Click Apply.
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Disabling Secure Terminal

Rationale

The secure terminal server on IGEL OS is a network service, providing a TLS/SSL-encrypted Telnet session. Reducing
the number of running network services reduces the system's attack surface. Even more so in this case, as Secure
Terminal by design enables a remote user to execute commands on the system.

Instructions
By default, Secure Terminal is not active. Should you want to deactivate it at any time, do the following:

1. InIGEL Setup go to System > Remote Access > Secure Terminal
2. Uncheck Secure Terminal.
3. Click Apply.

@ Secure Terminal can be enabled globally in UMS under UMS Administration > Global

Configuration > Remote Access. There you can also enable logging of users of Secure
Terminal.
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Wi-Fi and Bluetooth

Rogue or unencrypted Wi-Fi access points can put your data at risk, as can Bluetooth devices. If your device has Wi-
Fi and Bluetooth, make sure to configure them securely or disable them.

» Restricting Wi-Fi Access (see page 239)
+ Disabling Bluetooth (see page 240)
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Restricting Wi-Fi Access

Rationale

Using an unencrypted Wi-Fi network or falling for a rogue access point puts your users' data at risk. Enable strong
encryption and restrict Wi-Fi access to a default network and optionally employ a whitelist of additional networks in
order to prevent this.

Instructions

By default, Wi-Fi is not activated on IGEL OS. To activate it and preconfigure one or more allowed networks, follow
these instructions:

=

In IGEL Setup go to Network > LAN Interface > Wireless.

Check Activate Wireless Interface.

Do not check Enable wireless manager, as this would give the user free choice of Wi-Fi networks.
Click Apply.

Go to Network > LAN Interface > Wireless > Default Wi-Fi network.

Check Enable WPA Encryption.

Enter the Wireless network name (SSID).

Make authentication and encryption settings, see Default Wi-Fi Network in the IGEL OS Manual.
Click Apply.

Optional: Configure Additional Wi-Fi networks.

RNk WN
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Disabling Bluetooth

Rationale

If your device has a Bluetooth interface it may be used to access data. Disabling the interface reduces the risk of
data theft.

Instructions
By default Bluetooth is deactivated on IGEL OS. Should you want to disable it at any time, do the following:

1. Inthe IGEL Setup go to Devices > Bluetooth.
2. Disable Activate Bluetooth. (Default: disabled)
3. Click Apply.
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Using UD Pocket for BYOD Devices

Rationale

Letting users access company resources with their own devices (BYOD) and software poses a security risk: These
systems may have insecure configurations or even contain malware. In addition, company data should not be saved
on users' private devices.

Instructions

» Use the IGEL UD Pocket. This ensures the use of secure and trusted software. As the UD Pocket does not access
the device's mass storage, company data and private data will remain separated.

For details on the IGEL UD Pocket, see UD Pocket (UDP) Reference Manual.
For how to select the UD Pocket during the boot procedure, see Boot Settings and Starting Your UD Pocket.
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Secure Shell (SSH) Access to IGEL Linux with Keys

IGEL Linux has a built-in OpenSSH server which can be activated and configured via the setup application. It lets you
connect securely to the client over the network in order to issue commands or transfer files. While authentication
can be done with a username-password combination, using a private-public key pair can increase convenience
and/or security. This document describes how to generate and distribute the keys required.

+ Generating the SSH Key Pair (see page 243)
+ Distributing the Public Key with UMS (see page 245)
+ Configuring SSH Access on the Device (see page 247)
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Generating the SSH Key Pair

Prerequisites

+ Linux/Unix operating system, typically on the administrator's workstation
+ OpenSSH client software installed

Introduction
The following procedure will generate two keys:

+ Public key: This key is distributed to all machines the administrator wants to connect to. It can be
made public.
+ Private key: This key stays on the administrator's machine and has to be kept secret.

© Forthe confidentiality of the encrypted connection to devices, it is essential to keep the
private key secret.

An easily understandable explanation of private and public keys can be found in a blog post by the
programmer Blake Smith®.

Generating the Key Pair

1. Open aterminal session on your workstation as the user who is going to make the SSH
connections to the devices.
2. Issue the following command:

ssh-keygen
3. When prompted for the location to store the key pair in, you can:
+ Hit return, which will accept the default file name ~/.ssh/id_rsa

© Using the default name may overwrite existing SSH key pairs!

« Enter an absolute file path and key file name of your choice .

4. When prompted for a passphrase, you can
+ Enter a passphrase (twice)

@ Apassphrase protects the private key file in case it gets into the hands of an attacker. On
the other hand, it may be inconvenient to enter the passphrase for every connection.

« Hitreturnin order to use no passphrase.

20 http://blakesmith.me/2010/02/08/understanding-public-key-private-key-concepts.html
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© Thisincreases convenience because you will be able to log in without entering the
passphrase. However, it weakens security: The private key file will be unprotected if it gets
into the hands of an attacker.

Two files have been generated (default names):
« id_rsa -the private key file

+ id_rsa.pub -the publickey file
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Distributing the Public Key with UMS

o N oA

In UMS Console, right-click on Files in the navigation tree.
Select New File.

Upload the public key file ( *. pub ) as a Local File.

[ © Make sure that you do not upload the private key file by mistake. ]

Set the Classification to Undefined.
Specify the Thin Client file location as /wfs/user/.ssh/authorized_keys

Leave the Access rights as Read, Write, Execute.
Leave the Owner as User.
Assign the file to the desired thin clients, profiles or directories.

e ]

File source
(®) Upload local file to UMS server

Local file | C:Users\Administratorisample_rsa.pub | -

Upload location (LURL) | hitps IPM-MH-WINT-UMS.IGEL LOCAL 844 3iums_filetransfer/ | .

() Selectfile from UMS server

File location (URL) | -
File target
Classification | Undefined ‘l’]

Thin Client file location |M’stuseri.sshfauthnrized_keys |

Access rights

Read Write Execute
owner [ [V [+
Others [ [ U

Owner |User ¥

Ok Cancel
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@ If you wish to authorize more keys for SSH connections to thin clients, prepare an
authorized_keys file containing all the public keys. Simply append them using a text
editor.
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Configuring SSH Access on the Device

1. Go to System > Remote Access > SSH Access in the IGEL Setup or a profile.
Check Enable.
Optionally, if user hasanempty password, check Permit empty passwords.
Set Deny to No in the User access entry for user.

W

@ This configuration gives the remote user full shell access as if they were the local user on
the client.

Now you can connect to the device from the administrator's machine with the following
command:

ssh user@[client name or IP address]
Depending on whether you set a passphrase for the key, you may have to enter it or not.
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Secure Terminal (Telnet with TLS/SSL)

IGEL Linux version 5.11.100 or newer and IGEL Linux version 10.01.100 or newer allow terminal access via UMS with
transport encryption. In analogy to secure shadowing (see page 249), network traffic is encrypted with TLS/SSL. Secure
terminal connections can only be initiated from the UMS whose certficate is stored on the device.

For details about setting up a secure terminal connection, see UMS manual Secure Terminal (Secure Shell).

Secure Terminal is the best way to create a remote access from the UMS (on Linux or Windows installed) to Linux
devices, without installing an additional terminal software. Because the UMS includes the software.
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Secure Shadowing (VNC with TLS/SSL)

The Secure Shadowing function improves security when remotely maintaining a device via VNC at a number of
locations:

+ Encryption: The connection between the shadowing computer and the shadowed device is
encrypted.
This is independent of the VNC viewer used.

« Integrity: Only devices in the UMS database can be shadowed.

« Authorization: Only authorized persons (UMS administrators with adequate authorizations) can
shadow devices.
Direct shadowing without logging on to the UMS is not possible.

« Limiting: Only the VNC viewer program configured in the UMS (internal or external VNC viewer)
can be used for shadowing.
Direct shadowing of a device by another device is likewise not permitted.

@ Inaddition, IGEL Management Interface (IMl) in Version 2 or newer provides an API for
Secure Shadowing.

+ Logging: Connections established via secure shadowing are recorded in the UMS server log.
In addition to the connection data, the associated user data (shadowing UMS administrator,
optional) can be recorded in the log too.

(@ Of course, this is only relevant to devices that meet the requirements for secure
shadowing and have enabled the corresponding option. Other devices can be "freely"
shadowed in a familiar manner and, if necessary, secured by requesting a password. If you
would like to allow secure shadowing only, you can specify this in the UMS Console under
UMS Administration > Global Configuration > Remote Access.

« Basic Principles and Requirements (see page 250)
« Shadow Devices Securely (see page 251)
+ VNC Logging (see page 252)
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Basic Principles and Requirements
The Secure Shadowing option can be enabled subject to the following requirements being met:

+ IGEL Universal Desktop Linux or IGEL Universal Desktop OS 2, Version 5.03.190 and newer or
Version 10.01.100 and newer or IGEL Universal Desktop Windows Embedded Standard 7 from
Version 3.09.100.

+ IGEL Universal Management Suite from Version 4.07.100 onwards.

+ Theclientis registered on the UMS server.

« The client can communicate with UMS console and UMS server (see below).

Basic technical principles:

Unlike with "normal" shadowing, the connection between the VNC viewer and the VNC server (on the client) is not
established directly during secure shadowing. Instead, it runs via two proxies - one for the UMS console and one for
the VNC server on the device. These proxies communicate via a TLS/SSL-encrypted channel, while the local
communication, e.g. between the VNC viewer application and the UMS proxy, takes place in the conventional
unencrypted manner. As a result, a secure connection can also be established with external VNC programs that do
not support TLS/SSL connections.

The two proxies (UMS console and client) communicate with TLS/SSL encryption via the same port as the "normal"
VNC connection: 5900. As a result, no special rules for firewalls need to be configured in order to perform secure
shadowing.

If secure shadowing is active for a device under Setup > System > Shadowing > Secure Shadowing), the device
generates a certificate in accordance with the X.509 standard and transfers it to the UMS server when the system is
next started. The UMS server checks subsequent requests for a secure VNC connection using the certificate. The

certificate in PEM format can be found inthe /wfs/client-certs/tc_ca.crt directory onthe device. The
validity of the certificate can be checked on the (Linux) client using the command: x11lvnc -sslCertInfo /

wfs/client-certs/tc_ca.crt

If a UMS administrator calls up the Shadowing function in the UMS console for the device, the console receives a
signed request from the UMS server which is then passed on to the device to be shadowed. This in turn passes on
the request to the UMS server which checks the validity of the request using the original certificate. If this check is
successful, the console reports that the channel for the connection between the proxies can be established. The
UMS proxy on the console connects to the server proxy on the device, and the server proxy in turn establishes on
the device the connection to its VNC server.

Only when these connections have been established does the console call up the VNC viewer which then connects
to the console proxy. The VNC client and VNC server are now connected via the two proxies which transfer data with
TLS/SSL encryption.

Secure shadowing can be enforced independently of the client configuration for all devices that support this
function: UMS Administration > Global Configuration > Remote Access > Activate Global Secure VNC.
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Shadow Devices Securely

In order to shadow a device securely (with encryption), the administrator must log on to the server via the UMS
console. When doing so, it is irrelevant whether a purely local UMS administrator account is used or the user was
adopted via an Active Directory for example. As always, however, the UMS administrator must have the permission
to shadow the object, see Object-Related Access Rights.

The device to be shadowed is called up in the structure tree and, as usual, can be executed via Shadow in the
context menu. The connection window however differs from the dialog for normal VNC shadowing. The IP and port
of the client to be shadowed cannot be changed, and a password for the connection is not requested - this is
superfluous after logging on to the console beforehand.

Connect with

IGEL-O0EQ0CS3627EE 1723091 226| : 5900 kﬁ Pasgword [ Secure VHNC Cumneclwum] Shadow enabled

When a VNC connection has been established, the symbol in the connection tab indicates secure shadowing:

Z- IGEL VNC Viewer
File Tab Help

j 10.201.1.123:4 [~
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VNC Logging

Connections via secure shadowing are always logged in the UMS. Via UMS Administration > Global Configuration
> Remote Access > Secure VNC, you can configure whether the user name of the person shadowing is to be
recorded in the log:

+ Log user for secure VNC
The user name is included in the log.
O The user name is not included in the log. (default)

The VNC log can be called up via the context menu of a device or folder (for several devices, Logging > Logging:
Secure Access Logs). The name, MAC address and IP address of the shadowed device, the time and duration of the
procedure and, if configured accordingly, the user name of the shadowing UMS administrator are logged.

Remote Access Logs x

Filter: [ I

Thin Clie... | MAC Address UnitID: | Thin ClientIP | User | Starttime | Durat .| Comment Protocal
ws-l-trunk  00:E0:C5:14:31:C0 00EOCS51431C0  172.30.91.129 Sep 30, 2016 11:54:29 AM 0 Unknown Error Secure VMC A
ws-lx-trunk  00:E0:C5:14:31:C0 00EOC51431C0 172.30.91.129 Sep 30, 2016 11:54:42 AM 58 Secure VMNC
ws-l-trunk  00:EQ0:CH:14:31:C0 00EOCH1431C0 172.30.91.129 Sep 30, 2016 11:56:31 AM 0 Shadowing triggered by IMI - Secure VMC
ws-lx-trunk 00:E0:C5:14:31:C0 O00EOCH1431C0 172.30.91.129 Sep 30, 2016 11:56:31 AM 0 Shadowing triggered by IMl - Secure VMC
ws-lx-trunk 00:E0:C5:14:31:C0 00EOCS51431C0 172.30.91.129 Sep 30, 2016 11:57:31 AM 0 Shadowing triggered by IMI - Secure VMC
ws-betrunk  00:E0:C5:14:31:C0 00EOC51431C0 172.30.91.129 Sep 30, 2016 12:03:34 PM 5 Secure VNC
ws-le-trunk  00:E0:C5:14:31:C0 00EOC51431C0 172.30.91.129 Sep 30, 2016 1:48:18 PM 219 Secure VNC
ws-letrunk  00:E0:C5:14:31:C0 00E0C51431C0 172.30.91.129 Sep 30, 2016 2:32:40 PM 1007 Secure VMNC
ws-lx-trunk 00:EQ0:C5:14:31:C0 00E0CS51431C0 172.30.91.129 Sep 30, 2016 3:25:24 PM 120 Secure VNG v

48 Logs found.

> Tosort the list (e.g. according to user names), click on the relevant column header or filter the content shown
by making entries in the Filter field.
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Cherry eGK Channel Substitution

As of firmware version 10.05.100, the Cherry eGK Channel is no longer available. In the Igel Universal Desktop
Firmware, Linux V5, the VirtualChannel for Cherry eGK devices is still included parallel to the Cherry USB2LAN Proxy.
If you want to continue using the G87-1504/ST-1503 as before, with firmware version 10.05.100 and higher you have
to activate the proxy. All settings are automatically applied and run through the connector in the network.

Using the G87-1504/ST-1503 with firmware version 10.05.100 and higher:

« Activate the proxy - this can also be done from the backend.

® « Cherry USB2LAN Proxy (Under Smartcard) (see screenshot)
« IGEL device, valid for Cherry devices G87-1505, G87-1504/ST-1503 to USB

For IGEL Lx v5 and OS10:
+ Activate Cherry USB2LAN Proxy under IGEL Setup > Security > Smartcard > Services.

V' Activate Pt Daemon

Configuration
€) [V] Cherry USB2LAN Proxy
Metwark Interface auto
User Interface
Metwork

Devices

‘ Password
» Il Logon
» I Active Directory/Kerberos
O
[

B Middleware

System

For IGEL Lx v5:

+ Disable Cherry Channel 0 and Cherry Channel 1 under IGEL Setup > Sessions > RDP > RDP
Global > Mapping > Device Support.
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« Do not activate smartcard.

Configuration

op / XenApp

‘ Local Logon
‘ Window

B Drive Mapping

B cowmPorts

ﬁ Printer

[

ﬁ Audio
‘ Performance
‘ Options
B nat edirection
B Fabuia SB Redire
B vutimedia

2] |zl Enable plugin support

2]

CenterTools DriveLock cl
Cherry Channel 0 for reading German eGK-KVK with ST-1503/G
Cherry Channel 1 for reading German with 5T-15
Grundig MMC channel for dictation with Grundig de
Channel for Dictation with Olympus Devi
5 SpeechMike Control Channel for Dictation
¥ Phili peechMike Audio Channel for Dictation

Legacy Philips SpeechMike Mixer Channel for Dictation ((

Legacy Philips Digital Pocket Memo Channel for Dictation (C

Philips Speech Channel for Dictation

Enable smartcard

Install the Cherry eGK KVK software on the server. See https://www.cherry.de/files/software/Cherry-eGK-

KVK_Software_33.zip

Install the Cherry Linux software on the device.

+ In the CT-API configuration the G87-1504/ST-1503 can be configured as network device.

+ Link to Doku Client Server Integration: https://www.cherry.de/files/manual/
64410063-01_USBLANProxyClientServerUndCitrix.pdf

« Link to the software architecture documentation:: https://www.cherry.de/files/manual/Cherry-
eGK-KVK_Sofware-Architektur_Windows-20130927-v04.pdf

() TheVirtualChannel was replaced due to the following difficulties and the future application of the
telematics infrastructure (see also gematik anforderung lan)
+ Independent of Citrix version (no need to check compatibility anymore)
+ Independent of the server version (2008, 2012...), if the connection runs via RDP
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Single Sign-on for the Browser Proxy

Using a proxy to handle a browser's internet traffic provides additional security and control. However, if the proxy is
password-authenticated, the user has to enter their credentials, which adds some inconvenience.

With IGEL Linux version 5.08 or newer and IGEL Linux version 10.01.100 or newer, you can avoid this inconvenience
by using the passthrough feature. As a prerequisite, user logon must be carried out via Kerberos.
To enable single sign-on for the browser proxy:

1. Open the Setup and go to Security > Logon > Active Directory/Kerberos.
2. Activate Login to Active Directory/Kerberos.

IGEL Setup 10.01.120.01 (Build 5.3.27)

£ > ”~ / ™ Security * Logon ™ Active Directory/Kerberos

Configuration

B rirmware Update |

B smartcard Personalizat]
B dentify Monitors
B webcam Information
User Interface
Network
Devices
B Hardware Info
» Il Printer
¥ [J Storage Devices
B storage Hotplug
B Automount

4] Login to Active Directory Domain

B Elustooth
B USE access contral
Security
B Password
¥ [J Logen
B IGEL Smartcard
B Taskbar
|
B shared Workplace
¥ [ Active Directory/Kerbert

Login methods:

(] Explicit

] Remember last user name
[] smartcard

Logoff shortcut locations:
(/] start Menu
(] Application Launcher

[ start Menu's System tab
] Application Launcher's System tab

[ ] Desktop ] Desktop Context Menu
(] Quick Start Panel

Menu folder

Password Protection

[] Hotkey

Related Configurations

2] Active Directory /
Kerberos

Post Session
A
5] Command

Smartcard
& Middleware

Apply Ok Cancel

3. Go to Sessions > Browser > Browser Sessions > [name of the browser session] > Settings >

Proxy.
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4. In the Proxy Configuration choice, select Manual proxy configuration.
IGEL Setup 10.01.120,01 (Build 5.3.27)

s ™ Browser ™ Browser s » Browser ™ Settings ™ Proxy

Proxy Configuration | Manual proxy configuration Related Configurations

Proxy

Configuration

Im NoMachine NX Client FTP Proxy Port
» Il Parallels Client
» [ PowerTerm Terminal Ei
» I ThinLinc SSL Proxy
I ssH
» Bl VNC Viewer S0CKS Host

v 5 e SOCKS Protocal version [ SOCKS v5
¥ [ Browser Global

I Tabs No Proxy for localhost, 127.0.0.1
B content
B Frint Proxy Realm moz-proxy:{/172.30.178.10:8080
B Proxy [¥] Use Passthrough authentication
B Privacy o
B security
B Advanced Password
B Encryption
B commands [¥] Do not prompt for proxy authentication if credentials are saved
¥ [ Browser Sessions
¥ [ Browser
¥ [ settings
B Tabs
B content
| Frint
i Proxy
B Privacy
B Security
B Advanced
B Encryption
B Restart
B window
B Menus & Toolb -4
L

HTTP Proxy 172.30,178.10

Search v

Apply Ok Cancel

5. Foran HTTP proxy, define the following settings:
« HTTP proxy: IP address or hostname of the proxy to be used
+ Port: Port of the proxy for HTTP
+ No proxy for: IP addresses or hostnames of servers that can be accesses directly
+ Proxy realm: Area in which the browser authenticates itself for the proxy. Together with the
user name and password, this information is necessary for authentication.

® The Proxy realm field is internally pre-populated with the value moz-proxy://[HTTP

Proxy]: [Port] .Ifthefield is empty, this value will be used when authenticating the
browser. If the proxy expects another unknown value for the proxy realm, you can
determine this as follows: Leave the User name and Password fields empty and launch
the browser. The dialog window which appears will contain the correct value for the
Proxy realm field:

Authentication Required A X

The proxy moz-proxy:(/172.30.178.10:8080 is requesting a username and password. The
" site says:["'moz-proxy://172.30.178.10:8080"]

User Name: |

Password: | |

® cancel W 0K

In the
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example above, the value for the Proxy realm field is as follows: moz-proxy://

172.30.178.10:8080

+ Use passthrough authentication: Must be enabled to allow single sign-on for the browser

proxy.

+ Do not prompt for proxy authentication if credentials are saved: Must be enabled to
enable seamless single sign on for the browser proxy; suppresses the Authentication

Required dialog.

M NoMachine NX Client &
» [ Parallels Client
» Il PowerTerm Terminal E
» [l Thinlinc
B SSH
» [ VNC Viewer
v [ Browser
¥ [ Browser Global
B Tabs
B content
B rrint
B Proxy
B Privacy
B security
B Advanced
B Encryption
B commands
¥ [ Browser Sessions
v (3 Browser
¥ [ settings
B Tabs
B content
W Print
Prao:
B Frivacy
B security
B Advanced
B Encryption
B Restart
B window
B Menus & Toolb ‘;

Proxy Configuration

[Manua\ proxy configuration

M|

FTP Proxy Port

HTTP Proxy 172.30.178.10 Port 8080

SSL Proxy Port

S0CKS Host Port

SOCKS Protocol version |s0cKs vs M|

No Proxy for localhost, 127.0.0.1

Proxy Realm moz-proxy://172.30.178.10:8080

(] Use Passthrough authentication

(] Do not prompt for proxy authentication if credentials are saved ]

The next time the user logs in to the device, the browser proxy is ready to use.
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Limiting the Number of Permitted Login Attempts

Symptom

Users can attempt logging in as often and as fast as they want at the screen unlock prompt and local login prompts
(e.g. for Kerberos, Shared Workplace, IGEL Smartcard).

Problem

This leaves the system and remote sessions vulnerable to brute force login attacks.

Solution
In IGEL OS 10.03.100 and newer, the number of login attempts is limited to 5 within 30 seconds.
These values can be changed in the system registry:

1. In Setup, go to System > Registry

2. Gotothe auth.login.lockout_threshold parameter to set the maximum number of
login attempts within the specified interval.

3. Gotothe auth.login.lockout_duration parameterto settheintervalin seconds.

4. Click Apply or Ok.
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+ Certificate Enrollment and Renewal with SCEP (NDES) (see page 260)
+ Deploying Trusted Root Certificates (see page 280)
« Which CA Certificates Are Contained in IGEL OS? (see page 290)
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Certificate Enrollment and Renewal with SCEP (NDES)

SCEP is a protocol for certificate management which supports the secure issuance of certificates to network
devices.

Requirements

« SCEP server
The following SCEP server implementations can be used with IGEL Linux v5 or IGEL Linux 10:
« Windows 2008 Server with the Network Device Enrollment Service (NDES) role
« Windows 2012 Server
+ Windows 2016 Server
For information on how to deploy the NDES, see http://aka.ms/ndes.

« Connection between the SCEP server and the certification authority (CA).

This document explains the enrollment of certificates with SCEP.

Technical Background (see page 261)

Client Enrollment Details (see page 263)
Configuration of the SCEP Client (see page 265)
Files Involved (see page 274)

« Troubleshooting (see page 275)
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Technical Background

The Simple Certificate Enrollment Protocol (SCEP) defines a way of automatically enrolling certificates for the
authentication of network devices or VPNs. The client uses HTTP requests to fetch root certificates, to send

certificate requests, and to fetch client certificates from the server.

For an in-deep description, see the Microsoft technet article "Network Device Enrollment Service (NDES) in Active

Directory Certificate Services (AD CS)" under http://aka.ms/ndes.

Here is a typical certificate enrollment process:
e

~m

CA Certilicate
i [T
L 2

Certification
Authority

Check pefmissions

(

‘

AN

Domain
Controller

Confirm permissions

Device Administator SCEP Server
—— Create key j
N Request
password
Provide
password

Set password

Send enrolln

ent request

Send RArequest _

_ Issue certificate

Return certificate

1. The device creates an RSA public-private key pair.

2. The administrator requests a challenge password from the SCEP service (e. g. NDES).

@ Thechallenge password is only required for the first enrollment request. For certificate
renewal, the current certificate is used for authentication.

3. The SCEP server asks the domain controller if the administrator holds the required permissions for

the configured certificate templates.

4. The domain controller confirms that the administrator holds the required permissions.
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5. The SCEP server creates a challenge password and hands it over to the administrator.

@ Typically, the challenge password expires after a defined time. With the NDES that is
included in Windows 2008 Server, the default expiry time is 60 minutes.

6. The administrator provides the device with the challenge password, the CA identifier, and the
fingerprint of the CA certificate.

7. The device sends the enrollment request to the SCEP server, using the challenge password to
authenticate with the SCEP server. This action is triggered by the administrator.

8. The SCEP server signs the enrollment request with its enrollment agent certificate and sends it to
the CA.

9. The CAissues the desired certificate and returns it to the SCEP server.

10. The SCEP server returns the certificate to the device.
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Client Enrollment Details

This section describes the actual certificate enrollment in detail. The process described here corresponds to step 7
to 10 in the overall process (see page 261).

(® Theenrollment request and the response from the CA that contains the req

1. Theclient requests the CA's public certificate from the SCEP server.

The SCEP server sends the CA's public certificate to the client.

3. Theclient checks the CA's public certificate against the relevant fingerprint. The fingerprint has
been provided by the administrator via a UMS profile; see Defining the Certification Authority (see
page 270).

4. The client sends an enrollment request to the SCEP server. This enrollment request isan HTTP GET
request that contains the following:

Signed data PKCS7 Enveloped data PKCS7 Certificate Signing Request
(PKCS 10)

N

Version
Hashing algorithm
Signed (unencrypted) data: Version

Recipient and related
encrypted data encryption
key; the recipient is the CA.

Encrypted data: Version

(encrypted with a randomly
generated key that is
encrypted with the recipient's
public key)

Requested subject name
Public key of client
Challenge password
Requested extensions
Signature algorithm
Digital signature

Client certificate

Digital signature

5. Ifthe request was successful, the HTTP response from the SCEP server includes the following data:
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Signed data PKCS7 Enveloped data PKCS7 Degenerate Certificates (only
PKCS7)

Version

Hashing algorithm

Signed (unencrypted) data:  Version
List of recipients

Encrypted data: Version
Issued X.509 certificate

CA certificate

Digital signature
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Configuration of the SCEP Client

The configuration of the SCEP client on the IGEL Linux device is carried out as follows:

+ Creating a Profile in the UMS (see page 266)

+ Activating the SCEP Client (see page 267)

+ Entering the Data for the Certificate Signing Request (CSR) (see page 268)
« Defining the Certification Authority (CA) (see page 270)

+ Providing the SCEP Server Data (see page 271)

+ Applying the Profile to the Thin Clients (see page 272)
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Creating a Profile in the UMS

1. Inthe UMS structure tree, go to Profiles, open the context menu and select New Profile.

Enter an appropriate Profile Name.

In the Based on menu, select the firmware version that is installed on the devices in question.
Click OK.

The configuration dialog opens. The configuration dialog corresponds to the IGEL Setup available
on the devices to which the profile is assigned.

Call S
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Activating the SCEP Client

1. Goto Network > SCEP Client (NDES).
2. Enable Manage Certificates with SCEP.

SCEP Certificate Enrollment

> ' I petwork * SCEP Client (NDES)

Configuration & (V] Manage Cerificates with SCEP

User Interface

» I LAN Interfaces
B Mobile Broadband
» Il DHCP Client
» Il VPN
v [ SCEF Client (MDES)
i Certificate
i Cerification Authority
B scer
» [ Routing
i Hosts
» Il Network Drives

n P rosxy

Security
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Entering the Data for the Certificate Signing Request (CSR)

» Go to Network > SCEP Client (NDES) > Certificate and enter the following data:
Type of CommonName/SubjectAltName: The characteristic for linking the certificate to the thin client.

+ |P address: The IP address of the thin client.

« DNS name: The DNS name of the thin client.

« IP address (auto): The IP address of the thin client (inserted automatically).
« DNS name (auto): The DNS name of the thin client (inserted automatically).
« Email address: An email address.

« DNS name as UPN (auto)

() Iftheclient automatically obtains its network name, DNS Name (auto) is a good type for the thin client
certificate.

CommonName/SubjectAltName: Give a designation which matches the Type of CommonName/SubjectAltName.
For certain types, this occurs automatically. No entry is then required.

Organizational unit: Stipulated by the certification authority.

Organization: A freely definable designation for the organization to which the client belongs.

Locality: Details regarding the thin client’s locality. Example: "Augsburg".

State: Details regarding the thin client’s locality. Example: "Bayern".

Country: Two-digit ISO 3166-1 country code. Example: "DE".

RSA key length (bits): Select a key length (one suited to the certification authority) for the certificate that is to be
issued.
Possible values:

. "1024"
. "2048"
. "4096"

(@ TheRSAkey length specified here must not be lower than the minimum key length configured on the
server.
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SCEP Certificate Enrollment

> A LT

Configuration

» [ LAN Interfaces
B Wobile Broadband
» [l DHCF Client
» Il VPN
¥ [ SCEF Client (NDES)
B cerificate
B certification Autharity
B scer
» [l Routing
B Hosts
» Il Metwork Drives
‘ Proxy

Search

IGEL OS Articles

Type of CommoniamerSubjectalttame

CommanMamerSubjectalthlame

Organizational Unit

Organization

Locality

State

Country

RESA Key Length (hits)

& {DNS MNarme (auto)

& ‘Technical Documentation

A 1oELTechnology
ﬂ ‘Augsburg

& o

B ‘DE

N

Apply and send to thin client
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Defining the Certification Authority (CA)

1. Goto Network > SCEP Client (NDES) > Certification Authority.
2. Enter the details for the certification authority (CA):
+ CAldentifier: FQDN (fully qualified domain name) of the CA
+ CA Certificate Fingerprint (MD5): Fingerprint of the CA certificate in the form

01:02:03:04:05:06:07:08:09:0A:0B:0C:0D:0E:0F:10

® Youcan get the fingerprint from your NDES server: https://<NDES Servername>/

certsrv/mscep_admin

ITCO00BCADS5018

) ~ I ® MNetwark ™ SCEP Client (MNDES) ™ Certification Authority

Configuration CA ldentifier |Ca-examp|8-com |

= ion CA Cerificate Fingerprint (MD5) |:lJ--i:DS:DE:D?:IJB:DEI:DA:DEI:DC:DD:DE:DF:1 D||

User Interface

» [l LAN Interfaces
B Mobile Broadband
» [ DHCP Client
» I VPN
¥ [ SCEP Client (NDES)
B Certificate
B certification Authority
B scer
» [ Routing
‘ Hosts
» [l Metwork Drives
‘ P roxy

Apply and send to thin client Save Cancel

If the CA certificate fingerprint is specified, the client will use it to check the integrity of the CA
certificate it receives from the SCEP server.
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Providing the SCEP Server Data

1. Goto Network > SCEP Client (NDES) > SCEP.
2. Enter the following data:
« SCEP server URL: URL by which the SCEP client communicates with the SCEP server.

@ HTTPS s not supported; however, all security critical data that are transferred between
the SCEP client and other components are encrypted.

+ Proxy server for SCEP requests (optional): IP address or host name of the proxy server that
is used for the communication between the device and the SCEP server. If a web application
firewall is used instead of a proxy, its IP address or host name of the proxy server must be
entered here.

« Challenge password: Password that the SCEP client must present to the SCEP server in its
request (CSR).

® 0n aMicrosoft NDES server, you can retrieve the password by default under https:///

certsrv/mscep_admin.

© By default, the password on a Microsoft NDES server is valid for 1 hour and can be used only once.
In order to use the password on numerous devices, additional settings must be made on the NDES
server. For information, see the section "Password and Password Cache" on https://
social.technet.microsoft.com?.,

+ Certificate renewal period (days): Time interval before certificate expiry after which the
certificate renewal procedure is started. (Default: 30)

« Certificate expiry check interval (days): Specifies how often the certificate is checked
against its expiry date. (Default: 1)

3. Save the settings.

21 https://social.technet.microsoft.com/wiki/contents/articles/9063.active-directory-certificate-services-ad-cs-network-device-enrollment-service-
ndes.aspx
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Applying the Profile to the Thin Clients

1. Select all thin clients in the structure tree.

2. Inthe Assigned objects area, click €.

. IGEL Universal Management Suite 5

Server - 172.30.251.3

¥ [ ] IGEL Universal Management Suite §
¥ /3 Profiles (26)
¥ [ Mein erstes Verzeichnis (5)
J7 1{_Update
/7 Screensaver Countdown
/' Shared Workplace
[ Testprofil
/' elch: DE, Elchbrowser
v [ GCEP ()
J3 SCEF Ceificate Enroliment
¥ % Top Level Directory (4)
* | g Znd Level Directory (3)
[ L_Browser Sessions 1st Level
/7 |GEL-00E0CH3627EE
/7 |GEL-00E0CH3627EE
/7 |GEL-00E0CH3627EE
! ITCOOEDCA1AB106

T EL

[+

= [ Master Profiles (23
» X Template Keys and Groups (4)
» = Firmware Customizations {7)

[3 Retry automatic upgrade to IGEL Linux 10 despite of upgral

q @I ITCO00BCAO55018

]
Mame

1y

¥ System Information

Aftribute

MHame

LastIP

Site

Cormment
Department
Cost Center
Asset D
In-Service Date
Serial Mumber

Igel Cloud Gateway

Expiration Date of Maintenance Subscription
| | LastBoot Time

Metwork Name (at Boot Time)

Runtirne since last Boot

Total Operating Tirme

B ipset1

Graphics Memory 1 (MB)

Graphics Chipset 2

Graphics Memary 2 (ME)

v [ Thin Clients (2) DEnlis i
08 Type
3 Import (0) BIOS Vendor
ir; My Linu Thin Clients (0 BIOS Version
v o New devices (1) BIOS Date
[ ! Device Setial Mumhber
Structure Tag
[ = |

¥ L. Shared Waorkplace Users

3. Inthe Select assignable objects dialog, select the relevant profile and click

IGEL OS Articles

¥ Template Definition Check Results

Directory

Mame

r

to assign it.
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Select assighable objects x

Selected objects

7 Profiles (26) &
L & Mein erstes verzeichnis (5)
¥ P SCEP (1)

EF Certificate Enrollment

* [z Top Level Directory (4)
& 511 test
JZ Allawe firrmware upgrade to 1GEL Linwx 10
/7 DEVICE-03 \,
/& DEVICE-03
/& DEVICE-03
S Dummy=Profil W1 0
J& IGEL-N0EDCAZEITEE
J& IGEL-N0EDCAZEITEE
J& IGEL-N0EDCAZEITEE
J& ITCOOEDCATART06
J&' Retry autamatic upgrade to IGEL Linux 10 despite of upgrade fail
[# Screensaver countdown

LA Al fivreasses commresed o bee OEEL 1 imone 40

4, Click Ok.
5. Inthe Update time dialog, select Now and click Ok.
The client performs the actions as described in Client Enrollment Details (see page 263).
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Files Involved

Allfiles involved are stored in the directory /wfs/scep_certificates/cert0 . The following fixed file

names are used:

cacert.pem
racert_enc.pem
racert_sig.pem
client.csr
client.cert

client.key

IGEL OS Articles

CA certificate

RA certificate used for encryption (optional)
RA certificate used for signature (optional)
Certificate signing request

Client certificate

Private key of client certificate
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Troubleshooting

+ Diagnostics (see page 276)
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Diagnostics
Preliminary: Tools

System Log Viewer

» Inthe start menu, select the system icon and then System Log Viewer to open the system log viewer.

g Firmware Update
ICG Agent Setup

@ Identify Monitors

Metwork Tools

05 11 Upgrade Tool
Safely Rermove Hardware
Screenshot Tool

Setup

@ System Infarmation

IQ System Log Viewer ]

Task Manager
Touchscreen Calibration

E UMS Registration
m Webcam Information

For more information on starting, using, and configuring the system log viewer, see the System Log Viewer chapter

of the IGEL OS Manual.

Local Terminal

IGEL OS Articles

276/ 543



Certificates

» In the start menu, select the Local Terminal.

w EEElAppIication Launcher
. Local Terminal

If a local terminal session has not been set up on your device, proceed as follows:

1. Open the Setup and go to Accessories > Terminals.
2. Click Lt to create a local terminal session.
3. Click Ok to save the setting and exit the Setup.

For more information on starting and using the local terminal, see the Terminals chapter of the IGEL OS Manual.

Checking the Current Status of the Client Certificate Enrollment

> In the local terminal, enter the command cert_show_status
The status for each certificate relating to SCEP is shown:

+ CA certificate

+ RA encryption certificate
+ RAsignature certificate

+ Client certificate

Reviewing Log Messages

1. Open the system log viewer and select /tmp/journal.log

2. Press[Ctrl] + [F] and enter cert_agent to search for relevant messages.
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Alternatively, you can open a local terminal and enter journalctl | grep cert_agent

Reviewing the Certificates and Certificate Requests in the File System

1. Opena local terminal and login as user .

2. Enter 1s /wfs/scep-certificates/cert@/

Deleting a Certificate Request

1. Opena local terminal and login as root .

2. Enter rm -rf /wfs/scep-certificates/certo/

The directory that includes the certificate request, received certificates (if existing), and the
device's own private client key, is deleted. This can be useful for debugging purposes, and if SCEP
is no longer used.

Checking the CA

1. Openalocal terminal and login as root .

2. Enter scep_getca 0

Generating an SCEP Request Manually

1. Openalocal terminal and login as root .

2. Enter scep_mkrequest 0

Enrolling a Certificate Manually

1. Openalocal terminal and login as root .

2. Enter scep_enroll 0

Testing Certificate Renewal

1. Opena local terminal and login as root .
2. Generate an SCEP request and append "new" to the key file name: scep_mkrequest 0
“new”
An SCEP request is issued. In the directory /wfs/scep-certificates/cert0/ ,thekeyfile
clientnew. key iscreated.
3. Renew the certificate: scep_renew 0
4. Overwrite the old certificate with the new one: mv /wfs/scep-certificates/cert0/

clientnew.cert /wfs/scep-certificates/cert@/client.cert
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e

IGE

5. Overwrite the old key with the new one: mv /wfs/scep-certificates/cert0/

clientnew.key /wfs/scep-certificates/cert@/client.key
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Deploying Trusted Root Certificates

Purpose

IGEL OS comes with a number of trusted root certificates from certain Certificate Authorities (CA) pre-installed. Lists
of these root certificates can be found on the download server, in the

IGEL_UNIVERSAL_DESKTOP_FIRMWARE/LX/ directory®’. Theyare named [version]_CA-
certificates.txt -forexample,the list for IGEL OS version 10.03.100%,

Certificates signed with these root certificates can be used for server authentication and encryption in ICA, RDP,
Horizon and browser sessions. You can also verify the origin of Java applications.

Nevertheless, the root certificate you need might be missing. This document explains how to load and distribute it.

Requirements

The certificates must be available in the Base64 file format encoded with the file extension .pem, .crt

or .cer.

To check the file format, open the certificate with a text editor. It should look like this:

—————BEGIN CERTIFICATE-———-
MIIDWZCCAKOQAWIBADIQAA4 BWT VGG
MROWEQYKCZIMi ZFyLGOEGRYEDGYZdDET

EiNszngJsngHMQmmyS'29285062UJ
JUZN3SVTZT UZ 5w D HOM O PZy D ey
————— EMD CERTIFICATE-----

Solution

We advise you to use the following file transfer types for distributing the certificates via the UMS; see also
Registering a File on the UMS Server:

Type To be used for

Undefined All-purpose class, you need to set the owner and
access permissions manually.

Web Browser Certificate Server authentication/encryption of HTTPS
websites in browsers

22 http://myigel.biz/index.php?dir=IGEL_UNIVERSAL_DESKTOP_FIRMWARE/LX/V10/
23 http://myigel.biz/public/IGEL_UNIVERSAL_DESKTOP_FIRMWARE/LX/V10/Ix_10.03.100_CA-certificates.txt?forcedownload
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IGEL

SSL Certificate Server authentication/encryption in ICA, RDP or
Horizon sessions

Authentication via Active Directory (AD)

Java Certificate Authentication/encryption for Java applications

IBM iAccess Certificate Server authentication/encryption for IBM iAccess
sessions

Common Certificate (all-purpose) Multiple applications needing a certificate, e.g. if

you want to launch an ICA session in a browser, or
if you want to secure a Java session on a secure
website.

With these file transfer types, you will not need to reboot after installing.

+ Deploying Certificates via UMS (see page 282)
+ Installing Certificates Manually (see page 286)
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Deploying Certificates via UMS

We recommend using the Universal Management Suite when you need to deploy certificates to a several thin
clients.

Step 1: Loading certificate in the UMS

1. Openthe UMS console.

Right-click Files.

Choose New file to open the New file dialog.

Activate Upload local file to UMS server.

Browse your new certificate file under Local file.

Select the suitable Classification of the certificate under File target.
Confirm with OK.

Your certificate is now listed in the Files window.

Noouohkwn

Step 2: Assigning certificates to thin clients
After integrating the new certificates, you distribute them to the thin clients:

1. Choose one thin client or a group of thin clients in the UMS tree.
2. Click Add under Assigned objects.
The Select assignable object window opens.

IMhin ClientsiL¥ Devicess Assigned ohjects z 41‘. (—h =
1 =
Marme IP Address  MAC Address Product Firmware g. Marmne
Iﬂ IGEL-000C290 192 1R 3 NONC249049 IGEI Universal Deskinp...  4.06.50.. : o Full corfig sample
= JESBII Solect assighable objects | pp.. 4.05.50..
IGEL-000C2 .o 40611
153 Select assighahle objects :
IS IGEL-00EDC p.. 40650
E‘ IGEL-D0EQG ¥ |GEL Universal Management Suite p. 40611,
* Profiles
* Thin Clients
* e
Shared Workplace Users
» Johs
¥ Files
£ Torifikattest.cer Indirect assigned ohjects B o'Ia [ ]
Uni\fersalﬂxFi|esxz.amﬂkattest.cer| Directory | Name
Cancel

w

Select the new certificate and confirm by clicking on OK.

4. Select the Update time and confirm by clicking on OK.

The new certificate is now assigned to every thin client of the group and is listed under Assigned
objects.
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ed ohjects % .I. 4+ -

Mame

o Full config sample
= Zedifikattest.cer
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Loading Certificates in the UMS

Open the UMS console.

Right-click Files.

Choose New file to open the New file mask.

Activate Upload local file to UMS server.

Browse your new certificate file under Local file.

Select the suitable Classification of the certificate under File target.
Confirm with OK.

Your certificate is now listed in the Files window.

Nk whE
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Assigning Certificates to IGEL Thin Clients
After integrating the new certificates, you distribute them to the thin clients:

1. Choose one thin client or a group of thin clients in the UMS tree.
2. Click Add under Assigned objects.

The Select assignable object window opens.

Mame IF Address  MAC Address Product Firmuware
BIGEL—DDDCH N 167 1RA3  NAAC?909  IGFI Universal Desktop..  4.06.50...
@IGEL_DDDCE Select assignahble ohjects E TN
BIGEL—DDEDC p.. 4.06.50..
@IGEL—DDEDC ¥ |GEL Universal Management Suite p 40611
» Profiles
P Thin Clients
P Views
Shared Workplace Users
» Jobs
¥ Files
©  Fedifikattest.cer
Universal | FilesiZerlikatiest.cer |

r @

igned objects E ."_ (-EI‘ =

4
Mame

o Full config sample

Directary

ned objects 2 .':. [ ]

MName

w

Select the new certificate and confirm by clicking on OK.
4. Select the Update time and confirm by clicking on OK.

The new certificate is now assigned to every thin client of the group and is listed under Assigned
objects.

Mame

o Full config sample
= Zedifikattest.cer
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Installing Certificates Manually

Use the Firefox Certificate Manager in order to install web browser certificates; see Installing Web Browser
Certificates (see page 288).

For Java Runtime Environment certificates, use the Java Manager from the IGEL Setup; see Installing JRE
Certificates (see page 289).

Also a USB flash drive can be used for the manual import.
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Importing SSL Certificates (ICA, RDP, Horizon)

If a CA certificate is missing for RDP, ICA or Horizon, you can copy it from a USB storage device to the thin client:

1.
2.

Connect your USB storage device to the thin client.

Launch a Terminal session or press [CTRL]+[ALT]+[F11] to log in as ROOT on the Linux console of
the thin client.

Create a directory for certificates:

mkdir /wfs/ca-certs

Change to the directory:

cd /wfs/ca-certs

Get the name of your USB storage device:

1ls /userhome/media

Copy the certificate to the client:

cp /userhome/media// /wfs/ca-certs

Check whether the certificate was transferred:

1ls -al /wfs/ca-certs

End the terminal session or press [CTRL]+[ALT]+[F1] to exit the console.

@ The certificates you have saved will be available when you boot up the thin client next
time.
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Installing Web Browser Certificates
Installing web browser certificates manually:

1. Open the IGEL Setup.
2. Click Sessions > Browser > Browser Global > Certificates > View Certificates to open the Firefox

Certificate Manager.

s ™ Browser ™ Browser Global ™ Certificates

‘When a website requires a certificate | Select one automatically -

View Certificates

Certificate Validation | validate a certificate if it specifies an OCSP server A

» [ PowerTerm Terminal Enf
B IEM iAccess Client
» Il ThinLinc
M ssH
» Il VNC Viewer
¥ [ Browser
¥ [ Browser Global
B Tabs
B content
B Print
B Proxy
B Privacy
B security
B 2dvanced
B Encryption
i Certificates |
B smartcard Middley

3. Click Import... in the Authorities tab to import a new certificate from a directory or a USB flash
drive.

] When an OCSP server connection fails, treat the certificate as invalid

Certificate Manager

Your Certificates People|ServersfAuthoritiesjothers

You have certificates on file that identify these certificate authorities:

Certificate Name Security Device B
+ AC Camerfirma S.A. £
Chambers of Commerce Root - 2008 Builtin Object Token
Global Chambersign Root - 2008 Builtin Object Token
+ AC Camerfirma SA CIF AB2743287
Chambers of Commerce Root Builtin Object Token
Global chambersign Root Builtin Object Token .

— T

View... Edit Trust...

Export... Delete or Distrust...

(» Manually installed certificates will be saved permanently without any further configuration.
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Installing JRE Certificates

Installing Java Runtime Environment (JRE) certificates manually:

1. Activate the registry key java.deployment.save_certificates topermanently save the

JRE certificates.

Click Accessories > Java Manager.

Activate Desktop and click OK.

Open the Java Manager (Java Control Panel) from the desktop.

Click Manage Certificates... in the Security tab.
Java Control Panel - X

[ General [ Java [ Security | Advanced

6. Choose Signer CA under Certificate type.
Certificates x

ok wnN

Certificate type: |5i|_;|np_r CA |"|

User | System

lssued To Issuad By | |

7. Import the certificate.

@® Inthe UD2-MultiMedia, the commando su user -c "javaws -viewer" mustbe used.
Choose Trusted Certificates as Certificate type and import the certificate.
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Which CA Certificates Are Contained in IGEL OS?

The following CA certificates are contained in IGEL OS 10.05:

Certificate name Expiry date File in /etc/ssl/certs
ACCVRAIZ1 Dec 3109:37:37 2030 GMT ACCVRAIZ1.crt
ACEDICOM Root Apr 13 16:24:22 2028 GMT ACEDICOM_Root.crt

AC RAIZ FNMT-RCM Jan 100:00:00 2030 GMT AC_RAIZ FNMT-RCM.crt

Actalis Authentication Root CA  Sep 22 11:22:02 2030 GMT Actalis_Authentication_

Root_CA.crt

AddTrust External CA Root May 30 10:48:38 2020 GMT AddTrust_External_Root.
crt

AddTrust Class 1 CA Root May 30 10:38:31 2020 GMT AddTrust_Low-

Value_Services_Root.crt
AddTrust Public CA Root May 30 10:41:50 2020 GMT AddTrust_Public_Service
S_Root.crt
AddTrust Qualified CA Root May 30 10:44:50 2020 GMT AddTrust_Qualified_Cert

ificates_Root.crt

AffirmTrust Commercial Dec 31 14:06:06 2030 GMT  Aff4rmTrust_Commercial.
crt

AffirmTrust Networking Dec 3114:08:24 2030 GMT Aff+irmTrust_Networking.
crt

AffirmTrust Premium Dec 31 14:10:36 2040 GMT  AffirmTrust_Premium.crt

AffirmTrust Premium ECC Dec 31 14:20:24 2040 GMT  Aff4irmTrust_Premium_ECC
.crt

Amazon Root CA 1 Jan 17 00:00:00 2038 GMT Amazon_Root CA_1.crt

IGEL OS Articles 290 /543



Certificates

Certificate name

Amazon Root CA 2
Amazon Root CA 3
Amazon Root CA 4

Atos TrustedRoot 2011

Autoridad de Certificacion
Firmaprofesional CIF A62634068

Baltimore CyberTrust Root

Buypass Class 2 Root CA

Buypass Class 3 Root CA

CA Disig Root R1
CA Disig Root R2
CFCAEV ROOT
CNNIC ROOT

COMODO Certification Authority

COMODO ECC Certification
Authority

COMODO RSA Certification
Authority

IGEL OS Articles

Expiry date File in /etc/ssl/certs

May 26 00:00:00 2040 GMT Amazon_Root_CA_z .crt
May 26 00:00:00 2040 GMT Amazon_Root_CA_3 .crt

May 26 00:00:00 2040 GMT Amazon Root CA_4.crt

Dec 31 23:59:59 2030 GMT Atos TrustedRoot 2011.c
rt

Dec 31 08:38:152030 GMT Autoridad_de_Certificac
jon_Firmaprofesional_CIF

_A62634068.crt

May 12 23:59:00 2025 GMT Ba1timore_CyberTrust_Ro

ot.crt

.crt

.crt

Jul 19 09:06:56 2042 GMT CA_Disig_Root_Rl.crt
Jul 19 09:15:30 2042 GMT CA_Disig_Root_R2.crt
Dec 31 03:07:01 2029 GMT CFCA_EV_ROOT.crt

Apr 16 07:09:14 2027 GMT CNNIC_ROOT.crt
Dec 31 23:59:59 2029 GMT  coMODO_Certification_Au

thority.crt

Jan 18 23:59:59 2038 GMT  cOMODO_ECC_Certificatio
n_Authority.crt

Jan 18 23:59:59 2038 GMT  coMODO_RSA_Certificatio
n_Authority.crt
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Certificate name

Chambers of Commerce Root

Global Chambersign Root

Certigna

Certinomis - Autorité Racine

Certinomis - Root CA

Class 2 Primary CA

Certplus Root CAG1
Certplus Root CA G2
Certum CA

Certum Trusted Network CA

Certum Trusted Network CA 2

Chambers of Commerce Root -

2008

China Internet Network

Information Center EV Certificates

Root

IGEL OS Articles
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Expiry date File in /etc/ssl/certs

Sep 30 16:13:44 2037 GMT  Camer f+irma_Chambers_of_
Commerce_Root.crt

Sep 30 16:14:18 2037 GMT  Camer firma_Global_Chamb
ersign_Root.crt

Jun 29 15:13:05 2027 GMT Certigna.crt

Sep 17 08:28:59 2028 GMT Certinomis. -
_Autorité_Racine.crt

Oct2109:17:18 2033 GMT Certinomis -
_Root_CA.crt

Jul623:59:592019GMT  Certplus_Class_2_Primar

y_CA.crt

Jan 15 000000 2038 GMT Ce rtplus_Root_CA_Gz .crt

Jun 11 10:46:39 2027 GMT  Certum_Root CA.crt

Dec 3112:07:37 2029 GMT  Certum_Trusted_Network_

CA.crt
Oct 6 08:39:56 2046 GMT  Certum_Trusted_Network_

CA_2.crt

Jul3112:29:50 2038 GMT  Chambers_of_Commerce_Ro
ot_-_2008.crt

Aug 31 07:11:252030 GMT China_Internet_Network
Information_Center_EV_Ce

rtificates_Root.crt
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Certificate name

AAA Certificate Services

Secure Certificate Services

Trusted Certificate Services

Cybertrust Global Root

D-TRUST Root Class 3 CA 2 2009

D-TRUST Root Class 3 CA2 EV
2009

DST ACES CAX6
DST Root CA X3

Deutsche Telekom Root CA 2

DigiCert Assured ID Root CA

DigiCert Assured ID Root G2

DigiCert Assured ID Root G3

IGEL OS Articles
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Expiry date File in /etc/ssl/certs

Dec 3123:59:59 2028 GMT  Comodo_AAA_Services_roo
t.crt

Dec 3123:59:59 2028 GMT  Comodo_Secure_Services_
root.crt

Dec 3123:59:59 2028 GMT Ccomodo_Trusted _Services

_root.crt

Dec 15 08:00:00 2021 GMT  cybertrust_Global_Root.
crt

Nov 508:35:58 2029 GMT p-

TRUST_Root_Class_3 _CA_2_
2009.crt

Nov 508:50:46 2029 GMT  p-

TRUST _Root_Class_3 _CA_2_
EV_2009.crt

Nov 20 21:19:58 2017 GMT DST_ACES_CA_X6.crt
Sep 30 14:01:15 2021 GMT DST_Root_CA_X3.crt

Jul923:59:002019 GMT  peytsche _Telekom Root_C

A_2.crt

Nov 10 00:00:00 2031 GMT DigiCert_Assured_ID_Roo
t_CA.crt

Jan 15 12:00:00 2038 GMT D1 g-i Ce rt_Assu red_ID_ROO
t_G2.crt

Jan 15 12:00:00 2038 GMT D-i g-i Ce rt_Assu red_ID_Roo
t_G3.crt
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Certificate name

DigiCert Global Root CA

DigiCert Global Root G2

DigiCert Global Root G3

DigiCert High Assurance EV Root
CA

DigiCert Trusted Root G4

E-Tugra Certification Authority

EC-ACC

EE Certification Centre Root CA

Entrust.net* Certification

Authority (2048)

Entrust Root Certification
Authority

Entrust Root Certification
Authority - EC1

Entrust Root Certification
Authority - G2

24 http://Entrust.net

IGEL OS Articles
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Expiry date File in /etc/ssl/certs
.crt

.Ccrt

.crt

Nov 10 00:00:00 2031 GMT DigiCert_High_Assurance
_EV_Root_CA.crt

Jan 1512:00:00 2038 GMT pigiCert_Trusted_Root_G
4.crt
Mar 3 12:09:48 2023 GMT  g—

Tugra_Certification_Auth

ority.crt
Jan722:59:59 2031 GMT  Ec-ACC.crt

Dec 1723:59:59 2030 GMT EE_Certification_Centre

_Root_CA.crt

Jul2414:15:12 2029 GMT  Entrust.net_Premium_204

8 Secure_Server_CA.crt

Nov 27 20:53:42 2026 GMT Entrust_Root_Certificat

jon_Authority.crt

Dec 18 15:55:36 2037 GMT Entrust_Root_Certificat
jon_Authority_-_ECl.crt

Dec717:55:542030 GMT = Entrust_Root_Certificat
jon_Authority_-_G2.crt
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Certificates

Certificate name

GeoTrust Global CA

GeoTrust Global CA 2
GeoTrust Primary Certification

Authority

GeoTrust Primary Certification
Authority - G2

GeoTrust Primary Certification
Authority - G3

GeoTrust Universal CA

GeoTrust Universal CA 2

GlobalSign

GlobalSign

GlobalSign Root CA

GlobalSign

GlobalSign

IGEL OS Articles

e

IGE

Expiry date File in /etc/ssl/certs

May 21 04:00:00 2022 GMT  GeoTrust_Global_CA.crt

Mar 4 05:00:00 2019 GMT  GeoTrust_Global CA 2.cr
t

Jul16 23:59:59 2036 GMT  GeoTrust_Primary_Certif

ication_Authority.crt

Jan 18 23:59:59 2038 GMT  GeoTrust_Primary_Certif
ication_Authority_-

_G2.crt

Dec 123:59:59 2037 GMT  GeoTrust_Primary_Certif
ication_Authority_-
_G3.crt

Mar 4 05:00:00 2029 GMT  GeoTrust_Universal CA.c
rt

Mar 4 05:00:00 2029 GMT  GeoTrust_Universal CA_2

.crt

Jan 19 03:14:07 2038 GMT  G1lobalsi gn_ECC_Root_CA_
- _R4.crt

- _R5.crt

Dec 15 08:00:00 2021 GMT GlobalSign_Root_CA_-
_R2.crt

_R3.crt
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Certificate name

Global Chambersign Root - 2008

Go Daddy Class 2 Certification
Authority

Go Daddy Root Certificate
Authority - G2

Hellenic Academic and Research
Institutions ECC RootCA 2015

Hellenic Academic and Research
Institutions RootCA 2011

Hellenic Academic and Research
Institutions RootCA 2015

Hongkong Post Root CA 1

ISRG Root X1

IdenTrust Commercial Root CA 1

IdenTrust Public Sector Root CA 1

Imprivata Embedded Code
Signing CA

IGEL OS Articles

e

IGE

Expiry date File in /etc/ssl/certs
_—_2008.crt

Dec 31 23:59:59 2037 GMT Go_Daddy_Root_Certifica
te_Authority_-_G2.crt

Jun 3010:37:12 2040 GMT  Hellenic_Academic_and_R
esearch_Institutions_ECC
_RootCA_2015.crt

Dec113:49:522031GMT  Hellenic_Academic_and_R
esearch_Institutions_Roo
tCA_2011.crt

esearch_Institutions_Roo

tCA_2015.crt

.crt

Jun 411:04:382035GMT  TSRG_Root_X1.crt

Jan 16 18:12:23 2034 GMT  1denTrust_Commercial_Ro
ot_CA_l.crt

Jan 16 17:53:32 2034 GMT  1denTrust_Public_Sector
_Root_CA_l.crt

Sep 7 16:20:00 2033 GMT Imprivata.crt
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Certificate name Expiry date File in /etc/ssl/certs

lzenpe.com® Dec 13 08:27:252037 GMT 1 enpe.com®.crt

LuxTrust Global Root 2 Mar513:21:57 2035 GMT | yxTrust_Global_Root_2.
crt

Microsec e-Szigno Root CA2009  Dec 30 11:30:18 2029 GMT M4crosec_e-
Szigno_Root_CA_2009.crt
NetLock Arany (Class Gold) Dec 6 15:08:21 2028 GMT  NetLock_Arany_=Class_Go
F6tandsitvany . o
ld=_FOtanusitvany.crt
Network Solutions Certificate Dec 3123:59:59 2029 GMT Network_Solutions_Certi
Authority . .
ficate_Authority.crt
OISTE WiSeKey Global Root GA CA Dec 11 16:09:51 2037 GMT QISTE_WISeKey_Global_Ro
ot_GA_CA.crt
OISTE WiSeKey Global Root GB CA Dec115:10:31 2039 GMT  0ISTE_WISeKey_Global_Ro

ot _GB_CA.crt

OpenTrust Root CAG1 Jan 1500:00:00 2038 GMT  gpenTrust_Root_CA_Gl.cr
t

OpenTrust Root CA G2 Jan 1500:00:00 2038 GMT  openTrust_Root_CA_G2.cr
t

OpenTrust Root CA G3 Jan 1500:00:00 2038 GMT  gpenTrust_Root_CA_G3.cr
t

Autoridad de Certificacion Raiz del Dec 25 23:59:59 2020 GMT pSCProcert.crt
Estado Venezolano

QuoVadis Root Certification Mar 17 18:33:33 2021 GMT QuoVadis_Root_CA.crt
Authority

25 http://Izenpe.com
26 http://Izenpe.com
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Certificates

Certificate name

QuoVadis Root CA1G3

QuoVadis Root CA 2

QuoVadis Root CA2 G3

QuoVadis Root CA3

QuoVadis Root CA3 G3

SZAFIR ROOT CA2
SecureSign RootCAl1
SecureTrust CA

Secure Global CA

Security Communication EV

RootCAl

e

IGE

Expiry date File in /etc/ssl/certs
Jan 12 17:27:44 2042 GMT QuoVadis_Root_CA_1 _G3.c
rt

rt

rt

Oct1907:43:30 2035 GMT SZAFIR_ROOT_CA2.crt
Apr 8 04:56:47 2029 GMT  secureSign_RootCAll.crt
Dec 31 19:40:552029 GMT secureTrust_CA.crt

Jun602:12:322037GMT  security_Communication_
EV_RootCAl.crt

Security Communication RootCA2 May 29 05:00:39 2029 GMT security_Communication_

RootCA2.crt

Security Communication RootCA1 Sep 30 04:20:49 2023 GMT  security_Communication_

Sonera Class2 CA

Root CA.crt

Apr607:29:40 2021 GMT  sponera_Class_2 Root CA.

crt

Staat der Nederlanden EV Root CA Dec 8 11:10:28 2022 GMT  staat_der_Nederlanden_E

Staat der Nederlanden Root CA -

G2

IGEL OS Articles

V_Root_CA.crt

Mar 25 11:03:10 2020 GMT Staat_der_Nederlanden_R
oot_CA_-_G2.crt
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e

IGE

Certificate name Expiry date File in /etc/ssl/certs

Staat der Nederlanden Root CA-  Nov 13 23:00:00 2028 GMT Staat_der_Nederlanden R

G3
oot_CA_-_G3.crt

Starfield Class 2 Certification Jun2917:39:16 2034 GMT starfield _Class 2 CA.cr

Authorit
y t

Starfield Root Certificate Authority Dec 31 23:59:59 2037 GMT starfield Root_Certific

-G2
ate_Authority_-_G2.crt

Starfield Services Root Certificate Dec 3123:59:59 2037 GMT sStarfield _Services_Root

Authority - G2 o .
_Certificate_Authority_-

_G2.crt

SwissSign Gold CA - G2 Oct 25 08:30:35 2036 GMT  SyissSign_Gold_CA_-
_G2.crt

SwissSign Silver CA - G2 Oct 25 08:32:46 2036 GMT SwissSign_Silver_CA_-
_G2.crt

Swisscom Root CA 1 Aug 18 22:06:20 2025 GMT syisscom_Root CA_1l.crt

Swisscom Root CA 2 Jun 2507:38:14 2031 GMT  syisscom_Root CA_2.crt

Swisscom Root EV CA 2 Jun 25 08:45:08 2031 GMT  g\yisscom_Root EV_CA 2.c
rt

T-TeleSec GlobalRoot Class 2 Oct123:59:59 2033 GMT  T-

TeleSec_GlobalRoot_Class
_2.crt

T-TeleSec GlobalRoot Class 3 Oct 123:59:59 2033 GMT  T-

TeleSec_GlobalRoot_Class
_3.crt
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Certificate name

TUBITAK Kamu SM SSL Kok
Sertifikasi - Surum 1

Expiry date
Oct 25 08:25:55 2043 GMT

TURKTRUST Elektronik Sertifika
Hizmet Saglayicisi

Dec 22 18:37:19 2017 GMT

TWCA Global Root CA Dec 31 15:59:59 2030 GMT

TWCA Root Certification Authority Dec 31 15:59:59 2030 GMT

Government Root Certification Dec 513:23:33 2032 GMT

Authority

TeliaSonera Root CA vl Oct 18 12:00:50 2032 GMT

Trustis FPS Root CA Jan 21 11:36:54 2024 GMT

TUBITAK UEKAE Kok Sertifika
Hizmet Saglayicisi - Siriim 3

Aug2111:37:07 2017 GMT

TURKTRUST Elektronik Sertifika
Hizmet Saglayicisi H5

Apr2808:07:01 2023 GMT

USERTrust ECC Certification
Authority

Jan 18 23:59:59 2038 GMT

USERTrust RSA Certification
Authority

Jan 18 23:59:59 2038 GMT

IGEL OS Articles

e

IGE

File in /etc/ssl/certs

TUBITAK_Kamu_SM_SSL Kok
_Sertifikasi_-

_Surum_1.crt

TURKTRUST _Certificate_S
ervices_Provider_Root_20
O7.crt

TWCA_Global_Root_CA.crt

TWCA_Root_Certification
_Authority.crt

Taiwan_GRCA.crt

TeliaSonera_Root CA_vl.

crt
Trustis_FPS_Root_CA.crt

TUBITAK_UEKAE_KOk_Sertif
ika_Hizmet_Saglayicisi_-

_Surdm_3.crt

TURKTRUST _Elektronik_Se
rtifika_Hizmet_Saglayici
s1_H5.crt

USERTrust_ECC_Certifica
tion_Authority.crt

USERTrust _RSA Certifica
tion_Authority.crt
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Certificate name

UTN-USERFirst-Hardware

VeriSign Class 3 Public Primary
Certification Authority - G4

VeriSign Class 3 Public Primary
Certification Authority - G5

VeriSign Universal Root
Certification Authority

VeriSign Class 3 Public Primary
Certification Authority - G3

Visa eCommerce Root

XRamp Global Certification
Authority

certSIGN ROOT CA

ePKI Root Certification Authority

thawte Primary Root CA

thawte Primary Root CA - G2

IGEL OS Articles

e

IGE

Expiry date File in /etc/ssl/certs

Jul918:19:22 2019 GMT  yTN_USERFirst_Hardware_

Root_CA.crt

_Primary_Certification_A

uthority_-_G4.crt

_Primary_Certification_A

uthority_-_G5.crt

Dec 123:59:59 2037 GMT  yeriSign_Universal_Root
_Certification_Authority

.crt

_Primary_Certification_A

uthority_-_G3.crt
Jun 24 00:16:12 2022 GMT y4isa_eCommerce_Root.crt

Jan 105:37:19 2035 GMT XRamp_Global_CA_Root.Cr
t

Dec 20 02:31:27 2034 GMT epKI Root_Certification
_Authority.crt

JUI 16 23:59:59 2036 GMT thawte_Pr-i ma ry_Root_CA .

crt

Jan 18 23:59:59 2038 GMT thawte_Pr-i ma ry_Root_CA_
- _G2.crt
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e
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Certificate name Expiry date File in /etc/ssl/certs
thawte Primary Root CA - G3 Dec123:59:59 2037 GMT  thawte_Primary_Root_CA_
- _G3.crt
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Smartcard

» Authentication with IGEL Smartcard (see page 304)
» Smartcard Authentication (see page 313)
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Authentication with IGEL Smartcard

Smartcards make the user experience more convenient by providing a single device that supports multiple
authentication products across the enterprise. The user only has to remember a single PIN that unlocks the smart

card to access the network.

Prerequisites

Before using the IGEL smartcard, the relevant profiles and session information need to be written to the smartcard.

We describe a best practice way of how to proceed. The names of folders and profiles are only examples and can be

changed individually.

It is useful to use following folders and profiles on the Universal Management Suite (UMS):

Folder Profile

Smartcard Creation

Smartcard Key

Smartcard Operation

Smartcard Login

Purpose

Folder for devices which will be used for
smartcard creation.

This profile will apply the defined company key to
the devices. This key will be written while creating
the IGEL smartcard.

Folder for devices whose authentication process
will work only via IGEL smartcard.

This profile will apply the company key to the
devices and will activate the login with IGEL
smartcard.

» Create two folders under Profiles in the Universal Management Suite (UMS), e.g. "Smartcard Operation" and

"Smartcard Creation".

> Create the profile "Smartcard Login" for "Smartcard Operation".

» Create the profile "Smartcard Key" for "Smartcard Creation".

IGEL OS Articles

Creating IGEL Smartcard Folders (see page 305)

Folder "Smartcard Operation" (see page 306)

Folder "Smartcard Creation" (see page 307)

Writing the IGEL Smartcard (see page 308)

Smartcard Readers Supported by IGEL Smartcards (see page 312)
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Creating IGEL Smartcard Folders

First, add two new profile folders for creating profiles and assigning them to devices:

« "Smartcard Operation";
« "Smartcard Creation".

Server - 172.30.91.30

Fy

¥ /- IGEL Universal Management Suite 6

¥ Profiles (0)

[ Smartcard Operation (0)

[ Smartcard Creation (0)

IGEL OS Articles
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Folder "Smartcard Operation"
In this folder, you create a new profile "Smartcard Login":

1. Right-click the folder "Smartcard Operation".
Choose New Profile.

Enter a Profile Name, e.g. "Smartcard Login".
Click Security > Logon > IGEL Smartcard.
Enable Login with IGEL smartcard.

Enter your Company key.

oA WD

Configuration € [¥) Login with IGEL Smartcard

g
5
A .ories Company Key okkskokdok

REGE RS Start application to write IGEL Smartcards:
Network

Smartcard Personalization

Devices
Security

‘ Password
¥ [ Logon
B 1GEL smartcard
B Taskbar
B Active Directary/Kerber
I Active Directory/Kerberos
> I Smartcard

() Lateron, this profile will be applied to all devices where the authentication process shall work only
with a smartcard.
This way, the device will receive:

« the company key and
« theinformation that the authentication is only possible with the smartcard.

@ The company key is a private key shared between devices and smartcards. It should be
chosen similarly to a good password. If the smartcard does not hold the same company
key as the device, authentication will not be possible. Remember this company key
because you will need later to write exactly the same key to the smartcard.
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Folder "Smartcard Creation"
In this folder, you create a new profile "Smartcard Key":

1. Right-click the folder "Smartcard Creation".

2. Choose New Profile.

3. Enter a profile name, e.g. "Smartcard Key".

4. Click Security > Logon > IGEL Smartcard.

5. Enter the same Company key as in the profile "Smartcard Login".

Another additional folder is useful:

> Create the subfolder "Get settings from" under "Smartcard Creation".
In this folder, you create the profile with the session information you want to write to the smartcard.

Server - 172.30.91.30

¥ /- IGEL Universal Management Suite 6
Profiles (2]
¥ = Smartcard Operation (1)

Smartcard Login
¥ = Smartcard Creation (1)
¥ = Get settings from (1)
Smartcard Key

(D You need this additional folder because the assignment of active profiles from the UMS to the IGEL
smartcard can cause problems (firmware version < 5.06.100). Later on, you will copy the folder locally to
your device.
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Writing the IGEL Smartcard

Assigning the Profile "Smartcard Creation" to the Device

1. Prepare one device which has a smartcard reader/writer.

2. Integrate this device in the UMS and put it into the folder "Smartcard Creation".
Now the device automatically receives the company key from the profile. It will be used when
writing the smartcard.

Ensuring That the Profile Assignment Was Successful

1. Open the local setup of your device.
2. Click Security > Logon > IGEL Smartcard.
You should now see a disabled field Company key with a lock symbol.

* Logon ™ IGEL Smartcard

Configuration
9 | @M = @s
EEEIER—— o
IGEL Active Auto Logoff
Wi AR e Smartcard Directonyk...
- L
= -'

. Security A (] Login with IGEL Smart Card
Password [] Enable IGEL Smart Card without Locking Desktop

v Logon

IGEL Srmartcard Company Key |‘\1| kK

» o Active Directory/Kerber

Auto Logoff Start application to write IGEL Smart Cards:
oo Active Directory/Kerberos ||
R — — N S -
. System v | Smart Card Persanalization

Writing the Profiles to the Smartcard

1. Open the folder "Smartcard Creation" in the UMS.

2. Right-click your device.

3. Choose Take over settings from... to copy the profile settings to the device.
The dialog Copy settings from... opens.

4. Choose your profile from the folder "Smartcard Creation" > "Get settings from".

5. Enable Overwrite Sessions.
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Copy settings from ... E3

Zelect a profile

¥ Profiles (601) E
B o Misc (266)
¥ Smartcard Crestion (2)
¥ Get Settings from (1) /
_..- Example Seszion
_..- Smartcard Key
B o Smartcard Operation (1) E
@ Only Active Settings O Add Sessions
O Al Settings @ Creerwrite Sessions

6. Click OK to copy the profile with the settings and the company key to the device.

Writing the Smartcard

1. Open the local setup of your device.
2. Click Security > Logon > IGEL Smartcard.
3. Click Smartcard personalization.
The Smartcard personalization dialog opens.
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Smartcard Personalization

LLozd Sessions; Save Sessions

First name
Last Name
Require Password

Password

Available Sessions - Sessions on Smartcard |Autostart |Restart

[£] Browser
B caradigm Session

ICA Connection Center
Login

self-Service ==
genucard VPN Connection =
Java Manager

[®] RDP Session

EA rn Weh Acress | anin

Write smartcard | | X Close

ke

4. Enter the First name and the Last name of the smartcard holder that should appear at the login
prompt.

5. Activate Require password and specify the Password if a password has to be required for the
smartcard login.

6. Select the local sessions you want to write to the smartcard.

@ Usethe arrow buttons to add a session to the smartcard session list.

7. Activate Autostart for a session in the smartcard list if it should be automatically started at login.
Check Restart if desired.

@® The configuration of the sessions can be saved and reloaded at a later time.

8. Click Write smartcard to start the writing process with the defined settings.
9. Confirm the security question with Yes.
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Write Smartcard >

_ Writing the Smartcard overwrites all the Data
';' ! ;f on the Card. Do You want to go on?

P ]
. € No I @ ves
The notice Smartcard successfully written appears.
Write Smartcard b4
~—| Smartcard successfully written.
Lid

g 3
I ® Close !

Testing the New IGEL Smartcard

1. Go tothe UMS.

2. Register a new device in the UMS and putitin the folder "Smartcard Operation".
The device gets the company key and the profile information that authentication is only possible
with the IGEL smartcard.

3. Restart the device.
The Insert Smartcard... dialog opens.

4. Insert the IGEL smartcard into your device and verify the selected configuration.
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Smartcard Readers Supported by IGEL Smartcards
IGEL smartcards are supported by the following third-party smartcard readers:

« OMNIKEY CardMan 3111

+ OMNIKEY CardMan 3x21

« OMNIKEY CardMan 3621

« OMNIKEY CardMan 6121

« OMNIKEY CardMan 3821

+ USB CCID Smart Card Reader

« USB CCID Smart Card Reader Keyboard

+ Fujitsu Siemens Computers SmartCard-Reader USB 2A
+ Fujitsu Siemens Computers SmartCard-Reader Keyboard USB 2A
+ Fujitsu Siemens Computers SmartCard-Reader USB 2C
« Cherry SmartBoard XX44

« OMNIKEY CardMan 5121

+ OMNIKEY CardMan 5x21

+ HID Global OMNIKEY 3x21 Smart Card Reader

+ Cherry KC 1000 SC

+ Cherry KC 1000 SC/DI

« Cherry KC1000SCZ

« Cherry KC 1000 SC/DI Z

« Cherry SmartTerminal XX44 v2

« Cherry SmartTerminal XX44

+ OMNIKEY CardMan

+ CCID SC Reader

+ Cherry SC Reader.
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Smartcard Authentication

Certificate Authentication

The smartcards discussed here can hold digital certificates (x.509) and corresponding private keys. The private key
cannot be read from the card, but it can be used by the card itself for signing and decryption of data.

This enables the use of what is known as two-factor authentication: the user not only possesses the smartcard, he
or she can also prove the knowledge of the smartcard PIN by signing data using the private key stored on the
smartcard.

If you want to use Active Directory (AD), the certificate chain used by the key distribution center (domain controller)
must be available on the device. For instructions on deploying certificate files, see Registering a File on the UMS
Server (set Classification to "SSL Certificate") and Transferring a File to a Device.

Smartcard Readers

Smartcards are accessed via smartcard readers, using either a contact or contactless interface. The IGEL Third Party
Database?’ lists the readers that are supported by the Linux firmware.

PC/SC Resource Manager

The PC/SC Resource Manager is a common Application Programming Interface (API) that is available on Windows
and Linux operating systems. It provides a standardized way for applications to handle smartcards and readers.

The PC/SC Resource Manager is active by default in the Linux-based firmware and can be controlled via the Activate
PC/SC Daemon parameter on IGEL Setup > Devices > Smartcard > PC/SC or IGEL Setup > Security > Smartcard >
PC/SC or IGEL Setup > Security > Smartcard > Services (depending on the firmware version).

Smartcard Middleware

In order to provide a generalized interface to different types of smartcard hardware, there is an additional software
layer called smartcard middleware.

There are different types of middleware:

Windows Linux
CSP, Cryptographic Service Provider v
PKCS#11, Public-Key Cryptographic Standards v V4

27 https://www.igel.com/linux-3rd-party-hardware-database/
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Smartcard

Application

SC Middleware
CSP or PKCSH11

PC/SCResource
Manager

Smartcard Reader
Driver

Smartcard Reader

Smartcard

Some of the smartcard authentication methods require smartcard middleware to be installed on the endpoint
device. The following modules are available:

« Gemalto SafeNet

« cryptovision sc/interface

+ Gemalto IDPrime

+ Athena IDProtect

+ A.E.T.SafeSign

+ Secmaker NetiD

« Coolkey

» OpenSC

« TCOS3(IGEL Linux v5 only)
For information on how to use a custom PKCS#11 library, refer to the article Using a Custom
PKCS#11 Library (see page 378).

+ Active Directory Logon with Smartcard (see page 316)

« Citrix Legacy ICA Sessions (see page 317)

+ Citrix Legacy ICA Sessions with Local Logon Window (see page 318)
« Citrix StoreFront (see page 319)

» RDP Sessions (see page 321)

» Horizon Sessions (see page 322)

» Smartcard Authentication in Browser (see page 323)
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+ Citrix XenDesktop Appliance Mode (see page 324)
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Active Directory Logon with Smartcard

See the how-to Passthrough Authentication (see page 514).
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Citrix Legacy ICA Sessions
In this scenario, the smartcard middleware has to be installed on the server side.

1. Enable Activate PC/SC Daemon on the Smartcard > PC/SC page under Device or Security.
2. InIGEL Setup, check parameter ica.wfclient.smartcard under System > Registry.

Devices v — e icawwiclient smartcard
Search parameter ...
Security v
| ke [P Py ot T | 1
== A sCreenpercent &
Time and Date zetbwifocus
Uitz settwifacusontitled
Remote management
smallframesenabled
Shadow
Remate Access SlETUCEl
Energy speedscreenha
Firttrevare Customization speedscresnbacar
Registry speedscreenbacon Enable Smartcard Mapping
speedzcreenbadec E] Enable Smartcard Mapping
speedscreenbams

@ Both settings are active by default!
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Citrix Legacy ICA Sessions with Local Logon Window
This scenario allows ICA session roaming with a smartcard.

in addition to the configuration of the ICA Session (see page 317), the following settings are necessary:

» Check Use local login window and Smartcard logon under Sessions > Citrix > Citrix Global > Legacy ICA
Login.

se Kerberos passthrough authentication for all ICA sessions

Configuration
9 ﬂ V' Use local login window

Relaunch mode

B s Summary
B Global Session Options Setuser/domain from last login

vO Preset login information
B citrix Client Selection
O
‘ Legacy ICA Server Locz
[ ] Smartcard logon
‘ StoreFront Login

Show domain

Set client name to user name

> Select the appropriate PKCS#11 module for the smartcard under Security > Smartcard > Middleware.

« Gemalto/SafeNet eToken
« cryptovision sc/interface
« Gemalto IDPrime

« Athena IDProtect

+ A.E.T. SafeSign

« Secmaker Net iD

+ Coolkey

« OpenSC

» Custom PKCS#11 Module

For details about the CoolKey cryptographic library, see Using the CoolKey Cryptographic Library (see page 378).
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Citrix StoreFront

In this scenario, Citrix Receiver 13.1 or newer is required. The root certificate of the web server certificate used by the
StoreFront server has to be known as the trusted root certificate on the thin client - see Deploying Trusted Root
Certificates (see page 280), Certificate Type SSL Certificate.

1. Choose StoreFront as Citrix server type under Sessions > Citrix XenDesktop/XenApp > Citrix
StoreFront/Web Interface > Server.
2. Specify the Server Location.

Configuration Citrix servertype  #3  StoreFront

Server location

Praotocol Store address Path to Store Store name

B citrix Client Selection

»m

» I Citrix Legacy ICA Cilrik Store site address S

M D. | hit | - 443 C
‘ Login
‘ Appearance
0D
‘ Reconnect
‘ Refresh
‘ Logoff

3. Choose Smartcard authentication as Authentication type under Sessions > Citrix XenDesktop/
XenApp > Citrix StoreFront/Web Interface > Login.

Store name

Configuration Authentication type card authentication (StoreFront only, not Web Interf.
Only for Citrix StoreFront

 Options sthrough authentication

B citrix Client Selection
I
» [ Citrix Legacy
vO
[ ]
[}

L

Appearance

@ When used in combination with Active Directory Logon the enabled Use Passthrough
authentication activates single sign-on with smartcard.

4. Select the appropriate PKCS#11 module for the smartcard Security > Smartcard > Middleware.
« Gemalto/SafeNet eToken
+ cryptovision sc/interface
+ Gemalto IDPrime
+ Athena IDProtect
+ A.E.T. SafeSign
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e

IGE

+ Secmaker Net iD
+ Custom PKCS#11 module. See here also Using a Custom PKCS#11 Library (see page 378).
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RDP Sessions
In this scenario, the smartcard middleware has to be installed on the server side.

1. Enable Activate PC/SC Daemon under Security > Smartcard > Services.
2. Check Enable Smartcard under Sessions > RDP > RDP Global > Mapping > Device Support.

Configuration Enable plugin support

. ummary
n Global Session Options
» Il Citrix
¥ [0 RDP
v [ RDP Global
i Gateway
n Local Logon
i .'-"'l"irIdEIW
n Keyboard
¥ [ Mapping
n Dirive Mapping
B couPorts
‘ Printer

_ 8 Device Support v/ Enable smaricard
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Horizon Sessions

In this scenario, the smartcard middleware has to be installed on the virtual desktops as well as configured on the
endpoint device side.

The View Connection Server has to be configured on the endpoint device side.

(@ TheView Connection Server has to be configured to accept connections via SSL/TLS secured https URLs.
The root certificate of the certificate used for this service has to be known as the trusted root certificate on
the thin client (see the how-to Deploying Trusted Root Certificates (see page 280), certificate type SSL
Certificate).

1. Select the appropriate PKCS#11 support for the smartcard under Sessions > Horizon Client >
Horizon Client Global > Smartcard.
« Gemalto/SafeNet eToken
« cryptovision sc/interface
« Gemalto IDPrime
+ Athena IDProtect
+ A.E.T. SafeSign
+ Secmaker Net iD
+ Coolkey
» OpenSC
For details on the custom PKCS#11 library, refer to the article Using a Custom PKCS#11 Library (see
page 378).
2. Configure the Server URL under Sessions > Horizon Client > Horizon Client Sessions > [session
name] > Connection settings.

@ startthe URLwith https:// !
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Smartcard Authentication in Browser
Itis possible to authenticate using a smartcard at websites, e. g. Citrix Web Interface or StoreFront.

When connecting via an SSL/TLS secured https URL, the root certificate of the web server certificate has to be
known as the Trusted Root Certificate on the endpoint device; see Deploying Trusted Root Certificates (see page
280), certificate types Web Browser Certificate and (!) SSL Certificate.

> Select the appropriate PKCS#11 module (security device) for the smartcard under Sessions > Browser >
Browser Global > Smartcard Middleware.

« Gemalto/SafeNet eToken
« cryptovision sc/interface
« Gemalto IDPrime

« Athena IDProtect

« A.E.T. SafeSign

« Secmaker Net iD

« Coolkey

» OpenSC

For details on the custom PKCS#11 library, refer to the article Using a Custom PKCS#11 Library (see page 378).
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Citrix XenDesktop Appliance Mode
First configure the Smartcard authentication as described in Smartcard Authentication in Browser (see page 323).

Additionally:

1. Activate Enable Citrix Virtual Desktop under Sessions > Appliance Mode.
2. Enter the Virtual Desktop delivery server URL.
3. Enable Smartcard Login.

Configuration Appliance mode €)  Citrix Virtual Desktop

Virtual Desktop delivery server URL hitp:ifxenserver

€} (V] Smartcard Login

On-screen keyboard
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Desktop and Display

+ Display Configuration for Shared Workplace (SWP) (see page 326)

+ Display Switch (see page 327)

« Multimonitor (see page 331)

+ Showing and Hiding the On-Screen Software Keyboard Automatically (see page 343)

« Overcoming the Restrictions of a Full-Screen Session with the in-Session Control Bar (see page 344)
+ Screen Issues When Redocking Notebook (see page 346)
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Display Configuration for Shared Workplace (SWP)

As of IGEL Universal Desktop Linux version 4.14.100 and version 5.06.100, Shared Workplace allows user specific
screen resolutions and configurations. Resolution, layout, refresh rate, rotation, number of screens, monitor
connectors (DVI, VGA, ...) can be set per user, but color depth cannot.

() There are technical limitations to user-specific settings: For VIA graphics drivers/hardware, the maximum
desktop sizeis setinthe Screen section of the X confi guration file. The name and location of the X
configuration file depends on the firmware version:

+ IGEL Linux version 10: /config/Xserver/xorg.conf-0

+ IGEL Linux version5: /config/Xserver/xorg.conf-0 or /etc/X11/
xorg.conf (thisisasymboliclink that pointsto /config/Xserver/xorg.conf-0)
Inthe Screen section of the above-mentioned configuration file, you can find a line

suchas Virtual 1920 1200 .Thesize defined here cannot be changed dynamically;
itis a hard limit for the overall desktop size.

Best practice

It is recommended to set the initial desktop configuration to the maximum number of screens and the resolutions
to A utodetect . This way the user specific resolutions will not be restricted.

Debugging

If the total framebuffer size of the user specific resolutions exceeds the limits of the Virtual [width]

[height] settingfrom /config/Xserver/xorg.conf-0 (or /etc/X11l/xorg.conf ),the userspecific
resolutions cannot be activated and the screen configurations are not changed dynamically.

There is no warning dialog or anything else to alert the user to this restriction. But you can find related log
messagesvia journalctl orin /var/log/messages:

XRANDR: ERROR: CANNOT APPLY CHANGES ->

XRANDR: ERROR: -> Selected modes ([width]x[height]) would exceed the maximum
framebuffer size ([width]x[height])
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Display Switch

If you are using a notebook with IGEL UDC2, UDC3, or UD Pocket, you might want to connect an addtional monitor.
If you are using an IGEL thin client (UD series), you might want to use two monitors. Any thinkable display mode,
like clone mode/mirroring or extended mode, is possible. Moreover, you can change between the display modes
quickly.

Configure a Starter for the Display Switch

There are many ways to start the display switch. The following example shows how to define a hotkey typical for a
notebook.

1. Open the Setup and go to Accessories > Display Switch.
2. Activate Hotkey.

IGEL Setup 10.01.120.01 (Build 5.3.27)

< > A ] * Accessories * Display Switch

Configuration Session Name Display Switch
¥
A
B cA connection Center
» Il Terminals
» M Change Smartcard Pas [ Desktop [¥] Desktop Context Menu
» [ Change Password (] Quick start Panel
» I Setup . .
» [l Quick Settings
¥ [ Display Switch
B options
» I Application Launcher
» I Sound Preferences
» Il System Log Viewer
B uMS Registering
B Touchscreen Calibratio ) Hotkey
B Task Manager
B screenshot Tool
B on-Screen Keyboard
B Java Manager
B Monitor Calibration
B commands
B Network Tools
B Eluetooth Tool
B system Information
B Disk Utility
B safely Remove Hardwa
B Firmware Update
B smartcard Personalizat]
B dentify Monitors
B Webcam Information

Starting Methods for Session
(] start Menu V] start Menu's System tab
(] Application Launcher /] Application Launcher's System tab

Password Protection

Modifiers MNone

XF88Display

Henr lntarfarn

Search

Apply ok Cancel

By default, [Fn]+[F7] ( XF86D1isplay ) is defined as the hotkey for starting the display switch. You
can change the hotkey by selecting or entering different keys in Modifiers and Key.

@ Toenter a key that does not have a visible character, e. g. the [Tab] key, open a terminal,
logonas user andenter xev -event keyboard .Pressthe key to be used for the

hotkey. The text in brackets that begins with keysym contains the key symbol for the
Key field. Example: Tab in (keysym Oxff09, Tab)
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3. Press Apply or Ok.

Configure the Display Switch

1. Open the Setup and go to Accessories > Display Switch > Options.
2. Consider the following settings:

+ Dialog Type: In most cases, you can leave it at Minimal Dialog. The user can always switch
to the advanced dialog, provided that Advanced in the Buttons in Minimal Dialog area is

activated.

+ Preserve settings over reboot: Activate this if the settings made by the display switch are
to remain unchanged after reboot.

+ Configure new displays when connected: Activate this if you want the display switch to
start automatically as soon as a new monitor is connected.

+ To fine-tune the minimal dialog, change the settings under Buttons in Minimal Dialog.

B |CA Connection Center
» Il Terminals
» [l Change Smartcard Pas
» Il Change Password
» I Setup
» I Quick Settings
¥ [ Display Switch
|
» I Application Launcher
» Il Sound Preferences
» Il System Log Viewer
B UMS Registering
B Touchscreen Calibratio
B Task Manager
B Screenshot Tool
B on-Screen keyboard
B Java Manager
B Monitor calibration
B commands
B Network Tools
B Blustooth Tool
[ ] System Information
B Disk Utility
B safely Remove Hardwa
B Firmware Update
B smartcard Personalizat]
[ ] Identify Maonitors
B webcam Information

Ve e lombmrfm

Search

IGEL Setup 10.01.120.01 (Build 5.3.27)

switch  » Options

Dialog Type

| Minimal Dialog

(] Preserve settings over reboot
[[J configure new displays when cennected

Buttons in Minimal Dialog

(V] Mirror displays

/] Extend to the left

[ Extend to the right

[[] Rotate displays (Page orientation)
D Mouse options

V] Advanced

V] Reset

Apply Ok Cancel

Use the Display Switch

The minimal dialog will look similar to this; details depend on your specific setup:
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Displays
1: HDMI(l): Samsung 24" 2:VGA: Analog monitor Identify Displays

Button Function

Identify Displays Starts the monitor detection.

Uses only display 1.

Shows the same content on all screens, i.e. clone mode or mirroring.

Extends the display area to the screen on the right.

Extends the display area to the screen on the left

D
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For more information, see the manual chapter Using Display Switch.

Uses only display 2.

HO ML

1680x1050

2Z0P4LPY/AUS1435009584

The P marks the primary Display.
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Multimonitor
Working with two or more screens is becoming increasingly popular in professional working environments.
You can find out how to configure several screens and an extended desktop with the IGEL setup here.

There are different screen configuration options:

+ Automatic Configuration (see page 332)

+ Manual Configuration (see page 334)

+ Additional Settings (see page 336)

+ Auto Switch Monitor Configuration for Laptops (see page 341)

If you work with IGEL Universal Desktop or supported UDC2 hardware, multimonitor support is guaranteed.

Difficulties may arise if you work with UDC2 hardware and your hardware is not fully supported by IGEL.

(@ Multimonitor configuration for unsupported hardware only works if native graphic driver support
functions properly. You must ensure that the native driver really does work because the fallback VESA
driver does not allow multimonitor configuration. Click About in the Application Launcher to determine
which graphic chipset you work with. If VESA is listed there, the native driver will not work and
multimonitor configuration will not be possible.

» Seethe Linux 3rd party hardware database?® for supported graphic cards.

28 https://www.igel.com/linux-3rd-party-hardware-database/
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Automatic Configuration
The firmware recognizes the native graphic driver and will apply the screens automatically by default.
Define two or more monitors:

1. Go to User Interface > Display in the structure tree.
2. Select 2 (or more) under Number of screens.
Avyellow and a white rectangle for the primary and secondary screens will be shown:

2]

MNumber of screens

Selected screen
Screen resolution Autodetect

¥ Advanced ...

v Detect refresh rate automatically

Graphiccard Card 1

Monitor Automatic
Autodetect Resolution: The operating system reads out the EDID (Extended Display Identification
Data) of the monitors through DDC (Display Data Channel). With these data, the correct resolution

for the monitors can be recognized and set.
Automatic Monitor: Automatic assignment of the screen to the graphic connector (monitor).
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3. Dragand drop the rectangles to position the screens.
By default, the primary screen is the one where the taskbar is situated.

@ Ifthe Autodetect resolution is not available check the DDC Option under User interface >
Display > Options. The DDC Option must be enabled (default setting).
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Manual Configuration
During automatic configuration, the following problems can sometimes arise:

+ One of the screens remains black.
« There is the same display on all screens.

In this case, you can set the screens manually:

1. Go to User Interface > Display in the structure tree.
2]

Configuration -
Mumber of screens | -

‘ Power Options
n Access Control
‘ Gamma correction
B Options
» Il Desktop

‘ Language
» [ Screenlock/ Screensaver
» [ Input
» [ Hotkeys
» Il Font Services

MNetwork

Selected screen

Screen resolution Autodetect

»  Advanced ..

2. Select a screen number under Selected screen.
3. Specify the resolution manually under Resolution.

@ The standard resolution setting is Autodetect.

() FromIGEL Linux Version 10.03.100, you have the option of defining your own resolutions via the
registry ( x . xserver0.custom_resolution ). Inorder for the values set there to take effect,
the resolution must be set to Autodetect. The following parameters apply to the entry in the
registry:

+ WxH :W=width, H=height (example: 1920x1080)
+ WxHE@R :W=width, H=height, R =refresh rate (example: 1920x1080@60 or
1920x1200@59.8)

4. Select for all screens the respective connector under Monitor. The manual configuration can take
effect only if you assign the monitor connector to all screens.
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A

r

@ Ifyou adjust the settings directly in IGEL Setup, only the connected monitors will be
available in the selection list. If you want to configure the screens using the UMS profile, all
possible connectors will be shown in the selection list and you will not know which one is
relevant for your device.

Tip:
> Click Identify monitors in your client setup to obtain information about the connector names, screen

resolutions and screen numbers.

(@ This configuration cannot be accessed from the UMS.

The black field belongs to the screen number on the left side:

COnnector Name _l

screen resolution

DVI-D
S24B420/HAMDBOOESS

01200

screen numiber
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Additional Settings

A number of useful tips are provided below:

+ Rotating a Screen (Pivot) (see page 337)
+ Setting Different Backgrounds (see page 338)
+ Useful Window Settings (see page 339)
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IGEL

Rotating a Screen (Pivot)
1. Click on a monitor field.

2. Select E (Rotates the selected screen counterclockwise) or (Rotates the selected screen
clockwise).

(@ Two screens with autodetected resolutions are automatically aligned to the top.

> Alignment: If you enter the correct resolution, you can see the real size of the screens and you will be able to
align them the way you want.

@ Theindividual screen areas must however be in contact with each other at one edge and corner, and
cannot overlap.
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Setting Different Backgrounds

You can easily set different backgrounds for your screens.

» Click User Interface > Desktop > Background in the structure tree of the setup.
There is a configuration page for each screen.

Configuration Wallpaper (1st monitor) blue {
Wallpaper Style (15t Monitor) Streched

Color Style (1st Monitor) Solid color

Desktop Color (1st Monitor) Choose color

2nd Desktop Color (1st Monitor) Choose color

I Options €) V' Custom wallpaper download (1st monitor)

vO
= Custom Wallpaper file (1st Monitor) I:l

> Select the wallpaper and define the style.

@ You may also upload your own Custom Wallpaper, e.g. a background with your corporate design. See
Creating Your Own Wallpaper (see page 388).
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Useful Window Settings

Setting the Start Monitor or Full-screen Mode:

1. Click the name of your session under Sessions in the IGEL Setup, e.g. RDP > RDP Sessions.

2. lick [Session Name] > Window to configure the window settings.

Mumber of colors

| Global setting

Window size

Desktop scale factor

Display resolution
Start monitor

Multi-monitor fullscreen mode

€} fullscreen

Global setting

[Same as window size

| No configuration

| Global setting

@ Forthe function "2nd monitor as Start monitor" the Window size has to be set to full-

screen.

Setting the Multimonitor Full-screen Mode

1. Click Window in the global folder of your session, e.g. RDP > RDP Global > Window.

2. Configure the window settings.

Number of Colors
Window size

Desktop scale factor

[+/] Enable Display Control
[] control bar for RDP sessions

| Millions

fullscreen

auto

Multi Monitor

Multi-monitor fullscreen mode

Defining the Taskbar

1. Click User Interface > Desktop > Taskbar.
2. Define the Taskbar settings.
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] Use Taskbar

Taskbar Position

Vertical Taskbar Mode

Taskbar Height/width

MNumber of rows/columns in taskbar
Multi Monitor Taskbar Size

Maonitor

[] Taskbar an top of all windows

| Bottom

Deskbar

40

Automatic

[Restrict taskbar onto one monitor

1st monitor

[] Taskbar Auto Hide
Auto Hide Behavior
Taskbar Show Delay

Taskbar Hide Delay

Intelligently

600

@ If you want to expand the taskbar onto all monitors, you have to ensure that the screens
are aligned to the bottom. Otherwise, you will see only half of the taskbar on one monitor.
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Auto Switch Monitor Configuration for Laptops
This ist one example of how to configurate auto switch monitor for Laptops

1. Connect the Hardware and close/open lid

2. Open the Display Switch Utility

3. You can Drag & Drop the Displays for your intended configuration.
The display will snap adjacent to others.

4. If adisplay should not be used, it can be dragged to the disabled area on the top right - the screen
will be reactivated when it is dragged back to the active area.

5. To show the same content on multiple displays, one display should be dragged onto an other
active screen.
The interface will show mirror. The mirroring monitor will be displayed on the lower right.

6. Press Apply to save the setting

7. PressYes on the Keep configuration Dialog so that the current settings will be saved to persistent
storage and associated with the profile.
You can configure advanced functionality (e. g. panning, scalling and resolutions) in drop-down
boxes (hidden in a drawer on the right side)

+ Klick the > button on the right edge.
8. GoinIGEL Setup under Accessories > Display Switch > Options.
9. Enable Preserve settings over reboot and Smart display configuration. (Default: disabled)

IGEL Setup 10.05.500.01 (Build 5.9.18)

< > ~ ! » Accessories ™ Display Switch » Options
play P!

Configuration Dialog Type | Minimal Dialog

Sessions £} (V] Preserve settings over reboot

Accessories €} (] configure new displays when connected

B cA Connection Center
» [l Terminals
» [ Change Smartcard Pass
» I change Password
» [ Setup
» [l Quick Settings
¥ [ Display Switch
B options
» I ~pplication Launcher
» [ Sound Preferences
» [ System Log Wiewer
I UMS Registration
B Touchseraen Calibration

Buttons in Minimal Dialog

[ Mirror displays

(] Extend to the left

(] Extend to the right

(] Rotate displays (Page orientation)

[] Mouse options
] advanced
] Reset

10. TheIGEL Display Switch utility is now used for NVIDIA graphic devices as well.

Configuration of the display setting for Notebook lid handling

You can configure the lid handling of a notebook so that the notebook goes into standby mode by closing the lid,
regardless of whether the notebook is plugged in or not.

Settings of the Standby Mode

If you want your notebook to go into standby mode by closing the lid, while your notebook is plugged in, you have
to do following setting:

1. Go under IGEL Setup to System > Registry > system > actions > lid > ac
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2. SetLid close action while plugged in to Suspend (Default: Turn off display)
3. Click Apply or Ok to save the setting

If you want your notebook to go into standby mode by closing the lid, while your notebook isn't plugged in, you
have to do following setting:

1. Go under IGEL Setup to System > Registry > system > actions > lid > battery
2. SetLid close action while not plugged in to Suspend (Default: Turn off display)
3. Click Apply or Ok to save the setting

() Ifyou want that the notebook turn off display after closing the lid, it makes sense to set the following
setting to switch off the notebook internally:

1. Go under IGEL Setup to System > Registry > sessions > user_display0 > options >
lid_events.

2. Enable React on lid open and close event.

3. Click Apply or Ok to save the setting.
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Showing and Hiding the On-Screen Software Keyboard Automatically

You can configure the on-screen software keyboard to appear or disappear automatically when an input box is
selected or deselected (e. g. Firefox or screenlock).

Showing Automatically
With the following setting, a software keyboard will be shown automatically when an input box is focused.
1. Inthe Setup, go to Registry > userinterface > softkeyboard > autoshow (parameter:

userinterface.softkeyboard.autoshow).
2. Enable Automatically show on-screen keyboard when text field is selected.

Hiding Automatically

With the following setting, the software keyboard will be hidden automatically when an input box is not focused
anymore.

1. Inthe Setup, go to Registry > userinterface > softkeyboard > autohide (parameter:
userinterface.softkeyboard.autohide)
2. Enable Automatically hide on-screen keyboard when text field is deselected.

If there are any problems, e. g. the keyboard does not hide automatically, you have to disable Automatically hide
on-screen keyboard when text field is deselected and make sure that the following Setup parameters have been
enabled:

+ Accessories > On-Screen Keyboard > Autostart
+ Accessories > On-Screen Keyboard > Restart
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Overcoming the Restrictions of a Full-Screen Session with the in-Session
Control Bar

Running a session in full-screen mode gives you the advantage that the complete real estate of your monitor is at
the disposal of that session. However, you might still want to eject a hotplug drive, or to minimize or end the
current session. The solution provided by IGEL Linux is called in-session control bar.

Activating the in-session control bar:

1. Open the Setup and go to User Interface > Desktop > In-Session Control Bar.

2. Activate Use in-session control bar in all supported sessions if you want to have an in-session
control bar in all session types for which it is supported. If you want to have an in-session control
bar only in sessions of certain types, activate the appropriate options, e.g. Control bar for RDP

sessions.
Iﬂ ] Use In-session control bar in all supported sessions I

Start Monitor | Automatic )

[ ] contral bar for RDP sessions

[ ] control bar for Citrix sessions

[] control bar for ThinLinc sessions

[] contral bar for MX sessions

[] control bar for Parallels Client sessions

3. Inthe Start Monitor choice, select the display on which you want the in-session control bar to

appear. If unsure, leave it at Automatic.
#) (/] Use In-session control bar in all supported sessions

| start Monitor | Automatic - ||

[ ] contral bar for RDP sessions

[ ] control bar for Citrix sessions

[] control bar for ThinLinc sessions

[] Contral bar for MX sessions

[] control bar for Parallels Client sessions

4. Click Apply or Ok.

Using the in-session control bar:

1. Move the mouse to the upper edge of the desktop.
The in-session control bar appears.

) § dokuw7HS 4 3 X

2. To perform the desired action, click the appropriate icon:
« Toeject a USB device, click £ .
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« To minimize the session view, click * .
« To end the session, click X .
« To make the in-session control bar visible permanently, click * .

IGEL OS Articles 345 /543



Desktop and Display

Screen Issues When Redocking Notebook

Environment
UDC-converted notebooks running IGEL Linux 5 and above.
Issue

When you take a notebook off the dock, e. g. to move to meeting rooms or other locations, and redock the
notebook, the screen resolution ends up wrong, sometimes with a black screen and other similar screen issues.

Solution

1. In Setup, go to Accessories > Display Switch > Options.

2. Enable Configure new Displays when connected.
The display switch will start when the notebook is redocked.

3. Use the display switch to configure the display appropriately. For further information, see the Tips
& Tricks article Display Switch.

4. Click Ok to save the settings.

& LegalNote
IGEL's Terms & Conditions® apply.

29 https://www.igel.com/terms-conditions/

IGEL OS Articles 346 /543


https://www.igel.com/terms-conditions/
https://www.igel.com/terms-conditions/

Customizing 1

Customizing

« Custom Partition Tutorial (see page 348)

+ Using a Custom PKCS#11 Library (see page 378)

+ Adding an Icon for Browsing Removable Storage (see page 380)

« Adding an Icon for the Image Viewer (see page 382)

« Customizing IGEL OS Desktop (see page 384)

« How to Set Up a Countdown to Prevent an Undesired Screen Lock In IGEL OS (see page 403)
« Installing a Calculator on IGEL Linux (see page 415)

+ Keyboard Shortcuts for Managing Windows (see page 416)

+ Make Frequent User Actions Easier by Defining Hotkeys (see page 417)

+ Suspend to RAM - Wake Up by USB Mouse (see page 419)

« Taking Screenshots on IGEL Linux (see page 420)

+ Setting the Device's System Time (see page 421)

« Updating Timezone Information (Daylight Saving Time, DST) (see page 422)
« Adding or Changing a MIME Type Handler (see page 426)

+ Regional Settings in Sessions (see page 430)
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Custom Partition Tutorial

The Custom Partition (CP) mechanism solves the task of supplying additional software or other files to IGEL OS
while still being able to update the system in the regular way.

This tutorial describes creating contents for a Custom Partition for IGEL OS version 10.03.100 or newer. You may also
find it useful for updating existing custom partitions in order to make them work on IGEL OS version 10.03.100 or
newer, as some details have changed.

& ThelGEL Support Team offers support for the deployment of Custom Partitions. However, it is not possible
to offer support for any third-party software that is installed on a Custom Partition.

© Ifyou want to build a Custom Partition and give it to third parties make sure you have redistribution
permission for the software. This is usually the case for Open Source / Free Software, but not for
proprietary software. Read license agreements and respect them.

« AFirst Simple Custom Partition (see page 349)
+ Packaging a Simple Custom Partition (see page 355)
« AReal-World CP: Chromium (see page 363)
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A First Simple Custom Partition

As a first step, this tutorial will guide you through creating a simple Custom Partition. It will open a message window
greeting the user, which can be run by clicking a desktop icon. You will learn about some basic mechanisms of
Custom Partitions in this section.

« Development Environment (see page 350)
Activating the Custom Partition (see page 351)
Custom Partition with a Shell Script (see page 352)
Creating a Custom Application (see page 353)
Using a Partition Parameter (see page 354)
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Development Environment

For this first simple Custom Partition, you only need access to a thin client or converted device with IGEL OS version
10.03.100 or newer. And you need to be root.
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Activating the Custom Partition
By default the Custom Partition is disabled on IGEL OS. Activate it in order to start working on its contents.

In Setup go to System > Firmware Customization > Custom Partition > Partition.
Check Enable Partition.

Set the Sizeto 10M (Megabyte).

Leave the Mount Pointat /custom

Click Apply.
The Custom Partition is created on mass storage.

ok W e
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Custom Partition with a Shell Script

Your first CP will contain a simple shell script that displays the message "Hello, world!" with the help of the

gtkmessage utility.

m Hello, Warld!

+" Close

1. Loginto Local Terminalas root .
2. Changeintothe /custom directory: cd /custom
3. Make a hello directory for your CP contents: mkdir hello
4. Change into the hello directory: cd hello/
5. Open a new plaintext file using the GNU Nano editor: nano hello.sh
6. Put this content into the file:
#!/bin/bash
gtkmessage -m "Hello, World!" -t "Hello" -o "Close"
7. Save the file by pressing [Ctrl]+[o], [Return].
8. Exitthe GNU Nano editor by pressing [Ctrl]+[x].
9. Make the file executable: chmod a+x hello.sh

10. Run the shell script from the command line to testit: . /hello.sh

A message window like the one pictured above should open. You can close it with the Close
button.

IGEL OS Articles 352 /543



Customizing

Creating a Custom Application

In the previous step you have created a little application and executed it form the command line. Now make it more
convenient for end users to run it: Create a custom application and place an icon on the desktop that users can

click.

1.
2.

8.

N ok w

In Setup, go to System > Firmware Customization > Custom Application.
In the Custom Applications list, click + to add an application.
The Desktop Integration page opens.

Enter Hello Application intoasthe Session Name.
Click Apply.

Go to Settings.

Enter /custom/hello/hello.sh asthe Command.

Click OK.
A Hello Application icon has appeared on the desktop.

»

Hello Application

Double-click the icon.
The message window should open.
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Using a Partition Parameter

When you roll out the same Custom Partition contents to many devices you may still want the application to use
different data or options on some of the devices. Partition Parameters allow you to do this.

() Partition Parameters are a new feature in IGEL OS version 10.03.100 and newer.

This is how you add a Partiton Parameter to the sample CP.

Setting a Partition Parameter in Setup

1. Go to System >Firmware Customization > Custom Partition > Partition.
. Inthe Partition Parameters list, click [+] (Add).

2
3. Inthe dialog that opens, enter NAME asthe Name and Al-ice astheValue. Click OK.
4. Click Apply.

Getting the Value of a Partition Parameter

This is the command line for getting or setting a Partition Parameter's value:

customparam [get|set] PARAMETER_NAME [PARAMETER_VALUE]

1. Changethe hello.sh scriptto use thiscommand to get the parameter value:
#!/bin/bash

gtkmessage -m "Hello, $(customparam get NAME)!" -t "Hello" -o
"Close"

2. Click the Hello Application desktop icon.
You should see the following:

Hello - A X

Hello, Alice!
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Packaging a Simple Custom Partition

In the previous section, you developed Custom Partition contents locally on a thin client. Now package it in order to
deploy it to many thin clients via the Universal Management Suite (UMS).

« Development Environment (see page 356)

+ Compressing the Custom Partition Contents (see page 357)
+ Writing the *.inf Metadata File (see page 358)

+ Uploading the Files to the UMS (see page 359)

+ Creating a Profile for the Custom Partition (see page 360)

+ Assigning the Profile (see page 362)
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Development Environment
For this section you need

+ asystem with IGEL OS version 10.03.100 or newer,
« aWindows or Linux workstation with Universal Management Suite (UMS) in version 5.07.100 or
newer,
« amethod to exchange files between the thin client and the workstation.
While a USB pen or disk drive would do the trick, it is more convenient to have either a
+ Windows fileshare or
« an NFS export

that you can access both from the thin client and the workstation in order to exchange files.
Learn where to mount network drives in the IGEL OS Manual.
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Compressing the Custom Partition Contents

The contents of a Custom Partition are packaged as a compressed tar file. You can easily create it on the Linux
command line, e.g. on the thin client:
1. Inthe Local Terminal changeintothe /custom/ directory: cd /custom
2. Compressthe contents of the hello/ directoryinto an archive file named hello.tar.bz2:
tar cjvf hello.tar.bz2 hello/
Theresultisa hello.tar.bz2 file,sitting side-by-side with the hello/ directory. You will
upload it to UMS later.
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Writing the *.inf Metadata File

The compressed archive that you created in the previous step is accompanied by a plain text file with some
additional information for the thin client. You can use GNU Nano on the thin client or your favorite text editor
elsewhere to produce it.

Create a new file named hello.inf and put the following into it:

[INFO]
[PART]
file="hello.tar.bz2"

version="1.0_1igell"

size="10M"

name="hello"
minfw="10.03.100"

The individual entries and their meaning are:

[INFO]: Mandatory string

[PART]: Mandatory string

file: The filename of the *.tar.bz2 archive

version: The version of the contents, consisting of the vendor version (let's say this is hello 1.0)
and the IGEL package version (the first package we produced of the software), joined with an
underscore.

size: Size of the decompressed contents
name: Name of this content, used for naming the subdirectory within the custom partition and for

keeping track of installed contents
minfw: Minimum firmware version required for these contents
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Uploading the Files to the UMS

Upload the compressed hello.tar.bz2 archiveandthe hello.inf metadata file to the UMS, which will
serve them to other thin clients via HTTPS.
1. In UMS Console right-click the Files folder in the structure tree and select New File from the

context menu.
The New file dialog opens.

2. Under Upload local file to UMS server select the hello.tar.bz2 file with the file chooser.
3. Click OK.
4. Repeat the steps above forthe hello.inf file.

The new files show up in the Files folder.

File source
(® Upload local file to UMS server

Local file |,rmm;shared;upluad;mathias.huber;heua.tar.bzz |-

Upload location (URL) |https:ff—:server:pun}fums_filetransfer |-

() select file from UMS servar

File location (URL) | L
File target
Classification | Undefined v]

Thin Client file location | |

Access rights

Read Writa Exacute
owner ] @ ]
others [ [ ]

Owner | User |«

E Cancel
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Creating a Profile for the Custom Partition

After you have uploaded the Custom Partition files to UMS, you can now make the settings that will install the
Custom Partition on a thin client. Put them into a profile that you can assign to any number of thin clients.

Activating the Custom Partition

1. In UMS Console right-click the Profiles folder and select New Profile from the context menu.
The New Profile dialog opens.

2. Enter Hello CP astheProfile Nameand Installs the Hello Custom Partition
as the Description. You can leave the remaining fields.

3. Click OK.

The Setup window opens, where you will make the settings for this profile.

Go to System > Firmware Customization > Custom Partition > Partition.

Unlock the Enable Partition setting by clicking the orange triangle so that it turns blue.

Check Enable Partition.

Unlock the Size setting by clicking the orange triangle so that it turns blue, and enter 10M

Leave the Mount pointat /custom
Click OK.

e A

Setting the Download Source
For this step, you need to determine the HTTPS download address for the hello.inf file first.

1. To find out the IP address of your UMS, go to System > Remote Management in Setup. You will
find the UMS server your client is registered with there, and its IP.
2. Open a web browser and visit the following URL:

https://[IP or name of your UMS host]:8443/ums_filetransfer

3. When prompted, authenticate with your UMS username and password.
You will see a directory listing of the files that can be downloaded from UMS.
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Directory Listing For /- Mozilla Firefox
File Edit View History Bookmarks Tools Help

| Directory Listing For / x|+

) (O B | https://172.30.91.158:8443/ums_filetransfer | & ||Q Search | & B 4 & B &

chromium-browser.tar.bz2 79692.0 kb Thu, 10 Aug 20817 09:29:43
supportinfo/ Thu, 18 May 2017 11:19:59 GMT
IGEL Universal Desktop 0S5 3-10.02.120/ Wed, 12 Jul 20817 :14:29 GMT

IGEL Universal Desktop 0S 3-18.81.310/ Fri, 18 Aug 2017 ©9:58:37 GMT
IGEL Universal Desktop 0S 3-18.83.116/ Mon, 84 Sep 2017 :44:51 GMT

IGEL Zero-10.03.118/ Mon, 84 Sep 2017 :44:05 GMT
ovdc 3.2.0-amd64.tar.bz2 46051.0 kb Tue, 22 Aug 2017 12:56:01 GMT
IGEL Universal Desktop LX-10.02.218/ 31 Jul 2017 12:27:11 GMT
IGEL Universal Desktop LX-10.03.118/ 31 Aug 2017 :56:58 GMT

IGEL Universal Desktop LX-10.62.128/ 12 Jul 2017 15:14:04 GMT
Sep 2017 09:43:53 GMT

S Open Link in New Tab Sep 2017 89:44:38 GMT
——— Open Link in New Window . -

gdroot-g2  Open Link in New Private Window Sep 2017 09:09:05 GMT

gdig2.crt  Bookmark This Link Sep 2017 09:32:51 GMT
—  Savelink As...
Save Link to Pocket
Copy Link Location
Search Google for “hello.inf”

Inspect Element (Q)

Right-click the hello.inf entry and select Copy Link Location.

In the profile's settings go to System > Firmware Customization > Custom Partition >
Download.

Click [+] to add a Partition Download Source.

The Add dialog opens.

Paste the URL you copied from the browser into URL.

Enter the User name and Password for the access to your UMS.

You can ignore the Initializing Action and Finalizing Action fields for the time being.
10. Click OK.

o

LN

Creating a Custom Application

> Add a custom application to the profile by following the steps in Creating a Custom Application (see page 353).
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Assigning the Profile

Now that you have put all the settings for installing the Custom Partition on a thin client into a profile, it is time to
assign the profile.

1. Inthe UMS structure tree, drag and drop the icon of your profile onto the icon of a thin client.
The When should these changes take effect? dialog opens.

2. Select Now and click OK.
The thin client receives new settings.
The Hello Application icon appears on the desktop.

3. Inthethin client's local Setup, go to System > Firmware Customization > Custom Partition >
Partition.

4. Add a Partition Parameter with the Name NAME and a Value of your choice.

Click the icon to test the application.
6. It should open, displaying a text containing the name of your choice.

o
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A Real-World CP: Chromium

The previous example was simplified, but it taught you a lot of the IGEL Custom Partition fundamentals. Now build
on top of these and try your hand at a real-world CP: the Chromium web browser - the Open Source sibling of
Google Chrome, a complex application with a variety of features.

@ Asyou will be working with original Ubuntu packages, actual version numbers (or packages) may differ
from this tutorial, as Ubuntu frequently update their packages. The method for building the CP, however,
remains the same.

« Development Environment (see page 364)

+ Getting the Ubuntu Package (see page 365)

+ Unpacking the Ubuntu Package (see page 366)

+ Creating a Larger CP (see page 367)

+ Setting Up Library Paths via Script (see page 368)
+ The First Run (see page 370)

+ Obtaining Libatomic (see page 371)

+ Installing Libatomic (see page 372)

« Another Test Run (see page 373)

+ Providing Libffmpeg (see page 374)

« Chromium Starts Successfully (see page 375)

+ Packaging the Custom Application (see page 376)
« Advanced (see page 377)
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Development Environment

For this section you need

a system with IGEL OS version 10.03.100 or newer,
a Windows or Linux workstation with Universal Management Suite (UMS) in version 5.07.100 or
newer,

a Debian or Ubuntu Linux workstation for unpacking the *.deb package (can be the same as the

Linux workstation hosting UMS),

a method to exchange files between the thin client and the workstation.

While a USB pen or disk drive would do the trick, it is more convenient to have either a
+ Windows fileshare or
« an NFS export

that you can access both from the thin client and the workstation in order to exchange files.
Learn how to mount network drives in the IGEL OS Manual.*

30 http://edocs.igel.com/11105.htm
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Getting the Ubuntu Package

As the Chromium web browser is Free Software it can be found in the package repositories of Linux distributions. To
build Custom Partitions, use the software packages from exactly that Ubuntu version on which your version of IGEL
0S is based. From IGEL OS 10.04 up to IGEL OS 11.03, this is Ubuntu 16.04 (Xenial Xerus). You need packages for the

amd64 (also known as x86_64 ) architecture.
This is how to find the right package and download it to your Linux workstation:

1. Inaweb browser,goto https://packages.ubuntu.com
2. Use the Search package directories form to search

a. Set Keywordto chromium

b. SetDistributionto xenial

c. Click Search.

Search

Search package directories

Keyword: | chromium Search || Resst

Search on: '® Package names only Descriptions Source package names

Cnly show exact matches:
Distribution: | xenial ¥ | Section: | any v

3. Ontheresults page, click the chromium-browser package to go to its details page.
4. Atthe bottom of the details page, click the amd64 link to download the package to a local
directory on your Linux workstation.
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Unpacking the Ubuntu Package
Extract the Ubuntu package on your Debian/Ubuntu Linux workstation in order to access its files:

1. Open aterminal emulator.
2. Change to the directory where you saved the Ubuntu package.
3. Create a directory to extract the files to:

mkdir chromium-browser

4. Extract the package to the new directory:
dpkg -x *.deb chromium-browser/

5. Run the following command to see how much space the package contents need in total (in MB):
du -cms chromium-browser/*

The total is 255 MB (your package may differ slightly). To be on the safe side let's memorize that we
need approximately 400 MB of space for the CP contents.
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Creating a Larger CP
Create a larger Custom Partiton so we can put all the Chromium package files into it.

1. Onthe thin client, make sure that you have closed all Local Terminal windows.

In UMS Console, navigate to your target thin client.

In Assigned Objects, remove the Hello CP profile from this thin client.

When prompted When should these changes take effect? select Now.

The existing Custom Partition is deleted.

Right-click the thin client and select Edit Configuration.

In Setup go to System > Firmware Customization > Custom Partition > Partition.
Check Enable Partition.

Set the Sizeto 400M (Megabyte) to be on the safe side.

Call S

o © N w;

Leave the Mount Point at /custom

10. Click Save.
The new Custom Partition is created.

11. Onthethin client, open a Local Terminal and loginas root
12. Change into the Custom Partition: cd /custom

13. Check the size of the Custom partition: df -h ./

It should be roughly 400M - if it is still roughly 10M, close Local Terminal and use Setup to first
disable and then re-create the Custom Partition again.

14. Copythe complete chromium-browser/ directory with all its contents from the Debian/
Ubuntu machine into the Custom Partition on the thin client.
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Setting Up Library Paths via Script

With the whole package contents in place, you need to make sure that Chromium will be able to find its libraries
and other needed files. There is a pre-fabricated script for this.

1. Loginto Local Terminalas root .

2. Changeintothe /custom/chromium-browser directory.

3. Enterthecommand 1s -1.

4. You will see that instead of a single script as in the previous example there are the etc/ and
usr/ directories. They include many libraries and other files that Chromium will need to run.
However, it expects these directories not within the /custom/chromium-browser/

directory, but in the filesystem root, where system directories suchas /usr are located. The
Initialization Script for the Custom Partition will fix this by setting up symbolic links, so that for
example /custom/chromium-browser/usr/lib/library.so willappeartobein /

usr/lib/library.so ,where Chromium expects it.
5. Use the GNU nano editor to create the file custompart-chromium-browser and putthe
following contents into it - alternatively, edit the file elsewhere and copy itinto /custom/

chromium-browser/ :

#!/bin/sh
ACTION="custompart-chromium-browser_${1}"
# mount point path
MP=$(get custom_partition.mountpoint)
# custom partition path
CP="${MP}/chromium-browser"
# output to systemlog with ID amd tag
LOGGER="1logger -it ${ACTION}"
echo "Starting" | $LOGGER
case "$1" in
init)
# Initial permissions
chown -R root:root "${CP}" | $LOGGER
chmod 755 "${MP}" | $LOGGER
# Linking files and folders on proper path
find "${CP}" | while read LINE
do
DEST=$(echo -n "${LINE}" | sed -e "s|${CP}||g")
if [ ! -z "${DEST}" -a ! -e "${DEST}" ]; then
# Remove the last slash, if it is a dir
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[ -d SLINE ] && DEST=$(echo "${DEST}" | sed -e "s/\/
$//9") | $LOGGER
if [ ! -z "${DEST}" ], then
1n -sv "${LINE}" "${DEST}" | $LOGGER

fi
fi
done
ldconfig
stop)
killall -q -SIGTERM chromium-browser
sleep 1

killall -g -SIGKILL chromium-browser
i
esac
echo "Finished" | $LOGGER
exit 0

@ Usethis as a script template for your Custom Partitions, replacing all instances of
chromium-browser with the directory name of your CP.

6. Make the script executable with the following command:
chmod a+x custompart-chromium-browser

7. Runthe script:
./custompart-chromium-browser 1init

It should run and finish without any errors.
The library paths are set up now.
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The First Run

Now that the paths for the complete Chromium package contents have been set up, try running the program for the
first time:

1. Loginto Local Terminalas root .

2. Changeintothe /custom/chromium-browser/ directory.

3. The usr/bin/ and usr/1lib/ directories are good candidates for Chromium's main
executable. Try to run the following command:
.Jusr/lib/chromium-browser/chromium-browser
You will see the following error message:
/Jusr/lib/chromium-browser/chromium-browser: error while loading
shared libraries:
libatomic.so.1l: cannot open shared object file: No such file or
directory

This tells you that the program tries to load the shared library libatomic.so.1,butcan'tfind
it.
You will need to obtain libatomic.so.1l andinstallit.
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Obtaining Libatomic

The source for Libatomic will be Ubuntu Package Search again:

1. Inaweb browser,goto https://packages.ubuntu.com
2. This time use the Search the contents of packages form to search.
a. SetKeywordto libatomic.so.1l
. Select packages that contain files named like this.
. Set Distributionto xenial

b
C
d. SetArchitectureto amdé64
e

. Click Search.
Keyﬂ.l.rnrd:|libatc:mic.sc.1| Search | Reset |
Display:

@ packages that contain files named like this
O packages that contain files whose names end with the keyword

O packages that contain files whose names contain the keyword

Distribution: xenial |v|ﬂ.rchitecture: amdad |v|

3. This time the results page lists a lot of packages. But with the background knowledge that IGEL OS
libraries are located in /usr/1lib/x86_64-1linux-gnu/ you will find that libatomic1 is the
desired package. Download it to a local directory on your Linux workstation.

Jusrflib/gcc-snapshot/libx32/libatomic.so. goc-snapshot
usrflib/x86_64-linux-gnu/libatomic.so.1 libatomic1
Jusrflib32/libatomic.so.1 lib32atomict
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Installing Libatomic
This step installs Libatomic and sets up a symbolic link so the Chromium will find it.

1. Extract the package contents with this command:

dpkg —-x libatomic*.deb libatomic
2. Change into the extracted contents:

cd libatomicl/usr/1lib/x86_64-linux-gnu/
3. Listits contentsin longform: 1s -1

lrwxrwxrwx 1 huber huber 18 Nov 3 2816 -» libatomic.so0.1.1.8
-mw-r--r-- 1 huber huber 26760 Nov 3 2016 libatomic.so.1.1.8

This shows you that the library file is actually named 1libatomic.so.1.1.0 andthat
libatomic.so.1l isasymboliclinktoit. We will recreate the link on the thin client later.
4. Transferthe libatomic.so.1.1.0 fileto thethinclientand placeitin:
/custom/chromium-browser/usr/lib/chromium-browser/
5. Change into the directory:
cd /custom/chromium-browser/usr/lib/chromium-browser/
6. Create the symbolic link:

ln -s libatomic.so0.1.1.0 libatomic.so.1l
Now Libatomic is set up to be used by Chromium.
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Another Test Run
Test whether Chromium now has everything it needs to run.

1. Change into the Custom Partition directory on the thin client:
cd /custom/chromium-browser

2. Run Chromium:
.Jusr/1lib/chromium-browser/chromium-browser

3. You will see this error message:
/Jusr/lib/chromium-browser/chromium-browser: error while loading

shared libraries:

libffmpeg.so: cannot open shared object file: No such file or
directory

It seems Libatomic is no longer a problem, but now Chromium needs a further library:
libffmpeg.so
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Providing Libffmpeg

To obtain Libffmpeg, repeat the process for obtaining Libatomic (see page 371). Hint: The Ubuntu package is named
chromium-codecs-ffmpeg . It contains thefile 1ibffmpeg.so ,which you need to transfer to the thin

client. Placeitin /custom/chromium-browser/usr/1lib/chromium-browser/.

(@ Thisisaprocedure that you need to repeat until you have supplied all required libraries:
« Run the application from the commandline.
+ Scan the error message for needed libraries.

Obtain and install the required libraries.

Run the application from the commandline.
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Chromium Starts Successfully

Now you are ready to give running Chromium another try. It does not like to be started by root , becauseitis

much safer to run it as the non-privileged user .

1. Loginto Local Terminalas user .

2. Changeintothe /custom/chromium-browser directory.

3. Enter the following command:

./usr/1lib/chromium-browser/chromium-browser
Chromium starts for the first time. Congratulations, you now have working Chromium installation.
Welcome to Chromium - Chromium

/ [ welcome to Chromi x \
| / \

C | & Chromium | chrome://welcome wl o

Welcome to Chromium

Sign in to Chrome with your Google Account to get your

bookmarks, history, passwords, and other settings on

Mo thanks

all your devices.

The next step will package the Custom Partition so it can be deployed to any number of thin clients from UMS:
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Packaging the Custom Application

Now that the hardest part of creating the Custom Partition is done, package the CP for UMS. You are already
familiar with most of the steps from earlier in this tutorial.

Compress the CP Contents (see page 357) into chromium-browser.tar.bz2
Upload the compressed file to UMS as a new File.

Write the *.inf Metadata File (see page 358) with 400M as size.

Upload the *.inf Metadata File to UMS as a new File.
Create a Profile for the CP (see page 360) with the Initializing Action set to:

ok W

/custom/chromium-browser/custompart-chromium-browser 1init
and the Finalizing Action set to:
/custom/chromium-browser/custompart-chromium-browser stop
6. Create a Custom Application (see page 353) with the Command set to:
/custom/chromium-browser /usr/lib/chromium-browser/chromium-browser
7. Assign the CP to a new thin client in order to test everything.
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Advanced

Here are some advanced topics for you to try after you have completed this tutorial.

Using ldd to Find Required Libraries

Using the 1dd command is another way of determining the libraries that a binary requires.

1.
2.

3.

Loginto Local Terminalas root .
Find out which file the main binary of the Custom Partition is. It is usually found in bin/, usr/

bin/ or usr/lib/ andisnamed similar to the application name.
Run the following command:
ldd /custom/[name]/[binary] | grep 'not found'

This command line contains a filter, so that it will only show you those libraries that could not be

found.
Local Terminal - A X

root@GEORGE : /# 1dd /custom/chromium-browser/usr/lib/chromium-browser/chromium-browser
| grep 'not found'

libatomic.so.l == not found

libffmpeg.so == not found

libffmpeg.so == not found

libffmpeg.so == not found
root@GEORGE : /# ||

-~

Auto-updating Custom Partitions

The Custom Partition mechanism in IGEL OS can update the Custom Partition contents automatically when a newer
version is available on UMS. To activate it, follow these steps:

1.

o Lk wN

In Setup, go to System > Firmware Customization > Custom Partitition > Download.
Open the CP entry in the Partitions Data Sources list.

Enable Automatic Update.

Click OK.

Click Apply or Save in the Setup window.

On UMS, increase the version propertyinthe x.inf metadatafile.

When booting, the thin client checks whether there is a higher version of the Custom Partition
available on UMS. If so, the new CP version will be downloaded automatically.
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Using a Custom PKCS#11 Library

Issue

You want to use your own PKCS#11 library.

Problem

In the Setup, you cannot find how to activate a custom PKCS#11 library.

Solution

& Incaseof theinstallation of a custom PKCS#11 library, the file(s) must be placed on the endpoint device
either via UMS file transfer or Custom Partition (see page 348).

The use of the /wfs folderis NOT recommended because of its space limit.

Using with Kerberos and/or Citrix StoreFront Logon
To use a custom PKCS#11 library with Kerberos and/or Citrix StoreFront Logon:

+ In Setup, go to Security > Smartcard > Middleware.
+ Select Custom PKCS#11 module.

« Under Path to the library, enter the path to your PKCS#11 library. Example: /usr/1lib/
pkcsll/[name of the library].so

Using with VMware Horizon
To use a custom PKCS#11 library with VMware Horizon:

+ In Setup, go to System > Registry.
+ Enable theregistry key vmware.view.pkcsll.use_custom.

+ Settheregistry key vmware.view.pkcsll.custom_path tothe pathtoyour PKCS#11
library. Example: /usr/1lib/pkcsll/[name of the library].so

Using with Firefox Browser
To use a custom PKCS#11 library with the Firefox browser:

+ In Setup, go to System > Registry.
+ Enable theregistry key browserglobal.security_device.custom.enable.
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+ Settheregistry key browserglobal.security_device.custom.device_name tothe

name of your PKCS#11 library.
+ Settheregistry key browserglobal.security_device.custom. lib_path tothe path

to your PKCS#11 library. Example: /usr/lib/pkcsll/[name of the library].so
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Adding an Icon for Browsing Removable Storage

Symptom

There is no obvious way of viewing files from removable media locally on the thin client.

Problem

You want to view files from removable media locally on the thin client.

Solution
Create a custom application that opens the contents of removable media in the File Manager.

1. Go to System >Firmware Customization > Custom Application in Setup.

2. Click the star symbol to create a new Custom Application.

3. Enter a name, e.g. Removable Media, and choose desktop integration options for the application.
4

. Enter folder asthelconnameand thunar asthe Command in the Settings dialog:

4 p2 A | » System ™ Firmware Customization * Custom Application ™ Custom Application ™ Settings

Configuration Icon name ) [folder

Command 2] |thunar

Accessories
User Interface
Network
Devices
Security
System
B Time and Date
» I Update
» [l Remote management
» I Remote Access
n Remote Syslog
» [ Fower Options
¥ 3 Firmware Customization
¥ [ custom Partition
B Fartition
B Download
¥ 3 Custom Application
¥ [ custom Application
‘ Settings
B Desktop Integratid
» [ Custom Commands

5. Save the settings.
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6. Insert a removable medium such as a USB stick into the thin client.

userhome - File Manager

Remowvable Media . .
Desktop Directories Downloads

B,

vmwareview.jpg

D]

Image Viewer

7. Click the new Removable Media icon. This opens File Manager and lets you browse the contents.
Clicking a file will open it in the application configured by the MIME type handler (as of IGEL LINUX
5.06.100, see FAQ (see page 426)).
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Adding an Icon for the Image Viewer

Symptom

You want to view images locally on the thin client.

Problem

The image viewer contained in IGEL Linux as from version 5.06.100 on has no desktop icon or menu entry.

Solution
Create a custom application that opens the Image Viewer.

1. Go to System >Firmware Customization > Custom Application in Setup.
2. Click to create a new Custom Application.

3. Entera name, e.g. Image Viewer, and choose desktop integration options for the application.
4. Go to Image Viewer > Settings:

> ~ [ * System ® Firmware Customization * Custom Application ™ Image Viewer * Settings

lcon name £) |gpicview

Configuration

Sessions Command £) |gpicview
Accessories

User Interface

Metwork

Devices

Security
System

B Time and Date
» Il Update
» Il FRemote management
» Bl Remote Access
B Remote Syslog
» Il Fower Options
¥ [ Firmware Customization
» Il Custom Partition
¥ 3 custom Application
» [l Removable Media
¥ [ Image Viewer
. Settings
B Desktop Integratis
» I Custom Commands

5. Enter gpicview asboththe lcon name and the Command in the Settings dialog.
6. Save the settings.
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7. Click the newly created icon for Image Viewer.
8. The Image Viewer opens.
9. Click the Open File symbol to open a file.

Igel. PNG (789%592) 71%

Image Viewer

.

ILocal Terminal

RDP Session
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Customizing IGEL OS Desktop

You want to give your IGEL OS desktops a more individual look and feel. This document shows how to customize
your IGEL OS desktops using the Universal Management Suite (UMS). There are two ways to do it:

« via a firmware customization;
« via a profile.

() With afirmware customization function, you can change your desktop design much easier and quicker
than with a profile.
For an example, see Creating Your Own Wallpaper via Firmware Customization (see page 389). See also
Firmware Customizations and Create Firmware Customization in the UMS Reference Manual.

For information on customizing IGEL OS desktops via a profile, see:

« Introduction (see page 385)

+ Creating Your Own Wallpaper (see page 388)

+ Creating a New Bootsplash (see page 392)

+ Creating Your Own Screensaver (see page 394)

+ Assigning Your Own Company Logos (see page 399)
+ Creating Your Own Taskbar (see page 400)

+ Customizing Desktop Icons (see page 401)

IGEL Tech Video

Sorry, the widget is not supported in this export.
But you can reach it using the following URL:

https://www.youtube.com/watch?v=qFQttefMIX8
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Introduction

If you want to roll out your complete corporate design changes and apply them to multiple devices, you can create
one single profile for all settings.

Before defining special profiles, you must take the following steps:

+ Uploading a Picture (see page 386)
+ Creating a Profile (see page 387)
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Uploading a Picture

Upload your image files to the UMS server, then assign them to the relevant profile and also to your devices.

You can choose between the following formats for your pictures : BMP, JPG, GIF, TIF, PNG and SVG. Ensure that
the name of your image file has no blanks, otherwise the file will not be accepted. 25 MB of free storage space are
available for your pictures.

Upload your files:

1. Click New file on the context menu of the Files directory in the tree.
2. Browse to find your image in Local file.

File source

@ Upload local file to UMS server

Local file Clzers\Picturesthootstern jpg -
Upload location (URLY | Hitps:ALalGEL LOCAL 544 3ms_filetransfer! -_—
u Zelect file fram Uk= server
File: location (URL) e
File target
Classification | Undefined v|

Thin Cliert file location | fimagess

3. Browse to select a picture directory in Upload location (URL).
Since UMS version 5 you can use as upload location only /ums-filetransfer/ and its subdirectories.
4. Enter a Thin Client file location directory for the target device.
If you enter a directory which does not yet exist, it will be created automatically. If you do not enter
a specific directory, the image will be put in the root directory.
5. Click OK.
Your image will be listed in the list of Files.
6. Assign the image to your devices by dragging and dropping them or by adding them under
Assigned objects.

() Ifyou put more than one image in the Thin Client file location directory, all images will be
alternately shown by the screensaver (see page 394), one after the other.
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Creating a Profile
You have already uploaded your image file (see page 386).

As you work with the UMS, to manage several clients, you need to create a profile to assign the new settings to your
clients.

Create a Profile to assign your settings to the clients:

1. Click New profile in the context menu of the Profiles directory in the tree.
2. Enter a Profile Name.

3. Enter a Description and choose the firmware of your thin client under Based on.

New Profile x|
Profile Mame Wallpaper
Pl A create individual hackgruund|
Inherits Settings from | o Thin Clierts E
' ' B e A configuration sample
5w CE Devices
¥ & ES Devices
¥ o LX Devices
|ﬂ IGEL-000C29091 3CF
|ﬂ IGEL-000C29500018
| g
2 IGEL-000C29E2GER S |
Bazed on lIGEL Universal Desktop CE Standard-FTC 6.02.500 ']
@ Activate no Settings
() Activate all Settings
[j Owerwrite Sessions

4, Click OK.
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Creating Your Own Wallpaper
There are two ways how to create an own wallpaper:

+ Via a Firmware Customization (see page 389)
+ Via a Profile (see page 390)

With a Firmware Customization, setting up your own wallpaper is much easier than with a profile.
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Creating Your Own Wallpaper via Firmware Customization
This is how you can create your own wallpaper using a firmware customization function in the UMS:

1. Inthe UMS; right-click on Firmware Customizations > Create New Firmware Customization.
The Firmware Customization Details dialog opens.
2. Enter a Name for your wallpaper customization.
As Use Case, select Wallpaper.
4. Select the image file for each monitor:
« Click Choose file if you have already uploaded a file in the UMS.
+ Click Upload file if you want to upload a new file.

w

() Thefile name must not contain any blank spaces or special characters such as %, §, umlauts, etc.

5. Select yourimage file and click Open.

Check the image file location and click OK.

7. Optionally, click Next to directly apply this new firmware customization to a device or folder of
devices.

8. Click Finish to save your new firmware customization.

o
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Creating Your Own Wallpaper via a Profile

You have already uploaded your wallpaper picture; see Uploading a Picture (see page 386).

1.

2.
3.

Create a profile and name it, for example, Wallpaper; see Creating a Profile (see page 387).
The Profile Configuration window opens.

Set the wallpaper server location; see below "Setting the Wallpaper Server Location".
Configure the background of the client desktop; see below "Configuring the Background".

Setting the Wallpaper Server Location

1.

NoohkwnN

Click System > Firmware Customization > Corporate Designh > Background > Custom
Wallpaper Server.
Custom Wallpaper - Server Location

Protocol A [HTTR v
Server Mame a4 172309171

Semer Path QA. fums_filetransfers

Fart 0 Ay 900

ser name ﬂ_& igel

Pasgword 12 . W

Choose HTTP as Protocol.

Enter the Server name of your UMS Server.

Enter the path of your wallpaper directory as Server path.
The standard Port should be 9080.

Set your UMS administrator User name and Password.
Click Save to save the settings.

Configuring the Background

Eall

Open the profile.

Click System > Firmware Customization > Corporate Design > Background (1st Monitor).
Activate Custom wallpaper download.

Enter under Custom wallpaper file the name of the picture you want to define as your
background image.

@ Ifyou use more than one monitor, you have to assign the background image to each one
of them manually.

Assign the profile to your devices by dragging and dropping them or by adding them
under Assigned objects.
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Checking the Results

1. Choose the device in the Thin Clients directory of the structure tree.
2. Goto User Interface > Desktop > Background.
You will see that the wallpaper has already been assigned by the profile; you cannot set it

manually any more.
Alternatively, you can shadow your thin client and you will see the new wallpaper.

This way, you can automatically assign background images to your devices. It is very easy to maintain them
because the only thing you have to do if you want to choose another image is to change it in the profile.
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Creating a New Bootsplash

1. Upload your logo to the UMS server; see Uploading a Picture (see page 386).

2. Create a new profile named Bootlogo; seeCreating a Profile (see page 387).

3. Inthe profile configuration window, click System > Firmware Customization > Corporate Design
> Custom Bootsplash to create your own bootsplash.

Custom Bootsplash
é E] Enable Custom Bootsplash

Custom Bootsplash - Server Location

& EJ Llze firmware update senver location

Protocal
Serser Name
Server Path
Fort

User Mame

Passward

Activate Enable Custom Bootsplash.
Choose HTTP as Protocol.
Enter the Server Name of your UMS server.

© N Uk

Specify your HTTP server port under Port.

() Thedefault UMS HTTP server port is 9080.

S Sl S o

|HTTP v

daokumentation.igel.local

urms_filetransferfhootlogo

4080

igel

T

Enter the path of your boot logo directory as Server Path.

9. Enter your UMS administrator User Name and Password.

Custom Bootsplash - Settings

Custom Bootsplash file

Horizontal position of hootsplash image
Yerical Position of bootsplash image
Horizontal position of progress indicator

Yerical Position of progress indicatar

IGEL OS Articles
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10. Enter the name of your logo image in Custom Bootsplash file.
@ The optimum size of the picture is 800 x 600 pixels.

11. Apply vertical and horizontal position for the image and progress indicator.
The scale goes from 0 (left) to 100 (right); the default setting is 50 (centered).

12. Save the settings.

13. Assign the profile to your devices by dragging and dropping it or by adding it under Assigned
objects.

() After changing the image file or any setting of an existing custom bootsplash, the bootsplash code has to
be rebuilt. You can trigger this from UMS via Jobs > New Scheduled Job with the command Update
desktop customization.
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Creating Your Own Screensaver

This section describes how to configure an autostart screensaver with your own picture using the UMS.

Proceed as you did for the wallpaper:

1. Upload your logo to the UMS server. For details, see Uploading a Picture (see page 386).
() Thesize of the picture is irrelevant because it will be reduced automatically to 200 x 150 pixels.

2. Create a new Profile named Screensaver. For details, see Creating a Profile (see page 387).
3. Configure the profile settings.
There are four areas where you have to make settings in the screensaver profile:
+ Setting a Delay Time for Booting (see page 395)
+ Setting a Timeout for Autostart (see page 396)
+ Assigning the Custom Logo (see page 397)
+ Assigning the Custom Clock (see page 398)
4. Assign the profile to your devices by dragging and dropping them or by adding them under
Assigned objects.
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Setting a Delay Time for Booting
Configure Autostart in the screensaver profile under User Interface > Screenlock / Screensaver.

1. Enter a Session name, for example Screensaver.
2. Enable Autostart.
3. Enter the number of seconds of Delay.

() This setting tells the system that it must launch the autostart of this session with a certain delay
during booting.
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Setting a Timeout for Autostart

1. Click User Interface > Screenlock [ Screensaver > Options.
2. Enable Start automatically.
3. Enter a number of minutes for Timeout.

( With this setting, you decide how long the system has to wait before starting the screensaver after
the last input.
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Assigning the Custom Logo

1. Go to System > Firmware Customization > Corporate Designh > Company Logos.

2. Activate Enable image display.

3. Enter the Image file/directory you have defined under Thin Client file location. See Uploading a
Picture (see page 386).

() Ifyou enter afolder instead of a single image file as the source, all images in the folder will be
displayed as a slide show. The display time for the images can be configured.

4. Activate One image per monitor if you use more than one monitor and if you want to show
different pictures on each screen.
5. Under Image duration specify the time in seconds that you want to wait before the image is to be
changed.
6. Under Image display mode you can choose between the following different image actions:
+ Small-sized hopping: Small pictures are shown in changing positions.
+ Medium-sized hopping: Bigger pictures are shown in changing positions.
+ Full-screen center cut out: The pictures will be shown in full-screen mode. They may
possibly be cut at the border.
+ Full-screen letterbox: The pictures are shown in full size as large as possible according to
the screen.
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Assigning the Custom Clock

You can also configure a digital screensaver clock independently of the screen display.

1. Click User Interface > Screenlock / Screensaver > Screensaver.

2. Select the Clock display monitor where you want to display the clock.

3. Activate Show seconds if you want to see the digital time display, including seconds.
4. Define the size, position and color settings of your screensaver clock.
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Assigning Your Own Company Logos

You can set your own images for the start button and the company logo in the start menu.

—

() The Start buttonicon is customizable in IGEL Linux 5.08.100 and newer.

() To see the start menu with a company logo, you first have to set the Start Menu Type to "Advanced"
under User Interface > Desktop > Start Menu.
If you set the Start Menu Type to "Auto" and the device has a clock frequency of 1 GHz, the system will
select the "Advanced" type.

To assign your own icons via UMS:

1. Upload your logos to the UMS Server. For details, see Uploading a Picture (see page 386).

2. Create a new profile. For details, see Creating a Profile (see page 387).

The profile configuration window opens.

Go to System > Firmware Customization > Corporate Design > Company Logos > Start Menu.
Enter the file name and the full path of the image under Start button icon.

Enter the file name and the full path of the image under Company logo in start menu.

Click Save or Apply and send to Thin Client to save the settings.

Assign the profile to your devices by dragging and dropping them or by adding them

under Assigned objects.

Noouohkw

() Analternative to this is the chapter Create Firmware Customization in the UMS manual. Here you
will find further configuration options for adapting the UMS to your requirements.

IGEL OS Articles 399/543



Customizing

Creating Your Own Taskbar

You can apply your own design to a taskbar. To customize the taskbar on multiple devices, use the IGEL UMS and
proceed as follows:

1. Upload the desired image to the UMS server, see Uploading a Picture (see page 386).

2. Create a new profile, see Creating a Profile (see page 387).

3. Assign the image to the profile by dragging and dropping it or by adding it under Assigned
objects.

4. In the profile configuration window, go to User Interface > Desktop > Taskbar Background.

5. Select Background image under Background style.

Background Style [Background Image T]

Background Image Path Mfsiuzer/corporoate_design/igelstar
6. Enter the full path of the desired image under Background image path.

7. Assign the profile to your devices by dragging and dropping them or by adding them
under Assigned objects.
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Customizing Desktop Icons

() Youcanonly customize the desktop icon of a session. The taskbar icon of a session cannot be customized
and will remain the default icon. Complete customization is not possible.

Prerequisites
You can use the following graphic formats and resolutions for a custom desktop icon:

+ PNG - common resolutions are 128x128, 96x96, 64x64, 48x48, 32x32, 24x24, 22x22, 16x16, but
others are also accepted and scaled accordingly.

() Werecommend at least a resolution of 64x64.

+ SVG - no resolutions because SVG contains freely scalable vector graphics.

() Eventhough other formats like BMP or JPEG are supported, only PNG and SVG are recommended because
these formats support transparency.

To customize the desktop icon of a session, proceed as follows:

1. Inthe Setup, go to System > Registry.
2. Inthe Registry, navigate to sessions.[session name].icon.

() Fortechnical reasons, some registry keys do not match the session's name. For example, RDP
sessions are found under the key winconnect[0-...] .

3. Enter under Icon name the absolute path to your custom icon as shown in the sample picture
below.
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< > A

Configuration

B Time and Date
» Il Update
» [ Remote management
» [l Remote Access
Fower Options
» [ Firmware Customization

B Regist

Search

4. Click Ok to save the changes.
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» [ webcaminfod
* [ winconnectd%
¥ 3 winconnecto
B spplaunch
B =pplaunch_path

B applaunch_system

B autostart

B deskiop

B deskiop_path
B finzl_action

B hotkey

B hotkeymodifier

1y

sesslons.winconnectO.lcon

lcon name

fwfsfcustom_icon.png

B icon

B init_action
B menu_path
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How to Set Up a Countdown to Prevent an Undesired Screen Lock In IGEL
0S

In some situations, a screen lock that comes without a warning can cause disruption. Typically, this is the case
when a user who is logged in to a remote session does not interact with the device for some time, which results in
the screen lock kicking in. To circumvent this problem, you can set a visible countdown that is started before the
screen is locked, so the user can react in time.

() Review the timeouts in the power settings of your device to ensure that the display won't turn black before
the countdown is started; see System and Screen.

The configuration is described in the following sections:

+ Defining the Countdown's Behavior (see page 403)
+ Defining the Countdown's Appearance (see page 405)

For special purposes, like closing a remote session to prevent it from running unattended, you can configure an
additional set of commands. It consists of a command that determines whether the countdown should be started
(typically, check whether the remote session is running) and a command that will be executed when the countdown
reaches 0 (typically, close the remote session). The configuration is described in the following section:

+ Configuring a Conditional Countdown and Command (see page 407)

Defining the Countdown's Behavior
For a description of all options, see Options.
1. Inthe Setup or UMS configuration dialog, go to User Interface > Screenlock / Screensaver >
Options.

2. Activate Start automatically.

|+/| Start automatically

Timeout

In the Timeout field, specify after how many minutes the countdown should start.

(V] start automatically

Timeout
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4. Select the password to be used to unlock the screen:

+ None: The user can unlock the screen without a password. Please note that the countdown
will not be started when this option is selected!

+ User password: The user must enter the user password to unlock the screen. If you are
using Microsoft Active Directory (AD) resp. Kerberos for authentication, which is highly
recommended, the user's AD/Kerberos password will be used here. For details, see Active
Directory/Kerberos. If you are not using AD/Kerberos, the user password is configured in
Security > Password under User. Please note that the password should not, at any rate, be
set via a UMS profile, otherwise all affected devices would have the same password!

+ Local user password: The user must enter a special screen lock password to unlock the
screen; click Set to define this password. Please note that the password should not, at any
rate, be set via a UMS profile, otherwise all affected devices would have the same password!
This password is also used for Security > Logon > Local User > Login with local user
password; see Local User (see page 403).

If the user is logged in via Active Directory (AD), the AD credentials are used instead of this
password to unlock the screen.
If you are using Citrix Storefront, this password can be synchronized with the Citrix session
password by enabling Synchronize Citrix password with screen lock under Sessions >
Citrix > Citrix StoreFront > Login; see also Login.

Screenlock Password

2]

Mone

® llser passw

Local user password

|| Different screenlock timeout

€)  Allow administrator password

5. Set the Countdown duration in seconds. The range is from 1 to 60.
Configuration example:
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v Start automatically

Timeout

Screenlock Password
2]

Mone

User password

Local user password

) Allow administrator password

Countdown duration in seconds _
7 Seconds

Countdown visual effect Dark screenshot

Countdown background image ) Jusr/sharefzenity/

6. Apply the settings to your devices or to your profile.

Defining the Countdown's Appearance

1. Inthe Setup, go to User Interface > Screenlock / Screensaver > Options.

2. If you want the current desktop as a background image during the countdown, select the visual

effect:
« Dark screenshot: The desktop screenshot is darkened.
+ Gray screenshot: The desktop screenshot is grayed out.

3. If you want a custom image as a background image during the countdown, enter a valid path and
file name. Example: /images/ .Iftheimageis not already residing on your device, you can

upload it using the UMS; see Uploading a Picture (see page 386).
Configuration example with custom image:
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Countdown duration in seconds _
7 Seconds

Countdown visual effect Dark screenshaot

Countdown background image topwatch.jpg

4. Go to User Interface > Screenlock / Screensaver > Screensaver.

5. Customize the countdown's appearance using the following parameters; these parameters define
the appearance of both the screensaver's clock and the countdown. For further information, see
Screensaver.

+ Image display mode: Position and scaling for the background image

+ Clock display monitor: Select the monitor(s) on which the countdown is to be shown.

« Show seconds: Define whether the seconds should be displayed on the clock.

+ Clock display size: Size of the countdown digits

+ Horizontal clock position: Horizontal position of the countdown digits

« Vertical clock position: Vertical position of the countdown digits

+ Clock background color: Color of the countdown background area. The countdown
background area is a rectangle with rounded corners.

+ Clock background opacity percentage: Set the opacity for the clock's background area
(defined by Clock background color),

+ Clock foreground color: Color of the countdown digits

Configuration example:

Image display mode Full-screen center cut out

Clock display monitor

Clock disp

Horizontal clock position

Vertical clock position

Clock background color
Clock background opacity percentage

Clock foreground color

IGEL OS Articles
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Top
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6. Apply the settings to your devices or to your profile.
Here is an example of the countdown with a custom image:

Configuring a Conditional Countdown and Command

In our example, a Citrix session is running (e.g. in appliance mode), and the endpoint device has been idle for a
while. After the timeout, the system checks whether a Citrix session is running; this is to prevent the session from
running unattended. The Citrix session is detected, so the countdown kicks in. The user does not interact with the

device, so the countdown is not stopped. When the countdown has reached 0, the system kills the Citrix client; the
user is logged off.

In the following, we will first specify the command that determines whether the countdown should be started.
Then, we will specify the command that is executed when the countdown has reached 0.

Command That Determines the Condition under Which the Countdown Should Be Started

& Thiscommand only makes sense in combination with a command that is to be executed after the
countdown is done; see Command to Be Executed after the Countdown (see page 408).

1. Inthe Setup, go to System > Registry and open the registry key sessions > xlock0 > options >
countdown_condition_cmd

( sessions.xlock®.options.countdown_condition_cmd).
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2. Enterthe command in the field Countdown condition command. The user that issues the
commandsis user .If nocommand is defined here, the countdown will be started. Examples:

pgrep wfica (returns0if a Citrix session is present), pgrep igelrdp2

Countdown condition command

pgrep wfica

B changing p
B countdown_background _imz

B countdown condition_cmd
: tdow

3. Click Apply or Ok.
If the command returns 0, the countdown is started. When the countdown has reached 0, the
command specified with System > Registry > sessions > xlock0 > options >
countdown_done_cmd is executed (see Command to Be Executed after the Countdown (see page
408)).
If the command returns a non-zero value, the countdown is not started. A command that is
configured for execution after the countdown will therefore not be executed. The screen lock or
screensaver will be started.

Command to Be Executed after the Countdown

1. Inthe Setup, go to System > Registry and open the registry key sessions > xlock0 > options >
countdown_done_cmd ( sessions.xlock®.options.countdown_done_cmd ).

2. Enter the command in the field Countdown done command. The user that issues the commands
is user .Examples: killall wfica (terminatesthe Citrix ICAclient), Logoff

() Thecommand is executed synchronously before the countdown goes away. If the command
doesn't terminate quickly, it must be sent to the background by appending " & ".

Countdown done command
B changing p €2 [killall whical
B countdown_background imzs
B countdown_condition_cmd

B countdown done cmd

B countdown_done_cmd_conti
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3. (Optional) If you want to enforce the start of the screensaver after the Countdown done
command has been executed, open the registry key sessions > xlock0 > options >
countdown_done_cmd_continue
( sessions.xlock®.options.countdown_done_cmd_continue )and enable Continue
screensaver after countdown done command.

() Some applications stop the screensaver when they get restarted, so this does not always have the
desired effect.

B change_p _text Continue screensaver after countdown done command
B changing p:
B countdown_background ima

€) V Continue screensaver after count...

B countdown _condition cmd
B countdown done_cmd

g countdown_done _cmd conti

4, Click Apply or Ok.
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How to Set Up a Countdown in the IGEL OS

You can set up the countdown via the device's local Setup or via the IGEL Universal Management Suite (UMS). Itis
recommended to use the IGEL UMS and store your settings in a profile; this allows you to apply your settings to a
random number of devices in one go.

For more information about profiles, see the Profiles chapter in the IGEL UMS reference manual.

Defining the Countdown's Behavior

1. Inthe Setup, go to User Interface > Screenlock / Screensaver > Options.
2. Activate Start automatically.
3. Inthe Timeout field, set the idle timeout in minutes, after which the countdown should start.

4. Select the password to be used to unlock the screen:
+ None: The user can unlock the screen without a password.
+ User password: The user must enter the user password to unlock the screen. The user
password is configured in Security > Password.
+ Screenlock password: The user must enter a special screenlock password to unlock the
screen. Click Set to define the screenlock password.

5. Set the Countdown duration in seconds. The range is from 1 to 60.
Configuration example:

& (] Start automatically
Timeout & 1

Screen Lock Password
A O Nore

A O UserPassword

_ Set
A ®) Screen Lock Password

6. Apply the settings to your devices or to your profile.

Defining the Countdown's Appearance
1. Inthe Setup, go to User Interface > Screenlock / Screensaver > Options.
2. If you want the current desktop as a background image during the countdown, select the visual
effect:

« Dark screenshot: The desktop screenshot is darkened.
+ Gray screenshot: The desktop screenshot is grayed out.
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3. If you want a custom image as a background image during the countdown, enter a valid path and
file name. Example: /images/ .Iftheimage is not already residing on your device, you can

upload it using the UMS; see Uploading a Picture (see page 386).
Configuration example with custom image:

Countdown duration in seconds A 0 = - 10
Countdown visual effect & | Dark screenshot VJ
Countdown backaround image & fimagesistopwatch.jpg

4. Go to User Interface > Screenlock / Screensaver > Screensaver.

5. Customize the countdown's appearance using the following parameters; these parameters define
the appearance of both the screensaver's clock and the countdown. For further information, see
Screensaver.

+ Image display mode: Position and scaling for the background image

(@ This parameter is only relevant for IGEL Linux v5. With IGEL Linux version 10.03.500 or
higher, the Image display mode is set to "Full-screen letterbox".

+ Clock display monitor: Selects the monitor(s) on which the countdown is to be shown.

+ Clock display size: Size of the countdown digits

+ Horizontal clock position: Horizontal position of the countdown digits

« Vertical clock position: Vertical position of the countdown digits

+ Clock background color: Color of the countdown background area. The countdown
background area is a rectangle with rounded corners.

+ Clock foreground color: Color of the countdown digits

Configuration example:

Image display mode & | Full-screen center cut out YJ

Clock display monitar & |AII 'J
Show seconds

Clock display size é |Huge YJ

Horizontal clock position & |Right "J

Verical clock position & |T0p 'J

Clock background color

Clock hackground opacity percentage & Fiil

Clock foreground color
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6. Apply the settings to your devices or to your profile.
Here is an example of the countdown with a custom image:
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Configuring a Conditional Countdown and Command
You can specify an arbitrary command that is executed when the countdown has reached 0.
Additionally, you can specify a command that determines whether the countdown is to be started.

Example use case: The countdown is running, but the user does not interact with the device in order to make the
countdown stop. When the countdown has reached 0, the system checks whether a session is running, e.g. an
appliance mode Citrix session. If yes, the user is logged off from this session.

If no command is set to be executed after countdown, the screen will be locked instead.

The user that issues the commands depends on the firmware version in use:

« With IGEL Linux v5, the useris root.
« With IGEL OS Linux 10, the useris user .

To specify the command that determines the condition:
1. Inthe Setup, go to System > Registry and open the registry key sessions > xlock0 > options >
countdown_condition_cmd

( sessions.xlock®.options.countdown_condition_cmd).

2. Enterthe command in the field Countdown condition command. Example: pgrep wf-ica

(determines if a Citrix session is present)
3. Click Apply or Ok.
If the command returns 0, the countdown or commando is started.
If the command returns a non-zero value, the countdown or commando is not started.

To specify the command to be executed after the countdown:
1. Inthe Setup, go to System > Registry and open the registry key sessions > xlock0 > options >

countdown_done_cmd ( sessions.xlock®.options.countdown_done_cmd ).

2. Enter the command in the field Countdown done command. Example: killall wfica
(terminates the Citrix ICA client)

@ The command is executed synchronously before the countdown goes away. If the
command doesn't terminate quickly, it must be sent to the background by appending " & "

3. Open the registry key sessions > xlock0 > options > countdown_done_cmd_continue
( sessions.xlock®.options.countdown_done_cmd_continue )and specify whether
the screensaver should be started after the command has been started.

@ With IGEL Linux v5, the screensaver does not start immediately. It will be start