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Fehlersuche: Benutzer muss Anmeldeinformationen zweimal für RDP-Anmeldung angeben

Ausgabe

Wenn Sie sich mit einem Windows-Terminalserver verbinden, werden Sie zweimal aufgefordert, Ihre Anmeldedaten anzugeben.

Ursache

Dieses Verhalten wird durch die Funktionsweise der RDS-Lastverteilung verursacht. Der entscheidende Punkt ist, dass der Terminalserver nicht direkt mit dem Sitzungsbroker kommuniziert.

Das Szenario sieht stattdessen folgendermaßen aus:

  1. Der Client verbindet sich mit Terminalserver 1 und authentifiziert sich bei Terminalserver 1. Dies ist das erste Mal, dass der Benutzer nach seinen Anmeldedaten gefragt wird.

  2. Da wir einen Lastausgleich eingerichtet haben, wird Terminalserver 1 mit dem Sitzungsbroker sprechen und fragen, ob der Client Terminalserver 1 verwenden kann oder ob er an einen anderen Terminalserver umgeleitet werden soll.

  3. Wenn eine Umleitung stattfindet, muss sich der Client auch bei dem Terminalserver authentifizieren, zu dem er umgeleitet wurde (Terminalserver 2 in der Abbildung unten). Dies ist das zweite Mal, dass der Benutzer nach seinen Anmeldedaten gefragt wird.

Lösung

Das Problem kann durch Aktivierung der Kerberos/Active Directory-Authentifizierung behoben werden. Weitere Informationen finden Sie unter Active Directory/Kerberos.



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