UMS Installation on 64-bit Systems


Issue

What are the prerequisites to install IGEL Universal Management Suite on 64-bit operating systems?


Solution

  • Windows: Use the 32-bit compatibility mode (which is activated by default) before installing IGEL UMS (e.g. on Windows Server 2008 R2).

    see also MSDN: "Running 32-bit Applications"

  • Linux (amd64/x86_64): Install the 32-bit compatibility packages before installing IGEL UMS.
    Examples with Ubuntu follow below, apart from that see:

    FAQ: Installing UMS on Red Hat Enterprise Linux (RHEL) 7.3

    FAQ: Installing UMS on Oracle Linux Server 7.1


    Example with Ubuntu 14.04 LTS 64-bit:
    # add i386 support
    sudo dpkg --add-architecture i386
    sudo apt-get update
    # install libraries
    sudo apt-get install lib32z1 \ lib32ncurses5 \ lib32bz2-1.0 \ libxtst6:i386 \ libxinerama1:i386 \ libxi6:i386 \ libxext6:i386 \ libxrender1:i386

    Example with Ubuntu 16.04 LTS 64-bit:
    # add i386 support
    sudo dpkg --add-architecture i386
    sudo apt-get update
    # install libraries
    sudo apt-get install lib32z1 \ lib32ncurses5 \ libbz2-1.0:i386 \ libxtst6:i386 \ libxinerama1:i386 \ libxi6:i386 \ libxext6:i386 \ libxrender1:i386


    Legal Note

    IGEL's Terms & Conditions apply.


Last update: October 8, 2018