Firefox

  • Updated Firefox browser to version 60.8.0 ESR.
  • Fixes for mfsa2019-22, also known as:

     More...

    CVE-2019-9811, CVE-2019-11711, CVE-2019-11712, CVE-2019-11713,
    CVE-2019-11729, CVE-2019-11715, CVE-2019-11717, CVE-2019-11719,
    CVE-2019-11730, and CVE-2019-11709.

  • Fixes for mfsa2019-19, also known as: CVE-2019-11708.
  • Fixes for mfsa2019-18, also known as: CVE-2019-11707.
  • Fixes for mfsa2019-08, also known as:

     More...

    CVE-2019-9790, CVE-2019-9791, CVE-2019-9792, CVE-2019-9793,
    CVE-2019-9795, CVE-2019-9796, CVE-2018-18506, and CVE-2019-9788.

  • Fixes for mfsa2019-05, also known as: CVE-2018-18356, CVE-2019-5785.
  • Fixes for mfsa2019-02, also known as: CVE-2018-18500, CVE-2018-18505, and CVE-2018-18501.
  • Added allowance for Firefox to access Yubikey (FIDO/U2F) if apparmor is active.

Base system

  • Set default umask to 0077 for all non-root users.
  • Remote users home is now /home/ruser.
  • Fixed policykit-1 security issue CVE-2019-6133.
  • Fixed tiff security issues:

     More...

    CVE-2019-7663, CVE-2019-6128, CVE-2018-19210,
    CVE-2018-17000, CVE-2018-12900, and CVE-2018-10779.

  • Fixed lcms2 security issue CVE-2018-16435.
  • Fixed libpng1.6 security issues CVE-2019-7317 and CVE-2018-13785.
  • Fixed nss security issues CVE-2018-18508, CVE-2019-11729, and CVE-2019-11719.
  • Fixed procps security issues:

     More...

    CVE-2018-1126, CVE-2018-1125, CVE-2018-1124,
    CVE-2018-1123 and CVE-2018-1122.

  • Fixed evince security issues CVE-2019-11459 and CVE-2019-1010006.
  • Fixed gdk-pixbuf security issue CVE-2017-12447.
  • Fixed gst-plugins-base0.10 security issue CVE-2019-9928.
  • Fixed bind9 security issues CVE-2019-6465, CVE-2018-5745 and CVE-2018-5743.
  • Fixed libgd2 security issues CVE-2019-6978 and CVE-2019-6977.
  • Fixed ghostscript security issues CVE-2019-3839, CVE-2019-3838 and CVE-2019-3835. 
  • Fixed ldb security issue CVE-2019-3824.
  • Fixed file security issues CVE-2019-8907 and CVE-2019-8905.
  • Fixed poppler security issues:

     More...

    CVE-2019-9200, CVE-2019-9903, CVE-2019-9631, CVE-2019-12293,
    CVE-2019-10872, CVE-2019-10023, CVE-2019-10021, CVE-2019-10019,
    CVE-2019-10018, CVE-2018-20662, CVE-2018-18897, and CVE-2017-9865.

  • Fixed samba security issues CVE-2019-3880 and CVE-2018-16860.
  • Fixed openssl security issue CVE-2019-1559.
  • Fixed libxslt security issue CVE-2019-11068.
  • Fixed openssh security issue CVE-2019-6111.
  • Fixed wget security issue CVE-2019-5953.
  • Fixed wpa security issues:

     More...

    CVE-2019-9495, CVE-2019-9497, CVE-2019-9498,
    CVE-2019-9499, and CVE-2019-11555.

  • Fixed gtk+2.0 security issue CVE-2013-7447.
  • Fixed heimdal security issues CVE-2019-12098 and CVE-2018-16860.
  • Fixed webkit2gtk security issues CVE-2019-8615, CVE-2019-8607, and CVE-2019-8595.
  • Fixed gimp security issues:

     More...

    CVE-2017-17786, CVE-2017-17789, CVE-2017-17784,
    CVE-2017-17787, CVE-2017-17785, and CVE-2017-17788.

  • Fixed libtomcrypt security issue CVE-2018-12437.
  • Fixed unzip security issues CVE-2019-13232, CVE-2018-1000035, CVE-2016-9844, and CVE-2014-9913.
  • Fixed curl security issues:

     More...

    CVE-2018-16840, CVE-2018-16839, CVE-2019-3823,
    CVE-2019-3822, CVE-2018-16890, and CVE-2019-5346.

  • Fixed gnutls28 security issues CVE-2018-10846, CVE-2018-10845, CVE-2018-10844, and CVE-2018-1084.
  • Fixed db5.3 security issue CVE-2019-8457.
  • Fixed qtbase-opensource-src security issues CVE-2018-19873, CVE-2018-19870, and CVE-2018-15518.
  • Fixed libssh2 security issues:

     More...

    CVE-2019-3863, CVE-2019-3862, CVE-2019-3861,
    CVE-2019-3860, CVE-2019-3859, CVE-2019-3858,
    CVE-2019-3857, CVE-2019-3856, and CVE-2019-3855.

  • Fixed network-manager security issue CVE-2018-15688.
  • Fixed elfutils security issues:

     More...

    CVE-2019-7665, CVE-2019-7150, CVE-2019-7149,
    CVE-2018-18521, CVE-2018-18520, CVE-2018-18310,
    CVE-2018-16403, CVE-2018-16402, and CVE-2018-16062.

  • Fixed libsndfile security issues:

     More...

    CVE-2019-3832, CVE-2018-19758, CVE-2018-19662, CVE-2018-19661,
    CVE-2018-19432, CVE-2018-13139, CVE-2017-6892, CVE-2017-17457,
    CVE-2017-17456, CVE-2017-16942, CVE-2017-14634, CVE-2017-14246,
    and CVE-2017-14245.

  • Fixed dbus security issue CVE-2019-12749.
  • Fixed vim security issues CVE-2019-12735 and CVE-2017-5953.
  • Fixed glib2.0 security issue CVE-2019-12450.
  • Fixed openssl (1.1.x) security issues:

     More...

    CVE-2019-1543, CVE-2018-0737, CVE-2018-0735,
    CVE-2018-0734, and CVE-2018-0732.

  • Fixed sqlite3 security issues:

     More...

    CVE-2019-9937, CVE-2019-9936, CVE-2019-8457, CVE-2018-20506,
    CVE-2018-20346, CVE-2017-2520, CVE-2017-2519, CVE-2017-2518,
    CVE-2017-13685, CVE-2017-10989, and CVE-2016-6153.

  • Fixed systemd security issues:

     More...

    CVE-2019-6454, CVE-2019-6454, CVE-2018-1049,
    CVE-2018-15686, and CVE-2019-3842.

  • Fixed libseccomp security issue CVE-2019-9893.
  • Fixed bzip2 security issues CVE-2019-12900 and CVE-2016-3189.
  • Fixed imagemagick security issues:

     More...

    CVE-2019-9956, CVE-2019-7398, CVE-2019-7397, CVE-2019-7396,
    CVE-2019-7175, CVE-2019-11598, CVE-2019-11597, CVE-2019-11472,
    CVE-2019-11470, CVE-2019-10650, CVE-2019-10131, CVE-2018-20467,
    CVE-2018-18025, CVE-2018-18024, CVE-2018-18016, CVE-2018-17966,
    CVE-2018-17965, CVE-2018-16413, CVE-2018-16412, CVE-2017-12806,
    and CVE-2017-12805.

  • Fixed expat security issue CVE-2018-20843.
  • Fixed glib2.0 security issue CVE-2019-13012.
  • Fixed libvirt security issues CVE-2019-10167 and CVE-2019-10161.
  • Fixed gvfs security issue CVE-2019-12795.
  • Fixed libmspack security issue CVE-2019-1010305.
  • Fixed bash security issue CVE-2019-9924.
  • Fixed openldap security issues CVE-2019-13565 and CVE-2019-13057.
  • Updated libwebkit2gtk-4.0-37 to version 2.24.2.
    Security fixes:

     More...

    CVE-2019-8595, CVE-2019-8607, CVE-2019-8615, CVE-2019-6251,
    CVE-2018-4373, CVE-2018-4375, CVE-2018-4376, CVE-2018-4378,
    CVE-2018-4382, CVE-2018-4392, CVE-2018-4416, CVE-2018-4345,
    CVE-2018-4386, and CVE-2018-4372.

  • Fixed a vulnerability in the custom environment variable framework.
  • Fixed possible malicious owner change within TC setup configuration.
  • Fixed kernel TCP vulnerabilities CVE-2019-11477: SACK Panic, CVE-2019-11478: SACK Slowness, and CVE-2019-11479: Excess resource consumption due to low MSS values.
  • Changed minimally allowed MSS size to 1000 to prevent possible Denial of Service attacks.
  • Fixed a vulnerability in Java configuration script.