Problem

Wenn Sie sich mit einem Windows-Terminalserver verbinden, werden Sie aufgefordert, Ihre Anmeldeinformationen zweimal einzugeben.

Ursache

Dieses Verhalten wird durch die Funktionsweise des RDS-Lastausgleichs verursacht. Das Problem ist, dass der Terminalserver nicht direkt mit dem Session Broker kommuniziert.

Stattdessen ist das Szenario wie folgt:

  1. Der Client verbindet sich mit dem Terminalserver 1 und authentifiziert sich mit dem Terminalserver 1. Dies ist das erste Mal, dass der Benutzer nach seinen Zugangsdaten gefragt wird.
  2. Da wir ein Load Balancing-Setup haben, wird Terminalserver 1 mit dem Session Broker sprechen und fragen, ob der Client Terminalserver 1 verwenden kann oder ob er auf einen anderen Terminalserver umgeleitet werden soll.
  3. Wenn eine Umleitung stattfindet, muss sich der Client auch bei dem Terminalserver authentifizieren, auf den der Client umgeleitet wurde (Terminalserver 2 in der folgenden Abbildung). Dies ist das zweite Mal, dass der Benutzer nach seinen Zugangsdaten gefragt wird.


Lösung

Das Problem kann durch Aktivieren der Kerberos/Active Directory Authentifizierung behoben werden. Weitere Informationen finden Sie unter Active Directory/Kerberos v10.04.